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Get Information from
Drawings

You can retrieve general information from a drawing including identifying information and
the number of objects that it contains.

There are types of information stored in a drawing that are not specific to objects within the
drawing, but provide useful information to help you understand the behavior of the drawing,
the settings of system variables, the number of objects, descriptive information, and so on.

Obtain General Drawing Information
You can retrieve general information about the drawing file and its settings.

This information includes the following:

■ Custom descriptive information about the drawing (DWGPROPS)

■ General drawing settings (STATUS)

■ Amount of time spent in the drawing (TIME)

This information can help you document a drawing, displays a variety of drawing
settings such as the total number of objects in the drawing and the amount of
free space on your disk drive, and the total amount of time spent in the drawing
file.

See also:

■ Enter System Variables on the Command Line on page 42

■ Add Identifying Information to Drawings on page 188

■ Extract Geometric Information from Objects on page 765
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■ Compare Dimension Styles and Variables on page 1632

Quick Reference

Commands

DWGPROPS

Sets and displays the file properties of the current drawing.

SETVAR

Lists or changes the values of system variables.

STATUS

Displays drawing statistics, modes, and extents.

TIME

Displays the date and time statistics of a drawing.

System Variables

CDATE

Stores the current date and time in decimal format.

DATE

Stores the current date and time in Modified Julian Date format.

SAVENAME

Displays the file name and directory path of the most recently saved drawing.

Utilities

No entries

Command Modifiers

No entries

Count Objects Within a Drawing
You can count objects within a drawing using the QSELECT command.

4 | Chapter 1   Get Information from Drawings



The QSELECT command displays the Quick Select dialog box, which allows
you to create a selection set based on the filtering criteria. You can filter
selection sets by property such as color or linetype, and by object type.

Creating a selection set based on the filtering criteria in the Quick Select dialog
box, allows you to count specified types of objects within a drawing.

To count specified types of objects in a drawing

1 Click Home tab ➤ Utilities panel ➤ Quick Select. 

2 In the Quick Select dialog box, do one of the following:

■ In the Apply To List, select Entire Drawing.

■ Click the Select Objects button to select a group of objects. Press
ENTER. In the Apply To list, select Current selection.

3 In the Object Type list, select the type of object you want to count.

4 In the Properties list, select a property that belongs to the type of objects
you want to count.

5 In the Operator list, select = Equals.

6 In the Value list, select the property value of the type of objects you want
to count.

7 Click OK.

The number of objects displays at the command prompt.

Menu: Tools ➤ Quick Select
Command entry: QSELECT

Shortcut menu: End any active commands, right-click in the drawing area,
and choose Quick Select.

Quick Reference

Commands

QSELECT

Creates a selection set based on filtering criteria.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries
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The User Interface
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Tools in the Application
Window

Use the Application menu, Quick Access toolbar, and ribbon to access many frequently used
commands.

The Application Menu
Click the application button to search for commands, as well as access tools to
create, open, and publish a file.

Search for Commands
Perform a real-time search for commands on the Quick Access toolbar, in the
application menu, and on the ribbon.

The Search field displays at the top of the application menu. Search results can
include menu commands, basic tooltips, and command prompt text strings.
You can enter a search term in any language.

2
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To clear the search field in the Application menu

1 Click the Application button.
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2 In the Application menu, enter text in the search field.

The spyglass button to the right of the search field becomes an [X].

3 Click the [X] icon to the right of the search field. The search field is cleared
and the [X] icon returns to a spyglass.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

OPTIONS

Customizes the program settings.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Access Common Tools
Access common tools to start or publish a file in the application menu.

Click the application button to quickly

■ Create, open, or save a file

■ Audit, recover, and purge a file

■ Print or publish a file

■ Access the Options dialog box

■ Close AutoCAD
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NOTE You can also close AutoCAD by double-clicking the Application button.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

OPTIONS

Customizes the program settings.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Browse Files
View, sort, and access supported files that you have recently opened.

Recent Documents
View the most recently used files with the Recent Documents list.

Files display in the Recent Documents list with the most recently used file at
the top by default.
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Pinned Files

You can keep a file listed regardless of files that you save later using the push
pin button to the right. The file is displayed at the bottom of the list until you
turn off the push pin button.

Sort and Group Options

Use the drop-down list at the top of the Recent Documents list to sort or group
files by

■ File name

■ File size

■ File type

■ Date the files were last modified
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To change the preview display options for recent documents

1 Click the Application menu and then, click Recent Documents.

2 Under the Search text box, click the Display Options menu.

3 Select a display option.

NOTE The preview display option you choose remains in both the Recent
Documents and Open Documents lists.

To change the number of recent documents listed

1 Click Tools  ➤  Options.

2 In the Options dialog box, click the Open and Save tab.

3 In the Application Menu  ➤ Number of Recently Used Files text box,
enter the number of recent documents to be listed. You can choose any
number between 0 and 50.

To keep a document in the Recent Documents list

■ Click the push pin button to the right of the document.
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To view the Recent Documents list by access date

■ In the top-left corner of the Recent Documents list, in the By Ordered List
drop-down list, select By Access Date.

To view the Recent Documents list by size

■ In the top-left corner of the Recent Documents list, in the By Ordered List
drop-down list, select By Size.

To view the Recent Documents list by type

■ In the top-left corner of the Recent Documents list, in the By Ordered List
drop-down list, select By Type.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

OPTIONS

Customizes the program settings.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Currently Open Documents
View only files that are currently open with the Open Documents list.

Files display in the Open Documents list with the most recently opened file
at the top. To make a file current, click the file in the list.
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To change the preview display options for currently open documents

1 Click the Application menu and then, click Open Documents.

2 Under the Search text box, click the Display Options menu.

3 Select a display option.
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NOTE The preview display option you choose remains in both the Recent
Documents and Open Documents quick menus.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

OPTIONS

Customizes the program settings.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Preview Documents
View a thumbnail of files in the Recent Documents and Open Documents
lists.

When you hover over a file in either of the lists, a preview of the file is
displayed along with the following information:

■ Path where the file is stored

■ Date the file was last modified

■ Version of the product used to create the file

■ Name of the person who last saved the file

■ Name of the person who is currently editing the file

You can also include a thumbnail of the file next to the files in the list. To
change the file icon to a thumbnail preview, click the drop-down list at the
top of the Recent Documents or Open Documents lists and choose small icons,
large icons, small images, or large images.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

OPTIONS

Customizes the program settings.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Quick Access Toolbar
Display frequently used tools with the Quick Access toolbar.

View Undo and Redo History

The Quick Access toolbar displays options to undo and redo changes to your
file. To undo or redo a less recent change, click the drop-down button to the
right of the Undo and Redo buttons.
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Add Commands and Controls

Add unlimited tools to the Quick Access toolbar. Tools that extend past the
maximum length of the toolbar are displayed in a flyout button.

To add a ribbon button to the Quick Access toolbar, right-click the button on
the ribbon and click Add to Quick Access toolbar. Buttons are added to the
right of the default commands on the Quick Access toolbar.

Move the Quick Access Toolbar

Place the Quick Access toolbar either above or below the ribbon using the
Customization button.

See also:

■ Quick Access Toolbars
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■ Toolbars on page 32

To add a command to the Quick Access toolbar

1 Right-click the Quick Access toolbar.

2 Click Customize Quick Access Toolbar.

3 In the Customize User Interface (CUI) Editor, drag a command from the
Command list to the position you want it to be displayed on the Quick
Access toolbar.

For multiple commands, hold down CTRL and select the commands.

4 Click OK.

NOTE If you do not click OK, the commands added are not saved to the
Quick Access toolbar.

To remove a command from the Quick Access toolbar

1 Right-click over the command you want to remove.

2 Click Remove from Quick Access Toolbar.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

The Ribbon
The ribbon is a palette that displays task-based commands and controls.

Overview of the Ribbon
The ribbon is displayed automatically when you create or open a file, providing
a compact palette of all of the tools necessary to create your file.

The ribbon contains many of the same commands that were once available
on the dashboard. For example, the DIMLINEAR command was once available
on the dashboard’s Dimensions control panel. On the ribbon, DIMLINEAR is
located on the Annotation tab, in the Dimensions panel.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.
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RIBBON

Opens the ribbon window.

RIBBONCLOSE

Closes the ribbon window.

System Variables

MTEXTTOOLBAR

Controls the display of the Text Formatting toolbar.

RIBBONCONTEXTSELECT

Controls how ribbon contextual tabs are displayed when you single- or
double-click an object.

RIBBONCONTEXTSELLIM

Suppresses the display of ribbon contextual tabs when the selection set
includes more than the specified number of objects.

RIBBONSELECTMODE

Determines whether a pickfirst selection set remains selected after a ribbon
contextual tab is invoked and the command is completed.

RIBBONSTATE

Indicates whether the ribbon palette is open or closed.

TABLETOOLBAR

Controls the display of the Table toolbar.

Utilities

No entries

Command Modifiers

No entries

Display and Organize the Ribbon
The ribbon is displayed horizontally or vertically.

The horizontal ribbon is displayed across the top of the file window. You can
dock the vertical ribbon to the left or right of the application window.
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The vertical ribbon can also float in the file window or on a second monitor.

Ribbon Tabs and Panels

The ribbon is composed of a series of panels, which are organized into tabs
labeled by task. Ribbon panels contain many of the same tools and controls
available in toolbars and dialog boxes.

Some ribbon panels display a dialog box related to that panel. An icon in the
lower-right corner of the panel indicates that you can display a related dialog
box. Click the icon to display the associated dialog box.

To specify which ribbon tabs and panels are displayed, right-click the ribbon
and, on the shortcut menu, click or clear the names of tabs or panels.

Floating Panels

If you pull a panel off of a ribbon tab and into the drawing area or onto another
monitor, that panel floats where you placed it. The floating panel remains
open until you return it to the ribbon, even if you switch ribbon tabs.

Expanded Panels

An arrow to the right of a panel title indicates that you can expand the panel
to display additional tools and controls. By default, an expanded panel closes
automatically when you click another panel. To keep a panel expanded, click
the push pin icon in the bottom-left corner of the expanded panel.
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Contextual Ribbon Tabs

When you execute some commands, a special contextual ribbon tab is
displayed instead of a toolbar or dialog box. The contextual tab is closed when
you end the command.

See also:

■ Create Task-Based Workspaces on page 151

To display the ribbon

■ Click Tools menu ➤ Palettes ➤ Ribbon.

NOTE The ribbon displays the ribbon panels associated with the workspace
you used last.

To display the ribbon panels associated with a specific workspace, click
Tools menu ➤ Workspaces.

Command entry: RIBBON

To close the ribbon

■ At the Command prompt, enter ribbonclose.
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Command entry: RIBBONCLOSE
Shortcut menu: Right-click the ribbon tab bar and click Close.

To minimize the ribbon

1 Click the ribbon minimize button to the right of the ribbon tabs.

2 The minimize behavior cycles through the following minimize options:

■ Minimize to Tabs: Minimizes the ribbon so that only tab titles are
displayed.

■ Minimize to Panel Titles: Minimizes the ribbon so that only tab and
panel titles are displayed.

■ Show Full Ribbon: Displays tabs and full panels, including controls.

Shortcut menu: Right-click the ribbon, click Minimize, and then click one
of the above minimize options.
Pointing device: Double-click the name of the active ribbon tab.

To display or hide a ribbon panel

■ Right-click anywhere inside the ribbon. Under Panels, click or clear the
name of a panel.

NOTE In the 3D Modeling workspace, both the Home and Render tabs include
additional panels that are turned off by default.

To return a floating panel to the ribbon

■ Hover over the right side of the floating panel and click the Return Panels
to Ribbon icon.
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Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

RIBBON

Opens the ribbon window.

RIBBONCLOSE

Closes the ribbon window.

System Variables

MTEXTTOOLBAR

Controls the display of the Text Formatting toolbar.

RIBBONCONTEXTSELECT

Controls how ribbon contextual tabs are displayed when you single- or
double-click an object.

RIBBONCONTEXTSELLIM

Suppresses the display of ribbon contextual tabs when the selection set
includes more than the specified number of objects.

RIBBONSELECTMODE

Determines whether a pickfirst selection set remains selected after a ribbon
contextual tab is invoked and the command is completed.

RIBBONSTATE

Indicates whether the ribbon palette is open or closed.

TABLETOOLBAR

Controls the display of the Table toolbar.
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Utilities

No entries

Command Modifiers

No entries

Customize the Ribbon
You can customize the ribbon depending on your needs.

You can customize the ribbon in the following ways:

■ You can create and modify ribbon panels using the Customize User
Interface Editor. See Ribbon in the Customization Guide.

■ You can associate a customizable tool palette group with each tab on the
ribbon. Right-click the ribbon tab to display a list of available tool palette
groups.

■ You can change the order of ribbon tabs. Click the tab you want to move,
drag it to the desired position, and release.

■ You can change the order of ribbon panels. Click the panel you want to
move, drag it to the desired position, and release.

■ You can convert toolbars into ribbon panels using the Customize User
Interface Editor. See Ribbon in the Customization Guide.

See also:

■ Ribbon

To associate a tool palette group with a ribbon tab

1 Click Manage Tab  ➤  Customization panel  ➤  User Interface. 

2 In the Customize User Interface (CUI) Editor, Customize tab, in the
Customizations In <file name> pane, click the plus sign (+) next to the
Workspaces node to expand it.

3 Select the workspace that has the ribbon tab for which you want to assign
a tool palette group.
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4 In the Workspace Contents pane, click the plus sign (+) next to the Ribbon
Tabs node to expand it.

5 Select the ribbon tab that you want to assign a tool palette group.

6 In the Properties pane, in the ToolPalette Group box, click the down
arrow and select the tool palette group you want to assign to the ribbon
tab.

7 Click OK.

To display the tool palette group associated with a ribbon tab

■ Right-click a ribbon tab and click Show Related Tool Palette Group.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

RIBBON

Opens the ribbon window.

RIBBONCLOSE

Closes the ribbon window.

System Variables

MTEXTTOOLBAR

Controls the display of the Text Formatting toolbar.

RIBBONCONTEXTSELECT

Controls how ribbon contextual tabs are displayed when you single- or
double-click an object.

RIBBONCONTEXTSELLIM

Suppresses the display of ribbon contextual tabs when the selection set
includes more than the specified number of objects.
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RIBBONSELECTMODE

Determines whether a pickfirst selection set remains selected after a ribbon
contextual tab is invoked and the command is completed.

RIBBONSTATE

Indicates whether the ribbon palette is open or closed.

TABLETOOLBAR

Controls the display of the Table toolbar.

Utilities

No entries

Command Modifiers

No entries
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Other Tool Locations

Use common tools in the classic menu bar, toolbars, tool palettes, status bars, shortcut menus,
and Design Center to find more commands, settings, and modes.

Access the Classic Menu Bar
Display pull-down menus from the classic menu bar using one of several
methods. You can also specify alternate menus.

The classic menu bar can be displayed at the top of the drawing area. To display
the classic menu bar,

You can specify menus to display in the menu browser for all workspaces by
customizing a CUIx file and loading it into the program.

3
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See also:

■ Create Task-Based Workspaces on page 151

■ “Pull-down and Shortcut Menus” in the Customization Guide

To display the classic menu bar

■ On the Quick Access toolbar, click the Customization drop-down menu
 ➤  Show Menu Bar.

Command entry: MENUBAR

Quick Reference

Commands

No entries

System Variables

MENUBAR

Controls the display of the menu bar.

Utilities

No entries

Command Modifiers

No entries

Toolbars
Use buttons on toolbars to start commands, display flyout toolbars, and display
tooltips. You can display or hide, dock, and resize toolbars.

Toolbars contain buttons that start commands. When you move your mouse
or pointing device over a toolbar button, the tooltip displays the name of the
button. Buttons with a small black triangle in the lower-right corner are flyout
toolbars that contain related commands. With the cursor over the icon, hold
down the left button on your mouse until the flyout toolbar displays.
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The Quick Access toolbar at the top of the application window is displayed
by default. This toolbar is like those found in Microsoft® Office programs. It
contains frequently used AutoCAD® commands such as PLOT, UNDO, and
REDO, as well as Microsoft Office standard commands such as New, Open,
and Save. For more information about the Quick Access toolbar, see Quick
Access Toolbar on page 19.

NOTE You can turn a toolbar into a ribbon panel using the Customize User
Interface dialog box.

Display or Hide, Dock, and Resize Toolbars

You can display or hide toolbars, and you can save your selections as a
workspace. You can also create your own toolbars.

A toolbar displays as floating or docked. A floating toolbar displays anywhere
in the drawing area, and you can drag a floating toolbar to a new location,
resize it, or dock it. A docked toolbar is attached to any edge of the drawing
area. A toolbar docked at the top edge of the drawing area is located below
the ribbon. You can move a docked toolbar by dragging it to a new docking
location.

See also:

■ Create Task-Based Workspaces on page 151

■ “Toolbars” in the Customization Guide

■ Ribbon in the Customization Guide

To display a toolbar

Display a toolbar with one of the following methods

■ Right-click any toolbar and click a toolbar on the shortcut menu.

■ Click Tools  ➤  Toolbars and click the toolbar to display.

To dock a toolbar

1 Position the cursor on the name of the toolbar or in any blank area, and
hold down the button on your pointing device.

2 Drag the toolbar to a docking location at the top, bottom, or either side
of the drawing area.
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3 When the outline of the toolbar is displayed in the docking area, release
the button.

To place a toolbar in a docking region without docking it, hold down
Ctrl as you drag.

To undock a toolbar

1 Position the cursor on the double bars at the end of the toolbar, and hold
down the button on your pointing device.

2 Drag the toolbar away from its docked location and release the button.

To resize a toolbar

1 Position the cursor on the edge of a floating toolbar until the cursor
changes to a horizontal or vertical double arrow.

2 Hold down the button and move the cursor until the toolbar is in the
shape you want.

To close a toolbar

1 If the toolbar is docked, undock it.

2 Click the Close button in the upper-right corner of the toolbar.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

System Variables

TOOLTIPS

Controls the display of tooltips on the ribbon, toolbars, and other user
interface elements.

34 | Chapter 3   Other Tool Locations



Utilities

No entries

Command Modifiers

No entries

Status Bars
The application and drawing status bars provide useful information and
buttons for turning drawing tools on and off.

Application Status Bar
The application status bar displays the coordinate values of your cursor,
drawing tools, navigation tools, and tools for Quick View and annotation
scaling.

You can view the drawing tool buttons as icons or text. You also can easily
change the settings of snap, polar, osnap, and otrack from the shortcut menus
of these drawing tools.

You can preview and switch between open drawings and layouts in a drawing.
Use the navigation tools to switch between open drawings and view a model
in a drawing. You can also display tools for scaling annotations.

With the Workspace button, you can switch workspaces. The lock button
locks the current positions of the toolbars and windows. To expand the drawing
display area, click the Clean Screen button.

You can add or remove a button from the application status bar from the
shortcut menu of the status bar.

NOTE When the application status bar is turned off, the Clean Screen button is
not displayed on the screen.
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To display the application status bar

■ At the Command prompt, enter STATUSBAR and enter 1 to display only
the application status bar, or 2 to display both the application and drawing
status bars.

To control the display of icons and notifications in the status bar tray

1 Click  View tab  ➤  Windows panel  ➤  Status Bar. 

2 In the Status Bar drop-down, click Tray Settings.

3 In the Tray Settings dialog box, select or clear the following display
options:

■ Display Icons from Services. Displays the tray at the right end of the
status bar and displays icons from services. When this option is cleared,
the tray is not displayed.

■ Display Notifications from Services. Displays notifications from services
such as Communications Center. When the Display Icons from
Services option is cleared, this option is unavailable.

4 If Display Notifications from Services is selected, set a time for a
notification to be displayed, or select Display Until Closed.

5 Click OK.

Command entry: TRAYSETTINGS

To control the display of buttons on the status bar

1 Click  View tab  ➤  Windows panel  ➤  Status Bar. 

2 In the Status Bar drop-down, select any button name to change the
display.

Command entry: TRAYSETTINGS
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To control the display of cursor coordinates on the status bar

1 Click  View tab  ➤  Windows panel  ➤  Status Bar. 

2 In the Status Bar drop-down, select or clear Cursor Coordinate Values.

Command entry: TRAYSETTINGS

Quick Reference

Commands

TRAYSETTINGS

Controls the display of icons and notifications in the status bar tray.

System Variables

STATUSBAR

Controls the display of the application and drawing status bars.

Utilities

No entries

Command Modifiers

No entries

Drawing Status Bar
The drawing status bar displays several tools for scaling annotations.

Different tools display for model space and paper space.

When the drawing status bar is turned on, it displays at the bottom of the
drawing area. When the drawing status bar is turned off, the tools found on
the drawing status bar are moved to the application status bar.

Drawing Status Bar | 37



When the drawing status bar is turned on, you can use the Drawing Status
Bar menu to select which tool to display on the status bar.

To turn the drawing status bar on or off

■ Click View tab  ➤  Windows panel  ➤  Drawing Status Bar. 

Command entry: STATUSBAR

To control the display of buttons on the drawing status bar

■ Click the arrow to the right of the drawing status bar and select or clear
any option name.
Checked items are displayed on the drawing status bar.

Quick Reference

System Variables

STATUSBAR

Controls the display of the application and drawing status bars.

Keytips
Use the keyboard to access the Application menu, Quick Access toolbar, and
ribbon.

Press the Alt key to display shortcut keys for common tools in the application
window.

When you select a keytip, more keytips are displayed for that tool.
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The Command Window

Enter Commands on the Command Line
You can enter a command by using the keyboard. Some commands also have
abbreviated names called command aliases.

Commands, system variables, options, messages, and prompts are displayed
in a dockable and resizable window called the command window. The bottom
line of the command window is called the command line. The command line
displays the operation in progress and provides an inside view of exactly what
the program is doing.

To enter a command by using the keyboard, type the full command name on
the command line and press Enter or Spacebar.

NOTE When Dynamic Input is on and is set to display dynamic prompts, you can
enter many commands in tooltips near the cursor.

Some commands also have abbreviated names. For example, instead of entering
line to start the LINE command, you can enter l. Abbreviated command names
are called command aliases and are defined in the acad.pgp file.
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To define your own command aliases, see Create Command Aliases in the
Customization Guide.

To find a command, you can type a letter on the command line and press
TAB to cycle through all the commands that begin with that letter. Press Enter
or Spacebar. Restart a recently used command by right-clicking on the
command line.

Specify Command Options

When you enter commands on the command line, you see either a set of
options or a dialog box. For example, when you enter circle at the Command
prompt, the following prompt is displayed:

Specify center point for circle or [3P/2P/Ttr (tan, tan, radius)]:

You can specify the center point either by entering X,Y coordinate values or
by using the pointing device to click a point on the screen.

To choose a different option, enter the letters capitalized in one of the options
in the brackets. You can enter uppercase or lowercase letters. For example, to
choose the three-point option (3P), enter 3p.

Execute Commands

To execute commands, press Spacebar or Enter, or right-click your pointing
device after entering command names or responses to prompts. The
instructions in Help assume this step and do not specifically instruct you to
press Enter after each entry.

Repeat and Cancel Commands

If you want to repeat a command that you have just used, press Enter or
Spacebar, or right-click your pointing device at the Command prompt.

You also can repeat a command by entering multiple, a space, and the
command name, as shown in the following example:

Command: multiple circle

To cancel a command in progress, press ESC.

Interrupt a Command with Another Command or System Variable

Many commands can be used transparently: that is, they can be entered on
the command line while you use another command. Transparent commands
frequently change drawing settings or display , for example, GRID or ZOOM.
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In the Command Reference, transparent commands are designated by an
apostrophe in front of the command name.

To use a command transparently, click its toolbar button or enter an
apostrophe (') before entering the command at any prompt. On the command
line, double angle brackets (>>) precede prompts that are displayed for
transparent commands. After you complete the transparent command, the
original command resumes. In the following example, you turn on the dot
grid and set it to one-unit intervals while you draw a line, and then you
continue drawing the line.

Command: line
Specify first point: 'grid
>>Specify grid spacing (X) or [ON/OFF/Snap/Aspect] <0.000>: 1
Resuming LINE command
Specify first point:

Commands that do not select objects, create new objects, or end the drawing
session usually can be used transparently. Changes made in dialog boxes that
you have opened transparently cannot take effect until the interrupted
command has been executed. Similarly, if you reset a system variable
transparently, the new value cannot take effect until you start the next
command.

See also:

■ “Keyboard Shortcuts” in the Customization Guide

To copy a command you have recently used

1 Right-click on the command line. Click Recent Commands.

2 Click the command you want to use.

Quick Reference

Commands

MULTIPLE

Repeats the next command until canceled.

OPTIONS

Customizes the program settings.
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PASTECLIP

Pastes objects from the Clipboard into the current drawing.

System Variables

CMDNAMES

Displays the names of the active and transparent commands.

Utilities

No entries

Command Modifiers

No entries

Enter System Variables on the Command Line
System variables are settings that control how certain commands work.

They can turn on or turn off modes such as Snap, Grid, or Ortho. They can
set default scales for hatch patterns. They can store information about the
current drawing and about program configuration. Sometimes you use a system
variable in order to change a setting. At other times you use a system variable
to display the current status.

For example, the GRIDMODE system variable turns the dot grid display on
and off when you change the value. In this case, the GRIDMODE system
variable is functionally equivalent to the GRID command. DATE is a read-only
system variable that stores the current date. You can display this value, but
you cannot change it.

Bitcode Variables

Some system variables are controlled using bitcodes. With these system
variables, you add values to specify a unique combination of behaviors. For
example, the LOCKUI system variable provides the following bitcode values:

Toolbars and windows not locked0

Docked toolbars locked1

Docked or anchored windows locked2
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Floating toolbars locked4

Floating windows locked8

Thus, if LOCKUI is set to 1 + 4 = 5, only docked and floating toolbars are
locked; docked, anchored, and floating windows are not locked.

NOTE You can examine or change a system variable's setting transparently, that
is, while using another command; however, new values may not take effect until
the interrupted command ends.

To change the setting of a system variable

1 At the Command prompt, enter the system variable name. For example,
enter gridmode to change the grid setting.

2 To change the status of GRIDMODE, enter 1 for on or 0 for off. To retain
the current value of the system variable, press Enter.

To see a complete list of system variables

1 Click Tools menu ➤ Inquiry  ➤ Set Variable..

2 At the Variable Name prompt, enter ?.

3 At the Enter Variable(s) to List prompt, press Enter.

Command entry: SETVAR

Quick Reference

Commands

SETVAR

Lists or changes the values of system variables.

Enter System Variables on the Command Line | 43



System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Navigate and Edit Within the Command Window
You can edit text in the command window to correct or repeat commands.

Use the standard keys:

■ Up, Down, Left Arrow, and Right Arrow

■ Insert, Delete

■ Page Up, Page Down

■ Home, End

■ Backspace

You can repeat any command used in the current session by cycling through
the commands in the command window with Up ArrowCtrl and Down Arrow
and pressing Enter. By default, pressing Ctrl+C copies highlighted text to the
Clipboard. Pressing Ctrl+V pastes text from the Clipboard to the text window
or the command window.

If you right-click in the command window or text window, a shortcut menu
is displayed from which you can access the six most recently used commands,
copy selected text or the entire command history, paste text, and access the
Options dialog box.

For most commands, a command line with two or three lines of previous
prompts, called the command history, is sufficient for viewing and editing.
To see more than one line of command history, you can scroll through the
history or resize the command window by dragging its border. For commands
with text output, such as LIST, you might need a larger command window,
or you can press F2 to use the text window.
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Use the Text Window

The text window is a window similar to the command window in which you
can enter commands and view prompts and messages. The text window
displays a complete command history for the current work session. Use the
text window to view lengthy output of commands such as LIST, which displays
detailed information about objects you select. To move forward and backward
in the command history, you can click the scroll arrows along the right edge
of the window.

Press SHIFT with a key to highlight text. For example, press SHIFT+HOME in
the text window to highlight all text from the cursor location to the beginning
of the line.

To copy all the text in the text window to the Clipboard, use the COPYHIST
command.

To save commands to a log file, use the LOGFILEON command.

See also:

■ Dock, Resize, and Hide the Command Window on page 49

■ Use Dynamic Input on page 668

To close the text window

■ At the Command prompt, enter graphscr.

NOTE You can also close the text window by pressing F2, or using the standard
Windows controls.

To copy text from the text window to the command line

1 If the text window is not displayed, click Tools tab  ➤  Windows Elements

panel  ➤  Text Window. 

2 Select the text you want to copy.

3 Right-click in the command window or text window. Click Paste to
Command Line.

The text is copied to the Clipboard and then pasted on the command
line. After you press Enter, the commands are executed in sequence, like
a script. You can also use Ctrl+C and Ctrl+V to copy and paste text.
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Command entry: COPYCLIP, PASTECLIP

To display the text window

■ Click View tab ➤ Windows Elements panel ➤ Text Window. 

The text window is displayed in front of the drawing area.

Command entry: TEXTSCR

Quick Reference

Commands

COPYCLIP

Copies selected objects to the Clipboard.

COPYHIST

Copies the text in the command line history to the Clipboard.

GRAPHSCR

Switches from the text window to the drawing area.

LOGFILEOFF

Closes the text window log file opened by LOGFILEON.

LOGFILEON

Writes the text window contents to a file.

PASTECLIP

Pastes objects from the Clipboard into the current drawing.

TEXTSCR

Opens the text window.

System Variables

LOGFILEMODE

Specifies whether the contents of the text window are written to a log file.
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LOGFILENAME

Specifies the path and name of the text window log file for the current
drawing.

LOGFILEPATH

Specifies the path for the text window log files for all drawings in a session.

Utilities

No entries

Command Modifiers

No entries

Switch Between Dialog Boxes and the Command Line
You can display prompts on the command line instead of using a dialog box,
or switch back again. This option is useful primarily when using scripts.

Some functions are available both on the command line and in a dialog box.
In many cases, you can enter a hyphen before the command to suppress the
dialog box and display prompts on the command line instead. For example,
entering layer on the command line displays the Layer Properties Manager.
Entering -layer on the command line displays the equivalent command line
options. Suppressing the dialog box is useful for compatibility with earlier
versions of AutoCAD® and for using script files. There may be slight differences
between the options in the dialog box and those available on the command
line.

These system variables also affect the display of dialog boxes:

■ ATTDIA controls whether INSERT uses a dialog box for attribute value
entry.

■ CMDNAMES displays the name (in English) of the currently active
command and transparent command.

■ EXPERT controls whether certain warning dialog boxes are displayed.

■ FILEDIA controls the display of dialog boxes used with commands that
read and write files. For example, if FILEDIA is set to 1, SAVEAS displays
the Save Drawing As dialog box. If FILEDIA is set to 0, SAVEAS displays
prompts on the command line. The procedures in this documentation
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assume that FILEDIA is set to 1. Even when FILEDIA is set to 0, you can
display a file dialog box by entering a tilde (~) at the first prompt.

FILEDIA and EXPERT are useful when you use scripts to run commands.

To use the command line version of a command

■ For most commands, enter minus (-) in front of the command.

■ For dialog boxes that open and save files, set the FILEDIA system variable
to 0.

Quick Reference

Commands

GRAPHSCR

Switches from the text window to the drawing area.

System Variables

ATTDIA

Controls whether the INSERT command uses a dialog box for attribute value
entry.

CMDNAMES

Displays the names of the active and transparent commands.

EXPERT

Controls whether certain prompts are issued.

FILEDIA

Suppresses display of file navigation dialog boxes.
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Utilities

No entries

Command Modifiers

No entries

Dock, Resize, and Hide the Command Window
Change the position and display of the command window to suit the way
you work.

Dock the Command Window

By default, the command window is docked. The docked command window
is the same width as the AutoCAD window. If text that is entered becomes
longer than the width of the command line, the window pops up in front of
the command line to show the full text of the line.

Undock, or float, the command window by dragging it away from the docking
region. The docking region is an edge of the AutoCAD application window
that allows you to dock a toolbar, palette, or the command window. You can
move the floating command window anywhere on the screen and resize its
width and height with the pointing device.

Dock a floating command window again by dragging it to the docking region
of the AutoCAD window.

Anchoring the Command Window

The command window can be anchored on the left or right side of the
AutoCAD window. By anchoring the command window it remains on screen,
but in a minimized state, which allows you to bring it back up when needed.
This also helps to increase the amount of visible drawing area. The command
window must be floating before an anchoring side can be selected. To anchor
the command window make sure it is floating, and then right-click over its
title bar and select either Anchor Left or Anchor Right.

Resize the Command Window

You can resize the command window vertically by dragging the splitter bar,
which is located on the top edge of the window when it is docked on the
bottom and at the bottom edge of the window when it is docked at the top.
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Hide the Command Window

Hide and redisplay the command line by doing one of the following:

■ Click Tools menu  ➤ Command Line.

■ Press Ctrl+9.

When you hide the command line, you can still enter commands. However,
some commands and system variables return values at the command line, so
you may want to redisplay the command line in those instances.

NOTE For information about display options (such as auto-hide or transparency)
for dockable windows, see “Control the Display of Dockable Windows” in the
topic Set Interface Options on page 111.

To float the command window

■ Click the move handle (the double bars) on the left edge of the docked
command window and drag the command window away from the docking
region until it has a thick outline. Then drop it in the drawing area of the
AutoCAD window.

To make the floating command window transparent

1 In the floating Command window, click the Properties button and select
Transparency.

2 In the Transparency dialog box, move the slider to the left to make the
command window less transparent and to the right to make it more
transparent.

The range is from opaque to transparent. When the Turn Off Transparency
for All Palettes option is selected, the command window cannot be made
transparent.

To dock the command window

■ Click the title bar and drag the command window until it is over the top
or bottom docking region of the AutoCAD window. When the command
window becomes the same width as the AutoCAD window, release the
mouse button to dock it.
The docking region is an edge of the AutoCAD application window that
allows you to dock a toolbar, palette, or the command window.

50 | Chapter 3   Other Tool Locations



■ Right-click the title bar of the Command window, and select Allow
Docking.

NOTE You can control whether the command window docks by right-clicking
the title bar of the command window and then clicking Allow docking.

To resize the command window when it is docked

1 Position the cursor over the horizontal splitter bar so that the cursor
appears as a double line and arrows.

2 Drag the splitter bar vertically until the command window is the size you
want it to be.

To hide the command window

■ Click View tab ➤ Palettes panel ➤ Command Line. 

NOTE Some commands and system variables return values at the command line,
so you may want to display the command line in those instances. To display the
command line when it's hidden, press Ctrl+9. Alternate method:

Command entry: COMMANDLINE

Quick Reference

Commands

COMMANDLINE

Displays the Command Line window.

COMMANDLINEHIDE

Hides the Command Line window.

System Variables

PALETTEOPAQUE

Controls whether palettes can be made transparent.

Dock, Resize, and Hide the Command Window | 51



Utilities

No entries

Command Modifiers

No entries

Shortcut Menus
Display a shortcut menu for quick access to commands that are relevant to
your current activity.

You can display different shortcut menus when you right-click different areas
of the screen. Shortcut menus typically include options to

■ Repeat the last command entered

■ Cancel the current command

■ Display a list of recent user input

■ Cut, copy, and paste from the Clipboard

■ Select a different command option

■ Display a dialog box, such as Options or Customize

■ Undo the last command entered

You can customize right-click behavior to be time-sensitive, so that a quick
right-click acts the same as pressing Enter, and a longer right-click displays a
shortcut menu.

Shortcut menus can be customized using a customization (CUIx) file. The
main CUIx file is called acad.cuix by default.

See also:

■ “Create Submenus” in the Customization Guide

To display a shortcut menu

1 Move the cursor over an area, feature, or icon.

2 Right-click your mouse, or press the equivalent button on your pointing
device.
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A shortcut menu relevant to the cursor location is displayed. If one or
more objects are selected when you right-click in the drawing area, an
editing-oriented shortcut menu is displayed. You can also display a
shortcut menu during PAN or ZOOM.

To turn off shortcut menus in the drawing area

1 Click Tools menu  ➤ Options.

2 In the Options dialog box, User Preferences tab, under Windows Standard
Behavior, clear Shortcut Menus in Drawing Area.

3 To control Default, Edit, and Command shortcut menus individually,
select Shortcut Menus in Drawing Area. Right-Click Customization.

4 In the Right-Click Customization dialog box, under Default Mode or Edit
Mode, select one of the following options to control what happens when
you right-click in the drawing area and no command is in progress:

■ Repeat Last Command. Repeats the last command. Selecting this
option turns off the Default and Edit shortcut menus. Right-clicking
is the same as pressing Enter.

■ Shortcut Menu. Displays the Default or Edit shortcut menu.

5 Under Command Mode, select one of the following options to determine
what happens when you right-click in the drawing area while a command
is in progress:

■ Enter. Turns off the Command shortcut menu. Right-clicking is the
same as pressing Enter.

■ Shortcut Menu: Always Enabled. Displays the Command shortcut
menu.

■ Shortcut Menu: Enabled When Command Options Are Present.
Displays the Command shortcut menu only when options are
currently available in the Command prompt. In a Command prompt,
options are enclosed in square brackets. If no options are available,
right-clicking is the same as pressing Enter.

In addition to turning the Default, Edit, and Command shortcut menus
on and off, you can customize the options that are displayed on them.
For example, you can add options to the Edit shortcut menu that are
displayed only when circles are selected.
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To turn on time-sensitive right-click behavior

1 Click Tools menu  ➤ Options.

2 In the Options dialog box, User Preferences tab, under Windows Standard
Behavior, click Right-Click Customization.

3 In the Right-Click Customization dialog box, select Turn on Time-Sensitive
Right-Click.

You can specify the duration of the longer click. The default is 250
milliseconds

4 Click Apply & Close.

5 In the Options dialog box, click OK.

Command entry: OPTIONS

To control the display of recent input

1 At the Command prompt, enter inputhistorymode.

2 Enter a sum of one or more of the following values:

■ 0. No history of recent input is displayed.

■ 1. History of recent input is displayed at the Command prompt with
access through Up Arrow and Down Arrow keys.

■ 2. History of recent input for the current command is displayed in
the shortcut menu.

■ 4. History of recent input for all commands in the current session is
displayed in the shortcut menu.

■ 8. Markers for recent input of point locations are displayed in the
drawing.

The default value is 15.

3 (Optional) At the Command prompt, enter cmdinputhistorymax.

4 Enter a value to control how many unique values entered at a prompt
are remembered and available to be displayed as recent input.
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Quick Reference

Commands

COPYCLIP

Copies selected objects to the Clipboard.

COPYHIST

Copies the text in the command line history to the Clipboard.

CUI

Manages the customized user interface elements in the product.

CUTCLIP

Copies selected objects to the Clipboard and removes them from the drawing.

OPTIONS

Customizes the program settings.

PAN

Moves the view in the current viewport.

PASTECLIP

Pastes objects from the Clipboard into the current drawing.

PROPERTIES

Controls properties of existing objects.

TRAYSETTINGS

Controls the display of icons and notifications in the status bar tray.

U

Reverses the most recent operation.

ZOOM

Increases or decreases the magnification of the view in the current viewport.

System Variables

CMDINPUTHISTORYMAX

Sets the maximum number of previous input values that are stored for a
prompt in a command.

Shortcut Menus | 55



INPUTHISTORYMODE

Controls the content and location of the display of a history of user input.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

SHORTCUTMENU

Controls whether Default, Edit, and Command mode shortcut menus are
available in the drawing area.

TRAYICONS

Controls whether a tray is displayed on the status bar.

TRAYNOTIFY

Controls whether service notifications are displayed in the status bar tray.

TRAYTIMEOUT

Controls the length of time (in seconds) that service notifications are
displayed.

Utilities

No entries

Command Modifiers

No entries

Tool Palettes
Tool palettes are tabbed areas within the Tool Palettes window that provide
an efficient method for organizing, sharing, and placing blocks, hatches, and
other tools. Tool palettes can also contain custom tools provided by third-party
developers.

Create and Use Tools from Objects and Images
You can create a tool by dragging objects from your drawing onto a tool
palette. You can then use the new tool to create objects with the same
properties as the object you dragged onto the tool palette.
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Tool palettes are tabbed areas within the Tool Palettes window. The items you
add to a tool palette are called tools. You can create a tool by dragging any of
the following, one at a time, onto your tool palette:

■ Geometric objects such as lines, circles, and polylines

■ Dimensions

■ Blocks

■ Hatches

■ Solid fills

■ Gradient fills

■ Raster images

■ External references (xrefs)

NOTE When you drag an object onto a tool palette, you can switch to a different
tab by hovering over the tab for a few seconds.

You can then use the new tool to create objects in your drawing with the same
properties as the object you dragged to the tool palette. For example, if you
drag a red circle with a lineweight of .05 mm from your drawing to your tool
palette, the new tool creates a red circle with a lineweight of .05 mm. If you
drag a block or xref to a tool palette, the new tool inserts the block or xref
with the same properties into your drawing.

When you drag a geometric object or a dimension onto a tool palette, the
new tool is automatically created with an appropriate flyout. Dimension tool
flyouts, for example, provide an assortment of dimension styles. Click the
arrow on the right side of the tool icon on the tool palette to display the flyout.
When you use a tool on a flyout, the object in the drawing has the same
properties as the original tool on the tool palette.

Insert Blocks and Attach References

You can choose to be prompted for a rotation angle (starting from 0) when
you click and place a block or xref. This option ignores the angle specified
under Rotation in the Tool Properties dialog box. The rotation angle prompt
does not display if you drag the block or xref, or if you enter rotate at the
initial insertion Command prompt.

Blocks that are placed by dragging from a tool palette must often be rotated
or scaled after placement. You can use object snaps when dragging blocks
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from a tool palette; however, grid snap is suppressed during dragging. You
can set an auxiliary scale for a block or a hatch tool to override the regular
scale setting when you use the tool. (An auxiliary scale multiplies your current
scale setting by the plot scale or the dimension scale.)

Blocks dragged from a tool palette are automatically scaled according to the
ratio of units in both the block and the current drawing. For example, if the
current drawing uses meters as units and a block uses centimeters, the unit
ratio is 1 m/100 cm. When you drag the block into the drawing, it is inserted
at 1/100 scale.

NOTE In the Options dialog box, User Preferences tab, the Source Content Units
and Target Drawing Units settings are used when Drag-and-Drop Scale is set to
Unitless, either in the source block or target drawing.

Update Block Definitions on Tool Palettes

A block definition in your current drawing does not update automatically
when you modify the block in the source drawing. To update a block definition
in the current drawing, right-click the block tool on the tool palette and click
Redefine on the shortcut menu.

If the Redefine option is unavailable, then the block definition source is a
drawing file rather than a block within a drawing file. To update a block
definition that was created by inserting a drawing file, use DesignCenter. For
more information, see Add Content with DesignCenter on page 96.

NOTE If you move the source drawing file for a block tool to a different folder,
then modify the tool that references it by right-clicking the tool and, in the Tool
Properties dialog box, specifying the new source file folder.

See also:

■ Control Tool Properties on page 70

■ Customize Tool Palettes on page 74

■ Create Task-Based Workspaces on page 151

■ Add Content with DesignCenter on page 96
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To display the Tool Palettes window

Do one of the following:

■ Click View tab  ➤  Palettes panel  ➤  Tool Palettes. 

■ Press Ctrl+3.

Command entry: TOOLPALETTES

Toolbar: Standard  

To create a tool from an object in the current drawing

1 In the current drawing, select an object such as a dimension, block, hatch,
gradient fill, raster image, xref, or any geometric object.

2 Drag the object to a tool palette and, without releasing the mouse button,
move the cursor to the place on the tool palette where you want the tool.

You can switch to a different tab by hovering over the tab for a few
seconds. The black line indicates where the tool is located.

3 Release the mouse button.

Command entry: TOOLPALETTES

Toolbar: Standard  

To use a tool created from a geometric object

1 On a tool palette, click the geometric object tool you want to use.

2 Use the tool as if you selected the corresponding option from the Draw
menu or the corresponding button on the Draw toolbar, following the
Command prompts.

The geometric object you create has the same properties as the tool you
selected from the tool palette.

Command entry: TOOLPALETTES

Toolbar: Standard  
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To use a tool created from a dimension

1 On a tool palette, click the dimension tool you want to use.

2 Use the tool as if you selected the corresponding option from the
Dimension menu or the corresponding button on the Dimension toolbar,
following the Command prompts.

The dimension you create has the same dimension style and properties
as the tool you selected from the tool palette.

Toolbar: Standard  
Command entry: TOOLPALETTES

To use a tool on a tool flyout

1 On a tool palette, click the arrow on the right side of the dimension tool
or the geometric object tool you want to use.

2 On the flyout, select a tool.

3 Use the tool as if you selected the corresponding option from a menu or
the corresponding button on a toolbar, following the Command prompts.

The object you create has the same properties as the tool whose icon you
selected on the tool flyout.

Toolbar: Standard  
Command entry: TOOLPALETTES

To add or remove a tool flyout

1 On a tool palette, right-click the geometric object tool or the dimension
tool whose flyout you want to add or remove. Click Properties.

2 In the Tool Properties dialog box, under Command, click in the Use
Flyout box.

3 In the drop-down list, select Yes if you want to add a flyout, or select No
if you want to remove one.

4 Click OK.
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NOTE If you remove the flyout from a tool but then add the flyout back, the
image, name, and description (the tooltip) that displays on the tool palette
for each tool on the flyout will not be accurate. To correct this, return the
image, name, and description of the flyout tool to the default settings. See
To change the image, name, and description of a flyout tool to the default
settings.

Toolbar: Standard  
Command entry: TOOLPALETTES

To customize a tool flyout

1 On a tool palette, right-click the geometric object tool or dimension tool
whose flyout you want to customize. Click Properties.

2 In the Tool Properties dialog box, under Command, click in the Flyout
Options box. Click the [...] button.

3 In the Flyout Options dialog box, select the tools that you want to show
on the flyout. Click OK. (You must select at least one tool.)

4 In the Tool Properties dialog box, click OK.

Toolbar: Standard  
Command entry: TOOLPALETTES

To use a tool created from a hatch

1 On a tool palette, click a hatch tool and drag it to an object in the
drawing.

2 Release the mouse button to apply the hatch to the object.

The hatch you create has the same hatch style and properties as the tool
you selected from the tool palette.

Toolbar: Standard  
Command entry: TOOLPALETTES
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To use a tool created from a gradient fill

1 On a tool palette, click a gradient fill tool and drag it to an object in the
drawing.

2 Release the mouse button to apply the gradient fill to the object.

The gradient fill you create has the same style and properties as the tool
you selected from the tool palette.

Toolbar: Standard  
Command entry: TOOLPALETTES

To use a tool created from a block, xref, or raster image

1 On a tool palette, click the block, xref, or raster image you want to insert
into your drawing.

2 Drag the block, xref, or raster image to the appropriate place in the
drawing.

3 Release the mouse button to insert the block, xref, or raster image.

The block, xref, or raster image you insert has the same properties as the
tool you selected from the tool palette.

Toolbar: Standard  
Command entry: TOOLPALETTES

To be prompted for a rotation angle when placing a block or xref from a tool
palette

1 In a tool palette, right-click a block or xref tool. Click Properties.

2 In the Tool Properties dialog box, under Insert, click Prompt for Rotation.

3 In the drop-down list, select Yes.

4 Click OK.

NOTE This option ignores the angle specified under Rotation in the Tool
Properties dialog box. The rotation angle prompt does not display if you drag
the block or xref, or if you enter rotate at the initial insertion Command
prompt.
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Toolbar: Standard  
Command entry: TOOLPALETTES

Quick Reference

Commands

CUSTOMIZE

Customizes tool palettes and tool palette groups.

TOOLPALETTES

Opens the Tool Palettes window.

TOOLPALETTESCLOSE

Closes the Tool Palettes window.

UNITS

Controls coordinate and angle display formats and precision.

System Variables

INSUNITSDEFSOURCE

Sets source content units value when INSUNITS is set to 0.

INSUNITSDEFTARGET

Sets target drawing units value when INSUNITS is set to 0.

PALETTEOPAQUE

Controls whether palettes can be made transparent.

TPSTATE

Indicates whether the Tool Palettes window is open or closed.
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Utilities

No entries

Command Modifiers

No entries

Create and Use Command Tools
You can create a tool on a tool palette that executes a single command or a
string of commands.

You can add frequently used commands to a tool palette. When the Customize
dialog box is open, you can drag tools from a toolbar to a tool palette or you
can drag tools from the Customize User Interface (CUI) Editor to a tool palette.

Once you add a command to a tool palette, you can click the tool to execute
the command. For example, clicking a Save tool on a tool palette saves a
drawing just as the Save button on the Standard toolbar does.

You can also create a tool that executes a string of commands or customized
commands, such as an AutoLISP® routine, a VBA macro or application, or a
script.

NOTE Even though the tools on palettes can be clicked when the Customize User
Interface (CUI) Editor is displayed, the end results might be unpredictable. It is
best to not use any of the tools on a palette while the Customize User Interface
(CUI) Editor is displayed.

To create a command tool from a toolbar button

1 Make sure the toolbar that contains the command you want to add to
the tool palette is displayed.

If the required toolbar is not displayed, click Tools  ➤  Toolbars and select
another toolbar from the list.

2 Click Manage tab ➤ Customization panel ➤ Tool Palettes. 

NOTE Even though you won't make any changes in the Customize dialog
box in this procedure, it must be displayed when you add command tools
to a tool palette.
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3 In the program, drag a command (button) from a toolbar to the tool
palette and, without releasing the mouse button, move the cursor to the
place on the tool palette where you want the tool.

The black horizontal line indicates where the tool will be located.

4 Release the mouse button.

5 In the Customize dialog box, click Close.

Command entry: CUSTOMIZE

To create a command tool from the Customize User Interface

1 Click Manage tab  ➤  Customization panel  ➤  User Interface. 

If the CUI Editor is covering the Tool Palettes window, then move the
CUI Editor to the side.

2 In the Command List pane, drag a command to the tool palette and,
without releasing the mouse button, move the cursor to the place on the
tool palette where you want the tool.

The black horizontal line indicates where the tool will be located.

3 Release the mouse button.

4 In the CUI Editor, click Close.

Command entry: CUI

To create a command tool that executes multiple or customized commands
(advanced)

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the program, drag a command from a toolbar to the tool palette and,
without releasing the mouse button, move the cursor to the place on the
tool palette where you want the tool.

3 Release the mouse button.

4 On the tool palette, right-click the tool. Click Properties.
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5 In the Tool Properties dialog box, change the name and description to
an appropriate name and description for the string, AutoLISP routine, or
script.

6 Under Command, in the Command String box, enter a string of
commands or customized commands, such as an AutoLISP routine, a
VBA macro or application, or a script.

7 Click OK.

Command entry: CUSTOMIZE

To use a command tool

1 On a tool palette, click the command tool that you want to use.

2 Follow any Command prompts that are shown.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

CUSTOMIZE

Customizes tool palettes and tool palette groups.

TOOLPALETTES

Opens the Tool Palettes window.

TOOLPALETTESCLOSE

Closes the Tool Palettes window.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Change Tool Palette Settings
The options and settings for tool palettes are accessible from shortcut menus
that are displayed when you right-click in different areas of the Tool Palettes
window.

You can dock the Tool Palettes window on the right or left edge of the
application window. Press the Ctrl key if you want to prevent docking as you
move the Tool Palettes window.

Tool palette settings are saved with your profile.

These settings include

■ Allow Docking. Toggles the ability to dock or anchor palette windows. If
this option is selected, a window can be docked when you drag it over a
docking area at the side of a drawing. A docked window adheres to the
side of the application window and causes the drawing area to be resized.
Selecting this option also makes Anchor Right and Anchor Left available.

■ Anchor Left or Anchor Right. Attaches the palette to an anchor tab base
at the left or right side of the drawing area. The palette rolls open and
closed as the cursor moves across it. When an anchored palette is open,
its content overlaps the drawing area. An anchored palette cannot be set
to stay open.

■ Auto-hide. Controls the display of the palette when it is floating. When
this option is selected, only the tool palette title bar is displayed when the
cursor moves outside the tool palette. When this option is cleared, the
palette stays open continuously. You can display the tool palette title bar
as either icons or text from the shortcut menu of the title bar.
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■ Transparency. Sets the transparency of the Tool Palettes window so it does
not obscure objects under it.

■ Views. Changes the display style and size of the icons in a tool palette.

To change the rollover behavior of the Tool Palettes window

■ In the Tool Palettes window, at the top of the title bar, click the Auto-Hide
button.

NOTE Rollover behavior is available only when the Tool Palettes window is
undocked.
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To change the transparency of the Tool Palettes window

1 In the Tool Palettes window, at the top of the title bar, click the Properties
button. Click Transparency.

2 In the Transparency dialog box, adjust the level of transparency for the
Tool Palettes window. Click OK.

NOTE Transparency is available only when the Tool Palettes window is
undocked.

To change the icon display style in the Tool Palettes window

1 Right-click a blank area inside the Tool Palettes window. Click View
Options.

2 In the View Options dialog box, click the icon display option that you
want to set. You can also change the size of the icons.

3 Click the list box under Apply To, and then select either Current Tool
Palette or All Tool Palettes.

4 Click OK.

Quick Reference

Commands

CUSTOMIZE

Customizes tool palettes and tool palette groups.

TOOLPALETTES

Opens the Tool Palettes window.

TOOLPALETTESCLOSE

Closes the Tool Palettes window.

System Variables

PALETTEOPAQUE

Controls whether palettes can be made transparent.
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TPSTATE

Indicates whether the Tool Palettes window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Control Tool Properties
You can change the properties of any tool on a tool palette.

Once a tool is on a tool palette, you can change its properties. For example,
you can change the insertion scale of a block or the angle of a hatch pattern.

To change tool properties, right-click on a tool, and then click Properties on
the shortcut menu to display the Tool Properties dialog box. The Tool
Properties dialog box has the following two categories of properties:

■ Insert or Pattern properties. Control object-specific properties such as
scale, rotation, and angle.

■ General properties. Override the current drawing property settings such
as layer, color, and linetype.
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You can expand and collapse the property categories by clicking the arrow
buttons.

Specify a Different Icon for a Tool

You can replace the icon for a tool with an image that you specify. This is
useful when the automatically generated icon is too cluttered to be easily
recognizable.

To replace the image, right-click the tool in the tool palette and click Specify
Image on the shortcut menu.

To restore the default image for a tool, right-click the tool and click Remove
Specified Image.

Update the Icon for a Tool

The icon for a block, xref, or raster image in a tool palette is not automatically
updated if its definition changes. If you change the definition for a block,
xref, or raster image, you can update the icon by right-clicking the tool in the
palette and clicking Update Tool Image. You must save the drawing before
you can update the tool image.

Alternatively, you can delete the tool, and then replace it using DesignCenter™.

Specify Overrides for Tool Properties

In some cases, you may want to assign specific property overrides to a tool.
For example, you may want a hatch to be placed automatically on a
pre-specified layer, regardless of the current layer setting. This feature can save
you time and reduce errors by setting properties automatically when creating
certain objects.

The Tool Properties dialog box provides areas for each possible property
override.

Layer property overrides affect color, linetype, lineweight, plot style, and plot.
Layer property overrides are resolved as follows:

■ If a layer is missing from the drawing, that layer is created automatically.

■ If a layer to which you are adding content is currently turned off or frozen,
the layer is temporarily turned on or thawed.

To display the properties of a tool on a tool palette

1 On a tool palette, right-click a tool. Click Properties.
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2 In the Tool Properties dialog box, use the scroll bar to view all tool
properties.

You can resize the Tool Properties dialog box by dragging an edge, or you
can expand and collapse the property categories by clicking the double
arrow buttons.

3 Click OK.

To change the property of a tool on a tool palette

1 On a tool palette, right-click a tool. Click Properties.

2 In the Tool Properties dialog box, click any property in the list of
properties and specify the new value or setting.

■ Properties listed under the Insert or Pattern category control
object-specific properties such as scale, rotation, and angle.

■ Properties listed under the General category override the current
drawing property settings such as layer, color, and linetype.

■ Auxiliary scale for a block or a hatch tool overrides the regular scale
setting when the tool is used. (An auxiliary scale multiplies your
current scale setting by the plot scale or the dimension scale.)

You can resize the Tool Properties dialog box by dragging an edge, or you
can expand and collapse the property categories by clicking the arrow
buttons.

3 Click OK.

NOTE If you specify an image, name, or description for a tool that has a
flyout, that image, name, and description are displayed on the tool palette
for each tool on the flyout. To return the flyout tool's image, name, and
description to their default settings, leave the corresponding boxes blank in
the Tool Properties dialog box.

Toolbar: Standard  
Command entry: TOOLPALETTES

To refresh the image of a block tool on a tool palette

1 On a tool palette, right-click a tool.
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2 Click Update Tool Image.

NOTE You must save the drawing before you can update the tool image.

Toolbar: Standard  
Command entry: TOOLPALETTES

To change the image of a tool on a tool palette

1 On a tool palette, right-click a tool.

2 On the shortcut menu, click Specify Image.

3 In the Select Image File dialog box, locate the image file you want to use.

4 Click Open to insert the new image.

NOTE If you specify an image for a tool that has a flyout, that image is
displayed on the tool palette for each tool on the flyout. To return the flyout
tool images to their default images, see To change the image, name, and
description of a flyout tool to the default settings.

Toolbar: Standard  
Command entry: TOOLPALETTES

To change the image, name, and description of a flyout tool to the default
settings

1 On a tool palette, right-click a tool. Click Properties.

2 In the Tool Properties dialog box, right-click in the image area. Click
Delete Image.

3 Click in the Name box and delete the text.

4 Click in the Description box and delete the text.

5 Click OK.

NOTE Leaving the Image, Name, and Description boxes blank in the Tool
Properties dialog box will return the flyout tool's image, name, and description
to their default settings.
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Toolbar: Standard  
Command entry: TOOLPALETTES

Quick Reference

Commands

CUSTOMIZE

Customizes tool palettes and tool palette groups.

TOOLPALETTES

Opens the Tool Palettes window.

TOOLPALETTESCLOSE

Closes the Tool Palettes window.

TPNAVIGATE

Displays a specified tool palette or palette group.

System Variables

PALETTEOPAQUE

Controls whether palettes can be made transparent.

TPSTATE

Indicates whether the Tool Palettes window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Customize Tool Palettes
You can add tools to a tool palette with several methods.
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You can create new tool palettes using the Properties button on the title bar
of the Tool Palettes window. Add tools to a tool palette with the following
methods:

■ Drag any of the following onto your tool palette: geometric objects such
as lines, circles, and polylines; dimensions; hatches; gradient fills; blocks;
xrefs; raster images.

■ Drag drawings, blocks, and hatches from DesignCenter to the tool palette.
Drawings that are added to a tool palette are inserted as blocks when
dragged into the drawing.

■ Use the Customize dialog box to drag commands to a tool palette just as
you might add them to a toolbar.

■ Use the Customize User Interface (CUI) Editor to drag commands to a tool
palette from the Command List pane.

■ Use Cut, Copy, and Paste to move or copy tools from one tool palette to
another.

■ Manage tool palettes by creating new palettes from scratch, renaming,
deleting or moving palettes with the shortcut menu.

NOTE It is not recommended to create or rename tool palettes when the
Customize User Interface (CUI) Editor is displayed.

■ Create a tool palette tab with predetermined content by right-clicking a
folder, a drawing file, or a block in the DesignCenter tree view, and then
clicking Create Tool Palette on the shortcut menu.
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■ You can associate a customizable tool palette group with each panel on
the ribbon. Right-click the ribbon panel to display a list of available tool
palette groups.

NOTE If the source drawing file for a block, xref, or raster image tool is moved to
a different folder, you must modify the tool that references it by right-clicking the
tool and, in the Tool Properties dialog box, specifying the new source file folder.

Rearranging Tools and Tool Palettes

Once tools are placed on a tool palette, you can rearrange them by dragging
them around or by sorting them. You can also add text and separator lines to
tool palettes.

You can move a tool palette tab up and down the list of tabs by using the tool
palette shortcut menu or the Tool Palettes tab of the Customize dialog box.
Similarly, you can delete tool palettes that you no longer need. Tool palettes
that are deleted are lost unless they are first saved by exporting them to a file.
You can control the path to your tool palettes on the Files tab in the Options
dialog box. This path can be to a shared network location.

Read-Only Tool Palettes

If a tool palette file is set with a read-only attribute, a lock icon is displayed
in a lower corner of the tool palette. This indicates that you cannot modify
the tool palette beyond changing its display settings and rearranging the icons.
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To apply a read-only attribute to a tool palette, right-click the tool palette
(ATC) file in the following location: C:\documents and settings\<user
name>\application data\autodesk\AutoCAD
2010\r17.2\enu\support\ToolPalette\Palettes. On the shortcut menu, click
Properties. On the General tab, select Read-only, and click OK.

To create a tool palette

1 Click View tab  ➤ Palettes panel  ➤  Tool Palettes. 

2 In the Tool Palettes window, at the top of the title bar, click the Properties
button. Click New Palette.

3 In the text box, enter a name for the new palette.

4 If necessary, right-click over the tab and select Move Up or Move Down
to change the order in which the tab appears in.

Command entry: TOOLPALETTES

Toolbar: Standard  

To create a tool palette from a folder or a drawing

1 If DesignCenter is not already open, click View tab  ➤ Palettes
panel ➤ DesignCenter.

2 In the DesignCenter tree view or the content area, right-click a folder,
drawing file, or block. Click Create Tool Palette.

A new tool palette is created that contains all the blocks and hatches in
the selected folder or drawing.

Command entry: ADCENTER

Toolbar: Standard  

To associate a tool palette group with a ribbon panel

1 Click View tab  ➤  Palettes panel  ➤  Tool Palettes. 
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2 On the ribbon, right-click a ribbon panel and click Tool Palette Group.

3 Click an available tool palette group from the list.

4 Click Tools menu  ➤  Workspaces  ➤  Save Current As.

5 In the Save Workspace dialog box, enter a name for the new workspace
or select a name from the drop-down list. Click Save.

To display the tool palette group associated with a ribbon panel

■ Right-click a ribbon panel and click Show Related Tool Palette Group.

To rename a tool palette

1 Right-click a blank area inside the Tool Palettes window. Click Rename
Palette.

2 In the text box, enter a new name for the palette.

Command entry: TOOLPALETTES

Toolbar: Standard  

To delete a tool palette

1 Right-click a blank area inside the Tool Palettes window. Click Delete
Palette.

2 In the Confirm Palette Deletion message box, click OK to delete the tool
palette.

NOTE There is no way to undo the deletion of a tool palette. It is
recommended that you first export the tool palette before making any
deletions. Use the Export option in the Customize dialog box.

Command entry: TOOLPALETTES

Toolbar: Standard  
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To change the position of a tool palette

1 Right-click the tab that represents the tool palette you want to move in
the Tool Palettes Window. Click Move Up or Move Down.

2 Repeat step 1 until the tool palette has been moved to the desired location.

NOTE You can also change the order of a tool palette by right-clicking on
the title bar of a tool palette, and then clicking Customize Palettes.

Command entry: TOOLPALETTES

Toolbar: Standard  

To add text to a tool palette

1 Right-click a blank area inside the Tool Palettes window. Click Add Text.

2 In the text box, add the text you want to display in the window.

3 If necessary, drag the text to the appropriate location in the window.

Command entry: TOOLPALETTES

Toolbar: Standard  

To add a separator line to a tool palette

1 Right-click a blank area inside the Tool Palettes window. Click Add
Separator.

2 If necessary, drag the separator to the appropriate location in the window.

Command entry: TOOLPALETTES

Toolbar: Standard  

To sort items in a tool palette

■ Right-click a blank area inside the Tool Palettes window. Click Sort By ➤ 

Name or Sort By  ➤  Type.

NOTE Items are sorted in order, by text, separator, and tool.

Customize Tool Palettes | 79



Command entry: TOOLPALETTES

Toolbar: Standard  

Quick Reference

Commands

CUSTOMIZE

Customizes tool palettes and tool palette groups.

TOOLPALETTES

Opens the Tool Palettes window.

TOOLPALETTESCLOSE

Closes the Tool Palettes window.

System Variables

PALETTEOPAQUE

Controls whether palettes can be made transparent.

TPSTATE

Indicates whether the Tool Palettes window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Organize Tool Palettes
You can organize tool palettes into groups and specify which group of tool
palettes is displayed.

For example, if you have several tool palettes that contain hatch patterns, you
can use the CUSTOMIZE command to create a new palette group called Hatch
Patterns. You can then add all your tool palettes that contain hatch patterns
to the Hatch Pattern group.
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When you set the Hatch Pattern group as the current group, only those tool
palettes you've added to the group are displayed.

To create a tool palette group

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, under Palette Groups, right-click on the
lower, blank area. Click New Group.

If there are no groups listed in the Palette Groups area, you can create a
group by dragging a tool palette from the Tool Palettes area into the
Palette Groups area.

3 Enter a name for the tool palette group.

4 Click Close.

Command entry: CUSTOMIZE

To add a tool palette to a tool palette group

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, drag a tool palette from the Tool Palettes
area into a group in the Palette Groups area.

3 Click Close.

Command entry: CUSTOMIZE

To remove a tool palette from a tool palette group

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, under Palette Groups, right-click the name
of the tool palette you want to remove. Click Remove.

You can also drag the tool palette into the Tool Palettes area to remove
it from a group.

3 Click Close.
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Command entry: CUSTOMIZE

To display a tool palette group

1 Right-click on the title bar of a tool palette.

2 Click the name of the tool palette group that you want to display.

Command entry: CUSTOMIZE, TPNAVIGATE

To delete a tool palette group

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, under Palette Groups, right-click the tool
palette group you want to delete. Click Delete.

NOTE You cannot delete a tool palette group if it is set as the current group.
To delete a group that is set as the current group, you must first set another
group as the current group.

3 Click Close.

Command entry: CUSTOMIZE

To delete all tool palette groups

1 Right-click on the title bar of a tool palette. Click All Palettes.

NOTE You must display all tool palettes so that no tool palette group is set
as the current group.

2 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

3 In the Customize dialog box, under Palette Groups, right-click a tool
palette group. Click Delete.

4 Repeat step 3 until all tool palette groups are deleted.

5 Click Close.

Command entry: CUSTOMIZE
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To rename a tool palette group

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, under Palette Groups, right-click the tool
palette group you want to rename. Click Rename.

3 Enter a new name for the tool palette group.

4 Click Close.

Command entry: CUSTOMIZE

To rearrange tool palette groups

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, under Palette Groups, click a tool palette
group and drag it into the new position.

Any other tool palette groups contained in the group you move will also
be moved.

3 Click Close.

NOTE You cannot drag a tool palette group into a group that is contained
by it.

Command entry: CUSTOMIZE

To create a tool palette group within another one

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, under Palette Groups, right-click the tool
palette group to which you want to add the new group. Click New Group.

3 Enter a name for the new tool palette group.

4 Click Close.

Command entry: CUSTOMIZE
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To copy and paste a tool palette from one group to another

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, under Palette Groups, select the tool palette
that you want to copy.

3 Press Ctrl while you drag the selected tool palette to another group.

When you release the mouse button, a copy of the tool palette is displayed
in the new location.

4 Click Close.

Command entry: CUSTOMIZE

To change the order of displayed tool palettes within a group

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, under Palette Groups, drag a tool palette
to the new location in its tool palette group.

3 Click Close.

Command entry: CUSTOMIZE

To change the order of displayed tool palettes when all of them are displayed

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, under Tool Palettes, drag a tool palette to
the location you want.

When all tool palettes are displayed, they are shown in the order they
appear in this list.

3 Click Close.

Command entry: CUSTOMIZE
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To display all tool palettes

■ Right-click on the title bar of a tool palette. Click All Palettes.

Quick Reference

Commands

CUSTOMIZE

Customizes tool palettes and tool palette groups.

TOOLPALETTES

Opens the Tool Palettes window.

TOOLPALETTESCLOSE

Closes the Tool Palettes window.

TPNAVIGATE

Displays a specified tool palette or palette group.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Save and Share Tool Palettes
You can save and share a tool palette or tool palette group by exporting it or
importing it as a file.

You can save and share a tool palette by exporting it or importing it as a tool
palette file. Tool palette files have an .xtp file extension.

Similarly, you can save and share a tool palette group by exporting it or
importing it as a palette group file. Tool palette files have an .xpg file extension.
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In some cases, when you export a customized tool palette, an image folder
with the same name as the exported tool palette is automatically created in
the same location as the XTP file. This image folder contains the icon images
used on the exported tool palette. The folder is created when you export a
tool palette that contains any of the following items:

■ User-created content tools

■ Command tools that contain user-specified (custom) tool palette icons
(images)

When you import a customized tool palette, this image folder must be in the
same location as the imported XTP file in order for the icons to appear on the
tool palette.

Tool palettes can be used only in the version of AutoCAD in which they were
created. For example, you cannot use a tool palette that was created in
AutoCAD 2010 in AutoCAD 2005.

The default path for tool palette files is set on the Files tab of the Options
dialog box under Tool Palettes File Locations.

Tool palette groups are saved in profiles.

If you send tool palettes to someone who uses AutoCAD LT, note that some
tools created in AutoCAD do not behave the same way or work in AutoCAD
LT. Note the following limitations:

■ The color property of tools that use a color other than an AutoCAD Color
Index (ACI) color convert to ByLayer in AutoCAD LT.

■ Gradient fill tools switch to hatch tools in AutoCAD LT.

■ Raster image tools do not work in AutoCAD LT.

NOTE If a tool palette file is set with a read-only attribute, a lock icon is displayed
in a lower corner of the tool palette. This indicates that you cannot modify the
tool palette beyond changing its display settings and rearranging the icons.

See also:

■ Save and Restore Interface Settings (Profiles) on page 155
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To share a tool palette

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, under Palettes, right-click a tool palette.
On the shortcut menu, click Export.

3 In the Export Palette dialog box, enter a file name and click Save.

4 Click Close.

Command entry: CUSTOMIZE

To share a tool palette group

1 Click Manage tab  ➤  Customization panel  ➤  Tool Palettes. 

2 In the Customize dialog box, under Palette Groups, right-click a tool
palette group. Click Export.

3 In the Export Group dialog box, enter a file name and click Save.

4 Click Close.

Command entry: CUSTOMIZE

Quick Reference

Commands

CUSTOMIZE

Customizes tool palettes and tool palette groups.

TOOLPALETTES

Opens the Tool Palettes window.

TOOLPALETTESCLOSE

Closes the Tool Palettes window.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

DesignCenter
With DesignCenter, you can organize access to blocks, hatches, xrefs, and
other drawing content. You can drag content from any source drawing to
your current drawing. You can drag drawings, blocks, and hatches to a tool
palette. Source drawings can be on your computer, on a network location, or
on a website. In addition, if you have multiple drawings open, you can use
DesignCenter to streamline your drawing process by copying and pasting
other content, such as layer definitions, layouts, and text styles between
drawings.

Overview of DesignCenter
With DesignCenter, you can

■ Browse for drawing content such as drawings or symbol libraries on your
computer, on a networked drive, and on a web page

■ View definition tables for named objects such as blocks and layers in any
drawing file and then insert, attach, or copy and paste the definitions into
the current drawing

■ Update (redefine) a block definition

■ Create shortcuts to drawings, folders, and Internet locations that you access
frequently

■ Add content such as xrefs, blocks, and hatches to a drawing

■ Open drawing files in a new window

■ Drag drawings, blocks, and hatches to a tool palette for convenient access
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Quick Reference

Commands

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.

ADCNAVIGATE

Loads a specified DesignCenter drawing file, folder, or network path.

System Variables

ADCSTATE

Indicates whether the DesignCenter window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Understand the DesignCenter Window
You can control the size, location, and appearance of DesignCenter.

The Organization of the DesignCenter Window

The DesignCenter window is divided into the tree view on the left side and
the content area on the right side. Use the tree view to browse sources of
content and to display content in the content area. Use the content area to
add items to a drawing or to a tool palette.

Undocked, the DesignCenter window is displayed as shown.

Below the content area, you can also display a preview or a description of a
selected drawing, block, hatch pattern, or xref. A toolbar at the top of the
window provides several options and operations.
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Control the Size, Location, and Appearance of DesignCenter

You can control the size, location, and appearance of DesignCenter. Many of
these options can be set by right-clicking and selecting an option on the
shortcut menu.

■ Resize DesignCenter by dragging the bar between the content area and the
tree view or by dragging an edge of the window.

■ Dock DesignCenter by dragging it over the right or left docking region of
the application window until it snaps into the docked position. You can
also dock the DesignCenter window by double-clicking its title bar.

■ Undock DesignCenter by dragging the area above the toolbar away from
the docking region. Pressing Ctrl while dragging prevents docking.

■ Anchor DesignCenter by choosing Anchor Right or Anchor Left from the
shortcut menu. An anchored DesignCenter window rolls open and closed
as the cursor moves across it. When an anchored DesignCenter window
is open, its content overlaps the drawing area. It cannot be set to stay open.

■ When DesignCenter is floating, use Auto-hide to set it to roll open and
closed as the cursor moves across it.

The DesignCenter Toolbar

The DesignCenter toolbar controls navigation and display of information in
the tree view and the content area. For information about these buttons, see
the ADCENTER command. The same navigation and display options are
available on the shortcut menu. Right-click in the DesignCenter content area
to display the menu.

To change the DesignCenter rollover behavior

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 Right-click the DesignCenter title bar. Click Auto-hide.

When the DesignCenter rollover option is turned on, the DesignCenter
tree view and content area disappear when you move your cursor off the
DesignCenter window, leaving only the title bar. When you move your
cursor over the title bar, the DesignCenter window is restored.

Command entry: ADCENTER
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Toolbar: Standard  

To prevent DesignCenter from docking

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 On the DesignCenter title bar, click Propert. Press Ctrl as you move your
mouse.

Command entry: ADCENTER

Toolbar: Standard  

To display and hide the DesignCenter tree view

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 On the DesignCenter toolbar, click Tree View Toggle.

Command entry: ADCENTER

Toolbar: Standard  

Quick Reference

Commands

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.

ADCNAVIGATE

Loads a specified DesignCenter drawing file, folder, or network path.
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System Variables

ADCSTATE

Indicates whether the DesignCenter window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Access Content with DesignCenter
The tree view in the left portion of the DesignCenter window and the four
DesignCenter tabs help you find and load content into the content area.

Folders Tab

The Folders tab displays a hierarchy of navigational icons, including

■ Networks and computers

■ Web addresses (URLs)

■ Computer drives

■ Folders

■ Drawings and related support files

■ Xrefs, layouts, hatch styles, and named objects, including blocks, layers,
linetypes, text styles, dimension styles, table styles, multileader styles, and
plot styles within a drawing

Click an item in the tree view to display its contents in the content area. Click
the plus (+) or minus (-) sign to display and hide additional levels in the
hierarchy. You can also double-click an item to display deeper levels.
Right-clicking in the tree view displays a shortcut menu with several related
options.
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Open Drawings, History, and DC Online Tabs

The Open Drawings, History, and DC Online tabs provide alternate methods
of locating content.

■ Open Drawings. Displays a list of the drawings that are currently open.
Click a drawing file and then click one of the definition tables from the
list to load the content into the content area.

■ History. Displays a list of files opened previously with DesignCenter.
Double-click a drawing file from the list to navigate to the drawing file in
the tree view of the Folders tab and to load the content into the content
area.

■ DC Online. Provides content from the DesignCenter Online web page
including blocks, symbol libraries, manufacturer's content, and online
catalogs.

NOTE The DesignCenter Online (DC Online tab) is disabled by default. You can
enable it from the CAD Manager Control utility on page 101.

Bookmark Frequently Used Content

DesignCenter provides a solution to finding content that you need to access
quickly on a regular basis. Both the tree view and the content area include
options that activate a folder called Favorites. The Favorites folder can contain
shortcuts to content on local or network drives as well as in Internet locations.

When you select a drawing, folder, or another type of content and choose
Add to Favorites, a shortcut to that item is added to the Favorites folder. The
original file or folder doesn't actually move; in fact, all the shortcuts you create
are stored in the Favorites folder. The shortcuts saved in the Favorites folder can
be moved, copied, or deleted using Windows® Explorer.

To change the source of the content displayed in DesignCenter

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 On the DesignCenter window, click one of the following tabs:

■ Folders. Lists your local and network drives.

■ Open Drawings. Lists the drawings that are currently open.

■ History. Lists the last 20 locations accessed through DesignCenter.
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■ DC Online. Displays online content from the Web.

NOTE The DesignCenter Online (DC Online tab) is disabled by default. You
can enable it from the CAD Manager Control utility on page 101.

Command entry: ADCENTER

Toolbar: Standard  

To change the folder of the Home button in DesignCenter

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 In the DesignCenter tree view, navigate to the folder that you want to
set as home.

3 Right-click on the folder. Click Set as Home.

When you click the Home button, DesignCenter will automatically load this
folder.

Command entry: ADCENTER

Toolbar: Standard  

To add items to the Favorites folder in DesignCenter

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 Right-click the item in the DesignCenter tree view or content area. Click
Add to Favorites.

Toolbar: Standard  
Command entry: ADCENTER
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To display the contents of the Favorites folder in DesignCenter

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 In DesignCenter, click the Favorites button.

When you are working in the tree view, you can use the Folders tab to
navigate to the Favorites folder.

Command entry: ADCENTER

Toolbar: Standard  

To organize your DesignCenter Favorites folder

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 In DesignCenter, click the Favorites button.

3 Right-click the background in the content area. Click Organize Favorites.

Your Autodesk Favorites folder is opened in a window.

Toolbar: Standard  
Command entry: ADCENTER

Quick Reference

Commands

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.

ADCNAVIGATE

Loads a specified DesignCenter drawing file, folder, or network path.
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System Variables

ADCSTATE

Indicates whether the DesignCenter window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Add Content with DesignCenter
The right portion of the DesignCenter window operates on the content
displayed.

Double-clicking an item in the content area displays successive levels of detail.
For example, double-clicking a drawing image displays several icons, including
an icon for blocks. Double-clicking the Blocks icon displays images of each
block in the drawing.

Add Content to a Drawing

You can add content from the content area into your current drawing using
several methods:

■ Drag an item to the graphics area of a drawing to add it using default
settings, if any.

■ Right-click an item in the content area to display a shortcut menu with
several options.

■ Double-click a block to display the Insert dialog box; double-click a hatch
to display the Boundary Hatch and Fill dialog box.

You can preview graphical content such as a drawing, xref, or block in the
content area, and you can display a text description if available.

Update Block Definitions with DesignCenter

Unlike xrefs, when the source file of a block definition is changed, block
definitions in the drawings that contain that block are not automatically
updated. With DesignCenter, you decide whether a block definition should
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be updated in the current drawing. The source file of a block definition can
be a drawing file or a nested block in a symbol library drawing.

From the shortcut menu displayed when you right-click a block or drawing
file in the content area, click Redefine Only or Insert and Redefine to update
the selected block.

Open Drawings with DesignCenter

With DesignCenter, you can open a drawing from the content area using the
shortcut menu, pressing Ctrl while dragging a drawing, or dragging a drawing
icon to any location outside the graphics area of a drawing area. The drawing
name is added to the DesignCenter history list for quick access in future
sessions.

Add Items from DesignCenter to a Tool Palette

You can add drawings, blocks, and hatches from DesignCenter to the current
tool palette.

■ From the DesignCenter content area, you can drag one or more items to
the current tool palette.

■ From the DesignCenter tree view, you can right-click and, from the shortcut
menu, create a new tool palette from the current folder, drawing file, or
block icon.

When you add drawings to a tool palette, they are inserted as blocks when
you drag them into the current drawing.

NOTE You can select multiple blocks or hatches from the content area to add
them to a tool palette.

To create a tool palette containing DesignCenter content

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 Do one of the following:

■ Right-click an item in the DesignCenter tree view. Click Create Tool
Palette. The new tool palette contains the drawings, blocks, or hatches
from the item you selected.
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■ Right-click the background in the DesignCenter content area. Click
Create Tool Palette. The new tool palette contains the drawings, blocks,
or hatches from the DesignCenter content area.

■ Right-click a drawing in the DesignCenter tree view or content area.
Click Create Tool Palette of Blocks. The new tool palette contains the
blocks from the drawing you selected.

You can drag additional drawings, blocks, or hatches from the
DesignCenter content area to the tool palette.

Command entry: ADCENTER

Toolbar: Standard  

To load the content area from the DesignCenter Search dialog box

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 In DesignCenter, use one of the following methods:

■ Drag the item from the search results list into the content area.

■ Double-click the item in the search results list.

■ Right-click the item in the search results list. Click Load into Content
Area.

3 In the DesignCenter content area, double-click the Blocks icon.

Command entry: ADCENTER

Toolbar: Standard  

To load the content area of DesignCenter with a symbol library

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 On the DesignCenter toolbar, click Home.
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3 In the content area, double-click the symbol library drawing that you
want to load into the DesignCenter and then double-click the Blocks
icon.

The symbol library you selected is loaded into the DesignCenter content
area.

NOTE You can set your home folder to any folder that contains symbol library
drawings. If your home folder is set to a different path, navigate to a folder that
contains symbol library drawings and right-click on the folder. Click Set as Home.

Command entry: ADCENTER

Toolbar: Standard  

To load the content area of DesignCenter with hatch patterns

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 On the DesignCenter toolbar, click Search.

3 In the Search dialog box, click the Look For box. Click Hatch Pattern
Files.

4 On the Hatch Pattern Files tab, in the Search for the Name box, enter *.

5 Click Search Now.

6 Double-click one of the hatch pattern files that was found.

The hatch pattern file you selected is loaded into DesignCenter.

Toolbar: Standard  
Command entry: ADCENTER

To open a drawing from DesignCenter

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 
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2 In DesignCenter, do one of the following:

■ Right-click the drawing icon in the DesignCenter content area. Click
Open in Application Window.

■ Press Ctrl and drag the drawing icon from the DesignCenter content
area to the drawing area.

■ Drag the drawing icon from the DesignCenter content area to a
location anywhere outside the drawing area of the application window.
(If you drag the drawing icon into the drawing area, a block is created
in the current drawing.)

Command entry: ADCENTER

Toolbar: Standard  

To update a block definition with DesignCenter

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 Right-click a block in the DesignCenter content area. Click Redefine Only
or Insert and Redefine.

NOTE If the source of the block that you want to update is an entire drawing
file rather than a block definition within a drawing file, right-click the drawing's
icon in the DesignCenter content area. Click Insert as Block.

Command entry: ADCENTER

Toolbar: Standard  

Quick Reference

Commands

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.

100 | Chapter 3   Other Tool Locations



ADCNAVIGATE

Loads a specified DesignCenter drawing file, folder, or network path.

System Variables

ADCSTATE

Indicates whether the DesignCenter window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Retrieve Content from the Web with DesignCenter Online
DesignCenter Online provides access to pre-drawn content such as blocks,
symbol libraries, manufacturers' content, and online catalogs.

NOTE The DesignCenter Online (DC Online tab) is disabled by default. You can
enable it from the CAD Manager Control utility on page 101.

Overview of DesignCenter Online
DesignCenter Online provides access to pre-drawn content such as blocks,
symbol libraries, manufacturers' content, and online catalogs. This content
can be used in common design applications to assist you in creating your
drawings.

To access DesignCenter Online, click the DC Online tab in DesignCenter.
Once the DesignCenter Online window is open, you can browse, search, and
download content to use in your drawing.
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NOTE The DesignCenter Online (DC Online tab) is disabled by default. You can
enable it from the CAD Manager Control utility on page 101.

In the DesignCenter Online window, two panes are displayed—a right pane
and a left pane. The right pane is called the content area. The content area
displays the items or folders that you selected in the left pane. The left pane
can display one of the following four views:

■ Category Listing. Displays folders containing libraries of standard parts,
manufacturer-specific content, and content aggregator websites.

■ Search. Searches for online content. You can query items with Boolean
and multiple-word search strings.

■ Settings. Controls how many categories and items are displayed on each
page in the content area as a result of a search or folder navigation.

■ Collections. Specifies the discipline-specific content types that are displayed
in DesignCenter Online.

You choose the view by clicking the heading at the top of the left pane.

Once you select a folder in the left pane, all of its content is loaded into the
content area. You can select an item in the content area to load it into the
preview area. Items can be downloaded by dragging them from the preview
area into your drawing or tool palette, or by saving the items to your computer.
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NOTE If the DC Online tab is not available in DesignCenter and you want to access
DesignCenter Online, see your network or CAD administrator.

DesignCenter Online Privacy

DesignCenter Online is an interactive feature that must be connected to the
Internet to deliver content and information. Each time DesignCenter Online
is connected, it sends information to Autodesk so that the correct information
can be returned. All information is sent anonymously to maintain your privacy.

The following information is sent to Autodesk:

■ Product Name. The name of the product in which you are using
DesignCenter Online

■ Product Release Number. The version of the product

■ Product Language. The language version of your product

■ Random Number Identifier. DesignCenter Online assigns a random number
identifier to each person who uses the feature. This identifier is used to
retain your Collections and your Settings views each time DesignCenter
Online is used.

Autodesk compiles statistics using the information sent from DesignCenter
Online to monitor how it is being used and how it can be improved. Autodesk
will maintain information provided by or collected from you in accordance
with Autodesk's published privacy policy, which is available on
http://www.autodesk.com/privacy.

Turn the DC Online Tab On or Off

The CAD Manager Control utility turns the DC Online tab in DesignCenter
on and off. Information about how to use the utility is available after you
install the utility from the Installation Wizard by running the utility and
clicking Help in the CAD Manager Control Utility window.

To install the CAD Manager Control utility

1 Insert the product DVD, or the first CD, into your computer's drive.

2 In the Installation Wizard, click Install Tools And Utilities.

3 On the Welcome to the Installation wizard page, click Next.

4 Choose Autodesk CAD Manager Tools 4.0 on the Select the Products to
Install page. Click Next.
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5 Review the Autodesk software license agreement for your country or
region. You must accept this agreement to procede with the installation.
Choose your country or region, click I Accept, and then click Next.

NOTE If you do not agree to the terms of the license and wish to terminate
the installation, click Cancel.

6 On the Review - Configure - Install page, click Install if you want to accept
the default install location.

If you want the utility installed in a different installation path, click
Configure, set the path and then click Configuration Complete and then
Install.

7 Click Finish when the Installation Complete page is displayed.

See also:

■ Use Autodesk Seek to Add and Share Drawings

Quick Reference

Commands

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Understand DesignCenter Online Content Types
With DesignCenter Online, content is categorized into folders.
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In the DesignCenter Online folders, you can retrieve discipline-specific content.
The content that you can retrieve includes the following:

■ Standard Parts. Generic standard parts that are commonly used in design.
These parts include blocks for architectural, mechanical, and GIS
applications.

■ Manufacturers. Blocks and 3D models that can be located and downloaded
by clicking a link to a manufacturer's website.

■ Aggregators. Lists of libraries from commercial catalog providers can be
searched for parts and blocks.

You use the Collections view to select the categories of online content that
you want to display in the Category Listing view.

NOTE The DesignCenter Online (DC Online tab) is disabled by default. You can
enable it from the CAD Manager Control utility on page 101.

To view online content folders in the Category Listing view

■ In DesignCenter Online, at the top of the left pane, click the heading, and
then click Category Listing.

The category folders are displayed in the left pane of the window.
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Quick Reference

Commands

No entries

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Retrieve Content from the Web
You can download content from the Web and use it in your drawings.

Browse for Content

When you use the Category Listing view, you can click the folders in the left
pane to view their contents. These folders may contain other folders.

When you click a folder or an item inside a folder, the contents are displayed
in the Content area. When you click a block, graphical and descriptive
information about the block is displayed in the preview area.

Search for Content

When you search for online content with DesignCenter Online, you can query
items with Boolean and multiple-word search strings in the Search view. You

106 | Chapter 3   Other Tool Locations



can access Search by clicking the magnifying glass or by choosing Search from
the drop-down heading at the top of the left pane.

Control the Number of Categories and Items in a Page

By using the Settings view, you can control how many categories or items are
displayed on each page in the content area as a result of a search or folder
navigation.

Collections

You can choose the type of content to navigate and search. In the Collections
pane, you can specify the content types that are displayed each time you open
DesignCenter Online. For example, if you use architectural blocks in your
drawings, you select collections that contain architectural items. Once you
make your selection, categories that you specified are displayed.

Download Content

To download content from the Web, locate the folder containing the content
that you want to use. Then, click a thumbnail image of the content in the
content area. The content is displayed in the preview area along with
information about the content. You can drag the block directly from the
preview area into a drawing or tool palette, or you can save it to your computer
to be used later.

See also:

■ Use Autodesk Seek to Add and Share Drawings

To search for content in DesignCenter Online

1 In DesignCenter Online, at the top of the left pane, click the heading,
and then click Search.

2 In the Search view, enter a single word or multiple-word strings.

NOTE The Need Help link provides more information about searches,
including examples of Boolean searches.
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To specify content collections

1 In DesignCenter Online, at the top of the left pane, click the heading,
and then click Collections.

2 In the Collections view, click the check boxes of the collections that you
want to use.

3 Click Update Collections.

The categories that you have selected are displayed in the left pane.

To download content to your computer

1 In DesignCenter Online, at the top of the left pane, click the heading,
and then click Category Listing.

2 In the Category folders, click a content item.

3 In the Preview area, under the image of the content item, click Save This
Symbol As.

4 In the Save As dialog box, specify the location on your computer and the
file name.

5 Click Save.

The content is downloaded to your computer.

To download content to your drawing

1 In DesignCenter Online, at the top of the left pane, click the heading,
and then click Category Listing.

2 In the Category folders, click a content item to display it in the Preview
area.

3 Drag the image from the Preview area into your drawing or tool palette.

Quick Reference

Commands

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Retrieve Content from the Web with DesignCenter Online | 109



110



Customize the Drawing
Environment

You can change many window and drawing environment settings in the Options dialog box.
For example, you can change how often a drawing is automatically saved to a temporary file,
and you can link the program to folders containing files you use frequently. You can create
workspaces to set up a drawing environment that is specific to your drawing needs. Experiment
with different settings until you create the drawing environment that best fits your needs.

Set Interface Options
You can adjust the application interface and drawing area to match the way
you work.

Set Up the Drawing Area
You can adjust the color and display schemes used in the application and
drawing windows, and control the behavior of general features such as zoom
transitions.

Many of the settings are available from shortcut menus and the Options dialog
box. Some workspace elements, such as the presence and location of toolbars
and palettes, can be specified and saved using the Customize User Interface
dialog box.

Some settings affect how you work in the drawing area:

■ Background Colors (Options dialog box, Display tab). You specify the
background colors used in the layout and Model tabs and the color used for
prompts and crosshairs.

4
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■ Color Scheme (Options dialog box, Display tab, Colors). You specify a dark
or light color scheme for the overall user interface. The settings affect the
window frame background, status bar, title bar, menu browser frame,
toolbars, and palettes.

■ Background Colors (Options dialog box, Display tab, Colors). You specify
the background colors used in model space, layouts, and the block editor.
Background colors on the Model tab change to indicate whether you are
working in a 2D design context, 3D modeling (parallel projection), or 3D
modeling (perspective projection).

■ UCS Icon and Crosshairs Cursor (Options dialog box, 3D Modeling tab).
You specify that the 3D display options and labels for the UCS icon can
be set in the 3D Modeling tab of the Options dialog box.

■ Color Assignments for X, Y, and Z (Options dialog box, Display tab, Colors).
In 3D views, any interface elements that are associated with the UCS X, Y,
and Z axis use special color assignments. The X axis is colored or tinted
red, the Y axis is green, and the Z axis is blue. These tints can be turned on
or off in the Drawing Window Colors dialog box.

■ Clean Screen. You can expand the drawing display area to display only
the menu bar, status bar, and command window with the clean screen
button on the application status bar. Click the button again to restore the
previous setup.

■ View Transitions. You can control whether view transitions are smooth or
instantaneous when you pan, zoom, or change from one view to another
(VTOPTIONS command). The default is a smooth transition.

Tooltips

Several types of tooltips provide pop-up information for interaction with
toolbars, object snaps, and drafting operations.

You can view tooltips in toolbars, the menu browser, the ribbon, and dialog
boxes. Initially, a basic tooltip is displayed. If you continue to hover, the
tooltip expands to display additional information. You can customize the
display and content of a tooltip.

See also:

■ Display Tab (Options Dialog Box) in the Command Reference

■ User Interface Customization in the Customization Guide
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■ Rollover Tooltips in the Customization Guide

■ Create Tooltips and Extended Help for Commands in the Customization
Guide

To set options

1 Click the Application button. At the bottom of the Application menu,
click Options.

2 In the Options dialog box, click a tab.

3 Set options as desired.

4 Do either or both of the following:

■ Click Apply to record the current options settings in the system
registry.

■ Click OK to record the current options settings in the system registry
and close the Options dialog box.

Command entry: OPTIONS

To customize the colors of the application window elements

1 Click the Application button. At the bottom of the Application menu,
click Options.

2 In the Options dialog box, Display tab, click Colors.

3 In the Drawing Window Colors dialog box, select context and then the
interface element you want to change.

4 Select the color you want to use from the Color list.

To specify a custom color, select Select Color from the Color list.

5 If you want to revert to the default colors, click Restore Current Element,
Restore Current Context, or Restore All Contexts.

6 Click Apply and Close to record the current option settings in the system
registry and close the dialog box.

7 Click OK to close the Options dialog box.

Command entry: OPTIONS
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To change the appearance of view transitions

1 At the Command prompt, enter vtoptions.

2 In the View Transitions dialog box, check one or more of the following
options:

■ Enable Animation for Pan and Zoom. Makes a smooth view transition
during panning and zooming.

■ Enable Animation When View Rotates. Makes a smooth view transition
when the view angle is changed.

■ Enable Animation During Scripts. Makes a smooth view transition
while a script is running.

3 Set the transition speed by moving the slider.

4 To preserve performance, set the minimum frames per second for showing
smooth view transitions. When a smooth view transition cannot maintain
this speed, an instant transition is used.

5 Click OK.

Command entry: VTOPTIONS

To display hidden message dialogs

1 Click the Application button. At the bottom of the Application menu,
click Options.

2 In the Options dialog box, System tab, under General Options, click
Hidden Messages Settings button.

3 The Hidden Message Settings dialog box is displayed.

4 Check the corresponding dialog name from the tree directory.

5 Click OK.

To turn tooltips on or off

1 Click Tools menu  ➤ Options.

2 In the Options dialog box, Display tab, under Window Elements, click
Show Tooltips.

3 Click OK.
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Quick Reference

Commands

3DCONFIG

Sets options that affect 3D display performance.

CLEANSCREENON

Clears the screen of toolbars and dockable windows (excluding the command
line).

CLEANSCREENOFF

Restores display of toolbars and dockable windows (excluding the command
line).

OPTIONS

Customizes the program settings.

VIEWRES

Sets the resolution for objects in the current viewport.

VTOPTIONS

Displays a change in view as a smooth transition.

System Variables

CALCINPUT

Controls whether mathematical expressions and global constants are
evaluated in text and numeric entry boxes of windows and dialog boxes.

CLEANSCREENSTATE

Indicates whether the clean screen state is on or off.

CURSORSIZE

Determines the size of the crosshairs as a percentage of the screen size.

DRAGMODE

Controls the way dragged objects are displayed.

EXTNAMES

Sets the parameters for named object names (such as linetypes and layers)
stored in definition tables.
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GRIPCOLOR

Controls the color of unselected grips.

GRIPHOT

Controls the color of selected grips.

GRIPS

Controls the use of selection set grips for the Stretch, Move, Rotate, Scale,
and Mirror Grip modes.

INSUNITS

Specifies a drawing-units value for automatic scaling of blocks, images, or
xrefs when inserted or attached to a drawing.

INSUNITSDEFSOURCE

Sets source content units value when INSUNITS is set to 0.

INSUNITSDEFTARGET

Sets target drawing units value when INSUNITS is set to 0.

INTELLIGENTUPDATE

Controls the graphics refresh rate.

ISAVEBAK

Improves the speed of incremental saves, especially for large drawings.

ISAVEPERCENT

Determines the amount of wasted space tolerated in a drawing file.

LAYOUTREGENCTL

Specifies how the display list is updated in the Model tab and layout tabs.

LOCALE

Displays a code that indicates the current locale.

LOCALROOTPREFIX

Stores the full path to the root folder where local customizable files were
installed.

LOCKUI

Locks the position and size of toolbars and dockable windows such as
DesignCenter and the Properties palette.
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LOGFILEMODE

Specifies whether the contents of the text window are written to a log file.

LOGFILENAME

Specifies the path and name of the text window log file for the current
drawing.

LOGFILEPATH

Specifies the path for the text window log files for all drawings in a session.

MTEXTED

Sets the application for editing multiline text objects.

OLEQUALITY

Sets the default plot quality for OLE objects.

OLESTARTUP

Controls whether the source application of an embedded OLE object loads
when plotting.

OSNAPCOORD

Controls whether coordinates entered on the command line will override
running object snaps.

PAPERUPDATE

Controls the display of a warning dialog when attempting to print a layout
with a paper size different from the paper size specified by the default for
the plotter configuration file.

PALETTEOPAQUE

Controls the display of a warning dialog when attempting to print a layout
with a paper size different from the paper size specified by the default for
the plotter configuration file.

PICKADD

Controls whether subsequent selections replace the current selection set or
add to it.

PICKAUTO

Controls automatic windowing at the Select Objects prompt.
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PICKBOX

Sets the object selection target height, in pixels.

PICKDRAG

Controls the method of drawing a selection window.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

PICKSTYLE

Controls the use of group selection and associative hatch selection.

PSTYLEPOLICY

Controls the plot style mode, Color-Dependent or Named, that is used when
opening a drawing that was created in a release prior to AutoCAD 2000 or
when creating a new drawing from scratch without using a drawing template.

QTEXTMODE

Controls how text is displayed.

RASTERPREVIEW

Controls whether BMP preview images are saved with the drawing.

ROLLOVERTIPS

Controls the display of rollover tooltips in the application.

SAVEFILE

Stores the current automatic save file name.

SAVEFILEPATH

Specifies the path to the directory for all automatic save files for the current
session.

SAVETIME

Sets the automatic save interval, in minutes.

SPLINESEGS

Sets the number of line segments to be generated for each spline-fit polyline
generated by the Spline option of the PEDIT command.
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TDUSRTIMER

Stores the user-elapsed timer.

TOOLTIPMERGE

Combines drafting tooltips into a single tooltip.

TOOLTIPS

Controls the display of tooltips on the ribbon, toolbars, and other user
interface elements.

VISRETAIN

Controls the properties of xref-dependent layers.

VTDURATION

Sets the duration of a smooth view transition, in milliseconds.

VTENABLE

Controls when smooth view transitions are used.

VTFPS

Sets the minimum speed of a smooth view transition, in frames per second.

XLOADCTL

Turns xref demand-loading on and off, and controls whether it opens the
referenced drawing or a copy.

Utilities

No entries

Command Modifiers

No entries

Set Options for 3D Modeling with Perspective Projection
You can set specific display options when working with 3D models using
perspective projection.
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Using the Options dialog box, you can specify the following options when
your 3D model is set to use a perspective view:

■ Ground Plane (Options dialog box, Display tab, Colors). When perspective
projection is turned on, the XY plane of the UCS displays as a ground plane
with a gradient color. The ground plane displays a gradient from the ground
horizon to the ground origin.

■ Sky (Options dialog box, Display tab, Colors). The area not covered by the
ground plane is the sky, which displays a gradient color from the sky horizon
to the sky zenith.

■ Underground (Options dialog box, Display tab, Colors). If the ground
plane is viewed from below ground, the ground plane displays a gradient
from the earth horizon to the earth azimuth.

■ Ground Plane Grid (Options dialog box, Display tab, Colors). When
perspective projection is turned on, the grid displays as a ground plane grid.
Colors are set for major grid lines, minor grid lines, and axis lines.

Quick Reference

Commands

3DCONFIG

Sets options that affect 3D display performance.
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OPTIONS

Customizes the program settings.

VIEWRES

Sets the resolution for objects in the current viewport.

System Variables

APERTURE

Sets the display size for the object snap target box, in pixels.

CALCINPUT

Controls whether mathematical expressions and global constants are
evaluated in text and numeric entry boxes of windows and dialog boxes.

CLEANSCREENSTATE

Indicates whether the clean screen state is on or off.

CURSORSIZE

Determines the size of the crosshairs as a percentage of the screen size.

DCTCUST

Displays the path and file name of the current custom spelling dictionary.

DCTMAIN

Displays the three letter keyword for the current main spelling dictionary.

DEFPLSTYLE

Specifies the default plot style for new objects in a drawing when opening a
drawing that was created in a release prior to AutoCAD 2000, or when creating
a new drawing from scratch without using a drawing template.

DRAGMODE

Controls the way dragged objects are displayed.

EXTNAMES

Sets the parameters for named object names (such as linetypes and layers)
stored in definition tables.

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.
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GRIPBLOCK

Controls the display of grips in blocks.

GRIPCOLOR

Controls the color of unselected grips.

GRIPHOT

Controls the color of selected grips.

GRIPS

Controls the use of selection set grips for the Stretch, Move, Rotate, Scale,
and Mirror Grip modes.

INSUNITS

Specifies a drawing-units value for automatic scaling of blocks, images, or
xrefs when inserted or attached to a drawing.

INSUNITSDEFSOURCE

Sets source content units value when INSUNITS is set to 0.

INSUNITSDEFTARGET

Sets target drawing units value when INSUNITS is set to 0.

INTELLIGENTUPDATE

Controls the graphics refresh rate.

ISAVEBAK

Improves the speed of incremental saves, especially for large drawings.

ISAVEPERCENT

Determines the amount of wasted space tolerated in a drawing file.

LAYOUTREGENCTL

Specifies how the display list is updated in the Model tab and layout tabs.

LOCALE

Displays a code that indicates the current locale.

LOCALROOTPREFIX

Stores the full path to the root folder where local customizable files were
installed.
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LOCKUI

Locks the position and size of toolbars and dockable windows such as
DesignCenter and the Properties palette.

LOGFILEMODE

Specifies whether the contents of the text window are written to a log file.

LOGFILENAME

Specifies the path and name of the text window log file for the current
drawing.

LOGFILEPATH

Specifies the path for the text window log files for all drawings in a session.

MTEXTED

Sets the application for editing multiline text objects.

OLEQUALITY

Sets the default plot quality for OLE objects.

OLESTARTUP

Controls whether the source application of an embedded OLE object loads
when plotting.

OSNAPCOORD

Controls whether coordinates entered on the command line will override
running object snaps.

PAPERUPDATE

Controls the display of a warning dialog when attempting to print a layout
with a paper size different from the paper size specified by the default for
the plotter configuration file.

PALETTEOPAQUE

Controls whether palettes can be made transparent.

PICKADD

Controls whether subsequent selections replace the current selection set or
add to it.

PICKAUTO

Controls automatic windowing at the Select Objects prompt.
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PICKBOX

Sets the object selection target height, in pixels.

PICKDRAG

Controls the method of drawing a selection window.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

PICKSTYLE

Controls the use of group selection and associative hatch selection.

PSTYLEPOLICY

Controls the plot style mode, Color-Dependent or Named, that is used when
opening a drawing that was created in a release prior to AutoCAD 2000 or
when creating a new drawing from scratch without using a drawing template.

QTEXTMODE

Controls how text is displayed.

RASTERPREVIEW

Controls whether BMP preview images are saved with the drawing.

ROLLOVERTIPS

Controls the display of rollover tooltips in the application.

SAVEFILEPATH

Stores the current automatic save file name.

SAVEFILEPATH

Specifies the path to the directory for all automatic save files for the current
session.

SAVETIME

Sets the automatic save interval, in minutes.

SPLINESEGS

Sets the number of line segments to be generated for each spline-fit polyline
generated by the Spline option of the PEDIT command.
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TDUSRTIMER

Stores the user-elapsed timer.

TOOLTIPMERGE

Combines drafting tooltips into a single tooltip.

TOOLTIPS

Controls the display of tooltips on the ribbon, toolbars, and other user
interface elements.

VISRETAIN

Controls the properties of xref-dependent layers.

VTDURATION

Sets the duration of a smooth view transition, in milliseconds.

VTENABLE

Controls when smooth view transitions are used.

VTFPS

Sets the minimum speed of a smooth view transition, in frames per second.

XLOADCTL

Turns xref demand-loading on and off, and controls whether it opens the
referenced drawing or a copy.

Utilities

No entries

Command Modifiers

No entries

Switch Between Model Space and Layouts
You can control how you change between model space and one or more
layouts.

The classic interface provides a Model tab and one or more layout tabs. To
optimize space in the drawing area, you can turn off these tabs and use the
equivalent buttons on the status bar. The control to change between the two
interface designs is included as an item on the Model and layout tab shortcut
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menu, and on the shortcut menu of the Model/Layout button on the status
bar.

NOTE Access to all shortcut menu options is available from the tabs only.

To change the Model and layout tabs to status bar buttons

■ Right-click the Model tab or a layout tab. Click Hide Layout and Model
Tabs.

To turn on the Model and layout tabs

■ On the status bar, right-click the Model or layout button. Click Display
Layout and Model Tabs.

Quick Reference

Commands

DRAGMODE

Controls the way dragged objects are displayed.

OPTIONS

Customizes the program settings.

VIEWRES

Sets the resolution for objects in the current viewport.

System Variables

APERTURE

Sets the display size for the object snap target box, in pixels.

CALCINPUT

Controls whether mathematical expressions and global constants are
evaluated in text and numeric entry boxes of windows and dialog boxes.

CLEANSCREENSTATE

Indicates whether the clean screen state is on or off.

CURSORSIZE

Determines the size of the crosshairs as a percentage of the screen size.
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DCTCUST

Displays the path and file name of the current custom spelling dictionary.

DCTMAIN

Displays the three letter keyword for the current main spelling dictionary.

DEFPLSTYLE

Specifies the default plot style for new objects in a drawing when opening a
drawing that was created in a release prior to AutoCAD 2000, or when creating
a new drawing from scratch without using a drawing template.

DRAGMODE

Controls the way dragged objects are displayed.

EXTNAMES

Sets the parameters for named object names (such as linetypes and layers)
stored in definition tables.

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.

GRIPBLOCK

Controls the display of grips in blocks.

GRIPCOLOR

Controls the color of unselected grips.

GRIPHOT

Controls the color of selected grips.

GRIPS

Controls the use of selection set grips for the Stretch, Move, Rotate, Scale,
and Mirror Grip modes.

INSUNITS

Specifies a drawing-units value for automatic scaling of blocks, images, or
xrefs when inserted or attached to a drawing.

INSUNITSDEFSOURCE

Sets source content units value when INSUNITS is set to 0.
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INSUNITSDEFTARGET

Sets target drawing units value when INSUNITS is set to 0.

INTELLIGENTUPDATE

Controls the graphics refresh rate.

ISAVEBAK

Improves the speed of incremental saves, especially for large drawings.

ISAVEPERCENT

Determines the amount of wasted space tolerated in a drawing file.

LAYOUTREGENCTL

Specifies how the display list is updated in the Model tab and layout tabs.

LOCALE

Displays a code that indicates the current locale.

LOCALROOTPREFIX

Stores the full path to the root folder where local customizable files were
installed.

LOCKUI

Locks the position and size of toolbars and dockable windows such as
DesignCenter and the Properties palette.

LOGFILEMODE

Specifies whether the contents of the text window are written to a log file.

LOGFILENAME

Specifies the path and name of the text window log file for the current
drawing.

LOGFILEPATH

Specifies the path for the text window log files for all drawings in a session.

MTEXTED

Sets the application for editing multiline text objects.

OLEQUALITY

Sets the default plot quality for OLE objects.
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OLESTARTUP

Controls whether the source application of an embedded OLE object loads
when plotting.

OSNAPCOORD

Controls whether coordinates entered on the command line will override
running object snaps.

PAPERUPDATE

Controls the display of a warning dialog when attempting to print a layout
with a paper size different from the paper size specified by the default for
the plotter configuration file.

PALETTEOPAQUE

Controls whether palettes can be made transparent.

PICKADD

Controls whether subsequent selections replace the current selection set or
add to it.

PICKAUTO

Controls automatic windowing at the Select Objects prompt.

PICKBOX

Sets the object selection target height, in pixels.

PICKDRAG

Controls the method of drawing a selection window.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

PICKSTYLE

Controls the use of group selection and associative hatch selection.

PSTYLEPOLICY

Controls the plot style mode, Color-Dependent or Named, that is used when
opening a drawing that was created in a release prior to AutoCAD 2000 or
when creating a new drawing from scratch without using a drawing template.
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QTEXTMODE

Controls how text is displayed.

RASTERPREVIEW

Controls whether BMP preview images are saved with the drawing.

ROLLOVERTIPS

Controls the display of rollover tooltips in the application.

SAVEFILEPATH

Stores the current automatic save file name.

SAVEFILEPATH

Specifies the path to the directory for all automatic save files for the current
session.

SAVETIME

Sets the automatic save interval, in minutes.

SPLINESEGS

Sets the number of line segments to be generated for each spline-fit polyline
generated by the Spline option of the PEDIT command.

TDUSRTIMER

Stores the user-elapsed timer.

TOOLTIPMERGE

Combines drafting tooltips into a single tooltip.

TOOLTIPS

Controls the display of tooltips on the ribbon, toolbars, and other user
interface elements.

VISRETAIN

Controls the properties of xref-dependent layers.

VTDURATION

Sets the duration of a smooth view transition, in milliseconds.

VTENABLE

Controls when smooth view transitions are used.
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VTFPS

Sets the minimum speed of a smooth view transition, in frames per second.

XLOADCTL

Turns xref demand-loading on and off, and controls whether it opens the
referenced drawing or a copy.

Utilities

No entries

Command Modifiers

No entries

Specify Application Fonts
Change the fonts used in the application window and in the text window.

You can specify the font that is displayed in both the application and text
windows. To change the application font, use the Options dialog box, Display
tab.

NOTE This setting does not affect the text in your drawings.

To change the font displayed in the Command window

1 Click the Application button. At the bottom of the Application menu,
click Options.

2 In the Options dialog box, Display tab, under Window Elements, click
Fonts.

3 In the Command Line Window Font dialog box, select the appropriate
Font, Font Style, and Size.

An example of the current choices appears under Sample Command Line
Font.

4 Click Apply & Close to record the current option settings in the system
registry and close the dialog box.

5 In the Options dialog box, click OK.

Command entry: OPTIONS
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Quick Reference

Commands

OPTIONS

Customizes the program settings.

System Variables

APERTURE

Sets the display size for the object snap target box, in pixels.

CALCINPUT

Controls whether mathematical expressions and global constants are
evaluated in text and numeric entry boxes of windows and dialog boxes.

CLEANSCREENSTATE

Indicates whether the clean screen state is on or off.

CURSORSIZE

Determines the size of the crosshairs as a percentage of the screen size.

DCTCUST

Displays the path and file name of the current custom spelling dictionary.

DCTMAIN

Displays the three letter keyword for the current main spelling dictionary.

DEFPLSTYLE

Specifies the default plot style for new objects in a drawing when opening a
drawing that was created in a release prior to AutoCAD 2000, or when creating
a new drawing from scratch without using a drawing template.

DRAGMODE

Controls the way dragged objects are displayed.

EXTNAMES

Sets the parameters for named object names (such as linetypes and layers)
stored in definition tables.
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FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.

GRIPBLOCK

Controls the display of grips in blocks.

GRIPCOLOR

Controls the color of unselected grips.

GRIPHOT

Controls the color of selected grips.

GRIPS

Controls the use of selection set grips for the Stretch, Move, Rotate, Scale,
and Mirror Grip modes.

INSUNITS

Specifies a drawing-units value for automatic scaling of blocks, images, or
xrefs when inserted or attached to a drawing.

INSUNITSDEFSOURCE

Sets source content units value when INSUNITS is set to 0.

INSUNITSDEFTARGET

Sets target drawing units value when INSUNITS is set to 0.

INTELLIGENTUPDATE

Controls the graphics refresh rate.

ISAVEBAK

Improves the speed of incremental saves, especially for large drawings.

ISAVEPERCENT

Determines the amount of wasted space tolerated in a drawing file.

LAYOUTREGENCTL

Specifies how the display list is updated in the Model tab and layout tabs.

LOCALE

Displays a code that indicates the current locale.
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LOCALROOTPREFIX

Stores the full path to the root folder where local customizable files were
installed.

LOCKUI

Locks the position and size of toolbars and dockable windows such as
DesignCenter and the Properties palette.

LOGFILEMODE

Specifies whether the contents of the text window are written to a log file.

LOGFILENAME

Specifies the path and name of the text window log file for the current
drawing.

LOGFILEPATH

Specifies the path for the text window log files for all drawings in a session.

MTEXTED

Sets the application for editing multiline text objects.

OLEQUALITY

Sets the default plot quality for OLE objects.

OLESTARTUP

Controls whether the source application of an embedded OLE object loads
when plotting.

OSNAPCOORD

Controls whether coordinates entered on the command line will override
running object snaps.

PAPERUPDATE

Controls the display of a warning dialog when attempting to print a layout
with a paper size different from the paper size specified by the default for
the plotter configuration file.

PALETTEOPAQUE

Controls whether palettes can be made transparent.
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PICKADD

Controls whether subsequent selections replace the current selection set or
add to it.

PICKAUTO

Controls automatic windowing at the Select Objects prompt.

PICKBOX

Sets the object selection target height, in pixels.

PICKDRAG

Controls the method of drawing a selection window.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

PICKSTYLE

Controls the use of group selection and associative hatch selection.

PSTYLEPOLICY

Controls the plot style mode, Color-Dependent or Named, that is used when
opening a drawing that was created in a release prior to AutoCAD 2000 or
when creating a new drawing from scratch without using a drawing template.

QTEXTMODE

Controls how text is displayed.

RASTERPREVIEW

Controls whether BMP preview images are saved with the drawing.

ROLLOVERTIPS

Controls the display of rollover tooltips in the application.

SAVEFILEPATH

Stores the current automatic save file name.

SAVEFILEPATH

Specifies the path to the directory for all automatic save files for the current
session.
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SAVETIME

Sets the automatic save interval, in minutes.

SPLINESEGS

Sets the number of line segments to be generated for each spline-fit polyline
generated by the Spline option of the PEDIT command.

TDUSRTIMER

Stores the user-elapsed timer.

TOOLTIPMERGE

Combines drafting tooltips into a single tooltip.

TOOLTIPS

Controls the display of tooltips on the ribbon, toolbars, and other user
interface elements.

VISRETAIN

Controls the properties of xref-dependent layers.

VTDURATION

Sets the duration of a smooth view transition, in milliseconds.

VTENABLE

Controls when smooth view transitions are used.

VTFPS

Sets the minimum speed of a smooth view transition, in frames per second.

XLOADCTL

Turns xref demand-loading on and off, and controls whether it opens the
referenced drawing or a copy.
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Utilities

No entries

Command Modifiers

No entries

Specify the Behavior of Dockable Windows
Windows such as the Properties palette, tool palettes, and DesignCenter can
be docked, anchored, or floated.

Settings for these and other options are often changed on a shortcut menu,
available by right-clicking the title bar of the palette or window.

■ Resize. Drag an edge of the window to change its size. If the window has
panes, drag the bar between panes to resize the panes.

■ Allow Docking. Select this option if you want to dock or anchor a dockable
window. A docked window adheres to one side of the application window,
causing the drawing area to be resized.

■ Anchor. Attach, or anchor, a dockable window or palette to the left or right
side of the drawing area. An anchored window rolls open and closed as
the cursor moves across it. When an anchored window is open, its content
overlaps the drawing area. An anchored window cannot be set to stay
open. The Allow Docking option must be selected before you can anchor
a window.

■ Auto-hide. A floating window rolls open and closes as the cursor moves
across it. When this option is cleared, the window stays open continuously.
Docked windows with auto-hide show up as a bar inside the application.

■ Transparency. Sets the degree of transparency for the window and on
mouse over. The window becomes transparent so that it does not obscure
objects under it. The window becomes more opaque when it is moused
over. This option is not available for all windows.
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You can hide all the palettes at once with HIDEPALETTES and turn on all
hidden palettes with SHOWPALETTES.

NOTE If a palette has been turned back on manually and moved, it is not affected
by SHOWPALETTES.

To anchor a dockable window

1 At the top of the window or palette title bar, click the Propterties button.
Click Allow Docking.

2 Click the Properties button again. Click Anchor Right or Anchor Left.

To float an anchored window

Do one of the following:

■ At the top of the window or palette title bar, click the Properties button.
Clear Allow Docking.

■ When the anchored window is open, drag the window title bar away from
the anchor tab base.

■ Double-click the anchor tab.
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To dock a window or palette

1 At the top of the window or palette title bar, click the Properties button.
Click Allow Docking.

2 Click and drag the window or palette to a docking location on the right
or left side of the drawing area.

3 When the outline of the window is displayed in the docking area, release
the button.

NOTE To place a toolbar in a docking region without docking it, hold down
the Ctrl key as you drag.

To undock a window or palette

Use one of the following methods:

■ At the top of the window or palette title bar, click the Properties button.
Clear Allow Docking.

■ Double-click the double bars on the side or top of the window.

■ Position the cursor on the double bars at the top or side of the window,
hold down the left button on your pointing device, and drag the window
away from its docked location.

To turn Auto-hide on or off for a floating palette or window

■ At the top of the window or palette title bar, click the Auto-hide button.

If Auto-hide is selected, floating windows roll open and closed as the cursor
moves across them. When this option is cleared, the full window stays open
continuously.

NOTE This procedure applies to the Tool palette, DesignCenter, the Properties
palette, and several other palettes.

Quick Reference

Commands

DRAGMODE

Controls the way dragged objects are displayed.
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HIDEPALETTES

Hides currently displayed palettes (including the command line).

LOGFILEOFF

Closes the text window log file opened by LOGFILEON.

LOGFILEON

Writes the text window contents to a file.

OPTIONS

Customizes the program settings.

SHOWPALETTES

Restores the display of hidden palettes.

VIEWRES

Sets the resolution for objects in the current viewport.

VTOPTIONS

Displays a change in view as a smooth transition.

System Variables

APERTURE

Sets the display size for the object snap target box, in pixels.

CALCINPUT

Controls whether mathematical expressions and global constants are
evaluated in text and numeric entry boxes of windows and dialog boxes.

CLEANSCREENSTATE

Indicates whether the clean screen state is on or off.

CURSORSIZE

Determines the size of the crosshairs as a percentage of the screen size.

DCTCUST

Displays the path and file name of the current custom spelling dictionary.

DCTMAIN

Displays the three letter keyword for the current main spelling dictionary.
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DEFPLSTYLE

Specifies the default plot style for new objects in a drawing when opening a
drawing that was created in a release prior to AutoCAD 2000, or when creating
a new drawing from scratch without using a drawing template.

DRAGMODE

Controls the way dragged objects are displayed.

EXTNAMES

Sets the parameters for named object names (such as linetypes and layers)
stored in definition tables.

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.

GRIPBLOCK

Controls the display of grips in blocks.

GRIPCOLOR

Controls the color of unselected grips.

GRIPHOT

Controls the color of selected grips.

GRIPS

Controls the use of selection set grips for the Stretch, Move, Rotate, Scale,
and Mirror Grip modes.

INSUNITS

Specifies a drawing-units value for automatic scaling of blocks, images, or
xrefs when inserted or attached to a drawing.

INSUNITSDEFSOURCE

Sets source content units value when INSUNITS is set to 0.

INSUNITSDEFTARGET

Sets target drawing units value when INSUNITS is set to 0.

INTELLIGENTUPDATE

Controls the graphics refresh rate.
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ISAVEBAK

Improves the speed of incremental saves, especially for large drawings.

ISAVEPERCENT

Determines the amount of wasted space tolerated in a drawing file.

LAYOUTREGENCTL

Specifies how the display list is updated in the Model tab and layout tabs.

LOCALE

Displays a code that indicates the current locale.

LOCALROOTPREFIX

Stores the full path to the root folder where local customizable files were
installed.

LOCKUI

Locks the position and size of toolbars and dockable windows such as
DesignCenter and the Properties palette.

LOGFILEMODE

Specifies whether the contents of the text window are written to a log file.

LOGFILENAME

Specifies the path and name of the text window log file for the current
drawing.

LOGFILEPATH

Specifies the path for the text window log files for all drawings in a session.

MTEXTED

Sets the application for editing multiline text objects.

OLEQUALITY

Sets the default plot quality for OLE objects.

OLESTARTUP

Controls whether the source application of an embedded OLE object loads
when plotting.
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OSNAPCOORD

Controls whether coordinates entered on the command line will override
running object snaps.

PAPERUPDATE

Controls the display of a warning dialog when attempting to print a layout
with a paper size different from the paper size specified by the default for
the plotter configuration file.

PALETTEOPAQUE

Controls whether palettes can be made transparent.

PICKADD

Controls whether subsequent selections replace the current selection set or
add to it.

PICKAUTO

Controls automatic windowing at the Select Objects prompt.

PICKBOX

Sets the object selection target height, in pixels.

PICKDRAG

Controls the method of drawing a selection window.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

PICKSTYLE

Controls the use of group selection and associative hatch selection.

PSTYLEPOLICY

Controls the plot style mode, Color-Dependent or Named, that is used when
opening a drawing that was created in a release prior to AutoCAD 2000 or
when creating a new drawing from scratch without using a drawing template.

QTEXTMODE

Controls how text is displayed.

RASTERPREVIEW

Controls whether BMP preview images are saved with the drawing.
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ROLLOVERTIPS

Controls the display of rollover tooltips in the application.

SAVEFILEPATH

Stores the current automatic save file name.

SAVEFILEPATH

Specifies the path to the directory for all automatic save files for the current
session.

SAVETIME

Sets the automatic save interval, in minutes.

SPLINESEGS

Sets the number of line segments to be generated for each spline-fit polyline
generated by the Spline option of the PEDIT command.

TDUSRTIMER

Stores the user-elapsed timer.

TOOLTIPMERGE

Combines drafting tooltips into a single tooltip.

TOOLTIPS

Controls the display of tooltips on the ribbon, toolbars, and other user
interface elements.

VISRETAIN

Controls the properties of xref-dependent layers.

VTDURATION

Sets the duration of a smooth view transition, in milliseconds.

VTENABLE

Controls when smooth view transitions are used.

VTFPS

Sets the minimum speed of a smooth view transition, in frames per second.

XLOADCTL

Turns xref demand-loading on and off, and controls whether it opens the
referenced drawing or a copy.

144 | Chapter 4   Customize the Drawing Environment



Utilities

No entries

Command Modifiers

No entries

Control the Display of Toolbars
Similar to dockable windows, you can control the behavior of toolbars.

To display or hide toolbars, right-click any toolbar to display a list of toolbars.
A check mark next to a toolbar name indicates that it is displayed. Click a
toolbar name in the list to display or clear the check mark.

A toolbar can be docked or floating. A docked toolbar is attached to any edge
of the drawing area. A toolbar docked at the top edge of the drawing area is
located below the ribbon. Undock a toolbar by clicking the double bars and
dragging it into the drawing area. You can click the title bar and drag it to a
new location or dock it. Resize a floating toolbar by dragging an edge.

Lock the Position of Toolbars and Dockable Windows

Once you have arranged toolbars and docked, floating, or anchored windows
the way you want them, you can lock their position. Locked toolbars and
windows can still be opened and closed and items can be added and deleted.
To unlock them temporarily, press and hold Ctrl.

To lock the position and size of toolbars and dockable windows

■ Do one of the following:

■ Click View tab  ➤  Windows panel  ➤  Window Locking ➤  Floating
Toolbars/Panels.

■ Click View tab  ➤  Windows panel  ➤  Window Locking ➤ Docked
Toolbars/Panels.

■ Click View tab  ➤  Windows panel  ➤  Window Locking ➤ Floating
Windows.

■ Click View tab  ➤  Windows panel  ➤  Window Locking ➤ Docked
Windows.
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A lock icon in the system tray indicates whether toolbars or dockable windows
are locked. To unlock them temporarily, hold down Ctrl.

Command entry: LOCKUI
Shortcut menu: Right-click the lock icon in the system tray. Place a check
mark next to one or more options or click All  ➤  Locked.

Quick Reference

Commands

CLEANSCREENON

Clears the screen of toolbars and dockable windows (excluding the command
line).

CLEANSCREENOFF

Restores display of toolbars and dockable windows (excluding the command
line).

DRAGMODE

Controls the way dragged objects are displayed.

HIDEPALETTES

Hides currently displayed palettes (including the command line).

LOGFILEOFF

Closes the text window log file opened by LOGFILEON.

LOGFILEON

Writes the text window contents to a file.

OPTIONS

Customizes the program settings.

SHOWPALETTES

Restores the display of hidden palettes.

VIEWRES

Sets the resolution for objects in the current viewport.

VTOPTIONS

Displays a change in view as a smooth transition.
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System Variables

APERTURE

Sets the display size for the object snap target box, in pixels.

CALCINPUT

Controls whether mathematical expressions and global constants are
evaluated in text and numeric entry boxes of windows and dialog boxes.

CLEANSCREENSTATE

Indicates whether the clean screen state is on or off.

CURSORSIZE

Determines the size of the crosshairs as a percentage of the screen size.

DCTCUST

Displays the path and file name of the current custom spelling dictionary.

DCTMAIN

Displays the three letter keyword for the current main spelling dictionary.

DEFPLSTYLE

Specifies the default plot style for new objects in a drawing when opening a
drawing that was created in a release prior to AutoCAD 2000, or when creating
a new drawing from scratch without using a drawing template.

DRAGMODE

Controls the way dragged objects are displayed.

EXTNAMES

Sets the parameters for named object names (such as linetypes and layers)
stored in definition tables.

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.

GRIPBLOCK

Controls the display of grips in blocks.

GRIPCOLOR

Controls the color of unselected grips.
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GRIPHOT

Controls the color of selected grips.

GRIPS

Controls the use of selection set grips for the Stretch, Move, Rotate, Scale,
and Mirror Grip modes.

INSUNITS

Specifies a drawing-units value for automatic scaling of blocks, images, or
xrefs when inserted or attached to a drawing.

INSUNITSDEFSOURCE

Sets source content units value when INSUNITS is set to 0.

INSUNITSDEFTARGET

Sets target drawing units value when INSUNITS is set to 0.

INTELLIGENTUPDATE

Controls the graphics refresh rate.

ISAVEBAK

Improves the speed of incremental saves, especially for large drawings.

ISAVEPERCENT

Determines the amount of wasted space tolerated in a drawing file.

LAYOUTREGENCTL

Specifies how the display list is updated in the Model tab and layout tabs.

LOCALE

Displays a code that indicates the current locale.

LOCALROOTPREFIX

Stores the full path to the root folder where local customizable files were
installed.

LOCKUI

Locks the position and size of toolbars and dockable windows such as
DesignCenter and the Properties palette.

LOGFILEMODE

Specifies whether the contents of the text window are written to a log file.
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LOGFILENAME

Specifies the path and name of the text window log file for the current
drawing.

LOGFILEPATH

Specifies the path for the text window log files for all drawings in a session.

MTEXTED

Sets the application for editing multiline text objects.

OLEQUALITY

Sets the default plot quality for OLE objects.

OLESTARTUP

Controls whether the source application of an embedded OLE object loads
when plotting.

OSNAPCOORD

Controls whether coordinates entered on the command line will override
running object snaps.

PAPERUPDATE

Controls the display of a warning dialog when attempting to print a layout
with a paper size different from the paper size specified by the default for
the plotter configuration file.

PALETTEOPAQUE

Controls whether palettes can be made transparent.

PICKADD

Controls whether subsequent selections replace the current selection set or
add to it.

PICKAUTO

Controls automatic windowing at the Select Objects prompt.

PICKBOX

Sets the object selection target height, in pixels.

PICKDRAG

Controls the method of drawing a selection window.
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PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

PICKSTYLE

Controls the use of group selection and associative hatch selection.

PSTYLEPOLICY

Controls the plot style mode, Color-Dependent or Named, that is used when
opening a drawing that was created in a release prior to AutoCAD 2000 or
when creating a new drawing from scratch without using a drawing template.

QTEXTMODE

Controls how text is displayed.

RASTERPREVIEW

Controls whether BMP preview images are saved with the drawing.

ROLLOVERTIPS

Controls the display of rollover tooltips in the application.

SAVEFILEPATH

Stores the current automatic save file name.

SAVEFILEPATH

Specifies the path to the directory for all automatic save files for the current
session.

SAVETIME

Sets the automatic save interval, in minutes.

SPLINESEGS

Sets the number of line segments to be generated for each spline-fit polyline
generated by the Spline option of the PEDIT command.

TDUSRTIMER

Stores the user-elapsed timer.

TOOLTIPMERGE

Combines drafting tooltips into a single tooltip.
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TOOLTIPS

Controls the display of tooltips on the ribbon, toolbars, and other user
interface elements.

VISRETAIN

Controls the properties of xref-dependent layers.

VTDURATION

Sets the duration of a smooth view transition, in milliseconds.

VTENABLE

Controls when smooth view transitions are used.

VTFPS

Sets the minimum speed of a smooth view transition, in frames per second.

XLOADCTL

Turns xref demand-loading on and off, and controls whether it opens the
referenced drawing or a copy.

Utilities

No entries

Command Modifiers

No entries

Create Task-Based Workspaces
Workspaces are sets of menus, toolbars, palettes, and ribbon control panels
that are grouped and organized so that you can work in a custom, task-oriented
drawing environment.

When you use a workspace, only the menus, toolbars, and palettes that are
relevant to a task are displayed. In addition, a workspace may automatically
display the ribbon, a special palette with task-specific control panels.

For more information about using the ribbon, see The Ribbon on page 22.

You can easily switch between workspaces. The following task-based workspaces
are already defined in the product:

■ 2D Drafting & Annotation
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■ 3D Modeling

■ AutoCAD Classic

For example, when you create 3D models, you can use the 3D Modeling
workspace that contains only 3D-related toolbars, menus, and palettes.
Interface items that you do not need for 3D modeling are hidden, maximizing
the screen area available for your work.

When you make changes to your drawing display (such as moving, hiding,
or displaying a toolbar or a tool palette group) and you want to preserve the
display settings for future use, you can save the current settings to a workspace.

Switch Workspaces

You can switch to another workspace whenever you need to work on a different
task from the Workspace icon on the status bar.

Create or Change a Workspace

You can create your own workspaces and modify the default workspaces. To
create or change a workspace, use either of the following methods:

■ Display, hide, and rearrange your toolbars and windows, modify your
ribbon settings, and then save the current workspace from the Workspaces
icon in the status bar, Workspaces toolbar or the Window menu, or use
the WORKSPACE command.

■ For more extensive changes, open the Customize User Interface dialog box
to set up the workspace environment.

You can control the display order of your saved workspaces and other options
in the Workspace Settings dialog box.

NOTE For more information about creating or modifying workspaces, and how
toolbars and menus interact with workspaces, see Customize Workspaces in the
Customization Guide.

Select a Sample Workspace

You can experiment with the sample workspace included with the product.
This predefined workspace demonstrates how you might use a workspace to
streamline your work tasks.

You can find the sample workspace in the following location:
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<drive>:\Documents and Settings\<user name>\Application Data\Autodesk\AutoCAD
2010\<release>\<product language>\Support\acadSampleWorkspaces.cuix

To use the sample workspace, you must first transfer it to your main
customization (CUIx) file. To learn more about transferring a workspace, see
Transfer and Migrate Customization in the Customization Guide.

Workspaces and Profiles

Workspaces work with and complement the control over your drawing
environment that profiles provide.

Workspaces control the display of menus, toolbars, and palettes in the drawing
area. When you use or switch a workspace, you change the display of your
drawing area. You manage your workspaces from the Customize User Interface
dialog box.

Profiles save environment settings including many of your user options, drafting
settings, paths, and other values. Profiles are updated each time you make a
change to an option, setting, or other value. You can manage your profiles
from the Options dialog box.

NOTE When you make changes to the drawing display, the changes are stored
in your profile and are displayed the next time you launch the program, regardless
of your workspace settings. The profile changes are not automatically saved to a
workspace unless you select the Automatically Save Workspace Changes option
in the Workspace Settings dialog box. To preserve profile settings in a workspace,
click Save Current As from the shortcut menu of the workspace icon on the status
bar.

For more information about profiles, see Save and Restore Interface Settings
(Profiles) on page 155.

To switch workspaces

1 On the status bar, click Workspace Switching.

2 From the list of workspaces, select the workspace you want to switch to.

The workspace with a check mark is your current workspace.

Command entry: WORKSPACE
Menu: Tools  ➤ Workspaces

To change workspace settings

1 Click Tools menu  ➤  Workspaces  ➤  Workspace Settings.
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2 In the Workspace Settings dialog box, change workspace settings as
needed.

3 Click OK.

Command entry: WORKSPACE, WSSETTINGS

To save a workspace

1 Tools  ➤  Workspaces  ➤  Save Current As.

2 In the Save Workspace dialog box, enter a name for the new workspace
or select a name from the drop-down list.

3 Click Save.

Command entry: WORKSPACE, WSSAVE

Quick Reference

Commands

WORKSPACE

Creates, modifies, and saves workspaces and makes a workspace current.

WSSAVE

Saves a workspace.

WSSETTINGS

Sets options for workspaces.

System Variables

WSCURRENT

Returns the current workspace name at the Command prompt and sets a
workspace to current.
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Utilities

No entries

Command Modifiers

No entries

Save and Restore Interface Settings (Profiles)
Profiles store drawing environment settings. You can create profiles for different
users or projects, and you can share profiles by importing and exporting them
as files.

Profiles store settings such as the following:

■ Default search and project file paths

■ Template file locations

■ Initial folder specified in file navigation dialog boxes

■ Default linetype and hatch pattern files

■ Printer defaults

Profile information is typically set on the Files tab of the Options dialog box,
stored in the system registry, and can be exported to a text file (an ARG file).

Use Profiles for Shared Computers or Different Projects

Use the Profiles tab in the Options dialog box to create and save your drawing
environment settings as a profile. If you share your workstation with other
users who use the same login name, you can restore your options by making
the profile current. You can also create and save profiles to use with different
projects. By default, your current options are stored in a profile named
<<Unnamed Profile>>. The current profile name, as well as the current drawing
name, are displayed in the Options dialog box.

Transfer Profiles between Computers

Once you save a profile, you can export or import the ARG file to and from
different computers. This is useful for copying, restoring, or standardizing
project-oriented work environments over a network.

If you make changes to your current profile during a work session and you
want to save those changes in an ARG file, you must re-export the profile.
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When you export the profile with the current profile name, the ARG file is
updated with the new settings.

For more information about profiles, see OPTIONS in the Command Reference.

Customize the Default Profile with Initial Setup

When using Initial Setup, a new profile is created based on the profile named
<<Unnamed profile>>, or the current profile if <<Unnamed profile>> does
not exist. The new profile created is named Initial Setup Profile, and is assigned
the industry and default drawing template selected from Initial Setup. For
more information on Initial Setup, see Customize AutoCAD with Initial Setup
in the Stand-Alone Installation Guide.

To make a profile current

1 Click the Application button. At the bottom of the Application menu,
click Options.

2 In the Options dialog box, Profiles tab, select the profile you want to
make current.

3 Click Set Current.

4 Click OK.

Command entry: OPTIONS

To save a profile

1 Click the Application button. At the bottom of the Application menu,
click Options.

2 In the Options dialog box, Profiles tab, click Add to List.

3 In the Add Profiles dialog box, enter a Profile name and Description.

4 Click Apply & Close to record the current option settings in the system
registry and close the dialog box.

5 Click OK.

Command entry: OPTIONS

To make a profile current before starting the program

1 On the Windows desktop, right-click the program icon. Click Properties.
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2 In the AutoCAD Properties dialog box, Shortcut tab, under Target, enter
/p currentprofile after the current target directory. For example, to make
the profile User12 current, enter the following in Target:

"c:\Program Files\<current release name>\acad.exe"/p user12

3 Click OK.

The profile name you enter is the current profile each time you start the
program.

Quick Reference

Commands

OPTIONS

Customizes the program settings.

System Variables

CPROFILE

Displays the name of the current profile.

Utilities

No entries

Command Modifiers

No entries

Customize Startup
Command line switches can specify a separate startup routine for each project.

You can use command line switches to specify several options when you start
the program. For example, you can run a script, start with a specified drawing
template, and display a specified view when a drawing is opened. With
command line switches, you can also set up several program icons, each with
different start-up options.

Command line switches are parameters you can add to the acad.exe command
line associated with a Microsoft® Windows® shortcut icon or the Windows
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Run dialog box. You can include several switches within a single command
line. Valid switches are listed in the following table.

Designates a script to run after you start the
program (b stands for batch process). Scripts

Script name/b

can be used to set up drawing parameters
in a new drawing file. An SCR file type is as-
sumed.

Creates a new drawing based on a template
or prototype drawing. A DWT file type is
assumed.

Template file name/t

Specifies the path for the hardware config-
uration file that you want to use. You can

Configuration folder/c

specify a directory or a particular file. A CFG
file type is assumed.
If you don't set the /c switch, the executable
directory is searched and the ACADCFGW
or ACADCFG environment variable is used
as a way to define the configuration file and
directory location.

Designates a particular view of the drawing
for display at startup.

View name/v

Loads a specified ARX or DBX application.
Use the following format:

ARX or DBX application/ld

<path>\<filename>.ARX
If the path or file name contains spaces, then
the path or file name should be wrapped in
double quotes. If no path information is in-
cluded, the program search path is used.

Designates support folders other than the
current folder. Drawing support files include

Support folders/s

text fonts, menus, AutoLISP files, linetypes,
and hatch patterns. The maximum number
of folders you can specify in the path is 15.
Each folder name is delimited by semicolons.

Restores the default system pointing device.
It creates a new configuration file

Default system pointing
device

/r
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(acad2010.cfg) and renames the previous
configuration file to acad.bak.

Starts the program without first displaying
the logo screen.

No AutoCAD logo screen/nologo

Specifies a user-defined registry profile for
starting the program. The selected profile is

User-defined registry
profile for starting the

/p

in effect only for the current session of theprogram
program, unless you make another profile
current in the Options dialog box during
that session.
You create or import profiles on the Profiles
tab in the Options dialog box. With the /p
switch, you can specify only those profiles
that are listed in the Options dialog box. If
the profile does not exist, the current profile
is used.

Disables hardware acceleration on startup.Disables hardware/nohard-
ware acceleration

Suppresses the display of the Sheet Set
Manager window on startup.

No Sheet Set Manager
window

/nossm

Loads the named sheet set on startup. Use
the following format:

Sheet set/set

<path>\<sheet set data file>.DST

Designates which workspace in the loaded
CUIx files should be restored on startup.

Default workspace/w

Publishes a drawing set descriptions (DSD)
file in the background. Use the following
format:

Background plotting/publish-
ing

/pl

<path>\<drawing set descriptions file>.DSD

The syntax for using command line switches is

"drive:pathname\acad.exe" ["drawingname"] [/switch "name"]

When using a switch option, you must follow the switch with a space and
then the name of a file, path, or view within quotation marks. For example,
the following entry starts the program from a folder named AutoCAD 2010
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with the drawing template arch1.dwt, restores a named view PLAN1, and
executes a script file startup.scr.

"d:\AutoCAD 2010\acad.exe”/t "d:\AutoCAD 2010\template\arch1" /v "plan1"
/b "startup"

The environment settings are resolved in the following way:

■ If you use a command line switch to specify an environment setting, the
command line switch overrides the settings specified in either the Options
dialog box or the environment variable.

■ If a command line switch is not set, the corresponding value set in the
Options dialog box is used.

■ If neither a command line switch nor an Options value is set, the
environment variable value is used.

NOTE Command line switches and environment variables override values set in
the Options dialog box for the current session only. They do not alter the system
registry.

To start the program with a command line switch

1 Right-click the program icon on the Windows desktop. Click Properties.

2 In the AutoCAD Properties dialog box, Shortcut tab, in the Target box,
edit the parameters for the switch using the following syntax:

"drive:pathname\acad.exe" ["drawing name"] [/switch "name"]

Valid switches are as follows:

Script name (b stands for batch process)/b

Template file name/t

Configuration folder/c

View name/v

Support folders/s

Default system pointing device/r

No AutoCAD logo screen/nologo
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Disables hardware acceleration/nohardware

User-defined registry profile/p

No Sheet Set Manager window/nossm

Sheet Set name/set

Default workspace/w

Background plotting/publishing for a Drawing Set Descrip-
tions (DSD) file

/pl

For example, enter "d:\AutoCAD 2010\acad.exe" /t "d:\AutoCAD
2010\template\arch1" /v "plan1" /b "startup"

3 Click OK.

Quick Reference

Commands

No entries

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Play Back an Action Macro
After an action macro is recorded with the Action Recorder, you can play back
the series of recorded commands and input values.

You play back an action macro from the Action Recorder panel. You can also
enter the name of the action macro at the Command prompt. As an action
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macro is played back, you might be paused for input or requested to respond
to a message or requested to insert a base point.

Based on the current action or request for user interaction in the action macro,
an icon near the cursor is displayed to indicate when the action macro needs
input in order to continue. A dialog box may be displayed where you enter a
value or use the recorded value.

As an action macro is played back, the series of commands are performed one
after the other until playback is complete or an error is encountered. Some of
the reasons for the playback to stop or fail are as follows:

■ Invalid command. The command that is defined in the action macro is
unknown to AutoCAD. The action macro might have been recorded in a
different product or contains custom commands or macros that are not
loaded.

■ Empty selection. The current action expected a selection set of objects, but
no objects were selected.

■ Macro cancelled. The Cancel button in one of the dialogs boxes was clicked.

Location of Action Macros

When you record an action macro, it is saved to the path defined by the system
variable ACTRECPATH. For playback, paths are defined by the system variable
ACTPATH.

Both sets of paths are used when loading and playing back an action macro.
In the Action Recorder Settings node on the Files tab of the Options dialog
box, you can to set the paths used for both recording and reading action macro
files.

Record and Modify Action Macros

Recording and modifying action macros is done with the Action Recorder
panel on the ribbon. To learn how to record and modify action macros, see
Record and Modify Action Macros in the Customization Guide.

See also:

■ Record and Modify Action Macros
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To play back an action macro from the Action Recorder panel

1 On the ribbon, click Manage tab  ➤  Action Recorder panel. Click the
down arrow next to the Action Macro list and select the action macro to
play back.

2 Click Play.

3 Follow any Command prompts and dialog boxes displayed to complete
the action macro.

To play back an action macro from the Command prompt

■ At the Command prompt, enter the name of the action macro that you
want to play back and press Enter.
For example, if the action macro command name is DRAWLINE, enter
drawline at the Command prompt and press Enter.

To provide user input during playback

1 Start the playback on an action macro.

2 Follow the prompts displayed at the Command prompt.

To change the location used to search for recorded action macros

1 Click the Application button. At the bottom of the Application menu,
click Options.

2 In the Options dialog box, Files tab, in the list of nodes, click the plus
sign (+) next to Action Recorder Settings.

3 Click the plus sign (+) next to Additional Actions Reading File Locations,
and specify a folder path.

4 Click OK

Command entry: OPTIONS
Shortcut menu: Right-click in the drawing window. Click Options.
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Quick Reference

Commands

OPTIONS

Customizes the program settings.

RIBBON

Opens the ribbon window.

System Variables

ACTPATH

Specifies the additional paths to use when locating available action macros
for playback.

ACTRECPATH

Specifies the path used to store new action macros.

Utilities

No entries

Command Modifiers

No entries

Migrate and Specify Initial Setup
Migrating from an older release or getting started with AutoCAD for the first
time present different challenges.

Migrate Custom Settings allows you to copy your custom settings and files
from a previous release of AutoCAD to the latest release, making it easier to
start using the new release. Initial Setup helps you to perform some basic
customization of AutoCAD the first time you start it.

Migrate Custom Settings and Files

One of the challenges when moving from a previous release of AutoCAD to
the latest release is getting the new release to look and behave like the previous
release. You can use Migrate Custom Settings and the Customize User Interface
(CUI) Editor to transfer many of your custom settings and files to the latest
release.
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Initial Setup

You can perform some basic customization of AutoCAD with Initial Setup
which makes it easier to access specific tools and start a new drawing. Initial
Setup is displayed the first time you start AutoCAD and can also be accessed
from the Options dialog box. The following can be done with Initial Setup:

■ Specify an industry that best describes your work to help search for related
content to use in drawings and companion products developed by partners.

■ Add task-based tools to your default workspace.

■ Specify a drawing template to use when creating new drawings.

For more information on Initial Setup, see Customize AutoCAD with Initial
Setup in the Stand-Alone Installation Guide.

See also:

■ Migrate Custom Settings and Files from Previous Releases in the Stand-Alone
Installation Guide

■ Basic Customization in the Customization Guide

■ User Interface Customization in the Customization Guide

Migrate and Specify Initial Setup | 165



166
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Start a Drawing

You can start a new drawing several ways, including starting from scratch or using a template
file. In each case, you can choose the units of measurement and other unit format conventions.

Start a Drawing from Scratch
You can start from scratch from the Create New Drawing dialog box, from the
Select Template dialog box, or with a default drawing template file that uses no
dialog box at all.

Use a Drawing Template File
You can start a drawing that uses predefined settings from a default drawing
template file.

When you use a default drawing template file, new drawings automatically use
the settings defined in the specified file. That template file displays each time
you start a new drawing using the QNEW command.

You can specify the location of the default drawing template file using the
Options dialog box.

See also:

■ Use a Template File to Start a Drawing on page 175

To specify a path for the default drawing template file

1 Click the Application button. At the bottom of the Application menu, click
Options.

2 In the Options dialog box, click the Files tab.

5
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3 On the Files tab, expand the Template Settings node.

4 In the Template Settings node, expand the Drawing Template File
Location node.

5 Specify the path where your desired default drawing template file is
located on your local drive.

To start a drawing from scratch from a default drawing template file

NOTE If necessary, at the Command prompt, enter startup and 0; then enter
filedia and 1.

1 Click the Application button. At the bottom of the Application menu,
click Options.

2 In the Options dialog box, click the Files tab.

3 On the Files tab, expand the Template Settings node.

4 In the Template Settings node, expand the Default Template File Name
for QNEW node.

5 Specify a drawing template path and file name.

NOTE The drawing template path and file name must end with .dwt.

6 Click OK.

7 At the Command prompt, enter qnew.

The new drawing starts as drawing1.dwg. The default drawing name
changes to reflect the number of new drawings that have been started.
For example, if you start another drawing, the default drawing name is
drawing2.dwg.

Command entry: QNEW

Toolbar: Standard  
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Quick Reference

Commands

NEW

Creates a new drawing.

OPTIONS

Customizes the program settings.

QNEW

Starts a new drawing with a selected drawing template file.

System Variables

FILEDIA

Suppresses display of file navigation dialog boxes.

MEASUREINIT

Controls whether a drawing you start from scratch uses imperial or metric
default settings.

MEASUREMENT

Controls whether the current drawing uses imperial or metric hatch pattern
and linetype files.

STARTUP

Controls whether the Create New Drawing dialog box is displayed when a
new drawing is started with NEW or QNEW.

Utilities

No entries

Command Modifiers

No entries

Define Settings When You Create A New Drawing
You can define drawing settings each time you create a new drawing with the
Create New Drawing dialog box.
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You can use the Create New Drawing dialog box to choose either imperial or
metric units for the new drawing. The setting you select determines default
values used for many system variables controlling text, dimensions, grid, snap,
and the default linetype and hatch pattern file.

■ Imperial. Creates a new drawing based on the imperial measurement
system. The drawing uses internal default values, and the default grid
display boundary, called the gridlimits, is 12 x 9 inches.

■ Metric. Creates a new drawing based on the metric measurement system.
The drawing uses internal default values, and the default grid display
boundary is 420 x 290 millimeters.

To start a drawing from scratch with the Create Drawing dialog box

NOTE If necessary, at the Command prompt, enter startup and 1; then enter
filedia and 1.

1 Click File menu ➤ New..

2 In the Create New Drawing dialog box, click Start from Scratch.

3 Under Default Settings, click either Imperial or Metric.

The new drawing starts as drawing1.dwg. The default drawing name
changes to reflect the number of new drawings that have been started.
For example, if you start another drawing, the default drawing name is
drawing2.dwg.

Command entry: NEW

Quick Reference

Commands

NEW

Creates a new drawing.

OPTIONS

Customizes the program settings.

QNEW

Starts a new drawing with a selected drawing template file.
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System Variables

FILEDIA

Suppresses display of file navigation dialog boxes.

MEASUREINIT

Controls whether a drawing you start from scratch uses imperial or metric
default settings.

MEASUREMENT

Controls whether the current drawing uses imperial or metric hatch pattern
and linetype files.

STARTUP

Controls whether the Create New Drawing dialog box is displayed when a
new drawing is started with NEW or QNEW.

Utilities

No entries

Command Modifiers

No entries

Select a Template When You Create a New Drawing
You can choose a different drawing template file each time you create a new
drawing with the Select Template dialog box.

If you require different settings each time you create a new drawing, such as
an imperial template file and a metric template file, you can use the Select
Template dialog box to create a new drawing.

NOTE At the bottom-right corner of the Select Template dialog box, there is an
Open button with an arrow button next to it. If you click the arrow button, you
can choose between two internal default drawing templates, metric or imperial.

See also:

■ Use a Template File to Start a Drawing on page 175
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To choose a drawing template file each time you create a new drawing

NOTE If necessary, at the Command prompt, enter startup and 0; then enter
filedia and 1.

1 Click the Application button. At the bottom of the Application menu,
click Options.

2 In the Options dialog box, click the Files tab.

3 On the Files tab, expand the Template Settings node.

4 In the Template Settings node, expand the Default Template File Name
for QNEW node and double-click the contents.

5 Specify a drawing template folder path.

6 Click OK.

7 Click the Application button, and click New menu  ➤  Drawing.

The new drawing starts as drawing1.dwg. The default drawing name
changes to reflect the number of new drawings that have been started.
For example, if you start another drawing, the default drawing name is
drawing2.dwg.

QNEW

Quick Reference

Commands

NEW

Creates a new drawing.

OPTIONS

Customizes the program settings.

QNEW

Starts a new drawing with a selected drawing template file.

System Variables

FILEDIA

Suppresses display of file navigation dialog boxes.

174 | Chapter 5   Start a Drawing



MEASUREINIT

Controls whether a drawing you start from scratch uses imperial or metric
default settings.

MEASUREMENT

Controls whether the current drawing uses imperial or metric hatch pattern
and linetype files.

STARTUP

Controls whether the Create New Drawing dialog box is displayed when a
new drawing is started with NEW or QNEW.

Utilities

No entries

Command Modifiers

No entries

Use a Template File to Start a Drawing
A drawing template file is used to provide consistency in the drawings that
you create by providing standard styles and settings.

Drawing template files have a .dwt file extension.

When you create a new drawing based on an existing drawing template file
and make changes, the changes in the new drawing do not affect the drawing
template file.

Select a Drawing Template File

A default set of drawing template (DWT) files is installed with AutoCAD which
are used to create 2D drawings and 3D models. Many of the default drawing
templates are offered in two measurement types: imperial and metric. When
using one of the default drawing templates you need determine if you will be
working in 2D or 3D, and which measurement type best describes your work.

While the default templates provide for a quick way to start creating a new
drawing, it is best to create drawing templates specific to your company and
the drawings you create. You can use Initial Setup to select a drawing template
that is close to your industry, but you will still need to do some work to make
the drawing template file work best for you. For more information on Initial
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Setup, see Customize AutoCAD with Initial Setup in the Stand-Alone Installation
Guide.

Create a Drawing Template File

When you need to create several drawings that use the same conventions and
default settings, you can save time by creating or customizing a drawing
template file instead of specifying the conventions and default settings each
time you start. Conventions and settings commonly stored in template files
include

■ Unit type and precision

■ Title blocks, borders, and logos

■ Layer names

■ Snap, Grid, and Ortho settings

■ Grid limits

■ Annotation styles (dimension, text, table and multileader)

■ Linetypes

By default, drawing template files are stored in the template folder, where they
are easily accessible.

Recover the Default Drawing Template File

If the settings in the drawing template file acad.dwt or acadiso.dwt have been
changed from the original defaults, you can reset them by starting a new
drawing with no template and then saving the drawing as a drawing template
file, replacing acad.dwt or acadiso.dwt.

If you specify the 3D Modeling workspace, the default drawing template files
are acad3d.dwt and acadiso3d.dwt.

You can start a new drawing with the original defaults by using NEW to display
the Select Template dialog box. To do this, click the arrow next to the Open
button and then click one of the “no template” options from the list.

See also:

■ Use a Hyperlink to Start a New Drawing
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To start a drawing by selecting a template file

1 Click the Application menu, and click New menu  ➤  Drawing.

2 In the Select Template dialog box, select a template from the list.

3 Click Open.

The drawing is opened as drawing1.dwg. The default drawing name
changes to reflect the number of new drawings that have been opened.
For example, if you open another drawing from a template, the default
drawing name is drawing2.dwg.

To start a new drawing with no template file, click the arrow next to the
Open button. Select one of the “no template” options from the list.

Menu: File ➤ New
Command entry: NEW

To create a drawing template file from an existing drawing

1 Click the Application button, and click Open  ➤  Drawing.

2 In the Select File dialog box, select the file you want to use as a template.
Click OK.

3 To delete the existing file contents, click Home tab  ➤  Modify panel  ➤ 

Erase.

4 At the Select Objects prompt, enter all, and then select the border and
title block (if you want to remove them) and enter r (Remove).

5 Click the Application button, and click Save As  ➤  AutoCAD Drawing
Template.

DWT files must be saved in the current drawing file format. To create a
DWT file in a previous format, save the file in the desired DWG format,
and then rename the DWG file using a DWT extension.

6 In the Save Drawing As dialog box, File Name text box, enter a name for
the template.

7 Click Save.

8 Enter a description of the template.

9 Click OK.

The new template is saved in the template folder.
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Command entry: OPEN, SAVEAS

Toolbar: Standard  

To recover the default drawing template files

1 Click the Application button, and click New menu  ➤  Drawing.

2 In the Select Template dialog box, click the arrow next to the Open
button. Select one of the options from the list:

■ Open with No Template - Imperial (to restore acad.dwt)

■ Open with No Template - Metric (to restore acadiso.dwt)

The drawing opens with the default settings.

3 In the Save Drawing As dialog box, save the drawing with its original
name, either acad.dwt for imperial or acadiso.dwt for metric.

4 Click Save.

NOTE For the 3D Modeling workspace, the default drawing template files
are acad3d.dwt and acadiso3d.dwt

Quick Reference

Commands

NEW

Creates a new drawing.

OPEN

Opens an existing drawing file.

OPTIONS

Customizes the program settings.

SAVEAS

Saves a copy of the current drawing under a new file name.
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System Variables

MEASUREMENT

Controls whether the current drawing uses imperial or metric hatch pattern
and linetype files.

Utilities

No entries

Command Modifiers

No entries

Use a Wizard to Start a Drawing
A setup wizard establishes basic drawing settings step by step.

You have two wizard options to help you set up a drawing:

■ Quick Setup Wizard. Sets units of measurement, precision of displayed
units, and grid limits.

■ Advanced Setup Wizard. Sets units of measurement, precision of displayed
units, and grid limits. Also establishes angle settings such as units of
measurement style, precision, direction, and orientation.

These wizards are available in the Create New Drawing dialog box.

To begin a new drawing using a wizard

1 If necessary, set the STARTUP system variable to 1 and the FILEDIA system
variable to 1.

2 Click File menu ➤ New.

3 In the Create New Drawing dialog box, click Use a Wizard.

4 Click Quick Setup or Advanced Setup.

5 Complete the wizard pages using the Next and Back buttons to move
forward and backward.

6 On the last page, click Finish.

Command entry: NEW
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Quick Reference

Commands

NEW

Creates a new drawing.

System Variables

MEASUREINIT

Controls whether a drawing you start from scratch uses imperial or metric
default settings.

MEASUREMENT

Controls whether the current drawing uses imperial or metric hatch pattern
and linetype files.

Utilities

No entries

Command Modifiers

No entries

Specify Units and Unit Formats
Before you start to draw, you decide on the units of measurement to be used
in the drawing, and set the format, precision, and other conventions to be
used in coordinates and distances.

Determine the Units of Measurement
Before you start to draw, you must decide what one drawing unit represents
based on what you plan to draw. You can convert a drawing between systems
of measurement by scaling it.

Every object you create is measured in drawing units. Before you start to draw,
you must decide what one drawing unit will represent based on what you
plan to draw. Then you create your drawing at actual size with that convention.
For example, a distance of one drawing unit typically represents one millimeter,
one centimeter, one inch, or one foot in real-world units.
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Convert Drawing Units

If you start a drawing in one system of measurement (imperial or metric) and
then want to switch to the other system, use SCALE to scale the model
geometry by the appropriate conversion factor to obtain correct distances and
dimensions.

For example, to convert a drawing created in inches to centimeters, you scale
the model geometry by a factor of 2.54. To convert from centimeters to inches,
the scale factor is 1/2.54 or about 0.3937.

See also:

■ Set the Scale for Dimensions on page 1673

To set the units format and precision

1 Click the Application button, and click Drawing  ➤  Units.

2 In the Drawing Units dialog box, under Length, select a unit format and
precision. Click OK.

The Sample Output area shows an example of the unit format at the
current precision.

Command entry: UNITS

To convert a drawing from inches to centimeters

1 Click Home tab  ➤  Modify panel  ➤  Scale. 

2 At the Select Objects prompt, enter all.

All objects in the drawing are selected for scaling.

3 Enter a base point of *0,0.

Scaling will be relative to the world coordinate system origin and the
location of the drawing origin will remain at the WCS origin.

4 Enter a scale factor of 2.54 (there are 2.54 centimeters per inch).

All objects in the drawing are now 2.54 times larger, corresponding to
the equivalent distance in centimeters.

Command entry: SCALE
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Toolbar: Modify  

To convert a drawing from centimeters to inches

1 Click Home tab  ➤  Modify panel  ➤  Scale. 

2 At the Select Objects prompt, enter all.

All objects in the drawing are selected for scaling.

3 Enter a base point of *0,0.

Scaling is performed relative to the world coordinate system origin, and
the location of the drawing origin will remain at the WCS origin.

4 Enter a scale factor of 0.3937 (the inverse of 2.54 centimeters per inch).

All objects in the drawing are now smaller, corresponding to the
equivalent distance in inches.

Toolbar: Modify  
Command entry: SCALE

Quick Reference

Commands

UNITS

Controls coordinate and angle display formats and precision.

SCALE

Enlarges or reduces selected objects, keeping the proportions of the object
the same after scaling.

System Variables

LUNITS

Sets linear units.
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LUPREC

Sets the display precision for linear units and coordinates.

MEASUREINIT

Controls whether a drawing you start from scratch uses imperial or metric
default settings.

MEASUREMENT

Controls whether the current drawing uses imperial or metric hatch pattern
and linetype files.

UNITMODE

Controls the display format for units.

Utilities

No entries

Command Modifiers

No entries

Set Linear Unit Conventions
Before you start to draw, you set the format and the number of decimal places
to be used when you enter and display linear units.

You can choose from several common conventions to represent the display
style and the precision of distances and coordinates. Depending on what you
specify, you can enter and display in decimal format, fractional format, or
other notation. These settings affect

■ The Properties palette

■ Dynamic input

■ The LIST command

■ The ID command

■ The coordinate display on the status bar

■ Several dialog boxes that display coordinates
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You can set the unit type and precision in the Drawing Units dialog box, the
Quick Setup wizard, or the Advanced Setup wizard.

Understand Rounding and Precision

When you specify the display precision of units, the values for coordinates
and distances are rounded off. However, the internal precision of coordinates
and distances is always maintained regardless of the display precision.

For example, if you set the display precision of decimal-format units to 1 (or
0.0), the display of coordinates is rounded to one place after the decimal point.
Thus, the coordinates 0.000,1.375 are displayed as 0.0,1.4, but the internal
precision is still maintained.

Enter Distances in Imperial Architectural Format

In architectural format, to enter feet and inches, indicate feet using the prime
symbol ('), for example, 72'3. You don't need to enter quotation marks (“) to
specify inches.

NOTE The units format for creating and listing objects, measuring distances, and
displaying coordinate locations is separate from the dimension units setting used
in creating dimension values.

See also:

■ Set the Scale for Dimensions on page 1673

To set the units format and precision

1 Click the Application button, and click Drawing  ➤  Units.

2 In the Drawing Units dialog box, under Length, select a unit format and
precision. Click OK.

The Sample Output area shows an example of the unit format at the
current precision.

Command entry: UNITS

To convert a drawing from inches to centimeters

1 Click Home tab  ➤  Modify panel  ➤  Scale. 
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2 At the Select Objects prompt, enter all.

All objects in the drawing are selected for scaling.

3 Enter a base point of *0,0.

Scaling will be relative to the world coordinate system origin and the
location of the drawing origin will remain at the WCS origin.

4 Enter a scale factor of 2.54 (there are 2.54 centimeters per inch).

All objects in the drawing are now 2.54 times larger, corresponding to
the equivalent distance in centimeters.

Command entry: SCALE

Toolbar: Modify  

To convert a drawing from centimeters to inches

1 Click Home tab  ➤  Modify panel  ➤  Scale. 

2 At the Select Objects prompt, enter all.

All objects in the drawing are selected for scaling.

3 Enter a base point of *0,0.

Scaling is performed relative to the world coordinate system origin, and
the location of the drawing origin will remain at the WCS origin.

4 Enter a scale factor of 0.3937 (the inverse of 2.54 centimeters per inch).

All objects in the drawing are now smaller, corresponding to the
equivalent distance in inches.

Toolbar: Modify  
Command entry: SCALE
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Quick Reference

Commands

UNITS

Controls coordinate and angle display formats and precision.

System Variables

LUNITS

Sets linear units.

LUPREC

Sets the display precision for linear units and coordinates.

MEASUREINIT

Controls whether a drawing you start from scratch uses imperial or metric
default settings.

MEASUREMENT

Controls whether the current drawing uses imperial or metric hatch pattern
and linetype files.

UNITMODE

Controls the display format for units.

Utilities

No entries

Command Modifiers

No entries

Set Angular Unit Conventions
Angle conventions include the position of angle 0 and the direction of
measurement: clockwise or counterclockwise. You also set the format and the
number of decimal places.

You can choose from several common conventions to represent angles in a
drawing. You can specify that positive values of angles are measured either
clockwise or counterclockwise, and angle 0 can be set to any direction (usually
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East or North). You can enter angles using grads, radians, or surveyor's units
or using degrees, minutes, and seconds.

Work with Surveyor's Angles

If you use surveyor's angles when specifying polar coordinates, indicate whether
the surveyor's angles are in the north, south, east, or west direction. For
example, to enter a coordinate relative to the current coordinate for a property
line that is 72 feet, 8 inches long with a bearing of 45 degrees north, 20
minutes, 6 seconds east, enter

@72'8"<n45d20'6"e

To set the angle format and precision

1 Click the Application button, and click Drawing Utilities ➤  Units.

2 In the Drawing Units dialog box, under Angle, select an angle type and
precision.

The Sample Output area shows an example of the angle type at the current
precision.

3 Select Direction to specify an angle direction.

The angle direction controls the point from which angles are measured
and the direction in which they're measured. The default starting angle,
0 degrees, is toward 3 o'clock (or east), and positive angle measurement
is counterclockwise.

4 Select the options you want to use.

5 Click OK to close each dialog box.

Command entry: UNITS

Quick Reference

Commands

UNITS

Controls coordinate and angle display formats and precision.
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System Variables

ANGBASE

Sets the base angle to 0 with respect to the current UCS.

ANGDIR

Sets the direction of positive angles.

AUNITS

Sets units for angles.

AUPREC

Sets the display precision for angular units and coordinates.

UNITMODE

Controls the display format for units.

Utilities

No entries

Command Modifiers

No entries

Add Identifying Information to Drawings
You can keep track of your drawings more easily if you add keywords or other
information to them.

Use Windows Explorer

Drawing properties can help you identify a drawing. Some drawing properties
are stored by the operating system; for example, drawing type, location, and
size. These values are read-only in the drawing file and can only be changed
through Windows Explorer.

Use the Find Tool

The Find tool in a standard file selection dialog box can use this information.
For example, you can search for all files created on a certain date, or for files
you modified yesterday.
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Use DesignCenter

You can create additional properties in drawing files. You can store author,
title, and subject, and you can assign keywords, hyperlink addresses or directory
paths, and custom properties to your drawings. The Advanced tab in the Search
tool in DesignCenter can use these properties to locate drawing files. For more
information about DesignCenter, see ADCENTER and Access Content with
DesignCenter on page 92.

Use Sheet Set Manager Properties

With the Sheet Set Manager, you can assign a sheet title, number, and a
description to every sheet in a sheet set. For more information about sheet
sets, see Include Information with Sheets and Sheet Sets on page 506.

Display Properties in Fields

You can assign any of the drawing properties to a field in a text object. For
more information about fields, see Use Fields in Text on page 1532.

To display drawing properties for the active drawing

1 Click the Application button, and click Drawing  ➤  Drawing Properties.

2 In the Drawing Properties dialog box, click tabs to view the different types
of information.

Command entry: DWGPROPS

To define drawing properties

1 Click the Application button, and click Drawing  ➤  Drawing Properties.

2 In the Drawing Properties dialog box, enter property information on the
following tabs:

■ Summary tab. Enter the drawing title, subject, author, keywords,
comments, and a default address for hyperlinked data in your drawing.
For example, you can add the keyword Autodesk to certain drawing
files and then use DesignCenter to search for all drawing files with
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that keyword. For a hyperlink base, you can specify an Internet address
or a path to a folder on a network drive.

■ Custom tab. Click Add. In the Add Custom Property dialog box, enter
a name and a value for the custom property. Click OK. The new
custom property and its value are displayed on the Custom tab. This
information can be used for advanced searches in DesignCenter.

3 Click OK.

Command entry: DWGPROPS

Quick Reference

Commands

DWGPROPS

Sets and displays the file properties of the current drawing.

System Variables

CDATE

Stores the current date and time in decimal format.

DATE

Stores the current date and time in Modified Julian Date format.

TDCREATE

Stores the local time and date the drawing was created.

TDINDWG

Stores the total editing time, which is the total elapsed time between saves
of the current drawing.

TDUCREATE

Stores the universal time and date that the drawing was created.

TDUPDATE

Stores the local time and date of the last update/save.

TDUUPDATE

Stores the universal time and date of the last update or save.
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Utilities

No entries

Command Modifiers

No entries

Insert Geographical Location Information in a Drawing
You can embed the geographic location of the geometry in a drawing file.

Overview of Geographic Location
Geographic location embeds location-specific references – expressed as
real-world coordinates (X,Y, and Z) – in your drawing.

You can then send your georeferenced drawing for review.

For example, you can:

■ Put the drawing on a map (using AutoCAD Map 3D)

■ See your design in the landscape (using AutoCAD)

When you add a geographic location to a drawing, a geographic marker is
created.

The geographic marker is a visual representation of the location information
and is created at the specified point on the drawing.

Geographic location information can be included in either of the following
ways:

■ Import a KML or KMZ file with the appropriate location information

■ Import a location from Google Earth

■ Use the Geographic Location dialog box

When you insert location information, the drawing contains the following
data:

■ North direction — a vector that defines the direction of the North pole
from the XY plane
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■ Up direction — a vector that is always constrained 90 degrees to the XY
plane

■ Geographic location data

See also:

■ Define the Geographic Location for a DWG File on page 195

■ View the Geographic Location Information on page 199

To import a kml or kmz file into the drawing

1 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

2 Click Import a KML or KMZ File.

3 Navigate to the location of the KML or KMZ file. Click Open.

NOTE If your KML or KMZ file references multiple locations, only the first
location is used. In such cases, click Close when the Multiple Locations Found
dialog box is displayed.

4 Click or enter a point or value for the location in the World Coordinate
System (WCS) X, Y, Z format.

5 Click to specify the north direction.

A geographic marker (visual representation of the location information)
is inserted at the specified location.

NOTE The geographic marker displays differently in 2D and 3D views.

To import the current location from Google Earth

NOTE Before you proceed, you must have Google Earth installed and open, with
the location selected.

1 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

2 Click Import the current location from Google Earth.
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The Import from Google Earth task dialog box is displayed.

3 Click Continue.

4 Click or enter a point / value for the location in the World Coordinate
System (WCS) X, Y, Z format.

5 Click to specify the north direction.

The geographic marker is created at the specified point on the drawing.

NOTE The geographic marker displays differently in 2D and 3D views.

To enter the location values manually

1 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

2 Click Enter the Location Values.

3 (Optional) Select the latitude and longitude format.

You can enter the latitude, longitude, and time zone values manually,
or click the Use Map button (steps 4 through 8) to select the values
visually.

4 (Optional) Click Use Map.

5 In the Region drop-down list, select the applicable region.

6 In the Nearest City drop-down list, select the nearest city that represents
the time zone. Click OK.

NOTE The Time Zone value is updated automatically based on the Nearest
City selected.

7 Click Accept Updated Time Zone, if correct. To select a different time
zone, click Return to the Previous Dialog Box.

NOTE The latitude, longitude, direction, and time zone values are
automatically populated based on the values selected in the location picker
dialog box.

8 Click Pick Point to specify the X, Y, and Z coordinates. Values can also be
entered at the Command prompt.
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9 Use the Up or Down arrows to specify the elevation.

10 Click Pick Point, or drag the compass needle icon, to specify the angle.

The north direction angle is calculated when you select a point with
reference to the geographic location.

11 Specify the Up direction, if necessary.

12 Click OK.

NOTE The geographic marker displays differently in 2D and 3D views.

To view the graphic of a geographic marker

1 At the Command prompt, enter geomarkervisibility. Enter 1 (Geographic
marker is visible).

2 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

3 Insert a geographic marker using the options available.

To view the status bar coordinate display

1 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

2 Insert a geographic marker using the options available.

3 Right-click the status bar display. Click Geographic.

The status bar coordinates display the latitude and longitude values of
the geographic location.

Quick Reference

Command

GEOGRAPHICLOCATION

Specifies the geographic location information for a drawing file.

INSERT

Inserts a block or drawing into the current drawing.
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XATTACH

Inserts a DWG file as an external reference (xref).

System Variables

GEOLATLONGFORMAT

Controls the format of the latitude or longitude values in the Geographic
Location dialog box, and the coordinate status bar in Geographic mode.

GEOMARKERVISIBILITY

Controls the visibility of geographic markers.

Define the Geographic Location for a DWG File
You can insert geographic location information in the drawing by importing
.kml files, or .kmz files; or location information from Google Earth; or by
manually entering the location values.

Import KML or KMZ files

You can import the location information (latitude, longitude, and altitude)
specified in KML or KMZ files.

Once imported, specify the location in the drawing; and the north direction,
or angle.

NOTE When a KML or KMZ file references multiple locations only the first
placemark found is used.

Import Location from Google Earth

You can navigate to a specific location in Google Earth and import the location
information in the drawing file.

NOTE Before proceeding, you must have Google Earth installed and open with
the location selected.

You can then pick a point in the drawing to define the coordinates for the
location defined in Google Earth.

Use the Geographic Location Dialog Box

You can manually enter the latitude, longitude, north direction, elevation,
and up-direction values.
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You can also enter a city name or other known geographic entity in the
Location Picker dialog box to insert the location.

Latitude and longitude is defined either as Decimal Degrees or as Degree
Minutes Second.

To import a kml or kmz file into the drawing

1 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

2 Click Import a KML or KMZ File.

3 Navigate to the location of the KML or KMZ file. Click Open.

NOTE If your KML or KMZ file references multiple locations, only the first
location is used. In such cases, click Close when the Multiple Locations Found
dialog box is displayed.

4 Click or enter a point or value for the location in the World Coordinate
System (WCS) X, Y, Z format.

5 Click to specify the north direction.

A geographic marker (visual representation of the location information)
is inserted at the specified location.

NOTE The geographic marker displays differently in 2D and 3D views.

To import the current location from Google Earth

NOTE Before you proceed, you must have Google Earth installed and open, with
the location selected.

1 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

2 Click Import the current location from Google Earth.

The Import from Google Earth task dialog box is displayed.

3 Click Continue.

4 Click or enter a point / value for the location in the World Coordinate
System (WCS) X, Y, Z format.
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5 Click to specify the north direction.

The geographic marker is created at the specified point on the drawing.

NOTE The geographic marker displays differently in 2D and 3D views.

To enter the location values manually

1 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

2 Click Enter the Location Values.

3 (Optional) Select the latitude and longitude format.

You can enter the latitude, longitude, and time zone values manually,
or click the Use Map button (steps 4 through 8) to select the values
visually.

4 (Optional) Click Use Map.

5 In the Region drop-down list, select the applicable region.

6 In the Nearest City drop-down list, select the nearest city that represents
the time zone. Click OK.

NOTE The Time Zone value is updated automatically based on the Nearest
City selected.

7 Click Accept Updated Time Zone, if correct. To select a different time
zone, click Return to the Previous Dialog Box.

NOTE The latitude, longitude, direction, and time zone values are
automatically populated based on the values selected in the location picker
dialog box.

8 Click Pick Point to specify the X, Y, and Z coordinates. Values can also be
entered at the Command prompt.

9 Use the Up or Down arrows to specify the elevation.

10 Click Pick Point, or drag the compass needle icon, to specify the angle.

The north direction angle is calculated when you select a point with
reference to the geographic location.

11 Specify the Up direction, if necessary.
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12 Click OK.

NOTE The geographic marker displays differently in 2D and 3D views.

To edit a geographic marker

1 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

2 Click Edit Current Geographic Location.

3 Edit the existing values you want to change. Click OK.

To remove a geographic marker

1 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

2 Click Remove Geographic Location.

3 In the Confirmation dialog box, click Yes.

To import a drawing with an external coordinate system defined

1 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

2 Click one of the following options:

■ Leave Existing Coordinate System —AutoCAD does not convert the
external coordinate system to the LL84 coordinate system.

■ Convert to AutoCAD and then edit — Converts the coordinate system
to theLL84 system and then displays the Location Already Exists task
dialog box.

3 Edit the geographic location using the options presented.
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Quick Reference

Command

GEOGRAPHICLOCATION

Specifies the geographic location information for a drawing file.

INSERT

Inserts a block or drawing into the current drawing.

XATTACH

Inserts a DWG file as an external reference (xref).

System Variables

GEOLATLONGFORMAT

Controls the format of the latitude or longitude values in the Geographic
Location dialog box, and the coordinate status bar in Geographic mode.

GEOMARKERVISIBILITY

Controls the visibility of geographic markers.

View the Geographic Location Information
You can view a marker that defines the geographic location as a graphic (in
model space view) or as a status bar coordinate display.

You can view a geographic marker in either of the following ways:

■ A graphic overlaid on the model space view at the World Coordinate
System (WCS) location of the geographic marker.

NOTE  Set the GEOMARKERVISIBILITY system variable to 1 to view the graphic
for geographic marker in the drawing.

■ A status bar coordinate display that shows the latitude or longitude of a
WCS coordinate at the cursor location.

To view the graphic of a geographic marker

1 Enter GEOMARKERVISIBILITY at the Command prompt.

2 Enter 1 as the value.
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3 Enter geographiclocation at the Command prompt.

Insert a geographic marker using the options available.

A geographic marker is inserted at the coordinates specified.

To view the status bar coordinate display

1 Click Render tab ➤ Sun & Location panel ➤ Set Location. 

2 Insert a geographic marker using the options available.

3 Right-click the status bar display. Click Geographic.

The status bar coordinates display the latitude and longitude values of
the geographic location.

Quick Reference

Command

GEOGRAPHICLOCATION

Specifies the geographic location information for a drawing file.

INSERT

Inserts a block or drawing into the current drawing.

XATTACH

Inserts a DWG file as an external reference (xref).

System Variables

GEOLATLONGFORMAT

Controls the format of the latitude or longitude values in the Geographic
Location dialog box, and the coordinate status bar in Geographic mode.

GEOMARKERVISIBILITY

Controls the visibility of geographic markers.
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Open or Save a Drawing

You can use several methods to find and open drawings, even damaged drawings. You can
save and backup drawings automatically.

Open a Drawing
You open drawings to work on them just as you do with other Windows
applications. In addition, you can choose from several alternative methods.

To open a drawing, you can

■ Use Open on the File menu or Quick Access toolbar to display the Select File
dialog box. If the FILEDIA system variable is set to 0, the Command prompt
version displays instead of a file navigation dialog box.

■ Double-click a drawing in Windows Explorer to launch AutoCAD® and open
the drawing. If the program is already running, the drawing opens in the
current session rather than in a second session.

■ Drag a drawing from Windows Explorer into AutoCAD.
If you drop a drawing anywhere outside the drawing area—for example, the
command line or the blank space next to the toolbars— the drawing is
opened. However, if you drag a single drawing into the drawing area of an
open drawing, the new drawing is not opened but inserted as a block
reference.

■ Use DesignCenter to open drawings.

■ Use the Sheet Set Manager to locate and open the drawings in a sheet set.

6
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Work on Drawings During Loading

You can work on drawings before they are fully open. This is useful when you
work on large drawings and you want to begin working immediately. To take
advantage of this capability, three conditions are required.

■ The drawing must have been saved in paper space.

■ The OPENPARTIAL system variable must be set to 1.

■ The INDEXCTL system variable must be set to a non-zero value.

When these conditions are met, you can create or modify visible objects, pan
or zoom, turn off or freeze layers, and any other operation that does not require
displaying objects not visible when the drawing was last saved.

NOTE The Quick View feature will not be fully functional during loading under
these conditions.

Resolve Missing References

As you open a drawing, you are notified (messages and task dialog boxes)
when a reference cannot be located. From the References - Unresolved
Reference Files task dialog box, click Update the Location of the Referenced
Files to open the External References palette to make changes to missing
external references.

The following table outlines some of the references that might be missing and
describes how to handle them.

DescriptionMissing Reference Types

Missing external references are the result of AutoCAD
not being able to resolve the last known location of

External references

an xref, raster image, or underlay. To resolve a missing
external reference, locate the file and update its loca-
tion using the External References palette. For inform-
ation about resolving missing referenced drawing files,
see Resolve Missing External References. For informa-
tion about working with raster images and underlays,
see Attach Raster Image Files and Attach Files as Un-
derlays.

Missing shape files are often the result of custom
shapes being used in a linetype. Browse to the missing

Shapes

linetype file, or place the shape file in the folder with
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DescriptionMissing Reference Types

the drawing or one of the support paths defined in
the Options dialog box. For information about custom
shape files in linetypes, see Shapes in Custom Line-
types in the Customization Guide.

You can use eTransmit to avoid missing files when sharing drawings with
others outside of your company. For more information about eTransmit, see
Package a Set of Files for Internet Transmission.

Work with Large Objects

AutoCAD 2010 supports object size limits greater than those available in
previous releases. With increased object size limits you can create larger and
more complex models. Using increased object size limits can result in
compatibility issues with legacy drawing file formats (AutoCAD 2007 and
earlier).

When working with drawings that you might need to exchange with others
using AutoCAD 2009 and earlier, set the LARGEOBJECTSUPPORT system
variable to 0. Setting LARGEOBJECTSUPPORT to 0 warns you when a drawing
contains large objects that cannot be opened by a release of the program prior
to AutoCAD 2010.

TrustedDWG™ Drawing Files

DWG, DWT, and DWS files created with Autodesk applications and
RealDWG™-based applications are trusted by Autodesk. When you open a
TrustedDWG file, the following icon displays in the application status bar or
the drawing status bar.

If the DWGCHECK system variable is set to On (1), an alert box is displayed
if

■ The drawing file format is AutoCAD Release 14 or later and

■ The drawing file was not originally created by an Autodesk application or
RealDWG-based application.

For more information about TrustedDWG, click the TrustedDWG icon.

Recover Defective Drawing Files

In some circumstances, it is possible that a drawing file becomes defective.
This can result from hardware problems or transmission errors. If a drawing
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file is corrupt, you might be able to recover it. See Repair, Restore, or Recover
Drawing Files on page 239.

Change the Default Drawing Folder

Each time you start AutoCAD, the My Documents folder is the default path in
each standard file selection dialog box. Alternatively, you can configure
AutoCAD to always default to a specified path by changing the default drawing
folder using the REMEMBERFOLDERS system variable.

See also:

■ Overview of DesignCenter on page 88

■ Work with Sheets in a Sheet Set on page 479

■ Open and Save Drawing Files from the Internet

■ Overview of Using Markups for Design Review

To open a drawing

1 Click the Application button, and click Open  ➤  Drawing.

2 In the Select File dialog box, select one or more files. Click Open.

The icons on the left side of the dialog box provide quick access to
commonly used files and file locations. To reorder the icons, drag them
to a new location. To add, modify, or remove an icon, right-click the icon
to display a shortcut menu.

Menu: Click File ➤ Open
Command entry: OPEN

Toolbar: Standard   , Quick Access toolbar

To change the default drawing folder

1 At the Command prompt, enter rememberfolders, and then enter 0.

2 On the Windows desktop, right-click the AutoCAD icon. Click Properties.

3 Click the Shortcut tab.

4 In the Start In box, enter the path of the folder that should be the default
when you open or save drawing files.
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5 Click OK.

To enable support for large object size limits

1 Click the Application button, and click Options.

2 In the Options dialog box, Open and Save tab, under File Save, clear
Maintain Drawing Size Compatibility.

3 Click OK.

Command entry: OPTIONS, LARGEOBJECTSUPPORT

Quick Reference

Commands

CLOSE

Closes the current drawing.

CLOSEALL

Closes all currently open drawings.

ETRANSMIT

Packages a set of files for Internet transmission.

OPEN

Opens an existing drawing file.

OPTIONS

Customizes the program settings.

WHOHAS

Displays ownership information for opened drawing files.

System Variables

DWGCHECK

Checks drawings for potential problems when opening them.

FILEDIA

Suppresses display of file navigation dialog boxes.
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INDEXCTL

Controls whether layer and spatial indexes are created and saved in drawing
files.

LARGEOBJECTSUPPORT

Controls large object size limit support when you open and save drawings.

OPENPARTIAL

Controls whether a drawing file can be worked on before it is fully open.

REMEMBERFOLDERS

Controls the default path displayed in standard file selection dialog boxes.

ROAMABLEROOTPREFIX

Stores the full path to the root folder where roamable customizable files were
installed.

Utilities

No entries

Command Modifiers

No entries

Open Part of a Large Drawing (Partial Load)
If you work with large drawings, you can improve performance by opening
only the view and layer geometry that you want to work with.

If you work with large drawings, you can use the Partial Open option of the
OPEN command to select which view and layer geometry (graphical objects
only) that you want to work with in a drawing. For example, if you load
geometry from the EXTENTS view and the SITE layer, everything on the SITE
layer that falls within the Extents view is loaded into the drawing.

You can only edit what is loaded into the drawing file, but all the drawing's
named objects are available in the partially open drawing. Named objects
include layers, views, blocks, dimension styles, text styles, viewport
configurations, layouts, UCSs, and linetypes.

By organizing large drawings into sectored views, you can load and edit only
what you need. For example, if you work with a city plan and need to edit
only the southeast sector (sector D3 in the illustration), you can load this
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drawing area by specifying the predefined view. If you need to edit only the
city plot numbers, you can load just the geometry on this specific layer.

After a drawing is partially open, you can load additional geometry from a
view, selected area, or layer into the drawing by using PARTIALOAD. The
Partial Open option is available only for drawings in AutoCAD 2004 or later
format.

To partially open a drawing

1 Click the Application button, and click Open  ➤  Drawing.

2 In the Select File dialog box, select a drawing.

3 Click the arrow next to Open. Click Partial Open.

4 In the Partial Open dialog box, select a view; the default view is EXTENTS.

You can load only geometry from model space views that are saved in
the current drawing.

5 Select one or more layers.

If you do not select a layer or layers to load, no layer geometry is loaded
into the drawing but all drawing layers exist in the drawing. If no layer
geometry is specified to load into the drawing, no geometry is loaded
even if the geometry from a view is specified to load. If you draw objects
on a layer that is not loaded, you may be drawing on top of existing
geometry that is not loaded in the drawing.
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NOTE Xref-dependent layers are displayed in the Layer Geometry to Load
list only if the selected drawing was last saved with the VISRETAIN system
variable set to 1. Any layers created in the xref since the xref was loaded into
the drawing are not displayed in the Layer Geometry to Load list.

6 If the drawing contains a spatial index, you can select the Use Spatial
Index option.

A spatial index is a list that organizes objects based on their location in
space. A spatial index is used to locate the portion of the drawing that is
read; this minimizes the time required to open the drawing.

7 If the drawing contains xrefs but you don't want to load them, select
Unload All Xrefs on Open.

NOTE If you partially open a drawing that contains a bound xref, only the
portion of the xref that is loaded (defined by the selected view) is bound to
the partially open drawing.

8 Click Open.

You can choose to load additional information into the current drawing
as long as the drawing is partially open.

Menu: Click File ➤ Open
Command entry: PARTIALOPEN

To load additional geometry into a partially open drawing

1 Click File menu ➤ Partial Load.

NOTE The Partial Load option is available only if the current drawing is a
partially open drawing.

2 In the Partial Load dialog box, select a view, or click Pick Window to
define a view.

The default view is Extents. You can load only geometry from model
space views that are saved in the current drawing.

3 Select one or more layers.

If you do not select a layer or layers to load, no layer geometry is loaded
into the drawing, but all drawing layers exist in the drawing. If no layer
geometry is specified to load into the drawing, no geometry is loaded
even if the geometry from a view is specified to load. If you draw objects
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on a layer that is not loaded, you may be drawing on top of existing
geometry that is not loaded in the drawing. You cannot unload any
geometry that is loaded in the current drawing.

4 Click Open.

Command entry: PARTIALOAD

Quick Reference

Commands

PARTIALOAD

Loads additional geometry into a partially opened drawing.

PARTIALOPEN

Loads geometry and named objects from a selected view or layer into a
drawing.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Work with Multiple Open Drawings
You can preview and switch between open drawings and layouts in a drawing
and transfer information between open drawings.

Preview Open Drawings and Layouts
With Quick View, you can easily preview and switch between open drawings
and the model space and layouts in an open drawing. These are displayed in
thumbnail images called Quick View images at the bottom of the application
window.
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The Quick View tools in the application status bar do the following:

■ Quick View Drawings 
Displays all currently open drawings in a row of Quick View drawing
images. You can also preview and switch between the model space and
layouts in an open drawing when you move your cursor over a Quick View
drawing image. For more information, see Switch Between Open Drawings
on page 211.

■ Quick View Layouts 
Displays the model space and layouts in the current drawing in a row of
Quick View layout images. You can right-click a Quick View layout image
to view layout options. For more information, see Switch Between Layouts
in the Current Drawing on page 217.

The supported file formats are DWG, DWT, DXF, and DWS.

NOTE The application status bar must be displayed to view the Quick View tools.

Quick Reference

Commands

QVDRAWING

Displays open drawings and layouts in a drawing in preview images.

QVDRAWINGCLOSE

Closes preview images of open drawings and layouts in a drawing.

QVLAYOUT

Displays preview images of model space and layouts in a drawing.

QVLAYOUTCLOSE

Closes preview images of model space and layouts in a drawing.

System Variables

STATUSBAR

Controls the display of the application and drawing status bars.
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Utilities

No entries

Command Modifiers

No entries

Switch Between Open Drawings
Preview and switch between all open drawings and layouts in a drawing in
two-level structure with the Quick View Drawings tool.

The first level displays the Quick View images of open drawings and the second
level displays the images for model space and all layouts in a drawing.

When you click the Quick View Drawings button on the status bar, each open
drawing displays as a thumbnail image in a row. The image of the current
drawing is highlighted by default. If you move your cursor over an image, all
the layouts and the model for that drawing are displayed in a row of images
above the Quick View drawing.

The toolbar displayed below the Quick View drawings has the following
options:

■ Pin Quick View Drawings
Pins the row of Quick View images of drawings so that it is always visible
while you are working in the drawing editor.

■ New
Creates a drawing that is also displayed at the end of the Quick View images
row.

■ Open
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Opens an existing drawing that is also displayed at the end of the Quick
View images row.

■ Close
Closes all the Quick View images.

You can do any of the following with the Quick View Drawings tool:

■ Click a Quick View drawing image to make that drawing current.

■ Move your cursor over the Quick View drawing image to display the Save
and Close buttons on the top corners of the image to save or close the
drawing.

■ Move your cursor over a Quick View drawing to display the preview images
of the model space and layouts in the drawing.

■ Close all drawings, except the drawing you want to work on, from the
shortcut menu.

■ Close and save all open drawings.

■ Manage the display of the drawings in the windows to be tiled vertically
or horizontally, or cascaded.

You can access more options for layouts from the Quick View layout image.
For more information, see Switch Between Layouts in the Current Drawing
on page 217.

If a row of Quick View images extends beyond the application display area,
scroll arrows display on the left or right side of the row. You can scroll to view
the other images. You can resize Quick View images dynamically using Ctrl
+ scrollwheel.

TIP If you often work with many open drawings or many layouts in a drawing,
you can use multiple monitors to display complete rows of Quick View images.

Update Quick View Images

Quick View images are not updated dynamically when working on it. They
are updated when you switch between the model space and layouts; or use
the UPDATETHUMBSNOW command.

When a drawing does not have a stored image for a model space, a placeholder
image is displayed instead.
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This placeholder image is displayed in the following cases:

■ When the model space is not initialized

■ When the UPDATETHUMBNAIL system variable is set to 0. In this case,
the image is not updated even if you use the UPDATETHUMBSNOW
command.

When a drawing is saved in DXF format, it does not have a stored image for
a drawing. The image is not updated even if you use the UPDATETHUMBSNOW
command. A static image is displayed instead.

To display Quick View drawings

Do one of the following:

■ Click  the status bar

■ At the Command prompt, enter qvdrawing.
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Command entry: QVDRAWING

To preview and switch between open drawings

1 Click  the status bar.

A row of Quick View images is displayed at the bottom of the application.

2 Click the Quick View image you want to work on.

Command entry: QVDRAWING

To preview and switch between layouts in a drawing

1 Click  the status bar.

A row of Quick View images is displayed at the bottom of the application.

2 Move your cursor over a drawing image to preview the model and layouts
in a drawing.

3 Click a Quick View image to make the drawing or layout current.

Command entry: QVDRAWING

To resize a Quick View image

1 On the status bar, click  .

A row of Quick View images is displayed at the bottom of the application.

2 Press Ctrl + scrollwheel over a Quick View image to resize.

Command entry: QVDRAWING

To view Quick View images not displayed in the application display area

1 On the status bar, click  .

A row of Quick View images is displayed at the bottom of the application.

2 Click the left or right scroll arrow to view Quick View images not shown
on the application display area.
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Command entry: QVDRAWING

To pin the row of Quick View images

1 On the status bar, click  .

A toolbar is displayed below the row of Quick View images.

2 On the toolbar, click the Pin Quick View Drawings button  .

The Quick View images are always displayed unless you unpin them. To
unpin, click Pin Quick View Drawings button again.

To create a drawing in Quick View

1 On the status bar, click  .

A toolbar is displayed below the row of Quick View images.

2 On the toolbar, click the New button  .

A new drawing is displayed in a Quick View image.

To open a drawing in Quick View

1 On the status bar, click  .

A toolbar is displayed below the row of Quick View images.

2 On the toolbar, click Open  .

3 In the Select File dialog box, select one or more files.

4 Click Open.

To save a drawing in Quick View

1 On the status bar, click  .
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A row of images is displayed at the bottom of the application.

2 Mouse over the image you want to save.

3 Click  displayed on the Quick View image.

To save all open drawings in Quick View

1 On the status bar, click  .

A row of images is displayed at the bottom of the application.

2 Right-click any Quick View drawing image and click Save All.

To close a drawing in Quick View

1 On the status bar, click  .

A row of images is displayed at the bottom of the application.

2 Right-click the Quick View drawing image you want to close and click
Close.

To close all drawings in Quick View

1 On the status bar, click  .

A row of images is displayed at the bottom of the application.

2 Right-click any Quick View drawing image and click Close All.

To close all drawings except the drawing you want to work on in Quick View

1 On the status bar, click  .

A row of images is displayed at the bottom of the application.

2 Right-click the Quick View image of the drawing you want to work on.
Click Close Other Files.
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Quick Reference

Commands

QVDRAWING

Displays open drawings and layouts in a drawing in preview images.

QVDRAWINGCLOSE

Closes preview images of open drawings and layouts in a drawing.

SYSWINDOWS

Arranges windows and icons when the application window is shared with
external applications.

UPDATETHUMBSNOW

Manually updates thumbnail previews in the Sheet Set Manager and the
Quick View tool.

System Variables

QVDRAWINGPIN

Controls the default display state of preview images of drawings.

UPDATETHUMBNAIL

Controls updating of the thumbnail previews in the Sheet Set Manager and
Quick View.

Utilities

No entries

Command Modifiers

No entries

Switch Between Layouts in the Current Drawing
Preview and switch between the model space and layouts in the current
drawing with the Quick View Layouts tool.

When you click the Quick View Layouts button  on the status bar, the
model space and layouts in the drawing are displayed in a horizontal row.
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You can plot or publish when you move the cursor over a Quick View image
of a layout. The toolbar displayed below the Quick View images of drawings
has the following options:

■ Pin Quick View Layouts
Pins the row of Quick View images of layouts so that it is always visible
while you are working in the drawing editor.

■ New Layout
Creates a layout that is also displayed as a Quick View image at the end of
the row.

■ Publish
Launches the Publish dialog box to publish the layouts.

■ Close Quick View Layouts
Closes all the Quick View layout images.

You can do any of the following with a Quick View layout image:

■ Click the image to display the associated layout or model in the drawing
area

■ Move your cursor over the image to display the Plot and Publish buttons

■ Right-click the image to display a shortcut menu with additional options

■ Use Ctrl + scroll wheel to resize Quick View images dynamically
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TIP If you often work with many open drawings or many layouts in a drawing,
you can use multiple monitors to display complete rows of Quick View images.

If a row of Quick View images extends beyond the application display area,
scroll arrows display on the left or right side of the row. You can scroll to view
the other images.

NOTE The Quick View feature will not be fully functional if the drawing is still
opening and not fully loaded.

Update Quick View Layout Images

Quick View images for layouts are not updated dynamically when working
on a layout. They are updated when you switch between layouts or use the
UPDATETHUMBSNOW command.

When a drawing does not have a stored image for a layout, a placeholder
image is displayed instead.

This placeholder image is displayed in the following cases:

■ When the layout is not initialized

■ When the UPDATETHUMBNAIL system variable is set to 0. In this case,
the image is not updated even if you use the UPDATETHUMBSNOW
command.

To preview model space and layouts in a drawing

■ On the status bar, click  .
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A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

Command entry: QVLAYOUT

To update a thumbnail image

NOTE Verify that updatethumbnail is not set to 0

1 At the Command prompt, enter updatethumbsnow.

This command ensures that thumbnail images are updated.

2 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing
displays at the bottom of the application.

To make a model space or layout current

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 Click a model space or layout image to make it current.

Command entry: QVLAYOUT

To specify the page setup for a layout in Quick View

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 Right-click the Quick View image. Click Page Setup.

Command entry: QVLAYOUT
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To create a layout in Quick View

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application. A toolbar is displayed below
the Quick View images.

2 Do one of the following:

■ Right-click the Quick View image. Click New Layout.

■ On the toolbar, click  .

A Quick View image of a new layout is displayed.

Command entry: QVLAYOUT

To rename a layout in Quick View

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 Double-click the layout name you want to rename.

3 Enter a new name for the layout.

Command entry: QVLAYOUT

To import a layout from a template in Quick View

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 Right-click a Quick View image. Click From Template.

3 In the Select File dialog box, select a DWT or DWG file to import a layout
from. Click Open. In the Insert Layout(s) dialog box, select a layout to
import.
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4 Enter a new name for the layout. Click OK.

Command entry: QVLAYOUT

To arrange layouts in Quick View

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 Right-click the Quick View image you want to move. Click Move or Copy.

3 In the Move or Copy dialog box, select a new position for the model or
layout image that should be placed immediately after the moved or copied
layout. If you want to move the layout tab to the end of the list of layout
tabs, select Move to End.

4 Click OK.

Command entry: QVLAYOUT

To duplicate a layout in Quick View

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 Right-click the Quick View image you want to move. Click Move or Copy.

3 In the Move or Copy dialog box, select a new position for the new layout
image. Click OK.

NOTE This option is not available in model space.

Command entry: QVLAYOUT

To arrange layouts in Quick View

1 On the status bar, click  .
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A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 Right-click the Quick View image you want to move. Click Move or Copy.

3 In the Move or Copy dialog box, select a new position for the model or
layout image that should be placed immediately after the moved or copied
layout. If you want to move the layout tab to the end of the list of layout
tabs, select Move to End.

4 Click OK.

Command entry: QVLAYOUT

To activate the previous layout in Quick View

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 Right-click a Quick View image. Click Activate Previous Layout.

Command entry: QVLAYOUT

To select all layouts in Quick View

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 Right-click a Quick View image. Click Select All Layouts.

Command entry: QVLAYOUT

To export a layout to model space in Quick View

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 Right-click a Quick View image. Click Export Layout to a Model.
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3 In the Export Layout to Model Space Drawing dialog box, enter a name
for the new file. Click Save.

Command entry: QVLAYOUT

To plot a layout in Quick View

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 On the top-left corner of a layout image, click  .

3 In the Plot dialog box, select the plot settings. Click OK.

Command entry: QVLAYOUT

To publish a layout in Quick View

1 On the status bar, click  .

A row of Quick View images of model space and layouts in a drawing is
displayed at the bottom of the application.

2 On the top-left corner of a layout image, click  .

3 In the Publish dialog box, select the publish settings. Click OK.

Command entry: QVLAYOUT

Quick Reference

Commands

PLOT

Plots a drawing to a plotter, printer, or file.
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PUBLISH

Publishes drawings to DWF, DWFx, and PDF files, or to plotters.

QVLAYOUT

Displays preview images of model space and layouts in a drawing.

QVLAYOUTCLOSE

Closes preview images of model space and layouts in a drawing.

UPDATETHUMBSNOW

Manually updates thumbnail previews in the Sheet Set Manager and the
Quick View tool.

System Variables

QVLAYOUTPIN

Controls the default display state of preview images of model space and
layouts in a drawing.

UPDATETHUMBNAIL

Controls updating of the thumbnail previews in the Sheet Set Manager and
Quick View.

Transfer Information between Open Drawings
You can easily transfer information between drawings that are open in a single
session.

When you open multiple drawings in a single session, you can

■ Reference other drawings.

■ Copy and paste between drawings.

■ Drag selected objects from one drawing to another with the right-click
button on your pointing device.

■ Use Match Properties (MATCHPROP) to copy properties from objects in
one drawing to objects in another drawing.

■ Use object snaps, the Copy with Basepoint (COPYBASE) command, and
the Paste to Original Coordinates (PASTEORIG) command to ensure
accurate placement.
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To switch between open drawings

Do one of the following to switch between open drawings:

■ On the status bar, click the Quick View Drawings tool. 

■ Click anywhere in a drawing to make it active.

■ Use Ctrl+F6 or Ctrl+Tab.

Command entry: TASKBAR

To display multiple open drawings on the Windows taskbar

1 At the Command prompt, enter taskbar, and then enter 1.

2 To switch between drawings, press Alt+Tab.

Command entry: TASKBAR

To display only the active drawing on the Windows taskbar

■ At the Command prompt, enter taskbar, and then enter 0.

Command entry: TASKBAR

Quick Reference

Commands

OPTIONS

Customizes the program settings.

TASKBAR

Controls how drawings are displayed on the Windows taskbar.

Save a Drawing
You save drawing files for later use just as you do with other Microsoft
Windows applications. You can also set up automatic saving and backup files
and save only selected objects.
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When you work on a drawing, you should save it frequently. Saving protects
you from losing work in the event of a power failure or other unexpected
event. If you want to create a new version of a drawing without affecting the
original drawing, you can save it under another name.

The file extension for drawing files is .dwg, and unless you change the default
file format in which drawings are saved, drawings are saved in the latest
drawing file format. This format is optimized for file compression and for use
on a network.

The character limit for a DWG file name (including its path) is 256 characters.

NOTE If the FILEDIA system variable is set to 0, the Command prompt version
displays instead of a file navigation dialog box.

Save Part of a Drawing File

If you want to create a new drawing file from part of an existing drawing, you
use the WBLOCK command. With the command, you can select objects or
specify a block definition in your current drawing and save them to a new
drawing file. You can also save a description with the new drawing.

Save to a Different Type of Drawing File

You can save a drawing to an earlier version of the drawing format (DWG) or
drawing interchange format (DXF), or save a drawing as a template file. Choose
the format from Files of Type in the Save Drawing As dialog box.

Save with Visual Fidelity for Annotative Objects

When working with annotative on page 1923 objects, this option allows you to
maintain visual fidelity for these objects when they are viewed in AutoCAD
2007 and earlier releases. Visual fidelity is controlled by the SAVEFIDELITY
system variable.

If you work primarily in model space, it is recommended that you turn off
visual fidelity (set SAVEFIDELITY to 0). However, if you need to exchange
drawings with other users, and layout fidelity is most important, then visual
fidelity should be turned on (set SAVEFIDELITY to 1).

NOTE The SAVEFIDELITY system variable does not effect saving a drawing to the
AutoCAD 2010 drawing or DXF file formats.

Annotative objects may have multiple scale representations on page 1950. When
visual fidelity is on, annotative objects are decomposed and scale
representations are saved (in an anonymous block on page 1923) to separate
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layers, which are named based on their original layer and appended with a
number. If you explode the block in AutoCAD 2007 or earlier releases, and
then open the drawing in AutoCAD 2008 or later releases, each scale
representation becomes a separate annotative object, each with one annotation
scale. It is not recommended that you edit or create objects on these layers
when working with a drawing created in AutoCAD 2008 and later releases in
AutoCAD 2007 and earlier releases.

When this option is not selected, a single model space representation is
displayed on the Model tab. More annotation objects may be displayed on
the Model tab depending on the ANNOALLVISIBLE setting. Also, more objects
may be displayed in paper space viewports at different sizes than in AutoCAD
2008 and later releases.

Reduce the Time Required to Save a Drawing File

You can reduce the time required to save a drawing file if you specify
incremental saves rather than full saves. An incremental save updates only
those portions of the saved drawing file that you changed.

When you use incremental saves, drawing files will contain a percentage of
potentially wasted space. This percentage increases after each incremental
save until it reaches a specified maximum, at which time a full save is
performed instead. You can set the incremental save percentage in the Open
and Save tab of the Options dialog box or by setting the value of the system
variable ISAVEPERCENT. If you set the value of ISAVEPERCENT to 0, all saves
are full saves.

To reduce the size of drawing files, it is recommended that you perform a full
save (with ISAVEPERCENT set to 0) before transmitting or archiving a drawing.

Work Internationally

If you share drawing files with companies in other countries and regions, the
drawing file names might contain characters that are not used in other
languages.

If a drawing file is created in a different language version of Windows, the
following will occur:

■ If support for the language is installed, the file name characters are visible
in Windows Explorer.

■ If support for the language is not installed, the file name characters appear
as a series of boxes in Windows Explorer and a dialog box is displayed
offering to install the language pack.
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In either case, you will be able to open the drawing file beginning with
AutoCAD 2007 or AutoCAD LT 2007 because these products are
Unicode-compliant applications.

NOTE If you share drawing files with companies using earlier releases of the
product, you can avoid file name issues for Asian languages and languages that
use accented characters. In those circumstances, do not use high ASCII values, or
values of 80 hexadecimal and above, when creating a file name.

Maintain Compatibility with Large Object Limits

Drawings saved to a legacy drawing file format (AutoCAD 2007 or earlier) do
not support objects greater than 256MB. With the AutoCAD 2010 drawing
file format, these limitations have been removed allowing you to save objects
that are greater in size.

When saving to a legacy drawing file format (AutoCAD 2007 or earlier), the
drawing cannot contain large objects; there might be compatibility issues with
trying to open the drawing. The LARGEOBJECTSUPPORT system variable
controls the large object size limits used and the warning messages displayed
when a drawing is saved.

The following explains how object size limits for drawings is determined:

■ Drawing files cannot exceed an internal size limit of 4GB. This size is based
on the total size of all objects in a drawing when uncompressed. Since a
drawing file is normally compressed, the final size of a saved drawing file
on disk will vary based on the size and number of objects in a drawing.

■ Each individual object in a drawing cannot exceed an uncompressed size
limit of 256MB. For example, a mesh object, when saved to a file and
compressed, might be 75MB in size while the same object when
uncompressed might be 257MB.

In these situations, the drawing cannot be saved to an AutoCAD 2007 or earlier
file format until the issues are resolved. You can resolve the size limits by
breaking the drawing or objects up into several drawings or objects.

NOTE When working with the 64-bit release of AutoCAD, you can work more
efficiently with large objects and drawings. However, the drawing files you create
might be too large to open with the 32-bit release of AutoCAD.

See also:

■ Save Drawings to Previous Drawing File Formats
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■ Work with Drawings in Earlier Releases

■ Export Drawings to Other File Formats

■ Create Drawing Files for Use as Blocks on page 858

■ Add Identifying Information to Drawings on page 188

■ Create and Restore Backup Files on page 243

■ Share Drawing Files Internationally

■ Open and Save Drawing Files from the Internet

To save a drawing

1 Click File menu ➤ Save.

If you previously saved and named the drawing, any changes made are
saved and the Command prompt is redisplayed. If you have never saved
the drawing, the Save Drawing As dialog box is displayed.

2 In the Save Drawing As dialog box, under File Name, enter the new
drawing name; the file extension is not required. Click Save.

Command entry: SAVE

Toolbar: Standard  

To save a drawing automatically

1 Click the Application button. At the bottom of the Application menu,
click the Options button.

2 In the Options dialog box, Open and Save tab, select Automatic Save.

3 Enter a number in Minutes Between Saves. Click OK.

Command entry: OPTIONS

To save a backup of the previous version every time the drawing is saved

1 Click the Application button. At the bottom of the Application menu,
click the Options button.
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2 In the Options dialog box, Open and Save tab, select Create Backup Copy
with Each Save. Click OK.

Command entry: OPTIONS

To save selected objects into a new drawing file

1 At the Command prompt, enter wblock.

2 In the Write Block dialog box, under Objects, select Objects.

3 Under Base Point, click Pick Point.

4 Specify the base point in the drawing area, or enter coordinate values in
the X, Y, and Z boxes.

5 Under Objects, click the Select Objects button.

6 Select the objects in the drawing area.

7 Under Objects, select an option to indicate whether you want to retain,
convert, or delete the selected objects.

8 In the File Name box, enter the name for the new drawing file.

9 In the Location box, specify the folder for the new drawing file.

10 In the Insert Units box, you can select a different base unit. This option
provides a method to scale objects automatically in the new drawing file.

11 Click OK.

The objects you selected in the drawing are saved in a new drawing file.

Command entry: WBLOCK

To save a block definition as a new drawing file

1 At the Command prompt, enter wblock.

2 In the Write Block dialog box, select Block.

3 Click in the box next to Block. Select the block definition you want to
save.

4 In the File Name box, enter the name for the new drawing file.

5 In the Location box, specify the folder for the new drawing file.
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6 In the Insert Units box, you can select a different base unit. This option
provides a method to scale objects automatically in the new drawing file.

7 Click OK.

The objects in the specified block definition are saved as objects in a new
drawing file. The insertion base point of the block definition will be
located at the origin point (0,0,0) in the new drawing.

Command entry: WBLOCK

To maintain visual fidelity for annotative objects

1 Click the Application button, and click Options.

2 In the Options dialog box, Open and Save tab, under File Save, select
Maintain Visual Fidelity for Annotative Objects.

3 Click OK.

Command entry: OPTIONS, SAVEFIDELITY

To maintain large object compatibility with legacy drawing file formats

1 Click the Application button, click Options.

2 In the Options dialog box, Open and Save tab, under File Save, select
Maintain Drawing Size Compatibility.

3 Click OK.

Command entry: OPTIONS, LARGEOBJECTSUPPORT

Quick Reference

Commands

BLOCK

Creates a block definition from selected objects.

OPTIONS

Customizes the program settings.
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QSAVE

Saves the current drawing using the file format specified in the Options dialog
box.

QUIT

Exits the program.

SAVE

Saves the drawing under the current file name or a specified name.

SAVEAS

Saves a copy of the current drawing under a new file name.

WBLOCK

Writes objects or a block to a new drawing file.

System Variables

DWGCHECK

Checks drawings for potential problems when opening them.

DWGNAME

Stores the name of the current drawing.

DWGPREFIX

Stores the drive and folder prefix for the drawing.

DWGTITLED

Indicates whether the current drawing has been named.

FILEDIA

Suppresses display of file navigation dialog boxes.

ISAVEBAK

Improves the speed of incremental saves, especially for large drawings.

ISAVEPERCENT

Determines the amount of wasted space tolerated in a drawing file.

LARGEOBJECTSUPPORT

Controls large object size limit support when you open and save drawings.
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RASTERPREVIEW

Controls whether BMP preview images are saved with the drawing.

SAVEFIDELITY

Controls whether the drawing is saved with visual fidelity.

SAVEFILE

Stores the current automatic save file name.

SAVEFILEPATH

Specifies the path to the directory for all automatic save files for the current
session.

SAVENAME

Displays the file name and directory path of the most recently saved drawing.

SAVETIME

Sets the automatic save interval, in minutes.

Find a Drawing File
You can search for a drawing using name, location, and date filters, properties
such as keywords that you added to the drawing, or text strings containing a
specific word or phrase.

■ Use the Search tool in Microsoft® Windows® to search for drawings using
name, location, and date filters. You can also specify a word or phrase
contained in the drawing file. You can search for all textual data except
text in tables and fields, and xrefs within drawing files. Supported drawing
file types include DWG, DWF, DWT, and DWS.

■ Use the Search dialog box for DesignCenter™ to search for Microsoft
Windows file properties, such as title or keyword, that you added to
drawings.

■ Use the Select File dialog box for the OPEN command to display drawing
file previews. When the RASTERPREVIEW system variable is on, a raster
preview image is automatically generated and stored with the drawing
when you save it.

See also:

■ Add Identifying Information to Drawings on page 188
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■ Access Content with DesignCenter on page 92

■ Work with Sheets in a Sheet Set on page 479

To search for files

1 Click the Application button, and click Open  ➤  Drawing.

2 In the Select File dialog box, click Tools  ➤ Find

3 In the Find dialog box, Name & Location tab, specify a file type, file name,
and path.

You can use wild cards when specifying a file name.

4 On the Date Modified tab, click All Files, or click Find All Files Created
or Modified to specify a date filter.

You can search for drawings modified between a specified range of dates
or within a specified number of months or days.

5 Click Find Now.

6 Select one or more files from the search results. Click OK.

7 In the Select File dialog box, click Open.

Command entry: OPEN
Menu: File  ➤  Open

Toolbar: Standard  

Quick Reference

Commands

OPEN

Opens an existing drawing file.

Specify Search Paths and File Locations
You can set the search path to drawing support files such as text fonts,
drawings, linetypes, and hatch patterns. You also can specify the location of
temporary files, which is important when working in a network environment.
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The Files tab of the Options dialog box is where you set the search path that
is used by the program to find drawing support files such as text fonts,
drawings, linetypes, and hatch patterns. The MYDOCUMENTSPREFIX system
variable stores the location of the My Documents folder for the current user.

The working search path for drawing support files lists paths that are valid
and exist in the current system folder structure (including system network
mapping). Using these options helps improve performance when these files
are loaded.

Using the Files tab of the Options dialog box, you can also specify the location
of temporary files. Temporary files are created on disk, and then deleted when
you exit the program. The temporary folder is set to the location that Microsoft
Windows uses. If you plan to run this program from a write-protected folder
(for example, if you work on a network or open files on a CD), specify a
different location for your temporary files.

The temporary folder that you specify must not be write-protected, and the
drive containing the folder should have sufficient disk space for the temporary
files. It is recommended that you manually delete the files from this folder
on a regular basis to ensure sufficient space is provided for temporary files. If
not enough space is available for temporary files, you may experience errors
or instability in the program.

If you want to use a file that contains custom interface elements, specify it in
the Customizations Files item on the Files tab of the Options dialog box. The
default customization file is acad.cuix.

To change a search path

1 Click the Application button. At the bottom of the Application menu,
click the Options button.

2 In the Options dialog box, Files tab, click the plus sign (+) to the left of
the kind of path you want to change.

3 Select the path you want to change.

4 Click Browse, and then search drives and folders until you find the one
you want.

5 Select the drive and folder that you want to use. Click OK.

Command entry: OPTIONS
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Quick Reference

Commands

OPTIONS

Customizes the program settings.

System Variables

MYDOCUMENTSPREFIX

Stores the full path to the My Documents folder for the user currently logged
on.
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Repair, Restore, or Recover
Drawing Files

If a drawing file is damaged or if your program terminates unexpectedly, you can recover
some or all of the data by using commands to find and correct errors, or by reverting to a
backup file.

Repair a Damaged Drawing File
If a drawing file is damaged, you can recover some or all of the data by using
commands to find and correct errors.

Repair and Recovery

When an error occurs, diagnostic information is recorded in the acad.err file,
which you can use to report a problem.

A drawing file is marked as damaged if corrupted data is detected, or if you
request that the drawing be saved after a program failure. If the damage is minor,
sometimes you can repair the drawing simply by opening it. Otherwise, you
can use the following:

■ RECOVER. Performs an audit on, and attempts to open, any drawing file.

■ RECOVERALL. Similar to recover, it additionally operates on all nested xrefs.
The results are displayed in the Drawing Recovery Log window.

■ AUDIT. Finds and corrects errors in the currently open drawing file.

Example: Auditing Files

Auditing a file generates a description of problems with a drawing file and
recommendations for correcting them. As you start the audit, you specify

7
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whether you want the program to try to fix the problems it encounters. The
report is similar to the following example:

Auditing Header
DXF NAME Current Value Validation Default
PDMODE 990 - 2040
UCSFOLLOW 811 or 0
Error found in auditing header variables
4 Blocks audited
Pass 1 4 objects audited
Pass 2 4 objects audited
Total errors found 2 fixed 2

If you chose not to correct the errors, the last statement changes to

Total errors found 2 fixed 0.

The output from a recovery audit is written to an audit log (ADT) file if the
AUDITCTL system variable is set to 1 (On).

Recovery does not necessarily preserve the high-level consistency of the
drawing file. The program extracts as much material as it can from the damaged
file.

To repair a damaged drawing file

1 Click the Application button, and click Drawing Utilities  ➤  Recover  ➤ 

Recover. 

2 In the Select File dialog box, select a file. Click Open.

After the audit, all objects with errors are placed in the Previous selection
set for easy access. The output from the audit is written to an audit log
(ADT) file if the AUDITCTL system variable is set to 1 (On).

Command entry: RECOVER, RECOVERALL

To repair a damaged drawing file due to a system failure

1 If the program encounters a problem and cannot continue, it displays
an error message and, for some errors, an error code. Record the error
code number, save the changes if possible, and exit to the operating
system.

2 Restart the program.
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3 In the Drawing Recovery window, under Backup Files, double-click the
drawing node to expand it. On the list, double-click one of the drawing
or backup files to open it.

If the program detects that the drawing has been damaged, a message is
displayed asking if you want to proceed.

4 Enter y to proceed.

As the program attempts to repair the drawing, a diagnostic report is
displayed. The output from the audit is written to an audit log (ADT) file
if the AUDITCTL system variable is set to 1 (On).

5 Depending on whether the repair is successful, do one of the following:

■ If the repair is successful, the drawing opens. Save the drawing file.

■ If the program cannot repair the file, a message is displayed. In that
case, choose one of the other drawing or backup files listed in the
Drawing Recovery window beginning with step 3.

Command entry: RECOVER

To repair an open drawing

1 Click the Application button, and click Drawing  ➤  Audit. 

2 At the Fix Any Errors Detected? prompt, enter y or n.

AUDIT places all objects with errors in the Previous selection set for easy
access. The output from the audit is written to an audit log (ADT) file if
the AUDITCTL system variable is set to 1 (On).

NOTE If the drawing contains errors that AUDIT cannot fix, try using
RECOVER. RECOVER repairs any specified DWG file that is not the current
drawing file.

Command entry: AUDIT

To restore a drawing from a backup file

1 In Windows Explorer, locate the backup file identified by the .bak file
extension.

2 Right-click the backup file. Click Rename.
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3 Type a new name using the .dwg file extension.

4 Open the file as you would open any other drawing file.

Quick Reference

Commands

AUDIT

Evaluates the integrity of a drawing and corrects some errors.

DRAWINGRECOVERY

Displays a list of drawing files that can be recovered after a program or system
failure.

OPTIONS

Customizes the program settings.

RECOVER

Repairs and then opens a damaged drawing file.

RECOVERALL

Repairs and then opens a damaged drawing file.

System Variables

AUDITCTL

Controls whether AUDIT creates an audit report (ADT) file.

REPORTERROR

Controls whether an error report can be sent to Autodesk if the program
closes unexpectedly.

242 | Chapter 7   Repair, Restore, or Recover Drawing Files



Utilities

No entries

Command Modifiers

No entries

Create and Restore Backup Files
Backup files help ensure the safety of your drawing data. If a problem occurs,
you can restore a drawing backup file.

Computer hardware problems, power failures or surges, user mistakes, or
software problems can cause errors in a drawing. By saving your work
frequently, you can ensure a minimum of lost data if your system fails for any
reason. If a problem occurs, you can restore a drawing backup file.

Use Backup Files

In the Options dialog box, on the Open and Save tab, you can specify that
backup files are created when you save drawings. If you do, each time you
save a drawing, the previous version of your drawing is saved to a file with
the same name and a .bak file extension. The backup file is located in the same
folder as the drawing file.

You can revert to your backup version by renaming the .bak file in Windows
Explorer to a file with a .dwg extension. You may want to copy it to a different
folder to avoid overwriting your original file.

Save Your Drawing Automatically at Specified Intervals

If you turn the automatic save option on, your drawing is saved at specified
time intervals. By default, files saved automatically are temporarily assigned
the name filename_a_b_nnnn.sv$.

■ Filename is the current drawing name.

■ a is the number of open instances of the same drawing file in the same
work session.

■ b is the number of open instances of the same drawing in different work
sessions.

■ nnnn is a random number.
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These temporary files are automatically deleted when a drawing closes
normally. In the event of a program failure or a power failure, these files are
not deleted.

To recover a previous version of your drawing from the automatically saved
file, rename the file using a .dwg extension in place of the .sv$ extension before
you close the program.

See also:

■ Recover from a System Failure on page 245

To restore a drawing from a backup file

1 In Windows Explorer, locate the backup file identified by the .bak file
extension.

2 Select the file you want to rename. You do not need to open it.

3 Click File menu  ➤  Rename

4 Enter a new name using the .dwg file extension.

5 Open the file as you would open any other drawing file.

Quick Reference

Commands

OPTIONS

Customizes the program settings.

System Variables

ISAVEBAK

Improves the speed of incremental saves, especially for large drawings.
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Utilities

No entries

Command Modifiers

No entries

Recover from a System Failure
A hardware problem, power failure, or software problem can cause this program
to terminate unexpectedly. If this happens, you can restore the drawing files
that were open.

If the program fails, you can save your current work to a different file. This
file uses the format, DrawingFileName_recover.dwg, where DrawingFileName is
the file name of your current drawing.

Resolve Drawing Files

After a program or system failure, the Drawing Recovery Manager opens the
next time you start AutoCAD. Drawing Recovery Manager displays a list of all
drawing files that were open, including the following drawing file types:

■ Drawing files (DWG)

■ Drawing template files (DWT)

■ Drawing Standards files (DWS)

NOTE Unsaved drawings that are open at the time of an unexpected failure are
not tracked by the Drawing Recovery Manager. Be sure to save your work after
you begin, and regularly thereafter.

For each drawing, you can open and choose from the following files if they
exist:

■ DrawingFileName_recover.dwg

■ DrawingFileName_a_b_nnnn.sv$

■ DrawingFileName.dwg

■ DrawingFileName.bak
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NOTE The drawing, backup, and recover files are listed in the order of their time
stamps—the time when they were last saved.

Double-click a top-level drawing node listed under Backup Files to display up
to four files as listed above. Right-click any node under Backup Files to display
shortcut menu options.

If you close the Drawing Recovery window before resolving all affected
drawings, you can open Drawing Recovery at a later time with the
DRAWINGRECOVERY command.

Send an Error Report Automatically to Autodesk

If the program encounters a problem and closes unexpectedly, you can send
an error report to help Autodesk diagnose problems with the software. The
error report includes information about the state of your system at the time
the error occurred. You can also add other information, such as what you were
doing at the time of the error. The REPORTERROR system variable controls
whether the error-reporting feature is available.

To open the Drawing Recovery Manager

■ Click the Application button, and click Drawing Utilities  ➤  Open the

Drawing Recovery Manager. 
Any drawings that need to be restored from an unexpected program or
system failure are listed under Backup Files.

Command entry: DRAWINGRECOVERY

To restore a drawing using the Drawing Recovery Manager

1 If necessary, click the Application button, and click Drawing Utilities  ➤ 

Open the Drawing Recovery Manager. 

2 In the Drawing Recovery Manager, under Backup Files, double-click a
drawing node to list all available drawing and backup files.

3 Double-click a file to open it.

If the drawing file is damaged, the drawing is automatically repaired, if
possible.
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Command entry: DRAWINGRECOVERY

To remove a drawing from the Drawing Recovery Manager

1 If necessary, click the Application button, and click Drawing Utilities  ➤ 

Open the Drawing Recovery Manager. 

2 Do one of the following:

■ Restore the drawing and then save it.

■ Right-click a drawing node. Click Remove.

Command entry: DRAWINGRECOVERY

To expand or collapse all nodes in the Drawing Recovery Manager

■ Under the last drawing node listed, right-click in the Backup Files area.
Click Collapse All.

Command entry: DRAWINGRECOVERY

To turn error reporting on or off

1 At the command prompt, enter reporterror.

2 Enter 0 to turn off error reporting, or enter 1 to turn on error reporting.

Quick Reference

Commands

DRAWINGRECOVERY

Displays a list of drawing files that can be recovered after a program or system
failure.

DRAWINGRECOVERYHIDE

Closes the Drawing Recovery Manager.

OPTIONS

Customizes the program settings.
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RECOVER

Repairs and then opens a damaged drawing file.

System Variables

DRSTATE

Indicates whether the Drawing Recovery Manager window is open or closed.

ISAVEBAK

Improves the speed of incremental saves, especially for large drawings.

RECOVERYMODE

Controls whether drawing recovery information is recorded after a system
failure.

REPORTERROR

Controls whether an error report can be sent to Autodesk if the program
closes unexpectedly.

Utilities

No entries

Command Modifiers

No entries
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Maintain Standards in
Drawings

Drawings are easier to interpret if you set standards to enforce consistency. You can set
standards for layer names, dimension styles, and other elements; check drawings against these
standards; and then change any properties that do not conform.

Overview of CAD Standards
You can create a standards file to define common properties in order to maintain
consistency throughout your drawing files. Standards define a set of common
properties for named objects such as layers and text styles. You or your CAD
manager can create, apply, and audit standards in drawings to enforce
consistency. Because standards make it easier for others to interpret drawings,
standards are particularly useful in collaborative environments, where many
individuals contribute to the creation of a drawing.

Named Objects for Standards-Checking

You can create standards for the following named objects:

■ Layers

■ Text styles

■ Linetypes

■ Dimension styles

8
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Standards File

After you define standards, you save them as a standards file. You can then
associate the standards file with one or more drawing files. After you associate
a standards file with a drawing, you should periodically check the drawing to
make sure it conforms with the standards.

How a Standards Audit Works

When you check a drawing for standards violations, each named object of a
specific type is checked against the standards files associated with the drawing.
For example, each layer in the drawing is checked against the layers in the
standards file.

A standards audit can uncover two types of problems:

■ An object with a nonstandard name is present in the drawing being
checked. For example, a layer named WALL is present in the drawing but
not in any associated standards files.

■ A named object in a drawing matches the name of one in a standards file,
but their properties are different. For example, in the drawing the WALL
layer is yellow, but the standards file specifies red for the WALL layer.

When you fix objects with nonstandard names, the nonstandard objects are
purged from the drawing. Any drawing objects that are associated with the
nonstandard object are transferred to a replacement standard object that you
specify. For example, you fix a nonstandard layer, WALL, and replace it with
the standard ARCH-WALL. In this example, choosing Fix in the Check
Standards dialog box transfers all objects from layer WALL to layer ARCH-WALL
and then purges layer WALL from the drawing.

Standards Plug-Ins

The auditing process uses standards plug-ins, applications that define the rules
for the properties that are checked for individual named objects. Layers,
dimension styles, linetypes, and text styles are each checked against their
corresponding plug-ins. You can specify which plug-ins to use when checking
a drawing for standards violations. Autodesk or third-party developers may
add standards plug-ins for checking additional drawing properties.

All plug-ins check all properties for each named object except for the layer
plug-in. The following layer properties are checked when using the layer
plug-in:

■ Color
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■ Linetype

■ Lineweight

■ Plot style mode

■ Plot style name (when the PSTYLEMODE system variable is set to 0)

The following layer properties are not checked by the layer plug-in:

■ On/Off

■ Freeze/Thaw

■ Lock

■ Plot/No Plot

Standards Settings

A variety of settings that may be useful to CAD managers are available in the
CAD Standards Settings dialog box. This dialog box can be accessed by clicking
Settings in the Check Standards and Configure Standards dialog boxes.

Quick Reference

Commands

CHECKSTANDARDS

Checks the current drawing for standards violations.

STANDARDS

Manages the association of standards files with drawings.

System Variables

STANDARDSVIOLATION

Specifies whether a user is notified of standards violations in the current
drawing when a nonstandard object is created or modified.

Utilities

Batch Standards Checker

Audits a set of drawings for standards violations.
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Command Modifiers

No entries

Define Standards
To set standards, you create a file that defines properties for layers, dimension
styles, linetypes, and text styles, and you save it as a standards file with the
.dws file name extension.

Depending on how you organize your projects, you may decide to create and
associate more than one project-specific standards file with an individual
drawing. When you audit the drawing file, conflicts may arise between settings
in the standards files. For example, one standards file specifies that the layer
WALL is yellow, and another standards file specifies that it is red. In the case
of conflicts, the first standards file associated with the drawing takes
precedence. If necessary, you can change the order of the standards files to
change the precedence.

If you want to audit drawings using just a specific plug-in, you can specify the
plug-in when defining your standards file. For example, if recent changes to
a drawing are limited to text changes, you may want to audit the drawing
using only the layers and text styles plug-ins to save time. By default, all
plug-ins are used when auditing drawings for standards violations.

To create a standards file

1 Click the Application button, and click New menu  ➤  Drawing. 

2 Enter a template file name, or press Enter to continue.

3 In a new drawing, create any layers, dimension styles, linetypes, and text
styles that you want to be part of the standards file.

4 Click the Application button, and click Save As  ➤  AutoCAD Drawing
Standards.

DWS files must be saved in the current drawing file format. To create a
DWS file in a previous drawing file format, save the file in the desired
DWG format, and then rename the DWG file using a .dws extension.

5 In File Name, enter a name for the standards file. Click Save.
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To associate a standards file with the current drawing

1 Click Manage tab  ➤  Cad Standards panel  ➤  Configure. 

2 In the Configure Standards dialog box, Standards tab, click the plus (+)
button (Add Standards File).

3 In the Select Standards File dialog box, select a standards file. Click Open.

4 (Optional) Repeat steps 2 and 3 if you want to associate additional
standards files with the current drawing.

5 Click OK.

Command entry: STANDARDS

Toolbar: CAD Standards  

To remove a standards file from the current drawing

1 Click Manage tab  ➤  Cad Standards panel  ➤  Configure. 

2 In the Configure Standards dialog box, Standards tab, select a standards
file in Standards Files Associated with the Current Drawing.

3 Click the X button (Remove Standards File).

4 (Optional) Repeat steps 2 and 3 if you want to remove additional standards
files.

5 Click OK.

Command entry: STANDARDS

Toolbar: CAD Standards  

To change the order of standards files associated with the current drawing

1 Click Manage tab  ➤  Cad Standards panel  ➤  Configure. 
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2 In the Configure Standards dialog box, Standards tab, select the standards
file whose position you want to change in Standards Files Associated with
the Current Drawing.

3 Do one of the following:

■ Click the up arrow button (Move Up) to move the standards file up
one position in the list.

■ Click the down arrow button (Move Down) to move the standards
file down one position in the list.

4 (Optional) Repeat steps 2 and 3 if you want to change the position of
other standards files in the list.

5 Click OK.

Command entry: STANDARDS

Toolbar: CAD Standards  

To specify which standards plug-ins to use when auditing a drawing

1 Click Manage tab  ➤  Cad Standards panel  ➤  Configure. 

2 In the Configure Standards dialog box, Plug-ins tab, do one of the
following:

■ Select the check box for at least one plug-in to audit a drawing for
standards violations.

■ To select all plug-ins, right-click in the Plug-ins list. Click Select All.
(You can clear all plug-ins. Right-click in the Plug-ins list. Click Clear
All.)

3 Click OK.

Command entry: STANDARDS

Toolbar: CAD Standards  
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Quick Reference

Commands

STANDARDS

Manages the association of standards files with drawings.

System Variables

No entries.

Utilities

No entries

Command Modifiers

No entries

Check Drawings for Standards Violations
You can audit a drawing file for violations of standards and then fix violations.
The Batch Standards Checker audits more than one file at a time.

After you associate a standards file with a drawing, you should periodically
check the drawing to make sure it conforms with its standards. This is especially
important when more than one person is updating the drawing file. For
example, in a project with multiple subcontractors, one subcontractor may
create new layers that do not comply with the standards you have defined.
In that case, you need to be able to identify the nonstandard layers and fix
them.

You can use the notification feature to alert users that a standards violation
has occurred while working in a drawing. This feature allows you to fix a
standards violation just after it has occurred, making it easier to create and
maintain drawings that comply with standards.

Check a Single Drawing

You can use the CHECKSTANDARDS command to view all standards violations
in the current drawing. The Check Standards dialog box reports each
nonstandard object, along with any suggested fixes.

You can choose to fix or ignore each reported standards violation. If you ignore
a reported violation, it is flagged in the drawing. You can turn off the display
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of ignored problems so that they are not reported as violations the next time
you audit the drawing.

If no fix is provided for the current standards violation, no item is highlighted
in the Replace With list, and the Fix button is not available. If you fix a
standards violation that is currently displayed in the Check Standards dialog
box, the violation is not removed from the dialog box until you click the Fix
or the Next button.

Once the entire drawing has been audited, the Checking Complete message
is displayed. This message summarizes the standards violations that were
found in the drawing. The message also shows the violations that were fixed
automatically, the violations that were fixed manually, and the violations
that were ignored.

NOTE When a nonstandard layer contains multiple violations (for example, a
violation where there is a nonstandard layer name and one for nonstandard layer
properties), the first violation that is encountered is displayed. Subsequent violations
that exist on the nonstandard layer are not evaluated, and therefore, not displayed.
You will need to run the command again to check for additional violations.

Check Multiple Drawings

You can use the Batch Standards Checker to analyze multiple drawings and
summarize standards violations in an HTML report. To run a batch standards
audit, you must first create a standards check (CHX) file. The CHX file is a
configuration and report file; it contains a list of drawing and standards files,
as well as a report on a standards check.

By default, each drawing is checked against the standards files that are
associated with it. Alternatively, you can override the default and choose
another set of standards files to be used.

After the batch standards audit is complete, you can view an HTML report
with details of the audit. You can also create notes that are included in the
HTML report. This report can be exported and printed. In a collaborative
environment, you can distribute the report to drafters so that they can fix any
problems with their sections.

Use Notification of Standards Violations While Working in a Drawing

You can set options for notification in the CAD Standards Settings dialog box
and with the STANDARDSVIOLATION system variable. If you select Display
Alert upon Standards Violation in the dialog box, then an alert is displayed
when a violation occurs while you work. If you select Display Standards Status
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Bar Icon, an icon is displayed when you open a file associated with a standards
file and when you create or modify nonstandard objects.

By default, if an associated standards file is missing or if a violation occurs
while you work, a pop-up message appears in the lower-right corner of the
application window (the status bar tray).

You should check a drawing for standards violations using the Check Standards
dialog box before using the notification options. This prevents triggering a
notification alert carried over from a previous session. After a drawing has
been checked and fixed, the notification options trigger an alert only if a new
violation occurs.

Display Alerts for Named Objects

If you select Display Alert upon Standards Violation, you are notified of
violations when you create or edit only named objects (linetypes, text styles,
layers, and dimensions). Standards violations that do not affect named objects
do not trigger a notification alert. Also, if a named object was marked as
ignored in the Check Standards dialog box, that object no longer triggers a
notification alert, even though the named object is nonstandard. Changing
nonstandard named objects, such as setting a nonstandard layer as current,
does trigger a notification alert.

After an alert is displayed, you can choose to fix or not fix the violation.
Choosing to fix the violation opens the Check Standards dialog box. If it is
already open, the dialog box addresses the specific violations that just occurred.
You can resume your previous work in the Check Standards dialog box after
you respond to the most recent standards violations. Alternatively, if you do
not want to fix violations when alerted, you can click Do Not Fix to dismiss
the alert.

If you open a drawing that has one or more associated standards files, an
Associated Standards File(s) icon is displayed in the status bar. If an associated
standards file is missing, a Missing Standards File(s) icon is displayed in the
status bar. If you double-click the Missing Standards File(s) icon and then
resolve or dissociate missing standards files, the Missing Standards File(s) icon
is replaced by the Associated Standards File(s) icon.

NOTE If you select Display Alert upon Standards Violation in the Check Standards
dialog box and you fix a violation, you can return to a fixing operation where you
left off. If you select Display Standards Status Bar icon and you click the icon and
fix a violation, you must return to a standards-fixing operation from the beginning.
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To audit a drawing for standards violations

1 Open a drawing that has one or more associated standards files.

An Associated Standards File(s) icon is displayed in the status bar. If an
associated standards file is missing, a Missing Standards File(s) icon is
displayed in the status bar.

NOTE If you click the Missing Standards File(s) icon and then resolve or
dissociate missing standards files, the Missing Standards File(s) icon is replaced
by the Associated Standards File(s) icon.

2 In the drawing with one or more associated standards files, click Manage

tab  ➤ CAD Standards panel  ➤ Check. 

The Check Standards dialog box is displayed with the first standards
violation reported under Problem.

3 Do one of the following:

■ If you want to apply the item selected in the Replace With list to fix
the violation reported under Problem, click Fix. If there is a
recommended fix in the Replace With list, it is preceded by a check
mark. If no recommended fix exists for the current standards violation,
the Fix button is not available.
The Check Standards dialog box automatically displays the next
standards violation under Problem.

■ Manually fix the standards violation. Click the Next button to display
the next violation.

■ Select Mark This Problem as Ignored. Click the Next button to display
the next violation.
Selecting Mark This Problem as Ignored flags the standards violation
so you can prevent it from being displayed the next time you use the
CHECKSTANDARDS command.

■ Click the Next button to display the next violation.

4 Repeat steps 2 and 3 until you have cycled through all standards
violations.

5 Click Close.

Command entry: CHECKSTANDARDS
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Toolbar: CAD Standards  

To turn the display of ignored problems on or off

1 In a drawing with one or more associated standards files, click Manage

tab  ➤ CAD Standards panel  ➤ Check. 

2 In the Check Standards dialog box, click Settings.

3 In the CAD Standards Settings dialog box, select or clear Show Ignored
Problems. Click OK.

Command entry: CHECKSTANDARDS

Toolbar: CAD Standards  

To turn notification for standards violations on or off

1 Click Manage tab  ➤  Cad Standards panel  ➤  Configure. 

2 In the Configure Standards dialog box, click Settings.

3 Do one of the following:

■ To turn off standards notifications, select Disable Standards
Notifications.

■ To be notified by alert, select Display Alert upon Standards Violation.

■ To be notified by the display of an icon in the status bar, select Display
Standards Status Bar Icon.

4 Click OK.

Command entry: STANDARDS

Toolbar: CAD Standards  
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To start the Batch Standards Checker

■ Click Start menu (Windows)  ➤  All Programs  ➤  Autodesk  ➤ 

ProductNameLong ➤ Batch Standards Checker.

NOTE When you start the Batch Standards Checker from a DOS command line
using the DWGCHECKSTANDARDS command, the Batch Standards Checker
accepts a variety of command-line parameters that can be used for scripting batch
standards audits.

To create a standards check file for the Batch Standards Checker

1 Start the Batch Standards Checker.

2 In the Batch Standards Checker, click File menu  ➤ New Check File. (You
can also click New on the Batch Standards Checker toolbar.)

3 On the Drawings tab, click the + button (Add Drawing).

4 In the Open dialog box, select a drawing to audit.

5 (Optional) Repeat steps 3 and 4 if you want to add additional drawings
to the standards check file.

6 Click File menu  ➤ Save As. (You can also click the Save As button on
the Batch Standards Checker toolbar.)

7 In the Save As dialog box, in File Name, enter a name for the file.

8 Click Save.

To open an existing standards check file

1 Start the Batch Standards Checker.

2 In the Batch Standards Checker, click File menu  ➤ Open Check File.
(You can also click Open on the Batch Standards Checker toolbar.)

3 In the Open dialog box, locate and select a standards check file.

4 Click Open.

To specify a standards override for a standards check file

1 Start the Batch Standards Checker.

2 Create a standards check file or open an existing one.
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3 In the Batch Standards Checker, Standards tab, select the Check All
Drawings Using the Following Standards Files option.

4 Click the + button (Add Standards File).

5 In the Open dialog box, select a standards file to use as an override. Click
Open.

6 (Optional) Repeat steps 5 and 6 if you want to add additional standards
files as overrides.

7 In the Batch Standards Checker, click File menu  ➤ Save Check File. (You
can also click Save on the Batch Standards Checker toolbar.)

To audit a set of drawings for standards violations

1 Start the Batch Standards Checker.

2 Open an existing standards check file, or create a new one.

3 In the Batch Standards Checker, click Check menu ➤ Start Check. (You
can also click Start Check on the Batch Standards Checker toolbar.)

When the batch audit is complete, the report is displayed in a browser
window.

You can cancel the batch audit at any time by click Stop Check.

NOTE You cannot check encrypted files using the Batch Standards Checker.

To add notes to the batch audit report

1 Start the Batch Standards Checker.

2 Create a standards check file or open an existing one.

3 In the Batch Standards Checker, Notes tab, enter notes to be included in
the report.

4 Click File menu  ➤ Save Check File. (You can also click Save on the Batch
Standards Checker toolbar.)

To view a previously generated batch audit report

1 Start the Batch Standards Checker.

2 Open the standards check file that generated the report you want to view.
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3 In the Batch Standards Checker, click Check menu  ➤ View Report.(You
can also click View Report on the Batch Standards Checker toolbar.)

The report is displayed in a browser window.

4 Select one of the following options to filter the data displayed in the
report:

■ Overview. Summarizes the number of problems encountered in each
audited drawing.

■ Plug-ins. Summarizes the standards plug-ins installed on the system
used to run the batch audit.

■ Standards. Summarizes the standards files used to check the drawings
in the batch audit.

■ Problems. Provides detailed information about each problem that was
encountered.

■ Ignored Problems. Provides detailed information about problems that
were flagged as ignored.

■ All. Shows all available standards audit information.

5 In the For list, select individual drawings to view their audit information.

To export a batch audit report

1 Start the Batch Standards Checker.

2 Create a standards check file or open an existing one.

3 In the Batch Standards Checker, click Check  ➤ Export Report. (You can
also click Export Report on the Batch Standards Checker toolbar.)

Quick Reference

Commands

CHECKSTANDARDS

Checks the current drawing for standards violations.

STANDARDS

Manages the association of standards files with drawings.
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System Variables

STANDARDSVIOLATION

Specifies whether a user is notified of standards violations in the current
drawing when a nonstandard object is created or modified.

Utilities

Batch Standards Checker

Audits a set of drawings for standards violations.

Command Modifiers

No entries

Translate Layer Names and Properties
You can reorganize a drawing's layers to match a set of layer standards.

Convert Layers to Established Drawing Standards

With the Layer Translator, you can convert layers in one drawing to layer
standards that you define.

For example, if you receive a drawing from a company that does not follow
your company's layer standards, you can convert the drawing's layer names
and properties to your company's standards. You can map layers in the drawing
you are currently working on to different layers in another drawing or
standards file, and then convert the current layers using those mappings. If
the drawings contain layers of the same name, the Layer Translator can
automatically change the properties of the current layers to match those in
the other layers.

You can save your layer translation mappings in a file and reuse them with
other drawings.

View Selected Drawing Layers

With the Layer Translator, you can control which layers are visible in the
drawing area.

You can choose to display objects on all layers in your drawing, or objects on
layers you specify. By viewing selected layers, you can visually verify the
contents of those layers.
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Purge Unreferenced Layers

With the Layer Translator, you can purge (delete) all unreferenced layers from
a drawing.

For example, if your drawing includes layers that you do not need, you may
want to remove those layers. Reducing the number of layers makes working
with the remaining layers more manageable.

To convert a drawing's layers to standard layer settings

1 Click Manage tab  ➤  CAD Standards panel  ➤ Layer Translator. 

2 In the Layer Translator, do one of the following:

■ Click Load to load layers from a drawing, a drawing template, or a
drawing standards file. In the Select Drawing File dialog box, select
the file you want. Click Open.

■ Click New to define a new layer. In the New Layer dialog box, enter
a name for the new layer and select its properties. Click OK.

You can repeat step 2 as many times as you want. If you load other files
containing layers of the same name as ones already shown in the Translate
To list, the layer properties first loaded in the list are maintained; any
duplicate layer properties are ignored.

3 Map layers in the current drawing to the layers you want to convert to.
Use either or both of the following methods to map layers:

■ To map all identically named layers from one list to the other, click
Map Same.

■ To map individual layers, in the Translate From list, select one or
more layers. In the Translate To list, select the layer whose properties
you want to use. Click Map to define the mapping. You can repeat
this method for each layer or group of layers to be translated.

To remove a mapping, select the mapping from the Layer Translation
Mappings list. Click Remove. To remove all mappings, right-click in the
list. Click Remove All.

4 (Optional) You can perform the following tasks in the Layer Translator:

■ To change the properties of a mapped layer, in the Layer Translation
Mappings list, select the mapping whose properties you want to
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change. Click Edit. In the Edit Layer dialog box, change the linetype,
color, lineweight, or plot style of the mapped layer. Click OK.

■ To customize the process of layer translation, click Settings. In the
Settings dialog box, select the options you want. Click OK.

■ To save layer mappings to a file, click Save. In the Save Layer Mappings
dialog box, enter a file name. Click OK.

5 Click Translate to perform the layer translations you have specified.

Command entry: LAYTRANS

Toolbar: CAD Standards  

To specify which layers are displayed in the drawing area

1 Click Manage tab  ➤  CAD Standards panel  ➤ Layer Translator. 

2 In the Layer Translator, click Settings.

3 In the Settings dialog box, do one of the following:

■ To display objects on selected layers in your drawing, select Show
Layer Contents When Selected. Only the layers selected in the Layer
Translator dialog box are displayed in the drawing area.

■ To display objects on all layers in your drawing, clear Show Layer
Contents When Selected.

4 Click OK.

Command entry: LAYTRANS

Toolbar: CAD Standards  

To purge all unreferenced layers from a drawing

1 Click Manage tab  ➤  CAD Standards panel  ➤ Layer Translator. 
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2 In the Layer Translator, right-click in the Translate From list. Click Purge
Layers. All unreferenced layers are deleted from the current drawing.

Command entry: LAYTRANS

Toolbar: CAD Standards  

Quick Reference

Commands

LAYTRANS

Translates the layers in the current drawing to specified layer standards.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries
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Control the Drawing Views
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Change Views

You can magnify the details in your drawing for a closer view or shift the view to a different
part of the drawing. If you save views by name, you can restore them later.

Pan or Zoom a View
You can pan to reposition the view in the drawing area or zoom to change
magnification.

With the Realtime option of PAN, you pan dynamically by moving your pointing
device. Like panning with a camera, PAN does not change the location or
magnification of objects on your drawing; it changes only the view.

You can change the magnification of a view by zooming in and out, which is
similar to zooming in and out with a camera. ZOOM does not change the
absolute size of objects in the drawing; it changes only the magnification of the
view.

When you work with minute parts in your drawing, you may need to zoom out
frequently to see an overview of your work. Use ZOOM Previous to return quickly
to the prior view.

The options described here are the options most commonly used. For a
description of all ZOOM options, see the Command Reference.

9
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Zoom to Magnify a Specified Rectangular Area

You can quickly zoom on a rectangular area of your drawing by specifying
two diagonal corners of the area you are interested in.

The lower-left corner of the area you specify becomes the lower-left corner of
the new display. The shape of the zoom area you specify does not correspond
exactly to the new view, which must fit the shape of the viewport.

Zoom in Real Time

With the Realtime option, you zoom dynamically by moving your pointing
device up or down. By right-clicking, you can display a shortcut menu with
additional viewing options.

Zoom to Magnify One or More Objects

ZOOM Objects displays a view with the largest possible magnification that
includes all of the objects you selected.

Zoom to View All Objects in the Drawing

ZOOM Extents displays a view with the largest possible magnification that
includes all of the objects in the drawing. This view includes objects on layers
that are turned off but does not include objects on frozen layers.

ZOOM All displays either the user-defined grid limits or the drawing extents,
whichever view is larger.
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See also:

■ Pointing Devices

■ Scale Views in Layout Viewports on page 456

■ Toolbars on page 32

To pan by dragging

1 Click View tab  ➤  Navigate panel  ➤  Pan. 

2 When the hand cursor is displayed, click and hold your pointing device
as you move.

NOTE If you are using a wheel mouse, hold down the wheel button and
move the mouse.

3 To exit, press Enter or Esc, or right-click.

Command entry: PAN

Toolbar: Standard  

Pan or Zoom a View | 271



To pan by specifying points

1 Click View menu  ➤  Pan  ➤ Point. 

2 Specify a base point. This is the point you want to change.

3 Specify a second (pan to) point. This is the new location for the point
you selected first.

To zoom by dragging

1 Click View tab  ➤  Navigate panel  ➤ Realtime. 

2 When the magnifying glass cursor is displayed, click and hold your
pointing device and drag vertically to zoom in and out.

3 To exit, press Enter or Esc, or right-click.

Command entry: ZOOM

Toolbar: Standard  

To zoom in to an area by specifying its boundaries

1 Click View tab  ➤  Navigate panel  ➤  Window. 

2 Specify one corner of the rectangular area you want to view.

3 Specify the opposite corner.

You automatically choose the Window option when you specify a point
immediately after starting the ZOOM command.

Command entry: ZOOM

Toolbar: Standard  
Shortcut menu: With the ZOOM command active, right-click in the drawing
area. Click Zoom Window.
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To display the drawing extents by zooming

■ Click View tab  ➤  Navigate panel  ➤  Extents. 

All objects in the drawing are displayed to be as large as possible and still fit
in the current viewport or the drawing area.

Toolbar: Standard  
Command entry: ZOOM

Shortcut menu: With the ZOOM command active, right-click in the drawing
area. Click Zoom Extents.

To display the area of the grid limits by zooming

■ Click View tab  ➤  Navigate panel  ➤  All. 

The limits of the drawing grid fill the current viewport or the drawing area.
If there are any objects outside the grid limits, they are also included.

Command entry: ZOOM

Toolbar: Standard  

To restore the previous view

■ Click View tab  ➤  Navigate panel  ➤  Previous. 

Zoom Previous restores only the view magnification and position, not the
previous content of an edited drawing.

Command entry: ZOOM

Toolbar: Standard  
Shortcut menu: With the ZOOM command active, right-click in the drawing
area. Click Zoom Original.
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Quick Reference

Commands

DSVIEWER

Opens the Aerial View window.

PAN

Moves the view in the current viewport.

UNDO

Reverses the effect of commands.

VIEWRES

Sets the resolution for objects in the current viewport.

VTOPTIONS

Displays a change in view as a smooth transition.

ZOOM

Increases or decreases the magnification of the view in the current viewport.

System Variables

EXTMAX

Stores the upper-right point of the drawing extents.

EXTMIN

Stores the lower-left point of the drawing extents.

MBUTTONPAN

Controls the behavior of the third button or wheel on the pointing device.

RTDISPLAY

Controls the display of raster images and OLE objects during Realtime ZOOM
or PAN.

VTENABLE

Controls when smooth view transitions are used.

VTDURATION

Sets the duration of a smooth view transition, in milliseconds.
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VTFPS

Sets the minimum speed of a smooth view transition, in frames per second.

WHIPARC

Controls whether the display of circles and arcs is smooth.

WHIPTHREAD

Controls whether to use an additional processor to improve the speed of
operations such as ZOOM that redraw or regenerate the drawing.

ZOOMFACTOR

Controls how much the magnification changes when the mouse wheel moves
forward or backward.

Pan and Zoom with the Aerial View Window
In a large drawing, you can pan and zoom quickly in a window that can display
the whole drawing.

You can use the Aerial View window to change the view in your current
viewport quickly. If you keep the Aerial View window open as you work, you
can zoom and pan without interrupting your current command. You can also
specify a new view without having to choose a menu option or enter a
command.

Use the View Box to Pan and Zoom

Within the Aerial View window is a view box, a heavy rectangle that displays
the boundary of the view in your current viewport. You can change the view
in the drawing by changing the view box in the Aerial View window. To zoom
in to the drawing, make the view box smaller. To zoom out of the drawing,
make the view box larger. All pan and zoom operations are performed by
left-clicking. Right-click to end a pan or zoom operation.
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To pan the drawing, move the view box.

Change the View Displayed Inside the Aerial View Window

You can use the Aerial View toolbar buttons to change the magnification of
the image in the Aerial View window, or you can resize the image
incrementally. These changes do not affect the view in the drawing itself.

Use the Aerial View Window with Multiple Viewports

Only the view in the current viewport is used in the Aerial View window.

The Aerial View image is updated as you make changes to your drawing and
as you select different viewports. In complex drawings, you may want to turn
off this dynamic updating to improve drawing speed. If you turn off this
feature, the Aerial View image is updated only when you activate the Aerial
View window.
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To zoom to a new area using the Aerial View window

1 Click View menu  ➤  Aerial View.

2 In the Aerial View window, click inside the view box until you see the
arrow.

3 Drag to the right to zoom out. Drag to the left to zoom in.

4 Right-click to end the zoom operation.

Command entry: DSVIEWER

To pan using the Aerial View window

1 Click View menu  ➤  Aerial View.

2 In the Aerial View window, click inside the view box until you see an X.

3 Drag to change the view.

4 Right-click to end the pan operation.

Command entry: DSVIEWER

To display the entire drawing in the Aerial View window

1 Click View menu  ➤  Aerial View.

2 In the Aerial View window, click View menu ➤ Global.

Command entry: DSVIEWER

To increase or decrease magnification of the Aerial View image

1 Click View menu  ➤  Aerial View.

2 On the Aerial View toolbar, click Zoom Out or Zoom In.

NOTE When the entire drawing is displayed in the Aerial View window, the Zoom
Out menu option and button are unavailable. When the current view nearly fills
the Aerial View window, the Zoom In menu option and button are unavailable.

Command entry: DSVIEWER
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To turn dynamic updating on and off

■ Click View menu  ➤  Aerial View.

■ In the Aerial View window, click Options menu  ➤ Dynamic Update.
A check mark indicates that the Aerial View window shows changes as
they occur.

To turn viewport updating on and off

■ Click View menu  ➤  Aerial View.

■ In the Aerial View window, click Options menu  ➤ Auto Viewport.
A check mark indicates that Aerial View displays the current viewport as
you switch viewports.

Quick Reference

Commands

DSVIEWER

Opens the Aerial View window.

Save and Restore Views
When you save specific views by name, you can restore them for layout and
plotting or when you need to refer to specific details. You can create and save
views using the VIEW or the CAMERA command.

A named view created with the VIEW command consists of a specific
magnification, position, and orientation. In each drawing session, you can
restore the last view displayed in each viewport and up to 10 previous views.

Named views and cameras are saved with a drawing and can be used any time.
When you are composing a layout, you can restore a named view or a camera
to a viewport on the layout.

Save a View

When you name and save a view, the following settings are saved:

■ Magnification, center point, and view direction

■ View category that you assign to the view (optional)
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■ The location of the view (the Model tab or a specific layout tab)

■ Layer visibility in the drawing at the time the view is saved

■ User coordinate system

■ 3D perspective

■ Live section

■ Visual style

■ Background

Restore a Named View

You restore a named view to the current viewport. You can use named views
to do the following:

■ Compose a layout.

■ Restore a view that you use frequently while you are working in model
space.

■ Control which model space view is displayed when the drawing is opened.

To restore the previous view

■ Click View tab  ➤  Navigate panel  ➤  Previous. 

Zoom Previous restores only the view magnification and position, not the
previous content of an edited drawing.

Command entry: ZOOM

Toolbar: Standard  
Shortcut menu: With the ZOOM command active, right-click in the drawing
area. Click Zoom Original.

Save and Restore Views | 279



To display the previous view during PAN Realtime and ZOOM Realtime

■ Click View tab  ➤  Navigate panel  ➤  Zoom drop-down  ➤  Previous.

Alternatively, right-click in the drawing area. Click Zoom Original.

To save and name a view

1 Do one of the following:

■ If you have more than one viewport in model space, click inside the
viewport that contains the view you want to save.

■ If you are working in a layout, select the viewport.

2 Click View tab  ➤  Views panel  ➤  Named Views. 

3 In the View Manager, click New.

4 In the New View dialog box, View Name box, enter a name for the view.

If the drawing is part of a sheet set, the view categories for the sheet set
are listed. You can add a category or select one from the list.

5 In the Boundary section, select one of the following options to define
the area of the view:

■ Current Display. Includes all of the drawing that is currently visible.

■ Define Window. Saves part of the current display. The dialog box
closes while you use the pointing device in the drawing to specify
opposite corners of the view. To redefine the window, click the Define
View Window button.

6 Click OK twice to save the new view.

Command entry: VIEW

Toolbar: View  
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To restore a saved view

1 Do one of the following:

■ If you have more than one viewport in model space, click inside the
viewport that contains the view you want to restore.

■ If you are working in a layout, select the viewport.

2 Click View tab  ➤  Views panel  ➤  Named Views. 

3 In the View Manager, Views list, select the view that you want to restore.

4 Click Set Current. Click OK.

Command entry: VIEW

Toolbar: View  

To rename a view

1 Click View tab  ➤  Views panel  ➤  Named Views. 

2 In the View Manager, click the view name you want to change. If the
view isn’t already displayed, expand the appropriate View list, and then
click a view name.

3 In the General section of the Properties panel, select the view name. Enter
a new name.

4 Click OK.

Command entry: VIEW

Toolbar: View  

To change the properties of a view

1 Click View tab  ➤  Views panel  ➤  Named Views. 
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2 In the View Manager, click the view name you want to change. If the
view isn’t already displayed, expand the appropriate View list, and then
click a view name.

3 In the Properties panel, click the property that you want to change.

4 Specify the new property value by entering a new value or by selecting
from a list of values. Click OK.

Command entry: VIEW

Toolbar: View  

To delete a named view

1 Click View tab  ➤  Views panel  ➤  Named Views. 

2 In the View Manager, click a view, and then click Delete.

3 Click OK.

Command entry: VIEW

Toolbar: View  

To view a list of saved viewport arrangements

■ Click View tab ➤ Viewports panel ➤ Named. 

The list of saved viewports is displayed in the Viewports dialog box, Named
Viewports tab.

Command entry: VPORTS

Toolbar: Viewports  
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Quick Reference

Commands

VIEW

Saves and restores named views, camera views, layout views, and preset views.

VPORTS

Creates multiple viewports in model space or paper space.

ZOOM

Increases or decreases the magnification of the view in the current viewport.

Control the 3D Projection Style
You can view both parallel and perspective projection of a 3D model.

Overview of Parallel and Perspective Views
You can create realistic visual effects in a drawing by defining either parallel
or perspective projections of a model.

The difference between perspective views and parallel projections is that
perspective views require a distance between a theoretical camera and target
point. Small distances produce severe perspective effects; large distances
produce mild effects.

The following illustration shows the same model in both a parallel projection
and perspective projection. Both are based on the same viewing direction.
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Quick Reference

Commands

3DORBIT

Rotates the view in 3D space, but constrained to horizontal and vertical orbit
only.

DVIEW

Defines parallel projection or perspective views by using a camera and target.

System Variables

BACKZ

Stores the back clipping plane offset from the target plane for the current
viewport, in drawing units.

FRONTZ

Stores the front clipping plane offset from the target plane for the current
viewport, in drawing units.

LENSLENGTH

Stores the length of the lens (in millimeters) used in perspective viewing.

TARGET

Stores the location (as a UCS coordinate) of the target point for the current
viewport.

VIEWDIR

Stores the viewing direction in the current viewport, expressed in UCS
coordinates.

VIEWMODE

Stores the View mode for the current viewport.

VIEWTWIST

Stores the view rotation angle for the current viewport measured relative to
the WCS.
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WORLDVIEW

Define a Perspective Projection (DVIEW)
Perspective projections require a distance between a theoretical camera and
a target point. Small distances produce severe perspective effects; large distances
produce milder effects.

A perspective view remains in effect until the perspective effect is turned off
or until a new view is defined in its place.

To define a perspective view of a 3D model using DVIEW

1 At the Command prompt, enter dview.

2 Select the objects to display.

3 Enter ca (Camera).

By default, a camera point is set at the center of the drawing.

4 Adjust the view as if you're aiming a camera.

A representation of a house shows the current viewing angle. You can
set your view dynamically by moving the crosshairs and clicking.

5 To switch between angle-input methods, enter t (Toggle Angle).

You also can adjust the view with one of two angle-input methods.

■ For the Enter Angle from the XY Plane option, enter the angle of the
camera up or down relative to the XY plane of the current UCS. The
default setting, 90 degrees, points the camera straight down from
above.
After you enter the angle, the camera is locked at that height, and
you can rotate the camera about the target with the rotation angle
measured relative to the X axis of the current UCS.

■ For the Enter Angle in the XY Plane from the X Axis option, rotate
the camera about the target with the rotation angle measured relative
to the X axis of the current UCS.

6 To turn on the perspective view, enter d (Distance).

7 Specify a distance, or press Enter to set the perspective view.

You can use the slider bar to set the distance between the selected objects
and the camera, or you can enter a real number. If the target and camera
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points are very close (or if the Zoom option is set high), you might see
only a small part of your drawing.

Command entry: DVIEW

To turn off a perspective view using DVIEW

1 At the Command prompt, enter dview.

2 Select the objects to display.

3 Enter o (Off).

Perspective is turned off and the view is restored to a parallel projection.

Command entry: DVIEW

Quick Reference

Commands

3DORBIT

Rotates the view in 3D space, but constrained to horizontal and vertical orbit
only.

DVIEW

Defines parallel projection or perspective views by using a camera and target.

System Variables

BACKZ

Stores the back clipping plane offset from the target plane for the current
viewport, in drawing units.

FRONTZ

Stores the front clipping plane offset from the target plane for the current
viewport, in drawing units.

LENSLENGTH

Stores the length of the lens (in millimeters) used in perspective viewing.

PERSPECTIVE

Specifies whether the current viewport displays a perspective view.
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PERSPECTIVECLIP

Determines the location of eyepoint clipping.

TARGET

Stores the location (as a UCS coordinate) of the target point for the current
viewport.

VIEWDIR

Stores the viewing direction in the current viewport, expressed in UCS
coordinates.

VIEWMODE

Stores the View mode for the current viewport.

VIEWTWIST

Stores the view rotation angle for the current viewport measured relative to
the WCS.

WORLDVIEW

Define a Parallel Projection
You can define a parallel projection.

To determine the point or angle in model space, you can

■ Choose a preset 3D view from the View toolbar.

■ Enter a coordinate or angles that represent your viewing location in 3D.

■ Change to a view of the XY plane of the current UCS, a saved UCS, or the
WCS.

■ Change the 3D view dynamically with your pointing device.

■ Set front and back clipping planes to limit the objects being displayed.

Viewing in 3D is available only in model space. If you are working in paper
space, you cannot use 3D viewing commands such as VPOINT, DVIEW, or
PLAN to define paper space views. The view in paper space is always a plan
view.

To create a parallel projection dynamically

1 At the Command prompt, enter dview.
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2 Do one of the following:

■ Select the objects to display and press Enter.

■ Press Enter without selecting objects to see a representation of a house
that shows the current viewing angle.

3 Enter ca (Camera).

By default, a camera point is set at the center of the drawing.

4 Adjust the view as if you're aiming a camera.

You can set your view dynamically by moving the crosshairs and clicking.

5 To switch between the angle-input methods, enter t (Toggle Angle).

You can also adjust the view with one of two angle-input methods.

■ For the Enter Angle from the XY Plane option, enter the angle of the
camera up or down relative to the XY plane of the current UCS. The
default setting, 90 degrees, points the camera straight down from
above.
After you enter the angle, the camera is locked at that height, and
you can rotate the camera about the target with the rotation angle
measured relative to the X axis of the current UCS.

■ For the Enter Angle in the XY Plane from the X Axis option, rotate
the camera about the target with the rotation angle measured relative
to the X axis of the current UCS.

6 When you finish specifying the parallel projection, press Enter.

Command entry: DVIEW

Quick Reference

Commands

DVIEW

Defines parallel projection or perspective views by using a camera and target.

PLAN

Displays the plan view of a specified user coordinate system

VPOINT

Sets the viewing direction for a 3D visualization of the drawing.
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System Variables

PERSPECTIVE

Specifies whether the current viewport displays a perspective view.

VIEWDIR

Stores the viewing direction in the current viewport, expressed in UCS
coordinates.

WORLDVIEW

Choose Preset 3D Views
You can select predefined standard orthographic and isometric views by name
or description.

A quick way to set a view is to choose one of the predefined 3D views. You
can select predefined standard orthographic and isometric views by name or
description. These views represent commonly used options: Top, Bottom,
Front, Left, Right, and Back. In addition, you can set views from isometric
options: SW (southwest) Isometric, SE (southeast) Isometric, NE (northeast)
Isometric, and NW (northwest) Isometric.

To understand how the isometric views work, imagine you are looking down
at the top of a box. If you move toward the lower-left corner of the box, you
are viewing the box from the SW Isometric View. If you move toward the
upper-right corner of the box, you are viewing it from NE Isometric View.

To use a preset 3D view

■ Click View tab  ➤  Views panel  ➤  Named Views.

■ Select a preset view (Top, Bottom, Left, and so on).

Toolbar: View  
Command entry: VIEW
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Quick Reference

Commands

VIEW

Define a 3D View with Coordinate Values or Angles
You can define a viewing direction by entering the coordinate values of a
point or the measures of two angles of rotation.

This point represents your position in 3D space as you view the model while
looking toward the origin (0,0,0). Viewpoint coordinate values are relative to
the world coordinate system unless you change the WORLDVIEW system
variable. The conventions for defining standard views differ between
architectural (AEC) and mechanical design. In AEC design, the perpendicular
view of the XY plane is the top or plan view; in mechanical design, the
perpendicular view of the XY plane is the front view.

You can rotate a view using DDVPOINT. The following illustration shows a
view defined by two angles relative to the X axis and the XY plane of the WCS.

To set a view with a viewpoint coordinate

1 Click View menu  ➤  3D Views  ➤  Viewpoint.

2 Click inside the compass to specify the viewpoint. The selected viewpoint
is used to view the drawing in the direction of 0,0,0.

Command entry: VPOINT
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To set a view with two angles of rotation

1 Click View menu  ➤  3D Views  ➤  Viewpoint.

2 Enter r (Rotate) to specify a new direction using two angles.

3 Enter an angle in the XY plane measured from the positive X axis.

4 Enter an angle from the XY plane that represents your position while
viewing the model in the direction of 0,0,0.

Command entry: VPOINT

To set standard views with VPOINT (AEC convention)

1 Click View menu  ➤  3D Views  ➤  Viewpoint.

2 Enter a coordinate according to the viewpoint you want:

■ Enter 0,0,1 for a top (plan) view.

■ Enter 0,-1,0 for a front view.

■ Enter 1,0,0 for a right side view.

■ Enter 1,-1,1 for an isometric view.

Command entry: VPOINT

To set standard views with VPOINT (mechanical design convention)

1 Click View menu  ➤  3D Views  ➤  Viewpoint.

2 Enter a coordinate according to the viewpoint you want:

■ Enter 0,1,0 for a top view.

■ Enter 0,0,1 for a front view.

■ Enter 1,0,0 for a right side view.

■ Enter 1,1,1 for an isometric view. This view is identical to one with a
right-out of 45 degrees and a top-out of 35.267 degrees.

Command entry: VPOINT
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Quick Reference

Commands

VIEW

VPOINT

Sets the viewing direction for a 3D visualization of the drawing.

System Variables

WORLDVIEW

Change to a View of the XY Plane
You can change the current viewpoint to a plan view of the current UCS, a
previously saved UCS, or the WCS.

A plan view is a view aimed toward the origin (0,0,0) from a point on the
positive Z axis. This results in a view of the XY plane.

You can restore the view and coordinate system that is the default for most
drawings by setting the UCS orientation to World and then setting the 3D
view to Plan View.

To change the current view to the XY plane

1 Click View menu  ➤  3D Views  ➤  Plan View.

2 Select one of the following options:

■ Current (for the current UCS)

■ World (for the WCS)

■ Named (for a saved UCS)

NOTE PLAN changes the viewing direction and turns off perspective and
clipping; it does not change the current UCS. Any coordinates entered or
displayed subsequent to the PLAN command remain relative to the current
UCS.

Command entry: PLAN
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Quick Reference

Commands

DVIEW

Defines parallel projection or perspective views by using a camera and target.

PLAN

Displays the plan view of a specified user coordinate system

System Variables

BACKZ

Stores the back clipping plane offset from the target plane for the current
viewport, in drawing units.

FRONTZ

Stores the front clipping plane offset from the target plane for the current
viewport, in drawing units.

VIEWDIR

Stores the viewing direction in the current viewport, expressed in UCS
coordinates.

VIEWTWIST

Stores the view rotation angle for the current viewport measured relative to
the WCS.

WORLDVIEW

Shade a Model and Use Edge Effects
Hiding lines enhances the drawing and clarifies the design. The addition of
shading produces a more realistic image of your model.

Use a Visual Style to Display Your Model
A visual style is a collection of settings that control the display of edges and
shading in the viewport. Instead of using commands and setting system
variables, you change the properties of the visual style. As soon as you apply
a visual style or change its settings, you can see the effect in the viewport.

Shade a Model and Use Edge Effects | 293



The Visual Styles Manager displays sample images of the visual styles available
in the drawing. The selected visual style is indicated by a yellow border, and
its settings are displayed in the panel below the sample images.

When the ribbon on page 22 is displayed, you can change some frequently
used settings directly or open the Visual Styles Manager.

Five default visual styles are supplied with the product:

■ 2D Wireframe. Displays the objects using lines and curves to represent the
boundaries. Raster and OLE objects, linetypes, and lineweights are visible.

■ 3D Wireframe (upper left in the illustration). Displays the objects using
lines and curves to represent the boundaries.

■ 3D Hidden (upper right). Displays the objects using 3D wireframe
representation and hides lines representing back faces.

■ Realistic (lower left). Shades the objects and smooths the edges between
polygon faces. Materials that you have attached to the objects are displayed.

■ Conceptual (lower right). Shades the objects and smooths the edges
between polygon faces. Shading uses the Gooch face style, a transition
between cool and warm colors rather than dark to light. The effect is less
realistic, but it can make the details of the model easier to see.
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In shaded visual styles, faces are lighted by two distant light sources that follow
the viewpoint as you move around the model. This default lighting is designed
to illuminate all faces in the model so that they are visually discernable. Default
lighting is available only when other lights, including the sun, are off.

You can select a visual style and change its settings at any time. The changes
you make are reflected in the viewports where the visual style is applied. For
more information about face settings, environment settings, and edge settings,
see Customize a Visual Style on page 298. Any changes you make to a visual
style are saved in the drawing.

To save a visual style in the drawing

■ At the Command prompt, enter vssave.

To apply a visual style to a viewport

1 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 

2 Click in the viewport to make it current.

3 In the Visual Styles Manager, double-click the sample image of the visual
style.

The selected visual style is applied to the model in the viewport.

An icon in the sample image indicates that the visual style is in use in
the current viewport. When you change viewports, the icon changes to
indicate that the visual style is in use in the current drawing.

Visual Styles  

Right-click the visual style in the Visual Styles Manager. Click Apply to
Current Viewport.

VISUALSTYLES

To store a visual style on a tool palette

1 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 
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2 Click View tab  ➤ Palettes panel  ➤ Tool Palettes. 

3 In the Tool Palettes window, click the Visual Styles tab.

4 In the Visual Styles Manager, select the sample image of the visual style.

5 Below the images, click the Export the Selected Visual Style to the Tool
Palette button.

Command entry: VISUALSTYLES, TOOLPALETTES

Toolbar: Visual Styles  
Shortcut menu: Right-click the visual style in the Visual Styles Manager.
Click Export to Active Tool Palette.

To use a visual style from a different drawing

1 Open the drawing that has the visual style that you want to use.

2 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 

3 Click View tab  ➤ Palettes panel  ➤ Tool Palettes. 

4 In the Tool Palettes window, click the Visual Styles tab.

5 In the Visual Styles Manager, select the sample image of the visual style.

6 Below the images, click the Export the Selected Visual Style to the Tool
Palette button.

7 Open the drawing where you want to use the visual style.

8 On the tool palette, select the visual style.

9 Right-click and click Add to Current Drawing.

The visual style is added to the sample images in the Visual Styles Manager
and the ribbon.

Command entry: VISUALSTYLES, TOOLPALETTES
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Toolbar: Visual Styles  
Shortcut menu: Right-click the visual style in the Visual Styles Manager.
Click Export to Active Tool Palette.

To restore the original settings of a default visual style

1 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 

2 Select a default visual style.

A default visual style displays a drawing icon at bottom right in the sample
image.

3 Right-click and click Reset to Default.

Command entry: VISUALSTYLES

Toolbar: Visual Styles  

Quick Reference

Commands

SHADEMODE

Starts the VSCURRENT command.

TOOLPALETTES

Opens the Tool Palettes window.

VISUALSTYLES

Creates and modifies visual styles and applies a visual style to a viewport.

VISUALSTYLESCLOSE

Closes the Visual Styles Manager.

System Variables

VSLIGHTINGQUALITY

Sets the lighting quality in the current viewport.
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Customize a Visual Style
You can create your own visual styles by changing the face and edge settings
and using shadows and backgrounds.

Shade and Color Faces
Shading and color effects control the display of faces in a model.

Face Styles

The face style defines the shading on a face. Real (below left) is meant to
produce the effect of realism. Gooch (below right) can show details better by
softening the contrast between lighted areas and shadowed areas. Lighted
areas use warm tones and darker areas cool tones.
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When the None face style is active, there is no shading, and only edges are
displayed if Edge Mode is set to Facet Edges or Isolines under Edge Settings.

Lighting Quality

Faceted lighting computes a single color for each face. Objects appear flatter.
Smooth lighting smoothes the edges between polygon faces by computing
the colors as a gradient between the vertexes of the faces. This gives the objects
a smooth appearance. For the smoothest option, the Per-Pixel Lighting setting
needs to be turned on in the Manual Performance Tuning Dialog Box. The
colors are computed for individual pixels and gives a smoother appearance.
If not, the smooth setting is used instead.
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Highlights

The size of the highlights on an object affects the perception of shininess
(below). A smaller, more intense highlight makes objects look shinier. The
highlight intensity that is set in a visual style does not apply to objects with
materials attached.

Opacity

The opacity property controls the transparency of an object.
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Face Color Modes

Color can be displayed in the normal way, or you can change the face color
mode. Monochrome displays all faces in the same color and shaded. Tint uses
the same color to shade all faces by changing the hue and saturation values
of the color. Desaturate mode softens colors.

To change the display of faces from smooth to faceted

1 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 

2 With the current visual style selected in the sample images, in Face
Settings, Lighting Quality, change Smooth to Faceted.

Customize a Visual Style | 301



Command entry: VISUALSTYLES

Toolbar: Visual Styles  

To control the face style

1 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 

2 With the current visual style selected in the sample images, in Face
Settings, Face Style, select one of the following options:

■ Real, the default, is as close as possible to how the face would appear
in the real world.

■ Gooch uses cool and warm colors instead of dark and light to enhance
the display of faces that might be shadowed and difficult to see in a
realistic display.

■ None does not apply a face style. Other face settings are disabled.

Command entry: VISUALSTYLES

Toolbar: Visual Styles  

To control the display of colors on faces

1 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 

2 With the current visual style selected in the sample images, in Face
Settings, Materials and Color, Face Color Mode, select one of the following
options:

■ Normal. Does not apply a face color modifier.

■ Monochrome. Displays the model in shades of the color you specify.

■ Tint. Changes the hue and saturation value of face colors.

■ Desaturate. Softens the color by reducing its saturation component
by 30 percent.
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3 If Monochrome or Tint is selected, specify a color. Select Color opens the
Select Color dialog box.

Command entry: VISUALSTYLES

Toolbar: Visual Styles  

To make all faces in a viewport transparent

1 If the X-Ray Effect is not turned on: Click Render tab ➤ Visual Styles
panel ➤ X-Ray Effect.

2 On the Visual Styles panel, set the opacity by dragging the opacity slider.

Command entry: VSFACEOPACITY

Quick Reference

Commands

VISUALSTYLES

Creates and modifies visual styles and applies a visual style to a viewport.

System Variables

VISUALSTYLESCLOSE

Closes the Visual Styles Manager.

VSFACECOLORMODE

Controls how the color of faces is calculated.

VSFACEHIGHLIGHT

Controls the level of transparency for 3D objects.

VSFACEOPACITY

Turns on and off a preset level of transparency for 3D objects.

VSFACESTYLE

Controls how faces are displayed in the current viewport.
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VSLIGHTINGQUALITY

Sets the lighting quality in the current viewport.

VSMONOCOLOR

Sets the color for monochrome and tint display of faces in the visual style
applied to the current viewport.

Display Backgrounds and Shadows
The visual style also controls the display of backgrounds and shadows in the
viewport.

Backgrounds

You can use a color, a gradient fill, an image, or the sun & sky as a background
in the viewport in any 3D visual style, even one that does not shade objects.
To use a background, you first create a named view with a background and
set the named view as current in the viewport. When Background is set to On
in the current visual style, the background is displayed.

Shadows

Shaded objects in a viewport can display shadows. Ground shadows are
shadows that objects cast on the ground. Full shadows are shadows cast by
objects onto other objects. The lighting in the viewport must be from
user-created lights or the sun for full shadows to be displayed. Where shadows
overlap, they appear darker.

NOTE To display full shadows, hardware acceleration is required. When Enhanced
3D Performance is off, full shadows cannot be displayed. (To access these settings,
enter 3dconfig at the Command prompt. In the Adaptive Degradation and
Performance Tuning dialog box, click Manual Tune.)

Displaying shadows can slow performance. You can turn off shadows in the
current visual style while you work and turn them back on when you need
them.

In the Properties palette, you can set the Shadow Display property for an
object: casts shadows, receives shadows, casts and receives shadows, or ignores
shadows.

More options are available for shadows used in rendering.
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See also:

■ Use Shadows in Rendering

To control the display of shadows in a viewport

1 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 

2 With the current visual style selected in the sample images, in
Environment Settings, Shadow Display, select Off, Full Shadows, or
Ground Shadow.

Toolbar: Visual Styles  
Command entry: VISUALSTYLES

To set a solid as a viewport background

1 Click View tab  ➤  Views panel  ➤  Named Views. 
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2 In the View Manager, click the view name you want to change. If the
view isn’t already displayed, expand the appropriate View list, and then
click a view name.

3 In the Properties panel, click the Background Override field.

4 Select Solid from the Background Override drop-down list.

5 In the Background dialog box, click the swatch under the Color section.

6 In the Select Color dialog box, specify the color you want to use for the
background.

7 Click OK.

8 In the Background dialog box, click OK.

9 In the View Manager, click Set Current.

10 Click OK.

Command entry: VIEW

Toolbar: View 

To set a gradient as a viewport background

1 Click View tab  ➤  Views panel  ➤  Named Views. 

2 In the View Manager, click the view name you want to change. If the
view isn’t already displayed, expand the appropriate View list, and then
click a view name.

3 In the Properties panel, click the Background Override field.

4 Select Gradient from the Background Override drop-down list.

5 In the Background dialog box, specify the desired options for the gradient
fill.

■ Select Three Color to use a two or three color gradient fill.

■ Click on the color swatches to display the Select Color dialog box to
specify the colors you want to use for the gradient fill.

■ Enter a rotation value for the gradient fill in the Rotation text box.
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6 In the Background dialog box, click OK.

7 In the View Manager, click Set Current.

8 Click OK.

Command entry: VIEW

Toolbar: View 

To set an image as a viewport background

1 Click View tab  ➤  Views panel  ➤  Named Views. 

2 In the View Manager, click the view name you want to change. If the
view isn’t already displayed, expand the appropriate View list, and then
click a view name.

3 In the Properties panel, click the Background Override field.

4 Select Image from the Background Override drop-down list.

5 In the Background dialog box, click Browse and specify the image for the
background.

6 Click Adjust Image.

7 In the Adjust Background Image dialog box, specify the desired options
for the image.

■ Specify the position for the image by choosing an option from the
Image Position drop-down list.

■ Click Offset or Scale to adjust what functionality the sliders have.

■ Click Maintain Aspect Ratio When Scaling to have the image scale
uniformily.

■ Drag the sliders to adjust the offset or scale of the image based on the
current setting.

8 In the Adjust Background Image dialog box, click OK.

9 In the Background dialog box, click OK.

10 In the View Manager, click Set Current.
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11 Click OK.

Toolbar: View 
Command entry: VIEW

To set a Sun/Sky as a viewport background

1 Before changing the background, make sure that photometric lighting is
enabled:

■ Click Render tab  ➤  Lights panel  ➤  American Lighting Units

■ Click Render tab  ➤  Lights panel  ➤  International Lighting Units

2 Click View tab  ➤  Views panel  ➤  Named Views. 

3 In the View Manager, click the view name you want to change. If the
view isn’t already displayed, expand the appropriate View list, and then
click a view name.

4 In the Properties panel, click the Background Override field.

5 In the Background Override drop-down list, select Sun&Sky.

6 In the Adjust Sun & Sky Background dialog box, specify the desired
options for the background.

7 Click OK.

8 In the View Manager, click Set Current. Click OK.

Toolbar: View 
Command entry: LIGHTINGUNITS, VIEW
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Quick Reference

Commands

VIEW

VISUALSTYLES

Creates and modifies visual styles and applies a visual style to a viewport.

System Variables

CSHADOW

Sets the shadow display property for a 3D object.

LIGHTINGUNITS

Controls whether generic or photometric lights are used, and indicates the
current lighting units.

SHADOWPLANELOCATION

Controls the location of an invisible ground plane used to display shadows.

VSBACKGROUNDS

Controls whether backgrounds are displayed in the visual style applied to
the current viewport.

VSSHADOWS

Controls whether a visual style displays shadows.

VISUALSTYLESCLOSE

Closes the Visual Styles Manager.

Control the Display of Edges
Edges of different types can be displayed using different colors and linetypes.
You can also add special effects such as jitter and overhang to edges.

In a shaded or a wireframe model, the visual style sets the visibility and
appearance of isolines, facet edges, silhouette edges, obscured edges, and
intersection edges. Facet edges (the edges between planar faces representing
a surface) are displayed only when the angle between the facets is smaller than
the crease angle value you specify.
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Edge modifiers such as Overhang and Jitter produce the look of a model that
is still in the conceptual phase. Jitter makes lines look as though they were
sketched with a pencil. Overhang produces another kind of hand-drawn effect.

NOTE Plot styles are not available for objects with the Jitter edge modifier applied.

To control the display of edges and edge colors

1 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 

2 With the current visual style selected in the sample images, in Edge
Settings, Edge Mode, select Facet edges, Isolines, or None.

3 If Isolines is selected, specify the number of lines.

4 In Color, specify a color. Select Color opens the Select Color dialog box.

Command entry: VISUALSTYLES

Toolbar: Visual Styles  

To add an overhang effect to edges

1 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 

2 With the current visual style selected in the sample images, in Edge
Modifiers, click the Overhanging Edges button and adjust the amount
of overhang in Overhang.
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NOTE The overhang is scaled to look appropriate in viewports of different sizes.
The overhang effect is not applied to a line that is less than twice as long as the
overhang would be.

Command entry: VISUALSTYLES

Toolbar: Visual Styles  

To add a jitter effect to edges

1 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 

2 With the current visual style selected in the sample images, in Edge
Modifiers, click the Jitter Edges button and adjust the amount of jitter in
Jitter.

Command entry: VISUALSTYLES

Toolbar: Visual Styles  

To control display of silhouette edges

1 Click View tab  ➤  3D Palettes panel  ➤  Visual Styles Manager. 

2 With the current visual style selected in the sample images, in Fast
Silhouette Edges, Visible, select Yes or No.

3 If Yes is selected, specify a width for silhouette edges.

Toolbar: Visual Styles  
Command entry: VISUALSTYLES
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Quick Reference

Commands

VISUALSTYLES

Creates and modifies visual styles and applies a visual style to a viewport.

System Variables

FACETRES

Adjusts the smoothness of shaded and rendered objects and objects with
hidden lines removed.

INTERSECTIONCOLOR

Controls the color of polylines at the intersection of 3D surfaces when the
visual style is set to 2D Wireframe.

INTERSECTIONDISPLAY

Specifies the display of intersection polylines.

VISUALSTYLESCLOSE

Closes the Visual Styles Manager.

VSEDGECOLOR

Sets the color of edges in the visual style in the current viewport.

VSEDGEJITTER

Makes edges on 3D objects appear wavy, as though they were sketched with
a pencil.

VSEDGEOVERHANG

Makes edges on 3D objects extend beyond their intersection for a hand-drawn
effect.

VSEDGES

Controls the types of edges that are displayed in the viewport.

VSEDGESMOOTH

Specifies the angle at which crease edges are displayed.

VSHALOGAP

Sets the halo gap in the visual style applied to the current viewport.
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VSINTERSECTIONEDGES

Controls the display of intersection edges in the visual style applied to the
current viewport.

VSINTERSECTIONCOLOR

Specifies the color of intersection polylines in the visual style applied to the
current viewport.

VSINTERSECTIONLTYPE

Sets the linetype for intersection lines in the visual style applied to the current
viewport.

VSOBSCUREDEDGES

Controls whether obscured (hidden) edges are displayed.

VSOBSCUREDCOLOR

Specifies the color of obscured (hidden) lines in the visual style applied to
the current viewport.

VSOBSCUREDLTYPE

Specifies the linetype of obscured (hidden) lines in the visual style applied
to the current viewport.

VSSILHEDGES

Controls display of silhouette edges of solid objects in the visual style applied
to the current viewport.

VSSILHWIDTH

Specifies the width in pixels of silhouette edges in the current viewport.

Control Performance
3D graphics display and memory allocation can slow performance on your
system. Adaptive degradation, performance tuning and memory tuning are
different approaches to delivering the best performance possible.

Adaptive Degradation
Adaptive degradation is a way to control performance of features as you use
them.
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With adaptive degradation on, if performance goes below the level you specify,
effects are turned off or turned down in a certain order until performance
returns to an acceptable level. Each visual style sets a degradation order
appropriate for itself, based on a master order that you can adjust manually.

You set the performance level in frames per second in the Adaptive Degradation
and Performance Tuning dialog box. You can also control the order in which
features are turned off when performance slows. For example, if you’re working
on your model with a visual style that has shadows and a background, you
can move Shadows and Backgrounds to the top of the list so that they degrade
first and preserve edge effects that you need while drafting.

To set the performance level for adaptive degradation

1 Click Render tab  ➤  Visual Styles panel  ➤  Performance Tuner. 

2 In the Adaptive Degradation and Performance Tuning dialog box, check
Adaptive Degradation.

3 Enter or select a value for the frames per second. Degradation of the
display begins when performance is below this value.

4 Click OK.

Command entry: 3DCONFIG

To change the adaptive degradation order

1 Click Render tab  ➤  Visual Styles panel  ➤  Performance Tuner. 

2 In the Adaptive Degradation and Performance Tuning dialog box, select
a feature in the list.

3 Click Move Up or Move Down to change its order in the list.

Items at the top of the list degrade first. Click OK.

Command entry: 3DCONFIG
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Quick Reference

Commands

3DCONFIG

Sets options that affect 3D display performance.

System Variables

VSBACKGROUNDS

Controls whether backgrounds are displayed in the visual style applied to
the current viewport.

VSFACEOPACITY

Turns on and off a preset level of transparency for 3D objects.

VSINTERSECTIONEDGES

Controls the display of intersection edges in the visual style applied to the
current viewport.

VSSHADOWS

Controls whether a visual style displays shadows.

VSSILHEDGES

Controls display of silhouette edges of solid objects in the visual style applied
to the current viewport.

Performance Tuning
Examines your graphics card and 3D display driver and decides whether to
use software or hardware implementation for features that support both.

Features that cannot work properly on your system are turned off. Some
features may work but not be recommended for use with your graphics card
or 3D graphics display driver. You can turn these on at your own risk.

NOTE If you are using a graphics card that does not support all of the available
hardware effects, you can plot a drawing through software emulation. (To enable
the emulation of hardware effects in software, enter 3dconfig at the Command
prompt. In the Adaptive Degradation and Performance Tuning dialog box, click
Manual Tune. Then click Emulate Unsupported Hardware Effects in Software When
Plotting.)

Control Performance | 315



The performance tuner creates a log that reports the graphics card and 3D
display driver found on your system and the on or off status of effects. The
Current Effects Status section displays the settings of the current display driver.
An example of the Current Effects Status section might look like the following:

Enhanced 3D Performance: Available and on

Gooch shader: Available and using hardware

Full-shadow display: Available and on

Per-pixel lighting : Available and on

Texture compression: Available and on

You can manually turn on and off features that your system supports,
recommended or not.

The log that is created by the performance tuner not only displays information
about the current application driver, but also displays information about all
the available application drivers and which effects are supported. This
information is in the Available Application Drivers and Effect Support section.
By using the information that is displayed, you can make the best decision
about which application driver to use for your graphics card or the Software
driver. The Available Application Drivers and Effect Support section might
look like the following:

Software driver

Effect support:

Enhanced 3D Performance: Not applicable

Gooch shader: Software emulation only

Per-pixel lighting : Available and on

Full-shadow display: Not applicable

Texture compression: Not applicable

Autodesk driver: Certified

Effect support:

Enhanced 3D Performance: Available

Gooch shader: Available

Per-pixel lighting : Available and on

Full-shadow display: Available

Texture compression: Available

NOTE To display full shadows in viewports and to use Per-pixel lighting, hardware
acceleration is required. When Enhanced 3D Performance is off, full shadows
cannot be displayed in viewports. (To access these settings, enter 3dconfig at the
Command prompt. In the Adaptive Degradation and Performance Tuning dialog
box, click Manual Tune.)
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NOTE When Texture Compression is turned on, the amount of video memory
required to open a drawing that contains materials with images or has attached
images is decreased. By using the effect it can reduce the amount of video memory
necessary to display the drawing, but the downside to this effect is it may increase
the time it takes to load the images the first time that they are accessed. Also,
there is a reduction in the quality of the images when they are displayed in the
viewport or plotted. (To access these settings, enter 3dconfig at the Command
prompt. In the Adaptive Degradation and Performance Tuning dialog box, click
Manual Tune.)

Certification Updates

As more graphics cards and 3D display drivers are tested, they are added to a
list on the Autodesk website. You can check for updates and download the
latest list at any time. In the Adaptive Degradation and Performance Tuning
dialog box, click Check for Updates.

To view the performance tuner log

1 Click Render tab  ➤  Visual Styles panel  ➤  Performance Tuner. 

2 In the Adaptive Degradation and Performance Tuning dialog box, click
View Tune Log.

3 Click OK to exit each dialog box.

Command entry: 3DCONFIG

To tune performance manually

1 Click Render tab  ➤  Visual Styles panel  ➤  Performance Tuner. 

2 In the Adaptive Degradation and Performance Tuning dialog box, click
Manual Tune.

3 In the Manual Performance Tuning dialog box, you can enable hardware
acceleration if the icon next to the check box is a green check mark or a
yellow warning sign.

4 In General Settings, you can clear or turn down settings to improve
performance.

5 (Optional) Use the Reset to Recommended Values option.
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6 Click OK to exit each dialog box.

Command entry: 3dconfig

To check for graphics card and driver certification updates

1 Click Render tab  ➤  Visual Styles panel  ➤  Performance Tuner. 

2 In the Adaptive Degradation and Performance Tuning dialog box, click
Check for Updates.

A web page is displayed that describes the certification program.

3 Look for your graphics card and driver in the list. If you find them, follow
the download instructions.

4 Click OK to exit each dialog box.

Command entry: 3DCONFIG

Quick Reference

Commands

3DCONFIG

Sets options that affect 3D display performance.

System Variables

VSSHADOWS

Controls whether a visual style displays shadows.

Memory Tuning
Performance can also be improved by adding memory to your system. This is
especially true when working on larger models.

The system requirements for AutoCAD require at least 512 MB of physical
memory (RAM) for working in 2D. For creating and working with 3D models,
at least 2 GB of RAM is required.
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The size and complexity of a model often defines how efficiently an application
runs. If you notice increased hard drive activity, it means that physical memory
has been exceeded and data is being passed to a swap file (virtual memory).

A swap file is an area on the hard drive that Windows uses as if it were physical
memory (RAM). The swap file size is basically a limit which restricts the total
virtual size of the AutoCAD process. A good rule of thumb for configuring
your swap file is three times the amount of physical memory on your system.
This usually sets the limit high enough that AutoCAD doesn't run out of swap
space.

Typically, systems are limited to a maximum of 2 GB of virtual memory. On
some systems, you can set the /3GB switch that allows applications to use up
to 3 GB of virtual memory. Before attempting to set the switch, you need to
find out the following:

■ If your system supports the switch.

■ If other device drivers (video card, plotter drivers, etc.) may be affected if
the switch is set.

■ How to set the switch.

Refer to the Microsoft website for details regarding the /3GB switch.

To check physical memory (RAM)

1 On the Start menu (Windows), click Control Panel (or Settings  ➤  Control
Panel).

2 In the Control Panel, click System. You might have to click Performance
and Maintenance and then System.

3 On the General tab, review the information about your computer. The
amount of RAM should be listed on this tab.

To check swap file allocation

1 On the Start menu (Windows), click Control Panel (or Settings  ➤  Control
Panel).

2 In the Control Panel, click System. You might have to click Performance
and Maintenance and then System.

3 Open the Advanced tab and click the Settings (or Performance Options)
button under Performance.
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4 Check the allocated size under the Virtual Memory group, the file size
will be listed after the text “Total Paging File Size For All Drives”. You
might have to click the Advanced tab first in order to see the allocated
size.
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Use Viewing Tools

When working in 3D, you'll often want to display different views so that you can see and
verify the 3D effects in your drawing.

Specify 3D Views
You can control the 3D navigation display, projection, and visualization tools.

Overview of 3D Views
You can create an interactive view of your drawing in the current viewport.

Using the 3D viewing and navigation tools, you can navigate through a drawing,
set up a camera for a specific view, and create animations to share your design
with others. You can orbit, swivel, walk, and fly around a 3D model, set up a
camera, create a preview animation, and record motion path animations that
you can distribute to others to visually convey the intent of your design.

Quick Reference

Commands

3DCLIP

Starts an interactive 3D view and opens the Adjust Clipping Planes window.

3DCORBIT

Rotates the view in 3D space with continuous motion.

3DDISTANCE

Starts the interactive 3D view and makes objects appear closer or farther away.
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3DFLY

Changes the 3D view in a drawing interactively to create the appearance of
flying through the model.

3DFORBIT

Rotates the view in 3D space without constraining roll.

3DORBIT

Rotates the view in 3D space, but constrained to horizontal and vertical orbit
only.

3DORBITCTR

Sets the center of rotation in 3D Orbit view.

3DPAN

When a drawing is in a Perspective view, starts the interactive 3D view and
enables you to drag the view horizontally and vertically.

3DSWIVEL

Changes the target of the view in the direction that you drag.

3DWALK

Changes the 3D view in a drawing interactively to create the appearance of
walking through the model.

3DZOOM

Zooms in and out in a perspective view.

ANIPATH

Saves an animation file of a camera moving or panning in a 3D model.

CAMERA

Sets a camera and target location to create and save a 3D perspective view
of objects.

VIEW

WALKFLYSETTINGS

Controls the walk and fly navigation settings.
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System Variables

CAMERADISPLAY

Turns the display of camera objects on or off.

CAMERAHEIGHT

Specifies the default height for new camera objects.

Use 3D Navigation Tools
3D navigation tools allow you to view objects in a drawing from different
angles, heights, and distances.

Use the following 3D tools to orbit, swivel, adjust distance, zoom, and pan in
a 3D view.

■ 3D Orbit. Moves around a target. The target of the view stays stationary
while the camera location, or point of view, moves. The center of the
viewport, not the center of the objects you’re viewing, is the target point.

■ Constrained Orbit. Constrains 3D Orbit along the XY plane or the Z axis.
(3DORBIT)

■ Free Orbit. Orbits in any direction without reference to the planes. The
point of view is not constrained along the XY plane of the Z axis.
(3DFORBIT)

■ Continuous Orbit. Orbits continuously. Click and drag in the direction
you want the continuous orbit to move, and then release the mouse button.
The orbit continues to move in that direction. (3DCORBIT)

■ Adjust Distance. Changes the distance of objects as you move the cursor
vertically. You can make objects appear larger or smaller, and you can
adjust the distance. (3DDISTANCE)

■ Swivel. Simulates panning with a camera in the direction that you drag.
The target of the view changes. You can swivel the view along the XY plane
or along the Z axis. (3DSWIVEL)

■ Zoom. Simulates moving the camera closer to an object or farther away.
Zooming in magnifies the image. (3DZOOM)

■ Pan. Starts the interactive 3D view and enables you to drag the view
horizontally and vertically. (3DPAN)
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Animate a Navigation

You can create a preview animation of any navigation. Create the preview to
fine-tune your animation before you create a motion path animation. You
can create, record, play back, and save the animation. For more information
about previewing an animation, see Create Preview Animations on page 403.
For more information about creating motion path animations, see Create
Motion Path Animations on page 406.

To start 3D Orbit view

1 Select one or more objects that you want to view with 3DORBIT or select
no objects if you want to view the entire drawing.

NOTE OLE objects and raster objects do not appear in the 3D Orbit view.

2 Click View tab  ➤  Navigate panel  ➤ Orbit. 

3 Use one of the following methods to orbit around the objects:

■ To rotate along the XY plane, click in the drawing and drag the cursor
left or right.

■ To rotate along the Z axis, click in the drawing and drag the cursor
up or down.

■ To allow unconstrained orbiting along the XY plane and the Z axis,
press Shift while you drag the cursor. An arcball is displayed and you
can use the 3D Free Orbit (3DFORBIT) interaction.

4 Press Enter.

Command entry: 3DORBIT

Toolbar: 3D Navigation  

To switch to a different 3D navigation mode

1 Start any 3D navigation command.

2 Right-click in the drawing area. Click Other Navigation Modes, and click
another navigation mode.
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To choose a parallel or perspective projection in a 3D view

1 Start any 3D navigation command.

2 Right-click in the drawing area. Click Parallel or Perspective.

A check mark is displayed next to the current projection.

To change a visual style in a 3D view

1 Start any 3D navigation command, and right-click in the drawing area.
Click Visual Styles.

2 Select a visual style.

For more information about visual styles, see Use a Visual Style to Display
Your Model on page 293.

To start a continuous orbit

1 Click View tab  ➤  Navigate panel  ➤  Continuous Orbit. 

2 Click in the drawing and drag the cursor to start a continuous motion.
When you release cursor, the orbit continues in the direction that you
were dragging.

Command entry: 3DCORBIT

Toolbar: Orbit 

To reset a view

■ Start any 3D navigation command, and right-click in the drawing area.
Click Reset View.

The view that was originally displayed when you entered the 3D navigation
mode is restored.

To use preset views

1 Start any 3D navigation command, and right-click in the drawing area.
Click Preset Views.

2 Click a view.
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To display a named view

1 Start any 3D navigation command, and right-click in the drawing area.
Click Named Views.

2 Click a named view or a camera.

Quick Reference

Commands

3DCORBIT

Rotates the view in 3D space with continuous motion.

3DDISTANCE

Starts the interactive 3D view and makes objects appear closer or farther
away.

3DFORBIT

Rotates the view in 3D space without constraining roll.

3DORBIT

Rotates the view in 3D space, but constrained to horizontal and vertical orbit
only.

3DORBITCTR

Sets the center of rotation in 3D Orbit view.

3DPAN

When a drawing is in a Perspective view, starts the interactive 3D view and
enables you to drag the view horizontally and vertically.

3DSWIVEL

Changes the target of the view in the direction that you drag.

3DZOOM

Zooms in and out in a perspective view.

System Variables

PERSPECTIVE

Specifies whether the current viewport displays a perspective view.
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PERSPECTIVECLIP

Determines the location of eyepoint clipping.

Walk and Fly Through a Drawing
You can simulate walking and flying through a 3D drawing.

When you walk through a model, you travel along the XY plane. When you
fly through a model, you are not constrained by the XY plane, so you appear
to “fly” over an area in a model.

Use the Keyboard and Mouse Interactions to Walk and Fly

You can use a standard set of keys and mouse interactions to walk and fly
through a drawing. Use the four arrow keys or the W, A, S, and D keys to move
up, down, left, or right. To toggle between walk and fly mode, press the F key.
To specify the direction of the view, drag the mouse in the direction you want
to look.

NOTE The Walk and Fly Navigation Mappings balloon provides information about
the keyboard and mouse actions that control walk and fly modes. The appearance
of the balloon depends on the display option selected in the Walk and Fly settings
dialog box.

Display a Top View of a Model as You Walk or Fly

You can keep track of your position in a 3D model as you walk or fly through
it. When you start 3DWALK or 3DFLY, the Position Locator window displays
a top view of the model. A position indicator shows your location in
relationship to the model, and a target indicator shows the model you are
walking or flying through. You can edit the position settings in the Position
Locator window before you start walk or fly mode, or while you are moving
in the model.

NOTE If performance slows when the Position Locator window is displayed, you
can close the window.

Specify Walk and Fly Settings

Specify walk and fly settings in the 3D Navigate panel on the the ribbon  on
page 22or in the Walk and Fly Settings dialog box. You can set the default
step size, the number of steps per second, and other display settings.
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Animate Walk and Fly Navigation

You can create a preview animation of any navigation, including walking and
flying through a drawing. Create the preview to fine-tune your animation
before you create a motion path animation. You can create, record, play back,
and save the animation. For more information about previewing an animation,
see Create Preview Animations on page 403. For more information about
creating motion path animations, see Create Motion Path Animations on page
406.

To start walk mode

■ Click View menu  ➤  Walk and Fly  ➤  Walk.

Command entry: 3DWALK

Toolbar: 3D Navigation, Walk and Fly 
Shortcut menu: Start any 3D navigation command, right-click in the drawing
area, and select Other Navigation Modes  ➤  Walk.

To start fly mode

■ Click View menu  ➤  Walk and Fly  ➤ Fly.

Command entry: 3DFLY

Toolbar: 3D Navigation, Walk and Fly 
Shortcut menu: Start any 3D navigation command, right-click in the drawing
area, and select Other Navigation Modes  ➤  Fly.

To specify Walk or Fly settings

1 Click View menu  ➤  Walk and Fly  ➤  Walk and Fly Settings.

2 In the Walk and Fly Settings dialog box, under Settings, click the button
next to a display option.

3 In the Display Position Locator Window option, clear the check box if
you do not want to display the window.

NOTE If performance slows when this window is displayed, you may want
to close the Position Locator window.
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4 In the Current Drawing Settings section, under Walk/Fly Step Size, enter
a number to set the step size in drawing units.

5 In the Steps Per Second option, enter a number between 1 and 30.

6 Click OK.

Command entry: WALKFLYSETTINGS

Toolbar: 3D Navigation, Walk and Fly 

To change the viewing position in the Position Locator window

1 Do one of the following:

■ Click View menu  ➤  Walk and Fly  ➤  Walk.

■ Click View menu  ➤  Walk and Fly  ➤ Fly.

2 In the Position Locator window, Preview area, click the position indicator
(a colored dot) and drag it to a new position.

3 If the target indicator is displayed, click it and drag it to the new target.

4 In the General section, make any changes to the current settings.

5 Continue walking or flying through the model.

Toolbar: Walk and Fly
Command entry: 3DWALK, 3DFLY

To turn off the Position Locator window

1 Click View menu  ➤  Walk and Fly  ➤  Walk and Fly Settings.

2 In the Walk and Fly Settings dialog box, clear the check mark next to
Display Position Locator. Click OK.

Command entry: WALKFLYSETTINGS

Toolbar: 3D Navigation, Walk and Fly  
Shortcut menu: While in any 3D Navigation mode, right-click. Click Walk
And Fly Settings.
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Quick Reference

Commands

3DFLY

Changes the 3D view in a drawing interactively to create the appearance of
flying through the model.

3DWALK

Changes the 3D view in a drawing interactively to create the appearance of
walking through the model.

WALKFLYSETTINGS

Controls the walk and fly navigation settings.

Create a 3D Dynamic View (DVIEW)
You can change a view without interrupting your current operation using a
feature that combines panning and zooming.

With dynamic viewing, you can display the effects of changing your viewpoint
as you make the changes. Using this method, you can also simplify your view
temporarily by choosing only the objects that you need to determine the view.
Alternatively, if you press Enter without selecting any objects, 3D Dynamic
View displays a model of a small house instead of your actual drawing. You
can use this house to define the viewing angle and distance. When your
adjustments are complete and you exit the command, the changes are applied
to the entire 3D model in the current view.

NOTE More powerful options for dynamic viewing in 3D are available in the
3DORBIT command. For more information, see Use 3D Navigation Tools on page
323.

Set Clipping Planes

You can create cutaway, or section, views of your drawing by positioning front
and back clipping planes that control the visibility of objects based on their
distance from a theoretical camera. You can move the clipping planes
perpendicular to the line of sight between the camera and target (where the
camera is pointing). Clipping removes the display of objects from the front
and back of clipping planes. The following illustration shows how clipping
planes work:
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NOTE You can also set clipping planes when you create a camera glyph. For more
information, see Change Camera Properties on page 398.

To set clipping planes (DVIEW)

1 At the Command prompt, enter dview.

2 Select the objects on which to base the view.

3 At the Command prompt, enter cl (Clip).

4 Enter f to set a front clipping plane or b to set a back clipping plane, or
press Enter.

5 Position the clipping plane by dragging the slider or entering a distance
from the target.

6 Press Enter to exit the command.

NOTE You can also set clipping planes when you create a camera glyph. For
more information, see Change Camera Properties on page 398.

Command entry: DVIEW

To display the default view and UCS

■ Click View menu  ➤  3D Views  ➤  Plan View  ➤  World UCS.

Command entry: PLAN
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Quick Reference

Commands

DVIEW

Defines parallel projection or perspective views by using a camera and target.

PLAN

Displays the plan view of a specified user coordinate system

System Variables

VIEWDIR

Stores the viewing direction in the current viewport, expressed in UCS
coordinates.

VIEWTWIST

Stores the view rotation angle for the current viewport measured relative to
the WCS.

WORLDVIEW

Use ViewCube
ViewCube provides visual feedback of the current orientation of a model. You
can use the ViewCube tool to adjust the viewpoint of the model.

Overview of ViewCube
ViewCube is a 3D navigation tool that is displayed when you are working in
a 3D visual style. With ViewCube, you can switch between standard and
isometric views.

The ViewCube tool is a persistent, clickable and draggable interface that you
use to switch between standard and isometric views of your model. When you
display the ViewCube tool, it is shown in one of the corners of the window
over the model in an inactive state. While the ViewCube tool is inactive, it
provides visual feedback about the current viewpoint of the model as view
changes occur. When the cursor is positioned over the ViewCube tool, it
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becomes active; you can switch to one of the available preset views, roll the
current view, or change to the Home view of the model.

FaceCornerEdge

Control the Appearance of ViewCube

The ViewCube tool is displayed in one of two states: inactive and active. When
the ViewCube tool is inactive, it appears partially transparent by default so
that it does not obscure the view of the model. When active, it is opaque and
may obscure the view of the objects in the current view of the model.

In addition to controlling the inactive opacity level of the ViewCube tool,
you can also control the following properties for the ViewCube tool:

■ Size

■ Position

■ Display of the UCS menu

■ Default orientation

■ Compass display

Using the Compass
The compass is displayed below the ViewCube tool and indicates which
direction North is defined for the model. You can click a cardinal direction
letter on the compass to rotate the model, or you can click and drag one of
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the cardinal direction letters or the compass ring to interactively rotate the
model around the center of the view.

To display or hide the ViewCube tool

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 Click View tab ➤ 3D Palettes panel ➤ Visual Styles. 

3 Click in the viewport to make it current.

4 In the Visual Styles Manager, double-click one of the sample images of
the available visual styles other than 2D Wireframe.

Command entry: NAVVCUBE, VISUALSTYLES

To control the position of the ViewCube tool

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 Right-click the ViewCube tool and click ViewCube Settings.

3 In the ViewCube Settings dialog box, under Display, select one of the
available positions from the On-screen Position drop-down list.

4 Click OK.

Command entry: NAVVCUBE
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To control the size of the ViewCube tool

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 Right-click the ViewCube tool and click ViewCube Settings.

3 In the ViewCube Settings dialog box, Display, ViewCube Size, select or
clear Automatic. If Automatic is cleared, drag the ViewCube Size slider
left or right.

Dragging the slider to the left decreases the size of the ViewCube tool,
while dragging the slider to the right increases the size of the ViewCube
tool.

4 Click OK.

Command entry: NAVVCUBE

To control the inactive opacity of the ViewCube tool

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 Right-click the ViewCube tool and click ViewCube Settings.

3 In the ViewCube Settings dialog box, under Display, drag the Inactive
Opacity slider left or right.

Dragging the slider to the left increases the transparency of the ViewCube
tool, while dragging the slider to the right increases the opacity of the
ViewCube tool.

4 Click OK.

Command entry: NAVVCUBE

To display the compass for the ViewCube tool

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 Right-click the ViewCube tool and click ViewCube Settings.

3 In the ViewCube Settings dialog box, select Show Compass Below the
ViewCube.
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The compass is displayed below the ViewCube tool and indicates which
direction North is in the model.

4 Click OK.

Command entry: NAVVCUBE

Quick Reference

Commands

NAVVCUBE

Controls the visibility and display properties of the ViewCube tool.

OPTIONS

Customizes the program settings.

System Variables

NAVVCUBEDISPLAY

Controls the display of the ViewCube tool in the current viewport when the
3D graphics system is active.

NAVVCUBELOCATION

Identifies the corner in a viewport where the ViewCube tool is displayed.

NAVVCUBEOPACITY

Controls the opacity of the ViewCube tool when inactive.

NAVVCUBESIZE

Specifies the size of the ViewCube tool.

ViewCube Menu
Use the ViewCube menu to restore and define the Home view of a model,
switch between view projection modes, and change the interactive behavior
and appearance of the ViewCube tool.

The ViewCube menu has the following options:

■ Home. Restores the Home view saved with the model.
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■ Parallel. Switches the current view to parallel projection.

■ Perspective. Switches the current view to perspective projection.

■ Perspective with Ortho Faces. Switches the current view to perspective
projection unless the current view aligns with a face view defined on the
ViewCube tool.

■ Set Current View as Home. Defines the Home view of the model based on
the current view.

■ ViewCube Settings. Displays the dialog box where you can adjust the
appearance and behavior of the ViewCube tool.

■ Help. Launches the online Help system and displays the topic for the
ViewCube tool.

To display the ViewCube menu

To display the ViewCube menu, do one of the following:

■ Right-click on the compass, Home icon, or the main area of the ViewCube
tool.

■ Click the context menu button located below the ViewCube tool.

Command entry: NAVVCUBE

Quick Reference

Commands

NAVVCUBE

Controls the visibility and display properties of the ViewCube tool.

OPTIONS

Customizes the program settings.

System Variables

PERSPECTIVE

Specifies whether the current viewport displays a perspective view.
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Reorient the View of a Model with ViewCube
The ViewCube tool offers many intuitive ways to reorient the view of a model.

Reorient the Current View
You can reorient the current view of a model by clicking predefined areas on
the ViewCube tool or dragging the ViewCube tool.

The ViewCube tool provides twenty-six defined areas you can click to change
the current view of a model. The twenty-six defined areas are categorized into
three groups: corner, edge, and face. Of the twenty-six defined areas, six of
the areas represent standard orthogonal views of a model: top, bottom, front,
back, left, and right. Orthogonal views are set by clicking one of the faces on
the ViewCube tool.

You use the other twenty defined areas to access angled views of a model.
Clicking one of the corners on the ViewCube tool reorients the current view
of the model to a three-quarter view, based on a viewpoint defined by three
sides of the model. Clicking one of the edges reorients the view of the model
to a half view based on two sides of the model.

FaceCornerEdge

You can also click and drag the ViewCube tool to reorient the view of a model
to a custom viewpoint other than one of the twenty-six predefined viewpoints.
As you drag, the cursor changes to indicate that you are reorienting the current
view of the model. If you drag the ViewCube tool close to one of the preset
orientations and it is set to snap to the closest view, the ViewCube tool rotates
to the closest preset orientation.

The outline of the ViewCube tool helps you identify the form of orientation
it is in: freeform or constrained. When the ViewCube tool is in freeform
orientation, not orientated to one of the twenty-six predefined views, its
outline is displayed as dashed. The ViewCube tool is outlined in a solid
continuous line when it is constrained to one of the predefined views.

338 | Chapter 10   Use Viewing Tools



Roll a Face View
When you view a model from one of the face views, two roll arrow buttons
are displayed near the ViewCube tool. Use the roll arrows to rotate the current
view 90 degrees clockwise or counterclockwise around the center of the view.

Switch to an Adjacent Face
When the ViewCube tool is active while viewing a model from one of the face
views, four orthogonal triangles are displayed near the ViewCube tool. You
use these triangles to switch to one of the adjacent face views.

To interactively reorient the view

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 Click the ViewCube tool or the compass below the ViewCube tool, hold
down the left mouse button, and drag in the direction that you want to
orbit the model.

Command entry: NAVVCUBE
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To view an adjacent face

NOTE Make sure a face view is current.

■ Click one of the triangles displayed near the edges of the ViewCube tool.

Command entry: NAVVCUBE

To interactively reorient the view

■ Click the ViewCube tool, hold down the left mouse button, and drag in
the direction that you want to orbit the model.

Command entry: NAVVCUBE

To use animated transitions when reorienting a view to a preset orientation

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 Right-click the ViewCube tool, and click ViewCube Settings.

3 In the ViewCube Settings dialog box, under When Clicking on the
ViewCube, select Use View Transitions when Switching Views.

Transitions from one view to another appear animated when you click
a predefined area on the ViewCube tool.

4 Click OK.

Command entry: NAVVCUBE

To automatically fit the model after a view orientation

1 Click View tab  ➤  Views panel  ➤  ViewCube. 
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2 Right-click the ViewCube tool, and click ViewCube Settings.

3 In the ViewCube Settings dialog box, under When Clicking on the
ViewCube, click Zoom to Extents After View Change.

Clicking a predefined area of the ViewCube tool reorients the model and
fits the model to the window.

4 Click OK.

Command entry: NAVVCUBE

To roll a face view

NOTE Make sure a face view is displayed.

■ Click one of the roll arrows displayed above and to the right of the
ViewCube tool.
The left roll arrow rotates the view 90 degrees counterclockwise; the right
roll arrow rotates the view 90 degrees clockwise.

Command entry: NAVVCUBE

Quick Reference

Commands

NAVVCUBE

Controls the visibility and display properties of the ViewCube tool.

OPTIONS

Customizes the program settings.

Set the View Projection Mode
View projection produces realistic visual effects of a model.

The ViewCube tool supports two different view projections: perspective and
orthographic. Orthographic projection is also referred to as parallel projection.
Perspective projected views are calculated based on the distance from a
theoretical camera and target point. The shorter the distance between the
camera and the target point, the more distorted the perspective effect appears;
greater distances produce less distorted affects on the model. Orthographic
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projected views display all the points of a model being projected parallel to
the screen.

Orthographic projection mode makes it easier to work with a model due to
all the edges of the model appearing as the same size, regardless of the distance
from the camera. Orthographic projection mode though, is not how you
commonly see objects in the real world. Objects in the real world are seen in
perspective projection. So when you want to generate a rendering or hidden
line view of a model, using perspective projection will give the model a more
realistic look.

The following illustration shows the same model viewed from the same viewing
direction, but with different view projections.

PerspectiveParallel

When you change the view for a model, the view is updated using the previous
projection mode unless the current projection mode for the ViewCube tool
is Perspective with Ortho Faces. The Perspective with Ortho Faces mode forces
all views to be displayed in perspective projection unless the model is being
viewed from one of the face views: top, bottom, front, back, left, or right.

To change the view projection mode

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 Right-click on the ViewCube tool and click one of the following options:

■ Parallel

■ Perspective

■ Perspective with Ortho Faces

Command entry: NAVVCUBE
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Quick Reference

Commands

NAVVCUBE

Controls the visibility and display properties of the ViewCube tool.

OPTIONS

Customizes the program settings.

System Variables

NAVVCUBEDISPLAY

Controls the display of the ViewCube tool in the current viewport when the
3D graphics system is active.

PERSPECTIVE

Specifies whether the current viewport displays a perspective view.

Home View
You can define a Home view for a model so you can restore a familiar view
when you use the navigation tools.

The Home view is a special view stored with a model that makes it easy to
return to a known or familiar view. You can define any view of the model as
the Home view. The saved Home view can be applied to the current view by
clicking the Home button above the ViewCube tool or from the ViewCube
menu.

When you open a drawing that was created in a release earlier than AutoCAD
2008, the extents of a model are used as the default Home view. Drawings
created with AutoCAD 2010 have a Home view defined with a Top/Left/Front
orientation. While you can use the Home view to navigate back to a familiar
view, you can also use it to generate the thumbnail preview when you save a
model instead of using the last saved view.

The Thumbnail Preview Settings dialog box is used to control the thumbnail
preview for a drawing when saved (the Home or the last saved view). Along
with defining which view is used for the thumbnail preview, you can also set
the Home view back to its default view.
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To define the Home view

■ Right-click the ViewCube tool, and click Set Current View as Home.

Ribbon: View tab  ➤ Views panel  ➤ ViewCube Display
Menu: View ➤ Display ➤ ViewCube ➤ On
Command entry: NAVVCUBE

To reorient the model to the Home view

Use one of the following methods:

■ Click the Home button (  ) located near the ViewCube tool.

■ Right-click the ViewCube tool, and click Go Home.

Ribbon: View tab  ➤ Views panel  ➤ ViewCube Display
Menu: View ➤ Display ➤ ViewCube ➤ On
Command entry: NAVVCUBE

To reset the Home view to the default view

1 Click Tools menu  ➤ Options.

2 In the Options dialog box, Open and Save tab, under File Save, click
Thumbnail Preview Settings.

3 In the Thumbnail Preview Settings dialog box, click Reset Home to
Default.

4 Click OK to close the Thumbnail Preview Settings dialog box.

5 Click OK to close the Options dialog box.

Command entry: OPTIONS
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Quick Reference

Commands

NAVVCUBE

Controls the visibility and display properties of the ViewCube tool.

OPTIONS

Customizes the program settings.

Examine Individual Objects with ViewCube
You can examine individual objects of a model using the ViewCube tool.

With the ViewCube tool, you can define the center of a view based on one or
more selected objects. After you select an object or objects and you use the
ViewCube tool is used to change the orientation of the model, the model
rotates around the center of the view. The center of the view is calculated by
the extents of the selected objects.

To examine an individual object with ViewCube

1 In the model, select one or more objects to define the centerpoint of the
view.

2 Click one of the preset locations on the ViewCube tool, or click and drag
the ViewCube tool to reorient the view of the model.

The ViewCube tool reorients the view of the model based on the
centerpoint of the selected objects.

Ribbon: View tab  ➤ Views panel  ➤ ViewCube Display
Menu: View ➤ Display ➤ ViewCube ➤ On
Command entry: NAVVCUBE

Quick Reference

Commands

NAVVCUBE

Controls the visibility and display properties of the ViewCube tool.
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Change the UCS with ViewCube
With the ViewCube tool you can change the current UCS for the model to
one of the named UCSs saved with the model or you can define a new UCS.

The UCS menu, located below the ViewCube tool, displays the name of the
current UCS in the model. From the menu, you can restore one of the named
UCSs saved with the model, switch to WCS, or define a new UCS. With the
WCS item on the menu, you can switch the coordinate system from the current
UCS to WCS. With the new UCS, you can rotate the current UCS based on
one, two, or three points to define a new UCS. When you click New UCS, a
new UCS is defined with the default name of Unnamed. To save the UCS with
a name so it can be restored later, use the Named option.

You can orient the ViewCube tool with the current UCS or WCS. By orienting
the ViewCube tool with the current UCS, you know in which direction you
are modeling. Orienting the ViewCube tool with the WCS, you can navigate
the model based on the North and Up directions of the model. The settings
for controlling the orientation of the ViewCube tool are in the ViewCube
Settings dialog box.

To control the display of the UCS menu

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 Right-click on the ViewCube tool and click ViewCube Settings.

3 In the ViewCube Settings dialog box, under Display, click Show UCS
Menu.

The UCS menu is displayed below the ViewCube tool. You can see which
UCS is current and switch to a different named UCS.
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4 Click OK.

Command entry: NAVVCUBE

To switch to a different UCS

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 On the UCS menu located below the ViewCube tool, click the down
arrow next to the current UCS name.

3 Select a named UCS from the list.

Command entry: NAVVCUBE

To switch to WCS

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 On the UCS menu located below the ViewCube tool, click the down
arrow next to the current UCS name.

3 Select a WCS from the list.

Command entry: NAVVCUBE

To set the orientation of the ViewCube tool based on the current UCS or WCS

1 Click View tab  ➤  Views panel  ➤  ViewCube. 

2 Right-click the ViewCube tool and click ViewCube Settings.

3 In the ViewCube Settings dialog box, select Orient ViewCube to Current
UCS.

The ViewCube tool aligns with the current UCS.

4 Click OK.

Command entry: NAVVCUBE
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Quick Reference

Commands

NAVVCUBE

Controls the visibility and display properties of the ViewCube tool.

OPTIONS

Customizes the program settings.

UCS

Manages user coordinate systems.

System Variables

NAVVCUBEORIENT

Controls whether the ViewCube tool reflects the current UCS or WCS.

Navigate with SteeringWheels
SteeringWheels are tracking menus that allow you to access different 2D and
3D navigation tools from a single tool.

Overview of SteeringWheels
SteeringWheels are tracking menus that are divided into different sections
known as wedges. Each wedge on a wheel represents a single navigation tool.

SteeringWheels, also known as wheels, can save you time by combining many
of the common navigation tools into a single interface. Wheels are specific
to the context from which a model is being viewed.

348 | Chapter 10   Use Viewing Tools



The following illustrations show the different wheels available:

2D Navigation
Wheel

Tour Building
Wheel (Basic
Wheel)

View Object Wheel
(Basic Wheel)

Full Navigation
Wheel

Mini
Tour

Mini
View Ob-

Mini Full
Naviga-

Building
Wheel

ject
Wheel

tion
Wheel

First Contact Balloon

When a SteeringWheel is displayed the first time and a 3D view is current,
the First Contact balloon for the wheels is displayed. The First Contact balloon
serves as an introduction to the purpose of the wheels and shows how to use
them.
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Display and Use Wheels

Pressing and dragging on a wedge of a wheel is the primary mode of
interaction. After a wheel is displayed, click one of the wedges and hold down
the button on the pointing device to activate the navigation tool. Drag to
reorient the current view. Releasing the button returns you to the wheel.

Appearance of the Wheels

You can control the appearance of the wheels by switching between the
different styles of wheels that are available, or by adjusting the size and opacity.
Wheels (except the 2D Navigation wheel) are available in two different styles:
big and mini.

The size of a wheel controls how large or small the wedges and labels appear
on the wheel; the opacity level controls the visibility of the objects in the
model behind the wheel.

Wheel Tooltips, Tool Messages, and Tool Cursor Text

Tooltips are displayed for each button on a wheel as the cursor is moved over
them. The tooltips appear below the wheel and identify what action will be
performed if the wedge or button is clicked.

Similar to tooltips, tool messages and cursor text are displayed when you use
one of the navigation tools from a wheel. Tool messages are displayed when
a navigation tool is active; they provide basic instructions about using the
tool. Tool cursor text displays the name of the active navigation tool near the
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cursor. Disabling tool messages and cursor text only affects the messages that
are displayed when using the mini wheels or the big Full Navigation wheel.

To display a wheel

Do one of the following:

■ Click View tab  ➤  Navigate panel  ➤  SteeringWheels flyout  ➤  click one

of the available SteeringWheels. 

■ Click View menu  ➤  SteeringWheels

■ Right-click over the drawing window and click SteeringWheels

■ On the status bar, click SteeringWheels

Command entry: NAVSWHEEL

To close a wheel

Use one of the following methods to close the wheel:

■ Press Esc or Enter

■ Click the Close button

■ Right-click on the wheel and click Close Wheel

Command entry: NAVSWHEEL

To change the size of the wheels

1 Click View tab  ➤  Navigate panel  ➤  SteeringWheels flyout  ➤  click

one of the available SteeringWheels. 

2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, under Big Wheels or Mini
Wheels, slide the Wheel Size slider left or right.

Sliding the slider to the left decreases the size of the wheel, while sliding
the slider to the right increases the size of the wheel.

4 Click OK.

Menu: View ➤  SteeringWheels
Command entry: NAVSWHEEL
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Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

To change the opacity of the wheels

1 Click View tab  ➤  Navigate panel  ➤  SteeringWheels flyout  ➤  click

one of the available SteeringWheels. 

2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, under Big Wheels or Mini
Wheels, slide the Wheel Opacity slider left or right.

Sliding the slider to the left increases the transparency of the wheel, while
sliding the slider to the right decreases the transparency of the wheel
making it more opaque.

4 Click OK.

Command entry: NAVSWHEEL
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

To control the startup placement of the wheels

1 Click View tab  ➤  Navigate panel  ➤  SteeringWheels flyout  ➤  click

one of the available SteeringWheels. 

2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, under Display, click Show the
Pinned Wheel at Startup.

The wheel is displayed as pinned when it is displayed; when left
unchecked, the wheel follows the position of the cursor.

4 Click OK.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

352 | Chapter 10   Use Viewing Tools



Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

To enable tooltips for wheels

1 Click View tab  ➤  Navigate panel  ➤  SteeringWheels flyout  ➤  click

one of the available SteeringWheels. 

2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, under Display, click Show
Tooltips.

Tooltips are displayed for each wedge and buttons on a wheel when the
cursor hovers over the wheel.

4 Click OK.

Menu: View ➤  SteeringWheels
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

To enable messages for wheels

1 Click View tab  ➤  Navigate panel  ➤  SteeringWheels flyout  ➤  click

one of the available SteeringWheels. 

2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, under Display, click Show
Tool Messages.

Messages are displayed when you use the navigation tools.

4 Click OK.

Menu: View ➤  SteeringWheels
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL
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Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

OPTIONS

Customizes the program settings.

System Variables

NAVSWHEELMODE

Specifies the current mode of the SteeringWheel.

NAVSWHEELOPACITYBIG

Controls the opacity of the big SteeringWheels.

NAVSWHEELOPACITYMINI

Controls the opacity of the mini SteeringWheels.

NAVSWHEELSIZEBIG

Specifies the size of the big SteeringWheels.

NAVSWHEELSIZEMINI

Specifies the size of the mini SteeringWheels.

Wheel Menu
From the Wheel menu, you can switch between different wheels and change
the view of the model.

Use the Wheel menu to switch between the big and mini wheels that are
available, go to the Home view, change the preferences of the current wheel,
and control the behavior of the orbit, look, and walk 3D navigation tools. The
menu items available on the Wheel menu are dependent on the current wheel
and program.

The Wheel menu has the following options:

■ Mini View Object Wheel. Displays the mini View Object wheel.

■ Mini Tour Building Wheel. Displays the mini Tour Building wheel.
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■ Mini Full Navigation Wheel. Displays the mini Full Navigation wheel.

■ Full Navigation Wheel. Displays the big Full Navigation wheel.

■ Basic Wheels. Displays the big View Object or Tour Building wheel.

■ Go Home. Goes to the Home view saved with the model.

■ Fit to Window. Resizes and centers the current view to display all objects.

■ Restore Original Center. Restores the center point of the view to the extents
of the model.

■ Level Camera. Rotates the current view so it is relative to the XY ground
plane.

■ Increase Walk Speed. Increases the walk speed used for the Walk tool by
two times.

■ Decrease Walk Speed. Decreases the walk speed used for the Walk tool by
one half.

■ Help. Launches the online Help system and displays the topic about the
wheels.

■ SteeringWheel Settings. Displays the dialog box where you can adjust the
preferences for the wheels.

■ Close Wheel. Closes the wheel.

To display the Wheel menu

■ Click the down arrow in the lower-right corner of the wheel or right-click
on the wheel.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
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Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

System Variables

NAVSWHEELMODE

Specifies the current mode of the SteeringWheel.

Navigation Wheels
You can choose from several different wheels. Some wheels are designed for
2D navigation while other wheels are better suited for 3D navigation.

2D Navigation Wheel
The 2D Navigation wheel is for basic navigation of 2D views.

With this wheel you can access basic 2D navigation tools; it is particularly
useful when you do not have a pointing device with a scroll wheel. The wheel
includes the Pan and Zoom tools.

The 2D Navigation wheel wedges have the following options:

■ Pan. Repositions the current view by panning.

■ Zoom. Adjusts the magnification of the current view.

■ Rewind. Restores the most recent view orientation. You can move backward
or forward by clicking and dragging left or right.
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To switch to the 2D navigation wheel

■ Click View tab  ➤ Navigate panel  ➤ SteeringWheels flyout  ➤ 2D Wheel.

Command entry: NAVSWHEEL
Shortcut menu: SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

System Variables

NAVSWHEELMODE

Specifies the current mode of the SteeringWheel.

View Object Wheels
The View Object wheels are used for 3D navigation. Use these wheels to view
individual or groups of objects in a model.

With the View Object wheels (big and mini), you can view individual objects
or features in a model. The big View Object wheel is optimized for new 3D
users while the mini View Object wheel is optimized for experienced 3D users.
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Big View Object Wheel

The big View Object wheel wedges have the following options:

■ Center. Specifies a point on a model to adjust the center of the current
view or change the target point used for some of the navigation tools.

■ Zoom. Adjusts the magnification of the current view.

■ Rewind. Restores the most recent view orientation. You can move backward
or forward by clicking and dragging left or right.

■ Orbit. Rotates the current view around a fixed pivot point.

Mini View Object Wheel

The mini View Object wheel wedges have the following options:

■ Zoom (Top wedge). Adjusts the magnification of the current view.

■ Rewind (Right wedge). Restores the most recent view. You can move
backward or forward by clicking and dragging left or right.

■ Pan (Bottom wedge). Repositions the current view by panning.

■ Orbit (Left wedge). Rotates the current view around a fixed pivot point.

NOTE When the mini wheel is displayed, you can press and hold the middle
mouse button to pan, scroll the wheel button to zoom in and out, and hold the
SHIFT key while pressing and holding the middle mouse button to orbit the model.

To switch to the big View Objects wheel

Do one of the following:

■ Click View tab  ➤ Navigate panel  ➤ SteeringWheels flyout  ➤ Basic View

Object Wheel. 

■ Right-click on the wheel, and click Basic Wheels  ➤  View Object Wheel.

Command entry: NAVSWHEEL
Shortcut menu: SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
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To switch to the mini View Objects wheel

Do one of the following:

■ Click View tab  ➤ Navigate panel  ➤ SteeringWheels flyout  ➤ Mini View

Object Wheel. 

■ Right-click on the wheel, and click Mini View Object Wheel.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

System Variables

NAVSWHEELMODE

Specifies the current mode of the SteeringWheel.

Tour Building Wheels
The Tour Building wheels are for 3D navigation. Use these wheels to navigate
within the interior of a model.

With the Tour Building wheels (big and mini), you can move through a model,
such as a building, an assembly line, ship, or oil rig. You can also walk through
and navigate around a model. The big Tour Building wheel is optimized for
new 3D users while the mini Tour Building wheel is optimized for experienced
3D users.
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Big Tour Building Wheel

The big Tour Building wheel wedges have the following options:

■ Forward. Adjusts the distance between the current point of view and the
defined pivot point of the model. Clicking once moves forward half the
distance as far as the object you clicked.

■ Look. Swivels the current view.

■ Rewind. Restores the most recent view. You can move backward or forward
by clicking and dragging left or right.

■ Up/DownTool. Slides the current view of a model along the Z axis of the
model.

Mini Tour Building Wheel

The mini Tour Building wheel wedges have the following options:

■ Walk (Top wedge). Simulates walking through a model.

■ Rewind (Right wedge). Restores the most recent view. You can move
backward or forward by clicking and dragging left or right.

■ Up/Down (Bottom wedge). Slides the current view of a model along the
Z axis of the model.

■ Look (Left wedge). Swivels the current view.

NOTE When the mini wheel is displayed, you can press and hold the middle
mouse button to pan, scroll the wheel button to zoom in and out, and hold the
SHIFT key while pressing and holding the middle mouse button to orbit the model.
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To switch to the big Tour Building wheel

Do one of the following:

■ Click View tab  ➤ Navigate panel  ➤ SteeringWheels flyout  ➤ Basic Tour

Building Wheel. 

■ Right-click on the wheel, and click Basic Wheels  ➤  Tour Building Wheel.

Command entry: NAVSWHEEL

To switch to the mini Tour Building wheel

Do one of the following:

■ Click View tab  ➤  Navigate panel  ➤  SteeringWheels flyout  ➤  Mini Tour

Building Wheel. 

■ Right-click on the wheel, and click Mini Tour Building Wheel.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

System Variables

NAVSWHEELMODE

Specifies the current mode of the SteeringWheel.

Full Navigation Wheels
The Full Navigation wheels combine the 2D and 3D navigation tools found
on the 2D Navigation, View Object, and Tour Building wheels into a single
wheel.
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The Full Navigation wheels (big and mini) combine the 3D navigation tools
found on the View Object and Tour Building wheels. You can view individual
objects, and walk through and around a model. The big and mini Full
Navigation wheels are optimized for experienced 3D users.

NOTE When one of the Full Navigation wheels is displayed, you can press and
hold the middle mouse button to pan, scroll the wheel button to zoom in and
out, and hold the SHIFT key while pressing and holding the middle mouse button
to orbit the model.

Big Full Navigation Wheel

The big Full Navigation wheel wedges have the following options:

■ Zoom. Adjusts the magnification of the current view.

■ Rewind. Restores the most recent view. You can move backward or forward
by clicking and dragging left or right.

■ Pan. Repositions the current view by panning.

■ Orbit. Rotates the current view around a fixed pivot point.

■ Center. Specifies a point on a model to adjust the center of the current
view or change the target point used for some of the navigation tools.

■ Walk. Simulates walking through a model.

■ Look. Swivels the current view.

■ Up/Down. Slides the current view of a model along the Z axis of the model.

Mini Full Navigation Wheel

The mini Full Navigation wheel wedges have the following options:

■ Zoom (Top wedge). Adjusts the magnification of the current view.

■ Walk (Upper right wedge). Simulates walking through a model.
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■ Rewind (Right wedge). Restores the most recent view. You can move
backward or forward by clicking and dragging left or right.

■ Up/Down (Lower right wedge). Slides the current view of a model along
the Z axis of the model.

■ Pan (Bottom wedge). Repositions the current view by panning.

■ Look (Lower left wedge). Swivels the current view.

■ Orbit (Left wedge). Rotates the current view around a fixed pivot point.

■ Center (Upper left wedge). Specifies a point on a model to adjust the
center of the current view or change the target point used for some of the
navigation tools.

To switch to the big Full Navigation wheel

Do one of the following:

■ Click View tab ➤ Navigate panel ➤ SteeringWheels flyout ➤ Full Navigation

Wheel. 

■ Right-click on the wheel, and click Full Navigation Wheel.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

To switch to the mini Full Navigation wheel

Do one of the following:

■ Click View tab  ➤ Navigate panel  ➤ SteeringWheels flyout  ➤ Mini Full

Navigation Wheel. 

■ Right-click on the wheel, and click Mini Full Navigation Wheel.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
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Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

System Variables

NAVSWHEELMODE

Specifies the current mode of the SteeringWheel.

Navigation Tools
The navigation tools reorient the current view of a model.

The display of a model can be adjusted by increasing or decreasing the
magnification at which objects are displayed, rotating the model among other
ways of changing the orientation of the model using the tools on
SteeringWheels. You can create a view that defines an area of a model as the
Home view and use preset views to restore known viewpoints of a model with
the Autodesk® ViewCube® navigation tool.

Center Tool
The Center tool specifies a point on a model as the center of the current view.
It also changes the target point used for some of the navigation tools.

With the Center tool, you can define the center of the current view of a model.
To define the center, you drag the cursor over your model. A sphere is displayed
in addition to the cursor. The sphere indicates that the point below the cursor
in the model will be the center of the current view when you release the mouse
button, the model is centered on the sphere.

NOTE If a center point on a model cannot be identified, then a prohibited icon
(a circle with a diagonal line) is displayed instead of the sphere.
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The point defined by the Center tool provides a focal point for the Zoom tool
and a pivot point for the Orbit tool.

NOTE If you want to zoom from the Full Navigation wheels from your defined
center point, hold down CTRL before zooming.

To specify a point on a model as the center of a view

1 Display one of the Full Navigation wheels or the big View Object wheel.

2 Click and hold down the Center wedge.

3 Drag the cursor to the desired location of the model.

4 Release the button on your pointing device when the sphere is displayed.

The model is panned until the sphere is centered.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

To specify the target point for the Zoom and Orbit tools

1 Display one of the Full Navigation wheels or the big View Object wheel.

2 Click and hold down the Center wedge.

3 Drag the cursor over the desired location of the model.

4 Release the button on your pointing device when the sphere is displayed.

The model is panned until the sphere is centered.

5 Use the Zoom or Orbit tool to reorient the view of the model.

If you are using one of the Full Navigation wheels, hold down the CTRL
key before using the Zoom tool.
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Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

Forward Tool
The Forward tool adjusts the distance between the current point of view and
the defined pivot point of the model.

You use the Forward tool to change the magnification of the model by
increasing or decreasing the distance between the current point of view and
the pivot point. The distance that you can move forward or backward is limited
by the position of the pivot point.

To adjust the distance between the current point of view and the pivot point
you use the Drag Distance indicator. The Drag Distance indicator has two
marks on it that show the start and destination distances from the current
point of view. The current traveled distance is shown by the orange position
indicator. Slide the indicator forward or backwards to decrease or increase the
distance towards the pivot point.

To reorient a view by moving towards or away from the model

1 Display the big Tour Building wheel.

2 Click and hold down the Forward wedge.
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The Drag Distance indicator is displayed.

NOTE If you click the Forward wedge once, the model moves forward 50%
of the distance between the current location and the pivot point.

3 Drag the cursor up or down to change the distance from which you view
the model.

4 Release the button on your pointing device to return to the wheel.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

Look Tool
The Look tool rotates the view horizontally and vertically around a fixed point.

With the Look tool, you can rotate the current view vertically and horizontally.
When rotating the view, your line of sight rotates about the current eye
position, like turning your head. The Look tool can be compared to you
standing in a fixed location, and looking up or down while turning your head
left or right.

When using the Look tool, you adjust the view of the model by dragging the
cursor. As you drag, the cursor changes to the Look cursor and the model
rotates around the location of the current view.
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Walking through a Model

When using the Look tool from the big Full Navigation wheel, you can walk
through a model by using the arrow keys on the keyboard. Use the properties
dialog box for the SteeringWheels to adjust the walk speed.

Invert Vertical Axis

When you drag the cursor upward, the target point of the view raises; dragging
the cursor downward lowers the target point of the view. Use the properties
dialog box for the SteeringWheels to invert the vertical axis for the Look tool.

To look around a view with the Look tool

1 Display one of the Full Navigation wheels or the mini Tour Building
wheel.

2 Click and hold down the Look wedge.

The cursor changes to the Look cursor.

3 Drag the pointing device to change the direction in which you are
looking.

4 Release the button on your pointing device to return to the wheel.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
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To look around and walk through a model with the Look tool

1 Display the big Full Navigation wheel.

2 Click and hold down the Look wedge.

The cursor changes to the Look cursor.

3 Drag to change the direction in which you are looking.

4 While holding down the button on your pointing device, press the arrow
keys to walk in the model.

5 Release the button on your pointing device to return to the wheel.

6 Click Close to exit the wheel.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

To invert the vertical axis for the Look tool

1 Click View tab  ➤  Navigate panel  ➤  SteeringWheels flyout  ➤  click

one of the available SteeringWheels 

2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, click Invert Vertical Axis for
Look Tool.

Dragging the cursor downward lowers the target point of the view;
dragging the cursor upward raises the target point of the view.

4 Click OK.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
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Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

Orbit Tool
The Orbit tool rotates the current view around a model based on a fixed pivot
point.

You use the Orbit tool to change the orientation of a model. The cursor changes
to the Orbit cursor. As you drag the cursor, the model rotates around a pivot
point while the view remains fixed.

Specify the Pivot Point

The pivot point is the base point used when rotating the model with the Orbit
tool. You can specify the pivot point in the following ways:

■ Default pivot point. When you first open a model, the target point of the
current view is used as the pivot point for orbiting the model.

■ Select objects. You can select objects before the Orbit tool is used to
calculate the pivot point. The pivot point is calculated based on the center
of the extents of the selected objects.

■ Center tool. You can specify a point on the model to use as the pivot point
for orbiting with the Center tool.

■ CTRL+Click and drag. Press and hold down the CTRL key before clicking
the Orbit wedge or while the Orbit tool is active; then drag to the point
on the model you want to use as the pivot point. This option is only
available when using the big and mini Full Navigation wheels or the mini
View Object wheel.
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NOTE While the Orbit tool is active, you can be press and hold the CTRL key
at anytime to move the pivot point used by the Orbit tool.

Maintain Up Direction

You can control how the model orbits around the pivot point by choosing to
maintain the up direction of the model. When the up direction is maintained,
orbiting is constrained along the XY axis and in the Z direction. If you drag
horizontally, the camera moves parallel to the XY plane. If you drag vertically,
the camera moves along the Z axis.

If the up direction is not maintained, you can roll the model using the roll
ring which is centered around the pivot point. Use the properties dialog box
for the SteeringWheels to control whether the up direction is maintained or
not for the Orbit tool.

To orbit a model with the Orbit tool

1 Display one of the View Object or Full Navigation wheels.

2 Click and hold down the Orbit wedge.

The cursor changes to the Orbit cursor.

3 Drag to rotate the model.

NOTE Use the Center tool to re-center the model in the current view, if you
are using one of the Full Navigation or View Object wheels.

4 Release the button on your pointing device to return to the wheel.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

To orbit around an object with the Orbit tool

1 Press ESC to make sure no commands are active and to clear any
previously selected objects.

2 Select the objects in the model for which you want to define the pivot
point.

3 Display one of the View Object or Full Navigation wheels.
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4 Click and hold down the Orbit wedge.

The cursor changes to the Orbit cursor.

5 Drag to rotate the model.

6 Release the button on your pointing device to return to the wheel.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

To turn on selection sensitivity for the Orbit tool

1 Click View tab  ➤  Navigate panel  ➤  SteeringWheels flyout  ➤  click

one of the View Object or Full Navigation wheels. 

2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, click Use Selection Sensitivity
for Orbit Tool.

The extents of any objects that are selected before the wheel is displayed
are used to define the pivot point for the Orbit tool. If no objects are
selected, the pivot point used by the Orbit tool is the one defined by the
Center tool.

4 Click OK.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

To maintain the up direction for the Orbit tool

1 Click View tab  ➤  Navigate panel  ➤  SteeringWheels flyout  ➤  click

one of the View Object or Full Navigation wheels. 

2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, click Maintain Up Direction
for Orbit Tool.
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Orbiting the model is constrained along the XY plane and Z directions.

4 Click OK.

Command entry: NAVSWHEEL
Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels

Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

Pan Tool
The Pan tool repositions the current view of the model by panning.

When the pan tool is active, the Pan cursor (a four-sided arrow) is displayed.
Dragging the pointing device moves the model in the same direction. For
example, dragging upward moves the model up while dragging downward
moves the model down.

TIP If the cursor reaches the edge of the screen, you can continue panning by
dragging further to force it to wrap around the screen.

To pan the view with the Pan tool

1 Display the 2D Navigation wheel, one of the Full Navigation wheels, or
the mini View Object wheel.

2 Click and hold the Pan wedge.
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The cursor changes to the Pan cursor.

3 Drag to reposition the model.

4 Release the button on your pointing device to return to the wheel.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

To start the Pan tool with the middle button

1 Display the 2D Navigation wheel, the Full Navigation wheel, or one of
the mini wheels.

2 Press and hold down the scroll wheel or middle button.

The cursor changes to the Pan cursor.

3 Drag to reposition the model.

4 Release the wheel or button on your pointing device to return to the
wheel.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.
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Rewind Tool
The Rewind tool restores the most recent view. You can also move backward
or forward through previous views.

As you use the navigation tools to reorient the view of a model, the previous
view is saved to the navigation history. The navigation history holds a
representation of the previous views of the model along with a thumbnail. A
separate navigation history is maintained for each window; it is not maintained
after the window is closed. Rewind navigation history is view-specific.

With the Rewind tool, you can retrieve previous views from the navigation
history. From the navigation history, you can restore a previous view or scroll
through all of the saved views.

When you hold down the button on the pointing device over the Rewind
tool on the wheel, the Rewind History panel is displayed. You can scroll
through the navigation history. To restore one of the previous views in the
navigation history, drag the bracket to the left in the Rewind History panel.

When a view change occurs, the previous view is recorded to the navigation
history. If the view change is made with a wheel, a thumbnail is automatically
generated and added to the Rewind UI. For view changes that are made not
using a wheel, a thumbnail is only generated when the system variable
CAPTURETHUMBNAILS is set to a value of 2. You can control when thumbnails
are generated for view changes in the SteeringWheels Settings dialog box.

To restore the previous view

1 Display a wheel.

2 Click the Rewind wedge.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels
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Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

To restore a previous view with the Rewind History panel

1 Display a wheel.

2 Click and hold the Rewind wedge.

The Rewind History panel is displayed.

3 While holding down the button on your pointing device, drag to the left
or to the right to restore a previous view.

Dragging to the left restores an older previous view. Dragging to the right
restores a view that is newer than the one you are currently viewing. You
must have previously used the Rewind tool to see views available on the
right. The current position in the navigation history is indicated by the
orange box that is dragged along the Rewind History panel.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

To specify the display of rewind thumbnails

1 Display a wheel.

2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, select one of the following:

■ Never - Only display thumbnails for view changes made with the
SteeringWheels.

■ On Demand When the Bracket Is Moved Over an Empty Frame -
Display thumbnails on demand for a previous view change when
using the Rewind UI.

■ Automatically When a View Change Occurs - Display thumbnails for
all view changes saved to the navigation history.

4 Click OK.
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Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

System Variables

CAPTURETHUMBNAILS

Specifies if and when thumbnails are captured for the Rewind tool.

Up/Down Tool
The Up/Down tool slides the current view of a model along the Z axis of the
model.

Unlike the Pan tool, you use the UP/Down tool to adjust the height of the
current viewpoint along the model's Z axis. To adjust the vertical elevation
of the current view, you drag up or down. As you drag, the current elevation
and the allowed range of motion is displayed on a graphical element called
the Vertical Distance indicator.

The Vertical Distance indicator has two marks that show the highest (Top)
and lowest (Bottom) elevation the view can have. While changing the elevation
with the Vertical Distance indicator, the current elevation is shown by the
bright orange indicator, while the previous elevation is shown by the dim
orange indicator.
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To change the elevation of a view

1 Display one of the Full Navigation wheels or the Tour Building wheels.

2 Click and hold down the Up/Down wedge.

The Vertical Distance indicator is displayed.

3 Drag up or down to change the elevation of the view.

4 Release the button on your pointing device to return to the wheel.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

Walk Tool
The Walk tool simulates walking through a model.
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With the Walk tool, you can navigate through a model as if you were walking
through it. Once you start the Walk tool, the Center Circle icon is displayed
near the center of the view and the cursor changes to display a series of arrows.
To walk through the model, you drag in the direction in which you want to
move in.

Constrain the Walk Angle

When walking through a model, you can constrain the movement angle to
the ground plane. If the Constrain Walk Angle to Ground Plane option is
enabled, you can freely walk around while maintaining a constant camera
viewpoint elevation; if the walk angle is not constrained, you will “fly” in the
direction you are looking. Use the properties dialog box for the SteeringWheels
to constrain the movement angle to the ground plane for the Walk tool.

Movement Speed

As you walk or “fly” through a model, you can control the movement speed.
Movement speed is controlled by the distance in which the Cursor is moved
from the Center Circle icon and the current movement speed setting. You
can adjust the movement speed setting permanently and temporarily as you
use the Walk tool. To temporarily increase movement speed, press and hold
the + (plus) key while using the Walk tool.

Change the Elevation

As you use the Walk tool, you can adjust the camera elevation by holding
down the SHIFT key. This temporarily activates the Up/Down tool. With the
Up/Down tool active, drag up or down to adjust the elevation of the camera.
You can also use the UP ARROW and DOWN ARROW keys as you walk to adjust
the height of the view.

To use the Walk tool to move through the model

1 Display one of the Full Navigation wheels or the mini Tour Building
wheel.
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2 Click and hold down the Walk wedge.

The cursor changes to the Walk cursor and the Center Circle icon is
displayed.

3 Drag in the direction you want to walk.

NOTE While walking, press and hold down the + (plus) key to temporarily
increase your movement speed.

4 Release the button on your pointing device to return to the wheel.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

To change the movement speed for the Walk tool

1 Display a wheel.

2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, under Walk Tool, drag the
Walk Speed slider to the left to decrease the walking speed or to the right
to increase the walking speed.

4 Click OK.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

To constrain the walk angle to the ground plane

1 Display a wheel.
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2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, under Walk Tool, click
Constrain Walk Angle to Ground Plane.

Movement when walking is done parallel to the ground plane of the
model.

4 Click OK.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

To adjust the height of the current view from the Walk tool

1 Display one of the Full Navigation wheels or the mini Tour Building
wheel.

2 Click and hold down the Walk wedge.

The cursor changes to the Walk cursor and the Center Circle icon is
displayed.

3 Do one of the following:

■ Press and hold down the SHIFT key to enable the Up/Down tool; drag
up or down.

■ Press and hold down the UP ARROW or DOWN ARROW key.

4 Release the button on your pointing device to return to the wheel.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL
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Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

Zoom Tool
The Zoom tool adjusts the magnification of the current view of a model.

You use the Zoom tool to change the zoom magnification of a model. The
following mouse click and key combinations are available to control how the
Zoom tool behaves:

■ Click. If you click the Zoom tool on a wheel, the current view is zoomed
in by a factor of 25 percent. If you are using the Full Navigation wheel,
incremental zoom must be enabled in the properties dialog box for the
SteeringWheels.

■ SHIFT+click. If you hold down the SHIFT key before you click the Zoom
tool on a wheel, the current view is zoomed out by a factor of 25 percent.
Zooming is performed from the current location of the cursor, and not the
current pivot point.

NOTE When you start the Zoom tool from the Full Navigation wheel,
incremental zooming must be enabled in the properties dialog box for the
SteeringWheels in order to use CTRL+click and SHIFT+click.

■ CTRL+click. If you hold down the CTRL key before you click the Zoom tool
on a wheel, the current view is zoomed in by a factor of 25 percent.
Zooming is performed from the current pivot point, and not the location
of the cursor.

■ Click and drag. If you click the Zoom tool and hold down the button on
your pointing device, you can adjust the magnification of the model by
dragging up and down.

■ CTRL+click and drag. When using the Full Navigation wheels or the mini
View Object wheel, you can control the target point used by the Zoom
tool. By holding down the CTRL key, the Zoom tool uses the location of
the previous pivot point defined by the Zoom, Orbit, or Center tool.
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NOTE When you start the Zoom tool from the Full Navigation wheel, incremental
zooming must be enabled in the properties dialog box for the SteeringWheels in
order to use CTRL+click and SHIFT+click.

NOTE When you use the Zoom tool from the Full Navigation wheel or the View
Object wheel, the point in the view where you click to zoom becomes the Center
point for future Orbit operations until you either use the Zoom tool again or use
the Center tool. If you press CTRL before you click the Zoom wedge, the Center
point does not change.

Zoom Constraints

When changing the magnification of a model with the Zoom tool, you cannot
zoom in any further than the focus point or out past the extents of the model.
The direction you can zoom in and out is controlled by the center point set
by the Center tool.

When changing the magnification of a model with the Zoom tool, you cannot
zoom in any further than the focus point or out past the extents of the model.

To zoom a view with a single click

1 Display a wheel.

2 Right-click on the wheel and click SteeringWheel Settings.

3 In the SteeringWheels Settings dialog box, under Zoom Tool, select Enable
Single Click Incremental Zoom.

4 Click OK.

5 Display one of the Full Navigation Wheels or the mini View Object Wheel.

6 Click the Zoom wedge.

The magnification of the model is increased and you are zoomed in closer
to the model. If you hold down the Shift key while clicking the Zoom
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wedge, the model is zoomed out or you can hold down the Ctrl key to
zoom in.

7 Click Close to exit the wheel.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

To zoom a view in and out by dragging

1 Display the 2D Navigation wheel, one of the Full Navigation wheels, or
the mini View Object wheel.

2 Click and hold down the Zoom wedge.

The cursor changes to the Zoom cursor.

3 Drag vertically to zoom in or out.

4 Release the button on your pointing device to return to the wheel.

Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

To zoom in and out by scrolling the mouse wheel when a SteeringWheel is
displayed

1 Display one of the wheels other than the big Tour Building wheel.

2 Scroll the wheel forward or backward to zoom in or out.

3 Release the button on your pointing device to return to the wheel.
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Ribbon: View tab  ➤  Navigate panel  ➤  SteeringWheels flyout 
Menu: View ➤  SteeringWheels

Shortcut menu: Right-click over the drawing window and click
SteeringWheels

Toolbar: Status bar  ➤  SteeringWheels
Command entry: NAVSWHEEL

Quick Reference

Commands

NAVSWHEEL

Displays a wheel that contains a collection of view navigation tools.

Define and Change Views with ShowMotion
The Autodesk® ShowMotion® navigation tool provides an onscreen display
that can be used to create and play back cinematic camera animations. These
animations can be used for presentation purposes or to navigate through a
design.

Overview of ShowMotion
Using ShowMotion, you can add movement and transitions to a saved view.
These saved views are called shots. The types of shots that you can create are:

■ Still. Utilizes a single fixed camera position.

■ Cinematic. Utilizes a single camera with cinematic camera movements.

■ Recorded Walk. Records an animation by navigating around and through
a model.

Shot Sequences

Shot sequences are used to organize related shots together. These sequences
are also called view categories. By using shot sequences, you can do the
following:

■ Quickly locate a shot
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■ Play back more than one shot at a time

■ Control the order in which shots are played back

Using ShowMotion

ShowMotion is made up of three main parts: shot thumbnails, shot sequence
thumbnails, and the ShowMotion control. With the ShowMotion control,
which is along the bottom, you can play the animations assigned to a shot,
pin and unpin ShowMotion, and close ShowMotion. Use the shot and shot
sequence thumbnails to navigate the shots in the current model.

The ShowMotion control has the following options:

■ Pin/Unpin ShowMotion. Pins ShowMotion so the ShowMotion control
and all thumbnails remain displayed even if focus is shifted away from
ShowMotion. When ShowMotion is not pinned, the ShowMotion control
and all thumbnails disappear if the focus is switched away from
ShowMotion.

■ Play All. Starts the playback of shots in all shot sequences. Shots are played
left to right, starting with the leftmost shot sequence.

■ Stop. Stops the playback of the current shot.

■ Turn On/Off Looping. Enables or disables playback looping for the
animation assigned to the shot or shot sequence when played back.
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■ New Shot. Displays the New View/Shot Properties dialog box where you
can create a new shot.

■ Close ShowMotion. Closes the ShowMotion control and all thumbnails.

To launch ShowMotion

Use one of the following methods to launch ShowMotion

■ Click View  ➤ ShowMotion.

■ On the status bar, click ShowMotion.

Command entry: NAVSMOTION

To pin or unpin ShowMotion

■ On the ShowMotion control, click Pin ShowMotion or Unpin ShowMotion.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

To close ShowMotion

■ On the ShowMotion control, click Close ShowMotion or click in the
document window when ShowMotion is not pinned.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

Quick Reference

Commands

NAVSMOTION

Displays the ShowMotion interface.

Overview of ShowMotion | 387



Create and Modify Shots and Shot Sequences
You create and modify shots from ShowMotion. As you create or modify a
shot, a thumbnail is generated and added to a shot sequence.

Create and Modify a Shot

When a shot is created, it must be given a name and view type. The view type
assigned to the shot determines which transition and motion options you can
change. After a shot is created, a thumbnail is automatically generated and
placed under the shot sequence that was assigned to the shot. The name of
the shot is located below the thumbnail. If you need to change a shot, you
can right-click the shot that you want to modify.

The shortcut menu of a shot has the following options:

■ Properties. Displays the dialog box to modify the shot’s transition and
motion settings, and assigned shot sequence, among other settings.

■ Rename. Renames a shot.

■ Delete. Removes a shot.

■ Move Left and Move Right. Changes the position of a shot in the shot
sequence by one position to the left or right.

■ Update the Thumbnail. Updates the thumbnail for a single shot or for all
shots saved with the model.

Create and Modify a Shot Sequence

When a shot is created, you can add the shot to the default shot sequence or
specify the shot sequence to which the shot should be added. Each shot
sequence is represented by a thumbnail in ShowMotion. The thumbnail is
identical to the first shot in the shot sequence. The name of the shot sequence
is below the thumbnail.

The shortcut menu of a shot sequence has the following options:

■ Rename. Renames a shot sequence.

■ Delete. Removes a shot sequence.

■ Move Left and Move Right. Changes the position of a shot sequence in
ShowMotion by one position to the left or right.

■ Update the Thumbnail. Updates the thumbnails for all shots in a shot
sequence or for all shots saved with the model.
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To create a still shot

1 On the ShowMotion control, click New Shot.

2 In the New View/Shot Properties dialog box, in the View Name text box,
enter a name.

3 In the View Category drop-down list, select a view category.

4 In the View Type drop-down list, select a shot type.

5 On the Shot Properties tab, under Transition, select a transition type from
the Transition Type drop-down list.

6 Under Transition, enter a transition duration in the Transition Duration
text box.

7 Click OK.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

To create a recorded walk shot

1 On the ShowMotion control, click New Shot.

2 In the New View/Shot Properties dialog box, in the View name box, enter
a name.

3 In the View Category drop-down list, select a view category.

4 In the View Type drop-down list, select Recorded Walk.

5 On the Shot Properties tab, under Transition, select a transition type from
the Transition Type drop-down list.

6 Under Transition, enter a transition duration in the Transition Duration
text box.

7 Under Motion, click Start Recording.

8 Click on the 3D canvas and drag the mouse along the desired path of
animation. Release the mouse to stop recording.

9 Click OK.
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Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

To create a cinematic shot

1 On the ShowMotion control, click New Shot.

2 In the New View/Shot Properties dialog box, in the View name box, enter
a name.

3 In the View Category drop-down list, select a view category.

4 In the View Type drop-down list, select Cinematic.

5 On the Shot Properties tab, under Transition, select a transition type from
the Transition Type drop-down list.

6 Under Transition, enter a transition duration in the Transition Duration
text box.

7 Under Motion, set the camera position.

8 Under Motion, set the duration of the movement.

9 Under Motion, set the travel distance of the camera.

10 Click OK.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

To modify a shot

1 On ShowMotion, hover the cursor over the shot sequence that contains
the shot you want to modify.

2 Right-click the shot you want to modify, and click Properties.

3 In the View/Shot Properties dialog box, change the desired settings.

4 Click OK.

Menu: View  ➤ ShowMotion
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Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

To rename a shot or shot sequence

1 On ShowMotion, hover the cursor over the shot or shot sequence you
want to rename.

2 Right-click, and click Rename.

3 In the in-place editor, replace the existing name with the new name and
press ENTER.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

To resequence a shot or shot sequence

1 On ShowMotion, hover the cursor over the shot or shot sequence you
want to resequence.

2 Right-click, and click Move Left or Move Right.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

To delete a shot

1 On ShowMotion, hover the cursor over the shot you want to delete.

2 Right-click, and click Delete.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION
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To delete a shot sequence

1 On ShowMotion, hover the cursor over the shot sequence you want to
delete.

2 Right-click, and click Delete.

3 In the ShowMotion - Delete View Category dialog box, click Delete
Category.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

To update the thumbnail for a shot or shot sequence

1 On ShowMotion, hover the cursor over the shot or shot sequence for
which you want to update the thumbnail.

2 Right-click, and click Update the Thumbnail For  ➤  This View or This
Category.

Click All to update the thumbnails for all shots stored in the model.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

Quick Reference

Commands

NAVSMOTION

Displays the ShowMotion interface.

NEWSHOT

Creates a named view with motion that is played back when viewed with
ShowMotion.
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Play Back a Shot
You can view shots individually or together in a shot sequence.

Once a shot is created, you can play back the animation assigned to the shot
by using the view controls located on each shot or shot sequence thumbnail
or the ShowMotion control. The available view controls are:

■ Play. Starts the playback of a shot or shot sequence. When the cursor is
over the thumbnail, the Play button is displayed in the upper-left corner.
The Play button plays back the individual shot or all the shots in the shot
sequence.

■ Play All. Starts the playback of all shots in all shot sequences. Shots are
played left to right, starting with the leftmost shot sequence.

■ Pause. Stops the playback of a shot or shot sequence.

■ Stop. Stops the playback of the current shot.

■ Go. Restores the view of the model assigned to a shot or the first shot in
a shot sequence.

To play a shot

1 On ShowMotion, hover the cursor over the shot sequence that contains
the shot you want to play.

2 Position the cursor over the thumbnail of the shot you want to view.
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3 On the shot thumbnail, in the upper-left corner, click the Play button.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

To play all shots within a shot sequence

1 On ShowMotion, hover the cursor over the shot sequence that contains
the shots you want to play.

2 On the thumbnail for the shot sequence, click the Play button located
on the upper-left corner of the thumbnail.

All the shots in the shot sequence are played.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

To play all shots within all shot sequences

■ On the ShowMotion control, click Play All.
All the shots saved in the model are played back in the order of each shot
sequence.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

To pause or stop the playback of a shot

■ On the ShowMotion control, click Pause to pause the playback of the
current shot or Stop to stop playback.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
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Command entry: NAVSMOTION

To loop the playback of a shot

■ On the ShowMotion control, click Turn On/Off Looping.

NOTE If the loop setting is on, the shot loops until you click the Stop button
or press the ESC key.

Menu: View  ➤ ShowMotion

Toolbar: Status bar  ➤  ShowMotion 
Command entry: NAVSMOTION

Quick Reference

Commands

NAVSMOTION

Displays the ShowMotion interface.

VIEWGO

Restores a named view.

VIEWPLAY

Plays the animation associated to a named view.

Define a 3D View with a Camera
Define a 3D view by placing a camera in model space and adjusting camera
settings to suit your needs.

Overview of Cameras
You can place a camera in a drawing to define a 3D view.

You can turn a camera on or off in a drawing and use grips to edit a camera’s
location, target, or lens length. A camera is defined by a location XYZ
coordinate, a target XYZ coordinate, and a field of view/lens length, which
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determines the magnification, or zoom factor. You can also define clipping
planes, which establish front and back boundaries for the associated view.

■ Location. Defines the point from which you are viewing a 3D model.

■ Target. Defines the point you are viewing by specifying the coordinate at
the center of the view.

■ Lens length. Defines the magnification properties of a camera’s lens. The
greater the lens length, the narrower the field of view.

■ Front and back clipping planes. Specifies the location of clipping planes.
Clipping planes are boundaries that define, or clip, a view. In the camera's
view, everything between the camera and the front clipping plane is
hidden. Likewise, everything between the back clipping plane and the
target is hidden.

By default, saved cameras are given names such as Camera1, Camera2, and
so on. You can rename a camera to better describe its view. The View Manager
lists existing cameras in a drawing as well as other named views.

Use the Camera Glyph Appearance dialog box to control the camera glyph's
colors and size.

Quick Reference

Commands

CAMERA

Sets a camera and target location to create and save a 3D perspective view
of objects.

OPTIONS

Customizes the program settings.

System Variables

CAMERADISPLAY

Turns the display of camera objects on or off.

CAMERAHEIGHT

Specifies the default height for new camera objects.
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Create a Camera
Set a camera and target location to create and save 3D perspective views of
objects.

You can create a new camera by defining its location and a target, and by
further defining its name, height, lens length, and clipping planes. You can
also use one of several pre-defined camera types that are available on the tool
palette.

To create a camera

1 Click Render tab  ➤  Camera panel  ➤ Create Camera. 

2 Click in the drawing to specify the camera’s location.

3 Click again in the drawing to specify a target location.

4 Do one of the following:

■ If you are finished setting up the camera, press Enter.

■ To further define camera properties, right-click and select from the
list of options. Then press Enter to finish setting up the camera.

CAMERA

View  

To create a camera from the Tool palette

1 Click View tab  ➤  Palettes panel  ➤  Tool Palettes. 

2 In the Tool Palettes window, click the Camera tool palette tab to make
it active.

3 Select a camera type. Drag the camera icon from the tool palette, and
click in the drawing where you want to set its location.

4 Click again in the drawing when you want to place the target.

Command entry: TOOLPALETTES, CAMERA

Create a Camera | 397



To display a camera

■ Click Render tab ➤ Camera panel ➤ Show Cameras. 

Command entry: CAMERADISPLAY

Menu: Click View menu  ➤ Display  ➤ Cameras. 

Quick Reference

Commands

CAMERA

Sets a camera and target location to create and save a 3D perspective view
of objects.

OPTIONS

Customizes the program settings.

System Variables

CAMERADISPLAY

Turns the display of camera objects on or off.

CAMERAHEIGHT

Specifies the default height for new camera objects.

Change Camera Properties
You can modify a camera’s lens length, change its front and back clipping
planes, name a camera, and turn the display of all cameras on or off in a
drawing.

When you select a camera, the Camera Preview dialog box opens to display
the camera's view.

398 | Chapter 10   Use Viewing Tools



There are several ways to change camera settings:

■ Click and drag grips to resize or relocate a lens length or field of view.

■ Use the Dynamic Input tooltip to enter X,Y, Z coordinate values.
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■ Modify camera properties in the Camera Properties palette.
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To change a camera’s lens length

1 If cameras are not already displayed in the drawing, click Render tab  ➤ 

Camera panel  ➤  Show Cameras. 

2 Click the camera glyph.

3 Click a Lens Length/FOV grip tool.

4 Move the cursor and click where you want to position the lens.

5 Press Enter.

NOTE To change a lens length to a precise value, double-click a camera
glyph to open the Properties palette. In the Cameras section, Lens Length
option (mm), enter a numeric value.

Command entry: CAMERADISPLAY

To set a camera’s clipping planes

1 If cameras are not already displayed in the drawing, click Render tab  ➤ 

Camera panel  ➤  Show Cameras. 

2 Double-click the camera whose clipping planes you want to set.

3 In the Properties palette, Clipping section, Clipping option, select Front
On, Back On, or Front and Back On.

4 In the Front Plane or Back Plane option, enter numeric values.

5 Press Enter.

CAMERADISPLAY

To rename a camera

1 If cameras are not already displayed in the drawing, click Render tab  ➤ 

Camera panel  ➤  Show Cameras. 

2 Double-click a camera glyph.
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3 In the Properties palette, General section, Name option, enter a new
name.

4 Press Enter.

Command entry: CAMERADISPLAY

To change a camera’s location

1 If cameras are not already displayed in the drawing, click Render tab  ➤ 

Camera panel  ➤  Show Cameras. 

2 Click the camera glyph, drag it to the new location, and click to place
the camera.

3 Press Enter.

Command entry: CAMERADISPLAY

To change a camera’s target

1 If cameras are not already displayed in the drawing, click Render tab  ➤ 

Camera panel  ➤  Show Cameras. 

2 Click the camera glyph whose target you want to change.

3 Click the Target Distance grip tool (the blue grip in the center), drag it
to the new location, and click to place the target.

4 Press Enter.

Command entry: CAMERADISPLAY

To specify whether the camera glyph plots

1 If cameras are not already displayed in the drawing, click Render tab  ➤ 

Camera panel  ➤  Show Cameras. 

2 Double-click a camera.

3 In the Properties palette, Camera section, Plot option, click Yes or No.
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Command entry: CAMERADISPLAY

Quick Reference

Commands

CAMERA

Sets a camera and target location to create and save a 3D perspective view
of objects.

System Variables

CAMERADISPLAY

Turns the display of camera objects on or off.

CAMERAHEIGHT

Specifies the default height for new camera objects.

Create Preview Animations
You can create 3D preview animations and adjust the settings before you
create a motion path animation.

Preview animations are created with the controls on the Animation panel
found on the ribbon on page 22 and the 3D navigation tools. Once a 3D
navigation tool is active, the controls on the Animation panel are enabled to
start recording an animation.

The following commands can be used to create an animation

■ 3DCORBIT

■ 3DDISTANCE

■ 3DFLY

■ 3DFORBIT

■ 3DORBIT

■ 3DPAN

■ 3DSWIVEL

■ 3DWALK
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■ 3DZOOM

To learn more about the 3D navigation tools available for creating an
animation, see Use 3D Navigation Tools on page 323.

To create a preview animation

1 If the Animations panel is not displayed on the Render tab, right-click
the Render tab and click Panels  ➤  Animations.

2 Start any 3D navigation command such as 3DORBIT.

3 Click Render tab  ➤  Animations panel  ➤  Animation Record.

4 Navigate through the drawing. If you are in walk or fly mode, you can
use the Position Locator window as a visual guide.

5 (Optional) Do any of the following:

■ Right-click the drawing and click Other Navigation Modes. Click
another navigation mode.

■ Click Render tab  ➤  Animations panel  ➤  Animation Pause to set up
another navigation mode or adjust animation settings. If you are in
walk or fly mode, you can also adjust settings for the Position Locator
window.

6 To review the animation, click Render tab  ➤  Animations panel  ➤ 

Animation Play. In the Animation Preview dialog box, view the animation,
and do the following:

■ If you want to preview the animation in a different visual style, select
another style from the drop-down list.

■ If you are satisfied with the animation playback, click the Pause
button. Then click the Save button.

7 In the Save As dialog box, select a file location, file name, and file type
(AVI, MPG, MOV, or WMV).

8 Click Save.

To record a preview animation

1 If the Animations panel is not displayed on the Render tab, right-click
the Render tab and click Panels  ➤  Animations.

2 Start any navigation command such as 3DORBIT.
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3 Click Render tab  ➤  Animations panel  ➤  Animation Record.

4 Navigate through the model to record the movement.

5 When you are finished recording the animation, click Render tab  ➤ 

Animations panel  ➤  Animation Pause.

6 To review the animation, click Render tab  ➤  Animations panel  ➤ 

Animation Play. In the Animation Preview dialog box, view the recording
to verify that the animation is suitable for your presentation needs.

NOTE The playback of the animation gives you a general visual idea of the
final output. It may not display the visual style or with the same quality of
the final output.

7 If you are satisfied with the animation, click the Pause button. Then click
the Save button.

8 In the Save As dialog box, choose a location and file name.

NOTE To change the file type, click the Animation Settings button. In the
Animation Settings dialog box, Format option, click a file type. Click OK to
return to the Save As dialog box.

9 Click Save.

Quick Reference

Commands

3DCLIP

Starts an interactive 3D view and opens the Adjust Clipping Planes window.

3DCORBIT

Rotates the view in 3D space with continuous motion.

3DDISTANCE

Starts the interactive 3D view and makes objects appear closer or farther
away.

3DFLY

Changes the 3D view in a drawing interactively to create the appearance of
flying through the model.
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3DFORBIT

Rotates the view in 3D space without constraining roll.

3DORBIT

Rotates the view in 3D space, but constrained to horizontal and vertical orbit
only.

3DORBITCTR

Sets the center of rotation in 3D Orbit view.

3DPAN

When a drawing is in a Perspective view, starts the interactive 3D view and
enables you to drag the view horizontally and vertically.

3DSWIVEL

Changes the target of the view in the direction that you drag.

3DWALK

Changes the 3D view in a drawing interactively to create the appearance of
walking through the model.

3DZOOM

Zooms in and out in a perspective view.

Create Motion Path Animations
Motion path animations, such as 3D animated walk-throughs of a model,
allow you to visually demonstrate a model to both a technical and
non-technical audience. You can record and play back a navigation to
communicate your design intent dynamically.

Control a Camera Motion Path
You control the camera motion, and therefore the animation, by linking the
camera and its target to a point or a path.

To create an animation using motion paths, you link the camera and its target
to either a point or a path. If you want the camera to remain still, link it to a
point. If you want the camera to move along a path, link it to a path.
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If you want the target to remain still, link it to a point. If you want the target
to move, link it to a path. You cannot link both the camera and the target to
a point.

Use the same path when you want the animation view to follow in line with
the camera's path. You do this by setting the target's path to None in the
Motion Path Animation dialog box. This is the default setting.

NOTE To link a camera or target to a path, you must create the path object before
you create the motion path animation. A path can be a line, arc, elliptical arc,
circle, polyline, 3D polyline, or spline.

To create a motion path animation

1 In the drawing, create a path object for either the camera or the target.
A path can be a line, arc, elliptical arc, circle, polyline, 3D polyline, or
spline.

NOTE The path you create is not visible in the animation.

2 If the Animations panel is not displayed on the Render tab, right-click
the Render tab and click Panels  ➤  Animations.

3 Click Render tab ➤ Animations panel ➤ Animation Motion Path. 

4 In the Motion Path Animation dialog box, Camera section, click either
Point or Path.

5 Do one of the following:

■ To specify a new camera point, click the Pick Point button, and specify
a point in the drawing. Enter a name for the point. Click OK.

■ To specify a new camera path, click the Select Path button, and specify
a path in the drawing. Enter a name for the path. Click OK.

■ To specify an existing camera point or path, select it from the
drop-down list.

6 In the Motion Path Animation dialog box, Target section, click either
Point or Path.

7 Do one of the following:

■ To specify a new target point, click the Pick Point button, and specify
a point in the drawing. Enter a name for the point. Click OK.
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■ To specify a new target path, click the Select Path button, and specify
a path in the drawing. Enter a name for the path. Click OK.

■ To specify an existing target point or path, select it from the
drop-down list.

8 In the Animation Settings section, adjust the animation settings to create
the animation to suit your needs.

9 When you have finished adjusting the points, paths, and settings, click
Preview to view the animation, or OK to save it.

Command entry: ANIPATH

Quick Reference

Commands

ANIPATH

Saves an animation file of a camera moving or panning in a 3D model.

Specify Motion Path Settings
You determine the format of the animation file of a motion path animation
by specifying settings in the Motion Path Animation dialog box.

Several settings control the animation's frame rate, duration, resolution, visual
style, and file format.

To view a reverse motion path animation

1 If the Animations panel is not displayed on the Render tab, right-click
the Render tab and click Panels  ➤  Animations.

2 Click Render tab  ➤  Animations panel  ➤  Animation Motion Path.

3 In the Motion Path Animation dialog box, Animation Settings section,
click the Reverse check box.

4 Click OK.
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Command entry: ANIPATH

To control the speed and duration of the animation

1 If the Animations panel is not displayed on the Render tab, right-click
the Render tab and click Panels  ➤  Animations.

2 Click Render tab  ➤  Animations panel  ➤  Animation Motion Path.

3 In the Motion Path Animation dialog box, Animation Settings section,
specify a Frame rate (FPS).

4 Do one of the following:

■ Specify a number of frames.

■ Specify a duration, in seconds.

5 Click Preview or OK.

ANIPATH

To set animation resolution

1 If the Animations panel is not displayed on the Render tab, right-click
the Render tab and click Panels  ➤  Animations.

2 Click Render tab  ➤  Animations panel  ➤  Animation Motion Path.

3 In the Motion Path Animation dialog box, Animation Settings section,
select a resolution from the Resolution drop-down list.

Command entry: ANIPATH

To set the video format

1 If the Animations panel is not displayed on the Render tab, right-click
the Render tab and click Panels  ➤  Animations.
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2 Click Render tab  ➤  Animations panel  ➤  Animation Motion Path.

3 In the Motion Path Animation dialog box, Animation Settings section,
click a video format (AVI, MPG, MOV, or WMV) from the Format
drop-down list.

Command entry: ANIPATH

Quick Reference

Commands

ANIPATH

Saves an animation file of a camera moving or panning in a 3D model.

Record a Motion Path Animation
You can preview the animation before you record it and then save it in the
desired format.

To preview and save a motion path animation

1 If the Animations panel is not displayed on the Render tab, right-click
the Render tab and click Panels  ➤  Animations.

2 Click Render tab  ➤  Animations panel  ➤  Animation Motion Path.

3 In the Motion Path Animations dialog box, do the following:

■ Specify a point or path for the camera.

■ Specify a point or path for the target.

■ Adjust any animation settings.

4 To preview the animation, click the Preview button.

5 In the Animation Preview window, view the animation. When the preview
animation is complete, close the Animation Preview window.
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6 In the Motion Path Animations dialog box, click OK.

7 In the Save As dialog box, specify a file name and location to save the
animation file.

8 Click Save.

Command entry: ANIPATH

Quick Reference

Commands

ANIPATH

Saves an animation file of a camera moving or panning in a 3D model.
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Display Multiple Views in
Model Space

To see several views at the same time, you can split the drawing area of the Model tab into
separate viewing areas called model space viewports. You can save arrangements of model space
viewports for reuse at any time.

Set Model Space Viewports
On the Model tab, you can split the drawing area into one or more adjacent
rectangular views known as model space viewports.

Viewports are areas that display different views of your model. As you work on
the Model tab, you can split the drawing area into one or more adjacent
rectangular views known as model space viewports. In large or complex drawings,
displaying different views reduces the time needed to zoom or pan in a single
view. Also, errors you might miss in one view may be apparent in the others.

Viewports created on the Model tab completely fill the drawing area and do not
overlap. As you make changes in one viewport, the others are updated
simultaneously. Three model space viewports are shown in the illustration.
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You can also create viewports on a layout tab. You use those viewports, called
layout viewports, to arrange the views of your drawing on a sheet. You can move
and resize layout viewports. By using layout viewports, you have more control
over the display; for example, you can freeze certain layers in one layout
viewport without affecting the others. For more information about layouts
and layout viewports, see Create Multiple-View Drawing Layouts (Paper Space)
on page 431.

Use Model Space Viewports

With model space viewports, you can do the following:

■ Pan; zoom; set Snap, Grid, and UCS icon modes; and restore named views.

■ Save user coordinate system orientations with individual viewports.

■ Draw from one viewport to another when executing a command.

■ Name a viewport arrangement so that you can reuse it on the Model tab
or insert it on a layout tab.

Setting up different coordinate systems in individual viewports is useful if you
typically work on 3D models. See Assign User Coordinate System Orientations
to Viewports on page 662.

Split and Join Model Space Viewports

The illustrations below show several default model space viewport
configurations.

414 | Chapter 11   Display Multiple Views in Model Space



You can easily modify model space viewports by splitting and joining them.
If you want to join two viewports, they must share a common edge of the
same length.

To subdivide a viewport on the Model tab

1 If you have more than one viewport, click inside the viewport you want
to subdivide.

2 To indicate how many model space viewports should be created, do one
of the following:

■ Click View menu  ➤ Viewports  ➤ 2 Viewports.

■ ClickView menu ➤  Viewports ➤ 3 Viewports.

■ Click View menu  ➤  Viewports  ➤  4 Viewports

3 At the Next prompt, specify the arrangement of the new viewports.

Command entry: VPORTS

To join two viewports on the Model tab

1 Click View tab  ➤  Viewports panel  ➤  Viewports, Join. 

2 Click within the model space viewport containing the view you want to
keep.

3 Click within an adjacent viewport to join it to the first viewport.
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Command entry: VPORTS

To restore a single viewport on the Model tab

■ Click View tab  ➤  Viewports panel  ➤  New.

Command entry: VPORTS

To switch from a layout tab to the Model tab

■ Click the Model tab at the bottom of the drawing area.

Command entry: TILEMODE

Quick Reference

Commands

MODEL

Switches from a layout tab to the Model tab.

VPORTS

Creates multiple viewports in model space or paper space.

System Variables

MAXACTVP

Sets the maximum number of viewports that can be active at one time in a
layout.

CTAB

Returns the name of the current (model or layout) tab in the drawing.

TILEMODE

Makes the Model tab or the last layout tab current.
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Utilities

No entries

Command Modifiers

No entries

Select and Use the Current Viewport
When you use multiple viewports, one of them is the current viewport, which
accepts cursor input and view commands.

When a viewport is current, the cursor is displayed as crosshairs rather than
an arrow, and the viewport boundary is highlighted. You can change the
current viewport at any time except when a View command is in progress.

To make a viewport the current viewport, you click inside it or press CTRL+R
to cycle through the existing viewports.

To draw a line using two model space viewports, you start the line in the
current viewport, make another viewport current by clicking within it, and
then specify the endpoint of the line in the second viewport. In a large
drawing, you can use this method to draw a line from a detail in one corner
to a detail in a distant corner.

To make a viewport current

■ Click anywhere within the viewport border.
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To cycle through viewports without clicking

■ Press CTRL+ R repeatedly.

Quick Reference

Commands

No entries

System Variables

CVPORT

Displays the identification number of the current viewport.

VIEWCTR

Stores the center of view in the current viewport.

VIEWSIZE

Stores the height of the view displayed in the current viewport, measured in
drawing units.

Utilities

No entries

Command Modifiers

No entries

Save and Restore Model Tab Viewport Arrangements
Arrangements of model viewports can be saved and restored by name.

You don't have to set up viewports and views every time you need them. With
VPORTS, viewport arrangements can be saved and later restored by name.
Settings that are saved with viewport arrangements include

■ The number and position of viewports

■ The views that the viewports contain

■ The grid and snap settings for each viewport

■ The UCS icon display setting for each viewport
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You can list, restore, and delete the available viewport arrangements. A
viewport arrangement saved on the Model tab can be inserted on a layout
tab.

To save and name a viewport arrangement

1 Click View tab  ➤  Viewports panel  ➤  New.

2 In the Viewports dialog box, New Viewports tab, enter a name for the
viewport configuration in the New Name box.

The name can be up to 255 characters long and contain letters, digits,
the special characters dollar sign ($), hyphen (-), and underscore (_).

3 Click OK.

NOTE You can save a viewport arrangement only on the Model tab.

Command entry: VPORTS

To restore a saved viewport arrangement

1 Click View tab ➤ Viewports panel ➤ Named. 

2 In the Viewports dialog box, Named Viewports tab, select the name of
the viewport configuration from the list.

3 Click OK.

Command entry: VPORTS

To delete a saved viewport arrangement

1 Click View tab ➤ Viewports panel ➤ Named. 

2 In the Viewports dialog box, Named Viewports tab, select the name of
the viewport configuration you want to delete.

3 Press DELETE.

Command entry: VPORTS
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To view a list of saved viewport arrangements

■ Click View tab ➤ Viewports panel ➤ Named. 
The Viewports dialog box is displayed.

All saved viewport arrangements in the drawing are listed on the Named
Viewports tab under Named Viewports.

Command entry: VPORTS

Quick Reference

Commands

RENAME

Changes the names assigned to items such as layers and dimension styles.

VPORTS

Creates multiple viewports in model space or paper space.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries
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Choose a Work Process
Before You Begin
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Create Single-View
Drawings (Model Space)

If you are going to create a two dimensional drawing that has one view, you can create the
drawing and its annotation entirely in model space. This is the traditional method for creating
drawings with AutoCAD®.

With this method, you create the building, mechanical part, or geographic area that you want
to represent at full scale (1:1), but you create the text, dimensions, and the title block of the
drawing at a scale to match the intended plot scale.

Quick Start for Model Space Drafting
The process of creating and plotting a drawing file in model space is very
different from the process used in manual drafting.

In AutoCAD, there are two distinct working environments that are represented
by the Model and layout tabs. These tabs are located near the bottom of the
drawing area.

If you are going to create a two-dimensional drawing that has one view, you
can create both the model and its annotation entirely in model space, not using
a layout tab. This is the traditional method for creating drawings with AutoCAD.
This method is simple but has several limitations, including

■ It is suitable for 2D drawings only

■ It does not support multiple views and view-dependent layer settings

■ Scaling the annotation and title block requires computation unless you use
objects.
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With this method, you always draw geometric objects at full scale (1:1) and
text, dimensions, and other annotation at a scale that will appear at the correct
size when the drawing is plotted.

For information about using annotative objects and scaling annotations
automatically, see Scale Annotations on page 1393.

See also:

■ Create Multiple-View Drawing Layouts (Paper Space) on page 431

■ Work with Sheets in a Sheet Set on page 479

Quick Reference

Commands

MODEL

Switches from a layout tab to the Model tab.

RENAME

Changes the names assigned to items such as layers and dimension styles.

VPORTS

Creates multiple viewports in model space or paper space.

System Variables

CVPORT

Displays the identification number of the current viewport.

MAXACTVP

Sets the maximum number of viewports that can be active at one time in a
layout.

TILEMODE

Makes the Model tab or the last layout tab current.

VIEWCTR

Stores the center of view in the current viewport.
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VIEWSIZE

Stores the height of the view displayed in the current viewport, measured in
drawing units.

Utilities

No entries

Command Modifiers

No entries

Draw, Scale, and Annotate in Model Space
If you draw and plot from model space, you must determine and apply a scale
factor to annotate objects before you plot.

You can draw and plot entirely from model space. This method is useful
primarily for two-dimensional drawings that have a single view. With this
method, you use the following process:

■ Determine the unit of measurement (drawing units) for the drawing.

■ Specify the display style for the drawing unit.

■ Calculate and set the scale for dimensions, annotations, and blocks.

■ Draw at full scale (1:1) in model space.

■ Create the annotation and insert the blocks in model space.

■ Plot the drawing at the predetermined scale.

You can also use objects if you want to scale annotations automatically. For
information about using annotative objects and scaling annotations
automatically, see Scale Annotations on page 1393.

Determine the Unit of Measurement

Before you begin drawing in model space, you determine the unit of
measurement (drawing units) that you plan to use. You decide what each unit
on the screen represents, such as an inch, a millimeter, a kilometer, or some
other unit of measurement. For example, if you are drawing a motor part, you
might decide that one drawing unit equals a millimeter. If you are drawing a
map, you might decide that one unit equals a kilometer.
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Specify the Display Style of Drawing Units

Once you have determined a drawing unit for the drawing, you need to specify
the style for displaying the drawing unit, which includes the unit type and
precision. For example, a value of 14.5 can be displayed as 14.500, 14-1/2, or
1'2-1/2".

Specify the display style of drawing units with the UNITS command. The
default drawing unit type is decimal.

Set the Scale for Annotations and Blocks

Before you draw, you should set the scale for dimensions, annotations, and
blocks in your drawings. Scaling these elements beforehand ensures that they
are at the correct size when you plot the final drawing.

You should enter the scale for the following objects:

■ Text. Set the text height as you create text or by setting a fixed text height
in the text style (STYLE).

■ Dimensions. Set the dimension scale in a dimension style (DIMSTYLE) or
with the DIMSCALE system variable.

■ Linetypes. Set the scale for noncontinuous linetypes with the CELTSCALE
and LTSCALE system variables.

■ Hatch patterns. Set the scale for hatch patterns in the Hatch and Gradient
dialog box (HATCH) or with the HPSCALE system variable.

■ Blocks. Specify the insertion scale for blocks either as you insert them, or
set an insertion scale in the Insert dialog box (INSERT) or in DesignCenter
(ADCENTER). The system variables used for inserting blocks are INSUNITS,
INSUNITSDEFSOURCE, and INSUNITSDEFTARGET. This also applies to
the border and title block of the drawing.

You can also use objects if you want to scale annotations automatically. For
information about using annotative objects and scaling annotations
automatically, see Scale Annotations on page 1393.

Determine the Scale Factor for Plotting

To plot your drawing from the Model tab, you calculate the exact scale factor
by converting the drawing scale to a ratio of 1:n. This ratio compares plotted
units to drawing units that represent the actual size of the objects you are
drawing.
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For example, if you plan to plot at a scale of 1/4 inch = 1 foot, you would
calculate the scale factor 48 as follows:

1/4" = 12"

1 = 12 x 4

1 (plotted unit) = 48 (drawing units)

Using the same calculation, the scale factor for 1 centimeter = 1 meter is 100,
and the scale factor for 1 inch = 20 feet is 240.

Sample Scale Ratios
The sample architectural scale ratios in the table can be used to calculate text
sizes in model space.

Set drawing text
size to

To plot text size
at

Scale factorScale

30 cm3 mm1001 cm = 1 m

12"1/8"961/8" = 1'-0"

8"1/8"643/16" = 1'-0"

6"1/8"481/4" = 1'-0"

4"1/8"323/8" = 1'-0"

3"1/8"241/2" = 1'-0"

2"1/8"163/4" = 1'-0"

1.5"1/8"121" = 1'-0"

1.0"1/8"81 1/2" = 1'-0"

If you are working in metric units, you might have a sheet size of 210 x 297
mm (A4 size) and a scale factor of 20. You calculate grid limits as follows:

210 x 20 = 4200 mm

297 x 20 = 5900 mm

See also:

■ Specify Units and Unit Formats on page 180
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To specify the display style for drawing units

1 Click Format menu  ➤ Units. 

2 In the Drawing Units dialog box, set the unit values for your drawing.

3 As you change unit settings, you can see examples under Sample Output.

■ Under Length, select a unit type and level of precision. This determines
the display style for linear drawing units.

■ Under Drawing Units for DesignCenter Blocks, select the unit that
you want used to scale blocks, images, or other content inserted into
the drawing. If you do not want inserted content to be scaled, select
Unitless.

■ Under Angle, select an angle type and precision. This determines the
display style for angular drawing units. The default starting angle, 0
degrees, is toward 3 o'clock (or east).

■ To specify an angle direction, click Direction, and then select the base
angle in the Direction Control dialog box. The angle direction controls
the point from which angles are measured and the direction in which
they are measured. If you select Other, you can enter an angle, or click
Angle to specify an angle using your pointing device. The default
positive angle measurement is counterclockwise.

4 Click OK to exit each dialog box.

Command entry: UNITS

Quick Reference

Commands

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.

DIMSTYLE

Creates and modifies dimension styles.

INSERT

Inserts a block or drawing into the current drawing.
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LINETYPE

Loads, sets, and modifies linetypes.

PLOT

Plots a drawing to a plotter, printer, or file.

STYLE

Creates, modifies, or specifies text styles.

UNITS

Controls coordinate and angle display formats and precision.

System Variables

CELTSCALE

Sets the current object linetype scaling factor.

DIMSCALE

Sets the overall scale factor applied to dimensioning variables that specify
sizes, distances, or offsets.

HPSCALE

Specifies the hatch pattern scale factor, which must be greater than zero.

HPSPACE

Specifies the hatch pattern line spacing for user-defined simple patterns,
which must be greater than zero.

INSUNITS

Specifies a drawing-units value for automatic scaling of blocks, images, or
xrefs when inserted or attached to a drawing.

INSUNITSDEFSOURCE

Sets source content units value when INSUNITS is set to 0.

INSUNITSDEFTARGET

Sets target drawing units value when INSUNITS is set to 0.

LTSCALE

Sets the global linetype scale factor.
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LUNITS

Sets linear units.

TEXTSIZE

Sets the default height for new text objects drawn with the current text style.

Utilities

No entries

Command Modifiers

No entries
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Create Multiple-View
Drawing Layouts (Paper
Space)

Paper space is a sheet layout environment where you can specify the size of your sheet, add a
title block, display multiple views of your model, and create dimensions and notes for your
drawing.

Quick Start for Layouts
There are two distinct working environments, or “spaces,” in which you can
create objects in a drawing. These are represented by the Model and layout tabs.

Typically, a model composed of geometric objects is created in a
three-dimensional space called model space. A final layout of specific views and
annotations of this model is created in a two-dimensional space called paper
space. These spaces are accessible on two or more tabs near the bottom of the
drawing area: the Model tab and one or more layout tabs.

NOTE These tabs can be hidden, appearing instead as buttons on the status bar at
the bottom-center of the application window.

Working on the Model tab, you draw a model of your subject at 1:1 scale.
Working on a layout tab, you can create one or more layout viewports, dimensions,
notes, and a title block to represent a drawing sheet.

13
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Each layout viewport is like a picture frame containing a “photograph” of the
model in model space. Each layout viewport contains a view that displays the
model at the scale and orientation that you specify. You can also specify which
layers are visible in each layout viewport.

After you finish arranging the layout, you turn off the layer that contains the
layout viewport objects. The views are still visible, and you can plot the layout
without displaying the viewport boundaries.

Quick Reference

Commands

LAYOUT

Creates and modifies drawing layout tabs.

LAYOUTWIZARD

Creates a new layout tab and specifies page and plot settings.

MODEL

Switches from a layout tab to the Model tab.

MSPACE

Switches from paper space to a model space viewport.

MVIEW

Creates and controls layout viewports.

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.
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PSETUPIN

Imports a user-defined page setup into a new drawing layout.

PSPACE

Switches from a model space viewport to paper space.

VPORTS

Creates multiple viewports in model space or paper space.

VPLAYER

Sets layer visibility within viewports.

System Variables

MAXACTVP

Sets the maximum number of viewports that can be active at one time in a
layout.

PSLTSCALE

Controls the linetype scaling of objects displayed in paper space viewports.

TILEMODE

Makes the Model tab or the last layout tab current.

Utilities

No entries

Command Modifiers

No entries

Understand the Layout Process
When you use a layout tab to prepare your drawing for plotting, you follow
a series of steps in a process.

You design the subject of your drawing on the Model tab (in model space)
and prepare it for plotting on a layout tab (in paper space).

There is one Model tab and one or more layout tabs at the bottom of the
drawing window.
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NOTE These tabs can be hidden, appearing instead as buttons on the status bar
at the bottom-center of the application window.

You can initialize a layout by clicking on its tab to activate the previously
unused layout. A layout does not contain any plot settings before initialization.
Once initialized, layouts can be drawn upon, published, and added to sheet
sets as sheets (after the drawing has been saved).

Process Summary

When you prepare a layout, you typically step through the following process:

■ Create a model of your subject on the Model tab.

■ Click a layout tab.

■ Specify layout page settings such as plotting device, paper size, plot area,
plot scale, and drawing orientation.

■ Insert a title block into the layout (unless you have started with a drawing
template that already has a title block).

■ Create a new layer to be used for layout viewports.

■ Create layout viewports and position them on the layout.

■ Set the orientation, scale, and layer visibility of the view in each layout
viewport.

■ Add dimensions and annotate in the layout as needed.

■ Turn off the layer containing the layout viewports.

■ Plot your layout.

You can also use objects if you want to annotate your drawing in model space
and scale the annotations automatically. For information about using
annotative objects and scaling annotations automatically, see Scale Annotations
on page 1393.

The other topics in this chapter provide additional detail on how to create,
use, and modify layouts and layout viewports.
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Quick Reference

Commands

LAYOUT

Creates and modifies drawing layout tabs.

LAYOUTWIZARD

Creates a new layout tab and specifies page and plot settings.

MODEL

Switches from a layout tab to the Model tab.

MSPACE

Switches from paper space to a model space viewport.

MVIEW

Creates and controls layout viewports.

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

PSETUPIN

Imports a user-defined page setup into a new drawing layout.

PSPACE

Switches from a model space viewport to paper space.

VPLAYER

Sets layer visibility within viewports.

VPMAX

Expands the current layout viewport for editing.

VPMIN

Restores the current layout viewport.
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VPORTS

Creates multiple viewports in model space or paper space.

System Variables

LAYOUTREGENCTL

Specifies how the display list is updated in the Model tab and layout tabs.

MAXACTVP

Sets the maximum number of viewports that can be active at one time in a
layout.

TILEMODE

Makes the Model tab or the last layout tab current.

Utilities

No entries

Command Modifiers

No entries

Work with Model Space and Paper Space
There are several benefits to switching between model space and paper space
to perform certain tasks. Use model space for creating and editing your model.
Use paper space for composing your drawing sheet and defining views.

Work on the Model Tab
The Model tab accesses a limitless drawing area called model space. In model
space, you draw, view, and edit your model.

In model space, you draw your model at 1:1 scale, and you decide whether
one unit represents one millimeter, one centimeter, one inch, one foot, or
whatever unit is most convenient or customary in your business.

On the Model tab, you can view and edit model space objects. The crosshairs
cursor is active over the entire drawing area.
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In model space, you can also define named views that you display in layout
viewports on a layout.

To activate the Model tab

Do one of the following to make the Model tab current:

■ Click the Model tab.

■ Right-click any layout tab or the Model tab. Click Activate Model Tab.

■ If the Model and layout tabs are hidden, click the Model button on the
status bar at the bottom of the application window.

Quick Reference

Commands

MODEL

Switches from a layout tab to the Model tab.

MSPACE

Switches from paper space to a model space viewport.

PSPACE

Switches from a model space viewport to paper space.

System Variables

LAYOUTREGENCTL

Specifies how the display list is updated in the Model tab and layout tabs.
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MAXACTVP

Sets the maximum number of viewports that can be active at one time in a
layout.

TILEMODE

Makes the Model tab or the last layout tab current.

Utilities

No entries

Command Modifiers

No entries

Work on a Layout Tab
Layout tabs access an area called paper space. In paper space, you place your
title block, create layout viewports to display views, dimension your drawing,
and add notes.

In paper space, one unit represents the paper distance on a plotted sheet. The
units will be in either millimeters or inches, depending on the plot setup for
your plotter.

On a layout tab, you can view and edit paper space objects, such as layout
viewports and title blocks. You can also move an object (such as a leader or a
title block) from model space to paper space (or vice versa). The crosshairs
cursor is active over the entire layout area.

NOTE These tabs can be hidden, appearing instead as buttons on the status bar
at the bottom-center of the application window. To display the tabs, right-click
the Model or layout button and click Display Layout and Model Tabs on the
shortcut menu.
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Create Additional Layout Tabs

By default, a new drawing starts with two layout tabs, named Layout1 and
Layout2. If you use a drawing template or open an existing drawing, the layout
tabs in your drawing may be named differently.

You can create a new layout tab using one of the following methods:

■ Add a new layout tab with no settings and then specify the settings in the
Page Setup Manager.

■ Use the Create Layout wizard to create the layout tab and specify settings.

■ Copy a layout tab and its settings from the current drawing file.

■ Import a layout tab from an existing drawing template (DWT) file or
drawing (DWG) file.

NOTE You can create multiple layouts in a drawing; each layout can contain
different plot settings and paper sizes. However, to avoid confusion when
transmitting and publishing drawings, it is usually recommended that you create
only one layout for each drawing.

Use the Layout Wizard to Specify Layout Settings

You can create a new layout using the Create Layout wizard. The wizard
prompts you for information about the layout settings, including

■ A name for the new layout

■ The printer associated with the layout

■ A paper size to use for the layout

■ The orientation of the drawing on the paper

■ A title block

■ Viewport setup information

■ A location for the viewport configuration in the layout

You can edit the information entered in the wizard later. Click Output tab
 ➤  Plot panel  ➤ Page Setup Manager.

To specify the page setup for the current layout

■ Click Output tab ➤ Plot panel  ➤ Page Setup Manager.
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■ Right-click the current layout tab. Click Page Setup.

Toolbar: Layouts  
Command entry: PAGESETUP

To create a new layout

1 Click Insert menu  ➤ Layout ➤ New Layout.

2 Enter the name of the new layout at the command prompt.

A new layout tab is created. To switch to the new layout, choose the
layout tab.

Alternatively, you can right-click the existing layout tab and click New layout.
To rename a layout, double-click the layout tab.

Toolbar: Layouts  
Command entry: LAYOUT

To import a layout from a template

1 Click Insert menu  ➤ Layout ➤ Layout From Template.

2 In the Select File dialog box, select a DWT or DWG file to import a layout
from.

3 Click Open.

4 In the Insert Layout(s) dialog box, select a layout to import.

A new layout tab is created. To switch to the new layout, click the layout
tab.

Toolbar: Layouts  
Command entry: LAYOUT

To create a layout using a wizard

1 Click Insert menu  ➤ Layout ➤ Layout Wizard.
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2 On each page of the Create Layout wizard, select the appropriate settings
for the new layout.

When finished, the new layout will be the current layout tab.

Command entry: LAYOUTWIZARD

To duplicate a layout

1 Right-click the layout tab of the layout you want to duplicate. Click Move
or Copy.

2 In the Move or Copy dialog box, select a position for the new layout tab.

3 Make sure that Create a Copy is selected.

4 Click OK.

Alternatively, you can press CTRL+drag to create a duplicate copy of the
selected layout or a group of selected layouts.

NOTE The Model tab cannot be duplicated.

Command entry: LAYOUT

To rename a layout

1 Right-click the layout tab for the layout you want to rename. Click
Rename.

2 In the Rename Layout dialog box, enter the new name for the layout.

3 Click OK.

Alternatively, you can double-click the layout tab for the layout you want to
rename and directly enter the new name for the layout.

NOTE The Model tab cannot be renamed.

Command entry: LAYOUT

To delete a layout

1 Right-click the layout tab for the layout you want to delete. Click Delete.

2 In the warning box, click OK to delete the layout.
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Any named views associated with the layout are deleted automatically
when the layout is deleted.

NOTE The Model tab cannot be deleted.

Command entry: LAYOUT

To rearrange layout tabs

1 Right-click the layout tab of the layout you want to reposition. Click
Move or Copy.

2 In the Move or Copy dialog box, select the layout tab that should be
placed immediately after the moved or copied layout tab. If you want to
move the layout tab to the end of the list of layout tabs, select Move to
End.

3 Click OK.

Alternatively, you can click and drag the layout tab of the layout you want to
reposition and place the layout at the desired position.

NOTE The Model tab cannot be repositioned.

Command entry: LAYOUT

To make a layout current

Do one of the following to make a layout current:

■ Click the layout tab for the layout that you want to make current.

■ Press CTRL+Page Down to cycle through the layout tabs from left to right
or CTRL+Page Up to cycle through the layout tabs from right to left. Stop
when you get to the tab of the layout that you want to make current.

To move an object from model space to paper space (or vice versa)

1 Click Modify menu  ➤ Change Space. 

2 Select one or more objects to move.

3 Press ENTER to end the command.
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Command entry: CHSPACE

To activate the previous layout

1 Right-click any layout tab or the Model tab.

2 Click Activate Previous Layout.

To select all layouts

■ Right-click any layout tab. Click Select All Layouts.

Command entry: LAYOUT

To plot a layout

1 Click Output tab  ➤ Plot panel  ➤  Plot.

2 Do one of the following:

■ Right-click a layout tab. Click Plot.

■ Hold down SHIFT to select several layout tabs. Right-click a layout
tab. Click Publish Selected Layouts.

3 Select settings in the Plot or the Publish dialog box. Click OK or Publish.

Toolbar: Standard  
Command entry: PLOT

Quick Reference

Commands

LAYOUT

Creates and modifies drawing layout tabs.

LAYOUTWIZARD

Creates a new layout tab and specifies page and plot settings.

MODEL

Switches from a layout tab to the Model tab.
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MSPACE

Switches from paper space to a model space viewport.

MVIEW

Creates and controls layout viewports.

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

PSETUPIN

Imports a user-defined page setup into a new drawing layout.

PSPACE

Switches from a model space viewport to paper space.

VPORTS

Creates multiple viewports in model space or paper space.

VPLAYER

Sets layer visibility within viewports.

System Variables

CTAB

Returns the name of the current (model or layout) tab in the drawing.

CVPORT

Displays the identification number of the current viewport.

LAYOUTREGENCTL

Specifies how the display list is updated in the Model tab and layout tabs.

MAXACTVP

Sets the maximum number of viewports that can be active at one time in a
layout.

PLOTROTMODE

Controls the orientation of plots.
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TILEMODE

Makes the Model tab or the last layout tab current.

Utilities

No entries

Command Modifiers

No entries

Access Model Space from a Layout Viewport
You can access model space from a layout viewport to edit objects, to freeze
and thaw layers, and to adjust the view.

After creating viewport objects, you can access model space from a layout
viewport to perform the following tasks:

■ Create and modify objects in model space inside the layout viewport.

■ Pan the view inside the layout viewport and change layer visibility.

The method you use to access model space depends on what you plan to do.

Create and Modify Objects in a Layout Viewport

If you plan to create or modify objects, use the button on the status bar to
maximize the layout viewport. The maximized layout viewport expands to
fill the drawing area. The center point and the layer visibility settings of the
viewport are retained, and the surrounding objects are displayed.

You can pan and zoom while you are working in model space, but when you
restore the viewport to return to paper space, the position and scale of the
objects in the layout viewport are restored.

NOTE If you use PLOT while a viewport is maximized, the layout tab is restored
before the Plot dialog box is displayed. If you save and close the drawing while a
viewport is maximized, the drawing opens with the layout tab restored.

If you choose to switch to the Model tab to make changes, the layer visibility
settings are the settings for the drawing as a whole, not the settings for that
particular layout viewport. Also, the view is not centered or magnified the
same way it is in the layout viewport.

Access Model Space from a Layout Viewport | 445



Adjust the View in a Layout Viewport

If you plan to pan the view and change the visibility of layers, double-click
within a layout viewport to access model space. The viewport border becomes
thicker, and the crosshairs cursor is visible in the current viewport only. All
active viewports in the layout remain visible while you work. You can freeze
and thaw layers in the current viewport in the Layer Properties Manager, and
you can pan the view. To return to paper space, double-click an empty area
on the layout outside a viewport. The changes you made are displayed in the
viewport.

If you set the scale in the layout viewport before you access model space, you
can lock the scale to prevent changes. When the scale is locked, you cannot
use ZOOM while you work in model space.

To switch between model space and paper space on a layout

On a layout, use one of the following methods:

■ If you are in paper space, double-click within a layout viewport.
You are now in model space. The selected layout viewport becomes the
current viewport, and you can pan the view and change layer properties.
If you need to make significant changes to the model, it is recommended
that you use VPMAX to maximize the layout viewport or switch to the
Model tab.

■ If you are in model space in a layout viewport, double-click outside the
viewport.
You are now in paper space. You can create and modify objects on the
layout.

■ If you are in model space and want to switch to another layout viewport,
double-click within another layout viewport, or press CTRL+R to cycle
through the existing layout viewports.

To edit in a maximized layout viewport

1 Click the boundary of the layout viewport to select it.
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NOTE You can maximize a locked viewport and modify objects. When you
restore the viewport, it is locked again.

2 On the status bar, click the Maximize Viewport button.

You can restore the viewport and maximize another viewport by clicking
one of the arrows next to the Maximize Viewport button.

3 Make any changes.

4 To return to the layout viewport, click the Restore Viewport button on
the status bar.

The center point and magnification are returned to the settings that were
in effect before the viewport was maximized.

Command entry: VPMAX, VPMIN
Shortcut menu: Right-click. Click Maximize Viewport.

Quick Reference

Commands

MODEL

Switches from a layout tab to the Model tab.

MSPACE

Switches from paper space to a model space viewport.

PSPACE

Switches from a model space viewport to paper space.

VPMAX

Expands the current layout viewport for editing.

VPMIN

Restores the current layout viewport.

System Variables

VPMAXIMIZEDSTATE

Indicates whether the viewport is maximized or not.
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Utilities

No entries

Command Modifiers

No entries

Export a Layout to Model Space
You can export all visible objects from the current layout to model space.

You can export all visible objects from the current layout to the model space
with the EXPORTLAYOUT command. Objects that are outside the boundaries
of “paper” in the layout are also exported.

Some objects are not exported to the model space drawing. The objects are

■ Materials

■ Cameras

■ Lights

■ Named views

■ Objects on layers that are disabled (off) or frozen

■ Model space objects not visible in a given viewport

Changes to Exported Objects
When exported, some objects become a different object type, or are modified
in order to maximize visual fidelity with the layout.

Representation in Exported DrawingObject Type

Dimensions that exceed the boundaries of the layout viewport
are exploded.

Dimensions

Standard or dynamic blocks, with or without attributes, that
exceed the boundaries of the layout viewport will be converted

Standard or dynamic
block (with or without
attributes) to a new, anonymous block. Attributes are converted to text

objects in the block.
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Representation in Exported DrawingObject Type

NOTE The “Allow Exploding” setting (a setting on the block
definition) is ignored if the block exceeds the boundaries of
the layout viewport.

Objects become non-annotative.Annotative objects

An Xref with nested objects that exceed the boundaries of the
layout viewport is converted to a block reference and exploded.

External reference
(xref)

Layout viewports are represented by either a polyline or the
clipped viewport object.

Layout viewport

Custom objects are exploded and converted to anonymous
blocks.

Custom objects

Xrefs clipped with the XCLIP command are converted to a
clipped block reference.

Xref clipped with the
XCLIP command

The 2D wireframe visual style is used.Visual Styles

Objects within a perspective viewport will have parallel projec-
tion.

Perspective viewports

NOTE Objects that can be directly trimmed without changing their types are not
listed on the table.

Visual Changes to Objects

Not all objects when displayed in a layout will display the same in the Model
tab of the exported drawing. This includes (but is not limited to) the following
instances:

■ The same object displayed in multiple viewports becomes multiple objects
in the exported model space drawing. In addition, objects are transformed
and often scaled. Both of these can affect data extraction of blocks.

■ Some objects are converted or exploded in order to trim them.

■ Viewports in a layout can each have a different visual style; only a single
visual style can be used in model space.
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■ Polylines with width that is clipped by the viewport boundary may not
be accurately trimmed in the exported drawing.

Recommendations

When exporting a layout to model space, consider the following:

■ The performance of the EXPORTLAYOUT command may be slower if a
model space viewport is active.

■ In the exported drawing, the viewport displays the original linetype, which
may not match the look of the original drawing. If this happens, assign
“Continuous” linetype to viewports in the original drawing.

■ Linetype scaling may not be accurately maintained for objects in xrefs and
blocks if PSLTSCALE is 0.

■ If you have a problem with xrefs during export, detach unresolved xrefs
or manually bind xrefs and then use the EXPORTLAYOUT command.

■ Superhatch objects (from Express Tools) are exported, but the hatching
may not stay within the original boundaries. You can use the TRIM
command in the exported drawing to correct any problems with visual
appearance.

To export a layout to a model space drawing

1 Click File menu ➤ Export Layout to Model. 

NOTE You can use the EXPORTLAYOUT command only from a layout tab.

2 In the Export Layout to Model Space Drawing dialog box, enter a file
name.

3 Specify the location where you want to save the file. The default location
is the location of the current drawing.

4 Click Save.

Command entry: EXPORTLAYOUT
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To achieve better visual fidelity for a drawing containing AEC objects

1 In an open drawing, enter aectoacad. The AECTOACAD command creates
a new DWG file with all AEC objects exploded into basic AutoCAD objects.

NOTE It is also recommended to select Insert as the bind type when using
the AECTOACAD command.

2 Navigate to the converted drawing. Click Open.

3 On the command line, enter exportlatyout.

Command entry: EXPORTLAYOUT

Quick Reference

Commands

EXPORTLAYOUT

Creates a visual representation of the current layout in the model space of a
new drawing.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create and Modify Layout Viewports
You can create a single layout viewport that fits the entire layout or create
multiple layout viewports in the layout. Once you create the viewports, you
can change their size, their properties, and also scale and move them as needed.

NOTE It is important to create layout viewports on their own layer. When you are
ready to plot, you can turn off the layer and plot the layout without plotting the
boundaries of the layout viewports.
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With MVIEW, you have several options for creating one or more layout
viewports. You can also use COPY and ARRAY to create multiple layout
viewports.

Create Nonrectangular Layout Viewports

You can create a new viewport with nonrectangular boundaries by converting
an object drawn in paper space into a layout viewport.

You can use the MVIEW command to create nonrectangular viewports.

■ With the Object option, you can select a closed object, such as a circle or
closed polyline created in paper space, to convert into a layout viewport.
The object that defines the viewport boundary is associated with the
viewport after the viewport is created

■ With the Polygonal option, you can create a nonrectangular layout
viewport by specifying points. The prompts are the same as the prompts
for creating a polyline

NOTE When you want to suppress the display of the boundary of a layout viewport,
you should turn off the layer of the nonrectangular viewport instead of freezing
it. If the layer of a nonrectangular layout viewport is frozen, the viewport is not
clipped correctly.

Redefine Layout Viewport Boundaries

You can redefine the boundary of a layout viewport by using the VPCLIP
command. You can either select an existing object to designate as the new
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boundary, or specify the points of a new boundary. The new boundary does
not clip the old boundary, it redefines it.

A nonrectangular viewport consists of two objects: the viewport itself and the
clipping boundary. You can make changes to the viewport, the clipping
boundary, or both.

NOTE In the Properties palette, the default selection for a nonrectangular viewport
is Viewport. This is because you are more likely to change the properties of the
viewport than of the clipping boundary.

Resize Layout Viewports

If you want to change the shape or size of a layout viewport, you can use grips
to edit the vertices just as you edit any object with grips.

To create a new layout viewport

1 On the layout tab, Click View tab ➤ Viewports panel ➤ New.

2 In the Viewports dialog box, New Viewports tab, under Standard
Viewports, select Single.

3 Click to specify one corner of the new layout viewport.

4 Click to specify the opposite corner.

A new layout viewport object is available and displays a default view. To
adjust the view, double-click within the layout viewport to access model
space.

Toolbar: Viewports  
Command entry: VPORTS, MVIEW

To create a viewport configuration on a layout

1 Click a layout tab.

2 On the layout tab, Click View tab ➤ Viewports panel ➤ New.

3 In the Viewports dialog box, New Viewports tab, under standard viewports
select a viewport configuration from the list.

4 Under Setup, select either 2D or 3D.
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When you select 3D, a set of standard 3D views is applied to each viewport
in the configuration.

5 Under Viewport Spacing, select the amount of spacing you want to add
between the viewports.

6 To change a view, select a viewport in the preview image. Under Change
View To, select a view from the list of standard views.

The list includes top, bottom, front, back, left, right, and isometric views,
along with any named views that are saved in the drawing. The selected
view is displayed under Preview.

7 Click OK.

8 In the drawing area, specify two points to indicate the area to contain
the viewport configuration.

Toolbar: Viewports  
Command entry: VPORTS

To place a named viewport configuration into a layout

1 Click a layout tab.

2 Click View tab ➤ Viewports panel ➤ Named. 

3 In the Viewports dialog box, Named Viewports tab, select the named
viewport configuration from the list.

4 Click OK.

5 In the layout, specify a location for the named viewport configuration.

Toolbar: Viewports 

Command entry: VPORTS

454 | Chapter 13   Create Multiple-View Drawing Layouts (Paper Space)



To modify layout viewport properties using the Properties palette

1 Click the border of the layout viewport whose properties you want to
modify.

2 Click View tab  ➤  Palettes panel ➤  Properties

3 In the Properties palette, select the value for the property you want to
modify. Enter a new value or select a new setting from the list provided.

The new property setting or value is assigned to the selected layout
viewport.

Toolbar: Standard  
Command entry: PROPERTIES

Shortcut menu: Select the viewport and right-click in the drawing area.
Click Properties.

To clip a layout viewport boundary

1 Click View tab ➤ Viewports panel ➤ Viewport Clip. 

2 Select the viewport to clip.

3 (Optional) Enter d (Delete) to delete an existing clipping boundary.

4 Do one of the following:

5 Enter p (Polygonal) to specify a series of points to define a polygonal
boundary.

■

■ Select a paper space object that will define the new viewport boundary.

Command entry: Select the viewport to clip and right-click in the drawing
area. Click Viewport Clip.

Quick Reference

Commands

MVIEW

Creates and controls layout viewports.
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PROPERTIES

Controls properties of existing objects.

VPCLIP

Clips layout viewport objects and reshapes the viewport border.

VPORTS

Creates multiple viewports in model space or paper space.

System Variables

MAXACTVP

Sets the maximum number of viewports that can be active at one time in a
layout.

Utilities

No entries

Command Modifiers

No entries

Control Views in Layout Viewports
When you create a layout, you can add layout viewports that act as windows
into model space. In each layout viewport, you can control the view that is
displayed.

Scale Views in Layout Viewports
To scale each displayed view in the plotted drawing accurately, set the scale
of each view relative to paper space.

You can change the view scale of the viewport using

■ The Properties palette

■ The XP option of the ZOOM command

■ The Viewports toolbar
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NOTE You can modify the list of scales that are displayed in all view and plot scale
lists with SCALELISTEDIT.

When you work in a layout, the scale factor of a view in a layout viewport
represents a ratio between the actual size of the model displayed in the
viewport and the size of the layout. The ratio is determined by dividing the
paper space units by the model space units. For example, for a quarter-scale
drawing, the ratio would be a scale factor of one paper space unit to four model
space units, or 1:4.

Scaling or stretching the layout viewport border does not change the scale of
the view within the viewport.

Lock the Scale of Layout Viewports

Once you set the viewport scale, you cannot zoom within a viewport without
changing the viewport scale. By locking the viewport scale first, you can zoom
in to view different levels of detail in your viewport without altering the
viewport scale.

Scale locking locks the scale that you set for the selected viewport. Once the
scale is locked, you can continue to modify the geometry in the viewport
without affecting the viewport scale. If you turn a viewport's scale locking on,
most of the viewing commands, such as VPOINT, DVIEW, 3DORBIT, PLAN,
and VIEW, no longer function in that viewport.

NOTE Viewport scale locking is also available for nonrectangular viewports. To
lock a nonrectangular viewport, you must perform an extra step in the Properties
palette to select the viewport object rather than the viewport clipping boundary.

To modify a layout viewport scale using the Properties palette

1 Make sure you are on a layout tab in paper space.

2 Click the border of the viewport whose scale you want to modify.

3 Right-click, and then click Properties.

4 In the Properties palette, select Standard Scale, and then select a new
scale from the list.

The scale you choose is applied to the viewport.

NOTE To use a custom scale, enter a scale in the Custom Scale field in the
Properties palette.
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Toolbar: Standard  
Command entry: PROPERTIES

Shortcut menu: Select the viewport and right-click in the drawing area.
Click Properties.

To turn on scale locking in a layout viewport

1 In the layout, click the viewport whose scale you want to lock.

2 If necessary, open the Properties palette.

3 In the Properties palette, do one of the following:

■ If you selected a rectangular viewport, select Display Locked, and then
click Yes.

■ If you selected a nonrectangular viewport, first click All (2) and select
Viewport (1). Then select Display Locked, and click Yes.

The current viewport's scale is locked. If you change the zoom factor in
the viewport, only paper space objects are affected.

Toolbar: Standard  
Command entry: PROPERTIES

Shortcut menu: Select the viewport and right-click in the drawing area.
Click Properties.

Quick Reference

Commands

SCALELISTEDIT

Controls the list of scales available for layout viewports, page layouts, and
plotting.

MVIEW

Creates and controls layout viewports.

PROPERTIES

Controls properties of existing objects.
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VPORTS

Creates multiple viewports in model space or paper space.

ZOOM

Increases or decreases the magnification of the view in the current viewport.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Control Visibility in Layout Viewports
You can control the visibility of objects in layout viewports using several
methods. These methods are useful for emphasizing or hiding different
elements of a drawing, and for reducing screen regeneration time.

Freeze Specified Layers in a Layout Viewport
A major benefit to using layout viewports is that you can selectively freeze
layers in each layout viewport. You can also specify default visibility settings
for new viewports and for new layers. As a result, you can view different objects
in each layout viewport.

You can freeze or thaw layers in current and future layout viewports without
affecting other viewports. Frozen layers are invisible. They are not regenerated
or plotted. In the illustration, the layer showing terrain has been frozen in
one viewport.

Control Visibility in Layout Viewports | 459



Thawing the layer restores visibility. The easiest way to freeze or thaw layers
in the current viewport is to use the Layer Properties Manager.

In the Layer Properties Manager, on the right side, use the column labeled VP
Freeze to freeze one or more layers in the current layout viewport. To display
the VP Freeze column, you must be on a layout tab. Specify the current layout
viewport by double-clicking anywhere within its borders.

Freeze or Thaw Layers Automatically in New Layout Viewports

You can set visibility defaults for specific layers in all new layout viewports.
For example, you can restrict the display of dimensions by freezing the
DIMENSIONS layer in all new viewports. If you create a viewport that requires
dimensions, you can override the default setting by changing the setting in
the current viewport. Changing the default for new viewports does not affect
existing viewports.

Create New Layers That Are Frozen in All Layout Viewports

You can create new layers that are frozen in all existing and new layout
viewports. Then you can thaw the layers in the viewports you specify. This is
a shortcut for creating a new layer that is visible only in a single viewport.

To freeze or thaw layers in the current layout viewport

1 Double-click within a layout viewport to make it current.

2 Click Home tab  ➤  Layer panel  ➤  Layer Properties.

3 In the Layer Properties Manager, select the layers to freeze or thaw.

Hold down CTRL to select more than one layer. Hold down SHIFT to
select a sequence of layers.

4 Click the icon in the VP Freeze column for one of the selected layers.
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5 Click OK.

Toolbar: Layers  
Command entry: LAYER

To view a list of layers that are frozen in the current viewport

1 Click a layout tab.

2 Double-click within a layout viewport to make it current.

3 Click Home tab  ➤  Layer panel  ➤  Layer Properties.

4 In the Layer Properties Manager, look at the VP Freeze column for the
Freeze/Thaw in Current Viewports icon.

5 Click OK.

Toolbar: Layers  
Command entry: LAYER, VPLAYER

To freeze or thaw layers in all viewports

1 Click a layout tab.

2 Click Home tab  ➤  Layer panel  ➤  Layer Properties.

3 In the Layer Properties Manager, select one or more layers to freeze or
thaw.

Hold down CTRL to select more than one layer. Hold down SHIFT to
select a sequence of layers.

4 In the Freeze column, click the icon to freeze or thaw.

Toolbar: Layers  
Command entry: LAYER

To freeze or thaw layers in paper space

1 Click a layout tab.
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2 Make sure that you are in paper space. (On the status bar, PAPER is on.)

3 Click Home tab  ➤  Layer panel  ➤  Layer Properties.

4 In the Layer Properties Manager, select the layer or layers you want to
freeze or thaw.

5 In the Freeze column, click the icon to change a layer's state. The sun
icon means that a layer is thawed; the snowflake icon means that a layer
is frozen.

6 Click OK.

Toolbar: Layers  
Command entry: LAYER

To freeze or thaw layers in all new viewports

1 Click a layout tab.

2 Click Home tab  ➤  Layer panel  ➤  Layer Properties.

3 In the Layer Properties Manager, select the layer or layers you want to be
automatically frozen or thawed in new viewports you create.

Hold down CTRL to select more than one layer. Hold down SHIFT to
select a sequence of layers.

4 In the New VP Freeze column, click the icon to change a layer's state.
The sun icon means that a layer is thawed; the snowflake icon means
that a layer is frozen.

5 Click OK.

Toolbar: Layers  
Command entry: LAYER

To create new layers that are frozen in all viewports

1 Click a layout tab.

2 Click Home tab  ➤  Layer panel  ➤  Layer Properties.

3 Click the New Layer button to create a layer.
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4 Rename the new layer.

5 Click the icon in the Freeze column to change the layer's state to frozen.
The sun icon means that a layer is thawed; the snowflake icon means
that a layer is frozen.

6 Click OK.

Toolbar: Layers  
Command entry: LAYER, VPLAYER

Quick Reference

Commands

LAYER

Manages layers and layer properties.

VPLAYER

Sets layer visibility within viewports.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Screen Objects in Layout Viewports
Screening refers to applying less ink to an object when it is plotted. The object
appears dimmer on the screen and on the plotted paper. Screening can be
used to help differentiate objects in a drawing without changing the objects'
color properties.

To assign a screening value to an object, you must assign a plot style to the
object, and then define the screening value in that plot style.
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You can assign a screening value from 0 to 100. The default setting, 100, means
no screening is applied, and the object is displayed with normal ink intensity.
A screening value of 0 means the object contains no ink and is thus invisible
in that viewport.

See also:

■ Set Options for Plotted Objects on page 1809

To apply screening to objects in a layout viewport

1 Click File menu  ➤ Plot Style Manager.

2 Right-click a CTB or STB file. Click Open.

3 In the Plot Style Table Editor, Form View tab, select a plot style to change.

4 In the Screening box, enter an intensity value between 1 and 100.

5 Click Save & Close.

6 Click Output tab  ➤  Plot panel  ➤  Page Setup Manager.

7 In the Page Setup dialog box, Plot Device tab, select the edited plot style
table from the Plot Style Table (Pen Assignments) list.

8 Double-click within the layout viewport that contains the objects whose
screening you want to change.

9 Select the objects whose plot style you want to change.

10 Right-click in the drawing area and click Properties.

11 In the Properties palette, use one of the following methods:

■ If you are using named plot style tables, next to Plot Style, select the
plot style you edited in the Plot Style Table Editor. If that plot style
is not listed, select Other and set Active Plot Style Table to the plot
style you edited in the Plot Style Table Editor. Select the edited plot
style from the Plot Styles list in the Select Plot Style dialog box.

■ If you are using color-dependent plot style tables, next to Color, select
the color whose plot style you edited in the Plot Style Table Editor.
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Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PROPERTIES

Controls properties of existing objects.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Turn Layout Viewports On or Off
You can save time by turning some layout viewports off or by limiting the
number of active viewports.

Displaying a large number of active layout viewports can affect your system's
performance as the content of each layout viewport regenerates. You can save
time by turning some layout viewports off or by limiting the number of active
viewports. The following illustration shows the effects of turning off two
layout viewports.

Control Visibility in Layout Viewports | 465



New layout viewports are turned on by default. If you turn off the layout
viewports you aren't using, you can copy layout viewports without waiting
for each one to regenerate.

If you don't want to plot a layout viewport, you can turn the layout viewport
off.

To turn viewports on or off using the Properties palette

1 Make sure you are on a layout tab in paper space.

2 Click the border of the viewport to turn on or off.

3 Click Home tab  ➤  Layer panel  ➤  Layer Properties.

4 In the Properties palette, under Misc, select On, and then select Yes or
No to turn the viewport on or off.

For a nonrectangular viewport, select All (2) in the Properties palette, and
then select Viewport (1) before changing any viewport properties.

Toolbar: Standard  
Command entry: PROPERTIES

Shortcut menu: Select the viewport and right-click in the drawing area.
Click Display Viewport Objects.

Quick Reference

Commands

MVIEW

Creates and controls layout viewports.

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PROPERTIES

Controls properties of existing objects.

VPORTS

Creates multiple viewports in model space or paper space.
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System Variables

MAXACTVP

Sets the maximum number of viewports that can be active at one time in a
layout.

Utilities

No entries

Command Modifiers

No entries

Scale Linetypes in Layout Viewports
You can scale linetypes in paper space either based on the drawing units of
the space in which the object was created or based on the paper space units.

You can set the PSLTSCALE system variable to maintain the same linetype
scaling for objects displayed at different zoom factors in a layout and in a
layout viewport. For example, with PSLTSCALE set to 1 (default), set the current
linetype to dashed, and then draw a line in a paper space layout. In the layout,
create a viewport with a zoom factor of 1x, make that layout viewport current,
and then draw a line using the same dashed linetype. The dashed lines should
appear to be the same. If you change the viewport zoom factor to 2x, the
linetype scaling for the dashed line in the layout and the dashed line in the
layout viewport will be the same, regardless of the difference in the zoom
factor.

With PSLTSCALE turned on, you can still control the dash lengths with
LTSCALE and CELTSCALE. In the following illustration, the pattern of the
linetypes in the drawing on the left has been scaled to be the same regardless
of the scale of the view. In the drawing on the right, the scale of the linetypes
matches the scale of each view.

Scale Linetypes in Layout Viewports | 467



See also:

■ Set the Lineweight Scale for a Layout on page 1763

To scale linetypes globally in paper space

1 Click Home tab  ➤  Properties panel  ➤  Linetype.

2 In the Linetype Manager, click Show Details.

3 Under Global Scale Factor, enter a global scale to apply to the linetypes.

4 Click OK.

Command entry: LINETYPE

Quick Reference

Commands

LINETYPE

Loads, sets, and modifies linetypes.

System Variables

PSLTSCALE

Controls the linetype scaling of objects displayed in paper space viewports.

Utilities

No entries

Command Modifiers

No entries

Align Views in Layout Viewports
You can arrange the elements of your drawing by aligning the view in one
layout viewport with the view in another viewport.
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For angled, horizontal, and vertical alignments, you can move each layout
viewport relative to distances defined by the model-space geometry displayed.

To adjust the views on a layout with precision, you can create construction
geometry, use object snaps on the model-space objects displayed in layout
viewports, or use one of the cursor constraint features available on the status
bar.

To align objects between viewports using a construction line

1 Make sure you are on a layout tab.

2 Click Home tab  ➤  Draw panel  ➤  Construction Line.

3 Specify a point in the first viewport. Specify a second point to determine
a line for the alignment.

Choose a point that can be aligned with objects in the second viewport.
Use object snaps for precision.
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4 Click Home tab  ➤  Modify panel  ➤  Move.

5 Select the viewport to align to the first viewport. Press ENTER.

6 When prompted for a base point, specify a point in the second viewport.
Choose a point that corresponds with the point selected in the first
viewport.

7 When prompted for the second point, hold down SHIFT and right-click.
Click Object Snap ➤ Perpendicular.Click the construction line you created.

The first and second viewports, and the objects in the viewports, are
aligned.

NOTE When aligning objects in viewports, the scale of the viewports should
be the same.

To align objects between viewports using MVSETUP

1 At the command prompt, enter mvsetup.

2 Enter a (Align).

3 Select one of the following alignments:

■ Horizontal. Aligns a point in one viewport horizontally with a base
point in another viewport.

■ Vertical. Aligns a point in one viewport vertically with a base point
in another viewport.

■ Angled. Aligns a point in one viewport at a specified distance and
angle from a base point in another viewport.

4 Make sure the viewport with the view that is to remain stationary is
current. Then specify a base point.

5 Select the viewport with the view you want to realign. Then specify an
alignment point in that view.

6 For angled alignments only, specify a distance and displacement angle
from the base point to the alignment point in the second viewport.
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Quick Reference

Commands

MOVE

Moves objects a specified distance in a specified direction.

MVSETUP

Sets up the specifications of a drawing.

UCS

Manages user coordinate systems.

UCSICON

Controls the visibility and placement of the UCS icon.

UCSMAN

Manages defined user coordinate systems.

System Variables

UCSICON

Controls the visibility and placement of the UCS icon.

UCSVP

Determines whether the UCS in viewports remains fixed or changes to reflect
the UCS of the current viewport.

Utilities

No entries

Command Modifiers

No entries

Rotate Views in Layout Viewports
You can rotate an entire view within a layout viewport with the
VPROTATEASSOC system variable.

Rotate Views in Layout Viewports | 471



When VPROTATEASSOC is set to 1, the view within a viewport is rotated with
the viewport. When VPROTATEASSOC is set to 0, the view remains when the
viewport is rotated.

You can also rotate an entire view within a layout viewport by changing the
UCS and using the PLAN command.

With the UCS command, you can rotate the XY plane at any angle around the
Z axis. When you enter the PLAN command, the view rotates to match the
orientation of the XY plane.

Another way is touse the Align and then Rotate View options in the MVSETUP
command.

NOTE The ROTATE command rotates individual objects only and should not be
used to try to rotate a view.

To rotate a view within a viewport

1 At the Command prompt, enter vprotateassoc.

2 Set the value to 1.

3 Make sure you are on a layout tab.

4 Select the viewport with the view you want to rotate.

5 Enter r (Rotate) to rotate the view to a specified angle or with two points.

6 Specify a base point for the rotation.

7 Specify the rotation angle or specify a second point to determine the
angle of rotation.

The entire view rotates within the viewport.

NOTE When VPROTATEASSOC is set to 0, the view within the viewport is not
rotated when the viewport is rotated.
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To rotate a view by changing the UCS

1 Make sure you are on a layout tab.

2 Double-click within the viewport whose objects you want to rotate.

3 Make sure that the current UCS is parallel to the plane of rotation (the
UCS icon should look normal). If the UCS is not parallel to the plane of
rotation, Click View tab ➤ Coordinates panel ➤ View..

4 Click View tab ➤ Coordinates panel ➤ View.

To rotate the view 90 degrees clockwise, enter 90. To rotate the view 90
degrees counter-clockwise, enter -90.

5 Click View menu  ➤ 3D Views ➤ Plan View ➤ Current UCS.

The entire view rotates within the viewport. You may need to specify the
scale of the viewport again.

Toolbar: UCS  
Command entry: UCS

To rotate a layout view using MVSETUP

1 On a layout, enter mvsetup at the command prompt.

2 Enter a (Align).

3 Enter r (Rotate) to rotate the view to a specified angle or with two points.

4 If multiple viewports are available on the layout, click the viewport with
the view that you want to rotate.

5 Specify a base point for the rotation.

6 Specify the rotation angle or specify a second point to determine the
angle of rotation.

The entire view rotates within the viewport.

7 To restore the previous UCS, enter ucs and then p (Previous).
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Quick Reference

Commands

MVSETUP

Sets up the specifications of a drawing.

PLAN

Displays the plan view of a specified user coordinate system

UCS

Manages user coordinate systems.

UCSICON

Controls the visibility and placement of the UCS icon.

UCSMAN

Manages defined user coordinate systems.

System Variables

UCSICON

Controls the visibility and placement of the UCS icon.

UCSVP

Determines whether the UCS in viewports remains fixed or changes to reflect
the UCS of the current viewport.

VIEWTWIST

Stores the view rotation angle for the current viewport measured relative to
the WCS.

VPROTATEASSOC

Controls whether the view within a viewport is rotated with the viewport
when the viewport is rotated.
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Utilities

No entries

Command Modifiers

No entries

Reuse Layouts and Layout Settings
When you create a layout, you can choose to apply the information from an
existing template.

A layout template is a layout imported from a DWG or DWT file. When you
create a layout, you can choose to apply the information from an existing
template. The program has sample layout templates to use when you design
a new layout environment. The paper space objects and page setup in the
existing template are used in the new layout. Thus, the layout objects,
including any viewport objects, are displayed in paper space. You can keep
any of the existing objects from the template you import, or you can delete
the objects. No model space objects are imported.

The layout templates are identified with a .dwt file extension. However, a
layout template or layout from any drawing or drawing template can be
imported into the current drawing.

Save a Layout Template

Any drawing can be saved as a drawing template (DWT file), including all of
the objects and layout settings. You can save a layout to a new DWT file by
choosing the Save As option of the LAYOUT command. The template file is
saved in the drawing template file folder as defined in the Options dialog box,
Support tab. The layout template has a .dwt or .dwg extension like a drawing
template or drawing file, but it contains little information not essential to the
layout.

When you create a new layout template, any named items, such as blocks,
layers, and dimension styles, that are used in the layout are saved with the
template. These definition table items are imported as part of the layout
settings if you import this template into a new layout. It is recommended that
you use the Save As option of the LAYOUT command to create a new layout
template. When you use the Save As option, unused definition table items are
not saved with the file; they are not added to the new layout into which you
import the template.
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If you insert a layout from a drawing or template that was not created using
the Save As option of the LAYOUT command, definition table items that are
used in the drawing but not in the layout are inserted with the layout. To
eliminate unnecessary definition table items, use the PURGE command.

Insert a Layout Using DesignCenter

Using DesignCenter™, you can drag a layout with its objects from any drawing
into the current drawing.

When you use DesignCenter to insert a layout into a drawing, a new layout
is created that includes all of the paper space objects, definition tables, and
block definitions from the source layout. You can delete unneeded paper space
objects. To eliminate any unnecessary definition table information from the
new layout, use the PURGE command.

To create a layout using a layout template

1 Click Insert menu  ➤ Layout ➤ Layout From Template.

2 In the Select Template From File dialog box, select a drawing template
file from the list.

3 Click Open.

4 In the Insert Layout(s) dialog box, select the layout template from the
list. Click OK.

A new layout is created using the layout template you selected. The new
layout is assigned the name Layout with the next number in the sequence
and with the name of the imported layout attached.

For example, if you insert a layout called ANSI D from a layout template
and you already have two layouts in your drawing called Layout1 and
Layout2, the new layout is called Layout3 - ANSI D.

Toolbar: Layouts  
Command entry: LAYOUT

Shortcut menu: Right-click the layout tab. Click From Template.

To save a layout template

1 At the command prompt, enter layout.

2 At the prompt, enter sa to save the current layout as a template.
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3 Enter the name of the layout you are saving.

4 In the Create Drawing File dialog box, enter a name for the drawing
template file you are saving.

5 In Files of Type, select Drawing Template File (*.dwt).

6 Click Save.

To insert a layout using DesignCenter

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter.

2 In the tree view, find the drawing that contains the layout you want to
reuse.

3 Double-click the drawing name to expand the options beneath it.

4 Select the Layouts icon to display the individual layouts in the content
area.

5 Use one of the following methods to insert the layout into the current
drawing:

■ Drag the layout icon from the content area into the drawing.

■ Select a layout in the content area and right-click. Click Add Layout(s).

■ Double-click the layout in the content area.

Toolbar: Standard  
Command entry: ADCENTER

Quick Reference

Commands

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.

LAYOUT

Creates and modifies drawing layout tabs.
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PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PCINWIZARD

Displays a wizard to import PCP and PC2 configuration file plot settings into
the Model tab or current layout.

PURGE

Removes unused items, such as block definitions and layers, from the drawing.

System Variables

TDCREATE

Stores the local time and date the drawing was created.

TDUCREATE

Stores the universal time and date that the drawing was created.

TDUPDATE

Stores the local time and date of the last update/save.

TDUUPDATE

Stores the universal time and date of the last update or save.

Utilities

No entries

Command Modifiers

No entries
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Work with Sheets in a
Sheet Set

With the Sheet Set Manager, you can organize drawing layouts into named sheet sets. The
sheets in a sheet set can be transmitted, published, and archived as a unit.

Sheet sets facilitate the organization and management of drawings in a project, and improve
the communication in a work group.

Quick Start for Sheet Sets
A sheet set is an organized collection of sheets from several drawing files. A sheet
is a selected layout from a drawing file.

Sets of drawings are the primary deliverable for most design groups. Sets of
drawings communicate the overall design intent of a project and provide the
documentation and specifications for the project. However, managing sets of
drawings manually can be complicated and time consuming.

With the Sheet Set Manager, you can manage drawings as sheet sets. A sheet set
is an organized and named collection of sheets from several drawing files. A
sheet is a selected layout from a drawing file. You can import a layout from any
drawing into a sheet set as a numbered sheet.
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You can manage, transmit, publish, and archive sheet sets as a unit.

Quick Reference

Commands

NEWSHEETSET

Creates a new sheet set data file that manages drawing layouts, file paths,
and project data.

OPENSHEETSET

Opens a selected sheet set.

SHEETSET

Opens the Sheet Set Manager.

SHEETSETHIDE

Closes the Sheet Set Manager.

System Variables

SSFOUND

Displays the sheet set path and file name if a search for a sheet set is
successful.

SSLOCATE

Controls whether the sheet set associated with a drawing is located and
opened when the drawing is opened.
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SSMAUTOOPEN

Controls the display behavior of the Sheet Set Manager when a drawing
associated with a sheet is opened.

SSMPOLLTIME

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

SSMSHEETSTATUS

Controls how the status data in a sheet set is refreshed.

SSMSTATE

Indicates whether the Sheet Set Manager window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Understand the Sheet Set Manager Interface
Using the controls in the Sheet Set Manager, you can create, organize, and
manage sheets in a sheet set.
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You can use the following tabs and controls in the Sheet Set Manager:

Sheet Set Control. Lists menu options to create a new sheet set, open an
existing sheet set, or switch between open sheet sets.

Sheet List Tab. Displays an organized list of all sheets in the sheet set. Each
sheet in a sheet set is a specified layout in a drawing file.

Sheet Views Tab. Displays an organized list of all sheet views in the sheet set.
Only sheet views created with AutoCAD 2005 and later are listed.

Model Views Tab. Lists the paths and folder names for the drawings containing
model space views to be used in the sheet set.

■ Click a folder to list the drawing files that are located in that folder.

■ Click a drawing file to list the named model space views that are available
for placement in the current sheet.

■ Double-click a view to open the drawing containing the view.

■ Right-click or drag a view to place it in the current sheet.

Buttons. Provides convenient access for the most commonly used operations
for the currently selected tab.

Tree View. Displays the contents of a tab.

Details or Preview. Displays either descriptive information or a thumbnail
preview of the currently selected item in the tree view.

Actions Used in the Tree View

You can use the following actions in the tree view:

■ Right-click to access shortcut menus of the operations that are relevant to
the currently selected item.

■ Double-click items to open them. This is a convenient method for opening
drawing files from the Sheet List tab or from the Model Views tab. You
also double-click items in the tree view to expand or collapse them.

■ Click one or more items to select them for operations such as opening,
publishing, or transmitting.

■ Click a single item to display descriptive information or a thumbnail
preview of a selected sheet, view, or drawing file.

■ Drag items within the tree view to reorder them.
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NOTE To use the Sheet Set Manager effectively, right-click items in the tree view
to access relevant shortcut menus. For access to shortcut menus in the drawing
area that are needed for sheet set operations, the Shortcut Menus in Drawing Area
must be checked in the Options dialog box, User Preferences tab.

Quick Reference

Commands

NEWSHEETSET

Creates a new sheet set data file that manages drawing layouts, file paths,
and project data.

OPENSHEETSET

Opens a selected sheet set.

SHEETSET

Opens the Sheet Set Manager.

SHEETSETHIDE

Closes the Sheet Set Manager.

System Variables

SSFOUND

Displays the sheet set path and file name if a search for a sheet set is
successful.

SSLOCATE

Controls whether the sheet set associated with a drawing is located and
opened when the drawing is opened.

SSMAUTOOPEN

Controls the display behavior of the Sheet Set Manager when a drawing
associated with a sheet is opened.

SSMPOLLTIME

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

SSMSHEETSTATUS

Controls how the status data in a sheet set is refreshed.
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SSMSTATE

Indicates whether the Sheet Set Manager window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Create and Manage a Sheet Set
There are several methods for setting up and organizing a sheet set. You can
also include relevant information with a sheet set and its components.

Create a Sheet Set
You create a sheet set with the Create a Sheet Set wizard. In the wizard, you
can either create a sheet set from scratch based on existing drawings or use
an example sheet set as a template.

Layouts from specified drawing files are imported into the sheet set. The
associations and information that define a sheet set are stored in a sheet set
data (DST) file.

When creating a new sheet set using the Create Sheet Set wizard, a new folder
is created as the default sheet set storage location. This new folder, named
AutoCAD Sheet Sets, is located in the My Documents folder. The default location
for the sheet set file can be changed, and it is recommended that the DST file
is stored with the project files.

NOTE The DST file should be stored in a network location that is accessible to all
sheet set users on the network and mapped using the same logical drive. It is
strongly recommended that you store the DST and the sheet drawings in the same
folder. If an entire sheet set needs to be moved, or a server or folder name changes,
the DST file will still be able to locate the sheets using relative path information.
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Preparation Tasks

Before you begin creating a sheet set, you should complete the following tasks:

■ Consolidate drawing files. Move the drawing files to be used in the sheet
set into a small number of folders. This will simplify sheet set
administration.

■ Eliminate multiple layout tabs. Each drawing you plan to use in the sheet
set should have only one layout to be used as a sheet in the sheet set. This
is important for access to sheets by multiple users. Only one sheet in each
drawing can be open at a time.

■ Create a sheet creation template. Create or identify a drawing template
(DWT) file to be used by the sheet set for creating new sheets. This drawing
template file is called the sheet creation template. You specify this template
file in the Sheet Set Properties dialog box or the Subset Properties dialog
box.

■ Create a page setup overrides file. Create or identify a DWT file to store
page setups for plotting and publishing. This file, called the page setup
overrides file, can be used to apply a single page setup to all sheets in a sheet
set, overriding the individual page setups stored in each drawing.

NOTE Although it is possible to use several layouts from the same drawing file as
separate sheets in a sheet set, it is not recommended. This makes concurrent access
to each layout by multiple users impossible. This practice can also reduce your
management options and can complicate the organization of your sheet sets.

Create a Sheet Set from an Example Sheet Set

In the Create Sheet Set wizard, when you choose to create a sheet set from an
example, the example sheet set provides the organizational structure and
default settings for the new sheet set. You can also specify that folders are
created corresponding to the subset storage paths of the sheet set.

After you create an empty sheet set with this option, you can import layouts
or create sheets individually.

Create a Sheet Set from Existing Drawing Files

In the Create Sheet Set wizard, when you choose to create a sheet set from
existing drawing files, you specify one or more folders that contain drawing
files. With this option, you can specify that the subset organization for the
sheet set duplicates the folder structure of the drawing files. The layouts from
these drawings can be imported into the sheet set automatically.
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You can easily add more folders containing drawings by clicking the Browse
button for each additional folder.

Backup and Recover Sheet Set Data Files

The data stored in the sheet set data file represents a significant amount of
work, so you should take the same care to create backups of DST files as you
do for drawing files.

In the unlikely event of DST file corruption or a major user error, the previously
saved sheet set data file can be recovered. Every time the sheet set data file is
opened, the current sheet set data file is copied to a backup file (DS$). This
backup file has the same file name and is located in the same folder as the
current sheet set data file.

To recover the previous version of the sheet set data file, first make sure that
no one else on your network is working on the sheet set. Then, it is
recommended that you copy the existing DST file to another file name. Finally,
rename the backup file from the DS$ file extension to the DST file extension.

To open the Sheet Set Manager

■ Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

Toolbar: Standard  
Command entry: SHEETSET

To create a new sheet set

1 To create a new sheet set, do one of the following:

■ Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

■ In the Sheet Set Manager, click the Sheet Set control. Click New Sheet
Set.

2 Follow the steps in the Create Sheet Set wizard.

Command entry: NEWSHEETSET
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To open a sheet set

1 To open a sheet set, do one of the following:

■ Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

■ In the Sheet Set Manager, click the Sheet Set control. Click Open.

■ Double-click a sheet set data (DST) file.

2 In the Open Sheet Set dialog box, navigate to a folder that contains a
DST file. Click the DST file and then click open.

The Sheet Set Manager displays the sheet set data.

NOTE You can open several sheet sets and then use the Sheet Set control
to switch between them.

Toolbar: Standard  
Command entry: SHEETSET

To close a sheet set

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, Sheet List tab, right-click the sheet set node (at
the top of the list). Click Close Sheet Set.

The sheet set is no longer displayed in the Sheet Set Manager.

NOTE Close a sheet set to reduce the number of sheet sets listed in the Sheet
Set control. However, if you close a sheet set while you still have sheets in
the sheet set open, you will not be able to update the Sheet List table and
certain fields.

Toolbar: Standard  
Command entry: SHEETSET
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Quick Reference

Commands

NEWSHEETSET

Creates a new sheet set data file that manages drawing layouts, file paths,
and project data.

OPENSHEETSET

Opens a selected sheet set.

SHEETSET

Opens the Sheet Set Manager.

SHEETSETHIDE

Closes the Sheet Set Manager.

System Variables

SSFOUND

Displays the sheet set path and file name if a search for a sheet set is
successful.

SSLOCATE

Controls whether the sheet set associated with a drawing is located and
opened when the drawing is opened.

SSMAUTOOPEN

Controls the display behavior of the Sheet Set Manager when a drawing
associated with a sheet is opened.

SSMPOLLTIME

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

SSMSHEETSTATUS

Controls how the status data in a sheet set is refreshed.

SSMSTATE

Indicates whether the Sheet Set Manager window is open or closed.
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Utilities

No entries

Command Modifiers

No entries

Organize a Sheet Set
With a large sheet set, you will find it essential to organize sheets and views
in the tree view.

On the Sheet List tab, sheets can be arranged into collections called subsets.
On the Sheet Views tab, views can be arranged into collections called categories.

Use Sheet Subsets

Sheet subsets are often associated with a discipline such as architecture or
mechanical design. For example, in architecture, you might use a subset named
Structural; and in mechanical design, you might use a subset called Standard
Fasteners. In some cases, you might also find it useful to create subsets
associated with a review or completion status.

You can nest subsets into other subsets as needed. After you create or import
sheets or subsets, you can reorder them by dragging them in the tree view.

Use View Categories

View categories are often associated with a function. For example, in
architecture, you might use a view category called Elevations; and in
mechanical design, you might use a view category called Exploded.

You can display views either by category or by the sheet on which they are
located.
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You can nest categories into other categories as needed. To move a view to a
different category, drag them in the tree view or use the Set Category shortcut
menu option.

To reorder sheets in the sheet list

■ Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

■ In the Sheet Set Manager, on the Sheet List tab, drag a sheet up or down
the list.

The sheet is relocated above or below its previous location on the sheet list.
The sheet may also be moved into or out of a sheet subset.

Toolbar: Standard  
Command entry: SHEETSET

To create a new subset in the sheet list

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, Sheet List tab, right-click the sheet set node (at
the top of the list), or an existing subset. Click New Subset.

3 In the Subset Properties dialog box, under Subset Name, enter the name
of the new subset. Click OK.

You can drag the new subset anywhere on the sheet list, even under other
subsets.

NOTE If you want to create a subset under an existing subset, you can
right-click the existing subset. On the shortcut menu, click New Subset.

490 | Chapter 14   Work with Sheets in a Sheet Set



Toolbar: Standard  
Command entry: SHEETSET

To create a new view category in the view list

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, Sheet Views tab, click the View by Category
button.

3 Right-click the sheet set node (at the top of the list). Click New View
Category.

4 In the View Category dialog box, under Category Name, enter the name
of the new view category.

5 If a list of blocks is displayed, select the callout blocks to be used for the
views in this view category. You can add blocks to the list by clicking the
Add Blocks button.

Toolbar: Standard  
Command entry: SHEETSET

To remove a subset from the sheet list

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, Sheet List tab, drag all sheets out of the subset
that you want to remove.

3 Right-click the subset that you want to remove. Click Remove Subset.

Toolbar: Standard  
Command entry: SHEETSET
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To remove a view category from the view list

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, Sheet Views tab, click the View by Category
button.

3 Drag all views out of the view category that you want to remove.

4 Right-click the view category that you want to remove. Click Remove
Category.

Toolbar: Standard  
Command entry: SHEETSET

Quick Reference

Commands

NEWSHEETSET

Creates a new sheet set data file that manages drawing layouts, file paths,
and project data.

OPENSHEETSET

Opens a selected sheet set.

SHEETSET

Opens the Sheet Set Manager.

SHEETSETHIDE

Closes the Sheet Set Manager.

System Variables

SSFOUND

Displays the sheet set path and file name if a search for a sheet set is
successful.
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SSLOCATE

Controls whether the sheet set associated with a drawing is located and
opened when the drawing is opened.

SSMAUTOOPEN

Controls the display behavior of the Sheet Set Manager when a drawing
associated with a sheet is opened.

SSMPOLLTIME

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

SSMSHEETSTATUS

Controls how the status data in a sheet set is refreshed.

SSMSTATE

Indicates whether the Sheet Set Manager window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Create and Modify Sheets
There are several options in the Sheet Set Manager for creating sheets and
adding views either through a shortcut menu or one of the tab buttons.
Modifying a sheet should always be done from an open sheet set.

Following are descriptions of common sheet operations. You can access
commands by right-clicking an item in the tree view to display the relevant
shortcut menu.

■ Import layout as sheet. After you create a sheet set, you can import one
or more layouts from existing drawings. You can initialize a layout by
clicking on its tab to activate the previously unused layout. A layout does
not contain any plot settings before initialization. Once initialized, layouts
can be drawn upon, published, and added to sheet sets as sheets (after the
drawing has been saved). This is a fast method for creating multiple sheets
from layouts in several drawings. In the current drawing, you can drag a
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layout tab directly onto the Sheets area of the Sheet List tab in the Sheet
Set Manager.

■ Create a new sheet. As an alternative to importing existing layouts, you
can create a new sheet. When you place views in this sheet, the drawing
files associated with the views are attached as xrefs to the sheet drawing.
The sheet drawing file is created using either the AutoCAD 2004 format
or the AutoCAD 2007 format, depending on the format specified on the
Open and Save tab in the Options dialog box.

■ Modify a sheet. Double-click a sheet on the Sheet List tab to open a drawing
from the sheet set. Use SHIFT or CTRL to select multiple sheets. To review
a sheet, use the shortcut menu to open a drawing in read-only mode.

NOTE Modifying a sheet should always be done using an open sheet set in
the Sheet Set Manager. This ensures that all data associated with the sheet are
updated.

■ Rename and renumber a sheet. After you create a sheet, you can change
the sheet title and the sheet number. You can also specify a different
drawing file associated with the sheet.

NOTE If you change the layout name, the corresponding sheet title in the
sheet set is also updated or vice versa.

■ Remove a sheet from a sheet set. Removing a sheet from a sheet set
disassociates the sheet from the sheet set, but does not delete the drawing
file or the layout.

■ Reassociate a sheet. If you move a sheet to a different folder, you should
reassociate the sheet to the sheet set with the Sheet Properties dialog box
to correct the path. For any relocated sheet drawing, the paths for Expected
Layout and Found Layout are displayed in the Sheet Properties dialog box.
To reassociate the sheet, click the path in Expected Layout and then click
to navigate to the new location of the sheet.
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NOTE You can quickly confirm whether a sheet is in the expected folder by
looking at Details at the bottom of the Sheet List tab. If the selected sheet is
not in the expected location, path information for both Expected Location and
Found Location is displayed in Details.

■ Add a view to a sheet. From the Model Views tab, you can easily add a
view to a sheet by placing a named model space view or the entire drawing
onto the current sheet.

NOTE After creating a named model space view, you must save the drawing
to add the view to the Model Views tab. Click Refresh on the Model Views tab
to update the Sheet Set Manager tree view.

■ Add label blocks to views. With the Sheet Set Manager, you can label views
and details automatically as you place them. Labels contain data associated
with the referenced view.

■ Add callout blocks to views. Callout blocks is the term for the symbols that
reference other sheets. Callout blocks have many industry-specific names
such as reference tags, detail keys, detail makers, building section keys,
and so on. Callout blocks contain data associated with the sheet and view
that are referenced.

NOTE When you place a callout block with fields or a view on a sheet, make
sure that the current layer is unlocked.

■ Create a title sheet and table of contents. The first sheet in a sheet set will
usually be a title sheet that includes a description of the sheet set and a
table that lists all the sheets in the sheet set. You can create this table,
called a sheet list table, on an open sheet. The table automatically includes
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all the sheets in the sheet set. Once a sheet list table is created, you also
have options to edit, update, or delete the cell content of the table.
You can create a sheet list table from the shortcut menu of sheet set subsets
and sheets only when a sheet is open. You can also create sheet list tables
for multiple subsets and sheets. Any sheets added to a subset later on are
automatically added to the sheet list table.

NOTE For access to shortcut menus in the drawing area that are needed for
sheet list table operations, the Shortcut Menus in Drawing Area must be
checked in the Options dialog box, User Preferences tab.

Create Callout Blocks and Label Blocks (Advanced)

If you create a block to be used as a callout block or label block in a sheet set,
you can use a placeholder field to display information such as view title or
sheet number. The callout or label block must be defined in a DWG or DWT
file that is specified in the Sheet Set Properties dialog box. Later, you can insert
the callout or label block from a shortcut menu on the Sheet Views tab in the
Sheet Set Manager.

For the field to display the correct information about a view or sheets on
which you later insert it, the field must be included within a block attribute,
not text, when you define the block. To create the block attribute definition,
insert a placeholder field as the value, select the Preset option, and specify a
tag.

NOTE If you create your own label blocks and callout blocks, set any attribute
definitions to Preset to avoid prompts when placing these blocks in a drawing.

For more information about fields, see Insert Fields on page 1532.

Place a Sheet View (Advanced)

The Sheet Set Manager automates and enhances the process for adding views
to a sheet. A view on a sheet, called a sheet view, consists of several coincident
entities: an xref or geometry in model space, a layout viewport on a sheet,
and a named view in paper space.

■ The sheet view can display model space from a different drawing file. In
this case, that drawing is attached as an xref in your current drawing. The
layers of that drawing file are displayed only in the sheet view that you
create.
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NOTE The xref is attached using a relative path. If you need to change the
path to a fully specified (absolute) path, use the External References palette.

■ A layout viewport that displays the model space view is created on your
current sheet.

■ A named view that encompasses the area of the layout viewport is created
in paper space.

When you place a sheet view on a sheet, all the layers in the current drawing
(including layer 0) are frozen in the new viewport created by the view. The
layers are shown as frozen in the VP Freeze column of the Layer Properties
Manager.

If you need to remove a sheet view from a sheet, you can delete the layout
viewport to remove the view. However, to remove all unused items, you need
to detach the xref and delete the named paper space view.

NOTE The easiest method for removing a sheet view immediately after placing it
is to use UNDO.

See also:

■ Create Multiple-View Drawing Layouts (Paper Space) on page 431

To import a layout from the current drawing as a sheet

1 If the Model and layout tabs are not visible at the bottom of the drawing
area, right-click the Model button on the status bar and click Display
Layout and Model tabs.

2 Do one of the following:

■ Right-click a layout tab and click Import Layout as Sheet.

■ Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

■ Drag a layout tab onto the Sheet Set Manager, Sheet List Tab, Sheets
area.

3 Click Import Checked.

Toolbar: Standard  
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Command entry: SHEETSET

To import layouts from several drawings as sheets

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, Sheet List tab, right-click the sheet set node, a
subset node, or a sheet node. Click Import Layout as Sheet.

3 In the Import Layouts as Sheets dialog box, click Browse for Drawings
and navigate to the drawing that you want to use.

To select several drawings, use SHIFT or CTRL when you click on the
drawing files.

4 Click the check boxes of the layouts to be imported as sheets in the
current sheet set. Click Import Checked.

5 (Optional) On the Sheet List tab, right-click a newly imported sheet. Click
Rename & Renumber.

6 (Optional) In the Rename & Renumber Sheet dialog box, make any
changes to the sheet number and sheet title. Click OK.

NOTE Changes to the sheet number and sheet title have no effect on the
drawing file name unless a file rename option is checked.

Toolbar: Standard  
Command entry: SHEETSET

To create a new sheet

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, Sheet List tab, right-click either the sheet set
node, a subset node, or a sheet node. Click New Sheet.

3 In the New Sheet dialog box, enter the sheet number and sheet title. Click
OK.

The new sheet is created from the drawing template file specified in Sheet
Set Properties for the default new sheet creation template.
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NOTE You can change the default folder location for new sheets from the
Sheet Set Properties or the Subset Properties dialog box.

Toolbar: Standard  
Command entry: SHEETSET

To open a drawing file within a sheet set

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, double-click a sheet. To select several drawings,
use SHIFT or CTRL when you click on the drawing files.

The drawing file for the sheet is opened. Any changes made to the drawing
that are relevant to the sheet list are updated in the sheet set data (DST)
file.

Toolbar: Standard  
Command entry: SHEETSET

To open a drawing file read-only within a sheet set

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, right-click a sheet. Click Open Read-Only.

Toolbar: Standard  
Command entry: SHEETSET
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To remove a sheet from a sheet set

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, right-click the sheet that you want to remove. Click
Remove Sheet.

The specified sheet is removed from the sheet list. The sheet and the
drawing file are not deleted, however. The sheet can be added to a
different sheet set.

NOTE The DWG file associated with a sheet does not have to be accessible
for the sheet to be removed from the sheet set.

Toolbar: Standard  
Command entry: SHEETSET

To reassociate a sheet in a sheet set

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, open the sheet that you want to reassociate.

4 In the Sheet Set Manager, right-click the sheet. Click Remove Sheet.

5 Save the drawing.

6 In the Sheet Set Manager, right-click the Sheet Set. Click Import Layout
as Sheet.

7 In the Import Layout as Sheet dialog box, click Browse for Drawings.
Navigate to the drawing that you want to use.

8 Click the check box of the layout to be reassociated as a sheet in the
current sheet set. Click Import Checked.
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Toolbar: Standard  
Command entry: SHEETSET

To add a view to a sheet

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, do one of the following:

■ Double-click a sheet to open it.

■ Create a new sheet and open it.

4 On the Model Views tab, click the plus sign (+) next to a folder to list the
drawings in the folder.

5 From the list of drawing files, do one of the following:

■ To add a model space view to a sheet, click the plus sign (+) next to
a drawing file to list its named model space views. Right-click a model
space view.

■ To add an entire drawing as a view in a sheet, right-click a drawing
file.

6 Click Place on Sheet.

NOTE As an alternative to the previous two steps, you can drag a model
space view or a drawing from the Model Views tab to a sheet.

7 Right-click on the sheet. Click the scale for the sheet view.

8 Specify the insertion point for the sheet view.

The specified view is added to the sheet. If a view label block is defined
in the sheet set properties, a view label that displays view-specific
information is automatically placed on the sheet.

Toolbar: Standard  
Command entry: SHEETSET
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To add a sheet list table

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 Right-click a sheet set name, subset, or multiple sheet set names and
subsets. Click Insert Sheet List Table.

4 In the Insert Sheet List Table dialog box, do the following:

■ Set the Table Style in the Table Style Settings group.

■ On the Table Data tab, specify Title Text for the table and add, remove,
or change the order of the column entries.

■ On the Subsets and Sheets tab, select the subsets and sheets to be
included in the sheet list table.

NOTE If you add a sheet to a subset later on, you will be automatically
prompted to update the sheet list table.

5 Click OK.

Toolbar: Standard  
Command entry: SHEETSET

To edit a sheet list table

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet List tab, select a cell in an existing sheet list table.

3 Right-click the cell. Click Edit Sheet List Table Settings.

4 In the Edit Sheet List Table Settings dialog box, do one or more of the
following:

■ Change the Table Style if you don’t like the current format.

■ Edit the Title Text for the table.

■ Add, remove, or change the order of the column entries.
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■ Change the data type or heading text for column entries.

5 Click OK to close the dialog box and change the table to the drawing.

Shortcut menu: Select any cell in the sheet list table  ➤  Right-click to open
the shortcut menu  ➤  Edit Sheet List Table Settings.

To update a sheet list table

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet List tab, select a cell in an existing sheet list table.

3 Right-click the cell. Click Update Sheet List Table.

Shortcut menu: Select any cell in the sheet list table  ➤  Right-click to open
the shortcut menu  ➤  Update Sheet List Table.

To add a block to be used for sheet view callouts

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet Views tab, right-click the sheet set node.

4 In the Sheet Set Properties dialog box, click Callout Blocks. Click the [...]
button.

5 In the List of Blocks dialog box, do one of the following:

■ Click a block from the list of blocks.

■ Click the Add button and specify a new block to be added to the list.

6 Click OK to close each dialog box.

Toolbar: Standard  
Command entry: SHEETSET
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To change the default block used for sheet view labels

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet Views tab, right-click the sheet set node.

4 In the Sheet Set Properties dialog box, click Label Block for Views. Click
the [...] button.

5 In the Select Block dialog box, specify a new block to be used as the default
view label block.

6 Click OK to close each dialog box.

Toolbar: Standard  
Command entry: SHEETSET

To add a callout block to a sheet

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet Views tab, right-click the view with which you want to
associate a callout. Click Place Callout Block.

4 Specify the insertion point of the callout block.

The callout block is placed on the sheet. The callout block automatically
displays view-specific information about the view with which it is
associated.

Toolbar: Standard  
Command entry: SHEETSET
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To create a sheet list table on a title sheet

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, double-click the sheet to be used as the title sheet.

4 Right-click the sheet set node. Click Insert Sheet List Table.

5 In the Sheet List Table dialog box, enter the title of the table. Make any
formatting changes needed.

6 Click OK.

7 Specify the insertion point of the table.

The sheet list table automatically generates a list of all the sheets in the
sheet set.

Toolbar: Standard  
Command entry: SHEETSET

Quick Reference

Commands

NEWSHEETSET

Creates a new sheet set data file that manages drawing layouts, file paths,
and project data.

OPENSHEETSET

Opens a selected sheet set.

SHEETSET

Opens the Sheet Set Manager.

SHEETSETHIDE

Closes the Sheet Set Manager.
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System Variables

SSFOUND

Displays the sheet set path and file name if a search for a sheet set is
successful.

SSLOCATE

Controls whether the sheet set associated with a drawing is located and
opened when the drawing is opened.

SSMAUTOOPEN

Controls the display behavior of the Sheet Set Manager when a drawing
associated with a sheet is opened.

SSMPOLLTIME

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

SSMSHEETSTATUS

Controls how the status data in a sheet set is refreshed.

SSMSTATE

Indicates whether the Sheet Set Manager window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Include Information with Sheets and Sheet Sets
Sheet sets, subsets, and sheets include several types of information. This
information, called properties, includes titles, descriptions, file paths, and
custom properties that you define.

Different Properties for Different Levels (Owners)

Sheet sets, subsets, and sheets represent different levels of organization, and
each of these includes different types of properties. You specify the values for
these properties when you create the sheet set, subset, or sheet.
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In addition, you can define custom properties for a sheet and a sheet set. The
values for custom properties for sheets are typically specific to each sheet. For
example, a custom property for a sheet might include the name of the designer.
The values for custom properties for a sheet set are typically specific to a
project. For example, a custom property for a sheet set might include the
contract number.

You cannot create custom properties for subsets.

View and Edit Properties

You can view and edit properties from the Sheet List tab by right-clicking the
name of the sheet set, subset, or sheet. On the shortcut menu, click Properties.
The properties and values that are displayed in the Properties dialog box
depend on what you selected. You can edit the values of the properties by
clicking a value.

To edit the properties of a sheet set, subset, sheet, or view category

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 Do one of the following:

■ On the Sheet List tab, right-click the sheet set node, a subset, or a
sheet.

■ On the Sheet Views tab, right-click a view category.

4 Click Properties.

5 In the dialog box that is displayed, click any field and enter the changes.

6 Click OK.

Toolbar: Standard  
Command entry: SHEETSET

To create a custom property for a sheet set

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.
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2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, right-click the sheet set node. Click Properties.

4 In the Sheet Set Properties dialog box, click the Edit Custom Properties
button.

5 In the Custom Properties dialog box, do one of the following:

■ Click Add to create a new custom property for the sheet set. Click the
name and the default value to enter the information for these fields.
To assign this property to the sheet set, make sure that Sheet Set is
selected under Owner.

■ Click the name and the default value to change the information for
these fields.

■ Click a custom property from the list. Click Delete to remove the
property.

6 Click OK to close each dialog box.

Toolbar: Standard  
Command entry: SHEETSET

To create a custom property for a sheet

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, right-click the sheet set node.

4 In the Sheet Set Properties dialog box, click the Edit Custom Properties
button.

5 In the Custom Properties dialog box, do one of the following:

■ Click Add to create a new custom property for the sheet. Click the
name and the default value to enter the information for these fields.
To assign this property to the sheet, make sure that Sheet is selected
under Owner.
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■ Click the name and the default value to change the information for
these fields. With this method, you can change the value for every
sheet in the sheet set.

■ Click a custom property from the list. Click Delete to remove the
property.

6 Click OK to close each dialog box.

Toolbar: Standard  
Command entry: SHEETSET

Quick Reference

Commands

NEWSHEETSET

Creates a new sheet set data file that manages drawing layouts, file paths,
and project data.

OPENSHEETSET

Opens a selected sheet set.

SHEETSET

Opens the Sheet Set Manager.

SHEETSETHIDE

Closes the Sheet Set Manager.

System Variables

SSFOUND

Displays the sheet set path and file name if a search for a sheet set is
successful.

SSLOCATE

Controls whether the sheet set associated with a drawing is located and
opened when the drawing is opened.
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SSMAUTOOPEN

Controls the display behavior of the Sheet Set Manager when a drawing
associated with a sheet is opened.

SSMPOLLTIME

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

SSMSHEETSTATUS

Controls how the status data in a sheet set is refreshed.

SSMSTATE

Indicates whether the Sheet Set Manager window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Publish, Transmit, and Archive Sheet Sets
After you have organized drawings into a sheet set, you can publish, transmit,
and archive the sheet set as a package.

■ Publish a sheet set: Use the Publish feature to output the sheet set to a
plotter in either normal or reverse order. For more information, see Publish
a Sheet Set on page 1885. You can create single and multiple-sheet DWF or
DWFx files from a sheet set or portion of a sheet set.
For information on DWF files, see Plot DWF Files on page 1851.

For information on DWFx files, see Plot DWFx Files on page 1852.

■ Set options for properties to include in a published DWF or DWFx file:
You can decide what types of information to reveal in your published DWF
or DWFx files. The types of metadata that you can include are sheet and
sheet set properties, block properties and attributes, dynamic block
properties and attributes, and properties contained in custom objects.
Metadata is only included when you publish to DWF or DWFx; it is not
available when plotting to DWF or DWFx.
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■ Transmit a sheet set: Package and send a sheet set or a portion of a sheet
set over the Internet. For more information, see Package a Set of Files for
Internet Transmission.

■ Archive a sheet set: Package a sheet set or portion of a sheet set for storage.
This is very similar to packaging a transmittal set, except that you specify
a folder for the archive and you do not transmit the package. For more
information, see the ARCHIVE command.

Use Page Setups

Page setups provide the settings that are used for publishing and plotting.
When you create a sheet set, you specify a drawing template (DWT) file that
contains one or more page setups for all new sheets. This DWT file is called
the sheet creation template.

Another DWT file, called the page setup overrides file, contains page setups that
can be specified to override the page setups in each sheet. You specify the
page setup overrides file in the Sheet Set Properties dialog box.

When you publish a sheet set, you can use the page setups defined in each
drawing file, you can use the page setup overrides for all drawing files, or you
can publish to a DWF or DWFx file. For more information about page setups,
see Use Named Page Setups with Sheet Sets on page 1780.

NOTE With page setup overrides, you can use the PUBLISHCOLLATE system
variable to control whether plotting a sheet set can be interrupted by other plot
jobs or not.

Save a Selection of Sheets

You can select part of a sheet set for publishing and transmitting. On the Sheet
List tab, you can select individual sheets using standard Microsoft® Windows®

selection methods—press CTRL or SHIFT when you click items. You can specify
all the sheets in a sheet subset by clicking the subset node.

You will likely need to perform operations on the same group of sheets in a
sheet set repeatedly. To speed up selecting the sheets and to ensure that the
same sheets are selected each time, you can use the Sheet Set Manager to
reselect groups of sheets by name. These named groups of sheets are called
sheet selections. You can create and manage sheet selections by using the Sheet
Selections button at the top of the Sheet List tab.
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To save a sheet selection

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, click the sheets and subsets to include in the sheet
selection.

You can use CTRL or SHIFT to specify several items from the list.

4 In the Sheet List Manager, near the upper-right corner, click the Sheet
Selections button. Click Create.

5 In the New Sheet Selection dialog box, enter the name of the sheet
selection. Click OK.

Toolbar: Standard  
Command entry: SHEETSET

To restore a sheet selection

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, near the upper-right corner, click the Sheet
Selections button. Select the name of the sheet selection that you want
to restore.

The sheet selection is activated and available for publishing and
transmitting operations.

Toolbar: Standard  
Command entry: SHEETSET

To rename or delete a sheet selection

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.
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2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, near the upper-right corner, click the Sheet
Selections button. Click Manage.

4 In the Sheet Selections dialog box, select the name of a sheet selection
and do one of the following:

■ Click Rename to rename the sheet selection. Enter the new name for
the sheet selection.

■ Click Delete to remove the sheet selection name from the list. Click
Yes to confirm that you want to remove this sheet selection name.

5 Click OK.

Toolbar: Standard 
Command entry: SHEETSET

To modify an existing sheet selection

NOTE You cannot modify a sheet selection directly. Instead, you activate a sheet
selection and modify it, delete the name of the sheet selection, and then create a
new sheet selection in its place.

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, near the upper-right corner, click the Sheet
Selections button. Select the name of the sheet selection to modify.

4 Use the CTRL key to add and remove items from the sheet selection.

5 On the Sheet List Manager, near the upper-right corner, click the Sheet
Selections button. Click Manage.

6 Click Delete to remove the sheet selection name from the list. Click Yes
to confirm that you want to remove this sheet selection name.

7 Click OK to close the Sheet Selections dialog box.

8 On the Sheet List Manager, near the upper-right corner, click the Sheet
Selections button. Click Create.
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9 In the New Sheet Selection dialog box, enter the name of the sheet
selection. Click OK.

Toolbar: Standard  
Command entry: SHEETSET

To publish a DWF or DWFx file including layer, block, sheet set, and sheet
information

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, Sheet List tab, select the sheet set to publish
in a DWF or DWFx file.

3 Click the Publish button. Click Sheet Set Publish Options.

4 In the Sheet Set Publish Options dialog box, under DWF Data Options,
depending on what you want to include in the published DWF or DWFx
file, click any of the following to change the option to “Include.”

■ Layer information

■ Sheet set information (attributes you can choose to include are
description and custom properties)

■ Sheet information (attributes you can choose to include are sheet title,
sheet number, description, sheet set, subset, and sheet custom
properties)

■ Block information

NOTE Some sheet properties are always published in the DWF or DWFx
file (no matter what setting you make in the Sheet Set Publish Options
dialog box). These are: sheet name, sheet size, author, creator, creation
time, and modification time.

5 Click OK.

Toolbar: Standard 
Command entry: SHEETSET
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To publish a DWF or DWFx file using a block template file to include block
properties and attributes

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, Sheet List tab, select the sheet set to publish
in a DWF or DWFx file.

3 Click the Publish button. Click Sheet Set Publish Options.

4 In the Sheet Set Publish Options dialog box, under DWF Data Options,
Block Information, click to display the drop-down list, and select
“Include.”

5 Under DWF Data Options, Block Template File, select the block template
file you want to use or create a new one. Click OK.

The block template file defining the blocks and their properties and
attributes will be included in the published DWF or DWFx file.

Toolbar: Standard  
Command entry: SHEETSET

Quick Reference

Commands

ARCHIVE

Packages the current sheet set files for archive.

NEWSHEETSET

Creates a new sheet set data file that manages drawing layouts, file paths,
and project data.

OPENSHEETSET

Opens a selected sheet set.

SHEETSET

Opens the Sheet Set Manager.
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SHEETSETHIDE

Closes the Sheet Set Manager.

System Variables

PUBLISHCOLLATE

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

SSFOUND

Displays the sheet set path and file name if a search for a sheet set is
successful.

SSLOCATE

Controls whether the sheet set associated with a drawing is located and
opened when the drawing is opened.

SSMAUTOOPEN

Controls the display behavior of the Sheet Set Manager when a drawing
associated with a sheet is opened.

SSMSHEETSTATUS

Controls how the status data in a sheet set is refreshed.

SSMSTATE

Indicates whether the Sheet Set Manager window is open or closed.

Utilities

No entries

Command Modifiers

No entries

Use Sheet Sets in a Team
You can use sheet sets in a team that can involve network access, Internet
collaboration, and email transmittal. The team can also include people who
use software that does not include Sheet Set Manager.
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Work in a Team That Uses Sheet Set Manager

When you use sheet sets in a team, each member should have network access
to the sheet set data (DST) file and the drawing template (DWT) files associated
with the sheet set. Each team member can open the sheet set to load the sheet
set information from the DST file into the Sheet Set Manager.

Any changes that any team member makes opens the DST file briefly and
updates the information stored in that file. When the DST file is opened, a
lock icon is displayed next to the sheet set name in the top left corner of the
Sheet Set Manager.

 A green dot in the lock icon indicates that the Sheet Set
Manager session on your computer has temporarily locked the DST file.

 A red dot indicates that the Sheet Set Manager session
on a team member's computer has temporarily locked the DST file.

 A yellow dot in the lock icon means that the sheet is in
a special state; for example, its file properties may be set to Read-Only.

Other members of the team can automatically see changes to the sheet set in
the Sheet Set Manager tree view.

If each member of the team has access to the sheet set DWT files, new drawing
files and their sheets are created using the same drawing template file; page
setups for these drawings are also standardized.

NOTE If two or more users access the same sheet files through different logical
drives on a network, each will in turn be prompted to resave the sheet set using
their own logical drive. To avoid unnecessary saving, users should map the same
logical drives, if possible.

Status data for sheets in the current sheet set is also available to other team
members. This status data is displayed in the tree view and indicates one of
the following conditions:

 The sheet is available for editing.

 The sheet is locked.

 The sheet is missing or found in an unexpected folder location.

The active sheets of other team members are automatically polled for status
changes; the tree view is updated in your session of the Sheet Set Manager.
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The polling cycle skips the poll interval in your session when a command is
active. To force a sheet status update, click Refresh Sheet Status on the Sheet
List tab.

You can click any sheet to display more information in the Details area of the
Sheet Set Manager.

NOTE A false lock icon may be displayed if there is a network problem or if the
program terminates unexpectedly. If you suspect a problem, click the sheet to
display more information.

Work in a Team That Does Not Use Sheet Set Manager

With some limitations, you can use sheet sets in a team with members who
do not have network access, or do not have access to the Sheet Set Manager.
These team members may be using AutoCAD LT or an older version of
AutoCAD. In those circumstances, not all members of the team will have
access to the DST file. However, relevant information from the DST file is
stored (cached) in each drawing file, and sheet set information, such as custom
properties, is preserved when the drawing file is shared by other team members.

After a member of the team changes information in the DST file, the
information in several drawing files might need to be updated. With the sheet
set open, update a sheet by opening and saving the sheet.

You can update all sheets in a sheet set automatically with the Resave All
Sheets option in the sheet set shortcut menu. Drawing files saved in a previous
DWG file format are saved without changing the format.

NOTE In a network environment, make sure that all drawing files used in the
current sheet set that are opened by other users are closed before performing the
Resave All Sheets operation.

To resave all sheets in a sheet set

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Sheet Set Manager, open a sheet set.

3 On the Sheet List tab, right-click the sheet set node. Click Resave All
Sheets.

All sheets in the sheet set are resaved. This updates the sheet set
information that is stored in each drawing file.
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Toolbar: Standard  
Command entry: SHEETSET

Quick Reference

Commands

NEWSHEETSET

Creates a new sheet set data file that manages drawing layouts, file paths,
and project data.

OPENSHEETSET

Opens a selected sheet set.

SHEETSET

Opens the Sheet Set Manager.

SHEETSETHIDE

Closes the Sheet Set Manager.

System Variables

SSFOUND

Displays the sheet set path and file name if a search for a sheet set is
successful.

SSLOCATE

Controls whether the sheet set associated with a drawing is located and
opened when the drawing is opened.

SSMAUTOOPEN

Controls the display behavior of the Sheet Set Manager when a drawing
associated with a sheet is opened.

SSMPOLLTIME

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

SSMSHEETSTATUS

Controls how the status data in a sheet set is refreshed.
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SSMSTATE

Indicates whether the Sheet Set Manager window is open or closed.

Utilities

No entries

Command Modifiers

No entries
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Control the Properties of
Objects

You can organize objects in your drawing and control how they are displayed and plotted by
changing their properties, which include layer, linetype, color, lineweight, and plot style.

Layers are like transparent overlays on which you organize and group different kinds of
drawing information. The objects you create have common properties including colors,
linetypes, and lineweights. An object can assume these properties from the layer it is drawn
on, or properties can be specifically assigned to individual objects. Color helps you distinguish
similar elements in your drawings, while linetypes help you differentiate easily between
different drafting elements. Lineweights represent the size or type of an object through width,
enhancing your drawing and increasing legibility. Organizing layers and the objects on layers
makes it easier to manage the information in your drawings.

Work with Object Properties
You can change the object properties in your drawing by using the Properties
palette or the Quick Properties palette.

Overview of Object Properties
Every object you draw has properties. Some properties are general and apply to
most objects; for example, layer, color, linetype, and plot style. Other properties
are object-specific; for example, the properties of a circle include radius and
area, and the properties of a line include length and angle.

Most general properties can be assigned to an object by layer or can be assigned
to an object directly.

■ When a property is set to the value BYLAYER, the object is assigned the same
value as the layer on which it is drawn.

15

523



For example, if a line drawn on layer 0 is assigned the color BYLAYER, and
layer 0 is assigned the color Red, the line is red.

■ When a property is set to a specific value, that value overrides the value
set for the layer.
For example, if a line drawn on layer 0 is assigned the color Blue, and layer
0 is assigned the color Red, the line is blue.

See also:

■ Control the Color and Linetype Properties in Blocks on page 860

Quick Reference

Commands

PROPERTIES

Controls properties of existing objects.

PROPERTIESCLOSE

Closes the Properties palette.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Display and Change the Properties of Objects
You can display and change the current properties for any object in your
drawing.
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You can display and change the current properties for any object in your
drawing in the following ways:

■ Open the Quick Properties palette to view and change the settings for
selected properties of the object.

■ Open the Properties palette and view and change the settings for all
properties of the object.

■ View and change the settings in the Layer control on the Layers toolbar
and the Color, Linetype, Lineweight, and Plot Style controls on the
Properties toolbar.

■ Use the LIST command to view information in the text window.

■ Use the ID command to display a coordinate location.

Use the Quick Properties Palette

The Quick Properties palette lists the most commonly used properties for each
object type or a set of objects. You can easily customize the quick properties
for any object in the Customize User Interface (CUI) editor. See Quick
Properties in the Customization Guide.

■ When one or more objects of the same type are selected, the Quick
Properties palette displays the selected properties of that object type.

■ When two or more objects of different types are selected, the Quick
Properties palette displays the common properties, if any for all objects in
the selection set.

You can select any object to display the Quick Properties palette when the
QPMODE system variable is set to 1. When the QPMODE system variable is
set to 2, the Quick Properties palette displays only if the selected object is
defined in the Customize User Interface (CUI) editor to display properties.
You can use the QPLOCATION system variable to display the Quick Properties
palette by using cursor or float mode. You can also control the display settings
of the Quick Properties palette using the Drafting Settings Dialog Box.
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Use the Properties Palette

The Properties palette lists the current settings for properties of the selected
object or set of objects. You can modify any property that can be changed by
specifying a new value.

■ When more than one object is selected, the Properties palette displays only
those properties common to all objects in the selection set.

■ When no objects are selected, the Properties palette displays only the
general properties of the current layer, the name of the plot style table
attached to the layer, the view properties, and information about the UCS.

You can double-click most objects to open the Properties palette when the
DBLCLKEDIT system variable is set to On (the default). The exceptions include
blocks and attributes, hatches, gradient fills, text, multilines, and xrefs. If you
double-click any of these objects, an object-specific dialog box is displayed
instead of the Properties palette.

NOTE The DBLCLKEDIT system variable must be set to On and the PICKFIRST
system variable must be set to 1(the default) for double-clicking to work.

Change Object Property or ByBlock Settings to ByLayer

Using the SETBYLAYER command, you can change specified properties to
ByLayer for selected objects. Objects that have a ByBlock setting can also be
changed to ByLayer. When an object’s properties are not set to ByLayer, those
objects do not display the layer property overrides that were set by viewport.

In the SetByLayer Settings dialog box, you can specify which object property
settings are changed to ByLayer.

The SETBYLAYERMODE system variable stores the property settings that are
to be changed when the SETBYLAYER command is used.

See also:

■ Control the Color and Linetype Properties in Blocks on page 860

■ Filter Selection Sets on page 1066

■ Set Interface Options on page 111

■ Quick Properties in the Customization Guide
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To turn on and turn off the Quick Properties palette

■ On the status bar, click Quick Properties. 
If you want to dismiss the Quick Properties palette temporarily, press ESC.

To disable the Quick Properties palette

1 In the Quick Properties palette, click the Options button.

2 Click Disable.

NOTE When you select the Disable option, the value of QPMODE system variable
is changed to a negative number and the feature is turned off.

To change the settings of a Quick Properties palette

1 Click Tools menu  ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Quick Properties tab, select Quick
Properties On.

3 Select the location mode for the Quick Properties palette.

4 Under Size Settings, select or clear the Auto-Collapse option to expand
or collapse the Quick Properties palette. If this option is selected, enter
the height value in the text box.

5 Click OK.

Command entry: DSETTINGS

To set the Quick Properties palette to always display at its full height

1 In the Quick Properties palette, click the Options button.

2 Clear the Auto-Collapse option.

To display the properties of a single object

1 Select the object.

2 Click View tab  ➤  Palettes panel  ➤  Properties.

The Properties palette displays the properties of the selected object.

3 Alternatively, you can right-click in the drawing and then, click Properties.
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NOTE You can also double-click almost any object to display the Properties
palette.

Toolbar: Standard  
Command entry: PROPERTIES

To list database information for several objects

1 Click Home tab ➤ Properties panel ➤ List. 

2 Select one or more objects and press ENTER.

The text window displays a report.

Toolbar: Inquiry  
Command entry: LIST

To display the coordinate values of a point

1 Click Tools tab ➤ Inquiry panel ➤ ID Point. 

2 Specify the point whose coordinate values you want to identify.

The X, Y, and Z values are displayed at the Command prompt.

Toolbar: Inquiry  
Command entry: ID

To change properties of objects in the Properties palette

1 Select one or more objects.

2 Click View tab  ➤  Palettes panel  ➤  Properties.

The Properties palette displays the properties of the selected object.
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3 In the Properties palette, use the scroll bar next to the title bar to scroll
through the list of properties. You can click the arrow at the right of each
category to expand or collapse the list.

4 Select the value you want to change; use one of the following methods
to change the value:

■ Enter a new value.

■ Click the down arrow at the right and select a value from the list.

■ Click the Pick Point button to use the pointing device to change a
coordinate value.

■ Click the QuickCalc calculator button to calculate a new value.

■ Click the left or right arrow to increase or decrease the value.

■ Click the [...] button and change the property value in a dialog box.

Changes are applied immediately.

5 To undo a change, right-click an empty area in the Properties palette.
Click Undo.

6 Press ESC to remove the selection.

Toolbar: Standard  
Command entry: PROPERTIES

To change an object’s property setting to ByLayer

1 Click Home tab ➤ Modify panel ➤ Set to ByLayer. 

2 Enter S to specify which properties to change to ByLayer or select objects
using a standard selection method and press ENTER.

Command entry: SETBYLAYER

To change an object’s ByBlock setting to ByLayer

1 Click Home tab ➤ Modify panel ➤ Set to ByLayer . 
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2 Select objects using a standard selection method and press ENTER.

3 When prompted, enter Y to change ByBlock to Bylayer.

4 When prompted, specify whether blocks are included.

Command entry: SETBYLAYER

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

DSETTINGS

Sets grid and snap, polar and object snap tracking, object snap modes,
Dynamic Input, and Quick Properties.

ID

Displays the UCS coordinate values of a specified location.

LIST

Displays property data for selected objects.

PROPERTIES

Controls properties of existing objects.

PROPERTIESCLOSE

Closes the Properties palette.

SETBYLAYER

Changes the property overrides of selected objects to ByLayer.

System Variables

DBLCLKEDIT

Controls the double click editing behavior in the drawing area.

LUPREC

Sets the display precision for linear units and coordinates.
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OPMSTATE

Indicates whether the Properties palette is open, closed, or hidden.

PALETTEOPAQUE

Controls whether palettes can be made transparent.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

QPLOCATION

Sets the location mode of Quick Properties palette.

QPMODE

Sets the on or off state of Quick Properties palette.

SETBYLAYERMODE

Controls which properties are selected for the SETBYLAYER command.

Utilities

No entries

Command Modifiers

No entries

Copy Properties Between Objects
You can copy some or all properties of one object to other objects using Match
Properties.

The types of properties that can be copied include, but are not limited to,
color, layer, linetype, linetype scale, lineweight, plot style, viewport property
overrides, and 3D thickness.

By default, all applicable properties are automatically copied from the first
object you selected to the other objects. If you don't want a specific property
or properties to be copied, use the Settings option to suppress the copying of
that property. You can choose the Settings option at any time during the
command.
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To copy properties from one object to other objects

1 Click Home tab ➤ Properties panel ➤ Match Properties. 

2 Select the object whose properties you want to copy.

3 If you want to control which properties are transferred, enter s (Settings).
In the Property Settings dialog box, clear the items that you do not want
copied (all are on by default). Click OK.

4 Select the objects to which you want to apply the selected properties and
press ENTER.

Toolbar: Standard  
Command entry: MATCHPROP

Quick Reference

Commands

MATCHPROP

Applies the properties of a selected object to other objects.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Work with Layers
Layers are like transparent overlays on which you organize and group objects
in a drawing.

Overview of Layers
Layers are used to group information in a drawing by function and to enforce
linetype, color, and other standards.

Layers are the equivalent of the overlays used in paper-based drafting. Layers
are the primary organizational tool used in drawing. You use layers to group
information by function and to enforce linetype, color, and other standards.

By creating layers, you can associate similar types of objects by assigning them
to the same layer. For example, you can put construction lines, text,
dimensions, and title blocks on separate layers. You can then control the
following:

■ Whether objects on a layer are visible or dimmed in any viewports

■ Whether and how objects are plotted

■ What color is assigned to all objects on a layer
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■ What default linetype and lineweight are assigned to all objects on a layer

■ Whether objects on a layer can be modified

■ Whether objects display with different layer properties in individual layout
viewports

Every drawing includes a layer named 0. Layer 0 cannot be deleted or renamed.
It has two purposes:

■ Ensure that every drawing includes at least one layer

■ Provide a special layer that relates to controlling colors in blocks

NOTE It is recommended that you create several new layers with which to organize
your drawing rather than create your entire drawing on layer 0.

Quick Reference

Commands

CLASSICLAYER

Opens the modal Layer Properties Manager.

LAYER

Manages layers and layer properties.

LAYERPALETTE

Opens the modeless Layer Properties Manager.

System Variables

LAYERDLGMODE

Sets the flavor of the Layer Properties Manager that is defined for the use of
the LAYER command.

SHOWLAYERUSAGE

Displays icons in the Layer Properties Manager to indicate whether layers
are in use.
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Utilities

No entries

Command Modifiers

No entries

Use Layers to Manage Complexity
You can use layers to control the visibility of objects and to assign properties
to objects. Layers can be locked to prevent objects from being modified.

You can reduce the visual complexity of a drawing and improve display
performance by controlling how objects are displayed or plotted. For example,
you can use layers to control the properties and visibility of similar objects,
such as electrical parts or dimensions. Also, you can lock a layer to prevent
objects on that layer from being accidentally selected and modified.

Control the Visibility of Objects on a Layer

You can make drawing layers invisible either by turning them off or by freezing
them. Turning off or freezing layers is useful if you need an unobstructed view
when working in detail on a particular layer or set of layers or if you don't
want to plot details such as reference lines. Whether you choose to freeze
layers or turn them off depends on how you work and on the size of your
drawing.

■ On/Off. Objects on turned-off layers are invisible, but they still hide objects
when you use HIDE. When you turn layers on and off, the drawing is not
regenerated.

■ Freeze/Thaw. Objects on frozen layers are invisible and do not hide other
objects. In large drawings, freezing unneeded layers speeds up operations
involving display and regeneration. Thawing one or more layers may cause
the drawing to be regenerated. Freezing and thawing layers takes more
time than turning layers on and off.

In a layout, you can freeze layers in individual layout viewports.

NOTE Instead of turning off or freezing a layer, you can fade the layer by locking
it. See “Lock the Objects on a Layer” below.
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Assign a Default Color and Linetype to a Layer

Each layer has associated properties such as color and linetype that are assumed
by all objects on that layer when the setting is ByLayer. For example, if the
Color control on the Properties toolbar is set to BYLAYER, the color of new
objects is determined by the color setting for the layer in the Layer Properties
Manager.

If you set a specific color in the Color control, that color is used for all new
objects, overriding the default color for the current layer. The same is true for
the Linetype, Lineweight, and Plot Style controls on the Properties toolbar.

The BYBLOCK setting should be used only for creating blocks. See Control
the Color and Linetype Properties in Blocks on page 860.

Override Layer Properties in a Layout Viewport

Some layer properties can be changed using overrides on a viewport basis in
layouts. Using layer property overrides is an efficient way to display objects
with different property settings for color, linetype, lineweight, and plot style.
Layer property overrides are applied to the current layout viewport.

For example, if you want objects on the Electrical layer to display prominently
in one of two layout viewports, you set a Color override on the Electrical layer
for each of the two viewports. By setting the color red for one viewport and
gray for the other, you easily accomplish this objective without changing the
global color property assigned to the layer. See Override Layer Properties in
Viewports on page 559 for more information.

Lock the Objects on a Layer

When a layer is locked, none of the objects on that layer can be modified until
you unlock the layer. Locking layers reduces the possibility of modifying
objects accidentally. You can still apply object snaps to objects on a locked
layer and perform other operations that do not modify those objects.

You can fade the objects on locked layers to make them appear more faint
than other objects. This serves two purposes:

■ You can easily see what objects are on locked layers.

■ You can reduce the visual complexity of a drawing but still maintain visual
reference and object snapping capabilities to those objects.

The LAYLOCKFADECTL system variable controls the fading applied to locked
layers. Locked layers that are faded are plotted normally.
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NOTE Grips are not displayed on objects that are on locked layers.

To make a selected layer the current layer

1 Click Home tab ➤ Layers panel ➤ Make Object’s Layer Current. 

2 Select an object on the layer you want to make current.

Toolbar: Layers  
Command entry: LAYMCUR

To copy an object to another layer

1 Click Home tab ➤ Layers panel ➤ Copy Objects to New Layer. 

2 Select the objects you want to copy.

3 Press ENTER.

4 Select an object on the layer where you want the copied object to be
placed.

5 Do one of the following:

■ Specify a base point, and then specify a second point for the location
of the object on the destination layer.

■ Enter the displacement in the form of a Cartesian, polar, cylindrical,
or spherical coordinate value. At the prompt for the second point of
displacement, press ENTER.

Toolbar: Layers II  
Command entry: COPYTOLAYER

To dynamically display layers

1 Click Home tab ➤ Layers panel ➤ Layer Walk. 
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2 In the LayerWalk dialog box, click a layer to view the objects on that
layer. To select more than one layer, press CTRL and click the layers you
want to view.

The drawing displays the objects on the layers you selected.

3 Click Close.

Toolbar: Layers II  
Command entry: LAYWALK

To filter a layer list

1 Click Home tab ➤ Layers panel ➤ Layer Walk. 

2 In the LayerWalk dialog box, Filter list, do one of the following:

■ Enter an existing filter name or select a filter from the Filter drop-down
list.

■ Enter filter criteria (using wild-card characters) to create a list of the
layers you want filtered. For example, if want to filter layers named
“0” through “3”, you could enter a filter criteria of [0-3]*.

NOTE For more information about wild-card characters, see the
“Wild-Card Characters” section of Filter and Sort the List of Layers on
page 567.

The layer list displays layers defined in the filter.

3 Click Close.

Toolbar: Layers II  
Command entry: LAYWALK

To create and save a layer filter in the LayerWalk dialog box

1 Click Home tab ➤ Layers panel ➤ Layer Walk. 
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2 In the LayerWalk dialog box, Filter list, enter filter criteria (using wild-card
characters) to create a list of the layers you want filtered. For example, if
want to filter layers “0” through “3”, enter a filter criteria of [0-3]*.

NOTE For more information about wild-card characters, see the “Wild-Card
Characters” section of Filter and Sort the List of Layers on page 567.

3 Right-click, and then click Save Current Filter.

4 Click Close.

Toolbar: Layers II  
Command entry: LAYWALK

To turn on or off an active layer filter

1 Click Home tab ➤ Layers panel ➤ Layer Walk. 

2 In the LayerWalk dialog box, Filter list, enter an existing filter name or
select a filter from the Filter drop-down list.

3 Click the Filter check box to display or hide the layers in the layer list
that are defined in the active filter. The display of the layers in the drawing
itself does not change.

4 Click Close.

Toolbar: Layers II  
Command entry: LAYWALK

To turn the Always Show option on or off in the LayerWalk dialog box

1 Click Home tab ➤ Layers panel ➤ Layer Walk. 

2 In the LayerWalk dialog box, Layer list, double-click the layer you want
to set to Always Show. To select more than one layer, press SHIFT and
double-click the additional layers.
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An asterisk (*) is displayed to the left of each layer that you set to Always
Show. These layers are displayed in the drawing regardless of whether or
not they are in an active filter.

3 Click Close.

Toolbar: Layers II  
Command entry: LAYWALK

To purge unreferenced layers using the LayerWalk dialog box

1 Open a drawing that contains one or more unreferenced layers that you
want to purge.

2 Click Home tab ➤ Layers panel ➤ Layer Walk. 

3 In the LayerWalk dialog box, right-click. Click Select Unreferenced.

All unreferenced layers are selected.

NOTE The Purge button is active only when the layers you select are
unreferenced.

4 Click Purge.

5 Click Close.

NOTE You can also purge layers in the Layer Properties Manager. See To Remove
an Unused Layer. on page 552

Command entry: LAYWALK

Toolbar: Layers II  

To move an object to the current layer

1 Click Home tab ➤ Layers panel ➤ Change to Current Layer. 

2 Select the objects you want to move to the current layer.
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3 Press ENTER.

Toolbar: Layers II  
Command entry: LAYCUR

To delete a layer by selecting an object on that layer

1 Click Home tab ➤ Layers panel ➤ Delete. 

2 Select an object on the layer you want to delete.

3 Press ENTER.

All objects on the selected layer and the layer itself are deleted.

Command entry: LAYDEL

To freeze a layer by selecting an object on that layer

1 Click Home tab ➤ Layers panel ➤ Freeze. 

2 Select an object on the layer you want to freeze,.

3 Press ENTER.

The selected layer is frozen.

Toolbar: Layers II  
Command entry: LAYFRZ

To thaw all layers

■ Click Home tab ➤ Layers panel ➤ Thaw All Layers. 
All layers (except layers that are frozen in a viewport) are thawed.

Command entry: LAYTHW
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To display selected layers while turning off all other layers

1 Click Home tab ➤ Layers panel ➤ Isolate. 

2 Select an object on the layer you want to isolate.

3 Press ENTER.

The selected layer is isolated.

NOTE To restore layers to the layer state before you isolated them, use the
LAYUNISO command. Any layer settings you changed are preserved.

Toolbar: Layers II  
Command entry: LAYISO

To restore layer settings when exiting the LayerWalk dialog box

1 Click Home tab ➤ Layers panel ➤ Walk. 

2 In the LayerWalk dialog box, click a layer to view the objects on that
layer. To select more than one layer, click a layer in the list and drag the
cursor over the layers you want to view.

3 Do one of the following:

■ To return to the original view when you close the dialog box, make
sure the Restore on Exit check box is selected.

■ To return to the drawing with only the selected layers, make sure the
Restore on Exit check box is blank.

4 Click Close.

Toolbar: Layers II  
Command entry: LAYWALK
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To restore a drawing’s layer states after isolating a layer

■ After isolating a layer, and (optionally) making other layer changes, click

Home tab ➤ Layers panel ➤ Unisolate. 
The drawing is restored to the layer state before the layers were isolated.

Toolbar: Layers II  
Command entry: LAYUNISO

To isolate an object’s layer to the current viewport

1 Click a layout tab.

2 Click Home tab ➤ Layers panel ➤ Isolate to Current Viewport. 

3 Select the object whose layer you want to isolate. Press ENTER.

The selected layer is frozen in all viewports except the current viewport.

Command entry: LAYVPI

To turn a layer on and off by using the Layers toolbar

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties

2 In the Layer Properties Manager, click the light bulb for the layer name
that you want to turn on or off.

If the light bulb is yellow, the layer is turned on.

Toolbar: Layers  
Command entry: LAYER

To turn all layers on

■ Click Home tab ➤ Layers panel ➤ Turn All Layers On. 
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All layers in the drawing are turned on.

Command entry: LAYON

To turn a layer off by selecting an object on the layer

1 Click Home tab ➤ Layers panel ➤ Off. 

2 Select the object whose layer you want to turn off. Press ENTER.

Toolbar: Layers II  
Command entry: LAYOFF

To copy properties from one layer to other layers

1 Click  Home tab  ➤  Layers panel  ➤  Match. 

2 Select the object whose layer you want to change. Press ENTER.

3 Select an object on the layer where you want the object to move.

The object is moved to the selected layer.

Toolbar: Layers II  
Command entry: LAYMCH

To merge selected layers onto a destination layer

1 Click Home tab ➤ Layers panel ➤ Merge. 

2 Select any object on the layer you want to delete. Press ENTER.

3 Select any object on the layer where you want all the objects from the
first layer to be merged.

The objects from the first layer are moved to the selected layer, and the
first layer is deleted.
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Command entry: LAYMRG

To assign a color to a layer

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties

2 In the Layer Properties Manager, select a layer. Click the color icon.

3 In the Select Color dialog box, select a color.

4 Click Apply to save your changes, or click OK to save and close.

Toolbar: Layers  
Command entry: LAYER

To change the properties of more than one layer

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties

2 In the Layer Properties Manager list view, use one of the following
methods to select the layers:

■ Hold down CTRL and select layer names.

■ Right-click. Click Show Filters in Layer List to display a check mark,
and then select a layer filter.

3 Click the icons for the properties you want to change.

4 Click Apply to save your changes, or click OK to save and close.

Toolbar: Layers  
Command entry: LAYER

To hide the tree view in the Layer Properties Manager

■ Click Home tab  ➤  Layers panel  ➤  Layer Properties
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■ In the Layers Properties Manager, right-click in the list view. Clear the
Show Filter Tree option.

To move a column in the Layer Properties Manager

■ Click Home tab  ➤  Layers panel  ➤  Layer Properties

■ In the Layer Properties Manager, click on any column name and drag it
to a new location.

■ Right-click on any column name and click Customize. In the Customize
Layer Columns dialog, highlight the columns to move and click Move Up
to move the columns to the left in the Layer Properties Manager. Click
Move Down to move the columns to the right in the Layer Properties
Manager.

NOTE Column settings are specific to the drawing space in which they were set.
For example, column settings applied in model space are not applied to the Layer
Properties Manager when opened from paper space.

Toolbar: Layers  
Command entry: LAYER

To hide a column in the Layer Properties Manager

■ Click Home tab  ➤  Layers panel  ➤  Layers Properties

■ In the Layer Properties Manager, right-click on any column name and
select the column that is checked from the shortcut menu.

■ Right-click on any column name and click Customize. In the Customize
Layer Columns dialog, uncheck the columns to hide.

Columns names that are unchecked in the shortcut menu are hidden. To show
the column, right-click any column name and select the column name from
the shortcut menu. The Name column cannot be hidden.
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NOTE Column settings are specific to the drawing space in which they were set.
For example, column settings applied in model space are not applied to the Layer
Properties Manager when opened from paper space.

Toolbar: Layers  
Command entry: LAYER

To reorder columns in the Layer Properties Manager

■ Click Home tab  ➤  Layers panel  ➤  Layer Properties

■ In the Layer Properties Manager, click on the column name and drag and
release to the desired location.

■ Right-click on any column name and click Customize. In the Customize
Layer Columns dialog, check the column or columns to move and click
Move Up or Move Down.

Toolbar: Layers  
Command entry: LAYER

To reset all columns to their default settings in the Layer Properties Manager

■ Click Home tab  ➤  Layers panel  ➤  Layer Properties

■ In the Layer Properties Manager, right-click on any column name and
select Restore all Columns to Defaults from the shortcut menu.

All columns are reset to their original position, column width, and display
status.

NOTE Column settings are specific to the drawing space in which they were set.
For example, column settings applied in model space are not applied to the Layer
Properties Manager when opened from paper space.

Toolbar: Layers  
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Command entry: LAYER

To lock or unlock a layer by using the Layers toolbar

1 Click Home tab  ➤  Layers panel  ➤  Layers Properties

2 In the Layer Properties Manager, click the padlock icon for the layer name
that you want to lock or unlock.

If the padlock is open, the layer is unlocked.

3 (Optional) Specify the degree of fading for all locked layers with the
LAYLOCKFADECTL system variable.

Toolbar: Layers  
Command entry: LAYER, LAYLOCKFADECTL

Quick Reference

Commands

CLASSICLAYER

Opens the modal Layer Properties Manager.

COPYTOLAYER

Copies one or more objects to another layer.

LAYCUR

Changes the layer property of selected objects to the current layer.

LAYDEL

Deletes all objects on a layer and purges the layer.

LAYER

Manages layers and layer properties.

LAYERPALETTE

Opens the modeless Layer Properties Manager.
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LAYFRZ

Freezes the layer of selected objects.

LAYISO

Hides or locks all layers except those of the selected objects.

LAYMCH

Changes the layer of a selected object to match the destination layer.

LAYMCUR

Sets the current layer to that of a selected object.

LAYMRG

Merges selected layers into a target layer, removing the previous layers from
the drawing.

LAYOFF

Turns off the layer of a selected object.

LAYON

Turns on all layers in the drawing.

LAYTHW

Thaws all layers in the drawing.

LAYUNISO

Restores all layers that were hidden or locked with the LAYISO command.

LAYWALK

Displays objects on selected layers and hides objects on all other layers.

System Variables

LAYERDLGMODE

Sets the flavor of the Layer Properties Manager that is defined for the use of
the LAYER command.

LAYLOCKFADECTL

Controls the amount of fading for objects on locked layers.
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No entries

Utilities

No entries

Command Modifiers

No entries

Create and Name Layers
You can create and name a new layer for each conceptual grouping (such as
walls or dimensions) and assign common properties to each layer.

By organizing objects into layers, you can control the visibility and object
properties of a large number of objects separately for each layer and make
changes quickly.

NOTE The number of layers that you can create in a drawing and the number of
objects that you can create on each layer are practically unlimited.

Choose Layer Names Carefully

A layer name can include up to 255 characters (double-byte or alphanumeric):
letters, numbers, spaces, and several special characters. Layer names cannot
include the following characters:

< > / \ “ : ; ? * | = ‘

In many cases, the layer names you choose are dictated by corporate, industry,
or client standards.

The Layer Properties Manager sorts layers alphabetically by name. If you
organize your own layer scheme, choose layer names carefully. Use common
prefixes to name layers with related drawing components, you can use
wild-card characters in layer name filters when you need to find those layers
quickly.

NOTE If you consistently use a specific layering scheme, you can set up a drawing
template with layers, linetypes, and colors already assigned. For more information
about creating templates, see Use a Template File to Start a Drawing on page 175.
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Copy Layers from Another Drawing

You can use DesignCenter™ to copy layers from any drawing to another by
dragging. For example, you might have a drawing that contains all the standard
layers needed for a project. You can create a new drawing and use DesignCenter
to drag the predefined layers to the new drawing, which saves you time and
ensures consistency between drawings.

You can also drag layers or copy layers by double-clicking or by clicking Insert
on the shortcut menu.

NOTE You need to resolve duplicate layer names before you drag layers from
DesignCenter.

Select a Layer to Draw On

As you draw, newly created objects are placed on the current layer. The current
layer may be the default layer (0) or a layer you create and name yourself. You
switch from one layer to another by making a different layer current; any
subsequent objects you create are associated with the new current layer and
use its color, linetype, and other properties. You cannot make a layer the
current layer if it is frozen or if it is an xref-dependent layer.

Remove Layers

You can remove unused layers from your drawing with PURGE or by deleting
the layer from the Layer Properties Manager. You can delete only unreferenced
layers. Referenced layers include layers 0 and DEFPOINTS, layers containing
objects (including objects in block definitions), the current layer, and
xref-dependent layers.

WARNING Be careful about deleting layers if you are working on a drawing in a
shared project or one based on a set of layering standards.

To create a new layer

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties.

2 In the Layer Properties Manager, click the New Layer button.

A layer name, such as LAYER1, is automatically added to the layer list.

3 Enter a new layer name by typing over the highlighted layer name.

4 To change the properties, click icons.
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When you click Color, Linetype, Lineweight, or Plot Style, a dialog box
is displayed.

5 (Optional) Click in the Description column and enter text.

6 Click Apply to save your changes, or click OK to save and close.

Toolbar: Layer Properties  
Command entry: LAYER

To remove an unused layer

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties.

2 In the Layer Properties Manager, select the layer. Click the Delete Layer
button.

Layers that have objects assigned to them cannot be removed until those
objects are reassigned to a different layer or are deleted. Layers 0 and
DEFPOINTS and the current layer cannot be removed.

3 Click Apply to save your changes, or click OK to save and close.

The selected layer is removed.

Toolbar: Layers  
Command entry: LAYER

To purge all unused layers

1 Click Tools tab ➤ Drawing Utilities panel ➤ Purge. 

The Purge dialog box displays a tree view of object types with items that
can be purged (removed from the drawing).

2 To purge unreferenced layers, use one of the following methods:

■ To purge all unreferenced layers, select Layers.

■ To purge specific layers, double-click Layers to expand the tree view.
Select the layers to be purged.
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3 If the item you want to purge is not listed, select View Items You Cannot
Purge, select the layer, and read the explanation.

4 You are prompted to confirm each item in the list. If you do not want to
confirm each purge, clear the Confirm Each Item to Be Purged option.

5 Click Purge.

6 To confirm the purging of each item, respond to the prompt by choosing
Yes or No, or Yes to All if more than one item is selected.

7 Click Close.

Command entry: PURGE

Quick Reference

Commands

CLASSICLAYER

Opens the modal Layer Properties Manager.

LAYER

Manages layers and layer properties.

LAYERPALETTE

Opens the modeless Layer Properties Manager.

PURGE

Removes unused items, such as block definitions and layers, from the drawing.

System Variables

CLAYER

Sets the current layer.

LAYERDLGMODE

Sets the flavor of the Layer Properties Manager that is defined for the use of
the LAYER command.
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Utilities

No entries

Command Modifiers

No entries

Change Layer Settings and Layer Properties
You can change the name of a layer and any of its properties, including color
and linetype, and you can reassign objects from one layer to another.

Because everything in your drawing is associated with a layer, it's likely that
in the course of planning and creating a drawing, you'll need to change what
you place on a layer or how you view the layers in combination. You can

■ Reassign objects from one layer to another.

■ Change the name of a layer.

■ Change the default color, linetype, or other properties of the layer.

Reassigning an object to a different layer is useful if you create an object on
the wrong layer or decide to change your layer organization. Unless the color,
linetype, or other properties of the object have been set explicitly, an object
that you reassign to a different layer will acquire the properties of that layer.

You can change layer properties in the Layer Properties Manager and in the
Layer control on the Layers toolbar. Click the icons to change settings. Layer
names and colors can be changed only in the Layer Properties Manager, not
the Layer control.

Undo Changes to Layer Settings

You can use Layer Previous to undo changes you make to layer settings. For
example, if you freeze several layers and change some of the geometry in a
drawing, and then want to thaw the frozen layers, you can do this with a
single command without affecting the geometry changes. In another example,
if you changed the color and linetype of several layers but later decide you
prefer the old properties, you can use Layer Previous to undo the changes and
restore the original layer settings.

When you use Layer Previous, it undoes the most recent change or set of
changes made using either the Layer control or the Layer Properties Manager.
Every change you make to layer settings is tracked and can be undone with
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Layer Previous. You can use LAYERPMODE to suspend layer property tracking
when you don't need it, such as when you run large scripts. There is a modest
performance gain in turning off Layer Previous tracking.

Layer Previous does not undo the following changes:

■ Renamed layers. If you rename a layer and change its properties, Layer
Previous restores the original properties but not the original layer name.

■ Deleted layers. If you delete or purge a layer, using Layer Previous does
not restore it.

■ Added layers. If you add a new layer to a drawing, using Layer Previous
does not remove it.

Changes in the Layer Properties Manager can be grouped by enabling Combine
Layer Property Change option in User Preferences tab in the Options dialog
box.. Layer creation and deletion will be tracked in the Undo list as unique
items.

To change the layer of one or more objects

1 Select the objects whose layer you want to change.

2 Click Home tab  ➤  Layers panel  ➤  Layer Properties

3 In the Layer Properties Manager, select the layer that you want to assign
to the objects.

4 Press ESC to remove selection.

Toolbar: Layers  

To change the default linetype assigned to a layer

1 Click Home tab  ➤  Layers Panel  ➤  Layer Properties  .

2 In the Layer Properties Manager, select the linetype for the layer you want
to change.
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3 In the Select Linetype dialog box, if the linetype you need is not displayed,
click Load and use one of the following methods:

■ In the Load or Reload Linetypes dialog box, select one or more
linetypes to load. Click OK to return to the Select Linetype dialog box.

■ In the Load or Reload Linetypes dialog box, click File to open
additional linetype definition (LIN) files. Select one or more linetypes
to load. Click OK to return to the Select Linetype dialog box.

4 Select the linetype you want to use. Click OK to return to the Layer
Properties Manager.

5 Click Apply to save your changes, or click OK to save and close.

Toolbar: Layers  
Command entry: LAYER

To rename a layer

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties

2 In the Layer Properties Manager, select a layer. Click the name or press
F2.

3 Enter a new name.

4 Click Apply to save your changes, or click OK to save and close.

Toolbar: Layers  
Command entry: LAYER

To rename more than one layer

1 Click Tools tab ➤ Drawing Utilities panel ➤ Rename. 

2 In the Rename dialog box, in the Named Objects list, select Layers.

3 In Old Name, enter the old name, using wild-card characters; for example,
enter stairs$*.
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4 In Rename To, enter the new name using wild-card characters; for
example, enter s_*.

Results for this example are as follows: the layers STAIR$LEVEL-1,
STAIR$LEVEL-2, STAIR$LEVEL-3 are renamed S_LEVEL-1, S_LEVEL-2,
S_LEVEL-3.

5 Click Rename To to apply changes and continue, or click OK.

Command entry: RENAME

To undo changes to layer settings

■ Click Home tab ➤ Layers panel ➤ Previous. 

The Command prompt displays the message “Restored previous layer status.”

NOTE LAYERP does not restore deleted or purged layers and does not remove a
layer that was added. If you rename a layer and change its properties, Layer
Previous restores the original properties but not the original layer name.

Toolbar: Layers  
Command entry: LAYERP

To set Layer Previous tracking on or off

1 At the Command prompt, enter layerpmode.

The current Layer Previous tracking status is displayed.

2 Enter on to turn on Layer Previous tracking of layer settings, or enter off
to turn off tracking.

Command entry: LAYERPMODE

Quick Reference

Commands

CHANGE

Changes the properties of existing objects.
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CHPROP

Changes the properties of an object.

CLASSICLAYER

Opens the modal Layer Properties Manager.

LAYER

Manages layers and layer properties.

LAYERP

Undoes the last change or set of changes made to layer settings.

LAYERPALETTE

Opens the modeless Layer Properties Manager.

LAYERPMODE

Turns the tracking of changes made to layer settings on and off.

PROPERTIES

Controls properties of existing objects.

PURGE

Removes unused items, such as block definitions and layers, from the drawing.

RENAME

Changes the names assigned to items such as layers and dimension styles.

SETBYLAYER

Changes the property overrides of selected objects to ByLayer.

System Variables

CLAYER

Sets the current layer.

LAYERDLGMODE

Sets the flavor of the Layer Properties Manager that is defined for the use of
the LAYER command.

LAYERMANAGERSTATE

Indicates whether the Layer Properties Manager is open or closed.
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SETBYLAYERMODE

Controls which properties are selected for the SETBYLAYER command.

Utilities

No entries

Command Modifiers

No entries

Override Layer Properties in Viewports
You can display objects differently by setting property overrides for color,
linetype, lineweight, and plot style and apply them to individual layout
viewports.

Using property overrides is an efficient way for displaying objects with different
property settings in individual viewports without changing their ByLayer or
ByBlock properties. For example, objects can be made to display more
prominently by changing their color. Because layer property overrides do not
change the layer’s global properties, you can have objects display differently
in various viewports without having to create duplicate geometry or use xrefs
that have different layer settings.

Property override settings for color and lineweight were set on the Wiring layer
for the viewport on the left. Notice the wiring is a different color and lineweight
than in the right viewport.
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When the Layer Properties Manager is accessed from a layout tab, four columns
for layer property overrides are displayed

■ VP Color

■ VP Lineweight

■ VP Linetype

■ VP Plot Style (available only in named-plot style drawings)

When a property override is set for a layer, a Viewport Overrides filter is
automatically created in the Layer Properties Manager.

If you do not want to display or plot property overrides, set the
VPLAYEROVERRIDESMODE system variable to 0. Objects will display and plot
with their global layer properties.

NOTE Property overrides can still be set even when VPLAYEROVERRIDESMODE is
set to 0.

Property overrides that are on xref layers are not retained when the VISRETAIN
system variable is set to 0.

Viewport Property Overrides and Visual Styles

Layer property overrides for color, linetype, and lineweights are displayed in
viewports regardless of the visual style that is current. Although plot style
overrides can be set when the visual style is set to Conceptual or Realistic style,
they are not displayed or plotted.

Identify Layers with Property Overrides

Layers containing property overrides are identifiable in the Layer Properties
Manager when accessed from a layout tab. You can see which layers have
overrides by the following:

■ A background color displays for each layer name, override and
corresponding global property setting.
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■ A tooltip displays property override information when the cursor is placed
over the status icon for the layer containing overrides.

■ A different icon displays in the Status column.

■ A predefined filter named Viewport Overrides is displayed in the tree view
where all layers with viewport overrides are listed.

Layers that are assigned property overrides are also identifiable outside of the
Layer Properties Manager. Other areas of the user interface that indicate which
layers are assigned property overrides are as follows:

■ Layers toolbar. A background color displays behind layer names for the
current viewport. For color overrides, the override color is displayed instead
of the global color.

■ Properties toolbar. Displays ByLayer (VP) and a background color for layers
or objects that are assigned property overrides. Override properties are
displayed for color, linetype, and lineweight instead of global properties.

■ Layers panel on the ribbon. A background color displays behind the layer
names in the Layer drop-down list. Override properties are displayed for
color, linetype, and lineweight instead of global properties.

■ Properties panel on the ribbon. A background color displays behind the
color, linetype, lineweight, and plot style controls. Override properties are
displayed for color, linetype, and lineweight instead of global properties.

■ Properties palette. Displays ByLayer (VP) and a background color for layers
or objects that are assigned property overrides. Override properties are
displayed for color, linetype, and lineweight instead of global properties.

NOTE The background color for viewport overrides can be changed in the Layer
Settings dialog box.
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Property overrides that are set on the Lighting layer for the current viewport are
indicated by a blue background color.

Identify Viewports with Layer Property Overrides

Use the VPLAYEROVERRIDES system variable to check if the current viewport
contains layer property overrides. When VPLAYEROVERRIDES is equal to 1,
the viewport contains overrides.

You can also use the Properties palette to determine if a viewport contains
overrides. The Properties palette displays a Layer Property Overrides field. The
value that displays is the same as the setting for VPLAYEROVERRIDES.

Remove Layer Property Overrides

When you right-click a layer in the Layer Properties Manager, a shortcut menu
is displayed that lists options for removing property overrides. You can remove

■ A single property override from the selected layer for the selected viewport
or for all selected viewports

■ All property overrides from the selected layer for the selected viewport or
for all selected viewports

■ All property overrides from all layers in the selected viewport or for all
selected viewports

NOTE Another method for removing property overrides is to use the shortcut
menu when you right-click the border of the selected viewport or viewports. You
can remove viewport overrides for all layers for that viewport.
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To assign property overrides for the current layout viewport

1 On the layout tab, double-click inside a viewport to make it current.

2 Click Home tab  ➤  Layers panel  ➤  Layer Properties

3 In the Layer Properties Manager, select the global properties to override
in the VP Color, VP Linetype, VP Lineweight, and VP Plot Style columns.

Toolbar: Layers  
Command entry: LAYER

To remove an override from a layer for the current layout viewport

1 On the layout tab, double-click inside a viewport to make it current.

2 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

3 In the Layer Properties Manager, right-click the property override on the
layer you want to remove.

4 Click Remove Viewport Overrides For ➤  Property Override (Color,
Linetype, Lineweight, Plot Style) ➤ In Current Viewport Only.

Toolbar: Layers  
Command entry: LAYER

To remove an override from a layer for all layout viewports

1 On the layout tab, double-click inside a viewport to make it current.

2 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

3 In the Layer Properties Manager, right-click the property override on the
layer to remove.

4 Click Remove Viewport Overrides For ➤  Property Override (Color,
Linetype, Lineweight, Plot Style) ➤ In All Viewports.
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Toolbar: Layers  
Command entry: LAYER

To remove all overrides from a layer for the current layout viewport

1 On the layout tab, double-click inside a viewport to make it current.

2 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

3 In the Layer Properties Manager, right-click the layer.

4 Click Remove Viewport Overrides For ➤  Selected Layers  ➤ In Current
Viewport Only.

Toolbar: Layers  
Command entry: LAYER

To remove all overrides for all layout viewports

1 Click a layout tab.

2 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

3 In the Layer Properties Manager, select the Viewport Overrides filter.

4 Right-click on any layer. Click Remove Viewport Overrides For  ➤  All
Layers  ➤  In All Viewports.

Toolbar: Layers  
Command entry: LAYER

To check if the current layout viewport contains layer property overrides

1 Double-click within a viewport to make it current.

2 At the Command prompt, enter vplayeroverrides.
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If VPLAYEROVERRIDES displays 1, the selected viewport contains layer
viewport overrides. If 0 is displayed, no overrides are found.

Command entry: VPLAYEROVERRIDES

To not display or plot layer viewport overrides

1 At the Command prompt, enter vplayeroverridesmode.

2 Enter 0.

Command entry: VPLAYEROVERRIDESMODE

To change the background color for property overrides

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

2 In the Layer Properties Manager, click Settings.

3 In the Layer Settings dialog box, select a color for the viewport override
background color.

4 Click OK.

Toolbar: Layers  
Command entry: LAYER

To save layer viewport overrides in a layer state

1 On a layout tab, double-click in a viewport to make it active.

2 Click Home tab  ➤  Layers panel  ➤  Layer States Manager

3 In the Layer States Manager, click New.

4 In the New Layer State to Save dialog box, enter a name for the new layer
state, or select a name from the list. (Optional) Add a description.

5 Click OK.

6 Click Close to exit the Layer State Manager.

Toolbar: Layers  
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Command entry: LAYERSTATE

Quick Reference

Commands

CHPROP

Changes the properties of an object.

CLASSICLAYER

Opens the modal Layer Properties Manager.

LAYER

Manages layers and layer properties.

LAYERP

Undoes the last change or set of changes made to layer settings.

LAYERPALETTE

Opens the modeless Layer Properties Manager.

LAYERPMODE

Turns the tracking of changes made to layer settings on and off.

PROPERTIES

Controls properties of existing objects.

PURGE

Removes unused items, such as block definitions and layers, from the drawing.

RENAME

Changes the names assigned to items such as layers and dimension styles.

System Variables

CLAYER

Sets the current layer.

LAYERDLGMODE

Sets the flavor of the Layer Properties Manager that is defined for the use of
the LAYER command.
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VPLAYEROVERRIDES

Indicates if there are any layers with viewport (VP) property overrides for the
current layout viewport.

VPLAYEROVERRIDESMODE

Controls whether layer property overrides for layout viewports are displayed
and plotted.

Utilities

No entries

Command Modifiers

No entries

Filter and Sort the List of Layers
You can control which layer names are listed in the Layer Properties Manager
and sort them by name or by property, such as color or visibility.

A layer filter limits the display of layer names in the Layer Properties Manager
and in the Layer control on the Layers toolbar. In a large drawing, you can
use layer filters to display only the layers you need to work with.

There are two kinds of layer filters

■ Layer property filter Includes layers that have names or other properties
in common. For example, you can define a filter that includes all layers
that are red and whose names include the letters mech.

■ Layer group filter Includes the layers that are put into the filter when you
define it, regardless of their names or properties. Selected layers can be
added from the layer list by dragging them to the filter.

The tree view in the Layer Properties Manager displays default layer filters and
any named filters that you create and save in the current drawing. The icon
next to a layer filter indicates the type of filter. Five default filters are displayed

■ All. Displays all the layers in the current drawing. (Filter is always displayed.)

■ All Used. Displays all the layers on which objects in the current drawing
are drawn. (Filter is always displayed.)
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■ Xref. If xrefs are attached to the drawing, displays all the layers being
referenced from other drawings.

■ Viewport Overrides. If there are layers with overrides for the current
viewport, displays all layers containing property overrides.

■ Unreconciled New Layers. If new layers were added since the drawing was
last opened, saved, reloaded, or plotted, displays a list of new unreconciled
layers. See Reconcile New Layers on page 578 for more information.

NOTE The default filters cannot be renamed, edited, or deleted.

Once you have named and defined a layer filter, you can select it in the tree
view to display the layers in the list view. You can also apply the filter to the
Layers toolbar, so that the Layer control displays only the layers in the current
filter.

When you select a filter in the tree view and right-click, options on the shortcut
menu can be used to delete, rename, or modify filters. For example, you can
convert a layer property filter to a layer group filter. You can also change a
property of all layers in a filter. The Isolate Group option turns off all layers
in the drawing that are not in the selected filter.

Define a Layer Property Filter

A layer property filter is defined in the Layer Filter Properties dialog box, where
you select any of the following properties you want to include in the filter
definition:

■ Layer names, colors, linetypes, lineweights, and plot styles

■ Whether layers are in use

■ Whether layers are turned on or off

■ Whether layers are frozen or thawed in the active viewport or all viewports

■ Whether layers are locked or unlocked

■ Whether layers are set to be plotted

You use wild-card characters to filter layers by name. For example, if you want
to display only layers that start with the letters mech, you can enter mech*.
See “Wild-Card Characters” for a complete list.

The layers in a layer property filter may change as the properties of the layers
change. For example, if you define a layer property filter named Site that
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includes all layers with the letters site in the name and a CONTINUOUS
linetype, and then you change the linetype of some of those layers, the layers
with the new linetype are no longer part of the Site filter and are not displayed
when you apply that filter.

Layer property filters can be nested under other properties filters or under
group filters.

Define a Layer Group Filter

A layer group filter includes only those layers that you explicitly assign to it.
If the properties of the layers assigned to the filter change, the layers are still
part of the filter. Layer group filters can be nested only under other layer group
filters.

TIP Layers from the layer list can be included in a filter by clicking and dragging
the selected layers to the filter.

Invert a Layer Filter

You can also invert a layer filter. For example, if all the site plan information
in a drawing is contained in multiple layers that include the word site as part
of the layer name, you can display all information except site plan information
by first creating a filter definition that filters layers by name (*site*) and then
using the Invert Filter option.

Sort Layers

Once you have created layers, you can sort them by name or other properties.
In the Layer Properties Manager, click the column heading to sort layers by
the property in that column. Layer names can be sorted in ascending or
descending alphabetical order.

Wild-Card Characters
You can use wild-card characters to sort layers by name.

DefinitionCharacter

Matches any numeric digit# (pound)

Matches any alphabetic character@ (at)

Matches any nonalphanumeric character. (period)
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DefinitionCharacter

Matches any string and can be used anywhere in the search
string

* (asterisk)

Matches any single character; for example, ?BC matches ABC,
3BC, and so on

? (question mark)

Matches anything but the pattern; for example; ~*AB*matches
all strings that don't contain AB

~ (tilde)

Matches any one of the characters enclosed; for example,
[AB]C matches AC and BC

[ ]

Matches any character not enclosed; for example, [~AB]C
matches XC but not AC

[~]

Specifies a range for a single character; for example, [A-G]C
matches AC, BC, and so on to GC, but not HC

[-]

Reads the next character literally; for example, ̀ ~AB matches
~AB

` (reverse quote)

NOTE To filter on a layer name that contains a wild-card character, precede the
character with a reverse quote (`) so that it is not interpreted as a wild-card
character.

See also:

■ Reconcile New Layers on page 578

To quickly filter the display of layers by name

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

2 In the Layer Properties Manager, click in Search for Layer below the tree
view.

3 (Optional) To limit your search, select a layer filter in the tree view.

4 Enter a string of characters, including wild-card characters.
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The list view displays all layers whose names match the string. For
example, if you enter *mech*, all layers with the letters mech in their
names are displayed.

This quick filter is discarded when the Layer Properties Manager closes.

Toolbar: Layers  
Command entry: LAYER

To filter the display of layers by layer property

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

2 In the Layer Properties Manager, click the New Property Filter button.

3 In the Layer Filter Properties dialog box, enter a name for the filter.

4 Under Filter Definition, set the layer properties that you want to use to
define the filter.

■ To filter by name, use wild-card characters.

■ To filter by property, click in the column for the property you want.
Some properties display a dialog box when you click the [...] button.

■ To select more than one value for a property, right-click the row in
the filter definition. Click Duplicate Row. Select another value for that
property in the next row.
For example, the definition for a filter that displays only layers that
are on and are either yellow or red has two rows. The first row of the
filter definition has the On icon and red. The second row has the On
icon and yellow.

5 Click Apply to save your changes, or click OK to save and close.

Toolbar: Layers  
Command entry: LAYER
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To filter the display of layer names by selecting layers

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

2 In the Layer Properties Manager, click the New Group Filter button.

A new layer group filter named GROUP FILTER1 is created in the tree
view.

3 Enter a name for the filter.

4 In the tree view, click All or one of the other nodes to display layers in
the list view.

5 In the list view, select the layers you want to add to the filter, and drag
them to the filter name in the tree view.

6 Click Apply to save your changes, or click OK to save and close.

Toolbar: Layers  
Command entry: LAYER

To nest a layer filter under another layer filter

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

2 In the Layer Properties Manager tree view, select a layer filter.

■ A new layer property filter can be nested under a group filter or
another property filter.

■ A new layer group filter can be nested only under another group filter.

3 Right-click. Click New Properties Filter or New Group Filter.

4 Use one of the following methods:

■ For a new property filter, the Layer Properties Filter dialog box is
displayed. Under Filter Definition, set the layer properties that you
want to use to define the filter. Click OK.

■ For a new group filter, a filter is added to the tree view. Rename it,
select the parent filter to display its layers in the list view, and drag
layers from the list view to the new layer group filter.
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5 Click Apply to save your changes, or click OK to save and close.

Toolbar: Layers  
Command entry: LAYER

To sort the layer list in the Layer Properties Manager

■ Click Home tab  ➤  Layers panel  ➤  Layer Properties 

■ In the Layer Properties Manager, click any column heading.

To reverse the sorting order, click a second time.

Toolbar: Layers  
Command entry: LAYER

To remove a layer from a layer group filter

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

2 In the Layer Properties Manager tree view, select a group filter.

3 Select the layer you want to remove.

4 Right-click in the list view. Click Remove from Group Filter.

Toolbar: Layers  
Command entry: LAYER

Quick Reference

Commands

CLASSICLAYER

Opens the modal Layer Properties Manager.
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LAYER

Manages layers and layer properties.

LAYERPALETTE

Opens the modeless Layer Properties Manager.

System Variables

LAYERDLGMODE

Sets the flavor of the Layer Properties Manager that is defined for the use of
the LAYER command.

MAXSORT

Sets the maximum number of symbol names or block names sorted by listing
commands.

Utilities

No entries

Command Modifiers

No entries

Use New Layer Notification
You can be notified when new layers are added to the drawing before certain
tasks, such as plotting, saving, or restoring a layer state.

It is important to be aware of new layers that have been added to a drawing
or to an attached xref without your knowledge. You can avoid potential
problems, such as plotting objects that were added to the drawing by the
addition of a new layer.

You can control when to evaluate a drawing for new layers. You can specify
which commands, such as SAVE or PLOT, trigger the program to check the
layer list and alert you of new layers. This can include new layers that have
been added to attached xrefs.

The LAYEREVAL and LAYERNOTIFY system variables work together to control
whether the layer list is evaluated and when notification occurs. Both system
variables are saved in the drawing so you have control over which drawings
are checked for new layers. When a project is started, it may not be necessary
to know when new layers have been created. For drawings that are nearing
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completion, it may be important to be aware if new information has been
introduced into the drawing from the addition of new layers.

The LAYEREVALCTL controls the overall Unreconciled New Layer filter list
in the Layer Properties Manager which is evaluated for new layers. When the
New Layer Notification is checked (LAYEREVALCTL = 1), the new layer
notification feature is enabled and functions based on the LAYEREVAL and
LAYERNOTIFY drawing system variables. There should be no filter
(Unreconciled Layer filter) displayed when LAYEREVALCTL = 0. If one is
currently displayed, it will be turned off.

By default, LAYEREVAL is set to detect any new layers that have been added
to attached xrefs but not in the drawing. LAYERNOTIFY is set to notify you
of new layers when opening the drawing, when loading, reloading, or attaching
xrefs, or when restoring a layer state. To make changes to these settings, you
can either use the system variables or the Layer Settings dialog box.

When layer notification is turned on, an Unreconciled New Layers icon displays
on the status bar.

At that time, you can choose to view the new layers by right-clicking the icon
and clicking the View Unreconciled New Layers link from the menu. When
you click the link, the Layer Properties Manager opens, and the Unreconciled
New Layers filter is automatically selected. All new layers that have been added
to the drawing or attached xrefs are displayed in the list view.

The new layers are unreconciled because they have not yet been reviewed. The
process of manually marking them as reconciled removes them from the
Unreconciled New Layers list. (See Reconcile New Layers on page 578 for more
information.) Until you reconcile the layers, the notification bubble will
display each time the command that triggered the notification is used.

By using the LAYERNOTIFY system variable or the Layer Settings dialog box,
you can turn off layer notification but still have the layer list evaluated for
new layers. Although the notification bubble does not display, you can still
check for new layers by right-clicking the alert icon on the status bar. From
the shortcut menu, click the View Unreconciled New Layers option.
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New Layer Notification for Plotting

When the PLOT command is set to display new layer notification in the Layer
Settings dialog box, a dialog box is displayed instead of an icon on the status
bar. A message informs you that there are new layers in the drawing since the
layer list was last checked for new layers. Click Yes in the dialog box to view
the new layer list in the Layer Properties Manager before plotting.

Saving a Template (DWT) File

When saving a drawing as a template (dwt) file, you can choose to save the
layers in the drawing as unreconciled or reconciled in the Template Options
dialog box. By default, all layers are saved as unreconciled, so that when a
new drawing is started using the template, a layer baseline is not yet created
until the drawing is first saved as a .dwg file.

If the template file is saved with all layers as reconciled, a layer baseline is
created. That means when new layers are added to the drawing that is created
from the template file, any new layers that are created are unreconciled and
a new layer notification will display when the drawing is first saved or plotted.

Opening Multiple Drawings

When opening multiple drawings at the same time, an alert displays for each
drawing that contains new layers. This behavior occurs if layer notification is
turned on and the OPEN command is specified in the LAYERNOTIFY system
variable for each drawing.

To set new layer notification on and off

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

2 In the Layer Properties Manager, click Settings.

3 In the Layer Settings dialog box, click Evaluate New Layers Added to
Drawing.
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4 Click Notify When New Layers are Present. Select one or more options.

5 Click OK.

6 Click OK to exit the Layer Properties Manager.

Toolbar: Layers  
Command entry: LAYER

To set when new layer notification is displayed

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties 

2 In the Layer Properties Manager, click Settings.

3 In the Layer Settings dialog box, click Evaluate New Layers Added to
Drawing.

4 Click Notify When New Layers are Present.

5 Select the commands that will cause the layer list to be evaluated for new
layers.

6 Click OK.

Toolbar: Layers  
Command entry: LAYER

Quick Reference

Commands

CLASSICLAYER

Opens the modal Layer Properties Manager.

LAYER

Manages layers and layer properties.

LAYERPALETTE

Opens the modeless Layer Properties Manager.
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System Variables

LAYERDLGMODE

Sets the flavor of the Layer Properties Manager that is defined for the use of
the LAYER command.

LAYEREVALCTL

Controls the overall Unreconciled New Layer filter list in Layer Properties
Manager which is evaluated for new layers.

LAYERNOTIFY

Specifies when an alert displays when unreconciled new layers are found.

LAYEREVAL

Specifies whether the layer list is evaluated for new layers when added to the
drawing or to attached xrefs.

Utilities

No entries

Command Modifiers

No entries

Reconcile New Layers
Unreconciled layers are new layers that have been added to the drawing and
have not yet been acknowledged by the user and manually marked as
reconciled.

Reconciling new layers is the process of manually reviewing new layers so that
you can avoid potential errors before plotting your drawing or when restoring
a layer state.

Unreconciled layers are new layers that have been added to the drawing or to
attached xrefs since the layer list was last evaluated. The layer list is checked
for new layers when a command, such as PLOT is used. In new drawings, the
layer baseline is created when the drawing is saved or plotted for the first time.
When a new drawing is first saved, the layer baseline is created, and all layers
present in the saved drawing are considered reconciled (not new). Layers that
are added after a drawing is first saved are considered new unreconciled layers.
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NOTE The layer baseline is created when the LAYEREVAL system variable is set to
1 or 2.

When a command that is set in the Layer Settings dialog box or LAYEREVAL
system variable is used, the layer list is checked at that time and compared to
the baseline. If there are new layers, notification will display and the
Unreconciled New Layers filter is automatically created and activated in the
Layer Properties Manager.

Unreconciled layers become reconciled by right-clicking the layer and clicking
the Reconcile Layer option. Once a layer has become reconciled, it is removed
from the Unreconciled New Layers filter. After all new layers are reconciled,
the Unreconciled New Layers filter is removed.

NOTE You can reconcile multiple unreconciled layers at the same time.

Quick Reference

Commands

CLASSICLAYER

Opens the modal Layer Properties Manager.

LAYER

Manages layers and layer properties.

LAYERPALETTE

Opens the modeless Layer Properties Manager.

System Variables

LAYERDLGMODE

Sets the flavor of the Layer Properties Manager that is defined for the use of
the LAYER command.
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LAYERNOTIFY

Specifies when an alert displays when unreconciled new layers are found.

LAYEREVAL

Specifies whether the layer list is evaluated for new layers when added to the
drawing or to attached xrefs.

Utilities

No entries

Command Modifiers

No entries

Work with Layer States
You can save layer settings as named layer states. You can then restore, edit,
import them from other drawings and files, and export them for use in other
drawings.

Save, Restore, and Edit Layer States
You can save the current layer settings to a layer state, make changes to the
layer state, and restore them to the drawing later.

You can save the current layer settings in a drawing as a named layer state
and restore them later. Saving layer settings is convenient if you need to return
to particular settings for all layers during different stages in completing a
drawing or for plotting.

Save Layer Settings

Layer settings include layer states, such as on or locked, and layer properties,
such as color or linetype. In a named layer state, you can choose which layer
states and layer properties you want to restore later. For example, you can
choose to restore only the Frozen/Thawed setting of the layers in a drawing,
ignoring all other settings. When you restore that named layer state, all settings
remain as they are currently set except whether each layer is frozen or thawed.

Save Layer Property Override Settings

When layers contain viewport property overrides, those settings are saved to
a layer state when the viewport that contains overrides is active.
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If the layer state is saved from model space, any layer property override settings
are not included. This is because only one value can be saved for each layer
property in a layer state. If layer property overrides need to be saved in the
layer state, make the viewport active on the layout tab and then save the layer
state.

Restore Layer Settings

When you restore a layer state, the layer settings (layer states and layer
properties) that were specified when the layer state was saved are restored.
You can specify specific settings to restore in the Layer States Manager. The
layer property settings that are not selected remain unchanged in the drawing.

If the drawing contains layers that were added since a layer state was saved,
you can add those layers. By editing the layer state and using the Select Layers
to Add to Layer State dialog box you can select the layers you want to add to
the layer state.

NOTE To be notified when new layers are added to the drawing, use the
LAYEREVAL and LAYERNOTIFY system variables.

When restoring layer states, the following additional behaviors can occur

■ When restoring a layer state, the layer that was current when the layer
state was saved is made current. If that layer no longer exists, the current
layer does not change.

■ If a layout viewport is active when a layer state is restored, and the Visibility
in Current VP restore option is selected, all layers that need to be visible
in the viewport are turned on and thawed in model space. All layers that
should not be visible in the viewport are set to VP Freeze in the current
viewport and the model space visibility is unchanged.

The Layers panel on the RIBBON contains controls for selecting and restoring
saved layer states, including a button to access the Layer States Manager. The
name of the last restored layer state is displayed in the Layers panel. When
the layers are modified so that the current layer state is no longer current,
“Unsaved Layer State” is displayed instead of the name of the last restored
layer state.

Restore Property Override Settings

When the Apply Properties as Viewport Overrides restore option is selected
in the Layer States Manager, viewport overrides are restored to the viewport
that is current at the time the layer state is restored.
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When a layer state is saved in model space and is restored in paper space,

■ You can choose whether color, linetype, lineweight, or plot style properties
are restored as viewport overrides.

■ Viewport overrides are applied to the current layout viewport.

■ Layers that were turned off or frozen in model space are set to VP Freeze
in the Layer Properties Manager for the active layout viewport.

When a layer state is saved in paper space and is restored in model space,

■ Layer property overrides are restored as global layer properties in model
space.

■ Layers that were frozen in a layout viewport are also frozen in model space.

Edit Saved Layer Settings

Using the Edit Layer State dialog box, you can modify the properties of each
layer saved in a layer state.

All properties other than the layer name can be edited. Properties for multiple
layers can be changed at the same time.

You can also add layers to a layer state through the Select Layers to Add to
Layer State dialog box. For example, if new layers were added since the layer
state was saved, you can add them and resave the layer state. To delete layers,
use the Delete button in the Edit Layer State dialog box.

Layer States in Xrefs

When a drawing containing layer states is inserted in the host drawing, the
xref layer states are displayed in the Layer States Manager. The layer states are
listed by name and can be viewed in the Edit Layer State dialog box.

When an xref containing layer states is attached to the host drawing, those
layer states are also listed in the Layer States Manager. Although they can be
restored, they cannot be edited. Xref layer states are identifiable because the
layer state name is preceded by the xref drawing’s name and separated by a
double underscore symbol. (Example: Xref Name__Layer State Name.) When
the xref is bound to the host drawing, layer states are identifiable by $0$ that
displays between the xref name and layer state name. (Example: Xref
Name$0$Layer State Name.)

Layer states from nested xrefs are also included. Layer states from xrefs are
removed from the host drawing when the xref is detached or unloaded.
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To save layer settings in a named layer state

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer States drop-down list, click New Layer State.

3 In the New Layer State to Save dialog box, enter a name for the new layer
state, or select a name from the list.

4 (Optional) Add a description.

5 Click Close.

6 In the Layer States Manager, select the layer properties to restore by
default.

7 (Optional) Select the Turn Off New Layers Not Found in Layer State
option.

When this option is selected and you restore a named layer state, the
drawing looks the same way it did when the named layer state was saved.

8 Click Close to exit the Layer States Manager.

Toolbar: Layer States Manager 
Command entry: LAYERSTATE

To restore a layer state

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer State drop-down list, select Manage Layer States.

3 In the Layer States Manager dialog box, select a named layer state.

4 Click More to select any specific layer properties you want to restore.

5 Click Restore.

The Layer States Manager closes.

Toolbar: Layer States Manager 
Command entry: LAYERSTATE
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To add layers to a layer state

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer State drop-down list, select Manage Layer States.

3 In the Layer States Manager dialog box, select the named layer state that
you want to add layers to.

4 Click Edit.

5 In the Edit Layer State dialog box, click Add.

6 In the Select Layers to Add to Layer State dialog box, select the layers you
want to add.

7 Click OK.

8 Click OK to exit the Edit Layer State dialog box.

9 Click Close to exit the Layer States Manager.

Toolbar: Layer States Manager 
Command entry: LAYERSTATE

To delete layers from a layer state

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer State drop-down list, select Manage Layer States.

3 In the Layer States Manager dialog box, select the named layer state you
want to delete layers from.

4 Click Edit.

5 In the Edit Layer State dialog box, select the layers to delete and click the
Delete button.

6 Click OK.

7 Click OK to exit the Edit Layer State dialog box.

8 Click Close to exit the Layer States Manager.

Toolbar: Layer States Manager 
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Command entry: LAYERSTATE

To modify a named layer state

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer State drop-down list, select Manage Layer States.

3 In the Layer States Manager dialog box, select the named layer state you
want to modify.

4 Click Edit.

5 In the Edit Layer State dialog box, select the property cells to change.

6 Click OK.

7 Click Close to exit the Layer States Manager.

Toolbar: Layer States Manager 
Command entry: LAYERSTATE

To rename a named layer state

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer State drop-down list, select Manage Layer States.

3 In the Layer States Manager dialog box, select the named layer state you
want to rename.

4 Click Rename.

5 In the Name field, enter a new name.

6 Click Close to exit the Layer States Manager.

NOTE An alternate method is to select the layer state name and press F2 for
in-place editing.

Toolbar: Layer States Manager 
Command entry: LAYERSTATE
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To delete a named layer state

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer State drop-down list, select Manage Layer States.

3 In the Layer States Manager dialog box, select the named layer state to
delete.

4 Click Delete.

5 Click Close to exit the Layer States Manager.

Toolbar: Layer States Manager 
Command entry: LAYERSTATE

To include description and material properties to a layer state imported from
a previous release

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer State drop-down list, select Manage Layer States.

3 In the Layer States Manager, select the layer state that was imported from
a previous release.

4 Click Restore to restore the layer state.

5 Open the Layer States Manager. Click New.

6 In the New Layer State to Save dialog box, enter a new name for the layer
state. In the Description field, enter descriptive text about the layer
settings.

7 Click OK.

8 (Optional) Click Delete to remove the legacy layer state.

9 Click Close.

Description and material properties are saved with the updated layer state.

Toolbar: Layer States Manager 
Command entry: LAYERSTATE
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To select a layer state to restore

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer State drop-down list, select Manage Layer States.

3 In the Layer States Manager dialog box, select the layer state you want
to restore.

4 Click More and select any specific layer properties you want to restore.

5 Click Restore.

The Layer States Manager closes.

Toolbar: Layer States Manager 
Command entry: LAYERSTATE

To restore layer viewport overrides

1 Select a layout viewport.

2 Click Home tab  ➤  Layers panel  ➤  Layer State.

3 In the Layer State drop-down list, select Manage Layer States.

4 In the Layer States Manager dialog box, select the named layer state to
restore.

5 Select Restore as Viewport Overrides.

6 Click Restore.

The Layer States Manager closes. The saved values for color, linetype,
lineweight, and plot style are applied to the layers as overrides in the
current viewport.

Toolbar: Layer States Manager 
Command entry: LAYERSTATE
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Quick Reference

Commands

LAYERSTATE

Saves, restores, and manages named layer states.

System Variables

LAYERNOTIFY

Specifies when an alert displays when unreconciled new layers are found.

LAYEREVAL

Specifies whether the layer list is evaluated for new layers when added to the
drawing or to attached xrefs.

Utilities

No entries

Command Modifiers

No entries

Import and Export Layer States
You can import layer settings from other drawings and export layer states.

You can import layer states that are saved in drawing files (DWG, DWS, and
DWT) and from layer state (LAS) files. When importing layer states from a
drawing file, you can choose multiple layer states to import from the Select
Layer States dialog box. When exporting layer states, they are created as LAS
files.

If the layer state is imported from a drawing and it contains a layer property,
such as a linetype or plot style that is not loaded or available in the current
drawing, that property is automatically imported from the source drawing.

If the layer state is imported from an LAS file, and it contains linetype or plot
style properties that do not exist in the drawing, a message is displayed
notifying that the property could not be restored.
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NOTE When a layer state contains more than one property that cannot be restored
from an LAS file, the message that displays only indicates the first property it
encountered that cannot be restored.

When importing a layer state from an LAS file or from another drawing that
are duplicates of layer states in the current drawing, you can choose to
overwrite the existing layer state or not import it.

Layer states can be imported into a previous release of the program.

Layer States from LMAN

Layer states that were created using the LMAN Express Tool cannot be
imported. A message is displayed that there are no layer states to import.

You can access LMAN layer states in a drawing through the Layer States
Manager. When the Layer States Manager is first opened in a drawing
containing LMAN layer states, they are automatically converted to AutoCAD
layer states. A dialog box displays the number of layer states that have been
converted.

When the current drawing does not contain any named layer states, the LMAN
layer state names are retained. If the current drawing contains layer states,
LMAN layer state names display with the prefix “LMAN” followed by the
original layer state name.

To import saved layer settings from another drawing

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer State drop-down list, select Manage Layer States.

3 In the Layer States Manager dialog box, click Import.

4 In the Import Layer State dialog box, select a file name with a .dwg, .dws,
or .dwt file name extension. Click Open.

5 In the Select Layer States dialog box, select the layer states to import.
Click OK.
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6 To restore the named layer state now, select it in the Layer States Manager.
and click Restore. Click Close to not restore it.

If you restore the named layer state, the Layer States Manager closes.

7 Click Close to exit the Layer States Manager.

Toolbar: Layer States Manager  
Command entry: LAYERSTATE

To import saved layer settings from a layer state (LAS) file

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer State drop-down list, select Manage Layer States.

3 In the Layer States Manager dialog box, click Import.

4 In the Import Layer State dialog box, select the LAS file you want to
import layer states from. Click Open.

5 Click Yes to restore the named layer state now. Click No to add it to the
Layer States Manager without restoring it.

If you restore the named layer state, the Layer States Manager closes.

6 Click Close to exit the Layer States Manager.

Toolbar: Layer States Manager  
Command entry: LAYERSTATE

To export a saved layer state

1 Click Home tab  ➤  Layers panel  ➤  Layer State.

2 In the Layer State drop-down list, select Manage Layer States.

3 In the Layer States Manager dialog box, select the named layer state (LAS)
file you want to export. Click Export.

4 In the Export Layer State dialog box, specify where to export the layer
state file.

5 Click Save to exit the dialog box.

6 Click Close to exit the Layer States Manager.
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Toolbar: Layer States Manager 
Command entry: LAYERSTATE

Quick Reference

Commands

LAYERSTATE

Saves, restores, and manages named layer states.

System Variables

LAYERNOTIFY

Specifies when an alert displays when unreconciled new layers are found.

LAYEREVAL

Specifies whether the layer list is evaluated for new layers when added to the
drawing or to attached xrefs.

Utilities

No entries

Command Modifiers

No entries

Work with Colors
Color helps to group objects visually. You can assign colors to objects by layer
or individually.

Set the Current Color
You can use color to help you identify objects visually. You can assign the
color of an object either by layer or by specifying its color explicitly,
independent of layer.

You can assign the color of an object either by layer or by specifying its color
explicitly, independent of layer. Assigning colors by layer makes it easy to
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identify each layer within your drawing. Assigning colors explicitly provides
additional distinctions between objects on the same layer. Color is also used
as a way to indicate lineweight for color-dependent plotting.

You can use a variety of color palettes when assigning color to objects,
including

■ AutoCAD Color Index (ACI)

■ True Color®, PANTONE®

■ RAL™ Classic and RAL Design color books

■ DIC® Color Guide

■ Colors from imported color books.

ACI Colors

ACI colors are the standard colors used in AutoCAD. Each color is identified
by an ACI number, an integer from 1 through 255. Standard color names are
available only for colors 1 through 7. The colors are assigned as follows: 1 Red,
2 Yellow, 3 Green, 4 Cyan, 5 Blue, 6 Magenta, 7 White/Black.

True Colors

True colors use 24-bit color definitions to display over 16 million colors. When
specifying true colors, you can use either an RGB or HSL color model. With
the RGB color model, you can specify the red, green, and blue components
of the color; with the HSL color model, you can specify the hue, saturation,
and luminance aspects of the color.

Color Books

This program includes several standard Pantone color books. You can also
import other color books such as the DIC color guide or RAL color sets.
Importing user-defined color books can further expand your available color
selections.

NOTE Pantone has provided new color definitions for Architectural & Interiors
Cotton and Architectural & Interiors Paper color books. If you used these color
books in releases prior to AutoCAD 2006, you may notice subtle changes in the
colors.
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You install color books on your system by using the Files tab in the Options
dialog box. Once a color book is loaded, you can select colors from the color
book and apply them to objects in your drawings.

All objects are created using the current color, which is displayed in the Color
control on the Properties toolbar. You can also set the current color with the
Color control or the Select Color dialog box.

If the current color is set to BYLAYER, objects are created with the color
assigned to the current layer. If you do not want the current color to be the
color assigned to the current layer, you can specify a different color.

If the current color is set to BYBLOCK, objects are created using color 7 (white
or black) until the objects are grouped into a block. When the block is inserted
into the drawing, it acquires the current color setting.

To set an ACI color for all new objects

1 Click Home tab  ➤  Properties panel  ➤  Object Color.

2 In the Object Color drop-down list, click a color to draw all new objects
in that color, or click Select Color to display the Select Color dialog box
and do one of the following:

■ On the Index Color tab, click a color or enter the color name or
number in the Color box.

■ On the Index Color tab, click BYLAYER to draw new objects in the
color assigned to the current layer.

■ On the Index Color tab, click BYBLOCK to draw new objects in the
current color until they are grouped into a block. When the block is
inserted into the drawing, the objects in the block acquire the current
color setting.

3 Click OK.

The Color control displays the current color.

Command entry: COLOR

To set a true color for all new objects

1 Click  Home tab  ➤  Properties panel  ➤  Object Color. 
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2 In the Object Color drop-down list. click Select Color to display the Select
Color dialog box.

3 In the Select Color dialog box, True Color tab, do one of the following:

■ Select the HSL color model in the Color Model box. Specify a color
by entering a color value in the Color box or by specifying values in
the Hue, Saturation, and Luminance boxes.

■ Select the RGB color model in the Color Model box. Specify a color
by entering a color value in the Color box or by specifying values in
the Red, Green, and Blue boxes.

4 Click OK.

The Color control displays the current color.

Command entry: COLOR

To set a color from a color book for all new objects

1 Click Home tab  ➤  Properties panel  ➤  Object Color.

2 In the Object Color drop-down list, click Select Color.

3 In the Select Color dialog box, Color Book tab, select a color book from
the Color Book box.

4 Select a color by clicking on a color chip. To browse through the color
book, use the up and down arrows on the color slider.

5 Click OK.

The Color control displays the current color.

Command entry: COLOR

Quick Reference

Commands

COLOR

Sets the color for new objects.
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System Variables

CECOLOR

Sets the color of new objects.

Utilities

No entries

Command Modifiers

No entries

Change the Color of an Object
You can change the color of an object by reassigning it to another layer, by
changing the color of the layer the object is on, or by specifying a color for
the object explicitly.

You have three choices for changing the color of an object:

■ Reassign the object to another layer with a different color. If an object's
color is set to BYLAYER, and you reassign the object to a different layer, it
acquires its color from the new layer.

■ Change the color assigned to the layer that the object is on. If an object's
color is set to BYLAYER, it acquires the color of its layer. When you change
the color assigned to a layer, all objects on that layer assigned the BYLAYER
color are updated automatically.

■ Specify a color for an object to override the layer's color. You can specify
the color of each object explicitly. If you want to override the
layer-determined color of an object with a different one, change an existing
object's color from BYLAYER to a specific color, such as red.

If you want to set a specific color for all subsequently created objects, change
the current color setting on the Properties toolbar from BYLAYER to a specific
color.

See also:

■ Override Layer Properties in Viewports on page 559
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To change the layer of an object

1 Select the objects whose layer you want to change.

2 Click Home tab  ➤  Layers panel  ➤  Layer Properties.

3 In the Layers Properties Manager, click the Layer control.

4 Select the layer that you want to assign to the objects.

Toolbar: Layers  

To change the color assigned to a layer

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties.

2 In the Layer Properties Manager, click the color you want to change.

3 In the Select Color dialog box, do one of the following:

■ On the Index tab, click a color or enter the ACI color number (1-255)
or name in the Color box. Click OK.

■ On the True Color tab, select the HSL color model in the Color Model
option and specify a color by entering a color value in the Color box
or by specifying values in the Hue, Saturation, and Luminance boxes.
Click OK.

■ On the Color Books tab, select a color book from the Color Book box;
select a color by navigating the color book (using the up and down
arrows) and clicking on a color chip. Click OK.

4 Click OK to close each dialog box.

Toolbar: Layers  
Command entry: LAYER

To change the color of objects, overriding the layer's color

1 Select the objects whose color you want to change.
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2 Click View tab  ➤  Properties panel  ➤  Properties.

Alternatively, you can right-click one of the objects and then, click
Properties.

3 In the Properties palette, select Color.

An arrow is displayed in the right column.

4 Click the arrow and select a color from the list or click Select Color to
display the Select Color dialog box. If you click Select Color, do one of
the following:

■ On the Index tab, click a color or enter the ACI color number (1-255)
or name in the Color box.

■ On the True Color tab, select the HSL color model in the Color Model
option and specify a color by entering a color value in the Color box
or by specifying values in the Hue, Saturation, and Luminance boxes.
Click OK.

■ On the True Color tab, select the RGB color model in the Color Model
box. Specify a color by entering a color value in the Color box or by
specifying values in the Red, Green, and Blue boxes.

■ On the Color Books tab, select a color book from the Color Book box;
select a color by navigating the color book (using the up and down
arrows) and clicking on a color chip. Click OK.

Command entry: PROPERTIES

Quick Reference

Commands

CHANGE

Changes the properties of existing objects.

CHPROP

Changes the properties of an object.

COLOR

Sets the color for new objects.
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PROPERTIES

Controls properties of existing objects.

System Variables

CECOLOR

Sets the color of new objects.

Utilities

No entries

Command Modifiers

No entries

Use Color Books
When assigning colors to objects, you can choose colors from color books
that are loaded on your system. You can choose from a wide range of custom
colors when using color books. Color books include third-party or user-defined
files that contain named color swatches. These colors can be used to enhance
presentation drawings as well as to optimize the variety of color used in your
drawings. You can apply color book colors to objects in your drawings by
using the Color Books tab in the Select Color dialog box.

Install Color Books

Color book files must contain an .acb file extension in order to be recognized
by this program. To access color book colors from the Select Color dialog box,
you must first copy your color book files to a specified color book location.
On the Files tab of the Options dialog box, you can define the path where
color book files are stored. Multiple locations can be defined for the color
book path. These locations are saved in your user profile.

After loading a color book on your system, to access the new colors, you need
to close the Select Color dialog box and then open it again. The new color
book is displayed in the Color Book drop-down list on the Color Books tab.
Once you have loaded a color book, you can apply any colors that are defined
in the book to objects in your drawing.
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Browse Color Books

Color books are organized alphabetically into pages that you can browse
through. A page holds up to ten colors. If the color book you are browsing
through is not organized into pages, the colors are arranged into pages, with
each page containing up to seven colors.

To install a color book

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Files tab, click Color Book Locations.

3 Click Add to add a color book location.

4 Enter the new location in the blank path box.

5 Click OK.

Command entry: OPTIONS

To search for color swatches within a color book

1 Click Home tab  ➤  Properties panel  ➤  Object Color.

2 In the Object Color drop-down list, click Select Color.

3 In the Select Color dialog box, Color Books tab, select a color book from
the Color Book drop-down list.

You must first select any color swatch in the color book in order to
activate the Color edit box.

4 Under Color, enter the number of the color swatch you would like to
locate and press TAB.

The Color edit box and the New color chip display the requested color
or the color that is the closest match.

5 Click OK to apply the color.

Command entry: COLOR
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To change the default location of color book files

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Files tab, double-click Color Book Locations.

3 Select the following default color book location:

C:\Program Files\[current AutoCAD release number]\support\color

4 Click the location name to edit the path.

5 Enter the new location in the path box.

6 Click OK.

Command entry: OPTIONS

To define multiple folders for the color book path

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Files tab, click Color Book Locations.

3 Click Add to add a color book location.

4 Enter the new location in the blank path box.

5 Click OK.

Command entry: OPTIONS

Quick Reference

Commands

CHANGE

Changes the properties of existing objects.

CHPROP

Changes the properties of an object.
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COLOR

Sets the color for new objects.

PROPERTIES

Controls properties of existing objects.

System Variables

CECOLOR

Sets the color of new objects.

Utilities

No entries

Command Modifiers

No entries

Work with Linetypes
You can use linetypes to distinguish objects from one another visually and
make your drawing easier to read.

Overview of Linetypes
A linetype is a repeating pattern of dashes, dots, and blank spaces displayed
in a line or a curve. You assign linetypes to objects either by layer or by
specifying the linetype explicitly, independent of layers.

In addition to choosing a linetype, you can set its scale to control the size of
the dashes and spaces, and you can create your own custom linetypes.

NOTE These linetypes should not be confused with the hardware linetypes
provided by some plotters. The two types of dashed lines produce similar results.
Do not use both types at the same time, however, because the results can be
unpredictable.

See also:

■ “Custom Linetypes” in the Customization Guide
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Quick Reference

Commands

LINETYPE

Loads, sets, and modifies linetypes.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Load Linetypes
At the start of a project, you load the linetypes that are required for the project
so that they are available when you need them.

If you want to know what linetypes are already available, you can display a
list of linetypes that are loaded in the drawing or stored in an LIN (linetype
definition) file.

This program includes the linetype definition files acad.lin and acadiso.lin.
Which linetype file is appropriate depends on whether you use imperial or
metric measurements.

■ For imperial units, use the acad.lin file.

■ For metric measurements, use the acadiso.lin file.

Both linetype definition files contain several complex linetypes.

If you select a linetype whose name begins with ACAD_ISO, you can use the
ISO pen-width option when you plot.

You can remove unreferenced linetype information with PURGE or by deleting
the linetype from the Linetype Manager. BYBLOCK, BYLAYER, and
CONTINUOUS linetypes cannot be removed.

602 | Chapter 15   Control the Properties of Objects



To load a linetype

1 Click Home tab  ➤  Properties panel  ➤  Linetype. 

2 In the Linetype drop-down list, click Other. Then, in the Linetype
Manager dialog box, click Load.

3 In the Load or Reload Linetypes dialog box, select a linetype. Click OK.

If the linetype you need is not listed, click File. In the Select Linetype File
dialog box, select an LIN file whose linetypes you want to list and click.
The dialog box displays the linetype definitions stored in the selected
LIN file. Select a linetype. Click OK.

You can hold down CTRL to select several linetypes or SHIFT to select a
range of linetypes.

4 Click OK.

Command entry: LINETYPE

To list the linetypes loaded in the current drawing

1 Click Home tab  ➤  Properties panel  ➤  Linetype. 

2 Click anywhere outside the box to close it.

To list the linetypes in a linetype definition file

1 Click Home tab  ➤  Properties panel  ➤  Linetype. 

2 In the Linetype drop-down list, click Other. Then, in the Linetype
Manager dialog box, click Load.

3 In the Load or Reload Linetypes dialog box, click File.

4 In the Select Linetype File dialog box, select an LIN (linetype definition)
file whose linetypes you want to lit. Click Open.

The dialog box displays the linetype definitions stored in the selected
LIN file.

5 In the Load or Reload Linetypes dialog box, click Cancel.
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6 Click Cancel to close the Linetype Manager.

Command entry: LINETYPE

To unload an unused linetype

1 Click Home tab  ➤  Properties panel  ➤  Linetype. 

2 In the Linetype drop-down list, click Other. Then, in the Linetype
Manager dialog box, select a linetype. Click Delete.

The selected linetype is unloaded. Certain linetypes cannot be unloaded:
BYLAYER, BYBLOCK, CONTINUOUS, and any linetypes currently in use.

Command entry: LINETYPE

To purge an unused linetype

1 Click Tools tab ➤ Drawing Utilities panel ➤ Purge.

The Purge dialog box displays a tree view of object types with items that
can be purged.

2 To purge unreferenced linetypes, use one of the following methods:

■ To purge all unreferenced linetypes, select Linetypes.

■ To purge specific linetypes, double-click Linetypes to expand the tree
view. Then select the linetypes to be purged.

If the item you want to purge is not listed, select View Items You Cannot
Purge.

3 You are prompted to confirm each item in the list. If you do not want to
confirm each purge, clear the Confirm Each Item to Be Purged option.

4 Click Purge.

To confirm the purging of each item, respond to the prompt by choosing
Yes or No, or Yes to All if more than one item is selected.

5 Click Close.

Command entry: PURGE
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Quick Reference

Commands

LINETYPE

Loads, sets, and modifies linetypes.

PURGE

Removes unused items, such as block definitions and layers, from the drawing.

RENAME

Changes the names assigned to items such as layers and dimension styles.

System Variables

MEASUREINIT

Controls whether a drawing you start from scratch uses imperial or metric
default settings.

MEASUREMENT

Controls whether the current drawing uses imperial or metric hatch pattern
and linetype files.

Utilities

No entries

Command Modifiers

No entries

Set the Current Linetype
All objects are created using the current linetype, which is displayed in the
Linetype control on the Properties toolbar.

You can also set the current linetype with the Linetype control.

If the current linetype is set to BYLAYER, objects are created with the linetype
assigned to the current layer.

If the current linetype is set to BYBLOCK, objects are created using the
CONTINUOUS linetype until the objects are grouped into a block. When the
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block is inserted into the drawing, those objects acquire the current linetype
setting.

If you do not want the current linetype to be the linetype assigned to the
current layer, you can specify a different linetype explicitly.

The program does not display the linetype of certain objects: text, points,
viewports, hatches, and blocks.

To set the linetype for all new objects

1 Click Home tab  ➤  Properties panel  ➤  Linetype. 

2 In the Linetype drop-down list, click Other. Then, in the Linetype
Manager dialog box, click Load.

You can hold down CTRL to select several linetypes or SHIFT to select a
range of linetypes.

3 In the Linetype Manager dialog box, do one of the following:

■ Select a linetype and select Current to draw all new objects with that
linetype.

■ Select BYLAYER to draw new objects in the linetype assigned to the
current layer.

■ Select BYBLOCK to draw new objects in the current linetype until
they are grouped into a block. When the block is inserted into a
drawing, the objects in the block acquire the current linetype setting.

4 Click OK.

NOTE The Linetype control displays the current linetype. If the linetype you want
to use is already loaded, you can click the Linetype control and click the linetype
to make it current.

Command entry: LINETYPE

To change the linetype assigned to a layer

1 Click Home tab ➤ Layers panel ➤ Layer Properties.
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2 In the Layer Properties Manager, select the linetype name you want to
change.

3 In the Select Linetype dialog box, select the linetype you want. Click OK.

4 Click OK again.

Toolbar: Layers  
Command entry: LAYER

Quick Reference

Commands

LINETYPE

Loads, sets, and modifies linetypes.

System Variables

CELTYPE

Sets the linetype of new objects.

Utilities

No entries

Command Modifiers

No entries

Change the Linetype of an Object
You can change the linetype of an object by reassigning it to another layer,
by changing the linetype of the layer the object is on, or by specifying a
linetype for the object explicitly.

You have three choices for changing the linetype of an object:

■ Reassign the object to another layer with a different linetype. If an object's
linetype is set to BYLAYER, and you reassign the object to a different layer,
it acquires its linetype from the new layer.
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■ Change the linetype assigned to the layer that the object is on. If an object's
linetype is set to BYLAYER, it acquires the linetype of its layer. When you
change the linetype assigned to a layer, all objects on that layer assigned
the BYLAYER linetype are updated automatically.

■ Specify a linetype for an object to override the layer's linetype. You can
specify the linetype of each object explicitly. If you want to override the
layer-determined linetype of an object with a different one, change an
existing object's linetype from BYLAYER to a specific linetype, such as
DASHED.

If you want to set a specific linetype for all subsequently created objects,
change the current linetype setting on the Properties toolbar from BYLAYER
to a specific linetype.

See also:

■ Override Layer Properties in Viewports on page 559

To change the default linetype assigned to a layer

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties.

2 In the Layer Properties Manager, select the linetype name you want to
change.

3 In the Select Linetype dialog box, select a linetype.

If the linetype you need is not listed, click Load. Select a linetype and
click OK, or click File to open additional linetype definition (LIN) files.

4 Click OK to exit each dialog box.

Toolbar: Layers  
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Command entry: LAYER

To change the linetype of an object, overriding the layer's linetype

1 Select the objects whose linetype you want to change.

2 Click Home tab  ➤  Palettes panel  ➤  Properties. 

3 On the Properties palette, click the Linetype control.

4 Choose the linetype that you want to assign to the objects.

Command entry: PROPERTIES

Quick Reference

Commands

CHANGE

Changes the properties of existing objects.

CHPROP

Changes the properties of an object.

LAYER

Manages layers and layer properties.

LINETYPE

Loads, sets, and modifies linetypes.

PROPERTIES

Controls properties of existing objects.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Control Linetype Scale
You can use the same linetype at different scales by changing the linetype
scale factor either globally or individually for each object.

By default, both global and individual linetype scales are set to 1.0. The smaller
the scale, the more repetitions of the pattern are generated per drawing unit.
For example, with a setting of 0.5, two repetitions of the pattern in the linetype
definition are displayed for each drawing unit. Short line segments that cannot
display one full linetype pattern are displayed as continuous. You can use a
smaller linetype scale for lines that are too short to display even one dash
sequence.

The Linetype Manager displays the Global Scale Factor and Current Object
Scale.

■ The Global Scale Factor value controls the LTSCALE system variable, which
changes the linetype scale globally for both new and existing objects.

■ The Current Object Scale value controls the CELTSCALE system variable,
which sets the linetype scale for new objects.

The CELTSCALE value is multiplied by the LTSCALE value to get the displayed
linetype scale. You can easily change linetype scales in your drawing either
individually or globally.

In a layout, you can adjust the scaling of linetypes in different viewports with
PSLTSCALE.

To change the linetype scale of selected objects

1 Select the objects whose linetype scale you want to change.
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2 Click Home tab  ➤  Palettes panel  ➤  Properties. 

Alternatively, right-click one of the objects. Click Properties.

3 In the Properties palette, select Linetype Scale and enter the new value.

Toolbar: Standard  
Command entry: PROPERTIES

To set the linetype scale for new objects

1 Click Home tab  ➤  Properties panel  ➤  Linetype. 

2 In the Linetype drop-down list, select Other.

3 In the Linetype Manager, click Show Details to expand the dialog box.

4 Enter a new value for Current Object Scale.

5 Click OK.

Command entry: LINETYPE

To change linetype scale globally

1 Click Home tab  ➤  Properties panel  ➤  Linetype. 

2 In the Linetype Manager, click Show Details to expand the dialog box.

3 Enter a new value for Global Scale Factor.

4 Click OK.

Command entry: LINETYPE
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Quick Reference

Commands

LINETYPE

Loads, sets, and modifies linetypes.

System Variables

CELTSCALE

Sets the current object linetype scaling factor.

LTSCALE

Sets the global linetype scale factor.

PSLTSCALE

Controls the linetype scaling of objects displayed in paper space viewports.

Utilities

No entries

Command Modifiers

No entries

Display Linetypes on Short Segments and Polylines
You can center the pattern of a linetype on each segment of a polyline, and
you can control how the linetype is displayed on short segments.

If a line is too short to hold even one dash sequence, the result is a continuous
line between the endpoints, as shown below.

You can accommodate short segments by using a smaller value for their
individual linetype scales. For more information, see Control Linetype Scale
on page 610.
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For polylines, you can specify whether a linetype pattern is centered on each
segment or is continuous across vertices throughout the entire length of the
polyline. You do this by setting the PLINEGEN system variable.

To set the linetype display for all new polylines

1 At the Command prompt, enter plinegen.

2 Enter 1 to make the linetype pattern continue throughout the entire
length of two-dimensional polylines, or enter 0 to center the linetype
pattern on each segment.

Command entry: PLINEGEN

To change the linetype display of existing polylines

1 Select the polyline whose linetype display you want to change.

2 Click Home tab  ➤  Palettes panel  ➤  Properties.

3 In the Properties palette, click Linetype Generation and select Enabled
or Disabled.

Toolbar: Standard  
Command entry: PROPERTIES

Quick Reference

Commands

PROPERTIES

Controls properties of existing objects.
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System Variables

PLINEGEN

Sets how linetype patterns generate around the vertices of a 2D polyline.

Utilities

No entries

Command Modifiers

No entries

Control Lineweights
You can control the thickness of an object’s lines in both the drawing display
and plotting.

Overview of Lineweights
Lineweights are width values that are assigned to graphical objects as well as
some types of text.

Using lineweights, you can create heavy and thin lines to show cuts in sections,
depth in elevations, dimension lines and tick marks, and differences in details.
For example, by assigning varying lineweights to different layers, you can
easily differentiate between new, existing, and demolition construction.
Lineweights are not displayed unless the LWT button on the status bar is
selected.

TrueType fonts, raster images, points, and solid fills (2D solids) cannot display
lineweight. Wide polylines show lineweights only when displayed outside of
the plan view. You can export drawings to other applications or cut objects
to the Clipboard and retain lineweight information.

In model space, lineweights are displayed in pixels and do not change when
zoomed in or out. Thus, you should not use lineweights to represent the exact
width of an object in model space. For example, if you want to draw an object
with a real-world width of 0.5 inches, do not use a lineweight; instead, use a
polyline with a width of 0.5 inches to represent the object.

You can also plot objects in your drawing with custom lineweight values. Use
the Plot Style Table Editor to adjust the fixed lineweight values to plot at a
new value.
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Lineweight Scale in Drawings

Objects with a lineweight are plotted with the exact width of the assigned
lineweight value. The standard settings for these values include BYLAYER,
BYBLOCK, and Default. They are displayed in either inches or millimeters,
with millimeters being the default. All layers are initially set to 0.25 mm,
controlled by the LWDEFAULT system variable.

A lineweight value of 0.025 mm or less is displayed as one pixel in model
space and is plotted at the thinnest lineweight available on the specified
plotting device. Lineweight values that you enter at the Command prompt
are rounded to the nearest predefined value.

You set the lineweight units and the default value in the Lineweight Settings
dialog box. You can access the Lineweight Settings dialog box by using the
LWEIGHT command, by right-clicking the LWT button on the status bar and
choosing Settings, or by choosing Lineweight Settings on the User Preferences
tab in the Options dialog box.

See also:

■ Draw Polylines on page 801

To assign width to polylines

1 Click Home tab ➤ Draw panel ➤ Polyline. 

2 Specify the start point for the first segment in the polyline.

3 Enter w (width).

4 Enter a value for the width at the start of the line segment.

5 Enter a value for the width at the end of the line segment.

6 Specify the endpoint of the first segment of the polyline.

7 Enter w to specify different widths for the next segment, or press ENTER
to end the command.

Toolbar: Draw  
Command entry: PLINE
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To assign a lineweight to a layer

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties.

2 In the Layer Properties Manager, select a layer. Click the lineweight
associated with that layer.

3 In the Lineweight dialog box, select a lineweight from the list.

4 Click OK to close each dialog box.

Command entry: LAYER

To set the display scale of lineweights on the Model tab

1 Click Home tab  ➤  Properties panel  ➤  Lineweight. 

2 In the Lineweight drop-down list, select Lineweight Settings.

3 In the Lineweight Settings dialog box, under Adjust Display Scale, move
the slider to change the scale.

4 Click OK.

Command entry: LAYER, LWEIGHT

Quick Reference

Commands

LWEIGHT

Sets the current lineweight, lineweight display options, and lineweight units.

PLINE

Creates a 2D polyline.

System Variables

LWDEFAULT

Sets the value for the default lineweight.
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LWDISPLAY

Controls whether the lineweights of objects are displayed.

LWUNITS

Controls whether lineweight units are displayed in inches or millimeters.

Utilities

No entries

Command Modifiers

No entries

Display Lineweights
Lineweights can be turned on and off in a drawing, and are displayed
differently in model space than in a paper space layout.

■ In model space, a 0-value lineweight is displayed as one pixel, and other
lineweights use a pixel width proportional to their real-unit value.

■ In a paper space layout, lineweights are displayed in the exact plotting
width.

Regeneration time increases with lineweights that are represented by more
than one pixel. Turn off the display of lineweights to optimize performance
of the program.

You can turn the display of lineweights on or off by clicking LWT on the status
bar. This setting does not affect the plotting of lineweights.

Display Lineweights in Model Space

Lineweight display in model space does not change with the zoom factor. For
example, a lineweight value that is represented by a width of four pixels is
always displayed using four pixels regardless of how far you zoom in. If you
want the lineweights on objects to appear thicker or thinner on the Model
tab, use LWEIGHT to set their display scale. Changing the display scale does
not affect the lineweight plotting value.

In model space, weighted lines that are joined form a beveled joint with no
end caps. You can use plot styles to apply different joins and endcap styles to
objects with lineweights.
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NOTE Different styles of endcaps and joins of objects with lineweight are displayed
only in a full plot preview.

Display Lineweights in Layouts

In layouts and plot preview, lineweights are displayed in real-world units, and
lineweight display changes with the zoom factor. You can control lineweight
plotting and scaling in your drawing in the Plot dialog box, Plot Settings tab.

To display or hide lineweights

Use one of the following methods:

■ Click LWT on the status bar.

■ Select or clear Display Lineweight in the Lineweight Settings dialog box.

■ Set the LWDISPLAY system variable to 0 or 1.

Command entry: LWEIGHT

Quick Reference

Commands

LAYER

Manages layers and layer properties.

LWEIGHT

Sets the current lineweight, lineweight display options, and lineweight units.

PEDIT

Edits polylines and 3D polygon meshes.

PLINE

Creates a 2D polyline.

PLOT

Plots a drawing to a plotter, printer, or file.

System Variables

LWDEFAULT

Sets the value for the default lineweight.
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LWDISPLAY

Controls whether the lineweights of objects are displayed.

LWUNITS

Controls whether lineweight units are displayed in inches or millimeters.

PLINEWID

Stores the default polyline width.

Utilities

No entries

Command Modifiers

No entries

Set the Current Lineweight
The current lineweight is the lineweight used for any objects you draw until
you make another lineweight current.

All objects are created using the current lineweight, which is displayed in the
Lineweight control on the Properties toolbar. You can also set the current
lineweight with the Lineweight control.

If the current lineweight is set to BYLAYER, objects are created with the
lineweight assigned to the current layer.

If the current lineweight is set to BYBLOCK, objects are created using the
default lineweight setting until the objects are grouped into a block. When
the block is inserted into the drawing, it acquires the current lineweight setting.

If you do not want the current lineweight to be the lineweight assigned to
the current layer, you can specify a different lineweight explicitly.

Objects in drawings created in an earlier release of AutoCAD are assigned the
lineweight value of BYLAYER, and all layers are set to DEFAULT. Lineweight
assigned to objects is displayed as a solid fill drawn in the object's assigned
color.

To make a lineweight current for creating objects

1 Click Home tab  ➤  Properties panel  ➤  Lineweight. 
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2 In the Lineweight drop-down list, select Lineweight Settings.

3 In the Lineweight Settings dialog box, select a lineweight.

4 Click OK.

NOTE To display the lineweight at its current setting, the Display Lineweight
option must be selected in the Display Lineweight dialog box.

Command entry: LAYER, LWEIGHT

Quick Reference

Commands

LAYER

Manages layers and layer properties.

LWEIGHT

Sets the current lineweight, lineweight display options, and lineweight units.

PEDIT

Edits polylines and 3D polygon meshes.

PLINE

Creates a 2D polyline.

PLOT

Plots a drawing to a plotter, printer, or file.

System Variables

LWDEFAULT

Sets the value for the default lineweight.

LWDISPLAY

Controls whether the lineweights of objects are displayed.

LWUNITS

Controls whether lineweight units are displayed in inches or millimeters.
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PLINEWID

Stores the default polyline width.

Utilities

No entries

Command Modifiers

No entries

Change the Lineweight of an Object
You can change the lineweight of an object by reassigning it to another layer,
by changing the lineweight of the layer the object is on, or by specifying a
lineweight for the object explicitly.

You have three choices for changing the lineweight of an object:

■ Reassign the object to another layer with a different lineweight. If an
object's lineweight is set to BYLAYER, and you reassign the object to a
different layer, it acquires its lineweight from the new layer.

■ Change the lineweight assigned to the layer that the object is on. If an
object's lineweight is set to BYLAYER, it acquires the lineweight of its layer.
When you change the lineweight assigned to a layer, all objects on that
layer assigned the BYLAYER lineweight are updated automatically.

■ Specify a lineweight for an object to override the layer's lineweight. You
can specify the lineweight of each object explicitly. If you want to override
the layer-determined lineweight of an object with a different one, change
an existing object's lineweight from BYLAYER to a specific lineweight.

If you want to set a specific lineweight for all subsequently created objects,
change the current lineweight setting on the Properties toolbar from BYLAYER
to a specific lineweight.

See also:

■ Override Layer Properties in Viewports on page 559
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To change the line width of a polyline, donut, rectangle, or polygon

1 Click Home tab ➤ Modify panel ➤ Edit Polyline. 

2 Select one or more polyline objects.

3 Enter w (Width) and enter a new width for all segments.

4 Press ENTER to end the command.

Toolbar: Modify II  
Command entry: PEDIT

Quick Reference

Commands

LAYER

Manages layers and layer properties.

LWEIGHT

Sets the current lineweight, lineweight display options, and lineweight units.

PEDIT

Edits polylines and 3D polygon meshes.

PLINE

Creates a 2D polyline.

PLOT

Plots a drawing to a plotter, printer, or file.

System Variables

LWDEFAULT

Sets the value for the default lineweight.

LWDISPLAY

Controls whether the lineweights of objects are displayed.
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LWUNITS

Controls whether lineweight units are displayed in inches or millimeters.

PLINEWID

Stores the default polyline width.

Utilities

No entries

Command Modifiers

No entries

Control the Display Properties of Certain Objects
You can control how overlapping objects and certain other objects are
displayed and plotted.

Control the Display of Polylines, Hatches, Gradient Fills,
Lineweights, and Text

You can simplify the display of certain kinds of objects in order to speed
performance.

Display performance is improved when wide polylines and donuts, solid-filled
polygons (two-dimensional solids), hatches, gradient fills, and text are
displayed in simplified form. Simplified display also increases the speed of
creating test plots.

Turn Off Solid Fill

When you turn off Fill mode, wide polylines, solid-filled polygons, gradient
fill, and hatches are displayed in outline form. Except for patterned hatches
and gradient fills, solid fill is automatically turned off for hidden view and
nonplan views in three dimensions.
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Use Quick Text

When you turn on Quick Text mode in drawings that contain a lot of text
using complex fonts, only a rectangular frame defining the text is displayed
or plotted.

Turn Off Lineweights

Any lineweight width that is represented by more than one pixel may slow
down performance. If you want to improve display performance, turn
lineweights off. You can turn lineweights on and off by choosing the LWT
button on the status bar or by using the Lineweight Settings dialog box.
Lineweights are always plotted at their real-world value whether their display
is turned on or off.

Update the Display

New objects automatically use the current settings for displays of solid fill and
text. Except for lineweights, to update the display of existing objects using
these settings, you must use REGEN.

See also:

■ Use Layers to Manage Complexity on page 535

■ Display Lineweights on page 617

■ Use TrueType Fonts on page 1549
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To turn the display of solid fill on or off

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Display tab, under Display Performance, select
Apply Solid Fill.

A check mark indicates that Fill mode is on.

3 Click OK.

4 To display your changes, click View menu  ➤ Regen.

Command entry: OPTIONS, REGEN

To turn the display of text on or off

1 Click Tools  ➤ Options. 

2 In the Options dialog box, Display tab, under Display Performance, select
Show Text Boundary Frame Only.

The check mark indicates that text is displayed as a rectangular frame.

3 Click OK.

4 To display your changes, click View menu  ➤ Regen.

Command entry: OPTIONS, REGEN

To turn lineweights on or off

1 Click Home tab  ➤  Properties panel  ➤  Lineweight. 

2 In the Lineweight drop-dow list, select Lineweight Settings.

3 In the Lineweight Settings dialog box, select or clear Display Lineweight.

4 Click OK.

Command entry: LWEIGHT
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Quick Reference

Commands

DSETTINGS

Sets grid and snap, polar and object snap tracking, object snap modes,
Dynamic Input, and Quick Properties.

FILL

Controls the filling of objects such as hatches, 2D solids, and wide polylines.

LWEIGHT

Sets the current lineweight, lineweight display options, and lineweight units.

QTEXT

Controls the display and plotting of text and attribute objects.

REGEN

Regenerates the entire drawing from the current viewport.

System Variables

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.

LWDISPLAY

Controls whether the lineweights of objects are displayed.

QTEXTMODE

Controls how text is displayed.

TEXTFILL

Controls the filling of TrueType fonts while plotting and rendering.

TEXTQLTY

Sets the resolution tessellation fineness of text outlines.
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Utilities

No entries

Command Modifiers

No entries

Control How Overlapping Objects Are Displayed
You can control which overlapping objects appear to be on top.

Generally, overlapping objects such as text, wide polylines, and solid-filled
polygons are displayed in the order they are created: newly created objects in
front of existing objects. You can use DRAWORDER to change the draw order
(which is the display and plotting order) of any objects. TEXTTOFRONT
changes the draw order of all text and dimensions in the drawing.

NOTE Overlapping objects cannot be controlled between model space and paper
space. They can be controlled only within the same space.

To change the draw order of overlapping objects

1 Click Home tab  ➤  Modify panel  ➤  Draw Order drop-down list.

2 From the draw order drop down list, click one of the options.

3 Select the object(s) whose draw order you want to modify and press
ENTER.

4 Select the reference object(s) and press ENTER. (This step is necessary
only for the Bring Above Objects and Send Under Objects options.)

Toolbar:  Draw Order  
Command entry: DRAWORDER

Shortcut menu: Select an object and right-click. Click Draw Order
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Quick Reference

Commands

DRAWORDER

Changes the draw order of images and other objects.

QSELECT

Creates a selection set based on filtering criteria.

REGEN

Regenerates the entire drawing from the current viewport.

SELECT

Places selected objects in the Previous selection set.

TEXTTOFRONT

Brings text and dimensions in front of all other objects in the drawing.

WBLOCK

Writes objects or a block to a new drawing file.

System Variables

DRAWORDERCTL

Controls the default display behavior of overlapping objects when they are
created or edited.

HPDRAWORDER

Controls the draw order of hatches and fills.

SORTENTS

Controls object sorting in support of draw order for several operations.

Utilities

No entries

Command Modifiers

No entries
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Use Precision Tools

You can use a variety of precision drawing tools to help you produce accurate drawings quickly
and without performing tedious calculations.

Use Coordinates and Coordinate Systems (UCS)
For precise coordinate input, you can use several coordinate system entry
methods. You can also use a movable coordinate system, the user coordinate
system (UCS), for convenient coordinate entry and to establish workplanes.

Overview of Coordinate Entry
When a command prompts you for a point, you can use the pointing device to
specify a point, or you can enter a coordinate value at the command prompt.
When dynamic input is on, you can enter coordinate values in tooltips near
the cursor. You can enter two-dimensional coordinates as either Cartesian (X,Y)
or polar coordinates.

Cartesian and Polar Coordinates

A Cartesian coordinate system has three axes, X, Y, and Z. When you enter
coordinate values, you indicate a point's distance (in units) and its direction (+
or -) along the X, Y, and Z axes relative to the coordinate system origin (0,0,0).

In 2D, you specify points on the XY plane, also called the workplane. The
workplane is similar to a flat sheet of grid paper. The X value of a Cartesian
coordinate specifies horizontal distance, and the Y value specifies vertical
distance. The origin point (0,0) indicates where the two axes intersect.

Polar coordinates use a distance and an angle to locate a point. With both
Cartesian and polar coordinates, you can enter absolute coordinates based on
the origin (0,0), or relative coordinates based on the last point specified.
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Another method of entering a relative coordinate is by moving the cursor to
specify a direction and then entering a distance directly. This method is called
direct distance entry.

You can enter coordinates in scientific, decimal, engineering, architectural,
or fractional notation. You can enter angles in grads, radians, surveyor's units,
or degrees, minutes, and seconds. The UNITS command controls unit format.

Display Coordinates on the Status Bar

The current cursor location is displayed as a coordinate value on the status
bar.

There are three types of coordinate display: static, dynamic, and distance and
angle.

■ Static display. Updates only when you specify a point.

■ Dynamic display. Updates as you move the cursor.

■ Distance and angle display. Updates the relative distance (distance<angle)
as you move the cursor. This option is available only when you draw lines
or other objects that prompt for more than one point.

See also:

■ Enter Cartesian Coordinates on page 632

■ Enter Polar Coordinates on page 635

■ Enter 3D Coordinates on page 637

■ Use Dynamic Input on page 668

To display the coordinate values of a point

1 Click Tools tab ➤ Inquiry panel ➤ ID Point. 

2 Select the location you want to identify.

The X,Y,Z coordinate values are displayed at the command prompt.
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Toolbar: Inquiry  
Command entry: ID

To visually locate a point

1 Click Tools tab ➤ Inquiry panel ➤ ID Point. 

2 At the command prompt, enter the coordinate values of the point you
want to locate.

If the BLIPMODE system variable is on, a blip (a small cross) is displayed
at the point location.

Toolbar: Inquiry  
Command entry: ID

To change the coordinate display on the status bar

Use one of the following methods:

■ Click the coordinate display at the Specify Next Point prompt.

■ Press CTRL+L.

■ Set the COORDS system variable to 0 for static display, 1 for dynamic
display, or 2 for distance and angle display.

Quick Reference

Commands

BLIPMODE

Controls the display of marker blips.

ID

Displays the UCS coordinate values of a specified location.

LIST

Displays property data for selected objects.
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System Variables

BLIPMODE

Controls the display of marker blips.

COORDS

Controls the format and update frequency of coordinates on the status line.

LASTPOINT

Stores the last point specified, expressed as UCS coordinates for the current
space.

Utilities

No entries

Command Modifiers

No entries

Enter 2D Coordinates
Absolute and relative 2D Cartesian and polar coordinates determine precise
locations of objects in a drawing.

Enter Cartesian Coordinates
You can use absolute or relative Cartesian (rectangular) coordinates to locate
points when creating objects.

To use Cartesian coordinates to specify a point, enter an X value and a Y value
separated by a comma (X,Y). The X value is the positive or negative distance,
in units, along the horizontal axis. The Y value is the positive or negative
distance, in units, along the vertical axis.

Absolute coordinates are based on the UCS origin (0,0), which is the
intersection of the X and Y axes. Use absolute coordinates when you know the
precise X and Y values of the point.

With dynamic input, you can specify absolute coordinates with the # prefix.
If you enter coordinates on the command line instead of in the tooltip, the
# prefix is not used. For example, entering #3,4 specifies a point 3 units along
the X axis and 4 units along the Y axis from the UCS origin. For more
information about dynamic input, see Use Dynamic Input on page 668.
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The following example draws a line beginning at an X value of -2, a Y value
of 1, and an endpoint at 3,4. Enter the following in the tooltip:

Command: line
From point: #-2,1
To point: #3,4

The line is located as follows:

Relative coordinates are based on the last point entered. Use relative
coordinates when you know the location of a point in relation to the previous
point.

To specify relative coordinates, precede the coordinate values with an @ sign.
For example, entering @3,4 specifies a point 3 units along the X axis and 4
units along the Y axis from the last point specified.

The following example draws the sides of a triangle. The first side is a line
starting at the absolute coordinates -2,1 and ending at a point 5 units in the
X direction and 0 units in the Y direction. The second side is a line starting at
the endpoint of the first line and ending at a point 0 units in the X direction
and 3 units in the Y direction. The final line segment uses relative coordinates
to return to the starting point.

Command: line
From point: #-2,1
To point: @5,0
To point: @0,3
To point: @-5,-3
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To enter absolute Cartesian coordinates (2D)

■ At a prompt for a point, enter coordinates in the tooltip using the following
format:
#x,y

If dynamic input is turned off, enter coordinates on the command line
using the following format:

x,y

To enter relative Cartesian coordinates (2D)

■ At a prompt for a point, enter coordinates using the following format:
@x,y

Quick Reference

Commands

No entries

System Variables

COORDS

Controls the format and update frequency of coordinates on the status line.
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Utilities

No entries

Command Modifiers

No entries

Enter Polar Coordinates
You can use absolute or relative polar coordinates (distance and angle) to
locate points when creating objects.

To use polar coordinates to specify a point, enter a distance and an angle
separated by an angle bracket (<).

By default, angles increase in the counterclockwise direction and decrease in
the clockwise direction. To specify a clockwise direction, enter a negative value
for the angle. For example, entering 1<315 locates the same point as entering
1<-45. You can change the angle conventions for the current drawing with
UNITS.

Absolute polar coordinates are measured from the UCS origin (0,0), which is
the intersection of the X and Y axes. Use absolute polar coordinates when you
know the precise distance and angle coordinates of the point.

With dynamic input, you can specify absolute coordinates with the # prefix.
If you enter coordinates on the command line instead of in the tooltip, the
# prefix is not used. For example, entering #3<45 specifies a point 3 units from
the origin at an angle of 45 degrees from the X axis. For more information
about dynamic input, see Use Dynamic Input on page 668.

The following example shows two lines drawn with absolute polar coordinates
using the default angle direction setting. Enter the following in the tooltip:

Command: line
From point: #0,0
To point: #4<120
To point: #5<30
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Relative coordinates are based on the last point entered. Use relative
coordinates when you know the location of a point in relation to the previous
point.

To specify relative coordinates, precede the coordinate values with an @ sign.
For example, entering @1<45 specifies a point at a distance of 1 unit from the
last point specified at an angle of 45 degrees from the X axis.

The following example shows two lines drawn with relative polar coordinates.
In each illustration, the line begins at the location labeled as the previous
point.

Command: line
From point: @3<45
To point: @5<285

To enter absolute polar coordinates (2D)

■ At a prompt for a point, enter coordinates in the tooltip using the following
format:
#distance<angle

If dynamic input is turned off, enter coordinates on the command line
using the following format:

distance<angle
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To enter relative polar coordinates (2D)

■ At a prompt for a point, enter coordinates using the following format:
@distance<angle

Quick Reference

Commands

UNITS

Controls coordinate and angle display formats and precision.

System Variables

COORDS

Controls the format and update frequency of coordinates on the status line.

Utilities

No entries

Command Modifiers

No entries

Enter 3D Coordinates
Cartesian, cylindrical, or spherical coordinates locate points when you are
creating objects in 3D.

Enter 3D Cartesian Coordinates
3D Cartesian coordinates specify a precise location by using three coordinate
values: X, Y, and Z.

Entering 3D Cartesian coordinate values (X,Y,Z) is similar to entering 2D
coordinate values (X,Y). In addition to specifying X and Y values, you also
specify a Z value using the following format:

X,Y,Z
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NOTE For the following examples, it is assumed that dynamic input is turned off
or that the coordinates are entered on the command line. With dynamic input,
you specify absolute coordinates with the # prefix.

In the illustration below, the coordinate values of 3,2,5 indicates a point 3
units along the positive X axis, 2 units along the positive Y axis, and 5 units
along the positive Z axis.

Use Default Z Values

When you enter coordinates in the format X,Y, the Z value is copied from the
last point you entered. As a result, you can enter one location in the X,Y,Z
format and then enter subsequent locations using the X,Y format with the Z
value remaining constant. For example, if you enter the following coordinates
for a line

From point: 0,0,5
To point: 3,4

both endpoints of the line will have a Z value of 5. When you begin or open
any drawing, the initial default value of Z is greater than 0.

Use Absolute and Relative Coordinates

As with 2D coordinates, you can enter absolute coordinate values, which are
based on the origin, or you can enter relative coordinate values, which are
based on the last point entered. To enter relative coordinates, use the @ sign
as a prefix. For example, use @1,0,0 to enter a point one unit in the positive
X direction from the previous point. To enter absolute coordinates at the
command prompt, no prefix is necessary.
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Digitize Coordinates

When you enter coordinates by digitizing, the UCS Z value for all coordinates
is 0. You can use ELEV to set a default height above or below the Z = 0 plane
for digitizing without moving the UCS.

To enter absolute coordinates (3D)

■ At a prompt for a point, enter coordinates in the tooltip using the following
format:
#x,y,z

If dynamic input is turned off, enter coordinates on the command line
using the following format:

x,y,z

To enter relative coordinates (3D)

■ At a prompt for a point, enter coordinates using the following format:
@x,y,z

Quick Reference

Commands

GRID

Displays a grid pattern in the current viewport.

SNAP

Restricts cursor movement to specified intervals.

TABLET

Calibrates, configures, and turns on and off an attached digitizing tablet.

UCS

Manages user coordinate systems.

UCSICON

Controls the visibility and placement of the UCS icon.

UNITS

Controls coordinate and angle display formats and precision.
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System Variables

COORDS

Controls the format and update frequency of coordinates on the status line.

ELEVATION

Stores the current elevation of new objects relative to the current UCS.

TABMODE

Controls the use of the tablet.

Utilities

No entries

Command Modifiers

No entries

Enter Cylindrical Coordinates
3D cylindrical coordinates describe a precise location by a distance from the
UCS origin in the XY plane, an angle from the X axis in the XY plane, and a Z
value.

Cylindrical coordinate entry is the 3D equivalent of 2D polar coordinate entry.
It specifies an additional coordinate on an axis that is perpendicular to the
XY plane. Cylindrical coordinates define points by a distance in the XY plane
from the UCS origin, an angle from the X axis in the XY plane, and a Z value.
You specify a point using absolute cylindrical coordinates with the following
syntax:

X<[angle from X axis],Z

NOTE For the following examples, it is assumed that dynamic input is turned off
or that the coordinates are entered on the command line. With dynamic input,
you specify absolute coordinates with the # prefix.

In the illustration below, 5<30,6 indicates a point 5 units from the origin of
the current UCS, 30 degrees from the X axis in the XY plane, and 6 units along
the Z axis.
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When you need to define a point based on a previous point rather than the
UCS origin, you can enter relative cylindrical coordinate values with the @
prefix. For example, @4<45,5 specifies a point 4 units in the XY plane from
the last point entered, at an angle of 45 degrees from the positive X direction,
and extending 5 units in the positive Z direction.

To enter relative cylindrical coordinates

■ At a prompt for a point, enter the coordinate values using the following
format:
@x<angle from the X axis,z

For example, @4<60,2 represents a location that is 4 units along the X axis
from the last point measured at 60 degrees from the positive X axis and at 2
units in the positive Z direction.

Quick Reference

Commands

UNITS

Controls coordinate and angle display formats and precision.

System Variables

COORDS

Controls the format and update frequency of coordinates on the status line.

Enter 3D Coordinates | 641



Utilities

No entries

Command Modifiers

No entries

Enter Spherical Coordinates
3D spherical coordinates specify a location by a distance from the origin of
the current UCS, an angle from the X axis in the XY plane, and an angle from
the XY plane.

Spherical coordinate entry in 3D is similar to polar coordinate entry in 2D.
You locate a point by specifying its distance from the origin of the current
UCS, its angle from the X axis (in the XY plane), and its angle from the XY
plane, each angle preceded by an open angle bracket (<) as in the following
format:

X<[angle from X axis]<[angle from XY plane]

NOTE For the following examples, it is assumed that dynamic input is turned off
or that the coordinates are entered on the command line. With dynamic input,
you specify absolute coordinates with the # prefix.

In the following illustration, 8<60<30 indicates a point 8 units from the origin
of the current UCS in the XY plane, 60 degrees from the X axis in the XY plane,
and 30 degrees up the Z axis from the XY plane. 5<45<15 indicates a point 5
units from the origin, 45 degrees from the X axis in the XY plane, and 15
degrees up from the XY plane.
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When you need to define a point based on a previous point, enter the relative
spherical coordinate values by preceding them with the @ sign.

To enter relative spherical coordinates

■ At a prompt for a point, enter the coordinate values using the following
format:
@x<angle from the x axis<angle from the xy plane

For example, @4<60<30 represents a location that is 4 units from the last point
measured at 60 degrees from the positive X axis in the XY plane and at 30
degrees from the XY plane.

Quick Reference

Commands

UNITS

Controls coordinate and angle display formats and precision.

System Variables

COORDS

Controls the format and update frequency of coordinates on the status line.

Utilities

No entries

Command Modifiers

No entries

Understand the User Coordinate System (UCS)
You can relocate and rotate the user coordinate system for convenient
coordinate entry, grid display, grid snap, Ortho mode, and other drawing
tools.
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Understand the World and User Coordinate Systems

There are two coordinate systems: a fixed system called the world coordinate
system (WCS) and a movable system called the user coordinate system (UCS).
By default, these two systems are coincident in a new drawing.

Normally in 2D views, the WCS X axis is horizontal and the Y axis is vertical.
The WCS origin is where the X and Y axes intersect (0,0). All objects in a drawing
file are defined by their WCS coordinates. However, it is usually more
convenient to create and edit objects based on the movable UCS.

Work with the User Coordinate System

Virtually all coordinate entry as well as many other tools and operations
reference the current UCS. 2D tools and operations that depend on the location
and orientation of the UCS include the following:

■ Absolute and relative coordinate entry

■ Absolute reference angles

■ Definition of horizontal and vertical for Ortho mode, polar tracking, object
snap tracking, grid display, and grid snap

■ Orientation of horizontal and vertical dimensions

■ Orientation of text objects

■ View rotation using the PLAN command

644 | Chapter 16   Use Precision Tools



Moving or rotating the UCS can make it easier to work on particular areas of
a drawing.

You can relocate the user coordinate system with methods such as the
following:

■ Move the UCS by defining a new origin point.

■ Align the UCS with an existing object.

■ Rotate the UCS by specifying a new origin point and a point on the new
X axis.

■ Rotate the current UCS a specified angle around the Z axis.

■ Revert to the previous UCS.

■ Restore the UCS to be coincident with the WCS.

Each of these methods have a corresponding option in the UCS command.
Once you have defined a UCS, you can name it and then restore it when you
need to use it again.
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To define a new UCS origin in 2D

1 Click View tab ➤ UCS panel ➤ Origin. 

2 Specify a point for the new origin.

The UCS origin (0,0) is redefined at the point you specify.

Toolbar: UCS  
Command entry: UCS

To change the rotation angle of the UCS

1 Click View tab ➤ UCS panel ➤ Z. 

2 Specify a rotation angle.

Toolbar: UCS  
Command entry: UCS

To restore the UCS to be coincident with the WCS

1 Click View tab ➤ UCS panel ➤ Named UCS.

2 In the UCS dialog box, Named UCSs tab, select World.

3 Click Set Current.

4 Click OK.

Toolbar: UCS II  
Command entry: UCSMAN

To restore the previous UCS

1 Click View tab ➤ UCS panel ➤ Named UCS.

2 In the UCS dialog box, Named UCSs tab, select Previous.
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3 Click Set Current.

4 Click OK.

Toolbar: UCS II  
Command entry: UCSMAN

To save a UCS

1 Click View tab ➤ UCS panel ➤ Named UCS.

The new UCS is displayed in the UCS list as UNNAMED.

2 In the UCS dialog box, Named UCSs tab, select UNNAMED and enter a
new name. (You can also select UNNAMED, and right-click. Click
Rename.)

3 Click OK.

You can use up to 255 characters, including letters, digits, and the special
characters dollar sign ($), hyphen (-), and underscore (_). All UCS names
are converted to uppercase.

Toolbar: UCS II  
Command entry: UCSMAN

To restore a named UCS

1 Click View tab ➤ UCS panel ➤ Named UCS.

2 In the UCS dialog box, Named UCSs tab, you can view the origin and
axis direction of a listed UCS. Select the UCS name. Click Details.

When you have finished viewing the list, click OK to return to the UCS
dialog box.

3 Select the coordinate system you want to restore. Click Set Current.

4 Click OK.

Toolbar: UCS II  
Command entry: UCSMAN
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To rename a UCS

1 Click View tab ➤ UCS panel ➤ Named UCS.

2 In the UCS dialog box, Named UCSs tab, select the coordinate system
you want to rename. (You can also select UNNAMED, and right-click.
Click Rename.)

3 Enter a new name.

4 Click OK.

Toolbar: UCS II  
Command entry: UCSMAN

To delete a named UCS

1 Click View tab ➤ UCS panel ➤ Named UCS.

2 In the UCS dialog box, Named UCSs tab, select the UCS you want to
delete.

3 Press DELETE.

You cannot delete the current UCS or a UCS with the default name
UNNAMED.

Toolbar: UCS II  
Command entry: UCSMAN

Quick Reference

Commands

UCS

Manages user coordinate systems.

UCSICON

Controls the visibility and placement of the UCS icon.

UCSMAN

Manages defined user coordinate systems.
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System Variables

ERRNO

Displays the number of the appropriate error code when an AutoLISP function
call causes an error that AutoCAD detects.

PUCSBASE

Stores the name of the UCS that defines the origin and orientation of
orthographic UCS settings in paper space only.

UCSFOLLOW

Generates a plan view whenever you change from one UCS to another.

UCSNAME

Stores the name of the current coordinate system for the current viewport
in the current space.

UCSORG

Stores the origin point of the current coordinate system for the current
viewport in the current space.

UCSORTHO

Determines whether the related orthographic UCS setting is restored
automatically when an orthographic view is restored.

UCSXDIR

Stores the X direction of the current UCS for the current viewport in the
current space.

UCSYDIR

Stores the Y direction of the current UCS for the current viewport in the
current space.
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Utilities

No entries

Command Modifiers

No entries

Specify Workplanes in 3D (UCS)
Control of the user coordinate system is essential for effective 3D modeling.

Understand the User Coordinate System in 3D
When you work in 3D, the user coordinate system is useful for entering
coordinates, creating 3D objects on 2D workplanes, and rotating objects in
3D.

When you create or modify objects in a 3D environment, you can move and
reorient the UCS in 3D model space to simplify your work. The XY plane of
the UCS is called the workplane.

Important operations on objects in a 3D environment that depend on the
location and orientation of the UCS include the following:

■ Establish the workplane in on which to create and modify objects

■ Establish the workplane that contains the grid display and grid snap

■ Establish a new UCS Z axis about which to rotate objects in 3D

■ Determine up and down directions as well as horizontal and vertical for
Ortho mode, polar tracking, and object snap tracking

■ Define a 3D view directly into the workplane with the PLAN command
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Apply the Right-Hand Rule

Use the right-hand rule to determine the positive axis direction of the Z axis
when you know the direction of the X and Y axes in a 3D coordinate system.
Place the back of your right hand near the screen and point your thumb in
the direction of the positive X axis. Extend your index and middle fingers as
illustrated, pointing your index finger in the direction of the positive Y axis.
Your middle finger indicates the direction of the positive Z axis. By rotating
your hand, you see how the X, Y, and Z axes rotate as you change the UCS.

You can also use the right-hand rule for determining the default positive
direction of rotation about an axis in 3D space. Point your right thumb in the
positive direction of the axis and curl your fingers. Your fingers indicate the
positive rotation direction about the axis.

NOTE By default, when you specify a view in 3D, it is established relative to the
fixed WCS rather than the movable UCS.

To enter coordinates relative to the WCS

■ Precede coordinate values with an asterisk (*).

Entering @*2,0,0 specifies a point two units in the X direction of the last point
entered relative to the WCS. Entering @2,0,0 specifies a point two units in
the X direction of the last point entered relative to the UCS.
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In practice, most coordinates are entered relative to the UCS rather than the
WCS.

To specify a new UCS with three points

1 Click View tab ➤ UCS panel ➤ 3 Point.

2 Specify a new origin point. This is the point (0,0,0) on the new UCS.

3 Specify a point on the positive X axis of the new UCS.

4 Specify a point on the positive XY plane of the new UCS.

UCS  

To rotate the UCS around a major axis

1 Do one of the following:

■ Click View tab ➤ UCS panel ➤ Z. 

■ Click View tab ➤ UCS panel ➤ X. 

■ Click View tab ➤ UCS panel ➤ Y. 

2 Enter a rotation angle. A common rotation angle is 90.

Toolbar: UCS 

Quick Reference

Commands

UCS

Manages user coordinate systems.

UCSICON

Controls the visibility and placement of the UCS icon.
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UCSMAN

Manages defined user coordinate systems.

System Variables

UCSICON

Displays the UCS icon for the current viewport or layout.

UCSVP

Determines whether the UCS in viewports remains fixed or changes to reflect
the UCS of the current viewport.

Utilities

No entries

Command Modifiers

No entries

Control the User Coordinate System in 3D
Several methods are available for manipulating the user coordinate system in
3D. You can also save and restore user coordinate system orientations.

You define a user coordinate system (UCS) to change the location of the 0,0,0
origin point, the location and rotation of the XY plane, and the orientation
of the XY plane or Z axis. You can locate and orient a UCS anywhere in 3D
space, and you can define, save, and recall as many saved UCS locations as
you require.
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If multiple viewports are active, you can assign a different UCS to each
viewport. With the UCSVP system variable turned on, you can lock a UCS to
a viewport, automatically restoring the UCS each time that viewport is made
current.

Define the UCS Location

You can define a UCS in the following ways:

■ Specify a new origin (one point), new X axis (two points), or new XY plane
(three points).

■ Align the UCS by selecting a face on a 3D solid object. The selection can
be on a face or on an edge of the solid.

■ Align the new UCS with an existing object. The origin of the UCS is located
at the vertex nearest to where the object was selected.
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■ Align the new UCS with the current viewing direction.

■ Rotate the current UCS around any of its three major axes.

Specify Workplanes in 3D (UCS) | 655



■ Reorient the XY plane by specifying a new Z axis.

Use UCS Presets

If you do not want to define your own UCS, you can choose from several
preset coordinate systems. The images on the Orthographic UCSs tab of the
(Named) UCS dialog box show the available choices.

Change the Default Elevation

The ELEV command sets the default Z value for new objects above or below
the XY plane of the current UCS. This value is stored in the ELEVATION system
variable.

NOTE Generally, it is recommended that you leave the elevation set to zero and
control the XY plane of the current UCS with the UCS command.
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Change the UCS in Paper Space

You can define a new UCS in paper space just as you can in model space;
however, the UCS in paper space is restricted to 2D manipulation. Although
you can enter 3D coordinates in paper space, you cannot use 3D viewing
commands such as PLAN and VPOINT.

Save and Restore UCS Locations by Name

If you plan to work extensively in 3D, you can save named UCS locations,
each having a different origin and orientation, for various construction
requirements. You can relocate, save, and recall as many UCS orientations as
you require.

To define a new UCS origin in 3D

1 Click View tab ➤ UCS panel ➤ Origin. 

2 Specify a point for the new origin.

The UCS origin (0,0,0) is redefined at the point you specify.

Toolbar: UCS  
Command entry: UCS

To define a new UCS with a specified Z axis

1 Click View tab ➤ UCS panel ➤ Z. 

2 Specify a point for the new origin.

The UCS origin (0,0,0) is redefined at the point you specify.

3 Specify a point that lies on the positive Z axis.

Toolbar: UCS  
Command entry: UCS

Specify Workplanes in 3D (UCS) | 657



To define a new UCS with particular X and Y axes

1 Click View tab ➤ UCS panel ➤ 3 Point. 

2 Specify a point for the new origin.

The UCS origin (0,0,0) is redefined at the point you specify.

3 Specify a point that lies on the positive X axis.

4 Specify a point that lies on the positive Y axis.

Toolbar: UCS  
Command entry: UCS

To shift the XY plane

1 Click View tab ➤ UCS panel ➤ 3 Point. 

2 Specify an origin point for the new UCS (1).

For example, in a large drawing, you might specify an origin point near
the area in which you want to work.

3 Specify a point to indicate the horizontal orientation of the new UCS (2).
This point should be on the positive portion of the new X axis.

4 Specify a point to indicate the vertical orientation of the new UCS (3).
This point should be on the positive portion of the new Y axis.

The UCS, including grid, shifts to represent the X and Y axes you have
specified.

Toolbar: UCS  
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Command entry: UCS

To select a UCS preset

1 Click View tab ➤ UCS panel ➤ Named UCS. 

2 In the UCS dialog box, Orthographic UCSs tab, select a UCS orientation
from the list.

3 Click Set Current.

4 Click OK.

The UCS changes to the selected option.

Toolbar: UCS II  
Command entry: UCSMAN

To restore the location and orientation of the previous UCS

■ Click View tab ➤ UCS panel ➤ Previous. 

The previous UCS is restored.

Toolbar: UCS  
Command entry: UCS

Quick Reference

Commands

ELEV

Sets elevation and extrusion thickness of new objects.

UCS

Manages user coordinate systems.

Specify Workplanes in 3D (UCS) | 659



UCSMAN

Manages defined user coordinate systems.

System Variables

ELEVATION

Stores the current elevation of new objects relative to the current UCS.

UCSVP

Determines whether the UCS in viewports remains fixed or changes to reflect
the UCS of the current viewport.

Utilities

No entries

Command Modifiers

No entries

Use the Dynamic UCS with Solid Models
With the dynamic UCS feature, you can temporarily and automatically align
the XY plane of the UCS with a plane on a solid model while creating objects.

When in a draw command, you align the UCS by moving your pointer over
an edge of a face rather than having to use the UCS command. After you finish
the command, the UCS returns to its previous location and orientation.

For example, you can use the dynamic UCS to create a rectangle on an angled
face of a solid model as shown in the illustration.
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In the illustration on the left, the UCS is not aligned with the angled face.
Instead of relocating the UCS, you turn on the dynamic UCS on the status
bar or by pressing F6.

When you move the pointer completely over an edge as shown in the middle
illustration, the cursor changes to show the direction of the dynamic UCS
axes. You can then create objects on the angled face easily as shown in the
illustration on the right.

NOTE To display the XYZ labels on the cursor, right-click the DUCS button and
click Display Crosshair Labels.

The X axis of the dynamic UCS is located along an edge of the face and the
positive direction of the X axis always points toward the right half of the
screen. Only the front faces of a solid are detected by the dynamic UCS.

The types of commands that can use a dynamic UCS include the following:

■ Simple geometry. Line, polyline, rectangle, arc, circle

■ Text. Text, Multiline text, table

■ References. Insert, xref

■ Solids. Primitives and POLYSOLID

■ Editing. Rotate, mirror, align

■ Other. UCS, area, grip tool manipulation

TIP You can easily align the UCS with a plane on a solid model by turning on the
dynamic UCS feature and then using the UCS command to locate the origin on
that plane.

If Grid and Snap mode are turned on, they align temporarily to the dynamic
UCS. The limits of the grid display are set automatically.

You can temporarily turn off the dynamic UCS by pressing F6 or SHIFT+Z
while moving the pointer over a face.

NOTE The dynamic UCS is available only while a command is active.
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To change the UCS dynamically

1 Start a command supported by dynamic UCS.

2 If necessary, click DUCS on the status bar to turn it on.

3 Move your pointer over the edge of a face on a solid model.

4 Complete the command.

Quick Reference

Commands

OPTIONS

Customizes the program settings.

System Variables

OSOPTIONS

Automatically suppresses object snaps on hatch objects and geometry with
negative Z values when using a dynamic UCS.

UCSDETECT

Controls whether dynamic UCS acquisition is active or not.

Utilities

No entries

Command Modifiers

No entries

Assign User Coordinate System Orientations to Viewports
To facilitate editing objects in different views, you can define a different user
coordinate system orientation for each view.

Multiple viewports provide different views of your model. For example, you
might set up viewports that display top, front, right side, and isometric views.
To facilitate editing objects in different views, you can define a different UCS
for each view. Each time you make a viewport current, you can begin drawing
using the same UCS you used the last time that viewport was current.
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The UCS in each viewport is controlled by the UCSVP system variable. When
UCSVP is set to 1 in a viewport, the UCS last used in that viewport is saved
with the viewport and is restored when the viewport is made current again.
When UCSVP is set to 0 in a viewport, its UCS is always the same as the UCS
in the current viewport.

For example, you might set up three viewports: a top view, front view, and
isometric view. If you set the UCSVP system variable to 0 in the isometric
viewport, you can use the Top UCS in both the top viewport and the isometric
viewport. When you make the top viewport current, the isometric viewport's
UCS reflects the UCS top viewport. Likewise, making the front viewport current
switches the isometric viewport's UCS to match that of the front viewport.

The example is illustrated in the following figures. The first figure shows the
isometric viewport reflecting the UCS of the upper-left, or top, viewport, which
is current.

The second figure shows the change that occurs when the lower-left, or front,
viewport is made current. The UCS in the isometric viewport is updated to
reflect the UCS of the front viewport.
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In previous releases, the UCS was a global setting for all viewports in either
model or paper space. If you want to restore the behavior of previous releases,
you can set the value of the UCSVP system variable to 0 in all active viewports.

Quick Reference

Commands

UCS

Manages user coordinate systems.

System Variables

UCSVP

Determines whether the UCS in viewports remains fixed or changes to reflect
the UCS of the current viewport.
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Utilities

No entries

Command Modifiers

No entries

Control the Display of the User Coordinate System Icon
To help visualize the current orientation of the user coordinate system, you
can display the user coordinate system icon. Several versions of this icon are
available, and you can change its size, location, and color.

To indicate the location and orientation of the UCS, the UCS icon is displayed
either at the UCS origin point or in the lower-left corner of the current
viewport.

You can choose one of three styles of icon to represent the UCS.

Use the UCSICON command to choose between displaying the 2D or the 3D
UCS icon. The shaded UCS icon is displayed for a shaded 3D view. To indicate
the origin and orientation of the UCS, you can display the UCS icon at the
UCS origin point using the UCSICON command.

If the icon is displayed at the origin of the current UCS, a cross (+) appears in
the icon. If the icon is displayed in the lower-left corner of the viewport, no
cross appears in the icon.

If you have multiple viewports, each viewport displays its own UCS icon.

The UCS icon is displayed in various ways to help you visualize the orientation
of the workplane. The following figure shows some of the possible icon
displays.
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You can use the UCSICON command to switch between the 2D UCS icon and
the 3D UCS icon. You can also use the command to change the size, color,
arrowhead type, and icon line width of the 3D UCS icon.

The UCS broken pencil icon replaces the 2D UCS icon when the viewing
direction is in a plane parallel to the UCS XY plane. The broken pencil icon
indicates that the edge of the XY plane is almost perpendicular to your viewing
direction. This icon warns you not to use your pointing device to specify
coordinates.

When you use the pointing device to locate a point, it's normally placed on
the XY plane. If the UCS is rotated so that the Z axis lies in a plane parallel to
the viewing plane—that is, if the XY plane is edge-on to the viewer—it may
be difficult to visualize where the point will be located. In this case, the point
will be located on a plane parallel to your viewing plane that also contains
the UCS origin point. For example, if the viewing direction is along the X axis,
coordinates specified with a pointing device will be located on the YZ plane,
which contains the UCS origin point.

Use the 3D UCS icon to help you visualize which plane these coordinates will
be projected on; the 3D UCS icon does not use a broken pencil icon.

To turn the display of the UCS icon on and off

■ Click View tab ➤ UCS panel ➤ Toggle Icon. 
The check mark indicates whether the icon is on or off.
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Command entry: UCSICON

To display the UCS icon at the UCS origin

■ Click View tab ➤ UCS panel ➤ Origin. 
The UCS icon is displayed at the origin of the current coordinate system.
The check mark indicates whether the option is on or off.

Command entry: UCSICON

To change the appearance of the UCS icon

1 Click View menu  ➤ Display  ➤ UCS Icon  ➤ Properties.

2 In the UCS Icon dialog box, change the settings.

3 Click OK.

Command entry: UCSICON

Quick Reference

Commands

UCSICON

Controls the visibility and placement of the UCS icon.

System Variables

UCSICON

Displays the UCS icon for the current viewport or layout.
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Utilities

No entries

Command Modifiers

No entries

Use Dynamic Input
Dynamic Input provides a command interface near the cursor to help you
keep your focus in the drafting area.

When dynamic input is on, tooltips display information near the cursor that
is dynamically updated as the cursor moves. When a command is active, the
tooltips provide a place for user entry.

After you type a value in an input field and press TAB, the field then displays
a lock icon, and the cursor is constrained by the value that you entered. You
can then enter a value for the second input field. Alternately, if you type a
value and press ENTER, the second input field is ignored and the value is
interpreted as direct distance entry.

The actions required to complete a command or to use grips are similar to
those for the command prompt. The difference is that your attention can stay
near the cursor.

Dynamic input is not designed to replace the command window. You can
hide the command window to add screen area for drawing, but you will need
to display it for some operations. Press F2 to hide and display command
prompts and error messages as needed. Alternately, you can undock the
command window and use Auto-hide to roll open or roll up the window.

Turn On or Turn Off Dynamic Input

Click the dynamic input button  on the status bar to turn dynamic
input on and off. You can turn it off temporarily by holding down the F12
key. Dynamic input has three components: pointer input, dimensional input,

and dynamic prompts. Right-click  and click Settings to control what
is displayed by each component when dynamic input is on.
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Pointer Input

When pointer input is on and a command is active, the location of the
crosshairs is displayed as coordinates in a tooltip near the cursor. You can
enter coordinate values in the tooltip instead of on the command line.

The default for second and subsequent points is relative polar coordinates
(relative Cartesian for RECTANG). There is no need to type the at sign (@). If
you want to use absolute coordinates, use the pound sign (#) prefix. For
example, to move an object to the origin, for the second point prompt, enter
#0,0.

Use the pointer input settings to change the default format for coordinates
and to control when pointer input tooltips are displayed.

Dimensional Input

When dimensional input is on, the tooltips display distance and angle values
when a command prompts for a second point. The values in the dimensional
tooltips change as you move the cursor. Press TAB to move to the value you
want to change. Dimensional input is available for ARC, CIRCLE, ELLIPSE,
LINE, and PLINE.

When you use grips to edit an object, the dimensional input tooltips can
display the following information:

■ Original length

■ A length that updates as you move the grip

■ The change in the length

■ Angle

■ The change in the angle as you move the grip
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■ The radius of an arc

Use the dimensional input settings to display only the information you want
to see.

When you use grips to stretch objects or when you create new objects,
dimensional input displays only acute angles, that is, all angles are displayed
as 180 degrees or less. Thus, an angle of 270 degrees is displayed as 90 degrees
regardless of the ANGDIR system variable setting (set in the Drawing Units
dialog box). Angles specified when creating new objects rely on the cursor
location to determine the positive angle direction.

Dynamic Prompts

When dynamic prompts are on, prompts are displayed in a tooltip near the
cursor. You can enter a response in the tooltip instead of on the command
line. Press the DOWN ARROW key to view and select options. Press the UP
ARROW key to display recent input.

NOTE To use PASTECLIP in a dynamic prompt tooltip, type a letter and then
backspace to delete it before you paste the entry. Otherwise, the entry is pasted
into the drawing as text.

To enter coordinate values in dynamic input tooltips

1 On the status bar, verify that the dynamic input button  is on.
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2 Use one of the following methods to enter coordinate values or select
options:

■ To enter polar coordinates, enter the distance from the first point and
press TAB, and then enter an angle value and press ENTER.

■ To enter Cartesian coordinates, enter an X coordinate value and a
comma (,), and then enter a Y coordinate value and press ENTER.

■ If a down-arrow icon follows the prompt, press the DOWN ARROW
key until a dot is displayed next to the option. Press ENTER.

■ Press the UP ARROW key to access recent coordinates, or right-click
and click Recent Input to access the coordinates from a shortcut menu.

NOTE For dimensional input, after you type a value in an input field and press
TAB, the field then displays a lock icon, and the cursor is constrained by the value
that you entered.

To correct typing errors in dynamic input tooltips

■ When a dynamic input tooltip displays the red error outline, the current
entry is selected. Type over the selected text to replace it. You can also use
the RIGHT ARROW, LEFT ARROW, BACKSPACE, and DELETE keys to
correct your entry. After you make the correction, press TAB, comma (,),
or a left angle bracket (<) to remove the red outline and complete the
coordinates.

■ If you type the @ or # or * prefixes in a pointer input tooltip and then want
to change it, you can just type the character you want. There is no need
to backspace.

To specify relative or absolute coordinates in pointer input tooltips

■ To enter absolute coordinates when relative coordinates are displayed in
the tooltip, enter # to temporarily override the DYNPICOORDS system
variable.

■ To enter relative coordinates when absolute coordinates are displayed,
enter @ to temporarily override the DYNPICOORDS system variable.

■ To enter absolute world coordinate system (WCS) coordinates, enter *.

NOTE During pointer input, you can use the shortcut menu to access the # and
* prefixes.
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To choose options in dynamic prompt tooltips

1 Start a command.

Tooltips near the crosshairs display the coordinates of the cursor location
and a prompt.

2 If a prompt is displayed, press the DOWN ARROW key to display the
options.

3 Press DOWN ARROW or UP ARROW to place a dot next to the option
you want. Press ENTER.

Press ESC to undo the most recent action.

4 Specify points and enter options to complete the command.

To change the color, size, or transparency of tooltips

1 Right-click the dynamic input button  on the status bar. Click
Settings.

2 In the Drafting Settings dialog box, Dynamic Input tab, click Drafting
Tooltip Appearance.

3 In the Tooltip Appearance dialog box, under Color, click Model Color or
Layout Color to display the Select Color dialog box, where you can specify
a color for tooltips in the space you selected.

4 Under Size, move the slider to the right to make tooltips larger or to the
left to make them smaller. The default value, 0, is in the middle.

5 Under Transparency, move the slider. The lower the setting, the more
transparent the tooltip. A value of 100 sets the tooltip to opaque.

6 Under Apply To, choose an option:

■ Override OS Settings for All Drafting Tooltips. Applies the settings to
all tooltips, overriding the settings in the operating system.

■ Use Settings Only for Dynamic Input Tooltips. Applies the settings
only to the drafting tooltips used in dynamic input.

7 Click OK.

Command entry: DYNTOOLTIPS
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To merge the information in all drafting tooltips into one tooltip

■ At the command prompt, enter tooltipmerge.

Tooltips that display drafting information are merged into one.

To turn on or turn off dynamic input

■ On the status bar, click the dynamic input button  , or press F12.

To turn off dynamic input temporarily, hold down the F12 key while you
work.

NOTE The F12 temporary override key does not turn on dynamic input.

To change dynamic input settings

1 Right-click the dynamic input button  on the status bar. Click
Settings.

2 Change the dynamic input settings as needed.

3 Click OK to close each dialog box.

Command entry: DSETTINGS

To change pointer input settings

1 Right-click the dynamic input button  on the status bar. Click
Settings.

2 In the Drafting Settings dialog box, Dynamic Input tab, under Pointer
Input, click Settings.

3 In the Pointer Input Settings dialog box, select polar or Cartesian format
as the default.

4 Select relative or absolute coordinate format as the default.
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5 Under Visibility, select one of the following options:

■ As Soon As I Type Coordinate Data. When pointer input is turned
on, displays tooltips only when you start to enter coordinate data.

■ When a Command Asks for a Point. When pointer input is turned on,
displays tooltips whenever a command prompts for a point.

■ Always—Even When Not in a Command. Always displays tooltips
when pointer input is turned on.

6 Click OK to close each dialog box.

Command entry: DSETTINGS

To change dimensional input settings

1 Right-click the dynamic input button  on the status bar. Click
Settings.

2 In the Drafting Settings dialog box, Dynamic Input tab, under Dimension
Input, click Settings.

3 In the Dimension Input Settings dialog box, select Polar or Cartesian
format as the default.

4 Under Visibility, select one of the following options:

■ Show Only 1 Dimension Input Field at a Time. Displays only the
distance dimensional input tooltip when you are using grip editing
to stretch an object.

■ Show 2 Dimension Input Fields at a Time. Displays the distance and
angle dimensional input tooltips when you are using grip editing to
stretch an object.

■ Show the Following Dimension Input Fields Simultaneously. Displays
the selected dimensional input tooltips when you are using grip editing
to stretch an object. Select one or more of the check boxes.

5 Click OK to close each dialog box.

Command entry: DSETTINGS
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To display prompts in tooltips

1 Right-click the dynamic input button  on the status bar. Click
Settings.

2 In the Drafting Settings dialog box, Dynamic Input tab, under Dynamic
Prompts, check Show Command Prompting and Command Input Near
the Crosshairs.

3 Click OK.

Command entry: DSETTINGS

Quick Reference

Commands

DSETTINGS

Sets grid and snap, polar and object snap tracking, object snap modes,
Dynamic Input, and Quick Properties.

System Variables

DYNDIGRIP

Controls which dynamic dimensions are displayed during grip stretch editing.

DYNDIVIS

Controls how many dynamic dimensions are displayed during grip stretch
editing.

DYNMODE

Turns Dynamic Input features on and off.

DYNPICOORDS

Controls whether pointer input uses relative or absolute format for
coordinates.

DYNPIFORMAT

Controls whether pointer input uses polar or Cartesian format for coordinates.
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DYNPIVIS

Controls when pointer input is displayed.

DYNPROMPT

Controls display of prompts in Dynamic Input tooltips.

DYNTOOLTIPS

Controls which tooltips are affected by tooltip appearance settings.

TEMPOVERRIDES

Turns temporary override keys on and off.

TOOLTIPMERGE

Combines drafting tooltips into a single tooltip.

Utilities

No entries

Command Modifiers

No entries

Snap to Locations on Objects (Object Snaps)
Instead of entering coordinates, you can specify points relative to existing
objects such as endpoints of lines or center points of circles.

Use Object Snaps
Use object snaps to specify precise locations on objects. For example, you can
use an object snap to draw a line to the center of a circle or to the midpoint
of a polyline segment.

You can specify an object snap whenever you are prompted for a point. By
default, a marker and a tooltip are displayed when you move the cursor over
an object snap location on an object. This feature, called AutoSnap™, provides
a visual clue that indicates which object snaps are in effect.
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For a list of object snaps, see OSNAP.

Specify an Object Snap

To specify an object snap at a prompt for a point, you can

■ Press SHIFT and right-click to display the Object Snap shortcut menu

■ Click an object snap button on the Object Snap toolbar

■ Enter the name of an object snap at the command prompt

■ On the status bar, right-click the object snap button

When you specify an object snap at a prompt for a point, the object snap stays
in effect only for the next point that you specify.

NOTE Object snaps work only when you are prompted for a point. If you try to
use an object snap at the command prompt, an error message is displayed.

Use Running Object Snaps

If you need to use one or more object snaps repeatedly, you can turn on running
object snaps. For example, you might set Center as a running object snap if
you need to connect the centers of a series of circles with a line.

You can specify one or more running object snaps on the Object Snaps tab in
the Drafting Settings dialog box, which is accessible from the Tools menu. If
several running object snaps are on, more than one object snap may be eligible
at a given location. Press TAB to cycle through the possibilities before you
specify the point.

Click the OSNAP button on the status bar or press F3 to turn running object
snaps on and off.

NOTE If you want object snaps to ignore hatch objects, set the OSOPTIONS
system variable to 1.
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Use Object Snaps in 3D

By default, the Z-value of an object snap location is determined by the object's
location in space. However, if you work with object snaps on the plan view
of a building or the top view of a part, a constant Z-value is more useful.

If you turn on the OSNAPZ system variable, all object snaps are projected onto
the XY plane of the current UCS or, if ELEV is set to a non-zero value, onto a
plane parallel to XY plane at the specified elevation.

NOTE When you draw or modify objects, make sure that you know whether
OSNAPZ is on or off. There is no visual reminder, and you can get unexpected
results.

To snap to a geometric point on an object

1 At the prompt for a point, hold down SHIFT and right-click in the drawing
area. Select the object snap you want to use.

2 Move your cursor over the desired object snap location.

If AutoSnap is on, your cursor automatically locks onto the snap location
you selected, and a marker and tooltip indicate the object snap point.

3 Select an object.

The cursor snaps to the eligible location closest to your selection.

To set running object snaps

1 Click Tools menu  ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Object Snap tab, select the object
snaps you want to use.

3 Click OK.

Command entry: OSNAP

Shortcut menu: Right-click the OSNAP button  on the status bar.
Click Settings.

To turn on and turn off running object snaps as you work

■ On the status bar, click Osnap  , or press F3.
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If running object snaps have been set, the settings are turned on or off.

To turn running object snaps on and off temporarily, hold down the F3 key
while you work.

Command entry: OSNAP

To set object snaps to ignore hatch objects

1 At the command prompt, enter osoptions.

2 Enter 1.

Quick Reference

Commands

APERTURE

Sets the display size for the object snap target box, in pixels.

OPTIONS

Customizes the program settings.

OSNAP

Sets running object snap modes.

System Variables

APBOX

Turns the display of the AutoSnap aperture box on or off.

AUTOSNAP

Controls the display of the AutoSnap marker, tooltip, and magnet.

OSMODE

Sets running object snaps

OSNAPZ

Controls whether object snaps are automatically projected onto a plane
parallel to the XY plane of the current UCS at the current elevation.
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OSNAPCOORD

Controls whether coordinates entered on the command line will override
running object snaps.

OSOPTIONS

Automatically suppresses object snaps on hatch objects and geometry with
negative Z values when using a dynamic UCS.

Utilities

No entries

Command Modifiers

MTP (Command Modifier)

Locates the midpoint between two points.

The Object Snap Menu
Specify an object snap quickly and conveniently from a shortcut menu.

The object snap menu is displayed at your cursor location when you hold
down SHIFT and click the right mouse button or the equivalent button on
another pointing device.

The default object snap menu lists object snaps and tracking options. If you
want to change the options, you can modify a customization file. The main
customization file that’s shipped with the product is acad.cuix.

See also:

■ “Pull-down and Shortcut Menus” in the Customization Guide

■ Use Object Snaps on page 676

To display the object snap menu

1 Enter any command that prompts you to specify a point. For example,
enter line.

2 At the From Point prompt, hold down SHIFT and right-click.

The object snap menu is displayed, and you can click an object snap
option.
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Shortcut menu: On the status bar, right-click the object snap button 
. Click Settings.

Quick Reference

Commands

OSNAP

Sets running object snap modes.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set Visual Aids for Object Snaps (AutoSnap)
Object snaps include a visual aid called AutoSnap™ to help you see and use
object snaps more efficiently. AutoSnap displays a marker and a tooltip when
you move your cursor over an object snap location.

AutoSnap Tools

AutoSnap consists of the following snap tools:

■ Marker. Displays the object snap location when the cursor moves over or
near an object. Marker shape is dependent on the snap it is marking.

■ Tooltip. Describes which part of the object you are snapping to in a small
flag at the cursor location.

■ Magnet. Attracts and locks the cursor onto the nearest detected snap points.
Provides a visual cue, similar to snapping to a grid.
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■ Aperture box. Surrounds the crosshairs and defines an area within which
object snaps are evaluated. You can choose to display or not display the
aperture box, and you can change the aperture box size.

The AutoSnap markers, tooltips, and magnet are turned on by default. You
can change AutoSnap settings on the Drafting tab in the Options dialog box.

Use AutoSnap to Confirm or Change an Object Snap

If you have set more than one running object snap, you can press TAB to cycle
through all the object snap points available for a particular object.

To change the AutoSnap settings

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Drafting tab, change settings as needed:

■ Marker. Turns the marker on or off.

■ Magnet. Turns the magnet on or off.

■ Display AutoSnap Tooltip. Turns tooltips on or off.

■ Display AutoSnap Aperture Box. Turns the target box on or off when
you specify an object snap. This setting does not affect object snaps
when you are not using AutoSnap.

■ AutoSnap Marker Color. Changes the color of the marker.

■ AutoSnap Marker Size. Adjusts the size of the marker.

3 Click OK.

Command entry: OPTIONS

Quick Reference

Commands

APERTURE

Sets the display size for the object snap target box, in pixels.
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OPTIONS

Customizes the program settings.

OSNAP

Sets running object snap modes.

System Variables

APBOX

Turns the display of the AutoSnap aperture box on or off.

AUTOSNAP

Controls the display of the AutoSnap marker, tooltip, and magnet.

OSMODE

Sets running object snaps

Utilities

No entries

Command Modifiers

No entries

Override Object Snap Settings
While you work, you can turn running object snaps on and off temporarily
by using an override key. Temporary override keys can also be used for other
drawing aids; for example, Ortho mode and Polar mode.

For example, if you have set running object snaps but you want to turn them
off for one point, you can hold down F3. When you release this override key,
running object snaps are restored.

There are also temporary override keys for individual object snaps. Override
keys are set up to be easy to find by touch without looking away from your
drawing.

The keys in the following illustration are the default keys, but you can change
key assignments and add your own as needed.

Hold down SHIFT and one of the temporary override keys in the illustration:
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Turns off all snapping and tracking5Object snap override: Endpoint1

Object snap override: Center6Enforces object snap selection2

Object snap override: Midpoint7Toggles object snap tracking3

Toggles object snap mode (OSNAP)4

Temporary override keys are also available for the other drawing aids that you
set in the Drafting Settings dialog box.

See also:

■ “Adjust Grid and Grid Snap”

■ “Use Orthogonal Locking (Ortho Mode)”

■ “Use Polar Tracking and PolarSnap”

■ “Use Dynamic Input”
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■ Keyboard Shortcuts in the Customization Guide

To temporarily override the running object snap settings

■ Hold down F3 while you work.
When you release the key, the current running object snap settings are
restored.

To change the keyboard response time for temporary override keys

1 In the Windows Control Panel, click Keyboard.

2 In the Keyboard Properties dialog box, on the Speed tab, drag the Repeat
Rate slider to adjust the keyboard response time. Then click OK.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

CUSTOMIZE

Customizes tool palettes and tool palette groups.

OPTIONS

Customizes the program settings.

OSNAP

Sets running object snap modes.

System Variables

OSMODE

Sets running object snaps

TEMPOVERRIDES

Turns temporary override keys on and off.
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Utilities

No entries

Command Modifiers

No entries

Restrict Cursor Movement
Several tools are available that you can use to restrict or lock the movement
of your cursor.

Adjust Grid and Grid Snap
To enhance drawing speed and efficiency, you can display and snap to a
rectangular grid. You can also control its spacing, angle, and alignment.

The grid is a rectangular pattern of dots or lines that extends over the area
you specify as the grid limits. Using the grid is similar to placing a sheet of
grid paper under a drawing. The grid helps you align objects and visualize the
distances between them. The grid is not plotted.

Snap mode restricts the movement of the crosshairs to intervals that you
define. When Snap mode is on, the cursor seems to adhere, or "snap," to an
invisible rectangular grid. Snap is useful for specifying precise points with the
arrow keys or the pointing device.

Grid mode and Snap mode are independent but are often turned on at the
same time.

Control the Display Style and Area of the Grid

You can display the grid either as a rectangular pattern of dots or as rectangular
pattern of lines. The grid displays dots only when the current visual style is
set to 2D Wireframe, otherwise the grid displays lines. A lined grid is displayed
for all visual styles while working in 3D. There are several methods to change
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the current visual style, including the VSCURRENT command.

By default, the X and Y axes of the UCS display in a different color than the
grid lines. You can control the color in the Drawing Window Colors dialog
box. This dialog box is accessible from the Drafting tab in the Options dialog
box.

The LIMITS command controls the drawing area covered by the grid. As an
option, you can override the limits to make the grid cover the entire XY plane
of the user coordinate system (UCS). You can access this option in the Drafting
Settings dialog box or use the GRIDDISPLAY system variable.

NOTE When you use dynamic UCS, the grid limits are set automatically relative
to the size of the selected face of the solid and the drawing area available.

Control the Frequency of Major Grid Lines

If the grid is displayed as lines rather than dots, darker lines called major grid
lines display at intervals. When working in decimal units or with feet and
inches, major grid lines are especially useful for measuring distances quickly.
You can control the frequency of major grid lines in the Drafting Settings
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dialog box.

To turn off the display of major grid lines, set the frequency of major grid
lines to 1.

NOTE If the grid is displayed as lines, the grid limits are displayed also as darker
lines. Do not confuse these boundaries with major grid lines.

NOTE When the grid is displayed as lines and SNAPANG is set to a value other
than 0, the grid will not display. SNAPANG does not affect the display of the dotted
grid.

Change the Grid Dynamically During Zooming

If you zoom in or out of your drawing, the grid spacing is adjusted
automatically to be more appropriate for the new magnification. This is called
adaptive grid display.

For example, if you zoom way out, the density of displayed grid lines reduces
automatically. Conversely, if you zoom way in, additional grid lines display
in the same proportion as the major grid lines.
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Change Grid and Snap Spacing

As you work, you can turn Grid and Snap mode on and off, and you can
change the grid and snap spacing. You can turn Snap mode on and off
temporarily by using an override key.

Snap spacing does not have to match grid spacing. For example, you might
set a wide grid spacing to be used as a reference but maintain a closer snap
spacing for accuracy in specifying points.

Change the Grid and Snap Angle and Base

If you need to draw along a specific alignment or angle, you can change the
grid and snap angle by rotating the user coordinate system (UCS). This rotation
realigns the crosshairs on the screen to match the new angle. In the following
example, the UCS is rotated 30 degrees to match the angle of the anchor
bracket.

The grid and snap points are always aligned with the UCS origin. If you need
to shift the grid and grid snap origin, move the UCS.

See also:

■ “Set Isometric Grid and Snap”

■ Override Object Snap Settings on page 683

■ Use a Visual Style to Display Your Model on page 293

To display a grid and set grid spacing

1 Click Tools menu  ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Snap and Grid tab, select Grid On to
display the grid.

3 Under Snap Type, make sure Grid Snap and Rectangular Snap are selected.
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4 For Grid X Spacing, enter the horizontal grid spacing in units.

5 To use the same value for vertical grid spacing, press ENTER. Otherwise,
enter a new value for Grid Y Spacing.

6 Click OK.

Command entry: DSETTINGS

Shortcut menu: On the status bar, right-click the snap button  . Click
Settings.

To turn on Snap mode and set snap spacing

1 Click Tools menu  ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Snap and Grid tab, select Snap On.

3 Under Snap Type, make sure Grid Snap and Rectangular Snap are selected.

4 In the Snap X Spacing box, enter the horizontal snap spacing value in
units.

5 To specify the same vertical snap spacing, press ENTER. Otherwise, enter
a new distance in the Snap Y Spacing box.

6 Click OK.

Command entry: DSETTINGS

Shortcut menu: On the status bar, right-click the snap button  . Click
Settings.

To set the grid limits

1 Click Format menu  ➤ Drawing Limits.

2 At the command prompt, enter the coordinate values for a point at the
lower left corner of the grid limits.

3 Enter the coordinate values for a point at the upper right corner of the
grid limits.

The grid limits are set to a rectangular area defined by the two points.

Command entry: LIMITS
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To temporarily override Snap mode

■ Hold down F9 while you work.
When you release the key, Snap mode is restored.

To rotate the grid and snap angle and change the base point

1 Click View tab ➤ UCS panel ➤ Z. 

2 Enter the rotation angle for the UCS.

3 Click View tab ➤ UCS panel ➤ Origin. 

4 Specify a new origin point for the UCS.

5 Click OK.

Command entry: UCS

To change the grid display between dots and lines

1 At the command prompt, enter VSCURRENT.

2 Do one of the following:

■ To display the grid as dots, specify the 2D Wireframe option.

■ To display the grid as lines, specify any other option.

Command entry: VSCURRENT

To change the frequency of major grid lines

1 If necessary, at the command prompt, enter VSCURRENT and specify
any visual style other than 2D Wireframe.

2 Click Tools menu  ➤ Drafting Settings.

3 In the Drafting Settings dialog box, Snap and Grid tab, specify a number
for Major Line Every.

4 Click OK.

Command entry: VSCURRENT
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Shortcut menu: On the status bar, right-click the snap button  . Click
Settings.

Quick Reference

Commands

DSETTINGS

Sets grid and snap, polar and object snap tracking, object snap modes,
Dynamic Input, and Quick Properties.

GRID

Displays a grid pattern in the current viewport.

LIMITS

Sets and controls the limits of the grid display in the current Model or layout
tab.

SHADEMODE

Starts the VSCURRENT command.

SNAP

Restricts cursor movement to specified intervals.

System Variables

GRIDDISPLAY

Controls the display behavior and display limits of the grid.

GRIDMODE

Specifies whether the grid is turned on or off.

GRIDMAJOR

Controls the frequency of major grid lines compared to minor grid lines.

GRIDUNIT

Specifies the grid spacing (X and Y) for the current viewport.

LIMCHECK

Controls the creation of objects outside the grid limits.
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LIMMAX

Stores the upper-right grid limits for the current space, expressed as world
coordinates.

LIMMIN

Stores the lower-left grid limits for the current space, expressed as a world
coordinate.

SNAPANG

Sets the snap and grid rotation angle for the current viewport relative to the
current UCS.

SNAPBASE

Sets the snap and grid origin point for the current viewport relative to the
current UCS.

SNAPMODE

Turns the Snap mode on and off.

SNAPTYPE

Sets the type of snap for the current viewport.

SNAPUNIT

Sets the snap spacing for the current viewport.

TEMPOVERRIDES

Turns temporary override keys on and off.

Utilities

No entries

Command Modifiers

No entries

Use Orthogonal Locking (Ortho Mode)
You can restrict cursor movement to horizontal and vertical for convenience
and precision when creating and modifying objects.
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As you create or move objects, you can use Ortho mode to restrict the cursor
to the horizontal or vertical axis. As you move the cursor, the rubber-band
line follows the horizontal or vertical axis, whichever is nearest the cursor.

The orientation of the current user coordinate system (UCS) determines the
horizontal and vertical directions. In 3D views, Ortho mode additionally
restricts the cursor to the up and down directions. In that case, the tooltip
displays a +Z or -Z for the angle.

TIP Use direct distance entry with Ortho mode turned on to create orthogonal
lines of specified lengths or to move objects specified distances.

You can turn Ortho on and off at any time during drawing and editing. Ortho
is ignored when you enter coordinates or specify an object snap. To turn Ortho
on or off temporarily, hold down the temporary override key, SHIFT. While
you use the temporary override key, the direct distance entry method is not
available.

For drawing or editing objects at angles that are not parallel to the horizontal
or vertical axis, see Use Polar Tracking and PolarSnap on page 695.

If turned on, the isometric snap setting takes priority over the UCS in
determining horizontal and vertical directions.

NOTE Ortho mode and polar tracking cannot be on at the same time. Turning
on Ortho turns off polar tracking.

See also:

■ Override Object Snap Settings on page 683

To turn on or turn off Ortho mode

■ On the status bar, click the Ortho button .
To turn Ortho on or off temporarily, hold down the SHIFT key while you
work. While you use the temporary override key, the direct distance entry
method is not available.

NOTE Turning on Ortho automatically turns off polar tracking.

Command entry: ORTHO
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Quick Reference

Commands

ORTHO

Constrains cursor movement to the horizontal or vertical direction.

System Variables

ORTHOMODE

Constrains cursor movement to the perpendicular.

TEMPOVERRIDES

Turns temporary override keys on and off.

Utilities

No entries

Command Modifiers

No entries

Use Polar Tracking and PolarSnap
Polar tracking restricts cursor movement to specified angles. PolarSnap restricts
cursor movement to specified increments along a polar angle.

When you are creating or modifying objects, you can use polar tracking to
display temporary alignment paths defined by the polar angles you specify.
In 3D views, polar tracking additionally provides an alignment path in the
up and down directions. In that case, the tooltip displays a +Z or -Z for the
angle.

Polar angles are relative to the orientation of the current user coordinate
system (UCS) and the setting for the base angle convention in a drawing. The
angle base direction is set in the Drawing Units dialog box.

Use PolarSnap™ to snap to specified distances along the alignment path. For
example, in the following illustration you draw a two-unit line from point 1
to point 2, and then draw a two-unit line to point 3 at a 45-degree angle to
the line. If you turn on the 45-degree polar angle increment, an alignment
path and tooltip are displayed when your cursor crosses the 0 or 45-degree
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angle. The alignment path and tooltip disappear when you move the cursor
away from the angle.

As you move your cursor, alignment paths and tooltips are displayed when
you move the cursor near polar angles. The default angle measurement is 90
degrees. Use the alignment path and tooltip to draw your object. You can use
polar tracking with Intersection and Apparent Intersection object snaps to
find where a polar alignment path intersects another object.

NOTE Ortho mode and polar tracking cannot be on at the same time. Turning
on polar tracking turns off Ortho mode. Similarly, PolarSnap and grid snap cannot
be on at the same time. Turning on PolarSnap turns off grid snap.

Specify Polar Angles (Polar Tracking)

You can use polar tracking to track along polar angle increments of 90, 60,
45, 30, 22.5, 18, 15, 10, and 5 degrees, or you can specify other angles. The
following illustration shows the alignment paths displayed as you move your
cursor 90 degrees with the polar angle increment set to 30 degrees.

The orientation of 0 depends on the angle you set in the Drawing Units dialog
box (UNITS). The direction of snap (clockwise or counterclockwise) depends
on the units direction you specify when setting units of measurement.

You can turn polar tracking on and off temporarily by using an override key.
The direct distance entry method is not available while you are using the
temporary override key for polar tracking.
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Specify Polar Distances (PolarSnap)

PolarSnap restricts cursor movement to increments of a polar distance you
specify. For example, if you specify a length of 4 units, the cursor snaps from
the first point specified to lengths of 0, 4, 8, 12, 16, and so on. As you move
your cursor, a tooltip indicates the nearest PolarSnap increment. To restrict
point entry to polar distances, both polar tracking and Snap mode (set to
PolarSnap) must be on. You can turn off all snapping and tracking temporarily
by using an override key.

See also:

■ Override Object Snap Settings on page 683

To turn on and turn off polar tracking

■ Press F10, or click the polar button  on the status bar.
To turn polar tracking on or off temporarily, hold down the F10 key while
you work.

To set polar snap distance

1 Click Tools menu  ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Snap and Grid tab, select Snap On.

3 In Snap Type, select PolarSnap.

4 Under Polar Spacing, enter the polar distance.

5 On the Polar Tracking tab, select Polar Tracking On.

6 Select the angle from the Increment Angle list.

You can specify your own angles by choosing Additional Angles and then
New.

7 Click OK.

Command entry: DSETTINGS

Shortcut menu: On the status bar, right-click  .
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To draw objects using polar tracking

1 Turn on polar tracking and start a drawing command, such as ARC,
CIRCLE, or LINE.

You can also use polar tracking with editing commands, such as COPY
and MOVE.

2 As you move your cursor to specify points, notice the dotted polar tracking
line that appears at the tracking angles you specified. Points you specify
while the line is displayed conform to the polar tracking angle.

Command entry: DSETTINGS

To draw objects using polar distance

1 Turn on snap and polar tracking.

Make sure Polar Snap is selected in the Drafting Settings dialog box, Snap
& Grid tab.

2 Start a drawing command, such as LINE.

3 As you move your cursor, notice that the dotted polar tracking line
displays a tooltip that shows distance and angle.

4 Specify a point.

The length of the new line conforms to the polar distance.

Command entry: DSETTINGS

To set polar tracking angles

1 Click Tools menu  ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Polar Tracking tab, select Polar
Tracking On.

3 In the Increment Angle list, select the polar tracking angle.

4 To set additional tracking angles, select Additional Angles. Click New.
Enter the angle value in the text box.

5 Under Polar Angle Measurement, specify whether polar tracking
increments are based on the UCS or relative to the last object you created.

6 Click OK.
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Command entry: DSETTINGS

On the status bar, right-click  . Click an available angle or Settings to
set additional tracking angles.

Quick Reference

Commands

DSETTINGS

Sets grid and snap, polar and object snap tracking, object snap modes,
Dynamic Input, and Quick Properties.

SNAP

Restricts cursor movement to specified intervals.

UNITS

Controls coordinate and angle display formats and precision.

System Variables

ANGBASE

Sets the base angle to 0 with respect to the current UCS.

ANGDIR

Sets the direction of positive angles.

AUTOSNAP

Controls the display of the AutoSnap marker, tooltip, and magnet.

POLARANG

Sets the polar angle increment.

POLARDIST

Sets the snap increment when the SNAPTYPE is set to 1 (PolarSnap).

POLARMODE

Controls settings for polar and object snap tracking.

SNAPTYPE

Sets the type of snap for the current viewport.
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TEMPOVERRIDES

Turns temporary override keys on and off.

TRACKPATH

Controls the display of polar and object snap tracking alignment paths.

Utilities

No entries

Command Modifiers

No entries

Lock an Angle for One Point (Angle)
You can specify an angle override that locks the cursor for the next point
entered.

To specify an angle override, enter a left angle bracket (<) followed by an angle
whenever a command asks you to specify a point. The command prompt
sequence below shows a 30-degree override entered during a LINE command.

Command: line
Specify first point: Specify a start point for the line
Specify next point or [Undo]: <30
Angle Override: 30
Specify next point or [Undo]: Specify a point

The angle you specify will lock the cursor, overriding Grid Snap, Ortho mode,
and PolarSnap. Coordinate entry and object snaps have precedence over an
angle override.
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Quick Reference

Commands

No entries

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Combine or Offset Points and Coordinates
To specify a new point location, you can combine coordinate values from
several points or you can specify offsets from existing objects.

Combine Coordinate Values (Coordinate Filters)
You can use coordinate filters to extract one coordinate value at a time from
locations on existing objects.

Coordinate filters specify a new coordinate location by using the X value from
one location, the Y value of a second location, and, for 3D coordinates, the Z
value of a third location. When used with object snaps, coordinate filters
extract coordinate values from an existing object.

Coordinate filters are commonly used to locate the center of a rectangle and
to locate the projection of a 3D point on the XY plane of the UCS.

To specify a filter at the command prompt, enter a period and one or more
of the letters X, Y, and Z. The next entry is limited to a specific coordinate
value.

Example: Use of Coordinate Filters in 2D

In the following illustration, the hole in the holding plate was centered in the
rectangle by extracting the X,Y coordinates from the midpoints of the plate's
horizontal and vertical line segments.
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Here is the command prompt sequence:

Command: circle
Specify center point for circle or [3P/2P/Ttr (tangent tangent radius)]: .x
of: mid
of: Select the horizontal line on the lower edge of the holding plate
of: (need YZ): mid
of: Select the vertical line on the left side of the holding plate
of: Diameter/<Radius> Specify the radius of the hole

Coordinate filters work only when the program prompts you for a point. If
you try to use a coordinate filter at the command prompt, you see an error
message.

Example: Use of Coordinate Filters in 3D

This example shows how to use coordinate filters to create a point object at
the center (centroid) of a 3D object. Hidden lines have been removed for
clarity. The X value of the new point is extracted from the first location
specified, the Y value from the second location, and the Z value from the third.
The three values are combined to form the coordinate values of the new point.

Command: point
Point: .x
of mid
of select object (1)
(need YZ): .y
of mid
of select object (2)
(need Z): mid
of select object (3)
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To use coordinate filters to specify a point in 2D

1 At the prompt for a point, enter a coordinate filter (.x or .y).

For example, enter .x to specify the X value first.

2 To extract the first coordinate value, specify a point.

For example, if you entered .x in step 1, the X value is extracted from this
point.

3 To extract the next coordinate value, specify a different point.

The new point location combines the coordinate values extracted from
the points you specified in steps 2 and 3.

NOTE Instead of specifying a point in steps 2 or 3, you can enter a numeric value.

To use coordinate filters to specify a point in 3D

1 At the prompt for a point, enter a coordinate filter (.x, .y, .z, .xy, .xz, or
.yz).

For example, enter .x to specify the X value first.

2 To extract the specified coordinate value(s), specify a point.

For example, if you entered .x in step 1, the X value is extracted from this
point.

3 At the prompt for the remaining coordinates, do one of the following:

■ Extract the remaining coordinate values by specifying a point.

■ Enter another coordinate filter and return to step 2.

For example, if you entered .x in step 1, specify a second point to extract
the Y and Z coordinates simultaneously, or enter .y or .z to specify Y and
Z values separately.

The new point location combines the coordinate values extracted from
the points specified in steps 2 and 3.

NOTE Instead of specifying a point in steps 2 or 3, you can enter a numeric value.
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Quick Reference

Commands

No entries

System Variables

No entries

Utilities

No entries

Command Modifiers

Coordinate Filters (Command Modifier)

Combines X, Y, and Z values from different points to specify a single point.

Track to Points on Objects (Object Snap Tracking)
You can draw objects at specific angles or in specific relationship to other
objects along specified directions called alignment paths.

AutoTrack™ helps you draw objects at specific angles or in specific relationships
to other objects. When you turn on AutoTrack, temporary alignment paths
help you create objects at precise positions and angles. AutoTrack includes
two tracking options: polar tracking and object snap tracking.

You can toggle AutoTrack on and off with the Polar and Otrack buttons on
the status bar. Use temporary override keys to turn object snap tracking on
and off or to turn off all snapping and tracking. See the keyboard illustration
in Override Object Snap Settings on page 683.

Object snap tracking works in conjunction with object snaps. You must set
an object snap before you can track from an object's snap point.

Object Snap Tracking

Use object snap tracking to track along alignment paths that are based on
object snap points. Acquired points display a small plus sign (+), and you can
acquire up to seven tracking points at a time. After you acquire a point,
horizontal, vertical, or polar alignment paths relative to the point are displayed
as you move the cursor over their drawing paths. For example, you can select
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a point along a path based on an object endpoint or midpoint or an
intersection between objects.

In the following illustration, the Endpoint object snap is on. You start a line
by clicking its start point (1), move the cursor over another line's endpoint
(2) to acquire it, and then move the cursor along the horizontal alignment
path to locate the endpoint you want for the line you are drawing (3).

Change Object Snap Tracking Settings

By default, object snap tracking is set to orthogonal. Alignment paths are
displayed at 0, 90, 180, and 270 degrees from acquired object points. However,
you can use polar tracking angles instead.

For object snap tracking, object points are automatically acquired. However,
you can choose to acquire points only when you press SHIFT.

Change Alignment Path Display

You can change how AutoTrack displays alignment paths, and you can change
how object points are acquired for object snap tracking. By default, alignment
paths stretch to the end of the drawing window. You can change their display
to abbreviated lengths, or no length.

Tips for Using Object Snap Tracking

As you use AutoTrack (polar tracking and object snap tracking), you will
discover techniques that make specific design tasks easier. Here are a few you
might try.

■ Use Perpendicular, End, and Mid object snaps with object snap tracking
to draw to points that are perpendicular to the end and midpoints of
objects.

■ Use the Tangent and End object snaps with object snap tracking to draw
to points that are tangent to the endpoints of arcs.

■ Use object snap tracking with temporary tracking points. At a point prompt,
enter tt, then specify a temporary tracking point. A small + appears at the
point. As you move your cursor, AutoTrack alignment paths are displayed
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relative to the temporary point. To remove the point, move the cursor
back over the +.

■ After you acquire an object snap point, use direct distance to specify points
at precise distances along alignment paths from the acquired object snap
point. To specify a point prompt, select an object snap, move the cursor
to display an alignment path, then enter a distance at the command
prompt.

NOTE The direct distance entry method is not available while you are using
the temporary override key for object snap tracking.

■ Use the Automatic and SHIFT to Acquire options set on the Drafting tab
of the Options dialog box to manage point acquisition. Point acquisition
is set to Automatic by default. When working in close quarters, press SHIFT
to temporarily avoid acquiring a point.

To turn on and turn off object snap tracking

■ Press F11, or click  on the status bar.
To turn object snap tracking on and off temporarily, hold down the F11
key while you work.

To change AutoTrack settings

1 Click Tools menu  ➤ Options.

2 In the Options dialog box, Drafting tab, under AutoTrack Settings, select
or clear the following alignment path display options:

■ Display Polar Tracking Vector. Controls alignment path display for
object snap tracking. When cleared, no polar tracking path is
displayed.

■ Display Full Screen Tracking Vector. Controls alignment path display
for object snap tracking. When cleared, an alignment path is displayed
only from the object snap point to the cursor.

■ Display AutoTrack Tooltip. Controls the display of AutoTrack tooltips.
Tooltips tell you the type of object snap (for object snap tracking),
alignment angle, and distance from the previous point.
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3 Under Alignment Point Acquisition, select a method for acquiring object
points for object snap tracking:

■ Automatic. Acquires object points automatically. If you select this
option, you can press SHIFT to not acquire an object point

■ Shift to Acquire. Acquires object points only when you press SHIFT
while the cursor is over an object snap point.

Command entry: OPTIONS

Quick Reference

Commands

DSETTINGS

Sets grid and snap, polar and object snap tracking, object snap modes,
Dynamic Input, and Quick Properties.

OPTIONS

Customizes the program settings.

System Variables

AUTOSNAP

Controls the display of the AutoSnap marker, tooltip, and magnet.

POLARMODE

Controls settings for polar and object snap tracking.

TRACKPATH

Controls the display of polar and object snap tracking alignment paths.
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Utilities

No entries

Command Modifiers

No entries

Track to Offset Point Locations (Tracking)
You can use tracking to specify a point by offsetting vertically and horizontally
from a series of temporary points.

You can use the tracking method whenever you are prompted for a point.
Tracking uses the pointing device to specify a point by offsetting vertically
and horizontally from a series of temporary points. When you start tracking
and specify an initial reference point, the next reference point is constrained
to a path that extends vertically or horizontally from that point. The direction
of the offset is indicated by the rubber-band line. You change the direction
of the offset by moving the cursor through the reference point. You can track
as many points as you need. Typically, you use tracking in combination with
object snaps or direct distance entry.

For example, you can use tracking to find the center point of a rectangle
without using construction lines. Start tracking, and specify the midpoint of
a horizontal line. Drag the cursor vertically and specify the midpoint of a
vertical line (2). Press ENTER to accept the point (3) at the center of the
rectangle.

To use tracking to specify a point

1 Start a command, such as the LINE command.

2 Hold down SHIFT and right-click in the drawing area. Click Tracking.

3 Specify a point.

4 Move the cursor directly up, down, left, or right until you see the
rubber-band line.

The direction of movement affects the tracking direction. Notice that if
you move the cursor from left to right, you must then move it directly
over the last point specified in order to move it up or down.

5 Specify a second point.

6 Press ENTER to end tracking.
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The start point of the line snaps to the imaginary intersection of the
vertical and horizontal paths extending from the points you specified.
The position is determined by the direction in which you moved the
cursor after specifying the first point.

Command entry: TRACKING (Command Modifier) (Command Modifier)

Quick Reference

Commands

No entries

System Variables

No entries

Utilities

No entries

Command Modifiers

TRACKING (Command Modifier)

Locates a point from a series of temporary points.

Specify Distances
When specifying a point, you can enter distances, offsets, and measured
intervals.

Enter Direct Distances
You can specify a point by moving the cursor to indicate a direction and then
entering the distance.

To specify a line length quickly, without entering coordinate values, you can
specify a point by moving the cursor to indicate a direction and then entering
the distance from the first point. You can enter calculated distances from the
QuickCalc calculator. For more information, see Use the QuickCalc Calculator
on page 773.
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You can use direct distance entry to specify points for all commands requiring
more than one point. When Ortho mode or polar tracking is on, this method
is an efficient way to draw lines of specified length and direction, and to move
or copy objects.

NOTE The direct distance entry method is not available while you are using the
temporary override keys for Ortho mode, object snap tracking, or polar tracking.

See also:

■ Use Polar Tracking and PolarSnap on page 695

■ Lock an Angle for One Point (Angle) on page 700

To draw a line using direct distance entry

1 Click Home tab  ➤  Draw panel  ➤  Line.

2 Specify the first point and then, move the pointing device until the
rubber-band line extends at the same angle as the line you want to draw.

3 Enter a distance at the command prompt.

The line is drawn at the length and angle you specified.

4 LINE

Quick Reference

Commands

LINE

Creates straight line segments.

710 | Chapter 16   Use Precision Tools



System Variables

No entries

Utilities

No entries

Command Modifiers

Direct Distance Entry (Command Modifier)

Locates the next point at a specified distance in the direction of your cursor.

Offset from Temporary Reference Points
You can establish a temporary reference point as a base point for offsetting
subsequent points.

The From command modifier establishes a temporary reference point as a
base point for offsetting subsequent points. The From method does not
constrain the cursor to orthogonal movement. The From method usually is
used in combination with object snaps.

To offset a point from a temporary reference point

1 At a prompt for a point, enter from. Alternately, press SHIFT and
right-click to display the object snap menu, and then choose From.

2 If you want to offset from a location on an existing object, specify an
object snap method. Then select the object snap point.

3 Enter a relative coordinate (i.e. @1,1).
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Quick Reference

Commands

No entries

System Variables

No entries

Utilities

No entries

Command Modifiers

FROM (Command Modifier)

Locates a point offset from a reference point within a command.

Specify Intervals on Objects
You can mark off equal distances along objects.

Overview of Specifying Intervals on Objects
Provides a high-level overview of two options for marking off equal distances
along objects.

Sometimes you need to create points or insert symbols (blocks) at intervals
on an object.

You can

■ Specify the length of the segments (MEASURE)

■ Specify the number of equal segments (DIVIDE)

You can measure or divide lines, arcs, splines, circles, ellipses, and polylines.
With both methods, you can identify the intervals by inserting either a point
or a block.

By specifying points, you can use the Node object snap to align other objects
at intervals on the measured or divided object. By specifying blocks, you can
create precise geometric constructions or insert custom markers. The blocks
can rotate at each insertion point.
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You cannot insert a block unless it has already been defined within the
drawing. Variable attributes within the block are not included when you insert
the block references.

The points or blocks you draw using MEASURE or DIVIDE are placed in a
selection set. Therefore, if you want to edit them immediately, you can use
the Previous option of SELECT.

See also:

■ Create and Use Blocks (Symbols) on page 853

Quick Reference

Commands

BLOCK

Creates a block definition from selected objects.

DDPTYPE

Specifies the display style and size of point objects.

DIVIDE

Creates evenly spaced point objects or blocks along the length or perimeter
of an object.

MEASURE

Creates point objects or blocks at measured intervals along the length or
perimeter of an object.

WBLOCK

Writes objects or a block to a new drawing file.

System Variables

PDMODE

Controls how point objects are displayed.

PDSIZE

Sets the display size for point objects.
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Utilities

No entries

Command Modifiers

No entries

Specify Measured Intervals on Objects
You can mark off equal lengths from one end of a selected object.

You can use MEASURE to mark an object at specified intervals. You can mark
the intervals with either points or blocks. The last segment of a measured
object may be shorter than the interval you specify.

The starting point for measurements or divisions varies with the object type.
For lines or open polylines, the starting point is the endpoint closest to the
selection point. For closed polylines, it is the polyline start point. For circles,
it is at the angle from the center point that is equivalent to the current snap
angle. For example, if the snap angle is 0, the circle starts at the three o'clock
position and continues counterclockwise.

If the point marker is displayed as a single dot (the default setting), you may
not be able to see the measured intervals. You can change the style of the
point markers using several methods. To change the point style in a dialog
box, you can use DDPTYPE. Alternately, click Format menu  ➤ Point Style.
The PDMODE system variable also controls the appearance of point markers.
For example, you can change the value to make points appear as crosses.
PDSIZE controls the size of point objects.

To insert points at measured intervals on an object

1 Click Home tab  ➤  Draw panel  ➤  Point drop-down  ➤  Measure.

2 Select a line, arc, spline, circle, ellipse, or polyline.

3 Enter an interval length, or specify points to indicate a length.

Points are placed on the object at the specified intervals.

Command entry: MEASURE
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To insert blocks at measured intervals on an object

1 If necessary, create the block you want to insert.

2 Click Home tab  ➤  Draw panel  ➤  Point drop-down  ➤  Measure.

3 Select a line, arc, spline, circle, ellipse, or polyline.

4 Enter b (Block).

5 Enter the name of the block you want to insert.

6 Enter y to align the blocks with the measured object. Enter n to use a
rotation angle of 0 degrees.

7 Enter an interval length, or specify points to indicate a length.

Blocks are inserted on the object at the specified intervals.

Command entry: BLOCK, MEASURE

Quick Reference

Commands

BLOCK

Creates a block definition from selected objects.

DDPTYPE

Specifies the display style and size of point objects.

MEASURE

Creates point objects or blocks at measured intervals along the length or
perimeter of an object.

System Variables

PDMODE

Controls how point objects are displayed.

PDSIZE

Sets the display size for point objects.
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Utilities

No entries

Command Modifiers

No entries

Divide an Object into Equal Segments
You can divide a selected object into a specified number of equal lengths.

You can create points or insert blocks on an object at a specific number of
equal intervals. This operation does not actually break an object into individual
objects; it only identifies the location of the divisions so that you can use
them as geometric reference points.

The starting point for measurements or divisions varies with the object type.
For lines or open polylines, the starting point is the endpoint closest to the
selection point. For closed polylines, it is the polyline start point. For circles,
it is at the angle from the center point that is equivalent to the current snap
angle. For example, if the snap angle is 0, the circle starts at the three o'clock
position and continues counterclockwise.

If the point marker is displayed as a single dot (the default setting), you may
not be able to see the segments. You can change the style of the point markers
using several methods. To change the point style in a dialog box, you can use
DDPTYPE. Alternately, click Format menu  ➤  Point Style. The PDMODE
system variable also controls the appearance of point markers. For example,
you can change the value to make points appear as crosses. PDSIZE controls
the size of point objects.

To insert points to mark equal segments

1 Click Home tab  ➤  Draw panel  ➤  Point drop-down  ➤  Divide.

2 Select a line, circle, ellipse, polyline, arc, or spline.
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3 Enter the number of segments you want.

A point is placed between each segment.

Command entry: DIVIDE

To insert blocks to mark equal segments on an object

1 If necessary, create the block you want to insert.

2 Click Home tab  ➤  Draw panel  ➤  Point drop-down  ➤  Divide.

3 Select a line, arc, circle, ellipse, polyline, or spline.

4 Enter b (Block).

5 Enter the name of the block you want to insert.

6 Enter y to align the blocks with the divided object. Enter n to use a
rotation angle of 0 degrees.

7 Enter the number of segments you want.

Command entry: BLOCK, DIVIDE

Quick Reference

Commands

BLOCK

Creates a block definition from selected objects.

DDPTYPE

Specifies the display style and size of point objects.

DIVIDE

Creates evenly spaced point objects or blocks along the length or perimeter
of an object.

WBLOCK

Writes objects or a block to a new drawing file.
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System Variables

PDMODE

Controls how point objects are displayed.

PDSIZE

Sets the display size for point objects.

Utilities

No entries

Command Modifiers

No entries

Design with Parametric Constraints
With parametric drawing, you can add constraints to geometry to ensure that
the design conforms to specified requirements.

Overview of Constraints
Parametric drawing is a technology that is used for designing with constraints.
Constraints are associations and restrictions applied to 2D geometry.

There are two general types of constraints:

■ Geometric constraints control the relationships of objects with respect to
each other

■ Dimensional constraints control the distance, length, angle, and radius values
of objects

The following illustration displays geometric and dimensional constraints
using the default format and visibility.
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A blue cursor icon always displays when you move the cursor over an object
that has constraints applied to it.

In the design phase of a project, constraints provide a way to enforce
requirements when experimenting with different designs or when making
changes. Changes made to objects can adjust other objects automatically, and
restrict changes to distance and angle values.

With constraints, you can

■ Maintain design specifications and requirements by constraining the
geometry within a drawing

■ Apply multiple geometric constraints to objects instantly

■ Include formulas and equations within dimensional constraints

■ Make design changes quickly by changing the value of a variable

BEST PRACTICE It is recommended that you first apply geometric constraints to
determine the shape of a design, and then apply dimensional constraints to
determine the size of objects in a design.

Design Using Constraints

When you are creating or changing a design, a drawing will be in one of three
states:

■ Unconstrained. No constraints are applied to any geometry.
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■ Underconstrained. Some constraints are applied to the geometry.

■ Fully constrained. All relevant geometric and dimensional constraints are
applied to the geometry. A fully constrained set of objects also needs to
include at least one Fix constraint to lock the location of the geometry.

Thus, there are two general methods for designing with constraints:

■ You can work in an underconstrained drawing and make changes as you
go, using a combination of editing commands, grips, and adding or
changing constraints.

■ You can create and fully constrain a drawing first, and then control the
design exclusively by relaxing and replacing geometric constraints, and
changing the values in dimensional constraints.

The method that you choose depends on your design practices and the
requirements of your discipline.

NOTE The program prevents you from applying any constraints that result in an
overconstrained condition.

Use Constraints with Blocks and Xrefs

You can apply constraints between

■ An object in the drawing and an object within a block reference

■ An object within a block reference and an object within a different block
reference (not between objects within the same block reference)

■ The insertion point of an xref and an object or a block, but not to any
objects within xrefs

When you apply constraints to block references, the objects contained within
the block are automatically available for selection. You do not need to press
Ctrl for subobject selection. Adding constraints to a block reference can cause
it to move or rotate as a result.

NOTE Applying constraints to dynamic blocks suppresses the display of their
dynamic grips. You can still change the values in a dynamic block using the
Properties palette, but to redisplay the dynamic grips, the constraints must first
be removed from the dynamic block.
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Constraints can be used in block definitions, resulting in dynamic blocks. You
can control the size and shape of dynamic blocks directly from within the
drawing. For more information, see Add Constraints to Dynamic Blocks on
page 898.

Remove or Relax Constraints

There are two ways to cancel the effects of constraints when you need to make
design changes:

■ Delete the constraints individually and later apply new constraints. While
the cursor hovers over a geometric constraint icon, you can use the Delete
key or the shortcut menu to delete the constraint.

■ Relax the constraints temporarily on selected objects to make the changes.
With a grip selected or when you specify options during an editing
command, tap the Ctrl key to alternate between relaxing constraints and
maintaining constraints.

Relaxed constraints are not maintained during editing. Constraints are restored
automatically if possible when the editing process is complete. Constraints
that are no longer valid are removed.

NOTE The DELCONSTRAINT command deletes all geometric and dimensional
constraints from an object.

Quick Reference

Commands

AUTOCONSTRAIN

Applies geometric constraints to a selection set of objects based on orientation
of the objects relative to one another.

CONSTRAINTBAR

A toolbar-like UI element that displays the available geometric constraints
on an object.

CONSTRAINTSETTINGS

Controls the display of geometric constraints on constraint bars.
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DELCONSTRAINT

Removes all geometric and dimensional constraints from a selection set of
objects.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

GEOMCONSTRAINT

A toolbar-like UI element that displays the available geometric constraints
on an object.

LIST

Displays property data for selected objects.

PARAMETERS

Controls the associative parameters used in the drawing.

-PARAMETERS

Controls the associative parameters used in the drawing.

PARAMETERSCLOSE

Closes the Parameters Manager palette.

TEXTEDIT

Edits a dimensional constraint, dimension, or text object.

System Variables

CCONSTRAINTFORM

Controls whether annotational or dynamic constraints are applied to objects.

CONSTRAINTBARDISPLAY

Displays constraint bars for objects after you manually apply a constraint or
autoconstrain them.

CONSTRAINTBARMODE

Controls the display of geometrical constraints on constraint bars.

CONSTRAINTNAMEFORMAT

Controls the text format for dimensional constraints.
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CONSTRAINTRELAX

Indicates whether constraints are enforced or relaxed when editing an object.

CONSTRAINTSOLVEMODE

Controls constraint behavior when applying or editing constraints.

DIMCONSTRAINTICON

Displays the lock icon next to the text for dimensional constraints.

DYNCONSTRAINTDISPLAY

Displays or hides dynamic constraints.

DYNCONSTRAINTMODE

Displays hidden dimensional constraints when constrained objects are
selected.

PARAMETERCOPYMODE

Controls how constraints and referenced variables are copied when replicating
constrained geometry.

PARAMETERSSTATUS

Indicates whether the Parameters Manager palette is displayed or hidden.

Constrain Objects Geometrically
Geometric constraints determine the relationships between 2D geometric
objects or points on objects relative to each other.

Overview of Geometric Constraints
You can specify geometric constraints between 2D objects or points on objects.
When you later edit the constrained geometry, the constraints are maintained.

Thus, using geometric constraints, you have a method of including design
requirements in your drawing.

For example, in the illustration below, the following constraints are applied
to the geometry.

■ Every endpoint is constrained to remain coincident with the endpoint of
every adjacent object—these constraints are displayed as small blue squares
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■ The vertical lines are constrained to remain parallel with each other and
to remain equal to each other in length

■ The left vertical line is constrained to remain perpendicular to the
horizontal line

■ The horizontal line is constrained to remain horizontal

■ The location of the circle and the horizontal line are constrained to remain
fixed in space—these constraints are displayed as lock icons

The geometry is not fully constrained, however. Using grips, you can still change
the radius of the arc, the diameter of the circle, the length of the horizontal
line, and the length of the vertical lines. To specify these distances, you need
to apply dimensional constraints.

NOTE Constraints can be added to segments within a polyline as if they were
separate objects.

See also:

■ Overview of Dimensional Constraints on page 741

Quick Reference

Commands

AUTOCONSTRAIN

Applies geometric constraints to a selection set of objects based on orientation
of the objects relative to one another.

CONSTRAINTBAR

A toolbar-like UI element that displays the available geometric constraints
on an object.

724 | Chapter 16   Use Precision Tools



CONSTRAINTSETTINGS

Controls the display of geometric constraints on constraint bars.

DELCONSTRAINT

Removes all geometric and dimensional constraints from a selection set of
objects.

GEOMCONSTRAINT

A toolbar-like UI element that displays the available geometric constraints
on an object.

LIST

Displays property data for selected objects.

System Variables

CONSTRAINTBARMODE

Controls the display of geometrical constraints on constraint bars.

CONSTRAINTBARDISPLAY

Displays constraint bars for objects after you manually apply a constraint or
autoconstrain them.

CONSTRAINTNAMEFORMAT

Controls the text format for dimensional constraints.

CONSTRAINTRELAX

Indicates whether constraints are enforced or relaxed when editing an object.

CONSTRAINTSOLVEMODE

Controls constraint behavior when applying or editing constraints.

Apply or Remove Geometric Constraints
Geometric constraints associate geometric objects together, or specify a fixed
location or angle.

For example, you can specify that a line should always be perpendicular to
another one, that an arc and a circle should always remain concentric, or that
a line should always be tangent to an arc.
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When you apply a constraint, two things occur:

■ The object that you select adjusts automatically to conform to the specified
constraint

■ By default, a gray constraint icon displays near the constrained object as
shown in the previous illustration, and a small, blue glyph displays with
your cursor when you move it over a constrained object

Once applied, constraints permit only those changes to the geometry that do
not violate the constraints. This provides a method for exploring design options
or making design changes while maintaining the requirements and
specifications of the design.

NOTE The order in which you select two objects when you apply a constraint is
important in some cases. Normally, the second object you select adjusts to the
first object. For example, when you apply a Perpendicular constraint, the second
object you select will adjust to become perpendicular to the first.

You can apply geometric constraints to 2D geometric objects only. Objects
cannot be constrained between model space and paper space.
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Specify Constraint Points

With some constraints, you specify constraint points on objects instead of
selecting the objects. This behavior is similar to that of object snaps, but the
locations are limited to endpoints, midpoints, center points, and insertion
points.

For example, the Coincident constraint can restrict the location of the endpoint
of one line to the endpoint of another line.

The following glyph is displayed on the object as you roll over the object.

You use this glyph to confirm whether you are specifying the intended point
to constrain.

Use Fix Constraints

A Fix constraint associates a constraint point on an object, or the object itself
with a fixed location with respect to the World Coordinate System.

It is often advisable to specify a Fix constraint at an important geometric
feature. This locks the location of that point or object, and prevents geometry
from relocating when you make changes to the design.

When you fix an object, the angle of a line, or the center of an arc or circle is
also fixed.

Apply Multiple Geometric Constraints

You can apply multiple geometric constraints to objects either manually or
automatically.

When you want to apply all essential geometric constraints to a design
automatically, you can use AUTOCONSTRAIN with the objects that you select
in your drawing. This helps constrain the geometric shape of the
design—depending on your design, there might be cases where you need to
apply additional geometric constraints.

AUTOCONSTRAIN also provides settings in which you can specify the
following options:

■ What geometric constraints to apply
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■ What order to apply geometric constraints

■ What tolerances are used to determine whether objects are horizontal,
vertical, or touching

NOTE Equal or Fix constraints are not applied with AUTOCONSTRAIN. You must
apply these constraints individually.

To fully constrain the size and proportions of a design, you will later need to
apply dimensional constraints.

Remove Geometric Constraints

A geometric constraint cannot be modified, but you can delete it and apply
a different one. Several constraint options, including Delete, are available from
the shortcut menu that is displayed when you right-click a constraint icon in
the drawing.

You can delete all constraints from a selection set in a single operation with
DELCONSTRAINT.

To apply a coincident constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Coincident. 

2 Select the first and second points on two different objects.

The second point is made coincident to the first.

Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT

To apply a collinear constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Collinear. 

2 Select the first and second object. You can select either a line object or a
polyline subobject.

The second object is made collinear to the first.
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Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT

To apply a concentric constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Concentric. 

2 Select the first and second arc or circle object.

The second arc or circle moves to have the same center point as the first
object.

Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT

To apply a fix constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Fix. 

2 Select a point on an object.

Applying the Fix constraint to a point on the object locks the node in
place. You can still move the object.

Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT

To apply a parallel constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Parallel. 

2 Select the two objects to be made parallel. You can select either a line
object or a polyline subobject.

The second object is made parallel with the first object.
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Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT

To apply a perpendicular constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Perpendicular. 

2 Select the two objects to be made perpendicular. You can select either a
line object or a polyline subobject.

The second object is made perpendicular to the first object.

Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT

To apply a horizontal constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Horizontal. 

2 Select the line object or polyline subobject to be made horizontal.

Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT

To apply a vertical constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Vertical. 

2 Select the line object or polyline subobject to be made vertical.

Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT
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To apply a tangent constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Tangent. 

2 Select the two objects to be made tangential.

The second object maintains a point of tangency with the first object.

Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT

To apply a smooth constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Smooth. 

2 Select the first spline curve.

3 Select the second spline, line, polyline (subobject), or arc object.

The two objects are updated to be contiguous with one another.

Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT

To apply a symmetric constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Symmetric. 

2 Select the first and second object.

3 Select the symmetry line.

The selected objects become symmetrically constrained about the selected
line.

Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT
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To apply an equal constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Equal. 

2 Select the first and second object.

The second object is made equal to the first object.

Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT

To apply multiple geometric constraints to an object

1 Click Parametric tab  ➤ Geometric panel  ➤ AutoConstrain. 

2 Select the objects that you want to constrain.

3 Press Enter when you select the objects to be automatically constrained.

The Command prompt displays the number of constraints applied.

Toolbar: Parametric, Geometric Constraints 
Command entry: AUTOCONSTRAIN

To set the order for applying multiple geometric constraints to an object

1 Click Parametric tab  ➤ Geometric panel  ➤ AutoConstrain. 

2 At the Command prompt, enter s (Settings).

3 In the Constraint Settings dialog box, on the AutoConstrain tab, select
a Constraint Type.

4 Click Move Up or Move Down. This changes the priority for a constraint
when you use the AUTOCONSTRAIN command on an object.

5 Click OK.
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Toolbar: Parametric, Geometric Constraints 
Command entry: AUTOCONSTRAIN

Quick Reference

Commands

GEOMCONSTRAINT

A toolbar-like UI element that displays the available geometric constraints
on an object.

CONSTRAINTBAR

A toolbar-like UI element that displays the available geometric constraints
on an object.

CONSTRAINTSETTINGS

Controls the display of geometric constraints on constraint bars.

System Variables

CONSTRAINTBARMODE

Controls the display of geometrical constraints on constraint bars.

CONSTRAINTBARDISPLAY

Displays constraint bars for objects after you manually apply a constraint or
autoconstrain them.

CONSTRAINTNAMEFORMAT

Controls the text format for dimensional constraints.

CONSTRAINTRELAX

Indicates whether constraints are enforced or relaxed when editing an object.

CONSTRAINTSOLVEMODE

Controls constraint behavior when applying or editing constraints.

Display and Verify Geometric Constraints
You can determine visually what objects are associated with any geometric
constraint, or what constraints are associated with any object.
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Constraint icons provide information about how objects are constrained. A
constraint bar displays one or more icons that represent the geometric
constraints applied to an object.

You can drag constraint bars when you need to move them out of the way,
and you can also control whether they are displayed or hidden.

Verify the Geometric Constraints on Objects

You can confirm the association of geometric constraints with objects in two
ways.

■ When you roll over a constraint icon on a constraint bar, the objects
associated with that geometric constraint are highlighted.

■ When you roll over an object that has geometric constraints applied to it,
all constraint bars that are associated with the object are highlighted.
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These highlighting features simplify working with constraints especially when
you have many constraints applied throughout a drawing.

Control the Display of Constraint Bars

Geometric constraints and constraint bars can be displayed or hidden, either
individually or globally. You can do any of the following:

■ Display or hide all geometric constraints

■ Display or hide specified types of geometric constraints

■ Display or hide all geometric constraints associated with a selected object

Use the Constraint Settings dialog box to control the types of geometric
constraints that are displayed or hidden on constraint bars.

Hiding geometric constraints is useful when you analyze a design and want
to filter the display of geometric constraints. For example, you can choose to
display the icons for Parallel constraints only. Next, you might choose to
display the icons for Perpendicular constraints only.

When you are not working with geometric constraints, it is recommended
that you hide them globally.

NOTE To reduce clutter, Coincident constraints display by default as small,
light-blue squares. You can use an option in the Constraint Settings dialog box to
turn them off if necessary.

To display a geometric constraint

1 Click Parametric tab  ➤ Geometric panel  ➤ Show. 

2 Select the constrained objects.

3 Press Enter.

Toolbar: parametric 
Command entry: CONSTRAINTBAR
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To display all geometric constraints

 ➤ Click Parametric tab  ➤ Geometric panel  ➤ Show All. 

Toolbar: Parametric 
Command entry: CONSTRAINTBAR

To hide all geometric constraints

 ➤ Click Parametric tab  ➤ Geometric panel  ➤ Hide All. 

Toolbar: Parametric 
Command entry: CONSTRAINTBAR

To change the constraint bar settings using the constraint bar shortcut menu

1 Select a constrained object.

2 Ensure that the constraint bar is visible for the selected object.

3 Right-click the constraint bar, and click Constraint Bar Settings.

4 In the Constraint Settings dialog box, on the Geometric tab, select or
clear the appropriate check boxes.

5 Use the slider, or enter a value, to set the transparency level of constraint
bars in the drawing. The default value is 50.

6 Click OK.

Toolbar: Parametric 
Command entry: CONSTRAINTBAR
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Quick Reference

Commands

GEOMCONSTRAINT

A toolbar-like UI element that displays the available geometric constraints
on an object.

CONSTRAINTBAR

A toolbar-like UI element that displays the available geometric constraints
on an object.

CONSTRAINTSETTINGS

Controls the display of geometric constraints on constraint bars.

System Variables

CONSTRAINTBARMODE

Controls the display of geometrical constraints on constraint bars.

CONSTRAINTBARDISPLAY

Displays constraint bars for objects after you manually apply a constraint or
autoconstrain them.

CONSTRAINTNAMEFORMAT

Controls the text format for dimensional constraints.

CONSTRAINTRELAX

Indicates whether constraints are enforced or relaxed when editing an object.

CONSTRAINTSOLVEMODE

Controls constraint behavior when applying or editing constraints.

Modify Objects with Geometric Constraints Applied
You can edit constrained geometric objects with grips, editing commands, or
by relaxing or applying geometric constraints.

By definition, geometric constraints that are applied to geometric objects limit
the editing actions that you perform on the objects.
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Modify Constrained Objects with Grips

You can modify constrained geometry using grip editing modes. The geometry
will maintain all applied constraints.

For example, if a line object is constrained to remain tangent to a circle, you
can rotate the line and change its length and endpoints, but the line or its
extension will remain tangent to the circle.

If the circle was an arc instead, the line or its extension would remain tangent
to the arc or its extension.

The results of modifying underconstrained objects are based on what
constraints have already been applied and the object types involved. For
example, if the Radius constraint had not been applied, the radius of the circle
would have been modified instead of the tangent point of the line.

The CONSTRAINTSOLVEMODE system variable determines the way an object
behaves when constraints are applied or when grips are used to edit it.

BEST PRACTICE You can limit unexpected changes by applying additional
geometric or dimensional constraints. Common choices include Coincident and
Fix constraints.
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Modify Constrained Objects with Editing Commands

You can use editing commands such as MOVE, COPY, ROTATE, and SCALE
to modify constrained geometry. The results maintain the constraints applied
to the objects.

NOTE The TRIM, EXTEND, BREAK, and JOIN commands in some circumstances
can remove constraints.

By default, if an editing command results in copying the constrained objects,
the constraints applied to the original objects will also be duplicated. This
behavior is controlled by the PARAMETERCOPYMODE system variable. Using
the copying technique, you can save work by taking advantage of multiple
instances of objects, bilateral symmetry, or radial symmetry.

For information about temporarily relaxing constraints, see Overview of
Constraints on page 718.

To grip-edit constrained geometry

1 Select the constrained object.

2 Click the grips and drag it to edit the geometry.

Toolbar: Parametric, Geometric Constraints 
Command entry: GEOMCONSTRAINT

To turn a constraint off

1 Click the constrained object to select it.

2 Move your mouse over a grip.

The grips are displayed in red to show that the object is selected.

3 Click the grip.

4 Press and release the Ctrl key.

5 Move the object. The object moves freely as it is no longer constrained.

Constraint bars will no longer be displayed (if enabled) for the object, as
the constraints are turned off.

Toolbar: Parametric, Geometric Constraints 
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Command entry: GEOMCONSTRAINT

To delete a geometric constraint

1 Select a constrained object.

2 Ensure that the constraint bar is visible for the selected object.

3 Right-click the constraint bar. Click Delete.

Constraint bars for the deleted constraint will no longer display for the
object.

Toolbar: Parametric 
Command entry: DELCONSTRAINT

To delete all geometric constraints from an object

1 Select a constrained object.

2 Click Parametric tab  ➤ Manage panel  ➤ Delete Constraint.

NOTE All geometric and dimensional constraints are removed from the
object.

3 Press Enter.

Toolbar: Parametric 
Command entry: DELCONSTRAINT

Quick Reference

Commands

GEOMCONSTRAINT

A toolbar-like UI element that displays the available geometric constraints
on an object.

CONSTRAINTBAR

A toolbar-like UI element that displays the available geometric constraints
on an object.
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CONSTRAINTSETTINGS

Controls the display of geometric constraints on constraint bars.

System Variables

CONSTRAINTBARMODE

Controls the display of geometrical constraints on constraint bars.

CONSTRAINTBARDISPLAY

Displays constraint bars for objects after you manually apply a constraint or
autoconstrain them.

CONSTRAINTNAMEFORMAT

Controls the text format for dimensional constraints.

CONSTRAINTRELAX

Indicates whether constraints are enforced or relaxed when editing an object.

CONSTRAINTSOLVEMODE

Controls constraint behavior when applying or editing constraints.

Constrain Distances and Angles between Objects
You can control distances or angles between 2D geometric objects or points
on objects applying dimensional constraints and specifying values. You can
also constrain geometry with variables and equations.

Overview of Dimensional Constraints
Dimensional constraints control the size and proportions of a design. They
can constrain the following:

■ Distances between objects, or between points on objects

■ Angles between objects, or between points on objects

■ Sizes of arcs and circles

For example, the following illustration includes linear, aligned, angular, and
diameter constraints.
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If you change the value of a dimensional constraint, all the constraints on the
object are evaluated, and the objects that are affected are updated
automatically.

Also, constraints can be added directly to segments within a polyline as if they
were separate objects.

NOTE The number of decimal places displayed in dimensional constraints is
controlled by the LUPREC and AUPREC system variables.

Compare Dimensional Constraints with Dimension Objects

Dimensional constraints are different from dimension objects in the following
ways:

■ Dimensional constraints are used in the design phase of a drawing, but
dimensions are typically created in the documentation phase

■ Dimensional constraints drive the size or angle of objects, but dimensions
are driven by objects

■ By default, dimensional constraints are not objects, display with only a
single dimension style, maintain the same size during zoom operations,
and are not plotted

If you need to plot dimensional constraints or use dimension styles, you can
change the form of a dimensional constraint from dynamic to annotational.
See Apply Dimensional Constraints on page 744 for more detail.

Define Variables and Equations

With the Parameters Manager, you can define custom user variables that you
can reference from within dimensional constraints and other user variables.
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The expressions that you define can include a variety of predefined functions
and constants.

For more information about using variables and equations with constraints,
see Constrain a Design with Formulas and Equations on page 758

See also:

■ Overview of Geometric Constraints on page 723

Quick Reference

Commands

DELCONSTRAINT

Removes all geometric and dimensional constraints from a selection set of
objects.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

LIST

Displays property data for selected objects.

PARAMETERS

Controls the associative parameters used in the drawing.

-PARAMETERS

Controls the associative parameters used in the drawing.
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PARAMETERSCLOSE

Closes the Parameters Manager palette.

TEXTEDIT

Edits a dimensional constraint, dimension, or text object.

System Variables

CCONSTRAINTFORM

Controls whether annotational or dynamic constraints are applied to objects.

CONSTRAINTNAMEFORMAT

Controls the text format for dimensional constraints.

CONSTRAINTRELAX

Indicates whether constraints are enforced or relaxed when editing an object.

CONSTRAINTSOLVEMODE

Controls constraint behavior when applying or editing constraints.

DIMCONSTRAINTICON

Displays the lock icon next to the text for dimensional constraints.

DYNCONSTRAINTDISPLAY

Displays or hides dynamic constraints.

DYNCONSTRAINTMODE

Displays hidden dimensional constraints when constrained objects are
selected.

PARAMETERCOPYMODE

Controls how constraints and referenced variables are copied when replicating
constrained geometry.

PARAMETERSSTATUS

Indicates whether the Parameters Manager palette is displayed or hidden.

Apply Dimensional Constraints
Dimensional constraints maintain specified distances and angles between
geometric objects or points on objects.

744 | Chapter 16   Use Precision Tools



For example, you can specify that the length of a line should always remain
at 6.00 units, that the vertical distance between two points be maintained at
1.00 unit, and that a circle should always remain at 1.00 unit in diameter.

When you apply a dimensional constraint to an object, a constraint variable is
automatically created for maintaining the constraint value. By default, these
are assigned names such as d1 or dia1, but you can rename them in the
Parameters Manager.

Dimensional constraints can be created in one of the following forms:

■ Dynamic constraints

■ Annotational constraints

The forms have different purposes. In addition, any dynamic or annotational
constraint can be converted to a reference constraint.

Dynamic Constraints

By default, dimensional constraints are dynamic. They are ideal for normal
parametric drawing and design tasks.

Dynamic constraints have the following characteristics:

■ Maintain the same size when zooming in or out

■ Can easily be turned on or off globally in the drawing

■ Display using a fixed, predefined dimension style

■ Position the textual information automatically, and provide triangle grips
with which you can change the value of a dimensional constraint

■ Do not display when the drawing is plotted

If you need to control the dimension style of dynamic constraints, or if you
need to plot dimensional constraints, use the Properties palette to change
dynamic constraints to annotational constraints.
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Annotational Constraints

Annotational constraints are useful when you want dimensional constraints
to have the following characteristics:

■ Change their size when zooming in or out

■ Display individually with layers

■ Display using the current dimension style

■ Provide grip capabilities that are similar to those on dimensions

■ Display when the drawing is plotted

NOTE To display the text used in annotational constraints in the same format as
used in dimensions, set the CONSTRAINTNAMEFORMAT system variable to 1.

After plotting, you can use the Properties palette to convert annotational
constraints back to dynamic constraints.

Reference Constraints

A reference constraint is a driven dimensional constraint, either dynamic or
annotational. This means that it does not control the associated geometry,
but rather reports a measurement similar to a dimension object.

You use reference constraints as a convenient way to display measurements
that you would otherwise have to calculate. For example, the width in the
illustration is constrained by the diameter constraint, dia1, and the linear
constraint, d1. The reference constraint, d2, displays the total width but does
not constrain it. The textual information in reference constraints is always
displayed within parentheses.
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You can set the Reference property in the Properties palette to convert a
dynamic or annotational constraint to a reference constraint.

NOTE You cannot change a reference constraint back to a dimensional constraint
if doing so would overconstrain the geometry.

To create a linear dimensional constraint

1 Click Parametric tab  ➤ Dimensional panel  ➤ Linear. 

2 Select the two constraint points on the object.

3 Specify the dimension line location.

4 Enter a value or specify an expression (name=value).

5 Press Enter.

By default, a dynamic constraint is created.

Toolbar: Parametric, Dimensional Constraints 
Command entry: DIMCONSTRAINT

To create a horizontal dimensional constraint

1 Click Parametric tab  ➤ Dimensional panel  ➤ Horizontal. 

2 Select the two constraint points on the object.

3 Specify the dimension line location.

4 Enter a value or specify an expression (name=value).

5 Press Enter.

By default, a dynamic constraint is created.

Toolbar: Parametric, Dimensional Constraints 
Command entry: DIMCONSTRAINT

To create a vertical dimensional constraint

1 Click Parametric tab  ➤ Dimensional panel  ➤ Vertical. 
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2 Select the two constraint points on the object.

3 Specify the dimension line location.

4 Enter a value or specify an expression (name=value).

5 Press Enter.

By default, a dynamic constraint is created.

Toolbar: Parametric, Dimensional Constraints 
Command entry: DIMCONSTRAINT

To create an aligned dimensional constraint

1 Click Parametric tab  ➤ Dimensional panel  ➤ Aligned. 

2 Select the two constraint points on the object.

3 Specify the dimension line location.

4 Enter a value or specify an expression (name=value).

5 Press Enter.

By default, a dynamic constraint is created.

Toolbar: Parametric, Dimensional Constraints 
Command entry: DIMCONSTRAINT

To create an angular dimensional constraint

1 Click Parametric tab  ➤ Dimensional panel  ➤ Angular. 

2 Select two lines or an arc object.

3 Specify the dimension line location.

4 Enter a value or specify an expression (name=value).

5 Press Enter.

By default, a dynamic constraint is created.

Toolbar: Parametric, Dimensional Constraints 
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Command entry: DIMCONSTRAINT

To create a radial dimensional constraint

1 Click Parametric tab  ➤ Dimensional panel  ➤ Radial. 

2 Select an arc or a circle object.

3 Specify the dimension line location.

4 Enter a value or specify an expression (name=value).

5 Press Enter.

By default, a dynamic constraint is created.

Toolbar: Parametric, Dimensional Constraints 
Command entry: DIMCONSTRAINT

To create a diameter dimensional constraint

1 Click Parametric tab  ➤ Dimensional panel  ➤ Diameter. 

2 Select an arc or a circle object.

3 Specify the dimension line location.

4 Enter a value or specify an expression (name=value).

5 Press Enter.

By default, a dynamic constraint is created.

Toolbar: Parametric, Dimensional Constraints 
Command entry: DIMCONSTRAINT

To convert a dynamic constraint to an annotational constraint

1 Select the dynamic constraint.

2 At the Command prompt, enter properties.

3 Click the down arrow at the right of the Constraint Form property and
select Annotational.
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The Properties palette is populated with additional properties as the
constraint is now an annotational constraint.

Toolbar: Parametric, Dimensional Constraints
Command entry: DIMCONSTRAINT

To convert a dynamic or annotative constraint to a reference constraint

1 Select the dynamic or annotational constraint.

2 At the Command prompt, enter properties.

3 Click the down arrow at the right of the Reference property and select
Yes.

The Expression property is shaded to denote that it is not editable.

Toolbar: Parametric, Dimensional Constraints
Command entry: DIMCONSTRAINT

To change the dimension name format

1 Select an annotational constraint, right-click in the drawing area, and
click Dimension Name Format.

2 Select Value, Name, or Name and Expression.

The Expression reflects the selected dimension name format.

Toolbar: Parametric, Dimensional Constraints
Command entry: DIMCONSTRAINT

Quick Reference

Commands

DELCONSTRAINT

Removes all geometric and dimensional constraints from a selection set of
objects.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.
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LIST

Displays property data for selected objects.

PARAMETERS

Controls the associative parameters used in the drawing.

-PARAMETERS

Controls the associative parameters used in the drawing.

PARAMETERSCLOSE

Closes the Parameters Manager palette.

TEXTEDIT

Edits a dimensional constraint, dimension, or text object.

System Variables

CONSTRAINTNAMEFORMAT

Controls the text format for dimensional constraints.

CONSTRAINTRELAX

Indicates whether constraints are enforced or relaxed when editing an object.

CONSTRAINTSOLVEMODE

Controls constraint behavior when applying or editing constraints.

DIMCONSTRAINTICON

Displays the lock icon next to the text for dimensional constraints.

DYNCONSTRAINTDISPLAY

Displays or hides dynamic constraints.

DYNCONSTRAINTMODE

Displays hidden dimensional constraints when constrained objects are
selected.

PARAMETERCOPYMODE

Controls how constraints and referenced variables are copied when replicating
constrained geometry.

PARAMETERSSTATUS

Indicates whether the Parameters Manager palette is displayed or hidden.
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Control the Display of Dimensional Constraints
You can display or hide dynamic and annotational constraints within a
drawing.

Display or Hide Dynamic Constraints

You can hide all dynamic constraints globally within a drawing to reduce
clutter when you want to work with geometric constraints only, or when you
need to continue other work in the drawing. You can turn on their display
when needed from the ribbon or with the DYNCONSTRAINTDISPLAY system
variable.

By default, if you select an object associated with a hidden dynamic constraint,
all dynamic constraints associated with that object will display.

Display or Hide Annotational Constraints

You control the display of annotational constraints as you would with
dimension objects—you assign them to a layer and turn the layer on or off as
needed. You can also specify object properties for annotational constraints
such as dimension style, color, and lineweight.

To display dynamic dimensional constraints

 ➤ Click Parametric tab  ➤ Dimensional panel  ➤ Show Dynamic
Constraints.

To hide dynamic dimensional constraints

1 Ensure that dynamic constraints are displayed.

2 Click Parametric tab  ➤ Dimensional panel  ➤ Show Dynamic
Constraints

Quick Reference

Commands

DELCONSTRAINT

Removes all geometric and dimensional constraints from a selection set of
objects.
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DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

LIST

Displays property data for selected objects.

PARAMETERS

Controls the associative parameters used in the drawing.

-PARAMETERS

Controls the associative parameters used in the drawing.

PARAMETERSCLOSE

Closes the Parameters Manager palette.

TEXTEDIT

Edits a dimensional constraint, dimension, or text object.

System Variables

CONSTRAINTNAMEFORMAT

Controls the text format for dimensional constraints.

CONSTRAINTRELAX

Indicates whether constraints are enforced or relaxed when editing an object.

CONSTRAINTSOLVEMODE

Controls constraint behavior when applying or editing constraints.

DIMCONSTRAINTICON

Displays the lock icon next to the text for dimensional constraints.

DYNCONSTRAINTDISPLAY

Displays or hides dynamic constraints.

DYNCONSTRAINTMODE

Displays hidden dimensional constraints when constrained objects are
selected.

PARAMETERCOPYMODE

Controls how constraints and referenced variables are copied when replicating
constrained geometry.

Constrain Distances and Angles between Objects | 753



PARAMETERSSTATUS

Indicates whether the Parameters Manager palette is displayed or hidden.

Modify Objects with Dimensional Constraints Applied
You can control lengths, distances, and angles of objects by changing
constraint values, by manipulating dimensional constraints using grips, or by
changing user variables or expressions associated with dimensional constraints.

Edit Dimensional Constraint Names, Values, and Expressions

You can easily edit the names, values, and expressions that are associated with
dimensional constraints. There are four access points that you can use:

■ Double-click the dimensional constraint, select the dimensional constraint
and use the shortcut menu, or the TEXTEDIT command.

■ Open the Properties palette and select the dimensional constraint

■ Open the Parameters Manager and select the dimensional constraint either
from the list or from within the drawing

■ Customize the Quick Properties palette to display several constraint
properties

When you enter the changes, the results will propagate across the drawing
immediately.

NOTE You cannot edit the Expression and Value properties for a reference
constraint.

Modify Dimensional Constraints Using Their Grips

You can modify a constrained object either by using the triangular grips or
the square grips on the associated dimensional constraint.

The triangular grips on dimensional constraints provide a way of changing
the constraint value while maintaining the constraint.

For example, you can change the length of the diagonal line by using the
triangular grips on the Aligned dimensional constraint. The diagonal line
maintains its angle and the location of one of its endpoints.
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The square grip on dimensional constraints provides a way of changing the
location of the text and other elements.

Dynamic dimensional constraints are more limited than annotational
dimensional constraints in where the text can be located.

NOTE Triangular grips are not available for dimensional constraints that reference
other constraint variables in expressions.

For information about temporarily relaxing constraints, see Overview of
Constraints on page 718.

To grip-edit a dimensional constraint

1 Select a constrained object.

2 Click the grips and drag to edit the geometry.

Toolbar: Parametric, Dimensional Constraints 
Command entry: DIMCONSTRAINT
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To edit a dimensional constraint in-place

1 Double-click a dimensional constraint to display the in-place text editor.

2 Enter the new name, value, or expression (name=value).

3 Press Enter to confirm the change.

Toolbar: Parametric, Dimensional Constraints 
Command entry: DIMCONSTRAINT

To edit a dimensional constraint using the Properties palette

1 Select a dimensional constraint, right-click in the drawing area, and click
Properties.

2 Enter the new values for Name, Expression, and Description text boxes.

Toolbar: Parametric, Dimensional Constraints 
Command entry: DIMCONSTRAINT

To turn a dimensional constraint off

1 Click a constrained object in a drawing to select it.

The grips are displayed on the object to show that it is selected.

2 Move your cursor over a grip. The grip color turns red.

3 Click the grip.

4 Press and release the Ctrl key.

5 Move the object to the desired location.

The constraint is relaxed for the object, and you should be able to move
it.

Toolbar: Parametric, Dimensional Constraints 
Command entry: DIMCONSTRAINT
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To edit the dimensions using the Parameters Manager palette

1 Click Parametric tab  ➤ Manage panel  ➤ Parameters Manager. 

2 Double-click the variable you want to edit.

3 Press Tab to navigate across the columns.

4 Change the values in the appropriate column.

NOTE You can modify only the Name, Expression, and Description columns.

5 Press Enter.

Toolbar: Parametric, Dimensional Constraints 
Command entry: DIMCONSTRAINT

Quick Reference

Commands

DELCONSTRAINT

Removes all geometric and dimensional constraints from a selection set of
objects.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

LIST

Displays property data for selected objects.

PARAMETERS

Controls the associative parameters used in the drawing.

-PARAMETERS

Controls the associative parameters used in the drawing.

PARAMETERSCLOSE

Closes the Parameters Manager palette.
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TEXTEDIT

Edits a dimensional constraint, dimension, or text object.

System Variables

CONSTRAINTNAMEFORMAT

Controls the text format for dimensional constraints.

CONSTRAINTRELAX

Indicates whether constraints are enforced or relaxed when editing an object.

CONSTRAINTSOLVEMODE

Controls constraint behavior when applying or editing constraints.

DIMCONSTRAINTICON

Displays the lock icon next to the text for dimensional constraints.

DYNCONSTRAINTDISPLAY

Displays or hides dynamic constraints.

DYNCONSTRAINTMODE

Displays hidden dimensional constraints when constrained objects are
selected.

PARAMETERCOPYMODE

Controls how constraints and referenced variables are copied when replicating
constrained geometry.

PARAMETERSSTATUS

Indicates whether the Parameters Manager palette is displayed or hidden.

Constrain a Design with Formulas and Equations
You can control geometry using mathematical expressions that include the
names of dimensional constraints, user variables, and functions.

Formulas and equations can be represented either as expressions within
dimensional constraints or by defining a user variables. For example, the
following illustration represents a design that constrains a circle to the center
of the rectangle with an area equal to that of the rectangle.
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The Length and Width dimensional constraints are set to constants. The d1 and
d2 constraints are simple expressions that reference the Length and Width. The
Radius dimensional constraint is set to an expression that includes the square
root function, parentheses to determine the precedence of operations, the
Area user variable, the division operator, and the constant, PI. These parameters
are all displayed in the Parameters Manager.

As you can see, part of the equation for determining the area of the circle is
included in the Radius dimensional constraint and part was defined as a user
variable. Alternatively, the entire expression, sqrt (Length * Width / PI), could
have been assigned to the Radius dimensional constraint, defined in a user
variable, or some other combination.

Work with the Parameters Manager

The Parameters Manager displays dimensional constraints (both dynamic
constraints and annotational constraints), reference constraints, and user
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variables. You can easily create, modify, and delete parameters from the
Parameters Manager.

The Parameters Manager supports the following operations:

■ Click the name of a dimensional constraint to highlight the constraint in
the drawing.

■ Double-click a name or expression to edit it.

■ Right-click and click Delete to remove a dimensional constraint or user
variable.

■ Click a column heading to sort the list of parameters by name, expression,
or value.

NOTE With imperial units, the Parameters Manager interprets a minus or a dash
(-) as a unit separator rather than a subtraction operation. To specify subtraction,
include at least one space before or after the minus sign. For example, to subtract
9" from 5', enter 5' -9" rather than 5'-9".

Use Operators in Expressions
Dimensional constraints and user variables support the following operators
within expressions:

DescriptionOperator

Addition+

Subtraction or unary negation-

Floating point modulo%

Multiplication*

Division/

Exponentiation^

Parenthesis, expression delimiter( )

Decimal separator.
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Understand Precedence in Expressions

Expressions are evaluated according to the following standard mathematical
rules of precedence:

1 Expressions in parentheses first, starting with the innermost set

2 Operators in standard order: unary negation first, then exponents,
multiplication and division, and addition and subtraction last

3 Operators of equal precedence from left to right

Expressions are evaluated using the standard precedence as shown in the
following table in descending order.

Functions Supported in Expressions
The following functions are available for use in expressions:

SyntaxFunction

cos(expression)Cosine

sin(expression)Sine

tan(expression)Tangent

acos(expression)Arc cosine

asin(expression)Arc sine

atan(expression)Arc tangent

cosh(expression)Hyperbolic cosine

sinh(expression)Hyperbolic sine

tanh(expression)Hyperbolic tangent

acosh(expression)Arc hyperbolic cosine

asinh(expression)Arc hyperbolic sine

atanh(expression)Arc hyperbolic tangent

sqrt(expression)Square root
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SyntaxFunction

sign(expression)Signum function (-
1,0,1)

round(expression)Round to nearest in-
teger

trunc(expression)Truncate decimal

floor(expression)Round down

ceil(expression)Round up

abs(expression)Absolute value

max(expression1;expression2)Largest element in array

min(expression1;expression2)Smallest element in ar-
ray

d2r(expression)Degrees to radians

r2d(expression)Radians to degrees

ln(expression)Logarithm, base e

log(expression)Logarithm, base 10

exp(expression)Exponent, base e

exp10(expression)Exponent, base 10

pow(expression1;expression2)Power function

RandomRandom decimal, 0-1

In addition to these functions, the constants Pi and e are also available for
use in expressions.
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To create a user variable

1 Click Parametric tab  ➤ Manage panel  ➤ Parameters Manager. 

2 Click the New User Parameter icon.

A new user variable is created under the User Variables group.

Toolbar: Parametric 
Command entry: PARAMETERS

To reference a variable within an expression

1 Click Parametric tab  ➤ Manage panel  ➤ Parameters Manager. 

2 Double-click the variable you want to reference.

3 Right-click the cell in the Name column, and click Copy.

4 Double-click the Expression column where you want to include the
referenced variable.

5 Right-click the Expression column, and click Paste.

Toolbar: Parametric 
Command entry: PARAMETERS

To include a function in an expression

1 Click Parametric tab  ➤ Manage panel  ➤ Parameters Manager. 

2 Double-click the Expression column of the variable to which you want
to add the function.

3 Right-click the Expression column, and click Expressions.

4 Select the function to insert it in the Expression column.
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Toolbar: Parametric 
Command entry: PARAMETERS

To modify a user parameter

1 Click Parametric tab  ➤ Manage panel  ➤ Parameters Manager. 

2 Double-click the columns of the variable you want to edit.

3 Change the values of the appropriate columns.

NOTE You can modify only the Name, Expression, and Description columns.

4 Press Enter.

Toolbar: Parametric 
Command entry: PARAMETERS

To delete a user parameter

1 Click Parametric tab  ➤ Manage panel  ➤ Parameters Manager. 

2 Select the user variable you want to delete.

3 Click the Delete Parameter icon.

Toolbar: Parametric 
Command entry: PARAMETERS

To select a constrained object associated with a user parameter

1 Click Parametric tab  ➤ Manage panel  ➤ Parameters Manager. 

2 Click the dimensional variable to view the associated object in the
drawing.
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Toolbar: Parametric 
Command entry: PARAMETERS

Quick Reference

Commands

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

PARAMETERS

Controls the associative parameters used in the drawing.

-PARAMETERS

Controls the associative parameters used in the drawing.

Extract Geometric Information from Objects
The inquiry and calculation commands can provide information about objects
in your drawing and do useful calculations.

Obtain Distances, Angles, and Point Locations
You can obtain information about the relation between two specified points
or multiple points; for example, the distance between points or their angle in
the XY plane.

To determine the relation between points, you can display the

■ Distance between them

■ Angle between the points in the XY plane

■ Angle of the points from the XY plane

■ Delta, or changed, X, Y, and Z distances between them
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The ID command lists the X, Y, and Z coordinate values of a specified point.

See also:

■ Overview of Coordinate Entry on page 629

To calculate the distance and angle between two points

1 Click Tools tab ➤ Inquiry panel ➤ Distance.

2 Specify a first and second point for the distance you want to calculate.

3 Press ENTER.

The distance displays at the Command prompt in the current units
format.

Toolbar: Inquiry  
Command entry: DIST

To calculate the distance and angle between multiple points

1 Click Tools tab ➤ Inquiry panel ➤ Distance.

2 For the distance you want to calculate, specify a first and second point.

3 For the distance you want to calculate, specify the next point or points.

4 Press ENTER.

The distance displays at the Command prompt in the current units
format.
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Toolbar: Inquiry  
Command entry: DIST

Quick Reference

Commands

DIST

Measures the distance and angle between two points.

ID

Displays the UCS coordinate values of a specified location.

MEASUREGEOM

Measures the distance, radius, angle, area, and volume of selected objects or
sequence of points.

System Variables

DISTANCE

Stores the distance computed by the DIST command.

Utilities

No entries

Command Modifiers

No entries

Obtain Area and Mass Properties Information
You can obtain the area, perimeter, and mass properties defined by selected
objects or a sequence of points.

You can calculate the area and perimeter of a sequence of points. You can also
obtain the area, perimeter, and mass properties of any of several types of
objects.
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TIP A fast way to calculate an area bounded by several objects in 2D is to use the
BOUNDARY command. With BOUNDARY, you can pick a point within the area to
create a closed polyline or region. You can then use the Properties palette or the
LIST command to find the area and perimeter of the polyline or region.

Use Commands to Calculate Area

With the MEASUREGEOM and AREA commands, you can specify a series of
points or select an object to calculate area. If you need to calculate the
combined area of mutiple objects, you can keep a running total as you add
or subtract one area at a time from the selection set. You cannot use window
selection or crossing selection to select objects.

Total area and perimeter are saved in the AREA and PERIMETER system
variables.

In addition to area, with the MEASUREGEOM command, you can obtain
geometric information from objects such as distance, radius, angle, and volume.

Define an Area

You can measure an arbitrary closed region defined by the points you specify.
The points must lie on a plane parallel to the XY plane of the current UCS.

Calculate the Area, Perimeter, or Circumference of an Object

You can calculate the enclosed area and perimeter or circumference of circles,
ellipses, polylines, polygons, regions, and AutoCAD 3D solids. The information
displayed depends on the type of object selected:

■ Circles. Area and circumference display.

■ Ellipses, closed polylines, polygons, planar closed spline curves, and regions.
Area and perimeter display. For wide polylines, this area is defined by the
center of the width.
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■ Open objects such as open spline curves and open polylines. Area and
length display. Area is calcuated as though a straight line connects the
start point and endpoint.

■ AutoCAD 3D solids. Total 3D area for the object displays.

Example: How Various Areas Are Calculated

Combined Areas

Calculate Combined Areas

You can calculate the total area of multiple areas by specifying points or by
selecting objects. For example, you can measure the total area of selected
rooms in a floor plan.
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Subtract Areas from Combined Areas

You can subtract more than one area from a combined area as you calculate.
For example, if you have calculated the area of a floor plan, you can subtract
the area of a room.

Example: Subtraction of Areas from a Calculation

In the following example, the closed polyline represents a metal plate with
two large holes. The area of the polyline is first calculated and then the area
of each hole is subtracted. The area and perimeter or circumference of each
object displays, with a running total after each step.

The command prompt sequence is

Command: area
Specify first corner point or [Object/Add/Subtract]: a
Specify first corner point or [Object/Subtract]: o
(ADD mode) Select objects: Select the polyline (1)
Area = 0.34, Perimeter = 2.71
Total area = 0.34
(ADD mode) Select objects: Press ENTER
Specify first corner point or [Object/Subtract]: s
Specify first corner point or [Object/Add]: o
(SUBTRACT mode) Select objects: Select the lower circle (2)
Area = 0.02, Circumference = 0.46
Total area = 0.32
(SUBTRACT mode) Select objects: Select the upper circle (3)
Area = 0.02, Circumference = 0.46
Total area = 0.30
(SUBTRACT mode) Select circle or polyline: Press ENTER
Specify first corner point or [Object/Add]: Press ENTER

You can also use REGION to convert the plate and the holes to regions, subtract
the holes, and then use the Properties palette or the LIST command to find
the area of the plate.

TIP Use the QuickCalc calculator to convert from one system of area units to
another. For more information, see Use the QuickCalc Calculator on page 773.
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Calculate Mass Properties

With the MASSPROP command, you can analyze 3D solids and 2D regions
for their mass properties including volume, area, moments of inertia, center
of gravity, and so on. In addition, the result of the computations can be saved
to a text file.

See also:

■ Create and Combine Areas (Regions) on page 845

■ Overview of Object Properties on page 523

To calculate an area you define

1 Click Tools tab ➤ Inquiry panel ➤ Area.

2 Specify points in a sequence that define the perimeter of the area you
want to measure. Press ENTER.

The first and last points connect to form a closed area. The area and
perimeter display in the current units format.

Toolbar: Inquiry  
Command entry: AREA

To calculate the area of an object

1 Click Tools tab ➤ Inquiry panel ➤ Area.

2 At the command prompt, enter o (Object).

3 Select an object.

The area and perimeter of the selected object display in the current units
format.

Toolbar: Inquiry  
Command entry: AREA

To add an area as you calculate

1 Click Tools tab ➤ Inquiry panel ➤ Area.
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2 Enter a (Add).

3 Do one of the following:

■ Specify points to define the area you want to add. Press ENTER.

■ Enter o (Object) and select the objects you want to add.
Each new area and a running total of all areas displays in the current
units format.

4 Press ENTER twice to end the command.

Toolbar: Inquiry  
Command entry: AREA

To subtract an area as you calculate

1 While a combined area displays, enter s (Subtract).

2 Do one of the following:

■ Specify points to define the area you want to subtract. Press ENTER.

■ Enter o (Object) and select the objects you want to subtract.

The running total of all areas updates and displays as you define new
areas.

3 Press ENTER to end the command.

Toolbar: Inquiry  
Command entry: AREA

Quick Reference

Commands

AREA

Stores the last area computed by the AREA command.

LIST

Displays property data for selected objects.
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MASSPROP

Calculates the mass properties of regions or 3D solids.

MEASUREGEOM

Measures the distance, radius, angle, area, and volume of selected objects or
sequence of points.

PROPERTIES

Controls properties of existing objects.

QUICKCALC

Opens the QuickCalc calculator.

UNITS

Controls coordinate and angle display formats and precision.

System Variables

AREA

Stores the last area computed by the AREA command.

PERIMETER

Stores the last perimeter value computed by the AREA or LIST command.

Utilities

No entries

Command Modifiers

No entries

Use a Calculator
You can access a calculator function as you work with the program. You can
use either the QuickCalc calculator interface or the command prompt
calculator.

Use the QuickCalc Calculator
With the QuickCalc calculator, an interface that looks and functions like a
hand-held calculator, you can perform mathematical, scientific, and geometric
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calculations, convert units of measurement, manipulate the properties of
objects, and evaluate expressions.

Overview of QuickCalc
The QuickCalc calculator includes basic features similar to most standard
mathematical calculators.

In addition, QuickCalc has features specific to AutoCAD such as geometric
functions, a Units Conversion area, and a Variables area.

Unlike most calculators, QuickCalc is an expression builder. For greater
flexibility, it does not immediately calculate an answer when you click a
function. Instead, you compose an expression that you can easily edit and,
when you are finished, you click the equal sign (=) or press ENTER. Later, you
can retrieve the expression from the History area, modify it, and recalculate
the results.

With QuickCalc, you can

■ Perform mathematical and trigonometric calculations

■ Access and review previously entered calculations for re-evaluation

■ Use the calculator with the Properties palette to modify object properties

■ Convert units of measurement

■ Perform geometric calculations related to specific objects

■ Copy and paste values and expressions to and from the Properties palette
and the command prompt

■ Perform computations on mixed numbers (fractions), and feet and inches

■ Define, store, and use calculator variables

■ Use geometric functions from the CAL command
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Change QuickCalc Size and Appearance

Click the More/Less button on the calculator and only the Input box and
History area are displayed. You can use the expand/collapse arrows to open
and close areas. You can also control the size, location, and appearance of
QuickCalc. See Set Interface Options on page 111.

To clear the Input box

Do one of the following:

■ Click View tab  ➤  Palettes panel  ➤  QuickCalc.

■ On the QuickCalc toolbar, click the Clear button.

■ On the QuickCalc Number Pad, click the Clear button.
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Any current value or expression in the Input box is cleared and the value
is reset to 0.

Command entry: QUICKCALC

To use basic math functions in QuickCalc

1 Click View tab  ➤  Palettes panel  ➤  QuickCalc.

2 On the Number Pad, click a number.

3 Click an operator (+, -, *, /) button. Then enter the next number, and so
on.

4 Click the equal (=) sign.

The result is displayed in the Input box. The expression and result are
also displayed in the History area.

Command entry: QUICKCALC

To use scientific functions in QuickCalc

1 Click View tab  ➤  Palettes panel  ➤  QuickCalc.

2 On the Number Pad, enter a value.

3 In the Scientific area, click a function.

4 On the Number Pad, click the equal (=) sign.

The result is displayed in the Input box.

Command entry: QUICKCALC

To get the absolute value of a number using QuickCalc

1 Click View tab  ➤  Palettes panel  ➤  QuickCalc.

2 With the current value displayed, in the Scientific area click the abs
button.

3 On the Number Pad, click the equal (=) sign.
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The absolute value is displayed in the Input box.

Command entry: QUICKCALC

To round a number to the nearest integer using QuickCalc

1 Click View tab  ➤  Palettes panel  ➤  QuickCalc.

2 With the current value displayed, in the Scientific area click the rnd
button.

3 On the Number Pad, click the equal (=) sign.

The number, rounded to the nearest integer, is displayed in the Input
box.

Command entry: QUICKCALC

To display only the integer portion of a number with QuickCalc

1 Click View tab  ➤  Palettes panel  ➤  QuickCalc.

2 With the current value displayed, in the Scientific area click the trunc
button.

3 On the Number Pad, click the equal (=) sign.

The integer portion of the number is displayed in the Input box without
the decimal portion.

Command entry: QUICKCALC

To store a value in the QuickCalc memory

■ Click View tab  ➤  Palettes panel  ➤  QuickCalc.

■ With the current value displayed, click MS.
The previous value is overwritten and the new value is stored in memory.

Command entry: QUICKCALC
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To add the current value to the value stored in the QuickCalc memory

■ Click View tab  ➤  Palettes panel  ➤  QuickCalc.

■ With the current value displayed, click M+.
The sum of the new value and the value already in memory are displayed.

Command entry: QUICKCALC

To restore the value stored north QuickCalc memory

■ Click View tab  ➤  Palettes panel  ➤  QuickCalc.

■ With the current value displayed, click MR.
The displayed value or expression is appended and the value stored in
memory is displayed.

Command entry: QUICKCALC

To clear the value stored in the QuickCalc memory

■ Click View tab  ➤  Palettes panel  ➤  QuickCalc.

■ Click MC.
The value currently stored in memory is cleared.

Command entry: QUICKCALC

Quick Reference

Commands

QUICKCALC

Opens the QuickCalc calculator.

QCCLOSE

Closes QuickCalc.
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System Variables

QCSTATE

Indicates whether the QuickCalc calculator is open or closed.

Utilities

No entries

Command Modifiers

No entries

Access QuickCalc and Understand Its Behavior
Use QuickCalc directly as you would with a desktop calculator, or use it
transparently within a command or the Properties palette.

There are three ways to work with QuickCalc within the program:

■ Directly from the Tools menu, the Standard toolbar, a shortcut menu, or
the command prompt

■ Transparently during a command from a shortcut menu or the command
prompt

■ Transparently from the Properties palette

The method that you choose depends on how you are using QuickCalc.

Use QuickCalc Directly

When you work directly with QuickCalc, you can perform calculations and
unit conversions just as you would with a desktop calculator. You can use the
Windows clipboard (CTRL+C, CTRL+V) to transfer the results of your
calculations to other parts of the program or to external programs. Calculations
that you perform directly do not affect or change anything in your drawing.

You can access QuickCalc directly in the following ways:

■ Click Tools menu  ➤ Palettes  ➤ QuickCalc.

■ On the Standard toolbar, click the QuickCalc button.

■ In the drawing editor (with no command active), right-click and click
QuickCalc.
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■ At the command prompt, enter quickcalc.

■ At the command prompt, enter qc.

Use QuickCalc Transparently from Within a Command

During a command, you can access QuickCalc transparently in the following
ways:

■ Right-click to display the shortcut menu. Click QuickCalc.

■ At the command prompt, enter quickcalc.

■ At the command prompt, enter qc.

Calculations that you transfer to the command prompt affect the drawing.
For example, if you are drawing a line with the LINE command and you pass
an expression to the command prompt from the calculator, the next point of
the line uses the results, which might be a distance or coordinate value. In
QuickCalc, you click the Apply button to pass the value to the drawing based
on that expression.

NOTE When using QuickCalc transparently to calculate a value for direct distance
entry, Apply transfers the value to the command prompt. To use the value, position
the crosshairs to determine the direction and then press ENTER.

Use QuickCalc Transparently from the Properties Palette

When you want to modify properties and apply evaluated expressions to
objects in your drawing, you can access QuickCalc transparently from the
Properties palette. Use the following method:

■ Click any box in the Properties palette that contains a numeric value. Then
click the QuickCalc button that appears in the box.

■ After calculating a value, transfer the result to the Properties palette by
clicking the Apply button.

The object or drawing property is modified and the changes are displayed in
the drawing.

Calculate Mathematical Expressions in a Dialog Box

You can also enter and evaluate mathematical expressions in a dialog box
using the following format: =expression<ALT+ENTER>.
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NOTE To evaluate expressions in a dialog box, make sure the system variable,
CALCINPUT, is set to 1.

To use the QuickCalc calculator

Do one of the following:

■ Click View tab  ➤  Palettes panel  ➤  QuickCalc.

■ QuickCalc

■ Right-click the drawing area to display a shortcut menu. Click QuickCalc.

Command entry: QUICKCALC

To use the QuickCalc calculator within a command

Do one of the following:

■ At the command prompt, enter 'quickcalc or 'qc.

■ Right-click to display a shortcut menu. Click QuickCalc.

To use the QuickCalc calculator with the Properties palette

1 Click View tab  ➤  Palettes panel  ➤  Properties.

2 Open the Properties palette.

3 Click one or more objects.

4 Click a box with a numeric property.

5 Click the QuickCalc button in the box.

Command entry: QUICKCALC
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Quick Reference

Commands

QUICKCALC

Opens the QuickCalc calculator.

QCCLOSE

Closes QuickCalc.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Enter, Evaluate, and Retrieve Expressions
Enter expressions in QuickCalc using standard mathematical rules of
precedence; review and retrieve computations from the History area; and
understand the rules for using imperial units: length, area, and volume.

QuickCalc evaluates expressions according to the following standard
mathematical rules of precedence:

■ Expressions in parentheses first, starting with the innermost set

■ Operators in standard order: exponents first, multiplication and division
second, and addition and subtraction last

■ Operators of equal precedence from left to right

The Input box of the calculator is where you enter and retrieve expressions.
With QuickCalc, there are two ways you can enter data in the Input box. You
can either enter expressions using the QuickCalc Number Pad buttons, or you
can use the computer keyboard or numeric keypad. To use the computer
numeric keypad, you must have NUMLOCK on.
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To evaluate an expression, click the equal (=) sign on the QuickCalc Number
Pad, or press ENTER on the computer keyboard.

Understand the Syntax of Expressions

The syntax for QuickCalc expressions and command prompt calculator
expressions is identical. For example, to perform an operation on the vector
or coordinates 5,2,0, you enter [5,2,0] in the Input box.

You can use the GETVAR function to read the value of a system variable. The
syntax is

getvar(variable_name)

For more information see CAL.

Use the History Area

The History area keeps an ongoing record of calculations, similar to the paper
tape in a physical desk calculator. You can use the History area to review
previous operations and pass them back to the Input box for re-evaluation
with different parameters.

Rules for Displaying and Handling Units

QuickCalc adheres to the following rules:

■ Results of calculations are always expressed in decimal format unless a
distance is entered in feet and inches

■ Angular values entered in the Input box are assumed to be degrees
regardless of the settings in the Drawing Units dialog box. To specify
radians, grads, and degrees, append an r, g, or d after the angle value.

■ Results of angular calculations are always expressed in degrees with full
AutoCAD precision.

When the drawing units are set to architectural units, the calculator displays
the results of calculations of imperial units in the architectural format and
rounds to the display precision (LUPREC) specified in the drawing. The results
for all other calculations display in decimal format with full precision.

You can separate feet, inches, and fractional inches with a dash, a space, or
nothing. You can use any of the following syntax cases to enter valid feet-inch
formatted values:

■ 5' or 60"
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■ 5'-9" or 5' 9" or 5'9"

■ 5'-1/2" or 5' 1/2" or 5'1/2"

■ 5'-9-1/2" or 5' 9-1/2" or 5'9-1/2"

■ 5'-9 1/2" or 5' 9 1/2" or 5'9 1/2"

To designate inches for linear calculations, entering double quotes (") is
optional. For example, instead of entering 5'9-1/2", you could enter 5'9-1/2.

WARNING With imperial units, QuickCalc interprets a minus or a dash (-) as a
unit separator rather than a subtraction operation. To specify subtraction, include
at least one space before or after the minus sign. For example, to subtract 9" from
5', enter 5' -9" rather than 5'-9".

You can use QuickCalc to calculate square feet and cubic feet. To enter square
or cubic feet, you must enter units using these abbreviations:

■ sq. ft. or sq ft

■ cu. ft. or cu ft

Convert Decimal Units into Imperial Units

For distance measurements, enter an inches sign (") after the number in the
results display. For example, if the computed distance is 15, enter " after the
15, press ENTER or click = and the result displays in imperial units as 1'-3".

For computed results, enter the initial values in feet (') and inches (") to display
the results in feet and inches. For example:

■ 5 * 6 = 30

■ 5" * 6 = 2'-6"

■ 5" * 6" = 30 sq. in.

■ 5" * 0'-6" = 0.208333333 sq. ft.

To copy and paste a value from the QuickCalc Input box

1 Right-click the value in the Input box. Click Copy.

The current entry is copied to the clipboard.

2 Click in the new location and then right-click. Click Paste.
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The value is copied to the new location.

To paste a value from the QuickCalc Input box to the command line

■ On the QuickCalc toolbar, click the Paste Value to Command Line button.
The value in the Input box is pasted into the command line.

To clear the History area

■ On the QuickCalc toolbar, click the Clear History button.

Shortcut menu: Right-click the History area. Click Clear History.

To reuse a stored value or expression in the QuickCalc History area

1 Click the C button to clear the Input box if needed.

2 In the History area, double-click a value or expression. The value or
expression is displayed in the Input box.

NOTE The cursor must be on the value or expression to select it.

To change the font color of values or expressions in the QuickCalc History
area

1 Right-click in the History area. Click either Value Font Color or Expression
Font Color.

2 In the Color dialog box, click a Basic Color or click Define Custom Colors.

With Define Custom Colors, you can select a custom color and add it to
Custom Colors.

3 Click OK.

The colors you selected for values and expressions in the History area are
displayed.

Right-click Expression Font Color or Value Font Color. Click Basic Color
or Define Custom Colors.

To copy and paste an expression from the QuickCalc History area

1 Right-click the expression in the History area. Click Copy.

The current entry is copied to the clipboard.
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2 Right-click in the new location. Click Paste.

The expression is copied to the new location.

To append a value or expression from the QuickCalc History area to the Input
box

■ Double-click the value or expression in the History area.
The value or expression is appended to the Input box.

NOTE The cursor must be on the value or expression to select it.

Shortcut menu: Right-click Append Value to Input Area or Append
Expression to Input Area.

To modify a property in the Properties palette with QuickCalc

1 Select an object.

NOTE If QuickCalc is displayed on your desktop when you work with the
Properties palette, it is temporarily hidden while you use the modal calculator
from within the Properties palette.

2 In the Geometry section of the Properties palette, click on the value of a
property.

A small calculator icon is displayed to the right of the value.

NOTE Only properties that are displayed with a white background can be
changed.

3 Click the calculator icon.

QuickCalc opens and displays the current value of the object in the Input
box.

4 Perform a calculation on the displayed value and click the equal sign (=)
button.

The new value is displayed in the Input box.

5 Click Apply.

NOTE The Apply button is only available for editable number-based
properties.
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The calculator closes and the new value is displayed in the Properties
palette. The object is modified in the drawing.

To obtain X, Y, Z coordinate values for a point using QuickCalc

1 NOTE The QuickCalc toolbar Get Coordinates button uses the cur function.

On the QuickCalc toolbar, click the Get Coordinates button.

QuickCalc temporarily closes and you are prompted to specify a point.

2 In the drawing, click a point.

QuickCalc opens and displays the coordinate values of the point in the
Input box.

To measure the distance between two points using QuickCalc

1 NOTE The QuickCalc toolbar Distance Between Two Points button uses the
dist(p1,p2) function.

On the QuickCalc toolbar, click the Distance Between Two Points button.

QuickCalc temporarily closes and you are prompted to specify two points.

2 In the drawing, click the first point and then the second point.

QuickCalc opens and displays the value of the distance between the two
points in the Input box.

To get the angle of a line defined by two points using QuickCalc

1 NOTE The QuickCalc toolbar Angle of Line Defined by Two Points button
uses the ang(p1,p2) function.

On the QuickCalc toolbar, click the Angle of Line Defined by Two Points
button.

QuickCalc temporarily closes and you are prompted to specify two points.

2 Enter the coordinate values for the first point and then the second point.

QuickCalc opens and appends the value of the angle between the two
points to the end of any value or expression already present in the Input
box.
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To get the intersection of a line defined by four points using QuickCalc

1 NOTE The QuickCalc Intersection of Two Lines Defined by Four Points button
uses the ill(p1,p2,p3,p4) function.

On the QuickCalc toolbar, click the Intersection of Two Lines Defined
by Four Points button.

QuickCalc temporarily closes and you are prompted to specify four points.

2 Enter the coordinate values for the first point of line one, then the second
point of line one. Next, enter the coordinate values for the first point of
line two, then the second point of line two.

QuickCalc opens and appends the value of the evaluated expression to
the end of any value or expression already present in the Input box.

Quick Reference

Commands

QUICKCALC

Opens the QuickCalc calculator.

QCCLOSE

Closes QuickCalc.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Convert Units of Measurement
In the Units Conversion area of QuickCalc, you can obtain equivalent values
for different units of measurement.
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Unit conversions are available for length, area, volume, and angular values.
Based on which unit type you select, you can then select a list of units to
convert from and a list of units to convert to.

The Value to Convert box automatically displays the value from the Input
box. You can also enter a different value. The results of the units conversion
displays in the Converted Value box. You can paste this result to the Input
box by clicking the QuickCalc icon in the Converted Value box.

NOTE In the Value to Convert box, enter decimal values without units.

To convert units of measurement with QuickCalc

1 In the Units Conversion area, select a unit category on the Units Type
list.

2 In the Convert From list, select the type of unit you are converting from.

3 In the Convert To list, select the type of unit you are converting to.

4 In the Value to Convert box, enter the value you want to convert. Press
ENTER.

The converted value is displayed in the Converted Value box.

To copy a unit conversion result to the Input box of QuickCalc

■ On the Units Conversion title bar, click the Return Conversion Value to
Input Area button.
The converted value is displayed in the Input box.

To convert radians to degrees using QuickCalc

1 On the Number Pad, enter a value in radians.

2 In the Scientific area, click the r2d button.

3 On the Number Pad, click the equal (=) sign.

The conversion is displayed in the Input box.
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To convert degrees to radians using QuickCalc

1 On the Number Pad, enter a value in degrees.

2 In the Scientific area, click the d2r button.

3 On the Number Pad, click the equal (=) sign.

The conversion is displayed in the Input box.

Quick Reference

Commands

QUICKCALC

Opens the QuickCalc calculator.

QCCLOSE

Closes QuickCalc.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create and Use Calculator Variables
The Variables area of QuickCalc stores calculator variables that you can access
as needed. Calculator variables can either be constants or functions.

You can use the Variables area to define, store, and retrieve calculator variables.
Calculator variables can either be constants (coordinates/vectors, real numbers,
and integers) or functions. In the Variables area, you can

■ Click a calculator variable to display information such as value, type, and
description in the Details box at the bottom of the Variables area.

■ Double-click a calculator variable to load it into the QuickCalc Input box.
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Additional operations are available on the shortcut menus in the Variables
area.

Create New Calculator Variables

You can create new calculator variables using the shortcut menus in the
Variables area. When defining new calculator variables in the Variable
Definition dialog box, the following rules apply:

■ Constants. Any expression entered in the Value or Expression text entry
box is evaluated before the calculator variable is stored. Calculator variables
that are defined as constants are available “globally.” You can access and
use global constants in different drawings and sessions.

■ Functions. Any expression entered in the Value or Expression text entry
box is stored as text. Functions are evaluated when used in the QuickCalc
Input box.

Create Global Constants

You can use one of the following methods to create global constants:

■ Enter an expression in the Input box using the format $variable_name=value.
For example, to define the golden ratio to 8 decimal places as a global
constant called Phi, enter $Phi=1.61803399 in the Input box.

■ Click the New Variable button in the Variables area title bar. In the
Variables Definition dialog box, click Constant and fill in the other boxes.

■ Right-click the Variables area. Click New Variable.

Access Global Constants

You can access global constants and pass them to the Input box of the
QuickCalc as follows:

■ Double-click a variable in the Variables area of QuickCalc.

■ Click a variable from the list of calculator variables, and click the Return
Variable to Input Area button.

■ Enter a dollar sign ($) followed by the variable name, and press ENTER.

To use a global constant in a text or numeric entry box in a window or dialog
box, use the syntax: =$variable_name followed by pressing the END key. For
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example, to use the previously mentioned global variable, Phi, enter =$Phi
and press the END key.

NOTE In QuickCalc, only constants can be directly referred to by their global
variable names in the text or numeric entry boxes in windows and dialog boxes.

Use Shortcut Functions
Several sample calculator variables have been predefined and stored in the
Shortcut Functions category. These are geometric expressions that combine
CAL functions with the Endpoint Snap mode. The following table describes
the predefined variables that are available in the Variables area of the calculator.

DescriptionShortcut ForVariable

Distance between two endpointsdist(end,end)dee

Intersection of two lines defined by four end-
points

ill(end,end,end)ille

Midpoint between two endpoints(end+end)/2mee

Unit vector in the XY plane and normal to two
endpoints

nor(end,end)nee

Radius of a selected circle, arc, or polyline arcradrad

Vector from two endpointsvee(end,end)vee

Unit vector from two endpointsvec1(end,end)vee1

You can easily modify these calculator variables or create your own. For more
information, see the CAL command.

Organize Variables into Categories

You can organize calculator variables in the Variables area under several
categories. This results in a one-level tree structure. The Shortcut Functions
category has already been created and contains several functions.

Use the shortcut menu in the Variables area to create, rename, or delete variable
categories.
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To use a predefined variable in a QuickCalc expression

1 In the Variables area, click the variable you want to use.

2 On the QuickCalc Variables title bar, click the Return Variable to Input
Area button.

The variable is displayed in the Input box as part of your expression.

To create a new variable in QuickCalc

1 On the QuickCalc Variables title bar, click the New Variable button.

2 In the Variable Definition dialog box, under Variable Type, select Constant
or Function.

3 In the Variable Definition dialog box, under Variable Properties Name,
enter a name for the variable. Variable names cannot contain spaces or
special characters.

NOTE When referencing this variable from the Input box, the variable name
must begin with the dollar sign ($) to differentiate it from local LISP variables.

4 Under Variable Properties Group With, click New.

5 In the Category Definition dialog box, under Category Properties Name,
enter a name for the new category.

6 Under Description, enter a description for the new category. Click OK.

7 In the Variable Definition dialog box, under Value or Expression, enter
a value or expression for the new variable.

8 Under Description, enter a description of the new variable. Click OK.

The new variable is now displayed in the Variables area.

To edit a variable in QuickCalc

1 In the Variables area, click the variable you want to edit.

2 On the QuickCalc Variables title bar, click the Edit Variable button.

3 In the Variable Definition dialog box, make the edits to the variable.
Click OK.

To delete a variable in QuickCalc

1 In the Variables area, click the variable you want to delete.
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2 On the QuickCalc Variables title bar, click the Delete button.

To create a new global constant in the Input box of QuickCalc

■ In the Input box of QuickCalc, enter the following syntax:
$variable_name=value.
For example, you could center $Phi=1.618

NOTE Global variables are not case-sensitive.

QuickCalc adds the global constant to the list of variables in the Variables
area.

To access a global constant from dialog box or window

■ In any text or numeric entry box, enter an expression using the syntax:
=$variable_name followed by pressing the END key.

To evaluate mathematical expressions in a dialog box

1 If necessary, set the CALCINPUT system variable to 1.

2 In a dialog box, in an area where you can enter a numeric value, enter a
mathematical expression in the following format: =expression (for example,
=5+3).

3 Press Alt+Enter on the keyboard.

The expression is evaluated and its value is displayed.

CALCINPUT

Quick Reference

Commands

QCCLOSE

Closes QuickCalc.

QUICKCALC

Opens the QuickCalc calculator.
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System Variables

CALCINPUT

Controls whether mathematical expressions and global constants are
evaluated in text and numeric entry boxes of windows and dialog boxes.

Utilities

No entries

Command Modifiers

No entries

Use the Command Prompt Calculator
By entering an expression in the command prompt calculator, you can quickly
solve a mathematical problem or locate points in your drawing.

The CAL command runs the 3D calculator utility to evaluate vector expressions
(combining points, vectors, and numbers) and real and integer expressions.
The calculator performs standard mathematical functions. It also contains a
set of specialized functions for calculations involving points, vectors, and
AutoCAD geometry. With the CAL command, you can

■ Calculate a vector from two points, the length of a vector, a normal vector
(perpendicular to the XY plane), or a point on a line

■ Calculate a distance, radius, or angle

■ Specify a point with the pointing device

■ Specify the last-specified point or intersection

■ Use object snaps as variables in an expression

■ Convert points between a UCS and the WCS

■ Filter the X, Y, and Z components of a vector

■ Rotate a point around an axis
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Evaluating Expressions
CAL evaluates expressions according to standard mathematical rules of
precedence.

Mathematical operators in order of precedence

OperationOperator

Groups expressions( )

Indicates numeric exponent^

Multiplies and divides numbers*, /

Adds and subtracts numbers+, -

Calculating Points

You can use CAL whenever you need to calculate a point or a number within
a command.

For example, you enter (mid+cen)/2 to specify a point halfway between the
midpoint of a line and the center of a circle.

The following example uses CAL as a construction tool. It locates a center
point for a new circle, and then calculates one fifth of the radius of an existing
circle.

Here is the command prompr sequence:

Command: circle
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 'cal
>> Expression: (mid+cen)/2
>> Select entity for MID snap: Select the notch line (1)
>> Select entity for CEN snap: Select the large circle (2)
Diameter/<Radius>: 'cal
>> Expression: 1/5*rad
>> Select circle, arc or polyline segment for RAD function: Select the large circle
(3)
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Calculate Mathematical Expressions in a Dialog Box

You can also enter and evaluate mathematical expressions in a dialog box
using the following format: =expression<ALT+ENTER>.

NOTE To evaluate expressions in a dialog box, make sure the system variable,
CALCINPUT, is set to 1.

To start the command prompt calculator

Do one of the following:

■ At the command prompt, enter CAL. Then, enter a CAL expression.

■ At a prompt for a command in progress, enter ‘CAL to start the CAL
command transparently. Then, enter a CAL expression to calculate a value
for that prompt.

Quick Reference

Commands

CAL

Evaluates mathematical and geometric expressions.

System Variables

CALCINPUT

Controls whether mathematical expressions and global constants are
evaluated in text and numeric entry boxes of windows and dialog boxes.

Utilities

No entries

Command Modifiers

No entries
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Draw Geometric Objects

You can create a range of objects, from simple lines and circles to spline curves, and ellipses.
In general, you draw objects by specifying points with the pointing device or by entering
coordinate values at the command prompt.

Draw Linear Objects
A line, the most basic object, can be one segment or a series of connected
segments.

Draw Lines
You can close a sequence of line segments so that the first and last segments
are joined.

You can assign properties to lines including color, linetype, and lineweight. For
more information about properties, see Work with Object Properties on page
523.

You specify the locations that define the endpoints of each line with precision.
You can

■ Enter the coordinate values for an endpoint, using either absolute or relative
coordinates

■ Specify an object snap relative to an existing object. For example, you can
specify the center of a circle as one endpoint of the line

■ Turn grid snap on and snap to a location

There are other methods for creating precise lines. A highly efficient technique
is to offset a line from an existing line, and then trim or extend it to the desired
length.
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Use polyline objects instead of line objects if you want the segments to be
connected as a single object.

See also:

■ Use Coordinates and Coordinate Systems (UCS) on page 629

■ Use Object Snaps on page 676

■ Adjust Grid and Grid Snap on page 686

■ Draw Polylines on page 801

■ Offset an Object on page 1111

■ Break and Join Objects on page 1138

To draw lines

1 Click Home tab  ➤  Draw panel  ➤  Line.

2 Specify the start point.

You can use the pointing device or enter coordinate values at the
command prompt.

3 Complete the first line segment by specifying the endpoint.

To undo the previous line segment during the LINE command, enter u
or click Undo on the toolbar.

4 Specify the endpoints of any additional line segments.

5 Press ENTER to end or c to close a series of line segments.

To start a new line at the endpoint of the last line drawn, start the LINE
command again and press ENTER at the Specify Start Point prompt.

Toolbar: Draw  
Command entry: LINE
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Quick Reference

Commands

LINE

Creates straight line segments.

RAY

Creates a line that starts at a point and continues to infinity.

XLINE

Creates a line of infinite length.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Draw Polylines
A polyline is a connected sequence of segments created as a single object. You
can create straight line segments, arc segments, or a combination of the two.

Polylines are ideal for applications including the following:

■ Contour lines for topographic, isobaric, and other scientific applications

■ Wiring diagrams and printed cicuit board layouts

■ Process and piping diagrams
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■ Extrusion profiles and extrusion paths for 3D solid modeling

Polylines can be created with several commands including PLINE, RECTANG,
POLYGON, DONUT, BOUNDARY, and REVCLOUD. All of these commands
result in a LWPOLYLINE (lightweight polyline) object type.

With the 3DPOLY command, you can create non-planar polylines that result
in a POLYLINE object type. Fewer options are available with 3D polylines.

After you create a polyline, you can edit it using grips or PEDIT. You can use
EXPLODE to convert polylines to individual line and arc segments.

NOTE You can convert a spline-fit polyline created with PEDIT into a true spline
object with SPLINE.

Create Wide Polylines

You can draw polylines of various widths by using the Width and Halfwidth
options. You can set the width of individual segments and make them taper
gradually from one width to another. These options become available after
you specify a starting point for the polyline.

The Width and Halfwidth options set the width of the next polyline segments
you draw. Widths greater than zero produce wide lines, which are filled if Fill
mode is on and outlined if Fill mode is off.

Intersections of adjacent wide segments are usually beveled. However,
nontangent arc segments, acute angles, or segments that use a dash-dot
linetype are not beveled.

Create Polylines from the Boundaries of Objects

You can create a polyline from the boundaries of objects that form a closed
area with BOUNDARY. A polyline created using this method is a separate
object, distinct from the objects used to create it.

To expedite the boundary selection process in large or complex drawings, you
can specify a group of boundary candidates, called a boundary set. You create
this set by selecting the objects you want to use define the boundary.
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See also:

■ Draw Rectangles and Polygons on page 807

■ Modify Complex Objects on page 1153

■ Break and Join Objects on page 1138

■ Control Lineweights on page 614

To draw a polyline with straight segments

1 Click Home tab ➤ Draw panel ➤ Polyline. 

2 Specify the first point of the polyline.

3 Specify the endpoint of the first polyline segment.

4 Continue specifying segment endpoints as needed.

5 Press ENTER to end, or enter c to close the polyline.

To start a new polyline at the endpoint of the last polyline drawn, start
the PLINE command again and press ENTER at the Specify Start Point
prompt.

Toolbar: Draw  
Command entry: PLINE

To draw a line and arc combination polyline

1 Click Home tab ➤ Draw panel ➤ Polyline. 

2 Specify the start point of the polyline segment.
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3 Specify the endpoint of the polyline segment.

■ Switch to Arc mode by entering a (Arc) at the command prompt.

■ Return to Line mode by entering L (Line).

4 Specify additional polyline segments as needed.

5 Press ENTER to end, or enter c to close the polyline.

Toolbar: Draw  
Command entry: PLINE

To create a wide polyline

1 Click Home tab ➤ Draw panel ➤ Polyline. 

2 Specify the start point of the line segment.

3 Enter w (Width).

4 Enter the starting width of the line segment.

5 Specify the ending width of the line segment using one of the following
methods:

■ To create a line segment of equal width, press ENTER.

■ To create a tapering line segment, enter a different width.

6 Specify the endpoint of the polyline segment.

7 Continue specifying segment endpoints as needed.

8 Press ENTER to end, or enter c to close the polyline.

Toolbar: Draw  
Command entry: PLINE
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To create a boundary polyline

1 Click Home tab ➤ Draw panel ➤ Boundary. 

2 In the Boundary Creation dialog box, in the Object Type list, select
Polyline.

3 Under Boundary Set, do one of the following:

■ To create a boundary set from all objects visible in the current
viewport, select Current Viewport. Avoid this option for large, complex
drawings.

■ To specify which objects to include in the boundary set, click New.
Select the objects that you want to use to create the boundary. Using
this option automatically selects the Existing Set option.

4 Click Pick Points.

5 Specify points within each area that you want to form a boundary
polyline.

This area must be totally enclosed; that is, there can be no gaps between
enclosing objects. You can select more than one area. Click Island
Detection if you want internal closed areas to be included in the boundary
set.

6 Press ENTER to create the boundary polyline and end the command.

The command creates a polyline in the shape of the boundary. Because
this polyline overlaps the objects used to create it, it may not be visible.
However, you can move, copy, or modify it just as you can any other
polyline.

Command entry: BOUNDARY

Quick Reference

Commands

3DPOLY

Creates a 3D polyline.

BOUNDARY

Creates a region or a polyline from an enclosed area.
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EXPLODE

Breaks a compound object into its component objects.

FILL

Controls the filling of objects such as hatches, 2D solids, and wide polylines.

PEDIT

Edits polylines and 3D polygon meshes.

PLINE

Creates a 2D polyline.

POLYGON

Creates an equilateral closed polyline.

RECTANG

Creates a rectangular polyline.

System Variables

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.

HPBOUND

Controls the object type created by the BHATCH and BOUNDARY commands.

PLINECONVERTMODE

Specifies the fit method used in converting splines to polylines.

PLINEGEN

Sets how linetype patterns generate around the vertices of a 2D polyline.

PLINETYPE

Specifies whether optimized 2D polylines are used.

PLINEWID

Stores the default polyline width.
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Utilities

No entries

Command Modifiers

No entries

Draw Rectangles and Polygons
You can create rectangles and regular polygons quickly. Creating polygons is
a simple way to draw equilateral triangles, squares, pentagons, hexagons, and
so on.

If necessary, you can use EXPLODE to convert the resulting polyline object
into lines.

Draw Rectangles

Use RECTANG to create closed polylines in a rectangular shape.

Draw Regular Polygons

Use POLYGON to create closed polylines with between 3 and 1,024
equal-length sides. The following illustrations show polygons created using
three methods. In each case, two points are specified.

See also:

■ Draw Polylines on page 801

To draw a circumscribed polygon

1 Click Home tab ➤ Draw panel ➤ Polygon. 
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2 At the command prompt, enter the number of sides.

3 Specify the center of the polygon (1).

4 Enter c to specify a polygon circumscribed about a circle.

5 Enter the radius length (2).

Toolbar: Draw  
Command entry: POLYGON

To draw a polygon by specifying one edge

1 Click Home tab ➤ Draw panel ➤ Polygon. 

2 At the command prompt, enter the number of sides.

3 Enter e (Edge).

4 Specify the start point for one polygon segment.

5 Specify the endpoint of the polygon segment.

Toolbar: Draw  
Command entry: POLYGON

To draw an inscribed polygon

1 Click Home tab ➤ Draw panel ➤ Polygon. 

2 At the command prompt, enter the number of sides.

3 Specify the center of the polygon.
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4 Enter i to specify a polygon inscribed within a circle of specified points.

5 Enter the radius length.

Toolbar: Draw  
Command entry: POLYGON

To draw a rectangle

1 Click Home tab ➤ Draw panel ➤ Rectangle. 

2 Specify the first corner of the rectangle.

3 Specify the other corner of the rectangle.

Toolbar: Draw  
Command entry: RECTANG

Quick Reference

Commands

BOUNDARY

Creates a region or a polyline from an enclosed area.

EXPLODE

Breaks a compound object into its component objects.

POLYGON

Creates an equilateral closed polyline.

RECTANG

Creates a rectangular polyline.
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System Variables

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.

HPBOUND

Controls the object type created by the BHATCH and BOUNDARY commands.

PLINEWID

Stores the default polyline width.

POLYSIDES

Sets the default number of sides for the POLYGON command.

SNAPANG

Sets the snap and grid rotation angle for the current viewport relative to the
current UCS.

Utilities

No entries

Command Modifiers

No entries

Draw Multiline Objects
Multilines are composed of 1 to 16 parallel lines, called elements.

When you draw a multiline, you can use the STANDARD style, which has two
elements, or specify a style that you created previously. You can also change
the justification and scale of the multiline before you draw it.

Multiline justification determines which side of the cursor that the multiline
is drawn, or whether it is centered on the cursor.

Multiline scale controls the overall width of the multiline using the current
units. Multiline scale does not affect linetype scale. If you change the multiline
scale, you might need to make equivalent changes to the linetype scale to
prevent dots or dashes from being disproportionately sized.
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Create Multiline Styles

You can create named styles for multilines to control the number of elements
and the properties of each element. The properties of multilines include

■ The total number of elements and position of each element

■ The offset distance for each element from the middle of the multiline

■ The color and linetype of each element

■ The visibility of the lines, called joints, that appear at each vertex

■ The type of end caps that are used

■ The background fill color of the multiline

You can add up to 16 elements to a multiline style. Elements with a positive
offset appear on one side of the middle of the multiline; elements with a
negative offset appear on the other side of the middle of the multiline.

See also:

■ Modify Multilines on page 1165

To draw a multiline

1 Click Draw menu  ➤ Multiline. 

2 At the command prompt, enter st to select a style.

3 To list available styles, enter the style name or enter ?.

4 To justify the multiline, enter j and select top, zero, or bottom
justification.

5 To change the scale of the multiline, enter s and enter a new scale.

Now draw the multiline.
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6 Specify the starting point.

7 Specify a second point.

8 Specify additional points, or press ENTER. If you specify three or more
points, you can enter c to close the multiline.

Command entry: MLINE

To create a multiline style

1 Click Format menu  ➤ Multiline Style. 

2 In the Multiline Style dialog box, click New.

3 In the Create New Multiline Style dialog box, enter a name for the
multiline style and select a multiline style from which to start. Click
Continue.
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4 In the New Multiline Style dialog box, select the parameters for the
multiline style. You can also enter a description.

Descriptions are optional and can be up to 255 characters, including
spaces.

5 Click OK.

6 In the Multiline Style dialog box, click Save to save the multiline style to
a file (the default is acad.mln). You can save multiline styles to the same
file.

If you create more than one multiline style, save the current style before
creating a new one or you lose the changes to the first style.
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Quick Reference

Commands

OFFSET

Creates concentric circles, parallel lines, and parallel curves.

MLINE

Creates multiple parallel lines.

MLSTYLE

Creates, modifies, and manages multiline styles.

System Variables

CMLSTYLE

Sets the multiline style that governs the appearance of the multiline.

Utilities

No entries

Command Modifiers

No entries

Draw Freehand Sketches
Sketching is useful for creating irregular boundaries or for tracing with a
digitizer.

You can use the SKETCH command to draw freehand sketches. Sketching is
useful for creating irregular boundaries or for tracing with a digitizer.
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Create Sketches

To sketch, use the pointing device like a pen, clicking to put the “pen” down
on the screen to draw and clicking again to lift it up and stop drawing.
Freehand sketches comprise many line segments. Each line segment can be a
separate object or a polyline. You set the minimum length or increment of
the segments. Small line segments allow for greater accuracy, but they can
greatly increase the drawing file size. For this reason, use this tool sparingly.

Before sketching, check the CELTYPE system variable to make sure the current
linetype is BYLAYER. If you use a linetype with dots or dashes and set the
sketch line segment shorter than the spaces or dashes, you won't see the spaces
or dashes.

Erase Freehand Lines

You erase freehand lines by using the Erase option of the SKETCH command.
In Erase mode, wherever the cursor intersects the freehand line, everything
from the intersection to the end of the line is erased.

Once you record freehand lines, you can't edit them or erase them with the
Erase option of SKETCH. Use the ERASE command after you finish sketching.

Sketch in Tablet Mode

You use Tablet mode with a digitizer. Sketching in Tablet mode is useful for
such things as tracing map outlines from paper directly into a drawing. You
can't turn off Tablet mode while sketching.

When Tablet mode is on, you can configure the program to map the paper
drawing's coordinate system directly into the world coordinate system. Thus,
there is a direct correlation between the coordinates where screen crosshairs
appear, the coordinates on the tablet, and the coordinates in the original paper
drawing. After configuring the program to match the coordinates of the paper
drawing, you may find that the area shown on the screen is not the area you
need. To avoid this problem, use ZOOM to display the entire work area before
you start to sketch.

With some digitizers you can't select the menus while Tablet mode is on. See
your digitizer documentation for details.

Maintain Sketching Accuracy

To ensure accuracy on a slow computer, set the record increment value to a
negative value. SKETCH uses this value as if it was positive but tests every
point received from the pointer against twice the record increment. If the
point is more than two record increments away, your computer beeps as a
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warning that you should slow down to avoid losing accuracy. For example,
if the record increment is -1, you should move the cursor in increments of no
more than 2. Using this method does not slow down the tracing speed.

To sketch and record freehand lines

1 At the command prompt, enter sketch.

2 At the Record Increment prompt, enter the minimum line segment length.

3 Click the start point to put the “pen” down.

When you move the pointing device, temporary freehand line segments
of the length you specified are drawn. SKETCH doesn't accept coordinate
input. During the command, freehand lines are displayed in a different
color.

4 Click the endpoint to lift the “pen” up so that you can move the cursor
around the screen without drawing. Click a new start point to resume
drawing from the new cursor position.

5 Enter r at any time to record (save) the line you're drawing in the database
and those already drawn.

If the pen is down, you can continue drawing after recording. If the pen
is up, click to resume drawing. The freehand line starts from wherever
the cursor is when you click.

6 Press ENTER to complete the sketch and record all unrecorded lines.

To erase freehand lines

1 While running the SKETCH command, with the pen up or down, enter
e (Erase).

If the pen was down, it moves up.

2 Move the cursor to the end of the line you drew last and then move it
back as far along the line as you want to erase.

3 To end the erasure and return to the SKETCH Command prompt, enter
p. To undo the erasure, enter e.

If you want to change the current viewport while sketching, make sure
the pen is up, all lines entered so far have been recorded, and Tablet mode
is off.
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Quick Reference

Commands

SKETCH

Creates a series of freehand line segments.

System Variables

SKETCHINC

Sets the record increment for the SKETCH command.

SKPOLY

Determines whether the SKETCH command generates lines or polylines.

Utilities

No entries

Command Modifiers

No entries

Draw Curved Objects
Curved objects are arcs, circles, polyline arcs, donuts, ellipses, and splines.

Draw Arcs
To create an arc, you can specify various combinations of center, endpoint,
start point, radius, angle, chord length, and direction values.

You can create arcs in several ways. With the exception of the first method,
arcs are drawn counterclockwise from the start point to the endpoint.

Draw Arcs by Specifying Three Points

You can create an arc by specifying three points. In the following example,
the start point of the arc snaps to the endpoint of a line. The second point of
the arc snaps to the middle circle in the illustration.
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Draw Arcs by Specifying Start, Center, End

You can create an arc using a start point, center, and a third point that
determines the endpoint.

The distance between the start point and the center determines the radius.
The endpoint is determined by a line from the center that passes through the
third point. The resulting arc is always created counterclockwise from the start
point.

Using different options, you can specify either the start point first or the center
point first.

Draw Arcs by Specifying Start, Center, Angle

You can create an arc using a start point, center, and an included angle.

The distance between the start point and the center determines the radius.
The other end of the arc is determined by specifying an included angle that
uses the center of the arc as the vertex. The resulting arc is always created
counterclockwise from the start point.

Using different options, you can specify either the start point first or the center
point first.
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The included angle determines the endpoint of the arc. Use the Start, End,
Angle method when you know both endpoints but cannot snap to a center
point.

Draw Arcs by Specifying Start, Center, Length

You can create an arc using a start point, center, and the length of a chord.

The distance between the start point and the center determines the radius.
The other end of the arc is determined by specifying the length of a chord
between the start point and the endpoint of the arc. The resulting arc is always
created counterclockwise from the start point.

Using different options, you can specify either the start point first or the center
point first.

The length of the chord of the arc determines the included angle.

Draw Arcs by Specifying Start, End, Angle

You can create an arc using a start point, endpoint, and an included angle.
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The included angle between the endpoints of the arc determines the center
and the radius of the arc.

Draw Arcs by Specifying Start, End, Direction

You can create an arc using a start point, endpoint, and a tangent direction
at the start point.

The tangent direction can be specified either by locating a point on the desired
tangent line, or by entering an angle. You can determine which endpoint
controls the tangent by changing the order in which you specify the two
endpoints.

Draw Arcs by Specifying Start, End, Radius

You can create an arc using a start point, endpoint, and a radius.

The direction of the bulge of the arc is determined by the order in which you
specify its endpoints. You can specify the radius either by entering it or by
specifying a point at the desired radius distance.

Draw Contiguous Tangent Arcs and Lines

Immediately after you create an arc, you can start a line that is tangent to the
arc at an endpoint by starting the LINE command and pressing ENTER at the
Specify First Point prompt. You need to specify only the line length.

Immediately after you create a line or an arc, you can start an arc that is
tangent at an endpoint by starting the ARC command and pressing ENTER at
the Specify Start Point prompt. You need to specify only the endpoint of the
new arc.
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See also:

■ Draw Polylines on page 801

■ Break and Join Objects on page 1138

To draw an arc by specifying three points

1 Click Home tab ➤ Draw panel ➤ 3-Point. 

2 Specify the start point.

3 Specify a point on the arc.

4 Specify the endpoint.

Toolbar: Draw  
Command entry: ARC

To draw an arc using a start point, a center point, and an endpoint

1 Click Home tab ➤ Draw panel ➤ Start, Center, End. 

2 Specify a start point.

3 Specify the center point.

4 Specify the endpoint.

Toolbar: Draw  
Command entry: ARC

To continue an arc with a tangential line

1 Complete the arc.

2 Click Home tab ➤ Draw panel ➤ Line. 
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3 Press ENTER at the first prompt.

4 Enter the length of the line and press ENTER.

Toolbar: Draw  
Command entry: LINE

To continue an arc with a tangential arc

1 Complete the arc.

2 Click Home tab ➤ Draw panel ➤ Continue. 

3 Specify the second endpoint of the tangent arc.

Toolbar: Draw  
Command entry: ARC

Quick Reference

Commands

ARC

Creates an arc.

LINE

Creates straight line segments.

OFFSET

Creates concentric circles, parallel lines, and parallel curves.

VIEWRES

Sets the resolution for objects in the current viewport.

System Variables

ANGDIR

Sets the direction of positive angles.
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LASTANGLE

Stores the end angle of the last arc entered relative to the XY plane of the
current UCS for the current space.

WHIPARC

Controls whether the display of circles and arcs is smooth.

Utilities

No entries

Command Modifiers

No entries

Draw Circles
To create circles, you can specify various combinations of center, radius,
diameter, points on the circumference, and points on other objects.

You can create circles in several ways. The default method is to specify the
center and the radius. Three other ways to draw a circle are shown in the
illustration.

Draw a Circle Tangent to Other Objects

The tangent point is a point where an object touches another object without
intersecting it. To create a circle that is tangent to other objects, select the
objects and then specify the radius of the circle. In the illustrations below,
the bold circle is the one being drawn, and points 1 and 2 select the objects
to which it is tangent.
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To create a circle tangent at three points, set running object snaps (OSNAP)
to Tangent and use the three-point method to create the circle.

See also:

■ Use Object Snaps on page 676

■ Draw Isometric Circles

To draw a circle by specifying a center point and radius or diameter

1 Do one of the following:

■ Click Home tab ➤ Draw panel ➤ Center, Radius. 

■ Click Home tab ➤ Draw panel ➤ Center, Diameter. 

2 Specify the center point.

3 Specify the radius or diameter.

Toolbar: Draw  
Command entry: CIRCLE

To create a circle tangent to two objects

1 Click Home tab ➤ Draw panel ➤ Tan, Tan, Radius. 

The command starts Tangent object snap mode.
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2 Select the first object to draw the circle tangent to.

3 Select the second object to draw the circle tangent to.

4 Specify the radius of the circle.

Toolbar: Draw  
Command entry: CIRCLE

Quick Reference

Commands

CIRCLE

Creates a circle.

OFFSET

Creates concentric circles, parallel lines, and parallel curves.

System Variables

CIRCLERAD

Sets the default circle radius.

WHIPARC

Controls whether the display of circles and arcs is smooth.

Utilities

No entries

Command Modifiers

No entries

Draw Polyline Arcs
A polyline is a connected sequence of line segments created as a single object.
You can create straight line segments, arc segments, or a combination of the
two.
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Multisegmented lines provide editing capabilities unavailable for single lines.
For example, you can adjust their width and curvature. After you've created
a polyline, you can edit it with PEDIT or use EXPLODE to convert it to
individual line and arc segments. You can

■ Convert a spline-fit polyline into a true spline with SPLINE

■ Use closed polylines to create a polygon

■ Create a polyline from the boundaries of overlapping objects

Create Arc Polylines

When you draw arc segments in a polyline, the first point of the arc is the
endpoint of the previous segment. You can specify the angle, center point,
direction, or radius of the arc. You can also complete the arc by specifying a
second point and an endpoint.

Create Closed Polylines

You can draw a closed polyline to create a polygon. To close a polyline, specify
the starting point of the last side of the object, enter c (Close), and press
ENTER.

Create Wide Polylines

You can draw polylines of various widths by using the Width and Halfwidth
options. You can set the width of individual segments and make them taper
gradually from one width to another. These options become available after
you specify a starting point for the polyline.

The Width and Halfwidth options set the width of the next polyline segments
you draw. Zero (0) width produces a thin line. Widths greater than zero
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produce wide lines, which are filled if Fill mode is on and outlined if Fill mode
is off. The Halfwidth option sets width by specifying the distance from the
center of the wide polyline to an outside edge.

Taper

When you use the Width option, you are prompted for both a starting and
an ending width. By entering different values, you can taper the polyline. The
starting and ending points of wide polyline segments are in the center of the
line. Intersections of adjacent wide segments are usually beveled. However,
nontangent arc segments, acute angles, or segments that use a dash-dot
linetype are not beveled.

Create Polylines from the Boundaries of Objects

You can create a polyline from the boundaries of overlapping objects that
form a closed area. A polyline created using the boundary method is a separate
object, distinct from the objects used to create it. You can edit it using the
same methods used to edit other polylines.

To expedite the boundary selection process in large or complex drawings, you
can specify a group of boundary candidates, called a boundary set. You create
this set by selecting the objects you want to use to define the boundary.

See also:

■ Modify Splines on page 1160

■ Modify or Join Polylines on page 1155

■ Break and Join Objects on page 1138

■ Control Lineweights on page 614
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To draw a polyline with straight segments

1 Click Home tab ➤ Draw panel ➤ Polyline. 

2 Specify the first point of the polyline.

3 Specify the endpoint of the first polyline segment.

4 Continue specifying segment endpoints as needed.

5 Press ENTER to end, or enter c to close the polyline.

To start a new polyline at the endpoint of the last polyline drawn, start
the PLINE command again and press ENTER at the Specify Start Point
prompt.

Toolbar: Draw  
Command entry: PLINE

To draw a line and arc combination polyline

1 Click Home tab ➤ Draw panel ➤ Polyline. 

2 Specify the start point of the polyline segment.

3 Specify the endpoint of the polyline segment.

■ Switch to Arc mode by entering a (Arc) at the command prompt.

■ Return to Line mode by entering L (Line).

4 Specify additional polyline segments as needed.

5 Press ENTER to end, or enter c to close the polyline.

Toolbar: Draw  
Command entry: PLINE
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To create a wide polyline

1 Click Home tab ➤ Draw panel ➤ Polyline. 

2 Specify the start point of the line segment.

3 Enter w (Width).

4 Enter the starting width of the line segment.

5 Specify the ending width of the line segment using one of the following
methods:

■ To create a line segment of equal width, press ENTER.

■ To create a tapering line segment, enter a different width.

6 Specify the endpoint of the polyline segment.

7 Continue specifying segment endpoints as needed.

8 Press ENTER to end, or enter c to close the polyline.

Toolbar: Draw  
Command entry: PLINE

To create a boundary polyline

1 Click Home tab ➤ Draw panel ➤ Boundary. 

2 In the Boundary Creation dialog box, in the Object Type list, select
Polyline.

3 Under Boundary Set, do one of the following:

■ To create a boundary set from all objects visible in the current
viewport, select Current Viewport in the list. Avoid this option for
large, complex drawings.

■ To specify which objects to include in the boundary set, click New.
Select the objects that you want to use to create the boundary.
Choosing this option automatically selects the Existing Set option.

4 Click Pick Points.
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5 Specify points within each area that you want to form a boundary
polyline.

This area must be totally enclosed; that is, there can be no gaps between
enclosing objects. You can select more than one area.

6 Press ENTER to create the boundary polyline and end the command.

The command creates a polyline in the shape of the boundary. Because
this polyline overlaps the objects used to create it, it may not be visible.
However, you can move, copy, or modify it just as you can any other
polyline.

Command entry: BOUNDARY

Quick Reference

Commands

3DPOLY

Creates a 3D polyline.

BOUNDARY

Creates a region or a polyline from an enclosed area.

OFFSET

Creates concentric circles, parallel lines, and parallel curves.

PEDIT

Edits polylines and 3D polygon meshes.

PLINE

Creates a 2D polyline.

VIEWRES

Sets the resolution for objects in the current viewport.

System Variables

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.
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HPBOUND

Controls the object type created by the BHATCH and BOUNDARY commands.

PLINECONVERTMODE

Specifies the fit method used in converting splines to polylines.

PLINEGEN

Sets how linetype patterns generate around the vertices of a 2D polyline.

PLINETYPE

Specifies whether optimized 2D polylines are used.

PLINEWID

Stores the default polyline width.

Utilities

No entries

Command Modifiers

No entries

Draw Donuts
Donuts are filled rings or solid-filled circles that actually are closed polylines
with width.

To create a donut, you specify its inside and outside diameters and its center.
You can continue creating multiple copies with the same diameter by
specifying different center points. To create solid-filled circles, specify an inside
diameter of 0.
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To create a donut

1 Click Home tab ➤ Draw panel ➤ Donut. 

2 Specify the inside diameter (1).

3 Specify the outside diameter (2).

4 Specify the center of the donut (3).

5 Specify the center point for another donut, or press ENTER to complete
the command.

Quick Reference

Commands

DONUT

Creates a filled circle or a wide ring.

FILL

Controls the filling of objects such as hatches, 2D solids, and wide polylines.

System Variables

DONUTID

Sets the default for the inside diameter of a donut.

DONUTOD

Sets the default for the outside diameter of a donut.

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.
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Utilities

No entries

Command Modifiers

No entries

Draw Ellipses
The shape of an ellipse is determined by two axes that define its length and
width. The longer axis is called the major axis, and the shorter one is the
minor axis.

The illustrations below show two different ellipses created by specifying axis
and distance. The third point specifies only a distance and does not necessarily
designate the axis endpoint.

If you are drawing on isometric planes to simulate 3D, you can use ellipses to
represent isometric circles viewed from an oblique angle. First you need to
turn on Isometric Snap in the Drafting Settings dialog box.

See also:

■ Draw Isometric Circles

■ Break and Join Objects on page 1138
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To draw an isometric circle

1 Click Tools menu  ➤ Drafting Settings.

2 In the Drafting Settings dialog box, Snap and Grid tab, under Snap Type
and Style, click Isometric Snap. Click OK.

3 Click Home tab ➤ Draw panel ➤ Axis, End. 

4 Enter i (Isocircle).

5 Specify the center of the circle.

6 Specify the radius or diameter of the circle.

Toolbar: Draw  
Command entry: ELLIPSE

To draw a true ellipse using endpoints and distance

1 Click Home tab ➤ Draw panel ➤ Axis, End. 

2 Specify the first endpoint of the first axis (1).

3 Specify the second endpoint of the first axis (2).

4 Drag the pointing device away from the midpoint, and click to specify a
distance (3) for half the length of the second axis.

Toolbar: Draw  
Command entry: ELLIPSE
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To draw an elliptical arc using start and end angles

1 Click Home tab ➤ Draw panel ➤ Arc. 

2 Specify endpoints for the first axis (1 and 2).

3 Specify a distance to define half the length of the second axis (3).

4 Specify the start angle (4).

5 Specify the end angle (5).

The elliptical arc is drawn counterclockwise between the start point and
endpoint.

Toolbar: Draw  
Command entry: ELLIPSE

Quick Reference

Commands

ELLIPSE

Creates an ellipse or an elliptical arc.

System Variables

ANGDIR

Sets the direction of positive angles.

PELLIPSE

Controls the ellipse type created with ELLIPSE.
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Utilities

No entries

Command Modifiers

No entries

Draw Splines
A spline is a smooth curve that passes through or near a given set of points.
You can control how closely the curve fits the points.

The SPLINE command creates a particular type of spline known as a
nonuniform rational B-spline (NURBS) curve. A NURBS curve produces a
smooth curve between control points.

You create splines by specifying points. You can close the spline so that the
start and endpoints are coincident and tangent.

Tolerance describes how closely the spline fits the set of fit points you specify.
The lower the tolerance, the more closely the spline fits the points. At zero
tolerance, the spline passes through the points. You can change the
spline-fitting tolerance while drawing the spline to see the effect.

You can use two methods for creating splines:

■ Create spline curves with the Spline option of PEDIT to smooth existing
polylines created with PLINE. Such spline-fit polylines are created with
uniform knot vectors and are more likely to be included in drawings created
with earlier versions of the product.

■ Create splines, which are NURBS curves, with SPLINE. Drawings containing
splines use less memory and disk space than those containing spline-fit
polylines of similar shape.

You can easily convert spline-fit polylines into true splines with SPLINE.
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See also:

■ Modify Splines on page 1160

■ Break and Join Objects on page 1138

To convert a spline-fit polyline to a spline

1 Click Home tab ➤ Draw panel ➤ Spline. 

2 Enter o (Object).

3 Select a spline-fit polyline and press ENTER.

The selected object changes from a polyline to a spline.

To convert a spline by specifying points

1 Click Home tab ➤ Draw panel ➤ Spline. 

2 Specify the start point for the spline (1).

3 Specify points (2 through 5) to create the spline, and press ENTER.

4 Specify the start and end tangents (6, 7).

The spline below uses the same points but different start and end tangents.

The spline below uses the same points but a higher tolerance and different
start and end tangents.
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Toolbar: Draw  
Command entry: SPLINE

Quick Reference

Commands

PEDIT

Edits polylines and 3D polygon meshes.

PLINE

Creates a 2D polyline.

SPLINE

Creates a smooth curve that passes through or near specified points.

SPLINEDIT

Edits a spline or spline-fit polyline.

System Variables

PLINECONVERTMODE

Specifies the fit method used in converting splines to polylines.
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Utilities

No entries

Command Modifiers

No entries

Draw Helixes
A helix is an open 2D or 3D spiral.

You can use a helix as a path with the SWEEP command. For example, you
might sweep a circle along a helix path to create a solid model of a spring.

When you create a helix, you can specify the following:

■ Base radius

■ Top radius

■ Height

■ Number of turns

■ Turn height

■ Twist direction

If you specify the same value for both the base radius and the top radius, then
a cylindrical helix is created. By default, the top radius is set to the same value
as the base radius. You cannot specify 0 for both the base radius and top radius.

If you specify different values for the top radius and the base radius, then a
conical helix is created.

If you specify a height value of 0, then a flat, 2D spiral is created.

NOTE A helix is a spline approximation of a real helix. Length values may not be
completely accurate. However, when you use a helix as a sweep path, the resulting
values will be accurate regardless of the approximation.

See also:

■ Modify Helixes on page 1163

■ Create a Solid or Surface by Sweeping on page 1202
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To create a helix

1 Click Home tab ➤ Draw panel ➤ Helix. 

2 Specify the center point for the base of the helix.

3 Specify the base radius.

4 Specify the top radius or press ENTER to specify the same value as the
base radius.

5 Specify the height of the helix.

Toolbar: Modeling  
Command entry: HELIX

Quick Reference

Commands

HELIX

Creates a 2D spiral or 3D spring.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Draw Construction and Reference Geometry
Construction lines and reference points are temporary objects you create to
help you draw accurately.
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Draw Reference Points
Point objects are useful as nodes or reference geometry for object snaps and
relative offsets.

You can set the style of the points and their size relative to the screen or in
absolute units. Changing the style of points

■ Makes them more visible and easier to differentiate from grid dots

■ Affects the display of all point objects in the drawing

■ Requires using REGEN to make the change visible

To set point style and size

1 Click Format menu  ➤ Point Style. 

2 In the Point Style dialog box, select a point style.

3 In the Point Size box, specify a size, either relative to the screen or in
absolute units.

4 Click OK.

Command entry: DDPTYPE

To create a point object

1 Click Home tab  ➤  Draw panel  ➤  Point drop-down  ➤  Multiple Points.

2 Specify the point location.

You can snap to a point using the Node object snap.

Toolbar: Draw  
Command entry: POINT
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Quick Reference

Commands

DDPTYPE

Specifies the display style and size of point objects.

POINT

Creates a point object.

System Variables

PDMODE

Controls how point objects are displayed.

PDSIZE

Sets the display size for point objects.

Utilities

No entries

Command Modifiers

No entries

Draw Construction Lines (and Rays)
Lines that extend to infinity in one or both directions, known as rays and
construction lines, respectively, can be used as references for creating other
objects.

For example, you can use construction lines to find the center of a triangle,
prepare multiple views of the same item, or create temporary intersections to
use for object snaps.

Infinite lines do not change the total area of the drawing. Therefore, their
infinite dimensions have no effect on zooming or viewpoints, and they are
ignored by commands that display the drawing extents. You can move, rotate,
and copy infinite lines just as you can move, rotate, and copy other objects.
You may want to create infinite lines on a construction line layer that can be
frozen or turned off before plotting.
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Construction Lines

A construction line () can be placed anywhere in three-dimensional space.
You can specify its orientation in several ways. The default method for creating
the line is the two-point method: you specify two points to define the
orientation. The first point, the root, is the conceptual midpoint of the
construction line, that is, the point snapped to by the Midpoint object snap.

You can also create construction lines in several other ways.

■ Horizontal and Vertical. Create construction lines that pass through a point
you specify and are parallel to the X or Y axis of the current UCS.

■ Angle. Creates a construction line in one of two ways. Either you select a
reference line and then specify the angle of the construction line from
that line, or you create a construction line at a specific angle to the
horizontal axis by specifying an angle and then a point through which
the construction line should pass.

■ Bisector. Creates a construction line that bisects an angle you specify. You
specify the vertex and the lines that create the angle.

■ Offset. Creates a construction line parallel to a baseline you specify. You
specify the offset distance, select the baseline, and then indicate on which
side of the baseline to locate the construction line.

Rays

A ray is a line in three-dimensional space that starts at a point you specify and
extends to infinity. Unlike construction lines, which extend in two directions,
rays extend in only one direction. Using rays instead of construction lines can
help reduce visual clutter. Like construction lines, rays are ignored by
commands that display the drawing extents.
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To create a construction line by specifying two points

1 Click Home tab ➤ Draw panel ➤ Construction Line. 

2 Specify a point to define the root of the construction line.

3 Specify a second point through which the construction line should pass.

4 Continue to specify construction lines as needed.

All subsequent xlines pass through the first point specified.

5 Press ENTER to end the command.

Toolbar: Draw  
Command entry: XLINE

To create a ray

1 Click Home tab ➤ Draw panel ➤ Ray. 

2 Specify a starting point for the ray.

3 Specify a point through which the ray should pass.

4 Continue to specify points to create additional rays as needed.

All subsequent rays pass through the first point specified.

5 Press ENTER to end the command.

Command entry: RAY

Quick Reference

Commands

RAY

Creates a line that starts at a point and continues to infinity.

XLINE

Creates a line of infinite length.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create and Combine Areas (Regions)
Regions are two-dimensional enclosed areas that have physical properties such
as centroids or centers of mass. You can combine existing regions into a single,
complex region to calculate area.

Regions are two-dimensional enclosed areas you create from objects that form
closed loops. Loops can be combinations of lines, polylines, circles, arcs,
ellipses, elliptical arcs, and splines. The objects that make up the loops must
either be closed or form closed areas by sharing endpoints with other objects.

Regions can be used for

■ Applying hatching and shading

■ Analyzing properties, such as area, using MASSPROP

■ Extracting design information, such as the centroid

You can create regions out of multiple loops and out of open curves whose
endpoints are connected and form loops. You cannot form regions from open
objects that intersect to form a closed area: for example, intersecting arcs or
self-intersecting curves.

You can also create regions using BOUNDARY.
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You create composite regions by combining, subtracting, or finding the
intersection of regions. After forming these more complex regions, you can
apply hatching or analyze their area.

Objects combined using UNION:

Objects combined using SUBTRACT:

Objects combined using INTERSECT:

To define regions

1 Click Home tab ➤ Draw panel ➤ Region. 

2 Select objects to create the region.

These objects must each form an enclosed area, such as a circle or a closed
polyline.

3 Press ENTER.

A message at the command prompt indicates how many loops were
detected and how many regions were created.
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Command entry: REGION

To define regions by using boundaries

1 Click Home tab  ➤  Draw panel  ➤  Boundary. 

2 In the Boundary Creation dialog box, in the Object Type list, select
Region.

3 Click Pick Points.

4 Specify a point in your drawing inside each closed area that you want to
define as a region and press ENTER.

This point is known as the internal point.

NOTE You can make a new boundary set to limit the objects used to
determine the boundary.

Command entry: BOUNDARY

To combine regions by adding

1 Click Home tab  ➤  Solid Editing panel  ➤  Union.

2 Select one region for the union.

3 Select another region.

You can select regions to unite in any order.

4 Continue selecting regions or press ENTER to end the command.

The command converts the selected regions to a new combined region.

Command entry: UNION

To combine regions by subtracting

1 Click Home tab  ➤  Solid Editing panel  ➤  Subtract.

2 Select one or more regions from which to subtract and press ENTER.

Create and Combine Areas (Regions) | 847



3 Select the region to subtract and press ENTER.

The areas of the second regions you selected are subtracted from the areas
of the first regions.

Command entry: SUBTRACT

To combine regions by finding intersections

1 Click Home tab  ➤  Solid Editing panel  ➤  Intersect.

2 Select one region of the intersection.

3 Select another intersecting region.

You can select regions in any order to find their intersection.

4 Continue selecting regions or press ENTER to end the command.

The command converts the selected regions to a new region defined by
the intersection of the selected regions.

Command entry: INTERSECT

Quick Reference

Commands

BOUNDARY

Creates a region or a polyline from an enclosed area.

INTERSECT

Creates a 3D solid, surface, or 2D region from overlapping solids, surfaces,
or regions.

MASSPROP

Calculates the mass properties of regions or 3D solids.

REGION

Converts an object that encloses an area into a region object.

SUBTRACT

Combines selected 3D solids, surfaces, or 2D regions by subtraction.
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UNION

Combines selected 3D solids, surfaces, or 2D regions by addition.

System Variables

DELOBJ

Controls whether geometry used to create 3D objects is retained or deleted.

Utilities

No entries

Command Modifiers

No entries

Create Revision Clouds
Revision clouds are polylines that consist of sequential arcs. They are used to
call attention to parts of a drawing during the review stage.

If you review or redline drawings, you can increase your productivity by using
the Revision Cloud feature to highlight your markups. REVCLOUD creates a
polyline of sequential arcs to form a cloud-shaped object. You can select a
style for a revision cloud: Normal or Calligraphy. If you select Calligraphy,
the revision cloud looks as if it was drawn with a calligraphy pen.

You can create a revision cloud from scratch, or you can convert objects, such
as a circle, ellipse, polyline, or spline, to a revision cloud. When you convert
an object to a revision cloud, the original object is deleted if DELOBJ is set to
1 (the default).

You can set the minimum and maximum default values for the arc lengths
of a revision cloud. When you draw a revision cloud, you can vary the size of
the arcs by using pick points for the smaller arc segments. You can also edit
the individual arc lengths and chord lengths of a revision cloud by adjusting
the pick points.

REVCLOUD stores the last used arc length as a multiple of the DIMSCALE
system variable to provide consistency among drawings with different scale
factors.
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Make sure that you can see the entire area to be outlined with REVCLOUD
before you begin the command. REVCLOUD is not designed to support
transparent and real-time panning and zooming.

To create a revision cloud from scratch

1 Click Home tab ➤ Draw panel ➤ Revision Cloud. 

2 At the command prompt, specify a new minimum and maximum arc
length or specify a revision cloud starting point.

The default minimum and maximum arc lengths are set to 0.5000 units.
The maximum arc length can be no more than three times the minimum
arc length.

3 Guide the crosshairs along the cloud path. You can click pick points along
the path if you want to vary the size of the arcs.

4 Press ENTER at any time to stop drawing the revision cloud.

To close the revision cloud, return to its starting point.

Toolbar: Draw  
Command entry: REVCLOUD

To create revision clouds with a calligraphy pen style

1 Click Home tab ➤ Draw panel ➤ Revision Cloud. 

2 At the command prompt, enter style.

3 At the command prompt, enter calligraphy.
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4 Press ENTER to save the calligraphy setting and to continue with the
command, or press ESC to end the command.

Toolbar: Draw  
Command entry: REVCLOUD

To convert an object to a revision cloud

1 Click Home tab ➤ Draw panel ➤ Revision Cloud. 

2 At the command prompt, specify a new minimum and maximum arc
length or press ENTER.

The default minimum and maximum arc lengths are set to 0.5000 units.
The maximum arc length can be no more than three times the minimum
arc length.

3 Select the circle, ellipse, polyline, or spline that you want to convert to
a revision cloud.

To reverse the direction of the arcs, enter yes at the command prompt
and press ENTER.

4 Press ENTER to change the selected object to a revision cloud.

Toolbar: Draw  
Command entry: REVCLOUD

To change the default values for arc lengths in a revision cloud

1 Click Home tab ➤ Draw panel ➤ Revision Cloud. 

2 At the command prompt, specify a new minimum arc length and press
ENTER.

3 At the command prompt, specify a new maximum arc length and press
ENTER.

The maximum arc length can be no more than three times the minimum
arc length.
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4 Press ENTER to continue with the command or ESC to end the command.

Toolbar: Draw  
Command entry: REVCLOUD

To edit the individual lengths of arcs or chords in a revision cloud

1 In your drawing, select the revision cloud you want to edit.

2 Move the pick points along the path of the revision cloud to change the
arc lengths and chords.

Quick Reference

Commands

REVCLOUD

Creates a revision cloud using a polyline.

System Variables

DIMSCALE

Sets the overall scale factor applied to dimensioning variables that specify
sizes, distances, or offsets.

DELOBJ

Controls whether geometry used to create 3D objects is retained or deleted.

Utilities

No entries

Command Modifiers

No entries
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Create and Use Blocks
(Symbols)

A block is one or more objects combined to create a single object. Blocks help you reuse objects
in the same drawing or in other drawings.

Overview of Blocks
A block can be composed of objects drawn on several layers with various colors,
linetypes, and lineweight properties. Although a block is always inserted on the
current layer, the block reference preserves information about the original layer,
color, and linetype properties of the objects that are contained in the block.
You can control whether objects in a block retain their original properties or
inherit their properties from the current layer, color, linetype, or lineweight
settings.

Create Blocks

You can use several methods to create blocks:

■ Combine objects to create a block definition in your current drawing.

■ Use the Block Editor contextual tab (when the ribbon is active) or Block
Editor (when the ribbon is not active) to add dynamic behavior to a block
definition in your current drawing.

■ Create a drawing file and later insert it as a block in other drawings.

■ Create a drawing file with several related block definitions to serve as a block
library.

You can use PURGE to remove unused block definitions from a drawing.
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Dynamic Blocks

A block definition can contain elements that add dynamic behavior to a block,
which adds flexibility and intelligence to the geometry. When you insert a
block reference with dynamic behavior in a drawing, you can manipulate the
geometry of the block reference through custom grips or custom properties,
depending on how the block was defined. You can also constrain block
geometry.

Annotative Blocks

You can also create blocks. For more information about creating and working
with an annotative blocks, see Create Annotative Blocks and Attributes on
page 1417.

See also:

■ Scale Annotations on page 1393

Quick Reference

Commands

BLOCK

Creates a block definition from selected objects.

PURGE

Removes unused items, such as block definitions and layers, from the drawing.

WBLOCK

Writes objects or a block to a new drawing file.

System Variables

MAXSORT

Sets the maximum number of symbol names or block names sorted by listing
commands.

Create and Store Blocks
You create blocks by associating objects and giving them a name. You can
also attach information (attributes) to a block.
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How Blocks Are Stored and Referenced
The following illustrations are conceptual representations of three drawing
files. Each rectangle represents a separate drawing file and is divided into two
parts: the smaller part represents the block definition table, and the larger part
represents the objects in a drawing.

When you insert a block, you are inserting a block reference. The information
is not simply copied from the block definition to the drawing area. Instead,
a link is established between the block reference and the block definition.
Therefore, if the block definition is changed, all references are updated
automatically.

To reduce the size of a drawing, you can purge unused block definitions.

Quick Reference

Commands

BLOCK

Creates a block definition from selected objects.

PURGE

Removes unused items, such as block definitions and layers, from the drawing.

Create Blocks Within a Drawing
After you define a block in a drawing, you can insert a block reference in the
drawing as many times as necessary. Use this method to create blocks quickly.
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Each block definition includes a block name, one or more objects, the
coordinate values of the base point to be used for inserting the block, and any
associated attribute data.

The base point is used as a reference for positioning the block when you insert
it. Suppose you specify that the base point is at the lower-left corner of an
object in the block. Later, when you insert the block, you are prompted for
an insertion point. The block base point is aligned at the insertion point you
specified.

The block definition in the illustration comprises a name, PLUG_VALVE, four
lines, and a base point at the intersection of the two diagonal lines. For an
explanation of the schematic representation shown, see Overview of Blocks
on page 853.

The illustration shows a typical sequence for creating a block definition within
a drawing.

You can also use the Block Editor to create blocks that are saved within a
drawing. For more information about using the Block Editor, see Use the Block
Editor on page 868.

To define a block for the current drawing

1 Create the objects you want to use in the block definition.
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2 Click Insert tab ➤ Block panel ➤ Create. 

3 In the Block Definition dialog box, enter a block name in the Name box.

4 Under Objects, select Convert to Block.

If you want the original objects used to create the block definition to
remain in your drawing, make sure the Delete option is not selected. If
this option is selected, the original objects are erased from the drawing.
If necessary, you can use OOPS to restore them.

5 Click Select Objects.

6 Use your pointing device to select the objects to be included in the block
definition. Press Enter to complete object selection.

7 In the Block Definition dialog box under Base Point, specify the block
insertion point using one of these methods.

■ Click Pick Point to specify a point using the pointing device.

■ Enter the X,Y,Z coordinate values of the point.

8 In the Description box, enter a description for the block definition. This
description is displayed in DesignCenter™ (ADCENTER).

9 Click OK.

The block is defined in the current drawing and can be inserted at any
time.

Toolbar: Draw  
Command entry: BLOCK

Quick Reference

Commands

BLOCK

Creates a block definition from selected objects.
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Create Drawing Files for Use as Blocks
You can create drawing files for the purpose of inserting them into other
drawings as blocks. Individual drawing files are easy to create and manage as
the source of block definitions. Collections of symbols can be stored as
individual drawing files and grouped in folders.

Create a New Drawing File

You have two methods for creating drawing files:

■ Create and save a complete drawing file using SAVE or SAVEAS.

■ Create and save only selected objects from your current drawing to a new
drawing using EXPORT or WBLOCK.

With either method, you create an ordinary drawing file that can be inserted
as a block into any other drawing file. Using WBLOCK is recommended when
you need to create several versions of a symbol as separate drawing files, or
when you want to create a drawing file without leaving the current drawing.

Change the Base Point of Drawings to Be Used as Blocks

By default, the WCS (world coordinate system) origin (0,0,0) is used as the
base point for drawing files inserted as blocks. You can change the base point
by opening the original drawing and using BASE to specify a different base
point for insertion. The next time you insert the block, the new base point is
used.

Update Changes in the Original Drawing

If you change the original drawing after inserting it, the changes have no
effect on the current drawing. If you expect the original drawing to change,
and you want the changes to be reflected in the current drawing, you may
want to attach it as an external reference instead of inserting it as a block. For
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more information about external references, see Reference Other Drawing
Files.

Use Paper Space Objects in Blocks

Objects in paper space are not included when you insert a drawing as a block.
To transfer paper space objects to another drawing, make the objects into a
block or save them in a separate drawing file, and then insert the block or
drawing file into the other drawing.

To create a new drawing file from selected objects

1 Open an existing drawing or create a new drawing.

2 At the Command prompt, enter wblock.

3 In the Write Block dialog box, select Objects.

If you want the original objects used to create the new drawing to remain
in your drawing, make sure the Delete From Drawing option is not
selected. If this option is selected, the original objects are erased from the
drawing. If necessary, you can use OOPS to restore them.

4 Click Select Objects.

5 Use your pointing device to select the objects to be included in the new
drawing. Press Enter to complete object selection.

6 In the Write Block dialog box under Base Point, specify the point to be
the origin point (0,0,0) for the new drawing using one of these methods:

■ Click Specify Point to specify a point using the pointing device.

■ Enter the X,Y,Z coordinate values of the point.

7 Under Destination, enter a file name and path for the new drawing, or
click the [...] button to display a standard file selection dialog box.

8 Click OK.

A new drawing is created with the selected objects.

Command entry: WBLOCK

To create a new drawing file from an existing block definition

1 Click Insert tab ➤ Block panel ➤ Create. 
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2 In the Block Definition dialog box, in the Name box, select the block to
modify.

3 In the Name box, enter a new name.

4 In the Description box, enter or modify the description for the new
drawing file. Click OK.

Command entry: BLOCK

Quick Reference

Commands

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.

BASE

Sets the insertion base point for the current drawing.

BLOCK

Creates a block definition from selected objects.

EXPORT

Saves the objects in a drawing to a different file format.

INSERT

Inserts a block or drawing into the current drawing.

OOPS

Restores erased objects.

WBLOCK

Writes objects or a block to a new drawing file.

Control the Color and Linetype Properties in Blocks
Generally when you insert a block, the color, linetype, and lineweight of
objects in the block retain their original settings regardless of the current
settings in the drawing. However, you can create blocks with objects that
inherit the current color, linetype, and lineweight settings. These objects have
floating properties.
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You have three choices for how the color, linetype, and lineweight properties
of objects are treated when a block reference is inserted.

■ Objects in the block do not inherit color, linetype, and lineweight
properties from the current settings. The properties of objects in the block
do not change regardless of the current settings.
For this choice, it is recommended that you set the color, linetype, and
lineweight properties individually for each object in the block definition:
do not use BYBLOCK or BYLAYER color, linetype, and lineweight settings
when creating these objects.

■ Objects in the block inherit color, linetype, and lineweight properties from
the color, linetype, and lineweight assigned to the current layer only.
For this choice, before you create objects to be included in the block
definition, set the current layer to 0, and set the current color, linetype,
and lineweight to BYLAYER.

■ Objects inherit color, linetype, and lineweight properties from the current
color, linetype, and lineweight that you have set explicitly, that is, that
you have set to override the color, linetype, or lineweight assigned to the
current layer. If you have not explicitly set them, then these properties are
inherited from the color, linetype, and lineweight assigned to the current
layer.
For this choice, before you create objects to be included in the block
definition, set the current color or linetype to BYBLOCK.

Create objects with
these properties

Create objects on these
layers

If you want objects in a
block to

Any but BYBLOCK or
BYLAYER

Any but 0 (zero)Retain original properties

BYLAYER0 (zero)Inherit properties from the
current layer

BYBLOCKAnyInherit individual properties
first, then layer properties

Floating properties also apply to nested blocks when the nested block references
and the objects they contain use the settings required for floating properties.
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To set the color for all new objects

1 Click Home tab  ➤  Properties panel  ➤  Object Color.

2 Either click a color to draw all new objects in that color, or click Select
Color to display the Select Color dialog box and do one of the following:

■ On the Index tab, click a color or enter the ACI color number (1-255)
or name in the Color box, and then click OK.

■ On the True Color tab, select the HSL color model in the Color Model
option and specify a color by entering a color value in the Color box
or by specifying values in the Hue, Saturation, and Luminance boxes,
and then click OK.

■ On the Color Books tab, select a color book from the Color Book box,
select a color by navigating the color book (using the up and down
arrows) and clicking on a color chip, and then click OK.

■ Click BYLAYER to draw new objects in the color assigned to the current
layer.

■ Click BYBLOCK to draw new objects in the current color until they
are grouped into a block. When the block is inserted into the drawing,
the objects in the block acquire the current color setting.

3 Click OK.

The Color control displays the current color.

Command entry: COLOR

To set the linetype for all new objects

1 Click Home tab  ➤  Properties panel  ➤  Linetypes. 

2 If you need to load additional linetypes, click Load, select one or more
linetypes, and click OK.

You can hold down Ctrl to select several linetypes or Shift to select a
range of linetypes.

3 In the Linetype Manager, do one of the following:

■ Select a linetype and select Current to draw all new objects with that
linetype.
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■ Select BYLAYER to draw new objects in the linetype assigned to the
current layer.

■ Select BYBLOCK to draw new objects in the current linetype until
they are grouped into a block. When the block is inserted in a drawing,
the objects in the block acquire the current linetype setting.

4 Click OK.

The Linetype control displays the current linetype. If the linetype you
want to use is already loaded, you can click the Linetype control and
click the linetype to make it current.

Command entry: LINETYPE
Menu: Click Format menu  ➤ Linetype.

Quick Reference

Commands

COLOR

Sets the color for new objects.

LAYER

Manages layers and layer properties.

LINETYPE

Loads, sets, and modifies linetypes.

Nest Blocks
With nested blocks, you can build a single block out of several components.
For example, you can insert as a block a drawing of a mechanical assembly
that contains a housing, a bracket, and fasteners in which each fastener is a
block composed of a bolt, washer, and nut. The only restriction on nested
blocks is that you cannot insert blocks that reference themselves.

You can apply geometric constraints and constraint parameters to nested
objects in blocks. AutoCAD detects the nested entity or valid constraint point
for the nested entity regardless of the nesting level of the object.
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NOTE Constraints can only be applied between nested objects in the block and
objects in the drawing file, not between pairs of nested objects in the block
reference.

When a block definition is redefined, AutoCAD will re-evaluate the constraints
between geometry in the drawing and the nested geometry in the block
references. The drawing will then be updated appropriately. If a constraint
cannot be resolved as a result of the change to the block definition, then the
constraint is removed and an unresolved constraints message is displayed at
the command line.

Quick Reference

Commands

BLOCK

Creates a block definition from selected objects.

Create Block Libraries
A block library is a collection of block definitions stored in a single drawing
file. You can use block libraries supplied by Autodesk or other vendors or
create your own.

You can organize a set of related block definitions by creating the blocks in
the same drawing file. Drawing files used this way are called block, or symbol,
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libraries. These block definitions can be inserted individually into any drawing
that you are working on. Block library drawings are not different from other
drawing files except in how they are used.

When you use BLOCK to define each block definition in the block library
drawing, you can include a short description of the block that can be viewed
in DesignCenter.

Optionally, you can also document each block definition by inserting it in
the drawing area of the library drawing. In addition to the block geometry,
you can include text that provides the block name, the date of creation, the
date of the last modification, and any special instructions or conventions.
This creates a visual index of the blocks in the block library drawing.

Use DesignCenter to view and copy block definitions individually from block
library drawings (or from any existing drawing) to your current drawing.
DesignCenter does not overwrite an existing block definition in a drawing
with one that comes from another drawing.

To create a block library drawing

1 Begin a new drawing.

2 Define a block.

3 Repeat step 2 for as many related block definitions as you want to make.

4 Save the drawing using a name appropriate for a library drawing.

These blocks can be inserted into any drawing using DesignCenter
(ADCENTER).

Toolbar: Draw  
Command entry: BLOCK
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Quick Reference

Commands

BLOCK

Creates a block definition from selected objects.

Use Tool Palettes to Organize Blocks
You can use tool palettes to organize blocks that are stored in one drawing
file or separate drawing files.

Once you've added a block tool to a tool palette, you can easily insert the
block reference in your drawing by dragging it from the tool palette to the
drawing or by clicking and placing it in the drawing. For information about
using tool palettes to organize and insert blocks, see Create and Use Tools
from Objects and Images on page 56.

Quick Reference

Commands

TOOLPALETTES

Opens the Tool Palettes window.

Remove Block Definitions
To reduce the size of a drawing, you can remove unused block definitions.
You can remove a block reference from your drawing by erasing it; however,
the block definition remains in the drawing's block definition table.

To remove unused block definitions and decrease the drawing size, use PURGE
at any time in your drawing session.

All references to a block must be erased before you can purge the block
definition.

See also:

■ Overview of Blocks on page 853
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To remove a block definition

1 Click Tools tab ➤ Drawing Utilities panel ➤ Purge. 

The Purge dialog box displays a tree view of named objects that can be
purged.

2 To purge blocks, use one of the following methods:

■ To purge all unreferenced blocks, select Blocks. To include nested
blocks, select Purge Nested Items.

■ To purge specific blocks, double-click Blocks to expand the Block tree
view. Select the blocks to be purged.

If the item you want to purge is not listed, select View Items You Cannot
Purge.

3 You are prompted to confirm each item in the list. If you do not want to
confirm each purge, clear the Confirm Each Item to Be Purged option.

4 Click Purge.

To confirm the purging of each item, respond to the prompt by choosing
Yes or No, or Yes to All if more than one item is selected.

5 Select more items to purge, or click Close.

Command entry: PURGE

Quick Reference

Commands

PURGE

Removes unused items, such as block definitions and layers, from the drawing.

Add Dynamic Behavior to Blocks
Instead of being a fixed part of a drawing, a dynamic block reference can be
changed or manipulated as you work in a drawing.
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Use the Block Editor
You use the Block Editor to add dynamic behavior to blocks.

Overview of the Block Editor
The Block Editor is a special authoring area for creating block definitions and
adding dynamic behavior.

The Block Editor provides quick access to block authoring tools.

The Block Editor provides a drawing area in which you can draw and edit
geometry as you would in the program's main drawing area. You can specify
the background color for the Block Editor drawing area in the Display tab of
the Options dialog box.

NOTE You can use most commands in either the Block Editor contextual tab or
the Block Editor. When you enter a command that is not allowed in the Block
Editor, a message is displayed at the Command prompt.

You can use either the Block Editor contextual tab or the Block Editor to edit
or add dynamic behavior to block definitions that exist in the current drawing.
You can also use it to create new block definitions.

When the ribbon is active, a special ribbon contextual tab is displayed above
the drawing area. When the ribbon is not active, a special toolbar is displayed.
Both the ribbon contextual tab and toolbar provide tools to do the following:

■ Add a constraint

■ Add a parameter

■ Add an action

■ Define attributes

■ Close the Block Editor

■ Manage visibility states

■ Save the block definition

You can select any parameter, grip, action, or geometric object in either the
Block Editor contextual tab or the Block Editor to view its properties in the
Properties palette. When you select an object in the Block Editor, the
coordinate values shown in the Properties palette reflect the block definition
space.
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When you work in the Block Editor contextual tab or the Block Editor, the
command line should be displayed. The command line displays prompts for
nearly all aspects of creating dynamic blocks.

UCS in the Block Editor

A UCS icon is displayed in the drawing area of the Block Editor. The origin of
the UCS icon defines the base point for the block. You can change the base
point for the block by moving the geometry relative to the origin of the UCS
icon, or by adding a base point parameter.

The UCS command is disabled in the Block Editor. You can open an existing
3D block definition in the Block Editor and assign parameters to the block.
However, the parameters will ignore any Z coordinate values in the block
space. Consequently, the block reference cannot be edited along the Z axis.
Furthermore, while you can create a dynamic block that contains solid objects
and add actions to it, such as move, rotate, and scale, you can't perform solid
editing features within a dynamic block reference (for example, stretch a solid,
move a hole within a solid, and so on).

See also:

■ Define Block Attributes on page 1029

To open an existing block definition in the Block Editor

1 Click Insert tab  ➤ Block panel ➤ Edit. 

2 In the Edit Block Definition dialog box, do one of the following:

■ Select a block definition from the list.

■ Select <Current Drawing> if the drawing is the block definition you
want to open.

3 Click OK.

Toolbar: Standard  
Command entry: BEDIT

Shortcut menu: Right-click a selected block. Click Block Editor.
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To create a new block definition in the Block Editor

1 Click Insert tab  ➤ Block panel ➤ Edit. 

2 In the Edit Block Definition dialog box, enter a name for the new block
definition. Click OK.

3 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

NOTE This saves the block definition even if you have not added any objects
in the Block Editor drawing area.

4 Click Close Block Editor.

Toolbar: Standard  
Command entry: BEDIT

To open a block on a tool palette in the Block Editor

1 If the Tool Palettes window is not already open, click View tab  ➤  Palettes

panel  ➤  Tool Palettes. 

2 Right-click a block icon.

3 Click Block Editor.

NOTE A block on a tool palette may reside in another drawing. The drawing that
contains the block definition is opened in the Block Editor.

Command entry: TOOLPALETTES

Toolbar: Standard  
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To open a block from the DesignCenter window in the Block Editor

1 Click View tab  ➤  Palettes panel  ➤  DesignCenter. 

2 Right-click a block icon.

3 Click Block Editor.

Command entry: ADCENTER

Toolbar: Standard  

To open a drawing file saved as a block (not dynamic) in the Block Editor

1 Click the Application button, and click Open  ➤  Drawing.

2 Open the drawing file that is saved as a block.

3 Click Insert tab  ➤  Block panel  ➤  Edit. 

4 In the Edit Block Definition dialog box, select <Current Drawing>. Click
OK.

Toolbar: Standard  
Command entry: OPEN

To open a drawing file saved as a dynamic block in the Block Editor

1 Click the Application button, and click Open  ➤  Drawing.

2 Open the drawing file that is saved as a block.

An alert is displayed that states that the drawing file contains authoring
elements.

3 In the alert dialog box, click Yes to open the drawing in the Block Editor.

Command entry: OPEN

Toolbar: Standard  
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To view properties of a block definition in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Edit. 

2 In the Edit Block Definition dialog box, do one of the following:

■ Select a block definition from the list.

■ Select <Current Drawing> if the drawing is the block definition you
want to open.

3 Click OK.

4 Click View tab ➤  Palettes panel  ➤  Properties. 

5 In the Properties Palette window, under Block, view the properties of the
block definition.

Toolbar: Standard  
Command entry: BEDIT

To view properties of objects in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, select an object.

3 Click View tab ➤  Palettes panel  ➤  Properties. 

4 In the Properties Palette window, view the properties of the selected
object.

Command entry: BEDIT

Toolbar: Standard  
Shortcut menu: Right-click the selected object. Click Properties.
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To close the Block Editor

■ Click Block Editor tab  ➤  Close panel  ➤  Close Block Editor.

Command entry: BCLOSE

To prevent access to the Block Editor

1 At the Command prompt, enter blockeditlock.

2 Enter 1, and then press Enter.

Quick Reference

Commands

BCLOSE

Closes the Block Editor.

BEDIT

Opens the block definition in the Block Editor.

OPTIONS

Customizes the program settings.

PROPERTIES

Controls properties of existing objects.

System Variables

BLOCKEDITLOCK

Disallows opening of the Block Editor and editing of dynamic block
definitions.

Use the Parameters Manager
The Parameters Manager allows you to display and edit constraints, user
parameters, user variables, action parameters, and block attributes from within
the Block Editor.
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Within the Block Editor, the Parameters Manager displays and controls the
following categories:

■ Constraint Parameters

■ User Parameters

■ Action Parameters

■ Dimensional and Reference Constraints

■ User Variables

■ Block Attributes

For each of the above categories, you can display and control the following:

■ Expression

■ Value

■ Type

■ Display Order

■ Show or Hide Information

■ Description

For more information on the Parameters Manager in the Block Editor, see
Parameters Manager - Dynamic Blocks.

To display the Parameters Manager in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Manage panel  ➤  Parameters Manager.

Command entry: PARAMETERS

To display or hide additional columns in the Parameters Manager

■ In the Parameters Manager, right-click a column header and select or
de-select a column name.
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Quick Reference

Commands

PARAMETERS

Controls the associative parameters used in the drawing.

PARAMETERSCLOSE

Closes the Parameters Manager palette.

System Variables

PARAMETERSSTATUS

Indicates whether the Parameters Manager palette is displayed or hidden.

Define User Parameters in Dynamic Blocks
You can control the geometry of constraint parameters with mathematical
expressions.

While you can insert both user variables and user parameters in the Block
Editor, only user parameters are displayed as editable custom properties for a
block reference.

There are several types of user parameters. For more information, see Parameters
Manager - Dynamic Blocks.

NOTE User parameters can be exposed as custom properties of the block reference.
If it does not define an equation, then the property can be edited. If it is an
equation, then the property is read-only.

See also:

■ Parameters Manager - Dynamic Blocks

■ Constrain a Design with Formulas and Equations on page 758

■ Specify Custom Properties for Dynamic Blocks on page 1004

To create a new user parameter

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 
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2 Click Block Editor tab ➤ Dimensional panel ➤ Block Table. 

3 In the Block Properties Table dialog box, click New Properties.

4 In the New Parameter dialog box, specify a name and a value. Click OK.

Command entry: BTABLE

To create user parameters using the Parameters Manager

 ➤ 

To change the type of user parameter

 ➤ Use parameters manager

Quick Reference

Commands

BCPARAMETER

Applies constraint parameters to selected objects, or converts dimensional
constraints to parameter constraints.

BTABLE

Displays a dialog box to define variations of a block.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

System Variables

BCONSTATUSMODE

Turns the constraint display status on and off and controls the shading of
objects based on their constraint level.

Use a Block Properties Table
You can define and control values for parameters and properties within a
block definition using a Block Properties table.
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The Block Properties Table dialog box consists of a grid with parameters
defining column headings and rows defining the different property set values.
When selecting a block reference, it can be set to the values defined by one
of the rows in the block properties table.

A table can include any of the following parameters and properties:

■ Action parameters

■ User parameters

■ Constraint parameters

■ Attributes

NOTE Only one table is allowed in the block definition.

You can restrict the property set for block references to only values defined
by one of the rows of the table. You can also change individual properties of
the reference so that the property set no longer matches one of the defined
rows.

To add parameter properties to a block table

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, double-click a block properties table in the block
definition.

3 In the Block Properties Table dialog box, click Add Properties.

4 In the Add Parameter Properties dialog box, under the Parameter
Properties list, select the parameter properties you want to add to the
block table. Hold Ctrl to select more than one property.

5 Click OK.

Command entry: BTABLE

To check for errors in a block properties table

1 Click Block Editor tab ➤ Dimensional panel ➤ Block Table.

2 In the Block Properties Table dialog box, click Audit.
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Command entry: BTABLE

To open an existing block properties table

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, double-click a block properties table.

Command entry: BTABLE

Quick Reference

Commands

BCPARAMETER

Applies constraint parameters to selected objects, or converts dimensional
constraints to parameter constraints.

BTABLE

Displays a dialog box to define variations of a block.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

System Variables

BCONSTATUSMODE

Turns the constraint display status on and off and controls the shading of
objects based on their constraint level.

Use Block Authoring Palettes
The Block Editor has a block authoring palette with four tabs: Parameters,
Actions, Parameter Sets, and Constraints.

The Block Authoring Palettes window is displayed only in the Block Editor.
Use these palettes to add parameters and actions to your dynamic block
definition.
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Create Custom Block Authoring Tools

You can create custom block authoring tools. In order to preserve the default
tools on the block authoring palettes, you should create a new palette for
custom block authoring tools. You can then copy a parameter set tool from
one of the existing palettes and paste the copy onto the new palette. In the
Tool Properties dialog box, you can then change the properties of the new
tool, including the following:

■ Tool description

■ Parameter type

■ Associated action(s)

■ Key point on the parameter to which the action is tied (if applicable)

■ Tool palette image

You cannot drag parameters and actions from the Block Editor onto any tool
palette.

See also:

■ Add Action Parameters to Dynamic Blocks on page 936

■ Add Actions to Dynamic Blocks on page 960

■ Use Parameter Sets on page 984

■ Control Tool Properties on page 70

■ Organize Tool Palettes on page 80

To show or hide the Block Authoring palettes in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Edit Block Definition dialog box, Under Block To Create or Edit,
select a name from the list and then, click OK.

3 Click Block Editor tab  ➤  Manage panel  ➤ Authoring Palettes.
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Toolbar: Standard 
Command entry: BAUTHORPALETTE, BAUTHORPALETTECLOSE

To make a copy of a parameter set

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Edit Block Definition dialog box, Under Block To Create or Edit,
select a name from the list and then, click OK.

3 Click Block Editor tab  ➤  Manage panel  ➤  Authoring Palettes.

4 In the Block Authoring Palettes window, Parameters Sets tab, right-click
a parameter set. Click Copy.

5 Right-click anywhere on the palette to which you want to add the
parameter set (except on a parameter set). Click Paste.

To add an action to a parameter set

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Edit Block Definition dialog box, Under Block To Create or Edit,
select a name from the list and then, click OK.

3 Click Block Editor tab  ➤  Manage panel  ➤  Authoring Palettes.

4 In the Block Authoring Palettes window, Parameters Sets tab, right-click
a parameter set. Click Properties.

5 In the Tool Properties dialog box, under Parameter, click Actions, and
then click the [...] button.

6 In the Add Actions dialog box, under Action Object to Add, select an
action from the list.

7 Click Add.

8 (Optional) Repeat steps 3 and 4 to add additional actions.
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9 Click OK.

10 In the Tool Properties dialog box, click OK.

To delete an action from a parameter or parameter set

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Edit Block Definition dialog box, Under Block To Create or Edit,
select a name from the list and then, click OK.

3 Click Block Editor tab  ➤  Manage panel  ➤  Authoring Palettes.

4 In the Block Authoring Palettes window, right-click a parameter or
parameter set. Click Properties.

5 In the Tool Properties dialog box, under Parameter, click Actions, and
then click the [...] button.

6 In the Add Actions dialog box, under Action Object List, select an action
from the list.

7 Click Delete.

8 (Optional) Repeat steps 3 and 4 to delete additional actions.

9 Click OK.

10 In the Tool Properties dialog box, click OK.

Command entry: BEDIT ➤ BAUTHORPALETTE

Quick Reference

Commands

BAUTHORPALETTE

Opens the Block Authoring Palettes window in the Block Editor.

BAUTHORPALETTECLOSE

Closes the Block Authoring Palettes window in the Block Editor.

Use the Block Editor | 881



BEDIT

Opens the block definition in the Block Editor.

TOOLPALETTES

Opens the Tool Palettes window.

System Variables

BLOCKEDITOR

Indicates whether or not the Block Editor is open.

How Objects Are Displayed in the Block Editor
Parameters, actions, and their relationships (dependencies) are displayed in
different ways in the Block Editor. You can specify settings for some of these
elements.

Parameters

In the Block Editor, most parameters look like dimensions. If you create a
value set (a range or list of values) for a parameter, tick marks are shown at
the locations of those values.

You can specify the following settings for parameters in the Block Editor:

■ Parameter color

■ Parameter text and arrow size

■ Parameter font

■ Grip color

■ Display of value set markers (tick marks) for parameters

When you use a visibility parameter in your dynamic block definition, you
can specify which geometric objects are invisible for a given visibility state.
You can specify whether or not geometry that is made invisible for visibility
states displays in the Block Editor. In the following example, a visibility state
is displayed in the Block Editor. The geometry that displays in a dimmed state
is invisible for that visibility state.
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Actions

An action displays its name and icon (a lightning bolt) in the Block Editor.
You can specify the text size and color for actions in the Block Editor.

Grips

You can specify grip size and color for display in the Block Editor. This setting
does not affect the size and color of the grips in a block reference in a drawing.

Dependencies

When you select a parameter, grip, or action in the Block Editor, its associated
objects, or dependencies, are highlighted. This is called dependency highlighting.
You can turn dependency highlighting on or off.

The following example shows how dependency highlighting creates a halo
effect for the associated parameter (labeled Distance) and action (labeled
Stretch) when you select the custom grip in the Block Editor.

The following table details what is dependency highlighted when you select
an element in the Block Editor.

Objects that are dependency highlightedSelected object in
the Block Editor

Associated grips and actionsParameter

Associated parameter and actionsGrip

Associated parameters, grips, and the selection set (geo-
metry)

Action
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To specify the text size for parameters and actions in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Manage panel  ➤  Block Editor Settings.

3 In the Block Editor Settings dialog box, under Parameter and Grip Size,
specify the parameter size.

4 Enter an integer from 1 to 255 (pixels). Click OK.

Command entry: BESETTINGS

To specify the font for parameters in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Manage panel  ➤  Block Editor Settings.

3 In the Block Editor Settings dialog box, under Parameter Font, select the
font name and font style. Click OK.

Command entry: BESETTINGS

To specify the text color for actions in the Block Editor

1 At the Command prompt, enter bactioncolor.

2 Enter one of the following values:

■ BYLAYER

■ BYBLOCK

■ An integer from 1 to 255.

■ A true color specified by three integers each ranging from 1 to 255 in
the following format: RGB:000,000,000.

3 Press Enter.
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To specify the display size of grips in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Manage panel  ➤  Dialog box launcher. 

3 In the Block Editor Settings dialog box, under Parameter and Grip Size,
specify the grip size.

4 Enter an integer from 1 to 255 (pixels). Click OK.

Command entry: BESETTINGS

To specify the display color of grips in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Manage panel  ➤  Dialog box launcher. 

3 In the Block Editor Settings dialog box, under Authoring Objects, select
the grip color. Click OK.

Command entry: BESETTINGS

To specify the parameter text alignment in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Manage panel  ➤  Dialog box launcher. 

3 In the Block Editor Settings dialog box, under Authoring Objects, specify
the parameter text alignment. Click OK.

Command entry: BESETTINGS
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To update the text and grip display size at their specified values in the Block
Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, on the Block Editor toolbar, click Update Parameter
and Action Text Size.

NOTE When you zoom in and out in the Block Editor, text and grip size will change
relative to the zoom factor. However, you can update the Block Editor to display
the text and grip size at their specified values.

Command entry: REGEN

To specify whether or not objects that are invisible for a visibility state can
be seen in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Visibility panel ➤ Visibility Mode. 

Command entry: BVMODE

To turn dependency highlighting on or off in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Manage panel  ➤  Dialog box launcher. 

3 Select Highlight Dependent Objects during Selection.

4 Click OK.

Command entry: BESETTINGS
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To control whether value set markers (tick marks) are displayed

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Manage panel  ➤  Dialog box launcher. 

3 Select Display Tickmarks for Parameters with Value Sets. Click OK.

Command entry: BESETTINGS

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BESETTINGS

Displays the Block Editor Settings dialog box.

REGEN

Regenerates the entire drawing from the current viewport.

System Variables

BACTIONCOLOR

Sets the text color of actions in the Block Editor.

BDEPENDENCYHIGHLIGHT

Controls whether or not dependent objects are dependency highlighted
when a parameter, action, or grip is selected in the Block Editor.

BGRIPOBJCOLOR

Sets the color of grips in the Block Editor.

BGRIPOBJSIZE

Sets the display size of custom grips in the Block Editor relative to the screen
display.
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BPARAMETERCOLOR

Sets the color of parameters in the Block Editor.

BPARAMETERFONT

Sets the font used for parameters and actions in the Block Editor.

BPARAMETERSIZE

Sets the size of parameter text and features in the Block Editor relative to the
screen display.

BPTEXTHORIZONTAL

Forces the text displayed for action parametes and constraint parameters in
the Block Editor to be horizontal.

BTMARKDISPLAY

Controls whether or not value set markers are displayed for dynamic block
references.

BVMODE

Controls how objects that are made invisible for the current visibility state
are displayed in the Block Editor.

Modify Dynamic Block Definitions
After you've defined a dynamic block, you can modify it in the Block Editor.
You can delete, add, and modify the following elements in the Block Editor:

■ Constraints (see Add Constraints to Dynamic Blocks on page 898)

■ Parameters (see Add Action Parameters to Dynamic Blocks on page 936)

■ Actions (see Add Actions to Dynamic Blocks on page 960)

■ Geometry

■ Visibility states (see Create Visibility States)

■ Lookup tables (see Use Lookup Tables to Assign Data to Dynamic Blocks
on page 993)

■ Grips (see Specify Grips for Dynamic Blocks on page 987)

■ Properties (see Overview of Specifying Custom Properties for Dynamic
Blocks on page 1005)
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You can also use the BACTIONSET command to change an action's selection
set. If you delete a parameter associated with an action and need to reassign
that action to another parameter, use the BASSOCIATE command.

After you modify a dynamic block definition in the Block Editor, you must
save your changes (see Save Blocks on page 896).

WARNING If you redefine a dynamic block in AutoCAD 2005 or earlier, the block
will lose its dynamic behavior.

To open an existing dynamic block definition in the Block Editor

1 Open the drawing file that contains the dynamic block definition, or
open the drawing file that has been saved as a block.

2 Follow the steps in To open an existing dynamic block definition in the
Block Editor on page 889.

Toolbar: Standard  
Command entry: OPEN

Shortcut menu: Right-click a selected block. Click Block Editor.

To delete an element from a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, select the element you want to delete from the
dynamic block definition.

3 Press Delete.

To modify an action's selection set in a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, select an action.

3 At the Command prompt, enter bactionset.

4 Follow the Command prompts.
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5 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

To redefine a stretch or polar stretch action's stretch frame set in a dynamic
block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, double-click a stretch or polar stretch action.

3 Follow the Command prompts to define a new stretch frame and add
objects to or remove objects from the action's selection set.

4 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

5 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Command entry: BACTIONSET

Quick Reference

Commands

BACTION

Adds an action to a dynamic block definition.

BACTIONTOOL

Adds an action to a dynamic block definition.

BACTIONSET

Specifies the selection set of objects associated with an action in a dynamic
block definition.

BASSOCIATE

Associates an action with a parameter in a dynamic block definition.

890 | Chapter 18   Create and Use Blocks (Symbols)



BEDIT

Opens the block definition in the Block Editor.

BGRIPSET

Creates, deletes, or resets grips associated with a parameter.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BLOOKUPTABLE

Displays or creates a lookup table for a dynamic block definition.

BVSTATE

Creates, sets, or deletes a visibility state in a dynamic block.

Correct Errors in Dynamic Block Definitions
A yellow alert icon is displayed in the Block Editor if a dynamic block definition
contains errors or is incomplete. You need to correct the errors (or complete
the block) so the block reference will function properly in a drawing.

The yellow alert icon indicates that the block definition is not defined correctly
or is incomplete. For example, a parameter that is not associated with an
action will display an alert icon. An action that is not associated with a
parameter or a selection set, will also display an alert icon.

You can correct these errors by double-clicking the yellow alert icon and
following the Command prompts.

After you create a dynamic block definition in the Block Editor, you should
save it and then test the functionality of the block reference in a drawing. If
the block reference isn't functioning the way you intended, open the definition
in the Block Editor and double-check the types of parameters and actions you
used as well as their dependencies and properties.

To correct an error indicated by a yellow alert icon in a dynamic block
definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, double-click a yellow alert icon.
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3 Follow the Command prompts to correct the errors in the dynamic block
definition.

4 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

5 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

To view dependencies within a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, select a parameter or an action.

If you selected a parameter, its associated action is highlighted.

If you selected an action, its associated parameter and selection set of
geometry is highlighted.

3 When you're finished viewing the dependencies, press ESC.

4 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

View Actions Related to a Parameter
Action objects are grouped into Action bars based on their associated
parameters.

Action bars provide a quick visual representation of all actions associated with
a parameter. Each action is displayed as an icon on the action bar.

892 | Chapter 18   Create and Use Blocks (Symbols)



The action bar is located relative to the parameter object by default but can
be moved to any location.

Hover the cursor over an action icon to display

■ The associated parameter

■ The associated selection set

■ Additional graphics that belong to the action

NOTE In order to use the BASSOCIATE command, you must first set
BACTIONBARMODE to 0.

To display action bars for all parameters

■ Click Insert tab  ➤  Block panel  ➤  Block Editor. 

■ Click Block Editor tab ➤ Action Parameters panel ➤ Show All Actions.
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Command entry: BACTIONBAR

To hide action bars for all parameters

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Action Parameters panel ➤ Hide All Actions.

Command entry: BACTIONBAR

To turn on or off the Action bar mode

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Manage panel  ➤  Dialog box launcher. 

3 In the Block Editor Settings dialog box, select Display Action Bars. Click
OK.

Command entry: BACTIONBARMODE

Quick Reference

Commands

BACTIONBAR

Displays or hides action bars for a selection set of parameter objects.

System Variables

BACTIONBARMODE

Indicates whether the action bars or the legacy action objects are displayed
in the Block Editor.
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Test Blocks Within the Block Editor
A test block window is displayed to allow easy testing of the block definition
while creating dynamic blocks.

The block definition does not need to be saved to test the edits made in the
Block Editor. The test block window reflects the current block definition in
the Block Editor. You can test the block without exiting the Block Editor.

The test block window automatically closes when you exit the Block Editor,
open a different block from the Block Editor, or save the current block
definition to a different name.

Only one test block window can be open at a time. If a test block window is
open and you enter BTESTBLOCK, the window closes and a new test block
window is opened.

Most AutoCAD commands are unchanged in the test block window except
the following commands:

■ BEDIT - Disabled in test block window

■ SAVE, SAVEAS, and QSAVE - Do not display a default file name in the Save
dialog box. If you save from the test block window, the contextual tab is
removed and a new drawing is created. The test block window is closed.

■ CLOSE and QUIT- Do not prompt to save when closing the test block
window.

To test a dynamic block

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Open/Save panel ➤ Test Block. 

Command entry: BTESTBLOCK

To close the test block window

■ In the test block window, click Close Test Block Window. 
Closing the test block window returns you to the Block Editor.
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Quick Reference

Commands

BTESTBLOCK

Displays a window within the Block Editor to test a dynamic block.

System Variables

BLOCKTESTWINDOW

Indicates whether or not a test block window is current.

Save Blocks
When you are finished adding elements to your dynamic block definition in
the Block Editor, save the block definition.

In the Block Editor, you can save your block definition by clicking the Save
Block button on the Block Editor contextual tab, or by entering bsave at the
Command prompt. You should then save your drawing to make sure that the
block definition is saved in the drawing.

When you save a block definition in the Block Editor, the current values of
the geometry and parameters in the block are set as the default values for the
block reference. When you create a dynamic block that uses visibility states,
the default visibility state for the block reference is the visibility state at the
top of the list in the Manage Visibility States dialog box.

Once you've saved the block definition, you can close the Block Editor and
try your block in a drawing.

NOTE If you click File menu  ➤  Save while you are in the Block Editor, you will
save the drawing but not the block definition. You must specifically save the block
definition while you are in the Block Editor.

To save a block definition in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Open/Save panel ➤ Save Block. 
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3 To save the block definition in the drawing, click File menu  ➤ Save.

4 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Command entry: BSAVE

To save a copy of the current block definition in the Block Editor under a new
name

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Open/Save panel ➤ Save Block As. 

3 In the Save Block As dialog box, enter a name for the new block definition.

4 Click OK.

5 To save the block definition in the drawing, click File menu  ➤ Save.

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Command entry: BSAVEAS

To save the current block definition as a new drawing file

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Open/Save panel ➤ Save Block As. 

3 In the Save Block As dialog box, enter a name for the new block definition.

4 Select the Save Block Definition to Drawing File check box.

5 Click OK.

6 In the Browse For Drawing File dialog box, click Save.

Command entry: BSAVEAS
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Quick Reference

Commands

BCLOSE

Closes the Block Editor.

BEDIT

Opens the block definition in the Block Editor.

BSAVE

Saves the current block definition.

BSAVEAS

Saves a copy of the current block definition under a new name.

Add Constraints to Dynamic Blocks
You can add geometric constraints and constraint parameters to a dynamic
block in the Block Editor.

Add Geometric Constraints to Dynamic Blocks
A geometric constraint defines a relationship between two objects, or between
an object and a coordinate system.

Overview of Geometric Constraints in Dynamic Blocks
With geometric constraints, you can

■ Maintain parallel, perpendicular, tangent, or coincidence points between
two objects

■ Force a line or pair of points to remain vertical or horizontal

■ Fix a point on an object to the WCS

See also:

■ Constrain Objects Geometrically on page 723
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Automatically Constrain a Block Definition
You can automatically apply geometric constraints to the objects in the block
definition.

With the AUTOCONSTRAIN command, constraints are applied to objects that
already fit the criteria for geometric constraints as they are currently drawn
in the block definition.

For example, in the illustration below, an armchair is depicted on the left.
The AUTOCONSTRAIN command was applied to the armchair.

Because of the geometry of the objects, the following constraints were
automatically applied to the armchair on the right:

■ Coincident constraint on page 900

■ Parallel constraint on page 905

■ Perpendicular constraint on page 907

■ Horizontal constraint on page 908

■ Tangent constraint on page 911

■ Equal constraint on page 915

See also:

■ To apply multiple geometric constraints to an object on page 732
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Quick Reference

Commands
AUTOCONSTRAIN

Applies geometric constraints to a selection set of objects based on orientation
of the objects relative to one another.

Add a Coincident Constraint
A coincident constraint forces two points, or a point and line, to coincide.

Apply a Coincident Constraint

In the example below, a coincident constraint has been applied to the
midpoints of the two lines on the left. The result is the block definition on
the right, where the midpoints coincide with each other.

Manipulate a Coincident Constraint

When you manipulate a block with a coincident constraint applied, the
specified points will always coincide with each other.

In the example below, the constrained block on the left has been manipulated
to produce the block on the right. The two lines can move and change shape,
but will always be constrained to coincide at their midpoints.
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See also:

■ Apply or Remove Geometric Constraints on page 725

■ To apply a coincident constraint on page 728

Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.

Add a Colinear Constraint
A colinear constraint forces two lines to follow the same infinite line.

Apply a Colinear Constraint

In the example below, a colinear constraint has been applied to the two lines
on the left. The result is the block definition on the right, where the two lines
are aligned.

Manipulate a Colinear Constraint

When you manipulate a block with a colinear constraint applied, the specified
lines will always be aligned with each other.

In the example below, the constrained lines on the top have been rotated to
produce the block on the bottom. The two lines can move, change angle, or
change shape, but will always be constrained to align.
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See also:

■ Apply or Remove Geometric Constraints on page 725

■ To apply a collinear constraint on page 728

Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.

Add a Concentric Constraint
A concentric constraint forces selected circles, arcs, or ellipses to maintain the
same center point.

Apply a Concentric Constraint

In the example below, a concentric constraint has been applied to the two
circles on the left. On the right, the circles share the same center point.
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Manipulate a Concentric Constraint

When you manipulate a block with a concentric constraint applied, the
specified circles, arcs, or ellipses will always share the same center point.

In the example below, the constrained ellipses on the top have been
manipulated to produce the block on the bottom. The two ellipses can move,
change shape, or change size, but will always be constrained to share the same
center point.

See also:

■ Apply or Remove Geometric Constraints on page 725

■ To apply a concentric constraint on page 729
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Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.

Add a Fixed Constraint
A fixed constraint fixes a point or curve to a specified location and orientation
relative to the World Coordinate System (WCS).

Apply a Fixed Constraint

In the example below, a fix constraint has been applied to the rectangle on
the top. The result is the block definition on the bottom, where the bottom-left
corner of the rectangle is fixed to the specified coordinate. The red X indicates
the constrained point on the rectangle.

Manipulate a Fixed Constraint

When you manipulate a block with a fix constraint applied, the specified
point will always remain positioned at the same WCS coordinates.

In the example below, the geometry of the rectangle on the top has been
manipulated. The other three corners of the rectangle can move, but the
constrained point will remain in the same position.
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See also:

■ Apply or Remove Geometric Constraints on page 725

■ To apply a fix constraint on page 729

Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.

Add a Parallel Constraint
A parallel constraint forces two lines to remain parallel to each other.

Apply a Parallel Constraint

In the example below, a parallel constraint has been applied to the two lines
on the left. The result is the block definition on the right, where the lines are
parallel to each other.
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Manipulate a Parallel Constraint

When you manipulate a block with a parallel constraint applied, the specified
lines will always remain parallel to each other.

In the example below, a parallel constraint has been applied to one line in
each of the rectangles on top. The geometry of each rectangle on the bottom
has been changed, but the constrained lines remain parallel to each other.

See also:

■ Apply or Remove Geometric Constraints on page 725

■ To apply a parallel constraint on page 729
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Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.

Add a Perpendicular Constraint
A perpendicular constraint forces two lines or polyline segments to maintain
a 90-degree angle to each other.

Apply a Perpendicular Constraint

In the example below, a perpendicular constraint has been applied to the two
lines on the left. The result is the block definition on the right, where the lines
are perpendicular to each other.

Manipulate a Perpendicular Constraint

When you manipulate a block with a perpendicular constraint applied, the
specified lines will always remain perpendicular to each other.

In the example below, a perpendicular constraint has been applied to one
point on the octagon on the left. The geometry of the octagon on the right
has been changed, but the constrained lines remain perpendicular to each
other.
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See also:

■ Apply or Remove Geometric Constraints on page 725

■ To apply a perpendicular constraint on page 730

Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.

Add a Horizontal Constraint
A horizontal constraint forces a line or pair of points to remain parallel to the
X-axis of the current UCS.

Apply a Horizontal Constraint

In the example below, a horizontal constraint has been applied to the triangle
on the left. The result is the block definition on the right, where the
constrained line is horizontal to the current UCS.
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Manipulate a Horizontal Constraint

When you manipulate a block with a horizontal constraint applied, the
constrained line or points will always remain horizontal to the UCS.

In the example below, a horizontal constraint has been applied to the triangle
on the left. The geometry of the triangle on the right has been changed, but
the constrained line remains horizontal.

See also:

■ Apply or Remove Geometric Constraints on page 725

■ To apply a horizontal constraint on page 730

Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.

Add a Vertical Constraint
A vertical constraint forces lines of pairs of points to remain parallel to the
Y-axis of the current UCS.

Apply a Vertical Constraint

In the example below, a vertical constraint has been applied to the triangle
on the left. The result is the block definition on the right, where the
constrained line is vertical to the current UCS.
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Manipulate a Vertical Constraint

When you manipulate a block with a vertical constraint applied, the
constrained line or points will always remain vertical to the UCS.

In the example below, a vertical constraint has been applied to the triangle
on the left. The geometry of the triangle on the right has been changed, but
the constrained line remains vertical.

See also:

■ Apply or Remove Geometric Constraints on page 725

■ To apply a vertical constraint on page 730

Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.
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Add a Tangent Constraint
A tangent constraint forces two curves to maintain a point of tangency to
each other or their extensions.

Apply a Tangent Constraint

In the example below, a tangent constraint has been applied to the circle and
line on the left. The result is the block definition on the right, where the
constrained line is tangent to the circle.

Manipulate a Tangent Constraint

When you manipulate a block with a tangent constraint applied, the object
selected second will always remain tangent to the object selected first.

In the example below, a tangent constraint has been applied to the two circles
on the left. The size and rotation of the circles on the right have been changed,
but the tangency remains.

See also:

■ Apply or Remove Geometric Constraints on page 725
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■ To apply a tangent constraint on page 731

Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.

Add a Smooth Constraint
A smooth constraint forces a spline to maintain geometric continuity with
another spline, line, arc, or polyline.

Apply a Smooth Constraint

In the example below, a smooth constraint has been applied to the two spline
curves on the left. The result is the block definition on the right, where the
spline curves are joined continuously.

Manipulate a Smooth Constraint

When you manipulate a block with a smooth constraint applied, the
constrained objects will always maintain fluid continuity.
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In the example below, the two spline curves on the left have a smooth
constraint applied. The geometry of the spline curves on the right has been
changed, but they retain a fluid continuity.

See also:

■ Apply or Remove Geometric Constraints on page 725

■ To apply a smooth constraint on page 731

Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.

Add a Symmetric Constraint
A symmetric constraint forces two curves or points on an object to maintain
symmetry about a selected line.

Apply a Symmetric Constraint

In the example below, a symmetric constraint has been applied to the two
lines on the left. The result is the block definition on the right, where the lines
are parallel to each other.
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Manipulate a Symmetric Constraint

When you manipulate a block with a symmetric constraint applied, the
constrained line’s angle, or constrained circle’s center point and radius, will
remain symmetrical.

In the example below, the two outside edges of the polygon on the left have
a symmetric constraint applied. The geometry of the polygon on the right
has been changed, but the angles of the constrained edges remain symmetrical.

See also:

■ Apply or Remove Geometric Constraints on page 725

■ To apply a symmetric constraint on page 731

■ Create Construction Geometry Within a Block on page 1002
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Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.

Add an Equal Constraint
An equal constraint forces two lines or polyline segments to maintain equal
lengths or arcs.

Apply an Equal Constraint

In the example below, an equal constraint has been applied to the triangle
on the left. The result is the block definition on the right, where the
constrained lines in the triangle are equal to each other.

Manipulate an Equal Constraint

When you manipulate a block with an equal constraint applied, the
constrained objects will remain equal.

In the example below, two lines in the polygon on the left have an equal
constraint applied. The geometry of the polygon on the right has been
changed, but the constrained lines remain equal in length.
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See also:

■ Apply or Remove Geometric Constraints on page 725

■ To apply an equal constraint on page 732

Quick Reference

Commands

GEOMCONSTRAINT

Applies or persists geometric relationships between objects or points on
objects.

Add Dimensional Constraints to Dynamic Blocks
A dimensional constraint applied within the Block Editor using the
BCPARAMETER command is called a constraint parameter.

Overview of Constraint Parameters
While you can use both dimensional constraints and constraint parameters
in a block definition, only constraint parameters will display editable custom
properties for that block reference.

Constraint parameters contain parameter information. The parameter values
can be displayed or edited for the block reference. A constraint parameter can
only be created in the Block Editor.

916 | Chapter 18   Create and Use Blocks (Symbols)



The above block definition contains both a linear constraint and a horizontal
constraint parameter. The horizontal constraint parameter includes a grip,
while the linear constraint does not. The horizontal constraint parameter is
also dynamic, while the linear constraint is not.

See also:

■ Apply Dimensional Constraints on page 744

■ Specify Custom Properties for Dynamic Blocks on page 1004

■ Associative Dimensions on page 1627

To convert a dimensional constraint into a constraint parameter

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Dimensional panel ➤ Convert. 

3 Select a dimensional constraint in the Block Editor or enter a constraint
parameter type option in the command line.

To turn on or turn off the constraint display status

■ In the Block Editor status bar, click the Constraint Status button. 

To display or hide dynamic constraints

 ➤ Click Parametric tab  ➤  Dimensional panel  ➤  Dynamic Constraints.

DYNCONSTRAINTDISPLAY
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Quick Reference

Commands

BCPARAMETER

Applies constraint parameters to selected objects, or converts dimensional
constraints to parameter constraints.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

System Variables

BCONSTATUSMODE

Turns the constraint display status on and off and controls the shading of
objects based on their constraint level.

Add a Horizontal Constraint Parameter
A horizontal constraint parameter controls the X distance between two points
on one object, or between two objects.

While a linear dimension on page 1679 represents the distance between two
points, a horizontal constraint parameter defines and controls the horizontal
distance between two points.

In the example below, the polygon on the left has a horizontal constraint of
1 unit applied to the top line of the polygon. When that polygon is rotated,
the result is the polygon on the right. The constrained points will remain 1
unit apart horizontally.
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See also:

■ Apply Dimensional Constraints on page 744

■ Constrain a Design with Formulas and Equations on page 758

■ Create Horizontal and Vertical Dimensions on page 1679

To add a horizontal constraint to a block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Dimensional panel ➤ Horizontal. 

3 Specify the first constraint point or object.

4 Specify the second constraint point or object.

5 Specify the dimension line location.

6 Follow the Command prompts to specify the following for the constraint:

■ Value or name and value

■ Number of grips

7 Press Enter.

Command entry: BCPARAMETER

Quick Reference

Commands

BCPARAMETER

Applies constraint parameters to selected objects, or converts dimensional
constraints to parameter constraints.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.
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System Variables

BCONSTATUSMODE

Turns the constraint display status on and off and controls the shading of
objects based on their constraint level.

Add a Vertical Constraint Parameter
A vertical constraint controls the Y distance between two points on one object,
or between two objects.

While a linear dimension on page 1679 represents the distance between two
points, a vertical constraint parameter defines and controls the vertical distance
between two points.

In the example below, the polygon on the left has a vertical constraint of 2
units applied to the left line of the polygon. When that polygon is rotated
counterclockwise, the result is the polygon on the right. The constrained
points will remain 2 units apart vertically.

See also:

■ Apply Dimensional Constraints on page 744

■ Constrain a Design with Formulas and Equations on page 758

■ Create Horizontal and Vertical Dimensions on page 1679

To add a vertical constraint parameter to a block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Dimensional panel ➤ Vertical. 
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3 Specify the first constraint point or object.

4 Specify the second constraint point or object.

5 Specify the dimension line location.

6 Follow the Command prompts to specify the following for the constraint:

■ Value or name and value

■ Number of grips

7 Press Enter.

Command entry: BCPARAMETER

Quick Reference

Commands

BCPARAMETER

Applies constraint parameters to selected objects, or converts dimensional
constraints to parameter constraints.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

System Variables

BCONSTATUSMODE

Turns the constraint display status on and off and controls the shading of
objects based on their constraint level.

Add an Aligned Constraint Parameter
An aligned constraint controls the distance between two points on an object,
one point and one object, or two line segments.

While analigned dimension on page 1681 represents the distance between two
points, an aligned constraint parameter defines and controls the distance between
two points.

In the example below, two points on the polygon on the left have an aligned
constraint parameter applied. When that polygon is manipulated, the result
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is the polygon on the right. The constrained points will remain at the same
distance, and the other points will move to keep that distance.

See also:

■ Apply Dimensional Constraints on page 744

■ Constrain a Design with Formulas and Equations on page 758

■ Create Aligned Dimensions on page 1681

To add an aligned constraint to a block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Dimensional panel ➤ Aligned. 

3 Specify the first constraint point or object.

4 Specify the second constraint point or object.

5 Specify the dimension line location.

6 Follow the Command prompts to specify the following for the constraint:

■ Value or name and value

■ Number of grips

7 Press Enter.

Command entry: BCPARAMETER
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Quick Reference

Commands

BCPARAMETER

Applies constraint parameters to selected objects, or converts dimensional
constraints to parameter constraints.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

System Variables

BCONSTATUSMODE

Turns the constraint display status on and off and controls the shading of
objects based on their constraint level.

Add an Angular Constraint Parameter
An angular constraint controls the angle between two line or polyline
segments, or the angle of an arc.

While an angular dimension on page 1696 represents the angle between two
lines or three points, an angular constraint parameter defines and controls the
angle.

In the example below, the polygon on the left has an angular constraint of
30 degrees applied to one corner of the polygon. When one point on that
polygon is manipulated, the result is the polygon on the right. The constrained
corner will remain at 30 degrees, while the geometry of the polygon will
change to keep that angle.
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See also:

■ Apply Dimensional Constraints on page 744

■ Create Angular Dimensions on page 1696

To add an angular constraint to a block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Dimensional panel ➤ Angular. 

3 Specify a line or a polyline segment.

4 Specify the second line or the next two constraint points (for polyline
segments).

5 Specify the dimension line location.

6 Follow the Command prompts to specify the following for the constraint:

■ Value or name and value

■ Number of grips

7 Press Enter.

Command entry: BCPARAMETER

To add an angular constraint to an arc block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Dimensional panel ➤ Angular. 

3 Specify an arc.

4 Specify the dimension line location.

5 Follow the Command prompts to specify the following for the constraint:

■ Value or name and value
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■ Number of grips

6 Press Enter.

Command entry: BCPARAMETER

Quick Reference

Commands

BCPARAMETER

Applies constraint parameters to selected objects, or converts dimensional
constraints to parameter constraints.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

System Variables

BCONSTATUSMODE

Turns the constraint display status on and off and controls the shading of
objects based on their constraint level.

Add a Radial Constraint Parameter
A radial constraint parameter controls the radius of a circle, arc, or polyline
arc segment.

While a radial dimension on page 1688 represents the radius of a circle or arc,,
a radial constraint parameter defines and controls the radius.

In the example below, a radial constraint parameter has been applied to the
polyline arc in the block definition on the left. The polyline has been
manipulated in the block definition on the right. As a result, the radius of the
arc remains fixed while the polyline segments around it change.
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See also:

■ Apply Dimensional Constraints on page 744

■ Constrain a Design with Formulas and Equations on page 758

■ Create Radial Dimensions on page 1688

To add a radial constraint to a block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Dimensional panel ➤ Radius. 

3 Specify an arc or a circle.

4 Specify the dimension line location.

5 Follow the Command prompts to specify the following for the constraint:

■ Value or name and value

■ Number of grips

6 Press Enter.

Command entry: BCPARAMETER
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Quick Reference

Commands

BCPARAMETER

Applies constraint parameters to selected objects, or converts dimensional
constraints to parameter constraints.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

System Variables

BCONSTATUSMODE

Turns the constraint display status on and off and controls the shading of
objects based on their constraint level.

Add a Diameter Constraint Parameter
A diameter constraint parameter controls the radius of a circle, arc, or polyline
arc segment.

While a diameter dimension on page 1688 represents the diameter of an arc or
circle, a diameter constraint parameter defines and controls the diameter.

In the example below, a diameter constraint parameter has been applied to
the polyline arc in the block definition on the left. The polyline has been
manipulated in the block definition on the right. As a result, the diameter of
the arc remains fixed while the polyline segments around it change.

See also:

■ Apply Dimensional Constraints on page 744
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■ Constrain a Design with Formulas and Equations on page 758

■ Create Radial Dimensions on page 1688

To add a diameter constraint to a block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Dimensional panel ➤ Diameter. 

3 Specify an arc or a circle.

4 Specify the dimension line location.

5 Follow the Command prompts to specify the following for the constraint:

■ Value or name and value

■ Number of grips

6 Press Enter.

Command entry: BCPARAMETER

Quick Reference

Commands

BCPARAMETER

Applies constraint parameters to selected objects, or converts dimensional
constraints to parameter constraints.

DIMCONSTRAINT

Applies dimensional constraints to selected objects or points on objects.

System Variables

BCONSTATUSMODE

Turns the constraint display status on and off and controls the shading of
objects based on their constraint level.
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Identify Fully Constrained Objects
When an object is fully constrained, all relevant geometric and dimensional
constraints are applied to the geometry.

You should always fully constrain geometry in a dynamic block definition
that contains constraints. If a block definition is not fully constrained, you
may get unpredictable behavior when the block is inserted in a drawing.

For more information on fully constrained objects, see Overview of Constraints
on page 718.

Work with Fully Constrained Block Definitions

You can identify fully constrained objects with the constrained status mode
in the Block Editor. The BCONSTATUSMODE system variable allows you to
switch between the constrained status modes. You can also use the ribbon to
switch between modes while in the Block Editor.

The constrained geometry is represented with different colors. For more
information see the Block Editor Settings dialog box.

NOTE A fully constrained block definition must contain at least one fixed geometric
constraint.

See also:

■ Add a Fixed Constraint on page 904

To identify the constrained objects

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Manage panel  ➤  Constraint Status. 

The constrained objects are represented with the constraint status colors
specified in the Block Editor Settings dialog box.

Pointing device: In the Drawing Status Bar, click the Constraint Status
button.
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To specify color assignment for the constraint display status

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Manage panel  ➤  Block Editor Settings.

3 In the Block Editor Settings dialog box, under Constraint Status, specify
colors for the following constrained objects:

■ Unconstrained

■ Partially Constrained

■ Fully Constrained

■ Improperly Constrained

4 Click OK.

Command entry: BESETTINGS
Pointing device: In the Drawing Status Bar, right-click the Constraint Status
button and click Settings.

Quick Reference

Commands

BESETTINGS

Displays the Block Editor Settings dialog box.

System Variables

BCONSTATUSMODE

Turns the constraint display status on and off and controls the shading of
objects based on their constraint level.

Add Actions and Parameters to Dynamic Blocks
You can add actions and parameters to dynamic blocks to determine how a
block should behave when it is inserted into a drawing.
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Overview of Actions and Parameters in Dynamic Blocks
While you work, you can manipulate the geometry in a dynamic block
reference through custom grips or custom properties instead of searching for
another block to insert, or redefining the existing one.

For example, the size of a door block reference in a drawing might need to
change while you're editing the drawing. If the block is dynamic and defined
to have an adjustable size, you can drag the custom grip or by specify a
different size in the Properties palette. The door block might also contain an
alignment grip, which allows you to align the door block reference easily to
other geometry in the drawing.

You can create a block from scratch, or you can add dynamic behavior to an
existing block definition. You can also create geometry, just as you would in
the drawing area.

Parameters and actions are displayed only in the Block Editor. When you
insert a dynamic block reference in a drawing, the parameters and actions
contained in the dynamic block definition are not displayed.

Actions You Can Associ-
ate with a Parameter

Grip TypeParameter Type

Move, StretchStandardPoint

Move, Scale, Stretch, ArrayLinearLinear
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Actions You Can Associ-
ate with a Parameter

Grip TypeParameter Type

Move, Scale, Stretch, Polar
Stretch, Array,

StandardPolar

Move, Scale, Stretch, ArrayStandardXY

RotateRotationRotation

FlipFlipFlip

None (The action is im-
plied and contained within
the parameter.)

AlignmentAlignment

None (The action is im-
plied and controlled by
visibility states.)

LookupVisibility

LookupLookupLookup

NoneStandardBase

See also:

■ Save Blocks on page 896

To create a dynamic block

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Edit Block Definition dialog box, do one of the following:

■ Select a block definition from the list.
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■ Select <Current Drawing> if you want to save the drawing as a dynamic
block.

■ Under Block to Create or Edit, enter a name for a new block definition.

3 Click OK.

4 In the Block Editor, add or edit geometry as necessary.

5 Do one of the following:

■ Add one or more parameter sets from the Parameter Sets tab of the
Block Authoring Palettes, following the Command prompts.
Double-click the yellow alert icon (or use the BACTIONSET command)
and follow the Command prompts to associate the action with a
selection set of geometry.

■ Add one or more parameters from the Parameters tab of the Block
Authoring Palettes, following the Command prompts. Add one or
more actions from the Actions tab, following the Command prompts.

6 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

7 Click Close Block Editor.

Toolbar: Standard  
Command entry: BEDIT

Shortcut menu: Right-click a block. Click Block Editor.

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BLOCK

Creates a block definition from selected objects.
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Quick Start to Creating Dynamic Blocks
You add dynamic behavior to new or existing block definitions by adding
parameters and actions to the block in the Block Editor. In the following
example, a desk block is shown in the Block Editor. The block contains a linear
parameter, which displays similar to a dimension and is labeled “Distance,”
and a stretch action, which displays a lightning bolt and a “Stretch” label.

For a block to be dynamic, you must add at least one parameter. You then
add an action and associate the action with the parameter. The types of
parameters and actions you add to the block definition define how the block
reference will work in a drawing.

Process for Creating Dynamic Blocks

To create quality dynamic blocks, so you get the results you expect, it is
recommended that you follow the steps in the following process. This process
will help you author dynamic blocks effectively.

Step 1. Plan the contents of the dynamic block before you create it

Before you create a dynamic block, you should know what it will look like
and how it will be used in a drawing. Decide which objects within the block
will change or move when the dynamic block reference is manipulated.
Furthermore, decide how these objects will change. For example, you might
create a dynamic block that can be resized. In addition, when the block
reference is resized, additional geometry may be displayed. These factors
determine the types of parameters and actions you add to the block definition,
and how you make the parameters, actions, and geometry work together.

Step 2. Draw the geometry

You can draw the geometry for your dynamic block in the drawing area, the
Block Editor contextual tab, or the Block Editor. You can also use existing
geometry in a drawing or an existing block definition.
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NOTE If you will use visibility states to change how geometry is displayed in the
dynamic block references, you may not want to include all the geometry at this
point. For more information about working with visibility states, see Create Visibility
States.

Step 3. Understand how the block elements will work together

Before you add parameters and actions to your block definition, understand
their dependencies on each other and on the geometry within the block. When
you add an action to the block definition, you will need to associate the action
with a parameter and a selection set of geometry. This creates a dependency.
When you add multiple parameters and actions to a dynamic block reference,
you will need to set up the correct dependencies in order for the block reference
to function properly in a drawing.

For example, you create a dynamic block that contains several objects. Some
of the objects have a stretch action associated with them. You also want all
the objects to rotate around the same base point. In this case, you should add
the rotate action after adding all the other parameters and actions. If the rotate
action isn't associated with all of the other objects (geometry, parameters, and
actions) in the block definition, parts of the block reference may not rotate
or manipulating the block reference may cause unexpected results.

Step 4. Add parameters

Add the appropriate parameters to the dynamic block definition, following
the prompts at the Command prompt. For more information about using
parameters, see Add Action Parameters to Dynamic Blocks on page 936.

NOTE You can use the Parameter Sets tab of the Block Authoring Palettes to add
a parameter and an associated action at the same time. For more information
about using parameter sets, see Use Parameter Sets on page 984.

Step 5. Add actions

Add the appropriate actions to the dynamic block definition. Follow the
prompts at the Command prompt, making sure to associate the actions with
the correct parameters and geometry. For more information about using
actions, see Overview of Using Actions on page 960.

Step 6. Define how the dynamic block reference will be manipulated

You can specify how the dynamic block reference will be manipulated in the
drawing. You can manipulate a dynamic block reference through custom grips
and custom properties. When you create a dynamic block definition, you
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define what grips are displayed and how they edit the dynamic block reference.
You also specify whether or not custom properties for the block will be shown
in the Properties palette and whether or not these properties can be changed
through the palette or through custom grips.

Step 7. Test the block

On the ribbon, in the Block Editor contextual tab, Open/Save panel, click Test
Block to test the block before you save it.

See also:

■ Overview of Actions and Parameters in Dynamic Blocks on page 931

■ Overview of Dynamic Block Elements

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BLOCK

Creates a block definition from selected objects.

BTESTBLOCK

Displays a window within the Block Editor to test a dynamic block.

Add Action Parameters to Dynamic Blocks

Overview of Using Action Parameters
You can use parameters in block references to specify

■ Positions

■ Distances

■ Angles
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When you add a parameter to a block definition, custom grips and properties
are automatically added to the block. You use these custom grips and properties
to manipulate the block reference in the drawing.

When you add a parameter to a dynamic block definition, grips are added to
key points of the parameter. Key points are the parts of a parameter that you
use to manipulate the block reference. For example, a linear parameter has
key points at its base point and end point. You can manipulate the parameter
distance from either key point.

The type of parameter that you add to a dynamic block determines the type
of grips that are added. Each type of parameter supports only certain types of
actions.

For example, a block of a chair can contain an Angle property that defines a
rotation parameter. The rotation parameter defines the axis on which the
chair can be rotated as you edit.

If you add a point parameter to a dynamic block definition, the point
parameter defines two custom properties for the block reference: Position X
and Position Y (relative to the base point of the block reference.)

A dynamic block definition must contain at least one parameter. When a
parameter is added to a dynamic block definition, grips associated with key
points of the parameter are automatically added. You must then add an action
to the block definition and associate the action with a parameter.

In a drawing, you use a grip or custom property in the Properties palette to
manipulate the block reference. When you manipulate the block reference in
a drawing, by moving a grip or changing the value of a custom property in
the Properties palette, you change the value of the parameter that defines that
custom property in the block. When you change the value of the parameter,
it drives the action that is associated with that parameter, which changes the
geometry (or a property) of the dynamic block reference.

Parameters also define and constrain values that affect the dynamic block
reference's behavior in a drawing. Some parameters can have a fixed set of
values, minimum and maximum values, or increment values. For example, a
linear parameter used in a window block may have the following fixed set of
values: 10, 20, 30, and 40. When the block reference is inserted in a drawing,
you can only change the window to one of these values. Adding a value set
to a parameter allows you to limit how the block reference is manipulated in
a drawing. For more information about parameter value sets, see Specify Value
Sets for Dynamic Blocks on page 1009.

You can also extract parameter values through the Attribute Extraction wizard
or through an attribute extraction template file.
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See also:

■ Specify Value Sets for Dynamic Blocks on page 1009

■ Overview of Specifying Custom Properties for Dynamic Blocks on page 1005

■ Extract Data from Block Attributes on page 1034

■ Extract Block Attribute Data (Advanced) on page 1035

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BSAVE

Saves the current block definition.

Add a Point Parameter
A point parameter defines an X and Y location for the block in the drawing.

In the Block Editor, a point parameter displays similar to an ordinate
dimension.

You can also associate the following actions with a point parameter:

■ Move on page 962

■ Stretch on page 968

If a grip is displayed for a point parameter, you can manipulate the parameter
even if no action is associated with it.

The point parameter contains a property called Chain Actions. For more
information about allowing chained actions for a parameter, see Allow Chained
Actions for Dynamic Blocks on page 1014.

938 | Chapter 18   Create and Use Blocks (Symbols)



See also:

■ Specify Grips for Dynamic Blocks on page 987

■ Add a Move Action on page 962

■ Add a Stretch Action on page 968

To add a point parameter to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤  Action Parameters panel  ➤  Point.

3 (Optional) Follow the Command prompts to specify the following for
the parameter:

■ Type

■ Label

■ Description

■ Chained Actions

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you've added the parameter to the block definition.

4 Specify a location for the parameter.

5 Specify a location for the parameter label.

6 To add an action now, double-click the alert icon. Follow the prompts
to associate an action with the parameter and a selection set of geometry.

7 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

8 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BPARAMETER
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Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BSAVE

Saves the current block definition.

Add a Linear Parameter
A linear parameter shows the distance between two anchor points.

When you insert a linear parameter, grip movement is constrained along a
preset angle. In the Block Editor, a linear parameter looks similar to an aligned
dimension.

You can associate the following actions with a linear parameter:

■ Move

■ Scale

■ Stretch

■ Array

The linear parameter has a property called Chain Actions. For more information
about allowing chained actions for a parameter, see Allow Chained Actions
for Dynamic Blocks on page 1014.

To add a linear parameter to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Dimensional panel  ➤  Linear. 
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3 (Optional) Follow the Command prompts to specify the following for
the parameter:

■ Type

■ Label

■ Description

■ Value set

■ Chained Actions

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you've added the parameter to the block definition.

4 Specify a base point for the parameter.

5 Specify an endpoint for the parameter.

6 Specify a location for the parameter label

7 Follow the prompts to associate an action with the parameter and a
selection set of geometry.

8 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

9 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BPARAMETER

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.
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BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BSAVE

Saves the current block definition.

Add a Polar Parameter
A polar parameter shows the distance between two anchor points and displays
an angle value.

You can use both grips and the Properties palette to change both the distance
value and the angle of the block reference. In the Block Editor, the polar
parameter looks similar to an aligned dimension.

You can associate the following actions with a polar parameter:

■ Move

■ Scale

■ Stretch

■ Polar Stretch

■ Array

The polar parameter has a property called Chain Actions. For more information
about allowing chained actions for a parameter, see Allow Chained Actions
for Dynamic Blocks on page 1014.

To add a polar parameter to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Action Parameters panel  ➤  Polar. 

3 (Optional) Follow the Command prompts to specify the following for
the parameter:

■ Type

■ Label
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■ Description

■ Value set

■ Chained Actions

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you've added the parameter to the block definition.

4 Specify a base point for the parameter.

5 Specify an endpoint for the parameter.

6 Specify a location for the parameter label

7 To add an action now, double-click the alert icon. Follow the prompts
to associate an action with the parameter and a selection set of geometry.

8 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

9 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BPARAMETER

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BSAVE

Saves the current block definition.
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Add an XY Parameter
An XY parameter shows the X and Y distances from the base point of the
parameter.

In the Block Editor, an XY parameter displays as a pair of dimensions
(horizontal and vertical).

You can associate the following actions with an XY parameter:

■ Move

■ Scale

■ Stretch

■ Array

The XY parameter has a property called Chain Actions. For more information
about allowing chained actions for a parameter, see Allow Chained Actions
for Dynamic Blocks on page 1014.

To add an XY parameter to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤  Action Parameters panel  ➤  XY.

3 Follow the Command prompts to specify the parameter type.

4 Specify a base point for the parameter.

5 Specify an endpoint for the parameter.

6 To add an action now, double-click the alert icon. Follow the prompts
to associate an action with the parameter and a selection set of geometry.

7 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

8 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BPARAMETER
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Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BSAVE

Saves the current block definition.

Add a Rotation Parameter
A rotation parameter defines an angle.

In the Block Editor, a rotation parameter displays as a circle.

You can associate a rotate action on page 975 with a rotation parameter.

If a grip is displayed for a rotate parameter, you can manipulate the parameter
even if no action is associated with it.

The rotation parameter has a property called Chain Actions. For more
information about allowing chained actions for a parameter, see Allow Chained
Actions for Dynamic Blocks on page 1014.

See also:

■ Add a Rotate Action on page 975

To add a rotation parameter to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Action Parameters panel  ➤  Rotation.

3 Follow the Command prompts to specify the parameter type.

4 Specify a base point for the parameter.

5 Specify the radius for the parameter.

6 Specify a base angle for the parameter.
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The angle shown in the Properties palette when you select the block
reference in a drawing is measured relative to the base angle specified in
the block definition.

7 Specify a default rotation angle for the parameter.

8 Specify a location for the parameter label.

9 To add an action now, double-click the alert icon. Follow the prompts
to associate an action with the parameter and a selection set of geometry.

10 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

11 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BPARAMETER

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BSAVE

Saves the current block definition.

Add a Flip Parameter
A flip parameter flips objects.

In the Block Editor, a flip parameter displays as a reflection line. Objects can
be flipped about this reflection line. The parameter displays a value that
indicates whether the block reference has been flipped.

You can associate a flip action with a flip parameter.
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See also:

■ Add a Flip Action on page 978

To add a flip parameter to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Action Parameter panel  ➤  Flip.

3 (Optional) Follow the Command prompts to specify the following for
the parameter:

■ Type

■ Label

■ Description

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you've added the parameter to the block definition.

4 Specify the first point of the reflection line for the flip parameter.

This first point of the reflection line is the default location for the flip
parameter grip.

5 Specify the second point of the reflection line for the flip parameter.

6 Specify a location for the parameter label.

7 To add an action now, double-click the alert icon. Follow the prompts
to associate an action with the parameter and a selection set of geometry.

8 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

9 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BPARAMETER
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Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BSAVE

Saves the current block definition.

Add an Alignment Parameter
An alignment parameter defines an X and Y location and an angle.

An alignment parameter allows the block reference to automatically rotate
around a point to align with another object in the drawing. An alignment
parameter affects the rotation property of the block reference.

In the Block Editor, the parameter looks like an alignment line.

An alignment parameter always applies to the entire block and needs no action
associated with it.

To add an alignment parameter to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Action Parameter panel  ➤  Alignment.

3 Follow the Command prompts to specify the parameter type.

4 Specify the base point of the alignment parameter.

This base point is the default location for the alignment parameter grip.

5 (Optional) Enter type at the Command prompt and follow the prompts
to specify whether the parameter type is perpendicular or tangent.

6 Specify the alignment direction.
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7 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

8 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BPARAMETER

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BSAVE

Saves the current block definition.

Add a Visibility Parameter
A visibility parameter controls the visibility of objects in the block.

You can create a block that has many different graphical representations. You
can easily change a block reference that has different visibility states without
having to find a different one to insert in your drawing.

For example, you have the following four different weld symbols.
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Using visibility states, you can combine these weld symbols into a single
dynamic block. The following example shows the geometry for the four weld
symbols combined in one dynamic block definition in the Block Editor.

After you combine the geometry in the Block Editor, you add a visibility
parameter. You add only one visibility parameter to a dynamic block definition.
You do not associate any actions with a visibility parameter.

You can then create and name a different visibility state for each weld symbol
(for example, WLD1, WLD2, WLD3, and WLD4). You can make particular
geometry visible or invisible for each state. In the following example, the
WLD1 visibility state is displayed in the Block Editor. The geometry that
displays in a dimmed state is invisible for the WLD1 visibility state.

The visibility parameter includes a lookup grip. This grip is always displayed
in a block reference that contains visibility states. When you click the grip in
the block reference, a drop-down list of all the visibility states in the block
reference is displayed. When you select one of the states from the list, the
geometry that is visible for that state is displayed in the drawing.
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The Block Editor contextual tab displays the name of the current visibility
state. All blocks have at least one visibility state. You cannot delete the current
state. This area of the tool bar also provides several tools for working with
visibility states.

When you work with visibility states, you may or may not want to see the
geometry that is invisible for a given state. You can use the Visibility Mode
button (BVMODE) to display or not display geometry (in a dimmed state) that
is invisible. When the BVMODE system variable is set to 1, geometry that is
invisible for a given state displays in a dimmed mode.

To add a visibility parameter to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤  Action Parameter panel  ➤  Visibility.

3 (Optional) Follow the Command prompts to specify the following for
the parameter:

■ Type

■ Label

■ Description

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you've added the parameter to the block definition.
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4 Specify a location for the parameter.

This is the location for the visibility parameter grip in the block reference.

5 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

6 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BPARAMETER

To create a new visibility state based on the current state

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Visibility panel ➤ Visibility States. 

3 In the Visibility States dialog box, click New.

4 In the New Visibility State dialog box, enter a name for the new visibility
state.

5 Click Leave Visibility of Existing Objects Unchanged in New State.

6 Click OK.

The visibility of existing objects is unchanged in the new state.

Command entry: BVSTATE

To create a new visibility state in which all objects are invisible

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Visibility panel ➤ Visibility States. 

3 In the Visibility States dialog box, click New.
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4 In the New Visibility State dialog box, enter a name for the new visibility
state.

5 Click Hide All Existing Objects in New State.

6 Click OK.

Command entry: BVSTATE

To create a new visibility state in which all objects are visible

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Visibility panel ➤ Visibility States. 

3 In the Visibility States dialog box, click New.

4 In the New Visibility State dialog box, enter a name for the new visibility
state.

5 Click Show All Existing Objects in New State.

6 Click OK.

Command entry: BVSTATE

To make a visibility state current

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Visibility panel ➤ Visibility States. 

3 Select the visibility state that you want to set as the current state.

Command entry: BVSTATE
Shortcut menu: In the Visibility States dialog box, right-click a visibility
state in the list. Click Set Current.
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To delete a visibility state

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Visibility panel ➤ Visibility States. 

3 In the Visibility States dialog box, select a visibility state from the list.

4 Click Delete.

5 Click OK.

Command entry: BVSTATE
Shortcut menu: In the Visibility States dialog box, right-click a visibility
state in the list. Click Delete State.

To rename a visibility state

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Visibility panel ➤ Visibility States. 

3 In the Visibility States dialog box, select a visibility state from the list.

4 Click Rename.

5 Enter a new name for the visibility state.

6 Click OK.

Command entry: BVSTATE
Shortcut menu: Right-click a visibility state in the list. Click Rename State.

To make objects visible in the current visibility state

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

954 | Chapter 18   Create and Use Blocks (Symbols)



2 Click Block Editor tab ➤ Visibility panel ➤ Make Visible. 

3 In the drawing area, select the objects to make visible in the current
visibility state. Press Enter.

4 At the Command prompt, enter current. Press Enter.

Command entry: BVSHOW
Shortcut menu: In the Block Editor drawing area, select one or more objects.
Right-click in the drawing area. Click Object Visibility  ➤ Show For Current
State.

To make objects visible in all visibility states

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor drawing area, select the objects that you want to make
visible in all visibility states.

3 Right-click in the drawing area.

4 Click Object Visibility  ➤ Show For All States.

Command entry: BVSHOW

To make objects invisible in the current visibility state

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Visibility panel ➤ Make Invisible. 

3 In the drawing area, select the objects that you want to make invisible
in the current visibility state. Press Enter.

4 At the Command prompt, enter current. Press Enter.

Command entry: BVHIDE
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Shortcut menu: In the Block Editor drawing area, select one or more objects.
Right-click in the drawing area. Click Object Visibility  ➤ Hide For Current
State.

To make objects invisible in all visibility states

1 In the drawing area, select the objects that you want to make invisible
in all visibility states.

2 Right-click in the drawing area.

3 Click Object Visibility  ➤ Hide For All States.

Command entry: BVHIDE

To display or not display invisible geometry for visibility states

■ Click Insert tab  ➤  Block panel  ➤  Block Editor. 

■ Click Block Editor tab ➤ Visibility panel ➤ Visibility Mode. 

To change the order of the visibility states list for a dynamic block reference

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Visibility panel ➤ Visibility States. 

3 In the Visibility States dialog box, select a visibility state in the list.

4 Click Move Up or Move Down to change the order.

5 Repeat steps 2 and 3 until the list of visibility states is in the correct order.

6 Click OK.

Command entry: BVSTATE
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To set the default visibility state for the dynamic block reference

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Visibility panel ➤ Visibility States. 

3 In the Visibility States dialog box, select a visibility state in the list.

4 Click Move Up until the selected visibility state is at the top of the list.

5 Click OK.

Command entry: BVSTATE

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BVHIDE

Makes objects invisible in the current visibility state or all visibility states in
a dynamic block definition.

BVSHOW

Makes objects visible in the current visibility state or all visibility states in a
dynamic block definition.

BVSTATE

Creates, sets, or deletes a visibility state in a dynamic block.

System Variables

BVMODE

Controls how objects that are made invisible for the current visibility state
are displayed in the Block Editor.
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Add a Lookup Parameter
A lookup parameter defines a custom property that you can specify or set to
evaluate a value from a list or table you define.

A lookup parameter can be associated with a single lookup grip. In the block
reference, you click the grip to display a list of available values.

In the Block Editor, a lookup parameter displays as text with an associated
grip.

You can associate a lookup parameter with a lookup action.

See also:

■ Add a Lookup Action on page 983

To add a lookup parameter to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Action Parameter panel  ➤  Lookup.

3 (Optional) Follow the Command prompts to specify the following for
the parameter:

■ Type

■ Label

■ Description

■ Properties displayed for block reference

NOTE You can also specify and edit these properties in the Properties palette
at a later time, after you've added the parameter to the block definition.

4 Specify a location for the parameter.

5 To add an action now, double-click the alert icon. Follow the prompts
to associate a lookup action with the parameter. This will display the
Property Lookup Table dialog box, which you can complete now or later.

6 Click OK.
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7 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

8 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BPARAMETER

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BSAVE

Saves the current block definition.

Add a Base Point Parameter
A base point parameter defines a base point for the dynamic block reference
relative to the geometry in the block.

In the Block Editor, a base point parameter displays as a circle with crosshairs.

A base point parameter cannot be associated with any actions, but can belong
to an action's selection set.

To add a base point parameter to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤  Action Parameter panel  ➤  Basepoint.

3 Specify a location for the parameter.
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4 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

5 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BPARAMETER

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

BSAVE

Saves the current block definition.

Add Actions to Dynamic Blocks
Actions define how the geometry of a dynamic block reference will move or
change when the custom properties of the block reference are manipulated
in a drawing.

Overview of Using Actions
Actions define how the geometry of a dynamic block reference will move or
change when the block reference is manipulated in a drawing.

In general, when you add an action to a dynamic block definition, you must
associate the action with a parameter, a key point on the parameter, and
geometry. A key point is the point on a parameter that drives its associated
action when edited. The geometry associated with an action is called the
selection set.
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In the following example, the dynamic block definition contains geometry
that represents a desk, a linear parameter with one grip specified for its
endpoint, and a stretch action associated with the endpoint of the parameter
and the geometry for the right side of the desk. The endpoint of the parameter
is the key point. The geometry on the right side of the desk is the selection
set.

When you want to change the block reference in a drawing, you move the
grip, and the desk stretches.

You can assign more than one action to the same parameter and geometry.

NOTE Do not assign two or more of the same type of actions to the same key
point on a parameter if both actions affect the same geometry. This can result in
unexpected behavior in the block reference.

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BACTION

Adds an action to a dynamic block definition.

BACTIONSET

Specifies the selection set of objects associated with an action in a dynamic
block definition.
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BASSOCIATE

Associates an action with a parameter in a dynamic block definition.

Add a Move Action
The move action is similar to the MOVE command.

In a dynamic block definition, you can associate a move action with any of
the following parameters:

■ Point on page 938

■ Linear on page 940

■ Polar on page 942

■ XY on page 944

After associating a move action with a parameter, you associate the action
with a selection set of geometry.

In a dynamic block reference, if you change the value of a parameter associated
with a move action through a grip or the Properties palette, it may affect the
key point on the parameter associated with the move action. If the key point
is affected, the geometry in the move action's selection set will move.

For example, in a dynamic block that represents a chair, the block contains a
point parameter and a move action associated with the point parameter. The
move action's selection set contains all the geometry in the block. When you
use the grip associated with the point parameter (or the Position X or Position
Y properties in the Properties palette) to manipulate the dynamic block
reference, it changes the value of the point parameter. This change in value
causes the chair to move.

In the following example, when the chair block reference is moved by dragging
the point parameter grip, the new position of this grip is reported in the
Properties palette.
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Specify the Distance Type Property for a Move Action

When a move action is associated with an XY parameter, the move action has
an override property called Distance Type. This property specifies whether the
distance applied to the move is the parameter's X value, Y value, or X and Y
coordinate value from the parameter's base point.

For example, you specify X Distance as the Distance Type for a move action
in a dynamic block definition. That means that the block can only be moved
on the X axis. So if you try to move the block on the Y axis, it doesn't move.

See also:

■ Add a Point Parameter on page 938

■ Add a Linear Parameter on page 940

■ Add a Polar Parameter on page 942

■ Add an XY Parameter on page 944

■ Use Distance Multiplier and Angle Offset Action Overrides on page 1017

To add a move action to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤ Action Parameters panel ➤  Move.

3 In the Block Editor drawing area, select one of the following parameters
to associate with the move action:

■ Point

■ Linear

■ Polar

■ XY

4 Select the objects (the selection set) to associate with the action. Press
Enter.

5 (Optional) Follow the Command prompts to specify a distance multiplier
and angle offset.

6 Specify the location of the action.
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NOTE The action location in the block definition has no effect on the
appearance or functionality of the block reference.

7 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

8 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BACTION

To specify the Distance Type property for a move action associated with an
XY parameter

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, select a move action.

3 On the Properties palette, Overrides area, Distance Type, select an option
from the list.

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BACTION

Adds an action to a dynamic block definition.

BACTIONSET

Specifies the selection set of objects associated with an action in a dynamic
block definition.

BASSOCIATE

Associates an action with a parameter in a dynamic block definition.
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PROPERTIES

Controls properties of existing objects.

Add a Scale Action
The scale action is similar to the SCALE command. In a dynamic block
reference, a scale action causes the block's selection set to scale when the
associated parameter is edited by moving grips or by using the Properties
palette.

In a dynamic block definition, you associate a scale action with an entire
parameter, not a key point on the parameter. You can associate a scale action
with any of the following parameters:

■ Linear on page 940

■ Polar on page 942

■ XY on page 944

After associating a scale action with a parameter, you associate the action with
a selection set of geometry.

Specify the Type of Base Point for a Scale Action

The scale action has a property called Base Type. With this property, you specify
whether the base point for the scale factor is dependent or independent.

If the base type is dependent, the objects in the selection set scale relative to
the base point of the parameter with which the scale action is associated. In
the following example, a scale action is associated with an XY parameter. The
scale action base type is dependent. The base point of the XY parameter is
located at the lower left corner of the rectangle. When the custom grip is used
to scale the block, it scales relative to the lower-left corner of the rectangle.

If the base type is independent (shown in the Block Editor as an X marker),
you specify a base point independent of the parameter with which the scale
action is associated. The objects in the selection set will scale relative to this
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independent base point you specify. In the following example, a scale action
is associated with an XY parameter. The scale action base type is independent.
The independent base point is located at the center of the circle. When the
custom grip is used to scale the block, it scales relative to the center of the
circle.

Specify the Scale Type Property for a Scale Action

When a scale action is associated with an XY parameter, the scale action has
an override property called Scale Type. This property specifies whether the
scale factor applied is the parameter's X distance, Y distance, or X and Y
coordinate value distance from the parameter's base point.

For example, you specify X Distance as the Scale Type for a scale action in a
dynamic block definition. In a drawing, when you edit the block reference by
dragging a grip on the XY parameter only along the Y axis, the associated
geometry does not scale.

See also:

■ Add a Linear Parameter on page 940

■ Add a Polar Parameter on page 942

■ Add an XY Parameter on page 944

To add a scale action to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab  ➤  Action Parameters panel  ➤  Scale.

3 In the Block Editor drawing area, select one of the following parameters
to associate with the action:

■ Linear
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■ Polar

■ XY

4 Select the geometry (the selection set) to associate with the action. Press
Enter.

5 (Optional) Follow the Command prompts to specify the type of base
point.

6 Specify the location of the action.

NOTE The action location in the block definition has no effect on the
appearance or functionality of the block reference.

7 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

8 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BACTION

To specify an independent base point for a scale action in a dynamic block
definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, select a scale action.

3 On the Properties palette, Overrides area, Base Type, select Independent
from the drop-down list.

To specify the Scale Type property for a scale action associated with an XY
parameter

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, select a scale action associated with an XY parameter.
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3 On the Properties palette, Overrides area, Scale Type, select an option
from the drop-down list.

Depending on the override you apply, the scale action for the block is
limited to the X axis, the Y axis, or both.

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BACTION

Adds an action to a dynamic block definition.

BACTIONSET

Specifies the selection set of objects associated with an action in a dynamic
block definition.

BASSOCIATE

Associates an action with a parameter in a dynamic block definition.

Add a Stretch Action
A stretch action causes objects to move and stretch a specified distance in a
specified location.

In a dynamic block definition, you can associate a stretch action with any of
the following parameters:

■ Point on page 938

■ Linear on page 940

■ Polar on page 942

■ XY on page 944

After associating a stretch action with a parameter, you specify a stretch frame
for the stretch action. You then select the objects for the stretch action's
selection set. The stretch frame determines how the objects within or crossed
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by the frame are edited in the block reference. The behavior is similar to
specifying a crossing selection window with the STRETCH command.

■ Objects entirely within the frame are moved.

■ Objects that cross the frame are stretched.

■ Objects within or crossed by the frame, but not included in the selection
set, are not stretched or moved.

■ Objects outside the frame and included in the selection set are moved.

In the following example, the stretch frame is indicated by the dashed line,
and the selection set has a haloed effect. The top circle, while enclosed by the
stretch frame, is not included in the selection set, so the top circle won't move.
The bottom circle is entirely enclosed in the stretch frame and included in
the selection set, so the bottom circle will move. The rectangle is crossed by
the stretch frame and included in the selection set, so the rectangle will stretch.

In a dynamic block reference, if you change the value of a parameter associated
with a stretch action through a grip or the Properties palette, it may affect the
key point on the parameter associated with the stretch action. If the key point
is affected, the geometry in the stretch action's selection set will move.

Specify the Distance Type Property for a Stretch Action

When a stretch action is associated with an XY parameter, the stretch action
has an override property called Distance Type. This property specifies whether
the distance applied to the move is the parameter's X value, Y value, or X an
Y coordinate value from the parameter's base point.

For example, you specify X Distance as the Distance Type for a stretch action
in a dynamic block definition. In a drawing, when you try to edit the block
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reference by dragging the key point only along the Y axis, the associated
geometry does not move because you've added the Distance Type override
allowing only a move on the X axis.

See also:

■ Add a Point Parameter on page 938

■ Add a Linear Parameter on page 940

■ Add a Polar Parameter on page 942

■ Add an XY Parameter on page 944

■ Use Distance Multiplier and Angle Offset Action Overrides on page 1017

To add a stretch action to a block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤  Action Parameters panel ➤  Stretch.

3 In the Block Editor drawing area, select one of the following parameters
to associate with the action:

■ Point

■ Linear

■ Polar

■ XY

NOTE If you associated the stretch action with a point parameter, then skip
the next step.

4 Select a parameter point to associate with the action.

5 Specify the first corner of the stretch frame.

6 Specify the opposite corner of the stretch frame.

7 Select the objects for the selection set. Press Enter.

8 (Optional) Follow the Command prompts to specify a distance multiplier
and angle offset.
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9 Specify the location of the action.

10 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

11 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BACTION

To specify the Distance Type property for a stretch action associated with an
XY parameter

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, select a stretch action associated with an XY
parameter.

3 On the Properties palette, Overrides area, Distance Type, select an option
from the drop-down list.

Depending on the override you apply, the stretch action for the block is limited
to the X axis, the Y axis, or both.

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BACTION

Adds an action to a dynamic block definition.

BACTIONSET

Specifies the selection set of objects associated with an action in a dynamic
block definition.
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BASSOCIATE

Associates an action with a parameter in a dynamic block definition.

Add a Polar Stretch Action
In a dynamic block definition, you can only associate a polar stretch action
with a polar parameter. The base point for the stretch part of the action is the
parameter point opposite the key point.

After associating a polar stretch action with a polar parameter on page 942,
you specify a stretch frame for the polar stretch action. You then select objects
to stretch and objects to rotate.

■ Objects entirely within the frame are moved.

■ Objects that cross the frame are stretched.

■ Objects in the action's selection set specified to rotate only are not
stretched.

■ Objects within the frame are moved linearly after they are rotated.

■ Objects crossed by the frame are stretched linearly after they are rotated.

■ Objects within or crossed by the frame, but not included in the selection
set, are not stretched or rotated.

■ Objects outside the frame and included in the selection set are moved.

In the following example, the stretch frame is indicated by the dashed line,
and the selection set has a haloed effect. The top circle, while enclosed by the
stretch frame, is not included in the selection set, so the top circle won't move.
The bottom circle is entirely enclosed in the stretch frame and included in
the stretch selection set, so the bottom circle will move. The rectangle is crossed
by the stretch frame and included in the selection set, so the rectangle will
stretch. The square is entirely enclosed in the stretch frame and included in
the rotate selection set, but not the stretch selection set, so the square will
rotate only.
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In a dynamic block reference, if you change the value of a parameter associated
with a polar stretch action through a grip or the Properties palette, it may
affect the key point on the parameter associated with the polar stretch action.
If the key point is affected, the geometry in the polar stretch action's selection
set will move or rotate depending on how the block was defined.

NOTE If you only want objects in the block reference to rotate, don't include any
objects in the stretch frame.

See also:

■ Add a Polar Parameter on page 942

■ Use Distance Multiplier and Angle Offset Action Overrides on page 1017

To add a polar stretch action to a block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, in the Block Authoring Palettes window, Actions tab,
click the Stretch Action tool.

3 In the Block Editor drawing area, select a polar parameter to associate
with the action. (You can associate only a polar parameter with a polar
stretch action.)

4 Select a parameter point to associate with the action.

5 Specify the first corner of the stretch frame.

Add Actions and Parameters to Dynamic Blocks | 973



6 Specify the opposite corner of the stretch frame.

7 Select the objects to stretch or move. Press Enter.

8 Select the objects that you want to rotate. Press Enter.

9 (Optional) Follow the Command prompts to specify distance and offset.

10 Specify the location of the action.

NOTE The action location in the block definition has no effect on the
appearance or functionality of the block reference.

11 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

12 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BACTION

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BACTION

Adds an action to a dynamic block definition.

BACTIONSET

Specifies the selection set of objects associated with an action in a dynamic
block definition.

BASSOCIATE

Associates an action with a parameter in a dynamic block definition.

974 | Chapter 18   Create and Use Blocks (Symbols)



Add a Rotate Action
The rotate action is similar to the ROTATE command.

In a dynamic block definition, you can associate a rotate action only with a
rotation parameter on page 945. The rotate action is associated with the entire
parameter, not a key point on the parameter.

After associating a rotate action with a rotation parameter, you associate the
action with a selection set of geometry.

Specify the Type of Base Point for a Rotate Action

The rotate action has a property called Base Type. With this property, you
specify whether the base point for the rotation is the base point of the
parameter or an independent base point that you specify in the block
definition.

By default, Base Type is set to Dependent. This means that the block rotates
around the associated rotation parameter's base point. In the following
example, the chair block contains a rotation parameter and an associated
rotate action. The rotate action's Base Type is Dependent. The base point of
the parameter is at the center of the chair. Thus, the chair rotates about the
center point.

When you set Base Type to Independent, you can specify a base point for the
rotate action other than the base point of the associated rotation parameter.
This independent base point is shown in the Block Editor as an X marker. The
location of the independent base point can be changed by dragging it or by
editing the Base X and Base Y values in the Overrides section of the Properties
palette.
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In the following example, the chair block contains a rotation parameter and
an associated rotate action. The rotate action's Base Type is Independent. The
independent base point is located at the lower left corner of the chair. Thus,
the chair rotates about the lower left corner.

In the following example, each of the three rectangles in the dynamic block
reference rotates about an independent base point located at the lower left
corner of each rectangle. To achieve this, you assign one rotation parameter.
You then add three rotate actions. Each rotate action is associated with the
rotate parameter. Each rotate action is then associated with a different object
and assigned a different independent base point.

You could achieve the same result by using dependent base points, each with
a different base offset, for each rotation action. However, if you need to move
the rectangles independently from one another (for example, with a polar or
XY parameter and a move action) in the block reference, you should use
independent base points for the rotate actions, or the objects won't rotate
correctly.

See also:

■ Add a Rotation Parameter on page 945

To add a rotate action to a block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 
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2 In the Block Editor, in the Block Authoring Palettes window, Actions tab,
click the Rotate Action tool.

3 In the Block Editor drawing area, select a rotation parameter to associate
with the action. (You can associate only a rotation parameter with a rotate
action.)

4 Select the objects (the selection set) to associate with the action. Press
Enter.

5 (Optional) Follow the Command prompts to specify the type of base
point.

6 Specify the location of the action.

7 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

8 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BACTION

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BACTION

Adds an action to a dynamic block definition.

BACTIONSET

Specifies the selection set of objects associated with an action in a dynamic
block definition.

BASSOCIATE

Associates an action with a parameter in a dynamic block definition.
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Add a Flip Action
In a dynamic block reference, a flip action causes its associated selection set
to flip about an axis called a reflection line when the associated parameter is
edited through a grip or the Properties palette.

In a dynamic block definition, you can associate a flip action only with a flip
parameter on page 946. The flip action is associated with the entire parameter,
not a key point on the parameter. After associating a flip action with a flip
parameter, you associate the action with a selection set of geometry. Only the
selected objects will flip about the reflection line.

For example, in the following illustration, the polyline between the two circles
is not included in the flip action's selection set. When the block reference is
flipped, the polyline does not flip with the rest of the geometry.

See also:

■ Add a Flip Parameter on page 946

To add a flip action to a block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, in the Block Authoring Palettes window, Actions tab,
click the Flip Action tool.

3 In the Block Editor drawing area, select a parameter to associate with the
action. (You can associate only a flip parameter with a flip action.)
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4 Select the objects (the selection set) to associate with the action. Press
Enter.

5 Specify the location of the action.

6 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

7 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BACTION

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BACTION

Adds an action to a dynamic block definition.

BACTIONSET

Specifies the selection set of objects associated with an action in a dynamic
block definition.

BASSOCIATE

Associates an action with a parameter in a dynamic block definition.

Add an Array Action
An array action causes its associated objects to copy and array in a rectangular
pattern.
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In a dynamic block definition, you can associate an array action with any of
the following parameters:

■ Linear on page 940

■ Polar on page 942

■ XY on page 944

After associating an array action with a parameter, you associate the action
with a selection set of geometry.

Specify Rows and Columns for an Array Action

When you associate an array action with a linear or polar parameter, you
specify the column offset for the arrayed objects. The column offset determines
the distance between the arrayed objects. When you edit the parameter in the
block reference, the distance of the parameter (from base point to second
point) is divided by the column offset to determine the number of columns
(the number of objects).

For example, you might associate an array action with a linear parameter. You
specify that the array action has a column offset of 2. When you change the
linear parameter in the dynamic block reference to a distance of 10, the number
of columns for the block reference is 5.

If you associate an array action with an XY parameter, you can also specify
the row offset.

Including Parameters in an Array Action's Selection Set

When you include a parameter in an array action's selection set, it has no
effect on the behavior of the block reference. The parameter is not copied
with the other objects in the selection set. Additional grips are not displayed
in the block reference.

In the following example, a parking lot block can be arrayed to contain any
number of spaces. The vertical line can also be rotated. Notice that even after
the block has been arrayed, it still contains only one rotation grip.

However, when you edit the grip for the parameter included in the array
action's selection set, the parameter's associated action is triggered for all
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instances of the objects. The same behavior occurs when the parameter is not
included in the array action's selection set.

Using Rotate and Array Actions in the Same Dynamic Block

A dynamic block can contain an array action and a rotate action that have
the same selection set. The order in which the block reference is arrayed and
rotated affects the display of the block.

When you rotate the block first and then array it, all instances of the arrayed
objects are individually rotated around their own base point.

When you array the block first and then rotate it, all instances of the arrayed
objects are rotated around a single base point.

See also:

■ Add a Linear Parameter on page 940

■ Add a Polar Parameter on page 942

■ Add an XY Parameter on page 944

To add an array action to a block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, in the Block Authoring Palettes window, Actions tab,
click the Array Action tool.

3 In the Block Editor drawing area, select a parameter to associate with the
action. (You can associate linear, polar, and XY parameters with an array
action.)
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4 Select the objects (the selection set) to associate with the action. Press
Enter.

5 If you are associating the array action with an XY parameter, do one of
the following:

■ Enter the distance between rows.

■ Specify a unit cell by entering two values separated by a comma or
by picking two opposite points of a rectangle in the drawing area, and
then go to step 7.

6 Enter a value for the distance between columns.

7 If you are assigning the array action to an XY parameter, enter the distance
between rows.

8 Specify the location of the action.

9 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

10 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BACTION

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BACTION

Adds an action to a dynamic block definition.

BACTIONSET

Specifies the selection set of objects associated with an action in a dynamic
block definition.

BASSOCIATE

Associates an action with a parameter in a dynamic block definition.
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Add a Lookup Action
A lookup action assigns custom properties and values to a dynamic block.

When you add a lookup action to a dynamic block definition and associate
it with a lookup parameter, it creates a lookup table. For information about
adding lookup tables to dynamic blocks, see Use Lookup Tables to Assign Data
to Dynamic Blocks on page 993.

To add a lookup action to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, in the Block Authoring Palettes window, Actions tab,
click the Lookup Action tool.

3 In the Block Editor drawing area, select one or more lookup parameters
to associate with the action. (You can associate only a lookup action with
lookup parameters.)

4 Specify the location of the action.

5 In the Property Lookup Table dialog box, complete the table as necessary.

6 Click OK.

7 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

8 If you are finished using the Block Editor, click Close Block Editor.

Toolbar: Standard  
Command entry: BACTION

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.
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BACTION

Adds an action to a dynamic block definition.

BACTIONSET

Specifies the selection set of objects associated with an action in a dynamic
block definition.

BASSOCIATE

Associates an action with a parameter in a dynamic block definition.

BLOOKUPTABLE

Displays or creates a lookup table for a dynamic block definition.

Use Parameter Sets
You add a parameter set to your block the same way you add a parameter. The
action included in the parameter set is automatically added to your block
definition and associated with the added parameter. You must then associate
a selection set (geometry) with each action.

When you first add a parameter set to your dynamic block definition, a yellow
alert icon is displayed next to each action. This indicates that you need to
associate a selection set with each action. You can double click the yellow
alert icon (or use the BACTIONSET command) and follow the Command
prompts to associate the action with a selection set.

NOTE When you insert a lookup parameter set and double click the yellow alert
icon, the Property Lookup Table dialog box is displayed. Lookup actions are
associated with the data you add to this table, not a selection set.

The following table lists the parameter sets provided on the Parameter Sets
tab of the Block Authoring palette.

DescriptionParameter
Set

Adds a point parameter with one grip and an associated move action to
the dynamic block definition.

Point
Move

Adds a linear parameter with one grip and an associated move action to
the dynamic block definition.

Linear
Move
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DescriptionParameter
Set

Adds a linear parameter with one grip and an associated stretch action
to the dynamic block definition.

Linear
Stretch

Adds a linear parameter with one grip and an associated array action to
the dynamic block definition.

Linear Ar-
ray

Adds a linear parameter with two grips and a move action associated with
each grip to the dynamic block definition.

Linear
Move Pair

Adds a linear parameter with two grips and a stretch action associated
with each grip to the dynamic block definition.

Linear
Stretch
Pair

Adds a polar parameter with one grip and an associated move action to
the dynamic block definition.

Polar
Move

Adds a polar parameter with one grip and an associated stretch action to
the dynamic block definition.

Polar
Stretch

Adds a polar parameter with one grip and an associated array action to
the dynamic block definition.

Polar Array

Adds a polar parameter with two grips and a move action associated with
each grip to the dynamic block definition.

Polar
Move Pair

Adds a polar parameter with two grips and a stretch action associated
with each grip to the dynamic block definition.

Polar
Stretch
Pair

Adds an XY parameter with one grip and an associated move action to
the dynamic block definition.

XY Move

Adds an XY parameter with two grips and move action associated with
each grip to the dynamic block definition.

XY Move
Pair

Adds an XY parameter with four grips and a move action associated with
each grip to the dynamic block definition.

XY Move
Box Set

Adds an XY parameter with four grips and a stretch action associated with
each grip to the dynamic block definition.

XY Stretch
Box Set
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DescriptionParameter
Set

Adds an XY parameter with four grips and an array action associated with
each grip to the dynamic block definition.

XY Array
Box Set

Adds a rotation parameter with one grip and an associated rotate action
to the dynamic block definition.

Rotation

Adds a flip parameter with one grip and an associated flip action to the
dynamic block definition.

Flip

Adds a visibility parameter with one grip. No action is required with a
visibility parameter.

Visibility

Adds a lookup parameter with one grip and a lookup action to the dynamic
block definition.

Lookup

See also:

■ Use Block Authoring Palettes on page 878

To add parameter set to a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, in the Block Authoring Palettes window, on the
Parameter Sets tab, click a parameter set.

3 Follow the Command prompts.

4 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

5 (Optional) If you are finished using the Block Editor, click Close Block
Editor.
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Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

Specify Grips for Dynamic Blocks
When you add a parameter to a dynamic block definition, custom grips
associated with key points of the parameter are automatically added to the
block.

All parameters (except the alignment parameter, which always displays one
grip) have a property called Number of Grips. When you select a parameter in
the Block Editor, the Number of Grips property is displayed in the Properties
palette. This property allows you to specify, from a preset list, the number of
grips you want to display for the parameter.

NOTE Parameters that are not associated with an action do not display grips.

If you specify that a parameter has 0 grips, you can still edit the dynamic block
reference through the Properties palette (if the block is defined that way).

If a dynamic block definition contains visibility states or a lookup table on
page 993, you can define the block so that the only grip that is displayed is a
lookup grip. When you click this grip on the block reference, a drop-down
list is displayed. When you select an item from the list, the display of the
block reference may change.

Grips are automatically added at key points on the parameter. You can
reposition a grip anywhere in the block space relative to its associated key
point on the parameter. When you reposition a grip, it is still tied to the key
point with which it is associated. No matter where the grip is shown in the
block reference, it will still manipulate the key point with which it is associated.
If you move or change the key point of the parameter, the grip's position
relative to the key point is maintained. Because you use grips to manipulate
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dynamic block references in a drawing, you should make sure that each grip
is placed in a logical location. If a grip is not in a logical place, the behavior
may not be what is expected.

NOTE Grips are not displayed for key points that are not associated with an action.

Both linear and polar parameters can display two, one, or no grips. When you
define a linear or polar parameter to display one grip, it is displayed at the
endpoint of the parameter. You should only assign actions to the endpoint
of either of these parameters if you plan to display only one grip. Otherwise,
you will not be able to manipulate the reference (trigger the actions) because
a grip won't be displayed for the key point associated with the action.

If you reposition the grips for a dynamic block, you can use the BGRIPSET
command to reset the grips to their default locations.

The type of parameter you add to the dynamic block definition determines
the type of grips that are added to the block. These grips give visual clues as
to how the block reference can be manipulated in a drawing. The following
table details the types of grips used in dynamic blocks, what they look like,
and the parameters with which they are associated.

Associated Paramet-
ers

How the Grip Can Be Manipu-
lated in a Drawing

Grip
Type

Base, Point, Polar, and
XY

Within a plane in any directionStand-
ard

LinearBack and forth in a defined direction
or along an axis

Linear

RotationAround an axisRota-
tion

FlipClick to flip the dynamic block refer-
ence

Flip

AlignmentWithin a plane in any direction; when
moved over an object, triggers the

Align-
ment

block reference to align with the object

Visibility, LookupClick to display a list of itemsLookup
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Specify Tooltips on Grips

Each of the dynamic block parameters has one or more description fields with
the exception of the basepoint and alignment parameters. These descriptions
function as tooltips or prompts for the associated parameter, and their display
is controlled by theGRIPTIPS system variable.

The following is a table of dynamic block parameters and available descriptions.

DescriptionParamet-
er

Position descriptionPoint

Distance descriptionLinear

Distance description, angle descriptionPolar

Horizontal distance description, vertical distance descrip-
tion

XY

Angle descriptionRotation

Flip descriptionFlip

Visibility descriptionVisibility

Lookup descriptionLookup

Set to “Aligns block to object”Align-
ment

No special tooltip is requiredBasepoint

Specify Insertion Cycling for Grips in Dynamic Blocks

Grips in dynamic blocks have a property called Cycling. When this property
is set to Yes, the grip becomes an available insertion point for the dynamic
block reference. You can use the BCYCLEORDER command to turn on and
off cycling for grips in dynamic blocks as well as specify the cycling order for
the grips. When you insert the dynamic block reference in a drawing, you can
use the Ctrl key to cycle through the available grips to select which grip will
be the insertion point for the block.
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To specify the number of custom grips displayed for a parameter in a dynamic
block

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, select a parameter.

3 On the Properties palette, under Misc, click Number of Grips, and then
select the number of grips you want to display for the parameter.

4 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

5 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Command entry: BGRIPSET
Shortcut menu: In the Block Editor, select a parameter. Right-click in the
drawing area. Click Grip Display  ➤ any value.

To reposition a grip in a dynamic block definition

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, select a custom grip (not the standard grip associated
with the key point of the parameter).

3 Do one of the following to reposition the grip:

■ Drag the grip to another position in the block space.

■ On the Properties palette, under Geometry, enter values for the Base
X and Base Y properties. (These values are relative to the base point
of the parameter.)

4 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

5 (Optional) If you are finished using the Block Editor, click Close Block
Editor.
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To reset grips in a dynamic block definition to their default locations

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, at the Command prompt, enter bgripset.

3 Select the grip for which you want to reset the grip position(s).

4 At the Command prompt, enter reposition.

5 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Shortcut menu: In the Block Editor, select a parameter. Right-click in the
drawing area. Click Grip Display  ➤ Reset Position.

To turn insertion cycling on or off for a custom grip in a dynamic block
reference

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, at the Command prompt, enter bcycleorder.

3 In the Insertion Cycling Order dialog box, select a grip from the list, and
click Cycling to turn cycling on or off for the grip. (A check mark in the
Cycling column indicates that cycling is turned on for the grip.)

4 Click OK.

5 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Shortcut menu: In the Block Editor, select a dynamic grip. Right-click in
the drawing area. Click Insertion Cycling.
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To modify the insertion cycling order for custom grips in a dynamic block
reference

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, enter bcycleorder at the Command prompt.

3 In the Insertion Cycling Order dialog box, select a grip from the list, and
click Move Up or Move Down. (A check mark in the Cycling column
indicates that cycling is turned on for the grip.)

4 Repeat step 2 until you are finished modifying the grip cycling order.

5 Click OK.

6 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

7 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BCYCLEORDER

Changes the cycling order of grips for a dynamic block reference.

BGRIPSET

Creates, deletes, or resets grips associated with a parameter.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

System Variables

GRIPTIPS

Controls the display of grip tips when the cursor hovers over grips on dynamic
blocks and custom objects that support grip tips.
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Use Lookup Tables to Assign Data to Dynamic Blocks
You can use a lookup table to define properties for and assign property values
to a dynamic block.

Overview of Using Lookup Tables to Assign Data to
Dynamic Blocks
You can use a lookup table to define properties for and assign property values
to a dynamic block. Using lookup tables is a powerful way to associate
parameter values for the dynamic block reference with other data that you
specify (for example, a model or part number). You can extract this data from
block references in a drawing just as you would extract block attribute data.

NOTE Constraint parameters cannot be added to a lookup table. Instead, you
should use a Block Properties Table. For more information, see Use a Block
Properties Table on page 876.

When completed, the lookup table assigns property values to the dynamic
block reference based on how it is manipulated in a drawing. Conversely, you
can change how the block reference is displayed in the drawing by changing
the value of a lookup property of the block reference through a lookup grip
or the Properties palette.

The following example shows a dynamic block reference for a lighting fixture.
For this block, the Custom area of the Properties palette displays a size property.
This property is defined in the lookup table for the block.

If you change the size of the lighting fixture in your drawing (using the custom
grips), the size property in the Properties palette changes accordingly.
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You can also use the lookup grip to change the display of the block reference.
When you select a size from the list that is displayed when you click the grip,
the block's geometry changes and the new size is displayed in the Properties
palette under Custom.

Create a Lookup Table

After you've drawn the geometry and added the appropriate parameters and
actions required for the dynamic block's functionality, you can add a lookup
table to the block definition.

A blank lookup table is created when you add a lookup parameter to a dynamic
block definition and then add a lookup action and associate it with the lookup
parameter. The lookup table is displayed in the lookup table dialog box.
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Add Properties and Values to a Lookup Table

The Property Lookup Table consists of input properties and lookup properties.
Each input property and lookup property is represented by a column in the
table.

■ Input properties. Parameters other than lookup parameters (for example,
a linear parameter labeled “Width”). You can create a column under Input
Properties for every parameter in the block definition except for lookup,
alignment, and base point parameters.

■ Lookup properties. Lookup parameters. You add one lookup parameter to
the dynamic block definition for every lookup property column you want
to add to the lookup table. The lookup parameter label is used as the
property name.

After you add the properties (columns) to the table, you add values to the cells
in each column. You click a cell and enter a value. Make sure to follow the
guidelines in Specify Values for Lookup Tables on page 1001.

If you defined a value set for an input property (parameter) in the table, a
drop-down list of available values will display when you click a cell in that
column.

The following lookup table is used for the lighting fixture block shown
previously. The linear parameters that have been labeled “Height” and “Width”
have been added as input properties. “Size” has been added as a lookup
property. The values under Height and Width are taken from the value sets
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defined for each of those parameters. The values under Size are entered
manually.

When the parameter values in a dynamic block reference match a row of input
property values, the corresponding lookup property values in that table row
are assigned to the block reference. These lookup properties and values are
displayed in the Properties palette under Custom.

For example, when you edit the lighting fixture block reference to have a
height of 250 centimeters and a width of 500 centimeters, the Size property
in the Custom area of the Properties palette will display a value of 0.25 m x
0.50 m.

In the lookup table, at the bottom of the input properties is a row labeled
<Unmatched>. When the parameter values in a block reference do not match
a row of input property values defined in the block's lookup table, the lookup
property value that corresponds to <Unmatched> is assigned to the block
reference. The default value is Custom, but you can specify another value by
changing it in the table.

Enable Reverse Lookup

You can also specify that a lookup property allows for reverse lookup. This
adds a lookup grip to the dynamic block reference. When you click this grip,
a drop-down list of the lookup values for that lookup property (column in the
table) is displayed. When you select a value from the list, the corresponding
input property values are assigned to the block reference. Depending on how
the block was defined, this usually results in a change in the block reference's
geometry.
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To enable reverse lookup for a lookup property, each row in the lookup table
must be unique. After you add properties and values to the table, you can
check for errors and empty cells by clicking the audit button in the Property
Lookup Table dialog box. You can also use the shortcut menu options to insert,
delete, or reorder rows.

NOTE If you leave a cell empty in the lookup properties column and the cell has
an associated input property in the same row, the lookup property will not allow
for reverse lookup.

See also:

■ Extract Data from Block Attributes on page 1034

■ Extract Block Attribute Data (Advanced) on page 1035

To create a lookup table for a dynamic block

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, add one or more lookup parameters to a dynamic
block definition by following the steps in To add a lookup parameter to
a dynamic block definition on page 958.

3 In the Block Editor, add a lookup action to a dynamic block definition
by following the steps in To add a lookup action to a dynamic block
definition on page 983.

The Property Lookup Table dialog box is displayed.
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4 Use any of the following procedures to set up a lookup table for the
dynamic block:

■ To add input properties to a lookup table on page 998

■ To add lookup properties to a lookup table on page 998

■ To enable reverse lookup on page 999

5 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

6 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: BPARAMETER

To add input properties to a lookup table

1 In the Block Editor, double-click a lookup action in a dynamic block
definition.

2 In the Property Lookup Table dialog box, click Add Properties.

3 In the Add Parameter Properties dialog box, in the bottom-left corner of
the dialog box, click Add Input Properties.

4 In the Parameter Properties list, select the parameter properties you want
to add to the lookup table. Hold Ctrl down to select more than one
property.

5 Click OK.

Command entry: BLOOKUPTABLE

To add lookup properties to a lookup table

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, double-click a lookup action in a dynamic block
definition.
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3 In the Property Lookup Table dialog box, click Add Properties.

4 In the Add Parameter Properties dialog box, in the bottom-left corner of
the dialog box, click Add Lookup Properties.

5 In the Parameter Properties list, select the lookup parameter properties
you want to add to the lookup table. Hold Ctrl down to select more than
one property.

6 Click OK.

Command entry: BLOOKUPTABLE

To add values to a lookup table

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, double-click a lookup action in a dynamic block
definition.

3 In the Property Lookup Table dialog box, click an empty cell and do one
of the following:

■ Select a value from the drop-down list. (A drop-down list only displays
if a value set has been defined for the parameter.)

■ Enter a value.

4 Repeat Step 2 as required to complete the table.

5 Click OK.

Command entry: BLOOKUPTABLE

To enable reverse lookup

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, double-click a lookup action in a dynamic block
definition.

3 In the Property Lookup Table dialog box, at the bottom of a Lookup
Property column, click Read Only, and then select Allow Reverse Lookup
from the list.
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NOTE You can only select Allow Reverse Lookup if you have entered data in
the column.

4 Click OK.

Command entry: BLOOKUPTABLE

To make the lookup property read-only

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, double-click a lookup action in a dynamic block
definition.

3 In the Property Lookup Table dialog box, at the bottom of a Lookup
Property column, click Allow Reverse Lookup, and then select Read Only
from the list.

4 Click OK.

Command entry: BLOOKUPTABLE

To check for errors in a lookup table

■ In the Property Lookup Table dialog box, click Audit.

To open an existing lookup table

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, double-click a lookup action.

Command entry: BLOOKUPTABLE

Quick Reference

Commands

BACTION

Adds an action to a dynamic block definition.
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BEDIT

Opens the block definition in the Block Editor.

BLOOKUPTABLE

Displays or creates a lookup table for a dynamic block definition.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

Specify Values for Lookup Tables
The following rules apply when you specify values in lookup tables:

■ Use a comma as the delimiter between values.

■ You can specify any number of unique values separated by commas. For
example: 5,6,7 5.5,6.25

■ To specify a range, use brackets [ ] to specify that the range includes the
values separated by a comma, or use parentheses ( ) to specify that the
range does not include the values separated by a comma.

■ For a continuous range, use a pair of values separated by a comma, enclosed
in brackets or parentheses. For example: [3,10] specifies any value between
3 and 10, including 3 and 10 (3,10) specifies any value between 3 and 10,
not including 3 and 10.

■ For an open-ended range, use one value with a comma, enclosed in brackets
or parentheses. For example: [,5] specifies less than or equal to 5; (5,)
specifies greater than 5.

■ Use no more than 256 characters in a table cell.

■ You can use architectural and mechanical unit syntax (for example,
15'1/4").

■ If you enter a value in an invalid format, the value will be reset to the last
value when you move to another cell in the table.

Lookup tables support the following:

■ All numeric parameter properties (for example, distance and angles for
point, linear, polar, XY, and rotation parameters)
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■ Text string parameter properties (for example, flip and visibility parameter
values)

Quick Reference

Commands

BLOOKUPTABLE

Displays or creates a lookup table for a dynamic block definition.

Create Construction Geometry Within a Block
You can convert objects to construction geometry in the Block Editor.

You can create construction geometry that will display within the Block Editor,
but not in the drawing editor.

In the example below, a symmetric constraint on page 913 has been added to
the block definition on the left. However, you may not want the line of
symmetry to be displayed when the block is inserted into your drawing. In
the example on the right, the line of symmetry has been converted to a dashed
line that will not display when the block is inserted into a drawing.

You can add construction geometry (BCONSTRUCTION command) to the
selection sets of legacy actions. The construction geometry is not affected by
the visibility states. It is filtered from the selection set in the BVSTATE
command when you add or remove geometry from a visibility state.

NOTE When you explode a block containing construction geometry in previous
versions of AutoCAD, the geometry is hidden in the drawing.

See also:

■ Draw Construction and Reference Geometry on page 840

■ Add a Symmetric Constraint on page 913
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To convert an object into construction geometry

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Geometric panel ➤ Construction Geometry.

3 Select the Convert option.

4 Select the geometry to convert into construction geometry. Press Enter.

Command entry: BCONSTRUCTION

To revert construction geometry back to a regular object

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Geometric panel ➤ Construction Geometry.

3 Select the Revert option.

4 Select the construction geometry to revert into regular geometry. Press
Enter.

Command entry: BCONSTRUCTION

To display all construction geometry in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Geometric panel ➤ Construction Geometry.

3 Select the Show All option.
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Command entry: BCONSTRUCTION

To hide all construction geometry in the Block Editor

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 Click Block Editor tab ➤ Geometric panel ➤ Construction Geometry.

3 Select the Hide All option.

Command entry: BCONSTRUCTION

Quick Reference

Commands

BCONSTRUCTION

Converts geometry into construction geometry.

BVSTATE

Creates, sets, or deletes a visibility state in a dynamic block.

System Variables

BLOCKTESTWINDOW

Indicates whether or not a test block window is current.

Specify Custom Properties for Dynamic Blocks
When you create a dynamic block, you can specify custom properties for the
block. You can also specify whether or not these properties appear in the
Properties palette when you select the block reference in a drawing.
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Overview of Specifying Custom Properties for Dynamic
Blocks
In the Block Editor, you can specify properties for a parameter in a dynamic
block definition. Some of these properties can be displayed as custom properties
for the dynamic block reference when it is in a drawing. These properties are
displayed under Custom in the Properties palette.

In the Block Editor, you can specify parameter labels. When you select the
dynamic block reference in a drawing, these properties are shown under
Custom in the Properties palette. It is good practice to specify unique parameter
labels within the block.

Depending on the parameters used in the dynamic block definition, other
parameter properties may be listed under Custom in the Properties palette
when you select the dynamic block reference in a drawing. For example, a
polar parameter has an angle property that displays in the Properties palette.
Depending on how the dynamic block is defined, these properties might
display values such as size, angle, and position for a selected block reference.

You can specify whether or not these custom properties are displayed for the
block reference when it is selected in a drawing. These properties can also be
extracted using the Attribute Extraction wizard.

You can also use the Properties palette to specify the geometric properties
(such as color, linetype, and lineweight) of a parameter. These properties are
listed in the Properties Palette under Geometry when you select a parameter
in the Block Editor.

Other parameter properties, such as Value Set properties and Chain Actions,
define how the block reference will function in a drawing.

In the Block Editor, you can also specify if the block can be exploded and if
the block can be non-uniformly scaled.

See also:

■ Define User Parameters in Dynamic Blocks on page 875

■ Specify Value Sets for Dynamic Blocks on page 1009

■ Allow Chained Actions for Dynamic Blocks on page 1014

■ Specify Grips for Dynamic Blocks on page 987

■ Extract Data from Block Attributes on page 1034
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To specify a parameter label

1 Ensure that the Properties palette is displayed. If not, click Tools
menu ➤ Palettes ➤ Properties.

2 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

3 In the Block Editor, select a parameter.

4 In the Properties palette, under Property Labels, click <parameter type>
label.

5 Enter a label for the parameter.

6 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

7 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: PROPERTIES

Shortcut menu: Right-click the selected object. Click Rename Label. Enter
a new name for the parameter, and press Enter.

To specify the display of custom properties in a dynamic block reference

1 Ensure that the Properties palette is displayed. If not, click Tools
menu ➤ Palettes ➤ Properties.

2 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

3 In the Block Editor, select a parameter.

4 In the Properties palette, under Misc., click Show Properties.

5 On the drop-down list, do one of the following:

■ Select Yes to display custom properties for the block reference.

■ Select No to specify that the custom properties will not display for a
block reference.
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6 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

7 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: PROPERTIES

To specify that dynamic block reference can be exploded

1 Use one of the following procedures to open a block definition in the
Block Editor:

■ To open an existing block definition in the Block Editor on page 869

■ To open a drawing file saved as a block (not dynamic) in the Block
Editor on page 871

■ To open a drawing file saved as a dynamic block in the Block Editor
on page 871

2 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

3 In the Block Editor, make sure nothing is selected.

4 In the Properties palette, under Block, click Allow Exploding.

5 On the drop-down list, select Yes or No.

6 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

7 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: BEDIT
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To prevent non-uniform scaling in dynamic block reference

1 Use one of the following procedures to open a block definition in the
Block Editor:

■ To open an existing block definition in the Block Editor on page 869

■ To open a drawing file saved as a block (not dynamic) in the Block
Editor on page 871

■ To open a drawing file saved as a dynamic block in the Block Editor
on page 871

2 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

3 In the Block Editor, make sure nothing is selected.

4 In the Properties palette, under Block, click Scale Uniformly.

5 On the drop-down list, select Yes.

6 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

7 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: BEDIT

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

PROPERTIES

Controls properties of existing objects.
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Specify Value Sets for Dynamic Blocks
A value set is a range or list of values specified for a parameter. These values
can be displayed for the block reference as a drop-down list next to the
parameter label under Custom in the Properties palette. When you define a
value set for a parameter, the parameter is limited to these values when the
block reference is manipulated in a drawing. For example, if you define a linear
parameter in a block that represents a window to have a value set of 20, 40,
and 60, the window can only be stretched to 20, 40, or 60 units.

When you create a value list for a parameter, the value of the parameter as it
exists in the definition is automatically added to the value set. This is the
default value for the block reference when you insert it in a drawing.

In a block reference, if you change the parameter's value to a value other than
one in the list, the parameter will adjust to the closest valid value. For example,
you define a linear parameter to have a value set of 2, 4, and 6. When you try
to change the value of that parameter in a block reference to 10, the resulting
parameter value is 6 because it is the closest valid value.

When you specify a value set for a parameter in a dynamic block, tick marks
are displayed when you grip-edit the block reference in a drawing. The tick
marks indicate the locations for the parameter's valid values.

NOTE If you redefine the values in a value set after you've added the parameter
properties to a lookup table, make sure to update the lookup table to match the
new values in the value set.

To specify a value set for a linear or polar parameter

1 Ensure that the Properties palette is displayed. If not, click Tools
menu ➤ Palettes ➤ Properties.

2 Click Insert tab  ➤  Block panel  ➤  Block Editor. 
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3 In the Block Editor, select a linear or polar parameter.

4 In the Properties palette, under Value Set, click Dist Type.

5 On the drop-down list, select List.

6 In the Properties palette, under Value Set, click Dist Value List.

7 Click the [...] button.

8 In the Add Distance Value dialog box, under Distances to Add, enter one
value or two or more values separated by commas.

9 Click Add.

10 Click OK.

11 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

12 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: PROPERTIES

To specify a value set for an XY parameter

1 Ensure that the Properties palette is displayed. If not, click Tools
menu ➤ Palettes ➤ Properties.

2 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

3 In the Block Editor, select an XY parameter.

4 In the Properties palette, under Value Set, click Hor Type or Ver Type.

5 On the drop-down list, select List.

6 In the Properties palette, under Value Set, click Hor Value List or Ver
Value List.

7 Click the [...] button.
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8 In the Add Distance Value dialog box, under Distances to Add, enter one
value or two or more values separated by commas.

9 Click Add.

10 Click OK.

11 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

12 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: PROPERTIES

To specify a value set for a rotation parameter

1 Ensure that the Properties palette is displayed. If not, click Tools
menu ➤ Palettes ➤ Properties.

2 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

3 In the Block Editor, select a rotation parameter.

4 In the Properties palette, under Value Set, click Ang Type.

5 On the drop-down list, select List.

6 In the Properties palette, under Value Set, click Ang Value List.

7 Click the [...] button.

8 In the Add Angle Value dialog box, under Angle to Add, enter one value
or two or more values separated by commas.

9 Click Add.

10 Click OK.

11 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 
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12 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: PROPERTIES

To delete values from a parameter's value set

1 Ensure that the Properties palette is displayed. If not, click Tools
menu ➤ Palettes ➤ Properties.

2 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

3 In the Block Editor, select a linear, polar, XY, or rotation parameter.

4 In the Properties palette, under Value Set, click one of the following:

■ Dist Value List

■ Ang Value List

■ Hor Value List

■ Ver Value List

5 Click the [...] button.

6 In the Add Distance Value or Add Angle Value dialog box, select a value
from the list to delete.

7 Click Delete.

8 Click OK.

9 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

10 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: PROPERTIES
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To specify an incremental value set for a linear, polar, XY, or rotation
parameter

1 Ensure that the Properties palette is displayed. If not, click Tools
menu ➤ Palettes ➤ Properties.

2 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

3 In the Block Editor, select a linear, polar, XY, or rotation parameter.

4 In the Properties palette, under Value Set, click Dist Type, Ang Type, Hor
Type, or Ver Type.

5 On the drop-down list, select Increment.

6 In the Properties palette, under Value Set, click Dist Increment, Ang
Increment, Hor Increment, or Ver Increment, and then enter an
incremental value for the parameter.

7 Click Dist Minimum, Ang Minimum, Hor Minimum, or Ver Minimum,
and then enter a minimum value for the parameter.

8 Click Dist Maximum, Ang Maximum, Hor Maximum, or Ver Maximum,
and then enter a maximum value for the parameter.

9 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

10 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: PROPERTIES

To specify minimum and maximum values for a linear, polar, XY, or rotation
parameter

1 Ensure that the Properties palette is displayed. If not, click Tools
menu ➤ Palettes ➤ Properties.

2 Click Insert tab  ➤  Block panel  ➤  Block Editor. 
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3 In the Block Editor, select a linear, polar, XY, or rotation parameter.

4 In the Properties palette, under Value Set, click Dist Minimum, Ang
Minimum, Hor Minimum, or Ver Minimum, and then enter a minimum
value for the parameter.

5 Click Dist Maximum, Ang Maximum, Hor Maximum, or Ver Maximum,
and then enter a maximum value for the parameter.

6 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

7 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: PROPERTIES

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

PROPERTIES

Controls properties of existing objects.

Allow Chained Actions for Dynamic Blocks
Point, linear, polar, XY, and rotation parameters have a property called Chain
Actions. This property affects the parameter behavior if the parameter is part
of an action's selection set.

For example, you might include a point parameter in the selection set of a
stretch action that is associated with a linear parameter. When the linear
parameter is edited in a block reference, its associated stretch action triggers
a change in its selection set. Because the point parameter is included in the
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selection set, the point parameter is edited by the change in the linear
parameter.

The following example shows a block definition in the Block Editor. The point
parameter (labeled Position) is included in the stretch action's selection set.

If the Chain Actions property for the point parameter is set to Yes, a change
in the linear parameter will trigger the move action associated with the point
parameter, just as if you edited the point parameter in the block reference
through a grip or custom property.

If the Chain Actions property is set to No, the point parameter's associated
move action is not triggered by the changes to the linear parameter. Thus, the
circle doesn't move.
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To specify the Chain Actions property for a point, linear, polar, XY, or rotation
parameter

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, click Tools menu  ➤ Properties. The Properties palette
is displayed.

3 In the Block Editor, select a point, linear, polar, XY, or rotation parameter.

4 In the Properties palette, under Misc, click Chain Actions.

5 On the drop-down list, select Yes or No.

6 Click Block Editor tab  ➤  Open/Save panel  ➤  Save Block. 

7 (Optional) If you are finished using the Block Editor, click Close Block
Editor.

Toolbar: Standard  
Command entry: PROPERTIES

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

BPARAMETER

Adds a parameter with grips to a dynamic block definition.

PROPERTIES

Controls properties of existing objects.
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Use Distance Multiplier and Angle Offset Action
Overrides
Action overrides are properties of actions that have no effect on the block
reference until it is manipulated in a drawing. Use distance multiplier overrides
with the following actions:

■ Move on page 962

■ Stretch on page 968

■ Polar Stretch on page 972

You can specify these action override properties by following the Command
prompts when you add an action to a dynamic block definition. You can also
specify these properties in the Properties palette when you select an action in
the Block Editor.

Distance Multiplier Overrides

Use the distance multiplier property to change a parameter value by a specified
factor. For example, if you set the distance multiplier property to 2 for a stretch
action, the associated geometry in the block reference would increase and
double the distance of the grip movement.

Angle Offset Overrides

Use the angle offset property to increase or decrease the angle of a changed
parameter value by a specified amount. For example, if you set the angle offset
property of a move action to 90, the block reference would move 90 degrees
beyond the angle value of the grip movement.

See also:

■ Add a Move Action on page 962

■ Add a Stretch Action on page 968

■ Add a Polar Stretch Action on page 972

To specify a distance multiplier override for an action

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 
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2 In the Block Editor, select a move, stretch, polar stretch, or array action.

3 On the Properties palette, Overrides area, Distance Multiplier, enter a
value. Press Enter.

To specify an angle offset override for an action

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 

2 In the Block Editor, select a move, stretch, or polar stretch action.

3 On the Properties palette, Overrides area, Angle Offset, enter a value.
Press Enter.

Quick Reference

Commands

BACTION

Adds an action to a dynamic block definition.

BEDIT

Opens the block definition in the Block Editor.

PROPERTIES

Controls properties of existing objects.

Insert Blocks
When you insert a block, you create a block reference and specify its location,
scale, and rotation.

You can specify the scale of a block reference using different X, Y, and Z values.
Inserting a block creates an object called a block reference because it references
a block definition stored in your current drawing. An orange lightning bolt
icon displayed in the bottom-right corner of the block preview indicates that
the block is dynamic.
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If you insert a block that uses different drawing units than the units specified
for the drawing, the block is automatically scaled by a factor equivalent to
the ratio between the two units.

If you insert a block reference that includes editable custom properties or
attributes, you can change the values of these custom properties and attributes
in the Properties palette while you insert the block. The block’s custom
properties and attributes become editable in the Properties palette after the
block is specified in one of the following ways:

■ In the Insert dialog box after clicking OK.

■ Using the -INSERT command after entering the block name.

■ Clicking a block tool on a tool palette.

Insert a Drawing File as a Block

When you insert an entire drawing file into another drawing, the drawing
information is copied into the block table of the current drawing as a block
definition. Subsequent insertions reference the block definition with different
position, scale, and rotation settings, as shown in the following illustration.

Xrefs contained in a drawing you insert may not be displayed properly unless
the xref was previously inserted or attached to the destination drawing.
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Insert Blocks from Tool Palettes

You can insert blocks from tool palettes by dragging the block tool into the
drawing or by clicking the block tool and then specifying an insertion point.

You can choose to be prompted for a rotation angle (starting from 0) when
you click and place the block. When you select this option, the angle that is
specified under Rotation in the Tool Properties dialog box is ignored. The
prompt for a rotation angle is not shown if you drag the block or xref or, if at
the initial insertion Command prompt, you enter rotate.

Blocks that are placed by dragging from a tool palette must often be rotated
or scaled after they are placed. You can use object snaps when dragging blocks
from a tool palette; however, grid snap is suppressed during dragging.

When a block is dragged from a tool palette into a drawing, it is scaled
automatically according to the ratio of units defined in the block and defined
in the current drawing. For example, if the current drawing uses meters as its
units and a block is defined using centimeters as its units, the ratio of the
units is 1 m/100 cm. When the block is dragged into the drawing, it is inserted
at 1/100 scale.

NOTE In the Options dialog box, User Preferences tab, the Source Content Units
and Target Drawing Units settings are used when Drag-and-Drop Scale is set to
Unitless, either in the source block or target drawing.

Insert Blocks from Block Libraries

You can insert one or more block definitions from an existing drawing file
into your current drawing file. Choose this method when retrieving blocks
from block library drawings. A block library drawing contains block definitions
of symbols with similar functions. These block definitions are stored together
in a single drawing file for easy accessibility and management.

Insert Blocks with DesignCenter

Use DesignCenter to insert blocks from the current drawing or from another
drawing. Drag and drop the block names for quick placement. Double-click
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the block names to specify the precise location, rotation, and scale of the
blocks.

You cannot add blocks to a drawing while another command is active, and
you can only insert or attach one block at a time.

Insert Blocks at Intervals

You can insert blocks at intervals along a selected geometric object.

■ Use MEASURE to insert a block at measured intervals.

■ Use DIVIDE to insert a block at proportional (evenly spaced) intervals.

See also:

■ Create Drawing Files for Use as Blocks on page 858

■ Overview of Blocks on page 853

■ Create Block Libraries on page 864

■ Work with Dynamic Blocks in Drawings on page 1023

■ Add Text and Blocks to Tables on page 1606

■ Add Content with DesignCenter on page 96

■ Create and Use Tools from Objects and Images on page 56

To insert a block defined in the current drawing

1 Click Home tab ➤ Block panel ➤ Insert. 

2 In the Insert dialog box, in the Name box, select a name from a list of
block definitions.

3 If you want to use the pointing device to specify the insertion point,
scale, and rotation, select Specify On-Screen. Otherwise, enter values in
the Insertion Point, Scale, and Rotation boxes.

4 If you want the objects in the block to be inserted as individual objects
instead of as a single block, select Explode.

5 Click OK.
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Toolbar: Insert  
Command entry: INSERT

To insert a drawing file as a block by dragging

1 From Windows Explorer or any folder, drag the drawing file icon into
the drawing area.

When you release the button, you are prompted for an insertion point.

2 Specify the insertion point and scale and rotation values.

To insert a block using DesignCenter

1 If DesignCenter is not already open, click Tools menu  ➤ Palettes  ➤ 

DesignCenter.

2 Do one of the following to list the content you want to insert:

■ On the DesignCenter toolbar, click Tree View Toggle. Click the folder
that contains the drawing you want to insert.

■ Click the icon of a drawing file displayed in the tree view.

3 Do one of the following to insert the content:

■ Drag the drawing file or block into your current drawing. Use this
option when you want to insert blocks quickly and move or rotate
the blocks to their precise locations later.

■ Double-click the drawing file or block that you want to insert into
your current drawing. Use this option when you want to specify the
exact placement, rotation, and scale of the block as you insert it. Use
this option also when you want to update a block reference in your
drawing from the original source drawing file.

Toolbar: Standard  
Command entry: ADCENTER
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Quick Reference

Commands

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.

DIVIDE

Creates evenly spaced point objects or blocks along the length or perimeter
of an object.

INSERT

Inserts a block or drawing into the current drawing.

MEASURE

Creates point objects or blocks at measured intervals along the length or
perimeter of an object.

System Variables

ATTDIA

Controls whether the INSERT command uses a dialog box for attribute value
entry.

INSNAME

Sets a default block name for the INSERT command.

INSUNITS

Specifies a drawing-units value for automatic scaling of blocks, images, or
xrefs when inserted or attached to a drawing.

INSUNITSDEFSOURCE

Sets source content units value when INSUNITS is set to 0.

INSUNITSDEFTARGET

Sets target drawing units value when INSUNITS is set to 0.

Work with Dynamic Blocks in Drawings
A dynamic block has flexibility and intelligence. A dynamic block reference
can easily be changed in a drawing while you work. You can manipulate the
geometry through custom grips or custom properties. This allows you to adjust
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the block reference in-place as necessary rather than searching for another
block to insert or redefining the existing one.

For example, if you insert a door block reference in a drawing, you might need
to change the size of the door while you're editing the drawing. If the block
is dynamic and defined to have an adjustable size, you can change the size of
the door simply by dragging the custom grip or by specifying a different size
in Properties palette. You might also need to change the open angle of the
door. The door block might also contain an alignment grip, which allows you
to align the door block reference easily to other geometry in the drawing.

Hovering over a grip can also display a tooltip or prompt that explains the
parameter related to the grip. The display of the tooltip is controlled by
theGRIPTIPS system variable.

A dynamic block can have custom grips and custom properties. Depending
on how the block was defined, you may be able to manipulate the block
through these custom grips and custom properties. By default, custom grips
for a dynamic block are a different color than standard grips. You can change
the display color for custom grips with theGRIPDYNCOLOR system variable.
The following table shows the different types of custom grips that can be
included in a dynamic block.

How the Grip Can Be Manipulated in a DrawingGrip Type

Within a plane in any directionStandard
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How the Grip Can Be Manipulated in a DrawingGrip Type

Back and forth in a defined direction or along an axisLinear

Around an axisRotation

Clicked to flip the dynamic block referenceFlip

Within a plane in any direction; when moved over an
object, triggers the block reference to align with the ob-
ject

Alignment

Clicked to display a list of itemsLookup

After you've manipulated a dynamic block in a drawing, you can reset it. When
you reset a block reference, the block changes back to the default specified in
the block definition. If you non-uniformly scale or explode a dynamic block
reference, it loses its dynamic properties. You can reset the block to its default
values, which will make it dynamic again.

Some dynamic blocks are defined so that geometry within the block can only
be edited to certain sizes specified in the block definition. When you use a
grip to edit the block reference, tick marks are displayed at the locations of
valid values for the block reference. If you change a block property value to
a value other than one specified in the definition, the parameter will adjust
to the closest valid value. For example, a block is defined to have a length of
2, 4, and 6. When you try to change that distance value to 10, the resulting
value is 6 because it is the closest valid value.

To manipulate a dynamic block using custom grips

1 In a drawing, select a dynamic block reference.

2 Use the grips to stretch or change the block.

To manipulate a dynamic block using custom properties

1 In a drawing, select a dynamic block reference.

2 In the Properties palette, under Custom, change the required values.
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To reset block references in a drawing

1 In a drawing, select a dynamic block reference.

2 Right-click in the drawing area. Click Reset Block.

NOTE To reset more than one block reference at a time, use the RESETBLOCK
command.

Command entry: RESETBLOCK

To change the display color for custom grips

1 At the Command prompt, enter gripdyncolor.

2 Enter an integer from 1 to 255 (ACI color). Press Enter.

Quick Reference

Commands

ATTSYNC

Updates block references with new and changed attributes from a specified
block definition.

INSERT

Inserts a block or drawing into the current drawing.

PROPERTIES

Controls properties of existing objects.

RESETBLOCK

Resets one or more dynamic block references to the default values of the
block definition.

System Variables

BTMARKDISPLAY

Controls whether or not value set markers are displayed for dynamic block
references.

GRIPDYNCOLOR

Controls the color of custom grips for dynamic blocks.
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GRIPTIPS

Controls the display of grip tips when the cursor hovers over grips on dynamic
blocks and custom objects that support grip tips.

Attach Data to Blocks (Block Attributes)
You can attach information to blocks and later extract the information to
create a bill of materials or other report.

Overview of Block Attributes
An attribute is a label or tag that attaches data to a block. Examples of data
that might be contained in an attribute are part numbers, prices, comments,
and owners' names. The tag is equivalent to a column name in a database
table. The following illustration shows a block with four attributes: type,
manufacturer, model, and cost.

The attributes in the illustration are single-line attributes. You can also create
multiple-line attributes to store data such as addresses and descriptions.

Attribute information extracted from a drawing can be used in a spreadsheet
or database to produce a parts list or a bill of materials. You can associate more
than one attribute with a block, provided that each attribute has a different
tag.

Attributes also can be "invisible." An invisible attribute is not displayed or
plotted; however, the attribute information is stored in the drawing file and
can be written to an extraction file for use in a database program.
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Whenever you insert a block that has a variable attribute, you are prompted
to enter data to be stored with the block. Blocks can also use constant
attributes, attributes whose values do not change. Constant attributes do not
prompt you for a value when you insert the block.

You can also create attributes. For more information about creating and
working with an annotative attributes, see Create Annotative Blocks and
Attributes on page 1417.

See also:

■ Modify a Block Attribute Definition on page 1049

■ Modify the Data in Block Attributes on page 1047

■ Scale Annotations on page 1393

Quick Reference

Commands

ATTDEF

Creates an attribute definition for storing data in a block.

ATTDISP

Controls the visibility overrides for all block attributes in a drawing.

ATTEDIT

Changes attribute information in a block.

ATTIPEDIT

Changes the textual content of an attribute within a block.

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

PROPERTIES

Controls properties of existing objects.
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System Variables

AFLAGS

Sets options for attributes.

ATTDIA

Controls whether the INSERT command uses a dialog box for attribute value
entry.

ATTIPE

Controls the display of the in-place editor used to create multiline attributes.

ATTMODE

Controls display of attributes.

ATTMULTI

Controls whether multiline attributes can be created.

ATTREQ

Controls whether INSERT uses default attribute settings during insertion of
blocks.

Define Block Attributes
The characteristics include the tag, which is a name that identifies the attribute,
the prompt displayed when you insert the block, value information, text
formatting, location within the block, and any optional modes (Invisible,
Constant, Verify, Preset, Lock Position, and Multiple Lines).

If you plan to extract the attribute information for use in a parts list, you may
want to keep a list of the attribute tags you have created. You will need this
tag information later when you create the attribute template file.

Choose Attribute Modes

Attribute modes control the behavior of attributes in blocks. For example, you
can control

■ Whether an attribute is visible or invisible in the drawing

■ Whether an attribute has a constant value, such as a part number

■ Whether the attribute can be moved relative to the rest of the block
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■ Whether the attribute is a single-line attribute or a multiple-line attribute

If an attribute has a constant value, you will not be prompted for its value
when you insert the block. If an attribute has a variable value, such as the
asset number of a computer, you will be prompted when you insert the block.

Understand Single-Line and Multiple-Line Attributes

There are several differences between single-line and multiple-line attributes.

■ Single-line attributes are limited to 255 characters from the user interface.

■ Multiple-line attributes provide more formatting options than single-line
attributes.

■ When editing single-line and multiple line attributes, different editors are
displayed.

■ Multiple line attributes display four grips similar to MTEXT objects, while
single-line attributes display only one grip.

■ When a drawing is saved to AutoCAD 2007 or earlier, a multiple-line
attribute is converted to several single-line attributes, one for every line of
text in the original multiple-line attribute. If the drawing file is opened in
the current release, these single line attributes are automatically merged
back into a multiple-line attribute.

NOTE If a multiple-line attribute makes a round trip to an earlier release of
AutoCAD, the differences between these two types of attributes might result in
truncating very long lines of text and loss of formatting. However, before any
characters are truncated, AutoCAD displays a dialog box that lets you cancel the
operation.

Correct Mistakes in Block Attribute Definitions

If you make a mistake, you can use the Properties palette or DDEDIT to make
limited changes to an attribute definition before it is associated with a block.
If you need to make more extensive changes, delete the attribute definition
and create a new one.

Attach Attributes to Blocks

After you create one or more attribute definitions, you attach the attributes
to a block when you define or redefine that block. When you are prompted
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to select the objects to include in the block definition, include in the selection
set any attributes you want to attach to the block.

To use several attributes together, define them and then include them in the
same block. For example, you can define attributes tagged "Type,"
"Manufacturer," “Model,” and “Cost,” and then include them in a block called
CHAIR.

Usually, the order of the attribute prompts is the same as the order in which
you selected the attributes when you created the block. However, if you used
crossing or window selection to select the attributes, the order of the prompts
is the reverse of the order in which you created attributes. You can use the
Block Attribute Manager to change the order in which you are prompted for
attribute information when you insert the block reference.

When you open a block definition in the Block Editor, you can use the
Attribute Order dialog box to change the order in which you are prompted
for attribute information when you insert the block reference.

Use Attributes Without Attaching Them to Blocks

Stand-alone attributes can also be created. Once attributes have been defined,
and the drawing is saved, this drawing file can be inserted into another
drawing. When the drawing is inserted, you are prompted for the attribute
values.

To create an attribute definition

1 Click Home tab ➤ Block panel ➤ Define Attributes. 

2 In the Attribute Definition dialog box, set the attribute modes and enter
tag information, location, and text options.

3 Click OK.

After creating the attribute definition, you can select it as an object while
creating a block definition. If the attribute definition is incorporated into
a block, whenever you insert the block, you are prompted with the text
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string you specified for the attribute. Each subsequent instance of the
block can have a different value specified for the attribute.

Command entry: ATTDEF

To create a multiline attribute definition

1 Click Home tab ➤ Block panel ➤ Define Attributes. 

2 In the Attribute Definition dialog box, under Mode, select Multiple Lines.

3 Enter tag information, location, and text options.

4 (Optional) Under Text Settings, Boundary Width, specify a value.

5 (Optional) Click the Multiline In-Place Text Editor button to use the
in-place text editor to format the attribute in the drawing.

6 Click OK.

After creating the attribute definition, you can select it as an object while
creating a block definition. If the attribute definition is incorporated into
a block, whenever you insert the block, you are prompted with the text
string you specified for the attribute. Each subsequent instance of the
block can have a different value specified for the attribute.

Command entry: ATTDEF

To edit an attribute definition before it is associated with a block

1 Click Modify menu  ➤ Object  ➤ Text.

2 Select the attribute to edit.

3 In the Edit Attribute Definition dialog box, specify the attribute tag,
prompt, and default value. Then click OK.

Command entry: DDEDIT

To change the prompt order of attribute definitions

1 Click Insert tab  ➤  Block panel  ➤  Block Editor. 
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2 In the Block Editor, select a block attribute.

3 Right-click in the Block Editor drawing area.

4 Click Attribute Order.

5 In the Attribute Order dialog box, select an attribute definition.

6 Click Move Up or Move Down to change the prompt order of the attribute
definitions.

7 Repeat steps 2 and 3 until the attribute definition list is in the desired
order.

8 Click OK.

Command entry: BEDIT  ➤ BATTORDER

Quick Reference

Commands

ATTDEF

Creates an attribute definition for storing data in a block.

ATTDISP

Controls the visibility overrides for all block attributes in a drawing.

BATTORDER

Specifies the order of attributes for a block.

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

PROPERTIES

Controls properties of existing objects.

System Variables

AFLAGS

Sets options for attributes.
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ATTIPE

Controls the display of the in-place editor used to create multiline attributes.

ATTMULTI

Controls whether multiline attributes can be created.

Extract Data from Block Attributes
Extracting attribute information is an easy way to produce a schedule or bill
of materials directly from your drawing data. For example, a facilities drawing
might contain blocks representing office equipment. If each block has attributes
identifying the model and manufacturer of the equipment, you can generate
a report that estimates the cost of the equipment.

The Data Extraction wizard guides you through selecting drawings, block
instances, and attributes. The wizard can also create a file with a .dxe file
extension that contains all the settings for later reuse.

Output to a Table

If you extract attribute data to a table, the table is inserted in the current
drawing and current space (model space or paper space) and on the current
layer.

When you update the table, the attribute information is extracted again and
the data rows in the table are replaced. If you have included a title row or one
or more header rows in the table, they are not replaced during the update.

NOTE For access to shortcut menus in the drawing area that are needed for editing
and updating tables, the Shortcut Menus in Drawing Area must be checked in the
Options dialog box, User Preferences tab.

Output to a File

If you save the data to an external file, the comma-separated (CSV),
tab-separated (TXT), Microsoft Excel (XLS), and Microsoft Access (MDB) file
formats are available.

When the characters period (.), comma (,), or pound sign (#) are written to
an Excel or Access file, they are replaced with their Unicode representation.

See also:

■ Extract Data from Drawings and Spreadsheets
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To extract block attributes to a table or a file

■ Click Tools menu  ➤ Data Extraction.
The Data Extraction Wizard is displayed. The wizard provides step-by-step
instructions for extracting information from block attributes in the current
drawing or other drawings. The information is used to create a table in the
current drawing or is saved to an external file.

The Data Extraction wizard topic describes the options in the wizard.

Toolbar: Modify II  
Command entry: DATAEXTRACTION

To update extracted attribute data in a table

■ When the Outdated Table dialog box is displayed as you open or save a
drawing, click Update.

To turn off update notification for extracted attribute data in tables

1 At the Command prompt, enter dxeval.

2 Enter 0.

Quick Reference

Commands

DATAEXTRACTION

Extracts drawing data and merges data from an external source to a data
extraction table or external file.

System Variables

DXEVAL

Controls when update notification displays for data extraction tables.

Extract Block Attribute Data (Advanced)
You can extract attribute information from a drawing and create a separate
text file for use with database software. This feature is useful for creating parts
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lists with information already entered in the drawing database. Extracting
attribute information does not affect the drawing.

To create a parts list

■ Create and edit an attribute definition

■ Enter values for the attributes as you insert the blocks

■ Create a template file and then extract attribute information to a text file

To extract attribute information, you first create an attribute template file
using any text processor, then generate the attribute extraction file using
AutoCAD, and, finally, open the attribute extraction file in a database
application. If you plan to extract the attribute information to a DXF (drawing
interchange format) file, it is not necessary to first create an attribute template
file.

NOTE Make sure that the attribute extraction file does not have the same name
as the attribute template file.

Create an Attribute Extraction Template File

Before you extract attribute information, you must create an ASCII template
file to define the structure of the file that will contain the extracted attribute
information. The template file contains information about the tag name, data
type, field length, and number of decimal places associated with the
information you want to extract.

Each field in the template file extracts information from the block references
in the drawing. Each line in the template file specifies one field to be written
to the attribute extraction file, including the name of the field, its character
width, and its numerical precision. Each record in the attribute extraction file
includes all the specified fields in the order given by the template file.

The following template file includes the 15 possible fields. N means numeric,
C means character, www means a 3 digit number for the total width of the
field, and ddd means a 3 digit number representing how many numeric decimal
places are to be displayed to the right of the decimal point.

BL:NAME Cwww000 (Block name)
BL:LEVEL Nwww000 (Block nesting level)
BL:X Nwwwddd(X coordinate of block insertion point)
BL:Y Nwwwddd(Y coordinate of block insertion point)
BL:Z Nwwwddd(Z coordinate of block insertion point)
BL:NUMBER Nwww000 (Block counter; the same for MINSERT)
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BL:HANDLE Cwww000 (Block handle; the same for MINSERT)
BL:LAYER Cwww000 (Block insertion layer name)
BL:ORIENT Nwwwddd(Block rotation angle)
BL:XSCALE Nwwwddd(X scale factor)
BL:YSCALE Nwwwddd(Y scale factor)
BL:ZSCALE Nwwwddd(Z scale factor)
BL:XEXTRUDE Nwwwddd(X component of block extrusion direction)
BL:YEXTRUDE Nwwwddd(Y component of block extrusion direction)
BL:ZEXTRUDE Nwwwddd(Z component of block extrusion direction)
numericNwwwddd (Numeric attribute tag)
characterCwww000 (Character attribute tag)

The template file can include any or all of the BL:xxxxxxx field names listed,
but must include at least one attribute tag field. The attribute tag fields
determine which attributes, hence which blocks, are included in the attribute
extraction file. If a block contains some, but not all, of the specified attributes,
the values for the absent ones are filled with blanks or zeros, depending on
whether the field is a character field or a numeric field.

Comments should not be included in an attribute template file.

The illustration and table show an example of the type of information you're
likely to extract, including block name, manufacturer, model number, and
cost.

Decimal placesMaximum field
length

(C)haracter or
(N)umeric data

Field

000040CBlock name

000006CManufacturer

000015CModel

002006NCost

You can create any number of template files, depending on how you'll use
the data. Each line of a template file specifies one field to be written in the
attribute extraction file.
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Follow these additional guidelines:

■ Be sure to place a space between the attribute tag and the character or
numeric data. Use SPACEBAR, not TAB, to enter the space.

■ Press Enter at the end of each line, including the last line.

■ Each attribute extraction template file must include at least one attribute
tag field, but the same field can appear only once in the file.

The following is a sample template file.

BL:NAME C008000 (Block name, 8 characters)

BL:X N007001 (X coordinate, format nnnnnn.d)

BL:Y N007001  (Y coordinate, format nnnnnn.d)

SUPPLIER C016000 (Manufacturer's name, 16 characters)

MODEL C009000 (Model number, 9 characters)

PRICE N009002 (Unit price, format nnnnnnnn.dd)

NOTE The format code for a numeric field includes the decimal point in the total
field width. For example, the minimum field width to accommodate the number
249.95 would be 6 and would be represented as N006002. Character fields do
not use the last three digits of the format code.

Create an Attribute Extraction File

After creating a template file, you can extract the attribute information using
one of the following formats:

■ Comma-delimited format (CDF)

■ Space-delimited format (SDF)

■ Drawing interchange format (DXF)

The CDF format produces a file containing one record for each block reference
in a drawing. A comma separates the fields of each record, and single quotation
marks enclose the character fields. Some database applications can read this
format directly.

The SDF format also produces a file containing one record for each block
reference in a drawing. The fields of each record have a fixed width and employ
neither field separators nor character-string delimiters. The dBASE III Copy .
. . SDF operation also produces SDI-format files. The Append From... SDF
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operation can read a file in dBASE IV format, which user programs written in
FORTRAN can easily process.

DXF produces a subset of the drawing interchange format containing only
block reference, attribute, and end-of-sequence objects. This option requires
no attribute extraction template. The file extension .dxx distinguishes an
extraction file in DXF format from normal DXF files.

Use the Attribute Extraction File

The attribute extraction file lists values and other information for the attribute
tags you specified in the template file.

If you specified a CDF format using the sample template, the output might
appear as follows:

'DESK', 120.0, 49.5, 'ACME INDUST.', '51-793W', 379.95
'CHAIR', 122.0, 47.0, 'ACME INDUST.', '34-902A', 199.95
'DESK', -77.2, 40.0, 'TOP DRAWER INC.', 'X-52-44',249.95

By default, character fields are enclosed with single quotes (apostrophes). The
default field delimeter is a comma. The following two template records can
be used to override these defaults:

C:QUOTE c (Character string delimeter)
C:DELIM c (Field delimeter)

The first nonblank character following the C:QUOTE or C:DELIM field name
becomes the respective delimiter character. For example, if you want to enclose
character strings with double quotes, include the following line in your
attribute extraction template file:

C:QUOTE "

The quote delimiter must not be set to a character that can appear in a
character field. Similarly, the field delimiter must not be set to a character
that can appear in a numeric field.

If you specified an SDF format using the sample template, the file might be
similar to the following example.

(PRICE)(MODEL)(SUPPLIER)(Y)(X)(NAME)

379.9551-793WACME IN-
DUST.

49.5120.0DESK

199.9534-902AACME IN-
DUST.

47.0122.0CHAIR
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(PRICE)(MODEL)(SUPPLIER)(Y)(X)(NAME)

249.95X-52-44TOP DRAWER
INC.

40.0-77.2DESK

The order of the fields corresponds to the order of the fields in the template
files. You can use these files in other applications, such as spreadsheets, and
you can sort and manipulate the data as needed. For example, you can open
an attribute extraction file in Microsoft Excel in which you can specify a
separate column for each field. See the documentation for your spreadsheet
program for information about how to use data from other applications. If
you open the file in Notepad or another Windows text processor, you can
paste the information back into the drawing as text.

Nested Blocks

The line BL:LEVEL in a template file reports the nesting level of a block
reference. A block that is inserted in a drawing has a nesting level of 1. A block
reference that is part of (nested within) another block has a nesting level of
2, and so on.

For a nested block reference, the X,Y, Z coordinate values, scale factors,
extrusion direction, and rotation angle reflect the actual location, size,
orientation, and rotation of the nested block in the world coordinate system.

In some complex cases, nested block references cannot be correctly represented
with only two scale factors and a rotation angle, for example, if a nested block
reference is rotated in 3D. When this happens, the scale factors and rotation
angle in the extracted file record are set to zero.

Error Handling

If a field is not wide enough for the data that is to be placed in it, the data is
truncated and the following message is displayed:

** Field overflow in record <record number>

This could happen, for example, if you have a BL:NAME field with a width of
8 characters and a block in your drawing has a name 10 characters long.

To create an attribute extraction template file

1 Start Notepad.

You can use any text editor or word processor that can save a text file in
ASCII format.
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2 Enter template information in Notepad. See Extract Block Attribute Data
(Advanced) on page 1035 for format information.

3 Save the file with a .txt file extension.

To extract data about a specific tag, insert the tag name in place of the
"numeric" or "character" fields.

WARNING Do not use tab characters when constructing the template file with a
word processor. If you use tab character alignment, the attribute information file
is not created. To align the columns, insert ordinary spaces by pressing SPACEBAR.
The use of tab characters may cause inconsistent alignment.

To extract attribute information

1 At the Command prompt, enter attext.

2 In the Attribute Extraction dialog box, specify the appropriate file format:
CDF, SDF, or DXF.

3 Specify the objects to extract attributes from by choosing Select Objects.

You can select a single block or multiple blocks in the drawing.

4 Specify the attribute template file to use by entering the file name or by
choosing Template File and browsing.

5 Specify the output attribute information file by entering the file name
or by choosing Output File and browsing.

6 Click OK.

Command entry: ATTEXT

Quick Reference

Commands

ATTEXT

Extracts attribute data, informational text associated with a block, into a file.

DATAEXTRACTION

Extracts drawing data and merges data from an external source to a data
extraction table or external file.
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Modify Blocks
You can modify a block definition or a block reference already inserted in the
drawing.

Modify a Block Definition
You can redefine block definitions in your current drawing. Redefining a block
definition affects both previous and future insertions of the block in the current
drawing and any associated attributes.

There are two methods for redefining a block definition:

■ Modify the block definition in the current drawing.

■ Modify the block definition in the source drawing and reinsert it into the
current drawing.

The method you choose depends on whether you want to make changes in
the current drawing only or in a source drawing also.

Modify a Block Definition in the Current Drawing

To modify a block definition, follow the procedure to create a new block
definition, but enter the name of the existing block definition. This replaces
the existing block definition, and all the references to that block in the drawing
are immediately updated to reflect the new definition.

To save time, you can insert and explode an instance of the original block
and then use the resulting objects in creating the new block definition.

Update a Block Definition That Originated from a Drawing File

Block definitions created in your current drawing by inserting a drawing file
are not updated automatically when the original drawing is modified. You
can use INSERT to update a block definition from the drawing file.

Update a Block Definition That Originated from a Library Drawing
(Advanced)

DesignCenter™ does not overwrite an existing block definition in a drawing
with one that comes from another drawing. To update a block definition that
came from a library drawing, use WBLOCK to create a separate drawing file
from the library drawing block. Then, use INSERT to overwrite the block
definition in the drawing that uses the block.
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NOTE Block descriptions are stripped off when using INSERT. Use the Clipboard
to copy and paste a block description displayed in the Block Definition dialog box
from one block definition to another.

Modify the Description of a Block

To modify the DesignCenter description of a block definition, use BLOCK.
You can also add descriptions to any number of existing blocks in the Block
Definition dialog box.

Redefine Block Attributes

You can attach attributes to a block when you define or redefine that block.
When you are prompted to select the objects to include in the block definition,
include the desired attributes in the selection set. Redefining the attributes in
the block definition has the following effects on block references that were
previously inserted:

■ Constant attributes, which have a fixed value, are lost and replaced by any
new constant attributes.

■ Variable attributes remain unchanged, even if the new block definition
has no attributes.

■ New attributes do not appear in the existing block references.

See also:

■ Attach Data to Blocks (Block Attributes) on page 1027

■ Modify Dynamic Block Definitions on page 888

To update a block definition that originated from a drawing file

1 If DesignCenter is not already open, click Tools menu  ➤ Palettes  ➤ 

DesignCenter.

2 In the tree view, click the folder that contains the drawing file from which
the block originated.

3 In the content area (on the right side), right-click the drawing file.

4 On the shortcut menu, click Insert as Block.

5 In the Insert dialog box, click OK.

6 In the Block - Redefine Block dialog box, click Redefine Block.
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7 Press ESC to exit the command.

To modify a block description

1 Click Modify menu  ➤ Object  ➤ Block Description.

2 In the Block Definition dialog box, in the Name list, select the block for
which you want to modify the block description.

3 In the Description box, enter or modify the description of the block.

4 Click OK.

5 In the Block - Redefine Block dialog box, click Redefine Block.

Command entry: BLOCK

Quick Reference

Commands

BLOCK

Creates a block definition from selected objects.

EXPLODE

Breaks a compound object into its component objects.

PROPERTIES

Controls properties of existing objects.

Change the Color and Linetype in a Block
Blocks containing objects with floating properties inherit their color and
linetype from the layer on which they are inserted. Depending on how the
objects in the block were created, blocks can also inherit floating color and
linetype properties from the current explicit color and linetype that you set
to override the layer settings.

If a block was not created using objects with floating color and linetype
properties, the only way to change these properties is to redefine the block.
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See also:

■ Control the Color and Linetype Properties in Blocks on page 860

To change the layer of an object

1 Select the objects whose layer you want to change.

2 On the Layers toolbar, click the Layer control.

3 Select the layer that you want to assign to the objects.

Command entry: LAYER

To change the color assigned to a layer

1 On the Layers toolbar, click the Layer Properties Manager button.

2 In the Layer Properties Manager, click the color you want to change.

3 In the Select Color dialog box, use one of the following methods:

■ On the Index tab, click a color and then click OK.

■ On the Index tab, enter the ACI color number (1-255) or name in the
Color box, and then click OK.

■ On the True Color tab, select the HSL color model in the Color Model
option and specify a color by entering a color value in the Color box
or by specifying values in the Hue, Saturation, and Luminance boxes,
and then click OK.

■ On the Color Books tab, select a color book from the Color Book box,
select a color by navigating the color book (using the up and down
arrows) and clicking on a color chip, and then click OK.

4 Click OK.

Toolbar: Layers  
Command entry: LAYER

To change the color of an object, overriding the layer's color

1 On the Standard toolbar, click Properties.

2 Select the objects whose color you want to change.
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3 In the Properties palette, select Color.

An arrow is displayed in the right column.

4 Click the arrow and select a color from the list.

Toolbar: Standard  
Command entry: PROPERTIES

To change the linetype assigned to a layer

1 On the Layers toolbar, click the Layer Properties Manager button.

2 In the Layer Properties Manager, click Load and click one or more
linetypes to load, and then click OK.

You can hold down Ctrl to select several linetypes or Shift to select a
range of linetypes.

3 Select a layer from the list and then click Details to expand the dialog
box.

4 Select a linetype from the Linetype list.

5 Click OK to close the dialog box.

To open the Layer Properties Manager, click Format menu  ➤ Layer.

Toolbar: Layers  
Command entry: LAYER

To change the linetype of an object, overriding the layer's linetype

1 Select the objects whose linetype you want to change.

2 On the Properties toolbar, click the Linetype control.

3 Click the linetype that you want to assign to the objects.

Command entry: LINETYPE

To modify an existing block definition

1 Select the block to modify.
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2 Right-click the block and click Properties on the shortcut menu.

3 In the Properties palette, select and modify X and Y position, scale, rotation
values, or other properties.

Command entry: PROPERTIES

Quick Reference

Commands

LAYER

Manages layers and layer properties.

LINETYPE

Loads, sets, and modifies linetypes.

PROPERTIES

Controls properties of existing objects.

Modify the Data in Block Attributes
You can use any of the following methods to edit the values of attributes
attached to a block:

■ Double-click the block to display the Enhanced Attributes Editor

■ Press Ctrl and double-click the attribute to display the in-place editor

■ Open the Properties palette and select the block

■ Enter the ATTEDIT command to display the Edit Attributes dialog box

■ Enter the -ATTEDIT command for Command prompt access to multiple
attribute values and properties

You can also change the location of attributes in a block using grips. With
multiple-line attributes, you can also move grips to resize the width of the
text.

NOTE If you press Ctrl and double-click an attribute that includes a hyperlink, the
hyperlink opens the web page. To edit the attribute, use one of the other methods
listed.
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See also:

■ Modify a Block Definition on page 1042

To edit attribute data

1 Click Modify menu  ➤ Objects  ➤ Attribute  ➤ Single.

2 Select the block to edit.

3 In the Edit Attributes dialog box, retype the attribute information as
necessary and click OK.

Quick Reference

Commands

ATTEDIT

Changes attribute information in a block.

ATTIPEDIT

Changes the textual content of an attribute within a block.

ATTSYNC

Updates block references with new and changed attributes from a specified
block definition.

BATTMAN

Manages the attributes for a selected block definition.

EATTEDIT

Edits attributes in a block reference.

System Variables

ATTIPE

Controls the display of the in-place editor used to create multiline attributes.

ATTMULTI

Controls whether multiline attributes can be created.
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Modify a Block Attribute Definition
You can modify attributes in block definitions with the Block Attribute
Manager. For example, you can modify the following:

■ Properties that define how values are assigned to an attribute and whether
or not the assigned value is visible in the drawing area

■ Properties that define how attribute text is displayed in the drawing

■ Properties that define the layer that the attribute is on and the attribute
line's color, weight, and type

By default, attribute changes you make are applied to all existing block
references in the current drawing.

Changing the attribute properties of existing block references does not affect
the values assigned to those blocks. For example, in a block containing an
attribute whose tag is Cost and value is 19.99, the 19.99 value is unaffected
if you change the tag from Cost to Unit Cost.

Updating attributes with duplicate tag names can lead to unpredictable results.
Use the Block Attribute Manager to find duplicate tags and change tag names.

If constant attributes or nested attributed blocks are affected by your changes,
use REGEN to update the display of those blocks in the drawing area.

Change the Prompt Order for Attribute Values

When you define a block, the order in which you select the attributes
determines the order in which you are prompted for attribute information
when you insert the block. You can use the Block Attribute Manager to change
the order of prompts that request attribute values.

Remove Block Attributes

You can remove attributes from block definitions and from all existing block
references in the current drawing. Attributes removed from existing block
references do not disappear in the drawing area until you regenerate the
drawing using REGEN.

You cannot remove all attributes from a block; at least one attribute must
remain. If you need to remove all attributes, redefine the block.
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Update Block References

You can update attributes in all block references in the current drawing with
changes you made to the block definition. For example, you may have used
the Block Attribute Manager to modify attribute properties in several block
definitions in your drawing but elected not to automatically update existing
block references when you made the changes. Now that you are satisfied with
the attribute changes you made, you can apply those changes to all blocks in
the current drawing.

You can also use ATTSYNC to update attribute properties in block references
to match their block definition, or to update a block instance after you redefine
a block attribute using BLOCK, -BLOCK, or BEDIT.

Updating attribute properties in block references does not affect any values
that have been assigned to those attributes.

Edit Attributes in a Block Reference

You can select an attribute in a block reference and use the Properties palette
to change its properties, or you can use the Enhanced Attribute Editor to
modify all the attributes in a selected block reference.

See also:

■ Define Block Attributes on page 1029

■ Modify a Block Definition on page 1042

To edit attributes assigned to a block definition

1 Click Home tab ➤ Block panel ➤ Manage Attributes. 

2 In the Block Attribute Manager, select a block from the Block list, or click
Select Block and select a block in the drawing area.

3 In the list of attributes, double-click the attribute you want to edit, or
select the attribute and click Edit.

4 In the Edit Attribute dialog box, make the attribute changes you want,
and then click OK.

Toolbar: Modify II  

1050 | Chapter 18   Create and Use Blocks (Symbols)



Command entry: BATTMAN

To specify whether changes are applied to existing block references

1 Click Home tab ➤ Block panel ➤ Manage Attributes. 

2 In the Block Attribute Manager, click Settings.

3 In the Settings dialog box, do one of the following:

■ To apply changes to existing block references, select the Apply Changes
to Existing References option.

■ To apply changes only to new block insertions, clear the Apply
Changes to Existing References option.

4 Click OK.

Toolbar: Modify II  
Command entry: BATTMAN

To highlight duplicate attribute tags in a block

1 Click Home tab ➤ Block panel ➤ Manage Attributes. 

2 In the Block Attribute Manager, click Settings.

3 In the Settings dialog box, select Emphasize Duplicate Tags.

4 Click OK.

Toolbar: Modify II  
Command entry: BATTMAN

To change the prompt order for attribute values

1 Click Home tab ➤ Block panel ➤ Manage Attributes. 
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2 In the Block Attribute Manager, select a block from the Block list, or click
Select Block and select a block in the drawing area.

For the selected block, attributes are listed in their prompt order.

3 To move an attribute up in the prompt order, select the attribute, and
then click Move Up; to move an attribute down in the prompt order,
select the attribute, and then click Move Down.

NOTE The Move Up and Move Down buttons are unavailable for attributes
with constant values (Mode=C).

Toolbar: Modify II  
Command entry: BATTMAN

To remove an attribute from a block definition and all block references

1 Click Home tab ➤ Block panel ➤ Manage Attributes. 

2 In the Block Attribute Manager, select a block from the Block list, or click
Select Block and select a block in the drawing area.

3 (Optional) If you do not want attributes removed from existing instances
of the block, click Settings, and, in the Settings dialog box, clear Apply
Changes to Existing References.

4 In the Block Attribute Manager, select an attribute from the attribute list,
and then click Remove.

Attributes removed from existing block instances do not disappear until
you regenerate the drawing using REGEN.

Toolbar: Modify II  
Command entry: BATTMAN

To update existing block references with attributes you have modified

1 Click Home tab ➤ Block panel ➤ Manage Attributes. 
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2 In the Block Attribute Manager, select a block from the Block list, or click
Select Block and select a block in the drawing area.

3 Click Sync to update attributes you have changed in all block references
for the selected block.

Toolbar: Modify II  
Command entry: BATTMAN

To update the attributes in block references for a selected block definition

1 Click Home tab ➤ Block panel ➤ Synchronize Attributes. 

2 At the prompt, do one of the following:

■ Enter name, and then enter the name of the block whose block
references you want to update.

■ Enter ? to view a list of blocks, and then enter name, followed by the
name of the block.

■ Press Enter, and then use your pointing device to select a block in the
drawing area.

If you specify a block that does not exist, or if the block exists but does
not contain attributes, an error message is displayed.

Toolbar: Modify II  
Command entry: ATTSYNC

Alternate

1 Click Home tab ➤ Block panel ➤ Edit Single Attribute. 

2 In the drawing area, select the block you want to edit.

3 In the Enhanced Attribute Editor, select the attribute you want to edit.
You can change the attribute value or choose another tab and edit other
attribute properties.
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4 Make the attribute changes you want, and then do one of the following:

■ Click Apply to save your changes. The Enhanced Attribute Editor
remains open.
If you click Cancel later to exit the Enhanced Attribute Editor, attribute
changes you made prior to choosing Apply are not reversed.

■ Click OK to save your changes and close the Enhanced Attribute
Editor.

■ Click Select Block to edit the attributes of a different block. If you
made changes to the current block, but have not saved them, you are
prompted to do so before selecting a new block.

Toolbar: Modify II  
Command entry: EATTEDIT

Quick Reference

Commands

ATTIPEDIT

Changes the textual content of an attribute within a block.

ATTSYNC

Updates block references with new and changed attributes from a specified
block definition.

BATTMAN

Manages the attributes for a selected block definition.

EATTEDIT

Edits attributes in a block reference.

System Variables

ATTIPE

Controls the display of the in-place editor used to create multiline attributes.

ATTMULTI

Controls whether multiline attributes can be created.
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Disassemble a Block Reference (Explode)
If you need to modify one or more objects within a block separately, you can
disassemble, or explode, the block reference into its component objects. After
making the changes, you can

■ Create a new block definition

■ Redefine the existing block definition

■ Leave the component objects uncombined for other uses

You can automatically explode block references as you insert them by selecting
the Explode option in the Insert dialog box.

To explode a block reference

1 Click Home tab ➤ Modify panel ➤ Explode. 

2 Select the block to explode. Press Enter.

The block reference is disassembled into its component objects; however,
the block definition still exists in the drawing for insertion later.

Toolbar: Modify  
Command entry: EXPLODE

To control properties while you explode an object

1 Enter xplode.

2 Select the objects to be exploded.

3 If you selected more than one object, enter i to control properties for
individual objects, or enter g to control properties for all the selected
objects.

4 Enter an option for a property you want to change.

The property is applied to the compound object and the prompt is
redisplayed.

5 Enter another option, or enter e to explode the selected objects.
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The selected objects are exploded and the properties you specified are
applied to the component objects.

Quick Reference

Commands

EXPLODE

Breaks a compound object into its component objects.

XPLODE

Breaks a compound object into its component objects.
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Change Existing Objects

You can select objects, view and edit object properties, and perform general and object-specific
editing operations.

Select Objects
You have a wide range of options when you need to select objects for editing
operations.

Select Objects Individually
At the Select Objects prompt, you can select one or more objects individually.

Use the Pickbox Cursor

When the square pickbox cursor is in position to select an object, the object is
highlighted. Click to select the object.

You can control the size of the pickbox in the Options dialog box, Selection
tab.

Select Objects Close Together

It is difficult to select objects that are close together or lie directly on top of one
another. The example shows two lines and a circle that lie within the pickbox.
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If selection preview is turned on, you can cycle through the objects by rolling
over the object on top to highlight it, and pressing and holding Shift and then
pressing Spacebar continuously. When the required object is highlighted,
left-click to select it.

If selection preview is turned off, hold down Shift + Spacebar and click to cycle
through these objects, one after the other, until the one you want is selected.
Press Esc to turn off cycling.

Remove Selection from Objects

Remove objects from the current selection set by holding down Shift and
selecting them again.

See also:

■ Modify 3D Solid Subobjects on page 1310

■ Modify Composite Solids and Surfaces on page 1328

To select a single object

1 At the Select Objects prompt of any command, move the rectangular
pickbox cursor so that the object that you want to select is highlighted.

2 Click the object.

The object you selected is highlighted.

3 Press Enter to end object selection.

NOTE If the PICKFIRST system variable is set to 1 (noun-verb selection), you
can select objects before entering a command.

To change the size of the pickbox cursor

1 Click Tools menu  ➤ Options.

2 On the Selection tab, under Pickbox Size, move the pickbox size slider
until the pickbox is the size you want to use.

3 Click OK.

Command entry: PICKBOX
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To cycle through objects for selection

1 At the Select Objects prompt, hold down Shift + Spacebar. Click as near
as possible to the object you want.

2 Keep clicking until the object you want is highlighted.

3 Press Enter to select the object.

NOTE If selection preview is turned on, you can cycle through the objects by
rolling over the object on top to highlight it, and pressing and holding Shift and
then pressing Spacebar continuously. When the required object is highlighted,
left-click to select it.

To remove selection from objects

■ Hold down Shift. Click the objects that you want removed from the
selection set.

Quick Reference

Commands

PROPERTIES

Controls properties of existing objects.

SELECT

Places selected objects in the Previous selection set.

System Variables

3DSELECTIONMODE

Controls the selection precedence of visually overlapping objects when using
3D visual styles.

HIGHLIGHT

Controls object highlighting; does not affect objects selected with grips.

LEGACYCTRLPICK

Specifies the keys for selection cycling and the behavior for Ctrl+click.
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PICKADD

Controls whether subsequent selections replace the current selection set or
add to it.

PICKAUTO

Controls automatic windowing at the Select Objects prompt.

PICKBOX

Sets the object selection target height, in pixels.

PICKDRAG

Controls the method of drawing a selection window.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

Select Multiple Objects
At the Select Objects prompt, you can select many objects at the same time.

Specify a Rectangular Selection Area

Specify opposite corners to define a rectangular area. The background inside
the area changes color and becomes transparent. The direction that you drag
your cursor from the first point to the opposite corner determines which
objects are selected.

■ Window selection. Drag your cursor from left to right to select only objects
that are entirely enclosed by the rectangular area.

■ Crossing selection. Drag your cursor from right to left to select objects that
the rectangular window encloses or crosses.
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With a window selection, usually the entire object must be contained in the
rectangular selection area. However, if an object with a noncontinuous (dashed)
linetype is only partially visible in the viewport and all the visible vectors of
the linetype can be enclosed within the selection window, the entire object
is selected.

Specify an Irregularly Shaped Selection Area

Specify points to define an irregularly shaped area. Use window polygon
selection to select objects entirely enclosed by the selection area. Use crossing
polygon selection to select objects enclosed or crossed by the selection area.

Specify a Selection Fence

In a complex drawing, use a selection fence. A selection fence looks like a
polyline and selects only the objects it passes through. The circuit board
illustration shows a fence selecting several components.
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Use Other Selection Options

You can see all selection options by entering ? at the Select Objects prompt.
For a description of each of the selection options, see SELECT.

Remove Selection from Multiple Objects

You can enter r (Remove) at the Select Objects prompt and use any selection
option to remove objects from the selection set. If you are using the Remove
option and want to return to adding objects to the selection set, enter a (Add).

You can also remove objects from the current selection set by holding down
Shift and selecting them again, or by holding down Shift and then clicking
and dragging window or crossing selections. You can add and remove objects
repeatedly from the selection set.

To see a list of options at the Select Objects prompt

■ Enter ? at the Select Objects prompt.

To select objects within an irregularly shaped area

1 At the Select Objects prompt, enter wp (Window Polygon).

2 Specify points that define an area entirely enclosing the objects you want
to select.

3 Press Enter to close the polygon selection area and complete the selection.

To select objects crossing an irregularly shaped area

1 At the Select Objects prompt, enter cp (Crossing Polygon).

2 Specify points that define an area that encloses or crosses the objects you
want to select.

3 Press Enter to close the polygon selection area and complete the selection.
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To select objects with a fence

1 At the Select Objects prompt, enter f (Fence).

2 Specify points to create a fence that passes through the objects you want
to select.

3 Press Enter to complete the selection.

To remove several objects from the selection set

1 After selecting objects, at the Select Objects prompt, enter r (Remove).

2 Enter any selection option such as cp (Crossing Polygon) or f (Fence),
and select the objects to be removed from the selection set.

To return to adding objects to the selection set, enter a (Add).

Quick Reference

Commands

PROPERTIES

Controls properties of existing objects.

QSELECT

Creates a selection set based on filtering criteria.

SELECT

Places selected objects in the Previous selection set.

System Variables

HIGHLIGHT

Controls object highlighting; does not affect objects selected with grips.

PICKADD

Controls whether subsequent selections replace the current selection set or
add to it.

PICKAUTO

Controls automatic windowing at the Select Objects prompt.
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PICKBOX

Sets the object selection target height, in pixels.

PICKDRAG

Controls the method of drawing a selection window.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

PREVIEWEFFECT

Specifies the visual effect used for previewing selection of objects.

Prevent Objects from Being Selected
You can prevent objects on specified layers from being selected and modified
by locking those layers.

Typically, you lock layers to prevent accidental editing of particular objects.
Other operations are still possible when a layer is locked. For example, you
can make a locked layer current, and you can add objects to it. You can also
use inquiry commands (such as LIST), use object snaps to specify points on
objects on locked layers, and change the draw order of objects on locked layers.

To help you differentiate between locked and unlocked layers, you can do the
following:

■ Hover over an object to see whether a lock icon is displayed

■ Dim the objects on locked layers

NOTE Grips are not displayed on objects that are on locked layers.

To lock or unlock a layer

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties.

2 In the Layer Properties Manager, click the padlock for the layers that you
want to lock.

3 Click OK.
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If the padlock is closed, the layer is locked and objects on that layer
cannot be selected.

Toolbar: Layers  
Command entry: LAYER

To lock or unlock a layer by selecting an object on that layer

1 Click the Model tab.

2 Do either of the following:

■ Click Home tab  ➤  Layers panel  ➤  Lock.

■ Click Home tab  ➤  Layers panel  ➤  Unlock.

3 Select an object on the layer you want to lock or unlock.

Toolbar: Layer II 
Command entry: LAYLCK,LAYULK

Quick Reference

Commands

LAYER

Manages layers and layer properties.

LAYISO

Hides or locks all layers except those of the selected objects.

LAYLCK

Locks the layer of a selected object.
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LAYULK

Unlocks the layer of a selected object.

System Variables

LAYLOCKFADECTL

Controls the amount of fading for objects on locked layers.

Filter Selection Sets
You can use object properties or object types to include objects in a selection
set, or to exclude them.

Using either Quick Select (QSELECT) from the Properties palette or the Object
Selection Filters dialog box (FILTER), you can filter selection sets by property
(such as color) and by object type. For example, you can select all of the red
circles in a drawing without selecting any other object, or you can select all
objects except the red circles.

With Quick Select, you can quickly define a selection set based on filtering
criteria that you specify, and if an Autodesk or a third-party application was
used to add a feature classification to an object, you can select objects by
classification property. With object selection filters, you can name and save
filters for future use.

With either Quick Select or object selection filters, if you want to filter your
selection set based on color, linetype, or lineweight, first consider whether
these properties are set to BYLAYER for any objects in your drawing. For
example, an object may appear red because its color is set to BYLAYER and
the layer color is red.

See also:

■ Customize Object Selection on page 1070

■ Work with Layers on page 533

To create a selection set using Quick Select

In the following example, you use Quick Select to select the red objects in a
drawing.

1 Click Home tab ➤ Utilities panel ➤ Quick Select. 
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2 In the Quick Select dialog box, under Apply To, select Entire Drawing.

3 Under Object Type, select Multiple.

4 Under Properties, select Color.

5 Under Operator, select Equals.

6 Under Value, select Red.

7 Under How to Apply, select Include in New Selection Set.

8 Click OK.

All red objects in the drawing are selected and the Quick Select dialog
box closes. Objects that are set to BYLAYER and are red because the layer
color is red are not included in the selection set.

NOTE If an application such as Autodesk Map was used to add a feature
classification to an object, and the associated classification (XML) file is present,
you can select objects by classification property. Specifically, you can select a
classification in the Object Type box and a property in the Properties box.

Command entry: QSELECT

To exclude objects from the selection set

You can exclude objects from the current selection set by using the Exclude
from New Selection Set option. In the following example, you exclude all
circles with a radius greater than 1 from a set of objects already selected.

1 Select several objects.

2 Click Home tab ➤ Utilities panel ➤ Quick Select. 

3 In the Quick Select dialog box, under Apply To, select Current Selection.

4 Under Object Type, select Circle.

5 Under Properties, select Radius.

6 Under Operator, select Greater Than.

7 Under Value, enter 1.

8 Under How to Apply, select Exclude from New Selection Set.

9 Click OK.
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All circles with a radius greater than 1 are removed from the selection
set.

Command entry: QSELECT

To append objects to the selection set

You can use Quick Select to append objects to a current selection set. In the
following example, you keep the current selection set and append all objects
in the drawing that contain hyperlinks whose names begin with bld1_.

1 Click Home tab ➤ Utilities panel ➤ Quick Select. 

2 In the Quick Select dialog box, select Append to Current Selection Set.

3 In the Object Type box, select Multiple.

4 Under Properties, select Hyperlink.

5 Under Operator, select Wildcard Match.

6 Under Value, enter bld1_*.

7 Under How to Apply, select Include in New Selection Set.

8 Click OK.

Command entry: QSELECT

To name and save a filtered list

1 At the Command prompt, enter filter.

2 In the Object Selection Filters dialog box, under Select Filter, select a filter
such as Line.

3 Click Add to List.

4 Under Save As, enter a filter name such as Linefilter.

5 Click Save As.

6 Click Apply.

The filter is applied so you can select, in this case, only lines in the
drawing. If you select objects with a selection, the filter is applied to all
objects in the selection area.
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Command entry: FILTER

To use a named filter

1 At the Select Object prompt, enter 'filter. (The apostrophe makes it a
transparent command.)

2 In the Object Selection Filters dialog box, under Select Filter, select the
filter you want to use. Click Apply.

3 Use a crossing window to specify objects for selection.

Only the objects selected by the crossing window that match the filter
criteria are selected.

Quick Reference

Commands

FILTER

Creates a list of requirements that an object must meet to be included in a
selection set.

PROPERTIES

Controls properties of existing objects.

QSELECT

Creates a selection set based on filtering criteria.

SELECT

Places selected objects in the Previous selection set.

System Variables

PICKADD

Controls whether subsequent selections replace the current selection set or
add to it.

PICKAUTO

Controls automatic windowing at the Select Objects prompt.

PICKBOX

Sets the object selection target height, in pixels.

Filter Selection Sets | 1069



PICKDRAG

Controls the method of drawing a selection window.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

Customize Object Selection
You can control several aspects of selecting objects, such as whether you enter
a command first or select objects first, the size of the pickbox cursor, and how
selected objects are displayed.

For commands that use the Select Objects prompt, you can

■ Enter a command first, and then select objects

■ Select the objects first, and then enter a command

You can also choose

■ Whether objects to be selected are previewed during selection

■ Whether selected objects are highlighted

■ How you define selection areas and how you create selection sets

Select the Command First

When you use an editing command, a Select Objects prompt is displayed and
the crosshairs is replaced with a pickbox. You can respond to the Select Objects
prompt in various ways:

■ Select objects one at a time.

■ Click an empty area. Drag the cursor to define a rectangular selection area.

■ Enter a selection option. Enter ? to display all selection options.

■ Combine selection methods. For example, to select most of the objects in
the drawing area, select all objects and then remove the objects that you
do not want selected.

■ Enter 'filter to use a named selection filter. The apostrophe runs the
command transparently.
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Select Objects First

You can use one of two methods to select objects before starting a command:

■ Use the SELECT command, and enter ? to display all selection options. All
objects selected are put into the Previous selection set. To use the Previous
selection set, enter p at the Select Objects prompt of any subsequent
command.

■ When noun/verb selection is turned on, select objects at the Command
prompt before entering a command such as MOVE, COPY, or ERASE. With
this method, you can only select objects by clicking them individually or
by using automatic selection.

■ Enter qselect to filter the selection. Then enter p at the Select Objects
prompt of any subsequent command.

Highlight Objects to Be Selected

Objects are highlighted when the pickbox cursor rolls over them, providing
a preview of which object will be selected when you click.

When you specify an area to select multiple objects, the background of the
area becomes transparent.

These selection previewing effects are turned on by default. You can turn them
off or change the appearance of selection previewing (Options dialog box,
Selection tab). When the PICKBOX system variable is set to 0, selection
previewing of objects is not available.

Control the Appearance of Selected Objects

By default, selected objects are displayed with dashed lines. You can increase
program speed by setting the HIGHLIGHT system variable to 0. Turning off
selection highlighting does not affect grips on selected objects.
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Set Up Default Selection Methods

Options on the Selection tab of the Options dialog box control default selection
methods:

■ Use selection previewing and selection area effects to preview selection.

■ Select objects before entering a command (noun-verb selection) or after
entering a command. (PICKFIRST)

■ Press Shift to append objects to the selection set. (PICKADD)

■ Click and drag to create a selection window. Otherwise you must click
twice to define the corners of a selection window. (PICKDRAG)

■ Start Window or Crossing selection automatically when you click an empty
space. Otherwise, you must enter c or w to specify window crossing
selection. (PICKAUTO)

■ Change the size of the pickbox. (PICKBOX)

■ Select all objects in a group when you select one object in that group.

■ Include the boundary in the selection set when you select a hatch.

To change the size of the pickbox cursor

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Selection tab, under Pickbox Size, move the
slider until the pickbox is the size you want to use.

3 Click OK.

Command entry: OPTIONS

To change object selection settings

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Selection tab, make changes to the Selection
Preview and Selection Modes areas and the pickbox size.

3 Click OK.
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Command entry: OPTIONS

To turn on or turn off selection previewing

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Selection tab, select or clear options as follows:

■ Select the When a Command Is Active option to display the check
mark.

■ Select the When No Command Is Active option to display the check
mark.

■ Select both options to turn on selection preview whenever it is
available.

■ Clear both options to turn off selection preview entirely.

SELECTIONPREVIEW

To change the appearance of selection previewing

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Selection tab, click Visual Effect Settings.

3 In the Visual Effect Settings dialog box, select one of the following
options:

■ Dash. Displays dashed lines.

■ Thicken. Displays thickened lines.

■ Both. Displays dashed and thickened lines.

4 Click OK to exit each dialog box.

To exclude objects from selection previewing

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Selection tab, click Visual Effect Settings.
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3 In the Visual Effect Settings dialog box, click Advanced Options.

4 In the Advanced Preview Options dialog box, select any of the following
options to exclude objects from selection previewing:

■ Exclude Objects on Locked Layers

■ Xrefs

■ Tables

■ Groups

■ Multiline Text

■ Hatches

5 Click OK to exit each dialog box.

To change the appearance of the selection area

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Selection tab, click Visual Effect Settings.

3 In the Visual Effect Settings dialog box, change any of the following
settings:

■ Indicate Selection Area. Select to display effects for selection areas.

■ Window Selection Color. Select a color, or click Select Color to display
the Select Color dialog box. (WINDOWAREACOLOR system variable)

■ Crossing Selection Color. Select a color, or click Select Color to display
the Select Color dialog box. (CROSSINGAREACOLOR system variable)

■ Selection Area Opacity. Use the slider to set transparency for selection
areas. The lower the setting, the more transparent the area. A value
of 100 makes the area opaque. (SELECTIONAREAOPACITY system
variable)

4 Click OK to exit each dialog box.
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Quick Reference

Commands

FILTER

Creates a list of requirements that an object must meet to be included in a
selection set.

PROPERTIES

Controls properties of existing objects.

QSELECT

Creates a selection set based on filtering criteria.

System Variables

CROSSINGAREACOLOR

Controls the color of the selection area during crossing selection.

DRAGMODE

Controls the way dragged objects are displayed.

HIGHLIGHT

Controls object highlighting; does not affect objects selected with grips.

PICKADD

Controls whether subsequent selections replace the current selection set or
add to it.

PICKAUTO

Controls automatic windowing at the Select Objects prompt.

PICKBOX

Sets the object selection target height, in pixels.

PICKDRAG

Controls the method of drawing a selection window.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.
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PREVIEWEFFECT

Specifies the visual effect used for previewing selection of objects.

PREVIEWFILTER

Excludes specified object types from selection previewing.

SELECTIONAREA

Controls the display of effects for selection areas.

SELECTIONAREAOPACITY

Controls the transparency of the selection area during window and crossing
selection.

SELECTIONPREVIEW

Controls the display of selection previewing.

WINDOWAREACOLOR

Controls the color of the transparent selection area during window selection.

Group Objects
A group is a saved set of objects that you can select and edit together or
separately as needed. Groups provide an easy way to combine drawing elements
that you need to manipulate as a unit.

Overview of Groups
A group is a saved set of objects that you can select and edit together or
separately as needed. Groups provide an easy way to combine drawing elements
that you need to manipulate as a unit. You can create them quickly and with
a default name.

TIP Groups are useful in associating 3D solids when you do not want to combine
them with a Boolean operation.

You can change the components of groups as you work by adding or removing
objects.

In some ways, groups resemble blocks, which provide another method of
combining objects into a named set. For example, the groups you create are
saved from session to session. However, you can edit individual objects in
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groups more easily than you can edit them in blocks, which must be exploded
first. Unlike blocks, groups cannot be shared with other drawings.

Quick Reference

Commands

GROUP

Creates and manages saved sets of objects called groups.

System Variables

PICKSTYLE

Controls the use of group selection and associative hatch selection.

Create Groups
In addition to choosing the objects that will become the members of a group,
you can give the group a name and description.

When you create a group, you can give the group a name and description. If
you copy a group, the copy is given the default name Ax and is considered
unnamed. Unnamed groups are not listed in the Object Grouping dialog box
unless you select Include Unnamed.

If you choose a member of a group that can be selected for inclusion in a new
group, all members of the former group are included in the new group.

The objects in your drawing can be members of more than one group, and
groups themselves can be nested in other groups. You can ungroup a nested
group to restore the original group configuration.

Named groups are not maintained when you use a drawing as an external
reference or insert it as a block. However, you can bind and then explode the
external reference or explode the block to make the group available as an
unnamed group.

NOTE Avoid creating large groups containing hundreds or thousands of objects.
A large group significantly degrades the performance of this program.

To create a group

1 At the Command prompt, enter group.
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2 In the Object Grouping dialog box, under Group Identification, enter a
group name and a description.

3 In the Create Group area, click New.

The dialog box closes temporarily.

4 Select objects and press Enter.

5 Click OK.

Command entry: GROUP

Quick Reference

Commands

GROUP

Creates and manages saved sets of objects called groups.

System Variables

PICKSTYLE

Controls the use of group selection and associative hatch selection.

Select Objects in Groups
There are several methods for choosing a group, including selecting the group
by name or selecting one of the members of the group.

You can select groups by name at the Select Objects prompt. If the PICKSTYLE
system variable is set to 1 or 3 and you select any member of a selectable
group, all group members that meet the selection criteria are selected. You
can also turn group selection on and off by pressing Ctrl+ H or Shift+Ctrl+A.

All members of selectable groups are also selected when you use object selection
cycling (for example, if you want to select an object that lies directly behind
another object). Selecting an object that is a member of more than one
selectable group selects all the members of all the groups that contain that
object. To select groups for editing with grips, use the pointing device to select
the group at the Command prompt.
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To control whether all grouped objects can be selected individually

Do one of the following:

■ At the Command prompt, enter pickstyle. Enter 1 to turn on group
selection. Objects within groups can be selected as a group only, not
individually.

■ At the Command prompt, enter pickstyle. Enter 0 to turn off group
selection. Objects within groups can be selected individually only, not as
a group.

■ At any time, turn group selection on and off by pressing either Ctrl+H or
Ctrl+Shift+A.

To control selectability for a specific group

1 At the Command prompt, enter group.

2 In the Object Grouping dialog box, under Group Name, click the group
for which you want to change selectability.

3 Under Change Group, click Selectable.

This changes whether objects within the group are either selectable as a
group, subject to the PICKSTYLE system variable. If selectability is turned
off, the objects in a group are selectable only as individual objects. At the
top of the Object Grouping dialog box, under Selectable, each group
displays its current status.

4 Click OK.

Quick Reference

Commands

GROUP

Creates and manages saved sets of objects called groups.

System Variables

PICKSTYLE

Controls the use of group selection and associative hatch selection.
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Edit Groups
You can modify groups in a number of ways, including changing their
membership, modifying their properties, revising the names and descriptions
of groups, and removing them from the drawing.

Edit Objects as a Group

When group selection is turned on, you can move, copy, rotate, and modify
groups just as you can modify individual objects. If you need to edit objects
within a group, turn off group selection or use grips to edit individual objects.
For more information, see Select Objects in Groups on page 1078.

In some circumstances, it is useful to control the order in which objects that
belong to the same group are selected. For example, a custom routine that
generates toolpaths for numerical control devices might depend on a series
of contiguous objects in a specified order.

You can reorder group members in two ways: either change the numerical
position of individual members or ranges of group members, or reverse the
order of all members. The first object in each group is number 0, not number
1.

Change Group Components, Name, or Description

With the Object Grouping dialog box, you can specify objects to be added to
or removed from a group at any time. You can also revise a group's name or
description. If deleting an object or removing it from a group leaves the group
empty, the group remains defined but without any members.

NOTE Exploding an object such as a block instance or hatch that belongs to a
group does not automatically add the resulting components to any group.

Remove Groups

You can delete a group definition by using the “explode” option in the Object
Grouping dialog box. This operation is not the same as exploding a block,
hatch, or dimension. Objects that belonged to the exploded group remain in
the drawing.

As a result, the group is disbanded but the members are not changed in any
other way.

To delete a named group

1 At the Command prompt, enter group.
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2 In the Object Grouping dialog box, select the group name from the list
of groups.

3 Under Change Group, select Explode.

4 Click OK.

The group is deleted.

Command entry: GROUP

To reorder group members

1 At the Command prompt, enter group.

2 In the Object Grouping dialog box, under Change Group, click Re-Order.

3 In the Order Group dialog box, under Group Name, select the group to
reorder.

4 To view the current order of this group, click Highlight.

5 In the Object Grouping dialog box, click Next or Previous to view the
objects. Click OK when you have finished viewing the order of the objects.

6 In the Order Group dialog box, under Remove From Position, enter an
object number.

7 Under Enter New Position Number for the Object, enter a new position.

8 Under Number of Objects, enter the object number or range of numbers
to reorder. Click Re-Order.

9 Click OK to close each dialog box.

Command entry: GROUP

Quick Reference

Commands

GROUP

Creates and manages saved sets of objects called groups.

Group Objects | 1081



System Variables

PICKSTYLE

Controls the use of group selection and associative hatch selection.

Correct Mistakes
You can backtrack your recent actions using one of several methods.

Undo a Single Action

The simplest method of backtracking is to use Undo on the Standard toolbar
or the U command to undo a single action. Many commands include their
own U (undo) option so that you can correct mistakes without leaving the
command. When you are creating lines and polylines, for example, enter u
to undo the last segment.

NOTE By default, the UNDO command is set to combine consecutive pan and
zoom commands into a single operation when you undo or redo. However, pan
and zoom commands that are started from the menu are not combined, and
always remain separate actions.

Undo Several Actions at Once

Use the Mark option of UNDO to mark an action as you work. You can then
use the Back option of UNDO to undo all actions that occurred after the
marked action. Use the Begin and End options of UNDO to define a set of
actions to be treated as a group.

You can also undo several actions at once with the Undo list on the Standard
toolbar.

Reverse the Effect of Undo

You can reverse the effect of a single U or UNDO command by using REDO
immediately after using U or UNDO.

You can also redo several actions at once with the Redo list on the Standard
toolbar.

Erase Objects

You can erase any object that you draw. If you accidentally erase the wrong
object, you can use the UNDO command or the OOPS command to restore
it.
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For more information, see Erase Objects on page 1085.

Cancel a Command

You can cancel a command without completing it by pressing Esc.

To undo the most recent action

■ Click Edit menu  ➤ Undo.

Toolbar: Standard  
Command entry: U

To undo a specific number of actions

1 On the Standard toolbar, click the Undo list arrow.

A list of actions that you can undo, starting with the most recent action,
is displayed.

2 Drag to select the actions to undo.

3 Click to undo the selected actions.

Toolbar: Standard  
Command entry: UNDO

To redo an action

■ Click Edit menu  ➤ Redo.

Only the action immediately preceding an UNDO command can be reversed
with REDO. You cannot use REDO to repeat another command.

Toolbar: Standard  
Command entry: REDO

To redo a specific number of actions

1 On the Standard toolbar, click the Redo list arrow.
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A list of undo actions that you can redo, starting with the most recent
action, is displayed.

2 Drag to select the actions to redo.

3 Click to redo the selected actions.

Toolbar: Standard  
Command entry: MREDO

Quick Reference

Commands

ERASE

Removes objects from a drawing.

OPTIONS

Customizes the program settings.

OOPS

Restores erased objects.

REDO

Reverses the effects of previous UNDO or U command.

MREDO

Reverses the effects of several previous UNDO or U commands.

U

Reverses the most recent operation.

UNDO

Reverses the effect of commands.

System Variables

UNDOCTL

Indicates the state of the Auto, Control, and Group options of the UNDO
command.
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UNDOMARKS

Stores the number of marks placed in the UNDO control stream by the Mark
option.

Erase Objects
There are many ways to delete objects from your drawing and clean up the
display.

Remove Unused Definitions, Styles, and Objects

You can remove unused named and unnamed objects with PURGE. Some of the
unnamed objects you can purge include block definitions, dimension styles,
layers, linetypes, and text styles. With PURGE you can also remove zero-length
geometry and empty text objects.

Clean Up the Display

You can remove the plus-shaped markers called blips and stray pixels that
may be left over from some editing operations from the display area.

■ To remove blips, use REDRAW.

■ To remove stray pixels, use REGEN.

See also:

■ Correct Mistakes on page 1082

To erase an object

1 Click Home tab ➤ Modify panel ➤ Erase.

2 At the Select Objects prompt, use a selection method to select the objects
to be erased or enter an option:

■ Enter L (Last) to erase the last object drawn.

■ Enter p (Previous) to erase the last selection set.

■ Enter all to erase all objects from the drawing.

■ Enter ? to see a list of all selection methods.

3 Press Enter to end the command.
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Toolbar: Modify  
Command entry: ERASE

To restore the last erased object

■ At the Command prompt, enter oops.

The last objects that were removed by ERASE, BLOCK, or WBLOCK are restored.

Command entry: OOPS

To cut objects to the Clipboard

1 Select the objects you want to cut.

2 Click Home tab ➤ Utilities panel ➤ Cut. You can also press Ctrl+X.

The objects are available to be pasted into other Windows applications.

Command entry: CUTCLIP

To remove plus-shaped marker blips

■ Click View menu  ➤ Redraw. 

Command entry: REDRAW

To purge an unused linetype

1 Click Tools tab ➤ Drawing Utilities panel ➤ Purge. 

The Purge dialog box displays a tree view of object types with items that
can be purged.

2 To purge unreferenced linetypes, use one of the following methods:

■ To purge all unreferenced linetypes, select Linetypes.

■ To purge specific linetypes, double-click Linetypes to expand the tree
view. Then select the linetypes to be purged.
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If the item you want to purge is not listed, select View Items You Cannot
Purge.

3 You are prompted to confirm each item in the list. If you do not want to
confirm each purge, clear the Confirm Each Item to Be Purged option.

4 Click Purge.

To confirm the purging of each item, respond to the prompt by choosing
Yes or No, or Yes to All if more than one item is selected.

5 Click Close.

Command entry: PURGE

To remove zero-length geometry and empty text objects

1 Click Tools tab ➤ Drawing Utilities panel ➤ Purge. 

The Purge dialog box displays.

2 Select Purge zero-length geometry and empty text objects.

3 Click Purge.

4 Click Close.

Command entry: PURGE

Quick Reference

Commands

CUTCLIP

Copies selected objects to the Clipboard and removes them from the drawing.

ERASE

Removes objects from a drawing.

OOPS

Restores erased objects.

PURGE

Removes unused items, such as block definitions and layers, from the drawing.
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REDRAW

Refreshes the display in the current viewport.

REDRAWALL

Refreshes the display in all viewports.

REGEN

Regenerates the entire drawing from the current viewport.

UNDO

Reverses the effect of commands.

Use Windows Cut, Copy, and Paste
When you want to use objects from a drawing file in another application, you
can cut or copy these objects to the Clipboard and then paste them from the
Clipboard into the other application.

Cut Objects

Cutting deletes selected objects from the drawing and stores them on the
Clipboard. The objects are now available to be pasted into other Microsoft®

Windows® documents.

Copy Objects

You can use the Clipboard to copy part or all of a drawing into a document
created by another application. The objects are copied in vector format, which
retains the high resolution in other applications. These objects are stored in
WMF (Windows metafile) format in the Clipboard. The information stored
in the Clipboard can then be embedded in the other document. Updating the
original drawing does not update the copy embedded in the other application.

Paste Objects

Applications use different internal formats to store Clipboard information.
When you copy objects to the Clipboard, information is stored in all available
formats. When you paste the Clipboard contents into a drawing, the format
that retains the most information is used. However, you can override this
setting and convert pasted information to AutoCAD format.

Because it is the easiest format to edit, the AutoCAD format is the preferred
format for copying objects to and from AutoCAD. It retains all relevant object
information, including block references and 3D aspects.
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The Windows metafile (picture) format contains screen vector information,
and files can be scaled and printed without losing resolution. Use this format
to paste objects into Windows applications that support WMF files. Metafiles
pasted into AutoCAD are of higher resolution than bitmapped images (BMP
files) but are not as easily manipulated as AutoCAD objects. Bitmapped images
are raster images consisting of a pattern of pixels and are commonly used by
paint applications.

The color of the object doesn't change when copied to the Clipboard. For
example, white objects pasted onto a white background won't be visible. Use
the WMFBKGND and WMFFOREGND system variables to control whether
the background or foreground is transparent for metafile objects pasted into
other applications.

You can insert a linked or embedded object from the Clipboard into a drawing
with PASTESPEC. If you convert pasted information to AutoCAD format, the
object is inserted as a block reference. To edit the pasted information, explode
the block reference into its component objects. When you convert a Windows
metafile stored on the Clipboard to AutoCAD format, you may lose some
scaling precision. To retain proper scaling, save objects in the original drawing
as a block (WBLOCK), and then insert them into AutoCAD using INSERT.

To cut objects to the Clipboard

1 Select the objects you want to cut.

2 Click Home tab ➤ Utilities panel ➤ Cut. 

You can also press Ctrl+X.

The objects can be pasted into other Windows applications as well.

Command entry: CUTCLIP

To copy objects to the Clipboard

1 Select the objects you want to copy.

2 Click Home tab ➤ Utilities panel ➤ Copy Clip. 

You can also press Ctrl+C.

Command entry: COPYCLIP
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To paste objects from the Clipboard

■ Click Home tab ➤ Utilities panel ➤ Paste. 
You can also press Ctrl+V.

The objects currently on the Clipboard are pasted into the drawing.

Command entry: PASTECLIP

To convert pasted information to drawing file format

1 Click Home tab ➤ Utilities panel ➤ Paste Special. 

2 In the Paste Special dialog box, select Paste.

3 From the list of formats, select Picture.

4 Click OK.

Command entry: PASTESPEC

Quick Reference

Commands

COPYBASE

Copies selected objects to the Clipboard along with a specified base point.

COPYCLIP

Copies selected objects to the Clipboard.

CUTCLIP

Copies selected objects to the Clipboard and removes them from the drawing.

PASTEBLOCK

Pastes objects from the Clipboard into the current drawing as a block.

PASTECLIP

Pastes objects from the Clipboard into the current drawing.
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PASTEORIG

Pastes objects from the Clipboard into the current drawing using the original
coordinates.

PASTESPEC

Pastes objects from the Clipboard into the current drawing and controls the
format of the data.

WMFIN

Imports a Windows metafile.

WMFOPTS

Sets options for WMFIN.

WMFOUT

Saves objects to a Windows metafile.

System Variables

OLEHIDE

Controls the display and plotting of OLE objects.

WMFBKGND

Controls the background display when objects are inserted in Windows
metafile (WMF) format.

WMFFOREGND

Controls the assignment of the foreground color when objects are inserted
in Windows metafile (WMF) format.

Modify Objects
You can easily modify the size, shape, and location of objects.

Choose a Method to Modify Objects
You can easily modify the size, shape, and location of objects. You can

■ Enter a command first, and then select the objects to modify.

■ Select the objects first, and then enter a command to modify them.
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■ Select and right-click an object to display a shortcut menu with relevant
options.

■ Double-click an object to display the Properties palette or, in some cases,
a dialog box or editor that is specific to that type of object. (You can specify
the double click action for each object type by customizing a CUIx file and
loading it into the program.)

See also:

■ Change Text on page 1561

■ Select Objects on page 1057

■ Modify Existing Dimensions on page 1704

■ Display and Change the Properties of Objects on page 524

■ Work with Custom and Proxy Objects

■ “Double Click Actions” in the Customization Guide

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

DRAGMODE

Controls the way dragged objects are displayed.

PROPERTIES

Controls properties of existing objects.

SELECT

Places selected objects in the Previous selection set.

System Variables

DBLCLKEDIT

Controls the double click editing behavior in the drawing area.
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DRAGMODE

Controls the way dragged objects are displayed.

PICKADD

Controls whether subsequent selections replace the current selection set or
add to it.

PICKFIRST

Controls whether you select objects before (noun-verb selection) or after you
issue a command.

Move or Rotate Objects
You can move objects to a different location, or change the orientation of
objects by rotating them by an angle or to other objects.

Move Objects
You can move objects at a specified distance and direction from the originals.

Use coordinates, grid snap, object snaps, and other tools to move objects with
precision.

Specify Distance with Two Points

Move an object using the distance and direction specified by a base point
followed by a second point. In this example, you move the block representing
a window. Click Home tab ➤ Modify panel ➤ Move. Then select the object
to be moved (1). Specify the base point for the move (2) followed by a second
point (3). The object is moved the distance and direction of point 2 to point
3.
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Specify Distance with Relative Coordinates

You can move an object using a relative distance by entering coordinate values
for the first point and pressing Enter for the second point. The coordinate
values are used as a relative displacement rather than the location of a base
point.

NOTE Do not include an @ sign as you normally would for relative coordinates,
because relative coordinates are expected.

To copy objects a specified distance, you can also use direct distance entry
with Ortho mode and polar tracking. For more information, see Enter Direct
Distances on page 709

Use a Stretch-Move

You can also use STRETCH to move objects if all their endpoints lie entirely
within the selection window. Turn on Ortho mode or polar tracking to move
the objects at a specific angle.

A practical example is moving a door in a wall. The door in the illustration is
entirely within a crossing selection, while the wall lines are only partly within
the crossing selection area.

The result is that only the endpoints that lie within the crossing selection
move.

Use Alternate Methods

You can use grips to move and copy objects quickly. See Use Grips to Edit
Objects on page 1141.

You can also select objects and drag them to a new location; press Ctrl to make
a copy. Using this method, you can drag objects between open drawings and
other applications. If you drag with the right mouse button instead of the left,
a shortcut menu is displayed. The menu options include Move Here, Copy
Here, Paste as Block, and Cancel. See Embed OLE Objects in Drawings.
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To move an object using two points

1 Click Home tab ➤ Modify panel ➤ Move.

2 Select the objects to move.

3 Specify a base point for the move.

4 Specify a second point.

The objects you selected are moved to a new location determined by the
distance and direction between the first and second points.

Toolbar: Modify  
Command entry: MOVE

To move an object using a displacement

1 Click Home tab ➤ Modify panel ➤ Move.

2 Select the object to move.

3 Enter the displacement in the form of a Cartesian, polar, cylindrical, or
spherical coordinate value. Do not include the @ sign, because a relative
coordinate is assumed.

4 At the prompt for the second point, press Enter.

The coordinate values are used as a relative displacement rather than the
location of a base point. The selected objects are moved to a new location
determined by the relative coordinate values you enter.

Toolbar: Modify  
Command entry: MOVE

To move an object from model space to paper space (or vice versa)

1 Click a layout tab.
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2 Click Home tab ➤  Modify panel  ➤  Change Space.

3 Select one or more objects to move.

4 Press Enter.

The object is moved to the new space, and is scaled appropriately to the
new space.

Command entry: CHSPACE

To move by stretching

1 Click Home tab  ➤  Modify panel  ➤  Stretch.

2 Select the object by using crossing selection.

The crossing selection must include at least one vertex or endpoint.
Specify crossing selection by clicking, moving your pointing device from
right to left, and clicking again.

3 Do one of the following:

■ Specify the base point for the move, and then specify a second point.

■ Enter the displacement in the form of a Cartesian, polar, cylindrical,
or spherical coordinate value. Do not include the @ sign, because a
relative coordinate is assumed. At the prompt for the second point of
displacement, press Enter.

Any objects with at least one vertex or endpoint included within the
crossing selection are stretched. Any objects that are completely within
the crossing selection are moved without being stretched.

Toolbar: Modify  
Command entry: STRETCH
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Quick Reference

Commands

CHSPACE

Moves objects between model space and paper space.

MOVE

Moves objects a specified distance in a specified direction.

PROPERTIES

Controls properties of existing objects.

STRETCH

Stretches objects crossed by a selection window or polygon.

Command Modifiers

Direct Distance Entry (Command Modifier)

Locates the next point at a specified distance in the direction of your cursor.

Rotate Objects
You can rotate objects in your drawing around a specified base point.

To determine the angle of rotation, you can enter an angle value, drag using
the cursor, or specify a reference angle to align to an absolute angle.

Rotate an Object by a Specified Angle

Enter a rotation angle value from 0 to 360 degrees. You can also enter values
in radians, grads, or surveyor bearings. Entering a positive angle value rotates
the objects counterclockwise or clockwise, depending on the Direction Control
setting in the Drawing Units dialog box.

Rotate an Object by Dragging

Drag the object around the base point and specify a second point. Use Ortho
mode, polar tracking, or object snaps for greater precision.

For example, you can rotate the plan view of a house by selecting the objects
(1), specifying a base point (2), and specifying an angle of rotation by dragging
to another point (3).
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Rotate an Object to an Absolute Angle

With the Reference option, you can rotate an object to align it to an absolute
angle.

For example, to rotate the part in the illustration so the diagonal edge rotates
to 90 degrees, you select the objects to be rotated (1, 2), specify the base point
(3), and enter the Reference option. For the reference angle, specify the two
endpoints of the diagonal line (4, 5). For the new angle, enter 90.

Rotate an Object in 3D

To rotate 3D objects, you can use either ROTATE or ROTATE3D.

■ With ROTATE, you can rotate objects around a specified base point. The
axis of rotation passes through the base point and is parallel to the Z axis
of the current UCS.

■ With ROTATE3D, you can specify the axis of rotation using either two
points; an object; the X, Y, or Z axis; or the Z direction of the current view.

See also:

■ Rotate Views in Layout Viewports on page 471
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To rotate an object

1 Click Home tab ➤ Modify panel ➤ Rotate.

2 Select the object to rotate.

3 Specify the base point for the rotation.

4 Do one of the following:

■ Enter the angle of rotation.

■ Drag the object around its base point and specify a point location to
which you want to rotate the object.

■ Enter c to create a copy of the selected objects.

■ Enter r to rotate the selected objects from a specified reference angle
to an absolute angle.

Toolbar: Modify  
Command entry: ROTATE

To rotate an object to an absolute angle

1 Click Home tab ➤ Modify panel ➤ Rotate.

2 Select the objects to rotate.

3 Specify the base point for the rotation.

4 Enter r (Reference).

5 Enter a reference angle value or specify two point locations.

This determines an imaginary line that will be rotated to a new angle.

6 Enter the new angle, or specify a point.

The value that you enter for the new angle is an absolute angle, not a
relative value. Alternatively, if you specify a point, the reference angle
will be rotated to that point.

Toolbar: Modify  
Command entry: ROTATE
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To rotate a 3D object around an axis

1 Click Modify menu  ➤ 3D Operations ➤ Rotate 3D.

2 Select the object to rotate (1).

3 Specify the start point and endpoint of the axis about which the objects
are to be rotated (2 and 3).

The positive axis direction is from the start point to the end point, and
the rotation follows the right-hand rule (see Understand the User
Coordinate System in 3D on page 650).

4 Specify the angle of rotation.

Command entry: ROTATE3D

Quick Reference

Commands

ROTATE

Rotates objects around a base point.

ROTATE3D

Moves objects about a 3D axis.

Align Objects
You can move, rotate, or tilt an object so that it aligns with another object.
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In the following example, two pairs of points are used to align the piping in
2D using the ALIGN command. Endpoint object snaps align the pipes precisely.

In 3D, use the 3DALIGN command to specify up to three points to define the
source plane followed by up to three points to define the destination plane.

■ The first source point on an object, called the base point, is always moved
to the first destination point.

■ Specifying a second point for either the source or the destination results
in the selected objects being rotated.

■ A third point for either the source or the destination results in further
rotation of the selected objects.

TIP With 3D solid models, it is recommended that you turn on dynamic UCS to
speed the selection of the destination plane.

To align two objects in 2D

1 Click Modify menu  ➤ 3D Operations ➤ Align. 

2 Select the objects that you want to align.

3 Specify a source point and then the corresponding destination point. To
rotate the object, specify a second source point followed by a second
destination point.

4 Press Enter to end the command.

The selected objects are moved from the source point to the destination
point, and second and third points, if you specify them, rotate, and tilt
the selected objects.

Command entry: ALIGN

Move or Rotate Objects | 1101



To align two objects in 3D

1 Click Home tab  ➤  Modify panel  ➤  3D Align.

2 Select the objects that you want to align.

3 Specify either one, two, or three source points and then the corresponding
first, second, or third destination points. The first point is called the base
point.

The selected objects are moved from the source point to the destination
point, and second and third points, if you specify them, rotate, and tilt
the selected objects.

Command entry: 3DALIGN

Quick Reference

Commands

3DALIGN

Aligns objects with other objects in 2D and 3D.

ALIGN

Aligns objects with other objects in 2D and 3D.

System Variables

UCSDETECT

Controls whether dynamic UCS acquisition is active or not.

Copy, Offset, or Mirror Objects
You can create duplicates of objects in your drawing that are either identical
or similar to selected objects.
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Copy Objects
You can create duplicates of objects at a specified distance and direction from
the originals.

Use coordinates, grid snap, object snaps, and other tools to copy objects with
precision.

You can also use grips to move and copy objects quickly. See Use Grips to Edit
Objects on page 1141.

Specify Distance with Two Points

Copy an object using the distance and direction specified by a base point
followed by a second point. In this example, you copy the block representing
an electronic component. Click Edit menu  ➤ Copy.Then select the original
object to be copied. Specify the base point for the move (1) followed by a
second point (2). The object is copied the distance and direction of point 1
to point 2.

Specify Distance with Relative Coordinates

Copy an object using a relative distance by entering coordinate values for the
first point and pressing Enter for the second point. The coordinate values are
used as a relative displacement rather than the location of a base point.

NOTE Do not include an @ sign as you normally would for relative coordinates,
because relative coordinates are expected.

To copy objects a specified distance, you can also use direct distance entry
with Ortho mode and polar tracking. For more information, see Enter Direct
Distances on page 709.
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Create Multiple Copies

The COPY command repeats automatically by default. To exit the command,
press Enter. To change the default, use the COPYMODE system variable.

Move and Copy Objects by Dragging

You can also select objects and drag them to a new location using the left
mouse button over one of the selected objects; press Ctrl to make a copy.
Using this method, you can drag objects between open drawings and other
applications.

If you drag with the right mouse button instead of the left, a shortcut menu
is displayed after you drag the objects. The menu options include Move Here,
Copy Here, Paste as Block, and Cancel.

For information about using object linking and embedding, see Embed OLE
Objects in Drawings.

To copy an object using two points

1 Click Home tab  ➤  Modify panel  ➤  Copy.

2 Select the objects to copy.

3 Specify the base point.

4 Specify the second point. Press Enter.

Toolbar: Modify  
Command entry: COPY
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Quick Reference

Commands

COPY

Copies objects a specified distance in a specified direction.

System Variables

COPYMODE

Controls whether the COPY command repeats automatically.

Create an Array of Objects
You can create copies of objects in a rectangular or polar (circular) pattern
called an array.

For rectangular arrays, you control the number of rows and columns and the
distance between each. For polar arrays, you control the number of copies of
the object and whether the copies are rotated. To create many regularly spaced
objects, arraying is faster than copying.

Create Rectangular Arrays

A rectangular array is built along a baseline defined by the current snap rotation
angle. This angle is zero by default, so the rows and columns of a rectangular
array are orthogonal with respect to the X and Y axes. The default angle 0
direction setting can be changed in UNITS.
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Create Polar Arrays

When you create a polar array, the array is drawn counterclockwise or
clockwise, depending on whether you enter a positive or a negative value for
the angle to fill.

The radius of the array is determined by the distance from the specified center
point to a reference or base point on the last selected object. You can use the
default reference point (usually an arbitrary point that coincides with a snap
point), or you can specify a new base point to be used as the reference point.

Array in 3D

With 3DARRAY, you can create a rectangular array or a polar array of objects
in 3D. In addition to specifying the number of columns (X direction) and rows
(Y direction), you also specify the number of levels (Z direction).

Limit the Size of Arrays

If you specify a very large number of rows and columns for an array, it may
take a long time to create the copies. By default, the number of array elements
that can be generated by one command is limited to approximately 100,000.
This limit is controlled by the MaxArray setting in the registry.

You can change the limit by setting the MaxArray system registry variable
using (setenv “MaxArray” “n”) where n is a number between 100 and 10000000
(ten million).

NOTE When changing the value of MaxArray, you must enter MaxArray with the
capitalization shown.
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To create a rectangular array

1 Click Home tab ➤ Modify panel ➤ Array.

2 In the Array dialog box, select Rectangular Array.

3 Click Select Objects.

The Array dialog box closes. You are prompted for object selection.

4 Select the objects to be arrayed and press Enter.

5 In the Rows and Columns boxes, enter the number of rows and columns
in the array.

6 Specify the horizontal and vertical spacing (offsets) between objects by
using one of the following methods:

■ In the Row Offset and Column Offset boxes, enter the distance
between rows and between columns. Adding a plus sign (+) or a minus
sign (-) determines direction.

■ Click the Pick Both Offsets button to use the pointing device to specify
the diagonal corners of a cell in the array. The cell determines the
vertical and horizontal spacing of the rows and columns.

■ Click the Pick Row Offset or Pick Column Offset button to use the
pointing device to specify the horizontal and vertical spacing.

The example box displays the result.

7 To change the rotation angle of the array, enter the new angle next to
Angle of Array.

8 The default angle 0 direction setting can also be changed in UNITS.

9 Click OK to create the array.

Toolbar: Modify 
Command entry: ARRAY

To create a polar array

1 Click Home tab ➤ Modify panel ➤ Array.
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2 In the Array dialog box, select Polar Array.

3 Next to Center Point, do one of the following:

■ Enter an X value and a Y value for the center point of the polar array.

■ Click the Pick Center Point button. The Array dialog box closes and
you are prompted for object selection. Use the pointing device to
specify the center point of the polar array.

4 Click Select Objects.

The Array dialog box closes and you are prompted for object selection.

5 Select the objects to be arrayed.

6 In the Method box, select one of the following methods:

■ Total Number of Items & Angle to Fill

■ Total Number of Items & Angle Between Items

■ Angle to Fill & Angle Between Items

7 Enter the number of items (including the original object), if available.

8 Use one of the following methods:

■ Enter the angle to fill and angle between items, if available. Angle to
Fill specifies the distance to fill around the circumference of the array.
Angle Between Items specifies the distance between each item.

■ Click the Pick Angle to Fill button and the Pick Angle Between Items
button. Use the pointing device to specify the angle to fill and the
angle between items.

The example box displays the result.

9 You can set any of the following options:

■ To rotate the objects as they are arrayed, select Rotate Items As Copied.
The example area displays the result.

■ To specify the X,Y base point, select More, clear the Set to Object's
Default option and enter values in the X and Y boxes, or click the Pick
Base Point button and use the pointing device to specify the point.

10 Click OK to create the array.
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Toolbar: Modify  
Command entry: ARRAY

To create a 3D rectangular array of objects

1 Click Home tab  ➤  Modify panel  ➤  3D Array.

2 Select the object to array (1).

3 Specify Rectangular.

4 Enter the number of rows.

5 Enter the number of columns.

6 Enter the number of levels.

7 Specify the distance between rows.

8 Specify the distance between columns.

9 Specify the distance between levels.

Command entry: 3DARRAY

To create a 3D polar array of objects

1 Click Home tab  ➤  Modify panel  ➤  3D Array.

2 Select the object to array (1).
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3 Specify Polar.

4 Enter the number of items to array.

5 Specify the angle that the arrayed objects are to fill.

6 Press Enter to rotate the objects as they are arrayed, or enter n to retain
their orientation.

7 Specify the start point and endpoint of the axis about which the objects
are to be rotated (2 and 3).

Command entry: 3DARRAY

Quick Reference

Commands

3DARRAY

Creates a 3D matrix of objects in a rectangular or polar arrangement.

ARRAY

Creates multiple copies of objects in a pattern.

DSETTINGS

Sets grid and snap, polar and object snap tracking, object snap modes,
Dynamic Input, and Quick Properties.

UCS

Manages user coordinate systems.

UNITS

Controls coordinate and angle display formats and precision.
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System Variables

ANGBASE

Sets the base angle to 0 with respect to the current UCS.

ANGDIR

Sets the direction of positive angles.

SNAPANG

Sets the snap and grid rotation angle for the current viewport relative to the
current UCS.

Offset an Object
Offset an object to create a new object whose shape parallels the shape of the
original object.

OFFSET creates a new object whose shape parallels the shape of a selected
object. Offsetting a circle or an arc creates a larger or smaller circle or arc,
depending on which side you specify for the offset.

A highly effective drawing technique is to offset objects and then trim or
extend their ends.

You can offset

■ Lines
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■ Arcs

■ Circles

■ Ellipses and elliptical arcs (resulting in an oval-shaped spline)

■ 2D polylines

■ Construction lines (xlines) and rays

■ Splines

Special Cases for Offset Polylines and Splines

2D polylines and splines are trimmed automatically when the offset distance
is larger than can otherwise be accommodated.

Closed 2D polylines that are offset to create larger polylines result in potential
gaps between segments. The OFFSETGAPTYPE system variable controls how
these potential gaps are closed.

To offset an object by specifying a distance

1 Click Home tab ➤ Modify panel ➤ Offset.

2 Specify the offset distance.

You can enter a value or use the pointing device.

3 Select the object to offset.

4 Specify a point on the side where you want to place the new objects.

5 Select another object to offset, or press Enter to end the command.
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Toolbar: Modify  
Command entry: OFFSET

To offset an object through a point

1 Click Home tab ➤ Modify panel ➤ Offset.

2 Enter t (Through).

3 Select the object to offset.

4 Specify the through point.

5 Select another object to offset, or press Enter to end the command.

Toolbar: Modify  
Command entry: OFFSET

Quick Reference

Commands

OFFSET

Creates concentric circles, parallel lines, and parallel curves.

System Variables

OFFSETDIST

Sets the default offset distance.

OFFSETGAPTYPE

Controls how potential gaps between segments are treated when closed
polylines are offset.

Mirror Objects
You can flip objects about a specified axis to create a symmetrical mirror image.

Mirroring is useful for creating symmetrical objects because you can quickly
draw half the object and then mirror it instead of drawing the entire object.
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You flip objects about an axis called a mirror line to create a mirror image. To
specify this temporary mirror line, you enter two points. You can choose
whether to erase or retain the original objects.

By default, when you mirror text, attributes, and attribute definitions, they
are not reversed or turned upside down in the mirror image. The text has the
same alignment and justification as before the object was mirrored. If you do
want text to be reversed, set the MIRRTEXT system variable to 1.

MIRRTEXT affects text that is created with the TEXT, ATTDEF, or MTEXT
commands; attribute definitions; and variable attributes. Text and constant
attributes that are part of an inserted block are reversed when the block is
mirrored regardless of the MIRRTEXT setting.

Mirror in 3D

With MIRROR3D, you can mirror objects across a specified mirroring plane.
The mirroring plane can be one of the following:

■ The plane of a planar object

■ A plane parallel to the XY, YZ, or XZ plane of the current UCS that passes
through a specified point

■ A plane defined by three specified points (2, 3, and 4)
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To mirror objects in 2D

1 Click Home tab  ➤  Modify panel  ➤  Mirror.

2 Select the objects to mirror.

3 Specify the first point of the mirror line.

4 Specify the second point.

5 Press Enter to retain the original objects, or enter y to erase them.

Command entry: MIRROR

To mirror objects in 3D

1 Click Home tab ➤  Modify panel  ➤  3D Mirror.

2 Select the object to mirror.

3 Specify three points to define a mirroring plane.

4 Press Enter to retain the original objects, or enter y to delete them.

Command entry: MIRROR3D

Quick Reference

Commands

MIRROR

Creates a mirrored copy of selected objects.
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MIRROR3D

Creates a mirrored copy of selected objects across a mirroring plane.

System Variables

MIRRTEXT

Controls how the MIRROR command reflects text.

Change the Size and Shape of Objects
There are several methods for adjusting the lengths of existing objects relative
to other objects, both symmetrically and asymmetrically.

Trim or Extend Objects
You can shorten or lengthen objects to meet the edges of other objects.

This means you can first create an object such as a line and then later adjust
it to fit exactly between other objects.

Objects you select as cutting edges or boundary edges are not required to
intersect the object being trimmed. You can trim or extend an object to a
projected edge or to an extrapolated intersection; that is, where the objects
would intersect if they were extended.

If you do not specify a boundary and press Enter at the Select Objects prompt,
all displayed objects become potential boundaries.

NOTE To select cutting edges or boundary edges that include blocks, you can
use only the single selection, Crossing, Fence, and Select All options.

Trim Objects

You can trim objects so that they end precisely at boundary edges defined by
other objects.

For example, you can clean up the intersection of two walls smoothly by
trimming.
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An object can be one of the cutting edges and one of the objects being
trimmed. For example, in the illustrated light fixture, the circle is a cutting
edge for the construction lines and is also being trimmed.

When you trim several objects, the different selection methods can help you
choose the current cutting edges and objects to trim. In the following example,
the cutting edges are selected using crossing selection.

The following example uses the fence selection method to select a series of
objects for trimming.
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You can trim objects to their nearest intersection with other objects. Instead
of selecting cutting edges, you press Enter. Then, when you select the objects
to trim, the nearest displayed objects act as cutting edges. In this example,
the walls are trimmed so that they intersect smoothly.

You can extend objects without leaving the TRIM command. Hold down Shift
and select the objects to be extended.

Extend Objects

Extending operates the same way as trimming. You can extend objects so they
end precisely at boundary edges defined by other objects. In this example,
you extend the lines precisely to a circle, which is the boundary edge.

You can trim objects without leaving the EXTEND command. Hold down
Shift and select the objects to be trimmed.

Trim and Extend Wide Polylines

2D wide polylines trim and extend at their centerlines. The ends of wide
polylines are always square. Trimming a wide polyline at an angle causes
portions of the end to extend beyond the cutting edge

If you trim or extend a tapered 2D polyline segment, the width of the extended
end is corrected to continue the original taper to the new endpoint. If this
correction gives the segment a negative ending width, the ending width is
forced to 0.
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Trim and Extend Spline-Fit Polylines

Trimming a spline-fit polyline removes the curve-fit information and changes
the spline-fit segments into ordinary polyline segments.

Extending a spline-fit polyline adds a new vertex to the control frame for the
polyline.

Trim or Extend in 3D

You can trim or extend an object to any other object in 3D space, regardless
of whether the objects are on the same plane or parallel to the cutting or
boundary edges. In the TRIM and EXTEND commands, use the Project and
Edge options to select one of three projections for trimming or extending:

■ The XY plane of the current UCS

■ The plane of the current view

■ True 3D, which is not a projection

See also:

■ Break and Join Objects on page 1138

To extend an object

1 Click Home tab ➤ Modify panel ➤ Extend.

2 Select the objects to serve as boundary edges.

To select all displayed objects as potential boundary edges, press Enter
without selecting any objects.

3 Select the objects to extend.
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Toolbar: Modify  
Command entry: EXTEND

To trim an object

1 Click Home tab ➤ Modify panel ➤ Trim.

2 Select the objects to serve as cutting edges.

To select all displayed objects as potential cutting edges, press Enter
without selecting any objects.

3 Select the objects to trim.

Toolbar: Modify  
Command entry: TRIM

To extend objects in 3D wireframe models

1 Click Home tab ➤ Modify panel ➤ Extend  .

2 Select the boundary edge for extending (1).

3 Enter e (Edge).

4 Enter e (Extend).

5 Enter p (Project).

6 Enter u (UCS).

7 Select the object to extend (2).

Command entry: EXTEND
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To trim in 3D using the current view plane

1 Click Home tab ➤ Modify panel ➤ Trim  .

2 Select the cutting edge for trimming (1).

3 Enter p (Project).

4 Enter v (View).

5 Select the object to trim (2).

Command entry: TRIM

To trim objects in 3D wireframe models

1 Click Home tab ➤ Modify panel ➤ Trim  .

2 Select the cutting edges to use for trimming (1).

3 Enter p (Project).

4 Enter n (None).

5 Select the object to trim (2 and 3).

Command entry: TRIM
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Quick Reference

Commands

BREAK

Breaks the selected object between two points.

EXTEND

Extends objects to meet the edges of other objects.

JOIN

Joins similar objects to form a single, unbroken object.

LENGTHEN

Changes the length of objects and the included angle of arcs.

PROPERTIES

Controls properties of existing objects.

TRIM

Trims objects to meet the edges of other objects.

System Variables

EDGEMODE

Controls how the TRIM and EXTEND commands determine cutting and
boundary edges.

PROJMODE

Sets the current Projection mode for trimming or extending.

Resize or Reshape Objects
You can resize objects to make them longer or shorter in only one direction
or to make them proportionally larger or smaller.

You can also stretch certain objects by moving an endpoint, vertex, or control
point.
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Lengthen Objects

With LENGTHEN, you can change the included angle of arcs and the length
of the following objects:

■ Lines

■ Arcs

■ Open polylines

■ Elliptical arcs

■ Open splines.

The results are similar to extending and trimming. You can

■ Drag an object endpoint dynamically

■ Specify a new length or angle as a percentage of the total length or angle

■ Specify an incremental length or angle measured from an endpoint

■ Specify the object's total absolute length or included angle

Stretch Objects

With STRETCH, you relocate the endpoints of objects that lie across or within
a crossing selection window.

■ Objects that are partially enclosed by a crossing window are stretched.

■ Objects that are completely enclosed within the crossing window, or that
are selected individually, are moved rather than stretched.

To stretch an object, you specify a base point and then a point of displacement.
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To stretch with precision, use object snaps, grid snaps, and relative coordinate
entry.

Scale Objects Using a Scale Factor

With SCALE, you can make an object uniformly larger or smaller. To scale an
object, you specify a base point and a scale factor. Alternatively, you can
specify a length to be used as a scale factor based on the current drawing units.

A scale factor greater than 1 enlarges the object. A scale factor between 0 and
1 shrinks the object.

Scaling changes the size of all dimensions of the selected object. A scale factor
greater than 1 enlarges the object. A scale factor less than 1 shrinks the object.

NOTE When you use the SCALE command with objects, the position or location
of the object is scaled relative to the base point of the scale operation, but the size
of the object is not changed.

Scale Objects Using a Reference Distance

You can also scale by reference. Scaling by reference uses an existing distance
as a basis for the new size. To scale by reference, specify the current distance
and then the new desired size. For example, if one side of an object is 4.8 units
long and you want to expand it to 7.5 units, use 4.8 as the reference length.

You can use the Reference option to scale an entire drawing. For example, use
this option when the original drawing units need to be changed. Select all
objects in the drawing. Then use Reference to select two points and specify
the intended distance. All the objects in the drawing are scaled accordingly.

See also:

■ Break and Join Objects on page 1138

To stretch an object

1 Click Home tab ➤ Modify panel ➤ Stretch.

2 Select the object using a crossing window selection.
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The crossing window must include at least one vertex or endpoint.

3 Do one of the following:

■ Enter the displacement in the form of a relative Cartesian, polar,
cylindrical, or spherical coordinate. Do not include the @ sign, because
a relative coordinate is assumed. Press Enter at the prompt for the
second point of displacement.

■ Specify the base point for the stretch, and then specify a second point,
to determine the distance and direction.

Any objects with at least one vertex or endpoint included within the
crossing window are stretched. Any objects that are completely within
the crossing window, or selected individually, are moved without
stretching.

Toolbar: Modify  
Command entry: STRETCH

To scale an object by a scale factor

1 Click Home tab ➤ Modify panel ➤ Scale.

2 Select the object to scale.

3 Specify the base point.

4 Enter the scale factor or drag and click to specify a new scale.

Toolbar: Modify  
Command entry: SCALE

To scale an object by reference

1 Click Home tab ➤ Modify panel ➤ Scale.

2 Select the object to scale.

3 Select the base point.

4 Enter r (Reference).
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5 Select the first and second reference points, or enter a value for the
reference length.

Toolbar: Modify  
Command entry: SCALE

To change the length of an object by dragging

1 Click Home tab ➤ Modify panel ➤ Lengthen. 

2 Enter dy (Dynamic Dragging mode).

3 Select the object you want to lengthen.

4 Drag the endpoint closest to the point of selection, and specify a new
endpoint.

The selected object is lengthened or shortened without changing its
location or orientation.

Command entry: LENGTHEN

Quick Reference

Commands

JOIN

Joins similar objects to form a single, unbroken object.

LENGTHEN

Changes the length of objects and the included angle of arcs.

PEDIT

Edits polylines and 3D polygon meshes.

PROPERTIES

Controls properties of existing objects.

SCALE

Enlarges or reduces selected objects, keeping the proportions of the object
the same after scaling.
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SPLINEDIT

Edits a spline or spline-fit polyline.

STRETCH

Stretches objects crossed by a selection window or polygon.

System Variables

PLINECONVERTMODE

Specifies the fit method used in converting splines to polylines.

Fillet, Chamfer, Break, or Join Objects
You can change objects to meet in rounded or flattened corners. You can also
create or close gaps in objects.

Create Fillets
A fillet connects two objects with an arc that is tangent to the objects and has
a specified radius.

An inside corner is called a fillet and an outside corner is called a round; you
can create both using the FILLET command.

You can fillet

■ Arcs

■ Circles

■ Ellipses and elliptical arcs

■ Lines

■ Polylines

■ Rays
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■ Splines

■ Xlines

■ 3D solids

FILLET can be used to round all corners on a polyline using a single command.

NOTE Filleting a hatch boundary that was defined from line segments removes
hatch associativity. If the hatch boundary was defined from a polyline, associativity
is maintained.

If both objects being filleted are on the same layer, the fillet arc is created on
that layer. Otherwise, the fillet arc is created on the current layer. The layer
affects object properties including color and linetype.

Use the Multiple option to fillet more than one set of objects without leaving
the command.

Set the Fillet Radius

The fillet radius is the radius of the arc that connects filleted objects. Changing
the fillet radius affects subsequent fillets. If you set the fillet radius to 0, filleted
objects are trimmed or extended until they intersect, but no arc is created.

You can hold down Shift while selecting the objects to override the current
fillet radius with a value of 0.

Trim and Extend Filleted Objects

You can use the Trim option to specify whether the selected objects are
trimmed or extended to the endpoints of the resulting arc or left unchanged.
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Control the Location of the Fillet

Depending on the locations you specify, more than one possible fillet can
exist between the selected objects. Compare the selection locations and
resulting fillets in the illustrations.

Fillet Line and Polyline Combinations

To fillet lines with polylines, each line or its extension must intersect one of
the polyline line segments. If the Trim option is on, the filleted objects and
the fillet arc join to form a single new polyline.

Fillet an Entire Polyline

You can fillet an entire polyline or remove fillets from an entire polyline.

If you set a nonzero fillet radius, FILLET inserts fillet arcs at the vertex of each
polyline segment that is long enough to accommodate the fillet radius.
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If two polyline line segments converge as they approach an arc segment that
separates them, FILLET removes the arc segment and replaces it with a fillet
arc.

If you set the fillet radius to 0, no fillet arcs are inserted. If two polyline line
segments are separated by one arc segment, FILLET removes that arc and
extends the lines until they intersect.

Fillet Parallel Lines

You can fillet parallel lines, xlines, and rays. The current fillet radius
temporarily adjusts to create an arc that is tangent to both objects and located
in the plane common to both objects.

The first selected object must be a line or a ray, but the second object can be
a line, an xline, or a ray. The fillet arc connects as shown in the illustration.

Fillet Objects with Non-Zero Thickness in 3D

You can fillet coplanar objects with extrusion directions not parallel to the Z
axis of the current UCS. FILLET determines the extrusion direction for the
fillet arc in 3D space closest to the direction of the Z axis of the current UCS.

1130 | Chapter 19   Change Existing Objects



To set the fillet radius

1 Click Home tab ➤ Modify panel ➤ Fillet.

2 Enter r (Radius).

3 Enter the fillet radius

4 Select the objects to fillet.

Toolbar: Modify  
Command entry: FILLET

To fillet two line segments

1 Click Home tab ➤ Modify panel ➤ Fillet.

2 Select the first line.

3 Select the second line.

Toolbar: Modify  
Command entry: FILLET

To fillet without trimming

1 Click Home tab ➤ Modify panel ➤ Fillet.

2 If necessary, enter t (Trim). Enter n (No Trim).

3 Select the objects to fillet.

Toolbar: Modify  
Command entry: FILLET

To fillet an entire polyline

1 Click Home tab ➤ Modify panel ➤ Fillet.

2 Enter p (Polyline).

3 Select the polyline.
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Toolbar: Modify  
Command entry: FILLET

To fillet multiple sets of objects

1 Click Home tab ➤ Modify panel ➤ Fillet.

2 Enter m (Multiple).

The main prompt is displayed.

3 Select the first line, or enter an option and complete the prompts for that
option. Select the first line.

4 Select the second line.

The main prompt is displayed again.

5 Select the first line for the next fillet, or press Enter or Esc to end the
command.

Toolbar: Modify  
Command entry: FILLET

Quick Reference

Commands

FILLET

Rounds and fillets the edges of objects.

System Variables

FILLETRAD

Stores the current fillet radius.

TRIMMODE

Controls whether selected edges for chamfers and fillets are trimmed.
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Create Chamfers
A chamfer connects two objects to meet in a flattened or beveled corner.

A chamfer connects two objects with an angled line. It is usually used to
represent a beveled edge on a corner.

You can chamfer

■ Lines

■ Polylines

■ Rays

■ Xlines

■ 3D solids

CHAMFER can be used to bevel all corners of a polyline using a single
command.

NOTE Chamfering a hatch boundary that was defined from line segments removes
hatch associativity. If the hatch boundary was defined from a polyline, associativity
is maintained.

If both objects being chamfered are on the same layer, the chamfer line is
created on that layer. Otherwise, the chamfer line is created on the current
layer. The layer affects object properties including color and linetype.

Use the Multiple option to chamfer more than one set of objects without
leaving the command.

Chamfer by Specifying Distances

The chamfer distance is the amount each object is trimmed or extended to
meet the chamfer line or to intersect the other. If both chamfer distances are
0, chamfering trims or extends the two objects until they intersect but does
not create a chamfer line. You can hold down Shift while selecting the objects
to override the current chamfer distances with a value of 0.

Fillet, Chamfer, Break, or Join Objects | 1133



In the following example, you set the chamfer distance to 0.5 for the first line
and 0.25 for the second line. After you specify the chamfer distance, you select
the two lines as shown.

Trim and Extend Chamfered Objects

By default, objects are trimmed when chamfered, but you can use the Trim
option to specify that they remain untrimmed.

Chamfer by Specify Length and Angle

You can chamfer two objects by specifying where on the first selected object
the chamfer line starts, and then the angle the chamfer line forms with this
object.

In this example, you chamfer two lines so that the chamfer line starts 1.5
units from the intersection along the first line and forms an angle of 30 degrees
with this line.
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Chamfer Polylines and Polyline Segments

If the two objects you select for chamfering are segments of a polyline, they
must be adjacent or separated by no more than one arc segment. If they are
separated by an arc segment, as shown in the illustration, chamfering deletes
the arc and replaces it with a chamfer line.

Chamfer an Entire Polyline

When you chamfer an entire polyline, each intersection is chamfered. For
best results, keep the first and second chamfer distances equal.

In this example, the chamfer distances are set to equal values.

When you chamfer an entire polyline, only the segments that are long enough
to accommodate the chamfer distance are chamfered. The polyline in the
following illustration has some segments too short to be chamfered.

To set chamfer distances

1 Click Home tab ➤ Modify panel ➤ Chamfer.

2 Enter d (Distances).
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3 Enter the first chamfer distance.

4 Enter the second chamfer distance.

5 Select the lines for chamfering.

Toolbar: Modify  
Command entry: CHAMFER

To chamfer two nonparallel line segments

1 Click Home tab ➤ Modify panel ➤ Chamfer.

2 Select the first line.

3 Select the second line.

Toolbar: Modify  
Command entry: CHAMFER

To chamfer by specifying chamfer length and angle

1 Click Home tab ➤ Modify panel ➤ Chamfer.

2 Enter a (Angle).

3 Enter the distance from the corner to be chamfered along the first line.

4 Enter the chamfer angle.

5 Select the first line. Then select the second line.

Toolbar: Modify  
Command entry: CHAMFER

To chamfer without trimming

1 Click Home tab ➤ Modify panel ➤ Chamfer.

2 Enter t (Trim Control).

3 Enter n (No Trim).
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4 Select the objects to chamfer.

Toolbar: Modify  
Command entry: CHAMFER

To chamfer an entire polyline

1 Click Home tab ➤ Modify panel ➤ Chamfer.

2 Enter p (Polyline).

3 Select the polyline.

The polyline is chamfered using the current chamfer method and the
default distances.

Toolbar: Modify  
Command entry: CHAMFER

To chamfer multiple sets of objects

1 Click Home tab ➤ Modify panel ➤ Chamfer.

2 Enter m (Multiple).

The main prompt is displayed.

3 Select the first line, or enter an option and complete the prompts for that
option and then select the first line.

4 Select the second line.

The main prompt is displayed again.

5 Select the first line for the next chamfer, or press Enter or Esc to end the
command.

Toolbar: Modify  
Command entry: CHAMFER
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Quick Reference

Commands

CHAMFER

Bevels the edges of objects.

System Variables

CHAMFERA

Sets the first chamfer distance when CHAMMODE is set to 0.

CHAMFERB

Sets the second chamfer distance when CHAMMODE is set to 0.

CHAMFERC

Sets the chamfer length when CHAMMODE is set to 1.

CHAMFERD

Sets the chamfer angle when CHAMMODE is set to 1.

CHAMMODE

Sets the input method for CHAMFER

TRIMMODE

Controls whether selected edges for chamfers and fillets are trimmed.

Break and Join Objects
You can break an object into two objects with or without a gap between them.
You can also join objects to make a single object.

Break Objects

Use BREAK to create a gap in an object, resulting in two objects with a gap
between them. BREAK is often used to create space for block or text.
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To break an object without creating a gap, specify both break points at the
same location. The fastest way to do this is to enter @0,0 at the prompt for
the second point.

You can create breaks in most geometric objects except

■ Blocks

■ Dimensions

■ Mlines

■ Regions

Join Objects

Use JOIN to combine similar objects into a single object. You can also create
complete circles and ellipses from arcs and elliptical arcs. You can join

■ Arcs

■ Elliptical arcs

■ Lines

■ Polylines

■ Splines

The object to which you want to join similar objects is called a source object.
Objects to be joined must be located in the same plane. Additional restrictions
for each type of objects are described in the JOIN command.

NOTE When joining two or more arcs (or elliptical arcs), the arcs are joined
counterclockwise beginning from the source object.

See also:

■ Modify or Join Polylines on page 1155

■ Modify Complex Objects on page 1153

To break an object

1 Click Home tab ➤ Modify panel ➤ Break.

2 Select the object to break.
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By default, the point at which you select the object is the first break point.
To select a different pair of break points, enter f (First) and specify the
first break point.

3 Specify the second break point.

To break an object without creating a gap, enter @0,0 to specify the
previous point.

Toolbar: Modify  
Command entry: BREAK

To join objects

1 Click Home tab ➤ Modify panel ➤ Join.

2 Select the source object to which you want to join objects.

3 Select one or more objects to join to the source object.

Valid objects include arcs, elliptical arcs, lines, polylines, and splines.
Additional restrictions for each type of objects are described in the JOIN
command.

Toolbar: Modify  
Command entry: JOIN

Quick Reference

Commands

BREAK

Breaks the selected object between two points.

JOIN

Joins similar objects to form a single, unbroken object.
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Use Grips to Edit Objects
Grips are small squares that are displayed at strategic points on objects that
you have selected with a pointing device. You can drag these grips to edit
objects directly and quickly.

Use Grip Modes
You can drag grips to perform any stretch, move, rotate, scale, or mirror
operations. The editing operation you choose to perform is called a grip mode.

Grips are small, solid-filled squares that are displayed at strategic points on
objects that you have selected with a pointing device. You can drag these grips
to stretch, move, rotate, scale, or mirror objects quickly.

When grips are turned on, you can select the objects you want to manipulate
before entering a command, and then you can manipulate the objects with
the pointing device.

NOTE Grips are not displayed on objects that are on locked layers.

To use a grip mode, select a grip (base grip) to act as the base point for the
action. (A selected grip is also called a hot grip.) Then select one of the grip
modes. You can cycle through these modes by pressing Enter or Spacebar. You
can also use shortcut keys or right-click to see all of the modes and options.

NOTE When a 2D object lies on a plane other than the current UCS, the object
is stretched on the plane on which it was created, not on the plane of the current
UCS.

Use Grips to Edit Objects | 1141



Work with Quadrant Grips

For quadrant grips on circles and ellipses, distance is measured from the center
point, not the selected grip. For example, in Stretch mode, you can select a
quadrant grip to stretch a circle and then specify a distance at the Command
prompt for the new radius. The distance is measured from the center of the
circle, not the selected quadrant. If you select the center point to stretch the
circle, the circle moves.

Select and Modify Multiple Grips

You can use more than one grip as the base grips for the action. When you
select more than one grip (also called multiple hot grip selection), the shape of
the object is kept intact between the selected grips. To select more than one
grip, press and hold the Shift key, and then select the appropriate grips.

Limit the Display of Grips

You can limit the display of grips on selected objects. The GRIPOBJLIMIT
system variable suppresses the display of grips when the initial selection set
includes more than the specified number of objects. If you add objects to the
current selection set, the limit does not apply. For example, if GRIPOBJLIMIT
is set to 20, you can select 15 objects and then add 25 objects to the selection,
and all objects display grips.

NOTE Grips are not displayed on objects that are on locked layers.

Stretch with Grips

You can stretch an object by moving selected grips to new locations. Grips
on text, block references, midpoints of lines, centers of circles, and point
objects move the object rather than stretching it. This is an excellent method
for moving block references and adjusting dimensions.

Move with Grips

You can move objects by the grip selected. Selected objects are highlighted
and are moved the direction and distance of the next point location you
specify.

Rotate with Grips

You can rotate selected objects around a base point by dragging and specifying
a point location. Alternatively, you can enter an angle value. This is an
excellent method for rotating block references.
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Scale with Grips

You can scale selected objects relative to a base point. Increase the size of an
object by dragging outward from the base grip and specifying a point location,
or decrease the size by dragging inward. Alternatively, you can enter a value
for relative scaling.

Mirror with Grips

You can mirror selected objects across a temporary mirror line. Turning Ortho
on helps you specify a vertical or horizontal mirror line.

See also:

■ Use Dynamic Input on page 668

■ Work with Dynamic Blocks in Drawings on page 1023

To turn on grips

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Selection tab, select Enable Grips.

3 Click OK.

Command entry: OPTIONS

To set the color of the unselected grip beneath the cursor

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Selection tab, click the arrow under Hover
Grip Color.

3 Select a color, or click Select Color to display the Select Color dialog box.

To limit the number of objects in the initial selection set that display grips

1 Click Tools menu  ➤ Options. 
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2 In the Options dialog box, Selection tab, enter a number in the Object
Selection Limit for Display of Grips box. The maximum is 32,767.

If you add objects to the current selection set, the limit does not apply.

To display grip tips for custom objects that support grip tips

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Selection tab, select Enable Grip Tips.

To cancel grip selection

■ Press Esc.

To stretch an object using grips

1 Select the object to stretch.

2 Select a base grip on the object.

The selected grip is highlighted, and Stretch, the default grip mode, is
active.

3 Move the pointing device and click.

The selected object is stretched as the grip moves.

NOTE To copy the selected object while you’re stretching it, press and hold the
Ctrl key while you’re stretching the object.

To stretch using more than one grip

1 Select several objects to stretch.

2 Hold down Shift and click several grips so that they are highlighted.

3 Release Shift and select a grip as the base grip by clicking the grip.

The default grip mode, Stretch, is active.

4 Move the pointing device and click.

The selected grips act in unison and the selected objects are stretched.
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To move objects using grips

1 Select the objects to move.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and Stretch, the default grip mode, is
active.

3 Cycle through the grip modes by pressing Enter until the grip mode Move
appears.

Alternatively, you can right-click to display a shortcut menu of modes
and options.

4 Move the pointing device and click.

The selected objects are moved along with the grip.

NOTE To copy the selected object while you’re moving it, press and hold the Ctrl
key while you’re moving the object.

To rotate objects using grips

1 Select the objects to rotate.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and Stretch, the default grip mode, is
active.

3 Cycle through the grip modes by pressing Enter until the grip mode
Rotate appears.

Alternatively, you can right-click to display shortcut menu modes and
options.

4 Move the pointing device and click.

The selected objects are rotated around the base grip.

NOTE To copy the selected object while you’re rotating it, press and hold the Ctrl
key while you’re rotating the object.

To scale objects using grips

1 Select the objects to scale.

2 Select a base grip on an object by clicking the grip.
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The selected grip is highlighted, and Stretch, the default grip mode, is
active.

3 Cycle through the grip modes by pressing Enter until the grip mode Scale
appears.

Alternatively, you can right-click to display shortcut menu modes and
options.

4 Enter the scale factor or drag and click to specify a new scale.

NOTE To copy the selected object while you’re scaling it, press and hold the Ctrl
key while you’re scaling the object.

To mirror objects using grips

1 Select the objects to mirror.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and the default grip mode, Stretch, is
active.

3 Cycle through the grip modes by pressing Enter until the grip mode
Mirror appears.

Alternatively, you can right-click to display shortcut menu modes and
options.

4 Click to specify the second point of the mirror line.

Turning on Ortho mode is often useful when mirroring objects.

Quick Reference

Commands

OPTIONS

Customizes the program settings.

System Variables

GRIPBLOCK

Controls the display of grips in blocks.
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GRIPCOLOR

Controls the color of unselected grips.

GRIPHOT

Controls the color of selected grips.

GRIPHOVER

Controls the fill color of an unselected grip when the cursor pauses over it.

GRIPOBJLIMIT

Suppresses the display of grips when the selection set includes more than
the specified number of objects.

GRIPS

Controls the use of selection set grips for the Stretch, Move, Rotate, Scale,
and Mirror Grip modes.

GRIPSIZE

Sets the size of the grip box in pixels.

GRIPTIPS

Controls the display of grip tips when the cursor hovers over grips on dynamic
blocks and custom objects that support grip tips.

Make Multiple Copies with Grips
You can create multiple copies of objects as you modify them with any of the
grip modes.

For example, by using the Copy option, you can rotate the selected objects,
leaving copies at each location you specify with the pointing device.

You can also make multiple copies by holding down Ctrl as you select the
first point. For example, with the Stretch grip mode, you can stretch an object,
such as a line, and then copy it to any point in the drawing area. Multiple
copies continue being made until you turn off grips.
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NOTE When you use grips to make multiple copies of an object that contains
multiple , only the current scale representation is copied.

Define an Offset Snap or a Rotation Snap

You can place multiple copies at regularly spaced intervals with an offset snap.
The offset snap is defined by the distance between an object and the next
copy. In the lighting layout below, the first copy of the light fixture symbol
is placed at an offset of two units. All subsequent copies are then placed two
units apart.

If you hold down Ctrl while you select multiple copy points with the pointing
device, the graphics cursor snaps to an offset point based on the last two points
you selected. In the illustration below, the midpoint of line 1 is at coordinate
8,5. Based on that midpoint, line 2 was copied using the Ctrl key and Stretch
grip mode; its midpoint is at 9,5. The third line snaps to an offset based on
the coordinate values 10,5.

Similarly, you can place multiple copies at angular intervals around a base
grip with a rotation snap. The rotation snap is defined as the angle between
an object and the next copy when you are using Rotate grip mode. Hold down
Ctrl to use the rotation snap.
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To create copies in any grip mode

1 Select the objects to copy.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and the default grip mode, Stretch, is
active.

3 Cycle through the grip modes by pressing Enter until the grip mode you
want appears.

Alternatively, you can right-click to display shortcut menu modes and
options.

4 Enter c (Copy) or press and hold the Ctrl key while you stretch, move,
rotate, or scale.

Copies continue being made until you turn off grips.

5 Enter or specify the additional input required for the current grip mode.

6 Turn off grips by pressing Enter, Spacebar, or Esc.

To create an offset snap for multiple copies using grips

1 Select the objects to copy.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and the default grip mode, Stretch, is
active.

3 Cycle through the grip modes by pressing Enter until the grip mode Move
appears.

Alternatively, you can right-click to display shortcut menu modes and
options.
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4 Enter c (Copy).

5 Move the cursor and click.

The offset snap is the distance between the grip you selected and the
location you specified for the copy.

6 Hold down Ctrl and place additional copies by specifying additional
locations.

These copies are created at the same offset snap distance as the last copy.

7 Turn off grips by pressing Enter, Spacebar, or Esc.

To create a rotation snap for multiple rotated copies using grips

1 Select the objects to rotate.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and the default grip mode, Stretch, is
active.

3 Cycle through the grip modes by pressing Enter until the grip mode
Rotate appears.

Alternatively, you can right-click to display shortcut menu modes and
options.

4 Enter c (Copy).

5 Move the pointing device and click.

The rotation snap is the angle between the grip you selected and the
location you specified for the copy.

6 Hold down Ctrl and place additional copies by specifying additional
locations.

These copies are created at the same rotation snap angle as the first copy.

7 Turn off grips by pressing Enter, Spacebar, or Esc.

To mirror objects and retain the originals using grips

1 Select the objects to mirror.

2 Select a base grip on an object by clicking the grip.

The selected grip is highlighted, and the default grip mode, Stretch, is
active.
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3 Cycle through the grip modes by pressing Enter until the grip mode
Mirror appears.

Alternatively, you can right-click to display shortcut menu modes and
options.

4 Hold down Ctrl (or enter c for Copy) to retain the original image, and
specify the second point of the mirror line.

Turning on Ortho mode is often useful when mirroring objects.

5 Turn off grips by pressing Enter, Spacebar, or Esc.

Quick Reference

Commands

OPTIONS

Customizes the program settings.

System Variables

GRIPBLOCK

Controls the display of grips in blocks.

GRIPCOLOR

Controls the color of unselected grips.

GRIPHOT

Controls the color of selected grips.

GRIPS

Controls the use of selection set grips for the Stretch, Move, Rotate, Scale,
and Mirror Grip modes.

GRIPSIZE

Sets the size of the grip box in pixels.

Control Grips in Blocks
You can specify whether a block displays a single grip or multiple grips.
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You can specify whether a selected block reference displays a single grip at its
insertion point or displays multiple grips associated with the objects grouped
within the block.

See also:

■ Specify Grips for Dynamic Blocks on page 987

To turn grips within blocks on or off

1 Click Tools menu  ➤ Options. 

2 In the Options dialog box, Selection tab, select or clear Enable Grips
Within Blocks.

3 Click OK.

Command entry: OPTIONS

Quick Reference

Commands

OPTIONS

Customizes the program settings.

System Variables

GRIPBLOCK

Controls the display of grips in blocks.

GRIPCOLOR

Controls the color of unselected grips.
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GRIPHOT

Controls the color of selected grips.

GRIPS

Controls the use of selection set grips for the Stretch, Move, Rotate, Scale,
and Mirror Grip modes.

GRIPSIZE

Sets the size of the grip box in pixels.

Modify Complex Objects
Additional editing operations are available for complex objects, such as blocks,
dimensions, hatches, and polylines.

Disassociate Compound Objects (Explode)
You can convert a compound object, such as a polyline, dimension, hatch,
or block reference, into individual elements.

You can explode a compound object, such as a polyline, dimension, hatch,
or block reference, to convert it into individual elements. For example,
exploding a polyline breaks it down to simple lines and arcs. Exploding a
block reference or an associative dimension replaces it with copies of the
objects that compose the block or dimension.

Explode Dimensions and Hatches

When you explode a dimension or a hatch, all associativity is lost and the
dimension or hatch object is replaced by individual objects such as lines, text,
points, and 2D solids. To explode dimensions automatically when you create
them, set the DIMASSOC system variable to 0.

Explode Polylines

When you explode a polyline, any associated width information is discarded.
The resulting lines and arcs follow the polyline's centerline. If you explode a
block that contains a polyline, you need to explode the polyline separately.
If you explode a donut, its width becomes 0.
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Explode Block References

If you explode a block with attributes, the attribute values are lost, leaving
only the attribute definitions. The colors and linetypes of objects in exploded
block references can change.

Explode External References

An external reference (xref) is a drawing file linked (or attached) to another
drawing. You cannot explode xrefs and their dependent blocks.

To explode an object

1 Click Home tab ➤ Modify panel ➤ Explode. 

2 Select the objects to be exploded.

For most objects, exploding has no visible effect.

Toolbar: Modify  
Command entry: EXPLODE

Quick Reference

Commands

EXPLODE

Breaks a compound object into its component objects.

XPLODE

Breaks a compound object into its component objects.

System Variables

DIMASSOC

Controls the associativity of dimension objects and whether dimensions are
exploded.

EXPLMODE

Controls whether the EXPLODE command supports nonuniformly scaled
(NUS) blocks.
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Modify or Join Polylines
Additional editing operations are available for changing the shape and display
of polyline objects. You can also join separate polylines.

You can modify polylines in several ways using PEDIT, the Properties palette,
or grips including the following:

■ Move, add, or delete individual vertices

■ Set a uniform width for the entire polyline or control the width of each
segment

■ Create an approximation of a spline called a spline-fit polyline

■ Display noncontinuous linetypes with or without a dash before and after
each vertex

■ Change the orientation of text in a linetype assigned to a polyline by
reversing its direction

Join Polyline Segments

You can join a line, an arc, or another polyline to an open polyline if their
ends connect or are close to each other.

If the ends are not coincident but are within a distance that you can set, called
the fuzz distance, the ends are joined by either trimming them, extending
them, or connecting them with a new segment.

Spline-fit polylines return to their original shape when joined. Polylines cannot
be joined into a Y shape.

If the properties of several objects being joined into a polyline differ, the
resulting polyline inherits the properties of the first object that you selected.

Modify a Segment Within a Polyline

You can modify a segment in a polyline using the MOVE, ROTATE, or SCALE
commands. You select the single arc or line segment, also called a subobject,
within a polyline by pressing Ctrl when you click it.

You can also use the Stretch, Move, Rotate, and Scale grip modes to modify
the polyline segment. Properties of polyline segments such as color or linetype,
cannot be modified individually, but you can use the Properties palette to
modify the width of individual segments.
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See also:

■ Trim or Extend Objects on page 1116

■ Break and Join Objects on page 1138

To modify a polyline

1 Click Home tab ➤ Modify panel ➤ Edit Polyline.

2 Select the polyline to modify.

NOTE You can select a single arc or line segment, also called a subobject,
within a polyline by pressing the Ctrl key when you click it.

3 If the selected object is a spline, line, or an arc, the following prompt is
displayed:

Object selected is not a polyline.

Do you want it to turn into one? <Y>: Enter y or n, or press Enter

If you enter y, the object is converted into a single-segment 2D polyline
that you can edit.

Before the selected spline is converted to a polyline, the following prompt
is displayed:

Specify a precision <10>: Enter a new precision value or press Enter

The PLINECONVERTMODE system variable determines whether the
polylines are created with linear or arc segments. When the PEDITACCEPT
system variable is set to 1, this prompt is suppressed, and the selected
object is automatically converted to a polyline.

4 Edit the polyline by entering one or more of the following options:

■ Enter c (Close) to create a closed polyline.

■ Enter j (Join) to join contiguous lines, splines, arcs, or polylines.

■ Enter w (Width) to specify a new uniform width for the entire polyline.

■ Enter e (Edit Vertex) to edit a vertex.

■ Enter f (Fit) to create a series of arcs joining each pair of vertices.

■ Enter s (Spline) to create an approximation of a spline.

■ Enter d (Decurve) to remove extra vertices inserted by a fit or spline
curve and to straighten all segments of the polyline.
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■ Enter L (Ltype Gen) to generate the linetype in a continuous pattern
through the vertices of the polyline.

■ Enter r (Reverse) to reverse the order of vertices of the polyline.

■ Enter u (Undo) to reverse actions back to the start of PEDIT.

5 Enter x (Exit) to end a command option. Press Enter to exit the PEDIT
command.

Toolbar: Modify II  
Command entry: PEDIT

To reverse lines, polylines, splines, or helixes

1 Click Home tab ➤  Modify panel ➤  Reverse.

2 Select a line, polyline, spline, or helix to reverse.

3 Press Enter to end the command.

Command entry: REVERSE

To join polylines, splines, lines, and arcs into a single polyline

1 Click Home tab ➤ Modify panel ➤ Edit Polyline.

2 Select a polyline, spline, line, or arc to edit. If you selected a spline, line,
or arc, press Enter to convert the selected object into a polyline.

3 Enter j (Join).

4 Select one or more polylines, splines, lines, or arcs that are located end
to end.

Each selected polyline, spline, line, or arc is now joined into a single
polyline.

5 Press Enter to end the command.

Toolbar: Modify II  
Command entry: PEDIT
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To delete a vertex in a polyline

1 Click Home tab ➤ Modify panel ➤ Edit Polyline.

2 Select a polyline.

3 Enter e (Edit vertex).

The first vertex is marked with an X. Use the Next option to move the X
to the vertex preceding the one that you want to delete.

4 Enter s (Straighten).

5 Use the Next option to move the X to the vertex immediately following
the one that you want to delete.

6 Enter g (Go).

The vertex on the polyline is deleted. The vertices on either side of the
deleted vertex are joined by a straight polyline segment.

7 Enter x (Exit) to end editing vertices.

8 Press Enter to end the command.

Toolbar: Modify II  
Command entry: PEDIT

To taper the width of individual polyline segments

1 Click Home tab ➤ Modify panel ➤ Edit Polyline.

2 Select the polyline to edit.

3 Enter e (Edit Vertex).

The first vertex is marked with an X. Move to the appropriate vertex with
Next or Previous.

4 Enter w (Width).

5 Enter new starting and ending widths, and press Enter to move to the
next vertex. Repeat steps 4 and 5 for each segment.

6 Enter u (Undo) to reverse actions back to the start of PEDIT.

7 Enter x (Exit) to end editing vertices.

8 Press Enter to end the command.
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Toolbar: Modify II  
Command entry: PEDIT

Quick Reference

Commands

PEDIT

Edits polylines and 3D polygon meshes.

JOIN

Joins similar objects to form a single, unbroken object.

REVERSE

Reverses the order of vertices of the selected lines, polylines, splines, and
helixes.

System Variables

PEDITACCEPT

Suppresses display of the Object Selected Is Not a Polyline prompt in PEDIT.

PLINECONVERTMODE

Specifies the fit method used in converting splines to polylines.

SPLFRAME

Controls the display of splines and spline-fit polylines.

SPLINESEGS

Sets the number of line segments to be generated for each spline-fit polyline
generated by the Spline option of the PEDIT command.

SPLINETYPE

Sets the type of curve generated by the Spline option of the PEDIT command.

SURFTYPE

Controls the type of surface-fitting to be performed by the Smooth option
of the PEDIT command.
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SURFU

Sets the surface density for PEDIT Smooth in the M direction and the U
isolines density on surface objects.

SURFV

Sets the surface density for PEDIT Smooth in the N direction and the V
isolines density on surface objects.

Modify Splines
Additional editing options are available for changing the shape of spline
objects.

In addition to the general editing operations available for most objects, there
are additional options available for editing splines with SPLINEDIT.

You also can change the tolerance of the spline. Tolerance refers to how closely
the spline fits the set of fit points you specify. The lower the tolerance, the
more closely the spline fits the points.

Edit Splines with Grips

When you select a spline, grips are displayed on its fit points (the GRIPS system
variable must be set to 1). You can use grips to modify the shape and location
of the spline.

After certain operations, fit points are discarded and grips are displayed on
control points instead. These operations include trimming the spline, moving
the control points, and purging the fit data. If the spline's control frame is
turned on (the SPLFRAME system variable is set to 1), grips are displayed on
both the spline's control points and its fit points, when available.

You can delete fit points of a spline, add fit points for greater accuracy, or
move fit points to alter the shape of a spline. You can open or close a spline
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and edit the spline start and end tangents. Spline direction is reversible. You
can change the tolerance of the spline also. Tolerance refers to how closely the
spline fits the set of fit points you specify. The lower the tolerance, the more
closely the spline fits the points.

Refine the Shape of a Spline

You can refine a spline by increasing the number of control points in one
portion of the spline or by changing the weight of specific control points.
Increasing the weight of a control point pulls the spline more towards that
point. You can also refine a spline by changing its order. A spline's order is
the degree of the spline polynomial + 1. A cubic spline, for example, has order
4. The higher a spline's order, the more control points it has.

Consider the following example. You have created a spline to represent a
geographic contour. Grips are turned on, and you need to move the fourth
fit point to increase accuracy. When you select the spline, grips appear at the
control points. If you created the spline by fitting it through a set of points,
and you have not purged this information using the Purge option of the
SPLINEDIT command, and you select the Fit Data option, grips appear at the
fit points on the selected spline instead of at the control points.

See also:

■ Break and Join Objects on page 1138
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To edit a spline

1 Click Home tab ➤ Modify panel ➤ Edit Spline.

2 Select the spline to modify.

3 Edit the spline by entering one or more of the following options:

■ Enter f (Fit) to edit the fit data that defines the spline.

■ Enter c (Close) to change an open spline into a continuous, closed
loop.

■ Enter m (Move Vertex) to move a fit point to a new location.

■ Enter r (Refine) to modify a spline definition by adding and weighting
control points and elevating the order of the spline.

■ Enter e (Reverse) to reverse the direction of the spline.

■ Enter p (Convert to Polyline) to convert the spline to polyline.

■ Enter u (Undo) to cancel the last editing action.

4 Enter x (Exit) to end the command.

Toolbar: Modify II  
Command entry: SPLINEDIT

To convert a spline to a polyline

1 Click Home tab ➤ Modify panel ➤ Edit Spline.

2 Select the spline to convert.

3 Select the Convert to Polyline option.

4 Specify a precision value or press Enter to end the command.

Toolbar: Modify II  
Command entry: SPLINEDIT
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Quick Reference

Commands

JOIN

Joins similar objects to form a single, unbroken object.

SPLINEDIT

Edits a spline or spline-fit polyline.

REVERSE

Reverses the order of vertices of the selected lines, polylines, splines, and
helixes.

System Variables

PLINECONVERTMODE

Specifies the fit method used in converting splines to polylines.

SPLFRAME

Controls the display of splines and spline-fit polylines.

Modify Helixes
You can use grips or the Properties palette to modify the shape and size of a
helix.

You can use the grips on a helix to change the following properties:

■ Start point

■ Base radius

■ Top radius

■ Height

■ Location

When you use a grip to change the base radius of a helix, the top radius scales
to maintain the current ratio. Use the Properties palette to change the base
radius independent of the top radius.
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You can use the Properties palette to change other helix properties, such as

■ Number of turns (Turns)

■ Turn height

■ Direction of the twist — clockwise (CW) or counterclockwise (CCW)

With the Constrain property, you can specify that the Height, Turns, or Turn
Height properties of the helix are constrained. The Constrain property affects
how the helix changes when the Height, Turns, or Turn Height properties are
changed either through the Properties palette or through grip editing. The
table below shows the behavior of the helix depending on which property is
constrained.

Effect on these helix propertiesProperty to
change

Constrained
property

Turn HeightTurnsHeight

ChangedFixedChangedHeightHeight

ChangedChangedFixedTurns

ChangedChangedFixedTurn Height

ChangedFixedChangedHeightTurns

ChangedChangedFixedTurns

ChangedFixedChangedTurn Height

FixedChangedChangedHeightTurn Height

FixedChangedChangedTurns

ChangedChangedFixedTurn Height

See also:

■ Draw Helixes on page 839
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Quick Reference

Commands

HELIX

Creates a 2D spiral or 3D spring.

Modify Multilines
Multiline objects are composed of 1 to 16 parallel lines, called elements. To
modify multilines or their elements, you can use common editing commands,
a multiline editing command, and multiline styles.

Special multiline editing features are available with the MLEDITcommand
including the following:

■ Add or delete a vertex

■ Control the visibility of corner joints

■ Control the style of intersection with other multilines

■ Open or close gaps in a multiline object

Add and Delete Multiline Vertices

You can add or delete any vertex in a multiline.

Edit Multiline Intersections

If you have two multilines in a drawing, you can control the way they intersect.
Multilines can intersect in a cross or a T shape, and the crosses or T shapes
can be closed, open, or merged.
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Edit Multiline Styles

You can use MLSTYLE to edit multiline styles to change the properties of
multiline elements or the end caps and background fill of subsequently created
multilines.

Multiline styles control the number of line elements in a multiline and the
color, linetype, lineweight, and offset of each element. You can also modify
the display of joints, end caps, and background fill.

Multiline styles have the following limitations:

■ You cannot edit the element and multiline properties of the STANDARD
multiline style or any multiline style already used in the drawing.

■ To edit an existing multiline style, you must do so before you draw any
multilines in that style.

NOTE If you use MLSTYLE to create a multiline style without saving it, and then
select another style or create a new style, the first MLSTYLE properties are lost. To
maintain the properties, save each multiline style to an MLN file before creating
a new one.

Use Common Editing Commands on Multilines

You can use most of the common editing commands on multilines except

■ BREAK

■ CHAMFER

■ FILLET

■ LENGTHEN

■ OFFSET

To perform these operations, first use EXPLODE to replace the multiline object
with separate line objects.
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NOTE If you trim or extend a multiline object, only the first boundary object
encountered determines the shape of the end of the multiline. A multiline cannot
have a complex boundary at its endpoint.

See also:

■ Draw Multiline Objects on page 810

To delete a vertex from a multiline

1 Click Modify menu  ➤ Object ➤ Multiline.

2 In the Multiline Edit Tools dialog box, select Delete Vertex.

3 In the drawing, specify the vertex to delete. Press Enter.

Command entry: MLEDIT

To create a closed cross intersection

1 Click Modify menu  ➤ Object ➤ Multiline.

2 In the Multiline Edit Tools dialog box, select Closed Cross.

3 Select the multiline for the foreground.

4 Select the multiline for the background.

The intersection is modified. You can continue selecting intersecting
multilines to modify, or press Enter to end the command. Press Enter
again to redisplay the Multiline Edit Tools dialog box.

To edit a multiline style

1 Click Format menu  ➤ Multiline Style. 

2 In the Multiline Styles dialog box, select the style name from the list.
Click Modify.

3 Click Element Properties.

4 In the Modify Multiline Styles dialog box, change the settings as needed.

5 Click OK.
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6 In the Multiline Styles dialog box, click Save to save the changes to the
style in the MLN file.

7 Click OK.

Command entry: MLSTYLE

Quick Reference

Commands

MLEDIT

Edits multiline intersections, breaks, and vertices.

MLSTYLE

Creates, modifies, and manages multiline styles.
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Work with 3D Models
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Create 3D Models

Use three-dimensional models to help you visualize and test your designs in 3D space.

Overview of 3D Modeling
With 3D modeling, you can design using solid, surface, and mesh models.

Create new 3D solids and surfaces, or sweep, combine, and modify existing
objects. Create or convert objects to mesh to obtain enhanced smoothing and
creasing capabilities. You can also use simulated surfaces (3D thickness), or
wireframe models to represent 3D objects.

Solid Models

A solid model is a 3D representation that has such properties as mass, volume,
center of gravity, and moments of inertia.

Solid models contain the most information and are the least ambiguous of the
3D modeling types. You can analyze solids for their mass properties and export
data to applications that do NC (numerical control) milling or FEM (finite
element method) analysis.

20
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Use solid models as the building blocks for your model. You can start with
primitive solids such as cones, boxes, cylinders, and pyramids. Draw a custom
polysolid extrusion or use various sweeping operations to create solids whose
shapes conform to a path you specify. Then modify or recombine objects to
create new solid shapes.

Complex solid shapes are easier to construct and edit than legacy wireframe
models. However, if needed, you can explode a solid to break it down to
regions, bodies, surfaces, and wireframe objects.

NOTE When you work with 3D solids, you occasionally see messages that refer
to ASM or ShapeManager. ShapeManager® is the Autodesk technology that provides
3D solid modeling capabilities to AutoCAD and other products.

Surface Model

A surface model represents an infinitely thin shell that corresponds to the
shape of a 3D object.

You create surface models using some of the same tools that you use for solid
models. For example, you can use sweeping, lofting, and revolving to create
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a surface model. The difference is that surface models are open ended. Solid
models are closed.

Mesh Model

A mesh model consists of vertices, edges, and faces that use polygonal
representation (including triangles and quads) to define a 3D shape.

Unlike solid models, mesh has no mass properties. However, as with 3D solids,
you can create primitive mesh forms such as boxes, cones, and pyramids,
starting in AutoCAD 2010. You can then modify mesh models in ways that
are not available for 3D solids or surfaces. For example you can apply creases,
splits, and increasing levels of smoothness. You can drag mesh subobjects
(faces, edges, and vertices) to deform the object. To achieve more granular
results, you can refine the mesh in specific areas before modifying it.

Use mesh models to provide the hiding, shading, and rendering capabilities
of a solid model without the physical properties such as mass, moments of
inertia, and so on.

Advantages of 3D Modeling

Modeling in 3D has several advantages. You can

■ View the model from any vantage point

■ Generate reliable standard and auxiliary 2D views automatically

■ Create sections and 2D drawings

■ Remove hidden lines and do realistic shading

■ Check interferences and perform engineering analysis
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■ Add lighting and create realistic rendering

■ Navigate through the model

■ Use the model to create an animation

■ Extract manufacturing data

See also:

■ Enter 3D Coordinates on page 637

■ Specify Workplanes in 3D (UCS) on page 650

■ Use the Dynamic UCS with Solid Models on page 660

Quick Reference

Commands

BOX

Creates a 3D solid box.

CONE

Creates a 3D solid cone.

CYLINDER

Creates a 3D solid cylinder.

EXTRUDE

Extends the dimensions of a 2D object or 3D face into 3D space.

LOFT

Creates a 3D solid or surface in the space between several cross sections.

MESH

Creates a 3D mesh primitive object such as a box, cone, cylinder, pyramid,
sphere, wedge, or torus.

POLYSOLID

Creates a 3D wall-like polysolid.
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PYRAMID

Creates a 3D solid pyramid.

REVOLVE

Creates a 3D solid or surface by sweeping a 2D object around an axis.

SPHERE

Creates a 3D solid sphere.

SWEEP

Creates a 3D solid or surface by sweeping a 2D object along a path.

TORUS

Creates a donut-shaped 3D solid.

WEDGE

Creates a 3D solid wedge.

System Variables

DELOBJ

Controls whether geometry used to create 3D objects is retained or deleted.

PSOLWIDTH

Controls the default width for a swept solid object created with the
POLYSOLID command.

PSOLHEIGHT

Controls the default height for a swept solid object created with the
POLYSOLID command.

Create 3D Solids and Surfaces
Create 3D solids and surfaces from primitives or by combining or extending
existing objects.

Overview of Creating 3D Solids and Surfaces
Three-dimensional solid objects often start as one of several basic shapes, or
primitives, that you can then modify and recombine. A 3D solid or surface
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can also be the result of extruding a 2D shape to follow a specified path in 3D
space.

About Solid Primitives

You can create several basic 3D shapes, known as solid primitives: boxes, cones,
cylinders, spheres, wedges, pyramids, and tori (donuts).

By combining primitive shapes, you can create more complex solids. For
example, you can join two solids, subtract one from the other, or create a
shape based on the intersection of their volumes.

About Solids Based on Other Objects

You can also create 3D solids and surfaces from existing objects.

The following methods are available:

■ Sweep. Extends a 2D object along a path.
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■ Extrusion. Extends the shape of a 2D object in a perpendicular direction
into 3D space.

■ Revolve. Sweeps a 2D object around an axis.

■ Loft. Extends the contours of a shape between one or more open or closed
objects.

■ Slice. Divides a solid object into two separate 3D objects.

■ Conversion. Converts mesh objects and planar objects with thickness into
solids and surfaces.

Use Visual Styles with 3D Objects

Solids and surfaces can be displayed in one of several visual styles that are
applied to the viewport.

Quick Reference

Commands

BOX

Creates a 3D solid box.

CONE

Creates a 3D solid cone.

CONVTOSOLID

Converts 3D meshes and polylines and circles with thickness to 3D solids.
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CONVTOSURFACE

Converts objects to 3D surfaces.

CYLINDER

Creates a 3D solid cylinder.

EXTRUDE

Extends the dimensions of a 2D object or 3D face into 3D space.

INTERSECT

Creates a 3D solid, surface, or 2D region from overlapping solids, surfaces,
or regions.

INSERT

Inserts a block or drawing into the current drawing.

LOFT

Creates a 3D solid or surface in the space between several cross sections.

PYRAMID

Creates a 3D solid pyramid.

REVOLVE

Creates a 3D solid or surface by sweeping a 2D object around an axis.

SLICE

Creates new 3D solids and surfaces by slicing, or dividing, existing objects.

SUBTRACT

Combines selected 3D solids, surfaces, or 2D regions by subtraction.

SWEEP

Creates a 3D solid or surface by sweeping a 2D object along a path.

TORUS

Creates a donut-shaped 3D solid.

UNION

Combines selected 3D solids, surfaces, or 2D regions by addition.

VISUALSTYLES

Creates and modifies visual styles and applies a visual style to a viewport.
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WEDGE

Creates a 3D solid wedge.

System Variables

FACETRES

Adjusts the smoothness of shaded and rendered objects and objects with
hidden lines removed.

ISOLINES

Specifies the number of contour lines per surface on objects.

Create 3D Solid Primitives
Start with standard shapes known as solid primitives to create boxes, cones,
cylinders, spheres, tori (donuts), wedges, and pyramids.

Create a Solid Box
Create a rectangular or cubical solid box.

The base of the box is always drawn parallel to the XY plane of the current
UCS (workplane).
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Box Creation Options

Use the following options to control the size and rotation of the boxes you
create:

■ Create a cube. Use the Cube option of the BOX command to create a box
with sides of equal length.

■ Specify rotation. Use the Cube or Length option if you want to set the
rotation of the box in the XY plane.

■ Start from the center point. Use the Center Point option to create a box
using a specified center point.

To create a solid box based on two points and a height

1 Click Home tab ➤ Modeling panel ➤ Box.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height.

Toolbar: Modeling  
Command entry: BOX

To create a solid box based on length, width, and height

1 Click Home tab ➤ Modeling panel ➤ Box.

2 Specify the first corner of the base.

3 At the Command prompt, enter l (Length). Specify the length of the base.

4 Specify the width of the base.

5 Specify the height.

Toolbar: Modeling  
Command entry: BOX
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To create a solid box based on a center point, corner of base, and height

1 Click Home tab ➤ Modeling panel ➤ Box.

2 At the Command prompt, enter c (Center). Specify the center point of
the base.

3 To set the location of a corner of the base, use one of the following
methods:

■ To set the length and width simultaneously: Specify the location of
one corner of the base.

■ To set the length and width separately: At the Command prompt,
enter l (Length) and specify the length. Then specify the width.

4 Specify the height.

Toolbar: Modeling  
Command entry: BOX

To create a solid cube

1 Click Home tab ➤ Modeling panel ➤ Box.

2 Specify the first corner, or enter c (Center) to specify the center point of
the base.

3 At the Command prompt, enter c (Cube). Specify the length of the cube
and a rotation angle.

The length value sets both the width and height of the cube.

Toolbar: Modeling  
Command entry: BOX

Quick Reference

Commands

BOX

Creates a 3D solid box.
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System Variables

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Solid Wedge
Create a solid wedge with rectangular or cubical faces.

The base of the wedge is drawn parallel to the XY plane of the current UCS
with the sloped face opposite the first corner. The height of the wedge is
parallel to the Z axis.

Wedge Creation Options

Use the following options to control the size and rotation of the wedges you
create:

■ Create a wedge with sides of equal length. Use the Cube option of the
WEDGE command.
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■ Specify rotation. Use the Cube or Length option if you want to set the
rotation of the wedge in the XY plane.

■ Start from the center point. Use the Center Point option to create a wedge
using a specified center point.

To create a solid wedge based on two points and a height

1 Click Home tab ➤ Modeling panel ➤ Wedge.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height of the wedge.

Toolbar: Modeling  
Command entry: WEDGE

To create a solid wedge based on length, width, and height

1 Click Home tab ➤ Modeling panel ➤ Wedge.

2 Specify the first corner of the base.

3 At the Command prompt, enter l (Length). Specify the length of the base.

4 Specify the width of the base.

5 Specify the height of the wedge.

Toolbar: Modeling  
Command entry: WEDGE

To create a solid wedge based on a center point, corner of base, and height

1 Click Home tab ➤ Modeling panel ➤ Wedge.

2 At the Command prompt, enter c (Center). Specify the center point of
the base.
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3 To set the location of a corner of the base, use one of the following
methods:

■ To set the length and width simultaneously: Specify the location of one
corner of the base.

■ To set the length and width separately: At the Command prompt, enter
l (Length) and specify the length. Then specify the width.

4 Specify the height of the wedge.

Toolbar: Modeling  
Command entry: WEDGE

To create a solid wedge with equal length, width, and height

1 Click Home tab ➤ Modeling panel ➤ Wedge.

2 Specify the first corner or enter c (Center) to set the center point of the
base.

3 At the Command prompt, enter c (Cube). Specify the length of the wedge
and a rotation angle.

The length value sets both the width and height of the wedge.

Toolbar: Modeling  
Command entry: WEDGE

Quick Reference

Commands

WEDGE

Creates a 3D solid wedge.

System Variables

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.
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Create a Solid Cone
Create a pointed or frustum of a cone with a circular or elliptical base.

By default, the base of the cone lies on the XY plane of the current UCS. The
height of the cone is parallel to the Z axis.

Cone Creation Options

Use the following options to control the size and rotation of the cones you
create:

■ Set the height and orientation. Use the Axis Endpoint option of the CONE
command. Use the Top Radius option to specify the axis endpoint as the
point of the cone or the center of the top face. The axis endpoint can be
located anywhere in 3D space.

■ Create a frustum of a cone. Use the Top Radius option of the CONE
command to create a frustum, which tapers to an elliptical or planar face.

The Frustum tool is also available from the Modeling tab of the tool palette.
You can also use grips to modify the tip of a cone and convert it to a flat
face.

■ Specify circumference and base plane. The 3P (Three Points) option of the
CONE command defines the size and plane of the base of the cone
anywhere in 3D space.

■ Define the angle of the taper. To create a conical solid that requires a
specific angle to define its sides, draw a 2D circle. Then use EXTRUDE and

Create 3D Solid Primitives | 1185



the Taper Angle option to taper the circle at an angle along the Z axis. This
method, however, creates an extruded solid, not a true solid cone primitive.

See also:

■ Use Grips to Edit 3D Solids and Surfaces on page 1291

To create a solid cone with a circular base

1 Click Home tab ➤ Modeling panel ➤ Cone.

2 Specify the center point of the base.

3 Specify the radius or diameter of the base.

4 Specify the height of the cone.

Toolbar: Modeling  
Command entry: CONE

To create a solid cone with an elliptical base

1 Click Home tab ➤ Modeling panel ➤ Cone.

2 At the Command prompt, enter e (Elliptical).

3 Specify the start point of first axis.

4 Specify the endpoint of the first axis.

5 Specify the endpoint (length and rotation) of the second axis.

6 Specify the height of the cone.

Toolbar: Modeling  
Command entry: CONE

To create a frustum of a solid cone

1 Click Home tab ➤ Modeling panel ➤ Cone.

2 Specify the center point of the base.

3 Specify the radius or diameter of the base.
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4 At the Command prompt, enter t (Top radius). Specify the top radius.

5 Specify the height of the cone.

Toolbar: Modeling  
Command entry: CONE

To create a solid cone with the height and orientation specified by the axis
endpoint

1 Click Home tab ➤ Modeling panel ➤ Cone.

2 Specify the center point of the base.

3 Specify the radius or diameter of the base.

4 At the Command prompt, enter a (Axis endpoint). Specify the endpoint
and rotation of the cone.

This endpoint can be located anywhere in 3D space.

Toolbar: Modeling  
Command entry: CONE

Quick Reference

Commands

CONE

Creates a 3D solid cone.

System Variables

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Solid Cylinder
Create a solid cylinder with a circular or elliptical base.
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By default, the base of the cylinder lies on the XY plane of the current UCS.
The height of the cylinder is parallel to the Z axis.

Cylinder Creation Options

Use the following options to control the size and rotation of the cylinders you
create:

■ Set rotation. Use the Axis Endpoint option of the CYLINDER command
to set the height and rotation of the cylinder. The center point of the top
plane of the cylinder is the axis endpoint, which can be located anywhere
in 3D space.

■ Use three points to define the base. Use the 3P (Three Points) option to
define the base of the cylinder. You can set three points anywhere in 3D
space.

■ Construct a cylindrical form with special detail, such as grooves. Create a
closed polyline (PLINE to represent a 2D profile of the base. Use EXTRUDE
to define the height along the Z axis. The resulting extruded solid is not
a true solid cylinder primitive.

To create a solid cylinder with a circular base

1 Click Home tab ➤ Modeling panel ➤ Cylinder.

2 Specify the center point of the base.

3 Specify the radius or diameter of the base.

4 Specify the height of the cylinder.
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Toolbar: Modeling  
Command entry: CYLINDER

To create a solid cylinder with an elliptical base

1 Click Home tab ➤ Modeling panel ➤ Cylinder.

2 At the Command prompt, enter e (Elliptical).

3 Specify the start point of the first axis.

4 Specify the endpoint of the first axis.

5 Specify the endpoint (length and rotation) of the second axis.

6 Specify the height of the cylinder.

Toolbar: Modeling  
Command entry: CYLINDER

To create a solid cylinder with the height and rotation specified (axis endpoint)

1 Click Home tab ➤ Modeling panel ➤ Cylinder.

2 Specify the center point of the base.

3 Specify the radius or diameter of the base.

4 At the Command prompt, enter a (Axis endpoint). Specify the axis
endpoint of the cylinder.

This endpoint can be located anywhere in 3D space.

Toolbar: Modeling  
Command entry: CYLINDER
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Quick Reference

Commands

CYLINDER

Creates a 3D solid cylinder.

System Variables

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Solid Sphere
Create a solid sphere using one of several methods.

When you start with the center point, the central axis of the sphere parallels
the Z axis of the current user coordinate system (UCS).

Sphere Creation Options

Use the following options to draw a sphere with the SPHERE command:

■ Specify three points to set the size and plane of the circumference or
radius. Use the 3P (Three Points) option to define the size of the sphere
anywhere in 3D space. The three points also define the plane of the
circumference.

■ Specify two points to set the circumference or radius. Use the 2P (Two
Points) option to define the size of the sphere anywhere in 3D space. The
plane of the circumference matches the Z value of the first point.
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■ Set the size and location of the sphere based on other objects. Use the
Ttr (Tangent, Tangent, Radius) option to define a sphere that is tangent
to two circles, arcs, lines, and some 3D objects. The tangency points are
projected onto the current UCS.

To create a solid sphere

1 Click Home tab ➤ Modeling panel ➤ Sphere.

2 Specify the center of the sphere.

3 Specify the radius or diameter of the sphere.

Toolbar: Modeling  
Command entry: SPHERE

To create a solid sphere defined by three points

1 Click Home tab ➤ Modeling panel ➤ Sphere.

2 At the Command prompt, enter 3p (Three Points). Specify the first point.

3 Specify the second point.

4 Specify the third point.

Toolbar: Modeling  
Command entry: SPHERE

Quick Reference

Commands

SPHERE

Creates a 3D solid sphere.
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System Variables

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Solid Pyramid
Create a solid pyramid with up to 32 sides.

You can create a pyramid that tapers to a point, or create a frustum of a
pyramid, which tapers to a planar face.

Pyramid Creation Options

Use the following options to control the size, shape, and rotation of the
pyramids you create:

■ Set the number of sides. Use the Sides option of the PYRAMID command
to set the number of sides for the pyramid.

■ Set the length of the edges. Use the Edges option to specify the dimension
of the sides at the base.

■ Create a frustum of a pyramid. Use the Top Radius option to create a
frustum, which tapers to a planar face. The frustum face is parallel to, and
has the same number of sides as, the base.
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■ Set the height and rotation of the pyramid. Use the Axis Endpoint option
of the PYRAMID command to specify the height and rotation of the
pyramid. This endpoint, or top of the pyramid, can be located anywhere
in 3D space.

To create a solid pyramid

1 Click Home tab ➤ Modeling panel ➤ Pyramid.

2 At the Command prompt, enter s (Sides). Enter the number of sides to
use.

3 Specify the center point of the base.

4 Specify the radius or diameter of the base.

5 Specify the height of the pyramid.

Toolbar: Modeling  
Command entry: PYRAMID

To create a frustum of a solid pyramid

1 Click Home tab ➤ Modeling panel ➤ Pyramid.

2 At the Command prompt, enter s (Sides). Enter the number of sides to
use.

3 Specify the center point of the base.
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4 Specify the radius or diameter of the base.

5 Enter t (Top radius). Specify the radius of the planar face at the top of
the pyramid.

6 Specify the height of the pyramid.

Toolbar: Modeling  
Command entry: PYRAMID

Quick Reference

Commands

PYRAMID

Creates a 3D solid pyramid.

System Variables

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Solid Torus
Create a ring-shaped solid that resembles the inner tube of a tire.

A torus has two radius values. One value defines the tube. The other value
defines the distance from the center of the torus to the center of the tube. By
default, a torus is drawn parallel to and is bisected by the XY plane of the
current UCS.
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A torus can be self-intersecting. A self-intersecting torus has no center hole
because the radius of the tube is greater than the radius of the torus.

Torus Creation Options

Use the following options to control the size and rotation of the tori you
create.

■ Set the size and plane of the circumference or radius. Use the 3P (Three
Points) option to define the size of the torus anywhere in 3D space. The
three points also define the plane of the circumference. Use this option to
rotate the torus as you create it.

■ Set the circumference or radius. Use the 2P (Two Points) option to define
the size of the torus anywhere in 3D space. The plane of the circumference
matches the Z value of the first point.

■ Set the size and location of the torus based on other objects. Use the Ttr
(Tangent, Tangent, Radius) option to define a torus that is tangent to two
circles, arcs, lines, and some 3D objects. The tangency points are projected
onto the current UCS.

To create a solid torus

1 Click Home tab ➤ Modeling panel ➤ Torus.

2 Specify the center of the torus.

3 Specify the radius or diameter of the path that is swept by the torus tube.

4 Specify the radius or diameter of the tube.

Toolbar: Modeling  
Command entry: TORUS
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Quick Reference

Commands

TORUS

Creates a donut-shaped 3D solid.

System Variables

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Polysolid
Use the same techniques you use to create polylines to create a polysolid
object.

The POLYSOLID command provides a quick way to draw 3D walls. A polysolid
is like an extruded, wide polyline. In fact, you can draw polysolids the same
way that you draw a polyline, using both straight and curved segments. Unlike
extruded polylines, which lose any width properties upon extrusion, polysolids
retain the width of their line segments.

You can also convert objects such as a line, 2D polyline, arc, or circle to a
polysolid.

Polysolids are displayed as swept solids in the Properties palette.
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Polysolid Creation Options

Use the following options to control the size and shape of the polysolids you
create:

■ Create arced segments. Use the Arc option to add curved segments to the
polysolid. The profile of a polysolid with curved segments remains
perpendicular to the path.

■ Create a polysolid from a 2D object. Use the Object option to convert an
object such as a polyline, circle, line, or arc to a polysolid. The DELOBJ
system variable controls whether the path (a 2D object) is automatically
deleted when you create a polysolid.

■ Close the gap between the first and last points. Use the Close option to
create a connecting segment.

■ Set the height and width. Use the Height and Width options for the
POLYSOLID command. The values you set are stored in the PSOLWIDTH
and PSOLHEIGHT system variables.

■ Set where the object is drawn in relation to the specified points. Use the
Justification option to place the path of the polysolid to the right, to the
left, or down the center of the points you specify.

To draw a polysolid

1 Click Home tab ➤ Modeling panel ➤ Polysolid.

2 Specify a start point.

3 Specify the next point.

To create a curved segment, at the Command prompt, enter a (Arc) and
specify the next point.

4 Repeat step 3 to complete the desired solid.
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5 Press Enter.

Toolbar: Modeling  
Command entry: POLYSOLID

To create a polysolid from an existing object

1 Click Home tab ➤ Modeling panel ➤ Polysolid.

2 At the Command prompt, enter o (Object).

3 Select a 2D object such as a line, polyline, arc, or circle.

A 3D polysolid is created using the current height and width settings.
The original 2D object is deleted or retained, depending on the setting
of the DELOBJ system variable.

Toolbar: Modeling  
Command entry: POLYSOLID

Quick Reference

Commands

POLYSOLID

Creates a 3D wall-like polysolid.

System Variables

DELOBJ

Controls whether geometry used to create 3D objects is retained or deleted.

PSOLHEIGHT

Controls the default height for a swept solid object created with the
POLYSOLID command.

PSOLWIDTH

Controls the default width for a swept solid object created with the
POLYSOLID command.
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Construct Solids and Surfaces from Lines and Curves
Use existing lines and curves to define both the profile and path for the solid
or surface.

Extrude Objects
Create solids and surfaces by extending objects into 3D space.

The EXTRUDE command creates a solid or surface that extends the shape of
an object. Closed objects such as circles are converted to 3D solids. Open
objects such as lines are converted to 3D surfaces.

If you extrude a polyline with width, the width is ignored and the polyline is
extruded from the center of the polyline path. If you extrude an object with
thickness, the thickness is ignored.

Before you can create an extruded solid from separate objects such as multiple
lines or arcs, you must convert them to a single object. You can combine
objects to form a polyline by using the Join option of the PEDIT command.
You can also convert the objects to form a region by using the REGION
command.

For information about objects that can be extruded or used as extrusion paths,
see EXTRUDE.
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Options for Extrusion

When you extrude objects, you can specify any of the following options:

■ Specify a path for the extrusion. With the Path option, create a solid or
surface by specifying an object to be the path for the profile, or shape, of
the extrusion. The extruded solid starts from the plane of the profile and
ends on a plane perpendicular to the path at the endpoint of the path. For
best results, use object snaps to make sure that the path is on or within
the boundary of the object being extruded.

Extruding is different from sweeping. When you extrude a profile along a
path, the profile follows the shape of the path, even if the path does not
intersect the profile. With the SWEEP command, the profile moves to the
location of the swept path. Sweeping usually provides greater control and
better results.

■ Taper angle. Tapering the extrusion is useful for defining parts that require
a specific taper angle, such as a mold used to create metal products in a
foundry.
Avoid using large tapered angles. If the angle is too large, the profile can
taper to a point before it reaches the specified height.

■ Length and direction. With the Direction option, you can specify two
points to set the length and direction of the extrusion.

To extrude an object

1 Click Home tab ➤ Modeling panel ➤ Extrude.

2 Select the objects to extrude.

3 Specify the height.

After the extrusion, the original objects are deleted or retained, depending
on the setting of the DELOBJ system variable.
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Toolbar: Modeling  
Command entry: EXTRUDE

To extrude an object along a path

1 Click Home tab ➤ Modeling panel ➤ Extrude.

2 Select the objects to extrude.

3 At the Command prompt, enter p (Path).

4 Select the object to use as the path.

After the extrusion, the original objects are deleted or retained, depending
on the setting of the DELOBJ system variable.

Toolbar: Modeling  
Command entry: EXTRUDE

Quick Reference

Commands

EXTRUDE

Extends the dimensions of a 2D object or 3D face into 3D space.

PEDIT

Edits polylines and 3D polygon meshes.

REGION

Converts an object that encloses an area into a region object.

SWEEP

Creates a 3D solid or surface by sweeping a 2D object along a path.

System Variables

DELOBJ

Controls whether geometry used to create 3D objects is retained or deleted.
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SURFU

Sets the surface density for PEDIT Smooth in the M direction and the U
isolines density on surface objects.

SURFV

Sets the surface density for PEDIT Smooth in the N direction and the V
isolines density on surface objects.

Create a Solid or Surface by Sweeping
Create a new solid or surface by sweeping a planar curve (profile) along a path.

The SWEEP command draws a solid or surface object by extending a profile
shape (the swept object) along a specified path. When you sweep a profile
along a path, the profile is moved and aligned normal (perpendicular) to the
path.

If you sweep a closed curve along a path, the result is a solid. If you sweep an
open curve along a path, the result is a surface.

You can sweep more than one profile object, but all objects must lie on the
same plane.

The DELOBJ system variable controls whether the profile and sweep path are
automatically deleted.

Options for Sweeping

Swept objects can be twisted or scaled as they are swept. You can also use the
Properties palette to specify the following properties for the swept object:

■ Profile Rotation. Rotates the swept profile about the path.

■ Scale Along Path. Sets a scale factor of the end of the profile compared to
the start of the profile.
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■ Twist Along Path. Sets a twist angle for the objects being swept. The value
you enter sets the angle of rotation of the endpoint compared to the start
point.

■ Bank (natural rotation). Specifies whether the curve of a twisted profile
rotates naturally along a 3D path.

The Properties palette does not allow changes to be made to swept properties
under the following conditions:

■ If the Alignment option was turned off when the profile was swept

■ If the change would result in a modeling error such as a self-intersecting
solid

TIP To sweep a profile such as a closed polyline along a helix, move or rotate the
profile into place. Turn off the Alignment option in the SWEEP command. If you
get a modeling error, make sure that the result will not intersect itself.

For information about what type of objects can be used to create swept solids
or surfaces, see SWEEP.

See also:

■ Draw Helixes on page 839

■ Modify Helixes on page 1163

To create a solid or surface by sweeping an object along a path

1 Click Home tab ➤ Modeling ➤ Sweep.

2 Select objects to sweep.

3 Press Enter.

4 Select a sweep path.

After the sweep, the original objects are deleted or retained, depending
on the setting of the DELOBJ system variable.

Toolbar: Modeling  
Command entry: SWEEP
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Quick Reference

Commands

SWEEP

Creates a 3D solid or surface by sweeping a 2D object along a path.

System Variables

DELOBJ

Controls whether geometry used to create 3D objects is retained or deleted.

SURFU

Sets the surface density for PEDIT Smooth in the M direction and the U
isolines density on surface objects.

SURFV

Sets the surface density for PEDIT Smooth in the N direction and the V
isolines density on surface objects.

Create a Solid or Surface by Lofting
Create a 3D solid or surface by lofting a profile through a set of two or more
cross-section profiles.

The cross-section profiles define the shape of the resulting solid or surface
object. You must specify at least two cross-section profiles.

Cross-section profiles can be open (for example, an arc) or closed (for example,
a circle). The LOFT command flows through the space between the cross
sections. If you loft through a set of a closed cross-section curves, the result
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is a solid object. If you loft through a set of open cross-section curves, the
result is a surface object.

The cross sections that you use when lofting must be all open or all closed.
You cannot use a selection set that includes both open and closed curves.

The DELOBJ system variable controls whether the cross sections, paths, and
guides are automatically deleted when the solid or surface is created.

For information about objects that can be used for lofting, see LOFT.

Methods for Lofting

Lofting creates a solid or surface object that flows through other objects that
define its shape.

■ Cross-section profiles. Select a series of cross-section profiles to define the
shape of the new 3D object.

lofted objects with different cross-section settings

As you create a lofted object using only cross-section profiles, you can
adjust its shape in the Loft Settings dialog box. You can also modify the
settings later in the Properties dialog box. For more information, see Modify
Properties of 3D Objects on page 1279

■ Paths. Specify a path for the loft operation to obtain more control over
the shape of the lofted object. For best results, start the path curve on the
plane of the first cross section and end it on the plane of the last cross
section.
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■ Guide curves. Specify guide curves to match points on corresponding cross
sections. This method prevents undesired results, such as wrinkles in the
resulting 3D object.

Each guide curve must meet the following criteria:

■ Intersects each cross section

■ Starts on the first cross section

■ Ends on the last cross section

You can select any number of guide curves for the lofted surface or solid.

To create a solid or surface by lofting through a set of cross-section profiles

1 Click Home tab ➤ Modeling panel ➤ Loft.

2 In the drawing area, select cross-section profiles and press Enter. (Select
them in the order in which you want the new 3D object to pass through
the cross sections.)

3 Do one of the following:

■ Use cross-section profiles only. Press Enter again or enter c (Cross
sections only).
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In the Loft Settings dialog box, modify the options to control the
shape of the new object. Click the Preview Changes box to preview
the changes as you make them.

Click OK when finished.

■ Follow guide curves. Enter g (Guide curves). Select the guide curves
and press Enter.

■ Follow a path. Enter p (Path). Select a path and press Enter.

After the loft operation, the original objects are deleted or retained, depending
on the setting of the DELOBJ system variable.

Toolbar: Modeling  
Command entry: LOFT

Quick Reference

Commands

LOFT

Creates a 3D solid or surface in the space between several cross sections.

System Variables

DELOBJ

Controls whether geometry used to create 3D objects is retained or deleted.

LOFTANG1

Sets the draft angle through the first cross section in a loft operation.

LOFTANG2

Sets the draft angle through the last cross section in a loft operation.

LOFTMAG1

Sets the magnitude of the draft angle through the first cross section in a loft
operation.
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LOFTMAG2

Sets the magnitude of the draft angle through the last cross section in a loft
operation.

LOFTNORMALS

Controls the normals of a lofted object where it passes through cross sections.

LOFTPARAM

Controls the shape of lofted solids and surfaces.

SURFU

Sets the surface density for PEDIT Smooth in the M direction and the U
isolines density on surface objects.

SURFV

Sets the surface density for PEDIT Smooth in the N direction and the V
isolines density on surface objects.

Create a Solid or Surface by Revolving
Create a 3D object by revolving objects about an axis.

With the REVOLVE command, you can revolve open or closed objects about
an axis. The revolved objects define the profile of the new solid or surface.

If you revolve a closed object, the result is a solid. If you revolve an open
object, the result is a surface.

You can revolve more than one object at a time.

1208 | Chapter 20   Create 3D Models



Methods for Creating a Revolved Solid or Surface

When you revolve objects, you can specify one of the following options to
use as an axis of revolution:

■ Axis defined by two points you specify

■ X, Y, or Z axis

■ Axis defined by an object

A profile that consists of lines or arcs that meet a polyline creates a surface
object when it is revolved. To create a 3D solid object instead, first convert
the profile objects to a single polyline by using the Join option of the PEDIT
command.

For information about objects that can be used for revolving, see REVOLVE.

To revolve objects about an axis

1 Click Home tab ➤ Modeling panel ➤ Revolve.

2 Select the objects to revolve.

3 To specify the axis of revolution, specify one of the following:

■ The start and endpoint. Click to points on the screen to set the axis
orientation. The axis points must be on one side of the revolved object.
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The positive axis direction extends from the start point to the
endpoint.

■ The X, Y, or Z axis. Enter x, y, or z.

■ An object. Select a line, a linear edge of a polyline segment, or the
linear edge of a surface or solid.

4 Specify the angle of revolution.

Toolbar: Modeling  
Command entry: REVOLVE

Quick Reference

Commands

REVOLVE

Creates a 3D solid or surface by sweeping a 2D object around an axis.

System Variables

DELOBJ

Controls whether geometry used to create 3D objects is retained or deleted.

SURFU

Sets the surface density for PEDIT Smooth in the M direction and the U
isolines density on surface objects.

SURFV

Sets the surface density for PEDIT Smooth in the N direction and the V
isolines density on surface objects.

Create 3D Solids from Objects
Convert existing objects to 3D solids.

You can use several methods to convert objects in your drawing to 3D solids.
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mesh and polyline with thickness converted to optimized 3D solids

The DELOBJ system variable controls whether the objects you select are
automatically deleted when the 3D object is created.

Convert Surfaces and Objects with Thickness to 3D Solids

You can convert the several types of objects into extruded 3D solids with the
CONVTOSOLID command. These objects include closed polylines and circles
with thickness, as well as watertight meshes and surfaces. For a complete list
of objects that can be converted using this method, see CONVTOSOLID.

NOTE You cannot use CONVTOSOLID to convert different, contiguous objects
into a 3D solid. However, you can achieve the same result by first combining them.
Suppose you explode a 3D solid box into regions. Start by using CONVTOSURFACE
to convert each region to a surface. Then use UNION to form a compound surface
object. Finally, use CONVTOSOLID to convert the surface to a solid.

Convert Mesh to 3D Solids

When you convert mesh objects to 3D solids, the shape of the new solid object
approximates, but does not exactly duplicate, the original mesh object. You
can control the differentiation somewhat by specifying whether the result is
smooth or faceted (SMOOTHMESHCONVERT). You can also specify whether
the resulting faces are merged (optimized).

For example, if you convert a mesh box to a solid object, you have the
following options (available on the Mesh Modeling ribbon):

■ Smoothed and optimized. Coplanar faces are merged into a single face.
The overall shape of some faces can change. Edges of faces that are not
coplanar are rounded.
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■ Smoothed and not optimized. Each original mesh face is retained in the
converted object. Edges of faces that are not coplanar are rounded.

■ Faceted and optimized. Coplanar faces are merged into a single, flat face.
The overall shape of some faces can change. Edges of faces that are not
coplanar are creased, or angular.

■ Faceted and not optimized. Each original mesh face is converted to a flat
face. Edges of faces that are not coplanar are creased, or angular.
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You cannot convert the following types of mesh objects to a 3D solid:

■ Mesh with gaps between faces. Gizmo editing can sometimes result in
gaps, or holes between the faces. In some cases, you can close the gaps by
smoothing the mesh object.

■ Mesh that has self-intersecting boundaries. If you have modified a mesh
object so that one or more faces intersect faces in the same object, you
cannot convert it to a 3D solid.

In some cases, mesh that is not eligible to be converted to a solid object can
be converted to a surface.

Thicken Surfaces to Convert Them to 3D Solids

You can convert 3D surface objects to 3D solids with the THICKEN command.

Grip editing is limited for objects that are created using this method.
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To convert objects with thickness to extruded solids

1 Click Home tab ➤ Solid Editing panel ➤ Convert to Solid. 

2 Select one or more of the following types of objects and press Enter:

■ Uniform-width polylines with thickness

■ Closed, 0-width polylines with thickness

■ Circles with thickness

Command entry: CONVTOSOLID

To convert one or more surfaces to solids

1 Click Home tab ➤ Solid Editing panel ➤ Thicken. 

2 Select the surfaces you want to thicken. Press Enter.

3 Specify a thickness for the solid. Press Enter.

Command entry: THICKEN

To convert contiguous surfaces that enclose a volume to a 3D solid object

1 Click Home tab ➤ Solid Editing panel ➤ Union. 

2 Select objects whose surfaces are contiguous (with no gaps).

A compound object is created.

3 Click Home tab ➤ Solid Editing panel ➤ Convert to Solid.

4 Select the new compound object.

Command entry: UNION, CONVTOSOLID

To convert a mesh object to a 3D solid

1 Click Mesh Modeling tab ➤ Convert Mesh panel ➤ Smooth with Merging.
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2 Specify one of the following conversion options:

■ Smooth, optimized. The resulting model is smoothed, with merged
faces (SMOOTHMESHCONVERT = 0).

■ Smooth, not optimized. The resulting model is smooth, with the same
number of faces as the original mesh object (SMOOTHMESHCONVERT
= 1).

■ Faceted, optimized. The resulting model is angular, with merged,
planar faces (SMOOTHMESHCONVERT = 2).

■ Faceted, not optimized. The resulting model is angular, with the same
number of faces as the original mesh object (SMOOTHMESHCONVERT
= 3).

3 Click Mesh Modeling tab ➤ Convert Mesh panel ➤ Convert to Solid.

4 Select a mesh object that has no gaps or intersecting faces.

Command entry: SMOOTHMESHCONVERT, CONVTOSOLID

Quick Reference

Commands

CONVTOSOLID

Converts 3D meshes and polylines and circles with thickness to 3D solids.

THICKEN

Converts a surface into a 3D solid with a specified thickness.

UNION

Combines selected 3D solids, surfaces, or 2D regions by addition.

System Variables

DELOBJ

Controls whether geometry used to create 3D objects is retained or deleted.

SMOOTHMESHCONVERT

Sets whether mesh objects that you convert to 3D solids or surfaces are
smoothed or faceted, and whether their faces are merged.
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Create Surfaces from Objects
Convert existing objects to surfaces.

You can use several methods to convert objects in your drawing to 3D surfaces.

The DELOBJ system variable controls whether the objects you select are
automatically deleted when the 3D object is created.

Convert Objects to Surfaces

To convert any of the following objects into surfaces, use the
CONVTOSURFACE command:

■ 2D solids

■ Meshes

■ Regions

■ Bodies

■ Open, zero-width polylines with thickness

■ Lines with thickness

■ Arcs with thickness

■ Planar 3D faces

You can also create surfaces from 3D solids that have curved faces by exploding
them. To convert objects such as cylinders, use the EXPLODE command.

When you convert mesh objects to surfaces, the shape of the new solid object
approximates, but does not exactly duplicate, the original mesh object. You
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can control the differentiation somewhat by specifying whether the result is
smooth or faceted (SMOOTHMESHCONVERT). You can also specify whether
the resulting faces are merged (optimized).

Create a Planar Surface

Create a flat, planar surface, use the PLANESURF command. You can use either
of the following options:

■ Select one or more objects that form one or more enclosed areas

■ Specify the opposite corners of a rectangle

When you specify the corners of the surface, the surface is created parallel to
the workplane.

To convert one or more objects to surfaces

1 Click Home tab ➤ Solid Editing panel ➤ Convert to Surface. 

2 Select the objects you want to convert and press Enter.

Command entry: CONVTOSURFACE

To create a planar surface from an existing object

1 Click Home tab ➤ Modeling panel ➤ Planar Surface.

2 At the Command prompt, enter o (Object).

3 Select an object and press Enter.
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Toolbar: Modeling  
Command entry: PLANESURF

To convert a mesh object to a surface object

1 On the Mesh Modeling tab ➤ Convert Mesh panel, specify one of the
following conversion options:

■ Smooth, optimized. The resulting model is smoothed, with merged
faces (SMOOTHMESHCONVERT = 0).

■ Smooth, not optimized. The resulting model is smooth, with the same
number of faces as the original mesh object (SMOOTHMESHCONVERT
= 1).

■ Faceted, optimized. The resulting model is angular, with merged,
planar faces (SMOOTHMESHCONVERT = 2).

■ Faceted, not optimized. The resulting model is angular, with the same
number of faces as the original mesh object (SMOOTHMESHCONVERT
= 3).

2 Click Mesh Modeling tab ➤ Convert Mesh panel ➤ Convert to Surface.

3 Select a mesh object.

Command entry: SMOOTHMESHCONVERT, CONVTOSURFACE

To create a planar surface by specifying the corners of the surface

1 Click Home tab ➤ Modeling panel ➤ Planar Surface.

2 Specify the first corner of the surface.

3 Specify the second corner of the surface.

Toolbar: Modeling  
Command entry: PLANESURF
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Quick Reference

Commands

CONVTOSURFACE

Converts objects to 3D surfaces.

EXPLODE

Breaks a compound object into its component objects.

PLANESURF

Creates a planar surface.

System Variables

DELOBJ

Controls whether geometry used to create 3D objects is retained or deleted.

SMOOTHMESHCONVERT

Sets whether mesh objects that you convert to 3D solids or surfaces are
smoothed or faceted, and whether their faces are merged.

Combine or Slice 3D Objects
Create new composite 3D objects or slice objects to divide them.

Create Composite Objects
Create composite 3D objects by combining, subtracting, or finding the
intersecting mass of two or more 3D solids, surfaces, or regions.

Composite solids are created from two or more solids, surfaces, or regions
through any of the following commands: UNION, SUBTRACT, and INTERSECT.

By default, 3D solids record a history of their original forms. This history allows
you to see the original forms that make up composite solids. Surface objects
do not retain history. For more information, see Display Original Forms of
Composite Solids on page 1326.
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Methods for Creating Composite Objects

Three methods are available for creating composite solids, surfaces, or regions:

■ Combine two or more objects.
With UNION, you can combine the total volume of two or more objects.

■ Subtract one set of solids from another.
With SUBTRACT, you can remove the common area of one set of solids
from another. For example, you can use SUBTRACT to add holes to a
mechanical part by subtracting cylinders from the object.

■ Find the common volume.
With INTERSECT, you can create a composite solid from the common
volume of two or more overlapping solids. INTERSECT removes the portions
that do not overlap and creates a composite solid from the common
volume.

1220 | Chapter 20   Create 3D Models



Create Composites from Mixed Object Types

In addition to creating composite objects from the same object types, you can
also create composites from mixed surfaces and solids.

■ Mixed intersections. Combining a solid and surface through intersection
results in a surface.

■ Mixed subtractions. Subtracting a 3D solid from a surface results in a
surface. However, you cannot subtract a surface from a 3D solid object.

■ Mixed unions. You cannot create a union between 3D solid and surface
objects.

If a selection set contains objects that are both eligible and ineligible to be
composite objects, the ineligible objects are ignored. For example, with the
SUBTRACT command, if you select a solid object to be modified and then
select both a solid and a surface to be subtracted, only the solid object is
subtracted.

You cannot create composite mesh objects. However, if the selection set
contains mesh objects, you can choose to convert them to 3D solids or surfaces
and continue the operation. If the mesh is watertight (that is, it encloses a
volume with no gaps), it is converted to a solid object. If the mesh has gaps,
it is converted to a surface.

If a selection set of mixed objects contains regions, the regions are ignored.

To combine objects

1 Click Home tab ➤ Solid Editing panel ➤ Union.

2 Select the 3D solid, surface, or region objects to combine. Press Enter.

Toolbar: Solid Editing  
Command entry: UNION

To subtract objects from one another

1 Click Home tab ➤ Solid Editing panel ➤ Subtract.

2 Select the 3D solid, surface, or region to subtract from. Press Enter.

3 Select the 3D solid, surface, or region to subtract. Press Enter.
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Toolbar: Solid Editing  
Command entry: SUBTRACT

To create a compound object from the intersection with other objects

1 Click Home tab ➤ Solid Editing panel ➤ Intersect.

2 Select the 3D solid, surface, or region to intersect. Press Enter.

Toolbar: Solid Editing  
Command entry: INTERSECT

Quick Reference

Commands

INTERSECT

Creates a 3D solid, surface, or 2D region from overlapping solids, surfaces,
or regions.

SUBTRACT

Combines selected 3D solids, surfaces, or 2D regions by subtraction.

UNION

Combines selected 3D solids, surfaces, or 2D regions by addition.

System Variables

SHOWHIST

Controls the Show History property for solids in a drawing.

SOLIDHIST

Controls the default History property setting for new and existing objects.

Create 3D Solids or Surfaces by Slicing
Create new 3D solids or surfaces by slicing, or dividing, existing objects.
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When you use the SLICE command to slice a 3D solid or surface, you can
define the cutting plane in several ways. For example, you can specify three
points, an axis, a surface, or a planar object to act as a cutting plane. You can
retain one or both halves of the sliced object.

Sliced 3D solids do not retain a history of the original forms that created them.
However, they do retain the layer and color properties of the original objects.

For a complete list of objects that can be used for a slice operation, see SLICE.

Methods for Slicing 3D Solids

You can use the following methods to define the cutting plane used to slice
a 3D solid object:

■ Specify points. The default method is to specify two points that define the
cutting plane perpendicular to the current UCS. You can also specify three
points.

■ Slice along a plane of the current UCS. Specify whether you want to use
the XY, YZ, or ZX plane.

■ Slice along the Z axis. Specify the starting point for a slice that extends
along the Z axis.

■ Specify a surface to act as a cutting plane. Select a surface to act as a cutting
plane. You cannot use meshes that were created using the EDGESURF,
REVSURF, RULESURF, or TABSURF commands.

■ Slice along the plane of a 2D object. Select a circle, ellipse, circular or
elliptical arc, spline, or polyline segment to act as a cutting plane.

See also:

■ Create Sections and 2D Drawings from 3D Models on page 1363
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To slice solids or surfaces

1 Click Home tab ➤ Solid Editing panel ➤ Slice. 

2 Select the 3D solid or surface objects to slice. Press Enter.

3 Specify two points to define the cutting plane.

4 Specify which side to retain, or enter b (Both) to retain both sides.

Command entry: SLICE

To slice solids or surfaces with a planar object

1 Click Home tab ➤ Solid Editing panel ➤ Slice. 

2 Select the 3D solid or surface objects to slice. Press Enter.

3 At the Command prompt, enter o (Object). Press Enter.

4 Select a circle, ellipse, arc, 2D spline, or 2D polyline to use as the cutting
plane.

5 Specify which side to retain, or enter b (Both) to retain both sides.

Command entry: SLICE

To slice solids or surfaces with a surface

1 Click Home tab ➤ Solid Editing panel ➤ Slice. 

2 Select the 3D solid or surface objects to slice. Press Enter.

3 At the Command prompt, enter s (Surface).

4 Press Enter.

5 Select a surface to use as the cutting plane.

6 Specify which side to retain, or enter b (both) to retain both sides.

Command entry: SLICE
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Quick Reference

Commands

SLICE

Creates new 3D solids and surfaces by slicing, or dividing, existing objects.

Check 3D Models for Interferences
Find areas where 3D solids or surfaces intersect or overlap.

Use the INTERFERE command to check for areas of interference within a set
of 3D solid or surface models. You can compare two sets of objects or check
all 3D solids and surfaces in a drawing.

Interference checking creates temporary solid or surface objects and highlights
where the models intersect.

If the selection set contains both 3D solids and surfaces, the resulting
interference object is a surface.

You cannot check interference for mesh objects. However, if you select mesh
objects, you can choose to convert them to a solid or surface object and
continue the operation.

During the checking operation, you can use the Interference Checking dialog
box to cycle through and zoom to interference objects. You can also specify
whether to delete the temporary objects that are created during interference
checking.

Methods for Checking Interference

You can check interference using the following methods:

■ Define one selection set. Check the interference of all the 3D solids and
surfaces in a single selection set.

■ Define two selection sets. Check the interference of the objects in the first
set of objects against the objects in the second selection set.
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■ Individually specify solids that are nested within blocks or xrefs.
Individually select 3D solid or surface objects that are nested in blocks and
external references (xrefs) and compare them against other objects in the
selection set.

To check for interferences within a solid model

1 Click Home tab ➤ Solid Editing panel ➤ Interference Checking. 

2 Select the first set of 3D solids and surfaces in the model. Press Enter.

3 Select the second set of 3D solids and surfaces in the model. Press Enter.

The Interference Checking dialog box is displayed. The areas of
interference are displayed as new, highlighted solid objects.

4 To cycle through the interference objects, in the Interference Checking
dialog box, click Next and Previous.

5 To retain the new interference objects after you close the Interference
Checking dialog box, clear Delete Interference Objects Created on Close.

6 Click Close.

If Delete Interference Objects on Close is selected, the new interference
objects are deleted.

Command entry: INTERFERE

To change the display of interference objects

1 Click Home tab ➤ Solid Editing panel ➤ Interference Checking. 

2 Enter s (Settings). Press Enter.

3 In the Interference Settings dialog box, change any of the settings and
click OK.

Command entry: INTERFERE
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Quick Reference

Commands

INTERFERE

Creates a temporary 3D solid from the interferences between two sets of
selected 3D solids.

System Variables

INTERFERECOLOR

Sets the color for interference objects.

INTERFEREOBJVS

Sets the visual style for interference objects.

INTERFEREVPVS

Specifies the visual style for the viewport during interference checking.

Create Meshes
Create meshes from primitive forms or by filling between points on other
objects.

Overview of Creating Meshes
Mesh tessellation provides enhanced capabilities for modeling object shapes
in a more detailed way.
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Starting with AutoCAD 2010, the default mesh object type can be smoothed,
creased, split, and refined. Although you can continue to create the legacy
polyface and polygon mesh types, you can obtain more predictable results by
converting to the newer mesh object type.

Methods for Creating Mesh

You can create mesh objects using the following methods:

■ Create mesh primitives. Create standard shapes, such as boxes, cones,
cylinders, pyramids, spheres, wedges, and tori (MESH).

■ Create mesh from other objects. Create ruled, tabulated, revolved, or
edge-defined mesh objects, whose boundaries are interpolated from other
objects or points (RULESURF, TABSURF, REVSURF, EDGESURF).

■ Convert from other object types. Convert existing solid or surface models,
including composite models, to mesh objects (MESHSMOOTH).
You can also convert the legacy style of mesh to the new mesh object type.

■ Create custom meshes (legacy). Use 3DMESH to create polygon meshes,
usually scripted with AutoLISP routines, to create open-ended mesh. Use
PFACE to create mesh with multiple vertices defined by coordinates that
you specify. Although you can continue to create legacy polygonal and
polyface meshes, it is recommended that you convert to the enhanced
mesh object type to obtain enhanced editing capabilities.

About Tessellation

Tessellation is a collection of planar shapes that tile a mesh object. The
tessellation divisions, visible in unselected mesh objects, mark the edges of
the editable mesh faces. (To see these divisions in the 3D Hidden or Conceptual
visual styles, VSEDGES must be set to 1.)

When you smooth and refine mesh objects, you increase the density of the
tessellation (the number of subdivisions).

■ Smoothing. Increases how closely the mesh surface adheres to a rounded
form. You can increase mesh smoothness levels for selected objects in
increments or by changing the smoothness level in the Properties palette.
Smoothness level 0 (zero) applies the lowest level of smoothing to a mesh
object. Smoothness level 4 applies a high degree of smoothness.
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■ Refinement. Quadruples the number of subdivisions in a selected mesh
object or in a selected subobject, such as a face. Refinement also resets the
current smoothness level to 0, so that the object can no longer be sharpened
beyond that level. Because refinement greatly increases the density of a
mesh, you might want to restrict this option to areas that require finely
detailed modification. Refinement also helps you mold smaller sections
with less effect on the overall shape of the model.

While highly refined mesh gives you the ability to make detailed modifications,
it also comes at a cost: it can decrease program performance. By maintaining
maximum smoothness, face, and grid levels, you can help ensure that you do
not create meshes that are too dense to modify effectively. (Use
SMOOTHMESHMAXLEV, SMOOTHMESHMAXFACE, and
SMOOTHMESHGRID.)
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Set Mesh Properties Before and After Creation

You can set defaults that control a variety of mesh properties before and after
you create the mesh objects.

■ Mesh Primitive Options dialog box. Sets the density of the tessellation (the
number of subdivisions) per dimension for each type of mesh object you
create.

■ Mesh Tessellation Options dialog box. Sets the default settings for 3D solid
or surface objects that you convert to mesh. Options define how closely
mesh faces adhere to the shape of the object and level of smoothness. You
can also set the default to prefer the settings in the Mesh Primitive Options
dialog box for object conversions.

■ Properties palette. Modifies properties for both the mesh object and its
subobjects after they are created. For a selected mesh object, you can modify
the level of smoothness. For faces and edges, you can apply or remove
creasing, and modify crease retention levels.

■ Level of smoothness. By default, the mesh primitive objects that you create
have no smoothness. You can change this default with the Settings option
of the MESH command. The modified smoothness value is maintained
only during the current drawing session.

See also:

■ Modify Mesh Objects on page 1337

To set the maximum smoothness level for mesh objects

1 At the Command prompt, enter smoothmeshmaxlev.

2 Enter a value from 1 to 255.

(Use lower numbers to prevent extremely dense meshes that might affect
program performance.)

To set the maximum number of faces for mesh objects

1 At the Command prompt, enter smoothmeshmaxface.

2 Enter a value from 1 to 16,000,000.

To control the display of the mesh facet grid

1 At the Command prompt, enter smoothmeshgrid.
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2 Set the smoothness level at which the mesh object displays the underlying
facet grid:

■ 0 hides the display of the underlying facet grid.

■ 1 displays the facet grid for smoothness levels 0 and 1.

■ 2 or higher specifies the highest level of smoothness at which the
facet grid is displayed.

To change the default level of smoothness of new mesh primitive objects

1 At the Command prompt, enter mesh. Then enter se (SEttings).

2 Enter a smoothness value and press Enter.

(A smoothness level of 5 or less is recommended.)

3 Press Esc to end the command or specify a mesh primitive type to create.

The smoothness value is retained for the current drawing session.

Command entry: MESH

Quick Reference

Commands

3DFACE

Creates a three-sided or four-sided surface in 3D space.

3DMESH

Creates a free-form polygon mesh.

EDGESURF

Creates a mesh between four contiguous edges or curves.

MESH

Creates a 3D mesh primitive object such as a box, cone, cylinder, pyramid,
sphere, wedge, or torus.

MESHOPTIONS

Displays the Mesh Tessellation Options dialog box, which controls default
settings for converting existing objects to mesh objects.
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MESHPRIMITIVEOPTIONS

Displays the Mesh Primitive Options dialog box, which sets the tessellation
defaults for primitive mesh objects.

MESHSMOOTH

Converts 3D objects such as polygon meshes, surfaces, and solids to mesh
objects.

PFACE

Creates a 3D polyface mesh vertex by vertex.

PROPERTIES

Controls properties of existing objects.

REVSURF

Creates a mesh by revolving a profile about an axis.

RULESURF

Creates a mesh that represents the surface between two lines or curves.

TABSURF

Creates a mesh from a line or curve that is swept along a straight path.

System Variables

SMOOTHMESHMAXLEV

Sets the maximum smoothness level for mesh objects.

SMOOTHMESHMAXFACE

Sets the maximum number of faces permitted for mesh objects.

SMOOTHMESHGRID

Sets the maximum level of smoothness at which the underlying mesh facet
grid is displayed on 3D mesh objects.

VSEDGES

Controls the types of edges that are displayed in the viewport.

Create 3D Mesh Primitives
Create mesh boxes, cones, cylinders, pyramids, spheres, wedges, and tori.
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Create a Mesh Box
Create a rectangular or cubical mesh box.

The base of the mesh box is drawn parallel to the XY plane of the current UCS
(workplane).

You can set defaults for the number of divisions for each dimension of new
mesh boxes in the Mesh Primitive Options dialog box. You can also modify
these settings and the level of smoothness as you create the mesh object.

Mesh Box Creation Options

The Box option of the MESH command provides several methods for
determining the size and rotation of the mesh boxes you create.

■ Create a cube. Use the Cube option to create a mesh box with sides of
equal length.

■ Specify rotation. Use the Cube or Length option if you want to set the
rotation of the box in the XY plane.

■ Start from the center point. Use the Center option to create a box using
a specified center point.

To create a mesh box based on two points and a height

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Box. 

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height.
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Toolbar: Smooth Mesh Primitives 
Command entry: MESH

To create a mesh box based on length, width, and height

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Box. 

2 Specify the first corner of the base.

3 At the Command prompt, enter l (Length). Specify the length of the base.

4 Specify the width of the base.

5 Specify the height.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

To create a mesh box based on a center point, corner of base, and height

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Box. 

2 At the Command prompt, enter c (Center). Specify the center point of
the base.

3 To set the location of the corner of the base, use one of the following
methods:

■ To set the length and width simultaneously: Specify the location of
one corner of the base.

■ To set the length and width separately: At the Command prompt,
enter l (Length) and specify the length. Then specify the width.

■ Specify the height.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH
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To create a mesh cube

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Box. 

2 Specify the first corner or enter c (Center) and specify the center point
of the base.

3 At the Command prompt, enter c (Cube). Specify the length of the cube
and a rotation angle.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

Quick Reference

Commands

MESH

Creates a 3D mesh primitive object such as a box, cone, cylinder, pyramid,
sphere, wedge, or torus.

MESHPRIMITIVEOPTIONS

Displays the Mesh Primitive Options dialog box, which sets the tessellation
defaults for primitive mesh objects.

System Variables

DIVMESHBOXHEIGHT

Sets the number of subdivisions for the height of a mesh box along the Z
axis.

DIVMESHBOXLENGTH

Sets the number of subdivisions for the length of a mesh box along the X
axis.

DIVMESHBOXWIDTH

Sets the number of subdivisions for the width of a mesh box along the Y axis.
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DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Mesh Cone
Create a pointed or frustum mesh cone with a circular or elliptical base.

By default, the base of the mesh cone lies on the XY plane of the current UCS
and the height of the cone is parallel to the Z axis.

You can set the number of divisions for each dimension of new mesh cones
in the Mesh Primitive Options dialog box. You can also modify these settings
and the level of smoothness as you create the mesh object.

Mesh Cone Creation Options

The Cone option of the MESH command provides several methods for
determining the size and rotation of the mesh cones you create.

■ Set the height and orientation. Use the Axis Endpoint option when you
want to reorient the cone by placing the tip or axis endpoint anywhere in
3D space.

■ Create a frustum of a cone. Use the Top Radius option to create a frustum
of a cone, which tapers to an elliptical or planar face.

■ Specify circumference and base plane. The 3P (Three Points) option defines
the size and plane of the base of the cone anywhere in 3D space.

■ Create an elliptical base. Use the Elliptical option to create a cone base
whose axes are different lengths.

■ Set the location to be tangent to two objects. Use the Ttr (Tangent,
Tangent, Radius) option to define points on two objects. Depending on
the radius distance, the new cone is located as near as possible to the
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tangent points you specify. You can set up tangency with circles, arcs,
lines, and some 3D objects. The tangency points are projected onto the
current UCS. The appearance of tangency is affected by the current level
of smoothness.

To create a mesh cone with a circular base

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Cone. 

2 Specify the center point of the base.

3 Specify the radius or diameter of the base.

4 Specify the height of the cone.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

To create a mesh cone with an elliptical base

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Cone. 

2 At the Command prompt, enter e (Elliptical).

3 Specify the start point of first axis.

4 Specify the endpoint of the first axis.

5 Specify the endpoint (length and rotation) of the second axis.

6 Specify the height of the cone.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

To create a frustum of a mesh cone

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Cone. 
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2 Specify the center point of the base.

3 Specify the radius or diameter of the base.

4 At the Command prompt, enter t (Top radius). Specify the top radius.

5 Specify the height of the cone.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

To create a mesh cone with the height and orientation specified by the axis
endpoint

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Cone. 

2 Specify the center point of the base.

3 Specify the radius or diameter of the base.

4 At the Command prompt, enter a (Axis endpoint). Specify the endpoint
and rotation of the cone.

This endpoint can be located anywhere in 3D space.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

Quick Reference

Commands

MESH

Creates a 3D mesh primitive object such as a box, cone, cylinder, pyramid,
sphere, wedge, or torus.

MESHPRIMITIVEOPTIONS

Displays the Mesh Primitive Options dialog box, which sets the tessellation
defaults for primitive mesh objects.
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System Variables

DIVMESHCONEAXIS

Sets the number of subdivisions around the perimeter of the mesh cone base.

DIVMESHCONEBASE

Sets the number of subdivisions between the perimeter and the center point
of the mesh cone base.

DIVMESHCONEHEIGHT

Sets the number of subdivisions between the base and the point or top of
the mesh cone.

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Mesh Cylinder
Create a mesh cylinder with a circular or elliptical base.

By default, the base of the mesh cylinder lies on the XY plane of the current
UCS. The height of the cylinder is parallel to the Z axis.

You can set the number of divisions for each dimension of new mesh cylinders
in the Mesh Primitive Options dialog box. You can also modify these settings
and the level of smoothness as you create the mesh object.
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Mesh Cylinder Creation Options

The Cylinder option of the MESH command provides several methods for
determining the size and rotation of the mesh cylinders you create.

■ Set rotation. Use the Axis Endpoint option to set the height and rotation
of the cylinder. The center point of the top plane of the cylinder is the
axis endpoint, which can be located anywhere in 3D space.

■ Use three points to define the base. Use the 3P (Three Points) option to
define the base of the cylinder. You can set three points anywhere in 3D
space.

■ Create an elliptical base. Use the Elliptical option to create a cylinder base
whose axes are different lengths.

■ Set the location to be tangent to two objects. Use the Ttr (Tangent,
Tangent, Radius) option to define points on two objects. Depending on
the radius distance, the new cylinder is located as near as possible to the
tangent points you specify. You can set up tangency with circles, arcs,
lines, and some 3D objects. The tangency points are projected onto the
current UCS. The appearance of tangency is affected by the current level
of smoothness.

To create a mesh cylinder with a circular base

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Cylinder. 

2 Specify the center point of the base.

3 Specify the radius or diameter of the base.

4 Specify the height of the cylinder.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

To create a mesh cylinder with an elliptical base

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Cylinder. 

2 At the Command prompt, enter e (Elliptical).
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3 Specify the start point of the first axis.

4 Specify the endpoint of the first axis.

5 Specify the endpoint (length and rotation) of the second axis.

6 Specify the height of the cylinder.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

To create a mesh cylinder with the height and rotation specified (axis
endpoint)

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Cylinder. 

2 Specify the center point of the base.

3 Specify the radius or diameter of the base.

4 At the Command prompt, enter a (Axis endpoint). Specify the axis
endpoint of the cylinder.

This endpoint can be located anywhere in 3D space.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

Quick Reference

Commands

MESH

Creates a 3D mesh primitive object such as a box, cone, cylinder, pyramid,
sphere, wedge, or torus.

MESHPRIMITIVEOPTIONS

Displays the Mesh Primitive Options dialog box, which sets the tessellation
defaults for primitive mesh objects.
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System Variables

DIVMESHCYLAXIS

Sets the number of subdivisions around the perimeter of the mesh cylinder
base.

DIVMESHCYLBASE

Sets the number of radial subdivisions from the center of the mesh cylinder
base to its perimeter.

DIVMESHCYLHEIGHT

Sets the number of subdivisions between the base and the top of the mesh
cylinder.

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Mesh Pyramid
Create a mesh pyramid with up to 32 sides.

Create a pyramid that tapers to a point, or create a frustum of a pyramid,
which tapers to a planar face.

You can set the number of divisions for each dimension of new mesh pyramids
in the Mesh Primitive Options dialog box. You can also modify these settings
and the level of smoothness as you create the mesh object.

Mesh Pyramid Creation Options

The Pyramid option of the MESH command provides several methods for
determining the size and rotation of the mesh pyramids you create.

■ Set the number of sides. Use the Sides option to set the number of sides
for the mesh pyramid.
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■ Set the length of the edges. Use the Edges option to specify the dimension
of the sides at the base.

■ Create a frustum of a pyramid. Use the Top Radius option to create a
frustum, which tapers to a planar face. The frustum face is parallel to, and
has the same number of sides as, the base.

■ Set the height and rotation of the pyramid. Use the Axis Endpoint option
to specify the height and rotation of the pyramid. This endpoint is the top
of the pyramid. The axis endpoint can be located anywhere in 3D space.

■ Set the perimeter to be inscribed or circumscribed. Specify whether the
pyramid base is drawn inside or outside of the radius.

To create a mesh pyramid

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Pyramid. 

2 At the Command prompt, enter s (Sides). Enter the number of sides to
use.

Create 3D Mesh Primitives | 1243



3 Specify the center point of the base.

4 Specify the radius or diameter of the base.

5 Specify the height of the pyramid.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

To create a frustum of a mesh pyramid

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Pyramid. 

2 At the Command prompt, enter s (Sides). Enter the number of sides to
use.

3 Specify the center point of the base.

4 Specify the radius or diameter of the base.

5 Enter t (Top radius). Specify the radius of the planar face at the top of
the pyramid. Specify the height of the pyramid.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

Quick Reference

Commands

MESH

Creates a 3D mesh primitive object such as a box, cone, cylinder, pyramid,
sphere, wedge, or torus.

MESHPRIMITIVEOPTIONS

Displays the Mesh Primitive Options dialog box, which sets the tessellation
defaults for primitive mesh objects.
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System Variables

DIVMESHPYRBASE

Sets the number of radial subdivisions between the center of the mesh
pyramid base and its perimeter.

DIVMESHPYRHEIGHT

Sets the number of subdivisions between the base and the top of the mesh
pyramid.

DIVMESHPYRLENGTH

Sets the number of subdivisions along each dimension of a mesh pyramid
base.

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Mesh Sphere
Create a mesh sphere using one of several methods.

When you start with the center point, the central axis of the mesh sphere
parallels the Z axis of the current user coordinate system (UCS).

You can set the number of divisions for each dimension of new mesh spheres
in the Mesh Primitive Options dialog box. You can also modify these settings
and the level of smoothness as you create the mesh object.
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Mesh Sphere Creation Options

The Sphere option of the MESH command provides several methods for
determining the size and rotation of the mesh spheres you create.

■ Specify three points to set the size and plane of the circumference or
radius. Use the 3P (Three Points) option to define the size of the sphere
anywhere in 3D space. The three points also define the plane of the
circumference.

■ Specify two points to set the circumference or radius. Use the 2P (Two
Points) option to define the size of the sphere anywhere in 3D space. The
plane of the circumference matches the Z value of the first point.

■ Set the location to be tangent to two objects. Use the Ttr (Tangent,
Tangent, Radius) option to define points on two objects. Depending on
the radius distance, the sphere is located as near as possible to the tangent
points you specify. You can set up tangency with circles, arcs, lines, and
some 3D objects. The tangency points are projected onto the current UCS.
The appearance of tangency is affected by the current level of smoothness.

To create a mesh sphere

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Sphere. 

2 Specify the center of the sphere.

3 Specify the radius or diameter of the sphere.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

To create a mesh sphere defined by three points

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Sphere. 

2 Specify the center of the sphere.

3 Specify the radius or diameter of the sphere.
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Toolbar: Smooth Mesh Primitives 
Command entry: MESH

Quick Reference

Commands

MESH

Creates a 3D mesh primitive object such as a box, cone, cylinder, pyramid,
sphere, wedge, or torus.

MESHPRIMITIVEOPTIONS

Displays the Mesh Primitive Options dialog box, which sets the tessellation
defaults for primitive mesh objects.

System Variables

DIVMESHSPHEREAXIS

Sets the number of radial subdivisions around the axis endpoint of the mesh
sphere.

DIVMESHSPHEREHEIGHT

Sets the number of subdivisions between the two axis endpoints of the mesh
sphere.

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Mesh Wedge
Create a mesh wedge with rectangular or cubical faces.
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The base of the wedge is drawn parallel to the XY plane of the current UCS
with the sloped face opposite the first corner. The height of the wedge is
parallel to the Z axis.

You can set the number of divisions for each dimension of new mesh wedges
in the Mesh Primitive Options dialog box. You can also modify these settings
and the level of smoothness as you create the mesh object.

Mesh Wedge Creation Options

The Wedge option of the MESH command provides several methods for
determining the size and rotation of the mesh wedges you create.

■ Create a wedge with sides of equal length. Use the Cube option.

■ Specify rotation. Use the Cube or Length option if you want to set the
rotation of the mesh wedge in the XY plane.

■ Start from the center point. Use the Center Point option.

To create a mesh wedge based on two points and a height

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Wedge. 

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height of the wedge.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH
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To create a mesh wedge based on length, width, and height

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Wedge. 

2 Specify the first corner of the base.

3 At the Command prompt, enter l (Length). Specify the length of the base.

4 Specify the width of the base.

5 Specify the height of the wedge.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

To create a mesh wedge based on a center point, corner of base, and height

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Wedge. 

2 At the Command prompt, enter c (Center). Specify the center point of
the base.

3 To set the location of a corner of the base, use one of the following
methods:

■ To set the length and width simultaneously: Specify the location of
one corner of the base.

■ To set the length and width separately: At the Command prompt,
enter l (Length) and specify the length. Then specify the width.

4 Specify the height of the wedge.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

To create a mesh wedge with equal length, width, and height

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Wedge. 
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2 Specify the first corner or enter c (Center) to set the center point of the
base.

3 At the Command prompt, enter c (Cube). Specify the length of the wedge
and a rotation angle.

The length value sets both the width and height of the wedge.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

Quick Reference

Commands

MESH

Creates a 3D mesh primitive object such as a box, cone, cylinder, pyramid,
sphere, wedge, or torus.

MESHPRIMITIVEOPTIONS

Displays the Mesh Primitive Options dialog box, which sets the tessellation
defaults for primitive mesh objects.

System Variables

DIVMESHWEDGEBASE

Sets the number of subdivisions between the midpoint of the perimeter of
triangular dimension of the mesh wedge.

DIVMESHWEDGEHEIGHT

Sets the number of subdivisions for the height of the mesh wedge along the
Z axis.

DIVMESHWEDGELENGTH

Sets the number of subdivisions for the length of a mesh wedge along the X
axis.

DIVMESHWEDGESLOPE

Sets the number of subdivisions in the slope that extends from the apex of
the wedge to the edge of the base.
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DIVMESHWEDGEWIDTH

Sets the number of subdivisions for the width of the mesh wedge along the
Y axis.

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Create a Mesh Torus
Create a ring-shaped solid that resembles the inner tube of a tire.

A mesh torus has two radius values. One value defines the tube. The other
value defines the path, which is equivalent to the distance from the center of
the torus to the center of the tube. By default, a torus is drawn parallel to and
is bisected by the XY plane of the current UCS.

You can set the number of divisions for each dimension of new mesh tori in
the Mesh Primitive Options dialog box. You can also modify these settings
and the level of smoothness as you create the mesh object.

A mesh torus can be self-intersecting. A self-intersecting mesh torus has no
center hole because the radius of the tube is greater than the radius of the
torus.

Torus Creation Options

The Torus option of the MESH command provides several methods for
determining the size and rotation of the mesh tori you create.

■ Set the size and plane of the circumference or radius. Use the 3P (Three
Points) option to define the size of the mesh torus anywhere in 3D space.
The three points also define the plane of the circumference. Use this option
to rotate the mesh torus as you create it.
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■ Set the circumference or radius. Use the 2P (Two Points) option to define
the size of the mesh torus anywhere in 3D space. The plane of the
circumference matches the Z value of the first point.

■ Set the location to be tangent to two objects. Use the Ttr (Tangent,
Tangent, Radius) option to define points on two objects. Depending on
the specified radius distance, the path of the torus is located as near as
possible to the tangent points you specify. You can set up tangency with
circles, arcs, lines, and some 3D objects. The tangency points are projected
onto the current UCS. The appearance of tangency is affected by the current
level of smoothness.

To create a mesh torus

1 Click Mesh Modeling tab ➤ Primitives panel ➤ Mesh Torus. 

2 Specify the center of the torus.

3 Specify the radius or diameter of the overall path that is swept by the
torus tube.

4 Specify the radius or diameter of the tube.

Toolbar: Smooth Mesh Primitives 
Command entry: MESH

Quick Reference

Commands

MESH

Creates a 3D mesh primitive object such as a box, cone, cylinder, pyramid,
sphere, wedge, or torus.

MESHPRIMITIVEOPTIONS

Displays the Mesh Primitive Options dialog box, which sets the tessellation
defaults for primitive mesh objects.
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System Variables

DIVMESHTORUSPATH

Sets the number of subdivisions in the path that is swept by the profile of a
mesh torus.

DIVMESHTORUSSECTION

Sets the number of subdivisions in the profile that sweeps the path of a mesh
torus.

DRAGVS

Sets the visual style that is displayed while creating 3D solid and mesh
primitives and extruded solids, surfaces, and meshes.

Construct Meshes from Other Objects
Create mesh forms by filling the space between other objects such as lines
and arcs.

You can use a variety of methods to create mesh objects whose edges are
defined by other objects. The MESHTYPE system variable controls whether
the new objects are valid mesh objects, or whether they are created using
legacy polyface or polygon geometry.

You can control whether the mesh is displayed as a wireframe, hidden, or
conceptual image by changing the visual style (VISUALSTYLES).

Types of Meshes Created from Other Objects

You can create several types of meshes that are based on existing objects.

■ Ruled mesh. RULESURF creates a mesh that represents the ruled surface
between two lines or curves.
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■ Tabulated mesh. TABSURF creates a mesh that represents a general
tabulated surface. The surface is defined by the extrusion of a line or curve
(called a path curve) in a specified direction and distance (called a direction
vector or path).

■ Revolved mesh. REVSURF creates a mesh that approximates a surface of
revolution by rotating a profile about a specified axis. A profile can consist
of lines, circles, arcs, ellipses, elliptical arcs, polylines, splines, closed
polylines, polygons, closed splines, and donuts.

■ Edge-defined mesh. EDGESURF creates a mesh approximating a Coons
surface patch mesh from four adjoining edges. A Coons surface patch mesh
is a bicubic surface that is interpolated between four adjoining edges (which
can be general space curves).
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Create a Ruled Mesh

There are several methods for creating meshes.

With RULESURF, you create a mesh between two lines or curves. Use two
different objects to define the edges of the ruled mesh: lines, points, arcs,
circles, ellipses, elliptical arcs, 2D polylines, 3D polylines, or splines.

Both objects that are used as the “rails” of a ruled mesh must be either open
or closed. You can pair a point object with either an open or a closed object.

You can specify any two points on closed curves to complete the operation.
For open curves, construction of the ruled mesh is based on the locations of
the specified points on the curves.

Create a Tabulated Mesh

With the TABSURF command, you can create a mesh that represents a general
tabulated surface defined by a path curve and a direction vector. The path
curve can be a line, arc, circle, ellipse, elliptical arc, 2D polyline, 3D polyline,
or spline. The direction vector can be a line or an open 2D or 3D polyline.
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TABSURF creates the mesh as a series of parallel polygons running along a
specified path. The original object and the direction vector must already be
drawn, as shown in the following illustrations.

Create a Revolved Mesh

Use the REVSURF command to create a revolved mesh by rotating a profile
of the object about an axis. REVSURF is useful for mesh forms with rotational
symmetry.

The profile is called a path curve. It can consist of any combination of lines,
circles, arcs, ellipses, elliptical arcs, polylines, splines, closed polylines,
polygons, closed splines, or donuts.

Create an Edge-Defined Mesh

With the EDGESURF command, you can create a Coons surface patch mesh, as
shown in the following illustration, from four objects called edges. Edges can
be arcs, lines, polylines, splines, or elliptical arcs that form a closed loop and
share endpoints. A Coons patch is a bicubic surface (one curve in the M
direction and another in the N direction) interpolated between the four edges.
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To create a ruled mesh

1 Click Home tab ➤ Modeling panel ➤ Ruled Surface. 

2 Select an object to act as the first defining curve.

3 Select a second object as the second defining curve.

Mesh segments are drawn between the defining curves. The number of
segments equals the value set for SURFTAB1.

4 Erase the original curves if necessary.

Command entry: RULESURF

To create a tabulated mesh

1 Click Home tab ➤ Modeling panel ➤ Tabulated Surface. 

2 Specify an object to define the overall shape of the tabulated surface (the
path curve).

The object can be a line, arc, circle, ellipse, or a 2D or 3D polyline.

3 Specify an open line or polyline that defines the direction vector.

The mesh is extended from the start point to the endpoint of the direction
vector.

4 Erase the original objects if necessary.

Command entry: TABSURF

To create a revolved mesh

1 Click Home tab ➤ Modeling panel ➤ Revolved Surface. 

2 Specify an object to define the path curve.

The path curve, which defines the N direction of the mesh, can be a line,
arc, circle, ellipse, elliptical arc, 2D polyline, 3D polyline, or spline. If you
select a circle, closed ellipse, or closed polyline, the mesh is closed in the
N direction.
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3 Specify an object to define the axis of revolution.

The direction vector can be a line or an open 2D or 3D polyline. If you
choose a polyline, the vector sets the rotation axis from its first vertex to
its last vertex. Any intermediate vertices are ignored. The axis of revolution
determines the M direction of the mesh.

4 Specify the start angle.

If you specify a nonzero start angle, the mesh is generated at a position
offset from the path curve by that angle.

5 Specify the included angle.

The included angle specifies how far the mesh extends around the axis
of revolution.

6 Erase the original objects if necessary.

Command entry: REVSURF

To create an edge-defined Coons surface patch mesh

1 Click Home tab ➤ Modeling panel ➤ Edge Surface. 

2 Select four objects to define the four adjoining edges of the mesh patch.

The objects can be arcs, lines, polylines, splines, or elliptical arcs that
form a closed loop and share endpoints.

The first edge you select determines the M direction of the mesh.

Command entry: EDGESURF

Quick Reference

Commands

EDGESURF

Creates a mesh between four contiguous edges or curves.

PEDIT

Edits polylines and 3D polygon meshes.

1258 | Chapter 20   Create 3D Models



PFACE

Creates a 3D polyface mesh vertex by vertex.

REVSURF

Creates a mesh by revolving a profile about an axis.

RULESURF

Creates a mesh that represents the surface between two lines or curves.

TABSURF

Creates a mesh from a line or curve that is swept along a straight path.

VISUALSTYLES

Creates and modifies visual styles and applies a visual style to a viewport.

System Variables

FACETRATIO

Controls the aspect ratio of faceting for cylindrical and conic solids.

MESHTYPE

Controls the type of mesh that is created by REVSURF, TABSURF, RULESURF
and EDGESURF.

PLINECONVERTMODE

Specifies the fit method used in converting splines to polylines.

PFACEVMAX

Sets the maximum number of vertices per face.

SPLFRAME

Controls the display of splines and spline-fit polylines.

SURFTAB1

Sets the number of tabulations to be generated for the RULESURF and
TABSURF commands.

SURFTAB2

Sets the mesh density in the N direction for the REVSURF and EDGESURF
commands.
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SURFTYPE

Controls the type of surface-fitting to be performed by the Smooth option
of the PEDIT command.

SURFU

Sets the surface density for PEDIT Smooth in the M direction and the U
isolines density on surface objects.

SURFV

Sets the surface density for PEDIT Smooth in the N direction and the V
isolines density on surface objects.

Create Mesh by Conversion
Convert solids, surfaces, and legacy mesh types to mesh objects.

You can use the MESHSMOOTH command to convert certain objects to mesh.
Convert 3D solids, surfaces, and legacy mesh objects to the enhanced mesh
object in order to take advantage of capabilities such as smoothing, refinement,
creasing, and splitting.

Object Types That Can Be Converted

You obtain the most predictable results when you convert primitive solid
objects to mesh. That is, the resulting mesh adheres closely to the shape of
the original solid model.

You can also convert other types of objects, although the conversion results
may differ from what you expect. These objects include swept surfaces and
solids, legacy polygon and polyface mesh objects, regions, closed polylines,
and objects created with 3DFACE. For these objects, you can often improve
results by adjusting the conversion settings.
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Adjust Mesh Conversion Settings

If the conversion does not work as expected, try changing the settings in the
Mesh Tessellation Options dialog box. For example, if the Smooth Mesh
Optimized mesh type results in incorrect conversions, you can set the
tessellation shape to be Triangle or Mostly Quads.

You also can control the adherence to the original shape by setting the
maximum distance offset, angles, aspect ratios, and edge lengths for new faces.
The following example shows a 3D solid helix that has been converted to
mesh using different tessellation settings. The optimized mesh version has
been smoothed, but the other two conversions have no smoothness. Notice,
however, that the mostly quads conversion with the lower tessellation values
creates a mesh object that adheres most closely to the original version.
Smoothing this object improves its appearance even more.

Similarly, if you notice that a converted mesh object has a number of long,
slivered faces (which can sometimes cause gaps), try decreasing the Maximum
Edge Length for New Faces value.

If you are converting primitive solid objects, this dialog box also offers the
option of using the same default settings used to create primitive mesh objects.

When you select conversion candidates directly from this dialog box, you can
preview the results before you accept them.

See also:

■ Objects That Can Be Converted to Mesh
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To convert objects to mesh using defaults

1 Click Home tab ➤ Mesh panel ➤ Smooth Object. 

2 Select an object such as a 3D solid or surface.

(For a list of eligible objects, see Objects That Can Be Converted to Mesh.)

The objects are converted to mesh using the settings in the Mesh
Tessellation Options dialog box.

Toolbar: Mesh
Command entry: MESHSMOOTH

To modify conversion settings as you convert objects to mesh

1 Click Home tab ➤ Mesh panel ➤ dialog box launcher.

2 In the Mesh Tessellation Options dialog box, update the settings that
you want to change.

3 Click Select Objects to Tessellate.

4 Select an object such as a 3D solid or surface and press Enter.

(For a list of eligible objects, see Objects That Can Be Converted to Mesh.)

5 To display a preview of the converted object, click Preview.

The updated object is displayed in the drawing area.

6 Do one of the following:

■ To adjust the settings, press Esc to display the dialog box again. Repeat
steps 2 to 6.

■ To accept the conversion, press Enter.

Command entry: MESHOPTIONS

To modify mesh conversion settings

1 Click Home tab ➤ Mesh panel ➤ dialog box launcher.

2 In the Mesh Tessellation Options dialog box, update the settings that
you want to change and click OK.

Command entry: MESHOPTIONS
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Quick Reference

Commands

MESHOPTIONS

Displays the Mesh Tessellation Options dialog box, which controls default
settings for converting existing objects to mesh objects.

MESHPRIMITIVEOPTIONS

Displays the Mesh Primitive Options dialog box, which sets the tessellation
defaults for primitive mesh objects.

MESHSMOOTH

Converts 3D objects such as polygon meshes, surfaces, and solids to mesh
objects.

System Variables

FACETERDEVNORMAL

Sets the maximum angle between the surface normal and contiguous mesh
faces.

FACETERDEVSURFACE

Sets how closely the converted mesh object adheres to the original shape of
the solid or surface.

FACETERGRIDRATIO

Sets the maximum aspect ratio for the mesh subdivisions that are created
for solids and surfaces converted to mesh.

FACETERMAXEDGELENGTH

Sets the maximum length of edges for mesh objects that are created by
conversion from solids and surfaces.

FACETERMAXGRID

Sets the maximum number of U and V grid lines for solids and surfaces
converted to mesh.

FACETERMESHTYPE

Sets the type of mesh to be created.
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FACETERMINUGRID

Sets the minimum number of U grid lines for solids and surfaces that are
converted to mesh.

FACETERMINVGRID

Sets the minimum number of V grid lines for solids and surfaces that are
converted to mesh.

FACETERPRIMITIVEMODE

Specifies whether smoothness settings for objects that are converted to mesh
are derived from the Mesh Tessellation Options or the Mesh Primitive Options
dialog box.

FACETERSMOOTHLEV

Sets the default level of smoothness for objects that are converted to mesh.

Create Custom Mesh (Legacy)
Create custom polygon or polyface mesh by specifying vertices.

Specify individual vertices when you create mesh using the 3DMESH, PFACE,
and 3DFACE commands.

Understand Legacy Mesh Construction

The mesh density controls the number of facets in legacy polygonal and
polyface meshes. Density is defined in terms of a matrix of M and N vertices,
like a grid consisting of columns and rows. M and N specify the column and
row position, respectively, of any given vertex.

A mesh can be open or closed. If the start and end edges of the mesh do not
touch, a mesh is open in a given direction, as shown in the following
illustrations.
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Create a Rectangular Mesh

With the 3DMESH command, you can create polygon meshes that are open
in both the M and N directions (like the X and Y axes of an XY plane). In most
cases, you can use 3DMESH in conjunction with scripts or AutoLISP routines
when you know the mesh points.

As you create the mesh, you specify the size of the mesh in the M and N
directions. The total number of vertices you specify for the mesh is equal to
the M value times the N value.
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You can close the meshes with PEDIT. You can use 3DMESH to construct
irregular meshes.

Example:

In the following example of text at the Command prompt, you enter the
coordinate values for each vertex to create the mesh in the illustration.

Command: 3dmesh
Mesh M size: 4
Mesh N size:  3
Vertex (0, 0): 10,1, 3
Vertex (0, 1): 10, 5, 5
Vertex (0, 2): 10,10, 3
Vertex (1, 0): 15,1, 0
Vertex (1, 1): 15, 5, 0
Vertex (1, 2): 15,10, 0
Vertex (2, 0): 20,1, 0
Vertex (2, 1): 20, 5, -1
Vertex (2, 2): 20,10 ,0
Vertex (3, 0): 25,1, 0
Vertex (3, 1): 25, 5, 0
Vertex (3, 2): 25,10, 0

Create a Polyface Mesh

The PFACE command produces a polyface (polygon) mesh, with each face
capable of having numerous vertices. PFACE is typically used by applications
rather than by direct user input.

Creating a polyface mesh is like creating a rectangular mesh. To create a
polyface mesh, you specify coordinates for its vertices. You then define each
face by entering vertex numbers for all the vertices of that face. As you create
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the polyface mesh, you can set specific edges to be invisible, assign them to
layers, or give them colors.

To make the edge invisible, enter the vertex number as a negative value. For
instance, to make the edge between vertices 5 and 7 invisible in the following
illustration, you enter the following:

Face 3, vertex 3: -7

In the illustration, face 1 is defined by vertices 1, 5, 6, and 2. Face 2 is defined
by vertices 1, 4, 3, and 2. Face 3 is defined by vertices 1, 4, 7, and 5, and face
4 is defined by vertices 3, 4, 7, and 8.

You can control the display of invisible edges with the SPLFRAME system
variable. If SPLFRAME is set to a nonzero value, the invisible edges become
visible and can then be edited. If SPLFRAME is set to 0, the invisible edges
remain invisible.

Create Polyface Mesh Vertex by Vertex

With the 3DFACE command, you can create three-dimensional polyface mesh
by specifying each vertex. You can control visibility of each mesh edge
segment.

If you select a 3DFACE object during some mesh smoothing operations (such
as with MESHSMOOTHMORE), you are prompted to convert 3DFACE objects
to mesh objects.
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Create a Predefined 3D Mesh

The 3D command creates the following 3D shapes: boxes, cones, dishes, domes,
meshes, pyramids, spheres, tori (donuts), and wedges.

In the following illustrations, the numbers indicate points you specify to create
the mesh.

To view the objects you are creating with the 3D command more clearly, set
a viewing direction with 3DORBIT, DVIEW, or VPOINT.

To create a rectangular mesh

1 Click Home tab ➤ Modeling panel ➤ 3D Mesh.

2 Specify the M size, using an integer from 2 through 256.

3 Specify the N size, using an integer from 2 through 256.

4 Specify the vertex points as prompted. The number of vertices equals the
M value times the N value. Specifying the last vertex point completes the
mesh.
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Command entry: 3DMESH

Quick Reference

Commands

3DFACE

Creates a three-sided or four-sided surface in 3D space.

3DMESH

Creates a free-form polygon mesh.

PEDIT

Edits polylines and 3D polygon meshes.

PFACE

Creates a 3D polyface mesh vertex by vertex.

System Variables

PFACEVMAX

Sets the maximum number of vertices per face.

SPLFRAME

Controls the display of splines and spline-fit polylines.

Create Wireframe Models
A wireframe model is an edge or skeletal representation of a real-world 3D
object using lines and curves.

You can specify a wireframe visual style to help you see the overall structure
of 3D objects such as solids, surfaces, and meshes. In older drawings, you
might also encounter wireframe models that were created using legacy
methods.
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Wireframe models consist only of points, lines, and curves that describe the
edges of the object. Because each object that makes up a wireframe model
must be independently drawn and positioned, this type of modeling can be
the most time-consuming.

You can use a wireframe model to

■ View the model from any vantage point

■ Generate standard orthographic and auxiliary views automatically

■ Generate exploded and perspective views easily

■ Analyze spatial relationships, including the shortest distance between
corners and edges, and checking for interferences

■ Reduce the number of prototypes required

The ISOLINES system variable controls the number of tessellation lines used
to visualize curved portions of the wireframe. The FACETRES system variable
adjusts the smoothness of shaded and hidden-line objects.

Methods for Creating Wireframe Models

You can create wireframe models by positioning any 2D planar object anywhere
in 3D space, using the following methods:

■ Use the XEDGES command to create wireframe geometry from regions,
3D solids, surfaces, and meshes. XEDGES extracts all the edges on the
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selected objects or subobjects. The extracted edges form a duplicate
wireframe composed of 2D objects such as lines, circles, and 3D polylines.

■ Enter 3D coordinates that define the X, Y, and Z location of the object.

■ Set the default workplane (the XY plane of the UCS) on which to draw the
object.

■ Move or copy the object to its proper 3D location after you create it.

Wireframe modeling is a skill that requires practice and experience. The best
way to learn how to create wireframe models is to begin with simple models
before attempting models that are more complex.

Tips for Working with Wireframe Models

Creating 3D wireframe models can be more difficult and time-consuming
than creating their 2D views. Here are some tips that will help you work more
effectively:

■ Plan and organize your model so that you can turn off layers to reduce the
visual complexity of the model. Color can help you differentiate between
objects in various views.

■ Create construction geometry to define the basic envelope of the model.

■ Use multiple views, especially isometric views, to make visualizing the
model and selecting objects easier.

■ Become adept at manipulating the UCS in 3D. The XY plane of the current
UCS operates as a workplane to orient planar objects such as circles and
arcs. The UCS also determines the plane of operation for trimming and
extending, offsetting, and rotating objects.

■ Use object snaps and grid snap carefully to ensure the precision of your
model.

■ Use coordinate filters to drop perpendiculars and easily locate points in
3D based on the location of points on other objects.

To drop a perpendicular line from a 3D point down to the XY plane

1 Click Home tab ➤ Draw panel ➤ Line.

2 Use an object snap to specify a point on an object that is not on the XY
plane of the UCS.

This location defines the first point of the line.
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3 Enter .xy and then enter @ at the Of prompt.

This operation extracts the X and Y coordinate values from the first point.

4 Enter 0 to specify the Z value.

The X and Y values extracted from the first point are combined with a
new Z value (0) to finish the definition of the second point.

5 Press Enter to end the command.

Toolbar: Draw
Command entry: LINE

To create wireframe geometry by extracting edges

1 Click Home tab ➤ Solid Editing panel ➤ Extract Edges. 

2 Select one or more of the following objects:

■ 3D solids

■ Surfaces

■ Meshes

■ Regions

■ Edges (on 3D solids, surfaces, or meshes)

■ Faces (on 3D solids or meshes)

3 Press Enter.

Objects such as lines, arcs, splines, or 3D polylines are created along the
edges of the selected objects or subobjects.

Command entry: XEDGES

Quick Reference

Commands

UCS

Manages user coordinate systems.
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XEDGES

Creates wireframe geometry from the edges of a 3D solid, surface, mesh,
region, or subobject.

System Variables

ELEVATION

Stores the current elevation of new objects relative to the current UCS.

FACETRES

Adjusts the smoothness of shaded and rendered objects and objects with
hidden lines removed.

ISOLINES

Specifies the number of contour lines per surface on objects.

Add 3D Thickness to Objects
Use the thickness property to give objects a 3D appearance.

The 3D thickness of an object is the distance that object is extended, or
thickened, above or below its location in space. Positive thickness extrudes
upward in the positive Z direction; negative thickness extrudes downward
(negative Z). Zero (0) thickness means that there is no 3D thickening of the
object.

The orientation of the UCS when the object was created determines the Z
direction. Objects with a non-zero thickness can be shaded and can hide other
objects behind them.

The thickness property changes the appearance of the following types of
objects:

■ 2D solids

■ Arcs
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■ Circles

■ Lines

■ Polylines (including spline-fit polylines, rectangles, polygons, boundaries,
and donuts)

■ Text (only if created as a single-line text object using an SHX font)

■ Traces

■ Points

Modifying the thickness property of other types of objects does not affect
their appearance.

You can set the default thickness property for new objects you create by setting
the THICKNESS system variable. For existing objects, change the thickness
property on the Properties palette.

The 3D thickness is applied uniformly to an object; a single object cannot
have different thicknesses.

You might need to change the 3D viewpoint to see the effect of thickness on
an object.

NOTE  Although the THICKNESS variable sets an extruded thickness for new 2D
objects, those objects continue to be 2D objects. The THICKEN command adds
volume to a surface object, converting it to a 3D solid.

See also:

■ Create Surfaces from Objects on page 1216

To set the 3D thickness of new objects

1 Click Format menu  ➤ Thickness.

2 At the Command prompt, enter the value for the thickness distance.

When new objects are created, they have the specified 3D thickness.

Command entry: THICKNESS

To change the 3D thickness of existing objects

1 Select the objects whose 3D thickness you want to change.
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2 Right-click one of the objects. Click Properties.

3 In the Properties palette, select Thickness and enter a new value.

The selected objects change to display the specified 3D thickness.

Toolbar: Standard  
Command entry: PROPERTIES

Quick Reference

Commands

ELEV

Sets elevation and extrusion thickness of new objects.

PROPERTIES

Controls properties of existing objects.

THICKEN

Converts a surface into a 3D solid with a specified thickness.

System Variables

BACKZ

Stores the back clipping plane offset from the target plane for the current
viewport, in drawing units.

FRONTZ

Stores the front clipping plane offset from the target plane for the current
viewport, in drawing units.

THICKNESS

Sets the current 3D thickness.

VIEWMODE

Stores the View mode for the current viewport.
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Modify 3D Models

Change the appearance of a 3D model by manipulating both the object and its components.

Overview of Modifying 3D Objects
Three-dimensional modeling tools range from entering precise measurements
in the Properties palette, to more free-form methods such as grip and gizmo
editing. Some methods are specific to 3D solids or meshes. Other methods are
shared.

Convert to Other Object Types

In many cases, you can convert from one object type to another to take
advantage of specific editing capabilities.

For example you can convert selected surfaces, solids, and legacy mesh types
to mesh objects so that you can take advantage of smoothing and modeling
capabilities.

21
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Similarly, you can convert mesh to 3D solids and surfaces to accomplish some
composite object modeling tasks that are available only for those objects.
Conversion is often offered as a choice when you start activities that are
available only for solids and surfaces.

View Your Model from All Angles

When you work with any 3D object, you can easily make changes that are
not accurately reflected in the current view. To ensure that your modifications
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conform to your expectations, make sure you understand and use the
following:

■ Manipulate the 3D workplane (UCS). To understand how your model is
projected in 3D space, learn how to use the X, Y, and Z axes. See Specify
Workplanes in 3D (UCS) on page 650.

■ Rotate the view to display the model from different viewpoints. Several
navigation tools, including 3D Orbit and the ViewCube, are available to
help you rotate around your workspace. See Use Viewing Tools on page
321.

■ Display multiple viewports. Set up two or more viewports with different
viewing angles and visual styles. When you make a change in one viewport,
you can see its impact from several viewpoints at the same time. See Display
Multiple Views in Model Space on page 413.

Modify Properties of 3D Objects
Modify 3D objects by changing their settings in the Properties palette.

As with other objects, you can modify the properties of 3D objects such as
solids, surfaces, and mesh. In addition, you can modify specific components,
known as subobjects: faces, edges, and vertices.

Modify the Primitive Shapes

Primitive solid forms include basic shapes such as boxes, wedges, pyramids,
spheres, cylinders, cones, and tori. Each type of primitive solid has unique
properties. By changing settings in the Properties palette, you can modify
basic size, height, and shape characteristics. For example, to change a four-sided
pyramid that ends in a point to an eight-sided pyramid that ends in a planar
surface (pyramid frustum), update the Top Radius and Sides properties.
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Set Whether to Retain Compound Object History

With 3D solids that have been recombined to form compound objects, you
can choose to retain the history subobject, which represents components that
have been removed. The Properties palette controls the availability and display
of these histories. See Work with Complex 3D Solids and Surfaces on page 1326.

Modify Loft Settings

For lofted solids or surfaces, you can modify such properties as the number
of isolines and how the profile passes through the cross sections. (These
properties are set in the Loft Settings dialog box during the loft operation.)
The Surface Normals property settings change the overall shape of the lofted
object.

■ Ruled. Specifies that the solid or surface is ruled between the cross sections
and has sharp edges at the cross sections.

■ Smooth. Specifies that a smooth solid or surface is interpolated between
the cross sections and has sharp edges at the start and end cross sections.
The adjacent cross sections control the tangent direction.

1280 | Chapter 21   Modify 3D Models



■ First Normal. Specifies that the surface normal is perpendicular to the first
cross section.

■ Last Normal. Specifies that the surface normal is perpendicular to the last
cross section.

■ Ends Normal. Specifies that the surface normal is perpendicular to both
the first and last cross sections.
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■ All Normal. Specifies that the surface normal is perpendicular to all cross
sections.

■ Use Draft Angles. Controls the draft angle of the first and last cross sections
of the lofted solid or surface. The following variables control the draft angle
settings: LOFTANG1, LOFTANG2, LOFTMAG1, and LOFTMAG2.

Modify 3D Object and Subobject Properties

You can modify the properties of the 3D solid, surface, and mesh object in
the Properties palette. In addition, you can modify specific properties of
individual subobjects, such as faces, edges, and vertices. Different properties
are available for different types of subobjects.

In some cases, the application of properties can differ. depending on the object
type. For example, you can modify the properties of mesh faces, including
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their color. However, the color appearance of a mesh face might differ from
the equivalent color on a 3D solid face. This difference occurs because changing
the color of a face modifies the diffuse color of the face, but not the ambient
color (which is derived from the mesh material property). To obtain a closer
match between the color of 3D solid and mesh faces, you can add lights and
turn off the default lighting (which disables ambient lighting). You can also
try assigning a material that has the same ambient and diffuse color. For more
information see Create Materials.

Modify Mesh Forms by Changing Properties

Mesh objects have additional properties that control the level of smoothness
and creases. Crease properties of face, edge, and vertex subobjects are also
reflected in the Properties palette.

■ Level of Smoothness. Smooths or sharpens the edges of a mesh object.

■ Crease Type. Specifies the presence of a crease (or sharpened edge) and
the effect of smoothing. Smoothing does not affect a crease with a value
of Always. A crease set to By Level retains its sharpness until the mesh
object is smoothed to the specified crease level.
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■ Crease Level. When a crease is set to By Level, indicates the smoothing
level at which the crease starts to lose its sharpness.

To modify the contour of a lofted solid or surface by changing the surface
normal settings (Properties palette)

1 In a drawing, select a lofted solid or surface that was created with cross
sections.

2 If the Properties palette is not displayed, select any object. Right-click the
object to display the shortcut menu. Click Properties.

3 On the Properties palette, Geometry area, change the Surface Normals
setting. (For a description, see Modify Loft Settings on page 1280.)

To modify a mesh object in the Properties palette

1 If the Properties palette is not displayed, select any object. Right-click the
object to display the shortcut menu. Click Properties.

2 Click the mesh object to select it.

3 In the Properties palette, modify the properties you want to change.

Command entry: PROPERTIES

To modify a mesh face, edge, or vertex in the Properties palette

1 If the Properties palette is not displayed, select any object. Right-click the
object to display the shortcut menu. Click Properties.

2 Press Ctrl+click the mesh face, edge, or vertex that you want to modify.
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NOTE If you cannot select a specific subobject, verify whether subobject
selection filtering is turned on for a different subobject type. (Right-click in
the drawing area and click Subobject Selection Filter.)

3 In the Properties palette, modify the properties you want to change.

Command entry: PROPERTIES

Quick Reference

Commands

PROPERTIES

Controls properties of existing objects.

System Variables

LOFTANG1

Sets the draft angle through the first cross section in a loft operation.

LOFTANG2

Sets the draft angle through the last cross section in a loft operation.

LOFTMAG1

Sets the magnitude of the draft angle through the first cross section in a loft
operation.

LOFTMAG2

Sets the magnitude of the draft angle through the last cross section in a loft
operation.

Use Grips and Gizmos to Modify 3D Models
Use grips and gizmos to change the shape and size of solids and surfaces.

Select 3D Subobjects
Select faces, edges, and vertices by pressing Ctrl as you select 3D objects.

A subobject is a face, edge or vertex of a solid, surface, or mesh object.
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Select Subobjects

To select a face, edge, or vertex of a 3D object, press Ctrl as you select the
object. Selected subobjects display different types of grips, depending on the
subobject type.

You can select one or more subobjects on any number of 3D objects. The
selection set can include more than one type of subobject. Press Ctrl to select
subobjects at the selection prompts of the MOVE, ROTATE, SCALE, and ERASE
commands.

You can remove an item from the selection set by pressing the Shift key and
selecting it again.

Select Subobjects on Composite 3D Solids

Press and hold Ctrl to select faces, edges, and vertices on composite solids. If
the History property of the composite solid is set to Record, the first “pick”
might select the history subobject. (The history subobject is the portion of the
original object that was removed during the union, subtract, or intersect
operation.) Continue to hold down Ctrl and pick again to select a face, edge,
or vertex on the original form.
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Cycle Through Multiple Subobjects

Selection sets can contain any number of 3D solids, surfaces, meshes, and
subobjects.

In 3D views, some objects or subobjects might be hidden behind others. You
can press Ctrl+Spacebar to cycle through the hidden subobjects until the object
you want to select is highlighted.

For example, when you select faces on a box, the face in the foreground is
detected first. To select a hidden face, press the Spacebar (with Ctrl still
pressed). Release the Spacebar and click to select the face.

For best results, make sure that Selection Preview is turned on in the Options
dialog box. If selection preview is turned off, you can cycle through hidden
subobjects by pressing Ctrl+Spacebar as you click until the subobject is selected.

Turn on the Subobject Selection Filter

Selecting a specific type of subobject can be difficult on complex objects, such
as meshes. You can limit the selection to a face, edge, vertex, or history
subobject by setting a subobject selection filter.

Stored in the SUBOBJSELECTIONMODE system variable, this setting can be
changed from the shortcut menu or on the ribbon.
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When a subobject filter is turned on, the following icons are displayed near
the cursor:

Vertex filtering is on

Edge filtering is on

Face filtering is on

History subobject filtering is on

Subobject not eligible for selection

To select one or more faces, edges, or vertices on a 3D object

1 Press Ctrl+click a face, edge, or vertex.

2 Repeat step 1 until all subobjects are selected.

To create a selection set of 3D objects and subobjects

1 Click the required solid and surface objects.

2 Press and hold Ctrl.

3 Click a face, edge, or vertex.

4 Repeat steps 1 through 3 until the required subobjects are selected.

Command entry: SELECT

To remove a subobject from a selection set

1 Press and hold Ctrl+Shift.

2 Click a selected face, edge, or vertex.

The grip, if displayed, changes from red to blue.
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To select a face, edge, or vertex on the history form of a composite solid

1 Press and hold Ctrl.

2 Select the original form on which you want to select a face, edge, or
vertex.

3 With Ctrl still pressed, click a face, edge, or vertex.

You might need to repeat this step to select the required face, edge, or
vertex.

Command entry: SELECT (Subobject option)

To cycle through and select subobjects that are overlapping

1 Press and hold Ctrl as you press the Spacebar to cycle through the
subobjects that are both visible and hidden.

2 If the subobject that you want to select is not highlighted during the
cycle, move the cursor and repeat.

3 When the subobject is highlighted, release the Spacebar and click.

The subobject is selected.

To limit selection to a specific type of subobject

1 Click Home tab ➤ Subobject panel ➤ No Filter, Edge, Vertex, Face, or
Solid History.

2 Press Ctrl+click a 3D solid or mesh subobject.

Only the subobject type that you specified can be selected. If you specified
None, all subobject types can be selected.

Shortcut menu: Subobject Selection Filter
Command entry: SUBOBJSELECTIONMODE

Quick Reference

Commands

ERASE

Removes objects from a drawing.
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MOVE

Moves objects a specified distance in a specified direction.

ROTATE

Rotates objects around a base point.

SCALE

Enlarges or reduces selected objects, keeping the proportions of the object
the same after scaling.

SELECT

Places selected objects in the Previous selection set.

SOLIDEDIT

Edits faces and edges of 3D solid objects.

System Variables

GRIPHOVER

Controls the fill color of an unselected grip when the cursor pauses over it.

GRIPOBJLIMIT

Suppresses the display of grips when the selection set includes more than
the specified number of objects.

GRIPS

Controls the use of selection set grips for the Stretch, Move, Rotate, Scale,
and Mirror Grip modes.

GRIPSIZE

Sets the size of the grip box in pixels.

GRIPSUBOBJMODE

Sets whether edge, face, or vertex grips are active upon initial selection.

LEGACYCTRLPICK

Specifies the keys for selection cycling and the behavior for Ctrl+click.

SUBOBJSELECTIONMODE

Filters whether a face, edge, or vertex is selected with Ctrl+click.
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Use Grips to Edit 3D Solids and Surfaces
Use grips to change the size and shape of some individual solids and surfaces.

The method you use to manipulate the 3D solid or surface depends on the
type of object and the method used to create it.

NOTE For mesh objects, only the center grip is displayed. However you can edit
mesh objects with the 3D Move, Rotate, or Scale gizmos.

Primitive Solid Forms and Polysolids

You can drag grips to change the shape and size of primitive solids and
polysolids. For example, you can change the height and base radius of a cone
without losing the overall cone shape. Drag the top radius grips to transform
the cone to a flat-topped, frustum cone.

Extruded Solids and Surfaces

You can convert 2D objects to solids and surfaces with the EXTRUDE
command. When selected, extruded solids and surfaces display grips on their
profiles. A profile is the original outline that defines the shape of the extruded
solid or surface. Drag profile grips to modify the overall shape of the object.

If the extrusion was created along a sweep path, the path can be manipulated
with grips. If a path was not used, you can modify the height of the object
using a grip at the top of the extruded solid or surface.

Swept Solids and Surfaces

Swept solids and surfaces display grips on the swept profile as well as on the
sweep path. You can drag these grips to modify the solid or surface.
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When you click and drag a grip on the profile, the changes are constrained
to the plane of the profile curve.

Lofted Solids and Surfaces

Depending on how a lofted solid or surface was created, the solid or surface
displays grips on the following, defining lines or curves:

■ Cross section

■ Path

Drag grips on any of the defining lines or curves to modify the shape. If the
lofted object contains a path, you can only edit the portion of the path that
is between the first and last cross sections.

You cannot use grips to modify lofted solids or surfaces that are created with
guide curves.

Revolved Solids and Surfaces

Revolved solids and surfaces display grips on the revolved profile at the start
of the revolved solid or surface. You can use these grips to modify the profile
of the solid of surface.
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A grip is also displayed at the axis of revolution endpoint. You can relocate
the axis of revolution by dragging the grip to another location.

See also:

■ Create 3D Solids and Surfaces on page 1175

■ Create a Solid Cone on page 1185

To relocate the axis of revolution for a revolved solid or surface

1 In a drawing, select a revolved solid or surface.

2 Select the grip on the axis of revolution.

3 Click in another location to relocate the axis of revolution.

Quick Reference

Commands

EXTRUDE

Extends the dimensions of a 2D object or 3D face into 3D space.

SELECT

Places selected objects in the Previous selection set.

System Variables

GRIPHOVER

Controls the fill color of an unselected grip when the cursor pauses over it.
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GRIPOBJLIMIT

Suppresses the display of grips when the selection set includes more than
the specified number of objects.

GRIPS

Controls the use of selection set grips for the Stretch, Move, Rotate, Scale,
and Mirror Grip modes.

GRIPSIZE

Sets the size of the grip box in pixels.

GRIPSUBOBJMODE

Sets whether edge, face, or vertex grips are active upon initial selection.

Use Gizmos to Modify Objects
Use gizmos to move, rotate, or scale objects and subobjects in a 3D view.

Overview of Using Gizmos
Gizmos help you move, rotate, or scale a set of objects along a 3D axis or
plane.

There are three types of gizmos:

■ 3D Move gizmo. Relocates selected objects along an axis or plane.

■ 3D Rotate gizmo. Rotates selected objects about a specified axis.

■ 3D Scale gizmo. Scales selected objects along a specified plane or axis, or
uniformly along all 3 axes.

By default, gizmos are displayed automatically when you select an object or
subobject in a view that has a 3D visual style. Because they constrain
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modifications along specific planes or axes, gizmos help ensure more
predictable results.

You can specify which gizmos are displayed when an object is selected, or you
can suppress their display.

Quick Reference

Commands

3DMOVE

In a 3D view, displays the 3D Move gizmo to aid in moving 3D objects a
specified distance in a specified direction.

3DROTATE

In a 3D view, displays the 3D Rotate gizmo to aid in revolving 3D objects
around a base point.

3DSCALE

In a 3D view, displays the 3D Scale gizmo to aid in resizing 3D objects.

System Variables

DEFAULTGIZMO

Sets the 3D Move, 3D Rotate, or 3D Scale gizmo as the default during
subobject selection.

GRIPSUBOBJMODE

Sets whether edge, face, or vertex grips are active upon initial selection.

GTAUTO

Controls whether 3D gizmos are automatically displayed when you select
objects before you start a command in a viewport with a 3D visual style.

GTDEFAULT

Controls whether the 3D Move, 3D Rotate, or 3D Scale operation starts
automatically when you start the MOVE, ROTATE, or SCALE command in
a viewport with a 3D visual style.

GTLOCATION

Controls the initial location of the 3D Move, 3D Rotate, or 3D Scale gizmo
when you select objects before you start a command in a viewport with a
3D visual style.
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Use the Gizmos
Gizmos help move, rotate, and scale 3D objects and subobjects.

Display the Gizmos

Gizmos are available only in 3D views that are set to use a 3D visual style such
as 3D Hidden. You can set the gizmo to be displayed automatically when you
select a 3D object or subobject. Gizmos are also displayed during the 3DMOVE,
3DROTATE, and 3DSCALE commands.

If the visual style is set to 2D Wireframe, entering 3DMOVE, 3DROTATE, or
3DSCALE automatically converts the visual style to 3D Wireframe.

By default, the gizmo is initially placed in the center of the selection set.
However, you can relocate it anywhere in 3D space. The center box (or base
grip) of the gizmo sets the base point for the modification. This behavior is
equivalent to temporarily changing the position of the UCS as you move or
rotate the selected objects. The axis handles on the gizmo constrain the
movement or rotation to an axis or plane.

For best results, use object snaps to locate the grip center box.

Switch Between the Gizmos

Whenever you select an object in a 3D view, the default gizmo is displayed.
You can select a different default on the ribbon, or change the value of the
the DEFAULTGIZMO system variable. You can also suppress the display of
gizmos when objects are selected.

After the gizmo is active, you can also switch to a different type of gizmo. The
switching behavior differs, depending on when you select the objects:

■ Select objects first. If a gizmo operation is in progress, you can press the
Spacebar repeatedly to cycle through the other gizmo types. When you
switch gizmos this way, the gizmo activity is constrained to the originally
selected axis or plane.
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During a gizmo operation, you can also select a different gizmo type on
the shortcut menu.

■ Run the command first. When you start the 3D Move, 3D Rotate, or 3D
Scale operation before selecting objects, the gizmo is placed at the center
of the selection set. Use the Relocate Gizmo option on the shortcut menu
to relocate the gizmo anywhere in 3D space. You can also choose a different
type of gizmo on the shortcut menu.

Change the Gizmo Settings

The following settings affect the display of gizmos:

■ Default gizmo. The DEFAULTGIZMO system variable specifies which gizmo
is displayed by default when an object is selected in a view with a 3D visual
style. You can turn off display of the gizmo. This setting is also available
on the ribbon.

■ Default location. The GTLOCATION system variable sets the default
location of the gizmo. The gizmo can be displayed at the center of the
selection set (default), or it can be positioned at the 0,0,0 coordinates of
the current UCS.

■ Automatic display. The GTAUTO system variable sets whether gizmos are
displayed automatically whenever you select objects in a 3D view that is
set to a 3D visual style (default). If you turn off this system variable, the
grips are not displayed until the gizmos are active.

■ Conversion of move, rotate, and scale operations from 2D to 3D. Turn on
the GTDEFAULT system variable to start the 3DMOVE, 3DROTATE, or
3DSCALE command automatically when the MOVE, ROTATE, or SCALE
command is started in a 3D view. This system variable is turned off by
default.

■ Active status of subobject grips. If you press Ctrl+click a subobject, the
GRIPSUBOBJMODE system variable sets whether the subobject grips are
active immediately. Setting subobject grips to be active upon selection
helps you modify groups of mesh subobjects without selecting them again.

To specify which 3D gizmo is displayed by default when an object is selected

■ Click Home tab  ➤  Subobject panel  ➤  Move Gizmo, Rotate Gizmo, or
Scale Gizmo.
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Command entry: At the Command prompt, enter DEFAULTGIZMO. Then
enter 0 (Move Gizmo), 1 (Rotate Gizmo), or 2 (Scale Gizmo).

To suppress the display of the 3D gizmo when an object is selected

■ Click Home tab  ➤ Subobject panel  ➤ No Gizmo. 

Command entry: At the Command prompt, enter DEFAULTGIZMO, then
enter 3 (No Gizmo).

To set the default location for gizmos

1 At the Command prompt, enter gtlocation.

2 Do one of the following:

■ Enter 1 to set the location at the geometric center of the selection set.

■ Enter 0 to set the location to overlap the UCS icon.

3 Press Enter.

To relocate a gizmo

1 Right-click the center box (base grip) of the gizmo. Click Relocate Gizmo.

2 Click in the drawing area to specify a new location.

To change the type of gizmo while moving, rotating, or scaling objects

1 Select the 3D objects that you want to move, rotate, or scale.

■ To modify the entire object, select the object.

■ To modify a subobject (face, edge, or vertex), press Ctrl+click the
subobject. (You can limit the selection set by specifying a subobject
selection filter on the shortcut menu.)

2 Hover the cursor over an axis handle on the gizmo until it turns yellow
and the axis vector displays. Then click the axis handle.

3 Press the Spacebar to cycle through the gizmo types until the correct
gizmo is displayed.

When you change gizmos this way, the movement remains constrained
to the selected axis.
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NOTE You cannot use the Spacebar to change the type of gizmo when the
3DMOVE, 3DROTATE, or 3DSCALE command is active.

Shortcut menu: Right-click the gizmo  ➤  Move, Rotate, or Scale

Quick Reference

Commands

3DMOVE

In a 3D view, displays the 3D Move gizmo to aid in moving 3D objects a
specified distance in a specified direction.

3DROTATE

In a 3D view, displays the 3D Rotate gizmo to aid in revolving 3D objects
around a base point.

3DSCALE

In a 3D view, displays the 3D Scale gizmo to aid in resizing 3D objects.

System Variables

DEFAULTGIZMO

Sets the 3D Move, 3D Rotate, or 3D Scale gizmo as the default during
subobject selection.

GRIPSUBOBJMODE

Sets whether edge, face, or vertex grips are active upon initial selection.

GTAUTO

Controls whether 3D gizmos are automatically displayed when you select
objects before you start a command in a viewport with a 3D visual style.

GTDEFAULT

Controls whether the 3D Move, 3D Rotate, or 3D Scale operation starts
automatically when you start the MOVE, ROTATE, or SCALE command in
a viewport with a 3D visual style.

GTLOCATION

Controls the initial location of the 3D Move, 3D Rotate, or 3D Scale gizmo
when you select objects before you start a command in a viewport with a
3D visual style.
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Move 3D Objects
Move a selection set of objects and subobjects freely or constrain the movement
to an axis or plane.

To move 3D objects and subobjects, click and drag the gizmo anywhere in 3D
space. This location (indicated by the center box [or base grip] of the gizmo)
sets the base point for the movement and temporarily changes the position
of the UCS while you move the selected objects.

To move the objects freely, drag outside the gizmo or specify the axis or plane
to which you will constrain the movement.

Constrain the Movement to an Axis

You can use the Move gizmo to constrain the movement to an axis. As the
cursor hovers over an axis handle on the gizmo, a vector aligned with the axis
is displayed, and the specified axis turns yellow. Click the axis handle.

As you drag the cursor, movement of the selected objects and subobjects is
constrained to the highlighted axis. You can click or enter a value to specify
the distance of the move from the base point. If you enter a value, the
movement direction of the object follows the initial direction of the cursor
movement.
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Constrain the Movement to a Plane

You can use the Move gizmo to constrain the movement to a plane. Each
plane is identified by a rectangle that extends from the respective axis handles.
You can specify the plane of movement by moving the cursor over the
rectangle. When the rectangle turns yellow, click it.

As you drag the cursor, the selected objects and subobjects move only along
the highlighted plane. Click or enter a value to specify the distance of the
move from the base point.
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To move objects in 3D space along a specified axis

1 Click Home tab ➤ Modify panel ➤ 3D Move. 

2 Select the objects and subobjects you want to move using the following
methods:

■ Press and hold Ctrl to select subobjects (faces, edges, and vertices).

■ Release Ctrl to select entire objects.

3 When you have selected all objects, press Enter.

The Move gizmo is displayed attached to the cursor.

4 Click to place the Move gizmo, specifying the base point for the move.

5 Hover the cursor over an axis handle on the gizmo until it turns yellow
and the vector is displayed. Then click the axis handle.

6 Click or enter a value to specify the distance of the move.

Toolbar: Modeling  
Command entry: 3DMOVE

To move objects in 3D space constrained to a specified plane

1 Click Home tab ➤ Modify panel ➤ 3D Move. 

2 Select the objects and subobjects you want to move using the following
methods:

■ Press and hold Ctrl to select subobjects (faces, edges, and vertices).

■ Release Ctrl to select entire objects.

3 When you have selected all objects, press Enter.

The Move gizmo is displayed attached to the cursor.

4 Click to place the Move gizmo, specifying the base point for the move.

5 Move the cursor over the planar rectangle that intersects the axis handles
that define the plane of constraint. When the rectangle turns yellow,
click it.
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6 Click or enter a value to specify the distance of the move.

Toolbar: Modeling  
Command entry: 3DMOVE

Quick Reference

Commands

3DMOVE

In a 3D view, displays the 3D Move gizmo to aid in moving 3D objects a
specified distance in a specified direction.

System Variables

DEFAULTGIZMO

Sets the 3D Move, 3D Rotate, or 3D Scale gizmo as the default during
subobject selection.

Rotate 3D Objects
Constrain the rotation of 3D objects and subobjects to an axis.

After you select the objects and subobjects that you want to rotate, the gizmo
is located at the center of the selection set. This location is indicated by the
center box (or base grip) of the gizmo. It sets the base point for the movement
and temporarily changes the position of the UCS while you rotate the selected
objects.

You then rotate the objects freely by dragging outside the gizmo. You can also
specify an axis about which to constrain the rotation.

If you want to realign the center of rotation, you can relocate the gizmo by
using the Relocate Gizmo option on the shortcut menu.
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Constrain the Rotation to an Axis

You can constrain the rotation to a specified axis. As you move the cursor
over the rotation paths on the 3D rotate gizmo, a vector line representing the
axis of rotation is displayed. Specify an axis of rotation by clicking the rotation
path when it turns yellow.

When you drag the cursor, the selected objects and subobjects rotate about
the base point along the specified axis. The gizmo displays the degree of
rotation from the original position of the object as the object moves. You can
click or enter a value to specify the angle of the rotation.

To rotate objects in 3D space along a specified axis

1 Click Home tab ➤ Modify panel ➤ 3D Rotate. 

2 Select the objects and subobjects you want to rotate using the following
methods:

■ Press and hold Ctrl to select subobjects (faces, edges, and vertices).

■ Release Ctrl to select entire objects.

3 When you have selected all objects, press Enter.

The rotate gizmo is displayed attached to the cursor.

4 Click to place the rotate gizmo, specifying the base point for the move.
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5 Hover the cursor over an axis path on the gizmo until it turns yellow and
the vector that represents the axis of rotation is displayed. Click the path.

6 Click or enter a value to specify the angle of the rotation.

Toolbar: Modeling  
Command entry: 3DROTATE

Quick Reference

Commands

3DROTATE

In a 3D view, displays the 3D Rotate gizmo to aid in revolving 3D objects
around a base point.

System Variables

DEFAULTGIZMO

Sets the 3D Move, 3D Rotate, or 3D Scale gizmo as the default during
subobject selection.

Scale 3D Objects
Change the size of 3D objects uniformly or along a specified axis or plane.

After you select the objects and subobjects to scale, you can constrain the
object scaling by clicking the gizmo axis, plane, or the portion of the gizmo
between all three axes.
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Scale a 3D Object Along an Axis

You can constrain object scaling to a specified axis. As you move the cursor
over the axes on the 3D Scale gizmo, a vector line representing the axis of
scale is displayed. Specify an axis of scale by clicking the axis when it turns
yellow.

When you drag the cursor, the selected objects and subobjects are resized
along the specified axis. You can click or enter a value to specify the scale
from the selected base point.

Scale a 3D Object Along a Plane

You can constrain the object scaling to a specified plane. Each plane is
identified by a bar that extends from the outer ends of the respective axis
handles. You can specify the plane of scale by moving the cursor over one of
the bars. When the bar turns yellow, click it.
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As you drag the cursor, the selected objects and subobjects are scaled only
along the highlighted plane. Click or enter a value to specify the scale from
the selected base point.

Scale a 3D Object Uniformly

You can scale an object uniformly along all axes. As you move the cursor
toward the center point of the gizmo, a highlighted triangular area indicates
that you can click to scale the selected objects and subobjects along all three
axes.
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As you drag the cursor, the selected objects and subobjects are scaled uniformly.
Click or enter a value to specify the scale from the selected base point.

To scale a 3D object along a specified axis

1 Click Home tab ➤ Modify ➤ 3D Scale. 

2 Select the objects and subobjects you want to scale using the following
methods:

■ Press and hold Ctrl to select subobjects (faces, edges, and vertices).

■ Release Ctrl to select entire objects.

3 When you have selected all objects, press Enter.

The Scale gizmo is displayed at the center of the selected object or objects.

4 Specify a base point for the scale.

5 Hover the cursor over one of the axes of the gizmo until it turns yellow.
Click the yellow axis.

6 Click or enter a value to specify the scale of the selected object.

Command entry: 3DSCALE
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To scale a 3D object along a specified plane

1 Click Home tab ➤ Modify ➤ 3D Scale. 

2 Select the objects and subobjects you want to scale using the following
methods:

■ Press and hold Ctrl to select subobjects (faces, edges, and vertices).

■ Release Ctrl to select entire objects.

3 When you have selected all objects, press Enter.

The Scale gizmo is displayed at the center of the selected object or objects.

4 Specify a base point for the scale.

5 Hover the cursor over one of the bars found between each of the axes of
the gizmo until it turns yellow. Click the yellow bar.

6 Click or enter a value to specify the scale of the selected object.

Command entry: 3DSCALE

To scale a 3D object uniformly

1 Click Home tab ➤ Modify ➤ 3D Scale. 

2 Select the objects and subobjects you want to scale using the following
methods:

■ Press and hold Ctrl to select subobjects (faces, edges, and vertices).

■ Release Ctrl to select entire objects.

3 When you have selected all objects, press Enter.

The Scale gizmo is displayed at the center of the selected object or objects.

4 Specify a base point for the scale.

5 Hover the cursor over the triangular area closest to the center point of
the gizmo until it turns yellow. Click the yellow area.

6 Click or enter a value to specify the scale of the selected object.

Command entry: 3DSCALE
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Quick Reference

Commands

3DSCALE

In a 3D view, displays the 3D Scale gizmo to aid in resizing 3D objects.

System Variables

DEFAULTGIZMO

Sets the 3D Move, 3D Rotate, or 3D Scale gizmo as the default during
subobject selection.

Modify 3D Solid Subobjects
Modify the shape of a 3D solid by editing its subobjects (faces, edges, and
vertices).

Move, Rotate, and Scale 3D Subobjects
Move, rotate, and scale individual subobjects on 3D solids.

Use the same methods to modify a face, edge, or vertex that you use to modify
the entire object:

■ Drag grips

■ Use gizmos (3DMOVE, 3DROTATE, and 3DSCALE)

■ Enter object editing commands (MOVE, ROTATE, and SCALE)

When you move, rotate, or scale a subobject, the subobject is modified in a
way that maintains the integrity of the 3D solid. For example, when you drag
an edge to move it, the adjacent faces are adjusted so that they remain adjacent
to the edge.
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Several results are possible when you modify a solid. When you move, rotate,
or scale subobjects, you can press Ctrl one or more times as you drag to cycle
through modification options. The following illustration shows the
modification options for moving a face.

Move, Rotate, and Scale Subobjects on Composite Solids

When you modify composite solids, the effect of the edits depends on the
current setting of the History property.

■ To modify subobjects of each history component separately, the History
property must be set to Record.

■ To modify subobjects of the combined composite solid as a whole, the
History property must be set to None.

Rules and Limitations When Moving, Rotating, and Scaling Subobjects

You can only move, rotate, and scale subobjects on 3D solids if the operation
maintains the integrity of the solid. The following rules and limitations apply
to moving, rotating, and scaling subobjects:

■ When you use grips to modify subobjects, grips are not displayed on the
subobjects that cannot be moved, rotated, or scaled.

■ In most cases, you can move, rotate, and scale both planar and non-planar
faces.
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■ You can only modify an edge that is a straight line and that has at least
one planar adjacent face. The planes of the adjacent planar faces are
adjusted to contain the modified edge.

■ You cannot move, rotate, or scale edges (or their vertices) that are imprinted
inside faces.

■ You can only modify a vertex if it has at least one planar adjacent face.
The planes of the adjacent planar faces are adjusted to contain the modified
vertex.

■ When you drag a subobject, the final result might be different than the
preview displayed during the modification. This result occurs when the
solid geometry is adjusted in order to maintain its topology. In some cases,
the modification is not possible because it changes the topology of the
solid too severely.

■ If the modification causes spline surfaces to be extended, the operation is
often unsuccessful.

■ You cannot move, rotate, or scale non-manifold edges (edges that are
shared by more than two faces) or non-manifold vertices. Also, if some
non-manifold edges or vertices are present near faces, edges, and vertices
that you modify, the operation might not be possible.

See also:

■ Modify Mesh Objects on page 1337

Quick Reference

Commands

3DMOVE

In a 3D view, displays the 3D Move gizmo to aid in moving 3D objects a
specified distance in a specified direction.

3DROTATE

In a 3D view, displays the 3D Rotate gizmo to aid in revolving 3D objects
around a base point.

3DSCALE

In a 3D view, displays the 3D Scale gizmo to aid in resizing 3D objects.
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MOVE

Moves objects a specified distance in a specified direction.

ROTATE

Rotates objects around a base point.

SCALE

Enlarges or reduces selected objects, keeping the proportions of the object
the same after scaling.

System Variables

No entries

Modify Faces on 3D Objects
Modify individual faces on 3D objects using a variety of methods.

Move, Rotate, and Scale Faces on 3D Solids
Modify the location, rotation, and size of faces on a 3D solids.

cube with top face moved, rotated, and scaled

Use the MOVE, ROTATE, and SCALE commands to modify faces just as you
would with any other object. Press Ctrl+click to select a face on a solid.

If you move, rotate, or scale a face on a 3D solid primitive, the solid primitive’s
history is removed. The solid is no longer a true primitive and cannot be
manipulated using grips or the Properties palette.
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Face Modification Options

As you drag a face, press Ctrl to cycle through modification options.

■ Maintain shape of face, modify adjacent faces. When you move or rotate
a face without pressing Ctrl, the shape and size of the face is maintained.
However, the planes of adjacent faces might change.

■ Modify shape of face, retain edges. When you move or rotate a face and
press and release Ctrl once while dragging, the size of the face is modified
within the boundary, or footprint, of the adjacent faces.

■ Modify face, triangulate adjacent faces. When you move or rotate a face
and press and release Ctrl twice while dragging, the size and shape of the
face is maintained. (This behavior is the same as if you had not pressed
Ctrl). However, the adjacent planar faces are triangulated (divided into
two or more planar triangular faces), if necessary.

If you press and release Ctrl a third time, the modification returns to the first
option, as if you had not pressed Ctrl.
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Quick Reference

Commands

MOVE

Moves objects a specified distance in a specified direction.

ROTATE

Rotates objects around a base point.

SCALE

Enlarges or reduces selected objects, keeping the proportions of the object
the same after scaling.

System Variables

No entries

Copy, Delete, and Color Faces on 3D Solids
Copy, remove, or change the color of faces on 3D solid objects.

Copy a Face

You can duplicate the face of a 3D solid object using the copy option of the
SOLIDEDIT command. The selected faces are copied as regions or bodies.

Delete a Face

If you specify two points, the first point is used as a base point and a single
copy is placed relative to the base point. If you specify a single point and press
Enter, the original selection point is used as a base point. The next point is
the point of displacement.
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If a face is surrounded by coplanar faces, you can delete it using the following
methods:

■ Select the face and press Delete.

■ Select the face and enter erase.

■ Use the Delete option of the SOLIDEDIT command.

Color a Faces

You can modify the color of a face on a 3D solid by selecting the face and
then changing the Color property in the Properties palette.

See also:

■ Split or Extrude Mesh Faces on page 1352

To copy a face on a solid object

1 Click Home tab ➤ Solid Editing panel ➤ Face Editing drop-down ➤ Copy

Faces. 

2 Select the face to copy.

3 Select additional faces or press Enter to copy.

4 Specify the base point for the copy.

5 Specify the second point of displacement and press Enter.

NOTE Use EXTRUDE to extrude a copied face.

Command entry: SOLIDEDIT
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To delete a face on a solid object

1 Click Home tab ➤ Solid Editing panel ➤ Face Editing drop-down ➤ Delete
Faces.

2 Select the face to delete. (It must be surrounded by faces that share the
same plane.)

3 Select additional faces or press Enter to delete.

4 Press Enter to complete the command.

Toolbar: Solid Editing  
Command entry: SOLIDEDIT

To change the color of a face on a solid object

1 Press and hold Ctrl as you click a face on a 3D solid.

2 If the Properties palette is not displayed, select any object. Right-click the
object to display the shortcut menu. Click Properties.

3 In the Properties palette, under General, click the Color arrow and select
a color from the list

For additional color options, click Select Color to display the Select Color
dialog box. Specify a color and click OK.

PROPERTIES

Quick Reference

Commands

PROPERTIES

Controls properties of existing objects.

SOLIDEDIT

Edits faces and edges of 3D solid objects.
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System Variables

No entries

Modify Edges on 3D Objects
You can select and modify edges on a 3D solid.

Move, Rotate, and Scale Edges

Move, rotate, and scale the edges on 3D solids using grips, gizmos, and
commands.

cubes with edges moved, rotated, and scaled

You can use MOVE, ROTATE, and SCALE to modify edges on 3D solids just
as you can for any other object. Press and hold Ctrl to select the edge.

If you move, rotate, or scale an edge on a 3D solid primitive, the history of
the solid primitive is removed. The solid is no longer a true primitive and
cannot be manipulated using grips and the Properties palette.

Edges on regions can be selected, but do not display grips. These edges can
also be moved, rotated, and scaled.

Edge Modification Options

As you drag an edge, press Ctrl to cycle through modification options.
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■ Maintain length of edge. When you move, rotate, or scale an edge without
pressing Ctrl, the shared length of the edge and its vertices is maintained.
However, the planes of the adjacent faces adjacent might be changed.

■ Change the length of the edge. When you move, rotate, or scale an edge
and press and release Ctrl once while dragging, the edge is modified without
its vertices. The surfaces of the adjacent faces are maintained, but the
length of the modified edge might change.

■ Triangulate adjacent faces. When you move, rotate, or scale an edge and
press and release Ctrl twice while dragging, the edge and its vertices are
modified. (This behavior is the same as if you had not pressed Ctrl).
However, if the adjacent faces are no longer planar, they are triangulated
(divided into two or more planar triangular faces).

If you press and release Ctrl a third time, the modification returns to the first
option, as if you had not pressed Ctrl.

Delete Edges

You can also delete edges that completely divide two coplanar faces using one
of the following methods:

■ Select the edge and press Delete.

■ Select the edge and enter the ERASE command.
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Fillet and Chamfer 3D Solids and Surfaces

Add rounds and bevels to selected 3D solids using FILLET and CHAMFER. You
can modify the properties of the resulting 3D subobjects in the Properties
palette.

With the default method, you can specify the fillet radius and then select the
edges to fillet. Alternatively, you can specify individual measurements for
each filleted edge and fillet a tangential series of edges.

Color Edges

You can modify the color of an edge on a 3D object by selecting the edge and
changing the Color property in the Properties palette.

Copy Edges

You can copy individual edges on a 3D solid object. Edges are copied as lines,
arcs, circles, ellipses, or splines.

If you specify two points, the first point is used as a base point and a single
copy is placed relative to the base point. If you specify a single point, and then
press Enter, the original selection point is used as a base point. The next point
is used as a point of displacement.

See also:

■ Move, Rotate, and Scale 3D Subobjects on page 1310
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■ Use Gizmos to Modify Objects on page 1294

■ Modify Objects on page 1091

■ Move or Rotate Objects on page 1093

■ Resize or Reshape Objects on page 1122

■ Overview of Modifying Meshes on page 1337

To fillet a solid object

1 Click Home tab ➤ Modify panel ➤ Fillet. 

2 Select the edge of the solid to fillet.

3 Specify the fillet radius.

4 Select additional edges or press Enter to fillet.

Command entry: FILLET

To chamfer a 3D solid object

1 Click Home tab ➤ Modify panel ➤ Chamfer. 

2 Select the edge of the base surface to chamfer.

One of two surfaces adjacent to the selected edge is highlighted.

3 Do one of the following:

■ To select a different surface, enter n (Next).

■ To use the current surface, press Enter.

4 Specify the base surface distance.

The base surface distance is measured from the selected edge to a point
on the base surface. The other surface distance is measured from the
selected edge to a point on the adjacent surface.

5 Specify the location of the chamfer using one of the following options.

■ To specify an individual edge, select the edge.
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■ To select all edges around the base surface, enter l (Loop). Specify an
edge.

6 To complete the chamfer, press Enter.

Command entry: CHAMFER

To modify a fillet or chamfer on a 3D solid

1 Press and hold Ctrl as you select a fillet or chamfer on a 3D solid.

2 If the Properties palette is not displayed, select any object. Right-click the
object to display the shortcut menu. Click Properties.

3 In the Properties palette, modify the properties of the fillet or chamfer.

Command entry: PROPERTIES

To change the color of an edge on a solid object

1 Press and hold Ctrl as you click an edge on a 3D solid.

2 If the Properties palette is not displayed, select any object. Right-click the
object to display the shortcut menu. Click Properties.

3 In the Properties palette, under General, click the Color arrow and select
a color from the list

For additional color options, click Select Color to display the Select Color
dialog box. Specify a color and click OK.

PROPERTIES

To copy an edge on a solid object

1 Click Home tab ➤ Solid Editing panel ➤ Edge Editing drop-down  ➤ Copy
Edges.

2 Press Ctrl+click the edge of the face to copy.

3 Select additional edges, if needed, and press Enter.

4 Specify the base point of the copied edges.

5 Specify the second point of displacement to indicate the location of the
copied edges.

6 Press Enter to complete the command.
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Toolbar: Solid Editing  
Command entry: SOLIDEDIT

Quick Reference

Commands

EDGE

Changes the visibility of 3D face edges.

CHAMFER

Bevels the edges of objects.

FILLET

Rounds and fillets the edges of objects.

MOVE

Moves objects a specified distance in a specified direction.

PROPERTIES

Controls properties of existing objects.

ROTATE

Rotates objects around a base point.

SCALE

Enlarges or reduces selected objects, keeping the proportions of the object
the same after scaling.

SOLIDEDIT

Edits faces and edges of 3D solid objects.

System Variables

No entries

Modify Vertices on 3D Objects
Move, rotate, scale, or drag the vertices of 3D solids.
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wedge with two vertices moved

You can modify the form of a 3D solid by modifying one or more vertices.
Use grips and gizmos, or run the MOVE, ROTATE, or SCALE command. When
you scale or rotate vertices, you must select two or more vertices to see a
change in the solid object. Clicking and dragging a vertex “stretches” the 3D
object.

If you move, rotate, or scale one or more vertices on a 3D solid primitive, the
solid primitive history is removed. The solid is no longer a true primitive and
cannot be modified using grips and the Properties palette.

Vertex Modification Options

As you drag a vertex, press Ctrl to cycle through modification options.

■ Triangulate adjacent faces. When you move, rotate, or scale a vertex
without pressing Ctrl, some adjacent planar faces may be triangulated
(divided into two or more planar triangular faces).
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■ Modify some adjacent faces without triangulation. When you move, rotate,
or scale a vertex and press and release Ctrl once, some adjacent planar
faces might be adjusted.

If you press and release Ctrl a second time, the modification returns to the
first option, as if you had not pressed Ctrl.

Delete a Vertex

You can delete a vertex that connects two parallel edges that are collinear and
do not intersect on any other edges.

See also:

■ Move, Rotate, and Scale 3D Subobjects on page 1310

■ Use Gizmos to Modify Objects on page 1294

■ Modify Objects on page 1091

■ Overview of Modifying Meshes on page 1337

To move a vertex on a 3D object

1 Click Home tab  ➤  Subobject panel  ➤  Vertex.

2 Press Ctrl+click a vertex on a 3D object.

3 Drag the vertex to the required location.

To delete a vertex on a 3D object

1 Click Home tab  ➤  Subobject panel  ➤  Vertex.

2 Press Ctrl+click a vertex that connects collinear edges are parallel and do
not lie on any other edges.

3 Press Delete.

Quick Reference

Commands

MOVE

Moves objects a specified distance in a specified direction.
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ROTATE

Rotates objects around a base point.

SCALE

Enlarges or reduces selected objects, keeping the proportions of the object
the same after scaling.

SOLIDEDIT

Edits faces and edges of 3D solid objects.

System Variables

No entries

Work with Complex 3D Solids and Surfaces
Modify composite solids that are created by a union, subtract, intersect, fillet,
or chamfer process.

Display Original Forms of Composite Solids
By default, 3D composite objects retain a history that displays an editable
image of their original component forms.

Retain the History of the Composite Components

After you create a composite object, you can modify the shape of the new
object by modifying a highlighted wireframe image of its original components.
If the Show History property is Yes, wireframes of the original forms—including
forms that have been removed—are displayed in a dimmed state. (The
SHOWHIST system variable also controls this setting.)
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To retain a history of the original parts of composite solids, the History
property must be set to Record (Properties Palette) when the composite
operation occurs. (You can also use the SOLIDHIST system variable to set this
property.)

Display and Remove the History to Modify the Composite

When you modify the composite object, you can display the history. Then
use the grips on the history subobject to modify the object. For more
information about using grips with composite solids, see Modify Composite
Solids and Surfaces on page 1328.

You can remove the history of a selected composite object by changing its
History setting to None, or by entering the BREP command. After a history
has been removed, you can no longer select and modify the original, removed,
components of the solid. You can restart history retention for the solid by
changing its History setting back to Record.

Removing a composite history is useful when you work with complex
composite solids. After you create the initial complex form, set History to
None to remove the history. Then reset the value to Record. With this process,
you can create a complex composite object, and then reset it to serve as a base
form for additional composite operations.

To display the original components of a composite solid

1 If the Properties palette is not displayed, select any object. Right-click the
object to display the shortcut menu. Click Properties.

2 In a drawing, select a 3D composite solid.

3 On the Properties palette, Solid History area, under Show History, select
Yes.
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To remove the history of a solid object

1 If the Properties palette is not displayed, select any object. Right-click the
object to display the shortcut menu. Click Properties.

2 In a drawing, select a 3D solid.

3 On the Properties palette, Solid History area, under History, select None.

Command entry: BREP

To set a 3D solid to record a history of its original forms

1 If the Properties palette is not displayed, select any object. Right-click the
object to display the shortcut menu. Click Properties.

2 In a drawing, select a solid.

3 On the Properties palette, Solid History area, under History, select Record.

Quick Reference

Commands

BREP

Removes the history from 3D solid primitives and composite solids.

System Variables

SHOWHIST

Controls the Show History property for solids in a drawing.

SOLIDHIST

Controls the default History property setting for new and existing objects.

Modify Composite Solids and Surfaces
Modify the entire form of a composite 3D object or the original forms that
make up the composite.

You can move, scale, or rotate a selected composite object using grips or
gizmos.
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Modify Original Components of Composites

When the History property is set to Record, press the Ctrl key to display any
original forms that were removed during a union, subtract, or intersect
operation. If the original, removed form was a solid primitive, you can drag
the displayed grips to change its shape and size. As a result, the composite
object is modified.

If the selected individual form does not contain its history, you can move,
rotate, scale, or delete the form.

Modify Complex Composites

A composite object might be made up of other composite objects. You can
select the history images of composite objects by holding down the Ctrl key
as you click the forms. (For best results, set the subobject selection filter to
Solid History.)

You can also change the size and shape of composite objects by clicking and
dragging grips on individual faces, edges, and vertices. For more information,
see Modify 3D Solid Subobjects on page 1310.

Separate Discrete Objects Combined with a Union

If you have combined discrete 3D solids or surfaces using a union operation,
you can separate them into their original components. (Use the Separate
option of the SOLIDEDIT command.) To be separated, the composite objects
cannot overlap or share a common area or volume.
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After separation, the individual solids retain their original layers and colors.
All nested 3D solid objects are restored to their simplest forms.

See also:

■ Use Grips to Edit Objects on page 1141

■ Overview of Modifying Meshes on page 1337

To select an individual solid that is part of a composite solid

■ Press Ctrl + click an individual solid that is part of a composite solid.

To separate a 3D solid composite into individual solids

1 Click Home tab ➤ Solid Editing panel ➤ Solid Editing
drop-down ➤ Separate.

2 Select the 3D solid object.

NOTE This operation only applies to non-intersecting objects that have been
combined by union.

3 Press Enter to complete the command.

Toolbar: Solid Editing  
Command entry: SOLIDEDIT

Quick Reference

Commands

SOLIDEDIT

Edits faces and edges of 3D solid objects.

System Variables

LEGACYCTRLPICK

Specifies the keys for selection cycling and the behavior for Ctrl+click.
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Shell and Remove Redundancies in 3D Objects
Convert 3D solids to shells and remove redundant lines and edges.

Shell 3D Solids
Convert a 3D solid to a hollow wall, or shell.

When you can convert a solid object to a shell, new faces are created by
offsetting existing faces inside or outside their original positions.

Continuously tangent faces are treated as a single face when they are offset.

To create a 3D solid shell

1 Click Home tab ➤ Solid Editing panel ➤ Solid Editing drop-down ➤ Shell.

2 Select the 3D solid object.

3 Select one or more faces to be excluded from shelling.

4 Press Enter.

5 Specify the shell offset value.

A positive offset value creates a shell wall in a positive direction from the
face. A negative value creates a shell wall in a negative direction from the
face.

6 Press Enter to complete the command.

Toolbar: Solid Editing  
Command entry: SOLIDEDIT
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Quick Reference

Commands

SOLIDEDIT

Edits faces and edges of 3D solid objects.

System Variables

No entries

Clean and Check 3D Solids
Remove redundant faces, edges, and vertices from a 3D solid, and verify
whether the 3D solid is valid.

You can remove redundant edges or vertices that share the same surface or
vertex definition. This operation merges adjacent faces and deletes all
redundant edges, including imprinted and unused edges.

True 3D solid objects have editable properties, volume, and mass that are not
shared by objects created with thickness or closed surfaces. You can check
whether an object is a valid 3D solid by verifying whether it is listed as “3D
Solid” on the Properties palette. You can also use SOLIDEDIT to verify whether
a solid object is a valid 3D solid object.

To remove redundant lines from a 3D solid object

1 Click Home tab ➤ Solid Editing panel ➤ Solid Editing flyout ➤ Clean.

2 Select the 3D solid object.

3 Press Enter to complete the command.
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Toolbar: Solid Editing  
Command entry: SOLIDEDIT

To validate a 3D solid object

1 Click Home tab ➤ Solid Editing panel ➤ Solid Editing flyout ➤ Check.

2 Select the 3D solid object.

3 Press Enter to complete the command.

If the object is a valid 3D object, a message is displayed at the Command
prompt. If it is not valid, you continue to be prompted to select a 3D
solid.

Toolbar: Solid Editing  
Command entry: SOLIDEDIT

Quick Reference

Commands

SOLIDEDIT

Edits faces and edges of 3D solid objects.

System Variables

SOLIDCHECK

Turns 3D solid validation on and off for the current session.

Press or Pull Bounded Areas
Create a positive or negative extrusion in the shape of a bounded area.
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Press in or pull out bounded, or closed, areas to create 3D holes and positive
extrusions.

object formed using press and pull
operations on an imprinted pyramid

In combination with imprinted faces, you can form complex shapes using
press or pull operations to create extrusions and notches.

Methods for Press and Pull Modifications

With the PRESSPULL command, you specify the area to be extruded, and then
move the cursor or enter a value to specify the length of the extrusion. The
result is a single 3D solid object, often with a composite shape.

You can also press Ctrl+Shift+E to initiate a press or pull operation. To limit
the type of objects that can act as boundaries, turn off the IMPLIEDFACE
system variable. When the variable is off, only 3D faces and 3D solid faces
can be extruded using Ctrl+Shift+E. (This variable does not affect the
PRESSPULL command.)

NOTE If you alternatively use EXTRUDE to extend an existing face on a 3D solid,
a separate extruded object is created.

Types of Objects That Can Be Pressed or Pulled

You can press or pull several types of bounded areas, including closed objects,
areas enclosed by coplanar geometry, the faces of 3D solids, and an imprinted
area on the face of a 3D solid. For a complete list of objects that are eligible
for a press or pull extrusion, see PRESSPULL.
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You cannot taper the pressed or pulled shape as you create it. However, you
can achieve the same effect later by modifying the edges of the bounded area.

To press or pull a bounded area

1 Press and hold Ctrl+Shift+E.

2 Click any area bounded by coplanar lines or edges.

3 Drag the mouse to press or pull the bounded area.

4 Click two points or enter a value to specify the height or depth of the
extrusion.

Toolbar: Modeling  
Command entry: PRESSPULL

Quick Reference

Commands

EXTRUDE

Extends the dimensions of a 2D object or 3D face into 3D space.

PRESSPULL

Presses or pulls bounded areas.

System Variables

IMPLIEDFACE

Controls the detection of implied faces.

Add Edges and Faces to Solids and Surfaces
Add editable faces to 3D solids and surfaces by imprinting other objects, such
as arcs and circles.

With the IMPRINT command, you can add a new face to a 3D solid or surface
by imprinting a coplanar object that overlaps the selected face. Imprinting
provides additional edges that you can modify to reshape the solid object.
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For example, if a circle overlaps the face of a box, you can imprint the
intersecting curves on the solid.

You can delete or retain the original object as you imprint it.

Objects that can be imprinted on 3D solids and surfaces include arcs, circles,
lines, 2D and 3D polylines, ellipses, splines, regions, bodies, and other 3D
solids.

Edit Imprinted Objects

You can edit imprinted objects and subobjects in many of the same ways that
you can edit other faces. For example, you can Ctrl+click to select a new edge
and then drag to change its location.

The following limitations exist for imprinted objects:

■ You can move the edges of the imprinted face only within the plane of a
face.

■ You might be unable to move, rotate, or scale some subobjects.

■ Imprinted edges and faces might be lost when some subobjects are moved,
rotated, or scaled.

Subobjects with editing limitations include

■ Faces with imprinted edges or faces

■ Edges or vertices with adjacent faces that contain imprinted edges or faces

To imprint a 3D solid object

1 Click Home tab ➤ Solid Editing panel ➤ Edge Editing
drop-down ➤ Imprint.

2 Select the 3D solid object.
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3 Select a co-planar object that you want to imprint.

4 Press Enter to retain the original objects, or enter y to delete them.

5 Select additional objects to imprint or press Enter.

6 Press Enter to complete the command.

Toolbar: Solid Editing  
Command entry: IMPRINT

Quick Reference

Commands

IMPRINT

Imprints 2D geometry on a 3D solid or surface, creating additional edges on
planar faces.

System Variables

No entries

Modify Mesh Objects
Model mesh objects by changing smoothing levels, refining specific areas, or
adding creases.

Overview of Modifying Meshes
Modeling mesh objects differs from modeling 3D solids and surfaces in some
important ways.

Mesh objects do not have the mass and volume properties of 3D solids.
However, they do offer unique capabilities that enable you to design less
angular, more rounded models.
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NOTE The capabilities described in this section apply only to mesh objects created
in AutoCAD 2010 and later. They cannot be used with legacy polyface or polygon
mesh.

About Mesh Faces

Mesh objects are composed of faces and facets.
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Faces are non-overlapping units that—along with their edges and
vertices—form the basic editable units of a mesh object. When you move,
rotate, and scale individual mesh faces, surrounding faces are stretched and
deformed in order to avoid introducing gaps. When gaps occur, you can often
close them by smoothing the object or refining individual faces.

About Mesh Facets

Mesh faces have underlying structures, known as facets. The density of the
facet grid corresponds to the smoothness of the mesh. As the smoothness
level is increased, the density of the underlying facet grid also increases. When
you want to confine detailed mesh editing to a smaller area, you can convert
facets to editable faces by using refinement.

Unlike faces, facets cannot be individually modified. However, you can make
them more visible by modifying the VSLIGHTINGQUALITY system variable.

About Mesh Modeling

You can work with mesh objects in the following ways:

■ Add smoothness. Increase or decrease smoothness levels to round the
overall shape of the model. The underlying density of the mesh facet grid
increases as the mesh object smoothness level increases.

■ Refine the object to reset the baseline smoothness level. Refine a mesh
object to convert the underlying facet grid to editable faces. Refinement
also resets the lowest level of smoothness that can be applied to the object.

Overview of Modifying Meshes | 1339



■ Refine a face. Restrict the refinement to a specific mesh face. This method
avoids resetting the smoothness baseline.

■ Crease an edge. Remove the smoothness from specified edges. You can
also remove an existing crease.

■ Split a face. Divide an existing face into separate components along a path
you specify.

■ Extrude a face. Deform a specified face through extrusion. Unlike 3D solid
extrusion, a mesh extrusion does not create a separate object.

Use Grip Editing with Mesh

Grips, as described in Use Grips to Edit 3D Solids and Surfaces on page 1291, are
not available with meshes. However, you can manipulate the entire mesh
model or individual subobjects using the following methods:

■ Subobject selection and editing. Select faces, edges, and vertices the same
way you select 3D solid subobjects. Press Ctrl and click the component.
The subobject highlighting indicates what is selected. Press Shift and click
again to remove the selection from a subobject. By turning on the Subobject
Selection Filter, you can restrict selection to a specific subobject. See Select
3D Subobjects on page 1285.

■ Gizmo editing. When you select a mesh object or subobject, the 3D Move,
Rotate, or Scale gizmo is displayed automatically. (You can set which gizmo
is displayed by default.) Use these gizmos to modify the selection uniformly,
or along a specified plane or axis. See Use Gizmos to Modify Objects on
page 1294.

Because dense meshes can be difficult to work with, you can change settings
to improve the display and behavior of grips.

■ Set the subobject selection filter to select only faces, edges, or vertices:
Set the DEFAULTGIZMO system variable or use the shortcut menu.

■ Set whether a grip on a face, edge, or vertex is active immediately when
you select the subobject: Set the GRIPSUBOBJMODE system variable.
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Quick Reference

Commands

EXTRUDE

Extends the dimensions of a 2D object or 3D face into 3D space.

MESHCREASE

Sharpens the edges of selected mesh subobjects.

MESHREFINE

Multiplies the number of faces in selected mesh objects or faces.

MESHSMOOTHLESS

Decreases the level of smoothness for mesh objects by one level.

MESHSMOOTHMORE

Increases the level of smoothness for mesh objects by one level.

MESHSPLIT

Splits a mesh face into two faces.

MESHUNCREASE

Removes the crease from selected mesh faces, edges, or vertices.

System Variables

DEFAULTGIZMO

Sets the 3D Move, 3D Rotate, or 3D Scale gizmo as the default during
subobject selection.

GRIPSUBOBJMODE

Sets whether edge, face, or vertex grips are active upon initial selection.

VSLIGHTINGQUALITY

Sets the lighting quality in the current viewport.

Change Mesh Smoothness Levels
Increase the roundness of mesh objects by increasing the smoothness levels.
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Mesh objects are made up of multiple subdivisions, or tessellations, which
define the editable faces. Each face consists of underlying facets. When you
increase smoothness, you increase the number of facets to provide a smoother,
more rounded look.

Increase or Decrease Smoothness

As you work, you can increase and decrease the level of smoothness. The
differences are apparent both in the wireframe and conceptual visual styles
and in the rendered output.
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The lowest level of smoothness, or baseline, is 0. By default, Level 0 has no
smoothness. You can increase the smoothness of any mesh object up to the
current limits. However, you cannot decrease the smoothness of a mesh object
whose level of smoothness is zero.

If you have added creases to a mesh object, the effect of smoothing differs,
depending on the crease setting. The effect of creases added to mesh that has
no smoothness (Level 0) is not apparent until the mesh is smoothed.

As you edit an object using gizmos or grips, you might create gaps in the mesh
object. One way to close the gap is to smooth the object or refine individual
subobjects. Using hardware acceleration might also help resolve this problem.
(For more information, see Graphics System.)

Limit Mesh Density

Mesh is created at the level of smoothness that you specify. The smoothness
can range from None (0), to the default maximum (6), or to a level that you
specify. As an object is smoothed, the density of the mesh facet grid also
increases. For best results, model mesh objects at lower smoothness levels and
increase the smoothness only after modeling is complete.
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Dense meshes can result in subobjects that are difficult to select and edit. They
can also affect performance. Therefore you might want to set limits that
prevent the mesh from becoming too dense.

■ Maximum level of smoothness at which a grid is displayed
(SMOOTHMESHGRID). Displays the effects of modeling without the
complexity of the underlying facet grid. The default smoothness level is
3. The tessellation display becomes increasingly dense until the maximum
level is exceeded. Beyond that level, the display reverts to the most basic
level, even though the smoothing level can continue to increase.

■ Maximum number of faces in a drawing (SMOOTHMESHMAXFACE). Sets
the maximum number of mesh faces that are permitted per mesh object.

■ Maximum level of smoothness (SMOOTHMESHMAXLEV). Sets the
maximum smoothness level permitted for mesh objects.

To increase the smoothness of a mesh object

1 Click Mesh Modeling tab ➤ Mesh panel ➤ Smooth More. 

2 Select the mesh objects that you want to modify.

The smoothness of each object that you select is increased one level.

Toolbar: Smooth Mesh 
Command entry: MESHSMOOTHMORE

To decrease the smoothness of a mesh object

1 Click Mesh Modeling tab ➤ Mesh panel ➤ Smooth Less. 

2 Select the mesh objects that you want to modify.

The smoothness of each object that you select is decreased one level.

Toolbar: Smooth Mesh 
Command entry: MESHSMOOTHLESS
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To increase or decrease the smoothness of a mesh object (Properties palette)

1 If the Properties palette is not displayed, select any object. Right-click the
object to display the shortcut menu. Click Properties.

2 Select the mesh objects that you want to modify.

3 In the Properties palette, Geometry area, Smoothness box, select a new
smoothness level.

Toolbar: Standard 
Command entry: PROPERTIES

To control the display of the mesh facet grid

1 At the Command prompt, enter smoothmeshgrid.

2 Enter one of the following values:

■ 0 suppresses the display of the underlying mesh facet grid.

■ 1 displays the mesh facet grid only when the object has a level of
smoothness of 0 or 1.

■ 2 and higher sets the highest level of smoothness at which the facet
grid is displayed.

To set the maximum smoothness level for mesh objects

1 At the Command prompt, enter smoothmeshmaxlev.

2 Enter a value that represents the highest level of smoothness permissible
for mesh objects. The recommended range is 1 - 5.

To set the maximum number of mesh faces

1 At the Command prompt, enter smoothmeshmaxface.

2 Enter the maximum number of faces permitted for an object.

You can set a value up to 16,000,000.
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Quick Reference

Commands

MESHSMOOTHLESS

Decreases the level of smoothness for mesh objects by one level.

MESHSMOOTHMORE

Increases the level of smoothness for mesh objects by one level.

PROPERTIES

Controls properties of existing objects.

System Variables

SMOOTHMESHGRID

Sets the maximum level of smoothness at which the underlying mesh facet
grid is displayed on 3D mesh objects.

SMOOTHMESHMAXFACE

Sets the maximum number of faces permitted for mesh objects.

SMOOTHMESHMAXLEV

Sets the maximum smoothness level for mesh objects.

Refine Mesh Objects or Subobjects
Refine a mesh object or subobject to convert underlying facets to editable
faces.

You can refine any mesh that has a level of smoothness of 1 or higher.

Refine a Mesh Object and Reset the Baseline

Refining an object increases the number of editable faces by converting the
underlying facets to faces. The number of resulting faces depends on the
current level of smoothness. Higher smoothness levels result in a higher
number of faces after refinement.
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In addition to increasing the number of faces, refining a mesh object resets
its level of smoothness back to the baseline. Therefore, an object might appear
to be smoothed, but its smoothness level can still equal 0 (zero).

Refine a Mesh Face

You can refine an entire mesh object as shown in the previous illustration, or
select a specific face to refine. A refined face is subdivided into four faces and
the surrounding faces are deformed slightly to accommodate the change.

Refining a mesh face does not affect the overall smoothing level of the mesh
object. Unlike a refined mesh object, refined faces can be refined again
immediately. With mesh face refinement, you can target smaller areas for
detailed modeling.
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How Refinement Affects Creases

A crease that is set to Always retains its sharpness no matter how much you
smooth or refine the object. However, the behavior is different when you
assign a crease value. If you refine an object or edge that has a crease value,
the assigned crease value is lowered by the value of the original level of
smoothing. Suppose that you add a crease with a crease value of 4 and then
refine a mesh whose level of smoothness is 2. The new crease value is 2.

If a crease is applied before an object is smoothed or refined, the effect is not
apparent until after the object is smoothed or refined.

To refine a mesh object

1 Click Mesh Modeling tab ➤ Mesh panel ➤ Refine Mesh. 

2 Select the mesh object that you want to refine. (The object must have a
smoothness level of 1 or higher.)

The underlying mesh facets are converted to faces and the level of
smoothness for the object is set to 0. Higher levels of smoothness result
in a higher number of faces.

Toolbar: Smooth Mesh 
Command entry: MESHREFINE

To refine a mesh face

1 Set the subobject selection filter to select only faces: right-click anywhere
in the drawing area. Click Subobject Selection Filter  ➤ Face.
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2 Click Mesh Modeling tab ➤ Mesh panel ➤ Refine Mesh. 

3 Press Ctrl+click one or more mesh faces that you want to refine. Press
Enter. (The object must have a smoothness level of 1 or higher.)

Each face is subdivided into four new faces.

Toolbar: Smooth Mesh 
Command entry: MESHREFINE

Quick Reference

Commands

MESHREFINE

Multiplies the number of faces in selected mesh objects or faces.

Add Creases to Mesh
Add creases to sharpen mesh edges.

You can add creases to mesh objects that have a smoothing level of 1 or higher.
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Add Creases to Different Subobjects

The result of creasing differs, depending on what type of subobject you select.

■ Edge. The selected edge is sharpened. The adjacent faces are deformed to
accommodate the new crease angle.

■ Face. The selected face is flattened and all edges that bound that face are
sharpened. Adjacent faces are deformed to accommodate the new shape
of the face.

■ Vertex. The point of the vertex and all intersecting edges are sharpened.
Adjacent faces are deformed to accommodate the new vertex angle.

Assign a Crease Value to the Edge

As you apply a crease, you set a crease value that determines how the crease
is affected by smoothing. A value of Always ensures that the crease is always
retained, even when the mesh is repeatedly smoothed. Higher crease values
ensure that the crease is retained through several smoothing processes. (During
smoothing, the assigned crease value is decreased by the value of the original
level of smoothing.)

You can add a crease to mesh that has not been smoothed. However, the effect
is not visible unless you smooth the object.

Remove a Crease

You can restore a crease to a smoothed state that corresponds to the smoothing
level for the object. If you remove a crease that is adjacent to other creased
subobjects, their contours are adjusted.

To add creases to a mesh object

1 (Optional) Specify the type of subobject to crease: right-click in the
drawing area and click Subobject Selection Filter  ➤  Face, Vertex, or Edge.

2 Click Mesh Modeling tab ➤ Mesh panel ➤ Add Crease. 

3 Select the mesh edges, faces, or vertices to crease. (If you have set a
subobject selection filter, only one type of subobject can be selected.)

To remove a subobject from the selection set, Shift+click the subobject.

4 Specify the crease value:

■ Always retains the crease at all levels of smoothness.
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■ Values of 1 or higher sets the level of smoothness that starts to affect
the crease.

The specified subobjects are creased. A crease is not visible on objects
that have not been smoothed (the level of smoothness = 0).

Toolbar: Smooth Mesh 
Command entry: MESHCREASE

To change the crease value of an existing mesh crease (Properties palette)

1 If the Properties palette is not displayed, select any object. Right-click the
object to display the shortcut menu. Click Properties.

2 Press Ctrl+click the mesh subobject that you want to modify.

NOTE If you cannot select a specific subobject, verify whether subobject
selection filtering is turned on for a different subobject type. (Right-click in
the drawing area and click Subobject Selection Filter.)

3 In the Properties palette, Crease area, Type box, change the crease value:

■ None removes the crease and sets the subobject to the current level
of smoothness.

■ Always retains the crease at all levels of smoothness.

■ By Level sets the level of smoothness that starts to affect the crease.
When this setting is selected, you can specify the crease level in the
Level box.

Toolbar: Standard 
Command entry: PROPERTIES

To remove an existing mesh crease

1 (Optional) Specify the type of subobject to modify: right-click in the
drawing area and click Subobject Selection Filter  ➤  Face, Vertex, or Edge.

2 Click Mesh Modeling tab ➤ Mesh panel ➤ Remove Crease. 
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3 Press Ctrl+click the mesh subobjects to be modified and press Enter.

You can also use window selection to specify multiple subobjects.

Toolbar: Smooth Mesh 
Command entry: MESHUNCREASE

Quick Reference

Commands

MESHCREASE

Sharpens the edges of selected mesh subobjects.

MESHUNCREASE

Removes the crease from selected mesh faces, edges, or vertices.

PROPERTIES

Controls properties of existing objects.

Split or Extrude Mesh Faces
Split a mesh face or deform it through extrusion.

Split a Mesh Face

You can split a mesh face to make custom subdivisions. Use this method to
prevent deforming a larger area for small modifications.
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Because you specify the start point and end point of the split, this method
also gives you control over the shape of the two new faces.

Extrude a Mesh Face

You can add definition to a 3D object by extruding a mesh face. Extruding
other types of objects creates a separate 3D solid object. However extruding
a mesh face extends, or deforms, the existing object and subdivides the
extruded face.

You can use the same methods for extrusion of the faces of 3D solids and
meshes as you use for other types of objects. For example, you can specify an
extrusion direction, a path, or a taper angle. For more information about
extrusion, see Extrude Objects on page 1199.

To split a mesh face

1 Click Mesh Modeling tab ➤ Mesh Edit panel ➤ Split Mesh Face. 

2 Press Ctrl+click the mesh face that you want to split.

NOTE If you cannot select a face, verify whether subobject selection filtering
is turned on for a different subobject type. (Right-click in the drawing area
and click Subobject Selection Filter.)

3 Click the location on the edge where you want to start the split.

4 Click the location on the edge where you want to end the split.

The mesh face is split along the boundary you specified. Surrounding
faces are adjusted along the new faces.
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Command entry: MESHSPLIT

To extrude a mesh face

1 Click Mesh Modeling tab ➤ Mesh Edit panel ➤ Extrude Face. 

2 Press Ctrl+click a mesh face.

NOTE If you cannot select a face, verify whether subobject selection filtering
is turned on for a different subobject type. (Right-click in the drawing area
and click Subobject Selection Filter.)

3 Drag the face in the direction of the extrusion. Then specify the amount
of extrusion using one of the following methods:

■ Press Enter to set the extrusion dynamically.

■ Enter a value to indicate the height or depth of the extrusion.

The selected face is subdivided and extruded. The new, subdivided faces
are created around its boundaries to connect the extrusion with the
original adjacent faces.

Command entry: EXTRUDE

Quick Reference

Commands

MESHSPLIT

Splits a mesh face into two faces.

EXTRUDE

Extends the dimensions of a 2D object or 3D face into 3D space.

System Variables

DELOBJ

Controls whether geometry used to create 3D objects is retained or deleted.
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Tips for Working with Mesh
Learn some best practices for working with mesh models.

Mesh, with its enhanced modeling capabilities, offers a way to create more
fluid, free-form designs. Keep these tips in mind as you work.

Model mesh before you smooth it.

Mesh modeling is a powerful way to design, but higher levels of smoothness
increase complexity and can affect performance. You can work more efficiently
if you complete editing operations such as gizmo editing, extrusion, and face
splitting, on mesh objects that have not been smoothed. (That is, their level
of smoothness is 0.)

mesh sphere modeled by grip editing and extrusion, then smoothed

You can quickly switch between the levels of smoothness in the Properties
palette to get a preview of how your activities affect the smoothed object.

Refine or split a face instead of refining the entire object.

Refinement is a powerful way to subdivide faces. However, by increasing the
number of faces, you add to the overall complexity of the model. In addition,
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refining an entire mesh object resets the base level of smoothness to 0. This
change can result in a dense grid that can no longer be simplified. For best
results, avoid refining the object, and refine or split only the individual faces
that require more detailed modeling.

mesh box, refined mesh box, and mesh box with one face refined

Refining individual faces does not reset the level of smoothness for the object.

Crease edges to help limit distortion when the object is smoothed.

Creased edges can be set to maintain their sharpness, no matter how much
the object is smoothed. You may also need to crease the edges in surrounding
faces to obtain the result you want.

extruded faces on mesh torus, creased and
not creased

Creasing set to Always retains its sharpness after smoothing. If you set a crease
value, the creased edge becomes smoother at the equivalent level of
smoothness.
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Use gizmos to model faces, edges, and vertices.

3D Move, 3D Rotate, and 3D Scale gizmos can be used to modify entire mesh
objects, or specific subobjects.

For example, you can rotate and scale an individual face using the 3D Move,
Rotate, and Scale gizmos.

By constraining the modifications to a specified axis or plane, gizmos help
you avoid unexpected results. The default gizmo is displayed whenever you
select an object in a view that uses a 3D visual style. (You can also suppress
this display.) Therefore, you do not have to explicitly start the 3D Move, 3D
Rotate, or 3D Scale command to initiate these activities. You just need to select
an object.

When a gizmo is selected, you can use the shortcut menu to switch to a
different type of gizmo.

Use subobject selection filters to narrow the available selection candidates.

In a smoothed mesh, trying to select a specific subject can be difficult unless
you turn on subobject selection (shortcut menu). By specifying that the
selection set is limited to faces, edges, vertices, or even solid history subobjects,
you can restrict which subobject type is available when you press Ctrl and
move the mouse over the object.
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mesh faces selected when the face
subobject selection filter is on

A filter is especially valuable for selecting mesh vertices, which are not
highlighted as you move the mouse over them.

Model by extruding faces.

A key difference between gizmo editing and extrusion occurs in the way each
face is modified. With gizmo editing, if you select and drag a set of faces,
adjacent faces are stretched to accommodate the modification. When the
object is smoothed, the adjacent faces adapt to the new location of the face.

mesh faces extended using 3D Move gizmo, then smoothed

Mesh extrusion, however, inserts additional faces to close the gap between
the extruded face and its original surface.
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mesh faces extruded, then smoothed

If you are working on an object that has not been smoothed, try smoothing
it periodically to see how it is affected by smoothing.

Convert between mesh and 3D solids or surfaces.

Mesh modeling is powerful, but it cannot do everything that solid modeling
can do. If you need to edit mesh objects through intersection, subtraction, or
union, you can convert mesh to 3D solid or surface objects. Similarly, if you
need to apply creasing or smoothing to 3D solid or surface objects, you can
convert those objects to mesh.

Keep in mind that not all conversions retain complete fidelity to the shape
of the original object. Avoid switching between object types more than once,
if possible. If you notice that the conversion modifies the shape of the object
in an unacceptable way, undo the conversion and try again with different
settings.

■ The Mesh Tessellation Options Dialog Box (MESHOPTIONS) controls the
smoothness and shape of the faces for 3D solids or surfaces that are
converted to mesh. Although you can convert an object to mesh without
opening this dialog box (MESHSMOOTH), you can more easily experiment
with different conversion settings by launching the conversion operation
from within the dialog box.

■ The SMOOTHMESHCONVERT system variable (also available on the ribbon)
sets whether the mesh objects that you convert to 3D solids or surfaces are
smoothed or faceted, and whether their co-planar faces are optimized
(merged).
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You might have trouble converting some non-primitive mesh to solid objects
due to the following problems:

■ Gaps in the mesh. If you notice gaps, you can sometimes close them by
smoothing the object or by refining the faces that are adjacent to the gap.

mesh torus that has been twisted using 3D Rotate at various
smoothing levels

In some cases, you can also obtain better results by using hardware
acceleration to improve your graphics system.

■ Intersecting mesh faces. Be especially careful not to create self-intersections
as you move, rotate, or scale subobjects. (You create self-intersections when
you cause one or more faces to cross, or intersect other faces in the same
mesh model.) View the object from all viewpoints to ensure you create a
viable model.

mesh wedge with front faces dragged past the
back faces
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Mesh objects that cannot be converted to solids can often be converted to
surfaces instead.
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Create Sections and 2D
Drawings from 3D Models

Create cross sections, cutting planes, and flattened views of 3D objects.

Work with Sections
Create cross sections of 3D models.

Overview of Section Objects
Create a section plane that can be modified and moved to achieve the cross
section view that you need.

With the SECTIONPLANE command, you can create one or more section objects
and place them throughout a 3D model (3D solids, surfaces, or mesh). By
activating live sectioning, you can then view transient cuts in the 3D model as
you move the section object through it. The 3D objects themselves do not
change.

Set the Cross-Section with the Section Plane Indicator

Section objects have a transparent section plane indicator that acts as a cutting
plane. This plane can be moved through a 3D model that is composed of 3D
solids, surfaces, or regions to obtain different section views.

22

1363



Store Properties in Section Lines

The section plane contains a section line that stores section object properties.
You can create multiple section objects to store different properties. For
example, one section object can display a hatch pattern at the section plane
intersection. Another section object can display a specific linetype for the
boundary of the intersected area.

Analyze the Model with Live Sectioning

With live sectioning, you can dynamically analyze the interior details of 3D
objects by moving and adjusting the section plane. You can specify whether
to hide, or cut away, the portion of the model that is on the viewing side of
the section plane indicator.
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Save and Share Section Images

After you create a sectional view, you can generate an accurate 2D or 3D block
from the 3D model. These blocks can be analyzed or checked for clearances
and interference conditions. They can also be dimensioned, or used as
wireframe or rendered illustrations in documentation and presentation
drawings.

You can also save each section object as a tool on the tool palette. That way,
you can avoid resetting properties each time you create a section object.

Quick Reference

Commands

LIVESECTION

Turns on live sectioning for a selected section object.

SECTIONPLANE

Creates a section object that acts as a cutting plane through 3D objects.

SECTIONPLANESETTINGS

Sets display options for the selected section plane.

SECTIONPLANETOBLOCK

Saves selected section planes as 2D or 3D blocks.

Create Section Objects
Create cross sections to show interior details of 3D objects.

With the SECTIONPLANE command, you create a section object that acts as a
cutting plane through solids, surfaces, meshes, or regions. Then turn on live
sectioning to move the section object through the 3D model to reveal its inner
details in real time.

You can align a section object using several methods.

Align the Section Plane to a 3D Face

One way to set the section plane is to click the face of an existing 3D object.
(As you move the cursor, a dotted outline indicates the side of the plane to
be selected.) The section plane is automatically aligned to the plane of the
face you select.
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Section object aligned to face

Create a Straight Cutting Plane

Pick two points to create a straight cutting plane.

Add a Jogged Segment

The section plane can be a straight line or it can have multiple or jogged
sections. For example, a section containing a jog is one that cuts away a pie
slice-shaped wedge from a cylinder.

Create a section line that has jogged segments by using the Draw Section
option to pick multiple points throughout the 3D model.
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Section object with jogged segment

Create Orthographic Sections

You can align section objects to a specified orthographic orientation of the
current UCS, such as front, back, bottom, top, left, or right.

Orthographic section planes are placed so that they pass through the center
of the 3D extents of all 3D objects in the drawing.

Create a Region to Represent the Cross Section

With the SECTION command, you can create a 2D region object that represents
a planar cross section through a 3D solid object. You do not have live
sectioning capabilities when you use this legacy method to create cross sections.
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Define the plane of the cross section using one of the following methods:

■ Specify three points.

■ Specify a 2D object such as a circle, ellipse, arc, spline, or polyline.

■ Specify a view.

■ Specify the Z axis.

■ Specify the XY, YZ, or ZX plane.

The new region that represents the cross-sectional plane is placed on the
current layer.

NOTE Before you apply hatching to the cross-sectional cutting plane, align the
UCS with the cutting plane.

To create a section object by selecting a face

1 Click Home tab ➤ Section panel ➤ Section Plane. 

2 Click to select a face on your model.

A section object is created on the plane of the selected face.

3 Click the section line to display its grips.

4 Select a grip to move the section plane through the 3D object.

A section object is created in the Section Plane state. Live sectioning is
turned on.

Command entry: SECTIONPLANE
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To create a section object by specifying two points

1 Click Home tab ➤ Section panel ➤ Section Plane. 

2 Specify the first point of the section object.

3 Specify the endpoint.

The section object is created between the two points. Live sectioning is turned
off.

Command entry: SECTIONPLANE

To create a section object with jogged segments

1 Click Home tab ➤ Section panel ➤ Section Plane. 

2 At the Command prompt, enter d (Draw Section).

3 Specify the start point of the section object.

4 Specify a second point to create the first jogged segment.

From this point, you cannot create segments that intersect.

5 Continue specifying segment endpoints, then press Enter.

6 Specify a point in the direction of the sectional cut.

A section object with multiple segments is created in a Section Boundary state.
Live sectioning is turned off.

Command entry: SECTIONPLANE

To create a section object on a preset orthographic plane

1 Click Home tab ➤ Section panel ➤ Section Plane. 

2 At the Command prompt, enter o (Orthographic).

3 Select an alignment option.

The new section object intersects the center point of the 3D extents of all 3D
objects in the drawing. It is placed on the selected orthographic plane. Live
sectioning is turned on.

Command entry: SECTIONPLANE
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To create a region that represents the cross section of a 3D solid object

1 At the Command prompt, enter section.

2 Select the object to cross section.

3 Specify three points to define the cross-sectional plane.

Command entry: SECTION

Quick Reference

Commands

SECTIONPLANE

Creates a section object that acts as a cutting plane through 3D objects.

SECTION

Uses the intersection of a plane and solids, surfaces, or mesh to create a
region.

Modify a Section View
After you create a section, adjust its display or modify its shape and location
to change the represented section view.

Add Jogs to a Section
Add jogs, or angular segments, to existing section lines.

You can create a section line that has multiple segments (jogs), using the Draw
Section option of the SECTIONPLANE command. You can also add a jog to
an existing section object using the Add Jog to Section option on the shortcut
menu with SECTIONPLANEJOG.
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A jog that is added to an existing section object creates a segment that is
perpendicular to the selected segment. Its viewpoint is oriented in the direction
set by the Direction grip. The Nearest object snap is temporarily turned on to
help you place the jogs on a section.

You cannot add jogs to the side or back lines of the section object.

After adding jogs, you can reposition and resize the jogged sections by dragging
the section object grips.

To add jogs to a section

1 Click Home tab ➤ Section panel ➤ Jog. 

2 On a section object, select the section line.

3 Move the cursor over the section line.

4 Select a point on the section line where you want to place a jog that is
perpendicular to the selected segment.

To create additional jogs, repeat the steps.

NOTE You cannot create jogs that cause the line to intersect itself or close.

Shortcut menu: Add Jog to Section
Command entry: SECTIONPLANEJOG

Quick Reference

Commands

SECTIONPLANE

Creates a section object that acts as a cutting plane through 3D objects.

SECTIONPLANEJOG

Adds a jogged segment to a section object.

Use Live Section to Adjust the Cross Section
Use live sectioning to move a section object through the 3D model or region
dynamically.
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What Is Live Sectioning?

Live sectioning is an analytical tool for viewing cut geometry in a 3D solid,
surface, or region.

You can use live sectioning to analyze a model by moving the section object
through the object. For example, sliding the section object through an engine
assembly helps you visualize its internal components. You can use this method
to create a cross section view that you can save or reuse.

Turn on and Use Live Sectioning

Live sectioning works with 3D objects and regions in model space. When live
sectioning is activated, you can change the viewing planes by using grips to
adjust the location of the section object or its segments.

By turning on cutaway geometry, you can display the entire object that
contains the section plane. This option (available on the shortcut menu) can
only be turned on when section plane is active.

Live sectioning is turned on or off automatically, depending on how you
create the section object. For example, when you select a face to define the
section plane, live sectioning is turned on. When you create sections using
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the Draw Section option of the SECTIONPLANE command, live sectioning is
turned off. Live sectioning can be manually turned on or off after a section
object is created.

A drawing can contain multiple section objects. However, live sectioning can
only be active for one section object at a time. Suppose that your model has
two sections objects: Section A and Section B. If Section A has live sectioning
turned on and you activate live sectioning for Section B, live sectioning for
Section A is automatically turned off.

Turning off a section object layer does not turn off live sectioning. However,
freezing the layer turns off live sectioning.

To turn live sectioning on and off

1 Select a section object.

2 Click Home tab ➤ Section panel ➤ Live Section. 

Shortcut menu: Activate Live Sectioning
Command entry: LIVESECTION

To display cutaway geometry

1 Select a section object.

2 Right-click the section line. Click Show Cut-away Geometry to turn it
on.

The cut geometry is displayed according to the Foreground Line settings
in the Section Settings dialog box.

Quick Reference

Commands

LIVESECTION

Turns on live sectioning for a selected section object.

SECTIONPLANE

Creates a section object that acts as a cutting plane through 3D objects.

SECTIONPLANESETTINGS

Sets display options for the selected section plane.
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Use Grips to Modify Section Objects
Section object grips help you move and resize the section object.

Grips allow you to adjust the location, length, width, and height of the cutting
area.

■ Base grip. Acts as the basepoint for moving, scaling, and rotating the
section object. It is always adjacent to the Menu grip.

■ Second grip. Rotates the section object around the base grip.

■ Menu grip. Displays a menu of section object states, which control the
display of visual information about the cutting plane.

■ Direction grip. Controls the viewing direction of the 2D section. To reverse
the viewing direction of the section plane, click the Direction grip.

■ Arrow grip. (Section Boundary and Volume states only.) Modifies the
section object by modifying the shape and position of the section plane.
Only orthogonal movements in the direction of the arrow are permitted.

■ Segment end grips. (Section Boundary and Volume states only.) Stretches
the vertices of the section plane. You cannot move segment end grips so
that segments intersect. Segment end grips are displayed at the endpoints
of jogged segments.

You can select only one section object grip at a time.
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To adjust a section object using grips

1 In the drawing area, click the section plane.

Depending on the current section plane state, different grips are displayed.

2 Hover over the grip with the cursor until it turns red. Then drag the grip
to a new location.

3 To adjust the height, width, or depth of a section plane, click the Menu
grip and select Section Volume or Section Boundary.

Quick Reference

Commands

SECTIONPLANE

Creates a section object that acts as a cutting plane through 3D objects.

System Variables

GRIPSIZE

Sets the size of the grip box in pixels.

Set Section Object States and Properties
Set the display of the section object.

Set Section Object States

Section objects have the following display states:

■ Section Plane. The section line and transparent section plane indicator are
displayed. The cutting plane extends infinitely in all directions.
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■ Section Boundary. A 2D box shows the XY extents of the cutting plane.
The cutting plane along the Z axis extends infinitely.

■ Section Volume. A 3D box shows the extents of the cutting plane in all
directions.

You can switch between object states by clicking the Menu grip that is
displayed when you select the section object.

Set Section Object Properties

Section objects have properties like other AutoCAD objects. Properties are
stored in the section line and can be accessed in the Properties palette.

For each section object, you can change the name, layer, and linetype. You
can also change the color and transparency of the section plane indicator (the
cutting plane).

To change the state of a section object by using the Menu grip

1 Select the section object to display its grips.

2 Click the Menu grip.

3 On the section state menu, click the state you want to display.

The section display is updated to the selected state.

To change the state of a section object (Properties palette)

1 Right-click the section object. Click Properties.

2 In the Properties palette, under Section Object, change the value for Type.

The section display is updated to the selected state.

Command entry: PROPERTIES

To rename a section object

1 Right-click the section object. Click Properties.

2 In the Properties palette, under Section Object, in the Name box, enter
a different name.

Command entry: PROPERTIES
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To change the transparency and color of the section plane indicator

1 Right-click the section object. Click Properties.

2 In the Properties palette, under Section Object, in the Plane Transparency
box, enter a value of 1-100. Entering 1 makes the section plane indicator
opaque.

3 In the Plane Color box, select a color.

The section plane indicator is updated in the viewport.

Command entry: PROPERTIES

To change the height of the section plane indicator

1 Right-click the section object. Click Properties.

2 In the Properties palette, under Geometry, in the Top Plane box, change
the value.

This value changes the distance from the section line to the upper edge
of the section plane.

3 In the Bottom Plane box, enter a value.

This value changes the distance from the section line to the bottom edge
of the section plane.

The section plane indicator is updated in the viewport.

Command entry: PROPERTIES

To modify the live section display settings

1 Click Home tab ➤ Section panel ➤ Panel dialog box launcher.

2 Right-click the section object. Click Live Section Settings.

3 In the Section Settings Dialog Box, click Live Section Settings.

4 Modify the sections that you want to change and click OK.

Shortcut menu: Live Section Settings
Command entry: SECTIONPLANESETTINGS
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Quick Reference

Commands

PROPERTIES

Controls properties of existing objects.

SECTIONPLANE

Creates a section object that acts as a cutting plane through 3D objects.

SECTIONPLANESETTINGS

Sets display options for the selected section plane.

SECTIONPLANETOBLOCK

Saves selected section planes as 2D or 3D blocks.

Associate Section Objects with Views and Cameras
Associate section objects with named views and cameras in the View Manager.

When you activate a named view or camera that has an associated section
object, live sectioning is turned on for that section object. For a 3D model
with multiple section objects, you might want to associate a particular section
object to a view or camera. Later, you can restore a saved sectional view or
camera and activate live sectioning for the associated section object.

For example, you can set up two section objects that cut through the 3D model
in different directions. Section object A cuts the model along its width; Section
object B cuts the model along its length. Perhaps you want to view the sectional
cut that is perpendicular to your line of sight. By associating each section
object with a view or camera, you can quickly switch between the two views
and see the desired cross section.

To associate a section object with a view or camera

1 Click View tab ➤ Views panel ➤ Named Views.

2 In the View Manager, in the left pane, under Model Views, select a named
view or camera.

3 In the General section, in the Live Section drop-down list, select a section
object by name.

4 Click OK.
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The section object is now associated with a named view or camera. When
the named view or camera is restored, live sectioning is turned on for the
associated section object.

Toolbar: View 
Command entry: VIEW

Quick Reference

Commands

SECTIONPLANE

Creates a section object that acts as a cutting plane through 3D objects.

VIEW

Saves and restores named views, camera views, layout views, and preset views.

Save and Publish Section Objects
Save a section object as a block or tool, or publish it.

Save Sections as Blocks, Drawings, or Tools
Save the representation of the cross-sectional area where a section object
intersects a 3D model as a block.

Save Sections as Blocks or Drawings

You can save the section objects you create as blocks. Working from the
Generate Section / Elevation Dialog Box, you can choose the type of block
that is created.
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For example, suppose your project requires 2D elevation drawings or 2D cross
sections. The 2D Section / Elevation option creates an accurate block
representation that is ready for dimensioning.

To publish or render a cutaway of the 3D model, select the 3D Section option.
3D section geometry consists of mostly 3D solids and surfaces. However, profile
outlines and hatch patterns consist of 2D lines.

The display properties of 2D section/elevation blocks and 3D section blocks
are controlled in the Section Settings dialog box.

When you create section blocks, you have the following choices for how they
are handled:

■ Insert the section blocks. At the time of creation, you can insert a 2D or
3D section block into the drawing or save it to an external file. A 2D section
block is inserted on the XY plane of the current UCS, including section
blocks that extend into 3D space.
Inserted section blocks are initially unnamed. You can set the scale,
rotation, and basepoint upon insertion. You can modify and rename them
later by editing the block with BEDIT.

■ Export section blocks to a file. Save and name the new section objects so
they can be inserted later.
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■ Save section block components on separate layers. By default, section
block components such as intersection boundary, intersection fill,
background lines, cutaway geometry, and curve tangency lines are saved
on Layer 0. However, you can separate the components of saved section
blocks onto separate layers with a suffix or prefix that you specify.
Assigning a suffix or prefix helps you organize the block components into
layers that you can sort and identify quickly. The Layer properties lists in
the Section Settings dialog box provide the opportunity to customize the
layer names.

■ Specify whether to limit the section block to certain objects. The objects
that are included in a section block vary, depending on which section
object state is selected. You can also select specific objects to be included
as you create the section block.

Save Section Objects as Tools

As with other objects, you can create tools from individual section objects
and then access them in a tool palette when you need them.

If each of several section objects has its own set of properties, you can save
each section object as a tool. Later, you can quickly create new section objects
that use the same settings.

See also:

■ Create and Use Tools from Objects and Images on page 56

To save and insert a 2D or 3D section as a block

1 Click Home tab ➤ Section panel ➤ Create Block. 

2 Select the section object.

3 In the Generate Section/Elevation dialog box, click 2D Section/Elevation
or 3D Section.

4 In the expanded dialog box, select Include All Objects.

5 Under Destination, click Insert as New Block.

6 Click Create.

7 In the drawing area, specify an insertion point for the new block.

An unnamed block is inserted consisting of 2D or 3D geometry.
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Shortcut menu: Generate 2D/3D Section
Command entry: SECTIONPLANETOBLOCK

To save section block components on separate layers

1 Click Home tab ➤ Section panel ➤ Create Block. 

2 Click a section object.

3 In the Generate Section/Elevation dialog box, click 2D Section/Elevation
or 3D Section.

4 In the expanded dialog box, click Section Settings.

5 In the Section Settings dialog box, in the list of properties, click the Layer
box under the section component that you want to update.

6 In the expanded Layer list, specify the layer on which to place the section
block component:

■ To set an existing layer name, click *ObjectByLayer* or the name of
another layer. Go to step 7.

■ To create a descriptive label to be added to the block section layer
names, click New Layer Name Settings.

7 In the New Layer Name dialog box, specify how the descriptive text will
look:

■ Under Added Text Type, specify whether you want the descriptive
text to be a prefix or a suffix.

■ Under Text Added to the Existing Layer Name, enter descriptive text
to be added to the layer name.

Click OK.

8 In the Section Settings dialog box, click OK.

9 In the Generate Section / Elevation dialog box, click Create.

Shortcut menu: Generate 2D/3D Section
Command entry: SECTIONPLANETOBLOCK

To save a section object tool as a tool palette tool

1 On a section object, select the section line.
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2 Drag the section object to the position on the tool palette where you
want to place the tool.

The black line indicates the new location of the tool.

3 Release the mouse button.

The section object is saved as a tool on the tool palette.

Quick Reference

Commands

BEDIT

Opens the block definition in the Block Editor.

SECTIONPLANE

Creates a section object that acts as a cutting plane through 3D objects.

SECTIONPLANESETTINGS

Sets display options for the selected section plane.

SECTIONPLANETOBLOCK

Saves selected section planes as 2D or 3D blocks.

TOOLPALETTES

Opens the Tool Palettes window.

Publish Section Objects
Control the visibility of section objects when you render, plot, or view them
in the DWF file viewer.

Render Section Objects

With live sectioning turned on, all lines on a section object are rendered as
2D lines. The section plane indicator is rendered as a transparent material. Its
degree of transparency is controlled in the Properties palette.

If you want to render a 3D cutaway, save the cutaway section as a 3D block
and render the block reference.
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Plot Section Objects

When a section object is in a Section Boundary or Section Volume state,
displayed lines cannot be plotted. The section plane indicator is plotted as if
it were transparent. However, it does not have the same visual quality that it
has when it is rendered.

If you do not want to plot the section line, place the section object on a layer
that is turned off.

View Section Objects in the DWF file viewer

When live sectioning is active for a section object, the 3D model is displayed
in the DWF Viewer with the best possible visual quality. Geometry that is
hidden by live sectioning is also hidden in the DWF Viewer.

Display settings for live sections have the same appearance in the viewer as
they have in the drawing. For example, dashed linetypes and hatch patterns
assigned to intersected areas of a 3D model are retained in the DWF Viewer
display.

The section object is not visible in the DWF Viewer.

Quick Reference

Commands

3DDWF

Creates a 3D DWF or 3D DWFx file of your 3D model and displays it in the
DWF Viewer.

PLOT

Plots a drawing to a plotter, printer, or file.

PUBLISH

Publishes drawings to electronic sheet sets (DWF, DWFx, or PDF files) or
plotters.

RENDER

Creates a photorealistic or realistically shaded image of a 3D solid or surface
model.

SECTIONPLANE

Creates a section object that acts as a cutting plane through 3D objects.
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SECTIONPLANESETTINGS

Sets display options for the selected section plane.

SECTIONPLANETOBLOCK

Saves selected section planes as 2D or 3D blocks.

Create a Flattened View
Create a flattened view of the 3D solids and regions in the current view.

Create a Flatshot Object

With the FLATSHOT command, you can create a flattened, 2D representation
of the 3D model projected onto the XY plane. The resulting objects can be
inserted as a block or saved as a separate drawing.

The process is like taking a photograph of the entire 3D model and then laying
the photograph flat. This feature is useful for creating technical illustrations.

The flatshot process works only in model space. Start by setting up the view
you want, including orthographic or parallel views. All 3D objects in the model
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space viewport are captured. Therefore, be sure to place the objects you do
not want captured on layers that are turned off or frozen.

As you create the block, you can control how hidden lines are displayed by
adjusting the Foreground and Obscured Lines settings in the Flatshot dialog
box. For best results with mesh objects, clear the Show box under Obscured
Lines so that hidden lines are not represented.

Three-dimensional objects that have been sectioned are captured in their
entirety, as if they had not been sectioned.

NOTE To create profile images of 3D solids in paper space, use the SOLPROF
command.

Modify a Flatshot Block

You can modify a flattened view that has been inserted as a block in the same
way that you modify any other 2D block geometry.

To create a flattened 2D view of a 3D model

1 Set up the view of the 3D model.

2 Click Home tab ➤ Section panel ➤ Flatshot. 

3 In the Flatshot dialog box, under Destination, click one of the options.

4 Change the color and linetype settings for Foreground and Obscured
lines.

5 Click Create.

6 Specify an insertion point on the screen to place the block. Adjust the
basepoint, scale, and rotation if necessary.

A block is created consisting of 2D geometry that is projected onto the
XY plane of the current UCS.

Command entry: FLATSHOT

Quick Reference

Commands

FLATSHOT

Creates a 2D representation of all 3D objects based on the current view.
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SOLPROF

Creates 2D profile images of 3D solids for display in a layout viewport.
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Annotate Drawings
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Work with Annotations

When you annotate your drawings, you can use certain tools and properties to make working
with annotations easier.

Overview of Annotations
Annotations are notes or other types of explanatory symbols or objects that are
commonly used to add information to your drawing.

Examples of annotations include

■ Notes and labels

■ Tables

■ Dimensions and tolerances

■ Hatches

■ Callouts

■ Blocks

The types of objects that you use to create annotations include

■ Hatches

■ Text (single-line and multiline)

■ Tables

■ Dimensions

■ Tolerances

■ Leaders and multileaders
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■ Blocks

■ Attributes

Quick Reference

Commands

ATTDEF

Creates an attribute definition for storing data in a block.

BLOCK

Creates a block definition from selected objects.

DIMSTYLE

Creates and modifies dimension styles.

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.

MLEADERSTYLE

Creates and modifies multileader styles.

MTEXT

Creates a multiline text object.

OBJECTSCALE

Adds or deletes supported scales for annotative objects.

STYLE

Creates, modifies, or specifies text styles.

TEXT

Creates a single-line text object.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Scale Annotations
You can automate the process of scaling annotations in various layout
viewports and in model space.

Overview of Scaling Annotations
Objects that are commonly used to annotate drawings have a property called
Annotative. This property allows you to automate the process of scaling
annotations so that they plot or display at the correct size on the paper.

Instead of creating multiple annotations at different sizes and on separate
layers, you can turn on the annotative property by object or by style, and set
the annotation scale for layout or model viewports. The annotation scale
controls the size of the annotative objects relative to the model geometry in
the drawing.

The following objects are commonly used to annotate drawings and contain
an annotative property:

■ Text

■ Dimensions

■ Hatches

■ Tolerances

■ Multileaders

■ Blocks

■ Attributes
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When the Annotative property for these objects is turned on (set to Yes), these
objects are called annotative objects.

You define a paper size for annotative objects. The annotation scale you set for
layout viewports and model space determines the size of the annotative objects
in those spaces.

Save to Legacy Drawing File Format

Set the system variable SAVEFIDELITY to 1 when you save a drawing that
contains annotative objects to a legacy drawing file format (AutoCAD 2007
or earlier). This preserves the visual fidelity of the drawing when it is opened
in a release earlier than AutoCAD 2008 by saving individual representations
of each scale of each annotative object. The individual objects are saved to
layers that are used to organize objects of the same scale. Setting SAVEFIDELITY
to 0, when opening the drawing in AutoCAD 2008 or later release, results in
improved performance. For more information about saving a drawing to a
previous release, see Save a Drawing on page 226.

Workflow for Annotating Drawings

The following steps represent a typical workflow for annotating a drawing so
that your annotations will scale automatically.

1 Create annotative styles on page 1403.

2 In model space, set the annotation scale to the scale at which the
annotations will be plotted or displayed on page 1396.

3 Create annotative objects using annotative styles on page 1403.

If one or more annotative objects needs to be displayed at an additional scale,
follow these steps.

1 Add the additional scale to the annotative objects on page 1426.

2 Set the annotation scale to the new scale on page 1396 (the annotative
objects that support the new scale will be resized based on the annotation
scale).

3 Reposition the annotative objects as needed for the new scale

When you create your layouts, follow these steps.

1 Create a new layout on page 440 or make a layout current on page 442.

2 Create viewports on page 453.
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3 Set the annotation scale for each viewport on page 1396. (For each viewport,
the annotation scale and viewport scale should be the same).

For more information about setting visibility for annotative objects, see Display
Annotative Objects on page 1422. For more information about adding scales to
annotative objects, see Add and Modify Scale Representations on page 1424.

Quick Reference

Commands

OBJECTSCALE

Adds or deletes supported scales for annotative objects.

System Variables

ANNOAUTOSCALE

Updates annotative objects to support the annotation scale when the
annotation scale is changed.

CANNOSCALE

Sets the name of the current annotation scale for the current space.

CANNOSCALEVALUE

Returns the value of the current annotation scale.

MSLTSCALE

Scales linetypes displayed on the model tab by the annotation scale.

Utilities

No entries

Command Modifiers

No entries

Set Annotation Scale
is a setting that is saved with model space, layout viewports, and model views.
When you add objects to your drawing, they support the current annotation
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scale and are scaled based on that scale setting and automatically displayed
at the correct size in model space.

Before you add annotative objects to your model, you set the annotation scale.
Think about the eventual scale settings of the viewports in which the
annotations will display. The annotation scale should be set to the same scale
as the viewport in which the annotative objects will display in the layout (or
the plot scale if plotting from model space). For example, if the annotative
objects will display in a viewport that has a scale of 1:2, then you set the
annotation scale to 1:2.

When working on the model tab or when a viewport is selected, the current
annotation scale is displayed on the application or drawing status bar. You
can use the status bars to change the annotation scale.

You can use the ANNOAUTOSCALE system variable to update annotative
objects to support the current scale automatically when the annotation scale
is changed. ANNOAUTOSCALE is turned off by default to keep file size down

and improve performance. When ANNOAUTOSCALE is off, this button 
is displayed this way on the right side of the drawing status bar or application
status bar.

Use the CANNOSCALE system variable to set a default annotation scale setting.

See also:

■ Drawing Status Bar on page 37

To set the annotation scale while working on the Model tab

1 On the right side of the drawing or application status bar, click the arrow
next to the displayed annotation scale.

2 Select a scale from the list.

To set the annotation scale for a layout viewport

1 On a layout tab, select a viewport.

2 On the right side of the drawing or application status bar, click the arrow
next to the displayed annotation scale.

3 Select a scale from the list.
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To set the default annotation scale

1 At the command prompt, enter cannoscale.

2 Enter a scale name. Press ENTER

Command entry: CANNOSCALE

Quick Reference

Commands

OBJECTSCALE

Adds or deletes supported scales for annotative objects.

System Variables

ANNOAUTOSCALE

Updates annotative objects to support the annotation scale when the
annotation scale is changed.

CANNOSCALE

Sets the name of the current annotation scale for the current space.

CANNOSCALEVALUE

Returns the value of the current annotation scale.

MSLTSCALE

Scales linetypes displayed on the model tab by the annotation scale.

Utilities

No entries

Command Modifiers

No entries

Create Annotative Objects
Objects that are commonly used to annotate drawings have a property called
Annotative. When the Annotative property for these objects is turned on (set
to Yes), these objects are called annotative objects
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Overview of Creating Annotative Objects
When you add annotations to your drawing, you can turn on the property
for those objects. These annotative objects are scaled based on the current
setting and are automatically displayed at the correct size

Annotative objects are defined at a paper height and display at the size
determined by the annotation scale.

The following objects can be annotative (have an Annotative property):

■ Hatches

■ Text (single-line and multiline)

■ Dimensions

■ Tolerances

■ Leaders and multileaders (created with MLEADER)

■ Blocks

■ Attributes

Many of the dialog boxes used to create these objects contain an Annotative
check box where you can make the object annotative. You can also change
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existing objects to be annotative by changing the annotative property in the
Properties palette.

When you hover the cursor over an annotative object that supports one

annotation scale, the cursor displays a  icon. When the object supports

more than one annotation scale, it displays a  icon.

Text, dimension, and multileader styles can also be annotative. Annotative
styles create annotative objects.

Visual Fidelity for Annotative Objects

When working with objects, this option allows you to maintain visual fidelity
for these objects when they are viewed in AutoCAD 2007 and earlier releases.
Visual fidelity is controlled by the SAVEFIDELITY system variable.

If you work primarily in model space, it is recommended that you turn off
visual fidelity (set SAVEFIDELITY to 0). However, if you need to exchange
drawings with other users, and layout fidelity is most important, then visual
fidelity should be turned on (set SAVEFIDELITY to 1).

NOTE The SAVEFIDELITY system variable does not affect saving a drawing to the
AutoCAD 2010 drawing or DXF file formats.
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Annotative objects may have multiple . When visual fidelity is on, annotative
objects are decomposed and scale representations are saved (in an ) to separate
layers, which are named based on their original layer and appended with a
number. If you explode the block in AutoCAD 2007 or earlier releases, and
then open the drawing in AutoCAD 2008 or later releases, each scale
representation becomes a separate annotative object, each with one annotation
scale. It is not recommended that you edit or create objects on these layers
when working with a drawing created in AutoCAD 2008 and later releases in
AutoCAD 2007 and earlier releases.

When this option is not selected, a single model space representation is
displayed on the Model tab. More annotation objects may be displayed on
the Model tab depending on the ANNOALLVISIBLE setting. Also, more objects
may be displayed in paper space viewports at different sizes than in AutoCAD
2008 and later releases.

For a procedure to set this option for annotative objects, see To maintain
visual fidelity for annotative objects on page 232.

See also:

■ Work with Annotative Styles on page 1401

Quick Reference

Commands

ATTDEF

Creates an attribute definition for storing data in a block.

BLOCK

Creates a block definition from selected objects.

DIMSTYLE

Creates and modifies dimension styles.

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.

MLEADERSTYLE

Creates and modifies multileader styles.
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MTEXT

Creates a multiline text object.

STYLE

Creates, modifies, or specifies text styles.

TEXT

Creates a single-line text object.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Work with Annotative Styles
You can minimize the steps to annotate a drawing by using annotative styles.

Annotative text, dimension, and multileader styles create objects.

The dialog boxes used to define these objects contain an Annotative check
box where you can make the styles annotative. Annotative styles display a

special  icon before their names in dialog boxes and the Properties
palette.

Create Annotative Objects | 1401



You should specify the Paper Height value for any annotative text styles you
create. The Paper Height setting specifies the height of the text in paper space.

NOTE If you’ve specified the Paper Height value for a dimension or multileader
style, this setting overrides the text style Paper Height setting.

If you redefine styles to be annotative or nonannotative, existing objects that
reference those styles are not automatically updated to reflect the annotative
property of the style or definition. Use the ANNOUPDATE command to update
the existing objects to the current Annotative properties of the style.

When you change the Style property of an existing object (whether it’s
annotative or nonannotative), the object’s annotative properties will match
that of the new style. If the style does not have a fixed height (the Height
value is 0), the paper height of the object is calculated based on the object’s
current height and the annotation scale.

See also:

■ Work with Text Styles on page 1544

■ Create Annotative Text on page 1404

■ Use Dimension Styles on page 1630

■ Create Annotative Dimensions and Tolerances on page 1409
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■ Work with Leader Styles on page 1525

■ Create Annotative Leaders and Multileaders on page 1413

To create an annotative style

■ Follow the steps in one of the following procedures

■ To create a new annotative text style on page 1405

■ To change an existing nonannotative text style to annotative on page
1405

■ To create a new annotative dimension style on page 1410

■ To change an existing dimension style to annotative on page 1410

■ To create a new annotative multileader style on page 1414

■ To change an existing multileader style to annotative on page 1414

To create annotative objects from annotative styles

■ Follow the steps in one of the following procedures

■ To create annotative single-line text on page 1406

■ To create annotative multiline text on page 1406

■ To create an annotative dimension on page 1411

■ To create an annotative multileader on page 1415

Quick Reference

Commands

ANNOUPDATE

Updates existing annotative objects to match the current properties of their
styles.

DIMSTYLE

Creates and modifies dimension styles.
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MLEADERSTYLE

Creates and modifies multileader styles.

STYLE

Creates, modifies, or specifies text styles.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create Annotative Text
Use text for notes and labels in your drawing. You create annotative text by
using an annotative text style, which sets the height of the text on the paper.

The current automatically determines the display size of the text in model
space or paper space viewports.

For example, you want text to display at a height of 3/16" on the paper, so
you can define a text style to have a paper height of 3/16". When you add
text to a viewport that has a scale of 1/2"=1'0", the current annotation scale,
which is set to the same scale as the viewport’s, automatically scales the text
to display appropriately at 4.5".

You can also change existing nonannotative text to annotative by changing
the text’s Annotative property to Yes. This applies to any text created through
text styles or through the TEXT and MTEXT commands.

You can set the orientation of annotative text objects to match the orientation
of the paper. For more information about setting the orientation of annotative
objects, see Set Orientation for Annotations on page 1428.

See also:

■ Create Text on page 1472

■ Work with Annotative Styles on page 1401
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To create a new annotative text style

1 Click Annotate tab ➤ Text panel ➤ Text Style. 

2 In the Text Style dialog box, click New.

3 In the New Text Style dialog box, enter a new style name.

4 Click OK.

5 In the Text Style dialog box, under Size, select Annotative.

6 In the Paper Text Height box, enter the height of the text as it will display
on paper.

7 Click Apply.

8 (Optional) Click Set Current to set this style as the current text style.

9 Click Close.

Command entry: STYLE

To change an existing nonannotative text style to annotative

1 Click Annotate tab ➤ Text panel ➤ Text Style. 

2 In the Text Style dialog box, Styles list, select a style.

NOTE A  icon next to a text style name indicates that the style is
already annotative.

3 Under Size, select Annotative.

4 In the Paper Text Height box, enter the height of the text as it will display
on paper.

5 Click Apply.

6 (Optional) Click Set Current to set this style as the current text style.

7 Click Close.
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Command entry: STYLE

To create annotative single-line text

1 Click Annotate tab ➤ Text panel ➤ Text Style. 

2 In the Text Style dialog box, Styles list, select an annotative text style.

NOTE A  icon next to a text style name indicates that the style is
annotative.

3 Click Set Current to set this style as the current text style.

4 Click Close.

5 Click Annotate tab ➤ Text panel ➤ Single Line Text. 

6 Specify the insertion point for the first character.

7 Specify a text rotation angle.

8 Enter the text.

Command entry: STYLE, TEXT

To create annotative multiline text

1 Click Annotate tab ➤ Text panel ➤ Multiline Text. 

2 Specify opposite corners of a bounding box to define the width of the
multiline text object. The In-Place Text Editor is displayed.

3 Do one of the following:

■ On the Text Formatting toolbar, in the Text Style control, click the
arrow and select an existing annotative text style from the list.

■ Click the Annotative button on the toolbar to create annotative
multiline text.

4 Enter the text.
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5 On the Text Formatting toolbar, click OK.

Command entry: MTEXT

To change existing multiline text to annotative or nonannotative

1 Double-click a multiline text object. The In-Place Text Editor is displayed.

2 Click the Annotative  button on the toolbar to change existing
multiline text to annotative or nonannotative.

When the Annotative button is depressed, the text is annotative. When
the button is not depressed, the text is nonannotative.

3 Click OK to save the changes.

Shortcut menu: Select and right-click the text. Click Properties to change
the annotative property of the text.

To change existing text (single-line or multiline) to be annotative or
nonannotative

1 In the drawing, select a text object.

2 Click View tab  ➤  Palettes panel  ➤  Properties.

3 In the Properties palette, under Text, click Annotative.

4 On the drop-down list, select Yes or No.

Command entry: PROPERTIES

To update text to reflect the current annotative properties of the text style

1 Click Annotate tab ➤ Text panel ➤ Text Style. 

2 In the Text Style dialog box, Styles list, select the style used by the text
that you want to update.
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NOTE A  icon next to a text style name indicates that the style is
already annotative.

3 Under Size, select Annotative.

4 In the Paper Text Height box, enter the height of the text as it will display
on paper.

5 Click Apply.

6 (Optional) Click Set Current to set this style as the current text style.

7 Click Close.

8 In the drawing, select all the text objects (text and mtext) that you want
to update.

9 At the command prompt, enter annoupdate.

Command entry: STYLE

To change the height of annotative text as it will display on the paper

1 In the drawing, select a text object.

2 Click View tab  ➤  Palettes panel  ➤  Properties.

3 In the Properties palette, under Paper Text Height, enter a new value.

Command entry: PROPERTIES

Quick Reference

Commands

MTEXT

Creates a multiline text object.

STYLE

Creates, modifies, or specifies text styles.
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TEXT

Creates a single-line text object.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create Annotative Dimensions and Tolerances
You can create dimensions for measurements in your drawing through
annotative dimension styles.

Annotative dimension styles create dimensions in which all the elements of
the dimension, such as text, spacing, and arrows, scale uniformly by the .

If you associate a dimension to an annotative object, the associativity of the
dimension is lost.

You can also change an existing nonannotative dimension to annotative by
changing the dimension’s Annotative property to Yes.

NOTE When the current dimension style is annotative, the value of DIMSCALE is
automatically set to zero, and does not affect the dimension scale.
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You can also create annotative tolerances. Geometric tolerances show
acceptable deviations of form, profile, orientation, location, and runout of a
feature.

See also:

■ Dimensions and Tolerances on page 1623

■ Use Dimension Styles on page 1630

■ Work with Annotative Styles on page 1401

To create a new annotative dimension style

1 Click Annotate tab ➤ Dimensions panel ➤ Dimension Style. 

2 In the Dimension Style Manager dialog box, click New.

3 In the Create New Dimension Style dialog box, enter a new style name.

4 Select Annotative.

5 Click Continue.

6 In the New Dimension Style dialog box, select the appropriate tab and
make changes to define the dimension style.

7 Click OK.

8 (Optional) Click Set Current to set this style as the current dimension
style.

9 Click Close.

Command entry: DIMSTYLE

To change an existing dimension style to annotative

1 Click Annotate tab ➤ Dimensions panel ➤ Dimension Style. 

2 In the Dimension Style Manager dialog box, Styles list, select a style.
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NOTE A  icon next to a dimension style name indicates that the style
is already annotative.

3 Click Modify.

4 In the Modify Dimension Style dialog box, Fit tab, under Scale for
Dimension Features, select Annotative.

5 Click OK.

6 (Optional) Click Set Current to set this style as the current dimension
style.

7 Click Close.

Command entry: DIMSTYLE

To create an annotative dimension

1 Click Annotate tab ➤ Dimensions panel ➤ Dimension Style. 

2 In the Dimension Style Manager dialog box, Styles list, select an
annotative dimension style.

A  icon next to a dimension style name indicates that the style is
annotative.

3 Click Set Current.

4 Click Close.

5 Click Dimension menu and select a dimension type.

6 Press ENTER to select the object to dimension or specify the first and
second extension line origins.

7 Specify the dimension line location.

Command entry: DIMSTYLE
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To change an existing dimension to annotative or nonannotative

1 Select a dimension in a drawing.

2 Click View tab  ➤  Palettes panel  ➤  Properties.

3 In the Properties palette, under Misc, click Annotative.

4 On the drop-down list, select Yes or No.

Command entry: PROPERTIES

To update dimensions to reflect the current annotative properties of the
dimension style

1 Click Annotate tab ➤ Dimensions panel ➤ Dimension Style. 

2 In the Dimension Style Manager dialog box, Styles list, select a style.

NOTE A  icon next to a dimension style name indicates that the style
is already annotative.

3 Click Modify.

4 In the Modify Dimension Style dialog box, Fit tab, under Scale for
Dimension Features, select Annotative.

5 Click OK.

6 (Optional) Click Set Current to set this style as the current dimension
style.

7 Click Close.

8 In the drawing, select all the dimensions that you want to update.

9 At the command prompt, enter annoupdate.

Command entry: DIMSTYLE

To create an annotative tolerance

1 Follow the steps in To create geometric tolerances on page 1738.
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2 Click View tab  ➤  Palettes panel  ➤  Properties.

3 In the Properties palette, under Misc, click Annotative.

4 On the drop-down list, select Yes or No.

Command entry: PROPERTIES

Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

STYLE

Creates, modifies, or specifies text styles.

System Variables

DIMANNO

Creates a single-line text object.

Utilities

No entries

Command Modifiers

No entries

Create Annotative Leaders and Multileaders
Leaders and multileader on page 1941 are used to add call outs to your drawings.
You can create leaders through an annotative dimension style and multileaders
through an annotative multileader style.

When you create a leader, you create two separate objects: the leader and the
text, block, or tolerance associated with the leader. When you create a
multileader, you create a single object.
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If the multileader style is annotative, the associated text or tolerance will be
annotative as well, regardless of the annotative setting of the text style or
tolerance.

NOTE It is recommended that you create non-annotative entities when creating
a mleader content block.

Blocks used in leaders and multileaders must be non-annotative.

You can change the Annotative property of leaders and multileaders in the
Properties palette.

See also:

■ Create Leaders on page 1514

■ Work with Leader Styles on page 1525

To create a new annotative multileader style

1 Click Annotate tab ➤ Multileaders panel ➤ Multileader Style. 

2 In the Multileader Style Manager dialog box, click New.

3 In the Create New Multileader Style dialog box, enter a new style name,
and select Annotative.

4 Click Continue.

5 In the Modify Multileader Style dialog box, select the appropriate tab and
make changes to define the multileader style.

6 Click OK.

7 (Optional) Click Set Current to set this style as the multileader style.

8 Click Close.

Command entry: MLEADERSTYLE

To change an existing multileader style to annotative

1 Click Annotate tab ➤ Multileaders panel ➤ Multileader Style. 
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2 In the Multileader Style Manager dialog box, Styles list, select a style.

NOTE A  icon next to a multileader style name indicates that the style
is already annotative.

3 Click Modify.

4 In the Modify Multileader Style dialog box, Leader Structure tab, under
Scale, select Annotative.

5 Click OK.

6 (Optional) Click Set Current to set this style as the multileader style.

7 Click Close.

Command entry: MLEADERSTYLE

To create an annotative multileader

1 Click Annotate tab ➤ Multileaders panel ➤ Multileader Style. 

2 In the Multileader Style Manager dialog box, Styles list, select an
annotative multileader style.

NOTE A  icon next to a multileader style name indicates that the style
is annotative.

3 Click Set Current.

4 Click Close.

5 Click Annotate tab ➤ Multileaders panel ➤ Multileader. 

6 Choose a point for the leader head.

7 Choose the last point for the leader.

8 Specify the text width.
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9 Enter text.

10 On the Text Formatting toolbar, click OK.

Command entry: MLEADERSTYLE, MLEADER

To change an existing leader or multileader to annotative or nonannotative

1 Select a leader or multileader in a drawing.

2 Click View tab  ➤  Palettes panel  ➤  Properties.

3 In the Properties palette, under Misc, click Annotative.

4 On the drop-down list, select Yes or No.

Command entry: PROPERTIES

Quick Reference

Commands

MLEADERSTYLE

Creates and modifies multileader styles.

STYLE

Creates, modifies, or specifies text styles.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create Annotative Blocks and Attributes
If you want to use geometric objects to annotate your drawing, combine the
objects into an annotative block definition.

block definitions create annotative block references. Annotative block
references and attributes initially support the current annotation scale at the
time they are inserted. You should insert annotative block references with a
unit factor of 1.

You cannot change the Annotative property of individual block references.

To set an annotative block’s paper size, you should define the block in paper
space or on the Model tab with the set to 1:1.
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When creating and working with annotative blocks and annotative objects
within blocks, the following points should be noted:

■ Nonannotative blocks can contain annotative objects, which are scaled
by the block’s scale factor in addition to the annotation scale.

■ Annotative blocks cannot reside in annotative blocks.

■ Annotative block references are scaled uniformly by the current annotation
scale as well as any user scale applied to the block reference.

■ Blocks that contain annotative objects should not be manually scaled.

You can define annotative attributes for annotative and nonannotative blocks.
Use annotative attributes with nonannotative blocks when you want the
geometry in the block to display on the paper based on the scale of the
viewport, but you want the attribute text to display at the Paper Height defined
for the attribute.

You can set the orientation of annotative blocks to match the orientation of
the paper. For more information about setting the orientation of annotative
objects, see Set Orientation for Annotations on page 1428.

You can use the ANNOTATIVEDWG system variable to specify whether or
not the entire drawing will behave as an annotative block when inserted into
another drawing. The ANNOTATIVEDWG system variable becomes read-only
if the drawing contains annotative objects.

NOTE The INSUNITS setting is ignored when inserting blocks into a drawing.

See also:

■ Create and Use Blocks (Symbols) on page 853

■ Attach Data to Blocks (Block Attributes) on page 1027

To create an annotative block definition

1 Click Blocks & References tab ➤ Block panel ➤ Create. 

2 In the Block Definition dialog box, enter a block name in the Name box.

3 Under Objects, select Convert to Block.

4 Click Select Objects.
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5 Under Behavior, select Annotative.

6 Use your pointing device to select objects to be included in block
definition. Press ENTER to complete object selection.

7 In the Block Definition dialog box, under Base Point, specify the block
insertion point.

8 Click OK.

Command entry: BLOCK

To update existing block references to be annotative

1 Click Blocks & References tab ➤ Block panel ➤ Create. 

2 In the Block Definition dialog box, Name box, click the arrow and select
the name of the block you want to update to be annotative.

3 Under Behavior, select Annotative.

4 Click OK.

The existing block references in the drawing are now annotative.

Command entry: BLOCK

To create an annotative attribute definition

1 Click Blocks & References tab ➤ Attributes panel ➤ Define Attributes.

2 In the Attribute Definition dialog box, set the Attribute Modes and enter
Tag information, Insertion Point and Text Settings.

3 Under Text Settings, select Annotative.

4 Click OK.

5 Specify the start point.

6 Press ENTER.

Command entry: ATTDEF
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Quick Reference

Commands

ATTDEF

Creates an attribute definition for storing data in a block.

BLOCK

Creates a block definition from selected objects.

System Variables

ANNOTATIVEDWG

Specifies whether or not the drawing will behave as an annotative block
when inserted into another drawing.

Utilities

No entries

Command Modifiers

No entries

Create Annotative Hatches
Use an annotative hatch to symbolically represent material such as sand,
concrete, steel, earth, etc.

An hatch is defined at a paper size. You can create individual annotative hatch
objects as well as annotative hatch patterns.

The hatch pattern definitions stored in the acad.pat file contain information
that indicates whether the pattern is annotative or non-annotative. When
the selected hatch pattern is annotative, the Annotative checkbox in the Hatch
and Gradient dialog box should be selected.

The orientation of annotative hatches always matches the orientation of the
layout.
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See also:

■ Overview of Hatch Pattern Definitions in the Customization Guide

To create an annotative hatch object

1 Click Home tab ➤ Draw panel ➤ Hatch. 

2 In the Hatch and Gradient dialog box, click Add: Select Objects.

3 Specify the object or objects you want to hatch.

4 Under Options, select Annotative.

5 Click OK.

Command entry: HATCH

To change an existing hatch object to annotative

1 In model space, at the command prompt, enter cannoscale.

2 Enter the scale set for the viewport in which the hatch is displayed.

3 In the drawing, select the hatch.
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4 In the Properties palette, under Pattern, click Annotative.

5 On the drop-down list, select Yes.

Quick Reference

Commands

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Display Annotative Objects
For model space or a layout viewport, you can display all the annotative objects
or only those that support the current annotation scale.

This reduces the need to use multiple layers to manage the visibility of your
annotations.

You use the Annotation Visibility button on the right side of the application
or drawing status bar to choose the display setting for annotative objects.

Annotation visibility is turned on by default.  When annotation visibility
is turned on, all annotative objects are displayed. When annotation visibility

is turned off  , only annotative objects for the current scale are displayed.

In general, you should turn off annotation visibility, except when inspecting
a drawing created by another person or when adding scales to existing
annotative objects.
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Annotation visibility is also controlled by the ANNOALLVISIBLE system
variable.

In order for an annotative object to be visible, the layer the object is on must
be turned on.

If an object supports more than one annotation scale, the object will display
at the current scale.

When the MSLTSCALE system variable is set to 1 (default), linetypes displayed
on the model tab are scaled by the annotation scale

See also:

■ Drawing Status Bar on page 37

To display or hide annotative objects in a drawing

 ➤ On the drawing or application status bar, click the Annotation Visibility
button.

When the  button is displayed, all annotative objects are displayed.

When the  button is displayed, only annotative objects that support
the current annotation scale are displayed.

Quick Reference

Commands

No entries

System Variables

ANNOALLVISIBLE

Hides or displays annotative objects that do not support the current
annotation scale.

MSLTSCALE

Scales linetypes displayed on the model tab by the annotation scale.
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SELECTIONANNODISPLAY

Controls whether alternate scale representations are temporarily displayed
in a dimmed state when an annotative object is selected.

Utilities

No entries

Command Modifiers

No entries

Add and Modify Scale Representations
When you create an object in your drawing, it supports one : the annotation
scale that was current when you created the object. You can update annotative
objects to support additional annotation scales.

When you update an annotative object to support additional scales, you add
additional to the object.

For example, if an annotative multileader supports two annotations scales, it
has two scale representations.

When you select an annotative object, grips are displayed on the scale
representation that supports the current annotation scale. You can use these
grips to manipulate the current scale representation. All other scale
representations of the object are displayed in a dimmed state when the
SELECTIONANNODISPLAY system variable is set to 1 (default).
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Use the ANNORESET command to reset the location of all scale representations
for an annotative object to that of the current scale representation.

To add the current annotation scale to an annotative object

1 Click Annotate tab ➤ Annotation Scaling panel ➤ Add/Delete Scales.

2 In a drawing, select one or more annotative objects.

3 Press ENTER.

Command entry: OBJECTSCALE
Shortcut menu: With an annotative object selected, right-click in the
drawing area. Click Annotative Object Scale  ➤  Add Current Scale.

To delete the current annotation scale from an annotative object

1 Click Annotate tab ➤ Annotation Scaling panel ➤ Add/Delete Scales.

2 In a drawing, select one or more annotative objects.

3 Press ENTER.
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Command entry: OBJECTSCALE
Shortcut menu: With an annotative object selected, right-click in the
drawing area. Click Annotative Object Scale  ➤  Add Current Scale.

To automatically update annotative objects to support the current annotation
scale

■ On the drawing or application status bar, click the button  so it

displays as  .

To add an annotation scale to an annotative object

1 Click Annotate tab ➤ Annotation Scaling panel ➤ Add/Delete Scales.

2 In the drawing area, select one or more annotative objects.

3 Press ENTER.

4 In the Annotative Object Scale dialog box, click Add.

5 In the Add Scales to Object dialog box, select one or more scales to add
to the objects. (Press and hold the SHIFT key to select more than one
scale.)

6 Click OK.

7 In the Annotative Object Scale dialog box, click OK.

Command entry: OBJECTSCALE
Shortcut menu: With an annotative object selected, right-click in the
drawing area. Click Annotative Object Scale  ➤  Add/Delete Scales.

To delete an annotation scale from an annotative object

1 Click Annotate tab ➤ Annotation Scaling panel ➤ Add/Delete Scales.

2 In the drawing area, select one or more annotative objects.
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3 Press ENTER.

4 In the Annotative Object Scale dialog box, select one or more scales to
delete from the objects. (Press and hold the SHIFT key to select more than
one scale.).

NOTE You cannot delete the 1:1 scale.

5 Click OK.

Command entry: OBJECTSCALE
Shortcut menu: With an annotative object selected, right-click in the
drawing area. Click Annotative Object Scale  ➤  Add/Delete Scales.

Quick Reference

Commands

ANNORESET

Resets the locations of all alternate scale representations of the selected
annotative objects.

OBJECTSCALE

Adds or deletes supported scales for annotative objects.

System Variables

SELECTIONANNODISPLAY

Controls whether alternate scale representations are temporarily displayed
in a dimmed state when an annotative object is selected.
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Utilities

No entries

Command Modifiers

No entries

Set Orientation for Annotations
blocks and text can be set so that their orientation matches the orientation
of the layout. The orientation of annotative hatches always matches the
orientation of the layout.

Even if the view in the layout viewport is twisted or if the viewpoint is
non-planar, the orientation of these objects in layout viewports will match
the orientation of the layout.

Annotative attributes in blocks match the paper orientation of the block.

See also:

■ Work with Text Styles on page 1544

■ Create Annotative Text on page 1404

■ Create Annotative Blocks and Attributes on page 1417
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■ Create Annotative Hatches on page 1420

To match the layout’s orientation for an annotative text style

1 Click Annotate tab ➤ Text panel ➤ Text Style. 

2 In the Text Style dialog box, Styles list, select an annotative text style.

NOTE A  icon next to a text style name indicates that the style is
annotative.

3 Under Size, select Match Text Orientation to Layout.

4 Click Apply.

5 Click Close.

Command entry: STYLE

To match the layout’s orientation for an annotative block definition

1 Click Blocks & References tab ➤ Block panel ➤ Create. 

2 In the Block Definition dialog box, under Name, select a block.

3 Under Behavior, select Annotative.

4 Under Behavior, select Match Block Orientation to Layout.

5 Click Close.

Command entry: BLOCK

To match the layout’s orientation for an existing annotative text object

1 In the drawing, select an annotative text object.

2 Click Annotate tab ➤ Text panel ➤ Text Style. 
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3 In the Text Style dialog box, under Size, select Match Orientation to
Layout.

Command entry: STYLE
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Hatches, Fills, and
Wipeouts

■ Overview of Hatch Patterns and Fills on page 1431
■ Define Hatch Boundaries on page 1440
■ Choose Hatch Patterns and Solid Fills on page 1449
■ Modify Hatches and Solid-Filled Areas on page 1459
■ Create a Blank Area to Cover Objects on page 1465

Overview of Hatch Patterns and Fills

Define the Boundaries of a Hatch

You can choose from several methods to specify the boundaries of a hatch.

■ Specify a point in an area that is enclosed by objects.

■ Select objects that enclose an area.

■ Drag a hatch pattern into an enclosed area from a tool palette or
DesignCenter.

When you hatch a drawing, whole or partial objects that are not part of the
object boundary are ignored.

If a hatch line encounters an object such as text, an attribute, or a solid-fill
object, and if the object is selected as part of the boundary set, HATCH hatches
around the object.

24
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NOTE If you want to hatch an area whose boundary is not quite closed, you can
set the HPGAPTOL system variable to bridge gaps and treat the boundary as closed.
HPGAPTOL applies only to gaps between lines and arcs that, if extended, would
meet.

To reduce file size, a hatched area is defined in the drawing database as a single
graphical object.

Add Hatch Patterns and Solid Fills

You can use several methods to add hatch patterns to your drawing.

■ The HATCH command provides the most options.

■ You can drag hatches from a tool palette. Use tool palettes when you need
additional speed and convenience.
With the Tool Palettes window open, you can right-click a pattern tool to
access the Tool Properties dialog box from the shortcut menu. This dialog
box contains several hatch pattern options that are also available through
HATCH. For example, you can specify the scale and spacing for the hatch
pattern.

■ You can also use DesignCenter.

Control the Hatch Origin

By default, hatch patterns always “line up” with each other. However,
sometimes you might need to move the starting point, called the origin point,
of the hatch. For example, if you create a brick pattern, you might want to
start with a complete brick in the lower-left corner of the hatched area. In
that case, use the Hatch Origin options in the Hatch and Gradient dialog box.
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The location and behavior of a hatch pattern depends on the HPORIGIN,
HPORIGINMODE, and HPINHERIT system variables, and the location and
orientation of the user coordinate system.

Choose a Hatch Pattern

The program supplies a solid fill and more than 50 industry-standard hatch
patterns that you can use to differentiate the components of objects or
represent object materials. The program also comes with 14 hatch patterns
that conform to the ISO (International Standards Organization) standards.
When you select an ISO pattern, you can specify a pen width, which
determines the lineweight in the pattern.

On the Hatch of the Hatch and Gradient dialog box, the Type and Pattern
area displays the names of all the hatch patterns defined in the acad.pat text
file. You can add new hatch patterns to the dialog box by adding their
definitions to the acad.pat file.

Create Associative Hatches

An associative hatch is updated when you change the boundary. Hatched areas
created with HATCH are associative by default. This setting is stored in the
system variable HPASSOC. Hatches created by dragging hatch patterns from
tool palettes or DesignCenter™ use the setting in HPASSOC. You can remove
hatch associativity at any time or use HATCH to create a nonassociative hatch.
When the HPGAPTOL system variable is set to 0 (the default), associativity is
automatically removed if editing creates an open boundary.

You can use HATCH to create nonassociative hatches, which are independent
of their boundaries.

Create an Annotative Hatch

An hatch is defined at a paper size. You can create individual annotative hatch
objects as well as annotative hatch patterns.
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Use an annotative hatch to symbolically represent material such as sand,
concrete, steel, earth, etc.

For more information about creating and working with an annotative hatch,
see Create Annotative Hatches on page 1420.

Assign a Draw Order to a Hatch

You can assign a draw order to a hatch so that it is drawn either behind or in
front of the hatch boundary, or behind or in front of all other objects.

When you create a hatch, by default the hatch is drawn behind the hatch
boundary. This makes it easier to view and select the hatch boundary. You
can change the draw order of the hatch so that the hatch is drawn in front of
the hatch boundary instead, or either behind or in front of all other objects.
This setting is stored in the HPDRAWORDER system variable. Hatches created
by dragging hatch patterns from tool palettes or DesignCenter use the draw
order setting in HPDRAWORDER.

Limit Hatch Pattern Density

If you create a very dense hatch, the program may reject the hatch and display
a message indicating that the hatch scale is too small or its dash length too
short. You can change the maximum number of hatch lines by setting the
HPMAXLINES system variable.  You can set values between 100 and 10000000
(ten million). The default value for HPMAXLINES is 1000000.

Edit Hatch Boundaries

Because there are so many combinations of objects that can be hatched, editing
hatched geometry can produce unexpected results. If you create a hatch that
you don't want, you can undo it, trim the hatch, or delete the hatch and
rehatch the area.

Create Custom Hatch Patterns

You can also define your own hatch pattern using the current linetype with
the User Defined Pattern option of the Hatch and Gradient dialog box, or you
can create more complex hatch patterns.

See also:

■ Modify Hatches and Solid-Filled Areas on page 1459

■ “Overview of Hatch Pattern Definitions” in the Customization Guide

■ Scale Annotations on page 1393
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To drag hatch patterns into your drawing

1 Click Insert tab  ➤  Content panel  ➤  Design Center.

NOTE This procedure describes how to use DesignCenter to drag hatch
patterns into your drawing. You can also drag hatch patterns from a tool
palette.

2 On the Folders , click the Search button.

3 In the Search dialog box, make the following entries:

■ In Look For, select Hatch Pattern Files.

■ In the In box, select the drive where the program is installed.

■ Select the Search Subfolders option.

■ On the Hatch Pattern Files , in Search for the Name, enter * (asterisk).

4 Click Search Now.

The default hatch pattern file is acad.pat or acadiso.pat. The search results
may display the same file in different locations.

NOTE For convenient access, you can add the PAT file to Favorites by selecting
the file and clicking the Favorites button. A shortcut to the PAT file is displayed
in the Favorites folder on the Folders in DesignCenter.

5 In the search results, double-click the file to load the hatch patterns into
the content area of DesignCenter.

6 (Optional) Right-click a pattern to display a shortcut menu with the
following options:

■ HATCH. Opens the Hatch and Gradient dialog box.

■ Copy. Stores the hatch pattern to the Clipboard.

■ Create Tool Palette. Creates a new tool palette with the selected
pattern displayed.

7 From the content area, drag a hatch pattern onto a closed object in your
drawing or onto a tool palette.

NOTE If the hatch pattern scale is too large or small, an error message is
displayed. You can adjust the scale for any hatch pattern by double-clicking
it to display the Hatch and Gradient dialog box.

Overview of Hatch Patterns and Fills | 1435



Toolbar: Standard  
Command entry: ADCENTER

To hatch areas

1 Click Home tab ➤ Draw panel ➤ Hatch. 

2 In the Hatch and Gradient dialog box, click Add: Pick points.

3 In your drawing, specify a point inside each area that you want hatched,
and then press ENTER.

This point is known as the internal point.

4 In the Hatch and Gradient dialog box, Hatch , in the swatch box, verify
that the sample pattern is the pattern you want to use. To change patterns,
select another pattern from the Pattern list.

5 In the Hatch and Gradient dialog box, make adjustments, if necessary.

6 Under Draw Order, click one of the options.

You can change the draw order of the hatch so that the hatch is drawn
either behind or in front of the hatch boundary, or behind or in front of
all other objects.

7 Click OK.

Toolbar: Draw  
Command entry: HATCH

To hatch selected objects

1 Click Home tab ➤ Draw panel ➤ Hatch. 

2 In the Hatch and Gradient dialog box, click Add: Select objects.

3 Specify the object or objects you want to hatch.

The objects need not form a closed boundary. You can also specify any
islands that should remain unhatched. Also, you can set the HPGAPTOL
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system variable to treat a set of objects that almost enclose an area as a
closed hatch boundary.

4 Under Draw Order, click one of the options.

You can change the draw order of the hatch so that the hatch is drawn
either behind or in front of the hatch boundary, or behind or in front of
all other objects.

5 Click OK.

Toolbar: Draw  
Command entry: HATCH

Quick Reference

Commands

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.

BOUNDARY

Creates a region or a polyline from an enclosed area.

DONUT

Creates a filled circle or a wide ring.

FILL

Controls the filling of objects such as hatches, 2D solids, and wide polylines.

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.

HATCHEDIT

Modifies an existing hatch or fill.

MATCHPROP

Applies the properties of a selected object to other objects.
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PLINE

Creates a 2D polyline.

PROPERTIES

Controls properties of existing objects.

SOLID

Creates solid-filled triangles and quadrilaterals.

UCS

Manages user coordinate systems.

System Variables

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.

HPANG

Specifies the hatch pattern angle.

HPASSOC

Controls whether hatch patterns and gradient fills are associative.

HPBOUND

Controls the object type created by the BHATCH and BOUNDARY commands.

HPDRAWORDER

Controls the draw order of hatches and fills.

HPDOUBLE

Specifies hatch pattern doubling for user-defined patterns.

HPGAPTOL

Treats a set of objects that almost enclose an area as a closed hatch boundary.

HPINHERIT

Controls the hatch origin of the resulting hatch when using Inherit Properties
in HATCH and HATCHEDIT.
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HPMAXLINES

Sets the maximum number of hatch lines that are generated in a hatch
operation.

HPNAME

Sets a default hatch pattern name of up to 34 characters without spaces.

HPOBJWARNING

Sets the number of hatch boundary objects that can be selected before
displaying a warning message.

HPINHERIT

Controls the hatch origin of the resulting hatch when using Inherit Properties
in HATCH and HATCHEDIT.

HPORIGIN

Sets the hatch origin point for new hatch objects relative to the current user
coordinate system.

HPORIGINMODE

Controls how HATCH determines the default hatch origin point.

HPSCALE

Specifies the hatch pattern scale factor, which must be greater than zero.

HPSEPARATE

Controls whether HATCH creates a single hatch object or separate hatch
objects when operating on several closed boundaries.

HPSPACE

Specifies the hatch pattern line spacing for user-defined simple patterns,
which must be greater than zero.

PICKSTYLE

Controls the use of group selection and associative hatch selection.
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Utilities

No entries

Command Modifiers

No entries

Define Hatch Boundaries
You create a hatch by selecting an object to hatch or fill, or by defining a
boundary and then specifying an internal point.

Overview of Hatch Boundaries
You can hatch an enclosed area or hatch within a specified boundary using
HATCH. By default, HATCH creates associative hatches that are updated when
the boundary is changed.

You create a hatch by selecting an object to hatch or by defining a boundary
and then specifying an internal point. A hatch boundary can be any
combination of objects, such as lines, arcs, circles, and polylines, that forms
an enclosed area.

Enclosed areas within the hatch area are referred to as islands. You can hatch
them or leave them unhatched depending on the Islands setting in the Hatch
and Gradient dialog box.

If you are hatching a small area in a complex drawing, you can use boundary
sets to speed the process.

Objects can be hatched only if they are in a plane parallel to the XY plane of
the current UCS.

NOTE If you want to hatch an area that is not completely enclosed, you can set
a gap tolerance (HPGAPTOL system variable). Any gaps equal to or smaller than
the value you specify in the gap tolerance are ignored, and the boundary is treated
as closed.

Invalid Hatch Boundaries

When a hatch boundary cannot be determined, it might be because the
specified internal point is not within a fully enclosed area. Red circles are
displayed around unconnected endpoints of the boundary to identify gaps in
the hatch boundary.
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NOTE If a boundary is outside a screen display, you must zoom out to ensure the
point selected is within a fully enclosed area.

The red circles remain displayed even after you exit the HATCH command.
They are removed when you select another internal point for the hatch, or
by using the REDRAW, REGEN, or REGENALL command.

Quick Reference

Commands

BOUNDARY

Creates a region or a polyline from an enclosed area.

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.

HATCHEDIT

Modifies an existing hatch or fill.

System Variables

HPBOUND

Controls the object type created by the BHATCH and BOUNDARY commands.

HPGAPTOL

Treats a set of objects that almost enclose an area as a closed hatch boundary.

HPOBJWARNING

Sets the number of hatch boundary objects that can be selected before
displaying a warning message.
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HPSEPARATE

Controls whether HATCH creates a single hatch object or separate hatch
objects when operating on several closed boundaries.

PICKSTYLE

Controls the use of group selection and associative hatch selection.

Utilities

No entries

Command Modifiers

No entries

Control the Hatching in Islands
You can determine how enclosed areas within hatch boundaries, called islands,
are hatched.

You can determine how islands, enclosed areas within the hatch boundary,
are hatched using the three hatching styles: Normal, Outer, and Ignore. You
can preview these hatching styles in the More Options area of the Hatch and
Gradient dialog box.

Normal hatching style (the default) hatches inward from the outer boundary.
If the hatching process encounters an internal boundary, hatching is turned
off until another boundary is encountered.

If you hatch using the Normal hatching style, islands remain unhatched and
islands within islands are hatched, as shown below.

Outer hatching style hatches inward from the outer boundary and stops at
the next boundary.
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Ignore hatching style hatches the entire enclosed area, ignoring internal
boundaries.

You can also remove any islands from the hatch area.

See also:

■ Modify Hatches and Solid-Filled Areas on page 1459

To remove islands from the hatch area

1 Click Home tab ➤ Draw panel ➤ Hatch. 

2 In the Hatch and Gradient dialog box, after adding one or more
boundaries, click Remove Boundaries.

3 Select the boundaries that you want to remove and press ENTER.

4 In the Hatch and Gradient dialog box, click OK to apply the hatch.
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Toolbar: Draw  
Command entry: HATCH

Quick Reference

Commands

BOUNDARY

Creates a region or a polyline from an enclosed area.

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.

HATCHEDIT

Modifies an existing hatch or fill.

System Variables

HPOBJWARNING

Sets the number of hatch boundary objects that can be selected before
displaying a warning message.

HPSEPARATE

Controls whether HATCH creates a single hatch object or separate hatch
objects when operating on several closed boundaries.

Utilities

No entries

Command Modifiers

No entries

Define Hatch Boundaries in Large Drawings
You can save time hatching a small area in a complex drawing by defining a
set of objects in the drawing to be used in determining the hatch boundary.
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By default, HATCH defines the boundary by analyzing all closed objects in
the drawing. Analysis of all objects fully or partially visible on the screen as
boundaries can be time consuming in a complex drawing. To hatch a small
area of a complex drawing, you can define a set of objects in the drawing
called a boundary set. HATCH does not analyze objects that are not included
in the boundary set.

For clarity, first zoom into the area you want to hatch.

The View Selections option in the Hatch and Gradient dialog box, highlights
the objects in the drawing that define the boundary.

To define a boundary set in a complex drawing

1 Click Home tab ➤ Draw panel ➤ Hatch. 

2 In the Hatch and Gradient dialog box, More Options, under Boundary
Set, click New.

3 At the Select Objects prompt, specify opposite corner points for the
boundary set and press ENTER.

If you use crossing selection by specifying points from right to left, you
select all objects enclosed or crossed.

4 In the Hatch and Gradient dialog box, click Add Boundary. If necessary,
enter k to specify the Pick Internal Point option.

5 Specify the internal point.

6 Click OK to apply the hatch.
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Toolbar: Draw  
Command entry: HATCH

Quick Reference

Commands

BOUNDARY

Creates a region or a polyline from an enclosed area.

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.

HATCHEDIT

Modifies an existing hatch or fill.

System Variables

HPOBJWARNING

Sets the number of hatch boundary objects that can be selected before
displaying a warning message.
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Utilities

No entries

Command Modifiers

No entries

Create Unbounded Hatches
There are several methods you can use to create a hatch that does not display
a hatch boundary.

■ You can create a hatch with HATCH, and then erase some or all of the
boundary objects.

■ You can create a hatch with HATCH, making sure that the boundary objects
are on a different layer than the hatch. Then turn off or freeze the layer
of the boundary objects. This is the only method that maintains hatch
associativity.

■ You can trim an existing hatch with objects created as trim boundaries.
After trimming the hatch, erase the objects.

■ You can define a hatch boundary with the Draw option of -HATCH at the
command prompt by specifying boundary points.

For example, you might want to show that a large area of a drawing is filled
with a pattern by filling only a small section of that area, as shown in the
following illustration.

You can choose whether to retain the polyline boundary after the hatch is
created; here, the polyline boundary is not retained.
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To define a boundary by specifying points

1 At the command prompt, enter -hatch.

2 Enter the desired pattern. For example, enter earth to select the EARTH
pattern.

3 Specify the scale and angle for the pattern.

4 Enter w to specify the Draw option.

5 Specify points to define the boundary. Enter c to close the polyline
boundary, and then press ENTER.

6 Enter n to discard the polyline boundary once the hatch area has been
defined, or enter y to create a polyline.

Command entry: -HATCH

Quick Reference

Commands

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.

HATCHEDIT

Modifies an existing hatch or fill.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Choose Hatch Patterns and Solid Fills
You can use a predefined hatch pattern or solid fill, or you can create your
own hatch patterns.

Create Solid-Filled Areas
There are several methods for creating solid-filled areas.

Solid-filled areas can be created using

■ Hatches with a solid hatch pattern (HATCH)

■ 2D solids (SOLID)

■ Wide polylines or donuts (PLINE, DONUT)

See also:

■ Overview of Hatch Patterns and Fills on page 1431

■ Modify Hatches and Solid-Filled Areas on page 1459

■ Draw Polylines on page 801
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■ Draw Donuts on page 831

To create a hatch with a solid pattern

1 Click Home tab ➤ Draw panel ➤ Hatch. 

2 In the Hatch and Gradient dialog box, click Add: Pick points.

3 Specify a point in your drawing inside each area that you want hatched.

This point is known as the internal point.

4 Press ENTER.

5 In the Hatch and Gradient dialog box, Hatch , under Type, click
Predefined.

6 Click the [...] button next to Pattern.

7 In the Hatch Pattern Palette dialog box, Other Predefined , select Solid.
Click OK.

8 To see how the hatch pattern will look, click Preview.

9 When you finish previewing the hatch pattern, right-click or press ENTER
to apply the hatch, or press any other button or key to return to the Hatch
and Gradient dialog box.

10 In the Hatch and Gradient dialog box, make adjustments, if necessary.
(You can specify new hatch boundaries by clicking Add Boundaries or
Remove Boundaries.)

11 Click OK.

Toolbar: Draw  
Command entry: HATCH

To create a 2D solid object

1 Click Draw menu ➤ Modeling ➤ Meshes ➤ 2D Solid.

2 Specify the first point.

3 Specify the second point, moving left to right.
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4 Continue to specify points. Press ENTER when the object is complete.

When you create a quadrilateral solid-filled area, the sequence of the
third and fourth points determines its shape. Compare the following
illustrations:

Notice that to create the quadrilateral area, both the top and bottom
edges are specified from left to right. If you specify the first point on the
right and the second point on the left, then the third and fourth points
should also be in a right-to-left direction. As you continue to specify pairs
of points, be sure to continue this zigzag sequence to ensure the results
you expect.

Command entry: SOLID

To create a wide polyline

1 Click Home tab ➤ Draw panel ➤ Polyline. 

2 Specify the start point of the line segment.

3 Enter w (Width).

4 Enter the starting width of the line segment.

5 Specify the ending width of the line segment using one of the following
methods:

■ To create a line segment of equal width, press ENTER.

■ To create a tapering line segment, enter a different width.

6 Specify the endpoint of the polyline segment.

7 Continue specifying segment endpoints as needed.

8 Press ENTER to end, or enter c to close the polyline.
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Toolbar: Draw  
Command entry: PLINE

To create a donut

1 Click Home tab  ➤  Draw panel  ➤  Donut.

2 Specify the inside diameter (1).

3 Specify the outside diameter (2).

4 Specify the center of the donut (3).

5 Specify the center point for another donut, or press ENTER to complete
the command.

Command entry: DONUT

Quick Reference

Commands

DONUT

Creates a filled circle or a wide ring.

FILL

Controls the filling of objects such as hatches, 2D solids, and wide polylines.

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.
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PLINE

Creates a 2D polyline.

SOLID

Creates solid-filled triangles and quadrilaterals.

System Variables

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.

Utilities

No entries

Command Modifiers

No entries

Create Gradient-Filled Areas
A gradient fill is a solid hatch fill that gives the blended-color effect of a surface
with light on it. You can use gradient fills to suggest a solid form in
two-dimensional drawings.

The color in a gradient fill makes a smooth transition from light to dark, or
from dark to light, and back. You select a predefined pattern (for example,
linear, spherical, or radial sweep) and specify an angle for the pattern. In a
two-color gradient fill, the transition is both from light to dark and from the
first color to the second.

Gradient fills are applied to objects in the same way solid fills are and can be
associated with their boundaries or not. An associated fill is automatically
updated when the boundary changes.

You cannot use plot styles to control the plotted color of gradient fills.

Double-click a gradient fill to modify it.

To create a one-color gradient fill

1 Click Home tab ➤ Draw panel ➤ Hatch. 
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2 In the Hatch and Gradient dialog box, click Add: Pick points or Add:
Select objects.

3 Specify an internal point or select an object, and then press ENTER.

4 In the Hatch and Gradient dialog box, Gradient , select One Color.

5 If you want to change the color, click the [...] button next to the color.

6 In the Select Color dialog box, use the Shade/Tint slider to adjust the
color.

■ Move the slider toward Tint to create a color transition that moves
toward white.

■ Move the slider toward Shade to create a transition that moves toward
black.

7 Click a pattern, and set the following options:

■ Select Center to create a symmetrical fill, or clear Center to move the
“highlight” up and to the left.

■ Specify an angle for the “highlighted” area.

8 To see how the gradient fill will look, click Preview. Press ENTER or
right-click to return to the dialog box and make adjustments.

9 When you are satisfied, in the Hatch and Gradient dialog box, click OK
to create the gradient fill.

Toolbar: Draw  
Command entry: HATCH

To create a two-color gradient fill

1 Click Home tab ➤ Draw panel ➤ Hatch. 

2 In the Hatch and Gradient dialog box, click Add: Pick points or Add:
Select objects.

3 Specify an internal point or select an object, and then press ENTER.

4 In the Hatch and Gradient dialog box, Gradient , select Two Color.

The second color is the color of the highlighted area in the gradient fill.
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5 If you want to change either color, click the [...] button next to the color
to open the Select Color dialog box.

6 Click a pattern, and set the following options:

■ Select Center to create a symmetrical fill, or clear Center to move the
“highlight” up and to the left.

■ Specify an angle for the “highlighted” area.

7 To see how the gradient fill will look, click Preview. Press ENTER or
right-click to return to the dialog box and make adjustments.

8 When you are satisfied, in the Hatch and Gradient dialog box, click OK
to create the gradient fill.

Toolbar: Draw  
Command entry: HATCH

To modify a gradient fill

■ Double-click a gradient fill to modify it.

Quick Reference

Commands

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Use Predefined Hatch Patterns
You can choose from more than 50 industry-standard hatch patterns.
Additional hatch patterns are available from external pattern libraries.

The program supplies a solid fill and more than 50 industry-standard hatch
patterns, which can represent materials such as earth, brick, or clay.

Fourteen hatch patterns conform to International Standards Organization
(ISO) standards. When you select an ISO pattern, you can specify a pen width,
which determines the lineweight in the pattern.

In addition to using the patterns supplied with the program, you can use
patterns from an external pattern library. These patterns are listed by name
and are displayed in the Hatch Pattern Palette dialog box.

To use a predefined hatch pattern

1 Click Home tab ➤ Draw panel ➤ Hatch. 

2 In the Hatch and Gradient dialog box, click Add: Pick points or Add:
Select objects.

3 Specify an internal point or select an object.

4 In the Hatch and Gradient dialog box, Hatch , select Predefined in the
Type box.

5 From the Pattern box, select a pattern.

6 Click OK.
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Toolbar: Draw  
Command entry: HATCH

Quick Reference

Commands

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.

System Variables

HPANG

Specifies the hatch pattern angle.

HPBOUND

Controls the object type created by the BHATCH and BOUNDARY commands.

HPDOUBLE

Specifies hatch pattern doubling for user-defined patterns.

HPNAME

Sets a default hatch pattern name of up to 34 characters without spaces.

HPSCALE

Specifies the hatch pattern scale factor, which must be greater than zero.

Utilities

No entries

Command Modifiers

No entries

Create User-Defined Hatch Patterns
You can define a simple hatch pattern based on the current linetype.
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In addition to using predefined hatch patterns, you can define a simple hatch
pattern based on the current linetype. You define the pattern by changing
the angle and spacing of the hatch lines.

To create a user-defined hatch pattern

1 Specify the linetype for the user-defined hatch pattern by making that
linetype current.

2 Click Home tab ➤ Draw panel ➤ Hatch. 

3 In the Hatch and Gradient dialog box, click Add: Pick points or Add:
Select objects.

4 Specify an internal point or select an object.

5 In the Hatch and Gradient dialog box, Hatch , select User-Defined in the
Type box.

6 Specify the angle and spacing of the hatch pattern.

7 To use intersecting lines in the pattern, select Double.

8 Click OK.

Toolbar: Draw  
Command entry: HATCH

Quick Reference

Commands

HATCH

Fills an enclosed area or selected objects with a hatch pattern, solid fill, or
gradient fill.

System Variables

HPANG

Specifies the hatch pattern angle.
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HPBOUND

Controls the object type created by the BHATCH and BOUNDARY commands.

HPDOUBLE

Specifies hatch pattern doubling for user-defined patterns.

HPNAME

Sets a default hatch pattern name of up to 34 characters without spaces.

HPSCALE

Specifies the hatch pattern scale factor, which must be greater than zero.

HPSPACE

Specifies the hatch pattern line spacing for user-defined simple patterns,
which must be greater than zero.

Utilities

No entries

Command Modifiers

No entries

Modify Hatches and Solid-Filled Areas
You can modify both the pattern fill and the boundaries of hatches.

You can also modify solid-filled areas, but the method you use depends on
whether the solid-filled area is a solid-filled hatch, a 2D solid, or a wide polyline
or donut. You can also modify the draw order of your hatch.

Control Hatch Pattern Density

Hatching can produce a very large number of line and point objects. Although
stored as hatch objects, these line and point objects do use disk space and take
time to generate. If you use a relatively small scale factor when hatching an
area, the hatch could require millions of line and point objects, thus taking
a very long time to complete and possibly exhausting the available resources.
You can avoid this problem by imposing a limit on the number of objects
created by a single HATCH command. If the approximate number of objects
needed for a particular hatch (considering the boundary extents, pattern, and
scale) exceeds the limit, HATCH displays a message indicating that the hatch
scale is too small or that its dash length is too short, and the hatch request is
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rejected. If this occurs, carefully examine your hatch settings. The scale factor
may be unreasonable and may need to be adjusted.

The hatch object limit is set by the MaxHatch environment setting, which is
stored in the system registry. Its default value is 10000. You can change this
limit by setting the MaxHatch system registry variable using (setenv
“MaxHatch” “n”) where n is a number between 100 and 10000000 (ten
million).

NOTE MaxHatch must be entered with the letters M and H capitalized and the
rest of the letters in lowercase.

Change the Hatch Properties of an Existing Hatch

You can modify hatch-specific properties, such as pattern, scale, and angle,
of an existing hatch. You can use the following:

■ Hatch Edit dialog box (recommended)

■ Properties palette

You can also copy properties from one hatch to another. With the Inherit
Properties button in the Hatch Edit dialog box, you can copy all hatch-specific
properties, including the hatch origin, from one hatch to another. Use the
Match Properties dialog box to copy general properties and hatch-specific
properties (with the exception of the hatch origin), from one hatch to another.

You can use EXPLODE to disassemble a hatch into its component objects.

Modify a Hatch Boundary

If the editing you do maintains a closed boundary, an associative hatch is
updated automatically. If the editing produces an open boundary, the hatch
loses any associativity with the boundary and remains unchanged. Associativity
may also be lost during editing of a hatch boundary if the hatch pattern file
is not available at the time of editing. If you trim a hatch and the hatch pattern
(PAT) file is no longer available, the hatch will disappear.

Hatch associativity depends on whether you choose Associative in the Hatch
and Gradient (HATCH) and Hatch Edit (HATCHEDIT) dialog boxes.
Nonassociative hatches are not updated when their original boundary is
changed.

You can remove hatch associativity at any time, but once it is removed for an
existing hatch, it cannot be reestablished. The hatch must be recreated to
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restore associativity or a new hatch boundary must be created and associated
with the hatch.

To create a boundary around a nonassociative or unbounded hatch, in the
Hatch and Gradient dialog box, use the Recreate Boundary option. With this
option you can also specify that the new boundary is associated with the
hatch.

The Select Boundary Objects option in the Hatch Edit dialog box displays
grips for a selected hatch. When you manually select or use the Select Boundary
Objects option to select a nonassociative hatch, the hatch is selected and the
grips display on the boundary of the hatch. You can use these grips to change
the extents of nonassociative hatches.

Nonassociative hatch grips

When you manually select an associative hatch, it displays only a single grip
point of the hatch. With the Select Boundary Objects option, you can select
an associative hatch and display the boundary grip controls of the objects
associated with it. You can extend by editing the grip controls of the associated
objects.
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Associative hatch grips

NOTE If a hatch is associated with XREF or BLOCK, only a single grip point is
displayed. To edit the associated geometry, use REFEDIT or XOPEN.

The grip control tooltip displays more edit options available based on the grip
type. You can cycle through these options by pressing the CTRL key. For
example, an edge grip for a polyline segment has an option to convert the
segment to an arc while an edge grip for a polyline arc segment has an option
to convert to line.

Modify Solid-Filled Areas

Solid-filled areas can be represented by

■ Hatches (with a solid hatch pattern)

■ 2D solids

■ Gradient fills

■ Wide polylines or donuts

You modify each of these solid-filled objects just as you would any other
hatch, 2D solid, wide polyline, or donut. In addition to PROPERTIES, you can
use HATCHEDIT for solid-filled hatches and gradient fills, grip editing for 2D
solids, and PEDIT for wide polylines and donuts.
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Modify the Draw Order of a Hatch

When you edit a hatch, you can change its draw order, so that it is displayed
behind the hatch boundary, in front of the hatch boundary, behind all other
objects, or in front of all other objects.

To change the angle of a hatch

1 Select the hatch pattern.

2 Right-click the hatch. Click Properties.

3 In the Properties palette, enter the new value for Angle.

Toolbar: Standard  
Command entry: PROPERTIES

To set the limit of objects in a hatch pattern

 ➤ At the command prompt, enter (setenv “MaxHatch” “n”)

where n is a number between 100 and 10000000 (ten million). The higher
the value, the more dense the hatch pattern.

NOTE MaxHatch is case-sensitive.

To modify a gradient fill

1 Double-click the gradient fill you want to modify.

2 In the Hatch Edit dialog box, Gradient , make any changes.

3 To see how the gradient fill will look, click Preview. Press ENTER or
right-click to return to the dialog box and make adjustments.

4 When you are satisfied, in the Hatch and Gradient dialog box, click OK
to create the gradient fill.
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Quick Reference

Commands

EXPLODE

Breaks a compound object into its component objects.

FILL

Controls the filling of objects such as hatches, 2D solids, and wide polylines.

HATCHEDIT

Modifies an existing hatch or fill.

MATCHPROP

Applies the properties of a selected object to other objects.

PEDIT

Edits polylines and 3D polygon meshes.

PROPERTIES

Controls properties of existing objects.

System Variables

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled
in.

HPANG

Specifies the hatch pattern angle.

HPASSOC

Controls whether hatch patterns and gradient fills are associative.

HPDOUBLE

Specifies hatch pattern doubling for user-defined patterns.

HPINHERIT

Controls the hatch origin of the resulting hatch when using Inherit Properties
in HATCH and HATCHEDIT.
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HPNAME

Sets a default hatch pattern name of up to 34 characters without spaces.

HPORIGIN

Sets the hatch origin point for new hatch objects relative to the current user
coordinate system.

HPORIGINMODE

Controls how HATCH determines the default hatch origin point.

HPSCALE

Specifies the hatch pattern scale factor, which must be greater than zero.

HPSPACE

Specifies the hatch pattern line spacing for user-defined simple patterns,
which must be greater than zero.

Utilities

No entries

Command Modifiers

No entries

Create a Blank Area to Cover Objects
Wipeout objects cover existing objects with a blank area to make room for
notes or to mask details.

A wipeout object is a polygonal area that masks underlying objects with the
current background color. This area is bounded by the wipeout frame, which
you can turn on for editing and turn off for plotting.

You can create a wipeout object by specifying a polygonal area with a series
of points, or you can convert a closed polyline into a wipeout object.
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You can move or delete a wipeout object by first turning on wipeout frames
so you can select it.

Requirements and Limitations

If a polyline is used to create a wipeout object, the polyline must be closed,
contain line segments only, and have zero width.

You can create wipeout objects on a layout in paper space to mask objects in
model space; however, in the Page Settings dialog box, under Plot Options,
the Plot Paper Space Last option must be cleared before you plot to ensure
that the wipeout object is plotted correctly.

Because a wipeout object is similar to a raster image, it has the same
requirements for plotting: you need a raster-capable plotter with either an
ADI 4.3 raster-capable driver or the system printer driver.

See also:

■ Control How Overlapping Objects Are Displayed on page 627

To cover existing objects with a blank area

1 Click Annotate tab ➤ Markup panel ➤ Wipeout. 

2 Specify points in a sequence that defines the perimeter of the area to be
masked.

3 Press ENTER to end.

Command entry: WIPEOUT

To turn all wipeout frames on or off

1 Click Annotate tab ➤ Markup panel ➤ Wipeout. 

2 At the command prompt, enter f (Frames).

3 Enter on or off and press ENTER.

Command entry: WIPEOUT
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Quick Reference

Commands

WIPEOUT

Creates a wipeout object.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries
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Notes and Labels

You can create and modify several types of text, including text with leaders. You can control
most text style settings by defining text styles.

Overview of Notes and Labels
You can create text in various ways. For short, simple entries, use single-line
text. For longer entries with internal formatting, use multiline text (mtext).

Although all entered text uses the current text style, which establishes the default
font and format settings, you can use several methods to customize the text
appearance. There are several tools that can change text scale and justification,
find and replace text, and check for spelling errors.

Text that is included in a dimension or tolerance is created using the
dimensioning commands. You can also create multiline text with leaders.

To create single-line text

1 Click Home tab ➤ Annotation panel ➤ Single Line Text. 

2 Specify the insertion point for the first character. If you press ENTER, the
program locates the new text immediately below the last text object you
created, if any.

3 Specify the height of the text. This prompt is displayed only if text height
is set to 0 in the current text style.

A rubber-band line is attached from the text insertion point to the cursor.
Click to set the height of the text to the length of the rubber-band line.

4 Specify a text rotation angle.

25

1469



You can enter an angle value or use your pointing device.

5 Enter the text. At the end of each line, press ENTER. Enter more text as
needed.

NOTE Text that would otherwise be difficult to read (if it is very small, very
large, or is rotated) is displayed at a legible size and is oriented horizontally
so that you can easily read and edit it.

If you specify another point during this command, the cursor moves to
that point, and you can continue typing. Every time you press ENTER or
specify a point, a new text object is created.

6 Press ENTER on a blank line to end the command.

Command entry: TEXT

To create multiline text

1 Click Home tab ➤ Annotation panel ➤ Multiline Text.

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

If the ribbon is active, the MTEXT ribbon contextual tab displays. If the
ribbon is not active, the In-Place Text Editor is displayed.

3 To indent the first line of each paragraph, drag the first-line indent slider
on the ruler. To indent the other lines of each paragraph, drag the
paragraph slider.

4 To set tabs, click the ruler where you want a tab stop.

5 If you want to use a text style other than the default, on the ribbon, click
the Annotate tab, Text panel. Select the desired text style from the
drop-down list.

6 Enter text.

NOTE Text that would otherwise be difficult to read (if it is very small, very
large, or is rotated) is displayed at a legible size and is oriented horizontally
so that you can easily read and edit it.
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7 To override the current text style, select text as follows:

■ To select one or more letters, click and drag the pointing device over
the characters.

■ To select a word, double-click the word.

■ To select a paragraph, triple-click the paragraph.

8 On the ribbon, make format changes as follows:

■ To change the font of the selected text, select a font from the list.

■ To change the height of the selected text, enter a new value in the
Height box.

NOTE The MText height value is reset to 0 if its default height is not
modified during creation.

■ To format text in a TrueType font with boldface or italics, or to create
underlined or overlined text for any font, click the corresponding
button on the ribbon. SHX fonts do not support boldface or italics.

■ To apply color to selected text, choose a color from the Color list.
Click Other to display the Select Color dialog box.

9 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT
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Quick Reference

Commands

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

MLEADER

Creates a multileader object.

MTEXT

Creates a multiline text object.

SPELL

Checks spelling in a drawing.

STYLE

Creates, modifies, or specifies text styles.

TEXT

Creates a single-line text object.

System Variables

DIMASZ

Controls the size of dimension line and leader line arrowheads.

DIMLDRBLK

Specifies the arrow type for leaders.

Utilities

No entries

Command Modifiers

No entries

Create Text
You can create text using several methods, depending on your needs.
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Overview of Creating Text
The text you add to your drawings conveys a variety of information. It may
be a complex specification, title block information, a label, or even part of
the drawing.

Single-Line Text

For short entries that do not require multiple fonts or lines, create single-line
text. Single-line text is most convenient for labels.

Multiline Text

For long, complex entries, create multiline, or paragraph text. Multiline text
consists of any number of text lines or paragraphs that fit within a width you
specify; it can extend vertically to an indefinite length.

Regardless of the number of lines, each set of paragraphs created in a single
editing session forms a single object, which you can move, rotate, erase, copy,
mirror, or scale.

There are more editing options for multiline text than there are for single-line
text. For example, you can apply underlining, fonts, color, and text height
changes to individual characters, words, or phrases within a paragraph.

Annotative Text

Use text for notes and labels in your drawing. You create annotative text by
using an annotative text style, which sets the height of the text on the paper.

For more information about creating and working with an annotative text,
see Create Annotative Text on page 1404.

See also:

■ Scale Annotations on page 1393

To create single-line text

1 Click Home tab ➤ Annotation panel ➤ Single Line Text. 

2 Specify the insertion point for the first character. If you press ENTER, the
program locates the new text immediately below the last text object you
created, if any.
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3 Specify the height of the text. This prompt is displayed only if text height
is set to 0 in the current text style.

A rubber-band line is attached from the text insertion point to the cursor.
Click to set the height of the text to the length of the rubber-band line.

4 Specify a text rotation angle.

You can enter an angle value or use your pointing device.

5 Enter the text. At the end of each line, press ENTER. Enter more text as
needed.

NOTE Text that would otherwise be difficult to read (if it is very small, very
large, or is rotated) is displayed at a legible size and is oriented horizontally
so that you can easily read and edit it.

If you specify another point during this command, the cursor moves to
that point, and you can continue typing. Every time you press ENTER or
specify a point, a new text object is created.

6 Press ENTER on a blank line to end the command.

Command entry: TEXT

To create multiline text

1 Click Home tab ➤ Annotation panel ➤ Multiline Text. 

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

If the ribbon is active, the MTEXT ribbon contextual tab displays. If the
ribbon is not active, the In-Place Text Editor is displayed.

3 To indent the first line of each paragraph, drag the first-line indent slider
on the ruler. To indent the other lines of each paragraph, drag the
paragraph slider.

4 To set tabs, click the ruler where you want a tab stop.

5 If you want to use a text style other than the default, on the ribbon, click
the Annotate tab, Text panel. Select the desired text style from the
drop-down list.

6 Enter text.
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NOTE Text that would otherwise be difficult to read (if it is very small, very
large, or is rotated) is displayed at a legible size and is oriented horizontally
so that you can easily read and edit it.

7 To override the current text style, select text as follows:

■ To select one or more letters, click and drag the pointing device over
the characters.

■ To select a word, double-click the word.

■ To select a paragraph, triple-click the paragraph.

8 On the ribbon, make format changes as follows:

■ To change the font of the selected text, select a font from the list.

■ To change the height of the selected text, enter a new value in the
Height box.

NOTE The MText height value is reset to 0 if its default height is not
modified during creation.

■ To format text in a TrueType font with boldface or italics, or to create
underlined or overlined text for any font, click the corresponding
button on the ribbon. SHX fonts do not support boldface or italics.

■ To apply color to selected text, choose a color from the Color list.
Click Other to display the Select Color dialog box.

9 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT
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Quick Reference

Commands

MLEADER

Creates a multileader object.

MTEXT

Creates a multiline text object.

QLEADER

Creates a leader and leader annotation.

TEXT

Creates a single-line text object.

System Variables

DIMASSOC

Controls the associativity of dimension objects and whether dimensions are
exploded.

DIMASZ

Controls the size of dimension line and leader line arrowheads.

DIMLDRBLK

Specifies the arrow type for leaders.

Utilities

No entries

Command Modifiers

No entries

Create Single-Line Text
You can use single-line text to create one or more lines of text, where each
text line is an independent object that you can relocate, reformat, or otherwise
modify.
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Use single-line text (TEXT) to create one or more lines of text, ending each
line when you press ENTER. Each text line is an independent object that you
can relocate, reformat, or otherwise modify.

When you create single-line text, you assign a text style and set alignment.
The text style sets the default characteristics of the text object. The alignment
determines what part of the text character aligns with the insertion point. Use
the TEXT command to enter the text in-place, or enter -text at the Command
prompt to enter the text at the Command prompt.

You can insert a field in single-line text. A field is text that is set up to display
data that might change. When the field is updated, the latest value of the field
is displayed.

The text styles used for single-line text are the same as those used for multiline
text. When you create text, you assign an existing style by entering its name
at the Style prompt. If you need to apply formatting to individual words and
characters, use multiline text instead of single-line text.

You can also compress single-line text to fit between points that you specify.
This option stretches or squeezes the text to fill the designated space.

The DTEXTED system variable specifies the user interface displayed for editing
single-line text.

Align Single-Line Text

As you create text, you can align it. That is, you can justify it with one of the
alignment options shown in the following illustrations. Left alignment is the
default. To left-align text, do not enter an option at the Justify prompt.
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See also:

■ Use Fields in Text on page 1532

To create single-line text

1 Click Home tab ➤ Annotation panel ➤ Single Line Text. 

2 Specify the insertion point for the first character. If you press ENTER, the
program locates the new text immediately below the last text object you
created, if any.

3 Specify the height of the text. This prompt is displayed only if text height
is set to 0 in the current text style.

A rubber-band line is attached from the text insertion point to the cursor.
Click to set the height of the text to the length of the rubber-band line.

4 Specify a text rotation angle.

You can enter an angle value or use your pointing device.

5 Enter the text. At the end of each line, press ENTER. Enter more text as
needed.

NOTE Text that would otherwise be difficult to read (if it is very small, very
large, or is rotated) is displayed at a legible size and is oriented horizontally
so that you can easily read and edit it.
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If you specify another point during this command, the cursor moves to
that point, and you can continue typing. Every time you press ENTER or
specify a point, a new text object is created.

6 Press ENTER on a blank line to end the command.

Command entry: TEXT

To specify a text style when you create single-line text

1 Click Home tab ➤ Annotation panel ➤ Single Line Text. 

2 Enter s (Style).

3 At the Style Name prompt, enter an existing text style name.

If you first want to see a list of text styles, enter ? and press ENTER twice.

4 Continue creating text.

Command entry: TEXT

To align single-line text as you create it

1 Click Home tab ➤ Annotation panel ➤ Single Line Text. 

2 Enter j (Justify).

3 Enter an alignment option. For example, enter br to align text at its
bottom-right corner.

4 Continue creating text.

Command entry: TEXT

Quick Reference

Commands

QTEXT

Controls the display and plotting of text and attribute objects.

Create Single-Line Text | 1479



STYLE

Creates, modifies, or specifies text styles.

TEXT

Creates a single-line text object.

System Variables

DTEXTED

Specifies the user interface displayed for editing single-line text.

FONTALT

Specifies the alternate font to be used when the specified font file cannot be
located.

FONTMAP

Specifies the font mapping file to be used.

MIRRTEXT

Controls how the MIRROR command reflects text.

QTEXTMODE

Controls how text is displayed.

TEXTEVAL

Controls how text strings entered with TEXT (using AutoLISP) or with -TEXT
are evaluated.

TEXTFILL

Controls the filling of TrueType fonts while plotting and rendering.

TEXTQLTY

Sets the resolution tessellation fineness of text outlines.

TEXTSIZE

Sets the default height for new text objects drawn with the current text style.

TEXTSTYLE

Sets the name of the current text style.
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Utilities

No entries

Command Modifiers

No entries

Create Multiline Text
A multiline text (mtext) object includes one or more paragraphs of text that
can be manipulated as a single object.

Overview of Multiline Text
You can create a multiline text (mtext) object by entering or importing text.

You can create one or more paragraphs of multiline text (mtext) in the MTEXT
ribbon contextual tab (if the ribbon is active), or the In-Place Text Editor (or
an alternative text editor, if the ribbon is not active) You can also use
Command prompts. You can insert text from a file saved in ASCII or RTF
format.

Before entering or importing text, you specify opposite corners of a text
bounding box that defines the width of the paragraphs in the multiline text
object. The length of the multiline text object depends on the amount of text,
not the length of the bounding box. You can use grips to move or rotate a
multiline text object.

NOTE Multiline text objects and imported text files are limited to 256 KB in size.

The MTEXT ribbon contextual tab and In-Place Text Editor display the
bounding box with a ruler at the top. If the ribbon is not active, the Text
Formatting toolbar is also displayed. The editor is transparent so that, as you
create text, you can see whether the text overlaps other objects. To turn off
transparency while you work, select Opaque Background on the Options
menu. You can also make the background of the finished multiline text object
opaque and set its color.

You can also insert fields in multiline text. A field is text that is set up to
display data that might change. When the field is updated, the latest value of
the field is displayed.
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Text Style

Most characteristics of the text are controlled by the text style, which sets the
default font and other options, such as line spacing, justification, and color.
You can use the current text style or select a new one. The STANDARD text
style is the default.

Within the multiline text object, you can override the current text style by
applying formatting such as underlining, boldface, and different fonts to
individual characters. You can also create stacked text, such as fractions or
geometric tolerances and insert special characters, including Unicode
characters, for TrueType fonts.

NOTE Not all SHX and TrueType text fonts support Unicode characters.

Text Properties

In the Properties palette, you can view and change the object properties of a
multiline text object, including properties that apply specifically to text.

■ Justification determines where text is inserted with respect to the bounding
box and sets the direction of text flow as text is entered.

■ Line space options control the amount of space between lines of text.

■ Width defines the width of the bounding box and therefore controls where
the text wraps to a new line.

■ Background inserts an opaque background so that objects under the text
are masked.

To create multiline text

1 Click Home tab ➤ Annotation panel ➤ Multiline Text. 

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

If the ribbon is active, the MTEXT ribbon contextual tab displays. If the
ribbon is not active, the In-Place Text Editor is displayed.

3 To indent the first line of each paragraph, drag the first-line indent slider
on the ruler. To indent the other lines of each paragraph, drag the
paragraph slider.

4 To set tabs, click the ruler where you want a tab stop.
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5 If you want to use a text style other than the default, on the ribbon, click
the Annotate tab, Text panel. Select the desired text style from the
drop-down list.

6 Enter text.

NOTE Text that would otherwise be difficult to read (if it is very small, very
large, or is rotated) is displayed at a legible size and is oriented horizontally
so that you can easily read and edit it.

7 To override the current text style, select text as follows:

■ To select one or more letters, click and drag the pointing device over
the characters.

■ To select a word, double-click the word.

■ To select a paragraph, triple-click the paragraph.

8 On the ribbon, make format changes as follows:

■ To change the font of the selected text, select a font from the list.

■ To change the height of the selected text, enter a new value in the
Height box.

NOTE The MText height value is reset to 0 if its default height is not
modified during creation.

■ To format text in a TrueType font with boldface or italics, or to create
underlined or overlined text for any font, click the corresponding
button on the ribbon. SHX fonts do not support boldface or italics.

■ To apply color to selected text, choose a color from the Color list.
Click Other to display the Select Color dialog box.

9 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.
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Toolbar: Draw  
Command entry: MTEXT

To insert symbols or special characters in multiline text

1 If the ribbon is active, double-click a multiline text object to open the
MTEXT ribbon contextual tab. If the ribbon is not active, the In-Place
Text Editor is displayed.

2 On either the ribbon contextual tab or expanded toolbar, click Symbol.

3 Click one of the options on the menu, or click Other to display the
Character Map dialog box.

To access the Character Map dialog box, you must have charmap.exe
installed. See Microsoft® Windows® Help for information about adding
programs to your system.

4 In the Character Map dialog box, select a font.

5 Select a character, and use one of the following methods:

■ To insert a single character, drag the selected character into the editor.

■ To insert multiple characters, click Select to add each character to the
Characters to Copy box. When you have all the characters you want,
click Copy. Right-click in the editor. Click Paste.

6 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT
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To add an opaque background or fill to a multiline text object

1 If the ribbon is active, double-click a multiline text object to open the
MTEXT ribbon contextual tab. If the ribbon is not active, the In-Place
Text Editor is displayed.

2 On the ribbon contextual tab, click Background Mask. In the editor,
right-click. Click Background Mask.

3 In the Background Mask dialog box, select Use Background Mask.

4 Enter a value for Border Offset Factor.

The value is based on the text height. A factor of 1.0 exactly fits the
multiline text object. A factor of 1.5 (the default) extends the background
by 0.5 times the text height.

5 Under Fill Color, do one of the following:

■ Select the Use Drawing Background Color option.

■ Select a color for the background, or click Select Color to open the
Select Color dialog box.

6 Click OK to return to the editor.

7 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

The opaque background is applied when you exit the editor.

Toolbar: Draw  
Command entry: MTEXT

To change the Windows font smoothing setting to improve visibility of text
in the Multiline Text editor

1 On the Windows desktop, right-click. Click Properties.

2 In the Display Properties dialog box, click the Appearance tab.
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3 Click Effects.

4 In the Effects dialog box, click the Use the Following Method to Smooth
Edges of Screen Fonts to clear the setting.

5 Click OK to exit the Effects dialog box.

6 Click OK to exit the Display Properties dialog box.

Quick Reference

Commands

MTEXT

Creates a multiline text object.

QTEXT

Controls the display and plotting of text and attribute objects.

STYLE

Creates, modifies, or specifies text styles.

System Variables

MTEXTCOLUMN

Sets the default column setting for an mtext object.

MTEXTED

Sets the application for editing multiline text objects.

MTEXTFIXED

Sets the display size and orientation of multiline text in a specified text editor.

MTEXTTOOLBAR

Controls the display of the Text Formatting toolbar.

MTJIGSTRING

Sets the content of the sample text displayed at the cursor location when
the MTEXT command is started.

QTEXTMODE

Controls how text is displayed.
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TEXTFILL

Controls the filling of TrueType fonts while plotting and rendering.

TEXTQLTY

Sets the resolution tessellation fineness of text outlines.

TEXTSIZE

Sets the default height for new text objects drawn with the current text style.

TEXTSTYLE

Sets the name of the current text style.

Utilities

No entries

Command Modifiers

No entries

Justify Multiline Text
Justification of multiline text objects controls both text alignment and text
flow relative to the text insertion point.

Justification controls both text alignment and text flow relative to the text
insertion point. Text is left-justified and right-justified with respect to the
boundary rectangle that defines the text width. Text flows from the insertion
point, which can be at the middle, the top, or the bottom of the resulting text
object.

There are nine justification settings for multiline text.

If a single word is longer than the width of the paragraph, the word will extend
beyond the paragraph boundary.
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To justify multiline text

1 Click View tab  ➤  Palettes panel  ➤  Properties.

2 Select the multiline text object.

3 On the Properties palette, select one of the Justification options.

4 Click outside the Properties palette.

Command entry: PROPERTIES

Quick Reference

Commands

PROPERTIES

Controls properties of existing objects.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Format Characters Within Multiline Text
You can override the text style and apply different formatting to individual
words and characters within multiline text.

The format changes affect only the text you select; the current text style is
not changed.

You can specify a different font and text height and apply boldface, italics,
underlining, overlining, and color. You can also set an obliquing angle, change
the space between characters, and make characters wider or narrower. The
Remove Formatting option on the menu of options resets the character
attributes of selected text to the current text style and also resets the text color
to the color of the mtext object.

The text height setting specifies the height of capitalized text. For more
information about how height is calculated, see MTEXT.

See also:

■ Use an Alternate Text Editor on page 1576

To format characters in multiline text

1 If the ribbon is active, double-click a multiline text object to open the
MTEXT ribbon contextual tab. If the ribbon is not active, the In-Place
Text Editor is displayed.

2 Select the text you want to format:

■ To select one or more letters, click and drag the pointing device over
the characters.

■ To select a word, double-click the word.

Create Multiline Text | 1489



■ To select a paragraph, triple-click the paragraph.

3 On either the ribbon contextual tab or toolbar, make format changes as
follows:

■ To change the font of the selected text, select a font from the list.

■ To change the height of the selected text, enter a new value in the
Height box.

■ To format text in a TrueType font with boldface or italics, or to create
underlined or overlined text for any font, click the corresponding
button on the ribbon. SHX fonts do not support boldface or italics.

■ To apply color to selected text, select a color from the Color list. Click
Other to display the Select Color dialog box.

■ To set an obliquing angle for the text, enter a value between -85 and
85. A positive value slants text to the right. A negative value slants
text to the left.

■ To change letter spacing in the selected text, enter a new value.

■ To change the width of characters in the selected text, enter a new
value.

4 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT
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Quick Reference

Commands

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

MTEXT

Creates a multiline text object.

PROPERTIES

Controls properties of existing objects.

STYLE

Creates, modifies, or specifies text styles.

System Variables

TEXTFILL

Controls the filling of TrueType fonts while plotting and rendering.

TEXTSTYLE

Sets the name of the current text style.

Utilities

No entries

Command Modifiers

No entries

Create Lists in Multiline Text
You can create bulleted lists, lettered or numbered lists, or simple outlines in
multiline text.

Lines of multiline text can be formatted as a list. When you add or delete an
item, or move an item up or down a level, the list numbering automatically
adjusts. You can remove and reapply list formatting with the same method
as used in most text editors.
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Use Automatic List Formatting

By default, list formatting is applied to all text that looks like a list. Text that
meets all the following criteria is considered to be a list:

■ The line begins with one or more letters or numbers or a symbol.

■ The letters or numbers is followed by punctuation.

■ A space after the punctuation is created by pressing TAB.

■ The text following the space is ended by ENTER or SHIFT+ENTER.

NOTE If you do not want list formatting applied to all text that fits the criteria,
clear the Allow Bullets and Lists option. (Right-click in the In-Place Text Editor,
click Bullets and Lists, and clear Allow Bullets and Lists.) When Allow Bullets and
Lists is not checked, you cannot create new formatted lists in the multiline text
object.

To create a list, use one of the following methods:

■ Apply list formatting to new or selected text.

■ Use Auto-list (on by default) and type the elements of a list.

■ With Auto-list off, type the elements of a list and close and reopen the
editor to convert the text to a list.

Apply List Formatting

When you apply list formatting, you can specify bullets, uppercase or lowercase
letters, or numbers. Default settings are used for the type of list you choose.
Letters or numbers are followed by a period. Nested lists use a double bullet,
letter, or number. Items are indented based on the tab stops on the ruler in
the In-Place Text Editor.

Use Auto-list to Type a List

When Auto-list is on, you can create a list as you type. You can use letters,
numbers, or symbols.

For example, in the editor, enter \U+25CB, press TAB, and then enter some
text. This creates a empty circle style bullet.

Not all symbols are available from the character map for a particular text font.
However, if you specify the Unicode text directly (\U+25CB in this case), you
can always get the bullet format of your choice.
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NOTE Press TAB after you enter the Unicode text or symbol, or it will remain a
separate character.

You can also paste a symbol from the Character Map dialog box

The following characters can be used as punctuation after the number or letter
when you type a list but cannot be used as bullets:

DescriptionCharac-
ter

Period.

Colon:

Close parenthesis)

Close angle bracket>

Close square bracket]

Close curly bracket}

Paste a List from Another Document

If you copy a nested bulleted list (a list within a list) from Microsoft Word and
paste the list into multiline text, the bullets that are displayed as empty circles
cannot be formatted like other bullets in multiline text. This is because Word
uses the letter o instead of a bullet for nested bulleted lists. You can remove
formatting from the nested list and reapply to change the bullets to double
bullets.

To format multiline text as a list

1 Click Home tab ➤ Annotation panel ➤ Multiline Text. 

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

3 To expand the Text Formatting toolbar, click Options button  ➤  Show
Options.

4 If you are converting multiline text to a list, select the paragraphs.
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NOTE List formatting is only available when the Allow Bullets and Lists option
is checked (the default).

5 On the expanded toolbar, click Numbering, Bullets, or Uppercase Letters.

■ Numbering. Uses numbers with periods for the items in a list.

■ Bullets. Uses a bullet or other character for the items in a list.

■ Uppercase Letters. Uses uppercase letters with periods for the items
in a list. If the list has more items than the alphabet has letters, the
sequence continues by using double letters. To use lowercase letters,
right-click in the editor. Click Bullets and Lists  ➤  Lettered  ➤ 

Lowercase.

6 If you are creating new list items, enter the text.

7 To end the list, press ENTER to move to a new line. Click the button that
you clicked to start the list.

8 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT

To remove list formatting from multiline text

1 If the ribbon is active, double-click a multiline text object to open the
MTEXT ribbon contextual tab. If the ribbon is not active, the In-Place
Text Editor is displayed.

2 Select the list items.

3 To expand the Text Formatting toolbar, click Options button  ➤  Show
Options.
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4 On the expanded toolbar, click the active list button to make it inactive:
Numbering, Bullets, or Uppercase Letters.

NOTE If the list uses lowercase letters, click Uppercase Letters to convert the
list to uppercase. Then click Uppercase Letters to make it inactive.

5 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT

To create a lettered or numbered list in multiline text as you type

1 Click Home tab ➤ Annotation panel ➤ Multiline Text. 

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

3 To expand the Text Formatting toolbar, click Options button  ➤  Show
Options.

4 Click Bullets and Lists. Verify that Allow Auto-list and Allow Bullets and
Lists are checked.

5 Enter a letter or a number and a period (or other punctuation).

The following characters can be used as punctuation after letters and
numbers: period (.), colon (:), close parenthesis ()), close angle bracket
(>), close square bracket (]), and close curly bracket (}).

6 Press TAB.

7 Enter the text of the list item. Press ENTER to move to the next item, or
press SHIFT+ENTER to add a plain paragraph before the next item.

The item is automatically lettered or numbered in sequence.
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8 Press ENTER twice to end the list.

9 To save your changes and exit the editor, use one of the following
methods:

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

■ Click the Close Editor icon in the Multiline Text panel.

Toolbar: Draw  
Command entry: MTEXT

To create a bulleted list in multiline text as you type

1 Click Home tab ➤ Annotation panel ➤ Multiline Text. 

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

3 In the Options panel, click the Options  icon.

4 Click Bullets and Lists. Verify that Allow Auto-list and Allow Bullets and
Lists are selected (tick mark).

5 Start a line of text by entering \U+2022 (the Unicode string for a bullet)
or by selecting a bullet character or another symbol.

NOTE The following characters cannot be used as bullets: period (.), colon
(:), close parenthesis ()), close angle bracket (>), close square bracket (]), and
close curly bracket (}).

6 Alternatively, click Options  ➤  Symbol  ➤  Other.

The Character Map dialog box appears.

7 Double-click a symbol to copy it to the clipboard.

8 Close the Character Map dialog box.

9 Paste the symbol to the drawing, and press the up-arrow and End key to
return the cursor to the same line.
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10 Press TAB.

11 Enter the text of the list item. Press ENTER to move to the next item, or
press SHIFT+ENTER to add a plain paragraph before the next item.

The bullet character is automatically added to the next item.

12 Press ENTER twice to end the list.

13 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT

To move a list item in multiline text down a level

1 If the ribbon is active, double-click a multiline text object to open the
MTEXT ribbon contextual tab. If the ribbon is not active, the In-Place
Text Editor is displayed.

2 Place the cursor at the beginning of a list item and press TAB.

The item moves down one level and begins a nested list.

3 Press ENTER to start the next item at the same level, or press SHIFT+TAB
to move the item up a level.

4 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
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Command entry: MTEXT

To separate an existing list

1 If the ribbon is active, double-click a multiline text object to open the
MTEXT ribbon contextual tab. If the ribbon is not active, the In-Place
Text Editor is displayed.

2 Select a sequence of list items or place the cursor at the beginning of the
item where you want to start the new list.

3 Right-click in the editor. Click Bullets and Lists  ➤  Restart.

The selected items are renumbered as a separate sequence. If you select
items in the middle of a list, unselected items below the selected items
also become part of the new list.

4 To continue the original list below the new list, select the first item below
the new list.

5 Right-click in the editor. Click Bullets and Lists  ➤  Continue.

The selected item and the items following it are renumbered to continue
the previous list.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT

To convert the lists in a multiline text object to plain text

1 If the ribbon is active, double-click a multiline text object to open the
MTEXT ribbon contextual tab. If the ribbon is not active, the In-Place
Text Editor is displayed.

2 Right-click in the editor. Click Bullets and Lists. Remove the check mark
next to Allow Bullets and Lists.
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The plain text lists retain their bullets, numbers, or letters. If you add an
item to the list, the number or letter sequence does not change.

Quick Reference

Commands

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

MTEXT

Creates a multiline text object.

PROPERTIES

Controls properties of existing objects.

System Variables

TEXTFILL

Controls the filling of TrueType fonts while plotting and rendering.

TEXTQLTY

Sets the resolution tessellation fineness of text outlines.

Utilities

No entries

Command Modifiers

No entries

Indent Multiline Text and Use Tabs
You can control how paragraphs are indented in a multiline text (mtext)
object. The ruler in the In-Place Text Editor shows the settings for the current
paragraph.

Tabs and indents that you set before you start to enter text apply to the whole
multiline text object. To apply different tabs and indents to individual
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paragraphs, click in a single paragraph or select multiple paragraphs and then
change the settings.

Sliders on the ruler show indentation relative to the left side of the bounding
box. The top slider indents the first line of the paragraph, and the bottom
slider indents the other lines of the paragraph.

The long tick marks on the ruler show the default tab stops. If you click the
ruler to set your own tabs, the ruler displays a small, L-shaped marker at each
custom tab stop. You can delete a custom tab stop by dragging the marker off
the ruler.

To create paragraphs with hanging indentation

1 If the ribbon is active, double-click a multiline text object to open the
MTEXT ribbon contextual tab. If the ribbon is not active, the In-Place
Text Editor is displayed.

2 Select the paragraphs you want to indent.

3 On the ruler, slide the top indent marker to where you want the first line
of the paragraphs to start.

NOTE The ruler displays the tabs and indents that are set for the selected
paragraphs or, if no text is selected, the paragraph where the cursor is located.
The default tab stops are the long tick marks on the ruler. To set a custom
tab stop, click the ruler where you want the tab stop.

4 Slide the bottom indent marker to where you want the other lines of the
paragraphs to start.

This step indents turnover lines in paragraphs that are more than one
line long.

5 To change the indentation, select the paragraphs you want to change,
click the ruler to set new tab stops, if needed, and move the indent
markers.
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6 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT

Quick Reference

Commands

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

MTEXT

Creates a multiline text object.

PROPERTIES

Controls properties of existing objects.

System Variables

TEXTFILL

Controls the filling of TrueType fonts while plotting and rendering.

TEXTQLTY

Sets the resolution tessellation fineness of text outlines.
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Utilities

No entries

Command Modifiers

No entries

Specify the Line Spacing Within Multiline Text
Line spacing for multiline text is the distance between the baseline (bottom)
of one line of text and the baseline of the next line of text. The line space
factor applies to the entire multiline text object, not to selected lines.

You can set the spacing increment to a multiple of single line spacing, or as
an absolute distance. Single spacing is 1.66 times the height of the text
characters.

The default line space style, At Least, automatically increases line spacing to
accommodate characters that are too large to fit the line spacing you set for
the multiline text object. Use the other line space style, Exactly, to line up
text in tables.

To ensure that line spacing is identical in multiple multiline text objects, use
Exactly and set the Line Space Factor to the same value in each multiline text
object.

NOTE Using Exactly can cause text in lines located above or below lines with large
font characters to overlap the larger characters.

To change the line spacing of multiline text

1 Click View tab  ➤  Palettes panel  ➤  Properties.

2 Select the multiline text object you want to edit.

3 In the Properties palette, for Line Space Style, select one of the following:

■ At Least. Adjusts lines of text automatically based on the height of
the largest character in the line. More space is added between lines
of text with taller characters. This is the default setting.

■ Exactly. Forces the line spacing to be the same size for all lines of text
regardless of format differences such as font or text height.
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4 Change the line spacing by entering a new value for either of the
following options. The two line spacing options provide different ways
to set the same thing:

■ Line Space Factor. Sets the line spacing to a multiple of single-line
spacing. Single spacing is 1.66 times the height of the text characters.

■ Line Space Distance. Sets the line spacing to an absolute value
measured in drawing units. Valid values must be between 0.0833 and
1.3333.

NOTE After you exit the Properties palette, the value of the other line spacing
option is updated to correspond with the line spacing value that you entered.

Toolbar: Standard  
Command entry: PROPERTIES

Quick Reference

Commands

PROPERTIES

Controls properties of existing objects.

System Variables

TSPACEFAC

Controls the multiline text line-spacing distance measured as a factor of text
height.

TSPACETYPE

Controls the type of line spacing used in multiline text.
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Utilities

No entries

Command Modifiers

No entries

Create Stacked Characters Within Multiline Text
Characters representing fractions and tolerances can be formatted to conform
to several standards.

Stacked text refers to the fraction and tolerance formats applied to characters
within multiline text object and multileaders.

You use special characters to indicate how selected text should be stacked.

■ Slash (/) stacks text vertically, separated by a horizontal line.

■ Pound sign (#) stacks text diagonally, separated by a diagonal line.

■ Carat (^) creates a tolerance stack, which is stacked vertically and not
separated by a line.
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To stack characters manually within the In-Place Text Editor, select the text
to be formatted, including the special stacking character, and click the Stack
button on the Text Formatting toolbar.

Stack Numeric and Tolerance Characters Automatically

You can specify that numeric characters entered before and after a slash, pound
sign, or carat will stack automatically. For example, if you enter 1#3 followed
by a nonnumeric character or space, the AutoStack Properties dialog box is
displayed by default, and you can change the settings in the AutoStack dialog
box to specify your formatting preferences.

The automatic stacking feature applies only to numeric characters immediately
before and after the slash, pound sign, and carat. For tolerance stacking, the
+, -, and decimal character also stack automatically.

See also:

■ Use an Alternate Text Editor on page 1576

To create stacked text

1 Click Home tab ➤ Annotation panel ➤ Multiline Text. 

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.

3 In either the MTEXT ribbon contextual tab or In-Place Text Editor, set
text style and other multiline text properties as needed.

4 Enter the text you want to stack separated by one of the following
characters:

■ Slash (/) stacks text vertically, separated by a horizontal line.

■ Pound sign (#) stacks text diagonally, separated by a diagonal line.

■ Carat (^) creates a tolerance stack, which is not separated by a line.

If you enter numbers separated by stack characters and then enter a
nonnumeric character or press SPACEBAR, the AutoStack Properties dialog
box is displayed.

5 In the AutoStack Properties dialog box, you can choose to automatically
stack numbers (not nonnumeric text) and to remove leading blanks. You
can also specify whether the slash character creates a diagonal fraction
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or creates a vertical fraction. If you do not want to use AutoStack, click
Cancel to exit the dialog box.

6 Select the text that you want to stack, and click the Stack button on the
toolbar.

7 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT

To change stack properties

1 Double-click the multiline text object you want to edit.

2 In either the MTEXT ribbon contextual tab or In-Place Text Editor, select
the stacked text.

3 Right-click in the editor. Click Properties.

4 In the Stack Properties dialog box, change settings as needed.

5 To set properties for automatic stacking, click Autostack.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT
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To unstack text

1 Double-click the multiline text object you want to edit.

2 In either the MTEXT ribbon contextual tab or In-Place Text Editor, select
the stacked text.

3 Click Stack on the Text Formatting toolbar.

4 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Toolbar: Draw  
Command entry: MTEXT

Quick Reference

Commands

MTEXT

Creates a multiline text object.

System Variables

TSTACKALIGN

Controls the vertical alignment of stacked text.

TSTACKSIZE

Controls the percentage of stacked text fraction height relative to selected
text's current height.
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Utilities

No entries

Command Modifiers

No entries

Create and Edit Columns in Multiline Text
You can create and edit multiple columns using the In-Place Text Editor
column options and column grips.

Multiple columns can be created and edited in either the MTEXT ribbon
contextual tab or In-Place Text Editor and through the grip editing mode.
Editing columns using grips allows you the flexibility of seeing the changes
as you make them.

Columns follow a few rules. All columns have equal width and equal gutters.
A gutter is the space between columns. The height of columns remains constant
unless more text than the column can accommodate is added, or you manually
move the editing grip to adjust the column height.

Editing Columns in the In-Place Text Editor

When you are working with columns using either the MTEXT ribbon
contextual tab or In-Place Text Editor, the columns will be in a frame. If the
Opaque background is turned on, the background covers each column, leaving
gutter space blank. The ruler bar when applied, spans across all the columns,
but the ruler is only active for the column that is selected as current.

Adding text to a column with an arbitrary height will not increase the column
height even if text is already filling the column. Text will flow into another
column.

You can also insert a column break to force text to start flowing into the next
column. Anytime a column break is inserted, it is assumed that the current
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height of the column is fixed. To delete the break, highlight it and delete or
or use the Backspace key right after the break.

Editing Columns in the Property Palette

You will be able to select Static or Dynamic columns, turn off columns and
change column and gutter width through the Property Palette. Changing
column width in the palette will exhibit results similar to changing width
using grips. The palette is the only place that you can also change gutter
setting.

To create multiple columns in the In-Place Text Editor

1 If the ribbon is active, double-click a multiline text object to open the
MTEXT ribbon contextual tab. If the ribbon is not active, the In-Place
Text Editor is displayed.

2 In the In-Place Text Editor, select a column option and suboption from
columns list. You have a choice between Dynamic or Static columns.

You have two suboptions with Dynamic Columns – Auto height or
Manual height. Static Columns allows you to choose the number of
columns.

3 Adjust the column height by moving the arrows located on the bottom
left of the first column.

NOTE The arrows on the ruler on the upper right side only adjust gutter
width, not column width.

Toolbar: Draw  
Command entry: MTEXT

To adjust columns using grips

1 Select an area outside the mtext object. The In-Place Text Editor toolbar
will disappear.

2 Click once in the text area and grips will appear.

Grips control the location of the mtext object, the gutter width, and
vertical and horizontal movement of colmns.
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Toolbar: Draw  
Command entry: MTEXT

The following illustration demonstrates how grips are used with Dynamic
Columns - Manual Height.

The following illustration demonstrates how grips are used with Static
Columns.
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NOTE In general, grips only update the mtext object after the mouse button is
released.

Quick Reference

Commands

MTEXT

Creates a multiline text object.

System Variables

MTEXTCOLUMN

Sets the default column setting for an mtext object.
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Utilities

No entries

Command Modifiers

No entries

Import Text from External Files
You can insert TXT or RTF text files into your drawing by either importing
the text or dragging a file icon from Windows Explorer.

You can insert TXT or RTF text files created in word processors into your
drawing by either importing the text or dragging a file icon from Windows
Explorer.

Importing TXT or RTF files from other sources gives you the most flexibility.
For example, you can create a text file of standard notes that you include in
drawings. The imported text becomes a multiline text object, which you can
edit and reformat. Text imported from a TXT file inherits the current text
style. Text imported from an RTF file inherits the current text style name, but
retains its original fonts and format. Imported text files are limited to 256 KB
and must have a file extension of .txt or .rtf.

If you drag a text file into a drawing, text width is determined by line breaks
and carriage returns in the original document. When you drag an RTF file into
a drawing, the text is inserted as an OLE object.

If you use the Clipboard to paste text from another application, the text
becomes an OLE object. If you use the Clipboard to paste text from another
file, the text is inserted as a block reference, and it retains its original text
style.

See also:

■ Import OLE Objects

To import text files

1 Click Home tab ➤ Annotation panel ➤ Multiline Text. 

2 Specify opposite corners of a bounding box to define the width of the
multiline text object.
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3 Right-click in the editor. Click Import Text.

The size limit for an imported file is 256 KB.

4 In the Select File dialog box, double-click the file you want to import, or
select the file. Click Open.

The text is inserted at the cursor location.

5 Change the text as needed.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press Ctrl+Enter.

Toolbar: Draw  
Command entry: MTEXT

To insert a text file using the drag-and-drop method

1 Open Windows Explorer, but make sure it does not fill the screen.

2 Display the folder that contains the TXT or RTF file you want.

3 Drag the TXT or RTF file icon onto the drawing. TXT files are inserted as
multiline text objects using the current text style. RTF files are inserted
as OLE objects.

Quick Reference

Commands

MTEXT

Creates a multiline text object.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create Leaders
You can create, modify and add content to a leader object.

Overview of Leader Objects
A leader object is a line or a spline with an arrowhead at one end and a
multiline text object or block at the other.

In some cases, a short horizontal line, called a landing, connects text or blocks
and feature control frames to the leader line.

The landing and leader line are associated with the multiline text object or
block, so when the landing is relocated, the content and leader line move
along with it.

When associative dimensioning is turned on and object snaps are used to
locate the leader arrowhead, the leader is associated with the object to which
the arrowhead is attached. If the object is relocated, the arrowhead is relocated,
and the landing stretches accordingly.
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NOTE The leader object should not be confused with the leader line that is
automatically generated as part of a dimension line.

To create a leader with straight lines

1 Click Home tab ➤ Annotation panel ➤ Multileader. 

2 At the Command prompt, enter o to select options.

3 Enter l to specify leaders.

4 Enter t to specify the leader type.

5 Enter s to specify straight leaders.

6 In the drawing, click a start point for the leader head.

7 Click an end point for the leader.

8 Enter your MTEXT content.

9 On the Text Formatting toolbar, click OK.

Toolbar: Multileader  
Command entry: MLEADER

Quick Reference

Commands

LEADER

Creates a line that connects annotation to a feature.

MLEADER

Creates a multileader object.

QLEADER

Creates a leader and leader annotation.
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System Variables

DIMASSOC

Controls the associativity of dimension objects and whether dimensions are
exploded.

DIMGAP

Sets the distance around the dimension text when the dimension line breaks
to accommodate dimension text.

DIMLDRBLK

Specifies the arrow type for leaders.

MLEADERSCALE

Sets the overall scale factor applied to multileader objects.

Utilities

No entries

Command Modifiers

No entries

Create and Modify Leaders
A leader object typically consists of an arrowhead, an optional horizontal
landing, a leader line or curve, and either a multiline text object or block.

You can create a leader line from any point or feature in a drawing and control
its appearance as you draw. Leaders can be straight line segments or smooth
spline curves.
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A multileader object, or MLEADER, comprises a leader and a note. It can be
created arrowhead first, tail first, or content first. If a multileader style has
been used, then the multileader can be created from that style

Multileader objects can contain multiple leader lines, each of which can have
one or more segments, so that one note can point to multiple objects in your
drawing. You can modify the properties of leader segment in the Properties
palette. Using the MLEADEREDIT command, you can add leaders to, or remove
leaders from, an established multileader object.

Annotative multileaders containing multiple leader segments can have different
head points in each scale representation. Horizontal landings and arrowheads
can have different sizes, and landing gaps can have different distances,
depending on the scale representation. The appearance of the horizontal
landing within a multileader, as well as the type of leader line (straight or
spline) and number of leader segments will remain the same in all scale
representations. For more information, see Create Annotative Leaders and
Multileaders on page 1413.

You can use grips to modify the look of a multileader. Using grips, you can
lengthen or shorten a landing or leader line, or move the entire leader object.

Arrange Leaders

Multileaders can be arranged to add order and consistency to your drawing.

Multileader objects with blocks as content can be collected and attached to
one landing line. Using the MLEADERCOLLECT command, multileaders can
be collected horizontally, vertically, or within a specified area depending on
your drawing needs.
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Multileader objects can be sorted evenly along a specified line. Using the
MLEADERALIGN command, selected multileaders can be aligned and evenly
spaced as specified.

Associate Leaders with Objects

When associative dimensioning is turned on (DIMASSOC), the leader
arrowhead can be associated with a location on an object using an object snap.
If the object is relocated, the arrowhead remains attached to the object and
the leader line stretches, but the multiline text remains in place.

See also:

■ Create Annotative Leaders and Multileaders on page 1413

To create a leader with straight lines

1 Click Home tab ➤ Annotation panel ➤ Multileader. 

2 At the Command prompt, enter o to select options.

3 Enter l to specify leaders.

4 Enter t to specify the leader type.

5 Enter s to specify straight leaders.
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6 In the drawing, click a start point for the leader head.

7 Click an end point for the leader.

8 Enter your MTEXT content.

9 On the Text Formatting toolbar, click OK.

Toolbar: Multileader  
Command entry: MLEADER

To create a leader attached to block content at an angle

1 Click Home tab ➤ Annotation panel ➤ Multileader Style. 

2 In the Multileader Style Manager, click New.

3 In the Create New Multileader Style dialog box, specify a name for the
new multileader style.

4 In the Modify Multileader Style dialog box, Leader Structure tab, under
Landing Settings, uncheck Automatically Include Landing.

5 On the Content tab, next to Multileader Type, choose Block content.

6 Under Block Options, next to Attachment, choose one of the following:

■ Center Extents: Attaches the leader line to the center extent of the
block content

■ Insertion Point: Attaches the leader line to the block content from
any point you specify

7 Click OK.

8 In the Multileader Style Manager, click Close.

9 Do one of the following:

■ Create a multileader object on page 1518

■ Apply the new multileader style to an existing multileader object on
page 1527

Menu: Format ➤ Multileader Style
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Command entry: MLEADERSTYLE

To create a spline leader with text or a block

1 Click Home tab ➤ Annotation panel ➤ Multileader. 

2 At the Command prompt, enter o to select options.

3 Enter l to specify leaders.

4 Enter t to specify the leader type.

5 Enter p to specify a spline leader.

6 In the drawing, click a start point for the leader head.

7 Click the end point for the leader.

8 Enter your MTEXT content.

9 In the Text Formatting toolbar, click OK.

Toolbar: Multileader  
Command entry: MLEADER

To edit leader text

1 Double-click the text you want to edit.

If the ribbon is active, the MTEXT ribbon contextual tab is displayed. IF
the ribbon is not active, the In-Place Text Editor is displayed for both
single-line text and multiline text. The Text Formatting toolbar is not
available for single-line text.

2 Edit the text.

Command entry: DDEDIT
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To create multiple leaders from the same annotation

1 Select the multileader.

2 Click Annotate tab ➤ Multileaders panel ➤ Add Leader. 

3 Specify the endpoint for the new leader.

Toolbar: Multileader  
Command entry: MLEADEREDIT

To remove leaders from an annotation

1 Select the multileader.

2 On the Multileader toolbar, click Remove Leader.

3 Select the leader or leaders you want to remove. Press ENTER.

Toolbar: Multileader  
Command entry: MLEADEREDIT

To align and space leaders

1 Click Annotate tab ➤ Multileaders panel ➤ Align. 

2 Select the multileaders to be aligned. Press ENTER.

3 Specify a starting point in the drawing to begin the alignment. The point
you select is the position of the landing head.

4 If you want to change the spacing of the multileader objects, enter s and
specify one of the following spacing methods:

■ Distribute. Spaces content evenly between two selected points.

■ Use Current. Uses the current spacing between multileaders.

■ Make Parallel. Places content so that each of the last line segments
in the selected multileaders are parallel.
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5 In the drawing click a point to end the alignment.

Toolbar: Multileader  
Command entry: MLEADERALIGN

To collect multiple notes to be attached to a single landing

1 Click Annotate tab ➤ Multileaders panel ➤ Collect. On the
Multileader toolbar, click Collect Multileaders.

2 Select multileaders in the order you want them to be collected. The last
multileader selected retains its landing. Press ENTER.

Toolbar: Multileader  
Command entry: MLEADERCOLLECT

To create a landing line with multiple segments

1 Click Home tab ➤ Annotation panel ➤ Multileader Style. 

2 In the Multileader Style Manager, click New to create a new multileader
style.

3 In the Create New Multileader Style dialog box, specify a name for the
new multileader style.

4 In the Modify Multileader Style dialog box, select the Leader Structure
tab.

5 In the Constraints group box, select the Maximum Leader Points check
box. In the box to the right, specify a maximum number of points to be
prompted for upon creation of a new multileader. Click OK.

6 In the Multileader Style Manager, click Set Current to apply the new
multileader style to new multileaders that you create.

Toolbar: Multileader 
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Command entry: MLEADERSTYLE

To change the properties of a multileader leader

1 Press CTRL and select a segment of the leader line.

2 Right-click and then select Properties from the shortcut menu.

3 In the Properties palette, specify the properties of the segment.

Toolbar: Standard 
Command entry: PROPERTIES

Quick Reference

Commands

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

MLEADER

Creates a multileader object.

MLEADERALIGN

Aligns and spaces selected multileader objects.

MLEADERCOLLECT

Organizes selected multileaders that contain blocks into rows or columns,
and displays the result with a single leader.

MLEADEREDIT

Adds leader lines to, or removes leader lines from, a multileader object.

MLEADERSTYLE

Creates and modifies multileader styles.

PROPERTIES

Controls properties of existing objects.
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System Variables

DIMASSOC

Controls the associativity of dimension objects and whether dimensions are
exploded.

DIMASZ

Controls the size of dimension line and leader line arrowheads.

DIMCLRD

Assigns colors to dimension lines, arrowheads, and dimension leader lines.

DIMGAP

Sets the distance around the dimension text when the dimension line breaks
to accommodate dimension text.

DIMLDRBLK

Specifies the arrow type for leaders.

DIMSCALE

Sets the overall scale factor applied to dimensioning variables that specify
sizes, distances, or offsets.

DIMTAD

Controls the vertical position of text in relation to the dimension line.

DIMTXTDIRECTION

Specifies the reading direction of the dimension text.

MLEADERSCALE

Sets the overall scale factor applied to multileader objects.
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Utilities

No entries

Command Modifiers

No entries

Work with Leader Styles
The appearance of a leader is controlled by its multileader style. You can use
the default multileader style, STANDARD, or create your own multileader
styles.

The multileader style can specify formatting for landing lines, leader lines,
arrowheads, and content. For example, the STANDARD multileader style uses
a straight leader line with a closed filled arrowhead and multiline text content.

NOTE Annotative blocks cannot be used as either content or arrowheads in
multileader objects.

Once a multileader style has been defined, you can set it as the current
multileader style to be used when the MLEADER command is invoked.

To define a leader style

1 Click Home tab ➤ Annotation panel ➤ Multileader Style. 

2 In the Multileader Style Manager, click New.

3 In the Create New Multileader Style dialog box, specify a name for the
new multileader style.

4 In the Modify Multileader Style dialog box, Leader Format tab, select or
clear the following options:

■ Type. Determines the type of landing. You can choose a straight
landing, spline landing, or no landing.

■ Color. Determines the color of the landing.

■ Linetype. Determines the linetype of the landing.

■ Lineweight. Determines the lineweight of the landing.

5 Specify a symbol and size for the multileader arrowhead.
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6 On the Leader Structure tab, select or clear the following options:

■ Maximum Leader Points. Specifies a maximum number of points for
the multileader landing line.

■ First and Second Segment Angles. Specifies the angle of the first and
second points in the landing.

■ Landing - Keep Horizontal. Attaches a horizontal landing to the
multileader content.

■ Set Landing Distance. Determines the fixed distance for the
multileader landing line.

7 On the Content tab, specify either text or block content for the
multileader. If the multileader object will contain text content, then
select or clear the following options:

■ Default Text. Sets default text for the multileader content. A field can
be inserted here.

■ Text Style. Specifies a predefined text style for the attribute text.
Currently loaded text styles are displayed.

■ Text Angle. Specifies the rotation angle of the multileader text.

■ Text Color. Specifies the color of the multileader text.

■ Paper Height. Sets the height of the text as it will display in paper
space.

■ Frame Text. Frames the multileader text content with a text box.

■ Attachment. Controls the attachment of the landing to the multileader
text.

■ Landing Gap. Specifies the distance between the landing and the
multileader text.

If block content is specified, then select or clear the following options:

■ Source Block. Specifies the block used for multileader content.

■ Attachment. Specifies the way the block is attached to the multileader
object. You can attach the block by specifying the extents, the
insertion point, or the center point of the block.

■ Color. Specifies the color of the multileader block content. ByBlock
is selected by default.
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8 Click OK.

Menu: Format ➤ Multileader Style

Toolbar: Multileader  
Command entry: MLEADERSTYLE

To apply a leader style to an existing leader

1 Select the multileader to which you want to apply a new style.

2 On the ribbon, click the Annotate tab, Multileaders panel. Select the
desired multileader style from the drop-down list.

3 To create a new style, click the Multileader Style icon.

Toolbar: Multileader  
Command entry: MLEADERSTYLE

Quick Reference

Commands

MLEADERSTYLE

Creates and modifies multileader styles.

System Variables

CMLEADERSTYLE

Sets the name of the current multileader style.
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Utilities

No entries

Command Modifiers

No entries

Add Content to a Leader
Leaders can contain multiline text or blocks to label parts of your drawing.

Leaders Containing Multiline Text

Leaders can contain multiline text as content. Text can be inserted by default
when creating a leader style. Text style, color, height, and alignment can be
applied and modified in leader annotations. You can also offset a multiline
text object by specifying a landing gap distance in the current leader style.

You can create annotative multileaders with text as content. The text content
will be scaled according to the specified scale representation. Width,
justification, attachment, and rotation settings for text content can be different
depending on the specified scale representation. Actual text content cannot
change with the scale representation.

There are several options for placing multiline text as content in a leader
object.

Top of top line

Middle of top line

Bottom of top line
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Underline top line

Middle of text

Middle of bottom line

Bottom of bottom line

Underline bottom line

Underline all text

Leaders Containing Blocks

Multileaders can contain blocks as content by applying a multileader style
that references a block in your drawing.

NOTE Annotative Blocks cannot be used as either content or arrowheads in
multileader objects.
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Blocks can be connected to a multileader by attaching the landing to a selected
insertion point on the block. You can also connect a multileader to a center
point on the selected block.

You can create annotative multileaders with blocks as content. The block
content will be scaled according to the specified scale representation. Any
attributes within the block content will not change with the scale
representation. Non-annotative multileader objects can be scaled using the
MLEADERSCALE system variable.

See also:

■ Use Fields in Text on page 1532

Quick Reference

Commands

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

DIMSTYLE

Creates and modifies dimension styles.

MLEADER

Creates a multileader object.

MTEXT

Creates a multiline text object.

OPTIONS

Customizes the program settings.

PROPERTIES

Controls properties of existing objects.

PURGE

Removes unused items, such as block definitions and layers, from the drawing.

QTEXT

Controls the display and plotting of text and attribute objects.
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SPELL

Checks spelling in a drawing.

STYLE

Creates, modifies, or specifies text styles.

TEXT

Creates a single-line text object.

System Variables

DIMGAP

Sets the distance around the dimension text when the dimension line breaks
to accommodate dimension text.

FONTALT

Specifies the alternate font to be used when the specified font file cannot be
located.

FONTMAP

Specifies the font mapping file to be used.

MLEADERSCALE

Sets the overall scale factor applied to multileader objects.

MTEXTED

Sets the application for editing multiline text objects.

QTEXTMODE

Controls how text is displayed.

TEXTFILL

Controls the filling of TrueType fonts while plotting and rendering.

TEXTQLTY

Sets the resolution tessellation fineness of text outlines.
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Utilities

No entries

Command Modifiers

No entries

Use Fields in Text
A field is updatable text that is set up to display data that may change during
the life cycle of the drawing. When the field is updated, the latest value of the
field is displayed.

Insert Fields
A field is text that contains instructions to display data that you expect to
change during the life cycle of the drawing.

When a field is updated, the latest data is displayed. For example, the value
of the FileName field is the name of the file. If the file name changes, the new
file name is displayed when the field is updated.

Fields can be inserted in any kind of text (except tolerances), including text
in table cells, attributes, and attribute definitions. When any text command
is active, Insert Field is available on the shortcut menu.

Some sheet set fields can be inserted as placeholders. For example, you can
insert SheetNumberAndTitle as a placeholder. Later, when the layout is added
to a sheet set, the placeholder field displays the correct sheet number and
title.

Block placeholder fields can be used in block attribute definitions while you're
working in the Block Editor.

A field for which no value is available displays hyphens (----). For example,
the Author field, which is set in the Drawing Properties dialog box, may be
blank. An invalid field displays pound signs (####). For example, the
CurrentSheetName field, which is valid only in paper space, displays pound
signs if it is placed in model space.

Change the Appearance of a Field

The field text uses the same text style as the text object in which it is inserted.
By default, fields are displayed with a light gray background that is not plotted
(FIELDDISPLAY system variable).
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Formatting options in the Field dialog box control the appearance of the text
that is displayed. The options that are available depend on the type of field.
For example, the format for date fields includes options for displaying the day
of the week and the time, and the format for named object fields includes
capitalization options.

Edit a Field

A field is part of a text object and it can be edited from a text editor. The easiest
way to edit a field is to double click the text object that contains the field and
then, to display the Field dialog box, double click the field. These operations
are available on the shortcut menus as well.

If you no longer want to update a field, you can preserve the value that is
currently displayed by converting the field to text.

The field expression, consisting of escape characters and a field code, is shown
in the Field dialog box but cannot be edited.

To insert a field in text

1 Double-click the text to display the appropriate text editing dialog box.

2 Place the cursor where you want the field text to appear and right-click.
Click Insert Field.

For keyboard access, press CTRL+F.

3 In the Field dialog box, in Field Category, select All or select a category.

The fields in the selected category are displayed in the Field Names list.

4 In the Field Names list, select a field.

The current value of most fields is displayed in a shaded text box to the
right of Field Category. The current value of a date field is displayed in
the Examples list.

5 Select a format and any other options.

For example, when the NamedObject field is selected, you select a type
(for example, layer or textstyle) and a name (for example, 0 for layer or
STANDARD for textstyle).

Field Expression displays the expression that underlies the field. The field
expression cannot be edited, but you can learn how fields are constructed
by viewing this area.

6 Click OK to insert the field.
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The field displays its current value in the text when the Field dialog box
closes.

To insert a field in a table

1 Double-click inside a cell in a table to select it for editing.

2 Place the cursor where you want the field text to appear and right-click.
Click Insert Field.

3 In the Field dialog box, select All or select a category.

4 In the Field Names list, select a field.

The current value of the field is displayed in a shaded text box to the
right of Field Category.

5 Select a format and any other option.

6 Click OK to insert the field.

The field displays its current value when you move to the next cell.

To use a field to display a property of an object

1 Double-click a text object to display the appropriate text editing dialog
box.

2 Place the cursor where you want the field text to appear and right-click.
Click Insert Field.

3 In the Field dialog box, in Field Category, select All.

4 In the Field Names list, select Object.

5 In Object Type, click the Select Object button, and select an object in the
drawing.

6 In the Field dialog box, in Property, select the property whose value you
want to display in the text.

For example, the field could display the radius of a selected circle.

7 Select a format for the text.

8 Click OK.

The current value for the object's property is displayed in the text.
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To insert a sheet set placeholder field

1 Click Home tab  ➤  Block panel  ➤  Define Attributes.

2 In the Attribute Definition dialog box, under Mode, click Preset. Specify
any text options.

3 Under Attribute, in the Tag box, enter a name for the field.

4 To the right of the Value box, click the Insert Field button.

5 In the Field dialog box, under Field Category, select SheetSet.

6 In the Field Names list, select SheetSetPlaceholder.

7 In Placeholder Type, select the type of field that you want.

Temporary Value previews the placeholder field.

8 In Format, select a capitalization style for the placeholder field.

When the field is updated, the same style is used for the value of the
field.

9 (Optional) Click Associate Hyperlink if you want the field to serve as a
hyperlink to a location.

NOTE Associate Hyperlink is not available for the ViewportScale field.

10 Click OK to exit the Field dialog box.

The placeholder field displays its name when the Field dialog box closes:
for example, SheetNumber. Later, when the block is inserted from the
Views List tab shortcut menu in the Sheet Set Manager, the field displays
a value based on the sheet it is dragged to: for example, its sheet number.

11 Click OK in the Attribute Definition dialog box. Specify the location for
the field text to appear near the geometry that you have created to use
with the Sheet Set Manager as a callout block or a label block.

12 Create a block that includes the newly created attribute object along with
the geometry for the block.

Command entry: ATTDEF
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To format a field value

1 Double-click a text object to display the appropriate text editing dialog
box.

2 Double-click the field you want to format.

The Field dialog box is displayed. If formatting is available for the field,
the Field Format button is displayed.

3 Click Field Format.

In the Additional Format dialog box, the current value of the field is
displayed. When you select an option, the result is displayed in Preview.

4 Enter a conversion factor to apply to the current value.

For example, to convert inches to millimeters, enter 0.03937.

5 Enter any text that you want to precede or follow the field value.

For example, enter mm for millimeters.

6 Select a decimal separator. Select None or Comma to group thousands.

7 Select an option for suppressing zeros:

■ Leading: Suppresses leading zeros in all decimal field values. For
example, 0.5000 becomes .5000.

■ Trailing: Suppresses trailing zeros in all decimal field values. For
example, 12.5000 becomes 12.5, and 30.0000 becomes 30.

■ 0 Feet: Suppresses the feet portion of a feet-and-inches field value
when the distance is less than one foot. For example, 0'-6 1/2" becomes
6 1/2".

■ 0 Inches: Suppresses the inches portion of a feet-and-inches field value
when the distance is an integral number of feet. For example, 1'-0"
becomes 1'.

8 Click OK.

In the Field dialog box, the field value is displayed in Preview with the
formatting you specified.

9 Click OK.

To edit a field

1 Double-click a text object to display the appropriate text editing dialog
box.
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2 Double-click the field that you want to edit.

The Field dialog box is displayed.

3 Make any needed changes.

4 Click OK to exit the Field dialog box.

5 Exit the text editor.

Quick Reference

Commands

FIELD

Creates a multiline text object with a field that can be updated automatically
as the field value changes.

FIND

Finds the text that you specify, and can optionally replace it with other text.

INSERT

Inserts a block or drawing into the current drawing.

LIST

Displays property data for selected objects.

MTEXT

Creates a multiline text object.

SPELL

Checks spelling in a drawing.

TABLE

Creates an empty table object.

TABLEEXPORT

Exports data from a table object in CSV file format.

TABLESTYLE

Creates, modifies, or specifies table styles.
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UPDATEFIELD

Manually updates fields in selected objects in the drawing.

System Variables

CTABLESTYLE

Sets the name of the current table style.

FIELDDISPLAY

Controls whether fields are displayed with a gray background.

FIELDEVAL

Controls how fields are updated.

Utilities

No entries

Command Modifiers

No entries

Update Fields
When a field is updated, it displays the latest value. You can update fields
individually or update all fields in one or more selected text objects.

You can also set fields to be updated automatically when the drawing is
opened, saved, plotted, regenerated, or sent through ETRANSMIT.

Settings on the User Preferences Tab (Options Dialog Box) control whether
fields are updated automatically or on demand (FIELDEVAL system variable).
The Date field cannot be updated automatically regardless of the setting of
FIELDEVAL.

NOTE When the DEMANDLOAD system variable is set to 2, fields cannot be
updated until you use FIELD or UPDATEFIELD.

Contextual Fields in Blocks and Xrefs
Some fields are contextual; that is, their value is different depending on which
space or layout they reside in. For example, because each layout can have a
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different page setup attached, the value displayed by the PlotOrientation field
can be different in different layouts in the same drawing.

List of contextual fields

CurrentSheetTitleCurrentSheetCustom

DeviceNameCurrentSheetDescription

PaperSizeCurrentSheetNumber

PlotDateCurrentSheetNumberAndTitle

PlotOrientationCurrentSheetSet

PlotScaleCurrentSheetSetCustom

PageSetupNameCurrentSheetSetDescription

PlotStyleTableCurrentSheetSubSet

For compatibility with previous versions, contextual fields in blocks and xrefs
are not updated when you insert them in a drawing; instead, the field displays
the last cached value. Therefore, if you want to use a contextual field within
a block, for example, a title block, you must insert the field as an attribute.
For example, a title block can use the CurrentSheetNumber field as an attribute.
When you insert the title block, the field displays the sheet number of the
sheet on which the title block is inserted.

Most fields are not contextual and are updated in blocks and xrefs. Fields in
xrefs are updated based on the host file, not the source xref. These fields do
not have to be placed in attributes. For example, a field that displays the sheet
number of a particular sheet in a sheet set and that updates if that sheet
number changes, is a property of the sheet set. When you create the field, you
select the SheetSet field name, select the sheet set and the sheet that you want
in the tree view, and then select the property SheetNumber for the field value
to be displayed. This field displays the sheet number of that sheet, even if you
put the field in a block and insert it in another drawing. If the sheet is removed
from the sheet set, it no longer has a sheet number, and the field becomes
invalid and displays pound signs.

Some sheet set fields can be inserted as placeholders. For example, when you
create your own callout blocks and label blocks, you can insert the
SheetNumber field as a placeholder. Later, when the block is inserted from

Update Fields | 1539



the Views List tab shortcut menu in the Sheet Set Manager, the field displays
the sheet number of the drawing.

Compatibility with Previous Releases

When a drawing with fields is opened in AutoCAD 2004 or earlier, the fields
are not updated; they display the value last displayed in the drawing before
it was opened. If no changes are made to a field, it is updated normally when
it is reopened in a release that supports fields.

Fields are not available in the previous releases of AutoCAD LT. When a
drawing with fields is opened in the previous releases of AutoCAD LT, the
fields are evaluated based on the setting of the FIELDEVAL system variable in
the drawing, but the FIELDEVAL system variable is not accessible.

See also:

■ Work with AutoCAD Drawings in AutoCAD LT

To update a field manually

1 Double-click text.

2 Select the field to update and right-click. Click Update Field.

To update multiple fields manually

1 Click Blocks & References tab ➤ Data panel ➤ Update Fields . 

2 At the Select Objects prompt, select the objects that contain the fields
you want to update and press ENTER.

All of the fields in the selected objects are updated.

Command entry: UPDATEFIELD

To update fields automatically

1 At the Command prompt, enter fieldeval.

2 Enter a bitcode that is the sum of any of the following values:

■ 0: Not updated

■ 1: Updated on open
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■ 2: Updated on save

■ 4: Updated on plot

■ 8: Updated on use of ETRANSMIT

■ 16: Updated on regeneration

For example, to update fields only when the file is opened, saved, or
plotted, enter 7.

Quick Reference

Commands

FIELD

Creates a multiline text object with a field that can be updated automatically
as the field value changes.

UPDATEFIELD

Manually updates fields in selected objects in the drawing.

System Variables

FIELDDISPLAY

Controls whether fields are displayed with a gray background.

FIELDEVAL

Controls how fields are updated.

Utilities

No entries

Command Modifiers

No entries

Use Hyperlinks in Fields
The Hyperlink field assigns a hyperlink to any piece of text.

Use Hyperlinks in Fields | 1541



The hyperlink works the same way as a hyperlink attached to an object. When
the cursor pauses over the text, a hyperlink cursor is displayed, along with a
tooltip that describes the hyperlink. Hold down the CTRL key and click to
follow the link.

NOTE The Hyperlink field uses an absolute path to a file; the HYPERLINK command
can create a hyperlink with a relative path.

The fields that point to sheet and view titles and numbers can be assigned a
hyperlink when they are created. When these items are changed or moved in
the Sheet Set Manager, the hyperlinks associated with them still jump to the
correct location.

Hyperlinks in fields are converted from links to DWG files into links to DWF
files when published to a multi-sheet DWF file format.

To add a hyperlink field to text

1 Click Home tab ➤ Annotation panel ➤ Multiline Text. 

2 Place the cursor where you want the hyperlink text to appear.

3 Right-click in the editor. Click Insert Field.

4 In the Field dialog box, in Field Category, select Linked.

5 In Field Names, select Hyperlink, and click Hyperlink.

6 In the Insert Hyperlink dialog box, use one of the following methods to
specify a location:

■ Under Type the File or Web Page Name, enter the path and name of
the file that you want to associate with the hyperlink.

■ Under Browse For, click File, Web Page, or Target. Navigate to the
location to which you want to link. Click Open or OK.

7 (Optional) In Text to Display, select the default text that is displayed,
and enter the link text that you want to appear in the mtext object.

8 Click OK to close each dialog box.

9 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.
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■ Press CTRL+ENTER.

The hyperlink is displayed in the mtext object with the link text that you
entered. Use CTRL+click to jump to the hyperlinked location.

Toolbar: Draw  
Command entry: MTEXT

Quick Reference

Commands

FIELD

Creates a multiline text object with a field that can be updated automatically
as the field value changes.

FIND

Finds the text that you specify, and can optionally replace it with other text.

INSERT

Inserts a block or drawing into the current drawing.

LIST

Displays property data for selected objects.

MTEXT

Creates a multiline text object.

SPELL

Checks spelling in a drawing.

TABLE

Creates an empty table object.

TABLEEXPORT

Exports data from a table object in CSV file format.

TABLESTYLE

Creates, modifies, or specifies table styles.
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UPDATEFIELD

Manually updates fields in selected objects in the drawing.

System Variables

CTABLESTYLE

Sets the name of the current table style.

FIELDDISPLAY

Controls whether fields are displayed with a gray background.

FIELDEVAL

Controls how fields are updated.

Utilities

No entries

Command Modifiers

No entries

Work with Text Styles
When you enter text into your drawing, the current text style determines the
text font, size, angle, orientation, and other text characteristics.

Overview of Text Styles
All text in a drawing has a text style associated with it. When you enter text,
the program uses the current text style.

The current text style sets the font, size, obliquing angle, orientation, and
other text characteristics. If you want to create text using a different text style,
you can make another text style current. The table shows the settings for the
STANDARD text style.

The settings for the current text style are displayed at the Command prompts.
You can use or modify the current text style or create and load a new text
style. Once you've created a text style, you can modify its characteristics,
change its name, or delete it when you no longer need it.
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Create and Modify Text Styles

Except for the default STANDARD text style, you must create any text style
that you want to use.

Text style names can be up to 255 characters long. They can contain letters,
numbers, and the special characters dollar sign ($), underscore (_), and hyphen
(-). If you don't enter a text style name, the text styles are automatically named
Stylen, where n is a number that starts at 1.

You can modify an existing text style in the Text Style dialog box by changing
the settings. You can also update existing text of that text style to reflect the
changes.

Certain style settings affect multiline and single-line text objects differently.
For example, changing the Upside Down and Backwards options has no effect
on multiline text objects. Changing Width Factor and Obliquing has no effect
on single-line text.

If you rename an existing text style, any text using the old name assumes the
new text style name.

You can remove unreferenced text styles from your drawing with PURGE or
by deleting the text styles from the Text Styles dialog box. The STANDARD
text style cannot be removed.

Change Text Style
When you change the text style of a multiline text object, the updated settings
are applied to the entire object, and some formatting of individual characters
might not be retained. The following table describes the effects of text style
change on character formatting.

Retained?Formatting

NoBold

YesColor

NoFont

NoHeight

NoItalic

YesStacking
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Retained?Formatting

YesUnderlining

Annotative Text Styles

Use text for notes and labels in your drawing. You create annotative text by
using an annotative text style, which sets the height of the text on the paper.

For more information about creating and working with an annotative text,
see Create Annotative Text on page 1404.

See also:

■ Scale Annotations on page 1393

To set the current text style

■ On the ribbon, click the Annotate tab  ➤  Text panel. in the Text Style
drop-down list, select a text style.

Command entry: STYLE

Quick Reference

Commands

PURGE

Removes unused items, such as block definitions and layers, from the drawing.

STYLE

Creates, modifies, or specifies text styles.

System Variables

FONTALT

Specifies the alternate font to be used when the specified font file cannot be
located.

FONTMAP

Specifies the font mapping file to be used.
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TEXTSIZE

Sets the default height for new text objects drawn with the current text style.

TEXTSTYLE

Sets the name of the current text style.

Utilities

No entries

Command Modifiers

No entries

Assign Text Fonts
You can assign a text font as part of the text style definition. Several factors
depend on the type of text you are working with.

Overview of Assigning Text Fonts
Fonts define the shapes of the text characters that make up each character set.
You can use TrueType fonts in addition to compiled SHX fonts.

A single font can be used by more than one text style. If your company has a
standard font, you can modify other text style settings to create a set of text
styles that use this standard font in different ways. The following illustration
shows the same font used by different text styles that use different obliquing
settings to define the slant of the text.
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You can assign a font to a text style by selecting a font file from the list in the
Text Style dialog box.

Quick Reference

Commands

STYLE

Creates, modifies, or specifies text styles.

System Variables

FONTALT

Specifies the alternate font to be used when the specified font file cannot be
located.

FONTMAP

Specifies the font mapping file to be used.
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Utilities

No entries

Command Modifiers

No entries

Use TrueType Fonts
Several factors affect the display of TrueType fonts in a drawing.

TrueType fonts always appear filled in your drawing; however, when you plot,
the TEXTFILL system variable controls whether the fonts are filled. By default
TEXTFILL is set to 1 to plot the filled-in fonts.

The In-Place Text Editor can display only fonts that are recognized by Microsoft
Windows. Because SHX fonts are not recognized by Windows, a TrueType
equivalent is supplied in the In-Place Text Editor when you select an SHX or
any other non-TrueType font for editing.

See also:

■ Set Text Height on page 1556

To assign a TrueType font to a text style

1 Click Annotate tab  ➤  Text panel ➤ Panel Launcher button.

2 In the Text Style dialog box under Style Name, click New.

3 In the New Text Style dialog box, enter a style name for the new text
style. Click OK.

4 Under Font Name, select a TrueType font from the list.

TrueType fonts display a TrueType icon in front of their names.

5 To update text of the current style in the drawing, click Apply.

6 Click Close.

Menu: Format  ➤ Text Style

Toolbar: Styles  
Command entry: STYLE
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Quick Reference

Commands

QTEXT

Controls the display and plotting of text and attribute objects.

STYLE

Creates, modifies, or specifies text styles.

System Variables

QTEXTMODE

Controls how text is displayed.

TEXTFILL

Controls the filling of TrueType fonts while plotting and rendering.

TEXTQLTY

Sets the resolution tessellation fineness of text outlines.

Utilities

No entries

Command Modifiers

No entries

Use Text Fonts for International Work
Several factors affect your choosing, entering, and displaying international
text in a drawing.

The program supports the Unicode character-encoding standard. An SHX font
encoded using the Unicode standard font can contain many more characters
than are defined in your system; therefore, to use a character not directly
available from the keyboard, you can enter the escape sequence \U+nnnn,
where nnnn represents the Unicode hexadecimal value for the character.

Beginning with AutoCAD 2007, all SHX shape fonts are encoded with the
Unicode standard with the exception of Big Fonts. When choosing a text font
for international work, you can use either a TrueType Font or a Big Font.
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Asian Big Font SHX Files
Asian alphabets contain thousands of non-ASCII characters. To support such
text, the program provides a special type of shape definition known as a Big
Font file. You can set a style to use both regular and Big Font files.

Asian Language Big Fonts Included in the Product

DescriptionFont File Name

Japanese vertical font (a few characters are ro-
tated to work correctly in vertical text)

@extfont2.shx

Japanese font, subset of charactersbigfont.shx

Traditional Chinese fontchineset.shx

Japanese extended font, level 1extfont.shx

Japanese extended font, level 2extfont2.shx

Simplified Chinese fontgbcbig.shx

Korean fontwhgdtxt.shx

Korean fontwhgtxt.shx

Korean fontwhtgtxt.shx

Korean fontwhtmtxt.shx

When you specify fonts using -STYLE, the assumption is that the first name
is the normal font and the second (separated by a comma) is the Big Font. If
you enter only one name, it's assumed that it is the normal font and any
associated Big Font is removed. By using leading or trailing commas when
specifying the font file names, you can change one font without affecting the
other, as shown in the following table.

Specifying fonts and Big Fonts at the Command prompt

To specify this ...Enter this ...

Both normal fonts and Big Fonts[font name],[big font name]

Only a normal font (Big Font unchanged)[font name],
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Specifying fonts and Big Fonts at the Command prompt

To specify this ...Enter this ...

Only a Big Font (normal font unchanged),[big font name]

Only a normal font (Big Font, if any, removed)[font name]

No changeENTER (null response)

NOTE  Long file names that contain commas as font file names are not accepted.
The comma is interpreted as a separator for an SHX font-Big Font pair.

See also:

■ Substitute Fonts on page 1553

To assign an Asian-language SHX font to a text style

1 Click Home tab ➤ Annotation panel ➤ Text Style. 

2 In the Text Style dialog box, under Style Name, click New.

3 In the New Text Style dialog box, enter a style name for the new text
style. Click OK.

4 Under Font Name, select the name of an SHX font file, and then select
Use Big Font to select an Asian-language big font.

When you select Use Big Font, the Font Style box changes to a Big Font
Name box. Only SHX fonts are available for selection, and only Big Font
names are shown in the Big Font box.

5 To see the effects on different characters, enter a text string in the sample
text box that is located to the left of the Preview button. Click Preview.

6 To update text of the current style in the drawing, click Apply.

7 Click Close.

Toolbar: Styles  
Command entry: STYLE
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Quick Reference

Commands

STYLE

Creates, modifies, or specifies text styles.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Substitute Fonts
A font used in a drawing but that is not currently available on your system is
automatically substituted with another font.

The program accommodates a font that is not currently on your system by
substituting another font.

Specify an Alternate Font

If your drawing specifies a font that is not currently on your system, the font
designated as your alternate font is automatically substituted. By default, the
simplex.shx file is used. If you want to specify a different font, enter the alternate
font file name by changing the FONTALT system variable. If you use a text
style that uses a Big Font, you can map it to another font using the FONTALT
system variable. This system variable uses a default font file pair: txt.shx and
bigfont.shx. For more information, see Use Text Fonts for International Work
on page 1550.

In previous releases, you could display PostScript® fonts in the drawing.
Because later releases cannot display PostScript fonts, Autodesk has supplied
TrueType font equivalents. These PostScript fonts are mapped to the equivalent
TrueType fonts in a font mapping file. Additionally, when a TrueType font is
not available, you can specify a different TrueType font, making sure that the
fonts are similar to avoid text length or wrapping problems.
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If the default font does not support the characters you enter using the In-Place
Text Editor (MTEXT command), an alternative font is substituted.

CIF or MIF codes entered with the In-Place Text Editor or with the DTEXT
command are now automatically converted to display the actual characters.

Edit the Font Mapping File

A font mapping file is a list of text fonts and their substitutes. If a text font
used in a drawing cannot be located, another text font is substituted for the
missing font using a font mapping file.

Each line in the font mapping file contains the name of a font file (with no
file extension or path) followed by a semicolon (;) and the name of the
substitute font file. The substitute file name includes a file extension such as
.ttf.

A font mapping file is an ordinary ASCII text file with a .fmp extension. The
default font mapping file is acad.fmp for AutoCAD, and acadlt.fmp for AutoCAD
LT. You can change the font assignments in a font mapping file using any
ASCII text editor.

For example, you could use the following entry in a font map file to specify
that the timesnr.pfb font file be substituted with the times.ttf font file:

timesnr;times.ttf
The following table shows the font substitution rules used if a font file cannot
be located when a drawing is opened.

Font substitution

Fourth map-
ping order

Third mapping or-
der

Second mapping
order

First mapping or-
der

File exten-
sion

Windows substitutes
a similar font

Use font defined in
text style

Use font mapping
table

.ttf

Prompt for new
font

Use FONTALTUse font defined in
text style

Use font mapping
table

.shx

Prompt for new fontUse FONTALTUse font mapping
table

.pfb

Display Proxy Fonts

For third-party or custom SHX fonts that have no TrueType equivalent, one
of several different TrueType fonts called proxy fonts is substituted. In the
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In-Place Text Editor, proxy fonts look different from the fonts they represent
to indicate that the proxy fonts are substitutions for the fonts used in the
drawing.

Custom SHX fonts do not appear in the Font list on either the MTEXT Ribbon
Contextual Tab or the Text Formatting toolbar. If you want to format characters
by assigning one of these fonts, first create a text style that uses the font and
then apply that text style to the characters.

To specify a font mapping file

1 Click Tools menu  ➤ Options.

2 On the Files tab, in the list, double-click Text Editor, Dictionary, and Font
File Names.

3 Double-click Font Mapping File.

The acad.fmp file is specified by default.

4 To change the font mapping file, double-click the arrow line to open the
Select a File dialog box. Select a file and click Open. Click OK.

5 At the Command prompt, enter regen to convert existing text using the
new font mappings.

Command entry: OPTIONS

To specify a default alternate font

1 At the Command prompt, enter fontalt.

2 Enter the name of the font file you want to use as the alternative.

Quick Reference

Commands

MTEXT

Creates a multiline text object.

OPTIONS

Customizes the program settings.
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System Variables

FONTALT

Specifies the alternate font to be used when the specified font file cannot be
located.

FONTMAP

Specifies the font mapping file to be used.

Utilities

No entries

Command Modifiers

No entries

Set Text Height
Text height determines the size in drawing units of the letters in the font you
are using.

The exception is TrueType fonts: the value usually represents the size of the
uppercase letters.

If you specify a fixed height as part of a text style, the Height prompt is
bypassed when you create single-line text. When the height is set to 0 in the
text style, you are prompted for the height each time you create single-line
text. Set the value to 0 if you want to specify the height as you create text.

TrueType Fonts

For TrueType fonts, the value specified for text height represents the height
of a capital letter plus an ascent area reserved for accent marks and other marks
used in non-English languages. The relative portion of text height that is
assigned to capital letters and ascent characters is determined by the font
designer at the time the font is designed; consequently, it varies from font to
font.

In addition to the height of a capital letter and the ascent area that make up
the text height specified by the user, TrueType fonts have a descent area for
portions of characters that extend below the text insertion line, for example,
y, j, p, g, and q.

When you apply a text height override to all text in the editor, the entire
multiline text object is scaled, including its width.
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To set text height in a text style

1 Click Home tab ➤ Annotation panel ➤ Text Style. 

2 In the Text Style dialog box, select a style from the Style Name list.

3 Under Font, enter the text height (in drawing units) in the Height box.

4 To update existing text that uses this text style, click Apply.

5 Click Close.

Toolbar: Styles  
Command entry: STYLE

Quick Reference

Commands

STYLE

Creates, modifies, or specifies text styles.

System Variables

TEXTSIZE

Sets the default height for new text objects drawn with the current text style.

TEXTSTYLE

Sets the name of the current text style.
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Utilities

No entries

Command Modifiers

No entries

Set Text Obliquing Angle
The obliquing angle determines the forward or backward slant of the text.
The angle represents the offset from 90 degrees.

Entering a value between -85 and 85 makes the text oblique. A positive
obliquing angle slants text to the right. A negative obliquing angle slants text
to the left.

To set the obliquing angle in a text style

1 Click Home tab ➤ Annotation panel ➤ Text Style. 

2 In the Text Style dialog box, select a text style from the Style Name list.

3 Under Effects, enter an angle between -85 and 85 in the Oblique Angle
box.

A positive value slants text to the right. A negative value slants text to
the left.

4 To update existing text that uses this text style, click Apply.

5 Click Close.
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Toolbar: Styles  
Command entry: STYLE

Quick Reference

Commands

STYLE

Creates, modifies, or specifies text styles.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set Horizontal or Vertical Text Orientation
Text can be vertical or horizontal. Text can have a vertical orientation only if
the associated font supports dual orientation.

Lines of text are oriented to be vertical or horizontal. Text can have a vertical
orientation only if the associated font supports dual orientation. You can
create more than one line of vertical text. Each successive text line is drawn
to the right of the preceding line. The normal rotation angle for vertical text
is 270 degrees.
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NOTE Vertical orientation is not supported for TrueType fonts and symbols.

Vertical Text for Asian Languages

■ SHX fonts. Text can be created with SHX fonts and Big Fonts for vertical
display in the same way as for previous releases. For best results, use the
single-line TEXT command, not MTEXT. You can select a vertical style in
the Text Style dialog box.

■ TrueType fonts. You still select fonts starting with the @ sign, but now the
text is automatically rotated 270 degrees. (In AutoCAD 2005 and earlier
versions, you had to manually rotate this text.) Vertical cursor movement
is now supported for vertical text.

To set vertical orientation in a text style

1 Click Home tab ➤ Annotation panel ➤ Text Style. 

2 In the Text Style dialog box, select a text style from the Style Name list.

3 Under Effects, select Vertical.

4 To update existing text that uses this text style, click Apply.

5 Click Close.

Toolbar: Styles  
Command entry: STYLE
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Quick Reference

Commands

STYLE

Creates, modifies, or specifies text styles.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Change Text
You can change text content, formatting, and properties such as scale and
justification.

Overview of Changing Text
Text, whether created with TEXT, MTEXT, or MLEADER can be modified like
any other object.

You can move, rotate, erase, and copy it. You can change text properties in
the Properties palette.

You can also edit the contents of existing text and create a mirror image of
it. The MIRRTEXT system variable controls whether text is also reversed when
you mirror objects in your drawing. The procedures for modifying text vary
slightly, depending on how the text was created.
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Quick Reference

Commands

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

FIND

Finds the text that you specify, and can optionally replace it with other text.

PROPERTIES

Controls properties of existing objects.

System Variables

MIRRTEXT

Controls how the MIRROR command reflects text.

TEXTFILL

Controls the filling of TrueType fonts while plotting and rendering.

TEXTQLTY

Sets the resolution tessellation fineness of text outlines.

Utilities

No entries

Command Modifiers

No entries

Change Single-Line Text
You can change the contents, formatting and properties of single-line text.

You can change single-line text with DDEDIT and PROPERTIES. Use DDEDIT
when you need to change only the content of the text, not the formatting or
properties of the text object. Use PROPERTIES when you want to change
content, text style, location, orientation, size, justification, and other
properties.
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Text objects also have grips for moving, scaling, and rotating. A text object
has grips at the lower-left corner of the baseline and at the alignment point.

The effect of a command depends on which grip you choose.

To edit single-line text

1 Click Modify menu  ➤ Object  ➤ Text  ➤ Edit.

2 Select a single-line text object.

3 In the in-place editor, enter the new text.

4 Press ENTER.

5 Select another text object to edit, or press ENTER to end the command.

Command entry: DDEDIT

To modify properties of single-line text objects

1 Select a single-line text object.

2 Right-click the selected object. Click Properties.

3 In the Properties palette, enter any new text, and then change formatting
and other properties as needed.

Toolbar: Standard  
Command entry: PROPERTIES
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Quick Reference

Commands

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

PROPERTIES

Controls properties of existing objects.

TEXT

Creates a single-line text object.

System Variables

DTEXTED

Specifies the user interface displayed for editing single-line text.

TEXTFILL

Controls the filling of TrueType fonts while plotting and rendering.

TEXTQLTY

Sets the resolution tessellation fineness of text outlines.

Utilities

No entries

Command Modifiers

No entries

Change Multiline Text
You can change the location and content of multiline text objects with the
Properties palette, the In-Place Text Editor, and grips.

After you create multiline text, you can use the Properties palette to change

■ Text style assignment

■ Justification
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■ Width

■ Rotation

■ Line spacing

In addition, you can use either the MTEXT ribbon contextual tab (if the ribbon
is active) or the In-Place Text Editor (if the ribbon is not active) to modify
individual formatting, such as boldface and underlining, and to change the
width of the multiline text object.

Change Text Location

You can use grips to move multiline text or to resize the line width. A multiline
text object has grips at the four corners of the text boundary and, in some
cases, at the justification point.

If you use the Properties palette to move multiline text, you can edit content
and change properties at the same time.

Commands such as DIMLINEAR or LEADER create multiline text automatically
without requiring that a bounding box be specified; these objects have only
a single grip at the justification point.

When you need to align or move multiline text objects, you can use the Node
and Insertion object snaps for precision. If the OSNAPNODELEGACY system
variable is set to 0, the Node object snap ignores multiline text.

See also:

■ Work with Text Styles on page 1544

■ Control the Display of Polylines, Hatches, Gradient Fills, Lineweights, and
Text on page 623

To change multiline text

1 Select a multiline text object.

2 Right-click the selected object. Click Properties.

3 In the Properties palette, enter any new text and change formatting and
other settings as needed.

Toolbar: Standard  
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Command entry: PROPERTIES

To change the width of a multiline text object

1 Double-click the multiline text object.

2 In the In-Place Text Editor, use one of the following methods:

■ Move the cursor over the right end of the ruler until the cursor changes
to a double arrow. As you drag to the right to stretch the ruler, a tooltip
displays the width. Release to set a new width.

■ Right-click the bottom of the ruler. Click Set Mtext Width. In the
dialog box, enter the width in drawing units.

3 To save your changes and exit the editor, use one of the following
methods:

■ On the MTEXT ribbon contextual tab, in the Close panel, click Close
Text Editor.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

Quick Reference

Commands

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

FIND

Finds the text that you specify, and can optionally replace it with other text.

MTEDIT

Edits multiline text.

PROPERTIES

Controls properties of existing objects.

STYLE

Creates, modifies, or specifies text styles.
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System Variables

CENTERMT

Controls how grips stretch multiline text that is centered horizontally.

MIRRTEXT

Controls how the MIRROR command reflects text.

MTEXTED

Sets the application for editing multiline text objects.

OSNAPNODELEGACY

Controls whether the Node object snap can be used to snap to multiline text
objects.

TEXTFILL

Controls the filling of TrueType fonts while plotting and rendering.

TEXTQLTY

Sets the resolution tessellation fineness of text outlines.

Utilities

No entries

Command Modifiers

No entries

Find and Replace Text
You can easily find and replace text with the FIND command

To search for and replace text, use FIND. Replacement is based on text content
only; character formatting and text properties are not changed.

When searching for text in a 3D environment, the viewport will temporarily
change to a 2D viewport so that text isn’t blocked by 3D objects in your
drawing.

With FIND, you can use wild-card characters in your search.

DefinitionCharacter

Matches any numeric digit# (Pound)
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DefinitionCharacter

Matches any alphabetic character@ (At)

Matches any nonalphanumeric character. (Period)

Matches any string and can be used anywhere in the search
string

* (Asterisk)

Matches any single character; for example, ?BC matches ABC,
3BC, and so on

? (Question mark)

Matches anything but the pattern; for example; ~*AB*matches
all strings that don't contain AB

~ (Tilde)

Matches any one of the characters enclosed; for example,
[AB]C matches AC and BC

[ ]

Matches any character not enclosed; for example, [~AB]C
matches XC but not AC

[~]

Specifies a range for a single character; for example, [A-G]C
matches AC, BC, and so on to GC, but not HC

[-]

Reads the next character literally; for example, ̀ ~AB matches
~AB

` (Reverse quote)

To search for drawing files that contain a specific word or phrase, use the
Search tool in Microsoft® Windows® . You can use the Search tool to find all
textual data except text in tables and fields, and xrefs within drawing files.

To find specified text in a drawing

1 Click Annotate tab  ➤  Text panel  ➤  Find Text.

2 In Find What, enter the text you want to find.

3 In Find Where, specify the parts of the drawing to search, or click the
Select Objects button to select one or more text objects.

4 Click the Expand Find Options button to specify search options and text
types for the specified text.
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5 Click Find.

6 Use one of the following options to view the results of your search:

■ To list all results in a table, click the List Results check box.

■ To zoom to and highlight each result individually, leave the List
Results check box unchecked.

7 Click Close.

Toolbar: Text Formatting 
Command entry: FIND
Menu: Click Edit ➤ Find.

To replace text using the Find and Replace Dialog box

1 Click Annotate tab  ➤  Text panel  ➤  Find Text.

2 In Find What, enter the text you want to find.

3 In Find Where, specify the parts of the drawing to search, or click the
Select Objects button to select one or more text objects.

4 Click the Expand Find Options button to specify search options and text
types for the specified text.

5 In Replace With, enter the text with which you want to replace the found
text.

6 Click Find.

7 Use one of the following options to view the results of your search:

■ To list all results in a table, click the List Results check box.

■ To zoom to and highlight each result individually, leave the List
Results check box unchecked.

8 Use one of the following methods to replace text:

■ To replace only the found instance of the text string, click Replace.

■ To replace all instances of the text in Find Text String, click Replace
All.
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■ If search results have been listed in a table using the List Results
option, then you can select certain results in the list by pressing Click
+ CTRL. Alternately, you can select a range of results in the list by
pressing Shift + Click.

9 Click Close.

Toolbar: Text Formatting 
Command entry: FIND

Change Text Scale and Justification
Several commands are available for changing the scale of one or more text
and attribute objects, or their insertion points, simultaneously without
changing the location of the objects.

You can change the scale of one or more text objects, attributes, and attribute
definitions, or their insertion points, simultaneously without changing the
location of the objects.

Change the Scale of Multiple Text Objects

A drawing may contain hundreds of text objects that need to be scaled, and
it would be tedious to scale them individually. Use SCALETEXT to change the
scale of one or more text objects such as text, multiline text, and attributes.
You can specify a relative scale factor or an absolute text height, or you can
scale selected text to match the height of existing text. Each text object is
scaled using the same scale factor, and it maintains its current location.

Convert Text Height Between Model Space and Paper Space

The SPACETRANS command calculates equivalent lengths between model
space units and paper space units. By using SPACETRANS transparently, you
can provide commands with distance or length values relative to another
space. For example, you may want to create a text object in model space that
matches the height of other text in a layout. From model space, you could
enter

Command: text
Specify start point of text or [Justify/Style]: 1,3
Specify height <0.375>: 'spacetrans
>>Specify paper space distance <1.000>: 3/8
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Resuming TEXT command
Specify height <0.375>: 1.173

When the command is complete, a text object is created in model space with
a height of 1.173, which appears as 3/8 when viewed from a layout.

NOTE The SPACETRANS command is not available from the Model tab or in a
perspective view.

For more information about entering commands transparently, see Enter
Commands on the Command Line on page 39.

Change the Justification of Text Objects Without Changing Their Location

Use JUSTIFYTEXT to redefine the insertion point of text without moving the
text. For example, a table or schedule may contain text that is located correctly
but each text object in the table should be right-justified instead of left-justified
for future entries or modifications.

To scale multiline text objects without changing their locations

1 Click Annotate tab ➤ Text panel ➤ Scale. 

2 Select one or more multiline text objects and press ENTER.

3 Specify one of the justification options or press ENTER to accept the
existing text justifications.

4 Enter s and enter the scale factor to be applied to each mtxt object.

Command entry: SCALETEXT

Quick Reference

Commands

JUSTIFYTEXT

Changes the justification point of selected text objects without changing
their locations.

PROPERTIES

Controls properties of existing objects.
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SCALETEXT

Enlarges or reduces selected text objects without changing their locations.

SPACETRANS

Calculates equivalent model space and paper space lengths in a layout.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Check Spelling
You can check the spelling of all text as it is entered in your drawing. You can
also specify the specific language dictionary that is used and customize and
manage multiple custom spelling dictionaries.

You can check the spelling of all text objects in your drawing, including

■ Single and multiline text

■ Dimension text

■ Multileader text

■ Text within block attributes

■ Text within xrefs

With Check Spelling, your drawing or the areas of your drawing’s text that
you specify are searched for misspelled words. If a misspelled word is identified,
the word is highlighted and the drawing area zooms to that word in a scale
that is easy to read.
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Check Spelling As You Type

By default, you can check spelling as you enter text in the In-Place Text Editor.
Any word you enter is checked for spelling errors when it is completed. A
word is considered completed when one of the following actions are taken:

■ Pressing SPACEBAR or ENTER

■ Moving the cursor to another position within the In-Place Text Editor.

Misspelled words are underlined
with a red dotted line

Any word not found in the current dictionary is underlined as misspelled.
Spelling suggestions are displayed when you right-click the underlined word.

Switch Dictionaries

The Check Spelling feature contains several main dictionaries, which are
available in different languages. You can also create any number of custom
dictionaries and switch between them as needed.

During a spelling check, the words in the drawing are matched to the words
in the current main dictionary. Any words you add are stored in the custom
dictionary that is current at the time of the spelling check. For example, you
can add proper names so they are no longer identified as misspelled words.

NOTE By default AutoCAD provides you with one sample custom dictionary that
contains words such as AutoCAD and Autodesk.

To check spelling in another language, change to a different main dictionary.

You can change dictionaries in the Dictionaries dialog box or by specifying
the dictionary name in the DCTMAIN or DCTCUST system variable. For a list
of the main dictionary file names, see DCTMAIN.

NOTE  The filename for a custom dictionary cannot use any non-current code
page characters in its name. If you are sharing a custom dictionary between
different locals or languages do not use non-ASCII characters.
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Create and Edit Custom Dictionaries

A custom dictionary is a list of spelling exceptions that you have identified.
The files that contain them have a .cus file extension. You can use any ASCII
text editor to add or delete words, or combine several dictionaries.

To check spelling

1 Click Annotate tab ➤ Text panel ➤ Check Spelling. 

2 Click an option of where you want to check. Click Start. If no misspelled
words are found, a message is displayed. If a misspelling is found, the
Check Spelling dialog box identifies the misspelled word. The word is
highlighted and zoomed to in the drawing area.

3 Do one of the following:

■ To correct a word, select an alternate word from the Suggestions list
or type a word in the Suggestions box. Click Change or Change All.

■ To leave a word unchanged, click Ignore or Ignore All.

■ To leave a word unchanged and add it to the dictionary, click Add to
Dictionary.

4 Repeat step 3 for each misspelled word. Click Close to exit.

NOTE Click Undo to reverse the preceding Check Spelling action or series of
actions in the Check Spelling dialog box.

Toolbar: Text 
Command entry: SPELL

To check spelling in a block attribute

1 Click Annotate tab ➤ Text panel ➤ Check Spelling. 

2 In the Check Spelling dialog box, click Settings.

3 In the Check Spelling Settings dialog box, click Block Attributes. Click
OK.
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4 In the Check Spelling dialog box, click Start.

5 Do one of the following:

■ To correct a word, select an alternate word from the Suggestions list
or type a word in the Suggestions box. Click Change or Change All.

■ To leave a word unchanged, click Ignore or Ignore All.

■ To leave a word unchanged and add it to the dictionary, click Add to
Dictionary.

6 Repeat step 5 for each misspelled word. Click Close to exit.

Toolbar: Text 
Command entry: SPELL

To switch dictionaries while checking spelling

1 Click Annotate tab ➤ Text panel ➤ Check Spelling. 

2 In the Check Spelling dialog box, click Dictionaries.

3 Do one of the following:

■ To change the main dictionary, select a dictionary from the Current
Main Dictionary list.

■ To change the custom dictionary, select a dictionary under Current
Custom Dictionary.

4 Click Close.

Command entry: SPELL

To add a custom dictionary or word list

1 Click Annotate tab ➤ Text panel ➤ Check Spelling. 

2 In the Check Spelling dialog box, click Dictionaries.

3 In the Dictionaries dialog box, in the Current Custom dictionary list,
select Manage Custom Dictionaries.
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4 In the Custom Dictionaries list, click Add and browse to the dictionary’s
location. To create a new custom dictionary, click New and enter the
dictionary’s name. The name must contain the .cus extension.

5 Click OK. The newly selected dictionary is highlighted as the current
custom dictionary.

6 If you would like to import a word list into your custom dictionary, click
Import.

7 Click OK.

Command entry: SPELL

Quick Reference

Commands

SPELL

Checks spelling in a drawing.

System Variables

DCTCUST

Displays the path and file name of the current custom spelling dictionary.

DCTMAIN

Displays the three letter keyword for the current main spelling dictionary.

Utilities

No entries

Command Modifiers

No entries

Use an Alternate Text Editor
The default text editor is either the MTEXT ribbon contextual tab (if the ribbon
is active) or the In-Place Text Editor (if the ribbon is not active), but you can
elect to use any alternate editor that saves files in ASCII format.
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Overview of Using an Alternate Text Editor
You can use any text editor, such as Microsoft Notepad, that saves files in
ASCII format.

You can elect to use an alternate editor by specifying the editor with the
MTEXTED system variable.

If you use an alternate text editor for multiline text, you specify the properties
of the multiline text object at the Command prompt first. Then the text editor
opens for entering text. When you close the text editor, the text is inserted
within the width limit you specified.

If you use an alternate editor, you must enter special codes to apply formatting.

To edit text using an alternate text editor, use the same format codes. To avoid
losing format information when you make changes to the text, use the same
text editor you used to create the text.

Quick Reference

Commands

MTEXT

Creates a multiline text object.

OPTIONS

Customizes the program settings.

System Variables

MTEXTED

Sets the application for editing multiline text objects.
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Utilities

No entries

Command Modifiers

No entries

Format Multiline Text in an Alternate Text Editor
If you use an alternate text editor, you apply formatting by entering format
codes.

You can underline text, add a line over text, and create stacked text. You can
also change color, font, and text height. You can change the spaces between
text characters or increase the width of the characters themselves. To apply
formatting, use the format codes shown in the following table.

Format codes for paragraphs

To produce this …Enter this …PurposeFormat code

Autodesk \OAutoCAD\oTurns overline on
and off

\0...\o

Autodesk \LAutoCAD\lTurns underline on
and off

\L...\l

Autodesk AutoCAD\~LTInserts a nonbreaking
space

\~

Autodesk \\AutoCADInserts a backslash\\

Autodesk \{AutoCAD\}Inserts an opening and
closing brace

\{...\}

Autodesk \C2;AutoCADChanges to the
specified color

\Cvalue;

Autodesk \Ftimes; AutoCADChanges to the
specified font file

\File name;
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Format codes for paragraphs

To produce this …Enter this …PurposeFormat code

Autodesk \H2;AutoCADChanges to the text
height specified in
drawing units

\Hvalue;

Autodesk \H3x;AutoCADChanges the text height
to a multiple of the
current text height

\Hvaluex;

1.000\S+0.010^-0.000;Stacks the subsequent
text at the /, #, or ^ sym-
bol

\S...^...;

\T2;AutodeskAdjusts the space between
characters. Valid values

\Tvalue;

range from a minimum of
.75 to 4 times the original
spacing between charac-
ters.

\Q20;AutodeskChanges obliquing angle\Qangle;

\W2;AutodeskChanges width factor to
produce wide text

\Wvalue;

\A1;1\S1/2Sets the alignment value;
valid values: 0, 1, 2
(bottom, center, top)

\A

Autodesk\PAutoCADEnds paragraph\P

Braces can be nested up to eight levels deep.
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You can also use control codes to add special characters, such as tolerance or
dimensioning symbols. See MTEXT.

Example: Formatting Text in an Alternate Text Editor

This example describes how the text in the following illustration was created.

Each line below was entered in an alternate text editor:

{{\H1.5x; Big text} \A2; over text\A1;/\A0; under text}\P

{\A0;Baseline: 1 \S1/2;}\P

{\A1;Center: 1 \S1/2;}\P

{\A2;Topline: 1 \S1/2;}\P

{Tolerances: \A1;1.000\H.75x;\S+0.010^-0.000;}\P

{Architectural: 9-{\H.666x;\A2;11\A1;/\A0;16}\A2;"}\P

To specify an alternate text editor

1 At the Command prompt, enter mtexted.

2 At the prompt do one of the following:

■ Enter the path and name of the executable file for the ASCII text editor
that you want to use to create or edit multiline text.

■ Enter internal to restore the text editor.
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To create multiline text in an alternate text editor

1 To specify a text editor, at the Command prompt, enter mtexted. Then
enter the path of the editor you want to use.

2 Click Home tab ➤ Annotation panel ➤ Multiline Text. 

3 Specify the first corner of the multiline text boundary rectangle.

4 Specify the opposite corner of the multiline text boundary rectangle.

5 In the text editor, enter the text. Enter \P to end a paragraph and start a
new paragraph on the next line. (Be sure to capitalize the P.)

6 When your text entry is complete, save the changes and exit the text
editor.

Toolbar: Draw  
Command entry: MTEXT

Quick Reference

Commands

MTEXT

Creates a multiline text object.

OPTIONS

Customizes the program settings.

System Variables

MTEXTED

Sets the application for editing multiline text objects.

Utilities

No entries

Command Modifiers

No entries
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Tables

A table is a rectangular array of cells that contain annotation, primarily text but also blocks.
Tables appear in many different forms on many of the sheets that make up drawing sets. In
the AEC industry, tables are often referred to as “schedules” and contain information about
the materials needed for the construction of the building being designed. In the manufacturing
industry, they are often referred to as “BOM” (bills of materials).

The table object creates a table of any size that can be used for any purpose, including as a
list or index to a set of drawing sheets to be published.

Create and Modify Tables
A table is an object that contains data in rows and columns. A table object can
be created from an empty table or table style. A table can also be linked to data
in a Microsoft Excel spreadsheet.

After the table has been created, you can click any gridline on the table to select
it and then modify it by using the Properties palette or grips.

26
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When you change the height or width of the table, only the row on page 1949
or column on page 1928 adjacent to the grip you have selected will change. The
table will maintain its height or width. To change the size of the table
proportionally to the size of the row or column you are editing, press CTRL
while using a column grip.

Break Tables into Multiple Parts

A table with a large amount of data can be broken into primary and secondary
table fragments. Use the table breaking grips found at the bottom of your table
to make a table span multiple columns in your drawing or to manipulate the
different table parts you have already created.

Modify a Table Cell

You can click inside a cell to select it. Grips are displayed in the middle of the
cell borders. Click inside another cell to move selection to that cell. Drag the
grips on a cell to make the cell and its column or row larger or smaller.

NOTE When a cell is selected, press F2 to edit the cell text.
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To select more than one cell, click and drag over several cells. You can also
hold down SHIFT and click inside another cell to select those two cells and
all the cells between them.

When you click inside a table cell when the ribbon is active, the Table ribbon
contextual tab is displayed. If the ribbon is not active, the Table toolbar is
displayed. From here, you can

■ Edit rows and columns

■ Merge and unmerge cells

■ Alter the appearance of cell borders

■ Edit data formatting and alignment

■ Lock and unlock cells from editing

■ Insert blocks, fields, and formulas

■ Create and edit cell styles

■ Link the table to external data

With a cell selected, you can also right-click and use the options on the
shortcut menu to insert or delete columns and rows, combine adjacent cells,
or make other changes. When cells are selected, you can use CTRL+Y to repeat
the last action.

NOTE Using CTRL+Y to repeat the last action only repeats actions executed through
the shortcut menu, the Table ribbon contextual tab, or the Table toolbar.

Add a Table to a Tool Palette

When you add a table to a tool palette, the table properties (for example, table
style and number of rows and columns) and the cell property overrides (for
example, alignment and border lineweight) are stored in the tool definition.
The text, block content, and character formatting are also stored in the tool
definition.

Customize Display of Column Letters and Row Numbers

By default, the In-Place Text Editor displays column letters and row numbers
when a table cell is selected for editing. Use the TABLEINDICATOR system
variable to turn this display on and off. To set a new background color, select
a table, right-click, and click Table Indicator Color on the shortcut menu. The
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text color, size, and style and the line color are controlled by the settings for
column heads in the current table style.

See also:

■ Add Text and Blocks to Tables on page 1606

To create an empty table

1 Click Home tab ➤ Annotation panel ➤ Insert Table. 

2 In the Insert Table dialog box, select a table style from the list, or click
the button to the right of the drop-down menu to create a new table
style.

3 Click Start from Empty Table.

4 Insert the table in the drawing by doing one of the following:

■ Specify an insertion point for the table.

■ Specify a window for the table.

5 Set the number of columns and the column width.

If you used the window insertion method, you can select the number of
columns or the column width, but not both.

6 Set the number of rows and the row height.

If you used the window insertion method, the number of rows is
determined by the size of the window you specified and the row height.

7 Click OK.

Command entry: TABLE

To create a table from a linked spreadsheet

1 Click Home tab ➤ Annotation panel ➤ Insert Table. 

2 Click From a Data Link

3 Select an established data link from the drop-down menu, or click the
[...] button to create a new data link using the Data Link Manager.
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4 Click OK to specify an insertion point in the drawing for the table.

Command entry: TABLE

To create a table from a data extraction

1 Click Insert tab  ➤  Linking & Extraction panel ➤  Extract Data.

2 In the Data Extraction wizard, on the Begin page, click Create a New Data
Extraction. If you want to use a template (DXE or BLK) file, click Use
Previous Extraction as a Template. Click Next.

3 In the Save Data Extraction As dialog box, specify a file name for the data
extraction file. Click Save.

4 On the Define Data Source page, specify the drawings or folders from
which to extract data. Click Next.

5 On the Select Objects page, select the objects from which to extract data.
Click Next.

6 On the Select Properties page, select the properties from which to extract
data. Click Next.

7 On the Refine Data page, organize the columns if necessary. Click Next.

8 On the Choose Output page, click Insert Data Extraction Table into
Drawing to create a data extraction table. Click Next.

9 On the Table Styles page, choose a table style if one is defined in the
current drawing, or table if defined in a table style. Enter a title for the
table if necessary. Click Next.

10 In the Finish page, click Finish.

11 Click an insertion point in the drawing to create the table.

Toolbar: Modify II 
Command entry: DATAEXTRACTION
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To create a tool from a table in the current drawing

1 In the current drawing, select the table.

2 Using the right mouse button, drag the table to a tool palette and, without
releasing the mouse button, move the cursor to the place on the tool
palette where you want the tool.

You can switch to a different tab by hovering over the tab for a few
seconds. The black line indicates where the tool will be located.

3 Release the mouse button.

NOTE All formatting, table properties, and cell properties are saved in the
tool palette tool, as well as text and block content.

Toolbar: Standard 
Command entry: TOOLPALETTES

To lock and unlock cells

1 Select one or more cells in a table that you want to lock or unlock using
one of the following methods:

■ Click inside a cell.

■ Hold down SHIFT and click inside another cell to select those two
cells and all the cells between them.

■ Click inside the selected cell, drag to the cells you want to select, and
release.

2 Use one of the following options:

■ To unlock a cell or cells. On the Table ribbon contextual tab or Table
toolbar, click Locking  ➤  Unlocked

■ To lock a cell or cells. On the Table ribbon contextual tab or Table
toolbar, click Locking  ➤  Data and Format Locked

Command entry: TABLEDIT
Shortcut menu: Select and right-click a cell or range of cells. Click Locking.
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To use grips to modify a table

1 Click a gridline to select the table.

2 Use one of the following grips:

■ Upper-left grip. Moves the table.

■ Upper-right grip. Changes the width of the table and all columns
proportionally.

■ Lower-left grip. Changes the height of the table and all rows
proportionally.

■ Lower-right grip. Changes both the height and the width of the table
and changes the columns and rows proportionally.

■ Column grip (at the top of the column head row). Widens or narrows
adjacent columns without changing the width of the table.

■ CTRL+ a column grip. Changes the width of the column to the left of
the grip and widens or narrows the table to accommodate the change.

The minimum column width is the width of a single character. The
minimum row height for an empty table is the height of a line of text
plus the cell margins.

3 Press ESC to remove selection.

To use grips to modify cells in a table

1 Select one or more cells in a table that you want to change using one of
the following methods:

■ Click inside a cell.

■ Hold down SHIFT and click inside another cell to select those two
cells and all the cells between them.

■ Click inside the selected cell, drag to the cells you want to select, and
release.

2 To change the row height of the selected cell, drag the top or bottom
grip.

If more than one cell is selected, the row height changes equally for each
row.

3 To change the column width of the selected cell, drag the left or right
grip.
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If more than one cell is selected, the column width changes equally for
each column.

4 To merge selected cells, click Merge Cells on either the Table ribbon
contextual tab or Table toolbar.

If cells in more than one row or column are selected, you can merge by
row or by column.

5 Press ESC to remove selection.

To use the Properties palette to modify a table

1 Click a gridline to select the table.

2 Click View tab  ➤  Palettes panel  ➤  Properties.

3 In the Properties palette, click the value you want to change and enter
or select a new value.

The property is changed in the selected table.

4 Move the cursor outside the Properties palette, and press ESC to remove
selection.

Toolbar: Properties 
Command entry: PROPERTIES

Shortcut menu: Select and right-click a cell or range of cells. Click Properties.

To break a table into multiple parts using grips

1 Click a gridline to select the table.

2 Click the triangular grip at the bottom center gridline of the table.

■ When the triangle is pointed down, then table breaking is inactive.
New rows will be added to the bottom of the table.

■ When the triangle is pointed up, then table breaking is active. The
current position of the bottom of the table is the maximum height
of the table. Any new rows will be added to a second table part to the
right of the master table part.
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To change column width or row height in a table

1 Click inside a table cell in the column or row you want to change.

Hold down SHIFT and click inside another cell to select those two cells
and all the cells between them.

2 Right-click. Click Properties.

3 In the Properties palette, under Cell, click the cell width or the cell height
value and enter a new value.

4 Press ESC to remove selection.

To add columns or rows to a table

1 Click inside a table cell where you want to add a column or a row.

You can select more than one cell to add more than one column or row.

2 On either the Table ribbon contextual tab or Table toolbar, select one of
the following options:

■ Insert Row Above. Inserts a row above the selected cell.

■ Insert Row Below. Inserts a row below the selected cell.

■ Insert Column Left. Inserts a column to the left of the selected cell.

■ Insert Column Right. Inserts a column to the right of the selected cell.

NOTE The cell style of the new column or row will be the same as that of
the originally selected column or row. To change the cell style, right-click the
cell or cells and click Cell Style.

3 Press ESC to remove selection.

Shortcut menu: Select and right-click a cell or range of cells. Click Rows or
Columns and select an insertion method.

To merge cells in a table

1 Select the cells in a table that you want to merge using one of the
following methods:

■ Select a cell, and hold down SHIFT and click inside another cell to
select those two cells and all the cells between them.
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■ Click inside a selected cell, drag to the cells you want to select, and
release.

The resulting merged cell must be rectangular.

2 Click Merge Cells on either the Table ribbon contextual tab or Table
toolbar. If you want to create more than one merged cell, use one of the
following options:

■ All: Merges all cells in a rectangular selected range.

■ By Row: Merges the cells horizontally by removing the vertical
gridlines and leaving the horizontal gridlines intact.

■ By Column: Merges the cells vertically by removing the horizontal
gridlines and leaving the vertical gridlines intact.

3 Start typing to enter text in the new merged cell, or press ESC to remove
selection.

Shortcut menu: Select and right-click a cell or range of cells. Click Merge
and select a merging method.

To delete columns or rows in a table

1 Click inside a table cell in the column or row that you want to delete.

Hold down SHIFT and click inside another cell to select those two cells
and all the cells between them.

2 To delete rows, select Delete Rows on either the Table ribbon contextual
tab or the Table toolbar. To delete columns, select Delete Columns on
either the Table ribbon contextual tab or the Table toolbar.

NOTE Rows and columns that contain a portion of a data link cannot be
deleted.

3 Press ESC to remove selection.

Shortcut menu: Select and right-click a cell or range of cells. Click Columns
 ➤ Delete, or Rows  ➤ Delete.

1592 | Chapter 26   Tables



Quick Reference

Commands

FIELD

Creates a multiline text object with a field that can be updated automatically
as the field value changes.

FIND

Finds the text that you specify, and can optionally replace it with other text.

INSERT

Inserts a block or drawing into the current drawing.

LIST

Displays property data for selected objects.

MTEXT

Creates a multiline text object.

SPELL

Checks spelling in a drawing.

TABLE

Creates an empty table object.

TABLEDIT

Edits text in a table cell.

TABLEEXPORT

Exports data from a table object in CSV file format.

TABLESTYLE

Creates, modifies, or specifies table styles.

UPDATEFIELD

Manually updates fields in selected objects in the drawing.

System Variables

CTABLESTYLE

Sets the name of the current table style.
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FIELDDISPLAY

Controls whether fields are displayed with a gray background.

FIELDEVAL

Controls how fields are updated.

TABLETOOLBAR

Controls the display of the Table toolbar.

Utilities

No entries

Command Modifiers

No entries

Link a Table to External Data
A table can be linked to data in a Microsoft Excel (XLS, .XLSX, or CSV) file.
You can link to an entire spreadsheet, individual row, column, cell, or cell
range in Excel.

NOTE Microsoft Excel must be installed to use Microsoft Excel data links. To link
to the XLSX filetype, Microsoft Excel 2007 must be installed.

You can bring data from Microsoft Excel into a table in the following three
ways:

■ As formulas with supported data formats attached.

■ As calculated data from formulas calculated in Excel (supported data formats
not attached).

■ As calculated data from formulas calculated in Excel (with data formats
attached).

A table that contains data links displays indicators around linked cells. If you
hover your mouse cursor over the data link, information about the data link
is displayed.
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If a linked spreadsheet has been changed, such as adding a row or column,
the table in your drawing can be updated accordingly using the
DATALINKUPDATEcommand. Likewise, if a change is made to a table in your
drawing, then you can update the linked spreadsheet using the same command.

By default, a data link is locked from editing to prevent undesired changes to
the linked spreadsheet. You can lock cells from data changes, format changes,
or both. To unlock a data link, click Locking on either the Table ribbon
contextual tab or the Table toolbar.

See also:

■ Extract Data from Drawings and Spreadsheets
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To link to a table in an external spreadsheet

1 Click Annotate tab ➤ Tables panel ➤ Data Link. 

2 In the Data Link Manager tree view, click Create a New Excel Data Link.

3 In the Enter Data Link Name dialog box, enter a name for the data link.
Click OK.

4 Click the [...] button to browse for the XLS or CSV file to be linked to.

NOTE To link to the XLSX filetype, Microsoft Excel 2007 must be installed.

5 In the New Excel Data Link dialog box, select a link option (whole sheet,
range, or Excel named range). Click OK.

6 Select the new data link in the Data Link Manager tree view. Click OK.

Command entry: DATALINK

To remove a link to an external spreadsheet

1 Click inside a cell within the data linked table to select the cell.

2 Right-click and click Data Links  ➤  Detach Data Link.

Command entry: DATALINK

To set up a named range in Microsoft Excel

1 In Microsoft Excel, open the workbook or spreadsheet that you want to
access.

2 Select a range of cells to function as a linked range.

3 In the Name Box, enter a name for the range of cells, then press ENTER.

4 Repeat steps 2 and 3, if desired, to specify additional linked ranges.

5 On the File menu (Microsoft Excel), choose Save.

To link a table to a named range in Microsoft Excel

1 In your table, select the table cells to link.
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2 On either the Table ribbon contextual tab or Table toolbar, click Link
Cell.

3 In the Data Link Manager tree view, select Click to Create a New Excel
Data Link.

4 In the Enter Data Link Name dialog box, enter a name for the data link.
Click OK.

5 Click the [...] button to browse for the XLS or CSV file to link.

6 In the New Excel Data Link dialog box, select Link to a Named Range.
Click OK.

7 Select the new data link in the Data Link Manager tree view. Click OK.

Command entry: DATALINK

To link a table to cells in Microsoft Excel

1 In your table, select the table cells to link.

2 On the Table toolbar, click Link Cell.

3 In the Data Link Manager tree view, select Click to Create a New Excel
Data Link.

4 In the Enter Data Link Name dialog box, enter a name for the data link.
Click OK.

5 Click the [...] button to browse for the .xls or .csv file to be linked to.

6 In the New Excel Data Link dialog box, select Link to Range. Enter a valid
range from the Excel spreadsheet (for example, A1:D17). Click OK.

7 Select the new data link in the Data Link Manager tree view. Click OK.

Command entry: DATALINK

To update changed data between a drawing and Microsoft Excel

1 Click Annotate tab ➤ Tables panel ➤ Data Link. 

2 On the Data Link flyout, click Update Data Links.

Command entry: DATALINK
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To open an external spreadsheet from a data link

1 Select any cell in the linked table or range of linked cells.

2 Right-click and click Data Links  ➤  Open Data Link File.

Quick Reference

Commands

DATALINK

The Data Link dialog box is displayed.

DATALINKUPDATE

Updates data to or from an established external data link.

System Variables

DATALINKNOTIFY

Controls the notification for updated or missing data links.

Utilities

No entries

Command Modifiers

No entries

Work with Table Styles
The appearance of the table is controlled by its table style. You can use the
default table style, STANDARD, or create your own table styles.

When you create a new table style, you can specify a starting table. A starting
table is a table in your drawing that is used as an example for formatting the
new table style. Once a table is selected, you can specify the structure and
contents to copy from that table to the table style.

Cell styles can be created and applied to a table style upon insertion of a new
table. A table style can specify different cell styles in each type of row to display
a different justification and appearance for the text and gridlines. These cell
styles are specified upon insertion of a table. The STANDARD table style, for
example, contains a cell style consisting of merged cells with text that is
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centered. This cell style, named Title, can be specified as the first row cell of
the table. This creates a title row at the top of the new table.

The table can read from top to bottom or from the bottom up. The number
of columns and rows is almost unlimited.

The border properties in a table’s cell style control the display of the gridlines
that divide the table into cells. The borders of the title row, the column heads
row, and the data rows can have different lineweight and color and can be
displayed or not displayed. The Cell Style preview image in the bottom right
corner of the Table Style dialog box updates as you select border options.

The appearance of text in the cells of the table is controlled by the text style
that is specified in the current cell style. You can use any text style in the
drawing or create a new one. You can also use DesignCenter to copy table
styles from other drawings.

You can define the data and formatting for any cell style within a table style.
You can also overwrite the data and formatting for specific cells. For example,
you could set the formatting for all column heading rows to display text in
uppercase, and then select a single table cell to display text in lowercase. The
type of data you display in a row and the formatting for that data type is
controlled by the formatting options you select in the Table Cell Format dialog
box.

See also:

■ Work with Text Styles on page 1544

To define or modify a table style

1 Click Home tab ➤ Annotation panel ➤ Table Style. 

2 In the Table Style dialog box, click New.

3 In the Create New Table Style dialog box, enter a name for the new table
style.

4 In the Start With drop-down list, select a table style to provide default
settings for the new table style. Click Continue

5 In the New Table Style dialog box, click the Select Table button to select
a table in your drawing to which to apply the new table style settings.
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6 In the Table Direction drop-down list, select Down or Up. Up creates a
table that reads from the bottom up; the title row and the column heads
are at the bottom of the table.

7 In the Cell Styles drop-down list, select a cell style to apply to the table,
or create a new cell style by clicking the button to the right of the
drop-down list.

8 On the General tab, select or clear the following options for the current
cell style:

■ Fill Color. Specifies the fill color. Select None or a background color,
or click Select Color to display the Select Color dialog box.

■ Alignment. Specifies an alignment for cell contents. Center refers to
horizontal alignment; Middle refers to vertical alignment.

■ Format. Sets the data type and formatting for rows in a table. Click
the [...] button to display the Table Cell Format dialog box, where you
can further define formatting options.

■ Type. Specifies the cell style as either a label or data, which is used
when inserting default text in a table style containing a starting table.
Also used when creating a table tool on the tool palette.

■ Margins - Horizontal. Sets the distance between the text or block in
the cell and the left and right cell borders.

■ Margins - Vertical. Sets the distance between the text or block in the
cell and the top and bottom cell borders.

■ Merge Cells on Row/Column Creation. Merges any new row or column
created with the current cell style into one cell.

9 On the Text tab, select or clear the following options for the current cell
style:

■ Text Style. Specifies the text style. Select a text style, or click the [...]
button to open the Text Style dialog box and create a new text style.

■ Text Height. Specifies the text height. Enter a height for the text. This
option is available only when the selected text style has a text height
of 0. (The default text style, STANDARD, has a 0 text height.) If the
selected text style specifies a fixed text height, this option is
unavailable.

■ Text Color. Specifies the text color. Select a color, or click Select Color
to display the Select Color dialog box.
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■ Text Angle. Sets the text angle. The default text angle is 0 degrees.
You can enter any angle between -359 and +359 degrees.

10 Use the Borders tab to control the appearance of the table gridlines for
the current cell style. Specify the following options:

■ Lineweight. Sets the lineweight to use for borders that are displayed.
If you use a heavy lineweight, you may have to change the cell margins
so that the text can be seen.

■ Linetype. Sets the linetype to apply to the borders you specify by
clicking a border button. Standard linetypes of ByBlock, ByLayer, and
Continuous are displayed, or you can choose Other to load a custom
linetype.

■ Color. Specifies a color to use for borders that are displayed. Click
Select Color to display the Select Color dialog box.

■ Double Line. Specifies that the selected borders have a double linetype.
Change the spacing between the lines by entering a value in the
Spacing box.

■ Border display buttons. Applies the selected border options. Click a
button to apply the selected border options to all borders of the cell,
the outside border, the inside borders, the bottom border, the left
border, the top border, the right border, or no borders. The preview
in the dialog box updates to show the effect.

11 Click OK.

Toolbar: Styles 
Command entry: TABLESTYLE

To define or modify a cell style

1 Click Home tab ➤ Annotation panel ➤ Table Style. 

2 Select the table style that contains the cell style you want to modify, or
click New to create a new table style.

3 In the Table Style dialog box, in the Cell Styles drop-down list, select a
cell style to modify, or create a new cell style by clicking the button to
the right of the drop-down list.
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4 On the General tab, select or clear the following options for the current
cell style:

■ Fill Color. Specifies the fill color. Select None or a background color,
or click Select Color to display the Select Color dialog box.

■ Alignment. Specifies an alignment for cell contents. Center refers to
horizontal alignment; Middle refers to vertical alignment.

■ Format. Set the data type and formatting for rows in a table. Click the
[...] button to display the Table Cell Format dialog box, where you
can further define formatting options.

■ Type. Specifies the cell style as either a label or data, which is used
when inserting default text in a table style containing a starting table.
Also used when creating a table tool on the tool palette.

■ Margins - Horizontal. Sets the distance between the text or block in
the cell and the left and right cell borders.

■ Margins - Vertical. Sets the distance between the text or block in the
cell and the top and bottom cell borders.

■ Merge Cells on Row/Column Creation. Merges any new row or column
created with the current cell style into one cell.

5 On the Text tab, select or clear the following options for the current cell
style:

■ Text Style. Specifies the text style. Select a text style, or click the [...]
button to open the Text Style dialog box and create a new text style.

■ Text Height. Specifies the text height. Enter a height for the text. This
option is available only when the selected text style has a text height
of 0. (The default text style, STANDARD, has a 0 text height.) If the
selected text style specifies a fixed text height, this option is
unavailable.

■ Text Color. Specifies the text color. Select a color, or click Select Color
to display the Select Color dialog box.

■ Text Angle. Sets the text angle. The default text angle is 0 degrees.
You can enter any angle between -359 and +359 degrees.
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6 Use the Borders tab to control the appearance of the table gridlines for
the current cell style. Specify the following options:

■ Lineweight. Sets the lineweight to use for borders that are displayed.
If you use a heavy lineweight, you may have to change the cell margins
so that the text can be seen.

■ Linetype. Sets the linetype to apply to the borders you specify by
clicking a border button. Standard linetypes of ByBlock, ByLayer, and
Continuous are displayed, or you can choose Other to load a custom
linetype.

■ Color. Specifies a color to use for borders that are displayed. Click
Select Color to display the Select Color dialog box.

■ Double Line. Specifies that the selected borders will have a double
linetype. Change the spacing between the lines by entering a value
in the Spacing box.

■ Border display buttons. Applies the selected border options. Click a
button to apply the selected border options to all borders of the cell,
the outside border, the inside borders, the bottom border, the left
border, the top border, the right border, or no borders. The preview
in the dialog box updates to show the effect.

7 Click OK.

Toolbar: Styles 
Command entry: TABLESTYLE

To create a table style from an existing table

1 Click a gridline to select the table.

2 Right-click and click Table Style  ➤  Save as New Table Style.

Toolbar: Styles 
Command entry: TABLESTYLE

To create a cell style from an existing cell

1 Click inside the cell to create a cell style from.
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2 Right-click and click Cell Style  ➤  Save as New Cell Style.

Toolbar: Styles 
Command entry: TABLESTYLE

To apply a new table style to a table

1 Click a gridline to select the table.

2 Right-click and select Table Style.

3 On the Table Style flyout, select a table style from the list.

The new table style is applied to the table.

NOTE If the previous table style had a title row and the new one does not,
the title text is placed in the first cell of the table, and the other cells in the
first row are left blank.

4 Press ESC twice to remove selection.

Toolbar: Styles 
Command entry: TABLESTYLE

To change the table style that is applied to new tables

1 Click Home tab ➤ Annotation panel ➤ Table Style. 

2 In the Table Style dialog box, select a table style. Click Set Current.

3 Click Close.

The current table style is applied to new tables that you create.

Toolbar: Styles 
Command entry: TABLESTYLE
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Quick Reference

Commands

FIND

Finds the text that you specify, and can optionally replace it with other text.

INSERT

Inserts a block or drawing into the current drawing.

LIST

Displays property data for selected objects.

MTEXT

Creates a multiline text object.

SPELL

Checks spelling in a drawing.

TABLE

Creates an empty table object.

TABLEDIT

Edits text in a table cell.

TABLEEXPORT

Exports data from a table object in CSV file format.

TABLESTYLE

Creates, modifies, or specifies table styles.

UPDATEFIELD

Manually updates fields in selected objects in the drawing.

System Variables

CTABLESTYLE

Sets the name of the current table style.

FIELDDISPLAY

Controls whether fields are displayed with a gray background.
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FIELDEVAL

Controls how fields are updated.

Utilities

No entries

Command Modifiers

No entries

Add Text and Blocks to Tables
Table cell data can include text and multiple blocks.

When a table is created, the first cell is highlighted, the Text Formatting toolbar
is displayed, and you can begin entering text. The row height of the cell
increases to accommodate the number of lines of text. To move to the next
cell, press TAB, or use the arrow keys to move left, right, up, and down. You
can quickly edit cell text by pressing F2 in a selected cell.

When you insert a block into a table cell, either the block can be automatically
fit to the size of the cell, or the cell can adjust to accommodate the size of the
block. Blocks can be inserted from the Table toolbar, or from the shortcut
menu. Multiple blocks can be inserted in a table cell. If there is more than
one block in a table cell, use the Manage Cell Content dialog box to customize
the way the cell content is displayed.

1606 | Chapter 26   Tables



Inside the cell, the arrow keys move the cursor. Use the Table toolbar and the
shortcut menu to format text, import text, or make other changes to the text
in the cell.

See also:

■ Use Fields in Text on page 1532

■ Create Multiline Text on page 1481

To enter text in a table

1 Click inside a table cell, and start to enter text.

The Text Formatting toolbar is displayed.

2 Use the arrow keys to move the cursor in text inside a cell.

3 To create a line break within a cell, press ALT+ENTER .

4 To override the text style specified in the table style, click the arrow next
to the Text Style control on the toolbar and select a new text style.

The text style you select is applied to the text in the cell and any new
text that you enter in the cell.

Add Text and Blocks to Tables | 1607



5 To override the formatting in the current text style, first select text as
follows:

■ To select one or more characters, click and drag the pointing device
over the characters.

■ To select a word, double-click the word.

■ To select all the text in the cell, triple-click in the cell. (You can also
right-click. Click Select All.)

6 On the toolbar, make format changes as follows:

■ To change the font of the selected text, select a font from the list.

■ To change the height of the selected text, enter a new value in the
Height box.

■ To format text in a TrueType font with boldface or italics, or to create
underlined text for any font, click the corresponding button on the
toolbar. SHX fonts do not support boldface or italics.

■ To apply color to selected text, choose a color from the Color list.
Click Other to display the Select Color dialog box.

7 Use the keyboard to move from cell to cell:

■ Press TAB to move to the next cell. In the last cell of the table, press
TAB to add a new row.

■ Press SHIFT+TAB to move to the previous cell.

■ When the cursor is at the beginning or end of text in a cell, use the
arrow keys to move the cursor to adjacent cells. You can also use
CTRL+ an arrow key.

■ When text is highlighted in a cell, press an arrow key to remove
selection and move the cursor to the beginning or end of the text in
the cell.

■ Press ENTER to move down one cell.

8 To save your changes and exit, click OK on the toolbar or press
CTRL+ENTER .

Command entry: DDEDIT
Shortcut menu: Select and right-click a cell. Click Edit Text.
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To define or modify data formats

1 In a table, click the table cells where you want to redefine data and
formatting.

2 On the Table toolbar, click Data Format.

3 Choose a data type, format, and other options for the selected table cells.

4 Enter data in the selected table cells. The data type and format you chose
determines how the data is displayed.

5 Click OK.

Shortcut menu: Select and right-click a cell or range of cells. Click Data
Format.

To change the properties of cells in a table

1 Click inside the table cell you want to change.

Hold down SHIFT and click inside another cell to select those two cells
and all the cells between them.

2 Use one of the following methods:

■ To change one or more properties, in the Properties palette, click the
value you want to change and enter or select a new value.

■ To restore the default properties, right-click. Click Remove Property
Overrides.

Toolbar: Properties 
Shortcut menu: Select and right-click a cell or range of cells. Click Properties.

To copy the properties of a cell to other cells

1 Click inside the table cell whose properties you want to copy.

2 (Optional) To view the current properties of the selected table cell, press
CTRL+1 to open the Properties palette.

All the properties of the cell are copied except the cell type: text or block.

3 On the Table toolbar, click Match Cell.

The cursor changes to a paintbrush.
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4 To copy the properties to another table cell in the drawing, click inside
the cell.

5 Right-click or press ESC to stop copying properties.

Command entry: MATCHCELL
Shortcut menu: Select and right-click a cell or range of cells. Click Match
Cell.

To change the lineweight, linetype, or color of the borders of table cells

1 Click inside the table cell you want to change.

Hold down SHIFT and click inside another cell to select those two cells
and all the cells between them.

2 On the Table toolbar, click Cell Borders.

3 In the Cell Border Properties dialog box, select a lineweight, linetype and
color. To specify a double line border, select Double Line.

Use BYBLOCK to set the border properties to match the settings in the
table style that has been applied to the table.

4 Click one of the border type buttons to specify which borders of the cell
to modify, or select a border in the preview image.

5 Click OK.

6 Move the cursor outside the Properties palette, and press ESC to remove
selection, or select another cell.

Shortcut menu: Select and right-click a cell or range of cells. Click Borders.

To edit text in a table cell

1 Double-click inside the cell whose text you want to edit, or select the cell,
right-click, and click Edit Cell.

NOTE When a cell is selected, you can press F2 to edit the cell text.

2 Use the Text Formatting toolbar or the shortcut menu to make changes.

3 To save the changes and exit, click OK on the toolbar, press CTRL+ENTER,
or click outside the cell.

4 To remove selection from the table, press ESC.
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Command entry: DDEDIT
Shortcut menu: Select and right-click a cell. Click Edit Cell.

To insert a block in a table cell

1 On the Table toolbar, click Insert Block.

2 In the Insert dialog box, select a block from the list of blocks in the
drawing, or click Browse to find a block in another drawing.

3 Specify the following properties for the block:

■ Cell Alignment. Specifies alignment for the block in the table cell. The
block is middle-, top-, or bottom-aligned with respect to the top and
bottom borders of the cell. The block is center-, left-, or right-aligned
with respect to the left and right borders of the cell.

■ Scale. Specifies the scale for the block reference. Enter a value or select
AutoFit to scale the block to fit in the selected cell.

■ Rotation Angle. Specifies a rotation angle for the block.

4 Click OK.

If the block has attributes attached, the Edit Attributes dialog box is
displayed.

Shortcut menu: Select and right-click a cell. Click Insert ➤ Block.

To insert a field in a table cell

1 Double-click inside the table cell.

2 On the Table toolbar, click Insert Field, or press CTRL+F.

3 In the Field dialog box, select a category in the Field Category list to
display the field names in that category.

4 Select a field.

5 Select the format or other options available for that field.

6 Click OK.

Command entry: FIELD
Shortcut menu: Select and right-click a cell. Click Insert ➤ Field.
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Quick Reference

Commands

FIELD

Creates a multiline text object with a field that can be updated automatically
as the field value changes.

FIND

Finds the text that you specify, and can optionally replace it with other text.

INSERT

Inserts a block or drawing into the current drawing.

LIST

Displays property data for selected objects.

MATCHCELL

Applies the properties of a selected table cell to other table cells.

MTEXT

Creates a multiline text object.

SPELL

Checks spelling in a drawing.

TABLE

Creates an empty table object.

TABLEDIT

Edits text in a table cell.

TABLEEXPORT

Exports data from a table object in CSV file format.

TABLESTYLE

Creates, modifies, or specifies table styles.

UPDATEFIELD

Manually updates fields in selected objects in the drawing.
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System Variables

CTABLESTYLE

Sets the name of the current table style.

FIELDDISPLAY

Controls whether fields are displayed with a gray background.

FIELDEVAL

Controls how fields are updated.

Utilities

No entries

Command Modifiers

No entries

Use Formulas in Table Cells
Table cells can contain formulas that do calculations using the values in other
table cells.

With a table cell selected, you can insert formulas from the Table toolbar as
well as the shortcut menu. You can also open the In-Place Text Editor and
enter a formula in a table cell manually.

Insert a Formula

In formulas, cells are referred to by their column letter and row number. For
example, the cell at top left in the table is A1. Merged cells use the number
of what would be the top-left cell. A range of cells is defined by the first and
last cells, with a colon between them. For example, the range A5:C10 includes
cells in rows 5 through 10 in columns A, B, and C.

A formula must start with an equal sign (=). The formulas for sum, average,
and count ignore empty cells and cells that do not resolve to a numeric value.
Other formulas display an error (#) if any cell in the arithmetic expression is
empty or contains nonnumeric data.

Use the Cell option on the shortcut menu to select a cell in another table in
the same drawing. When you have selected the cell, the In-Place Text Editor
opens so you can enter the rest of the formula. You can also insert a formula
using the Table toolbar.
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Copy a Formula

When you copy a formula to another cell in the table, the range changes to
reflect the new location. For example, if the formula in A10 sums A1 through
A9, when you copy it to B10, the range of cells changes so that it sums B1
through B9.

If you don't want a cell address to change when you copy and paste the
formula, add a dollar sign ($) to the column or row part of the address. For
example, if you enter $A10, the column stays the same and the row changes.
If you enter $A$10, both column and row stay the same.

Insert Data Automatically

You can automatically increment data in adjacent cells within a table by using
the AutoFill grip. For example, a table with a date column can have the dates
automatically entered by entering the first necessary date and dragging the
AutoFill grip.

Numbers will fill automatically by increments of 1 if one cell is selected and
dragged. Similarly, dates will resolve by increments of one day if only one cell
is selected. If two cells are manually filled with dates one week apart, the
remaining cells are incremented by one week.

See also:

■ Use Fields in Text on page 1532

To sum the values in a range of table cells

1 Select the table cell where you want to place the formula by clicking
inside it. The Table toolbar is displayed.

2 On the Table toolbar, click Insert Formula  ➤  Sum.

The following prompt is displayed:

Select first corner of table cell range:

3 Click inside the first cell in the range.

The following prompt is displayed:

Select second corner of table cell range:

4 Click inside the last cell in the range.

The In-Place Text Editor opens and displays the formula in the cell.

5 Edit the formula, if necessary.
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6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

The cell displays the sum of the values in the range of cells. Empty cells
and cells that do not resolve to a numeric value are ignored.

Shortcut menu: Select and right-click a cell or range of cells. Click
Insert ➤ Formula ➤ Sum.

To average the values in a range of table cells

1 Select the table cell where you want to place the formula by clicking
inside it. The Table toolbar is displayed.

2 On the Table toolbar, click Insert Formula  ➤  Average.

The following prompt is displayed:

Select first corner of table cell range:

3 Click inside the first cell in the range.

The following prompt is displayed:

Select second corner of table cell range:

4 Click inside the last cell in the range.

The In-Place Text Editor opens and displays the formula in the cell.

5 Edit the formula, if necessary.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

The cell displays the average of the values in the range of cells. Empty
cells and cells that do not resolve to a numeric value are ignored.

Shortcut menu: Select and right-click a cell or range of cells. Click
Insert ➤ Formula ➤ Average.
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To count the cells in a table column or a table row

1 Select the table cell where you want to place the formula by clicking
inside it. The Table toolbar is displayed.

2 On the Table toolbar, click Insert Formula  ➤  Count

The following prompt is displayed:

Select first corner of table cell range:

3 Click inside the first cell in the range.

The following prompt is displayed:

Select second corner of table cell range:

4 Click inside the last cell in the range.

The In-Place Text Editor opens and displays the formula in the cell.

5 Edit the formula, if necessary.

6 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

The cell displays the total number of cells in the range.

Shortcut menu: Select and right-click a cell or range of cells. Click
Insert ➤ Formula ➤ Count.

To use a cell from a different table in a formula

1 Select the table cell where you want to place the formula by clicking
inside it. The Table toolbar is displayed.

2 On the Table toolbar, click Insert Formula  ➤  Cell.

The following prompt is displayed:

Select table cell:

3 Click inside the cell in the other table.

The In-Place Text Editor opens and displays the cell address.

4 Enter the rest of the formula.
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5 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

The cell displays the result of the calculation.

Shortcut menu: Select and right-click a cell or range of cells. Click
Insert ➤ Formula ➤ Cell.

To manually enter a formula in a table cell

1 Double-click inside a table cell.

The In-place Text Editor opens.

2 Enter a formula (a function or an arithmetic expression), as in the
following examples:

■ =sum(a1:a25,b1). Sums the values in the first 25 rows of column A
and the first row in column B.

■ =average(a100:d100). Calculates the average of the values in the first
4 columns in row 100.

■ =count(a1:m500). Displays the total number of cells in column A
through column M in rows 1 through 100.

■ =(a6+d6)/e1. Adds the values in A6 and D6 and divides the total by
the value in E1.
Use a colon to define a range of cells and a comma for individual cells.
A formula must start with an equal sign (=) and can contain any of
the following signs: plus (+), minus (-), times (*), divided by (/),
exponent (^), and parentheses ().

3 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

The cell displays the result of the calculation.
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Shortcut menu: Select and right-click a cell or range of cells. Click
Insert ➤ Formula ➤ Equation.

To turn off the display of column letters and row numbers for tables

1 At the command prompt, enter tableindicator.

2 At the Enter New Value prompt, enter 0.

When TABLEINDICATOR is set to 1, the In-Place Text Editor displays column
letters and row numbers when a table cell is selected.

Command entry: TABLEINDICATOR

To change the background color of column letters and row numbers for tables

1 Click a grid line to select a table.

2 Right-click. Click Table Indicator Color.

3 In the Select Color dialog box, select a color.

4 Click OK.

The text color, size, and style and the line color are controlled by the
settings for column heads in the current table style.

To insert a Formula field in a table cell

1 Click inside the table cell.

2 On the Table toolbar, click Insert Field.

3 In the Field dialog box, Field Category list, select Objects.

4 In Field Names, select Formula.

5 To enter a formula, use any of the following methods one or more times:

■ Click Average, Sum, or Count. The Field dialog box closes temporarily.
To specify a range, click inside the first and the last cell. The result is
appended to the formula.

■ Click Cell. The Field dialog box closes temporarily. Select a cell in a
table in the drawing. The cell address is appended to the formula.

6 (Optional) Select a format and a decimal separator.

7 Click OK.
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8 To save your changes and exit the editor, use one of the following
methods:

■ Click OK on the toolbar.

■ Click in the drawing outside the editor.

■ Press CTRL+ENTER.

The cell displays the result of the calculation.

Shortcut menu: Select and right-click a cell or range of cells. Click
Insert ➤ Formula.

To automatically fill cells with incremented data

1 Double-click inside a table cell.

2 Enter a numeric value; for example, 1 or 01/01/2000.

3 Press the down arrow and enter the next desired numeric value.

4 On the Text Formatting toolbar, click OK.

To change the format of the cell data, right-click the cell. Select Data
Format.

5 Select the cell or cells from which you want to increment data from.

6 Click the grip in the lower right corner of the cell or cells.

To change AutoFill options, right-click the AutoFill grip in the bottom
right-hand corner of the selected cell range and select one of the following
options:

■ Fill Series. Finds a pattern in the range of selected cells and fills the
selected cells with the subsequent cell format and value. If only 1 cell
is selected from which to increment data, then the data will increment
at a rate of 1 unit.

■ Fill Series Without Formatting. Follows the above guidelines without
cell formatting.

■ Copy Cells. Copies the format and values for the selected cells.

■ Copy Cells Without Formatting. Follows the above guidelines without
cell formatting.

■ Fill Formatting Only. Fills only cell formatting for the selected cells.
Cell values are ignored.
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7 Drag the grip through the cells you would like to automatically increment.
A preview of the value for each cell will display to the right of the selected
grip.

Quick Reference

Commands

FIELD

Creates a multiline text object with a field that can be updated automatically
as the field value changes.

MTEXT

Creates a multiline text object.

TABLE

Creates an empty table object.

TABLEEXPORT

Exports data from a table object in CSV file format.

TABLESTYLE

Creates, modifies, or specifies table styles.

UPDATEFIELD

Manually updates fields in selected objects in the drawing.

System Variables

CTABLESTYLE

Sets the name of the current table style.

FIELDDISPLAY

Controls whether fields are displayed with a gray background.

FIELDEVAL

Controls how fields are updated.

TABLEINDICATOR

Controls the display of row numbers and column letters when the In-Place
Text Editor is open for editing a table cell.
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Utilities

No entries

Command Modifiers

No entries
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Dimensions and Tolerances

You can add measurements to your drawing with several dimensioning commands. Use
dimension styles to format dimensions quickly and maintain industry or project dimensioning
standards.

Understand Basic Concepts of Dimensioning
You can create several types of dimensions, and you can control their appearance
by setting up dimension styles or by editing individual dimensions.

Overview of Dimensioning
Dimensioning is the process of adding measurement annotation to a drawing.

You can create dimensions for a variety of object types in many orientations.
The basic types of dimensioning are

■ Linear

■ Radial (radius, diameter and jogged)

■ Angular

■ Ordinate

■ Arc Length

Linear dimensions can be horizontal, vertical, aligned, rotated, baseline, or
continued (chained). Some examples are shown in the illustration.

27
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NOTE To simplify drawing organization and dimension scaling, it is recommended
that you create dimensions on layouts rather than in model space.

To create a dimension

1 Create a layer designated for dimensions and make it the current layer.

2 Near the bottom-left corner of the application window, click a layout
tab.

3 Click Dimension menu. Click a dimension option.

4 Follow the command prompts.

Command entry: DIMLINEAR, DIMRADIUS, DIMANGULAR

Quick Reference

Commands

DIMANGULAR

Creates an angular dimension.

DIMARC

Creates an arc length dimension.

DIMBREAK

Breaks or restores dimension and extension lines where they cross other
objects.
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DIMDIAMETER

Creates a diameter dimension for a circle or an arc.

DIMEDIT

Edits dimension text and extension lines.

DIMBREAK

Adds or removes inspection information for a selected dimension.

DIMJOGGED

Creates jogged dimensions for circles and arcs.

DIMBREAK

Adds or removes a jog line on a linear or aligned dimension.

DIMLINEAR

Creates a linear dimension.

DIMORDINATE

Creates ordinate dimensions.

DIMRADIUS

Creates a radius dimension for a circle or an arc.

DIMREASSOCIATE

Associates or reassociates selected dimensions to objects or points on objects.

DIMBREAK

Adjusts the spacing between linear dimensions or angular dimensions.

DIMSTYLE

Creates and modifies dimension styles.

DIMTEDIT

Moves and rotates dimension text and relocates the dimension line.

PROPERTIES

Controls properties of existing objects.

QDIM

Quickly creates a series of dimensions from selected objects.
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System Variables

DIMASSOC

Controls the associativity of dimension objects and whether dimensions are
exploded.

Utilities

No entries

Command Modifiers

No entries

Parts of a Dimension
Here is a list of the parts of a dimension along with their descriptions.

Dimensions have several distinct elements: dimension text, dimension lines,
arrowheads, and extension lines.

Dimension text is a text string that usually indicates the measurement value.
The text can also include prefixes, suffixes, and tolerances.

A dimension line indicates the direction and extent of a dimension. For angular
dimensions, the dimension line is an arc.

Arrowheads, also called symbols of termination, are displayed at each end of
the dimension line. You can specify different sizes and shapes for arrowheads
or tick marks.

Extension lines, also called projection lines or witness lines, extend from the
feature to the dimension line.

A center mark is a small cross that marks the center of a circle or arc.
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Centerlines are broken lines that mark the center of a circle or arc.

Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Associative Dimensions
Dimensions can be associative, nonassociative, or exploded. Associative
dimensions adjust to changes in the geometric objects that they measure.

Dimension associativity defines the relationship between geometric objects
and the dimensions that give their distance and angles. There are three types
of associativity between geometric objects and dimensions.

■ Associative dimensions. Automatically adjust their locations, orientations,
and measurement values when the geometric objects associated with them
are modified. Dimensions in a layout may be associated to objects in model
space. The DIMASSOC system variable is set to 2.
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■ Nonassociative dimensions. Selected and modified with the geometry they
measure. Nonassociative dimensions do not change when the geometric
objects they measure are modified. The dimension variable DIMASSOC is
set to 1.

■ Exploded dimensions. Contain a collection of separate objects rather than
a single dimension object. The DIMASSOC system variable is set to 0.

You can determine whether a dimension is associative or nonassociative by
selecting the dimension and doing one of the following:

■ Use the Properties palette to display the properties of the dimension.

■ Use the LIST command to display the properties of the dimension.

You can also use the Quick Select dialog box to filter the selection of associative
or nonassociative dimensions. A dimension is considered associative even if
only one end of the dimension is associated with a geometric object. The
DIMREASSOCIATE command displays the associative and nonassociative
elements of a dimension.

Special Situations and Limitations

You may need to use DIMREGEN to update associative dimensions after
panning or zooming with a wheel mouse, after opening a drawing that was
modified with an earlier release, or after opening a drawing with external
references that have been modified.

Although associative dimensions support most object types that you would
expect to dimension, they do not support the following:

■ Hatches

■ Multiline objects

■ 2D solids

■ Objects with nonzero thickness

■ Images

■ DWF underlays

When selecting objects to dimension, make sure that the objects that you
select don't include a directly overlapping object that does not support
associative dimensioning such as a 2D solid.
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Associativity is not maintained between a dimension and a block reference if
the block is redefined.

Associativity is not maintained between a dimension and a 3D solid if the
shape of the 3D solid is modified.

Dimensions created with QDIM are not associative but may be associated
individually with DIMREASSOCIATE.

NOTE In releases prior to AutoCAD 2002, the definitions of associative and
nonassociative dimensions were different and were controlled by the DIMASO
system variable. The behavior of dimensions is now controlled by the DIMASSOC
system variable.

For information about working with associative dimensions in combination
with previous releases, see Save Drawings to Previous Drawing File Formats.

See also:

■ Change Dimension Associativity on page 1733

To change the dimension associativity default

1 Click Tools menu  ➤ Options.

2 In the Options dialog box, User Preferences tab, under Associative
Dimensioning, select or clear Make New Dimensions Associative.

3 Do either or both of the following:

■ Click Apply to record the current Options settings in the system
registry.

■ Click OK to record the current Options settings in the system registry
and close the Options dialog box.

All subsequently created dimensions in the drawing use the new setting. Unlike
most other option settings, dimension associativity is saved in the drawing
file rather than in the system registry.

Command entry: OPTIONS
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Quick Reference

Commands

DIMDISASSOCIATE

Removes associativity from selected dimensions.

DIMREASSOCIATE

Associates or reassociates selected dimensions to objects or points on objects.

DIMREGEN

Updates the locations of all associative dimensions.

EXPLODE

Breaks a compound object into its component objects.

LIST

Displays property data for selected objects.

OPTIONS

Customizes the program settings.

System Variables

DIMASSOC

Controls the associativity of dimension objects and whether dimensions are
exploded.

Utilities

No entries

Command Modifiers

No entries

Use Dimension Styles
You can control the appearance of dimensions by changing settings. For
convenience and to help maintain dimensioning standards, you can store
these settings in dimension styles.
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Overview of Dimension Styles
A dimension style is a named collection of dimension settings that controls
the appearance of dimensions, such as arrowhead style, text location, and
lateral tolerances.

You create dimension styles to specify the format of dimensions quickly, and
to ensure that dimensions conform to industry or project standards.

■ When you create a dimension, it uses the settings of the current dimension
style

■ If you change a setting in a dimension style, all dimensions in a drawing
that use the style update automatically

■ You can create dimension substyles that, for specified types of dimensions,
deviate from the current dimension style

■ If necessary, you can override a dimension style temporarily

To set the current dimension style

■ On the Styles toolbar, in the Dimension Styles control, click the arrow and
select a dimension style from the list.

Command entry: DIMSTYLE

To create a dimension substyle

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style from which you want
to create a substyle. Click New.

3 In the Create New Dimension Style dialog box, select the type of
dimension that will apply to the substyle from the Use For list. Click
Continue.

4 In the New Dimension Style dialog box, select the appropriate tab and
make changes to define the dimension substyle.

5 Click OK.

6 Click Close to exit the Dimension Style Manager.

Command entry: DIMSTYLE
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Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Compare Dimension Styles and Variables
You can view all the settings in a dimension style. Dimension styles used in
externally referenced drawings are differentiated from those defined in your
current drawing.

You can list the dimension styles in the current drawing. You can also list all
dimensioning system variables and their current status or only the variables
affected by a dimension style.

When you list the current status of all dimensioning system variables, any
running overrides that apply to the current dimension style are listed. You
can also list the differences between a named dimension style and the current
dimension style.

Use Externally Referenced Dimension Styles

The program displays externally referenced dimension style names using the
same syntax as for other externally dependent named objects. When you view
externally referenced dimension styles using the Dimension Style Manager,
the name of the xref displays in the Styles list as Xref:drawing name with each
xref style appearing below the drawing name. For example, if the drawing file
baseplat.dwg has a dimension style called FRACTIONAL-1, and you attach
baseplat.dwg as an xref to a new drawing, then the xref dimension style is
displayed in the Styles list of the Dimension Style Manager as Xref:baseplat.dwg,
and FRACTIONAL-1 appears under the drawing name.
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Externally referenced dimension styles can be examined, but they cannot be
modified or made current. You can use an externally referenced dimension
style as a template for creating a new dimension style in your current drawing.

To list all dimension settings for the current dimension style

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style from the Styles list.

3 Click Compare.

The dimensioning system variables, their current settings, and a brief
description are listed. Overrides are included.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To list settings for an existing dimension style

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, enter a dimension style name, or select
a dimension whose dimension style you want to examine.

3 Click Compare.

Affected variables, their settings, and a brief description of each are listed.
Overrides are not included.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To list dimension styles in the current drawing

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 
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2 In the Dimension Style Manager, under List, select All Styles or Style in
Use.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To compare dimension styles

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style to compare from the
Styles list.

3 Click Compare.

The dimension style is compared to the current dimension style.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Control Dimension Geometry
You can control the appearance of dimension lines, extension lines,
arrowheads, and center marks.

Control Dimension Lines
You can control dimension line properties including color, lineweight, and
spacing.

You can control several aspects of a dimension line. You can

■ Specify color and lineweight for visual effect and plotting

■ Suppress the dimension line or, if the dimension line is broken by text,
one or both halves

■ Control the spacing between successive dimension lines in baseline
dimensions
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■ Control the distance by which the dimension line extends beyond the
extension lines for architectural tick (oblique stroke) arrowheads

To modify the display of dimension lines

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Lines tab, change the settings
under Dimension Lines as needed.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE
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Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

System Variables

DIMCLRD

Assigns colors to dimension lines, arrowheads, and dimension leader lines.

DIMDLE

Sets the distance the dimension line extends beyond the extension line when
oblique strokes are drawn instead of arrowheads.

DIMDLI

Controls the spacing of the dimension lines in baseline dimensions.

DIMGAP

Sets the distance around the dimension text when the dimension line breaks
to accommodate dimension text.

DIMLTYPE

Sets the linetype of the dimension line.

DIMLWD

Assigns lineweight to dimension lines.

DIMSD1

Controls suppression of the first dimension line and arrowhead.

DIMSD2

Controls suppression of the second dimension line and arrowhead.

DIMSOXD

Suppresses arrowheads if not enough space is available inside the extension
lines.

DIMTOFL

Controls whether a dimension line is drawn between the extension lines
even when the text is placed outside.
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Utilities

No entries

Command Modifiers

No entries

Control Extension Lines
You can control extension line properties including color, lineweight,
overshoot, and offset length.

You can control several aspects of the extension lines. You can

■ Specify color and lineweight for visual effect and plotting

■ Suppress one or both extension lines if they are unnecessary, or if there is
not enough space

■ Specify how far beyond from the dimension line the extension line extends
(overshoot)

■ Control the extension origin offset, the distance between the extension
line origin, and the start of the extension line

■ Specify a fixed length for extension lines, as measured from the dimension
line toward the extension line origin
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■ Specify a noncontinuous linetype, typically used for centerlines

■ Modify the angle of the extension lines of a selected dimension to make
them oblique

Fixed-Length Extension Lines

With the Dimension Style Manager, on the Lines tab, you can specify a
dimension style that sets the total length of extension lines starting from the
dimension line toward the dimension origin point.

The extension-line offset distance from the origin will never be less than the
value specified by the DIMEXO system variable.

See also:

■ Create Dimensions with Oblique Extension Lines on page 1686
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To modify the display of extension lines

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Lines tab, under Extension
Lines, change the settings as needed.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

System Variables

DIMCLRE

Assigns colors to dimension extension lines.

DIMDLE

Sets the distance the dimension line extends beyond the extension line when
oblique strokes are drawn instead of arrowheads.

DIMEXE

Specifies how far to extend the extension line beyond the dimension line.

DIMEXO

Specifies how far extension lines are offset from origin points.
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DIMFXL

Sets the total length of the extension lines starting from the dimension line
toward the dimension origin.

DIMFXLON

Controls whether extension lines are set to a fixed length.

DIMLTEX1

Sets the linetype of the first extension line.

DIMLTEX2

Sets the linetype of the second extension line.

DIMLWE

Assigns lineweight to extension lines.

DIMSE1

Suppresses display of the first extension line.

DIMSE2

Suppresses display of the second extension line.

Utilities

No entries

Command Modifiers

No entries

Control Dimension Arrowheads
You can control the arrowhead symbols in dimensions and leaders including
their type, size, and visibility.

You can choose from many standard types of arrowheads, or you can create
your own arrowheads. Additionally, you can

■ Suppress the display of arrowheads, or use one arrowhead only

■ Apply a different type of arrowhead to each end of a dimension line

■ Control the size of arrowheads
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■ Flip the direction of an arrowhead using the dimension shortcut menu

NOTE Flipped arrowheads maintain their appearance in versions later than
AutoCAD 2002. However, if you edit a drawing with flipped arrowheads in a
release earlier than AutoCAD 2006, the arrowhead directions will revert to their
original orientations.

See also:

■ Customize Arrowheads on page 1643

To choose an arrowhead

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Symbols and Arrows tab,
under Arrowheads, select the arrowhead type for the first end of the
dimension line.

The second arrowhead is automatically set to the same type.

4 To set the second end of the dimension line to a different arrowhead
type, select an arrowhead type from the Second list.

5 In the Size box, enter a size for the arrowhead.

6 Click OK.

7 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To flip the direction of an arrowhead

1 At the command prompt, select a single dimension object near the
arrowhead that you want to flip.

2 Right-click. Click Flip Arrow.
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Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

System Variables

DIMCLRD

Assigns colors to dimension lines, arrowheads, and dimension leader lines.

DIMDLE

Sets the distance the dimension line extends beyond the extension line when
oblique strokes are drawn instead of arrowheads.

DIMSD1

Controls suppression of the first dimension line and arrowhead.

DIMSD2

Controls suppression of the second dimension line and arrowhead.

Utilities

No entries

Command Modifiers

No entries

Customize Arrowheads
You can create your own custom arrowheads.

Arrowheads are stored as block definitions. To use your own arrowhead,
provide the name of an existing block definition. For information about
creating blocks, see Create Blocks Within a Drawing on page 855.

NOTE Annotative blocks cannot be used as custom arrowheads for dimensions
or leaders.

Arrowhead sizing relies on the overall dimension scale factor. When you create
a dimension, the block is inserted where the arrowheads would normally go.
The object's X and Y scale factors are set to arrowhead size overall scale. The
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dimension line is trimmed by text gap x overall scale units at each end. To trim
the dimension line, the rightmost block is inserted with a zero rotation angle
for horizontal dimensioning. The leftmost block is rotated 180 degrees about
its insertion point.

If you use paper-space scaling, the scale factor is computed before applying it
to the arrowhead size value.

To use your own arrowhead symbol

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Dimension Style Manager, Symbols and Arrows tab, under
Arrowheads, select User Arrow from the First arrowhead list.

4 In the Select Custom Arrow Block dialog box, enter the name of your
block. Click OK.

5 To choose a different custom arrowhead for the second arrowhead, repeat
steps 3 and 4, choosing User Arrow from the Second arrowhead list
(optional).

6 Click OK.

7 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

Quick Reference

Commands

BLOCK

Creates a block definition from selected objects.

DIMSTYLE

Creates and modifies dimension styles.
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WBLOCK

Writes objects or a block to a new drawing file.

System Variables

DIMASZ

Controls the size of dimension line and leader line arrowheads.

DIMBLK

Sets the arrowhead block displayed at the ends of dimension lines or leader
lines.

DIMBLK1

Sets the arrowhead for the first end of the dimension line when DIMSAH is
on.

DIMBLK2

Sets the arrowhead for the second end of the dimension line when DIMSAH
is on.

DIMCLRD

Assigns colors to dimension lines, arrowheads, and dimension leader lines.

DIMDLE

Sets the distance the dimension line extends beyond the extension line when
oblique strokes are drawn instead of arrowheads.

DIMSAH

Controls the display of dimension line arrowhead blocks.

DIMTSZ

Specifies the size of oblique strokes drawn instead of arrowheads for linear,
radius, and diameter dimensioning.
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Utilities

No entries

Command Modifiers

No entries

Control Dimension Text
You can control the placement of dimension text, arrowheads, and leader
lines relative to the dimension and extension lines.

Fit Dimension Text Within Extension Lines
Dimension text and arrowheads usually appear between the extension lines
when there is enough space. You can specify how these elements are placed
when space is limited.

Many factors, such as the size of extension line spacing and arrowhead size,
influence how dimension text and arrowheads fit within the extension lines.
In general, the best fit, given the available space, is applied. If possible, both
text and arrowheads are accommodated between the extension lines, no matter
what fit option you choose.

When creating new dimensions, you can choose to place text by entering a
coordinate or using the pointing device; this is known as user-defined text
placement. Alternatively, the program can compute the text position for you.
The options for automatic fitting of text and arrowheads are listed in the
Dimension Style Manager, Fit tab. For example, you can specify that text and
arrowheads be kept together. In this case, if there is not room for both between
the extension lines, they are both placed outside. You can specify that if there
is room for only text or arrowheads, then either text only or arrowheads only
are placed between the extension lines.

The following illustrations show how the program applies a "best fit" for
arrowheads and text.
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If there is no room for text between the extension lines, you can have a leader
line created automatically. This is useful in cases where text outside the
extension lines would interfere with other geometry, for example, in continued
dimensions. Whether text is drawn to the right or the left of the leader is
controlled by the horizontal justification setting on the Text tab of the
Modify/New Dimension Style dialog box. Also, you can fit text and arrowheads
by changing their size.

Even if the arrowheads are outside the extension lines, you can have a line
drawn between the extension lines. This is called forcing an internal line and
is illustrated as follows.

Fit Diameter Dimension Text

You can draw several different diameter dimensions depending on text
placement, horizontal settings on the Text tab, and whether you select the
Draw Dim Line Between Ext Lines option on the Fit tab.
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To place text within extension lines

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Fit tab, under Fit Options,
select an option.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

If there is enough room, text is fit between extension lines.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To force an internal line and choose a fit option

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Fit tab, Under Fine Tuning,
select Always Draw Dim Line Between Ext Lines.

4 Under Fit Options, select an option.
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5 Click OK.

6 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

System Variables

DIMATFIT

Determines how dimension text and arrows are arranged when space is not
sufficient to place both within the extension lines.

DIMJUST

Controls the horizontal positioning of dimension text.

DIMLWD

Assigns lineweight to dimension lines.

DIMTAD

Controls the vertical position of text in relation to the dimension line.

DIMTXTDIRECTION

Specifies the reading direction of the dimension text.

DIMTIH

Controls the position of dimension text inside the extension lines for all
dimension types except Ordinate.

DIMTIX

Draws text between extension lines.
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DIMTOFL

Controls whether a dimension line is drawn between the extension lines
even when the text is placed outside.

DIMTOH

Controls the position of dimension text outside the extension lines.

DIMTVP

Controls the vertical position of dimension text above or below the dimension
line.

DIMUPT

Controls options for user-positioned text.

Utilities

No entries

Command Modifiers

No entries

Control the Location of Dimension Text
You can locate dimension text manually and specify its alignment and
orientation.

The program comes with several justification settings that facilitate compliance
with international standards, or you can choose your own location for the
text.
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Many of the settings are interdependent. Example images in the Dimension
Style Manager are updated dynamically to illustrate how text appears as you
change the settings.

Align Dimension Text

Whether text is inside or outside the extension lines, you can choose whether
it is aligned with the dimension line or remains horizontal. The following
examples show two combinations of these options.

The default alignment is horizontal dimension text, even for vertical
dimensions.

Position Dimension Text Horizontally

The position of the text along the dimension line in relation to the extension
lines is referred to as text placement. To place text yourself when you create
a dimension, use the Place Text Manually When Dimensioning option on the
Fit tab of the Modify/New Dimension Style dialog box. Use the text placement
options to automatically place text at the center of the dimension line, at
either extension line, or over either extension line.
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First and second extension lines are defined by the order in which you specified
the extension line origins when you created the dimension. For angular
dimensions, the second extension line is counterclockwise from the first. In
the following illustrations, 1 is the first extension line origin and 2 the second.

If you place text manually, you can place the dimension text anywhere along
the dimension line, inside or outside the extension lines, as you create the
dimension. This option provides flexibility and is especially useful when space
is limited. However, the horizontal alignment options provide better accuracy
and consistency between dimensions.

Position Dimension Text Vertically

The position of the text relative to the dimension line is referred to as vertical
text placement. Text can be placed above or below or centered within the
dimension line. In the ANSI standards, centered text usually splits the
dimension line. In the ISO standards, it is usually above or outside the
dimension line. For example, ISO standards permit angular dimension text
to appear in any of the ways shown.
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Other settings, such as Text Alignment, affect the vertical alignment of text.
For example, if Horizontal Alignment is selected, text inside the extension
lines and centered within the dimension line is horizontal, as shown in the
leftmost illustration above. The text is horizontal even if the dimension line
is not itself horizontal.

To align text with the dimension line

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Text tab, under Text
Alignment, select Aligned with Dimension Line.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To place text at the second extension line

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Text tab, under Text
Placement, select Over Ext Line 2 from the Horizontal list box.

The example area reflects your selection.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles 
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Command entry: DIMSTYLE

To place dimension text manually

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Fit tab, under Fine Tuning,
select Place Text Manually When Dimensioning.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

As you create dimensions, you can move the text along the dimension
line. Use the pointing device or enter coordinates to specify the dimension
line and text locations.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To place text above the dimension line

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Text tab, under Text
Placement, select Above from the Vertical list box.

The example area reflects your selection.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE
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Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

DIMTEDIT

Moves and rotates dimension text and relocates the dimension line.

System Variables

DIMJUST

Controls the horizontal positioning of dimension text.

DIMTAD

Controls the vertical position of text in relation to the dimension line.

DIMTXTDIRECTION

Specifies the reading direction of the dimension text.

DIMTIH

Controls the position of dimension text inside the extension lines for all
dimension types except Ordinate.

DIMTOH

Controls the position of dimension text outside the extension lines.

DIMTVP

Controls the vertical position of dimension text above or below the dimension
line.

DIMUPT

Controls options for user-positioned text.
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Utilities

No entries

Command Modifiers

No entries

Control the Appearance of Dimension Text
You can include prefixes, suffixes, and user-supplied text in dimensions. You
can also control the text style and formatting used in dimension text.

The program supports a mixture of user-supplied text, prefixes and suffixes
supplied by the dimension style, and generated measurements. For example,
you could add a diameter symbol as a prefix to a measurement or add the
abbreviation for a unit, such as mm, as a suffix. Text in this context refers to
all dimension text, prefixes and suffixes, primary and alternate units, and
lateral tolerances. Geometric tolerances are controlled independently.

Dimension text is treated as a single string of text, which you create and format
using your text editor.

Control the Text Style in Dimensions

The appearance of dimension text is governed by the text style selected in the
Dimension Style Manager, Text tab. You can choose a text style while creating
a dimension style and specify a text color and a height independent of the
current text style's height setting. You can also specify the gap between base
dimension text and the box that surrounds it.

The text styles used for dimensions are the same text styles used by all text
created in your drawing.

For more information, see Work with Text Styles on page 1544.

Supply User Text to Dimensions

In addition to the prefixes and suffixes specified for primary and alternate
units, you can supply your own text as you create a dimension. Because the
prefix, suffix, and user-supplied text form a single text string, you can represent
tolerance stacks and apply changes to font, text size, and other characteristics
using the text editor.

To add user text above and below the dimension line, use the separator symbol
\X. Text that precedes this symbol is aligned with and above the dimension
line. Text that follows the \X symbol is aligned with and below the dimension
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line. The space between the dimension line and the text is determined by the
value you enter under Gap in the Annotation dialog box.

Example: User Text in Dimensions

In this example, the primary dimension measurement is 5.08, and the alternate
dimension measurement is 2.00. The primary units have the suffix H7/h6, and
the alternate units have the suffix inches.

At the text prompt, while creating the dimension, you enter the following
format string:

<> H7/h6\XSee Note 26\P[ ]

The angle brackets represent the primary units, and the square brackets
represent the alternate units. The \X separates text above the dimension line
from text below the dimension line. The \P is a paragraph break.

The resulting text appears as follows:

To control the text style in dimensions

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Text tab, under Text
Appearance, select a text style.

4 If the current text style does not have a fixed height, enter the height of
dimension text in the Text Height box.

5 Under Tolerances, enter a height for tolerance values in the Scaling for
Height box.

6 In the Offset from Dim Line box, enter a value for the gap around base
dimension text.

7 Select a color from the Text Color box.

Control Dimension Text | 1657



8 Click OK

9 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

System Variables

DIMCLRT

Assigns colors to dimension text.

DIMGAP

Sets the distance around the dimension text when the dimension line breaks
to accommodate dimension text.

DIMTFAC

Specifies a scale factor for the text height of fractions and tolerance values
relative to the dimension text height, as set by DIMTXT.

DIMTFILL

Controls the background of dimension text.

DIMTFILLCLR

Sets the color for the text background in dimensions.

DIMTXSTY

Specifies the text style of the dimension.

DIMTXT

Specifies the height of dimension text, unless the current text style has a
fixed height.
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DIMTXTDIRECTION

Specifies the reading direction of the dimension text.

Utilities

No entries

Command Modifiers

No entries

Control Dimension Values
The numeric values displayed in dimensions can appear in several formats.
You can also control how numeric distances are represented.

Control the Display of Dimension Units
The numeric values of dimensions can be displayed as a single measurement
or in two measurement systems. In either case, you can control details of how
the numeric values are presented.

The settings for primary units control the display of the dimension values,
including the unit format, the numeric precision, and the decimal separator
style. For example, you can enter the diameter symbol as a prefix, as shown
in the illustration. Any prefix you specify replaces the prefixes normally used
for diameter and radius dimensions (Diameter (unicode 2205 and R,
respectively).

These settings are available on the Primary Units tab of the Dimension Style
Manager.
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Control the Display of Alternate Units

You can create dimensions in two systems of measurement simultaneously.
A common use of this feature is to add feet and inches dimensions to drawings
created using metric units. The alternate units appear in square brackets ([ ])
in the dimension text. Alternate units cannot be applied to angular dimensions.

If alternate-units dimensioning is on when you edit a linear dimension, the
measurement is multiplied by an alternate scale value that you specify. This
value represents the number of alternate units per current unit of measurement.
The default value for imperial units is 25.4, which is the number of millimeters
per inch. The default value for metric units is about 0.0394, which is the
number of inches per millimeter. The number of decimal places is specified
by the precision value for alternate units.

For example, for imperial units, if the alternate scale setting is the default
value, 25.4, and the alternate precision is 0.00, the dimension might look like
the following figure.

To add and format primary units

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Primary Units tab, under
Linear or Angular Dimensions, select a unit format and precision value
for the primary units.

4 Under Linear Dimensions, enter any prefix and suffix for the displayed
dimension.

5 Click OK.

6 Click Close to exit the Dimension Style Manager.
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Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To add and format alternate units

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Alternate Units tab, select
Display Alternate Units.

4 Under Alternate Units

■ Select a unit format from the list.

■ Select a precision value for the alternate units.

■ Enter any prefix and suffix for the displayed dimension, including a
space character if you want a gap between the dimension and the
prefix or suffix.

5 Click OK.

6 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.
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System Variables

DIMALT

Controls the display of alternate units in dimensions.

DIMALTD

Controls the number of decimal places in alternate units.

DIMALTF

Controls the multiplier for alternate units.

DIMALTTD

Sets the number of decimal places for the tolerance values in the alternate
units of a dimension.

DIMALTU

Sets the units format for alternate units of all dimension substyles except
Angular.

DIMALTZ

Controls the suppression of zeros for alternate unit dimension values.

DIMAPOST

Specifies a text prefix or suffix (or both) to the alternate dimension
measurement for all types of dimensions except angular.

DIMAUNIT

Sets the units format for angular dimensions.

DIMDEC

Sets the number of decimal places displayed for the primary units of a
dimension.

DIMDSEP

Specifies a single-character decimal separator to use when creating dimensions
whose unit format is decimal.

DIMLFAC

Sets a scale factor for linear dimension measurements.

DIMLUNIT

Sets units for all dimension types except Angular.
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DIMPOST

Specifies a text prefix or suffix (or both) to the dimension measurement.

DIMTDEC

Sets the number of decimal places to display in tolerance values for the
primary units in a dimension.

Utilities

No entries

Command Modifiers

No entries

Round Off Dimension Values
You can round off the numeric values in dimensions and lateral tolerances.

You can round off all dimension values except those for angular dimensions.
For example, if you specify a round-off value of 0.25, all distances are rounded
to the nearest 0.25 unit. The number of digits displayed after the decimal
point depends on the precision set for primary and alternate units and lateral
tolerance values.

To round off dimension values

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.
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3 In Modify Dimension Style dialog box, Primary Units tab, under Linear
Dimensions, enter the round-off value.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

System Variables

DIMRND

Rounds all dimensioning distances to the specified value.

Utilities

No entries

Command Modifiers

No entries

Suppress Zeros in Dimensions
You can suppress leading and trailing zeros in the numeric portion of
dimension text. You can also specify the sub unit for the dimension distance.

If you suppress leading zeros in decimal dimensions, 0.500 becomes .500. If
you suppress trailing zeros, 0.500 becomes 0.5. You can suppress both leading
and trailing zeros so that 0.5000 becomes .5 and 0.0000 becomes 0.

For dimension distances less than one unit, you can set the dimension distance
to display in sub units. If the distance is shown in m, you can set to display
distances less than one m in cm or mm.
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The table shows the effect of selecting each option and provides examples of
the architectural units style. If feet are included with a fractional inch, the
number of inches is indicated as zero, no matter which option you select.
Thus, the dimension 4'-3/4" becomes 4'-0 3/4".

Zero suppression for feet and inches

ExamplesEffectOption

1'-0
3/4"

1'-0"0'-6"0'-0 1/2"Includes zero feet and
zero inches

No options
selected

1'-0
3/4"

1'0'-6"0'-0 1/2"Suppresses zero inches
(includes zero feet)

0 Inches se-
lected

1'-0
3/4"

1'-0"6"1/2"Suppresses zero feet (in-
cludes zero inches)

0 Feet selec-
ted

1'-0
3/4"

1'6"1/2"Suppresses zero feet and
zero inches

0 Feet and 0
Inches selec-
ted

To suppress zeros in dimension values

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Primary Units tab or Alternate
Units tab, under Zero Suppression, select from the following:

■ Sub-units factor: Suppresses leading zeros in decimal values.

■ Trailing. Suppresses trailing zeros in decimal values.

■ 0 Feet. Suppresses display of 0 feet in feet and inches values.

■ 0 Inches. Suppresses display of 0 inches in feet and inches values.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.
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Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To display dimension value in sub units

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Primary Units tab or Alternate
Units tab, under Zero Suppression, select Leading.

■ Sub-units factor: Sets the number of sub units to a unit. It is used to
display the dimension distance in a sub unit, for distances less than
one unit. For example, enter 100 if the suffix is m and the sub-unit
suffix is to display in cm.

■ Sub-units suffix: Includes a suffix to the dimension text sub unit. You
can enter text or use control codes to display special symbols. For
example, enter cm to for .96m to display as 96cm.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.
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System Variables

DIMALTTZ

Controls suppression of zeros in tolerance values.

DIMALTZ

Controls the suppression of zeros for alternate unit dimension values.

DIMAZIN

Suppresses zeros for angular dimensions.

DIMTZIN

Controls the suppression of zeros in tolerance values.

DIMZIN

Controls the suppression of zeros in the primary unit value.

Utilities

No entries

Command Modifiers

No entries

Display Lateral Tolerances
Lateral tolerances are values indicating the amount a measured distance can
vary. You can control whether lateral tolerances are displayed and you can
choose from several styles of lateral tolerances.

A lateral tolerance specifies the amount by which a dimension can vary. By
specifying tolerances in manufacturing, you can control the degree of accuracy
needed for a feature. A feature is some aspect of a part, such as a point, line,
axis, or surface.

You can apply tolerances directly to a dimension by appending the tolerances
to the dimension text. These dimension tolerances indicate the largest and
smallest permissible size of the dimension. You can also apply geometric
tolerances, which indicate deviations of form, profile, orientation, location,
and runout.

Lateral tolerances can be specified from theoretically exact measurements.
These are called basic dimensions and have a box drawn around them.
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If the dimension value can vary in both directions, the plus and minus values
you supply are appended to the dimension value as deviation tolerances. If
the deviation tolerance values are equal, they are displayed with a   sign and
they are known as symmetrical. Otherwise, the plus value goes above the
minus value.

If the tolerances are applied as limits, the program uses the plus and minus
values you supply to calculate a maximum and minimum value. These values
replace the dimension value. If you specify limits, the upper limit goes above
the lower.

Format Lateral Tolerances

You can control the vertical placement of tolerance values relative to the main
dimension text. Tolerances can align with the top, middle, or bottom of the
dimension text.
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Along with vertical placement of tolerance values, you can also control the
horizontal alignment of the upper and lower tolerance values.The upper and
lower tolerance values can be aligned using either the operational symbols or
decimal separators.

You can also control zero suppression as you can with the primary and
alternate units. Suppressing zeros in lateral tolerances has the same effect as
suppressing them in the primary and alternate units. If you suppress leading
zeros, 0.5 becomes .5, and if you suppress trailing zeros, 0.5000 becomes 0.5.

See also:

■ Add Geometric Tolerances on page 1736

To specify methods for lateral tolerances

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.
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3 In the Modify Dimension Style dialog box, Tolerances tab, under
Tolerance Format, select a method from the Method list, and then do
one of the following:

■ If you select Limits, enter upper and lower tolerance deviation in the
Upper Value and Lower Value boxes.

■ If you select Symmetrical tolerances, Lower Value is not available,
because you need only one tolerance value.

■ If you select Basic, enter a value in Offset from Dim Line (on the Text
tab) to represent the gap between the text and its enclosing box.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To align and suppress zeros in tolerance values

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Tolerances tab, under
Tolerance Format, select the alignment from the Vertical Position list.

4 To suppress zeros in primary or alternate units, under Zero Suppression,
select Leading to suppress leading zeros. Select Trailing to suppress trailing
zeros.

5 Click OK.

6 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE
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Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

System Variables

DIMALTTD

Sets the number of decimal places for the tolerance values in the alternate
units of a dimension.

DIMALTTZ

Controls suppression of zeros in tolerance values.

DIMGAP

Sets the distance around the dimension text when the dimension line breaks
to accommodate dimension text.

DIMLIM

Generates dimension limits as the default text.

DIMTDEC

Sets the number of decimal places to display in tolerance values for the
primary units in a dimension.

DIMTFAC

Specifies a scale factor for the text height of fractions and tolerance values
relative to the dimension text height, as set by DIMTXT.

DIMTM

Sets the minimum (or lower) tolerance limit for dimension text when
DIMTOL or DIMLIM is on.

DIMTOL

Appends tolerances to dimension text.

DIMTP

Sets the maximum (or upper) tolerance limit for dimension text when
DIMTOL or DIMLIM is on.
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DIMTZIN

Controls the suppression of zeros in tolerance values.

Utilities

No entries

Command Modifiers

No entries

Control the Display of Fractions
You can control the format of the fraction displayed in dimensions.

You can set the fraction format in dimensions using the DIMFRAC system
variable when the DIMLUNIT system variable is set to 4(architecture) or 5
(fractional).

The following illustration shows the different fraction formats available.

These settings are available on the Primary Units tab of the Dimension Style
Manager.

To specify the fraction format

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Primary Units tab, under
Linear dimensions, select one of the following from Fraction format:

■ Horizontal

■ Diagonal
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■ Not Stacked

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

Quick Reference

Commands

DIMSTYLE

Creates and modifies dimension styles.

System Variables

DIMFRAC

Sets the fraction format when DIMLUNIT is set to 4 (Architectural) or 5
(Fractional).

DIMLUNIT

Sets units for all dimension types except Angular.

Utilities

No entries

Command Modifiers

No entries

Set the Scale for Dimensions
You can specify the size of dimensions in your drawing. How you set dimension
size depends on the method you use to lay out and plot drawings.

Dimension scale affects the size of the dimension geometry relative to the
objects in the drawing. Dimension scale affects sizes, such as text height and
arrowhead size, and offsets, such as the extension line origin offset. You should
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set these sizes and offsets to values that represent their actual plotted size.
Dimension scale does not apply the overall scale factor to tolerances or
measured lengths, coordinates, or angles.

NOTE You can use annotative scaling to control the overall scale of dimensions
displayed in layout viewports. When you create annotative dimensions, they are
scaled based on the current annotation scale setting and automatically displayed
at the correct size.

Setting dimension scale depends on how you lay out your drawing. There are
three methods used to create dimensions in a drawing layout:

■ Dimension in model space for plotting in model space. This is the
traditional method used with single-view drawings. To create dimensions
that are scaled correctly for plotting, set the DIMSCALE system variable to
the inverse of the intended plot scale. For example, if the plot scale is 1/4,
set DIMSCALE to 4.

■ Dimension in model space for plotting in paper space. This was the
preferred method for complex, multiple-view drawings prior to AutoCAD
2002. Use this method when the dimensions in a drawing need to be
referenced by other drawings (xrefs) or when creating isometric dimensions
in 3D isometric views. To prevent the dimensions in one layout viewport
from being displayed in other layout viewports, create a dimensioning
layer for each layout viewport that is frozen in all other layout viewports.
To create dimensions that are scaled automatically for display in a paper
space layout, set the DIMSCALE system variable to 0.

■ Dimension in layouts. This is the simplest dimensioning method.
Dimensions are created in paper space by selecting model space objects or
by specifying object snap locations on model space objects. By default,
associativity between paper space dimensions and model space objects is
maintained. No additional scaling is required for dimensions created in a
paper space layout: DIMLFAC and DIMSCALE do not need to be changed
from their default value of 1.0000.

NOTE When you dimension model space objects in paper space using associative
dimensions, dimension values for the display scale of each viewport are
automatically adjusted. This adjustment is combined with the current setting for
DIMLFAC and is reported by the LIST command as a dimension style override. For
nonassociative dimensions, you must set DIMLFAC manually.
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See also:

■ Draw, Scale, and Annotate in Model Space on page 425

■ Scale Views in Layout Viewports on page 456

■ Scale Annotations on page 1393

To set the overall dimension scale

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In Modify Dimension Style dialog box, Fit tab, under Scale for Dimension
Features, enter a value for the overall scale.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To set the dimension scale for model space dimensions in layouts

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In Modify Dimension Style dialog box, Fit tab, under Scale for Dimension
Features, select Scale Dimension to Layout (Paper space).

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
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Command entry: DIMSTYLE

To set dimension scale for creating dimensions in a layout

1 Click a layout tab to switch to paper space.

2 To create dimensions in paper space with the correct model space
dimension values, use object snap modes to snap to points in model
space from paper space or select the objects directly.

The DIMLFAC system variable can be changed if you need to convert the
linear dimension values between the imperial and metric measurement
systems.

Quick Reference

Commands

DIMREGEN

Updates the locations of all associative dimensions.

DIMSTYLE

Creates and modifies dimension styles.

System Variables

DIMASSOC

Controls the associativity of dimension objects and whether dimensions are
exploded.

DIMLFAC

Sets a scale factor for linear dimension measurements.

DIMSCALE

Sets the overall scale factor applied to dimensioning variables that specify
sizes, distances, or offsets.
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Utilities

No entries

Command Modifiers

No entries

Create Dimensions
You can create all of the standard types of dimensions.

Create Linear Dimensions
You can create linear dimensions with horizontal, vertical, and aligned
dimension lines. These linear dimensions can also be stacked, or they can be
created end to end.

Overview of Creating Linear Dimensions
Linear dimensions can be horizontal, vertical, or aligned. With aligned
dimensions, the dimension line is parallel to the line (imaginary or real)
between the extension line origins. Baseline (or parallel) and continued (or
chain) dimensions are series of consecutive dimensions that are based on a
linear dimension.

In all four illustrations, the extension line origins are designated explicitly at
1 and 2, respectively. The dimension line location is specified at 3.
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As you create linear dimensions, you can modify the content of the text, the
angle of the text, or the angle of the dimension line.

Quick Reference

Commands

DIMALIGNED

Creates an aligned linear dimension.

DIMBASELINE

Creates a linear, angular, or ordinate dimension from the baseline of the
previous or selected dimension.

DIMCONTINUE

Creates a dimension that starts from an extension line of a previously created
dimension.

DIMEDIT

Edits dimension text and extension lines.

DIMLINEAR

Creates a linear dimension.
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DIMSTYLE

Creates and modifies dimension styles.

QDIM

Quickly creates a series of dimensions from selected objects.

System Variables

DIMDLI

Controls the spacing of the dimension lines in baseline dimensions.

Utilities

No entries

Command Modifiers

No entries

Create Horizontal and Vertical Dimensions
You can create dimensions using only the horizontal or vertical components
of the locations or objects that you specify.

The program automatically applies a horizontal or vertical dimension according
to the extension line origins that you specify or the location where you select
an object; however, you can override this as you create the dimension by
specifying that a dimension be horizontal or vertical. For example, in the
following illustration, a horizontal dimension is drawn by default unless you
specify a vertical one.
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To create a horizontal or vertical dimension

1 Click Home tab ➤ Annotation panel ➤ Linear. 

2 Press ENTER to select the object to dimension, or specify the first and
second extension line origins.

3 Before specifying the dimension line location, you can override the
dimension direction and edit the text, the text angle, or the dimension
line angle:

■ To rotate the extension lines, enter r (Rotated). Then enter the
dimension line angle.

■ To edit the text, enter m (multiline text). In the In-place Text Editor,
revise the text. Click OK.
Editing within or overwriting the brackets (<>) changes or removes
the dimension value calculated by the program. Adding text before
or after the brackets appends text before or after the dimension value.

■ To rotate the text, enter a (Angle). Then enter the text angle.

4 Specify the dimension line location.

Toolbar: Dimension  
Command entry: DIMLINEAR

Quick Reference

Commands

DIMLINEAR

Creates a linear dimension.

System Variables

DIMEXO

Specifies how far extension lines are offset from origin points.
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Utilities

No entries

Command Modifiers

No entries

Create Aligned Dimensions
You can create dimensions that are parallel to the locations or objects that
you specify.

In aligned dimensions, the dimension line is parallel to the extension line
origins. The illustration shows two examples of aligned dimensioning. The
object is selected (1), and the location of the aligned dimension is specified
(2). The extension lines are drawn automatically.

To create an aligned dimension

1 Click Home tab ➤ Annotation panel ➤ Aligned. 

2 Press ENTER to select the object to dimension, or specify the first and
second extension line origins.

3 Before specifying the dimension line location, you can edit the text or
change the text angle. Editing within or overwriting the brackets (<>)
changes or removes the dimension value calculated by the program.
Adding text before or after the brackets appends text before or after the
dimension value.

■ To edit the text using multiline text, enter m (multiline text). In the
In-place Text Editor, revise the text. Click OK.
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■ To edit the text using single-line text, enter t (Text). Revise the text
at the command prompt and press ENTER.

■ To rotate the text, enter a (Angle). Then enter the text angle.

4 Specify the dimension line location.

Toolbar: Dimension  
Command entry: DIMALIGNED

Quick Reference

Commands

DIMALIGNED

Creates an aligned linear dimension.

DIMSTYLE

Creates and modifies dimension styles.

System Variables

DIMEXO

Specifies how far extension lines are offset from origin points.

Utilities

No entries

Command Modifiers

No entries

Create Baseline and Continued Dimensions
Baseline dimensions are multiple dimensions measured from the same baseline.
Continued dimensions are multiple dimensions placed end to end.

You must create a linear, aligned, or angular dimension before you create
baseline or continued dimensions. You create baseline dimensions
incrementally from the most recently created dimension in the current session.
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Both baseline and continued dimensions are measured from the previous
extension line unless you specify another point as the point of origin.

To create a baseline linear dimension

1 Click Annotate tab ➤ Dimensions panel ➤ Baseline. 

By default, the origin of the last linear dimension created is used as the
first extension line for the new baseline dimension. You are prompted
for the second dimension line.

2 Use an object snap to select the second extension line origin, or press
ENTER to select any dimension as the base dimension.

The program automatically places the second dimension line at the
distance specified by the Baseline Spacing option in the Dimension Style
Manager, Lines tab.

3 Use an object snap to specify the next extension line origin.

4 Continue to select extension line origins as required.

5 Press ENTER twice to end the command.

Toolbar: Dimension  
Command entry: DIMBASELINE

To create a continued linear dimension

1 Click Annotate tab ➤ Dimensions panel ➤ Continue. 
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The program uses the origin of the second extension line of the existing
dimension as the first extension line origin.

2 Use object snaps to specify additional extension line origins.

3 Press ENTER twice to end the command.

Toolbar: Dimension  
Command entry: DIMCONTINUE

Quick Reference

Commands

DIMBASELINE

Creates a linear, angular, or ordinate dimension from the baseline of the
previous or selected dimension.

DIMCONTINUE

Creates a dimension that starts from an extension line of a previously created
dimension.

DIMSTYLE

Creates and modifies dimension styles.

System Variables

DIMDLI

Controls the spacing of the dimension lines in baseline dimensions.
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Utilities

No entries

Command Modifiers

No entries

Create Rotated Dimensions
In rotated dimensions, the dimension line is placed at an angle to the extension
line origins.

The illustration shows an example of a rotated dimension. In the example,
the angle specified for dimension rotation is equal to the angle of the slot.

To create a rotated dimension

1 Click Home tab ➤ Annotation panel ➤ Linear. 

2 Press ENTER to select the object to dimension or specify the first and
second extension line origins.

3 To rotate the dimension line, enter r (Rotated). Then enter the dimension
line angle.

4 Specify the dimension line location.

Toolbar: Dimension  
Command entry: DIMLINEAR
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Quick Reference

Commands

DIMALIGNED

Creates an aligned linear dimension.

DIMLINEAR

Creates a linear dimension.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create Dimensions with Oblique Extension Lines
You can create dimensions with extension lines that are not perpendicular to
their dimension lines.

Extension lines are created perpendicular to the dimension line. However, if
the extension lines conflict with other objects in a drawing, you can change
their angle after the dimension has been drawn.

New dimensions are not affected when you make an existing dimension
oblique.
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To make extension lines oblique

1 Click Annotate tab  ➤ Dimensions panel ➤ Oblique..

2 Select the dimension.

3 Enter a value for the angle of obliqueness, or specify two points.

Toolbar: Dimension   
Command entry: DIMEDIT

Quick Reference

Commands

DIMEDIT

Edits dimension text and extension lines.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create Radial Dimensions
Radial dimensions measure the radii and diameters of arcs and circles with
optional centerlines or a center mark.

There are two types of radial dimensions:

■ DIMRADIUS measures the radius of an arc or circle, and displays the
dimension text with the letter R in front of it.

■ DIMDIAMETER measures the diameter of an arc or circle, and displays the
dimension text with the diameter symbol in front of it.

For horizontal dimension text, if the angle of the radial dimension line is
greater than 15 degrees from horizontal, a hook line, also called a dogleg or
landing, one arrowhead long, is created next to the dimension text.

Control Extension Lines

When an arc is dimensioned, the radial or diametric dimension does not have
to be positioned along the arc directly. If a dimension is positioned past the
end of an arc, either an extension line will be drawn that follows the path of
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the arc being dimensioned or no extension line will be drawn. When the
extension line is suppressed (off), the dimension line of the radial or diametric
dimension is drawn through the center point of the arc instead of to the
extension line.

The DIMSE1 system variable controls whether or not a radial or diametric
dimension will be drawn with an extension line when it is positioned off the
end of an arc. When the display of the arc extension line is not suppressed,
a gap between the arc and arc extension line is made. The size of the gap
drawn is controlled with the DIMEXO system variable.

Control Centerlines and Center Marks

Depending on your dimension style settings, center marks and lines generate
automatically for diameter and radius dimensions. They are created only if
the dimension line is placed outside the circle or arc. You can create centerlines
and center marks directly with the DIMCENTER command.

You can control the size and visibility of centerlines and center marks on the
Modify Dimension Style dialog box, Symbols and Arrows tab, under Center
Marks. You can also access this setting with the DIMCEN system variable.
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The size of the centerline is the length of the centerline segment that extends
outside the circle or arc. It is also the size of the gap between the center mark
and the start of the centerline. The size of the center mark is the distance from
the center of the circle or arc to the end of the center mark.

Create Jogged Radius Dimensions

With the DIMJOGGED command, you can create jogged radius dimensions,
also called “foreshortened radius dimensions,” when the center of an arc or
circle is located off the layout and cannot be displayed in its true location.
The origin point of the dimension can be specified at a more convenient
location called the center location override.

You can control the default angle of the jog in the Modify Dimension Style
dialog box, Symbols and Arrows tab, under Radius Dimension Jog.
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Once a jogged radius dimension is created, you can modify the jog and the
center location override by

■ Using grips to move the features

■ Changing the locations of the features with the Properties palette

■ Using STRETCH

NOTE Jogged radius dimensions can be viewed but not edited in versions previous
to AutoCAD 2006. Also, if you make dramatic changes to the associated geometry,
you may get unpredictable results for the jogged radius dimension.

See also:

■ Fit Dimension Text Within Extension Lines on page 1646

To create a diameter dimension

1 Click Home tab ➤ Annotation panel ➤ Diameter. 

2 Select the arc or circle to dimension.

3 Enter options as needed:

■ To edit the dimension text content, enter t (Text) or m (multiline
text). Editing within or overwriting the brackets (<>) changes or
removes the dimension value. Adding text before or after the brackets
appends text before or after the dimension value.

■ To change the dimension text angle, enter a (Angle).

4 Specify the leader line location.
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Toolbar: Dimension  
Command entry: DIMDIAMETER

To create a radius dimension

1 Click Home tab ➤ Annotation panel ➤ Radius. 

2 Select an arc, circle, or polyline arc segment.

3 Enter options as needed:

■ To edit the dimension text content, enter t (Text) or m (multiline
text). Editing within or overwriting the brackets (<>) changes or
removes the dimension value. Adding text before or after the brackets
appends text before or after the dimension value.

■ To edit the dimension text angle, enter a (Angle).

4 Specify the leader line location.

Toolbar: Dimension  
Command entry: DIMRADIUS

To create a jogged radius dimension

1 Click Dimension menu  ➤ Jogged. 

2 Select an arc, circle, or polyline arc segment.

3 Specify a point for the dimension origin (the center location override).

4 Specify a point for the dimension line angle and the dimension text
location.

5 Specify another point for the location of the dimension jog.

Toolbar: Dimension  
Command entry: DIMJOGGED
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To create centerlines automatically with radial dimensions

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Symbols and Arrows tab,
under Center Marks, click Line.

4 In the Size box, enter the length of the centerline overshoot. Click OK.

5 Click Close to exit the Dimension Style Manager.

The example area in the dialog box displays the results of your changes.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To create centerlines or center marks on an arc or circle

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Symbols and Arrows tab,
under Center Marks, click Line.

4 In the Size box, enter the length of the centerline overshoot. Click OK.

5 Click Close to exit the Dimension Style Manager.

6 Click Annotate tab ➤ Dimensions panel ➤ Center Mark. 

7 Select an arc or a circle.

Toolbar: Dimension  
Command entry: DIMCENTER
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To change the display arc extension line for radial or diametric dimensions

1 Select the radial or diametric dimension for which you want to suppress
the arc extension line.

2 Right-click in the drawing. Click Properties.

3 In the Properties palette, Lines & Arrows category, click Ext Line.

4 Click the arrow next to Ext Line, and select On or Off from the list.

■ Select On to display the arc extension line.

■ Select Off to suppress the display of the arc extension line.

5 Press ESC to deselect the selected dimension.

Toolbar: Standard and Standard Annotation 
Command entry: PROPERTIES

Quick Reference

Commands

DIMCENTER

Creates the center mark or the centerlines of circles and arcs.

DIMDIAMETER

Creates a diameter dimension for a circle or an arc.

DIMJOGGED

Creates jogged dimensions for circles and arcs.

DIMRADIUS

Creates a radius dimension for a circle or an arc.

DIMSTYLE

Stores the name of the current dimension style.

QDIM

Quickly creates a series of dimensions from selected objects.
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System Variables

DIMATFIT

Determines how dimension text and arrows are arranged when space is not
sufficient to place both within the extension lines.

DIMCEN

Controls drawing of circle or arc center marks and centerlines by the
DIMCENTER, DIMDIAMETER, and DIMRADIUS commands.

DIMEXO

Specifies how far extension lines are offset from origin points.

DIMJOGANG

Determines the angle of the transverse segment of the dimension line in a
jogged radius dimension.

DIMJUST

Controls the horizontal positioning of dimension text.

DIMSE1

Suppresses display of the first extension line.

DIMTAD

Controls the vertical position of text in relation to the dimension line.

DIMTXTDIRECTION

Specifies the reading direction of the dimension text.

DIMTIH

Controls the position of dimension text inside the extension lines for all
dimension types except Ordinate.

DIMTMOVE

Sets dimension text movement rules.

DIMTOFL

Controls whether a dimension line is drawn between the extension lines
even when the text is placed outside.

DIMTOH

Controls the position of dimension text outside the extension lines.
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DIMUPT

Controls options for user-positioned text.

Utilities

No entries

Command Modifiers

No entries

Create Angular Dimensions
Angular dimensions measure the angle between two lines or three points.

To measure the angle between two radii of a circle, you select the circle and
specify the angle endpoints. With other objects, you select the objects and
then specify the dimension location. You can also dimension an angle by
specifying the angle vertex and endpoints. As you create the dimension, you
can modify the text content and alignment before specifying the dimension
line location.

NOTE You can create baseline and continued angular dimensions relative to
existing angular dimensions. Baseline and continued angular dimensions are limited
to 180 degrees or less. To obtain baseline and continued angular dimensions larger
than 180 degrees, use grip editing to stretch the location of the extension line of
an existing baseline or continued dimension.

Dimension Lines

If you use two straight, nonparallel lines to specify an angle, the dimension
line arc spans the angle between the two lines. If the dimension line arc does
not meet one or both of the lines being dimensioned, The program draws one
or two extension lines to intersect the dimension line arc. The arc is always
less than 180 degrees.

Dimension Circles and Arcs

If you use an arc or a circle or three points to specify an angle, the program
draws the dimension line arc between the extension lines. The extension lines
are drawn from the angle endpoints to the intersection of the dimension line
arc.
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The location that you specify for the dimension line arc determines the
quadrant of the dimensioned angle.

Dimension to a Quadrant

Angular dimensions can measure a specific quadrant that is formed when
dimensioning the angle between of the endpoints of a line or arc, center point
of a circle, or two vertices. As an angular dimension is being created, there are
four possible angles that can be measured. By specifying a quadrant it allows
you to ensure that the correct angle is dimensioned. When placing an angular
dimension after a quadrant has been specified, you can place the dimension
text outside of the extension lines of the dimension. The dimension line is
automatically extended.

To create an angular dimension

1 Click Home tab ➤ Annotation panel ➤ Angular. 

2 Use one of the following methods:

■ To dimension a circle, select the circle at the first endpoint of the
angle and then specify the second endpoint of the angle.

■ To dimension any other object, select the first line, and then select
the second line.
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3 Enter options as needed:

■ To edit the dimension text content, enter t (Text) or m (multiline
text). Editing within or overwriting the brackets (<>) changes or
removes the calculated dimension value. Adding text before or after
the brackets appends text before or after the dimension value.

■ To edit the dimension text angle, enter a (Angle).

■ To confine the dimension to a quadrant, enter q (Quadrant) and
specify the quadrant to measure.

4 Specify the dimension line arc location.

Toolbar: Dimension  
Command entry: DIMANGULAR

Quick Reference

Commands

DIMANGULAR

Creates an angular dimension.

DIMBASELINE

Creates a linear, angular, or ordinate dimension from the baseline of the
previous or selected dimension.

DIMCONTINUE

Creates a dimension that starts from an extension line of a previously created
dimension.

System Variables

DIMADEC

Controls the number of precision places displayed in angular dimensions.

DIMAUNIT

Sets the units format for angular dimensions.
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DIMDEC

Sets the number of decimal places displayed for the primary units of a
dimension.

Utilities

No entries

Command Modifiers

No entries

Create Ordinate Dimensions
Ordinate dimensions measure the perpendicular distance from an origin point
called the datum to a feature, such as a hole in a part. These dimensions prevent
escalating errors by maintaining accurate offsets of the features from the
datum.

Ordinate dimensions consist of an X or Y value with a leader line. X-datum
ordinate dimensions measure the distance of a feature from the datum along
the X axis. Y-datum ordinate dimensions measure the distance along the Y
axis.
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Locate the Datum

The location and orientation of the current UCS determines the ordinate
values. Before creating ordinate dimensions, you typically set the UCS origin
to coincide with the datum.

Locate the Leader

After you specify the feature location, you are prompted for the leader
endpoint. By default, the leader endpoint that you specify automatically
determines whether an X- or a Y-datum ordinate dimension is created. For
example, you can create an X-datum ordinate dimension by specifying a
location for the leader endpoint that is closer to vertical than horizontal.

After creating an ordinate dimension, you can easily relocate the dimension
leader and text using grip editing. The dimension text is always aligned with
the ordinate leader line.

To create ordinate dimensions

1 Click View tab ➤ Coordinates panel ➤ Origin. 

2 At the Specify New Origin Point prompt, specify an origin point.

The origin point specified is used to define the value assigned to the
ordinate dimension. Typically, the origin point is defined on the model.
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3 Click Home tab ➤ Annotation panel ➤ Ordinate. 

4 If straight ordinate leaders are required, turn Ortho mode on.

5 At the Select Feature Location prompt, specify a point location.

6 Enter x (X Datum) or y (Y Datum).

You can skip this step by making sure that the ordinate leader endpoint
is close to vertical for an X datum or close to horizontal for a Y datum.

7 Specify the ordinate leader endpoint.

Toolbar: Dimension  
Command entry: DIMORDINATE

Quick Reference

Commands

DIMORDINATE

Creates ordinate dimensions.

QDIM

Quickly creates a series of dimensions from selected objects.

UCS

Manages user coordinate systems.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create Arc Length Dimensions
Arc length dimensions measure the distance along an arc or polyline arc
segment.

Typical uses of arc length dimensions include measuring the travel distance
around a cam or indicating the length of a cable. To differentiate them from
linear or angular dimensions, arc length dimensions display an arc symbol
by default.

The arc symbol, also called a hat or cap, is displayed either above the dimension
text or preceding the dimension text. You can specify the placement style
using the Dimension Style Manager. The placement style can be changed on
the Symbols and Arrows tab of either the New Dimension Style dialog box or
the Modify Dimension Style dialog box.

The extension lines of an arc length dimension can be orthogonal or radial.
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NOTE Orthogonal extension lines are displayed only when the included angle of
the arc is less than 90 degrees.

To create an arc length dimension

1 Click Home tab ➤ Annotation panel ➤ Arc Length. 

2 Select an arc or polyline arc segment.

3 Specify the dimension line location.

Toolbar: Dimension  
Command entry: DIMARC

Quick Reference

Commands

DIMARC

Creates an arc length dimension.

DIMSTYLE

Creates and modifies dimension styles.

PROPERTIES

Controls properties of existing objects.

System Variables

DIMARCSYM

Controls display of the arc symbol in an arc length dimension.
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Utilities

No entries

Command Modifiers

No entries

Modify Existing Dimensions
You can modify all components of the existing dimension objects in a drawing
either individually or by using dimension styles.

Apply a New Dimension Style to Existing Dimensions
You can modify existing dimensions by applying a different dimension style.
If you make changes to a dimension style, you can choose whether to update
the dimensions associated with that dimension style.

When you create a dimension, the current dimension style is associated with
that dimension. The dimension retains this dimension style unless you apply
a new dimension style to it or set up dimension style overrides.

You can modify existing dimensions by applying a different dimension style.
If you make changes to a dimension style, you can choose whether to update
the dimensions associated with that dimension style.

You can restore an existing dimension style or apply the current dimension
style, including any dimension style overrides, to selected dimensions.

To apply the current dimension style to existing dimensions

1 Click Annotate tab  ➤  Dimensions panel  ➤  Update.

2 Select the dimensions to update to the current dimension style.

3 Press ENTER.

Toolbar: Dimension, Update  
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Command entry: DIMSTYLE

To restore a dimension style

1 Click Home tab  ➤  Annotation panel  ➤  Dimension Style.

2 In the Dimension Style Manager, select the dimension style to restore.
Click Set Current.

3 Click Close.

Toolbar: Dimension  
Command entry: DIMSTYLE

Alternate

■ On the Styles toolbar, click the arrow in the Dimension Styles control and
select a dimension style.

Quick Reference

Commands

DIMOVERRIDE

Controls overrides of system variables used in selected dimensions.

DIMSTYLE

Creates and modifies dimension styles.

PROPERTIES

Controls properties of existing objects.

System Variables

DIMCLRD

Assigns colors to dimension lines, arrowheads, and dimension leader lines.
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Utilities

No entries

Command Modifiers

No entries

Override a Dimension Style
With dimension style overrides, you can temporarily change a dimensioning
system variable without changing the current dimension style.

A dimension style override is a change made to specific settings in the current
dimension style. It is equivalent to changing a dimensioning system variable
without changing the current dimension style.

You can define dimension style overrides for individual dimensions, or for
the current dimension style.

■ For individual dimensions, you may want to create overrides to suppress
a dimension's extension lines or modify text and arrowhead placement so
that they do not overlap drawing geometry without creating a different
dimension style.

■ You can also set up overrides to the current dimension style. All dimensions
you create in the style include the overrides until you delete the overrides,
save the overrides to a new style, or set another style current. For example,
if you choose Override in the Dimension Style Manager, and change the
color of extension lines on the Lines tab, the current dimension style
remains unchanged. However, the new value for color is stored in the
DIMCLRE system variable. The next dimension you create will have
extension lines in the new color. You can save the dimension style overrides
as a new dimension style.

Some dimension characteristics are common to a drawing or to a style of
dimensioning and are therefore suited to be permanent dimension style
settings. Others generally apply on an individual basis and can be applied
more effectively as overrides. For example, a drawing usually uses a single type
of arrowhead, so it makes sense to define the arrowhead type as part of the
dimension style. Suppression of extension lines, however, usually applies in
individual cases only and is more suited to a dimension style override.

There are several ways to set up dimension style overrides. You can change
options in the dialog boxes or change system variable settings at the command
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prompt. You reverse the override by returning the changed settings to their
original values. The overrides apply to the dimension you are creating and all
subsequent dimensions created with that dimension style until you reverse
the override or make another dimension style current.

Example: Change a Dimension Style Override at the Command Prompt

You can override the current dimension style while creating a dimension by
entering the name of any dimensioning system variable at any prompt. In
this example, the dimension line color is changed. The change affects
subsequent dimensions you create until you reverse the override or make
another dimension style current.

Command: dimoverride
Enter dimension variable name to override or [Clear overrides]: dimclrd
Enter new value for dimension variable <BYBLOCK>: 5
Enter dimension variable name to override: Enter another dimension variable
name or press ENTER
Select objects: Use an object selection method and press ENTER when you finish

To set up dimension style overrides

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, under Styles, select the dimension style
for which you want to create an override. Click Override.

3 In the Override Current Style dialog box, make changes to the dimension
style by clicking the appropriate tab.

4 Click OK to return to the Dimension Style Manager.

The dimension style overrides are listed below the style they modify in
the dimension style name list.

5 Click Close.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE
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To apply dimension style overrides

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, click Override.

3 In the Override Current Style dialog box, enter the style overrides. Click
OK.

The program displays <style overrides> below the dimension style name
in the Dimension Style Manager dialog box. After you create dimension
style overrides, you can continue to modify dimension styles, compare
them with other dimension styles, or delete or rename the overrides.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

Quick Reference

Commands

DIMOVERRIDE

Controls overrides of system variables used in selected dimensions.

DIMSTYLE

Creates and modifies dimension styles.

PROPERTIES

Controls properties of existing objects.

System Variables

DIMCLRD

Assigns colors to dimension lines, arrowheads, and dimension leader lines.
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Utilities

No entries

Command Modifiers

No entries

Modify A Dimension
Dimensions can be modified to include more information than just the values
of the dimension. Dimensions can also be modified visually by using breaks
and by adjusting the spacing between them.

After you place a dimension, there are times when you need to modify the
information that the dimension represents. You can add a jog line to a linear
dimension to indicate that the dimension value does not represent the actual
dimensioned value or add an inspection dimension to represent how often a
dimension value of a manufactured part should be checked.

At times you might want to modify a dimension to simply improve readability.
You can make sure that the extension or dimension lines do not obscure any
objects; you can adjust the placement of linear dimensions so they are evenly
spaced.

Dimension Jog
Jog lines can be added to linear dimensions. Jog lines are used to represent a
dimension value that does not display the actual measurement. Typically, the
actual measurement value of the dimension is smaller than the displayed
value.

The jog is made up of two parallel lines and a cross line that forms two
40-degree angles. The height of the jog is determined by the linear jog size
value of the dimension style.

Modify A Dimension | 1709



Once you add a jog to a linear dimension, you can position it by using grips.
To reposition the jog, select the dimension and then select the grip. Move the
grip to another point along the dimension line. You can also adjust the height
of the jog symbol on a linear dimension on the Properties palette under Lines
& Arrows.

To add a jog to a linear dimension

1 Click Home tab ➤ Annotation panel ➤ Jog Line. 

2 Select a linear dimension.

3 Specify a point on the dimension line to place the jog.

Toolbar: Dimension  
Command entry: DIMJOGLINE

To add a jog to a linear dimension based on the midpoint of the selected
dimension line

1 Click Home tab ➤ Annotation panel ➤ Jog Line. 

2 Select a linear dimension.

3 Press ENTER to position the jog at the midpoint of the selected dimension
line.

Toolbar: Dimension  
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Command entry: DIMJOGLINE

To reposition a jog using grips

1 With no command active, select the linear dimension that has the jog
you want to reposition.

2 Select the grip in the middle of the jog.

The selected grip is highlighted, and the default grip mode, Stretch, is
active.

3 Drag the crosshairs along the dimension line and click to reposition the
jog.

TIP If you want to place the jog along the dimension line without changing
the position of the dimension line, turn Ortho mode on.

Toolbar: Dimension  
Command entry: DIMJOGLINE

To remove a jog

1 Click Home tab ➤ Annotation panel ➤ Jog Line. 

2 Enter r (Remove) and press ENTER.

3 Select the linear dimension to remove the jog from.

Toolbar: Dimension  
Command entry: DIMJOGLINE

To modify the height of a jog using the Properties palette

1 With no command active, select the linear dimension with the jog whose
height you want to change.

2 Right-click over the drawing window. Click Properties.

3 On the Properties palette, expand Lines & Arrows.

4 Select Jog Height Factor, and enter a new height for the jog.
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5 Click outside the Properties palette. Press ESC.

Toolbar: Dimension  
Command entry: DIMJOGLINE

Quick Reference

Commands

DIMALIGNED

Creates an aligned linear dimension.

DIMBASELINE

Creates a linear, angular, or ordinate dimension from the baseline of the
previous or selected dimension.

DIMCONTINUE

Creates a dimension that starts from an extension line of a previously created
dimension.

DIMJOGLINE

Adds or removes a jog line on a linear or aligned dimension.

DIMLINEAR

Creates a linear dimension.

DIMSTYLE

Creates and modifies dimension styles.

QDIM

Quickly creates a series of dimensions from selected objects.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Inspection Dimension
Inspection dimensions allow you to effectively communicate how frequently
manufactured parts should be checked to ensure that the dimension value
and tolerances of the parts are within the specified range.

When working with parts that need to met a specific tolerance or dimension
value before installing them into the final assembled product, you can use an
inspection dimension to specify how often the part should be tested.

You can add an inspection dimension to any type of dimension object; it is
composed of a frame and text values. The frame for an inspection dimension
is made up of two parallel lines and the end is round or square. The text values
are separated by vertical lines. An inspection dimension can contain up to
three different fields of information: inspection label, dimension value, and
inspection rate.

Inspection Dimension Fields
Inspection Label Text used to identify individual inspection dimensions. The
label is located in the leftmost section of the inspection dimension.

Dimension Value Dimension value that is displayed is the same value before
the inspection dimension is added. The dimension value can contain
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tolerances, text (both prefix and suffix), and the measured value. The
dimension value is located in the center section of the inspection dimension.

Inspection Rate Text used to communicate the frequency that the dimension
value should be inspected, expressed as a percentage. The rate is located in
the rightmost section of the inspection dimension.

You can add inspection dimensions to any type of dimension. The current
values of an inspection dimension are displayed on the Properties palette,
under Misc. The values include the properties that are used to control the look
of the frame, and the text for both the label and rate values.

To create an inspection dimension

1 Click Annotate tab ➤ Dimensions panel ➤ Inspect. 

2 In the Inspection Dimension dialog box, click Select Dimensions.

The Inspection Dimension dialog box closes. You are prompted to select
dimensions.

3 Select the dimension you want to make an inspection dimension. Press
ENTER to return to the dialog box.

4 Under the Shape section, specify the frame type.

5 Under the Label/Inspection rate section, specify the desired options.

■ Select the Label check box, and enter the desired label in the text box.

■ Select the Inspection Rate check box, and enter the desired rate in the
text box.

6 Click OK.

Toolbar: Dimension  
Command entry: DIMINSPECT

To modify an inspection dimension from the Inspection dialog box

1 Click Annotate tab ➤ Dimensions panel ➤ Inspect. 

2 In the Inspection Dimension dialog box, click Select Dimensions.

1714 | Chapter 27   Dimensions and Tolerances



The Inspection Dimension dialog box closes. You are prompted to select
dimensions.

3 Select the inspection dimension you want to modify. Press ENTER to
return to the dialog box.

4 Under the Shape section, make the desired changes to the frame type.

5 Under the Label/Inspection rate section, make the desired changes to the
label and inspection rate.

6 Click OK.

Toolbar: Dimension  
Command entry: DIMINSPECT

To remove an inspection dimension

1 Click Annotate tab ➤ Dimensions panel ➤ Inspect. 

2 In the Inspection Dimension dialog box, click Select Dimensions.

The Inspection Dimension dialog box closes. You are prompted to select
dimensions.

3 Select the dimension you want to remove the inspection dimension from.
Press ENTER to return to the dialog box.

4 Click Remove Inspection.

5 Click OK.

Toolbar: Dimension  
Command entry: DIMINSPECT

To modify an inspection dimension using the Properties palette

1 With no command active, select the inspection dimension you want to
modify.

2 Right-click over the drawing window. Click Properties.
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3 On the Properties palette, double-click the Misc caption of the pane to
expand it.

4 Specify the new values for the Inspection shape, label, and rate.

5 Click outside the Properties palette. Press ESC.

Toolbar: Dimension  
Command entry: DIMINSPECT

Quick Reference

Commands

DIMINSPECT

Adds or removes inspection information for a selected dimension.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Dimension Breaks
With dimension breaks, you can keep the dimension, extension, or leader
lines from appearing as if they are a part of the design.

Dimension breaks can be added to a dimension or a multileader automatically
or manually. The method that you choose to place dimension breaks depends
on the number of objects that intersect a dimension or multileader.
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You can add dimension breaks to the following dimension and leader objects:

■ Linear dimensions (aligned and rotated)

■ Angular dimensions (2- and 3-point)

■ Radial dimensions (radius, diameter, and jogged)

■ Arc length dimensions

■ Ordinate dimensions

■ Multileaders (straight only)

The following dimension and leader objects do not support dimension breaks:

■ Multileaders (spline only)

■ “Legacy” leaders (straight or spline)

The following table explains the conditions where dimension breaks do not
work or are not supported.

Dimension Break Exceptions

DescriptionCondition

Dimension breaks on dimensions or multileaders in xrefs
and blocks are not supported. However, the objects in an

No break in xrefs or
blocks

xref or block can be used as the cutting edges for dimension
breaks on dimensions or multileaders that are not in an
xref or block.

Dimension breaks cannot be placed on an arrowhead or
the dimension text. If you want a break to appear at the

No break on arrow-
head and dimension
text dimension text, it is recommended to use the background
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Dimension Break Exceptions

DescriptionCondition

mask option. If the intersecting point of an object and the
dimension are at the arrowhead or dimension text, the
break will not be displayed until the intersecting object, or
dimension or multileader are moved.

Automatic breaks are not supported for objects and dimen-
sions or multileaders that are in different spaces. In order

No break on trans-
spatial dimensions

to break a dimension or multileader that is in a different
space, you need to use the Manual option of the DIMBREAK
command.

You can move dimension breaks from dimensions or multileaders. When
removing dimension breaks from a dimension or multileader, all dimension
breaks are removed. If there are some dimension breaks that you don’t want
to remove, you need to add them again.

The following objects can be used as cutting edges when adding a dimension
break:

■ Dimension

■ Leader

■ Line

■ Circle

■ Arc

■ Spline

■ Ellipse

■ Polyline

■ Text

■ Multiline text

■ Blocks but limited to the previously mentioned objects in this list

■ Xrefs but limited to the previously mentioned objects in this list
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Automatic Dimension Breaks

To create an automatically placed dimension break, you select a dimension
or multileader, and then use the Auto option of the DIMBREAK command.
Automatic dimension breaks are updated any time the dimension or
multileader, or intersecting objects are modified.

You control the size of automatically placed dimension breaks on the Symbols
and Arrows tab of the Dimension Style dialog box. The specified size is affected
by the dimension break size, dimension scale, and current annotation scale
for the current viewport. For more information about annotation scaling, see
Scale Annotations on page 1393.

Dimension Break Created by Selecting an Object

Instead of placing a dimension break for each object that intersects a dimension
or multileader, you can specify which of the intersecting objects to use.
Dimension breaks that are added by selecting individual intersecting objects
are updated any time the dimension or multileader, or intersecting objects
are modified.

Dimension Break Created by Picking Two Points

You can place a dimension break by picking two points on the dimension,
extension, or leader line to determine the size and placement of the break.
Dimension breaks that are added manually by picking two points are not
automatically updated if the dimension or multileader, or intersecting object
is modified.

So if a dimension or multileader with a manually added dimension break is
moved or the intersecting object is modified, you might have to restore the
dimension or multileader, and then add the dimension break again. The size
of a dimension break that is created by picking two points is not affected by
the current dimension scale or annotation scale value for the current viewport.

To automatically create dimension breaks for each intersecting object

1 Click Annotate tab ➤ Dimensions panel ➤ Break. 

2 Select a dimension or multileader.

3 Enter a (Auto) and press ENTER.
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Toolbar: Dimension  
Command entry: DIMBREAK

To create a single dimension break based on an intersecting object

1 Click Annotate tab ➤ Dimensions panel ➤ Break. 

2 Select a dimension or multileader.

3 Select an object that intersects the dimension or multileader. Press ENTER.

Toolbar: Dimension  
Command entry: DIMBREAK

To create a manual dimension break

1 Click Annotate tab ➤ Dimensions panel ➤ Break. 

2 Select a dimension or multileader.

3 Enter m (Manual) and press ENTER.

4 Specify the first point on the dimension, extension, or leader line for the
dimension break.

5 Specify the second point along the dimension, extension, or leader line
for the dimension break.

Toolbar: Dimension  
Command entry: DIMBREAK

To create dimension breaks for multiple dimensions or multileaders at one
time

1 Click Annotate tab ➤ Dimensions panel ➤ Break. 
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2 Enter m (Multiple) and press ENTER.

3 Select the dimensions or multileaders to which to add the dimension
breaks.

4 Enter a (Auto) and press ENTER.

Toolbar: Dimension  
Command entry: DIMBREAK

To remove all dimension breaks from a dimension or multileader

1 Click Annotate tab ➤ Dimensions panel ➤ Break. 

2 Select a dimension or multileader.

3 Enter r (Remove) and press ENTER.

Toolbar: Dimension  
Command entry: DIMBREAK

To remove all dimension breaks from multiple dimensions or multileaders

1 Click Annotate tab ➤ Dimensions panel ➤ Break. 

2 Enter m (Multiple), and press ENTER.

3 Select the dimensions or multileaders from which to remove the
dimension breaks, and press ENTER.

4 Enter r (Remove), and press ENTER.

Toolbar: Dimension  
Command entry: DIMBREAK
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Quick Reference

Commands

DIMBREAK

Breaks or restores dimension and extension lines where they cross other
objects.

DIMSTYLE

Creates and modifies dimension styles.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Adjust Dimension Spacing
You can automatically adjust existing parallel linear and angular dimensions
in a drawing so they are equally spaced or aligned at the dimension line with
each other.

Parallel linear and angular dimensions can be created in a number of different
ways in a drawing. With the DIMLINEAR and DIMANGULAR commands you
can place one dimension at a time; you can use the DIMBASELINE and
DIMCONTINUE commands to help place additional linear dimensions based
on the previous linear dimension placed.

The DIMBASELINE command uses the DIMDLI system variable to create
equally spaced dimensions, but once the dimensions are placed, changing the
value of the system variable has no affect on the spacing of dimensions. If
you change the text size or adjust the scale for the dimensions, they remain
in the original position which can cause problems with overlapping dimension
lines and text.

You can space linear and angular dimensions that overlap or are not equally
spaced with the DIMSPACE command. The dimensions that are selected must
be linear or angular, of the same type (rotated or aligned), parallel or concentric
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to one another, and on the extension lines of each other. You can also align
linear and angular dimensions by using a spacing value of 0.

The following illustration shows parallel linear dimensions that are not equally
spaced and then those that are equally spaced after using the DIMSPACE
command.

To equally space parallel linear and angular dimensions automatically

1 Click Annotate tab ➤ Dimensions panel ➤ Adjust Space. 

2 Select the dimension that you want to use as the base dimension when
equally spacing dimensions.

3 Select the next dimension to equally space.

4 Continue to select dimensions and then press ENTER.

5 Enter a (Auto) and press ENTER.

Toolbar: Dimension  
Command entry: DIMSPACE

To equally space parallel linear and angular dimensions based on a distance

1 Click Annotate tab ➤ Dimensions panel ➤ Adjust Space. 

2 Select the dimension that you want to use as the base dimension when
equally spacing dimensions.

3 Select the next dimension to equally space.

4 Continue to select dimensions and then press ENTER.
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5 Enter a spacing value and press ENTER.

Toolbar: Dimension  
Command entry: DIMSPACE

To align parallel linear and angular dimensions

1 Click Annotate tab ➤ Dimensions panel ➤ Adjust Space. 

2 Select the dimension that you want to use as the base dimension when
equally spacing dimensions.

3 Select the next dimension to align.

4 Continue to select dimensions and then press ENTER.

5 Enter 0 and press ENTER.

Toolbar: Dimension  
Command entry: DIMSPACE

Quick Reference

Commands

DIMALIGNED

Creates an aligned linear dimension.

DIMANGULAR

Creates an angular dimension.

DIMBASELINE

Creates a linear, angular, or ordinate dimension from the baseline of the
previous or selected dimension.

DIMCONTINUE

Creates a dimension that starts from an extension line of a previously created
dimension.
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DIMLINEAR

Creates a linear dimension.

DIMSPACE

Adjusts the spacing between linear dimensions or angular dimensions.

DIMSTYLE

Creates and modifies dimension styles.

QDIM

Quickly creates a series of dimensions from selected objects.

System Variables

DIMDLI

Controls the spacing of the dimension lines in baseline dimensions.

Utilities

No entries

Command Modifiers

No entries

Modify Dimension Text
Once you've created a dimension, you can change the location and orientation
of the existing dimension text or replace it with new text.

Once you've created a dimension, you can rotate the existing text or replace
it with new text. You can move the text to a new location or back to its home
position, which is the position defined by the current dimension style. In the
following illustration, the home position is above and centered on the
dimension line.
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When you rotate or replace dimension text, you specify the change first, for
example, rotating the text to be at an angle. When you move dimension text,
you select a single dimension to move.

You can move dimension text to the left, right, or center along the dimension
line or to any position inside or outside the extension lines. A quick and simple
way to do this is by using grips. If you move text up or down, the current
vertical alignment of the text relative to the dimension line is not changed,
so the dimension and extension lines are modified accordingly. The following
illustration shows the result of moving text down and to the right. The text
remains centered vertically in relation to the dimension line.

See also:

■ Control Dimension Text on page 1646

To rotate dimension text

1 tab ➤ panel ➤ . 
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2 Select the dimension to edit.

3 Enter the new angle for the text.

Toolbar: Dimension 
Command entry: DIMTEDIT

To return dimension text to its home position

1 Click Dimension menu  ➤ Align Text  ➤ Home.

2 Select the dimension text you want to return to its home position.

Toolbar: Dimension  
Command entry: DIMTEDIT

To replace existing dimension text with new text

1 Click Modify menu  ➤ Object  ➤ Text  ➤ Edit.

2 Select the dimension text you want to edit.

3 In the In-Place Text Editor, enter the new dimension text. Click OK.

Toolbar: Text  
Command entry: DDEDIT

To move text to the left side of the dimension line

1 Click Annotate tab  ➤  Dimensions panel  ➤  Left Justify. 

2 Select the dimension.

The dimension text is left-justified along the dimension line inside the
extension lines. You can choose the Center or Right options to move the
text to the center or right of the dimension line.
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Toolbar: Dimension  
Command entry: DIMTEDIT

To set dimension line spacing for baseline and continued dimensions

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Lines tab, under Dimension
Lines, enter in the Baseline Spacing box the offset distance between
dimension lines for baseline and continued dimensions.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE

To change the extension origin offset

1 Click Home tab ➤ Annotation panel ➤ Dimension Style. 

2 In the Dimension Style Manager, select the style you want to change.
Click Modify.

3 In the Modify Dimension Style dialog box, Lines tab, under Extension
Lines, enter the new value for Offset from Origin.

4 Click OK.

5 Click Close to exit the Dimension Style Manager.

Toolbar: Dimension or Styles  
Command entry: DIMSTYLE
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Quick Reference

Commands

DDEDIT

Edits single-line text, dimension text, attribute definitions, and feature control
frames.

DIMEDIT

Edits dimension text and extension lines.

DIMTEDIT

Moves and rotates dimension text and relocates the dimension line.

PROPERTIES

Controls properties of existing objects.

System Variables

DIMCLRT

Assigns colors to dimension text.

DIMDSEP

Specifies a single-character decimal separator to use when creating dimensions
whose unit format is decimal.

DIMJUST

Controls the horizontal positioning of dimension text.

DIMTAD

Controls the vertical position of text in relation to the dimension line.

DIMTXTDIRECTION

Specifies the reading direction of the dimension text.

DIMTIH

Controls the position of dimension text inside the extension lines for all
dimension types except Ordinate.

DIMTMOVE

Sets dimension text movement rules.

Modify Dimension Text | 1729



DIMTOH

Controls the position of dimension text outside the extension lines.

DIMTVP

Controls the vertical position of dimension text above or below the dimension
line.

DIMUPT

Controls options for user-positioned text.

MTEXTED

Sets the application for editing multiline text objects.

Utilities

No entries

Command Modifiers

No entries

Modify Dimension Geometry
Grip editing is the quickest and easiest way to modify the location of
dimension elements. How you edit dimensions depends whether the dimension
is associative.

You can modify dimensions with the editing commands and with grip editing.
Grip editing is the quickest and easiest way to modify dimensions. How you
edit dimensions depends on whether the dimension is associative.

Modify Associative Dimensions

Associative dimensions retain their associativity to dimensioned objects
through many editing commands if both the dimension and the associated
geometry are selected and operated on with a single command. For example,
if a dimension and its associated geometry are moved, copied, or arrayed in
the same command, each dimension retains associativity with its respective
geometry.

In some circumstances, dimensions are automatically disassociated, including

■ If the associated geometric object is erased
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■ If the associated geometric object undergoes a Boolean operation such as
UNION or SUBTRACT

■ If grip editing is used to stretch a dimension parallel to its dimension line

■ If the association to a geometric object is specified using the Apparent
Intersection object snap, and the geometric object is moved so that the
apparent intersection no longer exists

In other circumstances, a dimension may become partially associated. For
example, if a linear dimension is associated with the endpoints of two
geometric objects and one of the objects is erased, the remaining association
is preserved. The disassociated end of the linear dimension may then be
associated with another geometric object using DIMREASSOCIATE.

NOTE The command prompt displays a warning message if a dimension is
disassociated.

Modify Nonassociative Dimensions

For nonassociative dimensions, when you edit dimensioned objects, you must
include the relevant dimension definition points in the selection set, or the
dimension is not updated. Definition points determine the dimension location.
For example, to stretch a dimension, you must include the appropriate
definition points in the selection set. You can easily include them by turning
on grips and selecting the object so that the grips are highlighted.

The definition points for each type of dimension are indicated in the following
illustrations. The middle point of the dimension text is a definition point for
all dimension types.
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If no angle vertex is shown, definition points are placed at the ends of the
lines that form the angle. In the two-line angular example, a definition point
is placed at the center point of the dimensioned arc.

NOTE Definition points are drawn on a special layer named DEFPOINTS, which
is not plotted.

Modify Exploded Dimensions

You can edit exploded dimensions as you would any other objects because
an exploded dimension is a collection of separate objects: lines, 2D solids, and
text. Occasionally you may need to explode a dimension to make changes
such as creating a break in a dimension line or extension line. Once a
dimension is exploded, you cannot reassociate the dimension into a dimension
object.
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See also:

■ Control Dimension Geometry on page 1635

Quick Reference

Commands

DIMEDIT

Edits dimension text and extension lines.

DIMDISASSOCIATE

Removes associativity from selected dimensions.

DIMREASSOCIATE

Associates or reassociates selected dimensions to objects or points on objects.

EXPLODE

Breaks a compound object into its component objects.

STRETCH

Stretches objects crossed by a selection window or polygon.

System Variables

DIMASSOC

Controls the associativity of dimension objects and whether dimensions are
exploded.

Utilities

No entries

Command Modifiers

No entries

Change Dimension Associativity
You may need to change the associativity of dimensions in several
circumstances including adding associativity to dimensions created in previous
releases.
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You may need to change the associativity of dimensions in several
circumstances such as the following:

■ Redefine the associativity of dimensions in drawings that have been edited
significantly.

■ Add associativity to dimensions that have been partially disassociated.

■ Add associativity to dimensions in legacy drawings.

■ Remove associativity from dimensions in drawings that will be used by
people working in releases prior to AutoCAD 2002, but who do not want
any proxy objects in the drawings.

Reassociate Dimensions to Different Objects

With DIMREASSOCIATE, you can select one or more dimensions and step
through the extension-line origin points of each dimension. For each
extension-line origin point, you can specify a new association point on a
geometric object. Association points determine the attachment of extension
lines to locations on geometric objects.

NOTE When you create or modify associative dimensions, it is important to locate
their association points carefully so that if you make a future design change, the
geometric objects that you change will also change the dimensions associated
with them.

When you use the DIMREASSOCIATE command, a marker is displayed that
indicates whether each successive extension line origin point of the dimension
is associative or nonassociative. A square with an X in it means that the point
is associated with a location on an object, while an X without the square
means that the point is not associated with an object. Use an object snap to
specify the new association for the extension-line origin point or press ENTER
to skip to the next extension-line origin point.

NOTE The marker disappears if you pan or zoom with a wheel mouse.

Change Nonassociative Dimensions to Associative

You can change all the nonassociative dimensions in a drawing to associative.
Use QSELECT to select all nonassociative dimensions, and then use
DIMREASSOCIATE to step through the dimensions, associating each one with
locations on geometric objects.
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Change Associative Dimensions to Nonassociative

You can change all associative dimensions in a drawing to nonassociative
dimensions. Use QSELECT to select all associative dimensions, and then use
DIMDISASSOCIATE to convert them into nonassociative dimensions.

See also:

■ Associative Dimensions on page 1627

■ Save Drawings to Previous Drawing File Formats

To associate or reassociate a dimension

1 Click Annotate tab ➤ Dimensions panel ➤ Reassociate. 

2 Select one or more dimensions to associate or reassociate.

3 Do one of the following:

■ Specify the new location of the extension-line origin point.

■ Enter s and select a geometric object to associate with the dimension.

■ Press ENTER to skip to the next extension-line origin point.

■ Press ESC to end the command but keep any associations you made
up to that point.

4 Repeat the previous step as needed.

Command entry: DIMREASSOCIATE

To disassociate a dimension

1 At the command prompt, enter DIMDISASSOCIATE.

2 Select one or more dimensions to disassociate and press ENTER when
you finish.
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Quick Reference

Commands

DIMDISASSOCIATE

Removes associativity from selected dimensions.

DIMREASSOCIATE

Associates or reassociates selected dimensions to objects or points on objects.

DIMREGEN

Updates the locations of all associative dimensions.

EXPLODE

Breaks a compound object into its component objects.

System Variables

DIMASSOC

Controls the associativity of dimension objects and whether dimensions are
exploded.

Utilities

No entries

Command Modifiers

No entries

Add Geometric Tolerances
You can add geometric tolerances that show acceptable deviations of form,
profile, orientation, location, and runout of a feature.

Overview of Geometric Tolerances
Geometric tolerances show acceptable deviations of form, profile, orientation,
location, and runout of a feature.

You add geometric tolerances in feature control frames. These frames contain
all the tolerance information for a single dimension. Geometric tolerances
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can be created with or without leader lines, depending on whether you create
them with TOLERANCE or LEADER.

A feature control frame consists of two or more components. The first feature
control frame contains a symbol that represents the geometric characteristic
to which a tolerance is being applied, for example, location, profile, form,
orientation, or runout. Form tolerances control straightness, flatness, circularity
and cylindricity; profiles control line and surface. In the illustration, the
characteristic is position.

You can use most editing commands to change feature control frames, and
you can snap to them using the object snap modes. You can also edit them
with grips.

NOTE Unlike dimensions and leaders, geometric tolerances cannot be associated
with geometric objects.

You can also create tolerances. For more information about creating and
working with an annotative tolerances, see Create Annotative Dimensions
and Tolerances on page 1409.

See also:

■ Scale Annotations on page 1393
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To create geometric tolerances

1 Click Annotate tab ➤ Dimensions panel ➤ Tolerance. 

2 In the Geometric Tolerance dialog box, click the first square under Sym
and select a symbol to insert.

3 Under Tolerance 1, click the first black box to insert a diameter symbol.

4 In the Text box, enter the first tolerance value.

5 To add a material condition (optional), click the second black box and
click a symbol in the Material Conditions dialog box to insert it.

6 In the Geometric Tolerance dialog box, add a second tolerance value
(optional) in the same way as the first tolerance value.

7 Under Datum 1, Datum 2, Datum 3, enter the datum reference letter.

8 Click the black box to insert a material condition symbol for each datum
reference.

9 In the Height box, enter a height.

10 Click the Projected Tolerance Zone box to insert the symbol.

11 In the Datum Identifier box, add a datum value.

12 Click OK.

13 In the drawing, specify a location for the feature control frame.

Toolbar: Dimension  
Command entry: TOLERANCE

To create a geometric tolerance with a leader

1 At the command prompt, enter leader.

2 Specify the start point of the leader.

3 Specify the second point of the leader.

4 Press ENTER twice to display the Annotation options.

5 Enter t (Tolerance), and create a feature control frame.
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The feature control frame is attached to the endpoint of the leader.

Command entry: LEADER

Quick Reference

Commands

LEADER

Creates a line that connects annotation to a feature.

TOLERANCE

Creates geometric tolerances contained in a feature control frame.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Material Conditions
Material conditions apply to features that can vary in size.

The second compartment contains the tolerance value. Depending on the
control type, the tolerance value is preceded by a diameter symbol and followed
by a material condition symbol.

Material conditions apply to features that can vary in size:

■ At maximum material condition (symbol M, also known as MMC), a feature
contains the maximum amount of material stated in the limits.

■ At MMC, a hole has minimum diameter, whereas a shaft has maximum
diameter.

■ At least material condition (symbol L, also known as LMC), a feature contains
the minimum amount of material stated in the limits.
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■ At LMC, a hole has maximum diameter, whereas a shaft has minimum
diameter.

■ Regardless of feature size (symbol S, also known as RFS) means a feature can
be any size within the stated limits.

Quick Reference

Commands

LEADER

Creates a line that connects annotation to a feature.

TOLERANCE

Creates geometric tolerances contained in a feature control frame.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Datum Reference Frames
The tolerance values in the feature control frame are followed by up to three
optional datum reference letters and their modifying symbols.

A datum is a theoretically exact point, axis, or plane from which you make
measurements and verify dimensions. Usually, two or three mutually
perpendicular planes perform this task best. These are jointly called the datum
reference frame.

The following illustration shows a datum reference frame verifying the
dimensions of the part.
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Quick Reference

Commands

LEADER

Creates a line that connects annotation to a feature.

TOLERANCE

Creates geometric tolerances contained in a feature control frame.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Projected Tolerance Zones
Projected tolerances are used to make the tolerance more specific.

Projected tolerances are specified in addition to positional tolerances to make
the tolerance more specific. For example, projected tolerances control the
perpendicularity tolerance zone of an embedded part.

The symbol for projected tolerance ( ) is preceded by a height value, which
specifies the minimum projected tolerance zone. The projected tolerance zone
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height and symbol appear in a frame below the feature control frame, as shown
in the following illustration.

Quick Reference

Commands

LEADER

Creates a line that connects annotation to a feature.

TOLERANCE

Creates geometric tolerances contained in a feature control frame.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Composite Tolerances
A composite tolerance specifies two tolerances for the same geometric
characteristic of a feature or for features that have different datum
requirements. One tolerance relates to a pattern of features and the other
tolerance to each feature within the pattern. The individual feature tolerance
is more restrictive than the pattern tolerance.
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In the following illustration, the point where datums A and B intersect is called
the datum axis, the point from which the position of the pattern is calculated.

A composite tolerance could specify both the diameter of the pattern of holes
and the diameter of each individual hole, as in the following illustration.

When you add composite tolerances to a drawing, you specify the first line
of a feature control frame and then choose the same geometric characteristic
symbol for the second line of the feature control frame. The geometric symbol
compartment is extended over both lines. You can then create a second line
of tolerance symbols.

Quick Reference

Commands

LEADER

Creates a line that connects annotation to a feature.

TOLERANCE

Creates geometric tolerances contained in a feature control frame.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries
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Prepare Drawings for
Plotting and Publishing

You prepare your drawing for plotting or publishing by specifying page setup settings. These
settings are stored in the drawing file with the layout. Once a layout is established, you can
modify the settings of its page setup or apply a different page setup.

Quick Start to Saving Settings for Plotting and Publishing
Preparing a drawing for plotting or publishing requires specifying many settings
and options that define the output of your drawing. To save time, you can save
these settings as a named page setup.

You can apply a named page setup to paper space layouts using the Page Setup
Manager. You can also import a named page setup from another drawing and
apply it to layouts in the current drawing.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PSETUPIN

Imports a user-defined page setup into a new drawing layout.

28
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Specify Page Setup Settings
Page setups are associated with layouts and stored in the drawing file. The
settings specified in a page setup determine the appearance and format of
your final output.

Overview of Page Setup Settings
A page setup is a collection of plot device and other settings that affect the
appearance and format of your final output. These settings can be modified
and applied to other layouts.

After you complete a drawing on the Model tab, you can begin creating a
layout to plot by clicking a layout tab. When you click a layout tab for the
first time, a single viewport is displayed on the page. A dashed line indicates
the printable area of the paper for the currently configured paper size and
plotter.

Once you have your layout set up, you specify the settings for the layout's
page setup, which includes the plot device settings and other settings that
affect the appearance and format of the output. The settings you specify in
the page setup are stored in the drawing file with the layout. You can modify
the settings of a page setup at any time.

By default, every initialized layout has a page setup associated with it. You
can initialize a layout by clicking on its tab to activate the previously unused
layout. A layout does not contain any plot settings before initialization. A
layout must be initialized (its paper size can be defined in the page setup to
any size other than 0 x 0) before it can be published. Once initialized, layouts
can be drawn upon, published, and added to sheet sets as sheets (after the
drawing has been saved). You can apply a named page setup saved with one
layout to another layout. This creates a new page setup with the same settings
as the first one.
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If you want the Page Setup Manager to be displayed each time you begin a
new drawing layout, select the Show Page Setup Manager for New Layouts
option on the Display tab in the Options dialog box. If you don't want a
viewport to be automatically created for each new layout, clear the Create
Viewport in New Layouts option on the Display tab in the Options dialog
box.

To modify the settings of a layout's page setup

1 Click the layout tab for which you want to modify the page setup settings.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, modify the required settings. Click OK.

6 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

To apply a layout's named page setup to another layout

1 Click the layout tab to which you want to apply another layout's page
setup settings.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select a named page setup
that you want to apply to the layout selected in the drawing area.

4 Click Set Current.

5 Click Close.
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Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Select a Printer or Plotter for a Layout
When you create a layout, you must select a printing or plotting device in the
Page Setup dialog box in order for the layout to be printed or plotted. Once
you've selected a device, you can view details about the name and location of
the device, and you can change the device's configuration.

The printer or plotter you select in the Page Setup dialog box determines the
printable area of the layout. This printable area is indicated by the dashed line
in the layout. If you change the paper size or the printing or plotting device,
it may change the printable area of your drawing page.

See also:

■ Select a Printer or Plotter on page 1791

■ “Control PC3 File Device and Document Settings” in the Driver and Peripheral
Guide
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To select a printer or plotter for a layout

1 Click the layout tab for which you want to specify a printer or plotter.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Printer/Plotter, select a printer or
plotter from the list. Click OK.

6 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab and select Page Setup Manager.

To change the configuration of a printer or plotter specified in a page setup

1 Click the layout tab for which you want to specify a printer or plotter.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Printer/Plotter, click Properties.

6 In the Plotter Configuration Editor, change the required settings. Click
OK.

7 In the Page Setup dialog box, click OK.

8 In the Page Setup Manager, click Close.

Toolbar: Layouts  
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Command entry: PAGESETUP
Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Select a Paper Size for a Layout
You can select a paper size from a standard list, or you can add custom paper
sizes using the Plotter Configuration Editor.

You can select a paper size from a standard list. The paper sizes available in
the list are determined by the plot device that is currently selected for the
layout. If your plotter is configured for raster output, you must specify the
output size in pixels. You can add custom paper sizes, which are stored in the
plotter configuration (PC3) file, using the Plotter Configuration Editor.

If you are using a system printer, the paper size is determined by the document
defaults that are set in the Windows Control Panel. The default paper size is
displayed in the Page Setup dialog box when you create a new layout for that
configured device. If you change the paper size in the Page Setup dialog box,
the new paper size is saved with the layout and overrides the size saved in the
plotter configuration (PC3) file.
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See also:

■ “Control PC3 File Device and Document Settings” in the Driver and Peripheral
Guide

To set the paper size for a layout

1 Click the layout tab for which you want to set the paper size.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Paper Size, select a paper size from
the list. Click OK.

6 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

To start the Plotter Configuration Editor

1 Click Output tab ➤ Plot panel ➤ Plotter Manager. 

2 In the Plotter Manager, double-click the plotter configuration (PC3) file
you want to edit.

The Plotter Configuration Editor is displayed.

Command entry: PLOTTERMANAGER

To add a custom paper size from scratch

1 Click Output tab ➤ Plot panel ➤ Plotter Manager. 
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2 In the Plotter Manager, double-click the plotter configuration (PC3) file
you want to edit.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size options.

4 Select Custom Paper Sizes.

5 Under Custom Paper Sizes, click Add.

6 In the Custom Paper Size wizard, Begin page, select Start from Scratch.
Click Next.

7 On the Media Bounds page, in the Units list, select either Inches or
Millimeters for paper size.

When a nondimensional raster image, such as BMP or TIFF, is plotted,
the size of the plot is specified in pixels, not inches or millimeters.

8 In the Width and Length lists, specify the paper width and length. Click
Next.

NOTE Each plotter has a maximum printable area determined by where it
grips the paper and how far the pen shuttle reaches. If you are creating a
paper size that is larger than the paper sizes offered in the Custom Paper Size
wizard, verify that the plotter is capable of plotting the new dimensions.

9 On the Printable Area page, use Top, Bottom, Left, and Right to specify
the printable area. Click Next.

10 On the Paper Size Name page, enter a name for the paper size. Click Next.

11 On the File Name page, enter a name for the PMP file.

12 On the Finish page, specify whether the paper source is Sheet-Fed or
Roll-Fed.

13 Click Print Test Page to verify the custom size.

A cross is printed that defines the paper size and a rectangle that defines
the printable area. If all four sides of the rectangle are not printed, increase
the printable area.

14 Click Finish to exit the Custom Paper Size wizard.

Command entry: PLOTTERMANAGER
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To add a new custom paper size starting from an existing paper size

1 Click Output tab ➤ Plot panel ➤ Plotter Manager. 

2 In the Plotter Manager, double-click the plotter configuration (PC3) file
you want to edit.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

4 Select Custom Paper Sizes.

5 Under Custom Paper Sizes, click Add.

6 In the Custom Paper Size wizard, Begin page, select Use Existing.

7 In the list of existing standard paper sizes, select a paper size on which
to base the custom paper size you are creating.

8 Follow the instructions in To add a custom paper size from scratch on
page 1753 to continue through the Custom Paper Size wizard.

The new paper size is a user-defined size, not a standard size.

9 Click Finish to exit the Custom Paper Size wizard.

Command entry: PLOTTERMANAGER

To edit a custom paper size

1 Click Output tab ➤ Plot panel ➤ Plotter Manager. 

2 In the Plotter Manager, double-click the plotter configuration (PC3) file
you want to edit.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

4 Select Custom Paper Sizes.

5 Under Custom Paper Sizes, select a paper size from the list. Click Edit.

6 In the Custom Paper Size wizard, make changes to the paper size, printable
area, custom paper size name, and source.
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7 Click Finish to exit the Custom Paper Size wizard.

Command entry: PLOTTERMANAGER

To delete a custom paper size

1 Click Output tab ➤ Plot panel ➤ Plotter Manager. 

2 In the Plotter Manager, double-click the plotter configuration (PC3) file
you want to edit.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

4 Click Custom Paper Sizes.

5 Under Custom Paper Sizes, select a paper size from the list.

6 Click Delete.

Command entry: PLOTTERMANAGER

To modify a standard paper size

1 Click Output tab ➤ Plot panel ➤ Plotter Manager. 

2 In the Plotter Manager, double-click the Plotter Configuration (PC3) file
you want to edit.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

4 Select Modify Standard Paper Sizes.

5 Under Modify Standard Paper Sizes, select the paper size you want to
adjust. Click Modify.

6 In the Custom Paper Size wizard, adjust the printable area as necessary.
Click Finish to exit the Custom Paper Size wizard.

Command entry: PLOTTERMANAGER
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Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOTTERMANAGER

Displays the Plotter Manager, where you can add or edit a plotter
configuration.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set the Plot Area of a Layout
You can specify the plot area to determine what will be included in the plot.

When you prepare to plot from the Model tab or a layout tab, you can specify
the plot area to determine what will be included in the plot. When you create
a new layout, the default Plot Area option is Layout. Layout plots all objects
within the printable area of the specified paper size.

The Display Plot Area option plots all the objects displayed in the drawing.
The Extents Plot Area option plots all the visible objects in the drawing. The
View Plot Area option plots a saved view. You can use the Window Plot Area
option to define an area to be plotted.

See also:

■ Specify the Area to Plot on page 1793
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To set the plot area and adjust the display

1 Click the layout tab for which you want to set the plot area and adjust
the display.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Plot Area, select one of the following
options:

■ Layout. Prints all objects within the printable area of the paper. This
option is only available from a layout tab.

■ Limits. Prints or plots the current grid limits. This option is only
available from the Model tab.

■ Extents. Plots all objects in the drawing.

■ Display. Plots all objects displayed in the drawing area.

■ View. Prints or plots a saved view. Select a named view from the list
provided.

■ Window. Plots objects in the area you define. Select the Window
option, and then respond to the prompts to define the area. Click the
Window button to edit the defined area.

6 Click OK.

7 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.
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Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Adjust the Plot Offset of a Layout
The printable area of a drawing sheet is defined by the selected output device
and is represented by the dashed line in a layout. When you change the output
device, the printable area may change.

The plot offset specifies an offset of the plot area relative to the lower-left
corner (the origin) of the printable area or the edge of the paper, depending
on the Specify Plot Offset Relative To option specified in the Options dialog
box, Plot and Publish tab. The Plot Offset area of the Plot dialog box displays
the specified plot offset option in parentheses.

You can offset the geometry on the paper by entering a positive or negative
value in the X and Y Offset boxes. However, this may result in the plot area
being clipped.

If you choose to plot an area other than the entire layout, you can also center
the plot on the sheet of paper.
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To adjust the plot offset of a layout

1 Click the layout tab for which you want to adjust the plot offset.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Plot Offset, enter a value in units for
X or Y or both. Click OK.

6 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.
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System Variables

PLOTOFFSET

Controls whether the plot offset is relative to the printable area or to the
edge of the paper.

Utilities

No entries

Command Modifiers

No entries

Set the Plot Scale for a Layout
When you plot a drawing layout, you can either specify a precise scale for the
layout or fit the image to the paper.

Normally, you plot a layout at a 1:1 scale. To specify a different scale for the
layout, set the plot scale for the layout in the Page Setup or the Plot dialog
box. In those dialog boxes, you can select a scale from a list or enter a scale.

NOTE You can modify the list of scales with SCALELISTEDIT.

When you are reviewing an early draft view, a precise scale is not always
important. You can use the Fit to Paper setting to plot the layout at the largest
possible size that fits the paper.

See also:

■ Scale Views in Layout Viewports on page 456

■ Draw, Scale, and Annotate in Model Space on page 425

To set the plot scale in a layout

1 Click the layout tab for which you want to set the plot scale.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.
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4 Click Modify.

5 In the Page Setup dialog box, under Plot Scale, select a scale from the
Scale list.

The default scale when plotting a layout is 1:1. To set a custom plot scale,
enter values in the Inches or Millimeters box and the Units box. The type
of unit is determined by the paper size, but you can change it in the list
box.

6 Click OK.

7 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup.

To set the Fit to Paper option when plotting

1 Click the layout tab for which you want to set the plot scale to Fit to
Paper.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, Under Plot Scale, select Fit to Paper.

NOTE If the Plot Area is set to Layout, you cannot select the Fit to Paper
option.

6 Click OK.

7 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.
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Quick Reference

Commands

SCALELISTEDIT

Controls the list of scales available for layout viewports, page layouts, and
plotting.

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set the Lineweight Scale for a Layout
You can scale lineweights proportionately in a layout with the plot scale.

Typically, lineweights specify the line width of plotted objects and are plotted
with the line width size regardless of the plot scale. Most often, you use the
default plot scale of 1:1 when plotting a layout. However, if you want to plot
an E-size layout that is scaled to fit on an A-size sheet of paper, for example,
you can specify lineweights to be scaled in proportion to the new plot scale.

See also:

■ Control Lineweights on page 614

To scale lineweights in a layout

1 Click the layout tab for which you want to scale lineweights.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 
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3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Plot Scale, select Scale Lineweights.

The lineweights in the current layout are scaled in proportion to the
designated plot scale. When you are working in the Model tab, this option
is not available.

6 Click OK.

7 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Select a Plot Style Table for a Layout
A plot style table is a collection of plot styles assigned to a layout or the Model
tab. A plot style is an object property, similar to linetype and color. A plot
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style can be assigned to an object or assigned to a layer. A plot style controls
an object's plotted properties.

You can also create a new plot style table to save in the page setup for the
layout or edit an existing plot style table.

If you select the Display Plot Styles option under Plot Style Table (Pen
Assignments), the properties of the plot styles assigned to objects are displayed
in the selected layout.

See also:

■ Control How Objects Are Plotted on page 1801

To select a plot style table for a layout

1 Click the layout tab for which you want to select a plot style table.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, Under Plot Style Table, select a Plot Style
Table from the list.

6 Click OK.

7 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

To create a new plot style table for a layout

1 Click the layout tab for which you want to create a new plot style table.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 
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3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, Under Plot Style Table, select New from the
list.

6 Follow the instructions in the wizard that is shown (the Add
Color-Dependent Plot Style Table wizard or the Add Named Plot Style
Table wizard).

7 In the Page Setup dialog box, click OK.

8 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

To edit a plot style table for a layout

1 Click the layout tab for which you want to edit a plot style table.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Plot Style Table, select the plot style
table you want to edit from the list.

6 Click the Edit button.

7 In the Plot Style Table Editor, make the required changes. Click Save &
Close.

8 In the Page Setup dialog box, click OK.

9 In the Page Setup Manager, click Close.
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Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

To display plot styles in a layout

1 Click the layout tab for which you want to display plot styles.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Plot Style Table, select the Display
Plot Styles option.

6 Click OK.

7 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set Shaded Viewport and Plot Options for a Layout
Shaded viewport and plot options settings affect how objects are plotted and
are saved in the page setup.

Shaded viewport and plot options affect how objects are plotted. The options
for shaded viewport plotting give you a large degree of flexibility in conveying
your three-dimensional designs to others. You can convey your design intent
by choosing how viewports are plotted and by specifying resolution levels.

Shaded Viewport Plotting Options

With shaded plotting options, you can choose whether to plot a set of shaded
objects using the As Displayed, Wireframe, Hidden, or Rendered option.

Shaded viewport plotting options apply to all objects in viewports and model
space. If you use the Shaded or Rendered options, plot style tables included
in the page setup do not affect plots. If you use the Render option,
two-dimensional wireframe objects, such as lines, arcs, and text, are not plotted.

NOTE Shaded viewport plotting requires a raster-capable device. Most modern
plotters and printers are raster-capable devices.

Plot Options

The following options that can be specified for layouts affect how objects are
plotted.

■ Plot Object Lineweights. Specifies that lineweights assigned to objects and
layers are plotted.

■ Plot with Plot Styles. Specifies that the drawing is plotted using plot styles.
Selecting this option automatically plots lineweights. If you do not select
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this option, objects are plotted with their assigned properties and not with
the plot style overrides.

■ Plot Paper Space Last. Specifies that objects in model space are plotted
before those in paper space.

■ Hide Paperspace Objects. Specifies whether the Hide operation applies to
objects in the paper space viewport. This option is available only from a
layout tab. The effect of this setting is reflected in the plot preview, but
not in the layout.

See also:

■ Set Shaded Viewport Options on page 1805

■ Set Options for Plotted Objects on page 1809

To set shaded viewport options for a layout

1 Click the layout tab for which you want to set shaded viewport options.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Shaded Viewport Options, select the
required settings.

6 Click OK.

7 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

To set plot options for a layout

1 Click the layout tab for which you want to set plot options.
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2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.

5 In the Page Setup dialog box, under Plot Options, select the required
settings.

6 Click OK.

7 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Determine the Drawing Orientation of a Layout
You can specify the orientation of the drawing on the paper using the
Landscape and Portrait settings. Landscape orients the drawing on the paper
so that the long edge of the paper is horizontal, and Portrait orients the paper
so that the short edge is horizontal. Changing the orientation creates the effect
of rotating the paper underneath the drawing.

In either landscape or portrait orientation, you can select Plot Upside-Down
to control whether the top or bottom of the drawing is plotted first.

Although you can specify the drawing orientation in both the Page Setup
dialog box and the Plot dialog box, the Page Setup settings are always saved
and reflected in the layout. In the Plot dialog box, you can override the page
setup settings for a single plot; however, the settings you apply are not saved
in the layout. To save the settings you apply using the Plot dialog box, click
the Apply to Layout button in the Plot dialog box.

If you change the drawing orientation, the layout origin remains in the
lower-left corner of the rotated page.

To set the orientation of the plotted drawing

1 Click the layout tab for which you want to set the drawing orientation.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, Page Setups area, select the page setup that
you want to modify.

4 Click Modify.
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5 In the Page Setup dialog box, under Drawing Orientation, do one of the
following:

■ If your drawing is horizontal, select Landscape.

■ If your drawing is vertical, select Portrait.

■ To rotate 180 degrees, select either Portrait or Landscape, and then
select Plot Upside-Down.

6 Click OK.

7 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Use the Layout Wizard to Specify Layout Settings
You can create a new layout using the Create Layout wizard.
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The wizard prompts you for information about the layout settings, including

■ A name for the new layout

■ The printer associated with the layout

■ A paper size to use for the layout

■ The orientation of the drawing on the paper

■ A title block

■ Viewport setup information

■ A location for the viewport configuration in the layout

You can edit the information entered in the wizard later. Click Output

tab ➤ Plot panel ➤ Page Setup Manger.  In the Page Setup Manager,
click Modify.

To create a layout using the wizard

1 Click Insert menu  ➤ Layout  ➤ Layout Wizard.

2 On each page of the Create Layout wizard, select the appropriate settings
for the new layout.

When finished, the new layout will be the current layout tab.

Command entry: LAYOUTWIZARD

Quick Reference

Commands

LAYOUTWIZARD

Creates a new layout tab and specifies page and plot settings.

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Import PCP or PC2 Settings into a Layout
You can import layout and plot settings contained in PCP or PC2 files into
the current layout.

If you work with drawings created in AutoCAD Release 14 or earlier, you can
choose to import layout and plot settings contained in a PCP or PC2 file and
apply them to the current layout. Settings that are saved in a PCP or PC2 file
include

■ Plot Area

■ Rotation

■ Paper Size

■ Plot Scale

■ Plot Origin

■ Plot Offset

In addition, a PC2 file contains any resolution information that has been
modified by a plotter calibration. Pen assignment information can also be
imported and saved in a plot style table using the Add Plot Style Table wizard.

To import plotting device and pen settings information, you can use the
Import PCP or PC2 Plot Settings wizard to choose a PCP or PC2 file whose
settings you want to import. You can also choose to modify any of the
imported settings using the Page Setup dialog box.

To import PCP or PC2 settings into the current layout

1 At the command prompt, enter pcinwizard.
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2 In the Import PCP or PC2 Plot Settings wizard, select the PCP or PC2 file
whose settings you want to import into the current layout.

Quick Reference

Commands

PCINWIZARD

Displays a wizard to import PCP and PC2 configuration file plot settings into
the Model tab or current layout.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create and Use Named Page Setups
You can save plot device and other page setup settings as named page setups
that can be modified and imported into other drawings.

You can create named page setups and apply them to other layouts in your
drawing. Named page setups are saved in the drawing file and can be imported
into other drawing files and applied to other layouts. You can also modify the
settings of named page setups. If you modify a named page setup, you can
choose whether the modifications apply to the current layout or to all the
layouts in the current drawing that use the named page setup.

If you want to plot the same layout more than one way, or if you want to
specify the same output options for several layouts, use named page setups.
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You can apply different named page setups to the same layout to achieve
specific results when plotting. For example, you might create the named page
setups in the following table to control scaling and paper size.

DescriptionPage setup name

Plot at scale 1:1, E-size sheetNoScaling

Plot at scale 1:2, C-size sheetScale 1 to 2

Plot to the draft-quality plotterDraft

Plot to the high-quality plotterFinal

Fit to Paper, A-size sheetFit-to-Paper

Once you specify a named page setup for a layout, whenever you plot or
publish the layout, it is plotted or published with the settings specified in the
named page setup set for the layout.

To create a new named page setup

1 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

2 In the Page Setup Manager, Page Setups area, click New.

3 In the New Page Setup dialog box, enter a name for the new page setup.

4 Under Start With, select a page setup in the list. The settings specified in
the selected page setup will be displayed in the Page Setup dialog box
after you click OK.

5 Click OK.

6 In the Page Setup dialog box, change any required settings. Click OK.

The new page setup is displayed in the Page Setups list in the Page Setup
Manager.

7 To apply the new page setup to the current layout, in the Page Setup
Manager, click Set Current.

8 In the Page Setup Manager, click Close.
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Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

To apply a named page setup to a layout

1 Click the layout tab for which you want to apply a named page setup.

2 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

3 In the Page Setup Manager, under Page Setups, select a named page setup
from the list.

NOTE A page setup that is not named is shown in the Page Setup Manager
with an asterisk on either side of its layout name. An unnamed page setup
does not have the same functionality as a named page setup. For example,
if you set an unnamed page setup as the current page setup for another
layout, the values are applied to the layout. If you make changes to the original
unnamed page setup, those changes do not carry over to the layout to which
the unnamed page setup was applied.

4 Click Set Current.

5 Click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

To modify a named page setup

1 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

2 In the Page Setup Manager, under Page Setups, select a named page setup
from the list.
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NOTE A page setup that is not named is shown in the Page Setup Manager
with an asterisk on either side of its layout name. An unnamed page setup
does not have the same functionality as a named page setup. For example,
if you set an unnamed page setup as the current page setup for another
layout, the values are applied to the layout. If you make changes to the original
unnamed page setup, those changes do not carry over to the layout to which
the unnamed page setup was applied.

3 Click Modify.

4 In the Page Setup dialog box, make the required changes. Click OK.

5 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

To import named page setups from another drawing

1 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

2 In the Page Setup Manager, click Import.

3 In the Select Page Setup From File dialog box, select a drawing file from
which you want to import one or more named page setups. Click Import.

4 In the Import Page Setups dialog box, select one or more page setups to
import. Click OK.

If a page setup with the same name already exists in the drawing, you
can redefine the settings of the existing one with the settings of the
imported page setup, or you can cancel the operation.

The imported page setups are displayed in the Page Setup Manager in the
list of page setups.

NOTE You can import both model space and layout page setups at the same
time. However, an imported model space page setup is shown in the Page
Setup Manager only if the model tab was current when you opened the Page
Setup Manager. Similarly, an imported layout page setup is shown in the
Page Setup Manager only if a layout tab was current when you opened the
Page Setup Manager.
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5 In the Page Setup Manager, click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

To delete a named page setup

1 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

2 In the Page Setup Manager, under Page Setups, right-click the named
page setup you want to delete. Click Delete.

NOTE A page setup that is not named is shown in the Page Setup Manager
with an asterisk on either side of its layout name. An unnamed page setup
does not have the same functionality as a named page setup. For example,
if you set an unnamed page setup as the current page setup for another
layout, the values are applied to the layout. If you make changes to the original
unnamed page setup, those changes do not carry over to the layout to which
the unnamed page setup was applied.

3 Click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

To rename a page setup

1 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

2 In the Page Setup Manager, under Page Setups, right-click the named
page setup you want to rename. Click Rename.
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NOTE A page setup that is not named is shown in the Page Setup Manager
with an asterisk on either side of its layout name. An unnamed page setup
does not have the same functionality as a named page setup. For example,
if you set an unnamed page setup as the current page setup for another
layout, the values are applied to the layout. If you make changes to the original
unnamed page setup, those changes do not carry over to the layout to which
the unnamed page setup was applied.

3 Enter a new name for the page setup.

4 Click Close.

Toolbar: Layouts  
Command entry: PAGESETUP

Shortcut menu: Right-click a layout tab. Click Page Setup Manager.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Use Named Page Setups with Sheet Sets
You can use named page setups to specify the same output options for all the
sheets in a sheet set.
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You can create a sheet from scratch using the Sheet Set Manager, and then
apply a named page setup to the layout.

You can also apply named page setups that are stored in the sheet set's page
setup overrides DWT file to a single sheet or to an entire sheet set for a
one-time publish operation.

See also:

■ Create and Use Named Page Setups on page 1775

To apply a named page setup to a sheet created from scratch

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Open Sheet Set dialog box, select a sheet set. Click Open.

3 In the Sheet Set Manager, right click in the Sheets area. Click New Sheet.

4 In the New Sheet dialog box, enter a number and sheet title. Click OK.

5 In the Sheet Set Manager, under Sheets, double-click the new sheet.

6 Click Output tab ➤ Plot panel ➤ Page Setup Manager. 

7 In the Page Setup Manager, under Page Setups, select a named page setup.
Click Set Current.

Named page setups are not enclosed in asterisks.

8 Click Close.

Toolbar: Standard  
Command entry: SHEETSET

To apply a named page setup as an override when publishing sheets

1 Click View tab  ➤  Palettes panel  ➤  Sheet Set Manager.

2 In the Open Sheet Set dialog box, select a sheet set. Click Open.
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3 In the Sheet Set Manager, in the Sheets area, select a sheet set, a subset,
or a sheet to publish.

4 At the top of the Sheet Set Manager, click the Publish button.

5 On the shortcut menu, place your cursor over Publish Using Page Setup
Override.

6 On the submenu, click the named page setup you want to use.

Toolbar: Standard  
Command entry: SHEETSET

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PUBLISH

Publishes drawings to DWF, DWFx, and PDF files, or to plotters.

SHEETSET

Opens the Sheet Set Manager.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries
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Plot Drawings

Once you have completed a drawing, you can use a number of methods to output the drawing.
You can plot the drawing on paper or create a file for use with another application. In either
case, you select the plot settings.

Quick Start to Plotting
To print a single layout or part of a drawing, use the Plot dialog box.

Use a named page setup or change the settings in the Plot dialog box to define
the output of your drawing.

To output more than one drawing, use the Publish dialog box.

See also:

■ “Quick Start to Publishing” on page 1

Quick Reference

Commands

PLOT

Plots a drawing to a plotter, printer, or file.

29
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Overview of Plotting
Understanding terms and concepts that relate to plotting makes your first
plotting experience in the program easier.

Plotter Manager

The Plotter Manager is a window that lists plotter configuration (PC3) files
for every non-system printer that you install. Plotter configuration files can
also be created for Windows® system printers if you want to use default
properties different from those used by Windows. Plotter configuration settings
specify port information, raster and vector graphics quality, paper sizes, and
custom properties that depend on the plotter type.

The Plotter Manager contains the Add-a-Plotter wizard, which is the primary
tool for creating plotter configurations. The Add-a-Plotter wizard prompts you
for information about the plotter you want to set up.

Layouts

A layout represents a plotted page. You can create as many layouts as you
need. Each layout is saved on its own layout tab and can be associated with
a different page setup.

Elements that appear only on a plotted page, such as title blocks and notes,
are drawn in paper space in a layout. The objects in the drawing are created
in model space on the Model tab. To view these objects in the layout, you
create layout viewports.

Layout Initialization

Layout initialization is a process in which a previously unused layout is made
active, by clicking on its tab.
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A layout does not contain any plot settings before initialization. Once
initialized, layouts can be drawn upon, published, and added to sheet sets as
sheets (after the drawing has been saved).

Page Setups

When you create a layout, you specify a plotter and settings such as page size
and plot orientation. These settings are saved in a page setup. You can control
these settings for layouts and for the Model tab using the Page Setup Manager.
You can name and save page setups for use with other layouts.

If you don't specify all the settings in the Page Setup dialog box when you
create a layout, you can set up the page just before you plot. Or you can
override a page setup at plot time. You can use the new page setup temporarily
for the current plot, or you can save the new page setup.

Plot Styles

A plot style controls how an object or layer is plotted by determining plotted
properties such as lineweight, color, and fill style. Plot style tables collect
groups of plot styles. The Plot Style Manager is a window that shows all the
plot style tables available.

There are two plot style types: color-dependent and named. A drawing can
use only one type of plot style table. You can convert a plot style table from
one type to the other. You can also change the type of plot style table a
drawing uses once it has been set.

For color-dependent plot style tables, an object's color determines how it is plotted.
These plot style table files have .ctb extensions. You cannot assign
color-dependent plot styles directly to objects. Instead, to control how an
object is plotted, you change its color. For example, all objects assigned the
color red in a drawing are plotted the same way.

Named plot style tables use plot styles that are assigned directly to objects and
layers. These plot style table files have .stb  extensions. Using them enables
each object in a drawing to be plotted differently, independent of its color.

Plot Stamps

A plot stamp is a line of text that is added to your plot. You can specify where
this text is located on the plot in the Plot Stamp dialog box. Turn this option
on to add specified plot stamp information—including drawing name, layout
name, date and time, and so on—to a drawing that is plotted to any device.
You can choose to record the plot stamp information to a log file instead of
plotting it, or in addition to plotting it.
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NOTE A drawing file or drawing template file that was created with an educational
version will always be plotted with the following plot stamp: PRODUCED BY AN
AUTODESK EDUCATIONAL PRODUCT. Blocks and xrefs created with an educational
version and used in a commercial version will also result in the educational plot
stamp being plotted.

See also:

■ Create Multiple-View Drawing Layouts (Paper Space) on page 431

■ “To view the custom properties Help” in the Driver and Peripheral Guide

To plot a drawing

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Printer/Plotter, select a plotter from the
Name list.

3 Under Paper Size, select a paper size from the Paper Size box.

4 (Optional) Under Number of Copies, enter the number of copies to plot.

5 Under Plot Area, specify the portion of your drawing to plot.

6 Under Plot Scale, select a scale from the Scale box.
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7 For more options, click the More Options button.

8 (Optional) Under Plot Style Table (Pen Assignments), select a plot style
table from the Name box.

9 (Optional) Under Shaded Viewport Options and Plot Options, select any
appropriate settings.

NOTE Plot stamping happens at plot time and is not saved with the drawing.

10 Under Drawing Orientation, select an orientation.

11 Click OK.

Toolbar: Standard  
Command entry: PLOT

Shortcut menu: Right-click the Model tab or a layout tab and click Plot.

To plot at the command prompt instead of in a dialog box, use -PLOT.

To turn background plotting on or off

1 Click Tools menu  ➤ Options.

2 In the Options dialog box, Plot and Publish tab, under Background
Processing Options, select or clear the Enable Background Plot When
Plotting option.

3 Click OK.

NOTE When you plot in the background, you can return immediately to
your drawing. While a plot job is being processed in the background, you
can check the status of your job by placing your cursor over the plotter icon
in the status tray. You can also view details about all completed jobs from
the current program session.

Command entry: OPTIONS
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To check the status of a plot job currently processing in the background

■ In the status tray, place your mouse over the plotter icon. The tooltip
displays the status of the plot job.

To cancel part or all of a plot job that is processing in the background

■ In the status tray, right-click the plotter icon. Click Cancel Sheet
<sheetname> or Cancel Entire Job.

To view details about jobs you have plotted

1 Do one of the following:

■ Click Output tab ➤ Plot panel ➤ View Details. 

■ In the status tray, click the plotter icon.

2 In the Plot and Publish Details dialog box, view details about plotted
jobs.

Command entry: VIEWPLOTDETAILS
Shortcut menu: In the status tray, right-click the plotter icon. Click View
Plot And Publish Details.

Quick Reference

Commands

OPTIONS

Customizes the program settings.

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PCINWIZARD

Displays a wizard to import PCP and PC2 configuration file plot settings into
the Model tab or current layout.

PLOT

Plots a drawing to a plotter, printer, or file.
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PLOTSTAMP

Places a plot stamp on a specified corner of each drawing and logs it to a file.

PLOTTERMANAGER

Displays the Plotter Manager, where you can add or edit a plotter
configuration.

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.

VIEWPLOTDETAILS

Displays information about completed plot and publish jobs.

System Variables

BACKGROUNDPLOT

Controls whether background plotting is turned on or off for plotting and
publishing.

Utilities

No entries

Command Modifiers

No entries

Use a Page Setup to Specify Plot Settings
You can use a page setup to specify the settings for your plot job. When you
select a page setup in the Plot dialog box, the settings from the page setup are
added to the Plot dialog box. You can choose to plot with those settings, or
change any of the settings individually and then plot.

Any settings you specify in the Plot dialog box can be saved as a new named
page setup by clicking the Add button in the Page Setup area.

Any settings specified in the Plot dialog box, whether you've applied a page
setup from the Page Setup list, or changed the settings individually, can be
saved to the layout for use the next time you plot.
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To plot a drawing using the settings specified in a page setup

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Page Setups, select a page setup from the
list.

3 (Optional) Change any of the individual settings in the Plot dialog box.

4 To save these settings to the layout, click Apply to Layout.

5 Click Plot.

Toolbar: Standard  
Command entry: PLOT

To save plot settings as a new named page setup

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, change the required settings.

3 Under Page Setups, click Add.

4 In the Add Page Setup dialog box, enter a name for the new named page
setup. Click OK.

Toolbar: Standard  
Command entry: PLOT

To save plot settings to the layout

1 Select a layout tab.

2 Click Output tab ➤ Plot panel ➤ Plot. 

3 In the Plot dialog box, under Page Setups, select a page setup or specify
settings individually.
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4 Click Apply to Layout.

Toolbar: Standard  
Command entry: PLOT

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

PLOTTERMANAGER

Displays the Plotter Manager, where you can add or edit a plotter
configuration.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Select a Printer or Plotter
Before plotting a drawing, you must select a printer or plotter. The device you
select affects the printable area of the drawing.

After selecting a printing or plotting device, you also can easily plot a drawing
using the default settings in the Plot dialog box.
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To select a printer or plotter

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Printer/Plotter, select a plotter from the
Name list.

If you have already selected a paper size and it is not supported by the
plotter you have chosen, you are warned that a paper size supported by
the plotter will be used. Click OK if the warning is displayed.

3 Once you have selected a plotter, you can continue to select a paper size,
or if the paper size is correct, click OK to plot the drawing.

Toolbar: Standard  
Command entry: PLOT

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

PLOTTERMANAGER

Displays the Plotter Manager, where you can add or edit a plotter
configuration.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Specify the Area to Plot
When plotting a drawing, you must specify the area of the drawing to plot.
The Plot dialog box provides the following options under Plot Area.

■ Layout or Limits. When plotting a layout, plots everything within the
printable area of the specified paper size, with the origin calculated from
0,0 in the layout. When plotting the Model tab, plots the entire drawing
area defined by the grid limits. If the current viewport does not display a
plan view, this option has the same effect as the Extents option.

■ Extents. Plots the portion of the current space of the drawing that contains
objects. All geometry in the current space is plotted. The drawing might
be regenerated to recalculate the extents before plotting.

■ Display. Plots the view in the current viewport in the Model tab or the
current paper space view in a layout tab.

■ View. Plots a view saved previously with the VIEW command. You can
select a named view from the list provided. If there are no saved views in
the drawing, this option is unavailable.

■ Window. Plots any portion of the drawing you specify. Click the Window
button to use a pointing device to specify opposite corners of the area to
be plotted, or enter coordinate values.

To set the drawing area as you plot

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Plot Area, specify the portion of your
drawing that you want to plot.
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3 Change other settings as needed. Click OK to plot the drawing.

Toolbar: Standard  
Command entry: PLOT

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set Paper Size
In the Plot dialog box, select the paper size that you want to use.

If you plot from a layout, you may have already specified a paper size in the
Page Setup dialog box. However, if you plot from the Model tab, you need to
specify a paper size when you plot. In the Plot dialog box, select the paper
size that you want to use. The list of paper sizes depends on the printer or
plotter that you have selected in either the Plot or Page Setup dialog box. The
list of available plotters includes all those that are currently configured for use
with Windows and those for which you have installed non-system drivers.

You can also set the default page size used to create new layouts for most
plotters by editing the PC3 file associated with that plotter. For Windows

1794 | Chapter 29   Plot Drawings



system printers, you can use this technique to specify different default page
sizes for Windows and for this program.

NOTE If the PAPERUPDATE system variable is set to 0, you are prompted if the
layout's existing paper size is not supported by the plotter you have selected. If
the PAPERUPDATE system variable is set to 1, the paper size is automatically
updated to reflect the default paper size of the selected plotter.

Use a Custom Paper Size

If you need to specify a paper size that is not listed in either the Plot dialog
box or the Page Setup dialog box, you can add a custom paper size for a
non-system plotter using the Plotter Configuration Editor. Typically, you
cannot add a custom paper size to Windows system printers because the
allowable page sizes and printable areas are determined by the manufacturer.
However, you can modify the printable area for paper sizes associated with a
Windows system printer.

To select a paper size for the current plot

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Printer/Plotter, select a plotter in the Name
box.

3 Under Paper Size, select a paper size from the list.

The paper sizes that are listed depend on the plotter you selected.

Toolbar: Standard  
Command entry: PLOT

To set the default paper size for a layout

1 Click Output tab ➤ Plot panel ➤ Page Setup. 

2 In Page Setup Manager, Page Setups area, the layout for which you want
to set the paper size should be selected. If not, select the layout. Click
Modify.
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3 In the Page Setup dialog box, under Paper Size, select a paper size from
the list. Click OK.

The paper sizes that are listed depend on the plotter specified in the page
setup.

4 In Page Setup Manager, click Close.

The layout reflects the changes.

Toolbar: Layouts  
Command entry: PAGESETUP

To set the default paper size for a plotter

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Printer/Plotter, select a plotter from the
Name list.

3 Click Properties.

The Plotter Configuration Editor is displayed.

4 To specify a default paper size, use one of the following methods:

■ For a non-system plotter, under Media, select Source and Size.

■ For a system printer, in the tree view, select Custom Properties. Then
under Access Custom Dialog, select Custom Properties.

5 Select the appropriate paper size.

6 Click OK to close each dialog box.

NOTE The available paper sizes depend on the printer or plotter. Some plotter
manufacturers may control paper size differently in the Plotter Configuration
Editor.

Toolbar: Layouts  
Command entry: PAGESETUP
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To create or edit a custom paper size for a non-system printer

1 Click Output tab ➤ Plot panel ➤ Manage Plotters. 

2 In the Plotter Manager, double-click the PC3 file whose configuration
you want to change.

3 In the Plotter Configuration Editor, Device and Document Settings tab,
under the User Defined Paper Sizes & Calibration, select Custom Paper
Sizes.

4 Set a new paper size using one of the following methods:

■ To add a custom paper size, click Add and follow the steps in the
Custom Paper Size wizard. You specify the size of the paper, the
printable area, and a name for the new paper size.

■ To edit an existing paper size, under Custom Paper Sizes, select the
paper size and click Edit. The Custom Paper Size wizard opens. Change
any of the paper size settings.

5 Click OK.

The new or edited paper size is available in both the Plot and Page Setup
dialog boxes when that PC3 file is selected.

NOTE Creating a custom paper size for a non-system driver attaches a plot
model parameter (PMP) file to the plotter configuration (PC3) file. The PMP
file contains custom plotter calibration and custom paper size information.
By default, PMP files are stored in the Drv folder.

Command entry: PLOTTERMANAGER

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.
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PLOTTERMANAGER

Displays the Plotter Manager, where you can add or edit a plotter
configuration.

System Variables

PAPERUPDATE

Controls the display of a warning dialog when attempting to print a layout
with a paper size different from the paper size specified by the default for
the plotter configuration file.

Utilities

No entries

Command Modifiers

No entries

Position the Drawing on the Paper
There are several ways to position a drawing on the paper. You can specify
the printable area, set the position of the plot, and set the drawing orientation.

Specify the Printable Area
The printable area is displayed by a dashed border in a layout. The plotter and
paper size you select determine the printable area.

WARNING If you set your plotter to use paper-saving features such as plotting
inked area or nesting, your plotter will probably not use the printable area and
plot offset specifications.

If your plotter reports an incorrect printable area for your paper size, you can
adjust the printable area in the Modify Standard Paper Sizes area under the
Modify Standard Paper Sizes (Printable Area) option on the Device and
Document Settings tab in the Plotter Configuration Editor.

NOTE The Modify Standard Paper Sizes option is not a margins feature. Specify
where your drawing is plotted on the page in the Plot Offset area in the Plot dialog
box.
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Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

PLOTTERMANAGER

Displays the Plotter Manager, where you can add or edit a plotter
configuration.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set the Position of the Plot
The printable area of a drawing sheet is defined by the selected output device
and is represented by the dashed line in a layout. You can change the position
of plot relative to the printable area or to the edge of the paper.

The printable area of a drawing sheet is defined by the selected output device
and is represented by the dashed line in a layout. When you change to another
output device, the printable area may change.

The settings in the Plot Offset area of the Plot dialog box specify an offset of
the plot area relative to the lower-left corner (the origin) of the printable area
or the edge of the paper, depending on the setting made in the Specify Plot
Offset Relative To option (Options dialog box, Plot and Publish tab). The Plot
Offset area of the Plot dialog box displays the specified plot offset option in
parentheses.
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You can offset the drawing on the paper by entering positive or negative values
in the X and Y offset boxes. However, this may result in the plot area being
clipped. If the Plot Area is not set to Layout (Extents, Display, View, or
Window), you can also select the Center the Plot option.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

PLOTTERMANAGER

Displays the Plotter Manager, where you can add or edit a plotter
configuration.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set Drawing Orientation
The drawing orientation determines whether the position of the plotted
drawing is landscape (the longer edge of the drawing is horizontal) or portrait
(the longer edge of the drawing is vertical). This is based on the size of paper
selected. You can also choose to plot upside down.
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Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

PLOTTERMANAGER

Displays the Plotter Manager, where you can add or edit a plotter
configuration.

System Variables

PLOTROTMODE

Controls the orientation of plots.

Utilities

No entries

Command Modifiers

No entries

Control How Objects Are Plotted
You can control how objects are plotted by setting the plot scale, by using
plot styles and plot style tables, and by setting an object's layer properties.

Set Plot Scale
When you specify a scale to output your drawing, you can choose from a list
of real-world scales, enter your own scale, or select Fit to Paper to scale the
drawing to fit onto the selected paper size.

Usually, you draw objects at their actual size. That is, you decide how to
interpret the size of a unit (an inch, a millimeter, a meter) and draw on a 1:1
scale. For example, if your unit of measurement is millimeters, then every unit
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in your drawing represents a millimeter. When you plot the drawing, you
either specify a precise scale or fit the image to the paper.

Most final drawings are plotted at a precise scale. The method used to set the
plot scale depends on whether you plot the Model tab or a layout:

■ On the Model tab, you can establish the scale in the Plot dialog box. This
scale represents a ratio of plotted units to the world-size units you used to
draw the model.

■ In a layout, you work with two scales. The first affects the overall layout
of the drawing, which usually is scaled 1:1, based on the paper size. The
second is the scale of the model itself, which is displayed in layout
viewports. The scale in each of these viewports represents a ratio of the
paper size to the size of the model in the viewport.

NOTE You can modify the list of scales that are displayed in all view and plot scale
lists with SCALELISTEDIT.

Set a Specific Scale

When you plot, the paper size you select determines the unit type, inches or
millimeters. For example, if the paper size is in mm, entering 1 under mm
and 10 under Units produces a plotted drawing in which each plotted
millimeter represents 10 actual millimeters.

The illustrations show a light bulb plotted at three different scales.

Scale the Drawing to Fit the Page

When you review drafts, a precise scale is not always important. You can use
the Fit to Paper option to plot the view at the largest possible size that fits the
paper. The height or width of the drawing is fit to the corresponding height
or width of the paper.
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When you plot a perspective view from model space, the view is scaled to fit
the paper even when you enter a scale.

When you select the Fit to Paper option, the text boxes change to reflect the
ratio of plotted units to drawing units. This scale is updated whenever you
change the paper size, plotter, plot origin, orientation, or size of the plotted
area in the Plot dialog box.

NOTE This option is not available when the Plot Area is set to Layout.

To plot using a real-world scale

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Plot Scale, select a scale from the Scale box.

3 Click OK to plot the drawing.

Toolbar: Standard  
Command entry: PLOT

To plot using a custom scale

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Plot Scale, enter a custom scale. The scale
requires two values, the number of plotted units (inches or mm) per the
number of drawing units. The type of unit is determined by the paper
size, but you can change it in the list box.

If you enter a custom scale, Custom is automatically selected in the Scale
box, even if the scale you enter is the same as a standard scale in the list.
A custom scale is the ratio between the plotted units and drawing units.
For example, 1:12 and 2:24 are plotted at the same scale.

3 Click OK to plot the drawing.

Toolbar: Standard  
Command entry: PLOT
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To scale a drawing to fit the page

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Plot Scale, select the Fit to Paper option.

The resulting scale is automatically calculated. The ratio of plotted units
to drawing units in the custom scale boxes is displayed.

3 Click OK to plot the drawing.

NOTE This option is not available when the Plot Area is set to Layout.

Toolbar: Standard  
Command entry: PLOT

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

SCALELISTEDIT

Controls the list of scales available for layout viewports, page layouts, and
plotting.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set Shaded Viewport Options
You can choose among several options for plotting shaded and rendered
viewports. You can plot a viewport as it is displayed, in wireframe, with hidden
lines removed, or as rendered.

You can specify how each viewport should be plotted, and save the plot settings
with a drawing. You also can choose from a wide variety of resolutions, up to
the resolution of your plotter, and save the resolution settings with a drawing.

NOTE If hardware acceleration is disabled or is enabled, but does not support all
of the available hardware effects, it is possible to plot a drawing that contains
shaded viewports with unsupported hardware effects by the graphics card through
software emulation. To enable software emulation of hardware effects that are
not supported by your graphics card, enter 3dconfig, and click Manual Tune. In
the Manual Performance Tuning dialog box, click Emulate unsupported hardware
effects in software when plotting. The effects will not appear in the viewport in
real-time, but will appear in the hardcopy or electronic file that is created during
the plot process.

Overview of Shaded Viewport Plotting
The options for shaded viewport plotting give you a large degree of flexibility
in conveying your three-dimensional designs to others. You can convey your
design intent by choosing how viewports are plotted and by specifying
resolution levels.

With shaded plotting options, you can choose whether to plot a set of shaded
objects as displayed or in wireframe, hidden mode, a visual style, or rendered.
Shaded and rendered viewports are plot-previewed, plotted, plotted to file,
and published with full shading and rendering.
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You can use realistic plots in your presentations by plotting viewports as they
are displayed on the screen or otherwise.

Shaded viewport plotting options apply to all objects in viewports and model
space. If you use the Shaded or Rendered options plot style tables included in
the page setup do not affect plots. If you use the Render option,
two-dimensional wireframe objects, such as lines, arcs, and text, are not plotted.

NOTE Shaded viewport plotting requires a raster-capable device. Most modern
plotters and printers are raster-capable devices.

Quick Reference

Commands

3DCONFIG

Sets options that affect 3D display performance.

PLOT

Plots a drawing to a plotter, printer, or file.

SHADEMODE

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Specify Shaded Plotting Settings
If you are plotting a drawing that contains 3D solids that are shaded, you can
control how the drawing is plotted.

Specifically, you can choose from the following options:

■ As Displayed. Plots the design as it is displayed; all the shading is preserved.

■ Wireframe. Displays lines and curves to represent object boundaries.
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■ Hidden. Suppresses the plotting of objects that are located behind other
objects.

■ Visual Styles. Plots the design as it appears in the visual style you select.

■ Rendered. Renders objects before they are plotted, based on Render options
you set before you plot or based on the render preset you select.

■ Render Presets. Renders objects based on the render preset you select.

You can select an option for your drawing either from model space or from a
layout. From model space, the options are available in the Properties palette
and the Plot dialog box. From a layout, after you select a viewport, the options
are available from the shortcut menu and from the Properties palette.

Either way, you can save your settings with the drawing.

NOTE If you select the Rendered option, specify Render settings before plotting.
If the Rendered option is used for a highly complex set of objects, the hardcopy
output might contain only the viewport border.

To modify the shade plot setting of a viewport

1 Make sure you are on a layout tab.

2 Double-click the border of the viewport you want to modify.

3 In the Properties palette, under Misc., select Shade Plot, and then select
an option for plotting.

Shortcut menu: Select the viewport and right-click in the drawing area.
Click a setting from the Shade Plot options.

To modify the shade plot setting in model space

1 Make sure you are on the Model tab and no objects are selected.

2 Click Output tab ➤ Plot panel ➤ Plot. 

3 In the Plot dialog box, under Shaded Viewport Options, Shade Plot
drop-down list, select an option.

Command entry: PLOT
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Quick Reference

Commands

PLOT

Plots a drawing to a plotter, printer, or file.

3DCONFIG

Sets options that affect 3D display performance.

SHADEMODE

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Specify a Resolution Level for Shaded Plotting
You can set the resolution of shaded plots for either greater speed or higher
fidelity.

After you select an appropriate plotter, you can specify the level of quality for
plotted output. The quality level determines the dots per inch (dpi). The dpi
that corresponds to a quality level is based on the plotter you select.

The maximum dpi available is also based on the plotter you select. You can
specify a custom quality level and directly change the dpi to a setting between
100 and the maximum dpi of the plotter.

The higher the fidelity, the more computer memory is used, so the longer it
takes to plot. High fidelity is not necessary for all plots, and a setting between
300 and 600 dpi is generally sufficient for most plots.

To specify a resolution level for shaded plotting

1 Click Output tab ➤ Plot panel ➤ Plot. 
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2 In the Plot dialog box, under Shaded Viewport Options, Quality
drop-down list, select an option.

If you want to enter a custom dpi, select Custom and specify a dpi in the
DPI box.

3 Click OK.

Command entry: PLOT

Quick Reference

Commands

PLOT

Plots a drawing to a plotter, printer, or file.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set Options for Plotted Objects
In the Plot and the Page Setup dialog boxes, you can choose from options that
affect how objects are plotted.

■ Shaded Viewport Plotting. Specifies shaded plotting options: As Displayed,
Wireframe, or Hidden. The effect of this setting is reflected in the plot
preview, but not in the layout.

■ Plot Object Lineweights. Specifies that lineweights assigned to objects and
layers are plotted.

■ Plot with Plot Styles. Specifies that the drawing is plotted using plot styles.
Selecting this option automatically plots lineweights. If you do not select
this option, objects are plotted with their assigned properties and not with
the plot style overrides.
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NOTE Plot styles are not available for objects with the Jitter edge modifier
applied (VISUALSTYLES).

■ Plot Paper Space Last. Specifies that objects in model space are plotted
before those in paper space.

■ Hide Paperspace Objects. Specifies whether the Hide operation applies to
objects in the paper space viewport. This option is available only from a
layout tab. The effect of this setting is reflected in the plot preview, but
not in the layout.

■ Plot Stamp On. Turns on plot stamping and places a plot stamp on a
specified corner of each drawing and/or logs it to a file. Plot stamp settings
are specified in the Plot Stamp dialog box, where you can specify the
information you want applied to the plot stamp, such as drawing name,
date and time, plot scale, and so on. To open the Plot Stamp dialog box,
select Plot Stamp On in the Plot dialog box, and then click the Plot Stamp
Settings button.

■ Save Changes to Layout. Saves changes you make in the Plot dialog box
to the layout if you click OK.

To set shaded plotting options from the Model tab

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, Shaded Viewport Options area, Shade Plot
drop-down list, select an option.

Toolbar: Standard  
Command entry: PLOT

To set shaded plotting options from a layout tab

1 Select a layout viewport.

2 Double-click the viewport border to display the Properties palette.

3 On the Properties palette, click Shade Plot.

4 In the Shade Plot drop-down list, select an option.
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Toolbar: Standard  
Command entry: PROPERTIES

Shortcut menu: Select the viewport, right-click in the drawing area, and
then click Shade Plot.

To remove hidden lines when plotting from the Model tab

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Shaded Viewport Options area, Shade Plot
drop-down list, select Hidden.

3 Click OK to plot the drawing.

Toolbar: Standard  
Command entry: PLOT

To remove hidden lines when plotting from a layout tab

1 Select a layout viewport.

2 Double-click the viewport border to display the Properties palette.

3 On the Properties palette, click Shade Plot.

4 In the Shade Plot drop-down list, select Hidden.

5 Click OK to plot the drawing.
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Toolbar: Standard  
Command entry: PROPERTIES

Shortcut menu: Select the viewport and right-click in the drawing area.
Click Shade Plot.

To plot lineweights

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Plot Options, select Plot Object Lineweights.

You can change this option only if the Plot with Plot Styles option is
cleared.

3 Click OK to plot the drawing.

Toolbar: Standard  
Command entry: PLOT

To turn off plot styles

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Plot Options, clear the Plot with Plot Styles
option.

3 Click OK to plot the drawing.
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Toolbar: Standard  
Command entry: PLOT

To change the order in which objects are plotted

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Plot Options, select Plot Paperspace Last.
Clear the Plot Paperspace Last option to plot paper space first.

3 Click OK to plot the drawing.

Toolbar: Standard  
Command entry: PLOT

To hide paper space objects when plotting from a layout tab

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Plot Options, select Hide Paperspace Objects.

3 Click OK to plot the drawing.

Toolbar: Standard  
Command entry: PLOT

Quick Reference

Commands

LWEIGHT

Sets the current lineweight, lineweight display options, and lineweight units.

OPTIONS

Customizes the program settings.
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PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

PLOTSTAMP

Places a plot stamp on a specified corner of each drawing and logs it to a file.

PROPERTIES

Controls properties of existing objects.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Use Plot Styles to Control Plotted Objects
You can control many aspects of how an object is plotted by using plot styles.

Overview of Plot Styles
A plot style controls an object's plotted properties.

A plot style is an object property, similar to linetype and color. A plot style
can be assigned to an object or assigned to a layer. A plot style controls an
object's plotted properties, including

■ Color

■ Dither

■ Grayscale

■ Pen number
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■ Virtual pen

■ Screening

■ Linetype

■ Lineweight

■ Line end style

■ Line join style

■ Fill style

Using plot styles gives you great flexibility because you can set them to override
other object properties or turn off the override as needed.

Groups of plot styles are saved in either of two types of plot style tables:
color-dependent (CTB) or named (STB). Color-dependent plot style tables set
style based on the color of the object. Named plot styles can be assigned to
an object independent of color.

NOTE Plot styles are not available for objects with the Jitter edge modifier applied
(VISUALSTYLES).

Quick Reference

Commands

CONVERTCTB

Converts a color-dependent plot style table (CTB) to a named plot style table
(STB).

CONVERTPSTYLES

Converts the current drawing to either named or color-dependent plot styles.

OPTIONS

Customizes the program settings.

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.
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System Variables

CPLOTSTYLE

Controls the current plot style for new objects.

DEFLPLSTYLE

Specifies the default plot style for all layers in a drawing when opening a
drawing that was created in a release prior to AutoCAD 2000, or for Layer 0
when creating a new drawing from scratch without using a drawing template.

DEFPLSTYLE

Specifies the default plot style for new objects in a drawing when opening a
drawing that was created in a release prior to AutoCAD 2000, or when creating
a new drawing from scratch without using a drawing template.

PSTYLEMODE

Indicates whether the current drawing is in a Color-Dependent or Named
Plot Style mode.

PSTYLEPOLICY

Controls the plot style mode, Color-Dependent or Named, that is used when
opening a drawing that was created in a release prior to AutoCAD 2000 or
when creating a new drawing from scratch without using a drawing template.

Utilities

No entries

Command Modifiers

No entries

Choose a Type of Plot Style Table
A plot style table is a collection of plot styles assigned to a layout or the Model
tab. There are two types of plot style tables: color-dependent plot style tables
and named plot style tables.

Color-dependent plot style tables (CTB) use an object's color to determine
characteristics such as lineweight. Every red object in a drawing is plotted the
same way. While you can edit plot styles in a color-dependent plot style table,
you cannot add or delete plot styles. There are 256 plot styles in a
color-dependent plot style table, one for each color.
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Named plot style tables (STB) contain user-defined plot styles. When you use a
named plot style table, objects that have the same color may be plotted
differently, based on the plot style assigned to the object. A named plot style
table can contain as many or as few plot styles as required. Named plot styles
can be assigned to objects or layers, just like any other property.

To set a plot style table type for new drawings

1 Click Tools menu  ➤ Options.

2 In the Options dialog box, Plot and Publish tab, click the Plot Style Table
Settings button.

3 In the Plot Style Table Settings dialog box, select Use Color-dependent
Plot Styles or Use Named Plot Styles.

4 (Optional) In the Default Style Table box, select a default plot style table.

5 (Optional) If Use Named Plot Styles is selected, select plot styles to assign
to Layer 0 and to new objects.

6 Click OK.

NOTE Setting plot style table types for new drawings does not affect existing
drawings.

Command entry: OPTIONS

Quick Reference

Commands

OPTIONS

Customizes the program settings.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Switch the Type of Plot Style Table
You can change which type of plot style table, color-dependent or named, is
used in a drawing.

You can use CONVERTPSTYLES to change which type of plot style table,
color-dependent or named, is used in a drawing.

When you convert a drawing from using color-dependent plot style tables to
using named plot style tables, any color-dependent plot style tables attached
to layouts in the drawing are removed, and named plot styles are attached in
their place. If you want to use the styles defined in the color-dependent plot
style tables after you convert to using named plot styles tables, you should
first convert any color-dependent plot style tables to named plot style tables.

When you convert a drawing from using named plot style tables to using
color-dependent plot style tables, the plot style names assigned to the objects
in the drawing are lost.

In addition to changing which type of plot style table a drawing uses, you can
use CONVERTCTB to convert color-dependent plot style tables to named plot
style tables. You cannot, however, convert a named plot style table to a
color-dependent plot style table.

To convert a drawing to use named plot styles

1 At the command prompt, enter convertpstyles.

2 Click OK when the alert box appears.

3 In the Select File dialog box, select a named plot style table to use for the
Model tab and any layouts that use plot style tables of the same name.

4 Click Open.

A message is displayed to confirm that the drawing was converted.
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NOTE If the Display Plot Styles option was already selected in the dialog box,
you must enter regen at the command prompt to display the plot style
settings.

To convert a drawing to use color-dependent plot styles

1 At the command prompt, enter convertpstyles.

2 Click OK.

A message is displayed to confirm that the drawing was converted.

To convert a color-dependent plot style table into a named plot style table

1 At the command prompt, enter convertctb.

2 In the Select File dialog box, select the name of the plot style table to
convert, and then click Open. By default, plot style tables are saved in
the Plot Styles folder.

3 Enter the new plot style table name. Click Save.

4 Click OK when the alert box appears.

NOTE Be sure to use the Plot Style Table Editor to change the names of the plot
styles in their new plot style table to be more meaningful before using the plot
style table with any drawings.

Command entry: CONVERTCTB

Quick Reference

Commands

CONVERTCTB

Converts a color-dependent plot style table (CTB) to a named plot style table
(STB).

CONVERTPSTYLES

Converts the current drawing to either named or color-dependent plot styles.

OPTIONS

Customizes the program settings.

Use Plot Styles to Control Plotted Objects | 1819



OPTIONS

Customizes the program settings.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Assign Plot Style Tables to Layouts
By assigning different plot style tables to each layout in your drawing, you
can control how objects in the layout are plotted. The plot style table affects
both model space and paper space objects. To plot the drawing without
applying plot style properties, select None from the list of plot style tables.

If you use named plot style tables, each object in the drawing either is assigned
a plot style directly or inherits a plot style from its layer.

To display the effects of a plot style table in a layout, select Display Plot Styles
under Plot Style Table in the Page Setup dialog box.

NOTE If you insert an xref into your current drawing, all defined plot style tables
are also inserted. You can modify the appearance of your objects by editing the
attached plot style tables with the Plot Style Table Editor.

To assign a plot style table to a layout

1 Click the Model tab or the layout tab to which you want to assign the
plot style table.

2 Click Output tab ➤ Plot panel ➤ Page Setup. 

3 In Page Setup Manager, click Modify.

4 Under Plot Style Table (Pen Assignments), select a plot style table from
the list.
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5 In the Question dialog box, click Yes or No to indicate whether the
selection should be applied to the current tab only or to all layouts.

This option is available only for the Model tab.

6 To preview the effects of the plot style table in the layout, select Display
Plot Styles.

This option is available only for layouts.

7 Click OK.

8 In Page Setup Manager, click Close.

NOTE If the Display Plot Styles option was already selected in the dialog box, you
must enter regen at the command prompt to display the plot style settings.

Toolbar: Layouts  
Command entry: PAGESETUP

To preview the effects of a plot style table in a layout

1 Click the layout tab in which you want to preview the effects of the plot
style table.

2 Click Output tab ➤ Plot panel ➤ Page Setup. 

3 In Page Setup Manager, click Modify.

4 In the Page Setup dialog box, under Plot Style Table (Pen Assignments),
select the Display Plot Styles option.

5 Click OK.

6 In Page Setup Manager, click Close.

The effects of the plot style table are previewed in the layout.

Toolbar: Layouts  
Command entry: PAGESETUP
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Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Manage Plot Style Tables
You can use the Plot Style Manager to add, delete, rename, copy, and edit plot
style tables.

Color-dependent (CTB) and named (STB) plot style tables are stored in the
Plot Styles folder by default. This folder is also known as the Plot Style Manager.

You can use the Plot Style Manager to add, delete, rename, copy, and edit plot
style tables. The Plot Style Manager lists all of the available plot style tables.

To create a plot style table

1 Click Tools menu  ➤ Wizards  ➤ Add Plot Style Table.

2 Read the first page. Click Next.

3 On the Begin page, you can choose to use an configuration file (CFG) or
plotter configuration file (PCP or PC2) to import pen settings, base the
new plot style table on an existing plot style table, or start from scratch.
If you use an existing plot style table, the new plot style table uses the
same type of table as the original. Click Next.

4 On the Pick Plot Style Table page, select Color-Dependent Plot Style Table
or Named Plot Style Table.
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5 If you are importing pen settings from a PCP, PC2, or CFG file, or if you
are basing the new plot style table on an existing plot style table, specify
the file on the Browse File Name page. If you use a CFG file, you may
need to select which plotter's configuration to import. Click Next.

6 On the File Name page, enter a name for the new plot style table. Click
Next.

7 On the Finish page, you can edit the new plot style table by choosing
Plot Style Table Editor. You can assign the new plot style table so that it
can be used in all drawings.

8 Click Finish.

The new plot style table is available in both the Plot and the Page Setup
dialog boxes for all drawings using color-dependent plot style tables.

To rename a plot style table

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Right-click the plot style whose name you want to change. Click Rename.

3 Enter the new file name. Be sure to add the same file extension (.ctb or
.stb). When finished, press ENTER.

The renamed plot style table is available in the Plot and Page Setup dialog
boxes for all drawings using that type of plot style table.

Command entry: STYLESMANAGER

To change a plot style table description

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Double-click the plot style table file whose description you want to
change.

3 In the Plot Style Table Editor, General tab, enter the new description for
the plot style table.

4 Click Save & Close.

Command entry: STYLESMANAGER
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To edit plot styles in a plot style table

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Double-click the plot style table you want to change.

3 In the Plot Style Table Editor, Form View tab, under Plot Styles, select a
plot style and edit the settings.

4 Click Save & Close.

Command entry: STYLESMANAGER

Quick Reference

Commands

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Use Color-Dependent Plot Style Tables
By using color-dependent plot styles to control how objects are plotted, you
ensure that all objects that share the same color are plotted the same way.

When a drawing uses color-dependent plot style tables, you cannot assign a
plot style to individual objects or layers. Instead, to assign plot style properties
to an object, you change the color of the object or layer.
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You can assign color-dependent plot style tables to layouts. You can use several
predefined color-dependent plot style tables, edit existing plot style tables, or
create your own.

Color-dependent plot style tables are stored in the Plot Styles folder and have
a .ctb extension.

Use Predefined Color-Dependent Plot Style Tables
Several color-dependent plot style tables are installed in the Plot Styles folder,
also known as the Plot Style Manager.

DescriptionTable

Default plot style tableacad.ctb

Sets first 9 colors to use first 9 fill patterns, all others to use
object's fill

fillPatterns.ctb

Converts all colors to grayscale when plottedgrayscale.ctb

Plots all colors as blackmonochrome.ctb

Applies no plot style tableNone

Uses 100% ink for all colorsscreening 100%.ctb

Uses 75% ink for all colorsscreening 75%.ctb

Uses 50% ink for all colorsscreening 50%.ctb

Uses 25% ink for all colorsscreening 25%.ctb

NOTE You can assign a color-dependent plot style table to a layout only if the
drawing has been set to use color-dependent plot style tables.

See also:

■ Assign Plot Style Tables to Layouts on page 1820
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Quick Reference

Commands

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Use Named Plot Style Tables
You can only create, delete, and apply plot styles in a named plot style table.
You can define as many or as few plot styles as you need in a drawing.

Use Named Plot Styles
Named plot styles are assigned to objects and layers in the same way that
linetype and color are assigned to objects.

An object whose plot style is set to BYLAYER inherits the plot style assigned
to its layer.

Use the Properties palette to change an object's plot style and the Layer
Properties Manager to change the plot style for a layer.

Because different plot style tables can be assigned to each layout and a named
plot style table can contain any number of plot styles, an object or layer may
have a plot style assigned to it that is not in every plot style table. In this case,
the plot style as missing in the Select Plot Style dialog box; the object's default
plotting properties are used. For example, named plot style table Style1 contains
plot styles A and B. Named plot style table Style2 contains plot styles B and
C. In a layout that uses Style1, any objects that use plot style C are listed as
having a missing plot style. Objects that are assigned plot style C in this layout
are plotted using their default settings.
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To change an object's plot style

You can change an object's plot style only if the drawing uses named plot
style tables. If the drawing uses color-dependent plot style tables, change the
object's color to alter its plotted appearance.

1 Select one or more objects whose plot style you want to change.

2 Click Veiw tab  ➤  Palettes panel  ➤  Properties.

TIP You can also right-click in the drawing area and then, click Properties.

3 In the Properties palette, select a plot style from the list of available plot
styles. Click the column next to Plot Style.

The plot styles listed are those already in use by objects and in the plot
style table attached to the current layout.

4 To select a plot style from a different plot style table, select Other. In the
Select Plot Style dialog box, you can attach a different plot style table to
the current layout and select a plot style from that plot style table.

5 To edit the current plot style table, click Editor.

6 Click OK when finished.

Any changes made in the Properties palette are immediate. If you change
the plot style table attached to the current layout, both model space and
paper space objects are affected.

Toolbar: Standard  
Command entry: PROPERTIES

To change a layer's plot style

1 Click Home tab  ➤  Layers panel  ➤  Layer Properties Manager.

2 In the Layer Properties Manager, select the layer whose plot style you
want to change.

3 Click the current plot style in the Plot Style column. Select the plot style
you want to use.
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4 To select a plot style from a different plot style table, select an active plot
style table from the Active Plot Style Tables list.

The list of plot styles changes to those in the selected plot style table.

5 To edit the selected plot style table, click Editor. Change settings as
necessary and click Save & Close.

6 Click OK.

You can change a layer's plot style only if the drawing uses named plot
style tables. If the drawing uses color-dependent plot style tables, change
the layer's color to alter the plotted appearance of objects on the layer.

NOTE An object's plot style property can be set to BYLAYER to inherit the
plot style of its layer.

Toolbar: Layers  
Command entry: LAYER

To set the current plot style

1 Click Home tab  ➤  Properties panel  ➤  Plot Style.

2 In the Current Plot Style dialog box, select a plot style from the list.

The plot styles displayed are those available in the current plot style table.

3 To select a plot style from a different plot style table, under Active Plot
Style Table, select a plot style table.

The list of plot styles changes to those in the selected plot style table.

4 To edit the selected plot style table, click Editor. Change settings as
necessary. Click Save & Close.

5 Click OK.

The plot style that you made current is used for any new objects created
in the drawing.

You can change the current plot style only if the drawing uses named
plot style tables. If the drawing uses color-dependent plot style tables,
change the color to alter the plotted appearance of objects and layers.
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NOTE The current plot style property can be set to BYLAYER to inherit the
plot style of the current layer.

Command entry: PLOTSTYLE

Quick Reference

Commands

LAYER

Manages layers and layer properties.

PLOTSTYLE

Controls the named plot styles that are attached to the current layout and
can be assigned to objects.

PROPERTIES

Controls properties of existing objects.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Manage Named Plot Styles
You can add, delete, rename, and copy plot styles in a named plot style table
using the Plot Style Table Editor.

The Plot Style Table Editor is also used to change plot style settings for both
named and color-dependent plot style tables.
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NOTE You cannot delete or edit the NORMAL plot style. Also, you cannot add,
delete, copy, or rename plot styles in a named plot style table if a color mapping
table has been attached to the plot style table. A color mapping table associates
every plot style with an ACI color.

See also:

■ Change Plot Style Settings on page 1835

To create a named plot style

1 Click Home tab  ➤  Properties panel  ➤  Plot Style.

2 Double-click the STB file to which you want to add a plot style.

3 (Optional) If you want to position the plot style in the list, on the Form
View tab, select the plot style that should precede the new plot style.

4 On the Form View or Table View tab, click Add Style.

5 In the Add Plot Style dialog box, enter the name of the plot style.

6 Click Save & Close.

NOTE You cannot edit the NORMAL plot style.

Command entry: STYLESMANAGER

To copy a named plot style

1 Click Home tab  ➤  Properties panel  ➤  Plot Style.

2 Double-click the STB file you want to edit.

3 In the Plot Style Table Editor, Form View tab, right-click the plot style
that you want to copy. Click Copy.

4 Right-click a plot style. Click Paste. If you want to position the new plot
style in the list, right-click the plot style that should precede the new plot
style.

5 In the Add Plot Style dialog box, enter the name of the plot style.
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6 Click Save & Close.

NOTE You cannot copy plot styles if the plot style table uses a color mapping
table. You cannot copy plot styles in a color-dependent plot style table.

Command entry: STYLESMANAGER

To change a plot style's description

1 Click Home tab  ➤  Properties panel  ➤  Plot Style.

2 Double-click the plot style table that contains the plot style whose
description you want to change.

3 In the Plot Style Table Editor, Form View tab, select the plot style whose
description you want to change.

4 Under Description, change the plot style's description.

You can select additional plot styles and modify their descriptions or
settings.

5 Click Save & Close.

NOTE You cannot delete or edit the NORMAL plot style.

Command entry: STYLESMANAGER

To rename a named plot style

1 Click Home tab  ➤  Properties panel  ➤  Plot Style.

2 Double-click the STB file that contains the plot style you want to rename.

3 In the Plot Style Table Editor, Form View tab, right-click the plot style
whose name you want to change. Click Rename.

4 Enter the new name for the plot style.

5 Click Save & Close.

NOTE You cannot rename the NORMAL style. You cannot rename plot styles in
a color-dependent plot style table.
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Command entry: STYLESMANAGER

To delete a named plot style

1 Click Home tab  ➤  Properties panel  ➤  Plot Style.

2 Double-click the STB file you want to edit.

3 In the Plot Style Table Editor, Form View tab, select the plot style that
you want to delete from the list of plot styles.

4 Click Delete Style.

5 Click Save & Close.

NOTE You cannot delete or edit the NORMAL plot style. You cannot delete plot
styles if the plot style table uses a color mapping table. You cannot delete plot
styles from a color-dependent plot style table.

Command entry: STYLESMANAGER

Quick Reference

Commands

PLOTSTYLE

Controls the named plot styles that are attached to the current layout and
can be assigned to objects.

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Use Predefined Named Plot Style Tables
One additional named plot style table is installed for you to use beyond the
default plot style table. All named plot style tables have an .stb extension.

■ acad.stb: Default plot style table

■ Monochrome.stb: All colors plot as black

■ None: No plot style table applied

NOTE Named plot style tables are available only if the drawing has been set to
use named plot style tables.

See also:

■ Assign Plot Style Tables to Layouts on page 1820

Quick Reference

Commands

PLOTSTYLE

Controls the named plot styles that are attached to the current layout and
can be assigned to objects.

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Delete Color Mapping Tables
If you delete the mapping table, the plot style table becomes an ordinary plot
style table and is no longer useful for applying plot styles to old drawings.

Named plot style tables that you create using CFG, PCP, or PC2 files have
color mapping tables that are created from your previous pen mappings.
Color-dependent plot style tables also have color mapping tables. Color
mapping tables are used to map plot styles to colors and thus to objects of
each color when opening pre- AutoCAD 2000 drawings. This enables you to
simulate the way drawings were plotted in previous versions.

While the color mapping table exists, you cannot add, delete, or rename plot
styles in that plot style table.

If you delete the mapping table, the plot style table becomes an ordinary plot
style table and is no longer useful for applying plot styles to old drawings. It
continues to be useful for new drawings.

WARNING If you delete a color mapping table, plot styles cannot automatically
be assigned to objects when older drawings are opened for the first time.

To delete a color mapping table

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, General tab, click Delete AutoCAD Release
14 Color Mapping Table.

4 Read the warning. Click Yes to delete the color mapping table, or click
No to keep it.
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5 Click Save & Close.

Command entry: STYLESMANAGER

Quick Reference

Commands

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Change Plot Style Settings
You can modify plot styles using the Plot Style Table Editor. Changes you
make to a plot style affect the objects to which that plot style is assigned.

Overview of Plot Style Settings
You can open the Plot Style Table Editor by double-clicking a CTB or STB file
in the Plotter Manager. The Plot Style Table Editor displays the plot styles
contained in the specified plot style table.

The General tab lists general information about the table. The Table View and
Form View tabs provide two ways to modify plot style settings. In general, the
Table View tab is convenient if you have a small number of plot styles. If you
have a large number of plot styles, the Form View tab might be more
convenient.

In a named plot style table, the NORMAL plot style represents an object's
default properties (no plot style applied). You cannot modify or delete the
NORMAL style.
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To edit plot style settings

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Double-click the plot style table you want to modify.

3 In the Plot Style Table Editor, Form View tab, under Plot Styles, select the
plot style you want to modify.

4 Under Properties, click the arrow next to the property you want to change.
Select an option from the list.

5 Edit other properties or plot styles as needed.

6 Click Save & Close.

Command entry: STYLESMANAGER

Quick Reference

Commands

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set Color, Screening, Grayscale, and Dither in Plot
Style Tables
You can use a plot style to assign color, screening, grayscale, and dither
properties.

1836 | Chapter 29   Plot Drawings



Assign Plot Style Colors

The default setting for plot style color is Use Object Color. With this setting,
the object retains its layer or individually set color. If you assign a plot style
color, the color overrides the object's color at plot time. You can specify one
of 255 ACI colors, a true color, or a color book color. The plotter must be
configured for True Color if you want to plot True Color plot styles.

NOTE If you use a plot style table saved in AutoCAD 2000 or later, the True Color
values change to the nearest match in the current version's palette.

Use Screening

You can select a color intensity setting that determines the amount of ink
placed on the paper while plotting. The valid range is 0 through 100. Selecting
0 reduces the color to white. Selecting 100 displays the color at its full intensity.
Screening is effective only if your plotter is configured to plot colors or
grayscale. Also, dithering must be enabled.

Use Dithering

A plotter uses dithering to approximate colors with dot patterns, giving the
impression of plotting with more colors than the ink colors available in the
plotter. If the plotter does not support dithering, the dithering setting is
ignored.

The most common reason for turning off dithering is to avoid false line typing
from dithering of thin vectors and to make dim colors more visible. When
you turn off dithering, colors are mapped to the nearest color, which limits
the range of colors used for plotting. Dithering is available whether you use
the object's color or assign a plot style color.

NOTE Dithering disables merge control.

Convert to Grayscale

When you select Convert to Grayscale, the object's colors are converted to
grayscale if the plotter supports grayscale. Light colors, such as yellow, are
plotted with light gray values. Dark colors are plotted with dark gray values.
If you clear Convert to Grayscale, the RGB values are used for the object's
colors. Conversion to grayscale is available whether you use the object's color
or assign a plot style color.
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To assign a plot style color

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Right-click a CTB or STB file. Click Open.

3 In the Plot Style Table Editor, Table View tab, click the Color field for the
plot style you want to change.

4 On the Color drop-down list, click the color you want to use or click
Select Color to display the Select Color dialog box and do one of the
following:

■ On the Index tab, click a color or enter the ACI color number (1-255)
or name in the Color box. Click OK.

■ On the True Color tab, in the Color Model box, specify a color. (Enter
a color value in the Color box or specify values in the Hue, Saturation,
and Luminance boxes.) Click OK.

■ On the Color Books tab, in the Color Book box, select a color (use the
up and down arrow and click on a color chip.) Click OK.

Command entry: STYLESMANAGER

To use screening

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change.

4 In the Screening box, enter an intensity value between 1 and 100.

5 When finished, click Save & Close.

You can edit properties for multiple plot styles while in the Plot Style
Table Editor.

NOTE A common practice when using screening is to set the plotted color
to black for each style so that the screening will be a percentage of black.
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Command entry: STYLESMANAGER

To enable or disable dithering

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change and select Dither.

4 Select On or Off.

5 When finished, click Save & Close.

You can edit properties for multiple plot styles while in the Plot Style
Table Editor.

Command entry: STYLESMANAGER

To enable or disable conversion to grayscale

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change and select Grayscale.

4 Select On or Off.

5 When finished, click Save & Close.

You can edit properties for multiple plot styles while in the Plot Style
Table Editor.

Command entry: STYLESMANAGER

Quick Reference

Commands

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Assign Pen Numbers and Virtual Pens in Plot Style
Tables
The pen assignments used by the plotter differ depending on whether you
use a pen plotter or another kind of printer, such as a laser printer.

Assign Pens to Plot Styles

The Use Assigned Pen Number setting in the Plot Style Table Editor specifies
which physical pen to use for each plot style. The physical pens in the plotter
are described in the plotter's configuration (PC3) file. If you use a pen plotter,
you must provide information about the color, speed, and width of each pen
in the Physical Pen Configuration section of the Plotter Configuration Editor.

For example, when you specify pen information in the Plotter Configuration
Editor, you might specify that pen #1 is black and 0.010 inches and pen #2 is
red and 0.020 inches. In the Plot Style Table Editor you can assign pen #1 to
the plot style called WATER PIPES and pen #2 to the plot style called SEWER
PIPES.

You can assign a pen to a plot style by selecting from a range of 32 pen
numbers in the Use Assigned Pen Number field. The default value is 1. If plot
style color is set to Use Object Color, or if you are editing a plot style in a
color-dependent plot style table, you cannot change the assigned pen number.

If you specify 0, the field is updated to read Automatic. The information you
provided under Physical Pen Characteristics in the Plotter Configuration Editor
is used to select the pen closest in color to the color of the object you are
plotting.
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Assign Pen Settings to Plotters Without Pens

Many plotters that do not use pens can simulate the performance of a pen
plotter by using virtual pens. For many devices, you can control the virtual
pens in the device with software or, by configuring them from the plotter's
control panel, with hardware.

If you allow software to control the pens, the Plot Style Table values for the
Lineweight, Linetype, Screening, Line End Style, Line Join Style, and Fill Style
settings are effective and override the settings on the plotter's control panel.

If you turn off software control of the pen attributes (typically done on the
plotter), then the software can select virtual pens but can't control lineweight,
linetype, end style, join style, fill style, or color. In the program, you select
hardware (virtual pen) control over software (normal) control by selecting
255 Virtual Pens in the Color Depth area of the Vector Graphics option on
the Device and Document Settings tab in the Plotter Configuration Editor.
Selecting any other color depth specifies software control.

In the Plot Style Table Editor under Virtual Pen #, you can specify a virtual
pen number between 1 and 255. Enter 0 or Automatic to specify that the
virtual pen assignment should be made from the ACI.

When you create a plot style table, it is important to remember that it can be
used with many different plotters and that the plotter and mode determine
what parts of the plot style table are enabled.

■ When using a pen plotter with user assigned pens, the virtual pen number
and any color assignments are ignored.

■ When using a pen plotter with automatically assigned pens, pens are
selected based on entity color and entity lineweight. Virtual pen numbers
are ignored.

■ When using a raster plotter in raster mode, the physical pen number and
the virtual pen number are ignored.

■ When using a raster plotter in virtual pen mode, everything except the
virtual pen number is ignored.

NOTE If you use another application to process your plot files after creating them,
and you modify the pen attributes, plotting without using virtual pens results in
pen numbers in the plot file having no simple relationship to object colors in the
program. This makes it difficult to apply additional pen attributes.
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To specify a virtual pen number

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change and click Virtual Pen.

4 Under Virtual Pen #, enter a number between 1 and 255 or enter 0 or
Automatic to have the program assign the ACI color of the object you
are plotting to the virtual pen.

5 When finished, click Save & Close.

You can edit properties for multiple plot styles while in the Plot Style
Table Editor.

Command entry: STYLESMANAGER

Quick Reference

Commands

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Control Plotted Lineweight and Linetype
Both lineweight and linetype can be set as an object property or controlled
when plotted by using a plot style. Lineweight or linetype settings in the plot
style override the object's lineweight or linetype at plot time.
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Assign and Display Lineweights

When you select the Lineweight field in the Plot Style Table Editor, a sample
of the lineweight as well as its numeric value are displayed. The default setting
for plot style lineweight is Use Object Lineweight. You can modify an existing
lineweight if the one you need is not available.

To view plot style lineweights in a layout, select Display Plot Styles under Plot
Style Table in the Page Setup dialog box.

Assign Linetypes

When you select the Linetype field in the Plot Style Table Editor, a list with
a sample and a description of each linetype are displayed. The default setting
for plot style linetype is Use Object Linetype.

Whether you choose to assign a linetype as a property of the object or as a
plot style, you can set the Adaptive Adjustment option. This option adjusts
the scale of the linetype to complete the linetype pattern. If you don't select
Adaptive Adjustment, the line might end in the middle of a pattern. Turn off
Adaptive Adjustment if linetype scale is important. Turn on Adaptive
Adjustment if complete linetype patterns are more important than correct
linetype scaling.

You can apply a global scale factor to non-ISO linetypes and fill patterns in
plot styles.

See also:

■ Work with Linetypes on page 601

■ Control Lineweights on page 614

To set the plotted lineweight

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change.

4 Click the Lineweight arrow and select a lineweight from the list. To specify
that the object's lineweight should be used select Use Object Lineweight.

5 Click Save & Close.
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You can edit properties for multiple plot styles while in the Plot Style
Table Editor.

Command entry: STYLESMANAGER

To set the plotted linetype

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, Form View tab, select the plot style you
want to change.

4 Click the Linetype arrow and select a linetype from the list. To specify
that the object's linetype should be used, select Use Object Linetype.

5 To adjust the linetype scale to show the complete pattern, on the Form
View tab, select On in the Adaptive box.

6 Click Save & Close.

You can edit properties for multiple plot styles while in the Plot Style
Table Editor.

Command entry: STYLESMANAGER

To apply scaling to non-ISO linetypes and fill patterns

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Double-click the plot style table that you want to modify.

3 In the Plot Style Table Editor, General tab, select Apply Global Scale Factor
to Non-ISO Linetypes.

This option scales linetypes and fill patterns according to a value that
you specify.

4 In the Scale Factor box, enter a scale factor to apply.

5 Click Save & Close.

Command entry: STYLESMANAGER
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Quick Reference

Commands

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Assign Plotted Line End and Join Styles
You can set the line end and join styles for objects that have lineweight
assigned, either as an object property or as a plot style override.

Assign Line End Style

The program includes the following line end style options:

■ Butt

■ Square

■ Round

■ Diamond

The default setting for Line End Style is Use Object End Style, which is rounded.
Assign a line end style in a plot style to override the object's default line end
style at plot time.

NOTE SHX text plots best with the Round End and Round Join styles.
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Assign Line Join Style

The program includes the following line join style options:

■ Miter

■ Bevel

■ Round

■ Diamond

The default setting for Line Join Style is Use Object Join Style, which is
rounded. Assign a line join style in a plot style to override the object's default
line join style at plot time.

To assign a line end or line join style

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Right-click a CTB or STB file. Click Open.

3 In the Plot Style Table Editor, Table View tab, click the Line End Style or
Line Join Style field for the plot style you want to change.

4 Select an option from the drop-down list.

Command entry: STYLESMANAGER

Quick Reference

Commands

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Assign Plotted Fill Styles
You can assign a variety of fill style options when plotting wide polylines,
donuts, objects hatched with a solid fill, and solids.

The program includes the following fill style options when plotting wide
polylines, donuts, objects hatched with a solid fill, and solids:

■ Solid

■ Checkerboard

■ Crosshatch

■ Diamonds

■ Horizontal Bars

■ Slant Left

■ Slant Right

■ Square

■ Dots

■ Vertical Bar

The default setting for Fill Style is Use Object Fill Style. Assign a fill style in a
plot style to override the object's fill style at plot time.

You can apply a global scale factor to non-ISO linetypes and fill patterns in
plot styles.

See also:

■ Choose Hatch Patterns and Solid Fills on page 1449
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To assign a fill style

1 Click Output tab ➤ Plot panel ➤ Plot Style Manager. 

2 Right-click a CTB or STB file. Click Open.

3 In the Plot Style Table Editor, Table View tab, click the Fill Style field for
the plot style you want to change.

4 Select a fill style from the drop-down list.

Command entry: STYLESMANAGER

Quick Reference

Commands

STYLESMANAGER

Displays the Plot Style Manager, where you can revise plot style tables.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Preview a Plot
It is good practice to generate a preview of the plotted drawing before sending
the drawing to the printer or plotter. Generating a preview saves time and
material.

You can preview the drawing from the Plot dialog box. The preview shows
exactly how the drawing will look when plotted, including lineweights, fill
patterns, and other plot style options.
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When you preview your drawing, the active toolbars and tool palettes are
hidden and a temporary Preview toolbar is displayed that provides buttons
to plot, pan, and zoom the drawing.

In the Plot and Page Setup dialog boxes, a thumbnail preview is also displayed,
which shows the printable area and the position of the drawing on the page.

To preview a plot

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, click Preview.

A preview window opens, and the cursor changes to the real-time zoom
cursor.

3 Right-click to display a shortcut menu with the following options: Plot,
Pan, Zoom, Zoom Window, or Zoom Original (to zoom to the original
preview magnification).

4 Press ESC to exit the preview and return to the Plot dialog box.

5 If necessary, make additional adjustments to the plot settings and preview
the plotted drawing again.
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6 Once the settings are correct, click OK to plot the drawing.

Toolbar: Standard  
Command entry: PLOT

Quick Reference

Commands

PAN

Moves the view in the current viewport.

PLOT

Plots a drawing to a plotter, printer, or file.

PREVIEW

Displays the drawing as it will be plotted.

ZOOM

Increases or decreases the magnification of the view in the current viewport.

System Variables

RASTERPREVIEW

Controls whether BMP preview images are saved with the drawing.

Utilities

No entries

Command Modifiers

No entries

Plot Files to Other Formats
You can export or plot your drawings in a number of formats, including DWF,
DWFx, DXF, PDF, and Windows metafile (WMF). You can also output your
drawings in image formats using specially designed plotter drivers.
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In each case, a nonsystem plotter driver is configured to output file
information. You can control the custom properties of each nonsystem driver
in the Plotter Configuration Editor. Specific help for each driver is also available
by choosing Help while in the custom Properties dialog box for the individual
driver (accessed through the Plotter Configuration Editor).

Plot DWF Files
You can create DWF files (a 2D vector file) to publish your drawings on the
web or across an intranet.

You can use the program to create DWF files. A DWF file is a 2D vector file
that you can use to publish your drawing on the World Wide Web or an
intranet network. Each DWF file can contain one or more drawing sheets.

DWF files can be opened, viewed, and plotted by anyone using Autodesk®

Design Review. With the DWF file viewer, you can also view DWF files in
Microsoft® Internet Explorer 5.01 or later. DWF files support real-time panning
and zooming as well as control over the display of layers and named views.

See also:

■ Publish Drawings on page 1865

■ Review and Markup Files with Design Review

To plot a DWF file

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Printer/Plotter, in the Name box, select the
DWF6 ePlot.pc3 configuration from the Name list.

3 Select plot settings for the DWF file as needed.

4 Click OK

5 In the Browse for Plot File dialog box, select a location and enter a file
name for the DWF file.

6 Click Save.
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Toolbar: Standard  
Command entry: PLOT

Quick Reference

Commands

PLOT

Plots a drawing to a plotter, printer, or file.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Plot DWFx Files
You can create DWFx files (DWF and XPS) to publish your drawings on the
web or across an intranet.

You can use the DWFx ePlot (XPS Compatible) plot configuration file to plot
to a DWFx file. Each DWFx file can contain one or more drawing sheets.

DWFx files can be opened, viewed, and plotted by anyone using the following
applications:

■ With Internet Explorer, you can view and print the 2D geometry of DWFx
files.

■ With Autodesk Design Review, you can view the complete DWFx file;
zoom and pan within the DWF file; turn layers on and off; and mark up
the drawings.

See also:

■ Publish Drawings on page 1865
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■ Review and Markup Files with Design Review

To plot a DWFx file

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Printer/plotter group, click the Name drop-down list, and select
the DWFx ePlot (XPS Compatible).pc3 configuration from the Name list.

3 Select plot settings for the DWFx file as needed.

4 Click OK.

5 In the Browse for Plot File dialog box, select a location and enter a file
name for the DWFx file.

6 Click Save.

Toolbar: Standard 
Command entry: PLOT

Quick Reference

Commands

PLOT

Plots a drawing to a plotter, printer, or file.

Plot to DXB File Formats
DXB (drawing interchange binary) file formats are supported using the DXB
non-system file driver. This is commonly used to “flatten” 3D drawings to
2D.

The output is compatible with the DXBIN command and with the ADI DXB
driver delivered with earlier releases. The DXB driver shares these limitations
of the ADI driver:

■ The driver produces 16-bit integer DXB files containing only vectors.

■ DXB output is monochrome; all vectors are color 7.
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■ Raster images and embedded OLE objects are not supported.

■ The driver ignores object and plot style lineweights.

See also:

■ “Configure for File Output” in the Driver and Peripheral Guide

To create a DXB file

1 Make sure you have configured a plotter driver for DXB file output. (See
Configure for File Output in the Driver and Peripheral Guide.)

2 Click Output tab ➤ Plot panel ➤ Plot. 

3 In the Plot dialog box, under Printer/Plotter, in the Name box, select a
DXB format configuration from the list.

4 Select plot settings for the DXB file as needed.

5 Click OK.

6 In the Browse for Plot File dialog box, select a location and enter a file
name for the DXB file.

7 Click Save.

Toolbar: Standard  
Command entry: PLOT

Quick Reference

Commands

PLOT

Plots a drawing to a plotter, printer, or file.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Plot to Raster File Formats
The nonsystem raster driver supports several raster file formats, including
Windows BMP, CALS, TIFF, PNG, TGA, PCX, and JPEG. The raster driver is
most commonly used to plot to files for desktop publishing.

All but one of the formats supported by this driver produce “dimensionless”
raster files that have size in pixels but do not have size in inches or millimeters.
The Dimensional CALS format is for plotters that can accept CALS files. If
your plotter accepts CALS files, you must specify a real paper size and
resolution. Specify the resolution in dots per inch in the Vector Graphics pane
of the Plotter Configuration Editor.

By default, the raster driver plots only to files. However, you can select Show
All Ports on the Ports page of the Add-a-Plotter wizard or the Ports tab in the
Plotter Configuration Editor; all of the ports on your computer are then
available for configuration. When configured for plotting to a port, this driver
plots to a file and then copies that file to the specified port. To plot successfully,
make sure that the device connected to the configured port can accept and
process the file. For more information, refer to the documentation provided
by the device manufacturer.

The type, size, and color depth of the raster file determine the final file size.
Raster files can grow very large. Use only the pixel dimensions and color depth
that you need.

You can configure the background color for raster plots in the custom
Properties dialog box in the Plotter Configuration Editor. If you change the
background color, any objects plotted in that color are invisible.

See also:

■ “Configure for File Output” in the Driver and Peripheral Guide
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To create a raster file

1 Make sure you have configured a plotter driver for raster file output. (See
Configure for File Output in the Driver and Peripheral Guide.)

2 Click Output tab ➤ Plot panel ➤ Plot. 

3 In the Plot dialog box, under Printer/Plotter, in the Name box, select a
raster format configuration from the list.

4 Select plot settings for the raster file as needed.

5 Click OK.

6 In the Browse for Plot File dialog box, select a location and enter a file
name for the raster file.

7 Click Save.

Toolbar: Standard  
Command entry: PLOT

Quick Reference

Commands

BMPOUT

Saves selected objects to a file in device-independent bitmap format.

JPGOUT

Saves selected objects to a file in JPEG file format.

PLOT

Plots a drawing to a plotter, printer, or file.

PNGOUT

Saves selected objects to a file in a Portable Network Graphics format.

TIFOUT

Saves selected objects to a file in TIFF file format.
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System Variables

RASTERDPI

Controls paper size and plot scaling when changing from dimensional to
dimensionless output devices, or vice versa.

Utilities

No entries

Command Modifiers

No entries

Plot Adobe PDF Files
Using the DWG to PDF driver, you can create Adobe® Portable Document
Format (PDF) files from drawings.

The Adobe® Portable Document Format (PDF) is a standard for electronic
information exchange. PDF files can be easily distributed for viewing and
printing in the Adobe Reader available from the Adobe web site without cost.
Using PDF files, you can share drawings with virtually anyone.

Like DWF6 files, PDF files are generated in a vector-based format, for
maintaining precision. Drawings that are converted to PDF can be easily
distributed for viewing and printing in Adobe Reader, versions 7 or later.

Use the custom Properties dialog box in the Plotter Configuration Editor to
customize the output. To display this dialog box, on the Device and Document
Settings tab, in the tree view, select Custom Properties. Then under Access
Custom Dialog, click the Custom Properties button.

You can customize the PDF output by specifying resolution. In the Custom
Properties dialog box in the Plotter Configuration Editor, you can specify the
resolution for vector and raster images ranging from 150 dpi to a maximum
of 4800 dpi. You can also specify custom resolutions for vector, gradient, color,
and black and white output.

NOTE Although transparent objects and wipeouts are displayed correctly in the
PDF viewer, they may not print with the same visual fidelity when default print
settings are used. If your drawing contains transparent objects, you may need to
adjust some settings in Adobe Acrobat. Set Transparency Flattening to "Print as
Image" or reduce the Raster/Vector Balance in Adobe Acrobat. Refer to the Adobe
documentation for more information.
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See also:

■ “Configure for File Output” in the Driver and Peripheral Guide

To plot a PDF file

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Printer/Plotter, in the Name box, select the
DWG to PDF.pc3 configuration from the Name list.

3 Select plot settings for the PDF file as needed.

4 Click OK.

5 In the Browse for Plot File dialog box, select a location and enter a file
name for the PDF file.

6 Click Save.

Toolbar: Standard  
Command entry: PLOT

To plot a PDF file in landscape orientation

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Printer/Plotter, in the Name box, select the
DWG to PDF.pc3 configuration from the Name list.

3 Under Paper Size, select a paper size that has the longer dimension listed
first. For example, ANSI A (11.00 x 8.50 Inches).

4 Click OK.

5 In the Browse for Plot File dialog box, select a location and enter a file
name for the PDF file.

6 Click Save.

Toolbar: Standard  
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Command entry: PLOT

Quick Reference

Commands

PLOT

Plots a drawing to a plotter, printer, or file.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Plot Adobe PostScript Files
Using the Adobe PostScript driver, you can use DWGs with an array of page
layout programs and archive tools such as the Adobe Acrobat Portable
Document Format (PDF).

You can use the non-system PostScript driver to plot drawings to PostScript
printers and PostScript files. Use the PS file format for printers and the EPS
file format for files. If you plot to a hardware port, PS output is automatic. If
you plot to a file and plan to copy the file to a printer, configure for PS output.

Use the custom Properties dialog box in the Plotter Configuration Editor to
customize the output. To display this dialog box, on the Device and Document
Settings tab, in the tree view, select Custom Properties. Then under Access
Custom Dialog, click the Custom Properties button.

The PostScript driver supports three types of PostScript.

■ Level 1: Use for most plotters.

■ Level 1.5: Use for plotters that support color images.

■ Level 2: If your plotter supports Level 2 PostScript, use to produce smaller
files that print more rapidly.
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The Tokenize PostScript Code and Compression options in the PostScript
Custom Properties dialog box reduce output file size and improve printing
speed on devices that support these options. If you have problems printing,
try clearing all the options. If you successfully print with no optimizations,
you can try turning the options on one at a time to determine the options
your printer supports.

Some desktop publishing applications only support Level 1 PostScript. If you
have problems using your EPS files, try a lower PostScript level and turn off
the optimizations just described.

Including a preview thumbnail in your EPS file makes the file substantially
larger but allows quick preview by many applications. The WMF preview is
for Windows; the EPSF preview is for Macintosh and other platforms.

NOTE Including both preview images can triple your file size.

See also:

■ Export PostScript Files

■ “Configure for File Output” in the Driver and Peripheral Guide

To plot a PostScript file

1 Make sure you have configured a plotter driver for PostScript file output.
(See “Configure for File Output” in the Driver and Peripheral Guide.)

2 Click Output tab ➤ Plot panel ➤ Plot. 

3 In the Plot dialog box, under Printer/Plotter, in the Name box, select a
PostScript format configuration.

4 Select plot settings for the PostScript file as needed.

5 Click OK.

6 In the Browse for Plot File dialog box, select a location and enter a file
name for the PostScript file.

7 Click Save.

Toolbar: Standard  
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Command entry: PLOT

Quick Reference

Commands

PLOT

Plots a drawing to a plotter, printer, or file.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create Plot Files
You can use any plotter configuration to create plot files that can be used with
spooling software or given to service bureaus for output.

See also:

■ “Set Device-Specific Configurations” in the Driver and Peripheral Guide

To create a plot (PLT) file

1 Click Output tab ➤ Plot panel ➤ Plot. 

2 In the Plot dialog box, under Printer/Plotter, in the Name box, select a
plotter configuration.

NOTE You must use the correct plotter configuration for the output device
in order to produce a valid PLT file.

3 If the Plot to File option is available and is not selected, select it.
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4 Select plot settings for the plot file as needed.

5 Click OK.

6 In the Browse for Plot File dialog box, select a location and enter a file
name for the plot file.

7 Click Save.

Toolbar: Standard  
Command entry: PLOT

To create a batch file for plot spooling

Plot files are meant to be used with spooling software or to be given to a service
bureau for output. A simple batch file can be used to output PLT files.

1 Open a text editor and save a batch file to a folder where you save your
PLT files.

2 Name the batch file something like MySpooler.bat.

3 Add a single line to the batch file that reads:

copy%1 \\server\printer

The%1 is a parameter that the batch file will replace with the name of
the .plt file being sent to the output device.

TIP If the output device is connected directly to the computer, you can
substitute the print server path with the printer port, such as LPT1.

4 Save the batch file and close the text editor.

To plot a plot (PLT) file from a batch file

This procedure uses the batch file created in To create a batch file for plot
spooling on page 1862.

1 Open a Command Prompt window and change directories to the folder
containing your PLT file and spooling batch file.

2 At the command prompt, enter the following:

MySpooler.bat MyDrawing.plt
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where MySpooler.bat is the name of the batch file you created and
MyDrawing.plt is the name of the plot file.

The PLT file is copied to the output device and the drawing is created.

Quick Reference

Commands

PLOT

Plots a drawing to a plotter, printer, or file.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries
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Publish Drawings

Publishing provides a streamlined alternative to plotting multiple drawings. You can easily
publish an entire sheet set from the Sheet Set Manager as a set of paper drawings or as a single,
electronic, multi-sheet DWF, DWFx, or PDF file.

Publishing an electronic drawing set as a DWF, DWFx, or PDF file saves time and increases
productivity by providing accurate, compressed representations of drawings in a file that's
easy to distribute and view.

Using Autodesk Design Review, you can view and plot DWF and DWFx files. Using Internet
Explorer 7, you can view and print the 2D geometry of a DWFx file.

Overview of Publishing
An electronic drawing set is the digital equivalent of a set of plotted drawings.
You create an electronic drawing set by publishing drawings to a DWF, DWFx,
or PDF file.

You can publish an entire sheet set from the Sheet Set Manager. With one click,
you can create an electronic drawing set by publishing the sheet set to a single,
multi-sheet DWF, DWFx, or PDF file.

You can create a paper drawing set by publishing the sheet set to the plotter
named in each sheet's page setup.

Using the Publish dialog box, you can assemble a collection of drawings to
publish and save the list as a Drawing Set Descriptions (DSD) file. You can
customize this collection of drawings for a specific user, and you can add and
remove sheets as a project evolves. Once you've created a list of drawing sheets
in the Publish dialog box, you can publish the drawings to any of the following:

■ The plotter named in each sheet's page setup (including drawings that you
want to plot to file)
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■ A single, multi-sheet DWF or DWFx file containing both 2D and 3D content

■ A single, multi-sheet PDF file containing 2D content

■ Multiple single-sheet DWF or DWFx files containing both 2D and 3D
content

■ Multiple single-sheet PDF files containing 2D content

Using 3D DWF publishing, you can create and publish DWF files of your
three-dimensional models and view them with Autodesk Design Review.

For more on publishing 3D DWF files, refer to 3D DWF Publishing on page
1908.

Publishing for Autodesk Design Review

Publishing an electronic drawing set as a DWF or DWFx file saves time and
increases productivity by providing accurate, compressed representations of
drawings in a file that is easy to distribute and view. This also maintains the
integrity of your original drawings.

DWF files, when published, are created in a vector-based format (except for
inserted raster image content), ensuring that precision is maintained.

DWFx files are created using Microsoft’s XPS format. DWFx files are ZIP files
and contain metadata. This metadata can be viewed only by Autodesk Design
Review.

You can view and print general graphics in Autodesk Design Review or in
Internet Explorer 7. Rich DWFx metadata can only be viewed in Autodesk
Design Review.

You can view or plot DWF or DWFx files using Autodesk Design Review. DWF
or DWFx files can be distributed using e-mail, FTP sites, project websites, or
CDs.

You can specify which block-related properties and attributes you want to
make available to Autodesk Design Review users. For example, you can publish
a DWF file or DWFx file for a plumbing contractor that contains block attribute
information about the plumbing fixtures specified in your drawing data. And,
from the same set of sheets, you can include only the block attribute data
about light fixtures for an electrical contractor.

By default, jobs that are published are processed in the background, so that
you can return immediately to your drawing. Only one job that you have
published can be processed in the background at a time. While a job is being
processed in the background, you can check its status by placing the cursor
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over the plotter icon on the right side of the status bar. You can also view
details about all completed jobs that you have plotted or published from the
current session.

See also:

■ Publish, Transmit, and Archive Sheet Sets on page 510

■ Specify Page Setup Settings on page 1748

■ Publish 3D DWF Files on page 1908

■ Review and Markup Files with Design Review

To check the status of a published job that is being processed in the
background

■ Place the cursor over the plotter icon in the status tray. A tooltip displays
the status of the job.

To cancel part or all of a published job that is processing in the background

■ Right-click the plotter icon in the status tray. Click Cancel Sheet
<sheetname> or Cancel Entire Job.

To view details about jobs you have published

1 Do one of the following:

■ Click Output tab ➤ Plot panel ➤ View Details. 

■ In the status tray, click the plotter icon.

2 In the Plot and Publish Details dialog box, view details about published
jobs.

Command entry: VIEWPLOTDETAILS
Shortcut menu: In the status tray, right-click the plotter icon. Click View
Plot and Publish Details.

To turn background publishing on or off using the options dialog box

1 Click Tools menu  ➤ Options.
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2 In the Options dialog box, Plot and Publish tab, under Background
Processing Options, select or clear the Enable Background Plot When
Publishing option.

3 Click OK.

Command entry: OPTIONS

To turn background publishing on or off using the publish dialog box

1 Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish Controls group, select or clear Publish in background.

Command entry: PUBLISH

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PUBLISH

Publishes drawings to DWF, DWFx, and PDF files, or to plotters.

System Variables

BACKGROUNDPLOT

Controls whether background plotting is turned on or off for plotting and
publishing.

PUBLISHCOLLATE

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.
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Utilities

No entries

Command Modifiers

No entries

Create and Modify a Drawing Set for Publishing
You can assemble a collection of drawing sheets to publish to a plotter, plot
files, DWF, DWFx, or PDF file. You can customize your drawing set for a
specific user, and you can add, remove, reorder, copy, and rename sheets in
a drawing set as a project evolves.

You can publish the drawing set directly to paper and single or multiple DWF,
DWFx, or PDF files. DWF, DWFx, and PDF files can be distributed using e-mail,
FTP sites, project websites, or CD. You can save a description of a drawing set
that has been assembled to publish in a Drawing Set Descriptions (DSD) file.

To create a drawing set for publishing

1 Open a drawing. Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box is displayed. If the Include Layouts When Adding
Sheets option is selected, either in the shortcut menu or in the Publish
dialog box, all the layouts in the current drawing are listed in the sheetlist.

2 In the Publish dialog box, you can modify the list of sheets by doing any
of the following as needed:

■ Add sheets. To add sheets from other drawings, click the Add Sheets
button (or drag drawings from the desktop). In the Select Drawings
dialog box, select drawings. Click Select to add them to the list of
sheets in the Publish dialog box. All of the layouts in a drawing become
individual sheets in the list of drawing sheets. You can remove the
individual sheets if you do not want them to become part of the
drawing set. A layout must be initialized (its paper size must be defined
in the page setup to any size other than 0 x 0) before it can be
published.
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NOTE To include all layouts when you add sheets to a drawing set, ensure
the Include Layouts When Adding Sheets option is selected either in the
shortcut menu or in the Publish dialog box.

■ Include model layouts. If you include an uninitialized (the paper size
is not defined in the page setup or is set to 0 x 0) model layout, it will
be marked as Uninitialized in the Status column on the sheet list. It
can be plotted if you select an override page setup for it in the Publish
dialog box from the page setup drop-down list under Page Setups in
the sheet list.

NOTE To include the model when you add sheets to a drawing set, ensure
the Include Model When Adding Sheets option is selected either in the
shortcut menu or in the Publish dialog box.

■ Remove sheets. To remove sheets from the list, select one or more
sheets in the list. Click the Remove Sheets button. To remove all
sheets, right-click the selection. Click Remove All.

■ Reorder sheets. To reorder the sheets up or down one position in the
list, select a sheet. Click either the Move Sheet Up or Move Sheet
Down button. Sheets in the drawing set are viewed or plotted in the
order shown in the list.

■ Rename sheets. To rename a sheet, select it in the list and right-click.
Click Rename Sheet. Enter the new sheet name.

■ Change page setups. To change the page setup for a layout, select the
sheet, and in the Page Setup list select a named page setup from the
list; or select one or more sheets and right-click. Click Change Page
Setup. In the Page Setup list, select a page setup, or select Import to
import page setups from another drawing or template. In the Import
Page Setups dialog box, select a drawing with one or more page setups.
Click Import. In the Page Setup list, select a named page setup.

NOTE Change the page setup for each layout depending on your desired
output. Model space page setups can only be applied to model space sheets;
paper space page setups can only be applied to paper space sheets.

■ Copy sheets. To copy one or more drawing sheets, select the sheets
in the list and right-click. Click Copy Selected Sheets. The copied
drawing sheets are added and highlighted at the end of the sheet list.
When a sheet is copied, its name is created by the addition of -Copy(n)
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at the end of the original sheet name. For example, if you create one
copy of a sheet called Plumbing, the copied sheet is called
Plumbing-Copy(1). Each time you copy the same sheet, the n is
incremented by 1. By creating copies of a sheet, you can have different
page setups and other settings for the same sheet.

3 When your list of drawing sheets is assembled and configured the way
you want for your drawing set, click the Save List button.

4 In the Save List As dialog box, in the File Name box, enter a name for the
list. Click Save.

The drawing set list is saved as a DSD (Drawing Set Descriptions) file.

Toolbar: Standard  
Command entry: PUBLISH

To add sheets from a drawing to a drawing set for publishing

1 Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish dialog box, click the Add Sheets button.

3 In the Select Drawings dialog box, select drawings. Click Select to add
them to the list of sheets in the Publish dialog box.

NOTE You can also drag drawings from the desktop into the Publish dialog
box to add sheets to the list.

All of the layouts in a drawing become individual sheets in the list of
drawing sheets.

You must remove the drawing sheets that you don't want to become a
part of the drawing set. Layouts must be initialized before they can be
published. (A layout is initialized if its paper size is defined in the page
setup to any size other than 0 x 0.)

Toolbar: Standard  
Command entry: PUBLISH
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To add sheets from a DSD file to a drawing set for publishing

1 Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish dialog box, click the Load Sheet List button.

3 In the Load List of Sheets dialog box, select a DSD file. Click Load.

4 In the Replace or Append dialog box, click Replace to replace the current
sheets with the sheets in the DSD file, or click Append to add the sheets
in the DSD file to the list of sheets in the Publish dialog box.

Toolbar: Standard  
Command entry: PUBLISH

To remove a sheet from a drawing set for publishing

1 Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish dialog box, ensure the sheets that you want to remove are
listed.

3 Under Sheets, select one or more sheets to remove. Click the Remove
Sheets button.

Toolbar: Standard  
Command entry: PUBLISH

To remove all sheets from a drawing set for publishing

1 Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish dialog box, ensure the sheets that you want to remove are
listed.

3 Right-click the selection. Click Remove All.

NOTE Removing all sheets cannot be undone.
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Toolbar: Standard  
Command entry: PUBLISH

To reorder sheets in a drawing set for publishing

1 Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish dialog box, ensure the sheets that you want to reorder are
listed.

3 Select a sheet. Click the Move Sheet Up or Move Sheet Down button.

NOTE Sheets in the drawing set are viewed or plotted in the order shown
in the Publish dialog box.

Toolbar: Standard  
Command entry: PUBLISH

To copy sheets in a drawing set for publishing

1 Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish dialog box, ensure the sheets that you want to copy are
listed.

3 Right-click the selection. Click Copy Selected Sheets.

The copied drawing sheets are added and highlighted at the end of the
sheet list. When a sheet is copied, its name is created by the addition of
-copy(n) at the end of the original sheet name.

For example, if you create one copy of a sheet called Plumbing, the copied
sheet is called Plumbing-Copy(1).

Each time you copy the same sheet, the n is incremented by 1. By creating
copies of a sheet, you can have different page setups and other settings
for the same sheet.
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Toolbar: Standard  
Command entry: PUBLISH

To rename sheets in a drawing set for publishing

1 Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish dialog box, ensure the sheets that you want to rename are
listed.

3 Select a sheet in the Sheet list, and then do one of the following:

■ Right-click the selection. Click Rename Sheet.

■ Press F2.

4 Enter the new sheet name.

Toolbar: Standard  
Command entry: PUBLISH

To change the page setup of one sheet in a drawing set for publishing

1 Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish dialog box, ensure the sheet for which you want to change
the page setup is listed.

3 Select a sheet in the Sheet list.

4 Under Page Setup, select a page setup to apply to the drawing sheet.

Toolbar: Standard  
Command entry: PUBLISH
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To change the page setup of one or more sheets in a drawing set for
publishing

1 Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish dialog box, ensure the sheets for which you want to change
the page setups are listed.

3 Select one or more sheets in the list.

4 Right-click the selection. Click Change Page Setup.

5 In the Page Setup list, select a page setup to apply to the drawing sheets.

NOTE Change the page setup for each layout depending on your desired
output. Model space page setups can only be applied to model space sheets;
paper space page setups can only be applied to paper space sheets.

Toolbar: Standard  
Command entry: PUBLISH

To import a page setup from another drawing to apply to a drawing sheet
for publishing

1 Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish dialog box, ensure the sheet for which you want to change
the page setup is listed.

3 Select a sheet in the Sheet list.

4 Under Page Setup, select Import from the list.

5 In the Import Page Setups dialog box, select the drawing whose page
setups you want to import. Click Import.

Toolbar: Standard  
Command entry: PUBLISH
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To publish multiple layouts in a drawing

1 In the drawing area, click a layout tab that you want to publish.

2 Press and hold the CTRL key, and then click the other layout tabs that
you want to publish.

3 Right-click one of the selected layout tabs. Click Publish Selected Layouts.

4 In the Publish dialog box, change any settings for the selected layouts.

5 Click Publish.

Command entry: PUBLISH

Quick Reference

Commands

PUBLISH

Publishes drawings to DWF, DWFx, and PDF files, or to plotters.

System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Create a Paper or Plot File Drawing Set
You can publish a drawing set to a plotter or plot file.

You can assemble drawing sheets into a customized drawing set and publish
the sheets to the plotter named in the page setup specified for each sheet. If
the plot device named in the page setup is a paper plotter, then your output
will be a paper drawing set.

If the plotter is configured to plot to a file, the sheets are saved to files in the
plot file location specified in the Publish Options dialog box. Each drawing
sheet's plot file is saved with the same name as the sheet, with the appropriate
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file extension for the file (for example, .plt, .jpg, or .bmp). The default location
can be changed in the Options dialog box, Plot and Publish tab, under Plot
to File.

See also:

■ Set Publish Options on page 1899

To create and publish a paper or plot file drawing set

1 Open a drawing. Click Output tab ➤ Publish panel ➤ Publish. 

2 In the Publish dialog box, the drawing layouts are shown in the Sheets
List. To create the drawing set, modify the list of drawing sheets by doing
any of the following as needed:

■ Add sheets. To add sheets from other drawings, click the Add Sheets
button (or drag drawings from the desktop). In the Select Drawings
dialog box, select drawings. Click Select to add them to the list of
sheets in the Publish dialog box. All of the layouts in a drawing become
individual sheets in the list of drawing sheets. You can remove the
individual sheets if you do not want them to become part of the
drawing set. A layout must be initialized (its paper size must be defined
in the page setup to any size other than 0 x 0) before it can be
published.

NOTE To include all layouts when you add sheets to a drawing set, ensure
the Include Layouts When Adding Sheets option is selected on the shortcut
menu or in the Publish dialog box.

■ Include model layouts. If an uninitialized (the paper size is not defined
in the page setup or is set to 0 x 0) model layout is included, it will
be marked as Uninitialized in the Status column on the sheet list. It
can be plotted if a page setup override is applied.

NOTE To include the Model when you add sheets to a drawing set, ensure
the Include Model When Adding Sheets option on the shortcut menu is
selected.

■ Remove sheets. To remove sheets from the list, select one or more
sheets in the list. Click the Remove Sheets button. To remove all
sheets, right-click. Click Remove All.
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■ Reorder sheets. To reorder the sheets up or down one position in the
list, select a sheet. Click either the Move Sheet Up or Move Sheet
Down button. Sheets in the drawing set are viewed or plotted in the
order shown in the list.

■ Rename sheets. To rename a sheet, select it in the list and right-click,
Click Rename Sheet. Enter the new sheet name.

■ Change page setups. To change the page setup for a layout, select the
sheet. In the Page Setup list, select a named page setup from the list,
or select one or more sheets in the list and right-click. Click Change
Page Setup. In the Page Setup list, select a page setup or select Import
to import page setups from another drawing or template. In the Import
Page Setups dialog box, select a drawing with one or more page setups.
Click Import. In the Page Setup list, select a named page setup.

NOTE Change the page setup for each layout depending on your desired
output. Model space page setups can only be applied to model space sheets;
paper space page setups can only be applied to paper space sheets.

■ Copy sheets. To copy one or more drawing sheets, select the sheets
in the list and right-click. Click Copy Selected Sheets. The copied
drawing sheets are added and highlighted at the end of the sheet list.
When a sheet is copied, its name is created by the addition of -Copy(n)
at the end of the original sheet name. For example, if you create one
copy of a sheet called Plumbing, the copied sheet is called
Plumbing-Copy(1). Each time you copy the same sheet, the n is
incremented by 1. By creating copies of a sheet, you can have different
page setups and other settings for the same sheet.

3 When your list of drawing sheets is assembled and configured the way
you want for your paper or plot file drawing set, click the Save Sheet List
button.

4 In the Save List As dialog box, in the File Name box, enter a name for the
drawing set list. Click Save.

The drawing set list is saved as a DSD (Drawing Set Descriptions) file.

5 In the Publish dialog box, under Publish To, select Plotter Named in Page
Setup.

6 Click Publish to start the process.
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If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in
progress: paper drawings are being plotted or plot files are being created.

7 To view information about the processed publish job, right-click the
plotter icon on the right side of the status bar. Click View Plot and Publish
Details.

Toolbar: Standard  
Command entry: PUBLISH

To publish multiple layouts

1 Hold the Shift key down and click to select the layout tabs.

2 Right click and select Publish Selected Layouts.

3 In the Publish dialog box, select Plotter, PDF, DWF, or DWFx from the
Publish To: drop-down list and click Publish.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

PLOTTERMANAGER

Displays the Plotter Manager, where you can add or edit a plotter
configuration.

PUBLISH

Publishes drawings to DWF, DWFx, and PDF files, or to plotters.
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System Variables

PUBLISHCOLLATE

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

Utilities

No entries

Command Modifiers

No entries

Publish an Electronic Drawing Set
You can publish an electronic drawing set as a DWF, DWFx, or PDF file.

You can assemble drawing sheets into a customized electronic drawing set.
An electronic drawing set is the digital equivalent of a set of plotted drawings.
This enables you to share your work with customers, suppliers, or people
within your own company who may need the drawings for review or for their
records.

An electronic drawing set can be saved as

■ A single, multi-sheet DWF, DWFx, or PDF file

■ Multiple, single-sheet DWF or DWFx, or PDF files

You can also send the published electronic drawing set as an e-mail attachment,
share it using a project collaboration site such as Autodesk Buzzsaw, or post
it to a website. Using Autodesk Design Review, you can view or plot only the
layouts you need.

You can use the default plotter driver as installed, or you can modify
configuration settings such as color depth, display resolution, file compression,
font handling, and other options. Once you modify the original plotter
configuration file, all future plotting and publishing of DWF, DWFx, or PDF
files will be affected.

IMPORTANT Create a copy of the original plotter configuration file before you
make any changes.
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See also:

■ Set Publish Options on page 1899

■ Review and Markup Files with Design Review

To create a DWF, DWFx, or PDF file using publish

1 Open a drawing. Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box is displayed. If the Include Layouts When Adding
Sheets option is selected either in the shortcut menu or in the Publish
dialog box, all the layouts in the current drawing are listed in the sheet
list.

2 In the Publish dialog box, you can modify the list of sheets by doing any
of the following as needed:

■ Add sheets. To add sheets from other drawings, click the Add Sheets
button (or drag drawings from the desktop). In the Select Drawings
dialog box, select drawings. Click Select to add them to the list of
sheets in the Publish dialog box. All of the layouts in a drawing become
individual sheets in the list of drawing sheets. You must remove those
sheets that you don't want to become a part of the drawing set.

NOTE To include all layouts when you add sheets to a drawing set, select —
Include Layouts When Adding Sheets option in the shortcut menu or Layout
Tab in the Include when adding sheets group.

■ Include model layouts. If you include an uninitialized (the paper size
is not defined in the page setup or is set to 0 x 0) model layout, it will
be marked as Uninitialized in the Status column on the sheet list. It
can be plotted if you select an override page setup for it in the Publish
dialog box from the page setup drop-down list under Page Setups in
the sheet list.

NOTE To include the model space when you add sheets to a drawing set,
select — Include Model When Adding Sheets option in the shortcut menu
or Model Tab in the Include when adding sheets group.

■ Remove sheets. To remove sheets from the list, select one or more
sheets, and then click the Remove Sheets button. To remove all sheets,
right-click. Click Remove All.
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■ Reorder sheets. To reorder the sheets up or down one position in the
list, select a sheet. Click either the Move Sheet Up or Move Sheet
Down button. Sheets in the drawing set are viewed or plotted in the
order shown in the list.

■ Rename sheets. To rename a sheet, select it in the list and right-click.
Click Rename Sheet. Enter the new sheet name.

■ Change page setups. To change the page setup for a layout, select the
sheet, and in the Page Setup list select a named page setup from the
list; or select one or more sheets and right-click. Click Change Page
Setup. In the Page Setup list, select a page setup, or select Import to
import page setups from another drawing or template. In the Import
Page Setups dialog box, select a drawing with one or more page setups.
Click Import. In the Page Setup list, select a named page setup.

NOTE Change the page setup for each layout depending on your desired
output. Model space page setups can only be applied to model space sheets;
paper space page setups can only be applied to paper space sheets.

■ Copy sheets. To copy one or more drawing sheets, select the sheets
in the list and right-click. Click Copy Selected Sheets. The copied
drawing sheets are added and highlighted at the end of the sheet list.
When a sheet is copied, its name is created by the addition of -Copy(n)
at the end of the original sheet name. For example, if you create one
copy of a sheet called Plumbing, the copied sheet is called
Plumbing-Copy(1). Each time you copy the same sheet, the n is
incremented by 1. By creating copies of a sheet, you can have different
page setups and other settings for the same sheet.

3 When your list of drawing sheets is assembled and configured the way
you want for your drawing set, click the Save Sheet List button.

NOTE Ensure that you have saved your drawing before you click the Save
Sheet List button.

4 In the Save List As dialog box, in the File Name box, enter a name for the
list. Click Save.

The drawing set list is saved as a drawing set descriptions (DSD) file.

5 In the Publish dialog box, under Publish To, click DWF Format, and select
DWF File or DWFx File. Click Publish.

6 In the Specify DWF File dialog box, enter a file name.
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The Files of Type is DWF or DWFx based on the selected DWF format.

7 Click Select to provide the name and destination for the DWF or DWFx
file.

NOTE You can also enter a URL so that the DWF or DWFx file is uploaded to
an FTP or HTTP site.

8 Click Save to start the electronic drawing set creation.

If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in
progress.

9 To view information about the processed publish job, right-click the
plotter icon on the right side of the status bar. Click View Plot and Publish
Details.

The information in the Plot and Publish Details dialog box is also saved
to the plot and Publish log file.

10 If you have the appropriate viewer installed, you can view the DWF or
DWFx file. Right-click the plotter icon on the right side of the status.
Click View DWF File.

Toolbar: Standard  
Command entry: PUBLISH

To create a DWF, DWFx, or PDF file using Windows Explorer

1 Launch Windows Explorer.

2 Select the drawings to publish to DWF or DWFx.

Use Shift or Ctrl + Click to select contiguous or non-contiguous files.

NOTE You can publish only 2D DWF or 2D DWFx files using the shortcut
menu in Windows Explorer.

3 Right-click the selection. Click Publish DWF.

The Specify DWF File dialog box appears in a temporary AutoCAD session.

4 Specify Files of type as either *.dwfx or *.dwf.

5 Type a file name, or select a file.
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AutoCAD publishes the drawing file with the following options:

DWF type = Multi-sheet

Password = Disabled

Layer information = Don’t include

Block information = Don’t include

By default, the DWF/ DWFx/PDF file will be saved to the same location
as the selected drawing file/s.

To create and email a DWF, DWFx, or PDF file using Windows Explorer

1 Launch Windows Explorer.

2 Select the drawings to publish to DWF / DWFx.

Use Shift or Ctrl + Click to select contiguous or non-contiguous files.

NOTE You can publish only 2D DWF or 2D DWFx using the shortcut menu
in Windows Explorer.

3 Right-click the selection. Click Publish DWF and Email.

The Specify DWF File dialog box is displayed in a temporary AutoCAD
session.

4 Specify Files of type as either *.dwfx or *.dwf.

5 Type a file name, or select a file.

The DWF or DWFx file contains the following settings:

DWF type = Multi-sheet

Password = Disabled

Layer information = Don’t include

Block information = Don’t include

6 AutoCAD launches your default mail application with the newly created
DWF or DWFx as an attachment.
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Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PUBLISH

Publishes drawings to DWF, DWFx, and PDF files, or to plotters.

System Variables

PUBLISHCOLLATE

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

PUBLISHHATCH

Controls whether hatch patterns published to DWF or DWFx format are
treated as a single object when they are opened in Autodesk Impression.

Utilities

No entries

Command Modifiers

No entries

Publish a Sheet Set
From the Sheet Set Manager, you can easily publish an entire sheet set, a subset
of a sheet set, or a single sheet. It is quicker to publish a sheet set in the Sheet
Set Manager rather than using the Publish dialog box.

When you publish from the Sheet Set Manager, you can publish an electronic
sheet set by publishing to a DWF, DWFx, or PDF file, or you can publish a
paper set by publishing to the plotter named in the page setup that is associated
with each drawing sheet. You can also publish your sheets using a page setup
that is saved in the page setup overrides DWT file associated with the sheet
set. This page setup overrides the current page setup settings for the individual
publish job.
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When you open the Publish dialog box from the Sheet Set Manager, the Publish
dialog box automatically lists the sheets you selected in the sheet set. You can
then modify the sheet set for publishing.

NOTE You can specify that sheets are sent to the plotter in reverse order. This
option is available from the Publish dialog box and from the Sheet Set Manager.

See also:

■ Use Named Page Setups with Sheet Sets on page 1780

■ Work with Sheets in a Sheet Set on page 479

■ Set Publish Options on page 1899

To publish a sheet set to a DWF file

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 

2 In the Sheet Set Manager, under Sheets, select a sheet set, subset, or sheet.

3 In the upper-right corner of the Sheet Set Manager, click the Publish
button.

NOTE Sheet sets cannot contain 3D DWF (or 3D DWFx) entries.

4 Click Publish to DWF from the flyout menu.

If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in
progress. Right-click this icon for options to view the DWF file or to view
information about the publish job.

TIP Publishing performance can be improved by disabling background
publishing. Ensure that background publishing is not selected in the Plot and
Publish tab (Tools  ➤  Options), and in the Publish Controls group.

Toolbar: Standard  
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Command entry: SHEETSET
Shortcut menu: Right-click a sheet set, subset, or sheet. Click Publish
menu ➤ Publish To DWF.

To publish a sheet set to a DWFx file

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 

2 In the Sheet Set Manager, under Sheets, select a sheet set, subset, or sheet.

3 In the upper-right corner of the Sheet Set Manager, click the Publish
button.

NOTE Sheet sets cannot contain 3D DWF (or 3D DWFx) entries.

4 Click Publish to DWFx from the flyout menu.

If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in
progress. Right-click this icon for options to view the DWF file or to view
information about the publish job.

TIP Publishing performance can be improved by disabling background
publishing. Ensure that background publishing is not selected in the Plot and
Publish tab (Tools  ➤  Options), and in the Publish Controls group.

Toolbar: Standard  
Command entry: SHEETSET

Shortcut menu: Right-click a sheet set, subset, or sheet. Click Publish
menu ➤ Publish To DWFx.

To publish a sheetset to a PDF file

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 
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2 In the Sheet Set Manager, right-click a sheet set, subset, or sheet. Click

Publish  ➤ Manage Page Setups. 

3 In the Page Setup Manager dialog box, click New.

4 In the New Page Setup dialog box, under New Page Setup Name, enter a
name for the PDF page setup. Click OK.

5 In the Page Setup dialog box, under Printer/Plotter, select the DWG to
PDF.pc3 configuration file.

If the Paper Size Not Found dialog box displays, choose the paper size
option for the sheet set.

6 In the Page Setup dialog box, set the desired page setup options. Click
OK.

7 In the Page Setup Manager, click Close.

8 In the Sheet Set Manager, right-click the sheet set to publish. Click
Publish  ➤ Publish Using Page Setup Override. Click the page setup you
created.

The PDF file is plotted to the directory listed in the Plot and Publish
Details (VIEWPLOTDETAILS) dialog box.

TIP Publishing performance can be improved by disabling background
publishing. Background publishing can be disabled by clearing the Publish
in background check box (Publish Controls group) in the Publish dialog box.

Toolbar: Standard  
Command entry: SHEETSET

To publish a subset of a sheet set or an individual sheet to a DWF file

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 

2 In the Sheet Set Manager, under Sheets, select a sheet set, subset, or sheet.

3 In the upper-right corner of the Sheet Set Manager, click the Publish
button.
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4 Click Publish to DWF from the flyout menu.

NOTE If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in progress.
Right-click this icon for options to view the DWF file or to view information
about the publish job.

Toolbar: Standard  
Command entry: SHEETSET

Shortcut menu: Right-click the sheet set, subset, or sheet. Click Publish  ➤ 

Publish To DWF.

To publish a subset of a sheet set or an individual sheet to a DWFx file

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 

2 In the Sheet Set Manager, under Sheets, select a sheet set, subset, or sheet.

3 In the upper-right corner of the Sheet Set Manager, click the Publish
button.

4 Click Publish to DWFx from the flyout menu.

NOTE If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in progress.
Right-click this icon for options to view the DWFx file or to view information
about the publish job.

Toolbar: Standard  
Command entry: SHEETSET
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Shortcut menu: Right-click the sheet set, subset, or sheet. Click Publish  ➤ 

Publish To DWFx.

To publish a subset of a sheet set or an individual sheet to a PDF file

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 

2 In the Sheet Set Manager, under Sheets, select a sheet set, subset, or sheet.

3 In the upper-right corner of the Sheet Set Manager, click the Publish
button.

4 Click Publish to DWFx from the flyout menu.

NOTE If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in progress.
Right-click this icon for options to view the DWFx file or to view information
about the publish job.

Toolbar: Standard  
Command entry: SHEETSET

Shortcut menu: Right-click the sheet set, subset, or sheet. Click Publish  ➤ 

Publish To DWFx.

To publish sheets in a sheet set to the plotter named in the sheet's page setup

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 

2 In the Sheet Set Manager, under Sheets, select a sheet set, subset, or sheet.

3 In the upper-right corner of the Sheet Set Manager, click the Publish
button. Click Publish To Plotter.
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NOTE If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in progress.
Right-click this icon for options to view the DWF file or to view information
about the publish job.

Toolbar: Standard  
Command entry: SHEETSET

Shortcut menu: Right-click the sheet set, subset, or sheet.Click Publish  ➤ 

Publish To Plotter.

To publish sheets in a sheet set using a page setup from the page setup
overrides file

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 

2 In the Sheet Set Manager, under Sheets, select the sheet set, subset, or
sheet.

3 In the upper-right corner of the Sheet Set Manager, click the Publish
button. Click Publish Using Page Setup Override  ➤  <filename.dwt>. (All
the named page setups that are saved in the page setup override DWT
file are listed.)

The settings in the selected page setup override file take precedence over
(override) the page setup settings currently set for the selected sheets.
The page setup override settings apply only for this individual publish
job.

NOTE If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in progress.
Right-click this icon for options to view the DWF file or to view information
about the publish job.

Toolbar: Standard  
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Command entry: SHEETSET
Shortcut menu: Right-click the sheet set, subset, or sheet. Click Publish  ➤ 

Publish Using Page Setup Override  ➤  <filename.dwt>.

To include a plot stamp on published sheets from a sheet set

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 

2 In the upper-right corner of the Sheet Set Manager, click the Publish
button. Click Include Plot Stamp.

A plot stamp will be included on all published sheets.

NOTE To change the plot stamp settings, click the Publish button. Click Plot
Stamp Settings.

Toolbar: Standard  
Command entry: SHEETSET

Shortcut menu: Right-click the node or name of a sheet set, subset, or an
individual sheet.Click Publish  ➤ Include Plot Stamp.

To publish sheets in a sheet set in reverse order

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 

2 In the Sheet Set Manager, under Sheets, select the name of a sheet set or
a subset.

3 In the upper-right corner of the Sheet Set Manager, click the Publish
button. Click Publish In Reverse Order.

A tick mark against the menu item indicates that when you click Publish,
the sheets will be published in reverse order.
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NOTE This option is not available for DWF files.

Toolbar: Standard  
Command entry: SHEETSET

Shortcut menu: Right-click the node or name of a sheet set, or subset. Click
Publish  ➤ Publish In Reverse Order.

To set options for publishing sheet sets

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 

2 In the upper-right corner of the Sheet Set Manager, click the Publish
button. Click Sheet Set Publish Options.

3 In the Sheet Set Publish Options dialog box, modify the settings as
required.

4 Click OK.

Toolbar: Standard  
Command entry: SHEETSET

Shortcut menu: Right-click the node or name of a sheet set, subset, or an
individual sheet.Click Publish  ➤ Sheet ions.

To modify the sheet set for publishing using the publish dialog box

1 Click View tab  ➤ Palettes panel  ➤  Sheet Set Manager. 

2 In the Sheet Set Manager, under Sheets, select the node or name of a
sheet set, subset, or an individual sheet.

3 In the upper-right corner of the Sheet Set Manager, click the Publish
button. Click Publish Dialog Box.
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The Publish dialog box is displayed and lists the sheets you selected in
the Sheet Set Manager.

4 In the Publish dialog box, modify the sheet list and settings as required.

5 Click Publish to publish the modified sheet set.

NOTE If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in progress.
Right-click this icon for options to view the DWF or DWFx file or to view
information about the publish job.

Toolbar: Standard  
Command entry: SHEETSET

Shortcut menu: Right-click the node or name of a sheet set, subset, or an
individual sheet.Click Publish  ➤ Publish Dialog Box.

Quick Reference

Commands

PAGESETUP

Controls the page layout, plotting device, paper size, and other settings for
each new layout.

PLOT

Plots a drawing to a plotter, printer, or file.

PUBLISH

Publishes drawings to DWF, DWFx, and PDF files, or to plotters.

SHEETSET

Opens the Sheet Set Manager.
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System Variables

PUBLISHCOLLATE

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

Utilities

No entries

Command Modifiers

No entries

Republish a Drawing Set
You can easily republish lists of drawing sheets that you previously saved in
the Drawing Set Descriptions (DSD) file format.

After drawings have been updated, you may want to republish a drawing set
for viewing or plotting. You can easily republish a sheet set (DST file) or a
collection of drawing sheets that you saved as a DSD (Drawing Set Descriptions)
file. You can also load and republish BP3 (Batch Plot) files.

To republish a drawing set

1 Click Output tab ➤ Publish panel ➤ Publish. 

If you have a drawing open, all the layouts in your drawing are shown
in the sheet list in the Publish dialog box. Right-click in the sheet list.
Click Remove All to delete the layouts from the list of drawing sheets.

2 In the Publish dialog box, click the Load Sheet List button.

3 In the Load List of Sheets dialog box, select the location of the DSD file
or the BP3 file. Click Load.

The drawing sheets in the saved drawing set are displayed in the sheet
list in the Publish dialog box.

4 In the Publish to group, do one of the following:

■ To publish to a DWF file —click DWF format, and select DWF File.

■ To publish to a DWFx file — click DWF format, and select DWFx File.
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■ To publish to a PDF file — click PDF format, and select PDF File.

■ To publish to a plotter or printer — click Plotter Named in Page Setup.

5 Click Publish.

If you have background publishing enabled, the animated plotter icon
on the right side of the status bar indicates that the publish job is in
progress.

6 If you have background publishing enabled, you can view information
about the processed publish job. Right-click the plotter icon on the right
side of the status bar. Click View Plot and Publish Details. The information
in the Plot and Publish Details dialog box is also saved to the plot and
publish log file.

Toolbar: Standard  
Command entry: PUBLISH

Quick Reference

Commands

PUBLISH

Publishes drawings to DWF, DWFx, and PDF files, or to plotters.

1896 | Chapter 30   Publish Drawings



System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

View Electronic Drawing Sets with Autodesk Design
Review

A published DWF or DWFx electronic drawing set can be viewed and plotted
with Autodesk Design Review.

A published drawing set is the digital equivalent of paper plots created from
your original drawings. The drawing set, which can be saved as a DWF or
DWFx file, can be viewed or plotted by anyone using Autodesk Design Review.

NOTE For DWFx files, you can view the 2D geometry of a DWFx file using Internet
Explorer 7.

With Autodesk Design Review, you can open, view, and print all DWF or
DWFx file formats and other raster format images. You can pan, zoom, and
view individual drawing sheets and viewports. You can also view layer
information, sheet and sheet set properties, block information and attributes,
and custom properties, if they are included in the DWF or DWFx file. As you
move your cursor across DWF or DWFx geometry in the viewer, objects with
associated data are displayed with a red highlighting effect. For more
information about Autodesk Design Review, see Review and Markup Files with
Design Review.

Recipients of drawing sets in DWF or DWFx format do not have to own or
know the program. From anywhere in the world, they can view and print
high-quality layouts using Autodesk Design Review.

Autodesk Design Review runs as a stand-alone application or embedded in
any application that supports ActiveX controls, such as Microsoft® Internet
Explorer.

For product information and a download link for the Autodesk Design Review,
refer to the Products page on the Autodesk website.
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See also:

■ Review and Markup Files with Design Review

To view a 2D DWFx in Internet Explorer 7

■ Click and drag the DWFx file to the Internet Explorer 7 window.

■ Click OK at the Internet Explorer dialog box.
A new window displays the contents of the DWFx file.

NOTE If you have a pop-up blocker, select “Allow Blocked Content”, and click
Yes when prompted.

To view the most recently published DWF file

■ In the program, right-click the plotter icon on the right side of the status
bar. Click View DWF file.

NOTE This option is available if you have the appropriate viewer installed on your
machine.

The DWF File is displayed in Autodesk Design Review (if installed), or in the
installed DWF Viewer (if you do not have Autodesk Design Review).

To view the most recently published DWFx file

■ In the program, right-click the plotter icon on the right side of the status
bar. Click View DWF file.
This option is available if you have the appropriate viewer installed on
your machine.

The DWFx file is displayed in either of the following applications (if
installed): Autodesk Design Review (by default), or in Internet Explorer 7
(2D DWFx files only).

Quick Reference

Commands

PUBLISH

Publishes drawings to DWF, DWFx, and PDF files, or to plotters.
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System Variables

No entries

Utilities

No entries

Command Modifiers

No entries

Set Publish Options
You can set options for publishing, such as output file location, multi-sheet
name options, file security (password protection), and whether or not to
include layer information. You can also decide what types of information to
reveal in your published DWF, DWFx, and PDF files and whether to publish
drawings automatically.

You can include the following types of metadata:

■ Sheet set properties (must publish using the Sheet Set Manager)

■ Sheet properties (must publish using the Sheet Set Manager)

■ Block standard properties and block custom properties and attributes

■ Properties contained in custom objects

You use a block template (BLK) file to determine which blocks and properties
to include in your published DWF, DWFx, or PDF file. You use the Block
Template dialog box to create or modify the settings of a block template (BLK)
file. You can also use BLK files created with the Attribute Extraction wizard.

When you change settings in the Publish Options dialog box, you can save
the settings to the Drawing Set Descriptions (DSD) file to reuse the next time
you publish drawings.

You can also specify whether a DWF, DWFx, or PDF file is created automatically
when a drawing is saved or closed in the Auto Publish Options Dialog Box.
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To change the default output location for published DWF, DWFx, PDF, and
plot files

1 Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box appears.

2 In the Publish To group, do one of the following:

- Click to select DWF Format; and select DWF File or DWFx File.

- Click to select Plotter Named in Page Setup.

3 Click Publish Options.

The Publish Options dialog box appears.

4 In the Default Output Location (DWF, DWFx, or Plot-to-File), do either
of the following:

■ Click Location and make a selection from the drop-down list.

■ Click the [...] button, and in the Select a Folder for Generated Files
dialog box, select a folder. Click Select.

5 In the Publish Options dialog box, click OK.

Toolbar: Standard  
Command entry: PUBLISH

To specify the file output type to single-sheet or a single multi-sheet DWF,
DWFx, or PDF file

1 Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box appears.

2 Click Publish Options.

The Publish Options dialog box appears.

3 In the General DWF Options pane, under DWF Type, make one of the
following selections:

■ Single-sheet DWF. Specifies that an individual single-sheet DWF or
DWFx file is created for each sheet.

1900 | Chapter 30   Publish Drawings



■ Multi-sheet DWF. Specifies that one multi-sheet DWF or DWFx file is
created.

4 Click OK.

5 In the Publish dialog box, contine with publishing tasks, and then close
the dialog box.

Toolbar: Standard  
Command entry: PUBLISH

To specify a name for multi-sheet DWF DWFx, or PDF file

1 Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box appears.

2 Click Publish Options.

The Publish Options dialog box appears.

3 In the General DWF Options pane, under DWF Type, select Multi-sheet
DWF from the drop-down list.

4 In the Multi-sheet DWF Options pane, under DWF Naming, select Specify
Name from the drop-down list.

5 Click OK.

6 In the Publish dialog box, contine with publishing tasks, and then close
the dialog box.

Toolbar: Standard  
Command entry: PUBLISH

To be prompted for a name for a multi-sheet DWF, DWFx, or PDF file

1 Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box Appears.
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2 Click Publish Options.

The Publish Options dialog box appears.

3 In the General DWF Options pane, under DWF Type, select Multi-sheet
DWF from the drop-down list.

4 In the Multi-sheet DWF Options, select Prompt for Name to be prompted
for a file name every time you publish a DWF file.

5 Click OK.

6 In the Publish dialog box, contine with publishing tasks, and then close
the dialog box.

Toolbar: Standard  
Command entry: PUBLISH

To specify that DWF, DWFx, or PDF files are published with password security

1 Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box appears.

2 Click Publish Options.

The Publish Options dialog box appears.

3 In the General DWF Options pane, under Password Protection, select one
of the following from the drop-down list:

■ Select Specify Password, and under Password, enter a password to use
for the DWF or DWFx file.

■ Select Prompt for Password. You will be prompted for a password or
phrase to open the published DWF or DWFx file.

DWF or DWFx passwords are case-sensitive. The password or phrase can
consist of letters, numbers, punctuation marks, or non-ASCII characters.

IMPORTANT Keep a list of passwords and their corresponding DWF or DWFx
file names in a safe place. If you lose or forget the password, it cannot be
recovered.

4 Click OK.
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5 In the Publish dialog box, contine with publishing tasks, and then close
the dialog box.

Toolbar: Standard  
Command entry: PUBLISH

To include layer information in a published DWF, DWFx, or PDF file

1 Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box appears.

2 Click Publish Options.

The Publish Options dialog box appears.

3 In the DWF Data Options, under Layer Information, click to display the
drop-down list, and select Include.

NOTE By default, Layer Information is set to Don't Include, to reduce
publishing time. If you change the setting to include layer information, you
can turn individual layers on and off when you view or print the DWF file.

4 Click OK.

5 In the Publish dialog box, contine with publishing tasks, and then close
the dialog box.

Toolbar: Standard  
Command entry: PUBLISH

To include block information in a published DWF, DWFx, or PDF file

1 Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box appears.

2 Click Publish Options.

The Publish Options dialog box appears.
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3 In the DWF Data Options pane, under Block Information, click to display
the drop-down list, and select Include.

NOTE By default, Block Information is set to Don't Include. If you change
the setting to include block information, you can use the viewer to view or
print block property and attribute information in the DWF or DWFx file.

4 Click OK.

5 In the Publish dialog box, contine with publishing tasks, and then close
the dialog box.

Toolbar: Standard  
Command entry: PUBLISH

To include block template information in a published DWF, DWFx, or PDF file

NOTE You can use block template (BLK) files created with the Publish Options
dialog box or BLK files created using the Attribute Extraction wizard.

1 Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box appears.

2 Click Publish Options.

The Publish Options dialog box appears.

3 In the DWF Data Options pane, under Block Information, click to display
the drop-down list. Select Include.

4 In the Publish Options dialog box, under DWF Data Options, Block
Template File, click to display the drop-down list. Select the block template
(BLK) file that contains the properties and attribute definitions you want
to make available in your published DWF or DWFx file. Click OK.

NOTE The list also contains the Create and Edit options. Create opens the
Publish Block Template dialog box where you can create a new block template
file. Edit opens the Edit Publish Template dialog box where you can select
an existing block template file to modify.

5 Click OK.
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6 In the Publish dialog box, contine with publishing tasks, and then close
the dialog box.

Toolbar: Standard  
Command entry: PUBLISH

To create a block template (BLK) file

1 Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box appears.

2 Click Publish Options.

The Publish Options dialog box appears.

3 In the DWF Data Options pane, under Block Information, click to display
the drop-down list, and select Include.

4 Under DWF Data Options, Block Template File, click to display the
drop-down list, and select Create.

The Publish Block Template dialog box opens with the Block Source
Drawing area displaying the current drawing.

NOTE The working set of drawings for this list is completely independent of
the drawings to include in the Publish operation.

5 Do one of the following:

■ If this drawing contains the block properties you want to include in
the published DWF or DWFx file, click Scan for Blocks.
The program scans the DWG file for all unique block definitions and
their associated properties and attributes.

■ If this drawing does not contain the block properties you want to
include in the published DWF or DWFx file, click Add.
The Select Drawings dialog box is displayed. Select drawings to add
to the block source drawings list. You can also add and remove
drawings that contain target blocks whose properties you want to
include in the published DWF or DWFx file. Click Scan for Blocks.

The DWG file is scanned for all unique block definitions and their
associated properties and attributes.
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NOTE By default, block settings for nested blocks and blocks in xrefs are
included. If you don't want to include these block settings, click Options
in the Publish Block Template dialog box and clear the related options.

6 In the Publish Block Template dialog box, under Block Data to Publish,
Unique Blocks From Source Drawings, Check Blocks to Publish, select
the block names you want to include in the published DWF or DWFx
files. You can right-click to select or clear all boxes.

7 Under Block Data to Publish, Properties of Selected Blocks, Check
Properties to Publish, select the properties you would like to include in
your published DWF or DWFx files. You can right-click to select or clear
all boxes.

The list displays the union of the properties of all selected blocks.

NOTE If you select a block on the block list and clear the check marks of all
its properties, only the name of the block is published to the resultant DWF
or DWFx file; no property information is included.

8 Click Save to name and save the block template file. Click OK.

The new block template file is now available under DWF Data Options
in the Publish Block Template dialog box.

9 In the Publish dialog box, contine with publishing tasks, and then close
the dialog box.

Toolbar: Standard  
Command entry: PUBLISH

To edit a block template (BLK) file

1 Click Output tab ➤ Publish panel ➤ Publish. 

The Publish dialog box appears.

2 Click Publish Options.

The Publish Options dialog box appears.

3 In the DWF Data Options pane, under Block Information, click to display
the drop-down list, and select Include.
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4 Under DWF Data Options, Block Template File, click to display the
drop-down list, and select Edit.

5 In the Select Block Template dialog box, click the Block Template (BLK)
file you want to edit, and then click Select.

NOTE The working set of drawings for this list is completely independent of
the drawings to include in the Publish operation.

6 In the Publish Block Template dialog box, click Scan for Blocks.

The program scans the DWG files for all unique block definitions and
their associated properties and attributes.

NOTE By default, block settings for nested blocks and blocks in xrefs are
included. If you don't want to include these block settings, click Options in
the Publish Block Template dialog box and clear the related options.

7 Under Block Data to Publish, Unique Blocks From Source Drawings, Check
Blocks to Publish, select or clear the block names you want to include in
the published DWF files.

8 Under Block Data to Publish, Properties of Selected Blocks, Check
Properties to Publish, select or clear the properties you want to include
in your published DWF or DWFx files.

This list displays the union of the properties of all selected blocks.

NOTE If you select a block from the block list and clear the check marks of
all its properties, only the name of the block is published to the resultant DWF
or DWFx file; no property information is included.

9 Click Save. Click OK.

The modified block template file is now available under DWF Data
Options in the Publish Block Template dialog box.

10 In the Publish dialog box, contine with publishing tasks, and then close
the dialog box.

Toolbar: Standard  
Command entry: PUBLISH
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Quick Reference

Commands

AUTOPUBLISH

Publishes drawings to DWF, DWFx, or PDF files automatically to a specified
location.

PUBLISH

Publishes drawings to DWF, DWFx, and PDF files, or to plotters.

System Variables

AUTODWFPUBLISH

Controls whether DWF (Design Web Format) files are created automatically
when you save or close drawing (DWG) files.

PUBLISHCOLLATE

Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file
can be interrupted by other plot jobs.

PUBLISHHATCH

Controls whether hatch patterns published to DWF or DWFx format are
treated as a single object when they are opened in Autodesk Impression.

Utilities

No entries

Command Modifiers

No entries

Publish 3D DWF Files
You can create and publish DWF or DWFx files of your 3D models and view
them with Autodesk Design Review.

You can generate DWF or DWFx files of your 3D models with nearly the same
visual fidelity as your original DWG files. You can create a single or multi-sheet
DWF or DWFx file with 2D and 3D model space objects. To access single sheet
3D DWF publishing, use the 3DDWF, EXPORT. To access multi-sheet
publishing with 2D and 3D model space objects use the PUBLISH command.
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Recipients of 3D DWF or 3D DWFx files can view and print them using
Autodesk Design Review.

For product information and a download link for the Autodesk Design Review,
refer to the Products page on the Autodesk website.

For more information about using the Autodesk Design Review, see the
Autodesk Design Review Help system.

Publish Single and Multiple 3D DWF or 3D DWFx Files

To publish a single 3D DWF or 3D DWFx file, use the EXPORT or 3DDWF
commands. With either of those commands running, the model you are
currently working on is saved as a 3D DWF or 3D DWFx file.

To publish multiple 3D DWF or 3D DWFx files at one time, you use the
PUBLISH command. The Publish dialog box displays a list of all the sheet
names of the drawing files that are currently open. You can determine which
sheets are published to a 3D DWF or 3D DWFx file by adding or removing
sheets on the Sheet Name list.

Publishing Materials

If you assigned texture mapped materials to your models, those materials can
be published with the 3D DWF or 3D DWFx file. Texture map orientation and
scaling that is set in the drawing editor is retained in the published 3D DWF
or 3D DWFx file.

There are some limitations to materials publishing.

■ The Diffuse Map channel is the only mapping that gets published. If you
use Opacity, Reflection, or Bump maps in your material, they do not get
published.

■ Procedural materials such as Wood or Marble do not get published.

NOTE Because the DWF Viewer and the rendering engine are different, you may
encounter some deviation in how the texture maps appear in the DWF Viewer.

Increase the Smoothness of 3D DWF or 3D DWFx Models

The smoothness of 3D DWF or 3D DWFx models is improved by changing
the value of the 3DDWFPREC system variable. The setting for 3DDWFPREC
ranges from 1 to 6. Higher settings greatly improve the appearance of objects
in the DWF Viewer.
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NOTE 3DDWFPREC is a global setting that affects all objects in the 3D model.
Therefore, higher values can result in very large file sizes.

Improve Performance with Large Models

Every object in your model gets processed when a DWF or DWFx file is
published. When working with large models, you can greatly improve
publishing performance by using blocks. For instance, your office model
contains a basic cubicle arrangement of eight partition walls, a desk, and a
chair. Those ten objects do not take much time to process by themselves.
However, if that basic cubicle arrangement is used 100 times, it means that
1000 objects must be processed and the publishing time increases accordingly.
If the basic cubicle arrangement is inserted into the model as a single block,
those ten objects are processed once for each insertion.

You can improve publishing performance even more by grouping
miscellaneous objects into temporary blocks. Once the publishing is complete,
you can explode those blocks and continue working on those objects.

As a design gets closer to completion, you can create blocks comprised of
portions of the model that are less likely to need further editing. If the first
floor of the office model is not going to change much, create a block containing
all of its components. During publishing, that block is processed as one object
instead of each individual object on that floor.

3D DWF or 3D DWFx Unsupported Content
When publishing a 3D DWF or 3D DWFx file, some drawing content may not
appear in the DWF Viewer. The content listed in the following table is not
supported when you output a 3D DWF or 3D DWFx file.

DetailsUnsupported Content

Animations and Walkthroughs

Block attributes

See the “Supported Text Fonts” tableFont types (Various)

Gradient fills (Hatches)

Hidden edges

Hyperlinks
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DetailsUnsupported Content

Images

Layer information

Lights and Shadows

Material components ■ Bump, Opacity, and Specular texture
maps

■ Procedural materials (for example,
wood & marble)

■ Reflection and refraction

■ Self-Illumination

■ Shininess

■ Translucency

Bold and Italic textMtext (partial)

Named views and cameras

OLE objects

Rays and X-lines

Section clipping and XClipping

Text thickness

Visual styles

Supported Text Fonts
Many text fonts are not supported when you publish a 3D DWF or 3D DWFx
file. The following table lists the fonts that are published.

Supported Text Fonts

Arial

Arial Black
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Supported Text Fonts

Comic Sans MS

Courier New

Impact

Lucinda Console

Lucinda Sans Unicode

Martlett

Tahoma

Times New Roman

Verdana

Verdana Italic

Webdings

Wingdings

See also:

■ Review and Markup Files with Design Review

To publish a single 3D DWF file

1 Click Output tab ➤  Export to DWF/PDF panel  ➤  3D DWF. 

2 In the Export Data dialog box, specify a name and location of the DWF
file. Click Save.

By default, all model space objects are published to the 3D DWF file and,
if your drawing contains xrefs, the Group By Xref Hierarchy option is
active.
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3 (Optional) Click Yes to open the Autodesk Design Review and view the
published 3D DWF file.

Toolbar: Standard  
Command entry: 3DDWF

To publish a single 3D DWFx file

1 Click Output tab ➤  Export to DWF/PDF panel  ➤  3D DWF. 

2 In the Export Data dialog box, specify a name and location of the DWFx
file.

3 In the Files of type drop-down list box, click 3D DWFx.

4 Click Save.

By default, all model space objects are published to the 3D DWFx file,
and if your drawing contains xrefs, the Group By Xref Hierarchy option
is active.

5 (Optional) Click Yes to open the Autodesk Design Review and view the
published 3D DWFx file.

Toolbar: Standard  

To export a 3D DWF file

1 Click Output tab ➤  Export to DWF/PDF panel  ➤  3D DWF. 

2 In the Export 3D DWF dialog box, specify the name and location of the
DWF file.

3 If necessary, select 3D DWF (*.dwf) from the Files Of Type list. Click Save.
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By default, all model space objects are exported to the 3D DWF file and
if your drawing contains xrefs, the Group By Xref Hierarchy option is
active.

4 (Optional) Click Yes to open the Autodesk Design Review and view the
published 3D DWF file.

Toolbar: Standard  
Command entry: EXPORT

To export a 3D DWFx file

1 Click Output tab ➤  Export to DWF/PDF panel  ➤  3D DWF. 

2 In the Export Data dialog box, specify the name and location of the DWFx
file.

3 Select 3D DWFx (*.dwfx) from the Files Of Type list. Click Save.

By default, all model space objects are exported to the 3D DWFx file, and
if your drawing contains xrefs, the Group By Xref Hierarchy option is
active.

4 (Optional) Click Yes to open the Autodesk Design Review and view the
published 3D DWFx file.

Toolbar: Standard  
Command entry: EXPORT

To publish multiple 3D or combined 2D and 3D DWF files

1 Click Output tab  ➤  Plot panel  ➤  Batch Plot. 

2 In the Publish dialog box, under Sheets to Publish, select the sheets you
want to publish and set their Page Setup / 3D DWF setting to 3D DWF.
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The sheets that are displayed in the Sheets to Publish group are controlled
by the PUBLISHALLSHEETS system variable.

3 In Publish To group, click to select DWF Format.

4 Select DWF File from the drop-down list.

NOTE The Status of the selected sheet will show, “3D DWF cannot be
published to a “Plotter Named in Paget Setup”, until you change the Publish
to option to DWF Format.

5 Click Publish Options. In General DWF Options, set the DWF Type to
Multi-sheet DWF.

6 Select the Publish Output options.

NOTE The Precision Override setting does not affect models sheets that are
converted to 3D DWF.

7 In 3D DWF options group, click Yes to publish materials. Click OK.

8 Click Publish.

Toolbar: Standard  
Command entry: PUBLISH

To publish multiple 3D or combined 2D and 3D DWFx files

1 Click Output tab  ➤  Plot panel  ➤  Batch Plot. 

2 In the Publish dialog box, under Sheets to Publish, select the sheets you
want to publish and set their Page Setup / 3D DWF setting to 3D DWF.

The sheets that are displayed in the Sheets to Publish group are controlled
by the PUBLISHALLSHEETS system variable.

NOTE The Status of the selected sheet will show, “3D DWF cannot be
published to a “Plotter Named in Paget Setup”, until you change the Publish
to option to DWF Format.
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3 In Publish To group, click to select DWF Format.

4 Select DWFx File from the drop-down list.

5 Click Publish Options. In General DWF Options, set the DWF Type to
Multi-sheet DWF.

6 Select the Publish Output options.

NOTE The Precision Override setting does not affect models sheets that are
converted to 3D DWF.

7 In 3D DWF options group, click Yes to publish materials. Click OK.

8 Click Publish.

Toolbar: Standard  
Command entry: PUBLISH

To publish selected objects in your model to a 3D DWF or 3D DWFx file

1 Click Output tab ➤  Export to DWF/PDF panel  ➤  3D DWF. 

2 In the Export Data dialog box, specify a name and location for the DWF
or DWFx file.

3 Click the Tools button at the upper right.

4 Click Tools menu  ➤ Options.

5 In the 3D DWF Publish dialog box, Objects To Publish, click Selected
Model Space Objects and then click the Select Objects button.

6 In the model, select the objects that you want to publish.

7 Press ENTER or the SPACEBAR when you’re done selecting objects.

8 Click OK.

9 In the Export Data dialog box, click Save.

10 (Optional) Click Yes to open the Autodesk Design Review and view the
published 3D DWF or 3D DWFx file.
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Command entry: EXPORT

To view and print a published 3D DWF file or 3D DWFx file

1 If you want to view a 3D DWF or 3D DWFx file, do either of the following:

■ Immediately after the 3D DWF or 3D DWFx file has been published,
click Yes to the question "Would you like to view it now?"
Autodesk Design Review opens the 3D DWF or 3D DWFx file.

■ In Windows Explorer, double-click the 3D DWF or 3D DWFx file to
open Autodesk Design Review and view the file.

■ Open Autodesk Design Review. Click File menu  ➤ Open. Select the
3D DWF or 3D DWFx file you want to view.

2 If you want to print a 3D DWF or 3D DWFx file, in Autodesk Design
Review, click File menu  ➤  Print.

For more information, see the Autodesk Design Review Help system.

Quick Reference

Commands

3DDWF

Creates a 3D DWF or 3D DWFx file of your 3D model and displays it in the
DWF Viewer.

EXPORT

Saves the objects in a drawing to a different file format.

PUBLISH

Publishes drawings to DWF, DWFx, and PDF files, or to plotters.

System Variables

3DDWFPREC

Controls the precision of 3D DWF or 3D DWFx publishing.

PUBLISHALLSHEETS

Specifies whether to load the contents of the active document or of all open
documents in the Publish dialog box.
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Utilities

No entries

Command Modifiers

No entries

Print 3D Models
You can obtain physical models of 3D models created in AutoCAD.

3D Printing Service Providers

Autodesk has partnered with several 3D printing service providers. They can
ouput physical models from 3D models created in AutoCAD.

When you use the 3DPRINT command, you specify 3D data from a DWG file
that is then translated to a faceted mesh representation consisting of triangles.
This representation is saved as binary STL file that can used by a 3D printing
service provider to create a physical model.

Autodesk 3D Printing Website

To avoid errors and broken parts when you pring 3D models, it is strongly
recommended that you follow guidelines on the Autodesk 3D Printing website.
This website provides information on 3D printing service providers and how
to optimize models for 3D printing.

How to Create and Obtain Physical Models
The following diagram illustrates, from begining to end, the basic steps of
creating and obtaining a physical model:

To ensure successful printing of your 3D
model, you may need to make some adjust-
ments to your drawing.

Prepare your 3D model

You must select the 3D solids you want to
print.

Select the 3D solids you want to print

Only the 3D solids you select are printed,
even if there are others in your drawing.

You must save your drawing as an STL file.Save your drawing as an STL file
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3D printing service providers require that
your drawing be saved in this format.
After you do this, no other dialog boxes
display in AutoCAD as part of the 3D
printing process.

You must select a 3D printing service pro-
vider. When making your decision carefully

Select a service provider

consider cost, materials, and minimum re-
quirements.
For a list of Autodesk-approved 3D printing
service providers, see the Autodesk 3D
Printing website.

After you select a 3D printing service pro-
vider, follow the directions on their website
to obtain your model.

Send the STL file to your service provider

To send a model to a 3D printing service

1 Open the DWG file that contains the 3D model you wish to print.

2 Optimize your model for 3D printing.

3 Click the Output tab  ➤  3D Print panel  ➤  Send to 3D Print Service.

4 In the 3D Printing - Prepare Model for Printing dialog box, click Continue.

5 In the selected DWG file, select the solids or watertight meshes you wish
to print. Press ENTER. In the Send to 3D Print Service Dialog Box, under
Output Preview, selected solids and watertight meshes display.

6 In the Send to 3D Print Service dialog box, under Output Dimensions,
specify output dimensions, including scale and bounding box length,
width, and height. Click OK.

NOTE If you modify output dimensions, the output preview remains
unchanged.

7 Save your prepared drawing as an STL file. The Autodesk 3D Printing Website
displays.

8 Select a 3D printing service provider.
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9 Follow the directions on your service provider’s website to

■ Set up an account

■ Receive a price quote

■ Upload your STL file

■ Order your model

■ Pay for your model

Command entry: 3DPRINT

Quick Reference

Commands

3DPRINT

Sends a 3D model to a 3D printing service.

System Variable

SMOOTHMESHCONVERT

Sets whether mesh objects that you convert to 3D solids or surfaces are
smoothed or faceted, and whether their faces are merged.

Utilities

No entries

Command Modifiers

No entries
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Glossary

Commands associated with definitions are shown in parentheses at the end
of the definition.

3D mesh primitive Basic mesh forms such as boxes, cones, cylinders,
pyramids, wedges, spheres, and tori.

3D view Any view where the UCS icon appears in rendered colored form;
current visual style is not 2D Wireframe, and the model is being viewed from
an isometric view.

absolute coordinates Coordinate values measured from a coordinate system's
origin point. See also origin, relative coordinates, user coordinate system (UCS),
world coordinates, and world coordinate system (WCS).

acquired point In the tracking or object snap tracking methods of locating
a point, an intermediate location used as a reference.

acquisition marker During tracking or object snap tracking, the temporary
plus sign displayed at the location of an acquired point.

action The smallest task or user interaction that can be recorded with the
Action Recorder.

Action bar Toolbar-like UI that displays the actions associated with a parameter
object.

action macro A series of recorded actions that can be played back in the active
drawing.

action macro file A file that stores all the actions contained in an action
macro. Action macro files have the file extension .actm.

Action tree A control used to display the recorded actions in an action macro.

activate Part of the Autodesk software registration process. It allows you to
run a product in compliance with the product's end-user license agreement.

adaptive degradation A method of controlling performance that turns off
features in a certain order when performance falls below a specified level.
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adaptive sampling A method to accelerate the anti-aliasing process within
the bounds of the sample matrix size. See also anti-aliasing.

adjacent cell selection A selection of table cells that share at least one
boundary with another cell in the same selection.

affine calibration A tablet calibration method that provides an arbitrary linear
transformation in two-dimensional space. Affine calibration requires three
calibration points to allow a tablet transformation that combines translation,
independent X and Y scaling, rotation, and some skewing. Use affine calibration
if a drawing has been stretched differently in the horizontal or vertical
direction. (TABLET)

alias A shortcut for a command. For example, CP is an alias for COPY, and Z
is an alias for ZOOM. You define aliases in the acad.pgp file.

aliasing The effect of discrete picture elements, or pixels, aligned as a straight
or curved edge on a fixed grid appearing to be jagged or stepped. See also
anti-aliasing.

aligned dimension A dimension that measures the distance between two
points at any angle. The dimension line is parallel to the line connecting the
dimension's definition points. (DIMALIGNED)

alpha channel Alpha is a type of data, found in 32-bit bitmap files, that
assigns transparency to the pixels in the image.

A 24-bit truecolor file contains three channels of color information: red, green,
and blue, or RGB. Each channel of a truecolor bitmap file is defined by 8 bits,
providing 256 levels of intensity. The intensity of each channel determines
the color of the pixel in the image. Thus, an RGB file is 24-bit with 256 levels
each of red, green, and blue.

By adding a fourth, alpha channel, the file can specify the transparency, or
opacity, of each of the pixels. An alpha value of 0 is transparent, an alpha
value of 255 is opaque, and values in between are semi-transparent. An RGBA
file (red, green, blue, alpha) is 32-bit, with the extra 8 bits of alpha providing
256 levels of transparency.

To output a rendered image with alpha, save in an alpha-compatible format
such as PNG, TIFF, or Targa.

ambient color A color produced only by ambient light. Ambient color is the
color of an object where it is in shadow. This color is what the object reflects
when illuminated by ambient light rather than direct light.

ambient light Light that illuminates all surfaces of a model with equal
intensity. Ambient light has no single source or direction and does not
diminish in intensity over distance.
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angular dimension A dimension that measures angles or arc segments and
consists of text, extension lines, and leaders. (DIMANGULAR)

angular unit The unit of measurement for an angle. Angular units can be
measured in decimal degrees, degrees/minutes/seconds, grads, and radians.

annotation scale A setting that is saved with model space, layout viewports,
and model views. When you create annotative objects, they are scaled based
on the current annotation scale setting and automatically displayed at the
correct size.

annotational constraint Dimensional constraint used to control the size of
the geometry as well as annotate the drawing.

See also parameter constraint, and dynamic constraint

annotations Text, dimensions, tolerances, symbols, notes, and other types
of explanatory symbols or objects that are used to add information to your
model.

annotative A property that belongs to objects that are commonly used to
annotate drawings. This property allows you to automate the process of scaling
annotations. Annotative objects are defined at a paper height and display in
layout viewports and model space at the size determined by the annotation
scale set for those spaces.

anonymous block An unnamed block created by a number of features,
including associative and nonassociative dimensions.

anti-aliasing A method that reduces aliasing by shading the pixels adjacent
to the main pixels that define a line or boundary. See also aliasing.

application button The button that is displayed in the top-left corner of the
application. If you click the application button, the application menu is
displayed.

application menu The menu that is displayed when you click the application
button. The application menu contains common tools for creating, saving,
and publishing a file.

approximation points Point locations that a B-spline must pass near, within
a fit tolerance. See also fit points and interpolation points.

array 1. Multiple copies of selected objects in a rectangular or polar (radial)
pattern. (ARRAY) 2. A collection of data items, each identified by a subscript
or key, arranged so a computer can examine the collection and retrieve data
with the key.
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arrowhead A terminator, such as an arrowhead, slash, or dot, at the end of a
dimension line showing where a dimension begins and ends.

aspect ratio Ratio of display width to height.

associative dimension A dimension that automatically adapts as the associated
geometry is modified. Controlled by the DIMASSOC system variable. See also
nonassociative dimension and exploded dimension.

associative hatch Hatching that conforms to its bounding objects such that
modifying the bounding objects automatically adjusts the hatch. (BHATCH)

attenuation The diminishing of light intensity over distance.

attribute definition An object that is included in a block definition to store
alphanumeric data. Attribute values can be predefined or specified when the
block is inserted. Attribute data can be extracted from a drawing and inserted
into external files. (ATTDEF)

attribute extraction file A text file to which extracted attribute data is written.
The contents and format are determined by the attribute extraction template
file. See also attribute extraction template file.

attribute extraction template file A text file that determines which attributes
are extracted and how they are formatted when written to an attribute
extraction file. See also attribute extraction file.

attribute prompt The text string displayed when you insert a block with an
attribute whose value is undefined. See also attribute definition, attribute tag,
and attribute value.

attribute tag A text string associated with an attribute that identifies a
particular attribute during extraction from the drawing database. See also
attribute definition, attribute prompt, and attribute value.

attribute value The alphanumeric information associated with an attribute
tag. See also attribute definition, attribute prompt, and attribute tag.
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AutoCAD library search path The order in which looks for a support file:
current directory, drawing directory, directory specified in the support path,
and directory containing the executable file, acad.exe.

AutoCAD window The drawing area, its surrounding menus, and the
command line.

axis tripod Icon with X, Y, and Z coordinates that is used to visualize the
viewpoint (view direction) of a drawing without displaying the drawing.
(VPOINT)

B-spline curve A blended piecewise polynomial curve passing near a given
set of control points. See also Bezier curve. (SPLINE)

back face The opposite side of a front face. Back faces are not visible in a
rendered image. See also front faces.

base point 1. In the context of editing grips, the grip that changes to a solid
color when selected to specify the focus of the subsequent editing operation.
2. A point for relative distance and angle when copying, moving, and rotating
objects. 3. The insertion base point of the current drawing. (BASE) 4. The
insertion base point for a block definition. (BLOCK)

baseline An imaginary line on which text characters appear to rest. Individual
characters can have descenders that drop below the baseline. See also baseline
dimension.

baseline dimension Multiple dimensions measured from the same baseline.
Also called parallel dimensions. See also baseline.

basic tooltip Displays a brief description for the tooltip.

basic wheels A reference to the View Object wheel and Tour Building wheel.

Bezier curve A polynomial curve defined by a set of control points,
representing an equation of an order one less than the number of points being
considered. A Bezier curve is a special case of a B-spline curve. See also B-spline
curve.

big wheels The large version of the SteeringWheels. Labels are displayed on
each wheel wedge and they are larger than the size of the cursor.

bitmap The digital representation of an image having bits referenced to pixels.
In color graphics, a different value represents each red, green, and blue
component of a pixel.

blips Temporary screen markers displayed in the drawing area when you
specify a point or select objects. (BLIPMODE)
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block A generic term for one or more objects that are combined to create a
single object. Commonly used for either block definition or block reference.
See also block definition and block reference. (BLOCK)

block action Defines how the geometry of a dynamic block reference will
move or change when the custom properties of a block reference are
manipulated in a drawing. A dynamic block definition usually contains at
least one action that is associated with a parameter. (BACTION)

block authoring object A dimensional constraint, parameter, or action that
adds intelligence to a block definition.

block authoring palettes Tool palettes used in the Block Editor to add actions
and parameters to dynamic block definitions.

block authoring tools Actions, parameters, and parameter sets on the tabs
of the Block Authoring Palettes window. Used in the Block Editor to create
dynamic blocks.

block constraint parameter A dimensional constraint that has block authoring
information associated with it.

See also: dynamic constraint

See also: annotational constraint

block definition The name, base point, and set of objects that are combined
and stored in the symbol table of a drawing. See also block and block reference.

block definition table The nongraphical data area of a drawing file that stores
block definitions. See also named object.

block instance See block reference.

block properties table A table that enables users to define different values
for a set of properties for the block definition. Replacement for lookup
properties in the future.

block reference A compound object that is inserted in a drawing and displays
the data stored in a block definition. Also called instance. See also block and
block definition. (INSERT)

bounded area A closed area that consists of a single object (such as a circle)
or of multiple, coplanar objects that overlap. You can insert hatch fills within
bounded areas.

Bounded areas are also used to create 3D objects through extrusion by using
the PRESSPULL command.
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bump map A map in which brightness values are translated into apparent
changes in the height of the surface of an object.

button menu The menu for a pointing device with multiple buttons. Each
button on the pointing device (except the pick button) can be defined in the
customization file (acad.cui).

BYBLOCK A special object property used to specify that the object inherits
the color or linetype of any block containing it. See also BYLAYER.

BYLAYER A special object property used to specify that the object inherits
the color or linetype associated with its layer. See also BYBLOCK.

callout block A block used as symbol to reference another sheet. Callout
blocks have many industry-specific terms, such as reference tags, detail keys,
detail markers, and so on. See also label block.

camera Defines the current eye-level position in a 3D model. A camera has a
location XYZ coordinate, a target XYZ coordinate, and a field of view or lens
length, which determines the magnification or zoom factor.

camera target Defines the point you are viewing by specifying the coordinate
at the center of the view.

candela The SI unit of luminous intensity (perceived power emitted by a
light source in a particular direction) (Symbol: cd). Cd/Sr

category See view category.

cell The smallest available table selection.

cell boundary The four gridlines surrounding a table cell. An adjacent cell
selection can be surrounded with a cell boundary.

cell style A style that contains specific formatting for table cells.

chain actions In a dynamic block definition, a property of point, linear, polar,
XY, and rotation parameters. When set to Yes, a change in an action that
contains the parameter in the action's selection set triggers any actions
associated with that parameter, just as if you had edited the parameter in the
block reference through a grip or custom property.

circular external reference An externally referenced drawing (xref) that
references itself directly or indirectly. The xref that creates the circular
condition is ignored.

clipping planes The boundaries that define or clip the field of view.
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CMYK For cyan, magenta, yellow, and key color. A system of defining colors by
specifying the percentages of cyan, magenta, yellow, and the key color, which
is typically black.

Color bleed scale Increases or decreases the saturation of the reflected color
from the material.

color map A table defining the intensity of red, green, and blue (RGB) for
each displayed color.

column A vertically adjacent table cell selection spanning the height of the
table. A single column is one cell in width.

command line A text area reserved for keyboard input, prompts, and
messages.

compass

A visual aid that indicates the directions North, South, East, and West in the
current model.

composite solid A solid created from two or more individual solids. (UNION,
SUBTRACT, INTERSECT)

constraint bar Displays the geometric constraints associated with objects or
with points on objects.

constraint point Point on an object that can be geometrically and/or
dimensionally constrained (for example, an endpoint or an insertion point).

constraints Form of parametric design.

Rules that govern the position, slope, tangency, dimensions, and relationships
among objects in a geometry.

construction plane See workplane.

contextual ribbon tab

A ribbon tab that is displayed only when a particular type of object, such as
a hatch or table, is included in a selection. Toolbars can be changed to
contextual tabs in the CUI.

continued dimension A type of linear dimension that uses the second
extension line origin of a selected dimension as its first extension line origin,
breaking one long dimension into shorter segments that add up to the total
measurement. Also called chain dimension. (DIMCONTINUE)

control frame A series of point locations used as a mechanism to control the
shape of a B-spline. These points are connected by a series of line segments
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for visual clarity and to distinguish the control frame from fit points. The
SPLFRAME system variable must be turned on to display control frames.

control point See control frame.

Coons patch In 3D surface meshes, the bicubic surface (one curved in the M
direction and another in the N direction) interpolated between four edges.

coordinate filters Functions that extract individual X, Y, and Z coordinate
values from different points to create a new, composite point. Also called X,Y,Z
point filters.

crease A sharpened ridge that defines one or more edges of a mesh face
subobject. (MESHCREASE)

cross sections Generally, curves or lines that define the profile (shape) of a
lofted solid or surface. Cross sections can be open or closed. A lofted solid or
surface is drawn in the space between the cross sections. (LOFT)

crosshairs A type of cursor consisting of two lines that intersect.

crossing selection A rectangular area drawn to select objects fully or partly
within its borders.

CTB file SA color-dependent plot style table.

ctrl-cycle Method for cycling between different behaviors while editing
geometry, either in a command or when grip-editing. Pressing and releasing
the CTRL key cycles the behavior. For constrained geometry, CTRL-cycling
switches between enforcing and relaxing constraints.

current drawing A drawing file that is open in the program, and receives any
command or action that you enter.

cursor See pointer and crosshairs.

cursor menu See shortcut menu.

custom grips In a dynamic block reference, used to manipulate the geometry
and custom properties.

custom object A type of object that is created by an ObjectARX application
and that typically has more specialized capabilities than standard objects.
Custom objects include parametric solids (AutoCAD Mechanical Desktop),
intelligently interactive door symbols (AutoCAD Architecture), polygon objects
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(AutoCAD Map 3D), and associative dimension objects (AutoCAD and
AutoCAD LT). See also proxy object and object enabler.

customization (CUI) file An XML-based file that stores customization data.
You modify a customization file through the Customize User Interface dialog
box. CUI files replace MNU, MNS, and MNC files that were used to define
menus in earlier releases.

data link A connection between a table and an external source of data.

decimal degrees A notation for specifying latitude and longitude. For example,
35.1234°, 100.5678°.

Latitude always precedes longitude

default drawing See initial environment.

default lighting The lighting in a shaded viewport when the sun and user
lights are turned off. Faces are lighted by two distant light sources that follow
the viewpoint as you move around the model.

default value The value that is accepted when you press ENTER at a
sub-prompt. The default value is displayed in angle brackets <>. See also default.

definition points Points for creating a dimension. The program refers to the
points to modify the appearance and value of a nonassociative dimension
when the dimensioned object is modified. Also called defpoints and stored on
the special layer DEFPOINTS.

definition table The nongraphical data area of a drawing file that stores block
definitions.

dependency highlighting In a dynamic block definition, how associated
objects are displayed when you select a parameter, grip, or action.

dependent named objects (in xrefs) Named objects brought into a drawing
by an external reference. See also named object and symbol table.

dependent symbols See dependent named objects (in xrefs).

DGN underlay See underlay.

DIESEL For Direct Interpretively Evaluated String Expression Language. A macro
language for altering the status line with the MODEMACRO system variable
and for customizing menu items.

diffuse color An object's predominant color.

dimension line arc An arc (usually with arrows at each end) spanning the
angle formed by the extension lines of an angle being measured. The
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dimension text near this arc sometimes divides it into two arcs. See also angular
dimension.

dimension style A named group of dimension settings that determines the
appearance of the dimension and simplifies the setting of dimension system
variables. (DIMSTYLE)

dimension text The measurement value of dimensioned objects.

dimension variables A set of numeric values, text strings, and settings that
control dimensioning features. (DIMSTYLE)

dimensional constraint Parametric dimensions that control the size, angle,
or position of geometry relative to the drawing or other objects.When
dimensions are changed, the object resizes.

direct distance entry A method to specify a second point by first moving the
cursor to indicate direction and then entering a distance.

dithering Combining color dots to give the impression of displaying more
colors than are actually available.

dockable window A user interface element that can be either docked,
anchored, or floating in the drawing area. Dockable windows include the
command window, tool palettes, Properties Palette, and so on.

drawing area The area in which your drawings are displayed and modified.
The size of the drawing area varies, depending on the size of the AutoCAD
window and on how many toolbars and other elements are displayed. See also
AutoCAD window.

drawing extents The smallest rectangle that contains all objects in a drawing,
positioned on the screen to display the largest possible view of all objects.
(ZOOM)

drawing limits See grid limits.

drawing set A collection of drawings assembled using the Publish dialog box.
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drawing state A collection of known settings that define the behavioral
properties of the drawing environment and/or drawing at a known period of
time, such as when an action macro was recorded or before the playback of
an action macro.

drawing template A drawing file with preestablished settings for new drawings
such as acad.dwtand acadiso.dwt however, any drawing can be used as a
template. See also initial environment.

driven constraint A non-parametric dimension enclosed in parentheses that
shows the current value of geometry. The value is updated when the geometry
changes size, but it does not control geometry.

driving dimension A parametric dimension that determines the size of
geometry and resizes the object when its value changes.

driving property A lookup property is considered invertible when a manual
change in the lookup value for a block reference causes other properties values
change.

DSD For drawing set descriptions. A file format for saving a description of a
drawing set that has been assembled using the Publish dialog box.

DST For sheet set data. The XML file format used to store the associations and
information that define a sheet set.

DWF

An open, published, and secure file format developed by Autodesk, DWF
enables you to combine and publish rich 2D- and 3D-design data and share
it with others.

DWF underlay See underlay.

DWFx

A version of DWF based on the XML Paper Specification (XPS) from Microsoft.
DWFx enables DWF files to be viewed using the free Microsoft XPS Viewer.
Generically referred to as DWF.

DWG Standard file format for saving vector graphics. See also DWF and DXF.

DXF For drawing interchange format. An ASCII or binary file format of a drawing
file for exporting drawings to other applications or for importing drawings
from other applications. See also DWF and DWG.

dynamic constraint Dimensional constraint (Constraint Form property =
"dynamic") that displays the constraints only when you select the constrained
object.
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See also: parameter constraint

See also: annotational constraint

dynamic dimension Temporary dimensions that appear on objects, including
dynamic block references, when they are grip edited.

edge The boundary of a face.

edge modifiers Effects such as overhang and jitter that control how edges are
displayed in a shaded model.

electronic drawing set The digital equivalent of a set of plotted drawings.
You create an electronic drawing set by publishing drawings to a DWF file.

elevation The default Z value above or below the XY plane of the current user
coordinate system, which is used for entering coordinates and digitizing
locations. (ELEV)

embed To use object linking and embedding (OLE) information from a source
document in a destination document. An embedded object is a copy of the
information from a source document that is placed in the destination
document and has no link to the source document. See also link.

empty selection set A selection set that contains no objects.

enterprise customization file A CUI file that is typically controlled by a CAD
manager. It is often accessed by many users and is stored in a shared network
location. The file is read-only to users to prevent the data in the file from
being changed. A CAD manager creates an enterprise CUI file by modifying
a main CUI file and then saving the file to the support location defined in
the Options dialog box, Files tab.

environment map A bitmap that is used to simulate reflections in materials
that have reflective properties. The map is “wrapped” around the scene and
any reflective object will show the appropriate portion of the map in the
reflective parts of its material.

environment variable A setting stored in the operating system that controls
the operation of a program.
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expanded panel

An area on the ribbon associated with a ribbon panel. An expanded panel
contains additional tools and controls. See also ribbon panel and ribbon.

explode To disassemble a complex object, such as a block, dimension, solid,
or polyline, into simpler objects. In the case of a block, the block definition
is unchanged. The block reference is replaced by the components of the block.
See also block, block definition, and block reference. (EXPLODE)

exploded dimension Independent objects that have the appearance of a
dimension but are not associated with the dimensioned object or each other.
Controlled by the DIMASSOC system variable. See also associative dimension,
nonassociative dimension, and explode. (EXPLODE)

extended tooltips When hovered over the tooltip for a period of time, displays
additional information.

extents See drawing extents.

external reference (xref) A drawing file referenced by another drawing. (XREF)

extrusion A 3D solid created by sweeping an object that encloses an area
along a linear path.

face A triangular or quadrilateral portion of a surface object.

face color mode A setting in the visual style that controls how color is
displayed on a face.

face style A setting in the visual style that defines the shading on a face.

facet The underlying structure of the face of a 3D solid, surface, or mesh.
Facets can be quadrilateral or triangular. Smoothing a mesh object increases
the number of facets for each face.

feature control frame The tolerance that applies to specific features or
patterns of features. Feature control frames always contain at least a geometric
characteristic symbol to indicate the type of control and a tolerance value to
indicate the amount of acceptable variation.

fence A multisegmented line specified to select objects it passes through.

field A specialized text object set up to display data that may change during
the life cycle of the drawing. When the field is updated, the latest value of the
field is displayed. (FIELD)

fill A solid color covering an area bounded by lines or curves. (FILL)

filters See coordinate filters.
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final gathering Final gathering is an optional, additional step to calculating
global illumination. Using a photon map to calculate global illumination can
cause rendering artifacts such as dark corners and low-frequency variations
in the lighting. You can reduce or eliminate these artifacts by turning on final
gathering, which increases the number of rays used to calculate global
illumination.

Final gathering can greatly increase rendering time. It is most useful for scenes
with overall diffuse lighting, less useful for scenes with bright spots of indirect
illumination.

You turn on final gathering on the Advanced Render Settings palette. See also
global illumination.

First Contact balloon The interactive graphical tooltip that is displayed when
the SteeringWheel is pinned during startup.

fit points Locations that a B-spline must pass through exactly or within a fit
tolerance. See also interpolation points and approximation points.

fit tolerance The setting for the maximum distance that a B-spline can pass
for each of the fit points that define it.

floating panel

A ribbon panel that is not attached to the rest of the ribbon or application
frame.

floating viewports See layout viewports.

font A character set, made up of letters, numbers, punctuation marks, and
symbols of a distinctive proportion and design.

footcandle The American unit of illuminance (symbol: fc). Lm/ft^2.

footcandle The American unit of illuminance (symbol: fc). Lm/ft^2

frame An individual, static image in an animated sequence. See also motion
path.

freeze A setting that suppresses the display of objects on selected layers. Objects
on frozen layers are not displayed, regenerated, or plotted. Freezing layers
shortens regenerating time. See also thaw. (LAYER)

front faces Faces with their normals pointed outward.

general property Properties that are common between a selection of objects.
These include Color, Layer, Linetype, Linetype scale, Plot style, Lineweight,
Hyperlink, and Thickness.
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geographic elevation The relative height along the specified up-direction
defined for a geographic marker.

geographic marker Visual representation of geographic location information.

geometric constraint Rules that define the geometric relationships of objects
(or points of objects) elements and control how an object can change shape
or size.

Geometric constraints are coincident, collinear, concentric, equal, fix,
horizontal, parallel, perpendicular, tangent, and vertical.

geometry All graphical objects such as lines, circles, arcs, polylines, and
dimensions. Nongraphical objects, such as linetypes, lineweights, text styles,
and layers are not considered geometry. See also named object.

gizmo A tool that permits you to manipulate a 3D object uniformly or along
a specified axis or plane. Examples of gizmos include the 3D Move, 3D Rotate,
and 3D Scale gizmos. They are displayed when you select a 3D object.

global illumination An indirect illumination technique that allows for effects
such as color bleeding. As light hits a colored object in the model, photons
bounce to adjacent objects and tint them with the color of the original object.

Gooch shading A type of shading that uses a transition from cool to warm
colors rather than from dark to light.

graphics area See drawing area.

graphics window See AutoCAD window and drawing area.

grid An area covered with regularly spaced dots or lines to aid drawing. The
grid spacing is adjustable. The grid dots are never plotted. See also grid limits.
(GRID)

grid limits The user-defined rectangular boundary of the drawing area covered
by dots when the grid is turned on. Also called drawing limits. (LIMITS)
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grip modes The editing capabilities activated when grips are displayed on an
object: stretching, moving, rotating, scaling, and mirroring.

grip tool An icon that you use in a 3D view to easily constrain the movement
or rotation of a selection set of objects to an axis or a plane. (3DMOVE,
3DROTATE)

grips Small squares and triangles that appear on objects you select. After
selecting the grip, you edit the object by dragging it with the pointing device
instead of entering commands.

ground plane The XY plane of the user coordinate system when perspective
projection is turned on. The ground plane displays with a color gradient
between the ground horizon (nearest to the horizon) and the ground origin
(opposite the horizon). See also sky and underground.

guide curves Lines or curves that intersect each cross section of a lofted solid
or surface and that define the form by adding additional wireframe information
to the object. (LOFT)

handle A unique alphanumeric tag for an object in the program's database.

HDI For Heidi Device Interface. An interface for developing device drivers that
are required for peripherals to work with the program and other Autodesk
products.

heads-up display (HUD) The process of transparently displaying user interface
elements on top of or over the drawing area without obscuring the view of
the objects drawn on the drawing area.

helix An open 2D or 3D spiral. (HELIX)

Help menu The legacy way to access online Help. In the current version of
AutoCAD, you can find Help on the InfoCenter toolbar or by pressing F1.

HLS For hue, lightness, and saturation. A system of defining color by specifying
the amount of hue, lightness, and saturation.

Home view A special view saved with the drawing that is controlled through
the ViewCube tool. The Home view is similar in concept to the default, initial
view presented when a drawing is first opened.

horizontal landing An optional line segment connecting the tail of a leader
line with the leader content.
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horizontal ribbon

The ribbon, when it is oriented across the top of the file window.

i-drop A method by which a drawing file can be dragged from a Web page
and inserted into another drawing.

IGES For Initial Graphics Exchange Specification. A standard format for digital
representation and exchange of information between CAD/CAM systems. In
AutoCAD-based products, the commands to import and export IGES files are
available only in AutoCAD Mechanical.

Illuminance In photometry, illuminance is the total luminous flux incident
on a surface per unit area.

indirect bump scale Scales the effect of the base material’s bump mapping
in areas lit by indirect light.

indirect illumination Illumination techniques such as global illumination
and final gathering, that enhance the realism of a scene by simulating radiosity,
or the interreflection of light between objects in a scene.

initial environment The variables and settings for new drawings as defined
by the default drawing template, such as acad.dwg or acadiso.dwg. See also
template drawing.

input property In a dynamic block definition, a parameter property other
than that of a lookup, alignment, or base point parameter that you can add
as a column to a lookup table. When the parameter values in a dynamic block
reference match a row of input property values, the corresponding lookup
property values in that table row are assigned to the block reference.
(BLOOKUPTABLE)

interface element A user interface object that can be customized, such as a
toolbar, pull-down menu, shortcut key, dockable window, and so on.

interpolation points Defining points that a B-spline passes through. See also
approximation points and fit points.

island An enclosed area within another enclosed area. Islands may be detected
as part of the process of creating hatches, polylines, and regions. (BHATCH,
BOUNDARY)

ISO For International Standards Organization. The organization that sets
international standards in all fields except electrical and electronics.
Headquarters are in Geneva, Switzerland.

isometric snap style A drafting option that aligns the cursor with two of three
isometric axes and displays grid, making 2D isometric drawings easier to create.
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key point In a dynamic block definition, the point on a parameter that drives
its associated action when edited in the block reference.

label block A block used to label views and details. Labels contain data, such
as a title, view number, and scale, that is associated with the referenced view.
See also callout block.

landing The portion of a leader object that acts as a pointer to the object
being called out. A landing can either be a straight line or a spline curve.

landing gap An optional space between a leader tail and the leader content.

layer A logical grouping of data that are like transparent acetate overlays on
a drawing. You can view layers individually or in combination. (LAYER)

layer index A list showing the objects on each layer. A layer index is used to
locate what portion of the drawing is read when you partially open a drawing.
Saving a layer index with a drawing also enhances performance when you
work with external references. The INDEXCTL system variable controls whether
layer and spatial indexes are saved with a drawing.

layer translation mappings Assignments of a set of layers to another set of
layers that defines standards. These standards include layer names and layer
properties. Also called layer mappings.

layout The environment in which you create and design paper space layout
viewports to be plotted. Multiple layouts can be created for each drawing.

layout viewports Objects that are created in paper space that display views.
See also paper space. (VPORTS)

leader tail The portion of a leader line that is connected to the annotation.

lens length Defines the magnification properties of a camera's lens. The greater
the lens length, the narrower the field of view.

level of smoothness The property assigned to a mesh object to control how
much the edges of the object are smoothed. Level 0 (zero) represents the least
rounded shape for a specified mesh object. Higher levels result in increased
smoothness.

light glyph The graphic representation of a point light or a spotlight.

limits See drawing limits.

line font See linetype.

linetype How a line or type of curve is displayed. For example, a continuous
line has a different linetype than a dashed line. Also called line font. (LINETYPE)
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lineweight A width value that can be assigned to all graphical objects except
TrueType® fonts and raster images.

link To use object linking and embedding (OLE) to reference data in another
file. When data is linked, any changes to it in the source document are
automatically updated in any destination document. See also embed.

LL84 coordinate system Common latitude longitudinal-based coordinate
system where latitude and longitude are both measured from -90 to 90 degrees.

Longitude begins at 0 degrees at the Prime Meridian in Greenwich, England
and is measured from -180 to 180.

Latitude is 0 degrees at the equator and is measured from -90 to 90.

lofted solid/surface A solid or surface that is drawn through a set of two or
more cross-section curves. The cross sections define the profile (shape) of the
resulting solid or surface. Cross sections (generally, curves or lines) can be
open or closed. (LOFT)

lookup property In a dynamic block definition, a lookup parameter that you
add to a lookup table. The lookup parameter label is used as the property
name. When the parameter values in a dynamic block reference match a row
of input property values, the corresponding lookup property values in that
table row are assigned to the block reference. (BLOOKUPTABLE)

lookup table Defines properties for and assigns property values to a dynamic
block. Assigns property values to the dynamic block reference based on how
the block is manipulated in a drawing. (BLOOKUPTABLE)

lumen  The SI unit of luminous flux (Symbol: lm). Cd * Sr

luminaire This refers to the aggregation of a lamp or lamps and its fixture.
The fixture may be a simple can or a complex armature with constrained
joints.

luminance Luminance is the value of light reflected off a surface. It is a
measure of how bright or dark we perceive the surface.

luminous flux The perceived power in per unit of solid angle. The total
luminous flux for a lamp is the perceived power emitted in all directions.

lux The SI unit of illuminance (symbol: lx). Lm/m^2

macro-derived selection A selection set of all the objects that have been
created during the playback of an action macro up to the command that is
requesting a selection set.
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main customization file A writable CUI file that defines most of the user
interface elements (including the standard menus, toolbars, keyboard
accelerators, and so on). The acad.cui file (the default main CUI file) is
automatically loaded when you start AutoCAD.

markup A single comment or a redline geometry correction inserted into a
DWF file using Autodesk Design Review.

markup set A group of markups contained within a single DWF file.

merge In tables, an adjacent cell selection that has been combined into a
single cell.

mesh A tessellated, or subdivided object type that is defined by faces, edges,
and vertices. Mesh can be smoothed to achieve a more rounded appearance
and creased to introduce ridges. Before AutoCAD 2010, only the less modifiable
polygon and polyface mesh was available.

mini wheels The small version of SteeringWheels. No labels are displayed on
any of the wedges and they are often the size of the cursor.

mirror To create a new version of an existing object by reflecting it
symmetrically with respect to a prescribed line or plane. (MIRROR)

mode A software setting or operating state.

model A two- or three-dimensional representation of an object.

model space One of the two primary spaces in which objects reside. Typically,
a geometric model is placed in a three-dimensional coordinate space called
model space. A final layout of specific views and annotations of this model is
placed in paper space. See also paper space. (MSPACE)

model viewports A type of display that splits the drawing area into one or
more adjacent rectangular viewing areas. See also layout viewports, TILEMODE,
and viewport. (VPORTS)

motion path Defines the path or target of a camera. A path can be a line, arc,
elliptical arc, circle, polyline, 3D polyline, or spline.

multi-sheet DWF A DWF file that contains multiple sheets.

multileader A leader object that creates annotations with multiple leader
lines.

named object Describes the various types of nongraphical information, such
as styles and definitions, stored with a drawing. Named objects include
linetypes, layers, dimension styles, text styles, block definitions, layouts, views,
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and viewport configurations. Named objects are stored in definition (symbol)
tables.

named objects, dependent See dependent named objects (in xrefs).

named path A saved motion path object that is linked to a camera or target.

named range A tool in Microsoft Excel that provides a method to assign a
meaningful name to a single cell or a range of cells.

named view A view saved for restoration later. (VIEW)

node An object snap specification to locate points, dimension definition
points, and dimension text origins.

nonassociative dimension A dimension that does not automatically change
as the associated geometry is modified. Controlled by the DIMASSOC system
variable. See also associative dimension and exploded dimension.

normal A normal is a vector that defines which way a face is pointing. The
direction of the normal indicates the front, or outer surface of the face.

noun-verb selection Selecting an object first and then performing an operation
on it rather than entering a command first and then selecting the object.

NURBS For nonuniform rational B-spline curve. A B-spline curve or surface defined
by a series of weighted control points and one or more knot vectors. See also
B-spline curve.

object One or more graphical elements, such as text, dimensions, lines, circles,
or polylines, treated as a single element for creation, manipulation, and
modification. Formerly called entity.

object enabler A tool that provides specific viewing and standard editing
access to a custom object when the ObjectARX application that created the
custom object is not present. See also custom object and proxy object.

Object Snap mode Methods for selecting commonly needed points on an
object while you create or edit a drawing. See also running object snap and
object snap override.

object snap override Turning off or changing a running Object Snap mode
for input of a single point. See also Object Snap mode and running object snap.

ObjectARX (AutoCAD Runtime Extension) A compiled-language
programming environment for developing AutoCAD applications.

OLE For object linking and embedding. An information-sharing method in which
data from a source document can be linked to or embedded in a destination
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document. Selecting the data in the destination document opens the source
application so that the data can be edited. See also embed and link.

opacity map Projection of opaque and transparent areas onto objects, creating
the effect of a solid surface with holes or gaps.

origin The point where coordinate axes intersect. For example, the origin of
a Cartesian coordinate system is where the X, Y, and Z axes meet at 0,0,0.

Ortho mode A setting that limits pointing device input to horizontal or
vertical (relative to the current snap angle and the user coordinate system).
See also snap angle and user coordinate system (UCS).

orthogonal Having perpendicular slopes or tangents at the point of
intersection.

output property A lookup property whose value is determined by input
properties (other parameter properties) through the use of a lookup table.

page setup A collection of plot device and other settings that affect the
appearance and format of the final output. These settings can be modified
and applied to other layouts.

pan To shift the view of a drawing without changing magnification. See also
zoom. (PAN)

paper space One of two primary spaces in which objects reside. Paper space
is used for creating a finished layout for printing or plotting, as opposed to
doing drafting or design work. You design your model using the Model tab.
See also model space and viewport. (PSPACE)

parameter In a dynamic block definition, defines custom properties for the
dynamic block by specifying positions, distances, and angles for geometry in
the block.

parameter set A tool on the Parameter Sets tab of the Block Authoring Palettes
window that adds one or more parameters and one or more associated actions
to the dynamic block definition.

parametric design Ability to establish relationships between objects, to drive
the size and orientation of geometry with model and user-defined parameters.

parametric drawing Feature in AutoCAD that assigns constraints to objects,
establishing the distance, location, and orientation of objects with respect to
other objects.
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partial customization file Any CUI file that is not defined as the main CUI
file. You can load and unload partial CUI files as you need them during a
drawing session.

path curve Defines the direction and length that a profile curve is lofted,
swept, or extruded to create a solid or surface. (SWEEP, LOFT, EXTRUDE)

PC2 file Complete plotter configuration file. PC2 files contain all plot settings
and device-specific settings that were saved in previous versions. See also PCP
file and PC3 file.

PC3 file Partial plotter configuration file. PC3 files contain plot settings
information such as the device driver and model, the output port to which
the device is connected, and various device-specific settings, but do not include
any custom plotter calibration or custom paper size information. See also PMP
file, STB file, and CTB file.

PCP file Partial plotter configuration file. PCP files contain basic plot
specifications and pen parameters that were saved in previous versions. Plot
settings that are stored in a PCP file include pen assignments, plotting units,
paper size, plot rotation, plot origin, scale factor, and pen optimization level.
See also PC2 file and PC3 file.

performance tuning A method of optimizing 3D graphics performance. The
performance tuner examines your graphics card and 3D display driver and
decides whether to use software or hardware implementation for features that
support both.

personalization Customizes the executable file during installation with the
user name, company, and other information.

perspective view Objects in 3D seen by an observer positioned at the
viewpoint looking at the view center. Objects appear smaller when the distance
from the observer (at the view point) to the view center increases. Although
a perspective view appears realistic, it does not preserve the shapes of objects.
Parallel lines seemingly converge in the view. The program has perspective
view settings for VPORTS table entries as well as viewport objects.

photometric lights Photometric lights are physically-correct lights. Physically
correct lights attenuate as the square of the distance. Photometry is the science
of measurement of visible light in terms of its perceived brightness.

photon map A technique to generate the indirect illumination effects of
global illumination used by the renderer. When it calculates indirect
illumination, the renderer traces photons emitted from a light. The photon
is traced through the model, being reflected or transmitted by objects, until
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it strikes a diffuse surface. When it strikes a surface, the photon is stored in
the photon map.

photorealistic rendering Rendering that resembles a photograph.

pick button The button on a pointing device that is used to select objects or
specify points on the screen. For example, on a two-button mouse, it is the
left button by default.

pick points Clicking and acquiring a point on an object in the drawing.

pick-first The selection of objects before an action macro or command is
issued.

pick-first set A selection set of objects that are selected prior to the execution
of an action macro or a command. See also pre-selection set.

plan view A view orientation from a point on the positive Z axis toward the
origin (0,0,0). (PLAN)

planar face A flat face that can be located anywhere in 3D space.

planar projection Mapping of objects or images onto a plane.

planar surface A flat surface that can be located anywhere in 3D space.
(PLANESURF)

playback The process of executing the actions stored in a previously recorded
action macro.

pline See polyline.

plot style An object property that specifies a set of overrides for color,
dithering, gray scale, pen assignments, screening, linetype, lineweight,
endstyles, joinstyles, and fill styles. Plot styles are applied at plot time.

plot style table A set of plot styles. Plot styles are defined in plot style tables
and apply to objects only when the plot style table is attached to a layout or
viewport.
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plug-ins Plug-ins are libraries of reuseable content that extend the functionality
of AutoCAD. Plug-ins are created by third party developers and can be accessed
from the Featured Technologies and Content channel of the Communications
Center.

PMP file Plot Model Parameter. File containing custom plotter calibration and
custom paper size information associated with plotter configuration file.

point 1. A location in three-dimensional space specified by X, Y, and Z
coordinate values. 2. An object consisting of a single coordinate location.
(POINT)

point filters See coordinate filters.

pointer A cursor on a video display screen that can be moved around to place
textual or graphical information. See also crosshairs.

polar array Objects copied around a specified center point a specified number
of times. (ARRAY)

Polar Snap A precision drawing tool used to snap to incremental distances
along the polar tracking alignment path. See also polar tracking on page 1946.

polar tracking A precision drawing tool that displays temporary alignment
paths defined by user-specified polar angles. See also Polar Snap.

polyface and polygon mesh Legacy mesh types that were available before
AutoCAD 2010. Although you can continue to create polygonal and polyface
mesh (for example, by setting MESHTYPE to 0), the newer, more modifiable
mesh type is recommended.

polygon window selection A multisided area specified to select objects in
groups. See also crossing selection and window selection.

polyline An object composed of one or more connected line segments or
circular arcs treated as a single object. Also called pline. (PLINE, PEDIT)

polysolid A swept solid that is drawn the same way you draw a polyline or
that is based on an existing line. By default, a polysolid always has a rectangular
profile. You can specify the height and width of the profile. (POLYSOLID)

pre-playback drawing environment The drawing state prior to the playback
of an action macro.

pre-selection set A selection set of objects that is defined prior to the execution
of an action macro.

primary table fragment The fragment of a broken table that contains the
beginning set of rows up to the first table break.
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primitive Basic 3D forms such as boxes, cones, cylinders, pyramids, wedges,
spheres, and tori. You can create primitive meshes and primitive 3D solid
objects.

procedural materials Materials that generate a 3D pattern in two or more
colors, and apply it to an object. These include marble and wood. Also called
template materials.

profile curve An object that is swept, extruded, or revolved and defines the
shape of the resulting solid or surface. (SWEEP, EXTRUDE, REVOLVE)

prompt A message on the command line or in a tooltip that asks for
information or requests action such as specifying a point.

proxy object A substitute for a custom object when the ObjectARX application
that created the custom object is not available. See also custom object and
object enabler.

push pin A push pin-shaped button used on the ribbon and in the application
menu. On the ribbon, push pins are used to keep a ribbon panel expanded.
In the application menu, push pins keep an item in the list of recently opened
items.

PWT A template file format used to publish drawings to the Web.

Quick View image A thumbnail image of a drawing, layout or model space
that is displayed using Quick View tools.

Quick View tool A tool to preview and switch between open drawings and
layouts in a drawing.

ray tracing The renderer can generate reflections and refractions. Ray tracing
traces the path of rays sampled from the light source. Reflections and
refractions generated this way are physically accurate.

You turn on ray tracing on the Advanced Render Settings palette.

ray-traced shadows A way that the renderer can generate shadows. Ray tracing
traces the path of rays sampled from the light source. Shadows appear where
rays have been blocked by objects. Ray-traced shadows have sharp edges.

Ray-traced shadows are active when Shadow Map is turned off on the Advanced
Render Settings palette.

recorded value The input captured during the recording of an action macro
for a sub-prompt of a command.

rectangular break To break a table into multiple parts that are evenly spaced
and set at a user-specified height using the table breaking grips.
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redraw To quickly refresh or clean up blip marks in the current viewport
without updating the drawing's database. See also regenerate. (REDRAW)

reference A definition, known as an external reference or block reference,
that is used and stored in the drawing. See also block (BLOCK) and external
reference (xref). (XREF)

refine To quadruple the number of faces in a mesh object as you reset the
baseline level of smoothness. (You cannot make a mesh courser than its
baseline level.) You can also refine specified mesh faces without resetting the
baseline level of smoothness for the object. (MESHREFINE)

reflectance scale Increases or decreases the amount of energy the material
reflects.

reflection color The color of a highlight on shiny material. Also called specular
color.

reflection line In a dynamic block reference, the axis about which a flip
action's selection set flips when the associated parameter is edited through a
grip or the Properties palette.

reflection mapping Creates the effect of a scene reflected on the surface of
a shiny object.

refraction How light distorts through an object.

regenerate To update a drawing's screen display by recomputing the screen
coordinates from the database. See also redraw. (REGEN)

region Two-dimensional enclosed areas that have physical properties such as
centroids or centers of mass. You can create regions from objects that form
closed loops. They area commonly created in order to apply hatching and
shading. (REGION)

relative coordinates Coordinates specified in relation to previous coordinates.

relax constraints Ability to temporarily ignore constraints while editing
geometry. After the geometry is edited, the constraints are either removed or
retained based on whether the constraint is still valid for the edited geometry.

request user input An item that is assigned to an action node that pauses the
playback of an action macro so a user can provide some form of input before
playback resumes.

reverse lookup Adds a lookup grip to a dynamic block reference. When you
click this grip, a drop-down list of the lookup values for that lookup property
(column in the lookup table) is displayed. When you select a value from the
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list, the corresponding input property values are assigned to the block reference.
Depending on how the block was defined, this usually results in a change in
the block reference's geometry. (BLOOKUPTABLE)

rewind Restores the previous view or movement path created by the Autodesk®

ViewCube® navigation tool, SteeringWheels, and other navigation tools.

RGB For red, green, and blue. A system of defining colors by specifying
percentages of red, green, and blue.

ribbon A palette that displays buttons and controls used for both 2D drawing
and annotation and 3D modeling, viewing, and rendering. See also ribbon tab
and ribbon panel and slide-out panel. (RIBBON)

ribbon panel

A labeled control in the ribbon. Ribbon panels contain buttons or other
controls. Multiple ribbon panels make a ribbon tab.

ribbon tab

The most general control on the ribbon. Ribbon tabs contain ribbon panels,
which contain buttons or other controls.

roll arrows Curved arrows located above the ViewCube tool with which you
can rotate the current view 90 degrees clockwise or counterclockwise.

roughness Value to simulate how light hitting a face is reflected back to the
user. A high roughness value simulates a non-shiny or rough object
(sandpaper/carpet). A low roughness value simulates a very shiny object
(metals, some plastics.)

row A horizontally adjacent table cell selection spanning the width of the
table. A single row is one cell in height.

RSS feed Information published by a website to which you subscribe. Usually
allows users to receive notifications when new content (articles) are posted.
RSS stands for Rich Site Summary (or Really Simple Syndication).

rubber-band line A line that stretches dynamically on the screen with the
movement of the cursor. One endpoint of the line is attached to a point in
your drawing, and the other is attached to the moving cursor.

running object snap Setting an Object Snap mode so it continues for
subsequent selections. See also Object Snap mode and object snap override.
(OSNAP)

sampling Sampling is an antialiasing technique. It provides a "best guess"
color for each rendered pixel. The renderer first samples the scene color at
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locations within the pixel or along the pixel's edge, then uses a filter to
combine the samples into a single pixel color.

save back To update the objects in the original reference (external or block
reference) with changes made to objects in a working set during in-place
reference editing.

scale representation The display of an annotative object based on the
annotation scales that the object supports. For example, if an annotative object
supports two annotations scales, it has two scale representations

script file A set of commands executed sequentially with a single SCRIPT
command. Script files are created outside the program using a text editor,
saved in text format, and stored in an external file with the file extension .scr.

search tag A user-defined keyword used to search for commands in the menu
browser.

secondary table fragment Any fragment of a broken table that does not
contain the beginning set of rows.

selection node A specific type of action tree node that is used to handle
selection activities.

selection sensitivity The ability to define the pivot point for reorienting a
model based on the current selection.

selection set One or more selected objects that a command can act upon at
the same time.

In a dynamic block definition, the geometry associated with an action.

shadow maps A shadow map is a bitmap that the renderer generates during
a pre-rendering pass of the scene. Shadow maps don't show the color cast by
transparent or translucent objects. On the other hand, shadow maps can have
soft-edged shadows, which ray-traced shadows cannot.

Shadow mapped shadows provide softer edges and can require less calculation
time than ray-traced shadows, but are less accurate. On the Advanced Render
Settings palette, shadow mapped shadows are active when Shadow Map is
turned on.

ShapeManager ShapeManager is the Autodesk technology that provides 3D
solid modeling to AutoCAD and other products.

sheet A layout selected from a drawing file and assigned to a sheet set. See
also sheet set.

sheet list table A table listing all sheets in a sheet set. A sheet list table can
be generated automatically with the Sheet Set Manager.
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sheet selection A named selection of sheets in a sheet set that can be
conveniently recalled for archiving, transmitting, and publishing operations.

sheet set An organized and named collection of sheets from several drawing
files. See also sheet. (SHEETSET)

shortcut keys Keys and key combinations that start commands; for example,
CTRL+S saves a file. The function keys (F1, F2, and so on) are also shortcut
keys. Also known as accelerator keys.

shortcut menu The menu displayed at your cursor location when you
right-click your pointing device. The shortcut menu and the options it provides
depend on the pointer location and other conditions, such as whether an
object is selected or a command is in progress.

shot A saved view that can later be restored by name or with ShowMotion. A
shot can contain a static thumbnail of the saved view or camera motion that
can be played back as an animation.

ShowMotion User interface element where you can access named views (shots)
that are stored in the current drawing. The named views (shots) are organized
by sequences and can contain movements.

sky The background color of the drawing area when perspective projection
is turned on. The sky displays with a color gradient between the sky horizon
(nearest to the horizon) and the sky zenith (opposite the horizon). See also
ground plane.

slide file A file that contains a raster image or snapshot of the objects displayed
in the drawing area. Slide files have the file extension .sld. (MSLIDE, VSLIDE)

slide library A collection of slide files organized for convenient retrieval and
display. Slide library names have the extension .slb and are created with the
slidelib.exe utility.

slide-out panel An area on the ribbon associated with a ribbon panel. A
slide-out panel contains additional tools and controls. See also ribbon panel
and ribbon.

smooth shading Smoothing of the edges between polygon faces.

smoothness A property of mesh objects that controls the roundness of the
object. Objects with higher levels of smoothness have more faces, or
tessellations.

snap angle The angle that the snap grid is rotated.
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snap grid The invisible grid that locks the pointer into alignment with the
grid points according to the spacing set by Snap. Snap grid does not necessarily
correspond to the visible grid, which is controlled separately by GRID. (SNAP)

Snap mode A mode for locking a pointing device into alignment with an
invisible rectangular grid. When Snap mode is on, the screen crosshairs and
all input coordinates are snapped to the nearest point on the grid. The snap
resolution defines the spacing of this grid. See also Object Snap mode. (SNAP)

snap resolution The spacing between points of the snap grid.

solid history A property of a solid that allows you to see and modify the
original forms of the solid.

solid object An object that represents the entire volume of an object, for
example a box.

solid primitive A basic solid form. Solid primitives include: box, wedge, cone,
cylinder, sphere, torus, and pyramid.

spatial index A list that organizes objects based on their location in space. A
spatial index is used to locate what portion of the drawing is read when you
partially open a drawing. Saving a spatial index with a drawing also enhances
performance when working with external references. The INDEXCTL system
variable controls whether layer and spatial indexes are saved with a drawing.

specular reflection The light in a narrow cone where the angle of the
incoming beam equals the angle of the reflected beam.

split face A mesh face that has been subdivided along a specified vector.

STB file For plot style table file. Contains plot styles and their characteristics.

SteeringWheels Tool set that provides access to 2D and 3D navigation tools.

stretch frame In a dynamic block definition that contains a stretch action or
a polar stretch action, determines how the objects within or crossed by the
frame are edited in the block reference.

sub-prompt A command prompt that instructs for a form of input to complete
a command or alter a property.

subdivision A division, or tessellation in a mesh object. As a mesh object is
smoothed, the number of subdivisions increases.

subobject Any part of a solid: a face, an edge, or a vertex. Also, an original
individual form that is part of a composite solid.
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Subscription Center Subscription members can access the latest releases of
Autodesk software, incremental product enhancements, personalized web
support, and self-paced e-Learning in InfoCenter. To access Subscription
Center, go to the InfoCenter toolbar and click the Key button.

subset A named collection of sheets in a sheet set that is often organized by
discipline or workflow stage. See also view category.

surface An open-ended, infinitely thin object that corresponds to the shape
of a 3D object. You can create surfaces in several ways. For example, you can
convert from other objects such as mesh, or with sweep, loft, or revolve
operations that create open-ended objects.

surface normal Positive direction perpendicular to the surface of an object.

swept solid/surface A solid or surface created in the shape of the specified
profile (the swept object) swept along the specified path. (SWEEP)

symbol A representation of an item commonly used in drawings. Symbols
are inserted in drawings as blocks.

symbol library A collection of block definitions stored in a single drawing
file.

symbol table See definition table and block definition table.

system variable A name that is recognized as a mode, size, or limit. Read-only
system variables, such as DWGNAME, cannot be modified directly by the user.

table A rectangular array of cells that contain annotation, primarily text but
also blocks. In the AEC industry, tables are often referred to as “schedules”
and contain information about the materials needed for the construction of
the building being designed. In the manufacturing industry, they are often
referred to as “BOM” (bills of materials). (TABLE)

table break The point at the bottom of a table row where the table will be
split into a supplementary table fragment.

table style A style that contains a specific table format and structure. A table
style contains at least 3 cell styles.

temporary files Data files created during an program session. The files are
deleted by the time you end the session. If the session ends abnormally, such
as during a power outage, temporary files might be left on the disk.

tessellation lines Lines that help you visualize a curved surface.
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In a 3D mesh object, tessellations indicate the boundaries of the mesh faces.

text style A named, saved collection of settings that determines the appearance
of text characters—for example, stretched, compressed, oblique, mirrored, or
set in a vertical column.

texture map The projection of an image (such as a tile pattern) onto an object
(such as a chair).

thaw A setting that displays previously frozen layers. See also freeze. (LAYER)

thickness The distance certain objects are extruded to give them a 3D
appearance. (PROPERTIES, CHPROP, ELEV, THICKNESS)

tiled viewports See model viewports.

TILEMODE A system variable that controls whether viewports can be created
as movable, resizable objects (layout viewports), or as nonoverlapping display
elements that appear side-by-side (model viewports). See also viewport.

tool message

A small instructional message that appears over the drawing window and is
specific to the active navigation tool from a SteeringWheel.

toolbar Part of the interface containing icons that represent commands.

tooltip A small box of text that identifies or explains an object or interface
element when the cursor hovers near or over it.

tracking A way to locate a point relative to other points on the drawing.

tracking menu

A cluster of buttons that follows the cursor as you move it over the window.

translucency How light is scattered through an object.

transmittance scale Increases or decreases the amount of energy a transparent
material transmits out to the scene.

transparency A quantity defining how much light is let through an object.
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transparent command A command started while another is in progress.
Precede transparent commands with an apostrophe.

two sided material The positive and negative normal of the material will be
considered during the rendering process.

UCS See user coordinate system (UCS).

UCS icon An icon that indicates the orientation of the UCS axes. (UCSICON)

underconstrained geometry Objects with unsolved degrees of freedom are
underconstrained.

underground The XY plane of the user coordinate system when perspective
projection is turned on and when viewed from below ground. The underground
plane displays with a color gradient between the earth horizon (nearest to the
horizon) and the earth azimuth (opposite the horizon). See also ground plane
and sky.

underlay A DWF, or DGN file used to provide visual context in a drawing
file. Underlays cannot be edited, and do not provide the full range of
notification. Underlays cannot be bound to a drawing. See also external
reference (xref).

up direction A vector defining what direction is Up. By default this is the
positive Z – axis (0,0,+1).

The up direction and the north direction are always constrained such that
they are perpendicular to each other.

user coordinate system (UCS) A user-defined coordinate system that defines
the orientation of the X, Y, and Z axes in 3D space. The UCS determines the
default placement of geometry in a drawing. See also world coordinate system
(WCS).

user parameter Named user-defined variable (real number or an expression)
that can be used in expressions for dimensional constraints or other user
parameters.

UVW The material’s coordinate space. Used instead of XYZ because that is
usually reserved for the world coordinate system (WCS). Most material maps
are a 2D plane assigned to a 3D surface. The U, V, and W coordinates parallel
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the relative directions of X, Y, and Z coordinates. If you look at a 2D map
image, U is the equivalent of X, and represents the horizontal direction of the
map. V is the equivalent of Y, and represents the vertical direction of the map.
W is the equivalent of Z and represents a direction perpendicular to the UV
plane of the map.

value node A specific type of action node that is used to handle requests for
user input and hold the recorded value that was captured during the recording
of an action macro.

value set In a dynamic block definition, a range or list of values specified for
a linear, polar, XY, or rotation parameter.

vector A mathematical object with precise direction and length but without
specific location.

vertex A location where edges or polyline segments meet.

vertical ribbon

The ribbon when it is oriented vertically, usually on the left or right of the
file window.

view A graphical representation of a model from a specific location (viewpoint)
in space. See also viewpoint and viewport. (3DORBIT, VPOINT, DVIEW, VIEW)

view category A named collection of views in a sheet set that is often
organized by function. See also subset.

ViewCube User interface element that displays the current orientation of a
model, and allows you to interactively rotate the current view or restore a
preset view.

viewpoint The location in 3D model space from which you are viewing a
model. See also view and viewport. (3DORBIT, DVIEW, VPOINT)

viewport A bounded area that displays some portion of the model space of a
drawing. The TILEMODE system variable determines the type of viewport
created. 1. When TILEMODE is off (0), viewports are objects that can be moved
and resized on a layout. (MVIEW) 2. When TILEMODE is on (1), the entire
drawing area is divided into nonoverlapping model viewports. See also
TILEMODE, view, and viewpoint. (VPORTS)

viewport configuration A named collection of model viewports that can be
saved and restored. (VPORTS)

virtual screen display The area in which the program can pan and zoom
without regenerating the drawing.
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visibility mode Displays or does not display geometry (in a dimmed state)
that is invisible for a visibility state. (BVMODE)

visibility state In a dynamic block, a custom property that allows only
specified geometry to display in the block reference. (BVSTATE)

visual style A collection of settings that control the display of edges and
shading in a viewport.

volumetric shadows A photorealistically rendered volume of space cast by
the shadow of an object.

watertight A closed 3D solid or mesh that has no gaps.

WCS See world coordinate system (WCS).

wheel

A reference to one of the individual user interface elements that make up
SteeringWheels. See also SteeringWheels.

wheel surface

Area of a SteeringWheel that is used to organize wedges and other buttons.

wheel wedge

A section on the surface of a SteeringWheel that is designated for a specific
navigation or orientation tool.

wheels

A reference to more than one of the individual user interface elements that
make up SteeringWheels. See also SteeringWheels.

window selection A rectangular area specified in the drawing area to select
multiple objects at the same time. See also crossing selection, polygon window
selection.

wipeout object A polygonal area that masks underlying objects with the
current background color. This area is bounded by the wipeout frame, which
you can turn on for editing and turn off for plotting.

wireframe model The representation of an object using lines and curves to
represent its boundaries.

working drawing A drawing for manufacturing or building purposes.

working set A group of objects selected for in-place reference editing.
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workplane Another name for the XY plane of the user coordinate system. See
also elevation and user coordinate system (UCS).

workspace A set of menus, toolbars and dockable windows (such as the
Properties palette, DesignCenter, and the Tool palettes window) that are
grouped and organized so that you can work in a custom, task-oriented drawing
environment.

world coordinate system (WCS) A coordinate system used as the basis for
defining all objects and other coordinate systems. See also user coordinate
system (UCS).

world coordinates Coordinates expressed in relation to the world coordinate
system (WCS).

wrap around

Behavior where the cursor wraps around the window and appears on the
opposite side to allow the continuation of a drag operation instead of stopping
at the edge of the drawing area.

X,Y,Z point filters See coordinate filters.

xref See external reference (xref).

zoom To reduce or increase the apparent magnification of the drawing area.
(ZOOM)
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2D Cartesian coordinates 629
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entering 632
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2D Drafting & Annotation
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2D objects
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simplified display 623
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3D arrays 1106
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defining 3D views 290
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3D coordinates
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cylindrical coordinates 640
entering 637
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3D DWF files 1908
3D DWFx files 1908
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3D meshes
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best practices 1355
converting objects to 1260
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creases 1348–1349, 1356
creating 1227
creating from other objects 1253
custom meshes 1264
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editing 1337
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legacy meshes 1264
predefined meshes 1268
primitives 1232
refining 1346–1347, 1355
selection filters 1357
self-intersections 1360
smoothness 1342
splitting faces 1352, 1355
tessellation 1228, 1342
types of 1253

3D Modeling workspace 151
3D models

3D solids 1175
3D surfaces 1175
3D views 321
about 1171, 1277
advantages 1173
backgrounds 304
cameras and 395
converting to meshes 1277
converting to objects 1277
dynamic views 330
edge display 309
editing 1277
flattened views of 1385
gizmos 1285
grips 1285
history 1280
interference problems in 1225
live sectioning 1372
loft settings 1280
meshes 1337, 1355
motion path animations 406
navigating views 323
parallel views 283
performance issues and 313, 315, 

318
perspective views 283
preview animations 403
properties 1279
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shadows 304
subobjects 1310
thickness 1273
types of 1171
viewing 1278
visual styles 293
wireframes 1270

3D Move gizmo 1294, 1300
3D objects

aligning 1101
arrays 1106
Block Editor and 869
coordinates 637
edge display 309
extending 1119
filleting 1130
flattened views of 1385
live sectioning 1372
lofting 1292
mirroring 1114
modifying 1277
motion path animations and 406
rotating 1098
shadows 304
subobjects 1310
sweeping 1291
thickness 1273
trimming 1119
visual styles 293
wireframes 1270

3D Orbit tool 323
3D Rotate gizmo 1294, 1303
3D Scale gizmo 1305
3D solid edges

imprinting objects on 1335
modifying 1310, 1318
redundant edges 1332

3D solid faces
imprinting objects on 1335
modifying 1310, 1313
redundant faces 1332

3D solid vertices
modifying 1310, 1324
redundant vertices 1332

3D solids
calculating geometric data for 769

chamfering 1320
cleaning 1332
colors 1316
composite solids 1219, 1326
converting meshes to 1359
converting objects to 1199, 1211
converting surfaces to 1213
converting to objects 1277
coordinates 637
edges on 309, 1310
extruding 1199, 1291
faces 1310
filleting 1320
flattened views of 1385
gizmos 1285
grips 1285, 1291
history 1280, 1326
imprinting objects on 1335
interferences 1225
lofting 1204, 1292
mass properties 771
meshes 1253, 1268
modifying 1277
polysolids 1196
pressing or pulling areas 1334
primitives 1279
revolving 1208, 1292
separating into original shapes 1329
shells 1331
slicing 1223
solid primitives 1176, 1179
subobjects 1310
sweeping 1202, 1291
types 1179
validating 1332
vertices 1310
wireframes 1270

3D space
3D models 1171
coordinates 637
elevations 656
object snaps 678
UCSs 650
workplanes 650

3D surfaces 1277
3D UCS icon 665
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3D views
architectural design

conventions 290
cameras in 395
changing viewpoints 292
defining 290
dynamic viewing 330
flying through models 327
gizmos in 1296
interactive 3D views 321
isometric views 289
mechanical design conventions 290
motion path animations 406
moving objects in 1300
multiple UCSs 662
navigation tools 323
preset views 289
preview animations 403
rotating 290
rotating objects in 1303
scaling objects in 1305
UCS orientation 292
walking through models 327

3D wireframe visual style 294

A

absolute coordinates
2D coordinates 632
3D coordinates 638
entering 629

ACB files 598
ACI colors 592
Acrobat PDF files

plotting 1857
action bars 892
action macros

playback 161
action parameters 936
actions (dynamic blocks)

about 960
action bars 892
array actions 980
Block Editor display 883
Chain Actions property 1014
flip actions 978

grips and 987
grouping 892
list of 931, 935
lookup actions 983
lookup tables and 993
move actions 962
overriding 1017
parameter sets and 984
polar stretch actions 972
rotate actions 975, 981
scale actions 965
selection sets 960
stretch actions 968
types 960

actions (user)
redoing 1082
undoing 1082

Actions palette 878
adaptive degradation 314
adaptive grid display 688
adaptive plot style adjustments 1843
Add-a-Plotter wizard 1784
ADI DXB driver 1853
Adjust Distance tool 323
Adobe Acrobat PDF files

plotting 1857
Adobe PostScript driver

plotting with 1859
Advanced Setup wizard 179
Aerial View window

panning with 275
zooming with 275

aggregators 105
aliases

entering commands with 39
aligned constraint parameters 921
aligned constraints 741, 921
aligned dimensions 1681
alignment

AutoTrack feature 704
dimension text 1651, 1725
dimensions 1722
displaying paths for 695
equal intervals 712, 714, 716
lateral tolerances 1668
multiline text 1487
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object snaps 676
objects 1101
single-line text 1477
text 1528
viewport objects 469

alignment grips 987, 1024
alignment parameters 948
allocating memory 313, 318
alternative fonts 1553
altitude 195
anchored palettes 67
anchored windows 137
angle coordinate display 630
angle offset property 1017
angles

angle overrides 700
calculating 765
constraints 741
defining 3D views with 290
hatches 1460
parameter specifications 936
polar angles 696
polar coordinates 635
QuickCalc display units 783
rotating objects by 1097
snap angle 689
unit types 186, 630

angular constraint parameters 923
angular constraints 741, 923
angular dimensions

breaks in 1716
creating 1696
definition points 1731
spacing between 1722

animations
motion path animation 406
preview animations 403
ShowMotion 385

annotation objects
annotative styles 1401
blocks as 1417
creating 1398
defined 1394
dimensions as 1409, 1674
hatches as 1420
leaders as 1413

model space and 425
multileaders as 1413
orientation 1428
scale representations 1424
scaling 426, 1393, 1395
text 1404, 1472
tolerances as 1409
types of 1391
updating 1396
updating scale 1424
visibility 1422
visual fidelity 227, 1400
workflow overview 1394

annotational constraints 746
annotative dimensions 1674
Annotative property 1393, 1398
aperture box (AutoSnap) 682
application status bar 35
application window

display fonts in 131
applications

opening attribute extraction
files 1040

RealDWG-based applications 203
arc length dimensions 1702, 1716
architectural units 184, 783
archiving

sheet sets 511
arcs

concentric constraints 902–903
dimensioning 1688, 1696, 1702
drawing 817
equal constraints 915
fillet arcs 1130
joining to polylines 1155
linetypes 601
modifying 1057
polyline arcs 826
revision cloud segments 849
smooth constraints 912
tangent to lines 820

areas
calculating 767, 845
combining calculations 769
subtracting 770

array actions 980
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arrays of objects
3D objects 1106
creating 1105
dynamic block actions 980
polar 1106
rectangular 1105

arrowheads
customizing 1643
dimension arrowheads 1626, 1641
leader styles 1525

ARX applications 158
Asian fonts 1551, 1560
ASM (ShapeManager) 1172
association points of dimensions 1734
associative dimensions

about 1627
annotation objects and 1409
association points 1734
changing associativity 1735
leader objects and 1518
limitations 1628
modifying 1730, 1734
system variables 1629
updating 1628

associative hatches
exploding 1153

attaching
block attributes 1027, 1030

attribute definitions 1029
attribute extraction templates 1035
attribute tags 1029
attributes of blocks 1027
auditing drawings

Batch Standards Checker 256
examples 239
standards violations 250, 255

Auto-hide option 137
auto-hiding palettes 67
Auto-list feature 1492
AutoCAD Classic workspace 151
Autodesk Design Review

viewing drawing sets in 1897
viewing DWF files 1851
viewing DWFx files 1852

AutoFill feature 1614

AutoLISP (LSP) applications
tools for 64

automatic block constraints 899
automatic saves 243
AutoSnap 676, 681
AutoStack feature 1505
AutoTrack feature 704
axes

coloring 111
constraining movement to 1300
constraining rotation to 1304
constraining scale to 1306
horizontal constraints 909
positive direction of 651
reflection lines 978
revolving objects around 1209
right-hand rule 651
vertical constraints 909
WCS 644

B

back, moving objects to 627
background colors

drawings 111
tables 1618
text 1482

background publishing 1866
backgrounds

visual styles and 304
backup files

restoring drawings from 243
saving 227
sheet set data 486

base grips 1141
base points

parameters 959
rotate actions and 975
scale actions and 965
snap base point 689

Base Type property 965, 975
baseline dimensions 1682
basic dimensions 1667
batch plots

publishing drawing sets 1895
Batch Standards Checker 256
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beveled corners 1133
Big Fonts

properties 1551
bills of materials (BOM) 1583
bisecting objects with construction

lines 843
bitcodes 42
bitmaps (BMP images)

pasting 1089
plotting to 1855

blips 1085
BLK files 1899
Block Attribute Manager

duplicate tags 1049
reordering prompts 1031

block attributes
about 1027
annotative 1398
attaching 1030
attribute definitions 1029
attribute extraction templates 1035
attribute tags 1029, 1037, 1049
attribute values 1049
constant 1028
definitions 1049
editing 1030
error handling 1040
exporting data 1034
extracting data from 1034
invisible 1027
modifying 1047
nested blocks 1040
removing 1049
stand-alone 1031
updating 1034, 1049
variable 1028

Block Authoring palettes 878
block definitions

about 856
actions 883
annotations 1391, 1417
base points 856
block attributes 1027
block definition tables 855
Block Editor 868
block libraries 864

colors 860
copying 865
creating 856
dependencies 883
descriptions 1043
drawing files as 858, 1019
dynamic block definitions 867
fields in 1532, 1538
inserting blocks 1018
linetypes 860
lineweights 860
model space settings 426
modifying 1042
object properties 860
parameters 882
publishing 3D files and 1910
removing 866
saving 896
tool palettes 866
updating 96, 1042

Block Editor
about 868
automatic block constraints 899
Block Authoring palettes 878
correcting block definitions 891
custom block authoring tools 879
custom properties 1005
dependency highlighting 883
dynamic block constraints 898
fully constrained objects 929
modifying dynamic block

definitions 888
object display 882
saving block definitions 896
testing blocks 895

block libraries
creating 864
inserting blocks 1020
updating block definitions 1042

block references
annotations and 1417
associative dimensions and 1629
block attributes 1027
colors 1044
descriptions 1043
dynamic blocks 867
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editing 1042, 1153
exploding 1055, 1154
grips 1152
groups compared to 1076
inserting 1018
leader objects and 1528
linetypes 1044
model space settings 426
nested 863
orientation 1428
paper space and 859
pasted objects as 1089
pasted text as 1512
properties 860
publishing 3D files and 1910
scaling 1020
table cells and 1606
updating 1050
xrefs vs. 858

block template files 1899
BMP files (bitmaps)

pasting 1089
plotting to 1855

BOM (bills of materials) 1583
borders (table cells) 1599
boundaries

boundary edges 1116
layout viewports 452
polylines 802, 827
regions 845
zooming to 270

boundary sets
defined 802
hatches 1445
polylines 827

bounded areas 1334
boxes

3D solids 1180
mesh boxes 1233
modifying 1279

BP3 files 1895
breaking

objects 1138
breaks in dimensions 1716
bringing objects to front 627
bulleted lists 1491

bullets 1491
BYBLOCK setting

block definitions 861
properties 526

BYLAYER setting 526

C

CAD Manager Control utility
DesignCenter Online and 103

CAD standards 249
calculating

angles 765
areas 767
circumferences 768
command prompt calculator 795
converting measurement units 789
distances 765
model space scale factors 427
perimeters 768
point coordinates 766
QuickCalc calculator 773

calculator variables in QuickCalc 790
calculators

command prompt calculator 795
QuickCalc 773

callout blocks
annotations 1391, 1413
sheet sets 495

CALS files 1855
Camera Properties palette 400
cameras

about 395
clipping planes 396
creating 397
lens length 395
linking to paths 406
locations 395
motion path animations 406
properties 398
recording animations 410
section objects and 1378
targets 395

canceling commands 40, 1083
caps 1702
catalogs of parts 101, 105
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categories
DesignCenter Online content 102
sheet set views 489

CDF files (comma delimited) 1038
cells (tables)

address format 1613
AutoFill feature 1614
background colors 1618
blocks in 1606
cell ranges 1613
formulas in 1613
merging 1585
modifying 1584
text in 1606

center location overrides 1690
center marks in dimensions 1626, 1689
centerlines in dimensions 1627, 1689
centers of gravity 771
certification of hardware and

software 317
Chain Actions property 1014
chamfering

3D solids 1320
hatch boundaries 1133
objects 1133

characters
formatting 1489, 1545
height 1556
international 1550
stacking 1505

checking interferences 1225
checking spelling 1572
circles

calculating geometric data for 768
concentric constraints 902–903
dimensioning 1689, 1696
donuts 831
drawing 823
grips on 1142
isometric circles 833
modifying 1057

circumferences 768
classic menu bar 31
Classic workspace 151
cleaning

clearing screen 112

screen display 1085
cleaning up 3D solids 1332
clearing screen 112
Clipboard (Windows) 1088
clipping

layout viewport boundaries 452
clipping boundaries

layout viewports 452
clipping planes

3D views and 330
cameras and 396

closed areas 1334
closed meshes 1264
closed polylines 826
coincident constraints 900
colinear constraints 901
collaborative drawing standards 249, 

255
collaborative sheet set use 517
collected leader lines 1517
collections of content 102, 105, 107
color books 598
color libraries 592
color mapping tables 1834
color palettes 592
color-dependent plot style tables 1785

about 1824
color mapping tables 1834
plot styles in 1816
switching to named 1818

color-dependent plot styles 1816, 1818
colors 591

3D solids 1316
ACI colors 592
application window elements 111
applying 591
blocks 860, 1044
changing 595
color books 598
color intensity 1837
color palettes 592
converting to grayscale 1837
current color 593
defaults 536
dimension elements 1635
dithering 1837
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edges 1320
fills 1431
filtering selection sets by 1066
grid elements 687
grips 1024
hatches 1431
layer property overrides 560
layers and 533, 536, 554
masking objects with 1465
names 592
pasted objects 1089
plot styles 1837
screening 463, 1837
table elements 1599
True Colors 592
visual styles and 301

columns (arrays) 980
columns (multiline text) 1508
columns (tables)

adding or deleting 1585
formatting 1599
modifying 1583

combining
joining objects 1139
regions 846
solids 1220, 1326

comma-delimited files (CDF) 1038
comma-separated files (CSV)

linking to tables 1594
command line

colors in 111
entering commands on 39
entering system variables on 42
hiding 50
prompts on 47
switches 157
switching between dialog boxes

and 47
syntax 159

command line switches
customizing program startup 157

command prompt calculator 795
command window

about 39
hiding 50
moving and resizing 49

navigating in 44
commands

aliases 39
canceling 40, 1083
command history 44
command line 39
command prompt calculator 795
creating tools for 64
Dynamic Input and 668
executing 40
options 40
performing calculations in 780
prompts for 47
repeating 40, 44
searching for 9
shortcut menus 44, 52
text window 45
transparent commands 40

composite regions 846
composite solids

3D solids 1219, 1326
history 1326
modifying 1328
modifying original

components 1329
selecting subobjects 1286
separating into original shapes 1329

composite tolerances 1742
compound objects 1153
concentric constraints 902–903
Conceptual visual style 294
cones

3D solids 1185
mesh cones 1236
modifying 1279

conflicting CAD standards 252
conical helixes 839
connecting

objects 1139
constant block attributes 1028
constants 790
Constrained Orbit tool 323
constraining

object movement 1300
object rotation 1304
object scaling 1306
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constraint bars 735
constraint parameters

about 916
aligned constraint parameters 921
angular constraint parameters 923
diameter constraint parameters 927
horizontal constraint

parameters 918
radial constraint parameters 925
user variables 875
vertical constraint parameters 920

constraint points 727
constraints

annotational constraints 746
applying 745
automatic block constraints 899
coincident constraints 900
colinear constraints 901
concentric constraints 902–903
constraint bars 735
construction geometry and 1002
contraint points 727
dimensional constraints 741, 916
displaying 734, 752
dynamic blocks 898
dynamic constraints 745
editing 728
editing constrained objects 737, 754
equal constraints 915
fix constraints 727
fixed constraints 904
formulas 758
fully constrained drawings 720
fully constrained objects 929
geometric constraints 723, 725
horizontal constraints 908–909
identifying 929
multiple constraints 727
parallel constraints 905–906
parameters 758
parametric constraints 718
perpendicular constraints 907
reference constraints 746
relaxing 721
removing 721
smooth constraints 912

symmetric constraints 913–914
tangent constraints 911
unconstrained drawings 719
underconstrained drawings 720
vertical constraints 909–910

Constraints palette 878
construction geometry 1002
construction lines

drawing 842
modifying 1057

context menus 52
contextual fields 1538
continued dimensions 1682
Continuous Orbit tool 323
control points on splines 1160
converting

3D models to objects 1277
colors to grayscale 1837
dimension units 1660
dimensions to annotations 1409
drawing units 180
fonts 1554
layers to drawing standards 263
LMAN layer states 589
meshes to 3D solids 1359
nonassociative dimensions to

associative 1734
objects to 3D solids 1211
objects to meshes 1260
objects to surfaces 1216
pasted objects to block

references 1089
plot style tables 1818
spline-fit polylines into splines 836
surfaces to 3D solids 1213
text in model or paper space 1570
text to annotations 1404
units of measurement 789

Coons surface patch meshes 1256
coordinate filters 701
coordinate systems

origin 629
Tablet mode and 815
types of 629
UCS (user coordinate system) 643
WCS (world coordinate system) 644
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coordinates
2D coordinates 632
3D coordinates 637
absolute values 629
calculating 766
camera locations 395, 399
coordinate filters 701
cursor location 630
displaying values 787
Dynamic Input and 669
geographic locations 191, 199
relative values 629
types of 629
unit types 630

copying
3D solid subobjects 1320
arrays of objects 1105
block definitions 865
faces 1315
formulas to table cells 1613
grip modes and 1147
layers 551
multiple copies of objects 1104
object properties 531
objects 1088, 1103
objects to other drawings 225
offsetting objects 1111

corners
beveled 1133
chamfering 1133
filleting 1127

correcting
dynamic block definitions 891
mistakes 1082
spelling 1572

CPolygon selection 1061
crashes, recovering from 245
creases

limiting distortion 1356
mesh objects 1348–1349

Create Layout wizard 439, 1773
Create Sheet Set wizard 484
cross sectioning

2D and 3D sections 1379
live sectioning 1372
lofting objects and 1204, 1292

section objects 1363
crosshairs

coloring 111
crossing selections 1061
CSV files (comma-separated) 1594
CTB files 1785, 1816, 1825
current viewports 417
cursor

coordinate display 630
Dynamic Input and 669
locking movement 700
moving in tables 1606
polar tracking 695
rubber-band line 694, 708

curved objects
drawing 817
modifying 1057
symmetric constraints 913–914
tangent constraints 911

CUS files 1574
custom block authoring tools 879
custom grips 1024
custom properties

dynamic blocks 931
grips and 1024
sheets and sheet sets 507

customizing
arrowheads 1643
dimension text 1656
dynamic block properties 1004
hatches 1434, 1458
object selection 1070
paper size 1752, 1795
profiles 155
ribbon 28
spelling dictionaries 1573
visual styles 298
workspaces 151

cutaway views 330
cutting

cutting edges 1116
objects 1088
slicing 1223

cutting edges 1116
cutting planes

live sectioning 1372
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section objects 1363
slicing solids 1223

Cycling property 989
cylinders

3D solids 1188
mesh cylinders 1239
modifying 1279

cylindrical coordinates 640
cylindrical helixes 839

D

damaged drawing files 239
data extraction

block attributes and 1034
data extraction tables

block attributes 1034
Data Extraction wizard

extracting block attributes 1034
data links

defined 1594
locking linked spreadsheets 1595
updating 1595

data types in tables 1599
databases

block attribute data in 1035
datum

composite tolerances 1742
geometric tolerances 1740
ordinate dimensions 1699

DBX applications 158
deleting

3D solid history 1327
block attributes 1049
block definitions 866
color mapping tables 1834
constraints 721
creases 1350
dimension breaks 1718
edges 1319
faces 1315
fillets 1129
freehand sketch lines 815
geometric constraints 725
group definitions 1080
layer property overrides 562

layers 551, 555
linetypes 602
multiline vertices 1165
objects 1088
objects from groups 1080
points in splines 1160
sheets 494
table elements 1585
text styles 1545
tools and palettes 76
unused named objects 1085
vertices 1325

deleting objects 1085
density of hatch patterns 1459
density of mesh objects 1343
dependencies

dependency highlighting 883
dynamic blocks 935

dependent base points 965, 975
deselecting objects 1058, 1062
DesignCenter

about 88
accessing content 92
adding content from 96
blocks in 865
copying block definitions 1042
creating tools 97
DesignCenter Online 101
display options 89
file metadata 189
hatches in 1433
inserting blocks from 1020
layouts in 476
toolbar 90
tree view 92
updating block definitions 96

DesignCenter Online
about 101
downloading content 106
searching for content 106
types of content 105

deviation tolerances 1668
dialog boxes

calculations in 780, 797
display options 47
suppressing display 47
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transparent commands and 41
diameter constraint parameters 927
diameter constraints 741, 927
diameter dimensions 1688

creating 1688
definition points 1731
text 1647

dictionaries 1573
digitizing coordinates 639
digitizing tablets

Tablet mode 815
dimension lines

angular dimensions 1696
defined 1626
leader objects vs. 1515
linear dimensions 1677

Dimension Style Manager
creating styles 1631
dimension values 1659, 1672
text options 1646
text styles 1656

dimension styles 1630
about 1631
applying 1704
listing 1632
modifying 1635
overriding 1706
system variables 1632

dimension text 1646
Dimensional CALS format 1855
dimensional constraints

about 741, 916
annotational constraints 746
applying 745
displaying 752
dynamic constraints 745
editing constrained objects 754
illustrated 718
reference constraints 746
user variables 875

dimensional input 669
dimensions 1623

about 1623
alignment 1651, 1722
angular 1696
annotations 1391, 1409, 1674

arc length 1702
arrowheads 1626
associative 1627, 1730, 1734
basic 1667
breaks in 1716
creating 1623, 1677
customizing contents 1656
dimension lines 1626, 1635
dimensional constraints 741
elements of 1626
exploded 1153, 1628, 1732
extension lines 1626
grips 1730
inspection 1713
jog lines 1710
lateral 1667
linear 1677
model space settings 426
modifying 1153, 1704, 1709
nonassociative 1628, 1731, 1734
ordinate 1699
radial 1688
scale 1673
spacing between 1722
styles 1630, 1704
text 1626, 1646, 1725
text styles 1656
types 1623, 1677
units of measurement 1656, 1659
values 1659

direct distance entry 630, 709
direction

axes 651
disassociated dimensions 1731
display drivers 315
display performance 623
displaying

3D files 1908
3D solid history 1327
alignment paths 705
annotative objects 1422
constrained objects 929
constraints 734
dimensional constraints 752
draw order 627
drawing properties 189
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drawing units 426
gizmos 1294, 1296
grip tools (gizmos) 1294
grips 1142
layers 535, 567
linetypes 612
lineweights 617
originals in composite solids 1326
overlapping objects 627
plot areas 1757
plot styles 1835
properties 525
published files 1897
Quick View images 210–211, 217
shadows 304
simplifying 623
toolbars 33
unreconciled layers 575

distance coordinate display 630
distance multiplier property 1017
Distance Type property 963, 969
distances

calculating 765
coordinate display 630
equal intervals 712
fuzz distance 1155
parameter specifications 936
polar distances 697
specifying 709

distributing
dimensions 1722
leader lines 1518

dithering 1837
dividing

objects into equal segments 712, 
714, 716

objects into original shapes 1329
docked palettes 67
docked toolbars 33
docked windows 49, 137
doglegs 1514, 1688
donuts

drawing 831
exploding 1153
simplified display 623

double click actions
editing 1091

downloading
DesignCenter Online content 102, 

106
draw order

changing 627
hatches 1434, 1463

drawing
3D solids 1179
arcs 817
boxes 1180
circles 823
cones 1185
construction lines 842
curved objects 817
cylinders 1188
direct distance entry 709
donuts 831
ellipses 833
freehand sketches 815
helixes and spirals 839
isometric circles 833
layout viewports and 445
lines 799
multilines 810
object properties 523
objects 799
Ortho mode 694
parametric drawing 718
polygons 807, 826
polyline arcs 826
polylines 801
polysolids 1196
precision 629
pyramids 1192
rays 842
rectangles 807
reference points 841
revision clouds 849
spheres 1190
splines 836
squares 807
tangent arcs and lines 820
tori 1194
triangles 807
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viewports and 417
wedges 1182
wide polylines 826

drawing extents 270, 1757, 1793
drawing files (DWG)

backups 243
file locations 236
finding 188, 234
inserting as blocks 1019
metadata 188
opening 201
repairing 239
saving 226–227
TrustedDWG 203

drawing orientation 1771, 1800
drawing properties

adding 189
displaying 189
finding files with 188, 234
metadata 188

Drawing Recovery Manager
recovering work 245

drawing sets
plotting 1876
publishing 1865, 1869, 1880
republishing 1895
sheet sets 1885
viewing published files 1897

drawing status bar 37
drawing templates

creating 176
default 176
opening 175
saving 227
starting drawings with 175
startup routines and 158

drawing units
about 180
angular measurements 186
converting 181
linear units 183
model space settings 425
precision 184
rounding off 184

drawings
2D sections of 3D models 1363

3D views 321
annotations in 1391
background colors 111
colors 591
copying between 225
counting objects in 5
creating tools from 97
cross sectioning 1363
DesignCenter drawings 97
extents 270
file formats 227
file locations 204, 236
finding 188, 234
fitting on paper 1798, 1802
fully constrained drawings 720
geographic location 191
incremental saves 228
information about 3
inserting as blocks 858
international files 228
layers 533
layouts 431, 433
measurement units 180
metadata 188
model space 423
multiple open drawings 209
naming 228
object properties 523
opening 201
orientation 1771, 1800
page setups 1747
partial saves 227
partially opening 206
plot settings 1747
plotting 1783
previewing 210, 1848
publishing 1865
repairing damaged drawings 239
saving 226
saving as templates 176
scaling 425
sheet sets 479
sheets 479
standards violations 250, 255
starting 169
switching between 211
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templates 175
text in 1472
TrustedDWG drawings 203
unconstrained drawings 719
underconstrained drawings 720
viewports 413
views 269

DSD files (drawing set
descriptions) 1869, 1899

DST files (sheet set data)
creating 484
team member access to 517

duration of animation 408
DWF files (Design Web Format)

3D DWF files 1908
metadata 1899
multi-sheet files 1899
plotting to 1851
publishing 1865, 1880
security options 1899
sheet sets and 1885
viewers 1851, 1897

DWFx files
3D DWFx files 1908
metadata 1899
plotting to 1852
publishing 1865, 1880
security options 1899
sheet set properties in 510
sheet sets and 1885
viewers 1852, 1897
viewing 1897

DWG files 169
DWG to PDF driver 1857
DWT files

saving layouts as 475
sheet creation templates 511
starting drawings 175

DXB files
plotting 1853

DXE files 1034
DXF files (drawing interchange format)

exporting block attribute data 1039
saving 227

DXX files 1039

dynamic block definitions
about 931, 1024
action parameters 936
actions 883, 931, 935, 960
assigning data to 993
block attributes 1027
Block Editor 868
constraints 898–899
construction geometry 1002
correcting 891
creating 931, 934
custom properties 1004
dependencies 883, 935
designing 934
geometry 934
grips and 987
inserting blocks 1018
lookup tables 993
modifying 888
parameter sets 984
parameters 877, 882, 931, 935
saving 896, 936
testing 891, 895
value sets 1009
visibility states 949
workflow 934

dynamic block references
about 931, 1024
actions 960
block attributes 1027
custom properties 935
grips 935, 1024
manipulating 935
modifying 1025
restoring 1025

dynamic constraints 745, 752
dynamic coordinate display 630
dynamic panning 269
dynamic prompts 670
dynamic UCSs 660
dynamic viewing 330

E

edge-defined meshes 1256
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edges
3D solid edges 1310
boundary edges 1116
colors 1320
copying 1320
creases 1349
customizing 309
cutting edges 1116
imprinting objects on 1335
mesh edges 1256
modifying 1318
redundant edges 1332

editing
3D models 1277
3D solids 1277, 1313, 1324
block attribute definitions 1030
block attributes 1047, 1049
block definitions 1042
block references 1042
cameras 400
columns of text 1508
complex objects 1153
composite solids 1328
constrained objects 737, 754
constraints 728
dictionaries 1573
dimension styles 1635
dimensions 1704, 1709
dynamic blocks 888, 1025
edges 1318
faces 1313
fields in text 1533
freehand sketches 815
gizmos 1294
grip tools (gizmos) 1294
grips and 1141
groups 1080
hatches 1459
helixes 1163
layer objects 536
layers 554, 582
leader objects 1516
meshes 1337
multiline styles 1166
multilines 1165
object properties 525

objects 1057, 1091
paper size 1798
plot style tables 1822, 1829
plot styles 1835
polylines 1155
printable areas 1798
properties 525
revision clouds 849
separating solids into shapes 1329
sheet and sheet set properties 507
sheets 494
ShowMotion shots 388
spirals 1163
splines 1160
surfaces 1277
tables 1606
text 1561, 1576
text styles 1545
vertices 1324

electronic drawing sets
plotting 1876
publishing 1865, 1869, 1880
republishing 1895
sheet sets 1885
viewing published files 1897

elevation 656
ellipses

calculating geometric data for 768
concentric constraints 902–903
drawing 833
grips on 1142
modifying 1057

elliptical arcs
modifying 1057

embedded objects (OLE) 1089
EPS files

plotting to 1859
equal constraints 915
equations

parametric constraints 758
erasing objects 1085
errors

block attribute extraction files 1040
correcting 1082
dynamic block definitions 891
reporting 246
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evaluating new layers in drawings 574, 
578

Excel spreadsheets
accessing data from 1594
opening attribute extraction

files 1040
exploded dimensions 1628, 1732
exploding

blocks 1055
compound objects 1153
objects 1153

exporting
3D files 1909
animations 408
block attribute data 1034–1035
layer states 588
layout objects to model space 448
plot files 1851
profiles 155
tool palettes 85

expressions 782, 795
parametric constraints 758

extending
3D objects 1119
chamfered objects 1134
filleted objects 1128
objects 1116

extension lines
angular dimensions 1696
appearance 1638
arc length dimensions 1702
arcs and 1688
breaks in 1716
defined 1626
oblique 1686
origins of 1677
properties 1638
text on 1646, 1652

external references (xrefs)
blocks and 858, 1019
exploding 1154
fields in 1538
layer states and 582
missing 202
sheet sets and 494
xref tools 57

externally referenced dimension
styles 1633

extracting
block attribute data 1034–1035
geometric data 765

extruding
faces 1358
mesh faces 1352
objects 1291, 1334

extruding objects 1199

F

faces of 3D solids
colors 1316
copying 1315
creases 1349
edge display 309
extruding 1352, 1358
face styles 298
imprinting objects on 1335
mesh faces 1347
mesh objects 1338
modifying 1310, 1313
redundant faces 1332
splitting 1352, 1355

facet edges 309
faceted lighting 299
faceted surfaces 1253
facets in mesh objects 1339
Favorites links (DesignCenter) 93
fields (databases)

attribute extraction and 1036
fields (text)

about 1532
hyperlinks in 1542
previous releases of AutoCAD

and 1540
file formats

animations 408
attribute extraction files 1038
drawing interchange formats 1853
pasted objects 1088
plot files 1851
plottable formats 1851–1853, 1855, 

1857, 1859
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publishing drawing sets 1865
Quick View images 210
saving drawings 227
trusted formats 203

files
backups 243
block attribute data 1034
creating 11
default locations 204
finding 188
large objects in 203
metadata 188
migrating 164
opening 11, 201
pinned 13
plotting to 1876
publishing 11, 1865, 1880
repairing damaged files 239
saving 226
search paths 236
sheets and sheet sets 479

Fill mode 623
filleting

3D solids 1320
objects 1127

fills
boundaries 1440
gradient fills 1453
plot styles 1847
solid fills 1449, 1462
turning off display 623
wipeout objects 1465

filtering
dimension types 1628
layers 550, 567
object selection 5, 1066
subobject selection filters 1287, 

1357
unreconciled new layers 575, 579
viewport overrides and 560

finding
commands 9
DesignCenter Online content 102, 

106
drawing files 188, 234
text 1567

fit points in splines 1160
fitting

dimension text 1646
spline reshaping 1161

Fix constraints 727
fixed constraints 904
fixed-length extension lines 1639
flat lighting 299
flattened views of 3D objects 1385
flip actions 978
flip grips 987, 1024
flip parameters 946, 984
Flip Set parameter set 984
flipping

arrowheads 1641
blocks 978
objects 1113

floating properties 860
floating toolbars 33
floating windows 49, 137
flying through models 327
flyouts

tool palettes 57
FMP files (font mapping) 1554
folders

file locations 204
font mapping files 1553
fonts 1547

alternative fonts 1553
assigning 1547
Big Fonts 1551
converting 1554
file locations 236
international sets 1550
mapping 1554
PostScript 1553
proxy fonts 1549, 1553
publishing 3D files and 1911
substitute fonts 1553
TrueType 1549
types of 1547
Unicode 1550

forcing internal lines 1647
foreshortened radius dimensions 1690
form tolerances 1737
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formatting text
character formatting 1545
codes for 1577
fields 1532
multiline text 1482, 1489
stacked text 1504
table cells 1599, 1606

formulas
copying 1613
inserting in table cells 1613
parametric constraints 758

fractions 1482, 1504
frame rates in animations 408
Free Orbit tool 323
freehand sketching 815
freezing

layers 535
layers in layout viewports 459

front views 290
front, moving objects to 627
fully constrained drawings 720
fully constrained objects 929
functions 790
fuzz distance 1155

G

gaps between objects 1139
geographic locations

about 191
defining 191
displaying location 199
importing data 195

geographic markers 191
geometric calculators 773
geometric constraints

about 723
applying 725
constraint points 727
creating 898
displaying 734
editing 728
editing constrained objects 737
fix constraints 727
illustrated 718
multiple constraints 727

relaxing 721
removing 721, 725

geometric tolerances 1736
composite tolerances 1742
datum reference frames 1740
lateral tolerances 1667
material conditions 1739
projected tolerances 1741

geometry
authoring blocks with

constraints 1002
dynamic blocks 934
object geometric data 765
partially opened drawings 206

gizmos
3D models 1285
about 1294
displaying 1296
mesh objects and 1357
moving objects with 1300
rotating objects with 1303
scaling objects with 1305
settings 1297
switching 1296

global constants 791
global linetype scale factor 610
Gooch face style 298
Google Earth 191, 195
gradient fills

creating 1453
simplified display 623

graphics cards 315
grayscale 1837
grid

displaying 686
snapping to 686

grid limits
calculating 427
overriding 687
zooming to 270

grip tools (gizmos) 1294
grips 1141

3D solids 1285, 1291
base grips 1141
Block Editor display 883
blocks 1152
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camera grips 399
constrained objects 755
copying objects with 1147
dimension text 1726
dimensional input 669
dimensions 1730
display options 1142
dynamic blocks 987
editing objects with 1141
gizmos 1294
grip modes 1141
grip tools (gizmos) 1294
helixes 1163
hot grips 1141
insertion cycling 989
jog lines 1710
parameters 937
quadrant grips 1142
section objects 1374
selecting 1142
splines 1160
surfaces 1291
tables 1584
text objects 1563, 1565
tooltips 989
types of 1024, 1286

ground plane 120
ground plane grid 120
groups

about 1076
action object groups 892
adding objects to 1080
creating 1076–1077
editing groups 1080
editing objects 1080
layer group filters 567
removing group definition 1080
removing objects from 1080
reordering objects in 1080
selecting 1078

guide curves 1206, 1292
gutters between text columns 1509

H

hanging indents 1499

hardware
acceleration 315
linetypes and 601

hatches
annotations and 1391, 1420
boundaries 1440
chamfering boundaries 1133
customizing 1434, 1458
density 1434, 1459
draw order 1434, 1463
editing 1153
exploding 1153
file locations 236
filleting boundaries 1128
gradient fills 1453
islands within 1442
ISO patterns 1433
large or complex drawings and 1445
model space settings 426
modifying 1459
nonassociative 1433
orientation 1428
origin point 1433
pattern libraries 1456
pre-defined 1433, 1456
properties 1460
simplified display 623
solid fills 1449, 1462
styles 1442
unbounded hatches 1447

hats 1702
height

table rows 1583
text 1489, 1570

helixes
drawing 839
modifying 1163

hexagons 807
hidden objects 1768, 1807
hiding

annotative objects 1422
dynamic block visibility states 949
hatch boundaries 1447
layers 535
palettes 67
paper space objects 1810
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toolbars 33
highlighting

dependencies 883
objects 1071
visual styles and 300

histories of 3D solids 1280, 1326
holes in 3D solids 1334
hollow objects 1331
hook lines 1514, 1688
horizontal constraint parameters 918
horizontal constraints 908–909, 918
horizontal dimension text 1651
horizontal dimensions 1679
horizontal ribbon 23
horizontal text 1559
hot grips 1141
hyperlinks

fields and 1542

I

icons
tool palette icons 68
tools 71

ignoring standards violations 255
imperial units

converting to metric 180
entering 184
linetype definition file for 602
QuickCalc display 783

importing
geographic location

information 195
layer states 588
layouts as sheets 493
named page setups 1775
plotter configuration settings 1774
profiles 155
text 1512
tool palettes 85

imprinting objects on 3D solids 1335
In-Place Text Editor

columns 1508
fonts in 1549
indents and 1499
multiline text 1481

table text and 1585, 1613
incremental saves 228
indenting paragraphs 1499
independent base points 965, 975
infinite lines 842
inheritance

blocks 861
joined objects 1155

Initial Setup
about 164
default profiles 156

initializing layouts 1784
input

QuickCalc calculator variables 790
input properties 995
inserting

blocks 1018, 1606
content with tools 57
DesignCenter content 96
drawing files as blocks 1019
fields in text 1532
formulas 1613
objects at equal intervals 712

insertion point for blocks 989
inspection dimensions 1713
inspection rates 1714
installation

color books 598
interferences 1225
international character sets 228
Internet

DesignCenter Online 101
interrupting commands 40
intersecting objects

composite solids and 1220
dimension breaks 1719
edges 309
interferences 1225
multilines 1165
regions 846
self-intersections 1360
trimming 1116

intervals on objects 712, 714, 716
inverting

layer filters 569
invisible block attributes 1027
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invisible objects in blocks 949
islands

hatch patterns and 1442
ISO hatch patterns 1433, 1456
ISO pen widths 602
isoline edges 309
isometric circles 833
isometric views

3D views 289

J

jitter edge effect 310
jog lines in dimensions 1710
jogged radius dimensions 1690
jogged segments in section objects 1370
joining

line join styles 1846
objects 1139, 1155

JPEG files
plotting to 1855

justified text
defined 1482
dimension text 1650
modifying 1571
settings 1487

K

key points
about 960
parameters 937, 987

keyboard shortcuts 38
keytips 38
keywords 189
KML files 191, 195
KMZ files 191, 195

L

L symbol (least material condition) 1739
label blocks

annotations 1391, 1404
sheet sets 495

labels (parameters) 1005

labels (text) 1472
landings

dimension text 1688
multileader leader lines 1514, 1517

landscape orientation 1771, 1800
languages

dictionaries 1573
large objects 203, 229
LAS files (layer states) 588
lateral tolerances

displaying 1667
stacked text in 1504

latitude 195
layer group filters 567
layer properties

blocks and 861
converting to drawing

standards 263
tool overrides 71

Layer Properties Manager
filtering layers 567
layer names 550
modifying layers 554
property overrides 560
sorting layers 567
unreconciled new layers and 579

layer property filters 568
layer states 580
Layer States Manager

LMAN layer states 589
restoring layer states 581
xrefs and 582

Layer Translator 263
layers 533

about 533
colors 536, 554, 595
converting to drawing

standards 263
copying 551
creating 550
current 551
default properties 536
deleting 551, 555
displaying 567
exporting layer states 588
filtering 550, 567
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freezing 459, 535
hiding 535
importing layer states 588
inverting filters 569
LAS files 588
layer 0 534
layer states 580
layout viewports and 459
linetypes 536, 554, 608
lineweights 536, 554, 614, 621
live sectioning and 1373
LMAN Express Tool 589
locking 535
metadata 1899
modifying 554, 582
modifying objects on 536
moving objects to another 554, 

595, 607, 621
naming 550, 554
new layer notification 574
overriding properties 536, 560
plot styles 536, 1826
preventing selection 1064
properties 554
reconciled 575, 578
referenced 551
restoring layer states 581
saving 580
selecting 551
settings 554
sorting 567
thawing 535
turning on or off 535
undoing changes 554
unlocking 535
unreconciled 575, 578
unused 551
visibility 445, 535
xrefs and 582

Layers toolbar 525
layout templates 475
layout viewports

about 431
accessing model space from 445
aligning views in 469
annotations and 1394, 1396

creating 452
drawing in 445
freezing layers in 459
linetypes in 467
magnifying 445
modifying views in 446
multiple 452
plotting 1768
resizing 453
rotating views in 472
scale 446
screening objects in 463
shaded 1768
turning on or off 465
views in 456
visibility in 459

Layout Wizard
creating layouts 1773

layouts
adding 439
dimensioning in 1674
display options 125
exporting objects to model

space 448
importing plotter configuration

files 1774
initializing 1748, 1784
inserting from DesignCenter 476
layer visibility 445, 535
layout tabs 431
layout templates 475
layout viewports 431
Layout Wizard 439, 1773
lineweights in 617, 1763
opening 210
orientation 1428, 1771, 1800
page setups 1748
paper size 1752, 1794
plot settings 1748, 1793, 1801
plot style tables 1820
plotting 1783
previewing 210
settings 439
shaded viewports 1805
sheet sets and 485, 493
switching to model space 217
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work process 438
leaders (leader lines)

annotations 1391, 1413
associativity and 1518
automatically creating 1647
blocks in 1528
breaks in 1716
creating 1516
defined 1514
landings 1517
modifying 1516
multileaders 1516
multiline text in 1528
ordinate dimensions and 1700
styles 1525

leading (line spacing) 1502
least material condition values 1739
legacy mesh types 1260, 1264
lengthening objects 1123
lens length of cameras 395
lettered lists 1491
lighting

face styles and 299
highlights 300
visual styles and 295

limits
arrays 1106
tolerances 1668

LIN files (linetype library) 602
line end styles 1845
line spacing

dimension text 1725
text 1482, 1502

Linear Array parameter set 984
linear constraints 741
linear dimensions

breaks in 1716
creating 1678
definition points 1731
jog lines 1710
spacing between 1722
types of 1677

linear grips 987, 1024
Linear Move Pair parameter set 984
Linear Move parameter set 984

linear parameters
dynamic blocks 940
grip numbers 987
parameter sets 984
values 1009

Linear Stretch Pair parameter set 984
Linear Stretch parameter set 984
linear units 183
lines

coincident constraints 900
colinear constraints 901
dimension lines 1635
direct distance entry 709
drawing 799
end styles 1845
equal constraints 915
extension lines 1638
filleting 1129
freehand lines 815
horizontal constraints 908–909
join styles 1846
joining to polylines 1155
linear constraints 741
linetypes 601
linetypes on short segments 612
lineweights 614
modifying 1057
multilines 810
Ortho mode 694
parallel constraints 905–906
perpendicular constraints 907
polyline arcs 826
smooth constraints 912
symmetric constraints 913–914
table gridlines 1599
tangent to arcs 820
vertical constraints 909–910

Linetype Manager
scale settings 610

linetypes
about 601
applying 605
blocks 860, 1044
current 605
defaults 536
deleting 602
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displaying on short segments 612
file locations 236
filtering selection sets by 1066
freehand sketches 815
hardware linetypes 601
layers and 533, 554, 608
layout viewports and 467
loading 602
model space settings 426
plot style linetypes 1843
polylines 612
reapplying 607
scaling 467, 610, 1843

lineweights
about 614
applying 614
block properties 860
current 619
defaults 536
dimension elements 1635
displaying 617, 620
filtering selection sets by 1066
layers and 533, 554, 621
model space and 614
objects not displaying 614
overriding 621
plot settings 1768
plot style lineweights 1843
plotting 614, 1809
previous releases and 619
reassigning 621
regenerating drawings and 617
scale 615, 1763
turning on or off 617, 624

linking
cameras to paths 406
pasted objects 1089

listing
dimension styles 1632
dimension system variables 1632
layers 567

lists in multiline text 1491
live sectioning

about 1363, 1372
cameras and 1378

LMAN Express Tool 589

LMC symbol (least material
condition) 1739

loading
color books 598
linetypes 602
partially opened drawings 206

location
cameras 395, 399
default drawing folder 204
geographic 191

locked tool palettes 76
locking

cursor movements 694, 700
layers 535
layout viewport scale 446, 457
sheets and sheet sets 517
table data links 1595
toolbars 145
windows 145

lofting objects
3D objects 1204, 1280, 1292
surfaces 1292

logo startup screen 159
longitude 195
lookup actions 983–984, 993
lookup grips 987, 993, 1024
lookup parameters 958, 984
lookup properties 995
Lookup Set parameter set 984
lookup tables

about 993
properties 995
reverse lookup 996
values 1001

M

M symbol (maximum material
condition) 1739

magnet snapping 681
magnifying views 269
major grid lines 687
manufacturer data

DesignCenter 105
mapping

fonts 1554

1984 | Index



layers to standard layers 263
markers

equal segments on objects 712, 
714, 716

geographic 191, 199
object snaps 681
point markers 714, 716
tracking points 704

markups
revision clouds 849

masking objects 1465
mass properties 771
material condition symbols 1739
materials

publishing 3D files and 1909
mathematical calculators 773
MaxArray system registry variable 1106
maximum material condition

values 1739
measurement units

about 180
converting 789
coordinates 630
dimension text 1656
dimensions 1659
model space 425
plot scale 1802
QuickCalc display 783
symbols 184

measurements
dimensions 1623
equal intervals 712, 714, 716
tolerances 1736

memory (RAM)
allocating 313
memory tuning 318

menus
classic menu bar 31
shortcut menus 52
workspace arrangements 151

merging
cells in tables 1585

mesh models 1173
meshes

about 1227, 1253
best practices 1355

boxes 1233
cones 1236
converting objects to 1260, 1277
converting to 3D solids 1211, 1278, 

1359
creases 1348–1349, 1356
creating 1228, 1253
custom 1264
cylinders 1239
density 1343
editing 1337
extruding 1358
extruding faces 1352
faces 1338
facets 1339
gizmos 1357
legacy mesh types 1260, 1264
predefined meshes 1268
primitives 1232
properties 1283
pyramids 1242
refining 1346–1347, 1355
selection filters 1357
self-intersections 1360
smoothness 1342
spheres 1245
splitting faces 1352, 1355
tessellation 1228, 1342
tori 1251
types 1253
wedges 1248

metadata
entering 188
publishing options 1899

metric units
converting to imperial 180
linetype definition file for 602

Microsoft Excel spreadsheets
accessing data from 1594
opening attribute extraction

files 1040
Microsoft Windows Clipboard 1088
migrating

Initial Setup 164
minor grid lines 687
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mirroring
grip methods for 1143
objects 1113
text 1113, 1561

misspellings 1572
MMC symbol (maximum material

condition) 1739
model space

accessing from layout viewports 445
annotations and 425, 1394, 1396
cameras in 395
defined 431
dimensioning in 1674
display options 125
drawing process in 423, 436
exporting layout objects to 448
layer states and 582
layer visibility settings 445
lineweight display in 614, 617
live sectioning and 1372
moving objects to paper space 438
plot scale 1801
plotting from 426, 1794, 1810
switching to layouts 217
text in 1570
viewports 413

model space viewports
Aerial View window and 276
assigning UCSs to 662
creating 413
UCSs in 654

modifying
3D models 1277
3D solids 1277, 1313, 1324
block attribute definitions 1030
block attributes 1047, 1049
block definitions 1042
block references 1042
cameras 400
colors 595
columns of text 1508
complex objects 1153
composite solids 1328
constrained objects 737, 754
dictionaries 1573
dimension styles 1635

dimensions 1704, 1709
dynamic blocks 888, 1025
edges 1318
faces 1313
fields in text 1533
freehand sketches 815
gizmos 1294
grip methods for 1141
grip tools (gizmos) 1294
hatches 1459
helixes and spirals 1163
layer objects 536
layers 554, 582
layout viewports 452, 456
leader objects 1516
lineweights 621
meshes 1337
multiline styles 1166
multilines 1165
object properties 525
objects 1057, 1091
paper size 1798
plot style tables 1822, 1829
plot styles 1835
polylines 1155
printable areas 1798
properties 525
revision clouds 849
separating objects into shapes 1329
sheet and sheet set properties 507
sheets 494
splines 1160
surfaces 1277
tables 1606
text 1561, 1576
text styles 1545
tools 58, 76
vertices 1324

moments of inertia 771
motion path animation

about 406
linking cameras to paths 406
recording 410
settings 408

move actions 962
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moving
3D Move gizmo 1294, 1300
3D solid subobjects 1310
blocks 962
constraining movement 1300
dimension text 1726
edges 1318
faces 1313
grip methods for 1142
jog lines 1710
layer objects to other layers 554
leader objects 1517
objects 1093, 1111
objects between model and paper

space 438
sheets to other sets 494
stretch-moves 1094
text 1563–1564
tools on palettes 76
UCSs 644
vertices 1324

mtext (multiline text) 1481
multileaders (leader lines)

annotations 1391, 1413
blocks in 1528
breaks in 1716
creating 1516
landings 1517
modifying 1516
styles 1525
text in 1528

multiline styles 1166
multiline text

about 1481
aligning 1487
annotations 1391
columns 1508
creating 1481
editing 1564
finding 1567
formatting 1489
height 1489, 1556
indenting 1499
justification 1487, 1571
leader objects and 1514
line spacing 1502

lists in 1491
obliquing angle 1558
orientation 1559
properties 1482
replacing 1567
stacked 1504
styles 1489, 1544
tabs 1499
text editors 1577
text wrap 1482

Multiline Text Editor 1576
multilines

drawing 810
editing commands 1166
intersections 1165
modifying 1165
styles 811, 1166
vertices 1165

multiple drawings
opening 209
switching between 225

multiple hot grip selection 1142
multiple layouts

Publish 1879
multiple-view drawing layouts 431
My Documents folder 204, 236

N

named layer states
saving 583–587, 589–590

named objects
CAD standards 249
partially open drawings and 206

named page setups
applying 1747
creating 1775
sheet sets and 1781

named plot style tables
about 1785, 1817
color mapping tables 1834
Plot Style Table Editor 1829
plot styles in 1826
switching to color-dependent 1818

named plot styles
about 1817, 1826
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creating 1829
predefined styles 1833
switching to color-dependent 1818

named views
saving 278
section objects and 1378

naming
layer states 580
layers 550, 554
selection filters 1066
text styles 1545
viewports 418
views 278

naming conventions
international 228

navigating
3D views 323
command window keys 44
SteeringWheels 348
ViewCube 332

nested blocks
block attributes 1040
creating 863

nonassociative dimensions 1628, 1731, 
1734

nonassociative hatches 1433
nonrectangular layout viewports 452
nonsystem plotter drivers

DXB driver 1853
PDF output 1857
plotting to 1851
PostScript driver 1859
raster driver 1855

nonuniform rational B-spline curves 836
notes

annotations 1391, 1404
creating text 1472

notification
new layers added 574
standards violations 257

Number of Grips property 987
numbered lists 1491
numeric values

block attribute data 1038
dimensions 1659
rounding 1663

suppressing zeros 1664
NURBS curves 836

O

object properties
about 523
assigning 523
blocks 860
colors 591, 595
copying 531
displaying 525
layer defaults 536
linetypes 601
lineweights 615
modifying 525

object snap tracking 704
object snaps 676

3D space 678
about 676
angles of 689
AutoSnap 681
base points 689
grid snap 686
object snap tracking 704
overriding 683
PolarSnap feature 695
running object snaps 677
shortcut menu 677, 680

objects
3D objects 1171
aligning 1101
arrays of 1105
assigning to other layers 595, 607, 

621
breaking 1138
chamfering 1133
colors 591
converting to meshes 1260
converting to revision clouds 849
copying 1088, 1103, 1147
counting 5
creating 3D solids from 1211
creating meshes from 1253
creating solids or surfaces

from 1199, 1216
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cross sectioning 1363
cutting 1088
deleting 1088
deselecting 1058, 1062
draw order 627
drawing 799
editing 1057, 1091
equal intervals on 712
erasing 1085
filleting 1127
filtering 1066
fully-constrained 929
geometric data 765
grips 1141
grouping 1076
highlighting 1071
joining 1139
large objects 203, 229
layers 533
layout viewports and 445
linetypes 601
lineweights 614
magnifying 270
masking 1465
mass properties 771
mirroring 1113
moving 1093
offsetting 1111, 1148
overlapping 627
paper space and 438
pasting 1088
plotting 1809
reshaping 1122
resizing 1122
rotating 1097
saving 227
scaling 1124
section objects 1363
selecting 1057
separating into original shapes 1329
simplified display 623
snapping 676
stretching 1123
subobjects 1310
visibility 459

oblique extension lines 1686

oblique text 1558
obscured edges 309
offset snaps 1148
offsetting

construction lines 843
copying objects 1148
objects 1111
plot offsets 1759, 1800
temporary reference points 711

OLE objects
pasted text as 1512
pasting 1089

opacity
visual styles 300

open meshes 1264
opening

attribute extraction files 1040
DesignCenter drawings 97
drawings 201
files 11
files with large objects 203, 229
layouts 210
multiple drawings 209
sheets and sheet sets 494

operators
calculations 782

ordinate dimensions 1699, 1716, 1731
orientation

annotations 1428
drawings 1771, 1800
fixed constraints 904
text 1559

origin
coordinate systems 629, 644
displaying UCS icon at 665
ordinate dimensions 1699

Ortho mode 694
orthographic sectioning 1367
orthographic views 289
overhang edge effect 310
overlapping objects

3D solids 1225
draw order 627
selecting 1057, 1287

overlays 533
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overrides
angle overrides 700
center locations of dimensions 1690
dimension styles 1632, 1706
dynamic block actions 1017
grid spacing 689
identifying 560
layer property overrides 536, 560, 

580
linetypes 608
lineweights 621
object snaps 683
removing 562
sheet set page setups 485, 511
snap spacing 689
tool properties 71

overshoot of extension lines 1638

P

Page Setup Manager
creating page setups 1747

page setup override files 485, 511
page setups 1747

Create Layout Wizard 1773
importing plotter configuration

settings 1774
named page setups 1747–1748, 

1775
overriding 485, 511
Page Setup Manager 1747
plot settings 1789
settings 1748
sheet sets 485, 511, 1781, 1885

pages
page setups 1747
sheets in sheet sets 479

Pan tool 323
panning

3D views 323
about 269
Aerial View window 275
dynamic 269
layout viewports 445

paper drawing sets 1876

paper size
fitting drawings on 1802
layout settings 1752
modifying 1798
plot scale and 1801
scaling drawings to fit 1761
settings 1794

paper space 431
about 431
blocks and 859
dimensioning in 1674
drawing in 431
exporting objects from 448
hiding objects 1810
layer states and 582
layout work process 438
lineweight display in 617–618
moving objects to model space 438
object visibility 459
plotting options 1769, 1810
text in 1570
UCS limitations 657

paper-saving features 1798
paragraphs (multiline text) 1481
parallel constraints 905–906
parallel dimensions 1722
parallel lines

construction lines 843
filleting 1130

parallel projections
about 283
creating 287

Parameter Sets palette 878
parameters

adding actions to 960
Block Editor display 882
Chain Actions property 1014
constraint parameters 916
custom properties 1005
defined 937
dynamic block action

parameters 936
dynamic blocks 877, 931, 935
grips and 987
key points 960
labels 1005
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lookup tables and 993, 995
parameter sets 984
parametric constraints 758
user variables 875
values 1009
visibility parameters 949

Parameters palette 878
parametric constraints

about 718
annotational constraints 746
applying 745
dimensional constraints 741
displaying 734, 752
dynamic constraints 745
editing constrained objects 737, 754
formulas 758
geometric constraints 723, 725
parameters 758
reference constraints 746
relaxing 721
removing 721

parametric drawing
about 718
parametric constraints 718

partial saves 227
partially open drawings 206
parts

DesignCenter Online content 102, 
105

inspection dimensions 1713
parts lists 1035

passwords
published files 1899

pasting
converting data while pasting 1089
lists 1493
objects 1088
objects from other drawings 225
text 1512

paths
default file locations 204
extruding 1291
linking to cameras 406
lofting 1205, 1292
motion path animations 406
support files 236

sweeping 1202
patterns

hatches 1431, 1456
libraries 1456

PC2 files (legacy plotter
configuration) 1774

PC3 files (plotter configuration)
about 1784

PCP files (legacy plotter
configuration) 1774

PCX files
plotting to 1855

PDF files
plotting 1857

pen plotters
pen assignments 1840

pen settings
color mapping tables 1834
importing into layouts 1774
plot style assignments 1840
raster plotters 1841
virtual pens 1841

penless plotters 1841
performance improvement

3D display and 313
adaptive degradation 314
Aerial View dynamic updating 276
arrays and 1106
fills display 623
groups and 1077
hardware acceleration 315
incremental saves 228
layers and 535
lineweights and 617, 624
memory and 313, 318
performance tuning 315
publishing 3D files and 1910
shadow display and 304
software acceleration 315
text display 623

performance tuner 316
perimeters 768
perpendicular constraints 907
perpendicular lines 694
perspective views

about 283
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defining 285
pickbox cursor 1057
pinned files 13
pixels

removing strays on display 1085
placeholder fields 1532
plan views

changing viewpoints 292
defined 290

planar closed spline curves 768
planar surfaces 1217
planes

constraining movement to 1301
constraining scale to 1306
workplanes 629

playing action macros 161
playing shots 393
plot areas

printable areas 1798
setting 1757, 1793

plot files 1783
plot settings

objects 1809
orientation 1800
page setups and 1789
scale 1801

plot stamps
about 1785
turning on 1810

Plot Style Manager 1822
Plot Style Table Editor

editing plot styles 1835
managing plot style tables 1829

plot style tables
assigning to layouts 1764, 1820
color mapping tables 1834
creating 1822
editing 1835
modifying 1822
Plot Style Manager 1822
Plot Style Table Editor 1829
predefined 1825, 1833
shaded viewport plotting options

and 1806
switching types 1818
types 1785, 1816, 1824, 1826

plot styles
about 1814
layers and 536, 554
modifying 1835
NORMAL style 1830
object plot styles 1826
plot style tables 1764, 1816
selecting 1809
settings 1835
types 1785, 1815

Plotter Configuration Editor
paper size 1752

plotter configuration files
about 1784

Plotter Manager
about 1784

plotters
configuration files 1784
offsetting plots 1800
paper size 1794
paper-saving features 1798
pen assignments 1840
raster plotters 1841
selecting 1750, 1791

plotting
about 1784
draw order and 627
drawing sets 1876
exporting files 1851
file formats 1851
fit options 1761
hardware linetypes 601
layout process and 433
lineweights 614–615, 618, 1809
model space settings 426
new layer notification and 576
offsets 1759
orientation 1771, 1800
page setups 1747, 1789
paper size 1794
paper space objects 1810
plot scale 1801
plot style tables 1764
plot styles 1809, 1814
positioning image on paper 1798
previewing 1848
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publishing 1865
quick start 1783
resolution 1808
scaling drawings for 1761
screened objects 463
section objects 1384
selecting output devices 1791
terminology 1784
test plot performance 623
text frames 624
wipeout objects 1466

plug-ins (CAD standards) 250, 252
PNG files (Portable Network Graphics)

plotting to 1855
point markers 714, 716
Point Move parameter set 984
point parameters 938, 984
pointer input 669
points

block base points 856
coincident constraints 900
control points 1160
coordinates 766
direct distance entry 710
drawing 841
equal intervals between 712, 714, 

716
fit points 1160
geometric data 765
horizontal constraints 908–909
key points 937, 960
offsetting objects from 711
point markers 714, 716
specifying 708
symmetric constraints 913–914
tracking points 704
vertical constraints 909–910

polar angles 696
Polar Array parameter set 984
polar arrays 1106
polar coordinates

2D coordinates 635
about 629
cylindrical coordinates 640
spherical coordinates 642

Polar Move Pair parameter set 984

Polar Move parameter set 984
polar parameters

dynamic blocks 942
grip numbers 987
parameter sets 984
values 1009

polar stretch actions 972
Polar Stretch Pair parameter set 984
Polar Stretch parameter set 984
polar tracking 695, 704
PolarSnap feature 695
polyface meshes

about 1264
creating 1266

polygon meshes 1264, 1266
polygons

calculating geometric data for 768
drawing 807, 826
polyface meshes 1266

polyline arcs 826
polylines

calculating geometric data for 768
chamfering 1135
closed 826
drawing 801
editing 1153
equal constraints 915
exploding 1153
filleting 1129
freehand sketches 815
joining 1155
linetypes 612
modifying 1057, 1155
offsetting 1112
perpendicular constraints 907
polyline arcs 826
revision clouds 849
simplifying display 623
smooth constraints 912
spline-fit polylines 836
wide polylines 802, 826

polysolids
drawing 1196

portrait orientation 1771, 1800
position parameter specifications 936
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PostScript driver
plotting with 1859

PostScript files
plotting to 1859

PostScript fonts 1553
precedence in calculations 782
precision

angular measurements 186
calculators 773
coordinate systems 629
cursor movements 686
distances 709
drawing units 184
Dynamic Input 668
freehand sketching 815
geometric data 765
numeric values 1663
object snaps 676
offset locations 701
point locations 701

predefined 3D meshes 1268
preset 3D views 289
pressing areas of 3D solids 1334
preview animations 403
previewing

animations 403, 410
drawings 210, 234
layouts 210
object selections 1071
online content 102
plotted drawings 1848

previous releases
fields and 1540
lineweights and 619

primitive solids
about 1179
grips 1291
modifying 1279
spheres 1190

primitives
mesh primitives 1232
solids 1179

printable areas 1748, 1750, 1759, 1793, 
1798

printers
offsetting plots 1800

selecting 1750, 1791
printing

3D DWF files 1908
page setups 1747

privacy 103
profile tolerances 1737
profiles (objects)

extruding 1291
lofting 1204
revolving 1208

profiles (user)
about 155
default profiles 156
Initial Setup 156
workspaces and 153

project lines 1638
projected tolerances 1741
prompts

command line 47
dynamic prompts 670

properties
3D models 1279
blocks 860
cameras 397–398
colors 591
copying 531
dimension lines 1635
displaying 525
dynamic blocks 877, 931, 1004
floating properties 860
hatches 1460
layer property filters 567
layers 533, 554
linetypes 601
lineweights 614
lookup tables 995
mass properties 771
meshes 1230, 1283
metadata 1899
modifying 525
multiline properties 811
objects 523
overriding 560
plot styles 1814
section objects 1376
selecting objects by filtering 1066
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sheets and sheet sets 507
simplifying display 623
tables 1583
text 1482, 1564
tool overrides 71
tool properties 70
views 278

Properties palette
modifying properties 525
object properties 526
performing calculations in 780
table properties 1583

Properties toolbar 525
proxy fonts 1549
PS files (PostScript)

plotting to 1859
Publish multiple layouts 1879
publishing

about 1865
background processing 1866
drawing sets 1865, 1869
files 11
page setups 1747
section objects 1383
sheet sets 510

pulling areas of 3D solids 1334
purging

block definitions 866
named objects 1085
unreferenced linetypes 602
unused layers 551

pyramids
3D solids 1192
mesh pyramids 1242
modifying 1279

Q

quadrant grips 1142
quadrants in dimensioning 1697
querying

block attribute data 1034
Quick Access toolbar 33
Quick Properties panel 525
Quick Setup wizard 179
Quick Text mode 624

Quick View tools 210–211, 217
QuickCalc calculator 773

displaying coordinate values 787

R

radial constraint parameters 925
radial constraints 925
radial dimensions 1688, 1716
radius (fillet) 1128
radius dimensions 1688, 1731
RAM

allocating 313
memory tuning 318

raster driver
plotting with 1855

raster images
file size 1855
plotting to 1855
preview images 234

raster plotters 1841
rays

drawing 842
filleting 1130
modifying 1057

read-only tool palettes 76
Real face style 298
RealDWG files 203
Realistic visual style 294
realtime panning 269
rearranging

objects in groups 1080
reassociating dimensions 1734
reconciled layers

about 578
marking 575

recording
animations 403, 410
history of composite solids 1327

recovering
after system failures 245
damaged drawings 239
sheet set data 486

recovery audits 239
rectangles

drawing 807
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modifying 1057
rectangular arrays 1105
rectangular meshes 1265
redoing actions 1082
redrawing screen display 1085
redundant edges 1332
redundant faces 1332
redundant vertices 1332
reference constraints 746
reference points

drawing 841
offsetting from 711

referenced layers 551
refinement

mesh objects 1346, 1355
tessellation 1229

reflection lines 978
refreshing screen display 1085
regardless of feature size values 1740
regenerating

drawings 617
layer display 535
screen display 624

regions
calculating geometric data for 768
composite 846
creating 845

relative coordinates
2D coordinates 632
3D coordinates 638
copying objects with 1103
cylindrical coordinates 641
entering 629
moving objects with 1094
spherical coordinates 643

relaxing constraints 721
removing

3D solid history 1327
blips 1085
block attributes 1049
block definitions 866
color mapping tables 1834
constraints 721
creases 1350
dimension breaks 1718
edges 1319

faces 1315
fillets 1129
freehand sketch lines 815
geometric constraints 725
group definition 1080
layer property overrides 562
multiline vertices 1165
objects 1088
objects from groups 1080
points in splines 1160
sheets 494
stray pixels 1085
table elements 1585
text styles 1545
tools and palettes 76
unreferenced linetypes 602
unused named objects 1085
vertices 1325

renaming
layers 554
sheets and sheet sets 494

rendering
plotting rendered objects 1807
section objects 1383
shaded viewport objects 1768, 1805

renumbering sheets in sheet sets 494
repairing

damaged drawing files 239
repeating commands 40, 44
replacing

dimension text 1726
text 1567

reports 256
republishing drawing sets 1895
reshaping

objects 1122, 1334
splines 1161

resizing
3D solid faces 1313
Aerial View image 276
annotations 1393, 1396, 1424
arrowheads 1643
columns in text 1509
dimension breaks 1719
dimensions 1673
edges 1318
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extending objects 1116
fitting drawings on paper 1761
layout viewports 453
leader objects 1517
object grips and 1143
objects 1122
tables 1584
text 1563–1564, 1570
toolbars 33
trimming objects 1116
windows 137

resolution
animations 408
PDF files 1857
plotting 1808

restoring
backup files 243
damaged drawings 243
default template file 176
layer settings 581
previous view 269
UCSs 645, 657
viewports 418
views 278

reverse lookup 996
reversing actions 1082
reviewing

new layers in drawings 574
revision clouds 849

revision clouds 849
revolved meshes 1256
revolving

objects 1208
solids 1292
surfaces 1292

RFS symbol (regardless of feature
size) 1740

ribbon
about 22
customizing 28
displaying and organizing 23
tool palettes and 28

right-click menus 52
right-hand rule 651
rotate actions 975, 981
rotated dimensions 1685

rotating
3D objects 1098
3D Rotate gizmo 1294, 1303
3D solid subobjects 1310
3D views 290
block insertion prompts 1020
blocks 975
constraining rotation 1304
dimension text 1726
dimensions 1685
edges 1318
faces 1313
grip methods for 1142
objects 1097
snap angles 689
UCSs 644
vertices 1324
views in layout viewports 472

rotation grips 987, 1024
rotation parameters 945, 984, 1009
Rotation Set parameter set 984
rotation snaps 1148
rounding

corners 1127
edges 1320

rounding off
dimension values 1663
drawing units 184

rows (arrays) 980
rows (tables)

adding or deleting 1585
formatting 1599
modifying 1583

RTF files 1512
rubber-band lines

locking 694
tracking 708

ruled meshes 1255
running object snaps 677, 683

S

S (regardless of feature size symbol) 1740
saving

animations 410
automatic saves 227, 243
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backup files 227, 243
block definitions 896
drawings 226
incremental saves 228
layer property overrides 580
layer settings 583–587, 589–590
layer states 580, 583–587, 589–590
layout templates 475
objects 227
page setups 1775
partial saves 227
preview images 234
profiles 155
publish options 1899
section objects 1381
selection filters 1066
sheet selections 511
sheet sets 517
standards files 252
tool palettes 76, 85
UCSs 657
unreconciled layers and 576
viewports 418
views 278
visual fidelity and 227, 1400
workspaces 153

scale
annotations 1393, 1395, 1424
dimensions 1660, 1673
drawing units 181
drawings 425
hatches 1460
layout viewports 456
linetypes 610
multilines 810
plot scale 1761, 1801
scale factors 1124

scale actions 965
scale factors

layout viewports 456
model space settings 426
scaling objects 1124

scale locking in layout viewports 446
Scale Type property 966
scaling

3D Scale gizmo 1294, 1305

3D solid subobjects 1310
annotations 1393, 1396, 1424
arrowheads 1643
blocks 1020
constraining scale 1306
drawings 426
drawings to fit paper 1761
edges 1318
faces 1313
grip methods for 1143
linetypes 467, 610, 1843
lineweights 1763
model space settings 425–426
objects 1124
plot scale 1801
scaling by reference 1124
tables 1583–1584
text 1563–1564, 1570
text scale ratios 427
vertices 1324
views in layout viewports 456

schedules
tables 1583

scientific calculators 773
screen display

cleaning up 1085
clearing 112
performance 623
updating 624

screening
layout viewports 463
plot settings 1837

scripts
customizing program startup 158
suppressing dialog boxes 47
tools for 64

SDF files (space-delimited format) 1038
search paths

default file locations 204
specifying 236

searching
finding commands 9
finding DesignCenter Online

content 102, 106
finding drawing files 188, 234
text search and replace 1567
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section objects
about 1363
cameras and 1378
creating 1365
grips 1374
jogged segments 1370
live sectioning 1372
object states 1375
plotting 1384
properties 1376
publishing 1383
rendering 1383
saving 1381
viewing 1384
views and 1378

sectioning
2D sections 1379
3D objects 1379
3D views and 330
cameras and 1378
jogged segments 1370
live sectioning 1363, 1365, 1372
lofting objects and 1204, 1292
publishing or plotting cross

sections 1383
section objects 1363
views and 1378

selecting
3D solid subobjects 1286
classification properties and 1066
CP and WP selection 1061
customizing object selection 1070
default options for 1072
deselecting 1058
grip methods for 1141
groups 1078
highlighted objects 1071
irregularly shaped selection

areas 1061
layers 551
methods for 1062
multiple objects 1060
objects 1057
output devices 1750, 1791
overlapping objects 1287
preventing object selection 1064

previewing selections 1071
selection fences 1061
selection windows 1060
subobject selection filters 1287
tables or table elements 1585

selection fences 1061
selection filters 1287, 1357
selection preview 1058
selection sets

assigning actions to blocks 984
defined 960

selection windows 1060
self-intersections 1360
sending objects to back 627
setting up pages 1748
setup wizards 179
shaded images

customizing shading 298
edge display 309
visual styles 293

shaded UCS icon 665
shaded viewports

plotting options 1768, 1805, 1809
resolution settings 1808

shadows
hardware acceleration and 304
visual styles 304

ShapeManager 1172
sheet creation templates 485, 511
sheet list tables 495
Sheet Set Manager

about 479
features 482
locking and unlocking sheets 517
publishing options 1885
shortcut menus 483
team collaboration 517

sheet sets
archiving 511
backing up and recovering 486
basing on drawing files 485
creating and modifying sheets 494
creating sets 484
defined 479
DST files 484
example sheet sets 485
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label and callout blocks 495
locking and unlocking 517
metadata 1899
named page setups and 1781
opening drawings within 494
organizing 489
overrides 511
page setups 485, 511
placeholder fields in 1532
properties 507
publishing 510, 1885
reassociating moved sheets 494
saving 517
saving sheet selections 511
sheet names and numbers 494
Sheet Set Manager 482
status 517
subsets and categories 489
team collaboration 517
titles and tables of content 495
transmitting 511
updating 517
views 495
working without Sheet Set

Manager 518
sheets in sheet sets

defined 479
layouts and 485
modifying 494
named page setups and 1781
names and numbers 494
opening 494
page setups 511
placeholder fields in 1532
properties 507
saving sheet selections 511
Sheet Set Manager 482
status 517
subsets 489
templates 485, 511
title sheets 495
views 495
working with 493

shelling solids 1331
shortcut menus

about 52

shortcuts
keytips 38

shots (ShowMotion) 385, 388, 393
ShowMotion 385
SHX fonts 1550, 1553, 1560
silhouette edges 309
single-line text

creating 1477
editing 1562
height 1556
obliquing angle 1558
orientation 1559
styles 1544

sketching freehand lines 814
sky

display options 120
slanted text 1558
slicing solids 1223
smooth constraints 912
smooth lighting 299
smooth rendering 1909
smoothing

mesh objects 1342, 1346, 1355
tessellation 1228

snapping (object snaps) 676
software acceleration 315
solid fills

creating 1449
modifying 1462
overlapping objects 627
turning off 623

solid primitives
about 1176
boxes 1180
cones 1185
creating 1179
cylinders 1188
pyramids 1192
tori 1194
wedges 1182

solids
3D solids 1211
composite solids 1219
converting objects to 1199
converting to meshes 1260
creating 1175
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extruding 1199
grips 1291
interferences 1225
lofting 1204
modifying 1277
polysolids 1196
revolving 1208
separating into original shapes 1329
solid modeling 1171
solid primitives 1179
sweeping 1202

sorting
layers 567

space-delimited format files (SDF) 1038
spacing

dimension elements 1635
dimensions 1722
equal intervals 712
grid lines 687
inserted blocks 1021

special characters
block attribute extraction files 1039
bullets in lists 1491
file names 228
filtering layers by 568
fractions 1504
inserting 1482
measurement units 184
tolerance stacks 1504

speed 313
spelling check 1572
spheres

3D solids 1190
mesh spheres 1245
modifying 1279

spherical coordinates 642
spirals

drawing 839
modifying 1163

spline-fit polylines
creating 836
extending 1119
trimming 1119

splines
calculating geometric data for 769
control points 1160

converting spline-fit polylines
into 836

drawing 836
editing 1160
fit points 1160
grips 1160
modifying 1057
offsetting 1112
reshaping 1161
smooth constraints 912
tolerance 1160

splitting
faces 1355
mesh faces 1352

spreadsheets
accessing data from 1594
attribute extraction data files 1040

squares 807, 1057
stacked text (multiline text) 1504
standard grips 987, 1024
standards (CAD)

about 249
Batch Standards Checker 256
checking for violations 255
converting layers and properties 263
defining 252
plug-ins 250, 252
violations reports 256

standards audits 250, 255
standards check files 256
standards files

about 249
associating with drawings 252
creating 252

standards plug-ins 250, 252
standards violations 250, 255
starting

customizing program startup 157
drawings 169

starting tables 1598
static coordinate display 630
status bars 35
STB files 1785, 1817, 1833
SteeringWheels 348
stray pixels 1085
stretch actions 968, 972
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stretch-moves 1094
stretching

blocks 968
grip methods for 1142
objects 1123
stretch-moves 1094

styles
annotations 1401
dimensions 1630
leader objects 1525
multiline styles 811
reference points 841
text 1544
visual 294

subobjects 1310
subsets of sheet sets 489
substitute fonts 1549, 1553
subtracting

areas 770
objects 1220
regions 846

support files
search paths 236

surface models 1172
surfaces

3D surfaces 1175
chamfering 1320
composite solids 1326
converting meshes to 1359
converting objects to 1199, 1216
converting to 3D solids 1211, 1213
converting to meshes 1260
extruding 1199, 1291
filleting 1320
grips 1291
lofting 1204, 1292
meshes 1253
modifying 1277
planar surfaces 1217
revolving 1208, 1292
sweeping 1202, 1291

surveyor angles 187
swap files 319
sweeping objects 1202, 1291
switches

customizing startup with 157

switching
dictionaries 1573
drawings 211
gizmos 1296
workspaces 152

Swivel tool 323
symbol libraries

creating 864
inserting blocks 1020
updating block definitions 1042

symbols
arcs 1702
block attribute extraction data 1039
bullets in lists 1491
file names 228
inserting 1482
material conditions 1739
measurement units 184
projected tolerances 1741
symbols of termination 1626
tolerances 1668

symmetric constraints 913–914
symmetrical tolerances 1668
syntax

command line switches 159
QuickCalc 783

system variables
bitcodes and 42
command line changes and 41
command line entry 42
dialog box display and 47

T

table styles 1598
Table toolbar 1585
tables (data extraction)

block attributes in 1034
tables (inserted)

adding rows or columns 1585
annotations 1391
AutoFill feature 1614
breaking into parts 1584
cell styles 1598
column width 1584
creating 1583
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data links 1594
defined 1583
deleting rows or columns 1585
editing 1584
fields in 1532
formatting 1599
formulas in 1613
gridlines 1599
grips 1584
inserting blocks in 1606
merging cells 1585
row height 1584
selecting elements 1585
table styles 1598
text in 1606
title rows 1599
updating linked data 1595

tables (lookup tables) 993
tables of contents 495
Tablet mode 815
tabs in text 1499
tabulated meshes 1255
tangent constraints 911
tangential objects

arcs and lines 820
circles 823

tapering
extruding objects and 1200
polylines 827

TARGA files 1855
targets of cameras 395, 406
teams

drawing standards 249, 255
shared tool palettes 85
sheet sets and 517

templates
attribute extraction templates 1035
block template files 1899
drawing templates 175
layout templates 475
new layer notification and 576
saving 227
sheet creation templates 485
sheet sets 511
startup routines and 158

temporary files 236

tessellation
about 1228
mesh objects 1342
refinement 1229
smoothing 1228

test plots 623
testing

dynamic blocks 891, 895, 936
part dimensions 1713

text
alignment 1477, 1528
annotations 1391, 1404
checking spelling 1572
columns in 1508
dimension text 1646, 1725
editing 1561, 1576
fields 1532
finding and replacing 1567
fonts 1547
height 1556
hyperlinks 1542
importing 1512
justification 1571
leader objects 1514
mirroring 1113, 1561
model space settings 426
model vs. paper space 1570
moving 1563–1564
multline text (mtext) 1481
obliquing angle 1558
orientation 1428, 1559
overlapping 627
pasting 1512
plotting 624
properties 1565
publishing 3D files and 1911
Quick Text mode 624
resizing 1570
scale ratios 427
scaling 1563–1564
simplified display 623–624
single-line 1477
tables 1583, 1599, 1606
text editors 1576
text styles 1544
types 1473
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text editors 1576
text files

exporting block attribute data
to 1035

importing 1512
text styles 1544

about 1544
creating 1545
dimension text 1656
fields 1532
fonts 1547
height 1556
modifying 1545
multiline text 1482, 1489
obliquing angle 1558
orientation in 1559
single-line text 1477
tables 1599

text window 131
text wrap 1482
textures

publishing 3D files and 1909
TGA files

plotting to 1855
thawing layers

layout viewports 459
regenerating drawings 535

thickness of objects 1213, 1273
tick marks for dynamic blocks 1025
TIFF files

plotting to 1855
title sheets 495
titles

tables 1599
title blocks 1773

tolerances
alignment 1668
annotations 1391, 1409
composite tolerances 1742
datum reference frames 1740
deviation tolerances 1668
geometric tolerances 1736
inspection dimensions 1713
lateral tolerances 1667
limits 1668
material conditions 1739

multiline text 1504
projected tolerances 1741
rounding values 1663
splines 836, 1160
suppressing zeros 1669
symbols 1668
symmetrical tolerances 1668

tool palettes
about 56
adding tools 75
block palettes 866
deleting 76
exporting or importing 85
grouping 80
locked 76
ribbon and 28
saving 76, 85
settings and options 67
tools 57

toolbars
about 32
display options 145
Quick Access toolbar 33
workspace arrangements 151

tools
adding to palettes 75
block tools 57
classic menu bar 31
command tools 64
creating 57
creating from DesignCenter

items 97
deleting 76
drawings as 97
modifying 58, 76
precision drawing tools 629
properties 70
rearranging 76
tool flyouts 57

tooltips
AutoSnap 681
Dynamic Input 668
dynamic prompts 670
grips 989
settings 112
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tori
3D solids 1194
mesh tori 1251
modifying 1279

torus objects
3D solids 1194
mesh tori 1251
modifying 1279

tracking
object snap tracking 704
polar tracking 696
specifying points 708

tracking points 704
transmittal packages

sheet sets 511
transparency

palettes 68
section planes 1376
visual styles 300
windows 137

transparent commands 40
triangles 807
trimming

3D objects 1119
chamfered objects 1134
filleted objects 1128
hatches 1447
objects 1116

True Color colors 592
TrueType fonts

about 1549
PostScript font equivalents 1553
proxy fonts 1554
text height 1556
vertical text 1560

TrustedDWG files 203
TXT files

importing 1512
typefaces 1547

U

UCS icon
Block Editor 869
coloring 111
display options 665

UCSs (user coordinate systems) 643
3D settings 653
3D space and 650
assigning to viewports 662
Block Editor 869
defining 644
dynamic UCSs 660
elevations 656
horizontal constraints 908–909
multiple viewports 654
paper space and 657
preset systems 656
restoring 657
saving 657
UCS icon 665
vertical constraints 909–910
workplanes 650

unbounded hatches 1447
unconstrained drawings 719
underconstrained drawings 720
underground (3D modeling) 120
undoing actions

correcting mistakes 1082
layer changes 554

Unicode fonts 1550
unions

3D solids 1220
regions 846
separating into original shapes 1329

units of measurement
about 180
converting 789
coordinate unit types 630
dimensions 1656, 1659
model space 425
plot scale 1802
QuickCalc display 783
symbols 184

unlocking
layers 535

unreconciled layers
about 578
displaying 575

unreferenced linetypes 602
unused layers 551
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updating
Aerial View images 276
annotations 1396, 1424
associative dimensions 1628
block attributes 1034, 1049
block definitions 96, 1042
block references 1050
display 624
fields 1538
lookup tables 993
sheet sets 517
table data 1595

user coordinate system (UCS) 643
user profiles 155
user variables 875

V

validating
3D solids 1332

values
dimension values 1659
dynamic block parameters 1009
lookup tables 1001
QuickCalc display 782
suppressing zeros 1664
text fields 1533

variable block attributes 1028
variables 790
VBA macros

tools for 64
vector expressions 795
versions of AutoCAD 164
vertex editing 1324
vertical constraint parameters 920
vertical constraints 909–910, 920
vertical dimension text 1652
vertical dimensions 1679
vertical ribbon 23
vertical text 1559
vertices

3D solid vertices 1310
creases 1349
modifying 1324
multilines 1165
redundant vertices 1332

video animations 408
video cards 315
view transitions 112
ViewCube 332
viewers

3D files 1908
DWF and DWFx files 1897
published files 1897

viewpoints in 3D space 290, 330
Viewport Overrides filter 560
viewports 413

Aerial View window and 276
aligning views in 469
annotations in 1394, 1396
arranging 414, 418
backgrounds in 304
creating 413
current 417
drawing in 417
layer property overrides and 560, 

581
layers and 560
layout viewports 452
plot options 1768, 1805
plotting 1809
restoring layer states and 581
shadows in 304
UCSs and 654, 662
visual styles in 295, 560

views
3D projection styles 283
3D views 321
Aerial View window 275
aligning in viewports 469
cameras in 395
changing 269
cross sections 1363
flattened 3D objects 1385
layout viewports 456
live sectioning 1378
model space 3D views 287
modifying 446
multiple-view drawing layouts 431
panning 269
partially opened drawings 206
performance issues and 313
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plot options 1757
plotting 1793
preset 3D views 289
properties 278
restoring 278
rotating 472
saving 278
scaling 456
settings 112
sheet set views 495
startup routines and 158
viewports 413
zooming 269

virtual memory 319
virtual pens 1841
visibility

annotations 1422
Block Editor settings 882
dynamic blocks 949
layers 445, 535
layout viewports and 459

visibility parameters 949, 984
Visibility Set parameter set 984
visual fidelity

annotative objects and 1400
exporting layout objects and 449
saving files and 227

visual styles
animations 408
backgrounds 304
customizing 298
default styles 294
defined 294
edge display 309
face styles 298
layer property overrides and 560
performance issues and 313
plotting 1807
shading 298
shadows 304

Visual Styles Manager 294
volumes 771

W

walking through models 327

walls
drawing 1196

WCS (world coordinate system)
about 644
fixed constraints 904
geographic locations 199

websites
DesignCenter Online 101
online content aggregators 105

wedges
3D solids 1182
mesh wedges 1248
modifying 1279

wide polylines
drawing 802, 826
extending 1118
simplified display 623
tapering segments 827
trimming 1118

width
table columns 1583

wildcard characters
filtering layers by 568

windows
anchored 137
docking 137
interface options 111
resizing 137
selection windows 1060
transparency 137
zooming to 270

Windows Clipboard 1088
wipeout objects 1465
wireframes

about 1270
plot options 1768
plotting 1806

witness lines 1638
WMF files

pasting 1089
workplanes 629, 650
workspaces

about 151
profiles and 153
samples 152
startup routines and 159
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switching 152
world coordinate system (WCS) 199, 644
WPolygon selection 1061

X

X axis 111, 908–909
X, Y coordinates 629
XGP files 85
xlines 842

filleting 1130
modifying 1057

XPS compatible files 1852
XTP files 85
XY Array Box Set parameter set 984
XY Move Box Set parameter set 984
XY Move parameter set 984
XY parameters 944, 984, 1009
XY planes (workplanes) 629
XY Stretch Box Set parameter set 984

Y

Y axis 111, 909–910
yellow alert icons 891

Z

Z axis 111
zero suppression

dimensions 1664
tolerances 1669

Zoom tool 323
zooming

3D views 323
about 269
Aerial View window 275
controlling zooming 270
grid display and 688
layout viewports 445
lineweight display and 617
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